ASAP2Library interface: Packages

ASAP2Library interface 8.0.73
ASAP2Library interface documentation
Packages
Here are the packages with brief descriptions (if available):
[detail level 123456]
▼N jnsoft |
▼N ASAP2 | Contains the ASAP2 parser base and the ASAP2 object model implementation..
▼N CCP | Implements the ASAP2 CCP (IF_DATA) Interface stuff.
C A2LCCP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CAN_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_DEFINED_PAGES | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_DP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_EVENT_GROUP | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_KP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LCCP_NODE | Base class for all A2L node definitions concerning CCP.
C A2LCCP_QP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_RASTER | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SEED_KEY | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SOURCE | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_TP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C SourceAndRaster | Hold a CCP Source with it's attached CCP Raster.
▼N Examples |
C Program | Sample console application
▼N Formulas | Contains all the stuff for dynamically compiled formulas.
C A2LFormula | Represents a constant or a formula definition
C A2LFormulaDict | A A2LFormula dictionary (key = NodeName, value = A2LFormula)
C IEvaluator | Interface for dynamically compiled formulas
▼N Helpers | Contains the ASAP2 parser helper stuff.
C AdaptiveState | Holds a Timestamp together with a MemoryRange to read from an ECU.
C Checksum | Provides methods for building checksums over data
C CToCSharpMath | Maps standard math C functions to .NET framework math function strings
▼C DictionaryProxy | Proxy class to permit XML Serialization of generic dictionaries
C KeyAndValue | Holds the keys and values
▼C DictionaryProxyComplex | Proxy class to permit XML Serialization of generic dictionaries with a complex value
C KeyAndValueComplex | Holds the keys and values
C Extensions | Implements basic helper stuff.
C RationalCoeffs | Rational coefficients of an A2LCOMPU_METHOD.
C TabCoeffs | Tab conversion computations.
C TCConversionRef | Typeconverter to edit a reference to A2LCOMPUMETHOD.
C TCFormatRef | Typeconverter to edit a reference to A2L Format string.
C TCMeasurementRef | Typeconverter to edit a reference to a A2LMEASUREMENT.
C TCTransformerRef | Typeconverter to edit a reference to A2LTRANSFORMER.
C TCTypedefRef | Typeconverter to edit a reference to A2LTYPEDEF.
C TCUnitRef | Typeconverter to edit a reference to A2LUNIT.
▼N KWP | Implements the ASAP2 KWP (IF_DATA) Interface stuff.
C A2LKWP_ADDRESS | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
▼C A2LKWP_CAN | See ASAP1B_KWP (COMMON_PARAMETERS)
C NETWORK_LIMITS | KWP QP_BLOB definition smaller v2000
C A2LKWP_CHECKSUM | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_DIAG_BAUD | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_DP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_FLASH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_FLASH_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_K_LINE | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_KP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LKWP_NODE | Base class for all A2L node definitions concerning KWP.
C A2LKWP_PAGE_SWITCH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_ROUTINE_PARA | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_SOURCE | See ASAP1B_KWP (COMMON_PARAMETERS)
C QP_BLOB | KWP QP_BLOB definition smaller v2000
C A2LKWP_TIME_DEF | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_TP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C BAUD_DEF | KWP Baudrate definition smaller v2000
C KWP_DATA_ACCESS | DATA ACCESS definition smaller v2000
C KWP_K_LINE | KLINE definition smaller v2000
C KWP_SERAM | KWP SERAM definition smaller v2000
C SECURITY_ACCESS | KWP SERAM definition smaller v2000
C KWP_TIME_DEF | Timing definition smaller v2000
C KWP_USDTP_TIMING | Timing definition smaller v2000
▼N Values | Defines and implements stuff for reading, writing and modifying characteristic values.
▼N CDF | Contains the classes mapping the Calibration Data Format (XML).
C MSRSW | The root element of the file.
C SWAXISCONT | Physical axis values.
C SWINSTANCE | Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.
C SWINSTANCESPEC | The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items.
C SWINSTANCETREE | Receives one particular set of calibration items
C SWSYSTEM | Describes one particular system within the current file
C SWVALUECONT | Physical values.
C VG | Holds double, text or group values.
▼N Examples |
C Program | Demo console application
C ASCIIValue | Class representing a characteristic CHAR_TYPE.ASCII value
C BaseValue | Base class for a characteristic value representation.
C CDFFile | Implements the Calibration Data File format reader/writer.
C CharacteristicValue | Creates a value representation for the different characteristic value types
C Cube4Value | Class representing a characteristic CHAR_TYPE.CUBE_4 value
C Cube5Value | Class representing a characteristic CHAR_TYPE.CUBE_5 value
C CuboidValue | Class representing a characteristic CHAR_TYPE.CUBOID value
C CurveValue | Class representing a characteristic CHAR_TYPE.CURVE value
C DataConservation | Base class for any import and export calibration data file formats
C DataFile | Base class for reading/writing S19 and HEX files
C DataFileBin | Class for reading/writing binary data files
C DataFileBinDlg | Dialog to get a start address for a data binary file.
C DataFileHex | Class for reading/writing Intel HEX files
C DataFileS19 | Class for reading/writing Motorola S files
C DCMFile | Implements the ETAS INCA DCM file format 2.x reader/writer
C MapValue | Class representing a characteristic CHAR_TYPE.MAP value
C MatlabFile | Implements the Matlab (*.m) file format reader/writer.
C MeasurementAccessData | Manages static memory data for A2LMEASUREMENTs.
C PARFile | Implements the CANape PAR data File format reader/writer
C SingleValue | Class representing a characteristic CHAR_TYPE.VALUE value
C ValBlkValue | Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value
▼N XCP | Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff.
C A2LXCP_ADDRESS_MAPPING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_BUFFER_RESERVE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT)
C A2LXCP_CAN_FD | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_CHECKSUM |
C A2LXCP_CLOCK | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation)
C A2LXCP_CORE_LOAD | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core)
C A2LXCP_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_CAN_ID | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_USB_ENDPOINT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_DAQ_MEMORY_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LXCP_ECU_STATES_MEMORY_ACCESS | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State)
C A2LXCP_ECU_STATES_STATE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States)
C A2LXCP_ENDPOINT | Base class for all endpoint classes.
C A2LXCP_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CAN_ID_LIST | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue)
C A2LXCP_EVENT_DAQ_PACKED_MODE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists).
C A2LXCP_EVENT_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_MIN_CYCLE_TIME | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels)
C A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table)
C A2LXCP_FRAMING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI
C A2LXCP_IN_EP_ONLY_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_ONLY_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_RESERR_DAQ_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_MEDIA | Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...)
C A2LXCP_NAMEDNODE | Base class for all A2LXCP entities with specific names.
C A2LXCP_NODE | Base class for all A2L node definitions concerning XCP.
▼C A2LXCP_ODT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED)
C ODT_ENTRY | Represents a single ODT entry.
C A2LXCP_ON_CAN | XCP on CAN parameters
C A2LXCP_ON_ETHERNET | Base class for the XCP ethernet media (UDP/TCP)
C A2LXCP_ON_SxI | XCP on SxI parameters
C A2LXCP_ON_TCP_IP | XCP on TCP parameters
C A2LXCP_ON_UDP_IP | XCP on UDP parameters
C A2LXCP_ON_USB | XCP on USB parameters
C A2LXCP_OUT_EP_CMD_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_OUT_EP_ONLY_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_PAG | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PAGE | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PGM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PROTOCOL_LAYER | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SECTOR | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SEGMENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_TIME_CORRELATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LXCP_TIMESTAMP_CHARACTERIZATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock)
C A2LXCP_TIMESTAMP_SUPPORTED | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C DAQAndEvt | Hold a DAQList with it's attached Event.
C OptionalCommandSet | Represents a set of unique strings used to optional commands.
C XCPCommModes | Supported communication modes.
C A2LA2ML | This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA).
C A2LADDRESS | Base class for all A2L entities containing an ECU address.
C A2LANNOTATION | see ASAP2 specification
C A2LANNOTATION_TEXT | see ASAP2 specification
C A2LAR_COMPONENT | see ASAP2 specification
C A2LAXIS_DESCR | see ASAP2 specification
C A2LAXIS_PTS | see ASAP2 specification
C A2LBIT_OPERATION | The BIT_OPERATION keyword can be used to perform operation on the masked out value
C A2LBLOB | see ASAP2 specification
C A2LCALIBRATION_HANDLE | see ASAP2 specification
C A2LCALIBRATION_METHOD | see ASAP2 specification
▼C A2LCANAPE_ADDRESS_UPDATE | ASAP2 CANAPE_ADDRESS_UPDATE Interface support.
C AdrMapType | Adress map type
C CALIBRATION_METHOD | CANAPE calibration method.
C ExSymbolType | Extended Symbol type
C FirstLastNode | Base class for MapSymbol and MemorySegment
C FlashSectionType | Flash section type
C MAP_SYMBOL | CANAPE map symbol
C MEMORY_SEGMENT | CANAPE memory segment
C SymbolType | Symbol type
▼C A2LCANAPE_EXT | ASAP2 CANAPE_EXT Interface support.
C DisplayType | Display setting definition
C LinkMapType | Linker map definition
C VirtualConvType | Virtual conversion definition
C A2LCHARACTERISTIC | see ASAP2 specification
C A2LCOMPU_METHOD | see ASAP2 specification
C A2LCOMPU_TAB | see ASAP2 specification
C A2LCOMPU_TAB_BASE | Base class for dictionary based compu methods.
C A2LCOMPU_VTAB | see ASAP2 specification
C A2LCOMPU_VTAB_RANGE | see ASAP2 specification
C A2LCONVERSION_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method.
C A2LDEF_CHARACTERISTIC | see ASAP2 specification
C A2LDEPENDENT_CHARACTERISTIC | see ASAP2 specification
C A2LFIX_AXIS_PAR_LIST | see ASAP2 specification
C A2LFORMULA | see ASAP2 specification
C A2LFRAME | see ASAP2 specification
C A2LFUNCTION | see ASAP2 specification
C A2LFUNCTION_LIST | see ASAP2 specification
C A2LGROUP | see ASAP2 specification
C A2LHEADER | see ASAP2 specification
C A2LIF_DATA | see ASAP2 specification
C A2LIN_MEASUREMENT | see ASAP2 specification
C A2LINSTANCE | see ASAP2 specification
C A2LLOC_MEASUREMENT | see ASAP2 specification
C A2LMEASUREMENT | see ASAP2 specification
C A2LMEMORY_LAYOUT | see ASAP2 specification
C A2LMEMORY_SEGMENT | see ASAP2 specification
C A2LMOD_COMMON | see ASAP2 specification
C A2LMOD_PAR | see ASAP2 specification
C A2LMODULE | see ASAP2 specification
C A2LNAMEDNODE | Base class for all A2L entities with specific names.
C A2LNODE | Base class for any A2L entity
C A2LOUT_MEASUREMENT | see ASAP2 specification
C A2LOVERWRITE | see ASAP2 specification
C A2LParser | The ASAP2 parser
C A2LParserProgressEventArgs | Progress EventArgument generated while parsing a file.
C A2LPROJECT | The one and only root node of an A2L source file
▼C A2LRECORD_LAYOUT | Record layout
C AxisPtsLayoutDesc | Layout description for axis points.
C AxisRescaleLayoutDesc | Layout description for axis rescale value pairs.
C FncValuesLayoutDesc | Layout description for function values
C ItemLayoutDesc | Base class for record layout items.
C A2LRECORD_LAYOUT_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LREF_CHARACTERISTIC | see ASAP2 specification
C A2LREF_GROUP | see ASAP2 specification
C A2LREF_MEASUREMENT | see ASAP2 specification
C A2LREFBASE | Base class for A2LFUNCTION and A2LGROUP
C A2LREFERENCE | Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs
C A2LSTRUCTURE_COMPONENT | see ASAP2 specification
C A2LSUB_FUNCTION | see ASAP2 specification
C A2LSUB_GROUP | see ASAP2 specification
C A2LTRANSFORMER | see ASAP2 specification
C A2LTRANSFORMER_IN_OBJECTS | see ASAP2 specification
C A2LTRANSFORMER_OUT_OBJECTS | see ASAP2 specification
C A2LTYPEDEF | Base class for all A2L typedef entities.
C A2LTYPEDEF_AXIS | see ASAP2 specification
C A2LTYPEDEF_BLOB | see ASAP2 specification
C A2LTYPEDEF_CHARACTERISTIC | see ASAP2 specification
C A2LTYPEDEF_CONVERSION_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method.
C A2LTYPEDEF_MEASUREMENT | see ASAP2 specification
C A2LTYPEDEF_RECORDLAYOUT_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LTYPEDEF_STRUCTURE | see ASAP2 specification
C A2LUNIT | see ASAP2 specification
C A2LUNSUPPORTEDNODE | Node type to store unsupported objects
C A2LUSER_RIGHTS | see ASAP2 specification
C A2LVAR_ADDRESS | see ASAP2 specification
C A2LVAR_CHARACTERISTIC | see ASAP2 specification
C A2LVAR_CRITERION | see ASAP2 specification
C A2LVAR_FORBIDDEN_COMB | see ASAP2 specification
C A2LVARIANT_CODING | See ASAP2 Specification > v1.6.0 .
C A2LVIRTUAL | see ASAP2 specification
C A2LVIRTUAL_CHARACTERISTIC | see ASAP2 specification
C AdditiveDescriptionEventArgs | Used to get an additive description for a A2LNode from user code.
C DAQMeasurement | Structure to specify a DAQ configuration for a single measurement.
C IA2LDescription | Interface for nodes containing a description property.
C IA2LMemory | Interface to access both types of memory.
C ICharValue | Interface for accessing a characteristic value representation
C IDataFile | Interface for reading and writing data files (S19 and HEX) files.
C MemorySegment | Implements the representation of a memory segment of a data file
C MemorySegmentList | Memory segment list type
C ModelChangedEventArgs | Changed model event arguments.
C NonCompliantException | Exception class for non ASAP2 compliant files
C WriterException | Exception class representing an ASAP2 Writer exception
▼N BLF | Implements the Vector BLF file format reader/writer
C AppText | Application text
C AppTextManaged | .NET Application text representation
C BLFFile | BLF file Reader/Writer.
C CANDriverError | CAN driver error
C CANError | CAN Error
C CANErrorExt | CAN Error (extended)
C CANFDManaged | CAN FD message
C CANFDMessage | CAN FD message
C CANFDMessage64 | CAN FD 64 message
C CANMessage | CAN message
C CANMessage2 | Extended CAN message
C CANStatistic | CAN driver statistic
▼C Header | Header structure
C Time | BLF time representation
C LObj | Log object base class
C LogContainer | Log container structure
C ObjBase | Object base class
C RestorePointContainer | Restore Point Container
C RestorePointContainerManaged | .NET Restore Point Container
C SysVariable | System variable
C SysVariableManaged | .NET System variable
▼N Comm | Contains all the stuff to communicate over XCP, CCP and CAN.
▼N CAN | All the stuff needed to communicate with CAN hardware.
▼N _8Devices | All the stuff needed to bind to the 8Devices CAN hardware.
C _8DevicesCAN | The 8Devices version of an ICANProvider
▼N Advantech | All the stuff needed to bind to the Advantech CAN hardware.
C AdvantechCAN | The Advantech version of an ICANProvider
▼N EbEl | All the stuff needed to bind to the Eberspächer electronics FlexCard CAN hardware
C EbElCAN | The Eberspächer electronics version of an ICANProvider
▼N ELM327 | All the stuff needed to bind to the ELM327 CAN hardware.
C ELM327CAN | The ELM327 version of an ICANProvider.
▼N ESD | All the stuff needed to bind to the ESD CAN hardware
C ESDCAN | The ESD version of an ICANProvider
▼N ETAS | All the stuff needed to bind to the ETAS CAN hardware (BOA)
C ETASCAN | The ETAS BOA version of an ICANProvider
▼N IMEActia | All the stuff needed to bind to the IMEActia CAN hardware
C IMEActiaCAN | The IMEActia version of an ICANProvider
▼N Intrepid | All the stuff needed to bind to the Intrepid CAN hardware
C IntrepidCAN | The Intrepid version of an ICANProvider
▼N IXXAT | All the stuff needed to bind to the IXXAT CAN hardware
C IXXATCAN | The IXXAT version of an ICANProvider
▼N Kvaser | All the stuff needed to bind to the Kvaser CAN hardware
C KvaserCAN | The Kvaser version of an ICANProvider
▼N Lawicel | All the stuff needed to bind to the Lawicel CAN hardware
C LawicelCAN | The Lawicel version of an ICANProvider
▼N MHS | All the stuff needed to bind to the MHS Tiny-CAN CAN hardware.
C MHSCAN | The MHS Tiny-CAN version of an ICANProvider
▼N NI | All the stuff needed to bind to the National Instruments CAN hardware (NI-CAN)
C NICAN | The National Instruments version of an ICANProvider
▼N NIXNET | All the stuff needed to bind to the National Instruments CAN hardware (XNET)
C NIXNET | The National Instruments XNET version of an ICANProvider
▼N Peak | All the stuff needed to bind to the Peak CAN hardware.
C PeakCAN | The Peak version of an ICANProvider
▼N Softing | All the stuff needed to bind to the Softing CAN hardware
C SoftingCAN | The Softing version of an ICANProvider
▼N Vector | All the stuff needed to bind to the Vector CAN hardware
C VectorCAN | The Vector version of an ICANProvider
C CANConfigException | CAN Configuration exception.
▼C CANConfiguration | Represents the vendor(hardware) independant CAN configuration
C BitRateConfig | CAN FD Bitrate configuration using common parameters.
C BitRatePar | Bitrate configuration from Brp, TSeg1, TSeg2, and SJw
C CANEventArgs | EventArgs class to notify transferred CAN frames.
C CANFilterIDs | Serializes CAN filter IDs.
C CANFrame | Represents a sent or received CAN message.
C CANFrameQueue | Queue implementation to store CANFrame's.
C CANProvider | Implements a base class for a vendor specific CAN provider
C ICANProvider | CAN Adapter interface to implement for each CAN Bus provider.
C J1939Frame | Represents a sent or received J1939 message.
C J1939FrameQueue | Queue implementation to store J1939 Frame's.
▼N CCP | Implements the CAN Calibration Protocol Version 2.1 (ASAM MCD-1 CCP)
C CCPErrorArgs | ErrorArgs class delivering received command errors.
C CCPEventArgs | EventArgs class delivering received events.
C CCPFrame | Represents an CCP frame
C CCPFrameQueue | Queue implementation to store CCPFrame's.
C CCPMaster | Implements the CCP Master to communicate with a CCP Slave
C CCPMasterBase | Implements the CCP Master base communication with a CCP Slave
C CCPonCAN | Base class implementing the CCP based communication instance.
C CmdActionDiagService | Supports CCP commands Diag and Action service.
C CmdBase | Base class represents a CCP command.
C CmdMoveClearBC | Supports CCP commands Move, Clear memory, BuildChksum.
C DAQDictCCP | Holds a dictionary of configured DAQ Lists
C DAQListCCP | DAQ List representation
C RespActionDiagService | Response from Get Diagnostic or Action service.
C RespBase | Base class represents a CCP response.
C RespBuildChecksum | Response from Build Checksum.
C RespDownload | Response from Get Size of DAQ list.
C RespExchangeID | Response from Exchange Station Identifications.
C RespGetActiveCALPage | Response from Get currently active Calibration Page.
C RespGetCCPVersion | Response from Get implemented Version of CCP.
C RespGetDAQSize | Response from Get Size of DAQ list.
C RespGetSeed | Response from Get Seed for Key.
C RespGetSStatus | Response from Get current session status from slave
C RespUnlock | Response from Unlock Protection.
▼N ECUSimulator | Implements the ECU simulator
▼C Program | Main class of the ECU simulator
C CCPSim | Implements the CCP ECU simulator.
C UDSSim | Implements the UDS ECU simulator.
C XCPSim | Implements the XCP ECU simulator.
N ETAS |
N Intrepid |
N IXXAT |
▼N LIN | All the stuff needed to communicate with LIN hardware.
▼N ETAS | All the stuff needed to bind to the ETAS LIN hardware.
C ETASLIN | The ETAS version of an ILINProvider
▼N Intrepid | All the stuff needed to bind to the Intrepid LIN hardware
C IntrepidLIN | The Intrepid version of an ILINProvider
▼N IXXAT | All the stuff needed to bind to the IXXAT LIN hardware
C IXXATLIN | The IXXAT version of an ILINProvider
▼N Kvaser | All the stuff needed to bind to the Kvaser LIN hardware.
C KvaserLIN | The Kvaser version of an ILINProvider
C LINMessageInfo |
▼N Peak | All the stuff needed to bind to the Peak LIN hardware.
C PeakLIN | The Peak version of an ILINProvider
▼N Vector | All the stuff needed to bind to the Vector LIN hardware
C VectorLIN | The Vector version of an ILINProvider
C ILINProvider | LIN Adapter interface to implement for each LIN Bus provider.
C LINConfiguration | Represents the vendor(hardware) independant LIN configuration
C LINEventArgs | EventArgs class to notify transferred LIN frames.
C LINFilterIDs | Serializes LIN filter IDs.
C LINFrame | Represents a sent or received LIN message.
C LINFrameDict | Maps LIN Id to LIN frames.
C LINFrameQueue | Queue implementation to store LINFrame's.
C LINProvider | Implements a base class for a vendor specific LIN provider
N Vector |
▼N XCP | Implements the XCP Protocol Version 1.3 (ASAM MCD-1 XCP V1.3.0)
▼N Examples |
C Program | ASAP2 XCP Sample console application
▼N SxI | All the stuff needed to communicate with Serial interfaces.
C ISxIProvider | Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...)
C SxIEventArgs | EventArgs class to notify transferred SxI data.
C SxIProvider | Implements a base class for serial interface specific SxI providers
C CmdBase | Base class represents a XCP command.
C CmdUserTransCmd | Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd.
C DAQDictXCP | Holds a dictionary of configured DAQ Lists
C DAQListXCP | DAQ List representation
C EventBase | Base class represents a XCP event.
C EventResumeMode | Event START IN RESUME MODE
C EventResumeModeTS | Event START IN RESUME MODE.
C EventStimTimeout | Event INDICATION OF TIME-OUT AT STIM.
C EventTimeSync | Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP.
C ODT | ECU Simulator: ODT representation
C ODTDict | ECUSimulator: Dictionary mapping PIDs to ODTs.
C RespBase | Base class represents a XCP response.
C RespBuildChecksum | Response from Build checksum over memory range
C RespConnect | Response from Set up connection with slave
C RespDTOCtrResp | Response from DTO CTR Properties command.
C RespError | Error Response
C RespEvent | Event response
C RespGetCALPage | Response from Get calibration page
C RespGetCommModeInfo | Response from Get current session status from slave
C RespGetDAQClock | Response from Get DAQ clock from slave
C RespGetDAQEventInfo | Response from Get specific information for an event channel
C RespGetDAQListInfo | Response from Get specific information for a DAQ list
C RespGetDAQListMode | Response from Get mode from DAQ list
C RespGetDAQListUSBEndpoint | Response from Get DAQ List USB Endpoint.
C RespGetDAQProcessorInfo | Response from Get general information on DAQ processor
C RespGetDAQResolutionInfo | Response from Get general information on DAQ processing resolution
C RespGetID | Response from Get identification from slave
C RespGetPageInfo | Response from Get specific information for a PAGE
C RespGetPAGProcessorInfo | Response from Get general information on PAG processor
C RespGetPGMProcessorInfo | Response from Get general information on PGM processor
C RespGetSectorInfoModeAddressOrLen | Response from Get specific information for a SECTOR
C RespGetSectorInfoModeSectorNameLen | Response from Get specific information for a SECTOR
C RespGetSeed | Response from Get seed for unlocking a protected resource
C RespGetSegmentInfo | Response from Get address information for a SEGMENT
C RespGetSegmentInfoAddress | Response from Get standard information for a SEGMENT
C RespGetSegmentMode | Response from Set mode for a SEGMENT
C RespGetStatus | Response from Get current session status from slave
C RespProgramStart | Response from Indicate the beginning of a programming sequence
C RespReadDAQ | Response from Read element from ODT entry
C RespService | Base class represents a XCP service request.
C RespStartStopDAQList | Response from Start/stop/select DAQ list
C RespTimeCorrelation | Response from Time Correlation command.
C RespUnlock | Response from Send key for unlocking a protected resource
C XCPCommunicator | Base class supporting any XCP based communication instance
C XCPErrorArgs | ErrorArgs class delivering received command errors.
C XCPEventArgs | EventArgs class delivering received events
C XCPFrame | Represents an XCP frame
C XCPFrameQueue | Queue implementation to store XCPFrame's.
C XCPMaster | Implements the XCP Master to communicate with a XCP Slave
C XCPMasterBase | Implements the XCP Master base communication with a XCP Slave
C XCPonEth | Base class implementing the XCP on ethernet based communication instance.
C XCPOnSxI | Implements the XCP on SxI based communication instance.
C XCPonTCP | Implements the TCP based XCP communication.
C XCPonUDP | Implements the UDP based XCP communication.
C XCPOnUSB | Implements the XCP on USB based communication instance.
C XCPReceiveBuffer | Implements a receive buffer for XCP frames
C XCPServiceRequestArgs | EventArgs class delivering received events
C CommKernel | Implements the Communication kernel
C CommMaster | Base class for both XCP and CCP master
C Communicator | Basic communicator implementation
C DAQCache | DAQ Record cache
C DAQDict | Holds the configured DAQ Lists for both XCP and CCP.
C DAQList | DAQ List representation base class for both XCP and CCP
C DAQStore | Holds received DAQ records
C DAQToEvtMapDict | Maps a XCP DAQList number to a specific XCP Event.
C Frame | Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP).
C FrameEventArgs | Frame queue event arguments.
C FrameProvider | Provides CAN/LIN Frames for CAN and LIN providers.
C FrameQueue | Base class for any frame type queue (CAN, CCP, XCP, UDS,...)
C IFrameProvider | Common Interface for the CAN/LIN/SxI frame providers.
C IResponse | Base class represents a CCP or XCP response.
C ODTEntry | Represents an ODT entry
C ODTList | Holds the configured ODTEntries within an ODT.
C ValuesReceivedEventArgs | Event arguments used on receiving acquisition data.
C XCPPrgParams | Transfer structure holding (XCP) programming parameters.
▼N DBC | Implements the DBC (Vector CANDb++) file format reader/writer
▼N Examples |
C Program | ASAP2ibrary DBC handling demonstration
▼C DBCFile | Implements the DBC (Vector CANDb++) file format reader/writer.
C AttribDefDict | Attributes dictionary type
C AttribDefType | CANDb++ Attribute definition type.
C AttributeType | CANDb++ Attribute type.
C AttributeTypeDict | CANDb++ Attributes dictionary.
C EnumDict | Defines a value table dictionary (mapping double values to strings).
C EnvironmentDict | Environment dictionary type
C EnvironmentType | CANDb++ Environment type.
C IDBCAttribute | Interface any DBC base class attributes must implement.
C IDBCBase | Interface any DBC base class must implement.
C IDBCComment | Interface any DBC base class supporting comments must implement.
C IDBCSignal | Interface any DBC base class supporting signals must implement.
C MsgType | CANDb++ (DBC) Message type.
C SignalGroupDict | Defines a signal group table dictionary (mapping signal group IDs to signal groups).
C SignalGroupType | Defines the CANDb++ signal group table.
C SignalType | CANDb++ (DBC) Signal type.
C SourceDict | Source dictionary type
C SourceType | CANDb++ (DBC) Device type.
C ValueTable | Defines the CANDb++ value table.
C ValueTableDict | Defines a value table dictionary (mapping value table idents to value tables).
▼N Diagnose |
▼N Comm | All the stuff to support various diagnostic service protocols
▼N DoIp | Implements the DoIP (ISO 13400) protocol.
▼N Examples |
C Program | ASAP2 DoIP Example
C AnnoncementEventArgs | Vehicle announcemnet event arguments
C BaseFrame | Base DoIP Frame
C DiagnosticMessage | Diagnostic message.
C DiagnosticPowerModeResponse | Diagnostic Powermode response.
▼C DoIPBase | Base class for a DoIP client or server
C Communicator | Holds a Socket, sender endpoint, receive buffer and stream length/position.
C ResponseEvent | Used to wait for and handle responses.
C DoIPClient | Implements the DoIP Client
C DoIPFrameQueue | Queue implementation to store DoIPFrame's.
C DoIPServer | Implements the DoIP Server (this is just used for simulating)
C EntityData | Holds a single Entity.
C EntityStatusResponse | Entity status response
C RespBase | Response base class.
C RoutingActivationResponse | Routing activation response.
C SrcDstFrame | Frame containing a source and destination address.
C SrcFrame | Frame containing a source address.
C VehicleIdResponse | VehicleId response.
▼N UDS | Implements the UDS Protocol (ISO 14229-1).
C DTCAndStatusRecord | Defines a single DTC record.
C RespBase | Base class for UDS protocol responses.
C RespControlDTCSetting | Response on Control DTC setting.
C RespData | Base class for UDS protocol responses with no Subfunction and a byte stream.
C RespDTCCount | DTC Count Response.
C RespDTCRecords | DTC records response.
C RespDTCSeverityRecords | DTC records with severity response.
C RespDynamicallyDefine | Base class for DynamicallyDefineDataIdentifier service.
C RespIdentfier | InputOutputControlByIdentifier/WriteDatByIdentifier response.
C RespLinkControl | Response on Event response.
C RespRequestUpDownload | Request upload/download service response.
C RespReset | ECUReset response.
C RespResponseOnEvent | Response on Event response.
C RespRoutineControl | Request Routine control service response.
C RespSecurityAccess | Security access response.
C RespSession | DiagnosticSessionControl response.
C RespSFBase | Base class for UDS protocol responses with Subfunction.
C RespTimingParameter | Timing parameter response.
C RespTransferData | Request TransferData service response.
C RespWriteMemoryByAddress | WriteMemoryByAddress response.
C ServiceProperties | Holds specification defined Service properties
C ServiceType | Service properties.
C SrcDataIdentifier | Dynamically Define Identifier by Id request.
C SrcDataMemory | Dynamically Define Identifier by memory address request.
▼C UDSClient | Implements the UDS client (Tester) Application protocol
C IdentifierRequest | Represents a cyclic Identifier request and its response data.
C UDSClientBase | Implements the UDS client base Application protocol
C UDSFrame | Represents an UDS frame.
C UDSFrameQueue | Queue implementation to store UDSFrame's.
C IsoTp | Implements the ISO 15765-2 (IsoTp) protocol
C IsoTpFSM | Represents the state machine to process an IsoTp message.
▼N ODX | All the ODX (Open Diagnostic Data Format) stuff
▼N Examples |
C Program | Sample console application
C AdminData | Administrative data definition.
C Audience | Defines user class types.
C BaseDocInfoContainer | Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash.
C BaseVariant | Diagnostic base variant definition.
C BaseVariantRef | Reference to base variant used in PARENT-REFS.
C Case | Multiplexer case.
C ChartContainer | Chart container.
C CompanyData | Definition of Company data.
C CompanySpecificInfo | Company specific info definition.
C ComParam | Communication parameter definition.
C ComParamBase | Communication paramter base class.
C COMParamRef | Communication parameters.
C ComParamSpec | Communication parameter specification definition.
C ComParamSubset | Communication parameter subset definition.
C ComplexComParam | Complex communication parameter definition.
C CompuInternalToPhys | Computation from a raw value to a physical value.
C CompuMethod | Compu method base definition.
C CompuRationalCoeffs | Compu method rational coefficients.
C CompuScale | Compu scale definition
C DataBlock | Data block definition.
C DataFile | Data file definition.
C DataFormat | Data format definition.
C DataObjectProp | Data object property specification.
C DefaultCase | Multiplexer default case definition.
C DetermineNumberOfItems | Part of dynamic length field part.
C DiagCodedTypeBase | Base class for diagnose coded types.
C DiagCodedTypeLL | Leading length diagnose coded type
C DiagCodedTypeMinMax | Minimum-Maximum diagnose coded type.
C DiagCodedTypePL | Param length diagnose coded type.
C DiagCodedTypeStd | Standard diagnose coded type.
C DiagDataDictionarySpec | Diagnostic dictionary specification.
C DiagDataDictSpec | Non serialized class used internally to hold DiagDataDictionarySpec instances.
C DiagLayerContainer | Diagnostic layer container.
C DiagService | Diagnostic service definition.
C DocRevision | Definition of a document revision.
C Dtc | Diagnostic trouble code.
C DtcDop | Diagnostic trouble codes specification.
C DynamicLengthField | Dynamic length field definition.
C EcuMem | ECU memory definition.
C EcuMemConnector | ECU memory connector definition.
C EcuSharedData | ECU shared data definition.
C EcuSharedDataRef | Reference to ECU shared data used in used in PARENT-REFS.
C EcuVariant | ECU variant definition.
C EcuVariantPatternContainer | ECU variant pattern container.
C EndOfPDUField | End of PDU filed definition.
C EnvDataDesc | Environment data description.
C EnvDataParamContainer | Environment data parameter container.
C Filter | Filter definition.
C Flash | Flash data definition.
C FlashDataExtern | Flash data definition (External).
C FlashDataIntern | Flash data definition (Internal).
C FunctClass | ODX function class element.
C FunctionalGroup | Functional group definition.
C FunctionalGroupRef | Reference to functional group used in PARENT-REFS.
C IcEcuProxy | Info Component ECU-PROXY.
C IcModelYear | Info Component MODEL-YEAR.
C IcOEM | Info Component OEM.
C IcVehicleModel | Info Component VEHICLE-MODEL.
C IcVehicleType | Info Component VEHICLE-TYPE.
C Id | Id tagged ODX element.
C Ident | Ident definition.
C IdentDesc | Ident descriptor definition.
C IdentifierRecord | Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22)
C IDescription | Used to indicate description supporting ODX nodes.
C IdRef | Id Reference.
C IId | Interface used to initialize ID dictionary while loading the ODX file
C InternalConstr | Internal constraints definition.
C LimitBase | Base class for Limit containing scales.
C MatchingParameterContainer | Matching parameter container.
C Mem | Memory definition.
C MemberLogicalLink | Member logical link type definition.
C Modification | Definition of a document revision modification.
C Mux | Multiplexer definition.
C NamedDescId | ODX base class for named elements with description.
C NamedId | ODX base class for named elements.
C NonCompliantException | Exception class for non ODX compliant files
C NotInheritedDiagComm | Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant.
C ODXFile | Open Diagnostic eXchange format (ODX) reader/writer.
C ODXRoot | ODX root
C ParamContainer | Paramter container definition.
C ParBaseDef | Parameter base definitiob.
C ParCodedConst | Coded parameter definition.
C ParDynamic | Paramneter with length reference.
C ParIdBase | Base class for ID referenced parameters.
C ParLength | Paramneter with length reference.
C ParMatchRequestParam | Matching request parameter.
C ParNrcConst | Used tp represent Negative response code constants.
C ParPhysConst | Physical constant parameter definition.
C ParReserved | Reserved Parameter definition.
C ParSystem | Parameter system definition.
C ParTableEntry | Parameter table entry definition
C ParTableKey | Parameter table key definition
C ParTableStruct | Parameter table entry definition
C ParValue | Parameter value definition.
▼C PDXIndex | PDX index.xml file
C ABLOCK | XML ABLOCK definition.
C FILE | XML FILE type definition.
C PhysicalDimension | Defines the physical dimension of a unit.
C PhysicalType | Defines the physical type in a data object property specification.
C PhysMem | Physical memory definition.
C PhysSegmentAddr | Physical memory segment definition with End Address.
C PhysSegmentBase | Base physical memory segment definition.
C PhysSegmentSize | Physical memory segment definition with Size.
C PkysicalVehicleLink | Physical vehicle link defintition.
C Protocol | Diagnostic Protocol definition.
C ProtocolRef | Reference to a diagnostic protocol used in PARENT-REFS.
C ProtStack | Protocol stack definition.
C RelatedDoc | Related document definition.
C ScaleConstr | Scale constraints definition.
C Sdg | SD group definition.
C Security | Security settings.
C Segment | Data segment definition.
C Session | ECU Session definition.
C SessionDesc | Session descriptor definition.
C SnRef | SHORT-NAME reference definition.
C StateTransitionContainer | State transition container.
C StaticField | Structure definition.
C Structure | Structure definition.
C SwitchKey | Multiplexer switch key definition.
C Table | Table definition.
C TableRow | Tablerow definition.
C TeamMember | Definition of a Team member.
C TypeValueElement | XML element with a TYPE Attribute and a Value text.
C Unit | ODX Unit element.
C UnitSpec | Specification of supported units.
C UnitSpecs | Non serialized class used internally to hold a UnitSpec instance.
C VehicleConnector | Vehicle connector definition.
C VehicleConnectorPin | Vehicle connector pin definition.
C VehicleInformation | Vehicle information.
C VehicleInfoSpec | Vehicle information specification.
C XDoc | External document definition.
▼N Helpers | Defines and implememts common helper types.
C Adler32Computer | Computes the Adler checksum used for zlib compressed files.
C Constants | Globally used constants.
C DataLimits | Represents data limits.
C DataPoint | Represents a data point in double floating point (64 Bit) precision.
C DataPointF | Represents a data point in single floating point (32 Bit) precision.
C DLLWrapper | Implements the ability to dynamically load a native windows DLL
C Extensions | Implements basic helper stuff.
C IgnoreNSXmlTextReader | XML text reader ignoring any namespace.
C MemoryRange | Holds a memory range.
C MemoryRangeList | Holds a range of memory.
C NativeSKDLL | Allows access to (native Windows) Seed&Key DLLs
C ParserEventArgs | Parser message EventArgument generated while parsing a file.
C ProgressArgs | EventArgs class to notify progress and support a cancel possibility.
C sRange | Represents a value range with a Min and Max border.
C TCByteOrder | Typeconverter to edit a reference the Byte order.
C TCByteOrderWithNotSet | Typeconverter to edit a reference the Byte order.
C TCHexType | Typeconverter to display and edit hex values.
C TcpSocketWithTimeout | Tcp socket using a configurable connect timeout.
C TimeBase | Provides system/application time functions.
▼N LIN |
▼N Examples |
C Program | ASAP2ibrary LION handling demonstration
▼N Logging | Defines logging support.
C ILog | Logging interface
C LogManager | Default LogManager (no log support at all).
▼N MDF | All the MDF (Measurement Data Format) stuff
▼N Examples |
▼N Reader |
C Program | MDF Reader example
▼N Writer |
C Program | MDF Writer example
▼N V3 | Implements the MDF V1.XX..V3.XX specific stuff.
C BLOCKBASE | Base class for all MDF V3 BLOCK types (except the IDBLOCK).
C CCBLOCK | MDF V3 CCBLOCK.
C CDBLOCK | The Channel Dependency Block
C CEBLOCK | The Channel Extension Block
C CGBLOCK | The Channel Group Block
C CNBLOCK | The Channel Block
C DGBLOCK | The Data Group Block
C HDBLOCK | The Header Block
C IDBLOCK | The File Identification Block
C SRBLOCK | The Sample Reduction Block
▼C TRBLOCK | The Trigger Block
C TriggerEvent | Trigger event data.
C TXBLOCK | The Text Block
▼N V4 | Implements the MDF V4.XX specific stuff
C ATBLOCKV4 | Container for binary data or a reference to an external file.
C BaseNames | Base class SI and CN comments
C BLOCKBASEV4 | Base class for all BLOCKV4 types (except the IDBLOCK).
C CABLOCKV4 | The channel array block
C CCBLOCKV4 | MDF V4 CCBLOCK.
C CGBLOCKV4 | The Channel Group Block
C CHBLOCKV4 | Channel hierarchy block.
C CNBLOCKV4 | The Channel Block
C CNcomment | MDF V4 Xml CNBLOCKV4 comment
C CommentBase | Base class for TXBLOCK references
C DataContainerV4 | Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4.
C DescType | Description of object. May exist in defferent languages.
C DGBLOCKV4 | The Data Group Block V4
C DisplayType | Display name of object. May exist in different languages.
C DLBLOCKV4 | DL Block
C DTBLOCKV4 | Container for data records with signal values.
C DZBLOCKV4 | DZ Block
C EBase | Base class for e and tree node.
C EType | MDF V4 Xml e Node
C EVBLOCKV4 | Event block
C FHBLOCKV4 | File history block.
C FHcomment | MDF V4 Xml HDBLOCKV4 comment
C HDBLOCKV4 | The Header Block V4
C HDcomment | MDF V4 Xml HDBLOCKV4 comment
C HLBLOCKV4 | Header information for linked list of data blocks.
C IDBLOCKV4 | The File Identification Block V4
C NamesBase | Base Name
C NamesType | Name of object in different languages
C RasterType | MDF V4 Xml Raster structure
C RDSDBLOCKV4 | Base class for SD, MD or RD blocks
C SIBLOCKV4 | Source information block
C SIcomment | MDF V4 Xml SIBLOCKV4 comment
C SRBLOCKV4 | The Sample Reduction Block.
C TreeType | MDF V4 Xml Tree
C VendorType | Vendor specific name, e.g. name as used in a specific tool.
C XmlBase | Base implementation for any MDF V4 Xml structure.
C Annotation | Structure holding a single annotation and it's timestamp.
C AnnotationList | Holds a list of Annotations.
C DataBlockExpander | Handles sorting of Datablocks.
C DataReader | MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression.
C DataStream | Handles a temporary stream per data handle.
C DependencyType | Dependency data.
C Helpers | MDF Helper functions and constants.
C ICCBLOCK | Channel computation Block interface.
C ICGBLOCK | Channel group Block interface.
C ICNBLOCK | Channel Block interface.
C IDataContainer | Interface for Data containers like SRBLOCK and DGBLOCK.
C IDGBLOCK | Data Group Block interface..
C IHDBLOCK | Header Block interface.
C IIDBLOCK | ID Block interface.
C IMDFBlock | Basic MDF block interface.
C IMDFComment | Interface to access TXBLOCK comments.
C ISRBLOCK | Sample reduction Block interface.
C MDFReader | Implements the MDF (Measurement Data Format) reader
C MDFWriter | Implements the MDF (Measurement Data Format) recorder.
C RawDataRecord | Used to transfer MDF raw data record.
C WriteRawDataEventArgs | EVent arguments to request the MDFWriter to write the raw data to the stream.
▼N Symbols | Implements the Symbol support
▼N ELF | Implements the ELF file format reader (supports 32 and 64 Bit)
▼N DWARF | All the stuff to support the DWARF Debugging Information Format Version 5.
C AbbrevEntry | DWARF abbreviation entry representation.
C AbbrevEntryArray | Represents an abbreviation array type.
C AbbrevEntryCU | Represents an abbreviation compilation unit.
C AbbrevEntryMember | Represents an abbreviation member.
C AbbrevEntryVarBase | Represents a base class for variables and members
C AbbrevEntryVariable | Represents an abbreviation variable.
C Attribute | DWARF attribute representation.
C CompilationUnitHeader | DWARF compilation unit header
▼C DWARFInfo | Implements a parser to support the DWARF Debugging Information Format Version 5
C SymbolsTree | DWARF symbols Tree.
C SymbolValue | Represents a DWARF symbol.
C TypeUnitHeader | Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section.
▼N Examples |
C Program | ASAP2ELFExample
▼C ELFFile | Implements the ELF file format reader.
C ELFHeader | ELF File Header definition
C ELFSection | ELF Section definition
C ELFSymbol | ELF File Symbol definition
C SectionList | List of ELF Sections.
C SectionValue | Maps a ELF Section name to an ELFSection instance.
C SymbolValue | ELF Symbol Value representation.
▼N MAP | Implements the MAP file format reader
▼C MAPFile | Parses MAP files
C SymbolValue | Contains a map file smbol entry (Name, address)
C SymbolFile | Implements the base class for specific Symbol files (like ELF or MAP).
C UpdateData | Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition.
C UpdaterSymbols | Created symbols by ELF, DWARF or MAP interpretation.
Generated by doxygen 1.9.2


ASAP2Library interface: jnsoft Namespace Reference

Namespaces
jnsoft Namespace Reference

Namespaces

namespace | ASAP2
Contains the ASAP2 parser base and the ASAP2 object model implementation...
namespace | BLF
Implements the Vector BLF file format reader/writer.
namespace | Comm
Contains all the stuff to communicate over XCP, CCP and CAN.
namespace | DBC
Implements the DBC (Vector CANDb++) file format reader/writer.
namespace | Helpers
Defines and implememts common helper types.
namespace | Logging
Defines logging support.
namespace | MDF
All the MDF (Measurement Data Format) stuff.
namespace | Symbols
Implements the Symbol support.


ASAP2Library interface: jnsoft.ASAP2 Namespace Reference

  • jnsoft
  • ASAP2
Namespaces | Classes | Enumerations | Functions
jnsoft.ASAP2 Namespace Reference

Contains the ASAP2 parser base and the ASAP2 object model implementation... More...

Namespaces

namespace | CCP
Implements the ASAP2 CCP (IF_DATA) Interface stuff.
namespace | Formulas
Contains all the stuff for dynamically compiled formulas.
namespace | Helpers
Contains the ASAP2 parser helper stuff.
namespace | KWP
Implements the ASAP2 KWP (IF_DATA) Interface stuff.
namespace | Values
Defines and implements stuff for reading, writing and modifying characteristic values.
namespace | XCP
Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff.

Classes

class | A2LA2ML
This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA). More...
class | A2LADDRESS
Base class for all A2L entities containing an ECU address. More...
class | A2LANNOTATION
see ASAP2 specification More...
class | A2LANNOTATION_TEXT
see ASAP2 specification More...
class | A2LAR_COMPONENT
see ASAP2 specification More...
class | A2LAXIS_DESCR
see ASAP2 specification More...
class | A2LAXIS_PTS
see ASAP2 specification More...
class | A2LBIT_OPERATION
The BIT_OPERATION keyword can be used to perform operation on the masked out value. More...
class | A2LBLOB
see ASAP2 specification More...
class | A2LCALIBRATION_HANDLE
see ASAP2 specification More...
class | A2LCALIBRATION_METHOD
see ASAP2 specification More...
class | A2LCANAPE_ADDRESS_UPDATE
ASAP2 CANAPE_ADDRESS_UPDATE Interface support. More...
class | A2LCANAPE_EXT
ASAP2 CANAPE_EXT Interface support. More...
class | A2LCHARACTERISTIC
see ASAP2 specification More...
class | A2LCOMPU_METHOD
see ASAP2 specification More...
class | A2LCOMPU_TAB
see ASAP2 specification More...
class | A2LCOMPU_TAB_BASE
Base class for dictionary based compu methods. More...
class | A2LCOMPU_VTAB
see ASAP2 specification More...
class | A2LCOMPU_VTAB_RANGE
see ASAP2 specification More...
class | A2LCONVERSION_REF
Base class for all A2L entities referencing an A2L_COMPUMETHOD method. More...
class | A2LDEF_CHARACTERISTIC
see ASAP2 specification More...
class | A2LDEPENDENT_CHARACTERISTIC
see ASAP2 specification More...
class | A2LFIX_AXIS_PAR_LIST
see ASAP2 specification More...
class | A2LFORMULA
see ASAP2 specification More...
class | A2LFRAME
see ASAP2 specification More...
class | A2LFUNCTION
see ASAP2 specification More...
class | A2LFUNCTION_LIST
see ASAP2 specification More...
class | A2LGROUP
see ASAP2 specification More...
class | A2LHEADER
see ASAP2 specification More...
class | A2LIF_DATA
see ASAP2 specification More...
class | A2LIN_MEASUREMENT
see ASAP2 specification More...
class | A2LINSTANCE
see ASAP2 specification More...
class | A2LLOC_MEASUREMENT
see ASAP2 specification More...
class | A2LMEASUREMENT
see ASAP2 specification More...
class | A2LMEMORY_LAYOUT
see ASAP2 specification More...
class | A2LMEMORY_SEGMENT
see ASAP2 specification More...
class | A2LMOD_COMMON
see ASAP2 specification More...
class | A2LMOD_PAR
see ASAP2 specification More...
class | A2LMODULE
see ASAP2 specification More...
class | A2LNAMEDNODE
Base class for all A2L entities with specific names. More...
class | A2LNODE
Base class for any A2L entity. More...
class | A2LOUT_MEASUREMENT
see ASAP2 specification More...
class | A2LOVERWRITE
see ASAP2 specification More...
class | A2LParser
The ASAP2 parser. More...
class | A2LParserProgressEventArgs
Progress EventArgument generated while parsing a file. More...
class | A2LPROJECT
The one and only root node of an A2L source file. More...
class | A2LRECORD_LAYOUT
Record layout. More...
class | A2LRECORD_LAYOUT_REF
Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT. More...
class | A2LREF_CHARACTERISTIC
see ASAP2 specification More...
class | A2LREF_GROUP
see ASAP2 specification More...
class | A2LREF_MEASUREMENT
see ASAP2 specification More...
class | A2LREFBASE
Base class for A2LFUNCTION and A2LGROUP. More...
class | A2LREFERENCE
Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs. More...
class | A2LSTRUCTURE_COMPONENT
see ASAP2 specification More...
class | A2LSUB_FUNCTION
see ASAP2 specification More...
class | A2LSUB_GROUP
see ASAP2 specification More...
class | A2LTRANSFORMER
see ASAP2 specification More...
class | A2LTRANSFORMER_IN_OBJECTS
see ASAP2 specification More...
class | A2LTRANSFORMER_OUT_OBJECTS
see ASAP2 specification More...
class | A2LTYPEDEF
Base class for all A2L typedef entities. More...
class | A2LTYPEDEF_AXIS
see ASAP2 specification More...
class | A2LTYPEDEF_BLOB
see ASAP2 specification More...
class | A2LTYPEDEF_CHARACTERISTIC
see ASAP2 specification More...
class | A2LTYPEDEF_CONVERSION_REF
Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method. More...
class | A2LTYPEDEF_MEASUREMENT
see ASAP2 specification More...
class | A2LTYPEDEF_RECORDLAYOUT_REF
Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT. More...
class | A2LTYPEDEF_STRUCTURE
see ASAP2 specification More...
class | A2LUNIT
see ASAP2 specification More...
class | A2LUNSUPPORTEDNODE
Node type to store unsupported objects. More...
class | A2LUSER_RIGHTS
see ASAP2 specification More...
class | A2LVAR_ADDRESS
see ASAP2 specification More...
class | A2LVAR_CHARACTERISTIC
see ASAP2 specification More...
class | A2LVAR_CRITERION
see ASAP2 specification More...
class | A2LVAR_FORBIDDEN_COMB
see ASAP2 specification More...
class | A2LVARIANT_CODING
See ASAP2 Specification > v1.6.0 . More...
class | A2LVIRTUAL
see ASAP2 specification More...
class | A2LVIRTUAL_CHARACTERISTIC
see ASAP2 specification More...
class | AdditiveDescriptionEventArgs
Used to get an additive description for a A2LNode from user code. More...
class | DAQMeasurement
Structure to specify a DAQ configuration for a single measurement. More...
interface | IA2LDescription
Interface for nodes containing a description property. More...
interface | IA2LMemory
Interface to access both types of memory. More...
interface | ICharValue
Interface for accessing a characteristic value representation. More...
interface | IDataFile
Interface for reading and writing data files (S19 and HEX) files. More...
class | MemorySegment
Implements the representation of a memory segment of a data file. More...
class | MemorySegmentList
Memory segment list type. More...
class | ModelChangedEventArgs
Changed model event arguments. More...
class | NonCompliantException
Exception class for non ASAP2 compliant files. More...
class | WriterException
Exception class representing an ASAP2 Writer exception. More...

Enumerations

enum | A2LChangedType { None , Added , Changed , Removed }
Possible types of changed model event.
enum A2LType {
UNSUPPORTED , PROJECT , HEADER , MODULE ,
A2ML , MOD_PAR , MEMORY_LAYOUT , IF_DATA ,
MOD_COMMON , AXIS_PTS , CHARACTERISTIC , AXIS_DESCR ,
MEASUREMENT , FUNCTION , GROUP , DEF_CHARACTERISTIC ,
REF_CHARACTERISTIC , REF_MEASUREMENT , REF_GROUP , IN_MEASUREMENT ,
OUT_MEASUREMENT , LOC_MEASUREMENT , SUB_FUNCTION , FUNCTION_LIST ,
SUB_GROUP , COMPU_METHOD , COMPU_VTAB_RANGE , COMPU_VTAB ,
RECORD_LAYOUT , CALIBRATION_METHOD , CALIBRATION_HANDLE , MEMORY_SEGMENT ,
ANNOTATION , ANNOTATION_TEXT , COMPU_TAB , FORMULA ,
FIX_AXIS_PAR_LIST , FRAME , DEPENDENT_CHARACTERISTIC , VIRTUAL_CHARACTERISTIC ,
UNIT , USER_RIGHTS , VIRTUAL , VAR_CRITERION ,
VAR_CHARACTERISTIC , VAR_ADDRESS , VAR_FORBIDDEN_COMB , BIT_OPERATION ,
VARIANT_CODING , BLOB , INSTANCE , TYPEDEF_STRUCTURE ,
TYPEDEF_BLOB , TYPEDEF_MEASUREMENT , TYPEDEF_AXIS , TYPEDEF_CHARACTERISTIC ,
STRUCTURE_COMPONENT , OVERWRITE , TRANSFORMER , TRANSFORMER_IN_OBJECTS ,
TRANSFORMER_OUT_OBJECTS , AR_COMPONENT , DAQ_LIST_CAN_ID , DEFINED_PAGES ,
CAN_PARAM , CHECKSUM_PARAM , TP_BLOB , SEED_KEY ,
SOURCE , RASTER , EVENT_GROUP , QP_BLOB ,
DP_BLOB , KP_BLOB , K_LINE , CAN ,
ADDRESS , NETWORK_LIMITS , TIME_DEF , COPY ,
FLASH_COPY , FLASH , DIAG_BAUD , PAGE_SWITCH ,
ROUTINE_PARA , DATA_ADDRESS , EVENT_CAN_ID_LIST , CAN_FD ,
PROTOCOL_LAYER , SEGMENT , CHECKSUM , PAGE ,
ADDRESS_MAPPING , DAQ , STIM , DAQ_LIST ,
EVENT , DAQ_EVENT , AVAILABLE_EVENT_LIST , DEFAULT_EVENT_LIST ,
CONSISTENCY_EVENT_LIST , TIMESTAMP_SUPPORTED , PAG , PGM ,
SECTOR , XCP_ON_UDP_IP , XCP_ON_TCP_IP , XCP_ON_CAN ,
TIME_CORRELATION , CLOCK , TIMESTAMP_CHARACTERIZATION , PREDEFINED ,
ODT , ECU_STATES , STATE , MEMORY_ACCESS ,
DAQ_MEMORY_CONSUMPTION , MIN_CYCLE_TIME , BUFFER_RESERVE , BUFFER_RESERVE_EVENT ,
DAQ_PACKED_MODE , CPU_LOAD_CONSUMPTION_DAQ , CPU_LOAD_CONSUMPTION_STIM , CPU_LOAD_CONSUMPTION_QUEUE ,
CPU_LOAD_CONSUMPTION_QUEUE_STIM , ODT_ENTRY_SIZE_FACTOR_TABLE , CORE_LOAD_MAX , CORE_LOAD_EP ,
XCP_ON_USB , DAQ_LIST_USB_ENDPOINT , OUT_EP_CMD_STIM , OUT_EP_ONLY_STIM ,
IN_EP_ONLY_DAQ , IN_EP_ONLY_EVSERV , IN_EP_RESERR_DAQ_EVSERV , XCP_ON_SxI ,
FRAMING , CANAPE_EXT , CANAPE_ADDRESS_UPDATE , MAP_SYMBOL
}
Supported types of the ASAP2 standard. More...
enum ADDR_TYPE {
DIRECT , PBYTE , PWORD , PLONG ,
PLONGLONG
}
Enumeration for description of the addressing of table values or axis point values. More...
enum AXIS_TYPE {
STD_AXIS , FIX_AXIS , COM_AXIS , RES_AXIS ,
CURVE_AXIS
}
Description of the axis points More...
enum AxisValueType {
XAxis , YAxis , ZAxis , _4Axis ,
_5Axis
}
Possible values for axis values increment/decremnt methods.
enum | BITOPERATION_TYPE { NotSet , RIGHT_SHIFT , LEFT_SHIFT }
The BIT_OPERATION keyword can be used to perform operation on the masked out value. More...
enum CALIBRATION_ACCESS {
NotSet , CALIBRATION , NO_CALIBRATION , NOT_IN_MCD_SYSTEM ,
OFFLINE_CALIBRATION
}
This keyword specifies the access of a CHARACTERISTIC or AXIS_PTS for calibration. More...
enum CHAR_TYPE {
NotSet , VALUE , ASCII = VALUE << 1 , VAL_BLK = VALUE << 2 ,
CURVE = VALUE << 3 , MAP = VALUE << 4 , CUBOID = VALUE << 5 , CUBE_4 = VALUE << 6 ,
CUBE_5 = VALUE << 7
}
Possible characteristic types More...
enum ChecksumType : byte {
NotSet , ADD_11 , ADD_12 , ADD_14 ,
CRC_8 , CRC_16 , CRC_32 , CRC_2_16 ,
ADD_22 , ADD_24 , ADD_44 , USER_DEFINED ,
CRC_16_CITT
}
Defined checksum types More...
enum CONVERSION_TYPE {
IDENTICAL , FORM , LINEAR , RAT_FUNC ,
TAB_INTP , TAB_NOINTP , TAB_VERB
}
see ASAP2 specification More...
enum | DAQEventType { None , XCP , CCP }
Possible event/raster types. More...
enum | DATA_SIZE { BYTE , WORD , LONG }
Enumeration for description of the word lengths in the ECU program More...
enum | DEPOSIT_TYPE { NotSet , ABSOLUTE , DIFFERENCE }
The axis points of a characteristic can be deposited in two different ways in the memory More...
enum | ECUPage : byte { Flash , RAM , NotSet = byte.MaxValue }
Possible active ECU pages (generic for XCP and CCP). More...
enum | EncodingType { ASCII , UTF8 , UTF16 , UTF32 }
Defines the encoding for characteristics of type CHAR_TYPE.ASCII. More...
enum INDEX_MODE {
NotSet , ROW_DIR , COLUMN_DIR , ALTERNATE_WITH_X ,
ALTERNATE_WITH_Y , ALTERNATE_CURVES
}
see ASAP2 specification More...
enum | INDEX_ORDER { INDEX_INCR , INDEX_DECR }
Enumeration for description of the axis point sequence in the memory. More...
enum | MEMORY_ATTRIBUTE { INTERN , EXTERN }
Memory attributes More...
enum MEMORY_TYPE {
RAM , EEPROM , EPROM , ROM ,
REGISTER , FLASH , NOT_IN_ECU
}
Description of the type of memory used More...
enum MEMORYPRG_TYPE {
UNKNOWN , CODE , DATA , OFFLINE_DATA ,
VARIABLES , SERAM , RESERVED , CALIBRATION_VARIABLES ,
EXCLUDE_FROM_FLASH
}
see ASAP2 specification More...
enum MONOTONY_TYPE {
NotSet , NOT_MON , MON_DECREASE , MON_INCREASE ,
STRICT_DECREASE , STRICT_INCREASE , MONOTONOUS , STRICT_MON
}
Description of the monotony. More...
enum | PRG_TYPE { PRG_CODE , PRG_DATA , PRG_RESERVED }
Description of the program segments More...
enum ScalingUnits {
Time_1uSec , Time_10uSec , Time_100uSec , Time_1mSec ,
Time_10mSec , Time_100mSec , Time_1Sec , Time_10Sec ,
Time_1Min , Time_1Hour , Time_1Day , AngularDegrees = 100 ,
Revolutions , Cycle , CylinderSegmentCombustion , FrameAvailableEvent = 998 ,
AlwaysOnNewValue , NonDeternministic , NotSet = int.MaxValue
}
Codes for scaling units (CSE). More...
enum | TriggerType { ON_CHANGE , ON_USER_REQUEST }
Defines values for the A2ÖTRANSFORMER Trigger. More...
enum | UNIT_TYPE { DERIVED , EXTENDED_SI }
see ASAP2 specification More...
enum | VarNamingType { NotSet , NUMERIC }
Format of variant extension (index) More...
enum | WriterIndent { Space , Tab }
Defines if the ASAP2 writer should use tabs or spaces as indentation. More...

Functions

delegate double | ModifyFunc (double originalValue, A2LRECORD_LAYOUT_REF layoutRef)
Function delegate for value modifying functions. More...
delegate double | ModifyFuncByValue (double originalValue, double value, bool treatValueAsPercent)
Function delegate for value modifying functions. More...

Detailed Description

Contains the ASAP2 parser base and the ASAP2 object model implementation...

Defines and implements stuff for managing data from data files (s19/Hex) files.

Currently the parser implements the following:

  • All entities defined in the ASAM_MCD-2MC Specifcation V1.7.0 except the IF_DATA sections.
  • Creating a fully-navigatable object model.
  • Parser performance is about 4 MBit/s.
  • The parser is able to rewrite the object model to an A2L file.
  • The parser ist able to export the object model to a XML file.

Integration of ASAP2 V1.7.A2LINSTANCEs into the object model:

  • To keep the writer functionality, any A2L object must be reproduced into the A2L object model. This also applies to A2LINSTANCEs and A2LTYPEDEFs, too
  • An A2LINSTANCE and its corresponding A2LTYPEDEF represents an already known type of [A2LBLOB,A2LMEASUREMENT,A2LCHARACTERISTIC,A2LAXIS_PTS].
    The parser creates dynamically instances of this types from A2LINSTANCEs into the object model.
    The dynamically created instances could be indicated with the introduced property A2LNODE.IsInstanced.

TODOs:

  • Currently the IF_DATA sections are not supported because these are vendor specific. Parse the AML language for integrating vendor independent IF_DATA sections.

To get started with parsing see A2LParser

Enumeration Type Documentation

◆ A2LType

enum A2LType

Supported types of the ASAP2 standard.

  • Specified for ASAP2 specification version 1.7.0
  • Some of the types are required (at least the A2LPROJECT), some are not. Refer to the ASAP2 specification which types you can rely on.
Enumerator
UNSUPPORTED | This type is used for A2L nodes currently not implemented
PROJECT | see ASAP2 specification
HEADER | see ASAP2 specification
MODULE | see ASAP2 specification
A2ML | see ASAP2 specification
MOD_PAR | see ASAP2 specification
MEMORY_LAYOUT | see ASAP2 specification
IF_DATA | see ASAP2 specification
MOD_COMMON | see ASAP2 specification
AXIS_PTS | see ASAP2 specification
CHARACTERISTIC | see ASAP2 specification
AXIS_DESCR | see ASAP2 specification
MEASUREMENT | see ASAP2 specification
FUNCTION | see ASAP2 specification
GROUP | see ASAP2 specification
DEF_CHARACTERISTIC | see ASAP2 specification
REF_CHARACTERISTIC | see ASAP2 specification
REF_MEASUREMENT | see ASAP2 specification
REF_GROUP | see ASAP2 specification
IN_MEASUREMENT | see ASAP2 specification
OUT_MEASUREMENT | see ASAP2 specification
LOC_MEASUREMENT | see ASAP2 specification
SUB_FUNCTION | see ASAP2 specification
FUNCTION_LIST | see ASAP2 specification
SUB_GROUP | see ASAP2 specification
COMPU_METHOD | see ASAP2 specification
COMPU_VTAB_RANGE | see ASAP2 specification
COMPU_VTAB | see ASAP2 specification
RECORD_LAYOUT | see ASAP2 specification
CALIBRATION_METHOD | see ASAP2 specification
CALIBRATION_HANDLE | see ASAP2 specification
MEMORY_SEGMENT | see ASAP2 specification
ANNOTATION | see ASAP2 specification
ANNOTATION_TEXT | see ASAP2 specification
COMPU_TAB | see ASAP2 specification
FORMULA | see ASAP2 specification
FIX_AXIS_PAR_LIST | see ASAP2 specification
FRAME | see ASAP2 specification
DEPENDENT_CHARACTERISTIC | see ASAP2 specification
VIRTUAL_CHARACTERISTIC | see ASAP2 specification
UNIT | see ASAP2 specification
USER_RIGHTS | see ASAP2 specification
VIRTUAL | see ASAP2 specification
VAR_CRITERION | see ASAP2 specification
VAR_CHARACTERISTIC | see ASAP2 specification
VAR_ADDRESS | see ASAP2 specification
VAR_FORBIDDEN_COMB | see ASAP2 specification
BIT_OPERATION | see ASAP2 specification
VARIANT_CODING | see ASAP2 specification
BLOB | see ASAP2 specification >= 1.7.0
INSTANCE | see ASAP2 specification >= 1.7.0
TYPEDEF_STRUCTURE | see ASAP2 specification >= 1.7.0
TYPEDEF_BLOB | see ASAP2 specification >= 1.7.0
TYPEDEF_MEASUREMENT | see ASAP2 specification >= 1.7.0
TYPEDEF_AXIS | see ASAP2 specification >= 1.7.0
TYPEDEF_CHARACTERISTIC | see ASAP2 specification >= 1.7.0
STRUCTURE_COMPONENT | see ASAP2 specification >= 1.7.0
OVERWRITE | see ASAP2 specification >= 1.7.0
TRANSFORMER | see ASAP2 specification >= 1.7.0
TRANSFORMER_IN_OBJECTS | see ASAP2 specification >= 1.7.0
TRANSFORMER_OUT_OBJECTS | see ASAP2 specification >= 1.7.0
AR_COMPONENT | see ASAP2 specification >= 1.7.0
DAQ_LIST_CAN_ID | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
DEFINED_PAGES | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
CAN_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
CHECKSUM_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
TP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
SEED_KEY | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
SOURCE | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
RASTER | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
EVENT_GROUP | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
QP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
DP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
KP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
K_LINE | See ASAP1B_KWP (COMMON_PARAMETERS)
CAN | See ASAP1B_KWP (COMMON_PARAMETERS)
ADDRESS | See ASAP1B_KWP (COMMON_PARAMETERS)
NETWORK_LIMITS | See ASAP1B_KWP (COMMON_PARAMETERS)
TIME_DEF | See ASAP1B_KWP (COMMON_PARAMETERS)
COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
FLASH_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
FLASH | See ASAP1B_KWP (COMMON_PARAMETERS)
DIAG_BAUD | See ASAP1B_KWP (COMMON_PARAMETERS)
PAGE_SWITCH | See ASAP1B_KWP (COMMON_PARAMETERS)
ROUTINE_PARA | See ASAP1B_KWP (COMMON_PARAMETERS)
DATA_ADDRESS | See ASAP1B_KWP (COMMON_PARAMETERS)
EVENT_CAN_ID_LIST | see ASAP2 specification > 1.6.0
CAN_FD | see ASAP2 specification > 1.6.0
PROTOCOL_LAYER | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
SEGMENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
CHECKSUM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
PAGE | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
ADDRESS_MAPPING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
DAQ_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
DAQ_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
AVAILABLE_EVENT_LIST | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
DEFAULT_EVENT_LIST | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
CONSISTENCY_EVENT_LIST | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
TIMESTAMP_SUPPORTED | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
PAG | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
PGM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
SECTOR | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
XCP_ON_UDP_IP | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
XCP_ON_TCP_IP | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
XCP_ON_CAN | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
TIME_CORRELATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
CLOCK | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation)
TIMESTAMP_CHARACTERIZATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock)
PREDEFINED | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (DAQ_LIST)
ODT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED)
ECU_STATES | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer)
STATE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States)
MEMORY_ACCESS | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State)
DAQ_MEMORY_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
MIN_CYCLE_TIME | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels)
BUFFER_RESERVE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT)
BUFFER_RESERVE_EVENT | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT)
DAQ_PACKED_MODE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists)
CPU_LOAD_CONSUMPTION_DAQ | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption for DAQ)
CPU_LOAD_CONSUMPTION_STIM | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption for STIM)
CPU_LOAD_CONSUMPTION_QUEUE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption for QUEUE)
CPU_LOAD_CONSUMPTION_QUEUE_STIM | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption for QUEUE_STIM)
ODT_ENTRY_SIZE_FACTOR_TABLE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table)
CORE_LOAD_MAX | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load maximum, max load on single core)
CORE_LOAD_EP | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption, max load on single core)
XCP_ON_USB | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
DAQ_LIST_USB_ENDPOINT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
OUT_EP_CMD_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
OUT_EP_ONLY_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
IN_EP_ONLY_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
IN_EP_ONLY_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
IN_EP_RESERR_DAQ_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
XCP_ON_SxI | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI
FRAMING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI

◆ ADDR_TYPE

enum ADDR_TYPE

Enumeration for description of the addressing of table values or axis point values.

See ASAP2 specification.

Enumerator
DIRECT | The relevant memory location has the first table value or axis point value, all others follow with incrementing address.
PBYTE | The relevant memory location has a 1 byte pointer to this table value or axis point value.
PWORD | The relevant memory location has a 2 byte pointer to this table value or axis point value.
PLONG | The relevant memory location has a 4 byte pointer to this table value or axis point value.
PLONGLONG | The relevant memory location has a 8 byte pointer to this table value or axis point value.

◆ AXIS_TYPE

enum AXIS_TYPE

Description of the axis points

Enumerator
STD_AXIS | Standard axis.
FIX_AXIS | This is a curve or a map with virtual axis points that are not deposited at EPROM. The axis points can be calculated from parameters defined with keywords FIX_AXIS_PAR, FIX_AXIS_PAR_DIST and FIX_AXIS_PAR_LIST. The axis points can‘t be modified.
COM_AXIS | Group axis points or description of the axis points for SIEMENS deposit. For this variant of the axis points the axis point values are separated from the table values of the curve or map in the emulation memory and must be described by a special AXIS_PTS data record. The reference to this record occurs with the keyword 'AXIS_PTS_REF'.
RES_AXIS | Rescale axis. For this variant of the axis points the axis point values are separated from the table values of the curve or map in the emulation memory and must be described by a special AXIS_PTS data record. The reference to this record occurs with the keyword 'AXIS_PTS_REF'.
CURVE_AXIS | Curve axis. This axis type uses a separate CURVE CHARACTERISTIC to rescale the ASAM MCD 2MC / ASAP2 Interface Specification 2002-02-05 Version 1.51 Release Page 47 of 277 axis. The referenced CURVE is used to lookup an axis index, and the index value is used by the controller to determine the operating point in the CURVE or MAP. See Appendix C for more details.

◆ BITOPERATION_TYPE

enum BITOPERATION_TYPE

The BIT_OPERATION keyword can be used to perform operation on the masked out value.

First BIT_MASK will be applied on measurement data, then LEFT_SHIFT / RIGHT_SHIFT is performed and last the SIGN_EXTEND is carried out. SIGN_EXTEND means that the sign bit (masked data’s leftmost bit) will be copied to all bit positions to the left of the sign bit. This results in a new datatype with the same signed value as the masked data.

Enumerator
NotSet | not set
RIGHT_SHIFT | Number of positions to left shift data, zeros will be shifted in from the right.
LEFT_SHIFT | Number of positions to right shift data, zeros will be shifted in from the left.

◆ CALIBRATION_ACCESS

enum CALIBRATION_ACCESS

This keyword specifies the access of a CHARACTERISTIC or AXIS_PTS for calibration.

It substitutes the READ_ONLY attribute since ASAM-MCD-2MC V1.4

Enumerator
NotSet | not set
CALIBRATION | Characteristic or axis points with calibration allowed.
NO_CALIBRATION | This keyword can be used to indicate that the axis points cannot be changed (but can be read only). Note: This optional keyword used at CHARACTERISTIC record indicates the adjustable object to be read only at all (table values and axis pts).
NOT_IN_MCD_SYSTEM | Internal characteristic or axis points which are not readable or writeable by the MCD-System. If there are references between AXIS_PTS and CHARACTERISTICS with one of them gets this value of CALIBRATION_ACCESS, the other one must get this value too.
OFFLINE_CALIBRATION | Variables which can be flashed but not emulated ore calibrated, e.g. values representing safety relevant property while driving.

◆ CHAR_TYPE

enum CHAR_TYPE

Possible characteristic types

Enumerator
NotSet | Unknown or not defined.
VALUE | scalar
ASCII | string
VAL_BLK | array without axes
CURVE | 1-dimensional array with axes
MAP | 2-dimensional array with axes
CUBOID | 3-dimensional array with axes
CUBE_4 | 4-dimensional array with axes
CUBE_5 | 5-dimensional array with axes

◆ ChecksumType

enum ChecksumType : byte

Defined checksum types

All checksum algorithms required by ASAP2 and XCP are supported.

Enumerator
NotSet | not set
ADD_11 | Add BYTE into a BYTE checksum, ignore overflows
ADD_12 | Add BYTE into a WORD checksum, ignore overflows
ADD_14 | Add BYTE into a DWORD checksum, ignore overflows
CRC_8 | See CRC error detection algorithms Only defined by CCP.
CRC_16 | See CRC error detection algorithms
CRC_32 | See CRC error detection algorithms
CRC_2_16 | See CRC error detection algorithms Only defined by CCP.
ADD_22 | Add WORD into a WORD checksum, ignore overflows, blocksize must be modulo 2
ADD_24 | Add WORD into DWORD, ignore overflows, blocksize must be modulo 2
ADD_44 | Add DWORD into DWORD, ignore overflows, blocksize must be modulo 4
USER_DEFINED | User defined algorithm, in externally calculated function
CRC_16_CITT | See CRC error detection algorithms

◆ CONVERSION_TYPE

enum CONVERSION_TYPE

see ASAP2 specification

Enumerator
IDENTICAL | no conversion of the internal source value. The following equation is applied: PHYS = INT
FORM | conversion based on the formula specified by the FORMULA keyword.
LINEAR | linear function of the following type: f(x)=ax + b for which: PHYS=f(INT) The coefficients a and b have to be specified by the COEFFS_LINEAR keyword.
RAT_FUNC | fractional rational function of the following type f(x)=(axx + bx + c)/(dxx + ex + f) for which: INT = f(PHYS)
TAB_INTP | table with interpolation
TAB_NOINTP | table without interpolation
TAB_VERB | verbal conversion table

◆ DAQEventType

enum DAQEventType

Possible event/raster types.

Not ASAP2 defined, but used for

  • A2LMEASUREMENT.addPresetDAQEvent
  • A2LMEASUREMENT.getPresetDAQEvent
  • A2LMEASUREMENT.getPresetDAQEvents

◆ DATA_SIZE

enum DATA_SIZE

Enumeration for description of the word lengths in the ECU program

Enumerator
BYTE | 8 Bit size
WORD | 16 Bit size
LONG | 32 Bit size

◆ DEPOSIT_TYPE

enum DEPOSIT_TYPE

The axis points of a characteristic can be deposited in two different ways in the memory

Enumerator
NotSet

Used when deposit type is 'not set'.

ABSOLUTE

absolute axis points

The individual axis point values are deposited as absolute values.

DIFFERENCE

difference axis points

The individual axis points are deposited as differences. Each axis point value is determined on the basis of the adjacent axis point (predecessor) and the corresponding difference. As reference point for the first axis point maxvalue is used:

  • 1-byte-size: maxvalue = 2^8 (256)
  • 2-byte-size: maxvalue = 2^16 (65536)
  • 4-byte-size: maxvalue = 2^32

◆ ECUPage

enum ECUPage : byte

Possible active ECU pages (generic for XCP and CCP).

Enumerator
Flash | The flash (persistent) page
RAM | The RAM (writeable) page
NotSet | Page is not known.

◆ EncodingType

enum EncodingType

Defines the encoding for characteristics of type CHAR_TYPE.ASCII.

If no ENCODING is specified, the content of the CHARACTERISTIC is interpreted as array of 8 Bit characters.

◆ INDEX_MODE

enum INDEX_MODE

see ASAP2 specification

Enumerator
NotSet

Index mode is not set.

This usually may never occur, but in some cases the value is optinal.

ROW_DIR

deposited in rows

COLUMN_DIR

deposited in columns

ALTERNATE_WITH_X

maps: deposited in columns, the columns of table values alternate with the respective X-coordinates. curves: table values and X-coordinate values are deposited alternating.

ALTERNATE_WITH_Y

maps: deposited in rows, the rows of table values alternate with the respective Y-coordinates (maps only).

ALTERNATE_CURVES

curves: curves which share a common axis are deposited in columns; each row of memory contains values for all the shared axis curves at a given axis breakpoint. Required in order to represent characteristics which correspond to arrays of structures in ECU program code. In the example code below, DT10, DT20, etcare treated as separate curves which may have different conversions or limits:

typedef struct { int DT10; int DT20; int DT30; int DT40; } VXP_TYPE; const VXP_TYPE VX_PLUS_DELAY_TIMES[5] = { { 10, 3, 4, 8 }, { 12, 2, 4, 6 }, { 17, 9, 5, 8 }, { 10, 1, 4, 8 }, { 18, 3, 8, 8 }, };

◆ INDEX_ORDER

enum INDEX_ORDER

Enumeration for description of the axis point sequence in the memory.

Enumerator
INDEX_INCR | Increasing index with increasing address.
INDEX_DECR | decreasing index with increasing address.

◆ MEMORY_ATTRIBUTE

enum MEMORY_ATTRIBUTE

Memory attributes

Enumerator
INTERN | internal segment
EXTERN | external segment

◆ MEMORY_TYPE

enum MEMORY_TYPE

Description of the type of memory used

Enumerator
RAM | segment of RAM
EEPROM | segment of EEPROM
EPROM | segment of EPROM
ROM | segment of ROM
REGISTER | segment of CPU registers
FLASH | segment of FLASH
NOT_IN_ECU | Not available segemnt in ECU memory (no download/upload to ECU)

◆ MEMORYPRG_TYPE

enum MEMORYPRG_TYPE

see ASAP2 specification

Enumerator
UNKNOWN

The kind of data is not known.

CODE

program code

DATA

program data allowed for online calibration

OFFLINE_DATA

program data allowed only for offline calibration

VARIABLES

program variables

SERAM

program data for serial emulation

RESERVED

reserved segments

CALIBRATION_VARIABLES

Values which are available in the ECU but do not exist in the Hex-file.

There is no upload required to get access to the ECU data. The ECU will never be touched by the instrumentation tool except by upload.

EXCLUDE_FROM_FLASH

Values existing in the ECU but not dropped down in the binary file.

There should no upload be needed to get access to the ECU data. The ECU will
never be touched by the instrumentation tool except by upload.
</summary>

◆ MONOTONY_TYPE

enum MONOTONY_TYPE

Description of the monotony.

This keyword can be used to specify the monotony of an adjustment object. The monotony is always related to an axis (see keyword "AXIS_DESCR"). With each adjustment operation the measurement and calibration system (user interface) verifies whether the monotony is guaranteed. Changes that do not correspond to the monotony are not allowed.

Enumerator
NotSet | not set
NOT_MON | no monotony required
MON_DECREASE | monotonously decreasing
MON_INCREASE | monotonously increasing
STRICT_DECREASE | strict monotonously decreasing
STRICT_INCREASE | strict monotonously increasing
MONOTONOUS | monotonously in- or decreasing
STRICT_MON | strict monotonously in- or decreasing

◆ PRG_TYPE

enum PRG_TYPE

Description of the program segments

Enumerator
PRG_CODE | program code
PRG_DATA | program data
PRG_RESERVED | other

◆ ScalingUnits

enum ScalingUnits

Codes for scaling units (CSE).

Enumerator
Time_1uSec | 1 µsec
Time_10uSec | 10 µsec
Time_100uSec | 100 µsec
Time_1mSec | 1 msec
Time_10mSec | 10 msec
Time_100mSec | 100 msec
Time_1Sec | 1 sec
Time_10Sec | 10 sec
Time_1Min | 1 Minute
Time_1Hour | 1 Hour
Time_1Day | 1 day
AngularDegrees | Angular degrees
Revolutions | Revolutions 360 degrees
Cycle | Cycle 720 degrees angle, e.g. in case of IC engines
CylinderSegmentCombustion | Cylinder segment Combustion, e.g. in case of IC engines
FrameAvailableEvent | When frame available Event Source defined in keyword Frame
AlwaysOnNewValue | Calculation of a new upper range limit after receiving a new partial value, e.g. when calculating a complex trigger condition
NonDeternministic | Without fixed scaling
NotSet | Refresh rate unit is not defined

◆ TriggerType

enum TriggerType

Defines values for the A2ÖTRANSFORMER Trigger.

Enumerator
ON_CHANGE | Triggers the TRANSFORMER whenever a referenced input object in IN_OBJECTS is changed.
ON_USER_REQUEST | Triggers the TRANSFORMER whenever the user issues the trigger request in the MC tool.

◆ UNIT_TYPE

enum UNIT_TYPE

see ASAP2 specification

Enumerator
DERIVED | Measurement unit derived from another one referenced by the optional parameter REF_UNIT.
EXTENDED_SI | Extended SI unit. Recommendation: The principle of describing "real" measurement units is to refer to SI units. Therefore, this relationship should be given by using the optional parameter SI_EXPONENTS.

◆ VarNamingType

enum VarNamingType

Format of variant extension (index)

Enumerator
NotSet | Not defined value.
NUMERIC | variant extension is a number (integer: 0,1,2,3...).

◆ WriterIndent

enum WriterIndent

Defines if the ASAP2 writer should use tabs or spaces as indentation.

Enumerator
Space | Using the blank character to indent.
Tab | Using the tabulator character to indent.

Function Documentation

◆ ModifyFunc()

delegate double jnsoft.ASAP2.ModifyFunc | ( | double | originalValue,
 |  | A2LRECORD_LAYOUT_REF | layoutRef
 | ) |  |

Function delegate for value modifying functions.

Parameters
originalValue | The original value
layoutRef | The corresponding characteristic
Returns
The resulting value

◆ ModifyFuncByValue()

delegate double jnsoft.ASAP2.ModifyFuncByValue | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |

Function delegate for value modifying functions.

Parameters
originalValue | The original value
value | The new value to to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value


ASAP2Library interface: jnsoft.ASAP2.CCP Namespace Reference

  • ASAP2
  • CCP
Classes | Enumerations
jnsoft.ASAP2.CCP Namespace Reference

Implements the ASAP2 CCP (IF_DATA) Interface stuff. More...

Classes

class | A2LCCP_ADDRESS_MAPPING
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_CAN_PARAM
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_CHECKSUM
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_CHECKSUM_PARAM
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_DEFINED_PAGES
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_DP_BLOB
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_EVENT_GROUP
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_KP_BLOB
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_NAMEDNODE
Base class for all A2LCCP entities with specific names. More...
class | A2LCCP_NODE
Base class for all A2L node definitions concerning CCP. More...
class | A2LCCP_QP_BLOB
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_RASTER
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_SEED_KEY
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_SOURCE
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LCCP_TP_BLOB
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
struct | SourceAndRaster
Hold a CCP Source with it's attached CCP Raster. More...

Enumerations

enum | CCP_ADDRESS_MODE { NotSet , DAQ , ODT }
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
enum | CCP_CHECKSUM_CALC_TYPE { NotSet , ACTIVE_PAGE , BIT_OR_WITH_OPT_PAGE }
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
enum | CCP_DAQ_MODE { NotSet , ALTERNATING , BURST }
Modes of cyclic data acquisition. More...
enum CCP_MEMORY_PAGE_TYPE {
NotSet , RAM = 1 , ROM = RAM << 1 , FLASH = RAM << 2 ,
EEPROM = RAM << 3 , RAM_INIT_BY_ECU = RAM << 4 , RAM_INIT_BY_TOOL = RAM << 5 , AUTO_FLASH_BACK = RAM << 6 ,
FLASH_BACK = RAM << 7 , DEFAULT = RAM << 8
}
Page types. More...
enum CCP_SCALING_UNIT : ushort {
_1US , _10US , _100US , _1MS ,
_10MS , _100MS , _1S , _10S ,
_1MIN , _1HOUR , _1DAY , AngularDegrees = 100 ,
Revolutions360Degrees = 101 , Cycle720Degrees = 102 , CylinderSegment = 103 , Event = 998 ,
OnValueChanged = 999 , NonDeterministic = 1000
}
Codes for scaling units (CSE). More...

Detailed Description

Implements the ASAP2 CCP (IF_DATA) Interface stuff.

Enumeration Type Documentation

◆ CCP_ADDRESS_MODE

enum CCP_ADDRESS_MODE

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)

Enumerator
NotSet

not set

◆ CCP_CHECKSUM_CALC_TYPE

enum CCP_CHECKSUM_CALC_TYPE

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)

Enumerator
NotSet

not set

◆ CCP_DAQ_MODE

enum CCP_DAQ_MODE

Modes of cyclic data acquisition.

Enumerator
NotSet | not set
ALTERNATING | ECU is sending one ODT per cycle
BURST | ECU is sending a complete DAQ

◆ CCP_MEMORY_PAGE_TYPE

enum CCP_MEMORY_PAGE_TYPE

Page types.

Enumerator
NotSet | not set
RAM | memory page in RAM
ROM | memory page in ROM
FLASH | memory page in FLASH
EEPROM | memory page in EEPROM
RAM_INIT_BY_ECU | memory page is initialised by ECU start-up
RAM_INIT_BY_TOOL | RAM- memory page is initialised by the MCS
AUTO_FLASH_BACK | RAM memory page is automatically flashed back
FLASH_BACK | feature available to flash back the RAM memory page
DEFAULT | memory page is standard (fallback mode)

◆ CCP_SCALING_UNIT

enum CCP_SCALING_UNIT : ushort

Codes for scaling units (CSE).

Enumerator
_1US | 1 US = 1 microsecond = 10E-6 second = 1MHz.
_10US | 10 US = 10 microseconds = 10E-5 seconds = 100KHz.
_100US | 100 US = 100 microseconds = 10E-4 seconds = 10KHz.
_1MS | 1 MS = 1 millisecond = 10E-3 second = 1KHz.
_10MS | 10 MS = 10 milliseconds = 10E-2 seconds = 100Hz.
_100MS | 100 MS = 100 milliseconds = 10E-1 seconds = 10Hz.
_1S | 1 S = 1 second = 1Hz.
_10S | 10 S = 10 second = 0.11Hz.
_1MIN | 1 M = 1 minute.
_1HOUR | 1 H = 1 hour.
_1DAY | 1 D = 1 day.
AngularDegrees | Referred to angle.
Revolutions360Degrees | Referred to angle.
Cycle720Degrees | Referred to angle (e.g. in case of IC engines).
CylinderSegment | Referred to combustion (e.g. in case of IC engines).
Event | Referred to Event (Source defined in keyword Frame).
OnValueChanged | Always if there is new value.
NonDeterministic | Non deterministic (without fixed scaling).


ASAP2Library interface: A2LCCP_ADDRESS_MAPPING Class Reference

  • ASAP2
  • CCP
  • A2LCCP_ADDRESS_MAPPING
Properties | List of all members
A2LCCP_ADDRESS_MAPPING Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

uint | BaseAddress [getset]
Base address of the memory segment to be mapped
uint | Length [getset]
Length of the segment to be mapped
uint | MapAddress [getset]
Address to which the base address is to be mapped
- Properties inherited from A2LCCP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.DP_BLOB
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCCP_NAMEDNODE
A2LCCP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LCCP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_ADDRESS_MAPPING
A2LCCP_ADDRESS_MAPPING Member List

This is the complete list of members for A2LCCP_ADDRESS_MAPPING, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LCCP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BaseAddress | A2LCCP_ADDRESS_MAPPING |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length | A2LCCP_ADDRESS_MAPPING |
MapAddress | A2LCCP_ADDRESS_MAPPING |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LCCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LCCP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_CAN_PARAM Class Reference

  • ASAP2
  • CCP
  • A2LCCP_CAN_PARAM
Properties | List of all members
A2LCCP_CAN_PARAM Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

byte | BTR0 [getset]
byte | BTR1 [getset]
ushort | Frequency [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_CAN_PARAM
A2LCCP_CAN_PARAM Member List

This is the complete list of members for A2LCCP_CAN_PARAM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BTR0 (defined in A2LCCP_CAN_PARAM) | A2LCCP_CAN_PARAM |
BTR1 (defined in A2LCCP_CAN_PARAM) | A2LCCP_CAN_PARAM |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Frequency (defined in A2LCCP_CAN_PARAM) | A2LCCP_CAN_PARAM |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_CHECKSUM Class Reference

  • ASAP2
  • CCP
  • A2LCCP_CHECKSUM
Properties | List of all members
A2LCCP_CHECKSUM Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

string | Dll [getset]
A reference to an external DLL
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_CHECKSUM
A2LCCP_CHECKSUM Member List

This is the complete list of members for A2LCCP_CHECKSUM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Dll | A2LCCP_CHECKSUM |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_CHECKSUM_PARAM Class Reference

  • ASAP2
  • CCP
  • A2LCCP_CHECKSUM_PARAM
Properties | List of all members
A2LCCP_CHECKSUM_PARAM Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

CCP_CHECKSUM_CALC_TYPE | CalcType [getset]
ChecksumType | ChecksumType [get]
uint | Limit [getset]
Maximum block length used by an ASAP1a-CCP command, for checksum calculation procedure.
ushort | Procedure [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_CHECKSUM_PARAM
A2LCCP_CHECKSUM_PARAM Member List

This is the complete list of members for A2LCCP_CHECKSUM_PARAM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CalcType (defined in A2LCCP_CHECKSUM_PARAM) | A2LCCP_CHECKSUM_PARAM |
ChangedType | A2LNODE |
ChecksumType (defined in A2LCCP_CHECKSUM_PARAM) | A2LCCP_CHECKSUM_PARAM |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Limit | A2LCCP_CHECKSUM_PARAM |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Procedure (defined in A2LCCP_CHECKSUM_PARAM) | A2LCCP_CHECKSUM_PARAM |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_DEFINED_PAGES Class Reference

  • ASAP2
  • CCP
  • A2LCCP_DEFINED_PAGES
Public Member Functions | Properties | List of all members
A2LCCP_DEFINED_PAGES Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Public Member Functions

bool | contains (uint address)
Returns a value, if the specified address is contained in the defined page. More...
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

uint | Address [getset]
byte | AddressExt [getset]
uint | Length [getset]
ushort | No [getset]
string | PageName [getset]
CCP_MEMORY_PAGE_TYPE | PageType [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)

Member Function Documentation

◆ contains()

bool contains ( uint address )

Returns a value, if the specified address is contained in the defined page.

Parameters
address The address to test
Returns
true if the address is contained


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_DEFINED_PAGES
A2LCCP_DEFINED_PAGES Member List

This is the complete list of members for A2LCCP_DEFINED_PAGES, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
AddressExt (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
ChangedType | A2LNODE |
Childs | A2LNODE |
contains(uint address) | A2LCCP_DEFINED_PAGES |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
No (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
NoCompuMethod | A2LNODE | static
PageName (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
PageType (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LCCP_DEFINED_PAGES) | A2LCCP_DEFINED_PAGES |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_DP_BLOB Class Reference

  • ASAP2
  • CCP
  • A2LCCP_DP_BLOB
Properties | List of all members
A2LCCP_DP_BLOB Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

uint | Address [getset]
Base address of the calibration data
ushort | AddressExt [getset]
Address extension of the calibration data (only Low Byte significant)
uint | Size [getset]
Number of Bytes belonging to the calibration data end of DP_BLOB
- Properties inherited from A2LCCP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.DP_BLOB
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCCP_NAMEDNODE
A2LCCP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LCCP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_DP_BLOB
A2LCCP_DP_BLOB Member List

This is the complete list of members for A2LCCP_DP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LCCP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LCCP_DP_BLOB |
AddressExt | A2LCCP_DP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LCCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Size | A2LCCP_DP_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LCCP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_EVENT_GROUP Class Reference

  • ASAP2
  • CCP
  • A2LCCP_EVENT_GROUP
Properties | List of all members
A2LCCP_EVENT_GROUP Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

string | NameLong [getset]
string | NameShort [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_EVENT_GROUP
A2LCCP_EVENT_GROUP Member List

This is the complete list of members for A2LCCP_EVENT_GROUP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NameLong (defined in A2LCCP_EVENT_GROUP) | A2LCCP_EVENT_GROUP |
NameShort (defined in A2LCCP_EVENT_GROUP) | A2LCCP_EVENT_GROUP |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_KP_BLOB Class Reference

  • ASAP2
  • CCP
  • A2LCCP_KP_BLOB
Properties | List of all members
A2LCCP_KP_BLOB Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

ushort[] | Rasters [getset]
Array of event channel initialization values
- Properties inherited from A2LCCP_DP_BLOB
uint | Address [getset]
Base address of the calibration data
ushort | AddressExt [getset]
Address extension of the calibration data (only Low Byte significant)
uint | Size [getset]
Number of Bytes belonging to the calibration data end of DP_BLOB
- Properties inherited from A2LCCP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.DP_BLOB
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCCP_NAMEDNODE
A2LCCP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LCCP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_KP_BLOB
A2LCCP_KP_BLOB Member List

This is the complete list of members for A2LCCP_KP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LCCP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LCCP_DP_BLOB |
AddressExt | A2LCCP_DP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LCCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Rasters | A2LCCP_KP_BLOB |
Size | A2LCCP_DP_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LCCP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_NAMEDNODE Class Reference

  • ASAP2
  • CCP
  • A2LCCP_NAMEDNODE
Protected Member Functions | Properties | List of all members
A2LCCP_NAMEDNODE Class Reference

Base class for all A2LCCP entities with specific names. More...

Protected Member Functions

A2LCCP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LCCP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.DP_BLOB
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2LCCP entities with specific names.

Constructor & Destructor Documentation

◆ A2LCCP_NAMEDNODE()

A2LCCP_NAMEDNODE | ( | A2LNODE | parent,
 |  | int | startLine,
 |  | int | endLine,
 |  | A2LType | subType
 | ) |  |
protected

Initialises a new instance of A2LCCP_NAMEDNODE with the specified parameters.

Parameters
parent | The parent node
startLine | The starting line
endLine | The ending line
subType | The A2L type subtype

Property Documentation

◆ Name

sealed override string Name
get

Gets the name of the node.

Use the setter with care! Changing the name requires to adjust all references to this instance.


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_NAMEDNODE
A2LCCP_NAMEDNODE Member List

This is the complete list of members for A2LCCP_NAMEDNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LCCP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LCCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LCCP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_NODE Class Reference

  • ASAP2
  • CCP
  • A2LCCP_NODE
Static Public Member Functions | Properties | List of all members
A2LCCP_NODE Class Reference

Base class for all A2L node definitions concerning CCP. More...

Static Public Member Functions

static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Properties

override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L node definitions concerning CCP.

Member Function Documentation

◆ getCycleTime()

static string getCycleTime | ( | CCP_SCALING_UNIT | scalingUnits,
 |  | uint | rate
 | ) |  |
static

Gets the cycle time from scaling units and rate.

Parameters
scalingUnits scaling units
rate
Returns


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_NODE
A2LCCP_NODE Member List

This is the complete list of members for A2LCCP_NODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_QP_BLOB Class Reference

  • ASAP2
  • CCP
  • A2LCCP_QP_BLOB
Public Member Functions | Properties | List of all members
A2LCCP_QP_BLOB Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Public Member Functions

A2LCCP_QP_BLOB (A2LCCP_QP_BLOB node, A2LNODE parent)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

uint | CANId [getset]
XCP_DAQ_LIST_CAN_TYPE | DAQListType [getset]
ushort | DAQNo [getset]
byte | FirstPID [getset]
ushort | Length [getset]
byte | Raster [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_QP_BLOB
A2LCCP_QP_BLOB Member List

This is the complete list of members for A2LCCP_QP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_QP_BLOB(A2LCCP_QP_BLOB node, A2LNODE parent) (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CANId (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQListType (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
DAQNo (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FirstPID (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Raster (defined in A2LCCP_QP_BLOB) | A2LCCP_QP_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_RASTER Class Reference

  • ASAP2
  • CCP
  • A2LCCP_RASTER
Public Member Functions | Properties | List of all members
A2LCCP_RASTER Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Public Member Functions

A2LCCP_RASTER (A2LCCP_RASTER node, A2LNODE parent)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

byte | EvtChnNo [getset]
string | NameLong [getset]
string | NameShort [getset]
uint | Rate [getset]
CCP_SCALING_UNIT | ScalingUnit [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_RASTER
A2LCCP_RASTER Member List

This is the complete list of members for A2LCCP_RASTER, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_RASTER(A2LCCP_RASTER node, A2LNODE parent) (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EvtChnNo (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NameLong (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
NameShort (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Rate (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
ScalingUnit (defined in A2LCCP_RASTER) | A2LCCP_RASTER |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_SEED_KEY Class Reference

  • ASAP2
  • CCP
  • A2LCCP_SEED_KEY
Properties | List of all members
A2LCCP_SEED_KEY Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

string | CalDll [getset]
A reference to an external DLL
string | DaqDll [getset]
A reference to an external DLL
string | PgmDll [getset]
A reference to an external DLL
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_SEED_KEY
A2LCCP_SEED_KEY Member List

This is the complete list of members for A2LCCP_SEED_KEY, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CalDll | A2LCCP_SEED_KEY |
ChangedType | A2LNODE |
Childs | A2LNODE |
DaqDll | A2LCCP_SEED_KEY |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PgmDll | A2LCCP_SEED_KEY |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_SOURCE Class Reference

  • ASAP2
  • CCP
  • A2LCCP_SOURCE
Public Member Functions | Properties | List of all members
A2LCCP_SOURCE Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Public Member Functions

A2LCCP_SOURCE (A2LCCP_SOURCE node, A2LNODE parent)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

bool | Active = true [getset]
Used from the CCPMaster to mark as available for online measuring.
string | NameLong [getset]
uint | Rate [getset]
CCP_SCALING_UNIT | ScalingUnit [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_SOURCE
A2LCCP_SOURCE Member List

This is the complete list of members for A2LCCP_SOURCE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCCP_SOURCE(A2LCCP_SOURCE node, A2LNODE parent) (defined in A2LCCP_SOURCE) | A2LCCP_SOURCE |
A2LNODE(int startLine) | A2LNODE | protected
Active | A2LCCP_SOURCE |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NameLong (defined in A2LCCP_SOURCE) | A2LCCP_SOURCE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Rate (defined in A2LCCP_SOURCE) | A2LCCP_SOURCE |
ScalingUnit (defined in A2LCCP_SOURCE) | A2LCCP_SOURCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCCP_TP_BLOB Class Reference

  • ASAP2
  • CCP
  • A2LCCP_TP_BLOB
Public Member Functions | Properties | List of all members
A2LCCP_TP_BLOB Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Public Member Functions

uint | computeAddress (byte addressExtension, uint address, ECUPage targetPage)
Computes the calibration address for the specified target page type. More...
A2LCCP_DEFINED_PAGES | findCALPage (byte addressExtension, uint address, ECUPage targetPage, out uint offset)
Gets the calibration page base address for the specified page type. More...
A2LCCP_DEFINED_PAGES | findPage (byte addressExtension, uint address)
Finds the defined page the specified address is within. More...
List< A2LCCP_DEFINED_PAGES > | getPages (CCP_MEMORY_PAGE_TYPE pageType)
Gets all pages containing at leat one of the specified page type flags. More...
override string | ToString ()
Returns the string representation. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

CCP_ADDRESS_MODE | AddressExt [getset]
uint | Baudrate [getset]
ushort | BlobVersion [getset]
BYTEORDER_TYPE | ByteOrder [getset]
uint | CANIDCmd [getset]
uint | CANIDResp [getset]
CCP_ADDRESS_MODE | Consistency [getset]
CCP_DAQ_MODE | DAQMode [getset]
HashSet< byte > | OptionalCmds = new HashSet<byte>() [getset]
SortedDictionary< ushort, SourceAndRaster > | SourceAndRasterMap = new SortedDictionary<ushort, SourceAndRaster>() [get]
Holds CCP Source and corresponding CCP Raster
ushort | StationAddress [getset]
ushort | Version [getset]
- Properties inherited from A2LCCP_NODE
override string | Name [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCCP_NODE
static string | getCycleTime (CCP_SCALING_UNIT scalingUnits, uint rate)
Gets the cycle time from scaling units and rate. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)

Member Function Documentation

◆ computeAddress()

uint computeAddress | ( | byte | addressExtension,
 |  | uint | address,
 |  | ECUPage | targetPage
 | ) |  |

Computes the calibration address for the specified target page type.

Parameters
addressExtension | The address extension
address | The address to compute the calibration page address for
targetPage | The page type to get the calibration page base address for
Returns
The computed address (or uint.MaxValue if the address could not be computed)
Exceptions
NotSupportedException Thrown for unsupported page types

◆ findCALPage()

A2LCCP_DEFINED_PAGES findCALPage | ( | byte | addressExtension,
 |  | uint | address,
 |  | ECUPage | targetPage,
 |  | out uint | offset
 | ) |  |

Gets the calibration page base address for the specified page type.

Search Iterates over defined pages

Parameters
addressExtension | The address extension
address | The address to compute the calibration page address for
targetPage | The page type to get the CAL page address for
offset | The offset of the addres to the target base address
Returns
The calibration page found or null if the page is not found)
Exceptions
NotSupportedException Thrown for unsupported page types

◆ findPage()

A2LCCP_DEFINED_PAGES findPage | ( | byte | addressExtension,
 |  | uint | address
 | ) |  |

Finds the defined page the specified address is within.

Parameters
addressExtension | The address extension
address | The address to find
Returns
The defined page instance or null if not found

◆ getPages()

List< A2LCCP_DEFINED_PAGES > getPages ( CCP_MEMORY_PAGE_TYPE pageType )

Gets all pages containing at leat one of the specified page type flags.

Parameters
pageType The page type flags to request
Returns
The list of defined pages (may be empty)

◆ ToString()

override string ToString ( )

Returns the string representation.

Returns


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • A2LCCP_TP_BLOB
A2LCCP_TP_BLOB Member List

This is the complete list of members for A2LCCP_TP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressExt (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
Baudrate (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
BlobVersion (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
ByteOrder (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
CANIDCmd (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
CANIDResp (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
computeAddress(byte addressExtension, uint address, ECUPage targetPage) | A2LCCP_TP_BLOB |
Consistency (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
DAQMode (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findCALPage(byte addressExtension, uint address, ECUPage targetPage, out uint offset) | A2LCCP_TP_BLOB |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
findPage(byte addressExtension, uint address) | A2LCCP_TP_BLOB |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(CCP_SCALING_UNIT scalingUnits, uint rate) | A2LCCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getPages(CCP_MEMORY_PAGE_TYPE pageType) | A2LCCP_TP_BLOB |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LCCP_NODE) | A2LCCP_NODE |
NoCompuMethod | A2LNODE | static
OptionalCmds (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
SourceAndRasterMap | A2LCCP_TP_BLOB |
StartLine | A2LNODE |
StationAddress (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |
Tag | A2LNODE |
ToString() | A2LCCP_TP_BLOB |
Type | A2LNODE |
Version (defined in A2LCCP_TP_BLOB) | A2LCCP_TP_BLOB |


ASAP2Library interface: SourceAndRaster Struct Reference

  • ASAP2
  • CCP
  • SourceAndRaster
Public Member Functions | Public Attributes | List of all members
SourceAndRaster Struct Reference

Hold a CCP Source with it's attached CCP Raster. More...

Public Member Functions

SourceAndRaster (A2LCCP_SOURCE source, A2LCCP_RASTER raster)
Creates a new instance of DAQAndEvt. More...

Public Attributes

A2LCCP_RASTER | Raster
Event (may be null)
A2LCCP_SOURCE | Source
DAQ List

Detailed Description

Hold a CCP Source with it's attached CCP Raster.

Constructor & Destructor Documentation

◆ SourceAndRaster()

SourceAndRaster | ( | A2LCCP_SOURCE | source,
 |  | A2LCCP_RASTER | raster
 | ) |  |

Creates a new instance of DAQAndEvt.

Parameters
source | A CCP source
raster | CCP Raster to attach


ASAP2Library interface: Member List

  • ASAP2
  • CCP
  • SourceAndRaster
SourceAndRaster Member List

This is the complete list of members for SourceAndRaster, including all inherited members.

Raster | SourceAndRaster
Source | SourceAndRaster
SourceAndRaster(A2LCCP_SOURCE source, A2LCCP_RASTER raster) | SourceAndRaster


ASAP2Library interface: jnsoft.ASAP2.Examples Namespace Reference

  • ASAP2
  • Examples
Classes
jnsoft.ASAP2.Examples Namespace Reference

Classes

class Program
Sample console application. More...


ASAP2Library interface: Program Class Reference

  • ASAP2
  • Examples
  • Program
List of all members
Program Class Reference

Sample console application. More...

Detailed Description

Sample console application.

Demonstrating a simple csv output of some ASAP2 nodes from the specified A2L file content.

Usage: ASAP2ParserExample A2LFile.a2l > test.csv Does an csv output to stdout, watch result by opening the test.csv with excel or something.

Demonstrates modifying the A2L object model and rewriting it into a new A2L file.

Usage: ASAP2WriterExample A2LFile.a2l

  • Delete the M"speed_by_formula" from the object model
  • Adds the Function _MyFunction
  • Adds the CompuMethod _MyCompuMethod
  • Adds the Measurement _MyMeasurement
  • Adds the Characteristic _MyCharacteristic
  • Adds the new measurment and characteristic to the new function
  • Rewrites the resulting A2L to a new filename.out.a2l Does an csv output to stdout, watch result by opening the test.csv with excel or something.


ASAP2Library interface: Member List

  • ASAP2
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: jnsoft.ASAP2.Formulas Namespace Reference

  • ASAP2
  • Formulas
Classes
jnsoft.ASAP2.Formulas Namespace Reference

Contains all the stuff for dynamically compiled formulas. More...

Classes

class | A2LFormula
Represents a constant or a formula definition. More...
class | A2LFormulaDict
A A2LFormula dictionary (key = NodeName, value = A2LFormula). More...
interface | IEvaluator
Interface for dynamically compiled formulas. More...

Detailed Description

Contains all the stuff for dynamically compiled formulas.


ASAP2Library interface: A2LFormula Class Reference

  • ASAP2
  • Formulas
  • A2LFormula
Public Member Functions | List of all members
A2LFormula Class Reference

Represents a constant or a formula definition. More...

Public Member Functions

double | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toRaw (DATA_TYPE dataType, double physValue)
Computes the raw value from a physical value. More...
override string | ToString ()
Provides a string representation for the instance. More...

Detailed Description

Represents a constant or a formula definition.

An instance of this class is created from a

  • SYSTEM_CONSTANT
  • A2LFORMULA
  • A2LFORMULA / A2LFORMULA_INV pair.

Provides methods to compute

  • physical from raw values
  • raw values from physical values

Member Function Documentation

◆ toPhysical()

double toPhysical ( double rawValue )

Computes the physical value from a raw value.

  • If this instance is based on a SYSTEM_CONSTANT, the input value is not used.
Parameters
rawValue The raw value to transform to a physical value.
Returns
Physical value.

◆ toRaw()

double toRaw | ( | DATA_TYPE | dataType,
 |  | double | physValue
 | ) |  |

Computes the raw value from a physical value.

  • For formulas, the inverse formula evaluator is used.
  • If a formula does not define the inverse case, double.NaN is returned.
Parameters
dataType | The raw data type of the value
physValue | The physical value to transform to a raw value.
Returns
Raw value.

◆ ToString()

override string ToString ( )

Provides a string representation for the instance.

Returns
The instance value as a string


ASAP2Library interface: Member List

  • ASAP2
  • Formulas
  • A2LFormula
A2LFormula Member List

This is the complete list of members for A2LFormula, including all inherited members.

toPhysical(double rawValue) | A2LFormula
toRaw(DATA_TYPE dataType, double physValue) | A2LFormula
ToString() | A2LFormula


ASAP2Library interface: A2LFormulaDict Class Reference

  • ASAP2
  • Formulas
  • A2LFormulaDict
Public Member Functions | List of all members
A2LFormulaDict Class Reference

A A2LFormula dictionary (key = NodeName, value = A2LFormula). More...

Public Member Functions

A2LFormulaDict (bool strictParsing=true)
Creates a new instance of A2LFormulaDict.
void | add (A2LParser parser, A2LFORMULA formula)
Adds a formula to the formula dictionary. More...
void | add (A2LParser parser, string ident, string _formula)
Adds a SYSTEM_CONSTANT to the formula dictionary. More...
void | buildAssembly (A2LParser parser, IDictionary< string, string > systemConstants)
Fills the A2LFormulaDict after all SYSTEM_CONSTANT and A2LCOMPU_METHOD are added. More...

Detailed Description

A A2LFormula dictionary (key = NodeName, value = A2LFormula).

The dictionary is created from SYSTEM_CONSTANT entries in the A2LMODPAR instance and A2LFORMULA / A2LFORMULA_INV instances.

The A2LParser creates this dictionary

  • construct instance
  • Add all SYSTEM_CONSTANT and A2LCOMPU_METHOD by calling the add methods.
  • Call buildAssembly
  • Set instance to A2LPROJECT.FormulaDict

Usage example:

using (var parser = new A2LParser())
{ // load test.a2l
parser.parse("test.a2l");
// Output all system constants and it's values to console
var modpar = parser.Project.getNode<A2LMODULE>(false).RefModPar;
foreach (var sc in modpar.SystemConstants)
Console.WriteLine($"SYSTEM_CONSTANT {sc.Key}({sc.Value}), value={parser.Project.FormulaDict[sc.Key].toPhysical(0)}");
}

Member Function Documentation

◆ add() [1/2]

void add | ( | A2LParser | parser,
 |  | A2LFORMULA | formula
 | ) |  |

Adds a formula to the formula dictionary.

Parameters
parser | The A2L parser instance (just to create messages)
formula | The formula method child node

◆ add() [2/2]

void add | ( | A2LParser | parser,
 |  | string | ident,
 |  | string | _formula
 | ) |  |

Adds a SYSTEM_CONSTANT to the formula dictionary.

Parameters
parser | The A2L parser instance (just to create messages, may be null)
ident | The ident (in this case the SYSTEM_CONSTANT name)
_formula | The formula as text

◆ buildAssembly()

void buildAssembly | ( | A2LParser | parser,
 |  | IDictionary< string, string > | systemConstants
 | ) |  |

Fills the A2LFormulaDict after all SYSTEM_CONSTANT and A2LCOMPU_METHOD are added.

The algorithm:

  • Build the string representation of a CSharp code class from the formulas added
  • Compile the resulting string by using the .NET compiler
  • Create IEvaluator instances of the compiled classes
  • Create A2LFormula instances with the IEvaluator instances.
Parameters
parser | The A2L parser instance (just to create messages, may be null)
systemConstants | The system constant dictionary


ASAP2Library interface: Member List

  • ASAP2
  • Formulas
  • A2LFormulaDict
A2LFormulaDict Member List

This is the complete list of members for A2LFormulaDict, including all inherited members.

A2LFormulaDict(bool strictParsing=true) | A2LFormulaDict
add(A2LParser parser, string ident, string _formula) | A2LFormulaDict
add(A2LParser parser, A2LFORMULA formula) | A2LFormulaDict
buildAssembly(A2LParser parser, IDictionary< string, string > systemConstants) | A2LFormulaDict


ASAP2Library interface: IEvaluator Interface Reference

  • ASAP2
  • Formulas
  • IEvaluator
Public Member Functions | List of all members
IEvaluator Interface Reference

Interface for dynamically compiled formulas. More...

Public Member Functions

double eval (double x)
Returns the f(x) formula result. More...

Detailed Description

Interface for dynamically compiled formulas.

Used to create compiled formulas (see A2LFormulaDict).

Member Function Documentation

◆ eval()

double eval ( double x )

Returns the f(x) formula result.

Parameters
x The x value as input into the formula
Returns
The computed f(x) value or double.NaN if any exception or error occured


ASAP2Library interface: Member List

  • ASAP2
  • Formulas
  • IEvaluator
IEvaluator Member List

This is the complete list of members for IEvaluator, including all inherited members.

eval(double x) IEvaluator


ASAP2Library interface: jnsoft.ASAP2.Helpers Namespace Reference

  • ASAP2
  • Helpers
Classes
jnsoft.ASAP2.Helpers Namespace Reference

Contains the ASAP2 parser helper stuff. More...

Classes

class | AdaptiveState
Holds a Timestamp together with a MemoryRange to read from an ECU. More...
class | Checksum
Provides methods for building checksums over data. More...
class | CToCSharpMath
Maps standard math C functions to .NET framework math function strings. More...
class | DictionaryProxy
Proxy class to permit XML Serialization of generic dictionaries More...
class | DictionaryProxyComplex
Proxy class to permit XML Serialization of generic dictionaries with a complex value More...
class | Extensions
Implements basic helper stuff. More...
class | RationalCoeffs
Rational coefficients of an A2LCOMPU_METHOD. More...
class | TabCoeffs
Tab conversion computations. More...
class | TCConversionRef
Typeconverter to edit a reference to A2LCOMPUMETHOD. More...
class | TCFormatRef
Typeconverter to edit a reference to A2L Format string. More...
class | TCMeasurementRef
Typeconverter to edit a reference to a A2LMEASUREMENT. More...
class | TCTransformerRef
Typeconverter to edit a reference to A2LTRANSFORMER. More...
class | TCTypedefRef
Typeconverter to edit a reference to A2LTYPEDEF. More...
class | TCUnitRef
Typeconverter to edit a reference to A2LUNIT. More...

Detailed Description

Contains the ASAP2 parser helper stuff.


ASAP2Library interface: AdaptiveState Class Reference

  • ASAP2
  • Helpers
  • AdaptiveState
Public Member Functions | Public Attributes | List of all members
AdaptiveState Class Reference

Holds a Timestamp together with a MemoryRange to read from an ECU. More...

Public Member Functions

void | add (A2LCHARACTERISTIC characteristic)
Adds a characteristic to the list of adaptive characteristics. More...
bool | isUpdateRequired (ScalingUnits unit, int rate, long currentTicks)
Indicates if an update from the ECU data is required. More...

Public Attributes

readonly List< A2LCHARACTERISTIC > | AdaptiveCharList = new List<A2LCHARACTERISTIC>()
The list of adaptive characteristics. More...
long | LastElapsedTicks = -1
The timestamp from the last successful call to isUpdateRequired.
MemoryRangeList | MemoryRanges = new MemoryRangeList()
Holds a list of memory ranges. More...

Detailed Description

Holds a Timestamp together with a MemoryRange to read from an ECU.

Member Function Documentation

◆ add()

void add ( A2LCHARACTERISTIC characteristic )

Adds a characteristic to the list of adaptive characteristics.

To reduce the number of ECU queries, the characteristics gets summarized into memory ranges.

Parameters
characteristic The characteristic to add to the adaptive characteristics list

◆ isUpdateRequired()

bool isUpdateRequired | ( | ScalingUnits | unit,
 |  | int | rate,
 |  | long | currentTicks
 | ) |  |

Indicates if an update from the ECU data is required.

This method supports only time based refresh units.

Parameters
unit | The refresh unit
rate | The refresh rate
currentTicks | The currently elapsed ticks
Returns
true if an update from the ECU data is required
Exceptions
NotImplementedException Thrown if the refresh unit is not implemented.

Member Data Documentation

◆ AdaptiveCharList

readonly List<A2LCHARACTERISTIC> AdaptiveCharList = new List<A2LCHARACTERISTIC>()

The list of adaptive characteristics.

Don't modify this list directly, use the add method!

◆ MemoryRanges

MemoryRangeList MemoryRanges = new MemoryRangeList()

Holds a list of memory ranges.

  • This is a result of the characteristics added so far.
  • Don't modify this list directly, use the add method!


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • AdaptiveState
AdaptiveState Member List

This is the complete list of members for AdaptiveState, including all inherited members.

AdaptiveCharList | AdaptiveState
add(A2LCHARACTERISTIC characteristic) | AdaptiveState
isUpdateRequired(ScalingUnits unit, int rate, long currentTicks) | AdaptiveState
LastElapsedTicks | AdaptiveState
MemoryRanges | AdaptiveState


ASAP2Library interface: Checksum Class Reference

  • ASAP2
  • Helpers
  • Checksum
Static Public Member Functions | List of all members
Checksum Class Reference

Provides methods for building checksums over data. More...

Static Public Member Functions

static uint | buildChecksum (ChecksumType type, byte[] data, int fromOffset, int length, out byte checksumLen)
Builds the checksum over the specified data with the specified checksum type. More...
static uint | buildChecksum (ChecksumType type, IntPtr data, int fromOffset, int length, out byte checksumLen)
Builds the checksum over the specified data with the specified checksum type. More...
static ushort | CRC16 (byte[] data, int fromOffset, int length)
Builds the CRC16 checksum over the given data. More...
static uint | CRC16 (IntPtr data, int fromOffset, int length)
Builds the CRC32 checksum over the given data. More...
static ushort | CRC16CCITT (byte[] data, int fromOffset, int length)
Builds the CRC16CCITT checksum over the given data. More...
static ushort | CRC16CCITT (IntPtr data, int fromOffset, int length)
Builds the CRC16CCITT checksum over the given data. More...
static uint | CRC32 (byte[] data, int fromOffset, int length)
Builds the CRC32 checksum over the given data. More...
static uint | CRC32 (IntPtr data, int fromOffset, int length)
Builds the CRC32 checksum over the given data. More...

Detailed Description

Provides methods for building checksums over data.

All checksum algorithms required by ASAP2 and XCP are supported.

Member Function Documentation

◆ buildChecksum() [1/2]

static uint buildChecksum | ( | ChecksumType | type,
 |  | byte[] | data,
 |  | int | fromOffset,
 |  | int | length,
 |  | out byte | checksumLen
 | ) |  |
static

Builds the checksum over the specified data with the specified checksum type.

Parameters
type | The type of the checksum to build
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
checksumLen | byte length of checksum (1, 2 or 4)
Returns
The checksum value
Exceptions
NotImplementedException Thrown for ChecksumType.XCP_USER_DEFINED

◆ buildChecksum() [2/2]

static uint buildChecksum | ( | ChecksumType | type,
 |  | IntPtr | data,
 |  | int | fromOffset,
 |  | int | length,
 |  | out byte | checksumLen
 | ) |  |
static

Builds the checksum over the specified data with the specified checksum type.

Parameters
type | The type of the checksum to build
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
checksumLen | byte length of checksum (1, 2 or 4)
Returns
The checksum value
Exceptions
NotImplementedException Thrown for ChecksumType.XCP_USER_DEFINED

◆ CRC16() [1/2]

static ushort CRC16 | ( | byte[] | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC16 checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC16 value

◆ CRC16() [2/2]

static uint CRC16 | ( | IntPtr | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC32 checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC32 value

◆ CRC16CCITT() [1/2]

static ushort CRC16CCITT | ( | byte[] | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC16CCITT checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC16CCITT value

◆ CRC16CCITT() [2/2]

static ushort CRC16CCITT | ( | IntPtr | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC16CCITT checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC16CCITT value

◆ CRC32() [1/2]

static uint CRC32 | ( | byte[] | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC32 checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC32 value

◆ CRC32() [2/2]

static uint CRC32 | ( | IntPtr | data,
 |  | int | fromOffset,
 |  | int | length
 | ) |  |
static

Builds the CRC32 checksum over the given data.

Parameters
data | The data to build the checksum over
fromOffset | The offset into the specified data to build the checksum over
length | The length of the data to build the checksum over
Returns
The CRC32 value


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • Checksum
Checksum Member List

This is the complete list of members for Checksum, including all inherited members.

buildChecksum(ChecksumType type, IntPtr data, int fromOffset, int length, out byte checksumLen) | Checksum | static
buildChecksum(ChecksumType type, byte[] data, int fromOffset, int length, out byte checksumLen) | Checksum | static
CRC16(byte[] data, int fromOffset, int length) | Checksum | static
CRC16(IntPtr data, int fromOffset, int length) | Checksum | static
CRC16CCITT(byte[] data, int fromOffset, int length) | Checksum | static
CRC16CCITT(IntPtr data, int fromOffset, int length) | Checksum | static
CRC32(byte[] data, int fromOffset, int length) | Checksum | static
CRC32(IntPtr data, int fromOffset, int length) | Checksum | static


ASAP2Library interface: CToCSharpMath Class Reference

  • ASAP2
  • Helpers
  • CToCSharpMath
Static Public Member Functions | List of all members
CToCSharpMath Class Reference

Maps standard math C functions to .NET framework math function strings. More...

Static Public Member Functions

static string getFunction (string mathCFun)
Gets the corresponding .NET framework math function strings to the specified math C function. More...

Detailed Description

Maps standard math C functions to .NET framework math function strings.

Supports the ASAP standard 1.7 and standards prev to 1.7, see ASAP2 specification, too.

Provided c functions are:

  • sin, asin, sinh, cos, acos, cosh, tan, atan, tanh
  • exp, log, log10, sqrt, abs, pow
  • ceil, floor
  • ASAP2 standrad prev to v1.7: arcsin, arcos, arctan

Member Function Documentation

◆ getFunction()

static string getFunction ( string mathCFun )
static

Gets the corresponding .NET framework math function strings to the specified math C function.

Parameters
mathCFun The standard ANSI C function
Returns
the corresponding .NET Framework function or null or string.Empty if not found


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • CToCSharpMath
CToCSharpMath Member List

This is the complete list of members for CToCSharpMath, including all inherited members.

getFunction(string mathCFun) CToCSharpMath static


ASAP2Library interface: DictionaryProxy< k, v > Class Template Reference

  • ASAP2
  • Helpers
  • DictionaryProxy
Classes | Public Member Functions | Properties | List of all members
DictionaryProxy< k, v > Class Template Reference

Proxy class to permit XML Serialization of generic dictionaries More...

Classes

struct KeyAndValue
Holds the keys and values More...

Public Member Functions

DictionaryProxy (IDictionary< k, v > original)
void getDict (IDictionary< k, v > dict)

Properties

KeyAndValue[] KVP [getset]

Detailed Description

Proxy class to permit XML Serialization of generic dictionaries

Template Parameters
K | The type of the key
V | The type of the value


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • DictionaryProxy
DictionaryProxy< k, v > Member List

This is the complete list of members for DictionaryProxy< k, v >, including all inherited members.

DictionaryProxy() (defined in DictionaryProxy< k, v >) | DictionaryProxy< k, v >
DictionaryProxy(IDictionary< k, v > original) (defined in DictionaryProxy< k, v >) | DictionaryProxy< k, v >
getDict(IDictionary< k, v > dict) (defined in DictionaryProxy< k, v >) | DictionaryProxy< k, v >
KVP (defined in DictionaryProxy< k, v >) | DictionaryProxy< k, v >


ASAP2Library interface: DictionaryProxy< k, v >.KeyAndValue Struct Reference

  • ASAP2
  • Helpers
  • DictionaryProxy
  • KeyAndValue
Public Attributes | List of all members
DictionaryProxy< k, v >.KeyAndValue Struct Reference

Holds the keys and values More...

Public Attributes

k | K
v | V

Detailed Description

Holds the keys and values


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • DictionaryProxy
  • KeyAndValue
DictionaryProxy< k, v >.KeyAndValue Member List

This is the complete list of members for DictionaryProxy< k, v >.KeyAndValue, including all inherited members.

K (defined in DictionaryProxy< k, v >.KeyAndValue) | DictionaryProxy< k, v >.KeyAndValue
V (defined in DictionaryProxy< k, v >.KeyAndValue) | DictionaryProxy< k, v >.KeyAndValue


ASAP2Library interface: DictionaryProxyComplex< k, v > Class Template Reference

  • ASAP2
  • Helpers
  • DictionaryProxyComplex
Classes | Public Member Functions | Properties | List of all members
DictionaryProxyComplex< k, v > Class Template Reference

Proxy class to permit XML Serialization of generic dictionaries with a complex value More...

Classes

struct KeyAndValueComplex
Holds the keys and values More...

Public Member Functions

DictionaryProxyComplex (IDictionary< k, v > original)
void getDict (IDictionary< k, v > dict)

Properties

KeyAndValueComplex[] KVP [getset]

Detailed Description

Proxy class to permit XML Serialization of generic dictionaries with a complex value

Template Parameters
K | The type of the key
V | The type of the value


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • DictionaryProxyComplex
DictionaryProxyComplex< k, v > Member List

This is the complete list of members for DictionaryProxyComplex< k, v >, including all inherited members.

DictionaryProxyComplex() (defined in DictionaryProxyComplex< k, v >) | DictionaryProxyComplex< k, v >
DictionaryProxyComplex(IDictionary< k, v > original) (defined in DictionaryProxyComplex< k, v >) | DictionaryProxyComplex< k, v >
getDict(IDictionary< k, v > dict) (defined in DictionaryProxyComplex< k, v >) | DictionaryProxyComplex< k, v >
KVP (defined in DictionaryProxyComplex< k, v >) | DictionaryProxyComplex< k, v >


ASAP2Library interface: DictionaryProxyComplex< k, v >.KeyAndValueComplex Struct Reference

  • ASAP2
  • Helpers
  • DictionaryProxyComplex
  • KeyAndValueComplex
Public Attributes | List of all members
DictionaryProxyComplex< k, v >.KeyAndValueComplex Struct Reference

Holds the keys and values More...

Public Attributes

k | K
v | V

Detailed Description

Holds the keys and values


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • DictionaryProxyComplex
  • KeyAndValueComplex
DictionaryProxyComplex< k, v >.KeyAndValueComplex Member List

This is the complete list of members for DictionaryProxyComplex< k, v >.KeyAndValueComplex, including all inherited members.

K (defined in DictionaryProxyComplex< k, v >.KeyAndValueComplex) | DictionaryProxyComplex< k, v >.KeyAndValueComplex
V (defined in DictionaryProxyComplex< k, v >.KeyAndValueComplex) | DictionaryProxyComplex< k, v >.KeyAndValueComplex


ASAP2Library interface: Extensions Class Reference

  • ASAP2
  • Helpers
  • Extensions
Static Public Member Functions | List of all members
Extensions Class Reference

Implements basic helper stuff. More...

Static Public Member Functions

static string unescapeStr (string input)
Unescapes a string according the ASAP2 definition. More...

Detailed Description

Implements basic helper stuff.

Member Function Documentation

◆ unescapeStr()

static string unescapeStr ( string input )
static

Unescapes a string according the ASAP2 definition.

Parameters
input text to Unescape
Returns
Unescaped text


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • Extensions
Extensions Member List

This is the complete list of members for Extensions, including all inherited members.

unescapeStr(string input) Extensions static


ASAP2Library interface: RationalCoeffs Class Reference

  • ASAP2
  • Helpers
  • RationalCoeffs
Public Member Functions | Public Attributes | Properties | List of all members
RationalCoeffs Class Reference

Rational coefficients of an A2LCOMPU_METHOD. More...

Public Member Functions

RationalCoeffs ()
Creates an instance using default coefficients (Identity).
RationalCoeffs (double factor, double offset)
Creates an instance from factor/offset More...
RationalCoeffs (double[] coeffs, bool copy=true)
Creates an instance using the specified coefficients. More...
RationalCoeffs (RationalCoeffs src)
Copy constructor. More...
double | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toRaw (double x, DATA_TYPE dataType=DATA_TYPE.FLOAT64_IEEE)
Computes the raw value from a physical value. More...
override string | ToString ()

Public Attributes

readonly double[] Coeffs
The rational methods coefficients, mapped from (a, b, c, f, e, f).

Properties

double | Factor [get]
Gets the factor parameter (as part of a linear function)
double | Offset [get]
Gets the offset parameter (as part of a linear function)

Detailed Description

Rational coefficients of an A2LCOMPU_METHOD.

Constructor & Destructor Documentation

◆ RationalCoeffs() [1/3]

RationalCoeffs | ( | double[] | coeffs,
 |  | bool | copy = true
 | ) |  |

Creates an instance using the specified coefficients.

Parameters
coeffs | The coefficients to use
copy | true if coefficents should be copied

◆ RationalCoeffs() [2/3]

RationalCoeffs | ( | double | factor,
 |  | double | offset
 | ) |  |

Creates an instance from factor/offset

Parameters
factor | The factor
offset | The offset

◆ RationalCoeffs() [3/3]

RationalCoeffs ( RationalCoeffs src )

Copy constructor.

Parameters
src Instance to copy form

Member Function Documentation

◆ toPhysical()

double toPhysical ( double rawValue )

Computes the physical value from a raw value.

The ASAP2 computation method formula inverts to a solution of a quadratic equation, which may have three outcomes:

  • Equation is degenerate: If A (see below) is zero, the equation degrates into solution of a linear equation.
  • Equation is non-degenerate with common root: If the two roots of the solution (x1 and x2) are equal, the formula can be applied.
  • Equation is non-degenerate with different roots: If the two roots of the solution (x1 and x2) are not equal, there is no basis to select the "right" solution. Fail with an exception in this case.
Parameters
rawValue The raw value to transform to physical.
Returns
Physical value.

◆ toRaw()

double toRaw | ( | double | x,
 |  | DATA_TYPE | dataType = DATA_TYPE.FLOAT64_IEEE
 | ) |  |

Computes the raw value from a physical value.

In this case simply apply the ASAP2 computation method formula below.

The asap formula: y = (a*x*x+b*x+c)/(d*x*x+e*x+f).

Parameters
x | Physical value to transform to raw value.
dataType | The raw data type of the value
Returns
Raw value.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • RationalCoeffs
RationalCoeffs Member List

This is the complete list of members for RationalCoeffs, including all inherited members.

Coeffs | RationalCoeffs
Factor | RationalCoeffs
Offset | RationalCoeffs
RationalCoeffs() | RationalCoeffs
RationalCoeffs(double[] coeffs, bool copy=true) | RationalCoeffs
RationalCoeffs(double factor, double offset) | RationalCoeffs
RationalCoeffs(RationalCoeffs src) | RationalCoeffs
toPhysical(double rawValue) | RationalCoeffs
toRaw(double x, DATA_TYPE dataType=DATA_TYPE.FLOAT64_IEEE) | RationalCoeffs
ToString() (defined in RationalCoeffs) | RationalCoeffs


ASAP2Library interface: TabCoeffs Class Reference

  • ASAP2
  • Helpers
  • TabCoeffs
Static Public Member Functions | List of all members
TabCoeffs Class Reference

Tab conversion computations. More...

Static Public Member Functions

static double | toPhysical (CONVERSION_TYPE convType, A2LCOMPU_TAB compuTab, double rawValue)
Computes the physical value from a raw value. More...
static double | toRaw (CONVERSION_TYPE convType, A2LCOMPU_TAB compuTab, DATA_TYPE dataType, double physicalValue)
Computes the raw value from a physical value. More...

Detailed Description

Tab conversion computations.

Member Function Documentation

◆ toPhysical()

static double toPhysical | ( | CONVERSION_TYPE | convType,
 |  | A2LCOMPU_TAB | compuTab,
 |  | double | rawValue
 | ) |  |
static

Computes the physical value from a raw value.

Parameters
convType | Conversion type (in this case CONVERSION_TYPE.TAB_INTP or CONVERSION_TYPE.TAB_NOINTP)
compuTab | The tab dictionary
rawValue | The raw value
Returns
Physical value.

◆ toRaw()

static double toRaw | ( | CONVERSION_TYPE | convType,
 |  | A2LCOMPU_TAB | compuTab,
 |  | DATA_TYPE | dataType,
 |  | double | physicalValue
 | ) |  |
static

Computes the raw value from a physical value.

Parameters
convType | Conversion type (in this case CONVERSION_TYPE.TAB_INTP or CONVERSION_TYPE.TAB_NOINTP)
compuTab | The tab dictionary
dataType | The raw data type of the value
physicalValue | The raw value
Returns
Raw value.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TabCoeffs
TabCoeffs Member List

This is the complete list of members for TabCoeffs, including all inherited members.

toPhysical(CONVERSION_TYPE convType, A2LCOMPU_TAB compuTab, double rawValue) | TabCoeffs | static
toRaw(CONVERSION_TYPE convType, A2LCOMPU_TAB compuTab, DATA_TYPE dataType, double physicalValue) | TabCoeffs | static


ASAP2Library interface: TCConversionRef Class Reference

  • ASAP2
  • Helpers
  • TCConversionRef
Public Member Functions | List of all members
TCConversionRef Class Reference

Typeconverter to edit a reference to A2LCOMPUMETHOD. More...

Public Member Functions

override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesExclusive (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to A2LCOMPUMETHOD.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCConversionRef
TCConversionRef Member List

This is the complete list of members for TCConversionRef, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCConversionRef) | TCConversionRef
GetStandardValuesExclusive(ITypeDescriptorContext context) (defined in TCConversionRef) | TCConversionRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCConversionRef) | TCConversionRef


ASAP2Library interface: TCFormatRef Class Reference

  • ASAP2
  • Helpers
  • TCFormatRef
Public Member Functions | List of all members
TCFormatRef Class Reference

Typeconverter to edit a reference to A2L Format string. More...

Public Member Functions

override bool | CanConvertFrom (ITypeDescriptorContext context, Type sourceType)
override object | ConvertFrom (ITypeDescriptorContext context, CultureInfo culture, object value)
override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to A2L Format string.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCFormatRef
TCFormatRef Member List

This is the complete list of members for TCFormatRef, including all inherited members.

CanConvertFrom(ITypeDescriptorContext context, Type sourceType) (defined in TCFormatRef) | TCFormatRef
ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) (defined in TCFormatRef) | TCFormatRef
GetStandardValues(ITypeDescriptorContext context) (defined in TCFormatRef) | TCFormatRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCFormatRef) | TCFormatRef


ASAP2Library interface: TCMeasurementRef Class Reference

  • ASAP2
  • Helpers
  • TCMeasurementRef
Public Member Functions | List of all members
TCMeasurementRef Class Reference

Typeconverter to edit a reference to a A2LMEASUREMENT. More...

Public Member Functions

override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesExclusive (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to a A2LMEASUREMENT.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCMeasurementRef
TCMeasurementRef Member List

This is the complete list of members for TCMeasurementRef, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCMeasurementRef) | TCMeasurementRef
GetStandardValuesExclusive(ITypeDescriptorContext context) (defined in TCMeasurementRef) | TCMeasurementRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCMeasurementRef) | TCMeasurementRef


ASAP2Library interface: TCTransformerRef Class Reference

  • ASAP2
  • Helpers
  • TCTransformerRef
Public Member Functions | List of all members
TCTransformerRef Class Reference

Typeconverter to edit a reference to A2LTRANSFORMER. More...

Public Member Functions

override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesExclusive (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to A2LTRANSFORMER.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCTransformerRef
TCTransformerRef Member List

This is the complete list of members for TCTransformerRef, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCTransformerRef) | TCTransformerRef
GetStandardValuesExclusive(ITypeDescriptorContext context) (defined in TCTransformerRef) | TCTransformerRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCTransformerRef) | TCTransformerRef


ASAP2Library interface: TCTypedefRef Class Reference

  • ASAP2
  • Helpers
  • TCTypedefRef
Public Member Functions | List of all members
TCTypedefRef Class Reference

Typeconverter to edit a reference to A2LTYPEDEF. More...

Public Member Functions

override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesExclusive (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to A2LTYPEDEF.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCTypedefRef
TCTypedefRef Member List

This is the complete list of members for TCTypedefRef, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCTypedefRef) | TCTypedefRef
GetStandardValuesExclusive(ITypeDescriptorContext context) (defined in TCTypedefRef) | TCTypedefRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCTypedefRef) | TCTypedefRef


ASAP2Library interface: TCUnitRef Class Reference

  • ASAP2
  • Helpers
  • TCUnitRef
Public Member Functions | List of all members
TCUnitRef Class Reference

Typeconverter to edit a reference to A2LUNIT. More...

Public Member Functions

override bool | CanConvertFrom (ITypeDescriptorContext context, Type sourceType)
override object | ConvertFrom (ITypeDescriptorContext context, CultureInfo culture, object value)
override StandardValuesCollection | GetStandardValues (ITypeDescriptorContext context)
override bool | GetStandardValuesExclusive (ITypeDescriptorContext context)
override bool | GetStandardValuesSupported (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference to A2LUNIT.


ASAP2Library interface: Member List

  • ASAP2
  • Helpers
  • TCUnitRef
TCUnitRef Member List

This is the complete list of members for TCUnitRef, including all inherited members.

CanConvertFrom(ITypeDescriptorContext context, Type sourceType) (defined in TCUnitRef) | TCUnitRef
ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) (defined in TCUnitRef) | TCUnitRef
GetStandardValues(ITypeDescriptorContext context) (defined in TCUnitRef) | TCUnitRef
GetStandardValuesExclusive(ITypeDescriptorContext context) (defined in TCUnitRef) | TCUnitRef
GetStandardValuesSupported(ITypeDescriptorContext context) (defined in TCUnitRef) | TCUnitRef


ASAP2Library interface: jnsoft.ASAP2.KWP Namespace Reference

  • ASAP2
  • KWP
Classes | Enumerations
jnsoft.ASAP2.KWP Namespace Reference

Implements the ASAP2 KWP (IF_DATA) Interface stuff. More...

Classes

class | A2LKWP_ADDRESS
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_ADDRESS_MAPPING
See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...
class | A2LKWP_CAN
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_CHECKSUM
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_COPY
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_DIAG_BAUD
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_DP_BLOB
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_FLASH
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_FLASH_COPY
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_K_LINE
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_KP_BLOB
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_NAMEDNODE
Base class for all A2LCCP entities with specific names. More...
class | A2LKWP_NODE
Base class for all A2L node definitions concerning KWP. More...
class | A2LKWP_PAGE_SWITCH
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_ROUTINE_PARA
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_SOURCE
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_TIME_DEF
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | A2LKWP_TP_BLOB
See ASAP1B_KWP (COMMON_PARAMETERS) More...
class | KWP_TIME_DEF
Timing definition smaller v2000 More...
class | KWP_USDTP_TIMING
Timing definition smaller v2000 More...

Enumerations

enum | AddressLocation { INTERN , EXTERN }
KWP KP_BLOB Address Locations.
enum | KWP_COPY_MODE { RAM_InitByECU , RAM_InitByTool }
ECU mode for copying Flash into RAM. More...
enum | KWP_DATA_ACCESS_FLAGS { ReadData = 1 , VerifyCode = ReadData << 1 , ReadCode = ReadData << 2 , RWOnlyOnActivePage = ReadData << 3 }
Data Access flags More...
enum | KWP_FLASH_MODE { NOFLASHBACK , AUTOFLASHBACK , TOOLFLASHBACK }
ECU mode for copying RAM into Flash.
enum | KWP_FLASH_RESULT { RequestRoutineResults , StartRoutine , CodedResult }
Results of copy routine.
enum | KWP_MEASUREMENT_MODE { ADDRESSMODE , BLOCKMODE }
KWP Measurement mode of ECU: Block with local Id or single by address More...
enum | KWP_PAGE_SWITCH_MODE { ESCAPE_CODE , LOCAL_ROUTINE }
Type of page switching service
enum KWP_PHYSICAL_LAYER {
NotSet , KLINE , CAN , KLINE_CAN ,
KLINE_AND_CAN
}
KWP possible physical layers. More...
enum | KWP_STIMULATION_MODE { NotSet , _WuP , _5Baud }
Modes of KWP Stimulation. More...
enum | KWP_VERSION { NotSet , VDA_1996 }
KWP Version greater v2000

Detailed Description

Implements the ASAP2 KWP (IF_DATA) Interface stuff.

Enumeration Type Documentation

◆ KWP_COPY_MODE

enum KWP_COPY_MODE

ECU mode for copying Flash into RAM.

Enumerator
RAM_InitByECU | RAM will be initialized by the ECU
RAM_InitByTool | RAM must be initialized by the Tool

◆ KWP_DATA_ACCESS_FLAGS

enum KWP_DATA_ACCESS_FLAGS

Data Access flags

Enumerator
ReadData | Upload from ECU flash data
VerifyCode | Verify access on ECU flash code
ReadCode | Upload from ECU flash code
RWOnlyOnActivePage | Read and write only on active page

◆ KWP_MEASUREMENT_MODE

enum KWP_MEASUREMENT_MODE

KWP Measurement mode of ECU: Block with local Id or single by address

Enumerator
ADDRESSMODE | Address mode
BLOCKMODE | Block mode

◆ KWP_PHYSICAL_LAYER

enum KWP_PHYSICAL_LAYER

KWP possible physical layers.

Enumerator
KLINE | K-LINE
CAN | CAN
KLINE_CAN | K-LINE and CAN
KLINE_AND_CAN | K-LINE and CAN

◆ KWP_STIMULATION_MODE

enum KWP_STIMULATION_MODE

Modes of KWP Stimulation.

Enumerator
_WuP | WuP
_5Baud | 5 Baud


ASAP2Library interface: A2LKWP_ADDRESS Class Reference

  • ASAP2
  • KWP
  • A2LKWP_ADDRESS
Properties | List of all members
A2LKWP_ADDRESS Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

uint | CANIdECU [getset]
CAN_ID ECU(or gateway) - Tester
uint | CANIdTester [getset]
CAN_ID Tester - ECU(or gateway)
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_ADDRESS
A2LKWP_ADDRESS Member List

This is the complete list of members for A2LKWP_ADDRESS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CANIdECU | A2LKWP_ADDRESS |
CANIdTester | A2LKWP_ADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_ADDRESS_MAPPING Class Reference

  • ASAP2
  • KWP
  • A2LKWP_ADDRESS_MAPPING
Properties | List of all members
A2LKWP_ADDRESS_MAPPING Class Reference

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS) More...

Properties

uint | BaseAddress [getset]
Base address of the memory segment to be mapped
uint | Length [getset]
Length of the segment to be mapped
uint | MapAddress [getset]
Address to which the base address is to be mapped
- Properties inherited from A2LKWP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.KP_BLOB.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LKWP_NAMEDNODE
A2LKWP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LKWP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_ADDRESS_MAPPING
A2LKWP_ADDRESS_MAPPING Member List

This is the complete list of members for A2LKWP_ADDRESS_MAPPING, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LKWP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LKWP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BaseAddress | A2LKWP_ADDRESS_MAPPING |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length | A2LKWP_ADDRESS_MAPPING |
MapAddress | A2LKWP_ADDRESS_MAPPING |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LKWP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LKWP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_CAN Class Reference

  • ASAP2
  • KWP
  • A2LKWP_CAN
Classes | Properties | List of all members
A2LKWP_CAN Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Classes

class NETWORK_LIMITS
KWP QP_BLOB definition smaller v2000 More...

Properties

uint | Baudrate [getset]
Baudrate [Hz]
byte | BTLCycles [getset]
BTL_CYCLES [slots/bit time]
NETWORK_LIMITS | NetworkLimits [getset]
byte | SampleCount [getset]
1 or 3 samples per bit
byte | SamplePoints [getset]
Sample point [% complete bit time]
byte | SJWLength [getset]
SJW length synchr. segm. in BTL_CYCLES
ushort | StartStopRoutineNo [getset]
Start stop FREE_RUNNING routine number
byte | SyncEdge [getset]
SYNC_EDGE
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_CAN
A2LKWP_CAN Member List

This is the complete list of members for A2LKWP_CAN, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Baudrate | A2LKWP_CAN |
BTLCycles | A2LKWP_CAN |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NetworkLimits (defined in A2LKWP_CAN) | A2LKWP_CAN |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
SampleCount | A2LKWP_CAN |
SamplePoints | A2LKWP_CAN |
SJWLength | A2LKWP_CAN |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StartStopRoutineNo | A2LKWP_CAN |
SyncEdge | A2LKWP_CAN |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_CAN.NETWORK_LIMITS Class Reference

  • ASAP2
  • KWP
  • A2LKWP_CAN
  • NETWORK_LIMITS
Properties | List of all members
A2LKWP_CAN.NETWORK_LIMITS Class Reference

KWP QP_BLOB definition smaller v2000 More...

Properties

byte | WFT_MAX [getset]
(max. waitframes)
ushort | XDL_MAX [getset]
(max. datalength)

Detailed Description

KWP QP_BLOB definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_CAN
  • NETWORK_LIMITS
A2LKWP_CAN.NETWORK_LIMITS Member List

This is the complete list of members for A2LKWP_CAN.NETWORK_LIMITS, including all inherited members.

WFT_MAX | A2LKWP_CAN.NETWORK_LIMITS
XDL_MAX | A2LKWP_CAN.NETWORK_LIMITS


ASAP2Library interface: A2LKWP_CHECKSUM Class Reference

  • ASAP2
  • KWP
  • A2LKWP_CHECKSUM
Properties | List of all members
A2LKWP_CHECKSUM Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

uint | ChkSumType [getset]
check sum type qualifier (see table)
ushort | LocalRoutineNo [getset]
No of local routine for check sum
bool | OnlyOnActivePage [getset]
check sum calculation only on active page
KWP_FLASH_RESULT | Result [getset]
result of checksum routine delivered by
byte[] | RNC_RESULT [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_CHECKSUM
A2LKWP_CHECKSUM Member List

This is the complete list of members for A2LKWP_CHECKSUM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ChkSumType | A2LKWP_CHECKSUM |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
LocalRoutineNo | A2LKWP_CHECKSUM |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OnlyOnActivePage | A2LKWP_CHECKSUM |
Parent | A2LNODE |
Result | A2LKWP_CHECKSUM |
RNC_RESULT (defined in A2LKWP_CHECKSUM) | A2LKWP_CHECKSUM |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_COPY Class Reference

  • ASAP2
  • KWP
  • A2LKWP_COPY
Properties | List of all members
A2LKWP_COPY Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

byte[] | COPY_PARA [getset]
list of add. parameters for local routine
byte | FLASHToRAMDiagMode [getset]
diagnostic mode for copy RAM to Flash
KWP_COPY_MODE | FLASHToRAMMode [getset]
ECU mode for copying Flash into RAM
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_COPY
A2LKWP_COPY Member List

This is the complete list of members for A2LKWP_COPY, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
COPY_PARA | A2LKWP_COPY |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FLASHToRAMDiagMode | A2LKWP_COPY |
FLASHToRAMMode | A2LKWP_COPY |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_DIAG_BAUD Class Reference

  • ASAP2
  • KWP
  • A2LKWP_DIAG_BAUD
Properties | List of all members
A2LKWP_DIAG_BAUD Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

uint | Baudrate [getset]
byte[] | BD_PARA [getset]
ushort | DiagMode [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_DIAG_BAUD
A2LKWP_DIAG_BAUD Member List

This is the complete list of members for A2LKWP_DIAG_BAUD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Baudrate (defined in A2LKWP_DIAG_BAUD) | A2LKWP_DIAG_BAUD |
BD_PARA (defined in A2LKWP_DIAG_BAUD) | A2LKWP_DIAG_BAUD |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DiagMode (defined in A2LKWP_DIAG_BAUD) | A2LKWP_DIAG_BAUD |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_DP_BLOB Class Reference

  • ASAP2
  • KWP
  • A2LKWP_DP_BLOB
Properties | List of all members
A2LKWP_DP_BLOB Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

uint | Address [getset]
Base address of the calibration data
uint | Length [getset]
Number of Bytes belonging to the calibration data end of DP_BLOB
- Properties inherited from A2LKWP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.KP_BLOB.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LKWP_NAMEDNODE
A2LKWP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LKWP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_DP_BLOB
A2LKWP_DP_BLOB Member List

This is the complete list of members for A2LKWP_DP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LKWP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LKWP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LKWP_DP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length | A2LKWP_DP_BLOB |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LKWP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LKWP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_FLASH Class Reference

  • ASAP2
  • KWP
  • A2LKWP_FLASH
Properties | List of all members
A2LKWP_FLASH Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

byte[] | COPY_FRAME [getset]
byte[] | COPY_PARA [getset]
KWP_FLASH_MODE | RAMToFLASHMode [getset]
ECU mode for copying RAM into Flash
ushort | RAMToFLASHRoutineNo [getset]
KWP_FLASH_RESULT | Result [getset]
result of copy routine delivered by
byte[] | RNC_RESULT [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_FLASH
A2LKWP_FLASH Member List

This is the complete list of members for A2LKWP_FLASH, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
COPY_FRAME (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
COPY_PARA (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RAMToFLASHMode | A2LKWP_FLASH |
RAMToFLASHRoutineNo (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
Result | A2LKWP_FLASH |
RNC_RESULT (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_FLASH_COPY Class Reference

  • ASAP2
  • KWP
  • A2LKWP_FLASH_COPY
Properties | List of all members
A2LKWP_FLASH_COPY Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

byte | FLASHToRAMDiagMode [getset]
diagnostic mode for copy RAM to Flash
KWP_COPY_MODE | FLASHToRAMMode [getset]
ECU mode for copying Flash into RAM
- Properties inherited from A2LKWP_FLASH
byte[] | COPY_FRAME [getset]
byte[] | COPY_PARA [getset]
KWP_FLASH_MODE | RAMToFLASHMode [getset]
ECU mode for copying RAM into Flash
ushort | RAMToFLASHRoutineNo [getset]
KWP_FLASH_RESULT | Result [getset]
result of copy routine delivered by
byte[] | RNC_RESULT [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_FLASH_COPY
A2LKWP_FLASH_COPY Member List

This is the complete list of members for A2LKWP_FLASH_COPY, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
COPY_FRAME (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
COPY_PARA (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FLASHToRAMDiagMode | A2LKWP_FLASH_COPY |
FLASHToRAMMode | A2LKWP_FLASH_COPY |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RAMToFLASHMode | A2LKWP_FLASH |
RAMToFLASHRoutineNo (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
Result | A2LKWP_FLASH |
RNC_RESULT (defined in A2LKWP_FLASH) | A2LKWP_FLASH |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_K_LINE Class Reference

  • ASAP2
  • KWP
  • A2LKWP_K_LINE
Properties | List of all members
A2LKWP_K_LINE Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

ushort | ECUAddress [getset]
KWP_STIMULATION_MODE | StimulationMode [getset]
ushort | TesterAddress [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_K_LINE
A2LKWP_K_LINE Member List

This is the complete list of members for A2LKWP_K_LINE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
ECUAddress (defined in A2LKWP_K_LINE) | A2LKWP_K_LINE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StimulationMode (defined in A2LKWP_K_LINE) | A2LKWP_K_LINE |
Tag | A2LNODE |
TesterAddress (defined in A2LKWP_K_LINE) | A2LKWP_K_LINE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_KP_BLOB Class Reference

  • ASAP2
  • KWP
  • A2LKWP_KP_BLOB
Properties | List of all members
A2LKWP_KP_BLOB Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

uint | Address [getset]
Base address of the calibration data
AddressLocation | Location [getset]
Address location
uint | Size [getset]
Number of Bytes belonging to the calibration data end of KP_BLOB
- Properties inherited from A2LKWP_NAMEDNODE
sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.KP_BLOB.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LKWP_NAMEDNODE
A2LKWP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LKWP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_KP_BLOB
A2LKWP_KP_BLOB Member List

This is the complete list of members for A2LKWP_KP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LKWP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LKWP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LKWP_KP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Location | A2LKWP_KP_BLOB |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LKWP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Size | A2LKWP_KP_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LKWP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_NAMEDNODE Class Reference

  • ASAP2
  • KWP
  • A2LKWP_NAMEDNODE
Protected Member Functions | Properties | List of all members
A2LKWP_NAMEDNODE Class Reference

Base class for all A2LCCP entities with specific names. More...

Protected Member Functions

A2LKWP_NAMEDNODE (A2LNODE parent, int startLine, int endLine, A2LType subType)
Initialises a new instance of A2LKWP_NAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

sealed override string | Name [get]
Gets the name of the node. More...
A2LType | SubType [getset]
Gets the A2L sub type like A2LType.KP_BLOB.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2LCCP entities with specific names.

Constructor & Destructor Documentation

◆ A2LKWP_NAMEDNODE()

A2LKWP_NAMEDNODE | ( | A2LNODE | parent,
 |  | int | startLine,
 |  | int | endLine,
 |  | A2LType | subType
 | ) |  |
protected

Initialises a new instance of A2LKWP_NAMEDNODE with the specified parameters.

Parameters
parent | The parent node
startLine | The starting line
endLine | The ending line
subType | The A2L type subtype

Property Documentation

◆ Name

sealed override string Name
get

Gets the name of the node.

Use the setter with care! Changing the name requires to adjust all references to this instance.


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_NAMEDNODE
A2LKWP_NAMEDNODE Member List

This is the complete list of members for A2LKWP_NAMEDNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LKWP_NAMEDNODE(A2LNODE parent, int startLine, int endLine, A2LType subType) | A2LKWP_NAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LKWP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SubType | A2LKWP_NAMEDNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_NODE Class Reference

  • ASAP2
  • KWP
  • A2LKWP_NODE
Static Protected Attributes | List of all members
A2LKWP_NODE Class Reference

Base class for all A2L node definitions concerning KWP. More...

Static Protected Attributes

const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

Base class for all A2L node definitions concerning KWP.


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_NODE
A2LKWP_NODE Member List

This is the complete list of members for A2LKWP_NODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_PAGE_SWITCH Class Reference

  • ASAP2
  • KWP
  • A2LKWP_PAGE_SWITCH
Properties | List of all members
A2LKWP_PAGE_SWITCH Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

byte[] | ESCAPE_CODE_PARA_GET [getset]
byte[] | ESCAPE_CODE_PARA_SET [getset]
KWP_PAGE_SWITCH_MODE | Mode [getset]
type of page switching service
byte[] | PAGE_CODE [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_PAGE_SWITCH
A2LKWP_PAGE_SWITCH Member List

This is the complete list of members for A2LKWP_PAGE_SWITCH, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
ESCAPE_CODE_PARA_GET (defined in A2LKWP_PAGE_SWITCH) | A2LKWP_PAGE_SWITCH |
ESCAPE_CODE_PARA_SET (defined in A2LKWP_PAGE_SWITCH) | A2LKWP_PAGE_SWITCH |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Mode | A2LKWP_PAGE_SWITCH |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
PAGE_CODE (defined in A2LKWP_PAGE_SWITCH) | A2LKWP_PAGE_SWITCH |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_ROUTINE_PARA Class Reference

  • ASAP2
  • KWP
  • A2LKWP_ROUTINE_PARA
Properties | List of all members
A2LKWP_ROUTINE_PARA Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

ushort | LocalRoutineNo [getset]
No of local routine for page switching
KWP_FLASH_RESULT | Result [getset]
result of copy routine delivered by
byte[] | RNC_RESULT [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_ROUTINE_PARA
A2LKWP_ROUTINE_PARA Member List

This is the complete list of members for A2LKWP_ROUTINE_PARA, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
LocalRoutineNo | A2LKWP_ROUTINE_PARA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Result | A2LKWP_ROUTINE_PARA |
RNC_RESULT (defined in A2LKWP_ROUTINE_PARA) | A2LKWP_ROUTINE_PARA |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_SOURCE Class Reference

  • ASAP2
  • KWP
  • A2LKWP_SOURCE
Classes | Properties | List of all members
A2LKWP_SOURCE Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Classes

class QP_BLOB
KWP QP_BLOB definition smaller v2000 More...

Properties

short | CSEUnit [getset]
string | NameLong [getset]
QP_BLOB | QPBlob [getset]
int | Rate [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_SOURCE
A2LKWP_SOURCE Member List

This is the complete list of members for A2LKWP_SOURCE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CSEUnit (defined in A2LKWP_SOURCE) | A2LKWP_SOURCE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NameLong (defined in A2LKWP_SOURCE) | A2LKWP_SOURCE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
QPBlob (defined in A2LKWP_SOURCE) | A2LKWP_SOURCE |
Rate (defined in A2LKWP_SOURCE) | A2LKWP_SOURCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LKWP_SOURCE.QP_BLOB Class Reference

  • ASAP2
  • KWP
  • A2LKWP_SOURCE
  • QP_BLOB
Properties | List of all members
A2LKWP_SOURCE.QP_BLOB Class Reference

KWP QP_BLOB definition smaller v2000 More...

Properties

ushort | BlockModeID [getset]
Block mode: local identifier
uint | CANId [getset]
CAN-Id for EUDTP frames for free running mode
ushort | Discriminator [getset]
discriminator if CAN-id shared for free running mode
ushort | MaxNoOfBytes [getset]
max. no of signals
ushort | MaxNoOfSignals [getset]
max. no of signals
ushort | MaxSamplingRate [getset]
max. sampling rate (+ p3min)
KWP_MEASUREMENT_MODE | MeasuremntMode [getset]
ushort | NoOfSamplings [getset]
No of sampling raster
KWP_PHYSICAL_LAYER | PhysicalLayer [getset]

Detailed Description

KWP QP_BLOB definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_SOURCE
  • QP_BLOB
A2LKWP_SOURCE.QP_BLOB Member List

This is the complete list of members for A2LKWP_SOURCE.QP_BLOB, including all inherited members.

BlockModeID | A2LKWP_SOURCE.QP_BLOB
CANId | A2LKWP_SOURCE.QP_BLOB
Discriminator | A2LKWP_SOURCE.QP_BLOB
MaxNoOfBytes | A2LKWP_SOURCE.QP_BLOB
MaxNoOfSignals | A2LKWP_SOURCE.QP_BLOB
MaxSamplingRate | A2LKWP_SOURCE.QP_BLOB
MeasuremntMode | A2LKWP_SOURCE.QP_BLOB
NoOfSamplings | A2LKWP_SOURCE.QP_BLOB
PhysicalLayer (defined in A2LKWP_SOURCE.QP_BLOB) | A2LKWP_SOURCE.QP_BLOB


ASAP2Library interface: A2LKWP_TIME_DEF Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TIME_DEF
Properties | List of all members
A2LKWP_TIME_DEF Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Properties

KWP_TIME_DEF[] | TimeDefs [getset]
Timing Parameter for KWP greater and equal v2000
KWP_USDTP_TIMING[] | USDTPTimings [getset]
USDTP Timing Parameter
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TIME_DEF
A2LKWP_TIME_DEF Member List

This is the complete list of members for A2LKWP_TIME_DEF, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TimeDefs | A2LKWP_TIME_DEF |
Type | A2LNODE |
USDTPTimings | A2LKWP_TIME_DEF |


ASAP2Library interface: A2LKWP_TP_BLOB Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
Classes | Public Member Functions | Properties | List of all members
A2LKWP_TP_BLOB Class Reference

See ASAP1B_KWP (COMMON_PARAMETERS) More...

Classes

class | BAUD_DEF
KWP Baudrate definition smaller v2000 More...
class | KWP_DATA_ACCESS
DATA ACCESS definition smaller v2000 More...
class | KWP_K_LINE
KLINE definition smaller v2000 More...
class | KWP_SERAM
KWP SERAM definition smaller v2000 More...
class | SECURITY_ACCESS
KWP SERAM definition smaller v2000 More...

Public Member Functions

override string | ToString ()
Returns the string representation. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

BAUD_DEF[] | BAUD_DEFs [getset]
Only valid if version is smaller v2000
BYTEORDER_TYPE | ByteOrder [getset]
KWP_DATA_ACCESS | DATA_ACCESS [getset]
Only valid if version is greater v2000
ushort | ECUAddress [getset]
Only valid if version is smaller v2000
KWP_VERSION | EVersion [getset]
Only valid if version is v2000 or greater
KWP_K_LINE | K_LINE [getset]
Only valid if version is greater v2000
uint | ProjectBaseAdress [getset]
Only valid if version is smaller v2000
SECURITY_ACCESS[] | SECURITY_ACCESSs [getset]
Only valid if version is smaller v2000
KWP_SERAM | SERAM [getset]
Only valid if version is smaller v2000
bool | StartDiagWithoutBdSwitch [getset]
Only valid if version is smaller v2000
KWP_STIMULATION_MODE | StimulationMode [getset]
Only valid if version is smaller v2000
ushort | TesterAddress [getset]
Only valid if version is smaller v2000
KWP_TIME_DEF[] | TIME_DEFs [getset]
Only valid if version is smaller v2000
ushort | Version [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LKWP_NODE
const string | mV10XXValid = "Only valid if version is smaller v2000"
const string | mV20XXValid = "Only valid if version is equal or greater v2000"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP1B_KWP (COMMON_PARAMETERS)

Member Function Documentation

◆ ToString()

override string ToString ( )

Returns the string representation.

Returns


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
A2LKWP_TP_BLOB Member List

This is the complete list of members for A2LKWP_TP_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BAUD_DEFs | A2LKWP_TP_BLOB |
ByteOrder (defined in A2LKWP_TP_BLOB) | A2LKWP_TP_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
DATA_ACCESS | A2LKWP_TP_BLOB |
deleteFromModel(A2LNODE node) | A2LNODE | static
ECUAddress | A2LKWP_TP_BLOB |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EVersion | A2LKWP_TP_BLOB |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
K_LINE | A2LKWP_TP_BLOB |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
mV10XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
mV20XXValid (defined in A2LKWP_NODE) | A2LKWP_NODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ProjectBaseAdress | A2LKWP_TP_BLOB |
SECURITY_ACCESSs | A2LKWP_TP_BLOB |
SERAM | A2LKWP_TP_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartDiagWithoutBdSwitch | A2LKWP_TP_BLOB |
StartLine | A2LNODE |
StimulationMode | A2LKWP_TP_BLOB |
Tag | A2LNODE |
TesterAddress | A2LKWP_TP_BLOB |
TIME_DEFs | A2LKWP_TP_BLOB |
ToString() | A2LKWP_TP_BLOB |
Type | A2LNODE |
Version (defined in A2LKWP_TP_BLOB) | A2LKWP_TP_BLOB |


ASAP2Library interface: A2LKWP_TP_BLOB.BAUD_DEF Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • BAUD_DEF
Properties | List of all members
A2LKWP_TP_BLOB.BAUD_DEF Class Reference

KWP Baudrate definition smaller v2000 More...

Properties

uint | BaudRate [getset]
Baud rate
ushort | DiagMode [getset]
Diag mode
uint | ik [getset]
i,k for ECU baudrate

Detailed Description

KWP Baudrate definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • BAUD_DEF
A2LKWP_TP_BLOB.BAUD_DEF Member List

This is the complete list of members for A2LKWP_TP_BLOB.BAUD_DEF, including all inherited members.

BaudRate | A2LKWP_TP_BLOB.BAUD_DEF
DiagMode | A2LKWP_TP_BLOB.BAUD_DEF
ik | A2LKWP_TP_BLOB.BAUD_DEF


ASAP2Library interface: A2LKWP_TP_BLOB.KWP_DATA_ACCESS Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_DATA_ACCESS
Properties | List of all members
A2LKWP_TP_BLOB.KWP_DATA_ACCESS Class Reference

DATA ACCESS definition smaller v2000 More...

Properties

uint | AdrFLASH [getset]
ECU address type qualifier for Flash page
uint | AdrRAM [getset]
ECU address type qualifier for RAM page
KWP_DATA_ACCESS_FLAGS | Flags [getset]
Data access flags

Detailed Description

DATA ACCESS definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_DATA_ACCESS
A2LKWP_TP_BLOB.KWP_DATA_ACCESS Member List

This is the complete list of members for A2LKWP_TP_BLOB.KWP_DATA_ACCESS, including all inherited members.

AdrFLASH | A2LKWP_TP_BLOB.KWP_DATA_ACCESS
AdrRAM | A2LKWP_TP_BLOB.KWP_DATA_ACCESS
Flags | A2LKWP_TP_BLOB.KWP_DATA_ACCESS


ASAP2Library interface: A2LKWP_TP_BLOB.KWP_K_LINE Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_K_LINE
Properties | List of all members
A2LKWP_TP_BLOB.KWP_K_LINE Class Reference

KLINE definition smaller v2000 More...

Properties

ushort | ECUAddress [getset]
KWP_STIMULATION_MODE | StimulationMode [getset]
ushort | TesterAddress [getset]

Detailed Description

KLINE definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_K_LINE
A2LKWP_TP_BLOB.KWP_K_LINE Member List

This is the complete list of members for A2LKWP_TP_BLOB.KWP_K_LINE, including all inherited members.

ECUAddress (defined in A2LKWP_TP_BLOB.KWP_K_LINE) | A2LKWP_TP_BLOB.KWP_K_LINE
StimulationMode (defined in A2LKWP_TP_BLOB.KWP_K_LINE) | A2LKWP_TP_BLOB.KWP_K_LINE
TesterAddress (defined in A2LKWP_TP_BLOB.KWP_K_LINE) | A2LKWP_TP_BLOB.KWP_K_LINE


ASAP2Library interface: A2LKWP_TP_BLOB.KWP_SERAM Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_SERAM
Properties | List of all members
A2LKWP_TP_BLOB.KWP_SERAM Class Reference

KWP SERAM definition smaller v2000 More...

Properties

uint | A [getset]
RAM begin
uint | AdrFLASH [getset]
ECU address type qualifier for Flash page
uint | AdrRAM [getset]
ECU address type qualifier for Flash page
uint | E [getset]
RAM end
KWP_DATA_ACCESS_FLAGS | Flags [getset]
Data access flags
uint | O [getset]
RAM end
uint | U [getset]
RAM begin

Detailed Description

KWP SERAM definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • KWP_SERAM
A2LKWP_TP_BLOB.KWP_SERAM Member List

This is the complete list of members for A2LKWP_TP_BLOB.KWP_SERAM, including all inherited members.

A | A2LKWP_TP_BLOB.KWP_SERAM
AdrFLASH | A2LKWP_TP_BLOB.KWP_SERAM
AdrRAM | A2LKWP_TP_BLOB.KWP_SERAM
E | A2LKWP_TP_BLOB.KWP_SERAM
Flags | A2LKWP_TP_BLOB.KWP_SERAM
O | A2LKWP_TP_BLOB.KWP_SERAM
U | A2LKWP_TP_BLOB.KWP_SERAM


ASAP2Library interface: A2LKWP_TP_BLOB.SECURITY_ACCESS Class Reference

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • SECURITY_ACCESS
Properties | List of all members
A2LKWP_TP_BLOB.SECURITY_ACCESS Class Reference

KWP SERAM definition smaller v2000 More...

Properties

ushort | AccessMode [getset]
Access mode for KWP2000 service 27h
ushort | CalcMode [getset]
method of seed&key calculation
ushort | Delaytime [getset]
delaytime in sec from stimulation to seed request

Detailed Description

KWP SERAM definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • A2LKWP_TP_BLOB
  • SECURITY_ACCESS
A2LKWP_TP_BLOB.SECURITY_ACCESS Member List

This is the complete list of members for A2LKWP_TP_BLOB.SECURITY_ACCESS, including all inherited members.

AccessMode | A2LKWP_TP_BLOB.SECURITY_ACCESS
CalcMode | A2LKWP_TP_BLOB.SECURITY_ACCESS
Delaytime | A2LKWP_TP_BLOB.SECURITY_ACCESS


ASAP2Library interface: KWP_TIME_DEF Class Reference

  • ASAP2
  • KWP
  • KWP_TIME_DEF
Properties | List of all members
KWP_TIME_DEF Class Reference

Timing definition smaller v2000 More...

Properties

ushort | p1Max [getset]
p1MAx in [ms]
ushort | p2Max [getset]
p2Max in [ms]
ushort | p2Min [getset]
p2Min in [ms]
ushort | p3Max [getset]
p3Max in [ms]
ushort | p3Min [getset]
p3Min in [ms]
ushort | p4Min [getset]
p4Min in [ms]

Detailed Description

Timing definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • KWP_TIME_DEF
KWP_TIME_DEF Member List

This is the complete list of members for KWP_TIME_DEF, including all inherited members.

p1Max | KWP_TIME_DEF
p2Max | KWP_TIME_DEF
p2Min | KWP_TIME_DEF
p3Max | KWP_TIME_DEF
p3Min | KWP_TIME_DEF
p4Min | KWP_TIME_DEF


ASAP2Library interface: KWP_USDTP_TIMING Class Reference

  • ASAP2
  • KWP
  • KWP_USDTP_TIMING
Properties | List of all members
KWP_USDTP_TIMING Class Reference

Timing definition smaller v2000 More...

Properties

ushort | AS [getset]
As [ms]
ushort | BS [getset]
Bs [ms]
ushort | CD [getset]
Cr [ms]

Detailed Description

Timing definition smaller v2000


ASAP2Library interface: Member List

  • ASAP2
  • KWP
  • KWP_USDTP_TIMING
KWP_USDTP_TIMING Member List

This is the complete list of members for KWP_USDTP_TIMING, including all inherited members.

AS | KWP_USDTP_TIMING
BS | KWP_USDTP_TIMING
CD | KWP_USDTP_TIMING


ASAP2Library interface: jnsoft.ASAP2.Values Namespace Reference

  • ASAP2
  • Values
Namespaces | Classes | Enumerations
jnsoft.ASAP2.Values Namespace Reference

Defines and implements stuff for reading, writing and modifying characteristic values. More...

Namespaces

namespace CDF
Contains the classes mapping the Calibration Data Format (XML).

Classes

class | ASCIIValue
Class representing a characteristic CHAR_TYPE.ASCII value. More...
class | BaseValue
Base class for a characteristic value representation. More...
class | CDFFile
Implements the Calibration Data File format reader/writer. More...
class | CharacteristicValue
Creates a value representation for the different characteristic value types. More...
class | Cube4Value
Class representing a characteristic CHAR_TYPE.CUBE_4 value. More...
class | Cube5Value
Class representing a characteristic CHAR_TYPE.CUBE_5 value. More...
class | CuboidValue
Class representing a characteristic CHAR_TYPE.CUBOID value. More...
class | CurveValue
Class representing a characteristic CHAR_TYPE.CURVE value. More...
class | DataConservation
Base class for any import and export calibration data file formats More...
class | DataFile
Base class for reading/writing S19 and HEX files. More...
class | DataFileBin
Class for reading/writing binary data files. More...
class | DataFileBinDlg
Dialog to get a start address for a data binary file. More...
class | DataFileHex
Class for reading/writing Intel HEX files. More...
class | DataFileS19
Class for reading/writing Motorola S files. More...
class | DCMFile
Implements the ETAS INCA DCM file format 2.x reader/writer. More...
class | MapValue
Class representing a characteristic CHAR_TYPE.MAP value. More...
class | MatlabFile
Implements the Matlab (*.m) file format reader/writer. More...
class | MeasurementAccessData
Manages static memory data for A2LMEASUREMENTs. More...
class | PARFile
Implements the CANape PAR data File format reader/writer. More...
class | SingleValue
Class representing a characteristic CHAR_TYPE.VALUE value. More...
class | ValBlkValue
Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value. More...

Enumerations

enum | DataFileType { IntelHex , MotorolaS , Binary }
Defines the supported data file types. More...
enum | MotorolaFileType { NotSet = 0 , _4Byte = 3 , _3Byte = 2 , _2Byte = 1 }
Possible Motorola file format types. More...

Detailed Description

Defines and implements stuff for reading, writing and modifying characteristic values.

Enumeration Type Documentation

◆ DataFileType

enum DataFileType

Defines the supported data file types.

Enumerator
IntelHex | Intel HEX file format.
MotorolaS | Motorola S-REC file format.
Binary | Binary file format.

◆ MotorolaFileType

enum MotorolaFileType

Possible Motorola file format types.

Enumerator
NotSet | Not set (write format as read from source file).
_4Byte | Record address type is 4 bytes.
_3Byte | Record address type is 3 bytes.
_2Byte | Record address type is 2 bytes.


ASAP2Library interface: jnsoft.ASAP2.Values.CDF Namespace Reference

  • ASAP2
  • Values
  • CDF
Classes
jnsoft.ASAP2.Values.CDF Namespace Reference

Contains the classes mapping the Calibration Data Format (XML). More...

Classes

class | MSRSW
The root element of the file. More...
class | SWAXISCONT
Physical axis values. More...
class | SWINSTANCE
Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF. More...
struct | SWINSTANCESPEC
The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items. More...
class | SWINSTANCETREE
Receives one particular set of calibration items. More...
class | SWSYSTEM
Describes one particular system within the current file. More...
class | SWVALUECONT
Physical values. More...
class | VG
Holds double, text or group values. More...

Detailed Description

Contains the classes mapping the Calibration Data Format (XML).


ASAP2Library interface: MSRSW Class Reference

  • ASAP2
  • Values
  • CDF
  • MSRSW
Public Attributes | List of all members
MSRSW Class Reference

The root element of the file. More...

Public Attributes

string | CATEGORY
string | CREATOR
string | CREATORVERSION
string | INTRODUCTION
string | SHORTNAME
List< SWSYSTEM > | SWSYSTEMS

Detailed Description

The root element of the file.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • MSRSW
MSRSW Member List

This is the complete list of members for MSRSW, including all inherited members.

CATEGORY (defined in MSRSW) | MSRSW
CREATOR (defined in MSRSW) | MSRSW
CREATORVERSION (defined in MSRSW) | MSRSW
INTRODUCTION (defined in MSRSW) | MSRSW
MSRSW() (defined in MSRSW) | MSRSW
SHORTNAME (defined in MSRSW) | MSRSW
SWSYSTEMS (defined in MSRSW) | MSRSW


ASAP2Library interface: SWAXISCONT Class Reference

  • ASAP2
  • Values
  • CDF
  • SWAXISCONT
Public Attributes | List of all members
SWAXISCONT Class Reference

Physical axis values. More...

Public Attributes

string | CATEGORY
int[] | SWARRAYSIZE
string | SWINSTANCEREF
string | UNITDISPLAYNAME
object[] | Vs

Detailed Description

Physical axis values.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWAXISCONT
SWAXISCONT Member List

This is the complete list of members for SWAXISCONT, including all inherited members.

CATEGORY (defined in SWAXISCONT) | SWAXISCONT
SWARRAYSIZE (defined in SWAXISCONT) | SWAXISCONT
SWAXISCONT() (defined in SWAXISCONT) | SWAXISCONT
SWINSTANCEREF (defined in SWAXISCONT) | SWAXISCONT
UNITDISPLAYNAME (defined in SWAXISCONT) | SWAXISCONT
Vs (defined in SWAXISCONT) | SWAXISCONT


ASAP2Library interface: SWINSTANCE Class Reference

  • ASAP2
  • Values
  • CDF
  • SWINSTANCE
Public Member Functions | Public Attributes | List of all members
SWINSTANCE Class Reference

Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF. More...

Public Member Functions

SWINSTANCE (string shortname, string category, SWVALUECONT valueCont)

Public Attributes

string | CATEGORY
string | LONGNAME
string | SHORTNAME
SWAXISCONT[] | SWAXISCONTS
string | SWFEATUREREF
SWVALUECONT | SWVALUECONT

Detailed Description

Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWINSTANCE
SWINSTANCE Member List

This is the complete list of members for SWINSTANCE, including all inherited members.

CATEGORY (defined in SWINSTANCE) | SWINSTANCE
LONGNAME (defined in SWINSTANCE) | SWINSTANCE
SHORTNAME (defined in SWINSTANCE) | SWINSTANCE
SWAXISCONTS (defined in SWINSTANCE) | SWINSTANCE
SWFEATUREREF (defined in SWINSTANCE) | SWINSTANCE
SWINSTANCE() (defined in SWINSTANCE) | SWINSTANCE
SWINSTANCE(string shortname, string category, SWVALUECONT valueCont) (defined in SWINSTANCE) | SWINSTANCE
SWVALUECONT (defined in SWINSTANCE) | SWINSTANCE


ASAP2Library interface: SWINSTANCESPEC Struct Reference

  • ASAP2
  • Values
  • CDF
  • SWINSTANCESPEC
Public Attributes | List of all members
SWINSTANCESPEC Struct Reference

The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items. More...

Public Attributes

List< SWINSTANCETREE > SWINSTANCETREEs

Detailed Description

The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWINSTANCESPEC
SWINSTANCESPEC Member List

This is the complete list of members for SWINSTANCESPEC, including all inherited members.

SWINSTANCETREEs (defined in SWINSTANCESPEC) SWINSTANCESPEC


ASAP2Library interface: SWINSTANCETREE Class Reference

  • ASAP2
  • Values
  • CDF
  • SWINSTANCETREE
Public Member Functions | Public Attributes | List of all members
SWINSTANCETREE Class Reference

Receives one particular set of calibration items. More...

Public Member Functions

SWINSTANCETREE (string shortName, string category, SWINSTANCETREEORIGIN origin, List< SWCSCOLLECTION > csColl, List< SWINSTANCE > instances)

Public Attributes

string | CATEGORY
string | SHORTNAME
List< SWCSCOLLECTION > | SWCSCOLLECTIONS
List< SWINSTANCE > | SWINSTANCEs
SWINSTANCETREEORIGIN | SWINSTANCETREEORIGIN

Detailed Description

Receives one particular set of calibration items.

Therefore it corresponds to CAL-LIST within CDF specification.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWINSTANCETREE
SWINSTANCETREE Member List

This is the complete list of members for SWINSTANCETREE, including all inherited members.

CATEGORY (defined in SWINSTANCETREE) | SWINSTANCETREE
SHORTNAME (defined in SWINSTANCETREE) | SWINSTANCETREE
SWCSCOLLECTIONS (defined in SWINSTANCETREE) | SWINSTANCETREE
SWINSTANCEs (defined in SWINSTANCETREE) | SWINSTANCETREE
SWINSTANCETREE() (defined in SWINSTANCETREE) | SWINSTANCETREE
SWINSTANCETREE(string shortName, string category, SWINSTANCETREEORIGIN origin, List< SWCSCOLLECTION > csColl, List< SWINSTANCE > instances) (defined in SWINSTANCETREE) | SWINSTANCETREE
SWINSTANCETREEORIGIN (defined in SWINSTANCETREE) | SWINSTANCETREE


ASAP2Library interface: SWSYSTEM Class Reference

  • ASAP2
  • Values
  • CDF
  • SWSYSTEM
Public Member Functions | Public Attributes | List of all members
SWSYSTEM Class Reference

Describes one particular system within the current file. More...

Public Member Functions

SWSYSTEM (SWINSTANCESPEC spec)

Public Attributes

string | SHORTNAME
SWINSTANCESPEC | SWINSTANCESPEC

Detailed Description

Describes one particular system within the current file.

This supports to transfer the calibration data of multi ecu systems within one file.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWSYSTEM
SWSYSTEM Member List

This is the complete list of members for SWSYSTEM, including all inherited members.

SHORTNAME (defined in SWSYSTEM) | SWSYSTEM
SWINSTANCESPEC (defined in SWSYSTEM) | SWSYSTEM
SWSYSTEM() (defined in SWSYSTEM) | SWSYSTEM
SWSYSTEM(SWINSTANCESPEC spec) (defined in SWSYSTEM) | SWSYSTEM


ASAP2Library interface: SWVALUECONT Class Reference

  • ASAP2
  • Values
  • CDF
  • SWVALUECONT
Public Attributes | List of all members
SWVALUECONT Class Reference

Physical values. More...

Public Attributes

int[] | SWARRAYSIZE
string | UNITDISPLAYNAME
object[] | Vs

Detailed Description

Physical values.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • SWVALUECONT
SWVALUECONT Member List

This is the complete list of members for SWVALUECONT, including all inherited members.

SWARRAYSIZE (defined in SWVALUECONT) | SWVALUECONT
SWVALUECONT() (defined in SWVALUECONT) | SWVALUECONT
UNITDISPLAYNAME (defined in SWVALUECONT) | SWVALUECONT
Vs (defined in SWVALUECONT) | SWVALUECONT


ASAP2Library interface: VG Class Reference

  • ASAP2
  • Values
  • CDF
  • VG
Public Member Functions | Public Attributes | List of all members
VG Class Reference

Holds double, text or group values. More...

Public Member Functions

VG (string label, object[] vs)

Public Attributes

string | LABEL
object[] | Vs

Detailed Description

Holds double, text or group values.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDF
  • VG
VG Member List

This is the complete list of members for VG, including all inherited members.

LABEL (defined in VG) | VG
VG() (defined in VG) | VG
VG(string label, object[] vs) (defined in VG) | VG
Vs (defined in VG) | VG


ASAP2Library interface: jnsoft.ASAP2.Values.Examples Namespace Reference

  • ASAP2
  • Values
  • Examples
Classes
jnsoft.ASAP2.Values.Examples Namespace Reference

Classes

class Program
Demo console application. More...


ASAP2Library interface: Program Class Reference

  • ASAP2
  • Values
  • Examples
  • Program
List of all members
Program Class Reference

Demo console application. More...

Detailed Description

Demo console application.

Merge data example.

  • Loading an A2L and it's corresponding datafile (.hex or .s19)
  • Do an EPK check on the datafile
  • Iterate over any characteristics and print and modify out values
  • save the changed data file

Usage: ASAP2AdjustDataExample A2LFile.a2l DataFile.hex|.s19 Prerequisites: A valid A2L file, and a corresponding data file (hex/s19)

  • Loading an A2L and it's corresponding datafile (HEX or S19)
  • Merging an INCA DCM file (.dcm)
  • Save the changed data file

Usage: ASAP2MergeDataExample A2LFile.a2l DataFileIn.hex|.s19 ImportDataFile.DCM


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: ASCIIValue Class Reference

  • ASAP2
  • Values
  • ASCIIValue
Public Member Functions | List of all members
ASCIIValue Class Reference

Class representing a characteristic CHAR_TYPE.ASCII value. More...

Public Member Functions

ASCIIValue ()
Default constructor
ASCIIValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Additional Inherited Members

- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.ASCII value.

The ICharValue.Value in this case is of type string.

Constructor & Destructor Documentation

◆ ASCIIValue()

ASCIIValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • ASCIIValue
ASCIIValue Member List

This is the complete list of members for ASCIIValue, including all inherited members.

ASCIIValue() | ASCIIValue |
ASCIIValue(A2LRECORD_LAYOUT_REF characteristic) | ASCIIValue |
BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() | BaseValue |


ASAP2Library interface: BaseValue Class Reference

  • ASAP2
  • Values
  • BaseValue
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
BaseValue Class Reference

Base class for a characteristic value representation. More...

Public Member Functions

BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Protected Attributes

double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat

Additional Inherited Members

- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Base class for a characteristic value representation.

Constructor & Destructor Documentation

◆ BaseValue()

BaseValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ CompareTo()

int CompareTo ( ICharValue other )

Comparable interface implementation for single numerical values.

Parameters
other The value to compare to
Returns
see IComparer.Compare

◆ GetFncValuesEnumerator()

IEnumerable< double > GetFncValuesEnumerator ( )

Gets a function values enumerator.

Returns
An iterator iterating over all function values

Implements ICharValue.

◆ getNextValue()

double getNextValue | ( | bool | increment,
 |  | double | value,
 |  | DATA_TYPE | dt,
 |  | A2LCOMPU_METHOD | compuMethod
 | ) |  |
protected

Gets the next value near to the specified value (by incrementing or decrementing).

This method is used for TAB_VERB and TAB_NOINTP values.

Parameters
increment | true for increment, false for decrement
value | The raw or physical value
dt | The raw data type of the value
compuMethod | The compu method of the value
Returns
The next valid value by increment or decrement based on the count of decimal places
Exceptions
ArgumentException Thrown, if the compuMethod is of not of type CONVERSION_TYTPE.TAB_NOINTP or CONVERSION_TYTPE.TAB_VERB

◆ incrementOrDecrement() [1/2]

virtual bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented in ValBlkValue, CurveValue, MapValue, and CuboidValue.

◆ incrementOrDecrement() [2/2]

virtual bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a single value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented in SingleValue.

◆ incrementOrDecrement< T >() [1/3]

bool incrementOrDecrement< T > | ( | T | value[,,],
 |  | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |
protected
Type Constraints
T : struct

◆ incrementOrDecrement< T >() [2/3]

bool incrementOrDecrement< T > | ( | T | value[,],
 |  | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |
protected
Type Constraints
T : struct

◆ incrementOrDecrement< T >() [3/3]

bool incrementOrDecrement< T > | ( | T[] | value,
 |  | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |
protected
Type Constraints
T : struct

◆ ToString()

override string ToString ( )

Gets a string representation of the value.

Returns


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • BaseValue
BaseValue Member List

This is the complete list of members for BaseValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() | BaseValue |


ASAP2Library interface: CDFFile Class Reference

  • ASAP2
  • Values
  • CDFFile
Static Public Member Functions | List of all members
CDFFile Class Reference

Implements the Calibration Data File format reader/writer. More...

Static Public Member Functions

static DataConservation | open (Stream stream, A2LMODULE module)
Opens a CDF file and returns a CDFFile instance. More...
static DataConservation | open (string path, A2LMODULE module)
Opens a CDF file and returns a CDFFile instance. More...
static int | save (string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, bool addParameterDesc)
Saves all characteristics of the module into a CDF file. More...
static int | save (string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, bool addParameterDesc)
Saves the specified characteristics into a CDF file. More...
static int | save (string path, string description, string a2LSource, string dataSource, IList< ICharValue > values, IEnumerable< A2LFUNCTION > functions, bool addParameterDesc)
Saves the specified characteristics into a CDF file. More...

Additional Inherited Members

- Public Types inherited from DataConservation
enum ErrorType {
NotFound , NotSupported , Format , TypeDiffers ,
NoOfElementsDiffers , XAxisInvalid , YAxisInvalid , ZAxisInvalid
}
- Public Attributes inherited from DataConservation
IList< Tuple< string, ErrorType > > | SkippedValues = new List<Tuple<string, ErrorType>>()
Gets the list of skipped values from the parameter file.
- Static Protected Member Functions inherited from DataConservation
static string | buildDescription (A2LMODULE module, string description)
static int | checkAxis (A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize)
static void | getAxisDescription (A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis)
Gets axis descriptions from the specified characteristic. More...
static double | getValue (string par)
- Static Protected Attributes inherited from DataConservation
static readonly string | mEOL = Environment.NewLine
- Properties inherited from DataConservation
IList< ICharValue > | Values = new List<ICharValue>() [get]
Gets the list of succesfully imported values from the parameter file.

Detailed Description

Implements the Calibration Data File format reader/writer.

Member Function Documentation

◆ open() [1/2]

static DataConservation open | ( | Stream | stream,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a CDF file and returns a CDFFile instance.

Parameters
stream | stream to read from
module | The module to read the characteristics from
Returns
A new CDFFile instance or null if failed

◆ open() [2/2]

static DataConservation open | ( | string | path,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a CDF file and returns a CDFFile instance.

Parameters
path | the fully qualified CDF filename
module | The module to read the characteristics from
Returns
A new CDFFile instance or null if failed

◆ save() [1/3]

static int save | ( | string | a2LSource,
 |  | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves all characteristics of the module into a CDF file.

Parameters
a2LSource | The source A2L file (may be null or empty)
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
addParameterDesc | Add parameter descriptions as LONG-NAME
Returns
count of written characteristics, -1 if failed

◆ save() [2/3]

static int save | ( | string | a2LSource,
 |  | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | IEnumerable< A2LCHARACTERISTIC > | characteristics,
 |  | bool | exportFunctions,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves the specified characteristics into a CDF file.

Parameters
a2LSource | The source A2L file (may be null or empty)
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
characteristics | The characteristics to save
exportFunctions | true if functions should be exported, too
addParameterDesc | Add parameter descriptions as LONG-NAME
Returns
count of written characteristics, -1 if failed

◆ save() [3/3]

static int save | ( | string | path,
 |  | string | description,
 |  | string | a2LSource,
 |  | string | dataSource,
 |  | IList< ICharValue > | values,
 |  | IEnumerable< A2LFUNCTION > | functions,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves the specified characteristics into a CDF file.

Parameters
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
a2LSource | The source A2L file (may be null or empty)
dataSource | The source data file (may be null or empty)
values | The values to save into the CDF file
functions | Functions to save into the CDF file (may be null or empty)
addParameterDesc | Add parameter descriptions as LONG-NAME
Returns
count of written characteristics, -1 if failed


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CDFFile
CDFFile Member List

This is the complete list of members for CDFFile, including all inherited members.

buildDescription(A2LMODULE module, string description) (defined in DataConservation) | DataConservation | protectedstatic
checkAxis(A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize) (defined in DataConservation) | DataConservation | protectedstatic
ErrorType enum name (defined in DataConservation) | DataConservation |
getAxisDescription(A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis) | DataConservation | protectedstatic
getValue(string par) (defined in DataConservation) | DataConservation | protectedstatic
mEOL (defined in DataConservation) | DataConservation | protectedstatic
open(string path, A2LMODULE module) | CDFFile | static
open(Stream stream, A2LMODULE module) | CDFFile | static
save(string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, bool addParameterDesc) | CDFFile | static
save(string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, bool addParameterDesc) | CDFFile | static
save(string path, string description, string a2LSource, string dataSource, IList< ICharValue > values, IEnumerable< A2LFUNCTION > functions, bool addParameterDesc) | CDFFile | static
SkippedValues | DataConservation |
Values | DataConservation |


ASAP2Library interface: CharacteristicValue Class Reference

  • ASAP2
  • Values
  • CharacteristicValue
Static Public Member Functions | List of all members
CharacteristicValue Class Reference

Creates a value representation for the different characteristic value types. More...

Static Public Member Functions

static ICharValue | createValue (IDataFile dataFile, A2LRECORD_LAYOUT_REF recordLayoutRef, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null)
Creates characteristic values according the specified characteristic from the given data file. More...
static T | getValue< T > (IDataFile dataFile, A2LAXIS_PTS axisPts, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null)
Creates a value representation for the specified A2LAXIS_PTS. More...
static T | getValue< T > (IDataFile dataFile, A2LCHARACTERISTIC characteristic, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null)
Creates a value representation for the specified A2LCHARACTERISTIC. More...
static double | modifyAddFunc (double originalValue, double value, bool treatValueAsPercent)
Modifies the value by adding a value. More...
static double | modifyDivFunc (double originalValue, double value, bool treatValueAsPercent)
Modifies the value by dividing with a value. More...
static double | modifyInvFunc (double originalValue, A2LRECORD_LAYOUT_REF layoutRef)
Inverts the original value. More...
static double | modifyMulFunc (double originalValue, double value, bool treatValueAsPercent)
Modifies the value by multiplying with a value. More...
static double | modifySetFunc (double originalValue, double value, bool treatValueAsPercent)
Modifies the value by simply setting a new value. More...
static double | modifySubFunc (double originalValue, double value, bool treatValueAsPercent)
Modifies the value by subtracting a value. More...
static bool | setValue (IDataFile dataFile, ICharValue value, IList< string > criterionValues=null)
Write the specified value in to the data file. More...

Detailed Description

Creates a value representation for the different characteristic value types.

  • Provides setValue and getValue to read/write data from/to byte streams.
  • Supported characteristic types: A2LCHARACTERISTIC (Value, ASCII, Value block, Curve, Map) and A2LAXIS_PTS
  • Not supported characteristic types: A2LCHARACTERISTIC (Cuboid, Cube_4, Cube_5)

Member Function Documentation

◆ createValue()

static ICharValue createValue | ( | IDataFile | dataFile,
 |  | A2LRECORD_LAYOUT_REF | recordLayoutRef,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | IList< string > | criterionValues = null
 | ) |  |
static

Creates characteristic values according the specified characteristic from the given data file.

Parameters
dataFile | The datafile to read from
recordLayoutRef | The corresponding characteristic to get the value for
format | The value format to create
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
The ICharValue instance

◆ getValue< T >() [1/2]

static T getValue< T > | ( | IDataFile | dataFile,
 |  | A2LAXIS_PTS | axisPts,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | IList< string > | criterionValues = null
 | ) |  |
static

Creates a value representation for the specified A2LAXIS_PTS.

Example code: Create a physical value representation for any A2LAXIS_PTS value within the project and store this on the characteristic's A2LNODE.Tag property.

var enAxisPts = mA2lParser.Project.AxisPtsDict.GetEnumerator();
while (enAxisPts.MoveNext())
{
var axisPts = enAxisPts.Current.Value;
var value = CharacteristicValue.getValue<ValBlkValue>(axisPts
, ValueObjectFormat.Physical
);
axisPts.Tag = value;
}
jnsoft.Helpers.ValueObjectFormat
ValueObjectFormat
Possible value object formats.
Definition: Helpers.cs:1418
Template Parameters
T The value type to create (in this case the ValBlkValue type)
Parameters
dataFile | The datafile to read from
axisPts | The source characteristic
format | The data format to create
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
a ValBlkValue instance
Exceptions
ArgumentException Thrown if T is not a ValBlkValue type
Type Constraints
T : ICharValue
T : new()

◆ getValue< T >() [2/2]

static T getValue< T > | ( | IDataFile | dataFile,
 |  | A2LCHARACTERISTIC | characteristic,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | IList< string > | criterionValues = null
 | ) |  |
static

Creates a value representation for the specified A2LCHARACTERISTIC.

Example code: Create a physical value representation for any characteristic single value type within the project and store this on the A2LNODE.Tag property.

var en = mA2lParser.Project.CharDict.GetEnumerator();
while (en.MoveNext())
{
var characteristic = en.Current.Value;
switch (characteristic.CharType)
{
case CHAR_TYPE.VALUE:
var value = CharacteristicValue.getValue<SingleValue>(characteristic
, ValueObjectFormat.Physical
);
characteristic.Tag = value;
break;
}
}
jnsoft.ASAP2.CHAR_TYPE
CHAR_TYPE
Possible characteristic types
Definition: ASAP2Base.cs:620
Template Parameters
T The value type to create (Depending on the characteristic's type, this must be a ICharValue derived class)
Parameters
dataFile | The datafile to read from
characteristic | The source characteristic
format | The value format to create
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
An ICharValue instance according the specified characteristic type
Exceptions
ArgumentException Thrown if the specified type doesn't fit to the characteristic's type
Type Constraints
T : ICharValue
T : new()

◆ modifyAddFunc()

static double modifyAddFunc | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |
static

Modifies the value by adding a value.

Parameters
originalValue | The original value
value | The new value to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value

◆ modifyDivFunc()

static double modifyDivFunc | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |
static

Modifies the value by dividing with a value.

Parameters
originalValue | The original value
value | The new value to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value

◆ modifyInvFunc()

static double modifyInvFunc | ( | double | originalValue,
 |  | A2LRECORD_LAYOUT_REF | layoutRef
 | ) |  |
static

Inverts the original value.

Parameters
originalValue | The original value
layoutRef | The corresponding characteristic
Returns
The resulting value

◆ modifyMulFunc()

static double modifyMulFunc | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |
static

Modifies the value by multiplying with a value.

Parameters
originalValue | The original value
value | The new value to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value

◆ modifySetFunc()

static double modifySetFunc | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |
static

Modifies the value by simply setting a new value.

Parameters
originalValue | The original value
value | The new value to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value

◆ modifySubFunc()

static double modifySubFunc | ( | double | originalValue,
 |  | double | value,
 |  | bool | treatValueAsPercent
 | ) |  |
static

Modifies the value by subtracting a value.

Parameters
originalValue | The original value
value | The new value to modify the original value with
treatValueAsPercent | true, if the value should be treated as percentage
Returns
The resulting value

◆ setValue()

static bool setValue | ( | IDataFile | dataFile,
 |  | ICharValue | value,
 |  | IList< string > | criterionValues = null
 | ) |  |
static

Write the specified value in to the data file.

Parameters
dataFile | The data file to write the value to
value | The value to write
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CharacteristicValue
CharacteristicValue Member List

This is the complete list of members for CharacteristicValue, including all inherited members.

createValue(IDataFile dataFile, A2LRECORD_LAYOUT_REF recordLayoutRef, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null) | CharacteristicValue | static
getValue< T >(IDataFile dataFile, A2LAXIS_PTS axisPts, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null) | CharacteristicValue | static
getValue< T >(IDataFile dataFile, A2LCHARACTERISTIC characteristic, ValueObjectFormat format=ValueObjectFormat.Physical, IList< string > criterionValues=null) | CharacteristicValue | static
modifyAddFunc(double originalValue, double value, bool treatValueAsPercent) | CharacteristicValue | static
modifyDivFunc(double originalValue, double value, bool treatValueAsPercent) | CharacteristicValue | static
modifyInvFunc(double originalValue, A2LRECORD_LAYOUT_REF layoutRef) | CharacteristicValue | static
modifyMulFunc(double originalValue, double value, bool treatValueAsPercent) | CharacteristicValue | static
modifySetFunc(double originalValue, double value, bool treatValueAsPercent) | CharacteristicValue | static
modifySubFunc(double originalValue, double value, bool treatValueAsPercent) | CharacteristicValue | static
setValue(IDataFile dataFile, ICharValue value, IList< string > criterionValues=null) | CharacteristicValue | static


ASAP2Library interface: Cube4Value Class Reference

  • ASAP2
  • Values
  • Cube4Value
Public Member Functions | List of all members
Cube4Value Class Reference

Class representing a characteristic CHAR_TYPE.CUBE_4 value. More...

Public Member Functions

Cube4Value ()
Default constructor
Cube4Value (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Additional Inherited Members

- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.CUBE_4 value.

The ICharValue.Value in this case is of type double[,,,].

Constructor & Destructor Documentation

◆ Cube4Value()

Cube4Value ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • Cube4Value
Cube4Value Member List

This is the complete list of members for Cube4Value, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
Cube4Value() | Cube4Value |
Cube4Value(A2LRECORD_LAYOUT_REF characteristic) | Cube4Value |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in Cube4Value) | Cube4Value |


ASAP2Library interface: Cube5Value Class Reference

  • ASAP2
  • Values
  • Cube5Value
Public Member Functions | List of all members
Cube5Value Class Reference

Class representing a characteristic CHAR_TYPE.CUBE_5 value. More...

Public Member Functions

Cube5Value ()
Default constructor
Cube5Value (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Additional Inherited Members

- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.CUBE_5 value.

The ICharValue.Value in this case is of type double[,,,,].

Constructor & Destructor Documentation

◆ Cube5Value()

Cube5Value ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • Cube5Value
Cube5Value Member List

This is the complete list of members for Cube5Value, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
Cube5Value() | Cube5Value |
Cube5Value(A2LRECORD_LAYOUT_REF characteristic) | Cube5Value |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in Cube5Value) | Cube5Value |


ASAP2Library interface: CuboidValue Class Reference

  • ASAP2
  • Values
  • CuboidValue
Public Member Functions | Protected Member Functions | List of all members
CuboidValue Class Reference

Class representing a characteristic CHAR_TYPE.CUBOID value. More...

Public Member Functions

CuboidValue ()
Default constructor
CuboidValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

override bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Additional Inherited Members

- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.CUBOID value.

The ICharValue.Value in this case is of type double[,,].

Constructor & Destructor Documentation

◆ CuboidValue()

CuboidValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ incrementOrDecrement()

override bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented from BaseValue.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CuboidValue
CuboidValue Member List

This is the complete list of members for CuboidValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
CuboidValue() | CuboidValue |
CuboidValue(A2LRECORD_LAYOUT_REF characteristic) | CuboidValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | CuboidValue | protectedvirtual
jnsoft::ASAP2::Values::BaseValue.incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in CuboidValue) | CuboidValue |


ASAP2Library interface: CurveValue Class Reference

  • ASAP2
  • Values
  • CurveValue
Public Member Functions | Protected Member Functions | List of all members
CurveValue Class Reference

Class representing a characteristic CHAR_TYPE.CURVE value. More...

Public Member Functions

CurveValue ()
Default constructor
CurveValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

override bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Additional Inherited Members

- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.CURVE value.

The ICharValue.Value in this case is of type double[].

Constructor & Destructor Documentation

◆ CurveValue()

CurveValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ incrementOrDecrement()

override bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented from BaseValue.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • CurveValue
CurveValue Member List

This is the complete list of members for CurveValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
CurveValue() | CurveValue |
CurveValue(A2LRECORD_LAYOUT_REF characteristic) | CurveValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | CurveValue | protectedvirtual
jnsoft::ASAP2::Values::BaseValue.incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in CurveValue) | CurveValue |


ASAP2Library interface: DataConservation Class Reference

  • ASAP2
  • Values
  • DataConservation
Public Types | Public Attributes | Static Protected Member Functions | Static Protected Attributes | Properties | List of all members
DataConservation Class Reference

Base class for any import and export calibration data file formats More...

Public Types

enum ErrorType {
NotFound , NotSupported , Format , TypeDiffers ,
NoOfElementsDiffers , XAxisInvalid , YAxisInvalid , ZAxisInvalid
}

Public Attributes

IList< Tuple< string, ErrorType > > SkippedValues = new List<Tuple<string, ErrorType>>()
Gets the list of skipped values from the parameter file.

Static Protected Member Functions

static string | buildDescription (A2LMODULE module, string description)
static int | checkAxis (A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize)
static void | getAxisDescription (A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis)
Gets axis descriptions from the specified characteristic. More...
static double | getValue (string par)

Static Protected Attributes

static readonly string mEOL = Environment.NewLine

Properties

IList< ICharValue > Values = new List<ICharValue>() [get]
Gets the list of succesfully imported values from the parameter file.

Detailed Description

Base class for any import and export calibration data file formats

Member Function Documentation

◆ getAxisDescription()

static void getAxisDescription | ( | A2LRECORD_LAYOUT_REF | layoutRef,
 |  | out A2LAXIS_DESCR[] | axisDescs,
 |  | out bool[] | isVariableAxis
 | ) |  |
staticprotected

Gets axis descriptions from the specified characteristic.

Parameters
layoutRef | The characteristic
axisDescs | list axis descriptions (may be null)
isVariableAxis | Indicates which axis may have variable size (1..MaxAxisPoints, may be null)


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataConservation
DataConservation Member List

This is the complete list of members for DataConservation, including all inherited members.

buildDescription(A2LMODULE module, string description) (defined in DataConservation) | DataConservation | protectedstatic
checkAxis(A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize) (defined in DataConservation) | DataConservation | protectedstatic
ErrorType enum name (defined in DataConservation) | DataConservation |
getAxisDescription(A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis) | DataConservation | protectedstatic
getValue(string par) (defined in DataConservation) | DataConservation | protectedstatic
mEOL (defined in DataConservation) | DataConservation | protectedstatic
SkippedValues | DataConservation |
Values | DataConservation |


ASAP2Library interface: DataFile Class Reference

  • ASAP2
  • Values
  • DataFile
Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Member Functions | Static Protected Attributes | Properties | List of all members
DataFile Class Referenceabstract

Base class for reading/writing S19 and HEX files. More...

Public Member Functions

abstract object | Clone ()
Clone method does a deep copy of the data file. More...
void | Dispose ()
Frees used resources.
abstract void | load (Stream stream)
Load the contents of a data file into memory. More...
abstract void | load (string fileName)
Load the contents of a data file into memory. More...
override string | ToString ()
Supplies a string representation of the datafile. More...

Static Public Member Functions

static string | getNearestDataFile (string srcFile, string epk=null)
Gets the nearest data file (S19, HEX or BIN) to the specified a2l file. More...
static IDataFile | open (DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile stream (may be a Motorola S, Intel HEX file or Binary file). More...
static void | open (IDataFile dataFile)
Initialises the specified DataFile by calling it's load function More...
static IDataFile | open (string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile (may be a Motorola S or Intel HEX file). More...

Protected Member Functions

DataFile (string filename, MemorySegmentList segments)
Constructs a new instance of this class. More...
bool | EPKCheck (uint epkAddress, string expectedEPK)
Checks all segments to find the specified epk string. More...
MemorySegment | findMemSeg (uint address, int len)
Finds the memory segment the specified data is within. More...
bool | setEPK (uint epkAddress, string epkToSet)
Set the EPK to the specified address. More...
void | setSegmentsData (MemorySegmentList segments)
Set segments data from the specified segments. More...

Static Protected Member Functions

static void import (IDataFile dataFile, IEnumerable< ICharValue > values)
Imports the specified values into the datafile. More...

Static Protected Attributes

const string mStrByteFormat = "{0:X2}"

Properties

HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues = new HashSet<A2LRECORD_LAYOUT_REF>() [get]
int | DataBytesPerLine [getset]
Gets the data bytes per line. More...
bool | IsDirty [getset]
MemorySegmentList | SegmentList [getprotected set]
string | SourceFilename [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Base class for reading/writing S19 and HEX files.

  • This class is constructed by the static DataFile.open method.
  • Use DataFile.open to load S19 or HEX files.
  • use DataFile.getNearestDataFile to find potential fitting files to a specified A2L file.

To load a data file into an already loaded A2L model:

  • Open the data file by DataFile.open
  • Get values for your characteristics by calling CharacteristicValue.getValue<T> with any of your characteristics from the A2L model

Constructor & Destructor Documentation

◆ DataFile()

DataFile | ( | string | filename,
 |  | MemorySegmentList | segments
 | ) |  |
protected

Constructs a new instance of this class.

Parameters
filename | The data file source filename
segments | Segments to initialize with, may be null or empty.

Member Function Documentation

◆ Clone()

abstract object Clone ( )
pure virtual

Clone method does a deep copy of the data file.

Returns
a new instance cloned from the current instance

Implemented in DataFileBin, DataFileHex, and DataFileS19.

◆ EPKCheck()

bool EPKCheck | ( | uint | epkAddress,
 |  | string | expectedEPK
 | ) |  |
protected

Checks all segments to find the specified epk string.

Parameters
epkAddress | The epk address
expectedEPK | The epk string to compare to
Returns
true if the specified EPK is found

◆ findMemSeg()

MemorySegment findMemSeg | ( | uint | address,
 |  | int | len
 | ) |  |
protected

Finds the memory segment the specified data is within.

Parameters
address | The start address to find
len | The length of the data
Returns
The segment instance or null if not found

◆ getNearestDataFile()

static string getNearestDataFile | ( | string | srcFile,
 |  | string | epk = null
 | ) |  |
static

Gets the nearest data file (S19, HEX or BIN) to the specified a2l file.

Alogorithm:

  • Check each file (extensions S19, HEX or BIN) within the specified source directory
  • return the file which corresponds to the name of the specified souce file excactly
  • if no one fits return the first file found (extensions S19, HEX or BIN)
Parameters
srcFile | The fully qualified path to the source (A2L) file
byteOrder | The byte order to get a file for
epk | A potential epk (EEPROM identifier, reuired only for bin files)
Returns
A fully qualified string of a potential fitting data file (S19 or HEX) or null if no fitting data file is found

◆ import()

static void import | ( | IDataFile | dataFile,
 |  | IEnumerable< ICharValue > | values
 | ) |  |
staticprotected

Imports the specified values into the datafile.

May be used e.g from a DCMFile import.

Parameters
dataFile | The datd file to import into
values | The values to import

◆ load() [1/2]

abstract void load ( Stream stream )
pure virtual

Load the contents of a data file into memory.

Parameters
stream Stream to read from.
Exceptions
Exception Thrown if failed

Implemented in DataFileBin, DataFileHex, and DataFileS19.

◆ load() [2/2]

abstract void load ( string fileName )
pure virtual

Load the contents of a data file into memory.

Parameters
fileName Fully qualified path to the data file to read.
Exceptions
Exception Thrown if failed

Implemented in DataFileBin, DataFileHex, and DataFileS19.

◆ open() [1/3]

static IDataFile open | ( | DataFileType | type,
 |  | Stream | stream,
 |  | MemorySegmentList | segments,
 |  | uint | epkAddress = 0,
 |  | string | epk = null
 | ) |  |
static

Opens the specified datafile stream (may be a Motorola S, Intel HEX file or Binary file).

The data read will be written into the specified MemorySegmentList.

Parameters
type | Type of datafile
stream | Stream to read from
segments | A list of memory segments created from the A2L source file (usually all data segmensts), may be null or empty.
epkAddress | A potential EPK address (required only for bin files)
epk | A potential epk (EEPROM identifier, reuired only for bin files)
Returns
A new instance of a data file or null if the file is not accessible, not valid
Exceptions
Exception If the file couldn't be openend

◆ open() [2/3]

static void open ( IDataFile dataFile )
static

Initialises the specified DataFile by calling it's load function

Parameters
dataFile The already created DataFilel Instance

◆ open() [3/3]

static IDataFile open | ( | string | filename,
 |  | MemorySegmentList | segments,
 |  | uint | epkAddress = 0,
 |  | string | epk = null
 | ) |  |
static

Opens the specified datafile (may be a Motorola S or Intel HEX file).

The data read will be written into the specified MemorySegmentList.

Example code:

// Create the list of memory segments from the A2L model...
var memSegs = createEmptyMemorySegments();
// Load the data file into the memory segments...
var dataFile = DataFile.open(dataFilename, memSegs);
jnsoft.ASAP2.Values.DataFile.DataFile
DataFile(string filename, MemorySegmentList segments)
Constructs a new instance of this class.
Definition: DataFile.cs:98
Parameters
filename | the fully qualified path to the file to open
segments | A list of memory segments created from the A2L source file (usually all data segmensts), may be null or empty.
epkAddress | A potential EPK address (required only for bin files)
epk | A potential epk (EEPROM identifier, reuired only for bin files)
Returns
A new instance of a data file or null if the file is not accessible, not valid
Exceptions
Exception If the file couldn't be openend

◆ setEPK()

bool setEPK | ( | uint | epkAddress,
 |  | string | epkToSet
 | ) |  |
protected

Set the EPK to the specified address.

Parameters
epkAddress | The epk address
epkToSet | The EPK string to set
Returns
true if the specified EPK is set

◆ setSegmentsData()

void setSegmentsData ( MemorySegmentList segments )
protected

Set segments data from the specified segments.

  • A segment exists if only if the starting addresses and the length is the same
  • If a segment is not existing in the target, the data will not be added
  • If a segment exists, the specified data will override the data in the target.
Parameters
segments The segments to set data from

◆ ToString()

override string ToString ( )

Supplies a string representation of the datafile.

Returns
the string representation

Property Documentation

◆ DataBytesPerLine

int DataBytesPerLine
getset

Gets the data bytes per line.

The value is initialized if the file is read from the filesystem.

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to a datafile.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataFile
DataFile Member List

This is the complete list of members for DataFile, including all inherited members.

ChangedValues (defined in DataFile) | DataFile | protected
Clone() | DataFile | pure virtual
DataBytesPerLine | DataFile |
DataFile(string filename, MemorySegmentList segments) | DataFile | protected
Dispose() | DataFile |
EPKCheck(uint epkAddress, string expectedEPK) | DataFile | protected
findMemSeg(uint address, int len) | DataFile | protected
getNearestDataFile(string srcFile, string epk=null) | DataFile | static
import(IDataFile dataFile, IEnumerable< ICharValue > values) | DataFile | protectedstatic
IsDirty (defined in DataFile) | DataFile | protected
load(string fileName) | DataFile | pure virtual
load(Stream stream) | DataFile | pure virtual
mStrByteFormat (defined in DataFile) | DataFile | protectedstatic
open(string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(IDataFile dataFile) | DataFile | static
SegmentList (defined in DataFile) | DataFile |
setEPK(uint epkAddress, string epkToSet) | DataFile | protected
setSegmentsData(MemorySegmentList segments) | DataFile | protected
SourceFilename (defined in DataFile) | DataFile | protected
Tag | DataFile |
ToString() | DataFile |


ASAP2Library interface: DataFileBin Class Reference

  • ASAP2
  • Values
  • DataFileBin
Public Member Functions | Properties | List of all members
DataFileBin Class Reference

Class for reading/writing binary data files. More...

Public Member Functions

DataFileBin (string filename, MemorySegmentList segments, uint epkAddress, string epk)
Constructs a new instance of this class. More...
override object | Clone ()
Provides implementation of the IClone member. More...
override void | load (Stream fs)
Load the contents of a data file into memory. More...
override void | load (string fileName)
Load the contents of a data file into memory. More...
- Public Member Functions inherited from DataFile
void | Dispose ()
Frees used resources.
override string | ToString ()
Supplies a string representation of the datafile. More...

Properties

string | EPK [get]
Gets the EPK.
uint | EPKAddress [get]
Gets the EPK address.
- Properties inherited from DataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues = new HashSet<A2LRECORD_LAYOUT_REF>() [get]
int | DataBytesPerLine [getset]
Gets the data bytes per line. More...
bool | IsDirty [getset]
MemorySegmentList | SegmentList [getprotected set]
string | SourceFilename [getset]
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IDataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues [get]
Gets the dictionary of changed characteristic values within the file. More...
bool | IsDirty [getset]
Gets a value indicating if the current file is changed in memory.
MemorySegmentList | SegmentList [get]
Gets the memory segment list.
string | SourceFilename [get]
Gets the fully qualified path to the source filename.

Additional Inherited Members

- Static Public Member Functions inherited from DataFile
static string | getNearestDataFile (string srcFile, string epk=null)
Gets the nearest data file (S19, HEX or BIN) to the specified a2l file. More...
static IDataFile | open (DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile stream (may be a Motorola S, Intel HEX file or Binary file). More...
static void | open (IDataFile dataFile)
Initialises the specified DataFile by calling it's load function More...
static IDataFile | open (string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile (may be a Motorola S or Intel HEX file). More...
- Protected Member Functions inherited from DataFile
DataFile (string filename, MemorySegmentList segments)
Constructs a new instance of this class. More...
bool | EPKCheck (uint epkAddress, string expectedEPK)
Checks all segments to find the specified epk string. More...
MemorySegment | findMemSeg (uint address, int len)
Finds the memory segment the specified data is within. More...
bool | setEPK (uint epkAddress, string epkToSet)
Set the EPK to the specified address. More...
void | setSegmentsData (MemorySegmentList segments)
Set segments data from the specified segments. More...
- Static Protected Member Functions inherited from DataFile
static void | import (IDataFile dataFile, IEnumerable< ICharValue > values)
Imports the specified values into the datafile. More...
- Static Protected Attributes inherited from DataFile
const string | mStrByteFormat = "{0:X2}"

Detailed Description

Class for reading/writing binary data files.

  • This class gets constructed by the static DataFile.open method.

Constructor & Destructor Documentation

◆ DataFileBin()

DataFileBin | ( | string | filename,
 |  | MemorySegmentList | segments,
 |  | uint | epkAddress,
 |  | string | epk
 | ) |  |

Constructs a new instance of this class.

Initialize the memory segment list with the specified segments.

Parameters
filename | The fully qualified path to the source filename.
segments | Segments to initialize with, may be null or empty.
epkAddress | A potential EPK address (requiredonly for bin files)
epk | A potential epk (EEPROM identifier, reuired only for bin files)

Member Function Documentation

◆ Clone()

override object Clone ( )
virtual

Provides implementation of the IClone member.

Returns
New instance of class as a copy of the original.

Implements DataFile.

◆ load() [1/2]

override void load ( Stream stream )
virtual

Load the contents of a data file into memory.

Parameters
stream Stream to read from.
Exceptions
Exception Thrown if failed

Implements DataFile.

◆ load() [2/2]

override void load ( string fileName )
virtual

Load the contents of a data file into memory.

Parameters
fileName Fully qualified path to the data file to read.
Exceptions
Exception Thrown if failed

Implements DataFile.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataFileBin
DataFileBin Member List

This is the complete list of members for DataFileBin, including all inherited members.

Clone() | DataFileBin | virtual
DataBytesPerLine | DataFile |
DataFile(string filename, MemorySegmentList segments) | DataFile | protected
DataFileBin(string filename, MemorySegmentList segments, uint epkAddress, string epk) | DataFileBin |
Dispose() | DataFile |
EPK | DataFileBin |
EPKAddress | DataFileBin |
EPKCheck(uint epkAddress, string expectedEPK) | DataFile | protected
jnsoft::ASAP2::Values::DataFile.findMemSeg(uint address, int len) | DataFile | protected
getNearestDataFile(string srcFile, string epk=null) | DataFile | static
jnsoft::ASAP2::Values::DataFile.import(IDataFile dataFile, IEnumerable< ICharValue > values) | DataFile | protectedstatic
load(Stream fs) | DataFileBin | virtual
load(string fileName) | DataFileBin | virtual
mStrByteFormat (defined in DataFile) | DataFile | protectedstatic
open(string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(IDataFile dataFile) | DataFile | static
SegmentList (defined in DataFile) | DataFile |
jnsoft::ASAP2::IDataFile.SegmentList | IDataFile |
Tag | DataFile |
ToString() | DataFile |


ASAP2Library interface: DataFileBinDlg Class Reference

  • ASAP2
  • Values
  • DataFileBinDlg
Public Member Functions | Protected Member Functions | Properties | List of all members
DataFileBinDlg Class Reference

Dialog to get a start address for a data binary file. More...

Public Member Functions

DataFileBinDlg (MemorySegmentList segments)
Creates a new instance of DataFileBinDlg. More...

Protected Member Functions

override void OnFormClosing (FormClosingEventArgs e)
Calle when the dialog gets closed. More...

Properties

UInt32 Address [get]
Gets the user selected address.

Detailed Description

Dialog to get a start address for a data binary file.

Constructor & Destructor Documentation

◆ DataFileBinDlg()

DataFileBinDlg ( MemorySegmentList segments )

Creates a new instance of DataFileBinDlg.

Parameters
segments The A2L defined emory segments (may be empty)

Member Function Documentation

◆ OnFormClosing()

override void OnFormClosing ( FormClosingEventArgs e )
protected

Calle when the dialog gets closed.

Parameters
e


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataFileBinDlg
DataFileBinDlg Member List

This is the complete list of members for DataFileBinDlg, including all inherited members.

Address | DataFileBinDlg |
DataFileBinDlg(MemorySegmentList segments) | DataFileBinDlg |
OnFormClosing(FormClosingEventArgs e) | DataFileBinDlg | protected


ASAP2Library interface: DataFileHex Class Reference

  • ASAP2
  • Values
  • DataFileHex
Public Member Functions | List of all members
DataFileHex Class Reference

Class for reading/writing Intel HEX files. More...

Public Member Functions

DataFileHex (string filename, MemorySegmentList segments)
Constructs a new instance of this class. More...
override object | Clone ()
Provides implementation of the IClone member. More...
override void | load (Stream fs)
Load the contents of a data file into memory. More...
override void | load (string fileName)
Load the contents of a data file into memory. More...
- Public Member Functions inherited from DataFile
void | Dispose ()
Frees used resources.
override string | ToString ()
Supplies a string representation of the datafile. More...

Additional Inherited Members

- Static Public Member Functions inherited from DataFile
static string | getNearestDataFile (string srcFile, string epk=null)
Gets the nearest data file (S19, HEX or BIN) to the specified a2l file. More...
static IDataFile | open (DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile stream (may be a Motorola S, Intel HEX file or Binary file). More...
static void | open (IDataFile dataFile)
Initialises the specified DataFile by calling it's load function More...
static IDataFile | open (string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile (may be a Motorola S or Intel HEX file). More...
- Protected Member Functions inherited from DataFile
DataFile (string filename, MemorySegmentList segments)
Constructs a new instance of this class. More...
bool | EPKCheck (uint epkAddress, string expectedEPK)
Checks all segments to find the specified epk string. More...
MemorySegment | findMemSeg (uint address, int len)
Finds the memory segment the specified data is within. More...
bool | setEPK (uint epkAddress, string epkToSet)
Set the EPK to the specified address. More...
void | setSegmentsData (MemorySegmentList segments)
Set segments data from the specified segments. More...
- Static Protected Member Functions inherited from DataFile
static void | import (IDataFile dataFile, IEnumerable< ICharValue > values)
Imports the specified values into the datafile. More...
- Static Protected Attributes inherited from DataFile
const string | mStrByteFormat = "{0:X2}"
- Properties inherited from DataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues = new HashSet<A2LRECORD_LAYOUT_REF>() [get]
int | DataBytesPerLine [getset]
Gets the data bytes per line. More...
bool | IsDirty [getset]
MemorySegmentList | SegmentList [getprotected set]
string | SourceFilename [getset]
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IDataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues [get]
Gets the dictionary of changed characteristic values within the file. More...
bool | IsDirty [getset]
Gets a value indicating if the current file is changed in memory.
MemorySegmentList | SegmentList [get]
Gets the memory segment list.
string | SourceFilename [get]
Gets the fully qualified path to the source filename.

Detailed Description

Class for reading/writing Intel HEX files.

  • This class gets constructed by the static DataFile.open method.

Constructor & Destructor Documentation

◆ DataFileHex()

DataFileHex | ( | string | filename,
 |  | MemorySegmentList | segments
 | ) |  |

Constructs a new instance of this class.

Initialize the memory segment list with the specified segments.

Parameters
filename | The fully qualified path to the source filename.
segments | Segments to initialize with, may be null or empty.

Member Function Documentation

◆ Clone()

override object Clone ( )
virtual

Provides implementation of the IClone member.

Returns
New instance of class as a copy of the original.

Implements DataFile.

◆ load() [1/2]

override void load ( Stream stream )
virtual

Load the contents of a data file into memory.

Parameters
stream Stream to read from.
Exceptions
Exception Thrown if failed

Implements DataFile.

◆ load() [2/2]

override void load ( string fileName )
virtual

Load the contents of a data file into memory.

Parameters
fileName Fully qualified path to the data file to read.
Exceptions
Exception Thrown if failed

Implements DataFile.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataFileHex
DataFileHex Member List

This is the complete list of members for DataFileHex, including all inherited members.

Clone() | DataFileHex | virtual
DataBytesPerLine | DataFile |
DataFile(string filename, MemorySegmentList segments) | DataFile | protected
DataFileHex(string filename, MemorySegmentList segments) | DataFileHex |
Dispose() | DataFile |
EPKCheck(uint epkAddress, string expectedEPK) | DataFile | protected
jnsoft::ASAP2::Values::DataFile.findMemSeg(uint address, int len) | DataFile | protected
getNearestDataFile(string srcFile, string epk=null) | DataFile | static
jnsoft::ASAP2::Values::DataFile.import(IDataFile dataFile, IEnumerable< ICharValue > values) | DataFile | protectedstatic
load(Stream fs) | DataFileHex | virtual
load(string fileName) | DataFileHex | virtual
mStrByteFormat (defined in DataFile) | DataFile | protectedstatic
open(string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(IDataFile dataFile) | DataFile | static
SegmentList (defined in DataFile) | DataFile |
jnsoft::ASAP2::IDataFile.SegmentList | IDataFile |
Tag | DataFile |
ToString() | DataFile |


ASAP2Library interface: DataFileS19 Class Reference

  • ASAP2
  • Values
  • DataFileS19
Public Member Functions | Properties | List of all members
DataFileS19 Class Reference

Class for reading/writing Motorola S files. More...

Public Member Functions

DataFileS19 (string filename, MemorySegmentList segments)
Construct a new instance of the S19 data file class. More...
override object | Clone ()
Implements the IClone member. More...
override void | load (Stream fs)
Load the contents of a data file into memory. More...
override void | load (string fileName)
Load the contents of a data file into memory. More...
- Public Member Functions inherited from DataFile
void | Dispose ()
Frees used resources.
override string | ToString ()
Supplies a string representation of the datafile. More...

Properties

MotorolaFileType | WriteFileType = MotorolaFileType._4Byte [getset]
Gets or set the file format. More...
- Properties inherited from DataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues = new HashSet<A2LRECORD_LAYOUT_REF>() [get]
int | DataBytesPerLine [getset]
Gets the data bytes per line. More...
bool | IsDirty [getset]
MemorySegmentList | SegmentList [getprotected set]
string | SourceFilename [getset]
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IDataFile
HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues [get]
Gets the dictionary of changed characteristic values within the file. More...
bool | IsDirty [getset]
Gets a value indicating if the current file is changed in memory.
MemorySegmentList | SegmentList [get]
Gets the memory segment list.
string | SourceFilename [get]
Gets the fully qualified path to the source filename.

Additional Inherited Members

- Static Public Member Functions inherited from DataFile
static string | getNearestDataFile (string srcFile, string epk=null)
Gets the nearest data file (S19, HEX or BIN) to the specified a2l file. More...
static IDataFile | open (DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile stream (may be a Motorola S, Intel HEX file or Binary file). More...
static void | open (IDataFile dataFile)
Initialises the specified DataFile by calling it's load function More...
static IDataFile | open (string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null)
Opens the specified datafile (may be a Motorola S or Intel HEX file). More...
- Protected Member Functions inherited from DataFile
DataFile (string filename, MemorySegmentList segments)
Constructs a new instance of this class. More...
bool | EPKCheck (uint epkAddress, string expectedEPK)
Checks all segments to find the specified epk string. More...
MemorySegment | findMemSeg (uint address, int len)
Finds the memory segment the specified data is within. More...
bool | setEPK (uint epkAddress, string epkToSet)
Set the EPK to the specified address. More...
void | setSegmentsData (MemorySegmentList segments)
Set segments data from the specified segments. More...
- Static Protected Member Functions inherited from DataFile
static void | import (IDataFile dataFile, IEnumerable< ICharValue > values)
Imports the specified values into the datafile. More...
- Static Protected Attributes inherited from DataFile
const string | mStrByteFormat = "{0:X2}"

Detailed Description

Class for reading/writing Motorola S files.

  • This class gets constructed by the static DataFile.open method.

Constructor & Destructor Documentation

◆ DataFileS19()

DataFileS19 | ( | string | filename,
 |  | MemorySegmentList | segments
 | ) |  |

Construct a new instance of the S19 data file class.

Initialize the memory segment list with the specified segments.

Parameters
filename | The fully qualified path to the source filename.
segments | Segments to initialize with, may be null or empty.

Member Function Documentation

◆ Clone()

override object Clone ( )
virtual

Implements the IClone member.

Returns
New instance of file as copy of the original.

Implements DataFile.

◆ load() [1/2]

override void load ( Stream stream )
virtual

Load the contents of a data file into memory.

Parameters
stream Stream to read from.
Exceptions
Exception Thrown if failed

Implements DataFile.

◆ load() [2/2]

override void load ( string fileName )
virtual

Load the contents of a data file into memory.

Parameters
fileName Fully qualified path to the data file to read.
Exceptions
Exception Thrown if failed

Implements DataFile.

Property Documentation

◆ WriteFileType

MotorolaFileType WriteFileType = MotorolaFileType._4Byte
getset

Gets or set the file format.

The value is initialized if the file is read from the filesystem.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DataFileS19
DataFileS19 Member List

This is the complete list of members for DataFileS19, including all inherited members.

Clone() | DataFileS19 | virtual
DataBytesPerLine | DataFile |
DataFile(string filename, MemorySegmentList segments) | DataFile | protected
DataFileS19(string filename, MemorySegmentList segments) | DataFileS19 |
Dispose() | DataFile |
EPKCheck(uint epkAddress, string expectedEPK) | DataFile | protected
jnsoft::ASAP2::Values::DataFile.findMemSeg(uint address, int len) | DataFile | protected
getNearestDataFile(string srcFile, string epk=null) | DataFile | static
jnsoft::ASAP2::Values::DataFile.import(IDataFile dataFile, IEnumerable< ICharValue > values) | DataFile | protectedstatic
load(Stream fs) | DataFileS19 | virtual
load(string fileName) | DataFileS19 | virtual
mStrByteFormat (defined in DataFile) | DataFile | protectedstatic
open(string filename, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(DataFileType type, Stream stream, MemorySegmentList segments, uint epkAddress=0, string epk=null) | DataFile | static
open(IDataFile dataFile) | DataFile | static
SegmentList (defined in DataFile) | DataFile |
jnsoft::ASAP2::IDataFile.SegmentList | IDataFile |
Tag | DataFile |
ToString() | DataFile |
WriteFileType | DataFileS19 |


ASAP2Library interface: DCMFile Class Reference

  • ASAP2
  • Values
  • DCMFile
Static Public Member Functions | List of all members
DCMFile Class Reference

Implements the ETAS INCA DCM file format 2.x reader/writer. More...

Static Public Member Functions

static DataConservation | open (Stream stream, A2LMODULE module)
Opens a DCM file and returns a DCMFile instance. More...
static DataConservation | open (string path, A2LMODULE module)
Opens a DCM file and returns a DCMFile instance. More...
static int | save (IDataFile dataFile, A2LMODULE module, string path, string description)
Saves all characteristics of the module into a DCM file. More...
static int | save (IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, Encoding encoding=null)
Saves the specified characteristics into a DCM file. More...
static int | save (string path, string description, IEnumerable< ICharValue > values, IEnumerable< A2LFUNCTION > functions, Encoding encoding=null)
Saves the specified characteristics into a DCM file. More...

Additional Inherited Members

- Public Types inherited from DataConservation
enum ErrorType {
NotFound , NotSupported , Format , TypeDiffers ,
NoOfElementsDiffers , XAxisInvalid , YAxisInvalid , ZAxisInvalid
}
- Public Attributes inherited from DataConservation
IList< Tuple< string, ErrorType > > | SkippedValues = new List<Tuple<string, ErrorType>>()
Gets the list of skipped values from the parameter file.
- Static Protected Member Functions inherited from DataConservation
static string | buildDescription (A2LMODULE module, string description)
static int | checkAxis (A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize)
static void | getAxisDescription (A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis)
Gets axis descriptions from the specified characteristic. More...
static double | getValue (string par)
- Static Protected Attributes inherited from DataConservation
static readonly string | mEOL = Environment.NewLine
- Properties inherited from DataConservation
IList< ICharValue > | Values = new List<ICharValue>() [get]
Gets the list of succesfully imported values from the parameter file.

Detailed Description

Implements the ETAS INCA DCM file format 2.x reader/writer.

The DCM file format is a Data Conservation format, a DAMOS format used in ASCET and INCA.

Member Function Documentation

◆ open() [1/2]

static DataConservation open | ( | Stream | stream,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a DCM file and returns a DCMFile instance.

Parameters
stream | Stream to read from
module | The module to read the characteristics from
Returns
A new DCMFile instance or null if failed

◆ open() [2/2]

static DataConservation open | ( | string | path,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a DCM file and returns a DCMFile instance.

Parameters
path | the fully qualified dcm/par filename
module | The module to read the characteristics from
Returns
A new DCMFile instance or null if failed

◆ save() [1/3]

static int save | ( | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description
 | ) |  |
static

Saves all characteristics of the module into a DCM file.

Parameters
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
Returns
count of written characteristics, -1 if failed

◆ save() [2/3]

static int save | ( | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | IEnumerable< A2LCHARACTERISTIC > | characteristics,
 |  | bool | exportFunctions,
 |  | Encoding | encoding = null
 | ) |  |
static

Saves the specified characteristics into a DCM file.

Parameters
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
characteristics | The characteristics to save
exportFunctions | true if functions should be exported, too
encoding | Encoding (if not specified the Encoding.Default is taken)
Returns
count of written characteristics, -1 if failed

◆ save() [3/3]

static int save | ( | string | path,
 |  | string | description,
 |  | IEnumerable< ICharValue > | values,
 |  | IEnumerable< A2LFUNCTION > | functions,
 |  | Encoding | encoding = null
 | ) |  |
static

Saves the specified characteristics into a DCM file.

Parameters
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
values | The values to save into the DCM file
functions | Functions to save into the DCM file (may be null or empty)
encoding | Encoding (if not specified the Encoding.Default is taken)
Returns
count of written characteristics, -1 if failed


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • DCMFile
DCMFile Member List

This is the complete list of members for DCMFile, including all inherited members.

buildDescription(A2LMODULE module, string description) (defined in DataConservation) | DataConservation | protectedstatic
checkAxis(A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize) (defined in DataConservation) | DataConservation | protectedstatic
ErrorType enum name (defined in DataConservation) | DataConservation |
getAxisDescription(A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis) | DataConservation | protectedstatic
getValue(string par) (defined in DataConservation) | DataConservation | protectedstatic
mEOL (defined in DataConservation) | DataConservation | protectedstatic
open(string path, A2LMODULE module) | DCMFile | static
open(Stream stream, A2LMODULE module) | DCMFile | static
save(IDataFile dataFile, A2LMODULE module, string path, string description) | DCMFile | static
save(IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, Encoding encoding=null) | DCMFile | static
save(string path, string description, IEnumerable< ICharValue > values, IEnumerable< A2LFUNCTION > functions, Encoding encoding=null) | DCMFile | static
SkippedValues | DataConservation |
Values | DataConservation |


ASAP2Library interface: MapValue Class Reference

  • ASAP2
  • Values
  • MapValue
Public Member Functions | Protected Member Functions | List of all members
MapValue Class Reference

Class representing a characteristic CHAR_TYPE.MAP value. More...

Public Member Functions

MapValue ()
Default constructor
MapValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

override bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Additional Inherited Members

- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.MAP value.

The ICharValue.Value in this case is of type double[,].

Constructor & Destructor Documentation

◆ MapValue()

MapValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ incrementOrDecrement()

override bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented from BaseValue.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • MapValue
MapValue Member List

This is the complete list of members for MapValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | MapValue | protectedvirtual
jnsoft::ASAP2::Values::BaseValue.incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
MapValue() | MapValue |
MapValue(A2LRECORD_LAYOUT_REF characteristic) | MapValue |
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in MapValue) | MapValue |


ASAP2Library interface: MatlabFile Class Reference

  • ASAP2
  • Values
  • MatlabFile
Static Public Member Functions | List of all members
MatlabFile Class Reference

Implements the Matlab (*.m) file format reader/writer. More...

Static Public Member Functions

static DataConservation | open (Stream stream, A2LMODULE module)
Opens a Matlab file and returns a MatlabFile instance. More...
static DataConservation | open (string path, A2LMODULE module)
Opens a Matlab file and returns a MatlabFile instance. More...
static int | save (IDataFile dataFile, A2LMODULE module, string path, string description, bool addParameterDesc)
Saves all characteristics of the module into a Matlab file. More...
static int | save (IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, bool addParameterDesc)
Saves the specified characteristics into a Matlab file. More...
static int | save (string path, string description, IEnumerable< ICharValue > values, IEnumerable< A2LFUNCTION > functions, bool addParameterDesc)
Saves the specified characteristics into a Matlab file. More...

Additional Inherited Members

- Public Types inherited from DataConservation
enum ErrorType {
NotFound , NotSupported , Format , TypeDiffers ,
NoOfElementsDiffers , XAxisInvalid , YAxisInvalid , ZAxisInvalid
}
- Public Attributes inherited from DataConservation
IList< Tuple< string, ErrorType > > | SkippedValues = new List<Tuple<string, ErrorType>>()
Gets the list of skipped values from the parameter file.
- Static Protected Member Functions inherited from DataConservation
static string | buildDescription (A2LMODULE module, string description)
static int | checkAxis (A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize)
static void | getAxisDescription (A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis)
Gets axis descriptions from the specified characteristic. More...
static double | getValue (string par)
- Static Protected Attributes inherited from DataConservation
static readonly string | mEOL = Environment.NewLine
- Properties inherited from DataConservation
IList< ICharValue > | Values = new List<ICharValue>() [get]
Gets the list of succesfully imported values from the parameter file.

Detailed Description

Implements the Matlab (*.m) file format reader/writer.

Member Function Documentation

◆ open() [1/2]

static DataConservation open | ( | Stream | stream,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a Matlab file and returns a MatlabFile instance.

Parameters
stream | Stream to read from
module | The module to read the characteristics from
Returns
A new MatlabFile instance or null if failed

◆ open() [2/2]

static DataConservation open | ( | string | path,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a Matlab file and returns a MatlabFile instance.

Parameters
path | the fully qualified Matlab filename
module | The module to read the characteristics from
Returns
A new MatlabFile instance or null if failed

◆ save() [1/3]

static int save | ( | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves all characteristics of the module into a Matlab file.

Parameters
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
addParameterDesc | Add parameter descriptions as comments
Returns
count of written characteristics, -1 if failed

◆ save() [2/3]

static int save | ( | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | IEnumerable< A2LCHARACTERISTIC > | characteristics,
 |  | bool | exportFunctions,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves the specified characteristics into a Matlab file.

Parameters
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
characteristics | The characteristics to save
exportFunctions | true if functions should be exported, too
addParameterDesc | Add parameter descriptions as comments
Returns
count of written characteristics, -1 if failed

◆ save() [3/3]

static int save | ( | string | path,
 |  | string | description,
 |  | IEnumerable< ICharValue > | values,
 |  | IEnumerable< A2LFUNCTION > | functions,
 |  | bool | addParameterDesc
 | ) |  |
static

Saves the specified characteristics into a Matlab file.

Parameters
path | the fully qualified path to the destination file
description an optional description for the file header (The '
' delimiter is supported for multiline descriptions)
values | The values to save into the Matlab file
functions | Functions to save into the Matlab file (may be null or empty)
addParameterDesc | Add parameter descriptions as comments
Returns
count of written characteristics, -1 if failed


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • MatlabFile
MatlabFile Member List

This is the complete list of members for MatlabFile, including all inherited members.

buildDescription(A2LMODULE module, string description) (defined in DataConservation) | DataConservation | protectedstatic
checkAxis(A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize) (defined in DataConservation) | DataConservation | protectedstatic
ErrorType enum name (defined in DataConservation) | DataConservation |
getAxisDescription(A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis) | DataConservation | protectedstatic
getValue(string par) (defined in DataConservation) | DataConservation | protectedstatic
mEOL (defined in DataConservation) | DataConservation | protectedstatic
open(string path, A2LMODULE module) | MatlabFile | static
open(Stream stream, A2LMODULE module) | MatlabFile | static
save(IDataFile dataFile, A2LMODULE module, string path, string description, bool addParameterDesc) | MatlabFile | static
save(IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics, bool exportFunctions, bool addParameterDesc) | MatlabFile | static
save(string path, string description, IEnumerable< ICharValue > values, IEnumerable< A2LFUNCTION > functions, bool addParameterDesc) | MatlabFile | static
SkippedValues | DataConservation |
Values | DataConservation |


ASAP2Library interface: MeasurementAccessData Class Reference

  • ASAP2
  • Values
  • MeasurementAccessData
Public Member Functions | Properties | List of all members
MeasurementAccessData Class Reference

Manages static memory data for A2LMEASUREMENTs. More...

Public Member Functions

MeasurementAccessData (List< A2LMEASUREMENT > measurements)
Cretae a new instance of MeasurementAccesData with the specified parameters. More...
byte[] | getData (uint address, int size)
Gets the data for the specified address and size. More...
bool | getData (uint address, int size, out byte[] data, out int offset)
Gets the data and offset for the specified address and size. More...
bool | getPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | setData (uint address, byte[] data)
Sets the data to the specified address. More...
bool | setPhysValue (A2LMEASUREMENT measurement, int x, int y, double value)
Sets the specified value to the measurement's memory. More...

Properties

List< byte[]> | DataChunks [get]
Gets the data chunks. More...
MemoryRangeList | MemoryRanges [get]
Gets the created memory ranges. More...

Detailed Description

Manages static memory data for A2LMEASUREMENTs.

Constructor & Destructor Documentation

◆ MeasurementAccessData()

MeasurementAccessData ( List< A2LMEASUREMENT > measurements )

Cretae a new instance of MeasurementAccesData with the specified parameters.

Parameters
measurements The list of measurements to create the memory for

Member Function Documentation

◆ getData() [1/2]

byte[] getData | ( | uint | address,
 |  | int | size
 | ) |  |

Gets the data for the specified address and size.

Parameters
address | The address to get the data fo
size | The size of the data to get
Returns
byte array instance, or null if not found

◆ getData() [2/2]

bool getData | ( | uint | address,
 |  | int | size,
 |  | out byte[] | data,
 |  | out int | offset
 | ) |  |

Gets the data and offset for the specified address and size.

Parameters
address | The address to get the data fo
size | The size of the data to get
data | The resulting data
offset | The resuling offset
Returns
byte array instance, or null if not found

◆ getPhysValue() [1/2]

bool getPhysValue | ( | A2LMEASUREMENT | measurement,
 |  | int | x,
 |  | int | y,
 |  | out double | value
 | ) |  |

Gets the last received physical value for the specified measurement address.

This is the version for an A2LMEASUREMENT with ARRAY_SIZE > 1 or a MATRIX_DIM specification.

Parameters
measurement | The measurement to get the physical value for
x | The column
y | The row
value | [out] the value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getPhysValue() [2/2]

bool getPhysValue | ( | A2LMEASUREMENT | measurement,
 |  | out double | value
 | ) |  |

Gets the last received physical value for the specified measurement address.

Parameters
measurement | The measurement to get the physical value for
value | [out] the value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getRawValue() [1/2]

bool getRawValue | ( | A2LMEASUREMENT | measurement,
 |  | int | x,
 |  | int | y,
 |  | out double | rawValue
 | ) |  |

Gets the last received raw value for the specified measurement address.

This is the version for an A2LMEASUREMENT with ARRAY_SIZE > 1 or a MATRIX_DIM specification.

Parameters
measurement | The measurement to get the raw value for
x | The column
y | The row
rawValue | [out] the raw value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getRawValue() [2/2]

bool getRawValue | ( | A2LMEASUREMENT | measurement,
 |  | out double | rawValue
 | ) |  |

Gets the last received raw value for the specified measurement address.

Parameters
measurement | The measurement to get the raw value for
rawValue | [out] the raw value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ setData()

bool setData | ( | uint | address,
 |  | byte[] | data
 | ) |  |

Sets the data to the specified address.

Parameters
address | The address to get the data fo
data | The data to set
Returns
true if successful

◆ setPhysValue()

bool setPhysValue | ( | A2LMEASUREMENT | measurement,
 |  | int | x,
 |  | int | y,
 |  | double | value
 | ) |  |

Sets the specified value to the measurement's memory.

This method is mainly used by the ECU simulator.

Parameters
measurement | The measurement
x | The column
y | The row
value | The physical value
Returns
true if the successful

Property Documentation

◆ DataChunks

List<byte[]> DataChunks
get

Gets the data chunks.

Do not modify, the data chunks are created by the constructor.

◆ MemoryRanges

MemoryRangeList MemoryRanges
get

Gets the created memory ranges.

Do not modify, the memory ranges are created by the constructor.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • MeasurementAccessData
MeasurementAccessData Member List

This is the complete list of members for MeasurementAccessData, including all inherited members.

DataChunks | MeasurementAccessData
getData(uint address, int size) | MeasurementAccessData
getData(uint address, int size, out byte[] data, out int offset) | MeasurementAccessData
getPhysValue(A2LMEASUREMENT measurement, out double value) | MeasurementAccessData
getPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | MeasurementAccessData
getRawValue(A2LMEASUREMENT measurement, out double rawValue) | MeasurementAccessData
getRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | MeasurementAccessData
MeasurementAccessData(List< A2LMEASUREMENT > measurements) | MeasurementAccessData
MemoryRanges | MeasurementAccessData
setData(uint address, byte[] data) | MeasurementAccessData
setPhysValue(A2LMEASUREMENT measurement, int x, int y, double value) | MeasurementAccessData


ASAP2Library interface: PARFile Class Reference

  • ASAP2
  • Values
  • PARFile
Public Types | Static Public Member Functions | List of all members
PARFile Class Reference

Implements the CANape PAR data File format reader/writer. More...

Public Types

enum ParType { Unknown , CANape_v3_1 , CANape_v3_2 }
CANApe Parameter file types. More...
- Public Types inherited from DataConservation
enum ErrorType {
NotFound , NotSupported , Format , TypeDiffers ,
NoOfElementsDiffers , XAxisInvalid , YAxisInvalid , ZAxisInvalid
}

Static Public Member Functions

static DataConservation | open (Stream stream, A2LMODULE module)
Opens a PAR file and returns a PARFile instance. More...
static DataConservation | open (string path, A2LMODULE module)
Opens a PAR file and returns a PARFile instance. More...
static int | save (string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics=null, Encoding encoding=null, ParType type=ParType.CANape_v3_1, bool deviceNumber=true, bool onlyCurrentVariant=false, string user="", string department="", string project="", string subject="")
Saves the specified characteristics into a PAR file. More...
static int | save (string path, string description, string a2LSource, string dataSource, IEnumerable< ICharValue > values, Encoding encoding=null, ParType type=ParType.CANape_v3_1, bool deviceNumber=true, bool onlyCurrentVariant=false, string user="", string department="", string project="", string subject="")
Saves the specified characteristics into a PAR file. More...

Additional Inherited Members

- Public Attributes inherited from DataConservation
IList< Tuple< string, ErrorType > > | SkippedValues = new List<Tuple<string, ErrorType>>()
Gets the list of skipped values from the parameter file.
- Static Protected Member Functions inherited from DataConservation
static string | buildDescription (A2LMODULE module, string description)
static int | checkAxis (A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize)
static void | getAxisDescription (A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis)
Gets axis descriptions from the specified characteristic. More...
static double | getValue (string par)
- Static Protected Attributes inherited from DataConservation
static readonly string | mEOL = Environment.NewLine
- Properties inherited from DataConservation
IList< ICharValue > | Values = new List<ICharValue>() [get]
Gets the list of succesfully imported values from the parameter file.

Detailed Description

Implements the CANape PAR data File format reader/writer.

The PAR format is a description of parameter sets for calibration purposes of electronic control units (ECUs). It represents a set of values for ECU internal calibration objects like parameters, curves and maps.The calibration values are stored in raw format. Physical values are stored as comment.

Member Enumeration Documentation

◆ ParType

enum ParType

CANApe Parameter file types.

Enumerator
CANape_v3_1 | CANape v3.1
CANape_v3_2 | CANape v3.2

Member Function Documentation

◆ open() [1/2]

static DataConservation open | ( | Stream | stream,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a PAR file and returns a PARFile instance.

Parameters
stream | Stream to read from
module | The module to read the characteristics from
Returns
A new PARFile instance or null if failed

◆ open() [2/2]

static DataConservation open | ( | string | path,
 |  | A2LMODULE | module
 | ) |  |
static

Opens a PAR file and returns a PARFile instance.

Parameters
path | the fully qualified PAR filename
module | The module to read the characteristics from
Returns
A new PARFile instance or null if failed

◆ save() [1/2]

static int save | ( | string | a2LSource,
 |  | IDataFile | dataFile,
 |  | A2LMODULE | module,
 |  | string | path,
 |  | string | description,
 |  | IEnumerable< A2LCHARACTERISTIC > | characteristics = null,
 |  | Encoding | encoding = null,
 |  | ParType | type = ParType.CANape_v3_1,
 |  | bool | deviceNumber = true,
 |  | bool | onlyCurrentVariant = false,
 |  | string | user = "",
 |  | string | department = "",
 |  | string | project = "",
 |  | string | subject = ""
 | ) |  |
static

Saves the specified characteristics into a PAR file.

This method adds missing COMAxis and CURVEAxis references automatically.

Parameters
a2LSource | The source A2L file or Database name, may be null or empty
dataFile | The datafile to read the values from
module | The module to read the characteristics from
path | the fully qualified path to the destination file
description | an optional (multiline) description for the file header
characteristics | The characteristics to save
encoding | Encoding (if not specified the Encoding.Default is taken)
type | Parameter file type
deviceNumber | Parameter file device number
onlyCurrentVariant | Parameter file only current variant information
user | user (shouldn't exceed 32 characters)
department | department (shouldn't exceed 32 characters)
project | project (shouldn't exceed 32 characters)
subject | subject (shouldn't exceed 32 characters)
Returns
count of written characteristics, -1 if failed

◆ save() [2/2]

static int save | ( | string | path,
 |  | string | description,
 |  | string | a2LSource,
 |  | string | dataSource,
 |  | IEnumerable< ICharValue > | values,
 |  | Encoding | encoding = null,
 |  | ParType | type = ParType.CANape_v3_1,
 |  | bool | deviceNumber = true,
 |  | bool | onlyCurrentVariant = false,
 |  | string | user = "",
 |  | string | department = "",
 |  | string | project = "",
 |  | string | subject = ""
 | ) |  |
static

Saves the specified characteristics into a PAR file.

Parameters
path | the fully qualified path to the destination file
description | an optional (multiline) description for the file header
a2LSource | The source A2L file or Database name, may be null or empty
dataSource | The source data file or parameter set name (may be null or empty)
values | The values to save into the PAR file (raw format required)
encoding | Encoding (if not specified the Encoding.Default is taken)
type | Parameter file type
deviceNumber | Parameter file device number
onlyCurrentVariant | Parameter file only current variant information
user | user (shouldn't exceed 32 characters)
department | department (shouldn't exceed 32 characters)
project | project (shouldn't exceed 32 characters)
subject | subject (shouldn't exceed 32 characters)
Returns
count of written characteristics, -1 if failed


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • PARFile
PARFile Member List

This is the complete list of members for PARFile, including all inherited members.

buildDescription(A2LMODULE module, string description) (defined in DataConservation) | DataConservation | protectedstatic
checkAxis(A2LAXIS_DESCR[] axisDescs, bool[] isVariableAxis, int idx, int srcSize) (defined in DataConservation) | DataConservation | protectedstatic
ErrorType enum name (defined in DataConservation) | DataConservation |
getAxisDescription(A2LRECORD_LAYOUT_REF layoutRef, out A2LAXIS_DESCR[] axisDescs, out bool[] isVariableAxis) | DataConservation | protectedstatic
getValue(string par) (defined in DataConservation) | DataConservation | protectedstatic
mEOL (defined in DataConservation) | DataConservation | protectedstatic
open(string path, A2LMODULE module) | PARFile | static
open(Stream stream, A2LMODULE module) | PARFile | static
ParType enum name | PARFile |
save(string a2LSource, IDataFile dataFile, A2LMODULE module, string path, string description, IEnumerable< A2LCHARACTERISTIC > characteristics=null, Encoding encoding=null, ParType type=ParType.CANape_v3_1, bool deviceNumber=true, bool onlyCurrentVariant=false, string user="", string department="", string project="", string subject="") | PARFile | static
save(string path, string description, string a2LSource, string dataSource, IEnumerable< ICharValue > values, Encoding encoding=null, ParType type=ParType.CANape_v3_1, bool deviceNumber=true, bool onlyCurrentVariant=false, string user="", string department="", string project="", string subject="") | PARFile | static
SkippedValues | DataConservation |
Values | DataConservation |


ASAP2Library interface: SingleValue Class Reference

  • ASAP2
  • Values
  • SingleValue
Public Member Functions | Protected Member Functions | List of all members
SingleValue Class Reference

Class representing a characteristic CHAR_TYPE.VALUE value. More...

Public Member Functions

SingleValue ()
Default constructor
SingleValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

override bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Additional Inherited Members

- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.VALUE value.

The ICharValue.Value in this case is of type double.

Constructor & Destructor Documentation

◆ SingleValue()

SingleValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ incrementOrDecrement()

override bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a single value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented from BaseValue.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • SingleValue
SingleValue Member List

This is the complete list of members for SingleValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | SingleValue | protectedvirtual
jnsoft::ASAP2::Values::BaseValue.incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
SingleValue() | SingleValue |
SingleValue(A2LRECORD_LAYOUT_REF characteristic) | SingleValue |
ToString() | BaseValue |


ASAP2Library interface: ValBlkValue Class Reference

  • ASAP2
  • Values
  • ValBlkValue
Public Member Functions | Protected Member Functions | List of all members
ValBlkValue Class Reference

Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value. More...

Public Member Functions

ValBlkValue ()
Default constructor
ValBlkValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
override string | ToString ()
- Public Member Functions inherited from BaseValue
BaseValue ()
Default constructor
BaseValue (A2LRECORD_LAYOUT_REF characteristic)
Specific constructor More...
int | CompareTo (ICharValue other)
Comparable interface implementation for single numerical values. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
override string | ToString ()
Gets a string representation of the value. More...

Protected Member Functions

override bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues)
Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
- Protected Member Functions inherited from BaseValue
double | getNextValue (bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod)
Gets the next value near to the specified value (by incrementing or decrementing). More...
virtual bool | incrementOrDecrement (IDataFile dataFile, bool increment, int count, IList< string > criterionValues)
Increments or decrements a single value by the specified increment/decrement count. More...
bool | incrementOrDecrement< T > (T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
bool | incrementOrDecrement< T > (T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)

Additional Inherited Members

- Protected Attributes inherited from BaseValue
double[][] | mAxisValue
A2LRECORD_LAYOUT_REF | mCharacteristic
int | mDecimalCount
int[] | mDecimalCountAxis
string | mUnit
string[] | mUnitAxis
object | mValue
ValueObjectFormat | mValueFormat
- Properties inherited from ICharValue
double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value.

The ICharValue.Value in this case is of type double[].

Constructor & Destructor Documentation

◆ ValBlkValue()

ValBlkValue ( A2LRECORD_LAYOUT_REF characteristic )

Specific constructor

Used from DCM, PAR import

Parameters
characteristic The corresponding characteristic

Member Function Documentation

◆ incrementOrDecrement()

override bool incrementOrDecrement | ( | IDataFile | dataFile,
 |  | bool | increment,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues
 | ) |  |
protectedvirtual

Increments or decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

Reimplemented from BaseValue.


ASAP2Library interface: Member List

  • ASAP2
  • Values
  • ValBlkValue
ValBlkValue Member List

This is the complete list of members for ValBlkValue, including all inherited members.

BaseValue() | BaseValue |
BaseValue(A2LRECORD_LAYOUT_REF characteristic) | BaseValue |
CompareTo(ICharValue other) | BaseValue |
GetFncValuesEnumerator() | BaseValue |
getNextValue(bool increment, double value, DATA_TYPE dt, A2LCOMPU_METHOD compuMethod) | BaseValue | protected
incrementOrDecrement(IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues) | ValBlkValue | protectedvirtual
jnsoft::ASAP2::Values::BaseValue.incrementOrDecrement(IDataFile dataFile, bool increment, int count, IList< string > criterionValues) | BaseValue | protectedvirtual
incrementOrDecrement< T >(T[] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
incrementOrDecrement< T >(T[,,] value, IDataFile dataFile, bool increment, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) (defined in BaseValue) | BaseValue | protected
mAxisValue (defined in BaseValue) | BaseValue | protected
mCharacteristic (defined in BaseValue) | BaseValue | protected
mDecimalCount (defined in BaseValue) | BaseValue | protected
mDecimalCountAxis (defined in BaseValue) | BaseValue | protected
mUnit (defined in BaseValue) | BaseValue | protected
mUnitAxis (defined in BaseValue) | BaseValue | protected
mValue (defined in BaseValue) | BaseValue | protected
mValueFormat (defined in BaseValue) | BaseValue | protected
ToString() (defined in ValBlkValue) | ValBlkValue |
ValBlkValue() | ValBlkValue |
ValBlkValue(A2LRECORD_LAYOUT_REF characteristic) | ValBlkValue |


ASAP2Library interface: jnsoft.ASAP2.XCP Namespace Reference

  • ASAP2
  • XCP
Classes | Enumerations
jnsoft.ASAP2.XCP Namespace Reference

Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff. More...

Classes

class | A2LXCP_ADDRESS_MAPPING
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_BUFFER_RESERVE
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT). More...
class | A2LXCP_CAN_FD
See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_CHECKSUM
class | A2LXCP_CLOCK
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation) More...
class | A2LXCP_CORE_LOAD
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core) More...
class | A2LXCP_DAQ
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_DAQ_EVENT
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_DAQ_LIST
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_DAQ_LIST_CAN_ID
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_DAQ_LIST_USB_ENDPOINT
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_DAQ_MEMORY_CONSUMPTION
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus) More...
class | A2LXCP_ECU_STATES_MEMORY_ACCESS
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State) More...
class | A2LXCP_ECU_STATES_STATE
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States) More...
class | A2LXCP_ENDPOINT
Base class for all endpoint classes. More...
class | A2LXCP_EVENT
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_EVENT_CAN_ID_LIST
See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption) More...
class | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue) More...
class | A2LXCP_EVENT_DAQ_PACKED_MODE
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists). More...
class | A2LXCP_EVENT_LIST
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_EVENT_MIN_CYCLE_TIME
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels). More...
class | A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table) More...
class | A2LXCP_FRAMING
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI More...
class | A2LXCP_IN_EP_ONLY_DAQ
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_IN_EP_ONLY_EVSERV
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_IN_EP_RESERR_DAQ_EVSERV
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_MEDIA
Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...) More...
class | A2LXCP_NAMEDNODE
Base class for all A2LXCP entities with specific names. More...
class | A2LXCP_NODE
Base class for all A2L node definitions concerning XCP. More...
class | A2LXCP_ODT
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED) More...
class | A2LXCP_ON_CAN
XCP on CAN parameters. More...
class | A2LXCP_ON_ETHERNET
Base class for the XCP ethernet media (UDP/TCP) More...
class | A2LXCP_ON_SxI
XCP on SxI parameters. More...
class | A2LXCP_ON_TCP_IP
XCP on TCP parameters. More...
class | A2LXCP_ON_UDP_IP
XCP on UDP parameters. More...
class | A2LXCP_ON_USB
XCP on USB parameters. More...
class | A2LXCP_OUT_EP_CMD_STIM
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_OUT_EP_ONLY_STIM
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...
class | A2LXCP_PAG
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_PAGE
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_PGM
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_PROTOCOL_LAYER
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_SECTOR
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_SEGMENT
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_STIM
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
class | A2LXCP_TIME_CORRELATION
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus) More...
class | A2LXCP_TIMESTAMP_CHARACTERIZATION
See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock) More...
class | A2LXCP_TIMESTAMP_SUPPORTED
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
struct | DAQAndEvt
Hold a DAQList with it's attached Event. More...
class | OptionalCommandSet
Represents a set of unique strings used to optional commands. More...
struct | XCPCommModes
Supported communication modes. More...

Enumerations

enum | ChecksumSxI { NotSet = -1 , NO_CHECKSUM , CHECKSUM_BYTE , CHECKSUM_WORD }
The XCP Tail may contain an optional BYTE or WORD size checksum. More...
enum CommModeBasic : byte {
NotSet = 0x00 , BigEndian = 0x01 , AddressGranularityBYTE = 0x00 , AddressGranularityWORD = 0x02 ,
AddressGranularityDWORD = 0x04 , SlaveBlockMode = 0x40 , Optional = 0x80
}
Basic communication mode flags. More...
enum | DTO_CTR_DAQ_MODE { NotSet , INSERT_COUNTER , INSERT_STIM_COUNTER_COPY }
When inserting the DTO CTR field. More...
enum | DTO_CTR_STIM_MODE { NotSet , DO_NOT_CHECK_COUNTER , CHECK_COUNTER }
When receiving DTOs with CTR field. More...
enum | PAGProperties : byte { NotSet = 0x00 , FreezeSupported = 0x01 }
The PAG properties is a bit mask described below. More...
enum | ParityType { NONE , ODD , EVEN }
See XCP Version 1.1, XCP over SxI
enum | StopBitsType { ONE_STOP_BIT = 1 , TWO_STOP_BITS = 2 }
See XCP Version 1.1, XCP over SxI
enum | SyncModeSize { NotSet , BYTE , WORD , DWORD = 4 }
See XCP Version 1.1, XCP over SxI
enum | XCP_ADDRESS_EXT : byte { FREE , ODT , DAQ }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum XCP_ADDRESS_MODE {
NotSet , DAQ , EVENT , ODT ,
NONE
}
See XCP Version 1.1, EVENT More...
enum | XCP_ALIGNMENT { _8_BIT = 1 , _16_BIT = _8_BIT << 1 , _32_BIT = _8_BIT << 2 , _64_BIT = _8_BIT << 3 }
Endpoint alignment for XCP on USB. More...
enum | XCP_BLOCK_MODE { STANDARD , SLAVE , MASTER = SLAVE << 1 , INTERLEAVED = SLAVE << 2 }
Possible supported BLOCK Modes. More...
enum | XCP_CLOCK_EPOCH { ATOMIC_TIME , UNIVERSAL_COORDINATED_TIME , ARBITRARY }
Clock Epoch's. More...
enum | XCP_CLOCK_MODE { XCP_SLAVE_CLOCK , ECU_CLOCK , XCP_SLAVE_GRANDMASTER_CLOCK , ECU_GRANDMASTER_CLOCK }
DAQ timestamp relation. More...
enum | XCP_CLOCK_READABILITY { RANDOMLY_READABLE , LIMITED_READABLE , NOT_READABLE }
Clock readability More...
enum | XCP_CLOCK_SYNC_FEATURE { SYN_UNSUPPORTED , SYNCHRONIZATION_ONLY , SYNTONIZATION_ONLY , SYN_ALL }
Synchronization features. More...
enum | XCP_DAQ_LIST_CAN_SAMPLE_RATE { NotSet , SINGLE , TRIPLE }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum | XCP_DAQ_LIST_CAN_TYPE { NotSet , VARIABLE , FIXED }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum | XCP_DAQ_LIST_TYPE { NotSet , DAQ , STIM , DAQ_STIM }
Supported types of the event channel. More...
enum | XCP_DAQ_MODE { STATIC , DYNAMIC }
Possible XCP DAQ modes. More...
enum | XCP_ECU_ACCESS : byte { NOT_ALLOWED = 1 , WITHOUT_XCP_ONLY = NOT_ALLOWED << 1 , WITH_XCP_ONLY = NOT_ALLOWED << 2 , DONT_CARE = NOT_ALLOWED << 3 }
Possible ECU access types.
enum | XCP_ENDPOINT { NotSet , IN , OUT }
Endpoint direction for XCP on USB. More...
enum | XCP_GROUP_MODE { ELEMENT_GROUPED , EVENT_GROUPED }
DAQ Event packed Group modes. More...
enum XCP_HEADER_LEN {
NotSet , BYTE , CTR_BYTE , FILL_BYTE ,
WORD , CTR_WORD , FILL_WORD
}
Header length for XCP on USB. More...
enum | XCP_ID_FIELD_TYPE { ABSOLUTE , BYTE , WORD , ALIGNED }
Defines the ID fields of the DAQKeyByte. More...
enum | XCP_MEMORY_ACCESS { NOT_ALLOWED , ALLOWED }
ECU State memory access. More...
enum | XCP_MESSAGE_PACKING { SINGLE , MULTIPLE , STREAMING }
Streaming mode for XCP on USB.
enum | XCP_NATIVE_TIMESTAMP_SIZE { FOUR_BYTE , EIGHT_BYTE }
Clocks timestamp characteristics native timestamp size
enum | XCP_ODT_ENTRY_SIZE : byte { BYTE = 1 , WORD = BYTE << 1 , DWORD = BYTE << 2 , DLONG = BYTE << 3 }
Granularity for size(granularity) of ODT entry (STIM or DAQ). More...
enum XCP_OPTIMISATION_TYPE : byte {
DEFAULT = 0x00 , ODT_TYPE_16 = 0x01 , ODT_TYPE_32 = 0x02 , ODT_TYPE_64 = ODT_TYPE_16 | ODT_TYPE_32 ,
ODT_TYPE_ALIGNMENT = 0x04 , MAX_ENTRY_SIZE = ODT_TYPE_ALIGNMENT | ODT_TYPE_16
}
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
enum | XCP_OVERLOAD_IND { NotSet , INDICATION , PID , EVENT }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum | XCP_PACK_MODE { OPTIONAL , MANDATORY }
DAQ Event packed modes. More...
enum | XCP_PACKET_ALIGMENT { _8 , _16 , _32 , NotSet }
Ethernet packet alignment.
enum | XCP_PGM_MODE { ABSOLUTE = 1 , FUNCTIONAL = ABSOLUTE << 1 }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
enum | XCP_READ_WRITE_ACCESS : byte { NOT_ALLOWED = 1 , WITHOUT_ECU_ONLY = NOT_ALLOWED << 1 , WITH_ECU_ONLY = NOT_ALLOWED << 2 , DONT_CARE = NOT_ALLOWED << 3 }
Possible read and write access types.
enum | XCP_RESOURCE_STATE { NOT_ACTIVE , ACTIVE }
ECU State resource states. More...
enum | XCP_STS_MODE { LAST , FIRST }
DAQ Event packed single timestamp modes. More...
enum | XCP_SYNCEDGE { NotSet , SINGLE , DUAL }
See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum XCP_TIMESTAMP_RESOLUTION : byte {
_1NS , _10NS , _100NS , _1US ,
_10US , _100US , _1MS , _10MS ,
_100MS , _1S , _1PS , _10PS ,
_100PS
}
Possible timestamp Resolutions. More...
enum | XCP_TIMESTAMP_SIZE { NotSet = 0 , BYTE = 1 , WORD = BYTE << 1 , DWORD = BYTE << 2 }
Possible timestamp size definitions. More...
enum | XCP_TRANSCEIVER_DELAY_COMPENSATION { NotSet , ON , OFF }
See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...
enum | XCP_TRANSFER { BULK_TRANSFER , INTERRUPT_TRANSFER }
Transfer types for XCP on USB.
enum | XCP_TS_RELATION { XCP_SLAVE_CLOCK , ECU_CLOCK }
DAQ timestamp relation. More...

Detailed Description

Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff.

Enumeration Type Documentation

◆ ChecksumSxI

enum ChecksumSxI

The XCP Tail may contain an optional BYTE or WORD size checksum.

The checksum is calculated by adding the bytes of the XCP Header, the bytes of the XCP Packet and the Fill bytes of the XCP Tail into a BYTE (ChecksumType.ADD_11) or WORD (ChecksumType.ADD_12), ignoring overflows.

Enumerator
NO_CHECKSUM | No checksum used.
CHECKSUM_BYTE | Checksum size is 1 byte.
CHECKSUM_WORD | Chekcsum size in 1 word.

◆ CommModeBasic

enum CommModeBasic : byte

Basic communication mode flags.

Used in A2LXCP_PROTOCOL_LAYER, RespConnect.

Enumerator
NotSet | not set
BigEndian | If not set, litle endian is used, big endian if set.
AddressGranularityBYTE | Address granularity is in bytes (8 Bit).
AddressGranularityWORD | Address granularity is in words (16 Bit).
AddressGranularityDWORD | Address granularity is in dwords (32 Bit).
SlaveBlockMode | The SlaveBlockMode flag indicates whether the Slave Block Mode is available.
Optional | The OPTIONAL flag indicates whether additional information on supported types of Communication mode is available. The master can get that additional information with GET_COMM_MODE_INFO.

◆ DTO_CTR_DAQ_MODE

enum DTO_CTR_DAQ_MODE

When inserting the DTO CTR field.

Enumerator
INSERT_COUNTER | use CTR of the related event channel
INSERT_STIM_COUNTER_COPY | use STIM CTR CPY of the related event channel

◆ DTO_CTR_STIM_MODE

enum DTO_CTR_STIM_MODE

When receiving DTOs with CTR field.

Enumerator
DO_NOT_CHECK_COUNTER | do not check CTR
CHECK_COUNTER | check CTR

◆ PAGProperties

enum PAGProperties : byte

The PAG properties is a bit mask described below.

Used in RespGetPagProcessorInfo.

Enumerator
FreezeSupported

The device supports freezing RAM memory to Flash.

◆ XCP_ADDRESS_EXT

enum XCP_ADDRESS_EXT : byte

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
FREE | address extension can be different within one and the same ODT.
ODT | address extension to be the same for all entries within one ODT.
DAQ | address extension to be the same for all entries within one DAQ.

◆ XCP_ADDRESS_MODE

enum XCP_ADDRESS_MODE

See XCP Version 1.1, EVENT

Enumerator
NotSet

not set

◆ XCP_ALIGNMENT

enum XCP_ALIGNMENT

Endpoint alignment for XCP on USB.

Enumerator
_8_BIT | 8 Bit alignment
_16_BIT | 16 Bit alignment
_32_BIT | 32 Bit alignment
_64_BIT | 64 Bit alignment

◆ XCP_BLOCK_MODE

enum XCP_BLOCK_MODE

Possible supported BLOCK Modes.

Enumerator
STANDARD | Standard mode
SLAVE | Slave Block mode is supported
MASTER | Master Block mode is supported
INTERLEAVED | Interleaved Block mode is supported

◆ XCP_CLOCK_EPOCH

enum XCP_CLOCK_EPOCH

Clock Epoch's.

Enumerator
ATOMIC_TIME | International Atomic Time (TAI)
UNIVERSAL_COORDINATED_TIME | Coordinated Universal Time (UTC)
ARBITRARY | unkown

◆ XCP_CLOCK_MODE

enum XCP_CLOCK_MODE

DAQ timestamp relation.

Enumerator
XCP_SLAVE_CLOCK |
ECU_CLOCK |
XCP_SLAVE_GRANDMASTER_CLOCK | related to XCP_SLAVE_CLOCK
ECU_GRANDMASTER_CLOCK | related to ECU_CLOCK in case of an external slave

◆ XCP_CLOCK_READABILITY

enum XCP_CLOCK_READABILITY

Clock readability

Enumerator
RANDOMLY_READABLE
LIMITED_READABLE
NOT_READABLE

◆ XCP_CLOCK_SYNC_FEATURE

enum XCP_CLOCK_SYNC_FEATURE

Synchronization features.

Enumerator
SYN_UNSUPPORTED | clock neither supports synchronization nor syntonization
SYNCHRONIZATION_ONLY | clock only supports synchronization to external grandmaster clock
SYNTONIZATION_ONLY | clock only supports syntonization to external grandmaster clock
SYN_ALL | clock supports synchronization as well as syntonization to external grandmaster clock

◆ XCP_DAQ_LIST_CAN_SAMPLE_RATE

enum XCP_DAQ_LIST_CAN_SAMPLE_RATE

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
NotSet | not set
SINGLE | 1 sample per bit
TRIPLE | 3 samples per bit

◆ XCP_DAQ_LIST_CAN_TYPE

enum XCP_DAQ_LIST_CAN_TYPE

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
NotSet

not set

◆ XCP_DAQ_LIST_TYPE

enum XCP_DAQ_LIST_TYPE

Supported types of the event channel.

Enumerator
NotSet | not set
DAQ | Only DAQ_LISTs with DIRECTION = DAQ.
STIM | Only STIM_LISTs with DIRECTION = STIM.
DAQ_STIM | both kind of DAQ_LISTs.

◆ XCP_DAQ_MODE

enum XCP_DAQ_MODE

Possible XCP DAQ modes.

Used in A2LXCP_DAQ.

Enumerator
STATIC | Static DAQ lists.
DYNAMIC | Dynamic DAQ lists.

◆ XCP_ENDPOINT

enum XCP_ENDPOINT

Endpoint direction for XCP on USB.

Enumerator
IN | IN Direction.
OUT | OUT Direction.

◆ XCP_GROUP_MODE

enum XCP_GROUP_MODE

DAQ Event packed Group modes.

Enumerator
ELEMENT_GROUPED | A0A1A2B0B1B2C0C1C2D0D1D2
EVENT_GROUPED | A0B0C0D0A1B1C1D1A2B2C2D2

◆ XCP_HEADER_LEN

enum XCP_HEADER_LEN

Header length for XCP on USB.

Enumerator
NotSet | This is the value to use for XCP on CAN.
BYTE | Only the message length in one byte.
CTR_BYTE | The message ctr and the length in one byte.
FILL_BYTE | The fill byte.
WORD | Only the message length in one word.
CTR_WORD | The message ctr and the length in one word.
FILL_WORD | The fill word

◆ XCP_ID_FIELD_TYPE

enum XCP_ID_FIELD_TYPE

Defines the ID fields of the DAQKeyByte.

Used in A2LXCP_DAQ.

Enumerator
ABSOLUTE | Absolute ODT number.
BYTE | Relative ODT number, absolute DAQ list number (BYTE).
WORD | Relative ODT number, absolute DAQ list number (WORD).
ALIGNED | Relative ODT number, absolute DAQ list.

◆ XCP_MEMORY_ACCESS

enum XCP_MEMORY_ACCESS

ECU State memory access.

Enumerator
NOT_ALLOWED | Memory access on resource is not allowed.
ALLOWED | Memory access on resource is allowed.

◆ XCP_ODT_ENTRY_SIZE

enum XCP_ODT_ENTRY_SIZE : byte

Granularity for size(granularity) of ODT entry (STIM or DAQ).

Used in A2LXCP_DAQ, A2LXCP_STIM.

Enumerator
BYTE | ODT entry size is a Byte (8 Bit).
WORD | ODT entry size is a Word (16 Bit).
DWORD | ODT entry size is a DWord (32 Bit).
DLONG | ODT entry size is a QWord (64 Bit).

◆ XCP_OVERLOAD_IND

enum XCP_OVERLOAD_IND

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
INDICATION

No overload indication.

◆ XCP_PACK_MODE

enum XCP_PACK_MODE

DAQ Event packed modes.

Enumerator
OPTIONAL | optional, EVENT allows also non-packed mode
MANDATORY | mandatory, only packed mode allowed

◆ XCP_RESOURCE_STATE

enum XCP_RESOURCE_STATE

ECU State resource states.

Enumerator
NOT_ACTIVE | Resource is not active.
ACTIVE | Resource is active.

◆ XCP_STS_MODE

enum XCP_STS_MODE

DAQ Event packed single timestamp modes.

Enumerator
LAST | single timestamp of last sample
FIRST | single timestamp of first sample

◆ XCP_SYNCEDGE

enum XCP_SYNCEDGE

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
NotSet | not set
SINGLE | on falling edge only
DUAL | on falling and rising edge

◆ XCP_TIMESTAMP_RESOLUTION

enum XCP_TIMESTAMP_RESOLUTION : byte

Possible timestamp Resolutions.

Used in A2LXCP_TIMESTAMP_SUPPORTED.

Enumerator
_1NS | 1 NS = 1 nanosecond = 10E-9 second = 1GHz.
_10NS | 10 NS = 10 nanoseconds = 10E-8 seconds = 100MHz.
_100NS | 100 NS = 100 nanoseconds = 10E-7 seconds = 10MHz.
_1US | 1 US = 1 microsecond = 10E-6 second = 1MHz.
_10US | 10 US = 10 microseconds = 10E-5 seconds = 100KHz.
_100US | 100 US = 100 microseconds = 10E-4 seconds = 10KHz.
_1MS | 1 MS = 1 millisecond = 10E-3 second = 1KHz.
_10MS | 10 MS = 10 milliseconds = 10E-2 seconds = 100Hz.
_100MS | 100 MS = 100 milliseconds = 10E-1 seconds = 10Hz.
_1S | 1 S = 1 second = 1Hz.
_1PS | 1 PS = 1 picosecond = 10E-12 second.
_10PS | 10 PS = 10 picoseconds = 10E-11 seconds.
_100PS | 100 PS = 100 picoseconds = 10E-10 seconds.

◆ XCP_TIMESTAMP_SIZE

enum XCP_TIMESTAMP_SIZE

Possible timestamp size definitions.

Used in A2LXCP_TIMESTAMP_SUPPORTED.

Enumerator
NotSet | No timestamp defined
BYTE | Timestamp size is a Byte (8 Bit).
WORD | Timestamp size is a Word (16 Bit).
DWORD | Timestamp size is a DWord (32 Bit).

◆ XCP_TRANSCEIVER_DELAY_COMPENSATION

enum XCP_TRANSCEIVER_DELAY_COMPENSATION

See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Enumerator
NotSet

not set

◆ XCP_TS_RELATION

enum XCP_TS_RELATION

DAQ timestamp relation.

Enumerator
XCP_SLAVE_CLOCK
ECU_CLOCK


ASAP2Library interface: A2LXCP_ADDRESS_MAPPING Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ADDRESS_MAPPING
Properties | List of all members
A2LXCP_ADDRESS_MAPPING Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

uint | DstAddress [getset]
uint | Length [getset]
uint | SrcAddress [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ADDRESS_MAPPING
A2LXCP_ADDRESS_MAPPING Member List

This is the complete list of members for A2LXCP_ADDRESS_MAPPING, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DstAddress (defined in A2LXCP_ADDRESS_MAPPING) | A2LXCP_ADDRESS_MAPPING |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length (defined in A2LXCP_ADDRESS_MAPPING) | A2LXCP_ADDRESS_MAPPING |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
SrcAddress (defined in A2LXCP_ADDRESS_MAPPING) | A2LXCP_ADDRESS_MAPPING |
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_BUFFER_RESERVE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_BUFFER_RESERVE
Properties | List of all members
A2LXCP_BUFFER_RESERVE Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT). More...

Properties

byte | ODT_DAQ [getset]
ODT_DAQ_BUFFER_ELEMENT_RESERVE in % of ODT_DAQ_BUFFER_ELEMENT_SIZE
byte | ODT_STIM [getset]
ODT_STIM_BUFFER_ELEMENT_RESERVE in % of ODT_STIM_BUFFER_ELEMENT_SIZE
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT).

Overrules default BUFFER_RESERVE for this EVENT.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_BUFFER_RESERVE
A2LXCP_BUFFER_RESERVE Member List

This is the complete list of members for A2LXCP_BUFFER_RESERVE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODT_DAQ | A2LXCP_BUFFER_RESERVE |
ODT_STIM | A2LXCP_BUFFER_RESERVE |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_CAN_FD Class Reference

  • ASAP2
  • XCP
  • A2LXCP_CAN_FD
Properties | List of all members
A2LXCP_CAN_FD Class Reference

See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

byte | BTLCycles [getset]
BTL_CYCLES [slots per bit time].
uint | DataTransferBaudrate [getset]
Data transfer BAUDRATE [Hz].
ushort | MaxDLC = 8 [getset]
Values of 8, 12, 16, 20, 24, 32, 48 or 64 are valid.
bool | MaxDLCRequired [getset]
Master to slave frames always to have DLC = MAX_DLC for CAN-FD.
byte | SamplePoint [getset]
Sample point receiver [% complete bit time].
byte | SecondarySamplePoint [getset]
Sender sample point [% complete bit time].
byte | SJW [getset]
Length synchr. segment [BTL_CYCLES].
XCP_SYNCEDGE | SyncEdge [getset]
XCP_TRANSCEIVER_DELAY_COMPENSATION | TransceiverDelayCompensation [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_CAN_FD
A2LXCP_CAN_FD Member List

This is the complete list of members for A2LXCP_CAN_FD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BTLCycles | A2LXCP_CAN_FD |
ChangedType | A2LNODE |
Childs | A2LNODE |
DataTransferBaudrate | A2LXCP_CAN_FD |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxDLC | A2LXCP_CAN_FD |
MaxDLCRequired | A2LXCP_CAN_FD |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
SamplePoint | A2LXCP_CAN_FD |
SecondarySamplePoint | A2LXCP_CAN_FD |
SJW | A2LXCP_CAN_FD |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SyncEdge (defined in A2LXCP_CAN_FD) | A2LXCP_CAN_FD |
Tag | A2LNODE |
TransceiverDelayCompensation (defined in A2LXCP_CAN_FD) | A2LXCP_CAN_FD |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_CHECKSUM Class Reference

  • ASAP2
  • XCP
  • A2LXCP_CHECKSUM
Properties | List of all members
A2LXCP_CHECKSUM Class Reference

More...

Properties

ChecksumType | CheckSum [getset]
The checksum computation method defined to compute checksums.
string | ExternalFunction [getset]
Name of the Checksum function including file extension without path (optional).
uint | MaxBlockSize = uint.MaxValue [getset]
Maximum block size for checksum calculation (optional).
ushort | MTABlockSizeAlign [getset]
Required alignment of MTA and block size (XCPplus)
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_CHECKSUM
A2LXCP_CHECKSUM Member List

This is the complete list of members for A2LXCP_CHECKSUM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
CheckSum | A2LXCP_CHECKSUM |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
ExternalFunction | A2LXCP_CHECKSUM |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxBlockSize | A2LXCP_CHECKSUM |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
MTABlockSizeAlign | A2LXCP_CHECKSUM |
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_CLOCK Class Reference

  • ASAP2
  • XCP
  • A2LXCP_CLOCK
Properties | List of all members
A2LXCP_CLOCK Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation) More...

Properties

XCP_CLOCK_EPOCH | Epoch [getset]
XCP_CLOCK_SYNC_FEATURE | Feature [getset]
ulong | MaxTimestmampValueBeforeWraparound [getset]
XCP_CLOCK_MODE | Mode [getset]
byte | Quality [getset]
Clock quality, stratum level
XCP_CLOCK_READABILITY | Readability [getset]
byte[] | UUID = new byte[8] [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_CLOCK
A2LXCP_CLOCK Member List

This is the complete list of members for A2LXCP_CLOCK, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
Epoch (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
Feature (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxTimestmampValueBeforeWraparound (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Mode (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Quality | A2LXCP_CLOCK |
Readability (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
UUID (defined in A2LXCP_CLOCK) | A2LXCP_CLOCK |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_CORE_LOAD Class Reference

  • ASAP2
  • XCP
  • A2LXCP_CORE_LOAD
Properties | List of all members
A2LXCP_CORE_LOAD Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core) More...

Properties

float | CORE_LOAD [getset]
max load or max of this event part
uint | CORE_NR [getset]
Core reference number
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_CORE_LOAD
A2LXCP_CORE_LOAD Member List

This is the complete list of members for A2LXCP_CORE_LOAD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CORE_LOAD | A2LXCP_CORE_LOAD |
CORE_NR | A2LXCP_CORE_LOAD |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ
Public Member Functions | Properties | List of all members
A2LXCP_DAQ Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Public Member Functions

byte | getIDFieldSize ()
Gets the size of the ID field. More...
bool | isDAQDynamic ()
Indicates if DAQs are configured dynamically.
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

XCP_ADDRESS_EXT | AdrExt [getset]
float | CoreLoadMaxTotal [getset]
Configuration limit Core load, (XCPplus extension)
float | CpuLoadMaxTotal [getset]
Configuration limit CPU load, (XCPplus extension)
ushort | DAQAlternatingSupported = ushort.MaxValue [getset]
Display Event Channel Number.
SortedDictionary< ushort, DAQAndEvt > | DAQAndEvtMap = new SortedDictionary<ushort, DAQAndEvt>() [get]
Holds DAQ List and corresponding XCP Event
bool | DtoCtrFieldSupported [getset]
XCP_ID_FIELD_TYPE | IDField [getset]
ushort | MaxDAQ [getset]
Gets or sets the maximum number of DAQ Lists (static and configurable ones).
ushort | MaxDAQTotal = ushort.MaxValue [getset]
Configuration limit DAQ, (XCPplus extension)
ushort | MaxEvtChn [getset]
Gets or sets the maximum number of available event channels
ushort | MaxODTDAQTotal = ushort.MaxValue [getset]
Configuration limit ODT/DAQ, (XCPplus extension)
ushort | MaxODTEntriesDAQTotal = ushort.MaxValue [getset]
Configuration limit ODT Entries on DAQ, (XCPplus extension)
ushort | MaxODTEntriesSTIMTotal = ushort.MaxValue [getset]
Configuration limit ODT Entries on STIM, (XCPplus extension)
ushort | MaxODTEntriesTotal = ushort.MaxValue [getset]
Configuration limit ODT Entries, (XCPplus extension)
byte | MaxODTEntrySize [getset]
Gets or sets the maxmimum size in bytes of a single ODT entry.
ushort | MaxODTSTIMTotal = ushort.MaxValue [getset]
Configuration limit ODT/STIM, (XCPplus extension)
ushort | MaxODTTotal = ushort.MaxValue [getset]
Configuration limit ODT, (XCPplus extension)
byte | MinDAQ [getset]
Gets or sets the first configurable DAQ List number
XCP_DAQ_MODE | Mode [getset]
Gets or sets a value if the DAQ lists that are not PREDEFINED shall be configured statically or dynamically.
XCP_ODT_ENTRY_SIZE | ODTEntrySize = XCP_ODT_ENTRY_SIZE.BYTE [getset]
XCP_OPTIMISATION_TYPE | OptType [getset]
XCP_OVERLOAD_IND | OverloadInd [getset]
bool | PIDOffSupported [getset]
bool | PrescalerSupported [getset]
bool | ResumeSupported [getset]
bool | StoreDAQSupported [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Member Function Documentation

◆ getIDFieldSize()

byte getIDFieldSize ( )

Gets the size of the ID field.

Returns


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ
A2LXCP_DAQ Member List

This is the complete list of members for A2LXCP_DAQ, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AdrExt (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
ChangedType | A2LNODE |
Childs | A2LNODE |
CoreLoadMaxTotal | A2LXCP_DAQ |
CpuLoadMaxTotal | A2LXCP_DAQ |
DAQAlternatingSupported | A2LXCP_DAQ |
DAQAndEvtMap | A2LXCP_DAQ |
deleteFromModel(A2LNODE node) | A2LNODE | static
DtoCtrFieldSupported (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getIDFieldSize() | A2LXCP_DAQ |
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IDField (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
isDAQDynamic() | A2LXCP_DAQ |
IsInstanced | A2LNODE |
MaxDAQ | A2LXCP_DAQ |
MaxDAQTotal | A2LXCP_DAQ |
MaxEvtChn | A2LXCP_DAQ |
MaxODTDAQTotal | A2LXCP_DAQ |
MaxODTEntriesDAQTotal | A2LXCP_DAQ |
MaxODTEntriesSTIMTotal | A2LXCP_DAQ |
MaxODTEntriesTotal | A2LXCP_DAQ |
MaxODTEntrySize | A2LXCP_DAQ |
MaxODTSTIMTotal | A2LXCP_DAQ |
MaxODTTotal | A2LXCP_DAQ |
mFilterLine (defined in A2LNODE) | A2LNODE | static
MinDAQ | A2LXCP_DAQ |
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Mode | A2LXCP_DAQ |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODTEntrySize (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
OptType (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
OverloadInd (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
Parent | A2LNODE |
PIDOffSupported (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
PrescalerSupported (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
ResumeSupported (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StoreDAQSupported (defined in A2LXCP_DAQ) | A2LXCP_DAQ |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ_EVENT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ_EVENT
Properties | List of all members
A2LXCP_DAQ_EVENT Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

ushort[] | Events [getset]
Events of a fixed event list (may be null or empty).
- Properties inherited from A2LXCP_NAMEDNODE
sealed override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ_EVENT
A2LXCP_DAQ_EVENT Member List

This is the complete list of members for A2LXCP_DAQ_EVENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
Events | A2LXCP_DAQ_EVENT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LXCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ_LIST Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST
Properties | List of all members
A2LXCP_DAQ_LIST Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

bool | Active = true [getset]
Used from the XCPMaster to mark as available for online measuring.
XCP_DAQ_LIST_TYPE | DAQListType [getset]
ushort | DAQNo [getset]
ushort | EventFixed = ushort.MaxValue [getset]
Always fixed to this A2LXCP_EVENT. More...
byte | FirstPID [getset]
byte | MaxODT [getset]
byte | MaxODTEntries [getset]
bool | PackedModeSupported [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Property Documentation

◆ EventFixed

ushort EventFixed = ushort.MaxValue
getset

Always fixed to this A2LXCP_EVENT.

If not defined the value is ushort.MaxValue.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST
A2LXCP_DAQ_LIST Member List

This is the complete list of members for A2LXCP_DAQ_LIST, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_DAQ_LIST() (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
Active | A2LXCP_DAQ_LIST |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQListType (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
DAQNo (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EventFixed | A2LXCP_DAQ_LIST |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FirstPID (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxODT (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
MaxODTEntries (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
PackedModeSupported (defined in A2LXCP_DAQ_LIST) | A2LXCP_DAQ_LIST |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ_LIST_CAN_ID Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST_CAN_ID
Properties | List of all members
A2LXCP_DAQ_LIST_CAN_ID Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

uint | CANId [getset]
XCP_DAQ_LIST_CAN_TYPE | DAQListType [getset]
ushort | DAQNo [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST_CAN_ID
A2LXCP_DAQ_LIST_CAN_ID Member List

This is the complete list of members for A2LXCP_DAQ_LIST_CAN_ID, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CANId (defined in A2LXCP_DAQ_LIST_CAN_ID) | A2LXCP_DAQ_LIST_CAN_ID |
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQListType (defined in A2LXCP_DAQ_LIST_CAN_ID) | A2LXCP_DAQ_LIST_CAN_ID |
DAQNo (defined in A2LXCP_DAQ_LIST_CAN_ID) | A2LXCP_DAQ_LIST_CAN_ID |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ_LIST_USB_ENDPOINT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST_USB_ENDPOINT
Properties | List of all members
A2LXCP_DAQ_LIST_USB_ENDPOINT Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Properties

ushort | DAQNo [getset]
Gets or sets the referenced DAQ Number.
byte | EPNo = byte.MaxValue [getset]
Gets or sets the EndPoint Number. More...
XCP_ENDPOINT | EPType = XCP_ENDPOINT.NotSet [getset]
Gets or sets the EndPoint type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB

Property Documentation

◆ EPNo

byte EPNo = byte.MaxValue
getset

Gets or sets the EndPoint Number.

Only valid if EndPoint type is set.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ_LIST_USB_ENDPOINT
A2LXCP_DAQ_LIST_USB_ENDPOINT Member List

This is the complete list of members for A2LXCP_DAQ_LIST_USB_ENDPOINT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQNo | A2LXCP_DAQ_LIST_USB_ENDPOINT |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_DAQ_LIST_USB_ENDPOINT |
EPType | A2LXCP_DAQ_LIST_USB_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_DAQ_MEMORY_CONSUMPTION Class Reference

  • ASAP2
  • XCP
  • A2LXCP_DAQ_MEMORY_CONSUMPTION
Properties | List of all members
A2LXCP_DAQ_MEMORY_CONSUMPTION Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus) More...

Properties

uint | DAQMemoryLimit [getset]
DAQ_MEMORY_LIMIT: in Elements[AG]
ushort | DAQSize [getset]
DAQ_SIZE: number of elements[AG] per DAQ list
ushort | ODTDAQBufferElementSize [getset]
ODT_DAQ_BUFFER_ELEMENT_SIZE: number of payload elements[AG]*factor = sizeof(send buffer)[AG]
ushort | ODTEntrySize [getset]
ODT_ENTRY_SIZE: number of elements[AG] per ODT_entry
ushort | ODTSize [getset]
ODT_SIZE: number of elements[AG] per ODT
ushort | ODTSTIMBufferElementSize [getset]
ODT_STIM_BUFFER_ELEMENT_SIZE: number of payload elements[AG]*factor = sizeof(send buffer)[AG]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_DAQ_MEMORY_CONSUMPTION
A2LXCP_DAQ_MEMORY_CONSUMPTION Member List

This is the complete list of members for A2LXCP_DAQ_MEMORY_CONSUMPTION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQMemoryLimit | A2LXCP_DAQ_MEMORY_CONSUMPTION |
DAQSize | A2LXCP_DAQ_MEMORY_CONSUMPTION |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODTDAQBufferElementSize | A2LXCP_DAQ_MEMORY_CONSUMPTION |
ODTEntrySize | A2LXCP_DAQ_MEMORY_CONSUMPTION |
ODTSize | A2LXCP_DAQ_MEMORY_CONSUMPTION |
ODTSTIMBufferElementSize | A2LXCP_DAQ_MEMORY_CONSUMPTION |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ECU_STATES_MEMORY_ACCESS Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ECU_STATES_MEMORY_ACCESS
Properties | List of all members
A2LXCP_ECU_STATES_MEMORY_ACCESS Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State) More...

Properties

XCP_MEMORY_ACCESS | ReadAccess [getset]
XCP_MEMORY_ACCESS | WriteAccess [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ECU_STATES_MEMORY_ACCESS
A2LXCP_ECU_STATES_MEMORY_ACCESS Member List

This is the complete list of members for A2LXCP_ECU_STATES_MEMORY_ACCESS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadAccess (defined in A2LXCP_ECU_STATES_MEMORY_ACCESS) | A2LXCP_ECU_STATES_MEMORY_ACCESS |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
WriteAccess (defined in A2LXCP_ECU_STATES_MEMORY_ACCESS) | A2LXCP_ECU_STATES_MEMORY_ACCESS |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ECU_STATES_STATE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ECU_STATES_STATE
Properties | List of all members
A2LXCP_ECU_STATES_STATE Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States) More...

Properties

XCP_RESOURCE_STATE | CAL_PAG [getset]
XCP_RESOURCE_STATE | DAQ [getset]
XCP_RESOURCE_STATE | PGM [getset]
string | StateName [getset]
byte | StateNumber [getset]
XCP_RESOURCE_STATE | STIM [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ECU_STATES_STATE
A2LXCP_ECU_STATES_STATE Member List

This is the complete list of members for A2LXCP_ECU_STATES_STATE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
CAL_PAG (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQ (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PGM (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StateName (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
StateNumber (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
STIM (defined in A2LXCP_ECU_STATES_STATE) | A2LXCP_ECU_STATES_STATE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ENDPOINT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ENDPOINT
Properties | List of all members
A2LXCP_ENDPOINT Class Reference

Base class for all endpoint classes. More...

Properties

XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all endpoint classes.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ENDPOINT
A2LXCP_ENDPOINT Member List

This is the complete list of members for A2LXCP_ENDPOINT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT
Properties | List of all members
A2LXCP_EVENT Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

ushort | COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = ushort.MaxValue [getset]
For compatibility reasons not to be considered, if 1.3 Bypassing features are implemented, ushort.MaxValue if not defined
XCP_ADDRESS_MODE | Consistency [getset]
float | CPU_LOAD_MAX [getset]
XCP_DAQ_LIST_TYPE | DAQListType [getset]
DTO_CTR_DAQ_MODE | DTO_CTR_DAQ_MODE = DTO_CTR_DAQ_MODE.NotSet [getset]
bool | DTO_CTR_DAQ_MODE_FIXED [getset]
DTO_CTR_STIM_MODE | DTO_CTR_STIM_MODE = DTO_CTR_STIM_MODE.NotSet [getset]
bool | DTO_CTR_STIM_MODE_FIXED [getset]
bool | EVENT_COUNTER_PRESENT [getset]
ushort | Id [getset]
byte | MaxDAQList [getset]
string | NameLong [getset]
string | NameShort [getset]
byte | Priority [getset]
ushort | RELATED_EVENT_CHANNEL_NUMBER = ushort.MaxValue [getset]
ushort.MaxValue if not defined
bool | RELATED_EVENT_CHANNEL_NUMBER_FIXED [getset]
bool | STIM_DTO_CTR_COPY_PRESENT [getset]
byte | TimeCycle [getset]
XCP_TIMESTAMP_RESOLUTION | TimeUnit [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT
A2LXCP_EVENT Member List

This is the complete list of members for A2LXCP_EVENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER | A2LXCP_EVENT |
Consistency (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
CPU_LOAD_MAX (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
DAQListType (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
deleteFromModel(A2LNODE node) | A2LNODE | static
DTO_CTR_DAQ_MODE (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
DTO_CTR_DAQ_MODE_FIXED (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
DTO_CTR_STIM_MODE (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
DTO_CTR_STIM_MODE_FIXED (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EVENT_COUNTER_PRESENT (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
Id (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
IsInstanced | A2LNODE |
MaxDAQList (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NameLong (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
NameShort (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Priority (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
RELATED_EVENT_CHANNEL_NUMBER | A2LXCP_EVENT |
RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
STIM_DTO_CTR_COPY_PRESENT (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
Tag | A2LNODE |
TimeCycle (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
TimeUnit (defined in A2LXCP_EVENT) | A2LXCP_EVENT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_CAN_ID_LIST Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CAN_ID_LIST
Properties | List of all members
A2LXCP_EVENT_CAN_ID_LIST Class Reference

See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

ushort | EvtNo [getset]
Reference to EVENT_NUMBER.
uint[] | FixedCANIds [getset]
This event is associated with this CAN IDs (may be null or empty).
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CAN_ID_LIST
A2LXCP_EVENT_CAN_ID_LIST Member List

This is the complete list of members for A2LXCP_EVENT_CAN_ID_LIST, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EvtNo | A2LXCP_EVENT_CAN_ID_LIST |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FixedCANIds | A2LXCP_EVENT_CAN_ID_LIST |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_CPU_LOAD_CONSUMPTION Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CPU_LOAD_CONSUMPTION
Properties | List of all members
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption) More...

Properties

float | DAQ_FACTOR [getset]
float | ODT_ENTRY_FACTOR [getset]
float | ODT_FACTOR [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CPU_LOAD_CONSUMPTION
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION Member List

This is the complete list of members for A2LXCP_EVENT_CPU_LOAD_CONSUMPTION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
DAQ_FACTOR (defined in A2LXCP_EVENT_CPU_LOAD_CONSUMPTION) | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODT_ENTRY_FACTOR (defined in A2LXCP_EVENT_CPU_LOAD_CONSUMPTION) | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION |
ODT_FACTOR (defined in A2LXCP_EVENT_CPU_LOAD_CONSUMPTION) | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE
Properties | List of all members
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue) More...

Properties

float | ODT_ELEMENT_LOAD [getset]
float | ODT_FACTOR [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE Member List

This is the complete list of members for A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODT_ELEMENT_LOAD (defined in A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE) | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE |
ODT_FACTOR (defined in A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE) | A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_DAQ_PACKED_MODE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_DAQ_PACKED_MODE
Properties | List of all members
A2LXCP_EVENT_DAQ_PACKED_MODE Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists). More...

Properties

List< ushort > | AltSampleCounts = new List<ushort>() [getset]
other valid sample count values (optional)
XCP_GROUP_MODE | GroupMode [getset]
DAQ packed mode, applies for all associated DAQ lists
XCP_PACK_MODE | PackMode [getset]
Usage
ushort | SampleCount [getset]
DAQ packed mode sample count
XCP_STS_MODE | STSMode [getset]
Single Timestamp mode
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists).


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_DAQ_PACKED_MODE
A2LXCP_EVENT_DAQ_PACKED_MODE Member List

This is the complete list of members for A2LXCP_EVENT_DAQ_PACKED_MODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AltSampleCounts | A2LXCP_EVENT_DAQ_PACKED_MODE |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
GroupMode | A2LXCP_EVENT_DAQ_PACKED_MODE |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
PackMode | A2LXCP_EVENT_DAQ_PACKED_MODE |
Parent | A2LNODE |
SampleCount | A2LXCP_EVENT_DAQ_PACKED_MODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
STSMode | A2LXCP_EVENT_DAQ_PACKED_MODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_LIST Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_LIST
Properties | List of all members
A2LXCP_EVENT_LIST Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

List< ushort > | Events = new List<ushort>() [getset]
Events of a fixed event list (may be null or empty).
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_LIST
A2LXCP_EVENT_LIST Member List

This is the complete list of members for A2LXCP_EVENT_LIST, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
Events | A2LXCP_EVENT_LIST |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_MIN_CYCLE_TIME Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_MIN_CYCLE_TIME
Properties | List of all members
A2LXCP_EVENT_MIN_CYCLE_TIME Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels). More...

Properties

byte | TimeCycle [getset]
XCP_TIMESTAMP_RESOLUTION | TimeUnit [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels).

  • See XCP Version 1.3, Event channels
  • Configuration with 0-0 not allowed.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_MIN_CYCLE_TIME
A2LXCP_EVENT_MIN_CYCLE_TIME Member List

This is the complete list of members for A2LXCP_EVENT_MIN_CYCLE_TIME, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TimeCycle (defined in A2LXCP_EVENT_MIN_CYCLE_TIME) | A2LXCP_EVENT_MIN_CYCLE_TIME |
TimeUnit (defined in A2LXCP_EVENT_MIN_CYCLE_TIME) | A2LXCP_EVENT_MIN_CYCLE_TIME |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE
Properties | List of all members
A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table) More...

Properties

uint | SIZE [getset]
float | SIZE_FACTOR [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE
A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE Member List

This is the complete list of members for A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
SIZE (defined in A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE) | A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE |
SIZE_FACTOR (defined in A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE) | A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_FRAMING Class Reference

  • ASAP2
  • XCP
  • A2LXCP_FRAMING
Properties | List of all members
A2LXCP_FRAMING Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI More...

Properties

byte | ESC [getset]
byte | SYNC [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI

The framing protocol defines two special characters: SYNC and ESC. If framing is used, every XCP on SCI Message is preceded by a SYNC character.

if a data bytes contained in the SxI frame equals SYNC or ESC they are escaped using the ESC byte.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_FRAMING
A2LXCP_FRAMING Member List

This is the complete list of members for A2LXCP_FRAMING, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
ESC (defined in A2LXCP_FRAMING) | A2LXCP_FRAMING |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SYNC (defined in A2LXCP_FRAMING) | A2LXCP_FRAMING |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_IN_EP_ONLY_DAQ Class Reference

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_ONLY_DAQ
Public Member Functions | List of all members
A2LXCP_IN_EP_ONLY_DAQ Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Public Member Functions

A2LXCP_IN_EP_ONLY_DAQ (int startLine)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ENDPOINT
XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_ONLY_DAQ
A2LXCP_IN_EP_ONLY_DAQ Member List

This is the complete list of members for A2LXCP_IN_EP_ONLY_DAQ, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_IN_EP_ONLY_DAQ() (defined in A2LXCP_IN_EP_ONLY_DAQ) | A2LXCP_IN_EP_ONLY_DAQ |
A2LXCP_IN_EP_ONLY_DAQ(int startLine) (defined in A2LXCP_IN_EP_ONLY_DAQ) | A2LXCP_IN_EP_ONLY_DAQ |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_IN_EP_ONLY_EVSERV Class Reference

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_ONLY_EVSERV
Public Member Functions | List of all members
A2LXCP_IN_EP_ONLY_EVSERV Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Public Member Functions

A2LXCP_IN_EP_ONLY_EVSERV (int startLine)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ENDPOINT
XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_ONLY_EVSERV
A2LXCP_IN_EP_ONLY_EVSERV Member List

This is the complete list of members for A2LXCP_IN_EP_ONLY_EVSERV, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_IN_EP_ONLY_EVSERV() (defined in A2LXCP_IN_EP_ONLY_EVSERV) | A2LXCP_IN_EP_ONLY_EVSERV |
A2LXCP_IN_EP_ONLY_EVSERV(int startLine) (defined in A2LXCP_IN_EP_ONLY_EVSERV) | A2LXCP_IN_EP_ONLY_EVSERV |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_IN_EP_RESERR_DAQ_EVSERV Class Reference

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_RESERR_DAQ_EVSERV
Public Member Functions | List of all members
A2LXCP_IN_EP_RESERR_DAQ_EVSERV Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Public Member Functions

A2LXCP_IN_EP_RESERR_DAQ_EVSERV (int startLine)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ENDPOINT
XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_IN_EP_RESERR_DAQ_EVSERV
A2LXCP_IN_EP_RESERR_DAQ_EVSERV Member List

This is the complete list of members for A2LXCP_IN_EP_RESERR_DAQ_EVSERV, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_IN_EP_RESERR_DAQ_EVSERV() (defined in A2LXCP_IN_EP_RESERR_DAQ_EVSERV) | A2LXCP_IN_EP_RESERR_DAQ_EVSERV |
A2LXCP_IN_EP_RESERR_DAQ_EVSERV(int startLine) (defined in A2LXCP_IN_EP_RESERR_DAQ_EVSERV) | A2LXCP_IN_EP_RESERR_DAQ_EVSERV |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_MEDIA Class Reference

  • ASAP2
  • XCP
  • A2LXCP_MEDIA
Public Member Functions | Protected Member Functions | Properties | List of all members
A2LXCP_MEDIA Class Reference

Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...) More...

Public Member Functions

void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...)

Member Function Documentation

◆ getSettings()

void getSettings | ( | out A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | out A2LXCP_CHECKSUM | checksum,
 |  | out A2LXCP_PAG | pag,
 |  | out A2LXCP_DAQ | daq,
 |  | out A2LXCP_PGM | pgm
 | ) |  |

Gets the XCP settings for this instance.

Parameters
protocolLayer | only valid if return value is true
checksum | may be null and may only valid if return value is true
pag | The XCP PAG section (may be null and may only valid if return value is true)
daq | The XCP DAQ section (may be null and may only valid if return value is true)
pgm | The XCP PGM section (may be null and may only valid if return value is true)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_MEDIA
A2LXCP_MEDIA Member List

This is the complete list of members for A2LXCP_MEDIA, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
IsInstanced | A2LNODE |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_NAMEDNODE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_NAMEDNODE
Properties | List of all members
A2LXCP_NAMEDNODE Class Reference

Base class for all A2LXCP entities with specific names. More...

Properties

sealed override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2LXCP entities with specific names.

Property Documentation

◆ Name

sealed override string Name
getset

Gets the name of the node.

Use the setter with care! Changing the name requires to adjust all references to this instance.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_NAMEDNODE
A2LXCP_NAMEDNODE Member List

This is the complete list of members for A2LXCP_NAMEDNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LXCP_NAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_NODE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_NODE
Static Public Member Functions | Static Protected Member Functions | Static Protected Attributes | List of all members
A2LXCP_NODE Class Reference

Base class for all A2L node definitions concerning XCP. More...

Static Public Member Functions

static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Static Protected Member Functions

static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...

Static Protected Attributes

const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

Base class for all A2L node definitions concerning XCP.

Member Function Documentation

◆ getCommModes()

static XCPCommModes getCommModes | ( | A2LXCP_NODE | node,
 |  | A2LParser | parser,
 |  | ref List< string > | parameterList,
 |  | ref int | i
 | ) |  |
staticprotected

Gets the supported communciation modes, if defined.

Parameters
node | An XCP node instance
parameterList | The parameter list
i | The index into the parameter list to start from
parser | The parser object for notifiying messages
Returns
supported communication mode instance

◆ getCycleTime()

static string getCycleTime | ( | XCP_TIMESTAMP_RESOLUTION | res,
 |  | byte | timeCycle
 | ) |  |
static

Gets the cycle time from timestamp resolution and time cycle.

Parameters
res
timeCycle
Returns


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_NODE
A2LXCP_NODE Member List

This is the complete list of members for A2LXCP_NODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ODT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ODT
Classes | Properties | List of all members
A2LXCP_ODT Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED) More...

Classes

class ODT_ENTRY
Represents a single ODT entry. More...

Properties

List< ODT_ENTRY > | ODTEntries = new List<ODT_ENTRY>() [getset]
Set of ODT Entries (may be null or empty).
byte | ODTNo [getset]
ODT Number
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ODT
A2LXCP_ODT Member List

This is the complete list of members for A2LXCP_ODT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODTEntries | A2LXCP_ODT |
ODTNo | A2LXCP_ODT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ODT.ODT_ENTRY Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ODT
  • ODT_ENTRY
Properties | List of all members
A2LXCP_ODT.ODT_ENTRY Class Reference

Represents a single ODT entry. More...

Properties

uint | Address [getset]
byte | AddressExtension [getset]
byte | BitOffset [getset]
byte | OdtEntryNo [getset]
byte | Size [getset]

Detailed Description

Represents a single ODT entry.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ODT
  • ODT_ENTRY
A2LXCP_ODT.ODT_ENTRY Member List

This is the complete list of members for A2LXCP_ODT.ODT_ENTRY, including all inherited members.

Address (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY
AddressExtension (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY
BitOffset (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY
ODT_ENTRY() (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY
OdtEntryNo (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY
Size (defined in A2LXCP_ODT.ODT_ENTRY) | A2LXCP_ODT.ODT_ENTRY


ASAP2Library interface: A2LXCP_ON_CAN Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_CAN
Public Member Functions | Properties | List of all members
A2LXCP_ON_CAN Class Reference

XCP on CAN parameters. More...

Public Member Functions

A2LXCP_ON_CAN (A2LXCP_ON_CAN src)
Constructor to support simulator entries. More...
override string | ToString ()
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

uint | Baudrate [getset]
byte | BTLCycles [getset]
BTL_CYCLES [slots per bit time].
uint | CANIDBroadcast = uint.MaxValue [getset]
uint | CANIDCmd = uint.MaxValue [getset]
uint | CANIDGetDAQClockMulticast = uint.MaxValue [getset]
bool | CANIDMasterIncremental [getset]
Master uses range of CAN-IDs More...
uint | CANIDResp = uint.MaxValue [getset]
bool | MaxDLCRequired [getset]
Master to slave frames always to have DLC = MAX_DLC_for CAN-FD.
bool | MeasurementSplitAllowed [getset]
bool | RequestIDsByBroadcast [get]
Indicates if a Cmd/Rsp ID pairs must be requested by a broadcast
byte | SamplePoint [getset]
Sample point receiver [% complete bit time].
XCP_DAQ_LIST_CAN_SAMPLE_RATE | SampleRate [getset]
byte | SJW [getset]
Length synchr. segment [BTL_CYCLES].
XCP_SYNCEDGE | SyncEdge [getset]
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

XCP on CAN parameters.

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Constructor & Destructor Documentation

◆ A2LXCP_ON_CAN()

A2LXCP_ON_CAN ( A2LXCP_ON_CAN src )

Constructor to support simulator entries.

Parameters
src The source instance

Property Documentation

◆ CANIDMasterIncremental

bool CANIDMasterIncremental
getset

Master uses range of CAN-IDs

  • Start of range = CAN_ID_MASTER
  • End of range = CAN_ID_MASTER + MAX_BS(_PGM)-1


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_CAN
A2LXCP_ON_CAN Member List

This is the complete list of members for A2LXCP_ON_CAN, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_CAN(A2LXCP_ON_CAN src) | A2LXCP_ON_CAN |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Baudrate (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
BTLCycles | A2LXCP_ON_CAN |
CANIDBroadcast (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
CANIDCmd (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
CANIDGetDAQClockMulticast (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
CANIDMasterIncremental | A2LXCP_ON_CAN |
CANIDResp (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
IsInstanced | A2LNODE |
MaxBusLoad | A2LXCP_MEDIA |
MaxDLCRequired | A2LXCP_ON_CAN |
MeasurementSplitAllowed (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
Parent | A2LNODE |
RequestIDsByBroadcast | A2LXCP_ON_CAN |
SamplePoint | A2LXCP_ON_CAN |
SampleRate (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
SJW | A2LXCP_ON_CAN |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SyncEdge (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
Tag | A2LNODE |
ToString() (defined in A2LXCP_ON_CAN) | A2LXCP_ON_CAN |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ON_ETHERNET Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_ETHERNET
Public Member Functions | Protected Member Functions | Properties | List of all members
A2LXCP_ON_ETHERNET Class Reference

Base class for the XCP ethernet media (UDP/TCP) More...

Public Member Functions

override string | ToString ()
Builds a string representation for the XCPEntry. More...
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LXCP_ON_ETHERNET (A2LXCP_ON_ETHERNET src)
Constructor to support simulator entries. More...
A2LXCP_ON_ETHERNET (int startLine)
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

string | Address [getset]
The ethernet address to connect to. More...
string | HostName [getset]
The remote host name to connect to.
string | IPV6 [getset]
IP(V6) address.
uint | MaxBitRate [getset]
Network speed which is the base for MAX_BUS_LOAD in Mbit (only valid for XCP > v1.1).
XCP_PACKET_ALIGMENT | PacketAlignment = XCP_PACKET_ALIGMENT.NotSet [getset]
ushort | Port [getset]
The ethernet port to connect to.
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for the XCP ethernet media (UDP/TCP)

Constructor & Destructor Documentation

◆ A2LXCP_ON_ETHERNET()

A2LXCP_ON_ETHERNET ( A2LXCP_ON_ETHERNET src )
protected

Constructor to support simulator entries.

Parameters
src The source instance

Member Function Documentation

◆ ToString()

override string ToString ( )

Builds a string representation for the XCPEntry.

Returns
The instance as a string

Property Documentation

◆ Address

string Address
getset

The ethernet address to connect to.

May be an IP(V4) address or a host name.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_ETHERNET
A2LXCP_ON_ETHERNET Member List

This is the complete list of members for A2LXCP_ON_ETHERNET, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_ETHERNET(int startLine) (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET | protected
A2LXCP_ON_ETHERNET(A2LXCP_ON_ETHERNET src) | A2LXCP_ON_ETHERNET | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LXCP_ON_ETHERNET |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
HostName | A2LXCP_ON_ETHERNET |
IPV6 | A2LXCP_ON_ETHERNET |
IsInstanced | A2LNODE |
MaxBitRate | A2LXCP_ON_ETHERNET |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
PacketAlignment (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET |
Parent | A2LNODE |
Port | A2LXCP_ON_ETHERNET |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() | A2LXCP_ON_ETHERNET |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ON_SxI Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_SxI
Public Member Functions | Properties | List of all members
A2LXCP_ON_SxI Class Reference

XCP on SxI parameters. More...

Public Member Functions

A2LXCP_ON_SxI (A2LXCP_ON_SxI src)
override string | ToString ()
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

uint | Baudrate [getset]
ChecksumSxI | Checksum = ChecksumSxI.NotSet [getset]
AsyncFullDuplexMode | DuplexMode [getset]
XCP_HEADER_LEN | HeaderLen = XCP_HEADER_LEN.NotSet [getset]
SyncModeSize | SyncFullDuplexMode [getset]
SyncModeSize | SyncMasterSlaveMode [getset]
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

XCP on SxI parameters.

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_SxI
A2LXCP_ON_SxI Member List

This is the complete list of members for A2LXCP_ON_SxI, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_SxI(A2LXCP_ON_SxI src) (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Baudrate (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
ChangedType | A2LNODE |
Checksum (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DuplexMode (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
HeaderLen (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
IsInstanced | A2LNODE |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SyncFullDuplexMode (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
SyncMasterSlaveMode (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
Tag | A2LNODE |
ToString() (defined in A2LXCP_ON_SxI) | A2LXCP_ON_SxI |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ON_TCP_IP Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_TCP_IP
Public Member Functions | List of all members
A2LXCP_ON_TCP_IP Class Reference

XCP on TCP parameters. More...

Public Member Functions

A2LXCP_ON_TCP_IP (A2LXCP_ON_TCP_IP src)
Constructor to support simulator entries. More...
- Public Member Functions inherited from A2LXCP_ON_ETHERNET
override string | ToString ()
Builds a string representation for the XCPEntry. More...
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LXCP_ON_ETHERNET
A2LXCP_ON_ETHERNET (A2LXCP_ON_ETHERNET src)
Constructor to support simulator entries. More...
A2LXCP_ON_ETHERNET (int startLine)
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ON_ETHERNET
string | Address [getset]
The ethernet address to connect to. More...
string | HostName [getset]
The remote host name to connect to.
string | IPV6 [getset]
IP(V6) address.
uint | MaxBitRate [getset]
Network speed which is the base for MAX_BUS_LOAD in Mbit (only valid for XCP > v1.1).
XCP_PACKET_ALIGMENT | PacketAlignment = XCP_PACKET_ALIGMENT.NotSet [getset]
ushort | Port [getset]
The ethernet port to connect to.
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

XCP on TCP parameters.

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Constructor & Destructor Documentation

◆ A2LXCP_ON_TCP_IP()

A2LXCP_ON_TCP_IP ( A2LXCP_ON_TCP_IP src )

Constructor to support simulator entries.

Parameters
src The source instance


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_TCP_IP
A2LXCP_ON_TCP_IP Member List

This is the complete list of members for A2LXCP_ON_TCP_IP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_ETHERNET(int startLine) (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET | protected
A2LXCP_ON_ETHERNET(A2LXCP_ON_ETHERNET src) | A2LXCP_ON_ETHERNET | protected
A2LXCP_ON_TCP_IP() (defined in A2LXCP_ON_TCP_IP) | A2LXCP_ON_TCP_IP |
A2LXCP_ON_TCP_IP(A2LXCP_ON_TCP_IP src) | A2LXCP_ON_TCP_IP |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LXCP_ON_ETHERNET |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
HostName | A2LXCP_ON_ETHERNET |
IPV6 | A2LXCP_ON_ETHERNET |
IsInstanced | A2LNODE |
MaxBitRate | A2LXCP_ON_ETHERNET |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
PacketAlignment (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET |
Parent | A2LNODE |
Port | A2LXCP_ON_ETHERNET |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() | A2LXCP_ON_ETHERNET |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ON_UDP_IP Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_UDP_IP
Public Member Functions | List of all members
A2LXCP_ON_UDP_IP Class Reference

XCP on UDP parameters. More...

Public Member Functions

A2LXCP_ON_UDP_IP (A2LXCP_ON_UDP_IP src)
Constructor to support simulator entries. More...
- Public Member Functions inherited from A2LXCP_ON_ETHERNET
override string | ToString ()
Builds a string representation for the XCPEntry. More...
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LXCP_ON_ETHERNET
A2LXCP_ON_ETHERNET (A2LXCP_ON_ETHERNET src)
Constructor to support simulator entries. More...
A2LXCP_ON_ETHERNET (int startLine)
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ON_ETHERNET
string | Address [getset]
The ethernet address to connect to. More...
string | HostName [getset]
The remote host name to connect to.
string | IPV6 [getset]
IP(V6) address.
uint | MaxBitRate [getset]
Network speed which is the base for MAX_BUS_LOAD in Mbit (only valid for XCP > v1.1).
XCP_PACKET_ALIGMENT | PacketAlignment = XCP_PACKET_ALIGMENT.NotSet [getset]
ushort | Port [getset]
The ethernet port to connect to.
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

XCP on UDP parameters.

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Constructor & Destructor Documentation

◆ A2LXCP_ON_UDP_IP()

A2LXCP_ON_UDP_IP ( A2LXCP_ON_UDP_IP src )

Constructor to support simulator entries.

Parameters
src The source instance


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_UDP_IP
A2LXCP_ON_UDP_IP Member List

This is the complete list of members for A2LXCP_ON_UDP_IP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_ETHERNET(int startLine) (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET | protected
A2LXCP_ON_ETHERNET(A2LXCP_ON_ETHERNET src) | A2LXCP_ON_ETHERNET | protected
A2LXCP_ON_UDP_IP() (defined in A2LXCP_ON_UDP_IP) | A2LXCP_ON_UDP_IP |
A2LXCP_ON_UDP_IP(A2LXCP_ON_UDP_IP src) | A2LXCP_ON_UDP_IP |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LXCP_ON_ETHERNET |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
HostName | A2LXCP_ON_ETHERNET |
IPV6 | A2LXCP_ON_ETHERNET |
IsInstanced | A2LNODE |
MaxBitRate | A2LXCP_ON_ETHERNET |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalTLCmds | A2LXCP_MEDIA |
PacketAlignment (defined in A2LXCP_ON_ETHERNET) | A2LXCP_ON_ETHERNET |
Parent | A2LNODE |
Port | A2LXCP_ON_ETHERNET |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() | A2LXCP_ON_ETHERNET |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_ON_USB Class Reference

  • ASAP2
  • XCP
  • A2LXCP_ON_USB
Public Member Functions | Properties | List of all members
A2LXCP_ON_USB Class Reference

XCP on USB parameters. More...

Public Member Functions

A2LXCP_ON_USB (A2LXCP_ON_USB src)
override string | ToString ()
- Public Member Functions inherited from A2LXCP_MEDIA
void | getSettings (out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm)
Gets the XCP settings for this instance. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

byte | AlternateSettingNo = byte.MaxValue [getset]
Alternate setting number.
XCP_HEADER_LEN | HeaderLen [getset]
Header length.
string | InterfaceDescriptor [getset]
Interface string descriptor.
byte | NumberOfIF [getset]
Number of interfaces.
ushort | ProductID [getset]
Gets or sets the Product ID.
ushort | VendorID [getset]
Gets or sets the Vendor ID.
- Properties inherited from A2LXCP_MEDIA
uint | MaxBusLoad [getset]
Maximum available bus load in percent (only valid for XCP > v1.1).
OptionalCommandSet | OptionalTLCmds = new OptionalCommandSet() [getset]
Optional commands for transport layer (GET_SLAVE_ID, GET_DAQ_ID, SET_DAQ_ID, GET_DAQ_CLOCK_MULTICAST).
string | TransportLayerInstance [getset]
Transport layer instance is only valid for XCP > v1.1.
ushort | Version [getset]
Gets or sets the Version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LXCP_MEDIA
A2LXCP_MEDIA (A2LXCP_MEDIA src)
A2LXCP_MEDIA (int startLine)
string | getTsStr ()
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

XCP on USB parameters.

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_ON_USB
A2LXCP_ON_USB Member List

This is the complete list of members for A2LXCP_ON_USB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_MEDIA() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(A2LXCP_MEDIA src) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_MEDIA(int startLine) (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
A2LXCP_ON_USB(A2LXCP_ON_USB src) (defined in A2LXCP_ON_USB) | A2LXCP_ON_USB |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AlternateSettingNo | A2LXCP_ON_USB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSettings(out A2LXCP_PROTOCOL_LAYER protocolLayer, out A2LXCP_CHECKSUM checksum, out A2LXCP_PAG pag, out A2LXCP_DAQ daq, out A2LXCP_PGM pgm) | A2LXCP_MEDIA |
getTsStr() (defined in A2LXCP_MEDIA) | A2LXCP_MEDIA | protected
HeaderLen | A2LXCP_ON_USB |
InterfaceDescriptor | A2LXCP_ON_USB |
IsInstanced | A2LNODE |
MaxBusLoad | A2LXCP_MEDIA |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
NumberOfIF | A2LXCP_ON_USB |
OptionalTLCmds | A2LXCP_MEDIA |
Parent | A2LNODE |
ProductID | A2LXCP_ON_USB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LXCP_ON_USB) | A2LXCP_ON_USB |
TransportLayerInstance | A2LXCP_MEDIA |
Type | A2LNODE |
VendorID | A2LXCP_ON_USB |
Version | A2LXCP_MEDIA |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_OUT_EP_CMD_STIM Class Reference

  • ASAP2
  • XCP
  • A2LXCP_OUT_EP_CMD_STIM
Public Member Functions | List of all members
A2LXCP_OUT_EP_CMD_STIM Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Public Member Functions

A2LXCP_OUT_EP_CMD_STIM (int startLine)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ENDPOINT
XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_OUT_EP_CMD_STIM
A2LXCP_OUT_EP_CMD_STIM Member List

This is the complete list of members for A2LXCP_OUT_EP_CMD_STIM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_OUT_EP_CMD_STIM() (defined in A2LXCP_OUT_EP_CMD_STIM) | A2LXCP_OUT_EP_CMD_STIM |
A2LXCP_OUT_EP_CMD_STIM(int startLine) (defined in A2LXCP_OUT_EP_CMD_STIM) | A2LXCP_OUT_EP_CMD_STIM |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_OUT_EP_ONLY_STIM Class Reference

  • ASAP2
  • XCP
  • A2LXCP_OUT_EP_ONLY_STIM
Public Member Functions | List of all members
A2LXCP_OUT_EP_ONLY_STIM Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB More...

Public Member Functions

A2LXCP_OUT_EP_ONLY_STIM (int startLine)
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Additional Inherited Members

- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LXCP_ENDPOINT
XCP_ALIGNMENT | Alignment = XCP_ALIGNMENT._8_BIT [getset]
Gets or sets the endpoint transfer type.
byte | EPNo [getset]
Gets or sets the endpoint Number.
byte | EPPollInterval [getset]
Gets or sets the endpoint polling interval.
ushort | HostBufferSize = byte.MaxValue [getset]
Gets or sets the recommended host buffer size (optional).
ushort | MaxPktSize [getset]
Gets or sets the maximum packet size.
XCP_MESSAGE_PACKING | Packing [getset]
Gets or sets the endpoint transfer type.
XCP_TRANSFER | TransferType [getset]
Gets or sets the endpoint transfer type.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_OUT_EP_ONLY_STIM
A2LXCP_OUT_EP_ONLY_STIM Member List

This is the complete list of members for A2LXCP_OUT_EP_ONLY_STIM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LXCP_OUT_EP_ONLY_STIM() (defined in A2LXCP_OUT_EP_ONLY_STIM) | A2LXCP_OUT_EP_ONLY_STIM |
A2LXCP_OUT_EP_ONLY_STIM(int startLine) (defined in A2LXCP_OUT_EP_ONLY_STIM) | A2LXCP_OUT_EP_ONLY_STIM |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignment | A2LXCP_ENDPOINT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPNo | A2LXCP_ENDPOINT |
EPPollInterval | A2LXCP_ENDPOINT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
HostBufferSize | A2LXCP_ENDPOINT |
IsInstanced | A2LNODE |
MaxPktSize | A2LXCP_ENDPOINT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Packing | A2LXCP_ENDPOINT |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TransferType | A2LXCP_ENDPOINT |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_PAG Class Reference

  • ASAP2
  • XCP
  • A2LXCP_PAG
Properties | List of all members
A2LXCP_PAG Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

byte | MaxSegments [getset]
PAGProperties | Properties [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_PAG
A2LXCP_PAG Member List

This is the complete list of members for A2LXCP_PAG, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxSegments (defined in A2LXCP_PAG) | A2LXCP_PAG |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Properties (defined in A2LXCP_PAG) | A2LXCP_PAG |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_PAGE Class Reference

  • ASAP2
  • XCP
  • A2LXCP_PAGE
Properties | List of all members
A2LXCP_PAGE Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

XCP_ECU_ACCESS | AccessECU [getset]
ECU Access type.
XCP_READ_WRITE_ACCESS | AccessRead [getset]
Read Access type.
XCP_READ_WRITE_ACCESS | AccessWrite [getset]
Write Access type.
byte | PageNo [getset]
Page number for this segment.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_PAGE
A2LXCP_PAGE Member List

This is the complete list of members for A2LXCP_PAGE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
AccessECU | A2LXCP_PAGE |
AccessRead | A2LXCP_PAGE |
AccessWrite | A2LXCP_PAGE |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
PageNo | A2LXCP_PAGE |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_PGM Class Reference

  • ASAP2
  • XCP
  • A2LXCP_PGM
Properties | List of all members
A2LXCP_PGM Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

XCPCommModes | CommModesSupported [getset]
byte | MaxCTO [getset]
byte | MaxSectors [getset]
XCP_PGM_MODE | Mode [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_PGM
A2LXCP_PGM Member List

This is the complete list of members for A2LXCP_PGM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CommModesSupported (defined in A2LXCP_PGM) | A2LXCP_PGM |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxCTO (defined in A2LXCP_PGM) | A2LXCP_PGM |
MaxSectors (defined in A2LXCP_PGM) | A2LXCP_PGM |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Mode (defined in A2LXCP_PGM) | A2LXCP_PGM |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_PROTOCOL_LAYER Class Reference

  • ASAP2
  • XCP
  • A2LXCP_PROTOCOL_LAYER
Properties | List of all members
A2LXCP_PROTOCOL_LAYER Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

BYTEORDER_TYPE? | ByteOrder [get]
Gets the ByteOrder.
CommModeBasic | CommModeBasic [getset]
XCPCommModes | CommModesSupported [getset]
byte | MaxCTO = byte.MaxValue [getset]
Indicates the maximum length of a CTO packet in bytes.
ushort | MaxDTO = ushort.MaxValue [getset]
Indicates the maximum length of a DTO packet in bytes (Default for DAQ and STIM).
ushort | MaxDTOStim = ushort.MaxValue [getset]
Overrules MaxDTO for STIM use case.
OptionalCommandSet | OptionalCmds = new OptionalCommandSet() [getset]
Allowed optional commands.
string | SeedAndKeyExternalFunction [getset]
Name of the Seed&Key function including file extension without path.
ushort[] | Timings = new ushort[7] [getset]
Protocol Timing settings. More...
ushort | Version [getset]
Protocol layer version.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Property Documentation

◆ Timings

ushort [] Timings = new ushort[7]
getset

Protocol Timing settings.

Indizes mapped to: T1=0, T2=1, T3=2, T4=3, T5=4, T6=5, T7=6.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_PROTOCOL_LAYER
A2LXCP_PROTOCOL_LAYER Member List

This is the complete list of members for A2LXCP_PROTOCOL_LAYER, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ByteOrder | A2LXCP_PROTOCOL_LAYER |
ChangedType | A2LNODE |
Childs | A2LNODE |
CommModeBasic (defined in A2LXCP_PROTOCOL_LAYER) | A2LXCP_PROTOCOL_LAYER |
CommModesSupported (defined in A2LXCP_PROTOCOL_LAYER) | A2LXCP_PROTOCOL_LAYER |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxCTO | A2LXCP_PROTOCOL_LAYER |
MaxDTO | A2LXCP_PROTOCOL_LAYER |
MaxDTOStim | A2LXCP_PROTOCOL_LAYER |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
OptionalCmds | A2LXCP_PROTOCOL_LAYER |
Parent | A2LNODE |
SeedAndKeyExternalFunction | A2LXCP_PROTOCOL_LAYER |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Timings | A2LXCP_PROTOCOL_LAYER |
Type | A2LNODE |
Version | A2LXCP_PROTOCOL_LAYER |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_SECTOR Class Reference

  • ASAP2
  • XCP
  • A2LXCP_SECTOR
Properties | List of all members
A2LXCP_SECTOR Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

uint | Address [getset]
byte | ClearSeqNo [getset]
uint | Length [getset]
string | NameLong [getset]
byte | Number [getset]
byte | PgmMethod [getset]
byte | PgmSeqNo [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_SECTOR
A2LXCP_SECTOR Member List

This is the complete list of members for A2LXCP_SECTOR, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
ChangedType | A2LNODE |
Childs | A2LNODE |
ClearSeqNo (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Length (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NameLong (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
NoCompuMethod | A2LNODE | static
Number (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
Parent | A2LNODE |
PgmMethod (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
PgmSeqNo (defined in A2LXCP_SECTOR) | A2LXCP_SECTOR |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_SEGMENT Class Reference

  • ASAP2
  • XCP
  • A2LXCP_SEGMENT
Properties | List of all members
A2LXCP_SEGMENT Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

byte | AddressExtension [getset]
The Address extension of the segment.
byte | CompressionMethod [getset]
The compression method. More...
byte | DefaultPageNumber = byte.MaxValue [getset]
Number of the default page
byte | EncryptionMethod [getset]
The encryption method. More...
byte | NoOfPages [getset]
The number of pages.
uint | PgmVerify [getset]
Verification value for PGM.
byte | SegmentNo [getset]
The Segment number.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)

Property Documentation

◆ CompressionMethod

byte CompressionMethod
getset

The compression method.

  • 0x00..0x7f Data uncompressed (default)
  • 0x80..0xff User defined

◆ EncryptionMethod

byte EncryptionMethod
getset

The encryption method.

  • 0x00..0x7f Data unencrypted (default)
  • 0x80..0xff User defined


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_SEGMENT
A2LXCP_SEGMENT Member List

This is the complete list of members for A2LXCP_SEGMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressExtension | A2LXCP_SEGMENT |
ChangedType | A2LNODE |
Childs | A2LNODE |
CompressionMethod | A2LXCP_SEGMENT |
DefaultPageNumber | A2LXCP_SEGMENT |
deleteFromModel(A2LNODE node) | A2LNODE | static
EncryptionMethod | A2LXCP_SEGMENT |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
NoOfPages | A2LXCP_SEGMENT |
Parent | A2LNODE |
PgmVerify | A2LXCP_SEGMENT |
SegmentNo | A2LXCP_SEGMENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_STIM Class Reference

  • ASAP2
  • XCP
  • A2LXCP_STIM
Properties | List of all members
A2LXCP_STIM Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

bool | BitSTIMSupported [getset]
bitwise stimulation supported
byte | MaxODTEntrySize = byte.MaxValue [getset]
byte | MinSTSTIM [getset]
Separation time between DTOs time in units of 100 microseconds.
XCP_ODT_ENTRY_SIZE | ODTEntrySize [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_STIM
A2LXCP_STIM Member List

This is the complete list of members for A2LXCP_STIM, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BitSTIMSupported | A2LXCP_STIM |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
MaxODTEntrySize (defined in A2LXCP_STIM) | A2LXCP_STIM |
mFilterLine (defined in A2LNODE) | A2LNODE | static
MinSTSTIM | A2LXCP_STIM |
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
ODTEntrySize (defined in A2LXCP_STIM) | A2LXCP_STIM |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_TIME_CORRELATION Class Reference

  • ASAP2
  • XCP
  • A2LXCP_TIME_CORRELATION
Properties | List of all members
A2LXCP_TIME_CORRELATION Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus) More...

Properties

XCP_TS_RELATION | TimestampsRelateTo [getset]
XCP_SLAVE_CLOCK and ECU_CLOCK need not necessarily be the same clock, i.e. in case of an external XCP Slave, these clocks might differ
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_TIME_CORRELATION
A2LXCP_TIME_CORRELATION Member List

This is the complete list of members for A2LXCP_TIME_CORRELATION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TimestampsRelateTo | A2LXCP_TIME_CORRELATION |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_TIMESTAMP_CHARACTERIZATION Class Reference

  • ASAP2
  • XCP
  • A2LXCP_TIMESTAMP_CHARACTERIZATION
Properties | List of all members
A2LXCP_TIMESTAMP_CHARACTERIZATION Class Reference

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock) More...

Properties

XCP_TIMESTAMP_RESOLUTION | Resolution [getset]
XCP_NATIVE_TIMESTAMP_SIZE | Size [getset]
Native timestamp size
uint | TimestampTicks [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_TIMESTAMP_CHARACTERIZATION
A2LXCP_TIMESTAMP_CHARACTERIZATION Member List

This is the complete list of members for A2LXCP_TIMESTAMP_CHARACTERIZATION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Resolution (defined in A2LXCP_TIMESTAMP_CHARACTERIZATION) | A2LXCP_TIMESTAMP_CHARACTERIZATION |
Size | A2LXCP_TIMESTAMP_CHARACTERIZATION |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
TimestampTicks (defined in A2LXCP_TIMESTAMP_CHARACTERIZATION) | A2LXCP_TIMESTAMP_CHARACTERIZATION |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: A2LXCP_TIMESTAMP_SUPPORTED Class Reference

  • ASAP2
  • XCP
  • A2LXCP_TIMESTAMP_SUPPORTED
Properties | List of all members
A2LXCP_TIMESTAMP_SUPPORTED Class Reference

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS) More...

Properties

bool | IsFixed [getset]
Indicates if the timestamps are fixed.
XCP_TIMESTAMP_RESOLUTION | Resolution [getset]
XCP_TIMESTAMP_SIZE | Size [getset]
ushort | Ticks [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LXCP_NODE
static string | getCycleTime (XCP_TIMESTAMP_RESOLUTION res, byte timeCycle)
Gets the cycle time from timestamp resolution and time cycle. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LXCP_NODE
static XCPCommModes | getCommModes (A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i)
Gets the supported communciation modes, if defined. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LXCP_NODE
const string | XCPPLusDesc = "Requires IF_DATA defined as XCPplus"
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • A2LXCP_TIMESTAMP_SUPPORTED
A2LXCP_TIMESTAMP_SUPPORTED Member List

This is the complete list of members for A2LXCP_TIMESTAMP_SUPPORTED, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCommModes(A2LXCP_NODE node, A2LParser parser, ref List< string > parameterList, ref int i) | A2LXCP_NODE | protectedstatic
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getCycleTime(XCP_TIMESTAMP_RESOLUTION res, byte timeCycle) | A2LXCP_NODE | static
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsFixed | A2LXCP_TIMESTAMP_SUPPORTED |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Resolution (defined in A2LXCP_TIMESTAMP_SUPPORTED) | A2LXCP_TIMESTAMP_SUPPORTED |
Size (defined in A2LXCP_TIMESTAMP_SUPPORTED) | A2LXCP_TIMESTAMP_SUPPORTED |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Ticks (defined in A2LXCP_TIMESTAMP_SUPPORTED) | A2LXCP_TIMESTAMP_SUPPORTED |
Type | A2LNODE |
XCPPLusDesc (defined in A2LXCP_NODE) | A2LXCP_NODE | protectedstatic


ASAP2Library interface: DAQAndEvt Struct Reference

  • ASAP2
  • XCP
  • DAQAndEvt
Public Member Functions | Public Attributes | List of all members
DAQAndEvt Struct Reference

Hold a DAQList with it's attached Event. More...

Public Member Functions

DAQAndEvt (A2LXCP_DAQ_LIST daqList, A2LXCP_EVENT evt)
Creates a new instance of DAQAndEvt. More...

Public Attributes

readonly A2LXCP_DAQ_LIST | DAQList
DAQ List
readonly A2LXCP_EVENT | Evt
Event (may be null)

Detailed Description

Hold a DAQList with it's attached Event.

Constructor & Destructor Documentation

◆ DAQAndEvt()

DAQAndEvt | ( | A2LXCP_DAQ_LIST | daqList,
 |  | A2LXCP_EVENT | evt
 | ) |  |

Creates a new instance of DAQAndEvt.

Parameters
daqList | A DAQ List
evt | Event to attach


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • DAQAndEvt
DAQAndEvt Member List

This is the complete list of members for DAQAndEvt, including all inherited members.

DAQAndEvt(A2LXCP_DAQ_LIST daqList, A2LXCP_EVENT evt) | DAQAndEvt
DAQList | DAQAndEvt
Evt | DAQAndEvt


ASAP2Library interface: OptionalCommandSet Class Reference

  • ASAP2
  • XCP
  • OptionalCommandSet
Public Member Functions | List of all members
OptionalCommandSet Class Reference

Represents a set of unique strings used to optional commands. More...

Public Member Functions

override string ToString ()

Detailed Description

Represents a set of unique strings used to optional commands.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • OptionalCommandSet
OptionalCommandSet Member List

This is the complete list of members for OptionalCommandSet, including all inherited members.

OptionalCommandSet() (defined in OptionalCommandSet) | OptionalCommandSet
ToString() (defined in OptionalCommandSet) | OptionalCommandSet


ASAP2Library interface: XCPCommModes Struct Reference

  • ASAP2
  • XCP
  • XCPCommModes
Properties | List of all members
XCPCommModes Struct Reference

Supported communication modes. More...

Properties

XCP_BLOCK_MODE | CommMode [getset]
A combination of supported comunication modes
byte | MaxBS [getset]
Indicates the maximum allowed block size as the number of consecutive command packets (DOWNLOAD_NEXT) in a block sequence.
byte | MinST [getset]
Indicates the required minimum separation time between the packets of a block transfer from the master device to the slave device in units of 100 microseconds.
byte | QueueSize [getset]
Indicates the maximum number of consecutive command packets the master can send to the receipt queue of the slave.

Detailed Description

Supported communication modes.


ASAP2Library interface: Member List

  • ASAP2
  • XCP
  • XCPCommModes
XCPCommModes Member List

This is the complete list of members for XCPCommModes, including all inherited members.

CommMode | XCPCommModes
MaxBS | XCPCommModes
MinST | XCPCommModes
QueueSize | XCPCommModes


ASAP2Library interface: A2LA2ML Class Reference

  • ASAP2
  • A2LA2ML
List of all members
A2LA2ML Class Reference

This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA). More...

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LUNSUPPORTEDNODE
A2LUNSUPPORTEDNODE (int startLine)
Creates a new instance of A2LUNSUPPORTEDNODE with the specified parameter. More...
virtual void | setContent (A2LParser parser, ref List< string > parameterList, int startIndex, StringBuilder content)
Try to recognize additional IF Data types. More...
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LUNSUPPORTEDNODE
string | Content [getset]
Represents the original content from the ASAP2 file as a string. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA).


ASAP2Library interface: Member List

  • ASAP2
  • A2LA2ML
A2LA2ML Member List

This is the complete list of members for A2LA2ML, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LUNSUPPORTEDNODE(int startLine) | A2LUNSUPPORTEDNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
Content | A2LUNSUPPORTEDNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
setContent(A2LParser parser, ref List< string > parameterList, int startIndex, StringBuilder content) | A2LUNSUPPORTEDNODE | protectedvirtual
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LADDRESS Class Reference

  • ASAP2
  • A2LADDRESS
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
A2LADDRESS Class Referenceabstract

Base class for all A2L entities containing an ECU address. More...

Public Member Functions

virtual string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
abstract int | getMemorySize ()
Gets the size of used memory in bytes. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Protected Attributes

string mDisplayName = string.Empty

Properties

uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L entities containing an ECU address.

Constructor & Destructor Documentation

◆ A2LADDRESS()

A2LADDRESS | ( | A2LMODULE | module,
 |  | A2LINSTANCE | instance
 | ) |  |
protected

Creates instance from an A2LINSTANCE.

Parameters
module | The module to add the instance to
instance | The instance to create from

Member Function Documentation

◆ addFromInstance()

void addFromInstance | ( | A2LMODULE | module,
 |  | A2LType | type,
 |  | A2LTYPEDEF | typedef
 | ) |  |
protected

Parameters
module | The module to add to
type | The A2L type to set
typedef | The typedef reference

◆ getDescriptionAndAnnotation()

virtual string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
virtual

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

Reimplemented in A2LAXIS_PTS, A2LCHARACTERISTIC, A2LMEASUREMENT, and A2LINSTANCE.

◆ getMemorySize()

abstract int getMemorySize ( )
pure virtual

Gets the size of used memory in bytes.

Returns

Implemented in A2LMEASUREMENT, A2LBLOB, A2LINSTANCE, and A2LRECORD_LAYOUT_REF.

Property Documentation

◆ AddressExtension

int AddressExtension
getset

Gets the address extension.

This keyword is an additional address information. For instance it can be used, to distinguish different address spaces of an ECU (multi-micro controller devices).

◆ DisplayName

sealed override string? DisplayName
getset

Gets the display name.

Can be used as a display name (alternative to the ‘name’ attribute).

◆ ModelLink

string ModelLink
getset

Object model's name.

This model_link can be used to reference a software model object the CHARACTERISTIC, AXIS_PTS, BLOB, INSTANCE or MEASUREMENT was derived from.

◆ SymbolOffset

int SymbolOffset
getset

Offset of the Symbol relative to the symbol’s address in the linker map file.

Only Valid if SymbolLink is not null or empty.


ASAP2Library interface: Member List

  • ASAP2
  • A2LADDRESS
A2LADDRESS Member List

This is the complete list of members for A2LADDRESS, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LADDRESS | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySize() | A2LADDRESS | pure virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
ModelLink | A2LADDRESS |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefInstance | A2LADDRESS |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LANNOTATION Class Reference

  • ASAP2
  • A2LANNOTATION
Public Member Functions | Properties | List of all members
A2LANNOTATION Class Reference

see ASAP2 specification More...

Public Member Functions

override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

string | Label [getset]
string | Origin [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LANNOTATION
A2LANNOTATION Member List

This is the complete list of members for A2LANNOTATION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Label (defined in A2LANNOTATION) | A2LANNOTATION |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Origin (defined in A2LANNOTATION) | A2LANNOTATION |
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LANNOTATION) | A2LANNOTATION |
Type | A2LNODE |


ASAP2Library interface: A2LANNOTATION_TEXT Class Reference

  • ASAP2
  • A2LANNOTATION_TEXT
Properties | List of all members
A2LANNOTATION_TEXT Class Reference

see ASAP2 specification More...

Properties

string | Text [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LANNOTATION_TEXT
A2LANNOTATION_TEXT Member List

This is the complete list of members for A2LANNOTATION_TEXT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Text (defined in A2LANNOTATION_TEXT) | A2LANNOTATION_TEXT |
Type | A2LNODE |


ASAP2Library interface: A2LAR_COMPONENT Class Reference

  • ASAP2
  • A2LAR_COMPONENT
Properties | List of all members
A2LAR_COMPONENT Class Reference

see ASAP2 specification More...

Properties

string | ComponentType [getset]
string | PrototypeOf [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LAR_COMPONENT
A2LAR_COMPONENT Member List

This is the complete list of members for A2LAR_COMPONENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ComponentType (defined in A2LAR_COMPONENT) | A2LAR_COMPONENT |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PrototypeOf (defined in A2LAR_COMPONENT) | A2LAR_COMPONENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LAXIS_DESCR Class Reference

  • ASAP2
  • A2LAXIS_DESCR
Properties | List of all members
A2LAXIS_DESCR Class Reference

see ASAP2 specification More...

Properties

string | AxisPtsRef [getset]
AXIS_TYPE | AxisType [getset]
BYTEORDER_TYPE | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
string | CurveAxisRef [getset]
DEPOSIT_TYPE??? | Deposit [getset]
FIX_AXIS_PAR | FixAxisPar [getset]
FIX_AXIS_PAR_DIST | FixAxisParDist [getset]
string????? | Format [getset]
string | InputQuantity [getset]
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
double | LowerLimitEx [getset]
int | MaxAxisPoints [getset]
double | MaxGrad = double.NaN [getset]
MONOTONY_TYPE | Monotony [getset]
bool | ReadOnly [getset]
A2LAXIS_PTS | RefAxisPtsRef [get]
Gets the direct reference to the AXISPTS instance. More...
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
A2LCHARACTERISTIC | RefCurveAxisRef [get]
Gets the direct reference to the Curve axis reference instance. More...
A2LMEASUREMENT | RefMeasurement [get]
Gets the direct reference to the input measurement of the axis. More...
double | StepSize = double.NaN [getset]
string? | Unit [getset]
double | UpperLimit [getset]
double | UpperLimitEx [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Property Documentation

◆ ByteOrder

BYTEORDER_TYPE ByteOrder
getset

Gets or sets the Byte order (optional).

  • If the local value is NotSet, the value from A2LMOD_COMMON is taken.
  • The setter initialises the byte order cache (e.g. if the MOD_COMMON vbyte order is changed).
  • The local member is explicitely set.

◆ IsFormatNotSet

bool IsFormatNotSet
get

Indicates if a format string is not set.

A not set format occurs if it is not explicitly defined by the Format property and (the referenced CompuMethod is defined as a NO_COMPU_METHOD or the referenced CompuMethod is not found and replaced by a default one)

◆ RefAxisPtsRef

A2LAXIS_PTS RefAxisPtsRef
get

Gets the direct reference to the AXISPTS instance.

May be null if not defined.

◆ RefCurveAxisRef

A2LCHARACTERISTIC RefCurveAxisRef
get

Gets the direct reference to the Curve axis reference instance.

May be null if not defined.

◆ RefMeasurement

A2LMEASUREMENT RefMeasurement
get

Gets the direct reference to the input measurement of the axis.

May be null if no input measurement is defined.


ASAP2Library interface: Member List

  • ASAP2
  • A2LAXIS_DESCR
A2LAXIS_DESCR Member List

This is the complete list of members for A2LAXIS_DESCR, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AxisPtsRef (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
AxisType (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
ByteOrder | A2LAXIS_DESCR |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
CurveAxisRef (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
deleteFromModel(A2LNODE node) | A2LNODE | static
Deposit (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FixAxisPar (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
FixAxisParDist (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
Format (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
InputQuantity (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
IsFormatNotSet | A2LAXIS_DESCR |
IsInstanced | A2LNODE |
LowerLimit (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
LowerLimitEx (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
MaxAxisPoints (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
MaxGrad (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Monotony (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadOnly (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
RefAxisPtsRef | A2LAXIS_DESCR |
RefCompuMethod | A2LAXIS_DESCR |
RefCurveAxisRef | A2LAXIS_DESCR |
RefMeasurement | A2LAXIS_DESCR |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
Tag | A2LNODE |
Type | A2LNODE |
Unit (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
UpperLimit (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |
UpperLimitEx (defined in A2LAXIS_DESCR) | A2LAXIS_DESCR |


ASAP2Library interface: A2LAXIS_PTS Class Reference

  • ASAP2
  • A2LAXIS_PTS
Public Member Functions | Properties | List of all members
A2LAXIS_PTS Class Reference

see ASAP2 specification More...

Public Member Functions

override string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCHARACTERISTICs. More...
override int | getSize ()
Gets the size in bytes of the characteristic. More...
- Public Member Functions inherited from A2LRECORD_LAYOUT_REF
uint | getAddress (IList< string > criterionValues=null)
Gets the effective address supporting a potentially defined variant coding. More...
A2LFUNCTION getDefCharacteristicFunction ()
Gets the function which holds the current instance as the DEF_CHARACTERISTIC. More...
IA2LMemory getMemorySegment ()
Gets the corresponding memory segment (may be null). More...
sealed override int | getMemorySize ()
Gets the size of used memory in bytes. More...
bool | isReadOnly ()
Returns a value indicating if the characteristic value should not be changed. More...
string | toStringValue (double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LCONVERSION_REF
override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
sealed override string | ToString ()
string | toStringValue (double physValue)
Builds a string representation from the specified physical value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true)
Builds a string representation from the specified value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...

Properties

DEPOSIT_TYPE??? | Deposit [getset]
string | InputQuantity [getset]
int | MaxAxisPoints [getset]
MONOTONY_TYPE | Monotony [getset]
A2LMEASUREMENT | RefMeasurement [get]
Gets the direct reference to the input measurement of the axis. More...
- Properties inherited from A2LRECORD_LAYOUT_REF
bool | GuardRails [getset]
Gets or sets the guard rails. More...
double | LowerLimitEx [getset]
Gets or sets the extended lower limit.
double | MaxDiff [getset]
Gets or sets the maximum float with respect to an adjustment of a table value.
bool | ReadOnly [getset]
Gets or sets the readonly state. More...
string | RecordLayout [getset]
Gets a reference to the corresponding data record for description of the record layout (see A2LRECORD_LAYOUT) More...
A2LRECORD_LAYOUT | RefRecordLayout [get]
Gets the direct reference to the corresponding record layout. More...
double | StepSize = double.NaN [getset]
Gets or sets the step size. More...
double | UpperLimitEx [getset]
Gets or sets the extended upper limit.
- Properties inherited from A2LCONVERSION_REF
BYTEORDER_TYPE??? | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
Gets or sets the conversion's name. More...
int | DecimalCount [get]
Gets the decimal count of the corresponding Format value.
string????? | Format [getset]
Gets or sets the format. More...
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
Gets or sets the plausible range of table values, lower limit.
string | MemorySegmentRef [get]
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
IEnumerable< A2LREFBASE > | RefFunctions [get]
Gets the list of functions referring this node.
string? | Unit [getset]
Gets or sets the Unit.
double | UpperLimit [getset]
Gets or sets the plausible range of table values, upper limit.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCONVERSION_REF
static int | getDecimalCount (string format)
Gets the decimal count from an A2L format string. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount)
Builds a string representation from the specified value. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LRECORD_LAYOUT_REF
A2LRECORD_LAYOUT_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LCONVERSION_REF
A2LCONVERSION_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LRECORD_LAYOUT_REF
string | mRecordLayout
- Protected Attributes inherited from A2LCONVERSION_REF
BYTEORDER_TYPE | mByteOrder
string | mConversion
string | mFormat = string.Empty
string | mMemorySegmentRef
string | mPhysUnit
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

override string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
virtual

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Reimplemented from A2LADDRESS.

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCHARACTERISTICs.

Returns
May be null or empty if not referenced by any characateristic.

Reimplemented from A2LNODE.

◆ getSize()

override int getSize ( )
virtual

Gets the size in bytes of the characteristic.

The size is calculated from

  • the corresponding record layout
  • the number of elements from MatrixDim
  • external references (like A2LAXIS_PTS) of the characteristic is not taken into account

Together with the characteristic's address, the characteristic's complete value could be read or written directly from/to a MemorySegment or device.

Returns
The size in bytes

Implements A2LRECORD_LAYOUT_REF.

Property Documentation

◆ RefMeasurement

A2LMEASUREMENT RefMeasurement
get

Gets the direct reference to the input measurement of the axis.

May be null if no input measurement is defined.


ASAP2Library interface: Member List

  • ASAP2
  • A2LAXIS_PTS
A2LAXIS_PTS Member List

This is the complete list of members for A2LAXIS_PTS, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCONVERSION_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv) | A2LCONVERSION_REF | protected
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LRECORD_LAYOUT_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout) | A2LRECORD_LAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
ByteOrder | A2LCONVERSION_REF |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LCONVERSION_REF |
DecimalCount | A2LCONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Deposit (defined in A2LAXIS_PTS) | A2LAXIS_PTS |
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LCONVERSION_REF |
getAddress(IList< string > criterionValues=null) | A2LRECORD_LAYOUT_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDecimalCount(string format) | A2LCONVERSION_REF | static
getDefCharacteristicFunction() | A2LRECORD_LAYOUT_REF |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LAXIS_PTS | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySegment() | A2LRECORD_LAYOUT_REF |
getMemorySize() | A2LRECORD_LAYOUT_REF | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LCONVERSION_REF | virtual
getRefNodes() | A2LAXIS_PTS | virtual
getSize() | A2LAXIS_PTS | virtual
GuardRails | A2LRECORD_LAYOUT_REF |
InputQuantity (defined in A2LAXIS_PTS) | A2LAXIS_PTS |
IsFormatNotSet | A2LCONVERSION_REF |
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
isReadOnly() | A2LRECORD_LAYOUT_REF |
LowerLimit | A2LCONVERSION_REF |
LowerLimitEx | A2LRECORD_LAYOUT_REF |
MaxAxisPoints (defined in A2LAXIS_PTS) | A2LAXIS_PTS |
MaxDiff | A2LRECORD_LAYOUT_REF |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mByteOrder (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mConversion (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
MemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mFormat (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mMemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
ModelLink | A2LADDRESS |
Monotony (defined in A2LAXIS_PTS) | A2LAXIS_PTS |
mPhysUnit (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mRecordLayout (defined in A2LRECORD_LAYOUT_REF) | A2LRECORD_LAYOUT_REF | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadOnly | A2LRECORD_LAYOUT_REF |
RecordLayout | A2LRECORD_LAYOUT_REF |
RefCompuMethod | A2LCONVERSION_REF |
RefFunctions | A2LCONVERSION_REF |
RefInstance | A2LADDRESS |
RefMeasurement | A2LAXIS_PTS |
RefRecordLayout | A2LRECORD_LAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LRECORD_LAYOUT_REF |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
toStringValue(double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated) | A2LRECORD_LAYOUT_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount) | A2LCONVERSION_REF | static
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double physValue) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF | static
Type | A2LNODE |
Unit | A2LCONVERSION_REF |
UpperLimit | A2LCONVERSION_REF |
UpperLimitEx | A2LRECORD_LAYOUT_REF |


ASAP2Library interface: A2LBIT_OPERATION Class Reference

  • ASAP2
  • A2LBIT_OPERATION
Properties | List of all members
A2LBIT_OPERATION Class Reference

The BIT_OPERATION keyword can be used to perform operation on the masked out value. More...

Properties

BITOPERATION_TYPE | BitOperation [getset]
int | Count [getset]
bool | SignExtend [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

The BIT_OPERATION keyword can be used to perform operation on the masked out value.

First BIT_MASK will be applied on measurement data, then LEFT_SHIFT / RIGHT_SHIFT is performed and last the SIGN_EXTEND is carried out.

SIGN_EXTEND means that the sign bit (masked data’s leftmost bit) will be copied to all bit positions to the left of the sign bit. This results in a new datatype with the same signed value as the masked data.


ASAP2Library interface: Member List

  • ASAP2
  • A2LBIT_OPERATION
A2LBIT_OPERATION Member List

This is the complete list of members for A2LBIT_OPERATION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BitOperation (defined in A2LBIT_OPERATION) | A2LBIT_OPERATION |
ChangedType | A2LNODE |
Childs | A2LNODE |
Count (defined in A2LBIT_OPERATION) | A2LBIT_OPERATION |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
SignExtend (defined in A2LBIT_OPERATION) | A2LBIT_OPERATION |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LBLOB Class Reference

  • ASAP2
  • A2LBLOB
Public Member Functions | Properties | List of all members
A2LBLOB Class Reference

see ASAP2 specification More...

Public Member Functions

override int | getMemorySize ()
Gets the size of used memory in bytes. More...
- Public Member Functions inherited from A2LADDRESS
virtual string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

ADDR_TYPE | AddrType [getset]
uint | Size [getset]
Gets or sets the size of the adjustable object in the emulation memory.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getMemorySize()

override int getMemorySize ( )
virtual

Gets the size of used memory in bytes.

Returns

Implements A2LADDRESS.


ASAP2Library interface: Member List

  • ASAP2
  • A2LBLOB
A2LBLOB Member List

This is the complete list of members for A2LBLOB, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
AddrType (defined in A2LBLOB) | A2LBLOB |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LADDRESS | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySize() | A2LBLOB | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
ModelLink | A2LADDRESS |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefInstance | A2LADDRESS |
Size | A2LBLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCALIBRATION_HANDLE Class Reference

  • ASAP2
  • A2LCALIBRATION_HANDLE
Properties | List of all members
A2LCALIBRATION_HANDLE Class Reference

see ASAP2 specification More...

Properties

List< uint > | Handles [getset]
string | Text [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LCALIBRATION_HANDLE
A2LCALIBRATION_HANDLE Member List

This is the complete list of members for A2LCALIBRATION_HANDLE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
Handles (defined in A2LCALIBRATION_HANDLE) | A2LCALIBRATION_HANDLE |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Text (defined in A2LCALIBRATION_HANDLE) | A2LCALIBRATION_HANDLE |
Type | A2LNODE |


ASAP2Library interface: A2LCALIBRATION_METHOD Class Reference

  • ASAP2
  • A2LCALIBRATION_METHOD
Properties | List of all members
A2LCALIBRATION_METHOD Class Reference

see ASAP2 specification More...

Properties

string | Method [getset]
int | Version [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LCALIBRATION_METHOD
A2LCALIBRATION_METHOD Member List

This is the complete list of members for A2LCALIBRATION_METHOD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Method (defined in A2LCALIBRATION_METHOD) | A2LCALIBRATION_METHOD |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
Version (defined in A2LCALIBRATION_METHOD) | A2LCALIBRATION_METHOD |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
Classes | Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE Class Reference

ASAP2 CANAPE_ADDRESS_UPDATE Interface support. More...

Classes

class | AdrMapType
Adress map type More...
class | CALIBRATION_METHOD
CANAPE calibration method. More...
class | ExSymbolType
Extended Symbol type More...
class | FirstLastNode
Base class for MapSymbol and MemorySegment More...
class | FlashSectionType
Flash section type More...
class | MAP_SYMBOL
CANAPE map symbol More...
class | MEMORY_SEGMENT
CANAPE memory segment More...
class | SymbolType
Symbol type More...

Properties

SymbolType | ECU_CALIBRATION_OFFSET [getset]
ECU CALIBRATION Offset
List< SymbolType > | EPK_ADDRESS [getset]
EPK Address mapping
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

ASAP2 CANAPE_ADDRESS_UPDATE Interface support.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
A2LCANAPE_ADDRESS_UPDATE Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
ECU_CALIBRATION_OFFSET | A2LCANAPE_ADDRESS_UPDATE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPK_ADDRESS | A2LCANAPE_ADDRESS_UPDATE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.AdrMapType Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • AdrMapType
Public Attributes | List of all members
A2LCANAPE_ADDRESS_UPDATE.AdrMapType Class Reference

Adress map type More...

Public Attributes

string | Dst
Destination
string | Src
Source

Detailed Description

Adress map type


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • AdrMapType
A2LCANAPE_ADDRESS_UPDATE.AdrMapType Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.AdrMapType, including all inherited members.

Dst | A2LCANAPE_ADDRESS_UPDATE.AdrMapType
Src | A2LCANAPE_ADDRESS_UPDATE.AdrMapType


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • CALIBRATION_METHOD
Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD Class Reference

CANAPE calibration method. More...

Properties

ExSymbolType | AutoSarSinglePointered [getset]
AutoSAR single pointered
ExSymbolType | InCircuit2 [getset]
InCicuit2
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

CANAPE calibration method.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • CALIBRATION_METHOD
A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AutoSarSinglePointered | A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
InCircuit2 | A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.ExSymbolType Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • ExSymbolType
Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE.ExSymbolType Class Reference

Extended Symbol type More...

Properties

FlashSectionType | FlashSection [getset]
Flash section
SymbolType | OriginalPtrTable [getset]
Original pointer table
- Properties inherited from A2LCANAPE_ADDRESS_UPDATE.SymbolType
string | Name [getset]
Symbol name
uint | Offset [getset]
Symbol name (optional)

Detailed Description

Extended Symbol type


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • ExSymbolType
A2LCANAPE_ADDRESS_UPDATE.ExSymbolType Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.ExSymbolType, including all inherited members.

FlashSection | A2LCANAPE_ADDRESS_UPDATE.ExSymbolType
Name | A2LCANAPE_ADDRESS_UPDATE.SymbolType
Offset | A2LCANAPE_ADDRESS_UPDATE.SymbolType
OriginalPtrTable | A2LCANAPE_ADDRESS_UPDATE.ExSymbolType


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.FirstLastNode Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • FirstLastNode
Protected Member Functions | Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE.FirstLastNode Class Reference

Base class for MapSymbol and MemorySegment More...

Protected Member Functions

FirstLastNode (int startLine)
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

AdrMapType[] | AddressMappingXcp [getset]
SymbolType | First [getset]
First symbol
SymbolType | Last [getset]
Last symbol
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for MapSymbol and MemorySegment


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • FirstLastNode
A2LCANAPE_ADDRESS_UPDATE.FirstLastNode Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.FirstLastNode, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressMappingXcp (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
First | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
FirstLastNode() (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
FirstLastNode(int startLine) (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Last | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.FlashSectionType Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • FlashSectionType
Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE.FlashSectionType Class Reference

Flash section type More...

Properties

uint | Address [getset]
Flash section address
uint | Length [getset]
Flash section length

Detailed Description

Flash section type


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • FlashSectionType
A2LCANAPE_ADDRESS_UPDATE.FlashSectionType Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.FlashSectionType, including all inherited members.

Address | A2LCANAPE_ADDRESS_UPDATE.FlashSectionType
Length | A2LCANAPE_ADDRESS_UPDATE.FlashSectionType


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • MAP_SYMBOL
List of all members
A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL Class Reference

CANAPE map symbol More...

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
FirstLastNode (int startLine)
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
AdrMapType[] | AddressMappingXcp [getset]
SymbolType | First [getset]
First symbol
SymbolType | Last [getset]
Last symbol
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

CANAPE map symbol


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • MAP_SYMBOL
A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressMappingXcp (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
First | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
FirstLastNode() (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
FirstLastNode(int startLine) (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Last | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • MEMORY_SEGMENT
List of all members
A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT Class Reference

CANAPE memory segment More...

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
FirstLastNode (int startLine)
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
AdrMapType[] | AddressMappingXcp [getset]
SymbolType | First [getset]
First symbol
SymbolType | Last [getset]
Last symbol
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

CANAPE memory segment


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • MEMORY_SEGMENT
A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressMappingXcp (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
First | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
FirstLastNode() (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
FirstLastNode(int startLine) (defined in A2LCANAPE_ADDRESS_UPDATE.FirstLastNode) | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | protected
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Last | A2LCANAPE_ADDRESS_UPDATE.FirstLastNode |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCANAPE_ADDRESS_UPDATE.SymbolType Class Reference

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • SymbolType
Properties | List of all members
A2LCANAPE_ADDRESS_UPDATE.SymbolType Class Reference

Symbol type More...

Properties

string | Name [getset]
Symbol name
uint | Offset [getset]
Symbol name (optional)

Detailed Description

Symbol type


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_ADDRESS_UPDATE
  • SymbolType
A2LCANAPE_ADDRESS_UPDATE.SymbolType Member List

This is the complete list of members for A2LCANAPE_ADDRESS_UPDATE.SymbolType, including all inherited members.

Name | A2LCANAPE_ADDRESS_UPDATE.SymbolType
Offset | A2LCANAPE_ADDRESS_UPDATE.SymbolType


ASAP2Library interface: A2LCANAPE_EXT Class Reference

  • ASAP2
  • A2LCANAPE_EXT
Classes | Properties | List of all members
A2LCANAPE_EXT Class Reference

ASAP2 CANAPE_EXT Interface support. More...

Classes

class | DisplayType
Display setting definition More...
class | LinkMapType
Linker map definition More...
class | VirtualConvType
Virtual conversion definition More...

Properties

DisplayType | Display [getset]
Display setting
LinkMapType | LinkMap [getset]
Linker map
override string | Name [get]
Gets the name of the node.
ushort | Version [getset]
Structure version number
VirtualConvType | VirtualConversion [getset]
Virtual conversion
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

ASAP2 CANAPE_EXT Interface support.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_EXT
A2LCANAPE_EXT Member List

This is the complete list of members for A2LCANAPE_EXT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Display | A2LCANAPE_EXT |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
LinkMap | A2LCANAPE_EXT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LCANAPE_EXT |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
Version | A2LCANAPE_EXT |
VirtualConversion | A2LCANAPE_EXT |


ASAP2Library interface: A2LCANAPE_EXT.DisplayType Class Reference

  • ASAP2
  • A2LCANAPE_EXT
  • DisplayType
Properties | List of all members
A2LCANAPE_EXT.DisplayType Class Reference

Display setting definition More...

Properties

int | Color [getset]
double | Max [getset]
double | Min [getset]

Detailed Description

Display setting definition


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_EXT
  • DisplayType
A2LCANAPE_EXT.DisplayType Member List

This is the complete list of members for A2LCANAPE_EXT.DisplayType, including all inherited members.

Color (defined in A2LCANAPE_EXT.DisplayType) | A2LCANAPE_EXT.DisplayType
Max (defined in A2LCANAPE_EXT.DisplayType) | A2LCANAPE_EXT.DisplayType
Min (defined in A2LCANAPE_EXT.DisplayType) | A2LCANAPE_EXT.DisplayType


ASAP2Library interface: A2LCANAPE_EXT.LinkMapType Class Reference

  • ASAP2
  • A2LCANAPE_EXT
  • LinkMapType
Properties | List of all members
A2LCANAPE_EXT.LinkMapType Class Reference

Linker map definition More...

Properties

uint | BaseAddress [getset]
ushort | BaseAddressExt [getset]
ushort | BitOffset [getset]
ushort | DataTypEnum [getset]
ushort | IsAddressRelativeToDS [getset]
ushort | IsDataTypeValid [getset]
string | Name [getset]
int | OffsetSegment [getset]

Detailed Description

Linker map definition


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_EXT
  • LinkMapType
A2LCANAPE_EXT.LinkMapType Member List

This is the complete list of members for A2LCANAPE_EXT.LinkMapType, including all inherited members.

BaseAddress (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
BaseAddressExt (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
BitOffset (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
DataTypEnum (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
IsAddressRelativeToDS (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
IsDataTypeValid (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
Name (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType
OffsetSegment (defined in A2LCANAPE_EXT.LinkMapType) | A2LCANAPE_EXT.LinkMapType


ASAP2Library interface: A2LCANAPE_EXT.VirtualConvType Class Reference

  • ASAP2
  • A2LCANAPE_EXT
  • VirtualConvType
Properties | List of all members
A2LCANAPE_EXT.VirtualConvType Class Reference

Virtual conversion definition More...

Properties

string Name [getset]

Detailed Description

Virtual conversion definition


ASAP2Library interface: Member List

  • ASAP2
  • A2LCANAPE_EXT
  • VirtualConvType
A2LCANAPE_EXT.VirtualConvType Member List

This is the complete list of members for A2LCANAPE_EXT.VirtualConvType, including all inherited members.

Name (defined in A2LCANAPE_EXT.VirtualConvType) A2LCANAPE_EXT.VirtualConvType


ASAP2Library interface: A2LCHARACTERISTIC Class Reference

  • ASAP2
  • A2LCHARACTERISTIC
Public Member Functions | Properties | List of all members
A2LCHARACTERISTIC Class Reference

see ASAP2 specification More...

Public Member Functions

override string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
int | getNumberOfElements ()
Gets the number of elements depending on the CharType property. More...
override int | getSize ()
Gets the size in bytes of the characteristic. More...
- Public Member Functions inherited from A2LRECORD_LAYOUT_REF
uint | getAddress (IList< string > criterionValues=null)
Gets the effective address supporting a potentially defined variant coding. More...
A2LFUNCTION getDefCharacteristicFunction ()
Gets the function which holds the current instance as the DEF_CHARACTERISTIC. More...
IA2LMemory getMemorySegment ()
Gets the corresponding memory segment (may be null). More...
sealed override int | getMemorySize ()
Gets the size of used memory in bytes. More...
bool | isReadOnly ()
Returns a value indicating if the characteristic value should not be changed. More...
string | toStringValue (double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LCONVERSION_REF
override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
sealed override string | ToString ()
string | toStringValue (double physValue)
Builds a string representation from the specified physical value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true)
Builds a string representation from the specified value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

ulong | Bitmask = ulong.MaxValue [getset]
Gets or sets the Bitmask.
CHAR_TYPE | CharType [getset]
Gets the characteristic type.
string | ComparisonQuantity [getset]
Gets or sets the comparison quantity.
bool | Discrete [getset]
Gets or sets the discrete flag. More...
EncodingType | Encoding = EncodingType.ASCII [getset]
Encoding to use for CHAR_TYPE.ASCII.
int[] | MatrixDim [getset]
Gets the 3-value (x, y, z) integer matrix dimensions. More...
int | Number [getset]
Gets the number of fixed values. More...
A2LMEASUREMENT | RefComparisonQuantity [get]
Gets the direct reference to the reference comparison quantity of the axis. More...
- Properties inherited from A2LRECORD_LAYOUT_REF
bool | GuardRails [getset]
Gets or sets the guard rails. More...
double | LowerLimitEx [getset]
Gets or sets the extended lower limit.
double | MaxDiff [getset]
Gets or sets the maximum float with respect to an adjustment of a table value.
bool | ReadOnly [getset]
Gets or sets the readonly state. More...
string | RecordLayout [getset]
Gets a reference to the corresponding data record for description of the record layout (see A2LRECORD_LAYOUT) More...
A2LRECORD_LAYOUT | RefRecordLayout [get]
Gets the direct reference to the corresponding record layout. More...
double | StepSize = double.NaN [getset]
Gets or sets the step size. More...
double | UpperLimitEx [getset]
Gets or sets the extended upper limit.
- Properties inherited from A2LCONVERSION_REF
BYTEORDER_TYPE??? | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
Gets or sets the conversion's name. More...
int | DecimalCount [get]
Gets the decimal count of the corresponding Format value.
string????? | Format [getset]
Gets or sets the format. More...
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
Gets or sets the plausible range of table values, lower limit.
string | MemorySegmentRef [get]
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
IEnumerable< A2LREFBASE > | RefFunctions [get]
Gets the list of functions referring this node.
string? | Unit [getset]
Gets or sets the Unit.
double | UpperLimit [getset]
Gets or sets the plausible range of table values, upper limit.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCONVERSION_REF
static int | getDecimalCount (string format)
Gets the decimal count from an A2L format string. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount)
Builds a string representation from the specified value. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LRECORD_LAYOUT_REF
A2LRECORD_LAYOUT_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LCONVERSION_REF
A2LCONVERSION_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LRECORD_LAYOUT_REF
string | mRecordLayout
- Protected Attributes inherited from A2LCONVERSION_REF
BYTEORDER_TYPE | mByteOrder
string | mConversion
string | mFormat = string.Empty
string | mMemorySegmentRef
string | mPhysUnit
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

override string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
virtual

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Reimplemented from A2LADDRESS.

◆ getNumberOfElements()

int getNumberOfElements ( )

Gets the number of elements depending on the CharType property.

  • CHAR_TYPE.VALUE: aleays 1
  • CHAR_TYPE.ASCII, CHAR_TYPE.VAL_BLK: multiplied with MatrixDim values or Number
  • all others: Not supported
Returns
The number of elements
Exceptions
NotSupportedException Thrown, if accessed by not supported types.

◆ getSize()

override int getSize ( )
virtual

Gets the size in bytes of the characteristic.

The size is calculated from

  • the corresponding record layout
  • the number of elements from MatrixDim
  • external references (like A2LAXIS_PTS) of the characteristic is not taken into account

Together with the characteristic's address, the characteristic's complete value could be read or written directly from/to a MemorySegment or device.

Returns
The size in bytes

Implements A2LRECORD_LAYOUT_REF.

Property Documentation

◆ Discrete

bool Discrete
getset

Gets or sets the discrete flag.

This keyword indicates that the characteristic values are discrete values which should not be interpolated – e.g. in graphic display windows or further calculations. This flag can be used e.g. for integer objects describing states. If the keyword is not specified the values are interpreted as continuous values which can be interpolated.

◆ MatrixDim

int [] MatrixDim
getset

Gets the 3-value (x, y, z) integer matrix dimensions.

Shows the size and dimension of a multidimensional characteristic (e.g. VAL_BLK). If the MATRIX_DIM keyword is used, then the option NUMBER is not needed. However, if the keywords NUMBER and MATRIX_DIM are both used, the resulting value in NUMBER must be the same as xDim * yDim * zDim for MATRIX_DIM. If the keyword is missing the array has only one dimension with the size given at NUMBER.

◆ Number

int Number
getset

Gets the number of fixed values.

For the adjustable object types 'fixed value block' (VAL_BLK) and 'string' (ASCII), this keyword specifies the number of fixed values and characters respectively.

◆ RefComparisonQuantity

A2LMEASUREMENT RefComparisonQuantity
get

Gets the direct reference to the reference comparison quantity of the axis.

May be null if not defined.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCHARACTERISTIC
A2LCHARACTERISTIC Member List

This is the complete list of members for A2LCHARACTERISTIC, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCONVERSION_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv) | A2LCONVERSION_REF | protected
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LRECORD_LAYOUT_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout) | A2LRECORD_LAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
Bitmask | A2LCHARACTERISTIC |
ByteOrder | A2LCONVERSION_REF |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
CharType | A2LCHARACTERISTIC |
Childs | A2LNODE |
ComparisonQuantity | A2LCHARACTERISTIC |
Conversion | A2LCONVERSION_REF |
DecimalCount | A2LCONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
Discrete | A2LCHARACTERISTIC |
DisplayName | A2LADDRESS |
Encoding | A2LCHARACTERISTIC |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LCONVERSION_REF |
getAddress(IList< string > criterionValues=null) | A2LRECORD_LAYOUT_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDecimalCount(string format) | A2LCONVERSION_REF | static
getDefCharacteristicFunction() | A2LRECORD_LAYOUT_REF |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCHARACTERISTIC | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySegment() | A2LRECORD_LAYOUT_REF |
getMemorySize() | A2LRECORD_LAYOUT_REF | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getNumberOfElements() | A2LCHARACTERISTIC |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LCONVERSION_REF | virtual
getRefNodes() | A2LNODE | virtual
getSize() | A2LCHARACTERISTIC | virtual
GuardRails | A2LRECORD_LAYOUT_REF |
IsFormatNotSet | A2LCONVERSION_REF |
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
isReadOnly() | A2LRECORD_LAYOUT_REF |
LowerLimit | A2LCONVERSION_REF |
LowerLimitEx | A2LRECORD_LAYOUT_REF |
MatrixDim | A2LCHARACTERISTIC |
MaxDiff | A2LRECORD_LAYOUT_REF |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mByteOrder (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mConversion (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
MemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mFormat (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mMemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
ModelLink | A2LADDRESS |
mPhysUnit (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mRecordLayout (defined in A2LRECORD_LAYOUT_REF) | A2LRECORD_LAYOUT_REF | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Number | A2LCHARACTERISTIC |
Parent | A2LNODE |
ReadOnly | A2LRECORD_LAYOUT_REF |
RecordLayout | A2LRECORD_LAYOUT_REF |
RefComparisonQuantity | A2LCHARACTERISTIC |
RefCompuMethod | A2LCONVERSION_REF |
RefFunctions | A2LCONVERSION_REF |
RefInstance | A2LADDRESS |
RefRecordLayout | A2LRECORD_LAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LRECORD_LAYOUT_REF |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
toStringValue(double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated) | A2LRECORD_LAYOUT_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount) | A2LCONVERSION_REF | static
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double physValue) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF | static
Type | A2LNODE |
Unit | A2LCONVERSION_REF |
UpperLimit | A2LCONVERSION_REF |
UpperLimitEx | A2LRECORD_LAYOUT_REF |


ASAP2Library interface: A2LCOMPU_METHOD Class Reference

  • ASAP2
  • A2LCOMPU_METHOD
Public Member Functions | Static Public Attributes | Properties | List of all members
A2LCOMPU_METHOD Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
double | getMinIncrement (double physLower, double physUpper, int decimalCount, DATA_TYPE dataType)
Gets the minimum increment. More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
double | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toPhysical (double rawValue, int decimalCount)
Computes the physical value from a raw value. More...
double | toRaw (DATA_TYPE dataType, double physicalValue)
Computes the raw value from a physical value. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Static Public Attributes

static readonly Regex | FormatMatcher = new Regex(@"%(?:\d+.\d+|.\d+)", RegexOptions.CultureInvariant)
static readonly A2LCOMPU_METHOD | mDefaultCompuMethod = new A2LCOMPU_METHOD(-2) { Name = NoCompuMethod, Format = DefaultFormat }
Default compu method definition (no conversion from raw to physical values).
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion

Properties

RationalCoeffs | Coeffs = new RationalCoeffs() [getset]
string | CompuTabRef [getset]
CONVERSION_TYPE | ConversionType [getset]
string | Description [getset]
string | Format [getset]
bool?? | IsString [get]
Indicates if the compu method's physical value is represented as a string (Verbal or Verbal range).
A2LCOMPU_TAB_BASE | RefCompuTab [get]
string | StatusStringRef [getset]
string | Unit [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getMinIncrement()

double getMinIncrement | ( | double | physLower,
 |  | double | physUpper,
 |  | int | decimalCount,
 |  | DATA_TYPE | dataType
 | ) |  |

Gets the minimum increment.

Parameters
physLower | Physical lower limit
physUpper | Physical upper limit
decimalCount | Count of decimal places
dataType | Data type of the corresponding A2LCONVERSION_REF instance
Returns
the computed increment

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCONVERSION_REFs.

Returns
May be null or empty if not referenced by any node.

Reimplemented from A2LNODE.

◆ toPhysical() [1/2]

double toPhysical ( double rawValue )

Computes the physical value from a raw value.

Parameters
rawValue The raw value
Returns
Physical value.

◆ toPhysical() [2/2]

double toPhysical | ( | double | rawValue,
 |  | int | decimalCount
 | ) |  |

Computes the physical value from a raw value.

Parameters
rawValue | The raw value
decimalCount | The decimal count to round to
Returns
Physical value.

◆ toRaw()

double toRaw | ( | DATA_TYPE | dataType,
 |  | double | physicalValue
 | ) |  |

Computes the raw value from a physical value.

Parameters
dataType | The raw data type of the value
physicalValue | The raw value
Returns
Raw value.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCOMPU_METHOD
A2LCOMPU_METHOD Member List

This is the complete list of members for A2LCOMPU_METHOD, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
Coeffs (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
CompuTabRef (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
ConversionType (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
FormatMatcher (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD | static
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCOMPU_METHOD |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMinIncrement(double physLower, double physUpper, int decimalCount, DATA_TYPE dataType) | A2LCOMPU_METHOD |
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LCOMPU_METHOD | virtual
IsInstanced | A2LNODE |
IsString | A2LCOMPU_METHOD |
mDefaultCompuMethod | A2LCOMPU_METHOD | static
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefCompuTab (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StatusStringRef (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |
Tag | A2LNODE |
toPhysical(double rawValue) | A2LCOMPU_METHOD |
toPhysical(double rawValue, int decimalCount) | A2LCOMPU_METHOD |
toRaw(DATA_TYPE dataType, double physicalValue) | A2LCOMPU_METHOD |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
Unit (defined in A2LCOMPU_METHOD) | A2LCOMPU_METHOD |


ASAP2Library interface: A2LCOMPU_TAB Class Reference

  • ASAP2
  • A2LCOMPU_TAB
Public Member Functions | Properties | List of all members
A2LCOMPU_TAB Class Reference

see ASAP2 specification More...

Public Member Functions

double | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toRaw (double physicalValue)
Computes the raw value from the specified physical (string) value. More...
double | toRaw (string strValue)
Computes the raw value from the specified physical (string) value. More...
- Public Member Functions inherited from A2LCOMPU_TAB_BASE
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

double | DefaultValueNumeric = double.NaN [getset]
SortedList< float, double > | Values = new SortedList<float, double>() [getset]
DictionaryProxy< float, double > | Values_ [getset]
This is just to serialize and deserialize to XML, use the Values property to access.
- Properties inherited from A2LCOMPU_TAB_BASE
CONVERSION_TYPE | ConversionType [getset]
string | DefaultValue [getset]
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ toPhysical()

double toPhysical ( double rawValue )

Computes the physical value from a raw value.

Parameters
rawValue The raw value
Returns
The physical value string.

◆ toRaw() [1/2]

double toRaw ( double physicalValue )

Computes the raw value from the specified physical (string) value.

Parameters
physicalValue The physical (string) value
Returns
The raw value

◆ toRaw() [2/2]

double toRaw ( string strValue )

Computes the raw value from the specified physical (string) value.

Parameters
strValue The physical (string) value
Returns
The raw value


ASAP2Library interface: Member List

  • ASAP2
  • A2LCOMPU_TAB
A2LCOMPU_TAB Member List

This is the complete list of members for A2LCOMPU_TAB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ConversionType (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DefaultValue (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DefaultValueNumeric (defined in A2LCOMPU_TAB) | A2LCOMPU_TAB |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCOMPU_TAB_BASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LCOMPU_TAB_BASE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
toPhysical(double rawValue) | A2LCOMPU_TAB |
toRaw(string strValue) | A2LCOMPU_TAB |
toRaw(double physicalValue) | A2LCOMPU_TAB |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
Values (defined in A2LCOMPU_TAB) | A2LCOMPU_TAB |
Values_ | A2LCOMPU_TAB |


ASAP2Library interface: A2LCOMPU_TAB_BASE Class Reference

  • ASAP2
  • A2LCOMPU_TAB_BASE
Public Member Functions | Properties | List of all members
A2LCOMPU_TAB_BASE Class Reference

Base class for dictionary based compu methods. More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

CONVERSION_TYPE | ConversionType [getset]
string | DefaultValue [getset]
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for dictionary based compu methods.

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCONVERSION_REFs.

Returns
May be null or empty if not referenced by any node.

Reimplemented from A2LNODE.


ASAP2Library interface: Member List

  • ASAP2
  • A2LCOMPU_TAB_BASE
A2LCOMPU_TAB_BASE Member List

This is the complete list of members for A2LCOMPU_TAB_BASE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ConversionType (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DefaultValue (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCOMPU_TAB_BASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LCOMPU_TAB_BASE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LCOMPU_VTAB Class Reference

  • ASAP2
  • A2LCOMPU_VTAB
Public Member Functions | Properties | List of all members
A2LCOMPU_VTAB Class Reference

see ASAP2 specification More...

Public Member Functions

string | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toRaw (string strValue)
Computes the raw value from the specified physical (string) value. More...
- Public Member Functions inherited from A2LCOMPU_TAB_BASE
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

SortedList< long, string > | Verbs = new SortedList<long, string>() [getset]
DictionaryProxy< long, string > | Verbs_ [getset]
This is just to serialize and deserialize to XML, use the Verbs property to access.
- Properties inherited from A2LCOMPU_TAB_BASE
CONVERSION_TYPE | ConversionType [getset]
string | DefaultValue [getset]
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ toPhysical()

string toPhysical ( double rawValue )

Computes the physical value from a raw value.

Parameters
rawValue The raw value
Returns
The physical value string.

◆ toRaw()

double toRaw ( string strValue )

Computes the raw value from the specified physical (string) value.

Returns

  • 0 if the string is null or empty
  • 0 if the specified string is not defined
Parameters
strValue The physical (string) value
Returns
The raw value


ASAP2Library interface: Member List

  • ASAP2
  • A2LCOMPU_VTAB
A2LCOMPU_VTAB Member List

This is the complete list of members for A2LCOMPU_VTAB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ConversionType (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DefaultValue (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCOMPU_TAB_BASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LCOMPU_TAB_BASE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
toPhysical(double rawValue) | A2LCOMPU_VTAB |
toRaw(string strValue) | A2LCOMPU_VTAB |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
Verbs (defined in A2LCOMPU_VTAB) | A2LCOMPU_VTAB |
Verbs_ | A2LCOMPU_VTAB |


ASAP2Library interface: A2LCOMPU_VTAB_RANGE Class Reference

  • ASAP2
  • A2LCOMPU_VTAB_RANGE
Public Member Functions | Properties | List of all members
A2LCOMPU_VTAB_RANGE Class Reference

see ASAP2 specification More...

Public Member Functions

string | toPhysical (double rawValue)
Computes the physical value from a raw value. More...
double | toRaw (string physValue)
Computes the raw value from a physical value More...
- Public Member Functions inherited from A2LCOMPU_TAB_BASE
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

Dictionary< string, List< sRange > > | Verbs = new Dictionary<string, List<sRange>>() [get]
DictionaryProxyComplex< string, List< sRange > > | Verbs_ [getset]
This is just to serialize and deserialize to XML, use the Verbs property to access.
- Properties inherited from A2LCOMPU_TAB_BASE
CONVERSION_TYPE | ConversionType [getset]
string | DefaultValue [getset]
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ toPhysical()

string toPhysical ( double rawValue )

Computes the physical value from a raw value.

Parameters
rawValue The raw value
Returns
The physical value string.

◆ toRaw()

double toRaw ( string physValue )

Computes the raw value from a physical value

This method looses potential data as the raw value may be ambigous in this case (something between Min and Max) Nevertheless there are DCM files exporting the physical key of ranges.

Parameters
physValue The physical value as a string
Returns
the raw value (always the Mininmum range value for a found key)


ASAP2Library interface: Member List

  • ASAP2
  • A2LCOMPU_VTAB_RANGE
A2LCOMPU_VTAB_RANGE Member List

This is the complete list of members for A2LCOMPU_VTAB_RANGE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
ConversionType (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DefaultValue (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LCOMPU_TAB_BASE) | A2LCOMPU_TAB_BASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LCOMPU_TAB_BASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LCOMPU_TAB_BASE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
toPhysical(double rawValue) | A2LCOMPU_VTAB_RANGE |
toRaw(string physValue) | A2LCOMPU_VTAB_RANGE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
Verbs (defined in A2LCOMPU_VTAB_RANGE) | A2LCOMPU_VTAB_RANGE |
Verbs_ | A2LCOMPU_VTAB_RANGE |


ASAP2Library interface: A2LCONVERSION_REF Class Reference

  • ASAP2
  • A2LCONVERSION_REF
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
A2LCONVERSION_REF Class Reference

Base class for all A2L entities referencing an A2L_COMPUMETHOD method. More...

Public Member Functions

override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
sealed override string | ToString ()
string | toStringValue (double physValue)
Builds a string representation from the specified physical value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true)
Builds a string representation from the specified value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LADDRESS
virtual string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
abstract int | getMemorySize ()
Gets the size of used memory in bytes. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Static Public Member Functions

static int | getDecimalCount (string format)
Gets the decimal count from an A2L format string. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount)
Builds a string representation from the specified value. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Protected Member Functions

A2LCONVERSION_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Protected Attributes

BYTEORDER_TYPE | mByteOrder
string | mConversion
string | mFormat = string.Empty
string | mMemorySegmentRef
string | mPhysUnit
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty

Properties

BYTEORDER_TYPE??? | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
Gets or sets the conversion's name. More...
int | DecimalCount [get]
Gets the decimal count of the corresponding Format value.
string????? | Format [getset]
Gets or sets the format. More...
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
Gets or sets the plausible range of table values, lower limit.
string | MemorySegmentRef [get]
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
IEnumerable< A2LREFBASE > | RefFunctions [get]
Gets the list of functions referring this node.
string? | Unit [getset]
Gets or sets the Unit.
double | UpperLimit [getset]
Gets or sets the plausible range of table values, upper limit.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L entities referencing an A2L_COMPUMETHOD method.

Constructor & Destructor Documentation

◆ A2LCONVERSION_REF()

A2LCONVERSION_REF | ( | A2LMODULE | module,
 |  | A2LINSTANCE | instance,
 |  | A2LTYPEDEF_CONVERSION_REF | tdConv
 | ) |  |
protected

Creates instance from an A2LINSTANCE.

Parameters
module | The module to add the instance to
instance | The instance to create from
tdConv | The conversion ref typedef reference

Member Function Documentation

◆ getDecimalCount()

static int getDecimalCount ( string format )
static

Gets the decimal count from an A2L format string.

Parameters
format
Returns
The count of decimal places

◆ getRefFunctions()

override IEnumerable< A2LREFBASE > getRefFunctions ( )
virtual

Gets the referencing functions.

Ususally only valid for A2LMEASUREMENT and A2LCHARACTERISTIC.

Returns
May be null or empty if not referenced by any node.

Reimplemented from A2LNODE.

◆ toStringValue() [1/5]

string toStringValue ( double physValue )

Builds a string representation from the specified physical value.

Parameters
physValue The physical value to build the string for
Returns
the string representation

◆ toStringValue() [2/5]

static string toStringValue | ( | double | value,
 |  | ValueObjectFormat | format,
 |  | DATA_TYPE | dataType,
 |  | A2LCOMPU_METHOD | compuMethod,
 |  | int | decimalCount
 | ) |  |
static

Builds a string representation from the specified value.

Parameters
value | The value to build the string for
format | The value format
dataType | The data type (only important if format is raw)
compuMethod | The corresponding comp method
decimalCount | The value decimal count (only used if ValueObjectFormt.Physical is set)
Returns
the string representation

◆ toStringValue() [3/5]

static string toStringValue | ( | double | value,
 |  | ValueObjectFormat | format,
 |  | DATA_TYPE | dataType,
 |  | A2LCOMPU_METHOD | compuMethod,
 |  | int | decimalCount,
 |  | double | lowerLimit,
 |  | double | upperLimit,
 |  | out bool | lowerLimitViolated,
 |  | out bool | upperLimitViolated
 | ) |  |
static

Builds a string representation from the specified value.

Parameters
value | The value to build the string for
format | The value format
dataType | The data type (only used if ValueObjectFormt.Physical is not set)
compuMethod | The corresponding comp method
decimalCount | The value decimal count (only used if ValueObjectFormt.Physical is set)
lowerLimit | The physical lower limit
upperLimit | The physical upper limit
lowerLimitViolated | true if the lower limit is violated
upperLimitViolated | true if the upper limit is violated
Returns
the string representation

◆ toStringValue() [4/5]

string toStringValue | ( | double | value,
 |  | ValueObjectFormat | format,
 |  | DATA_TYPE | dataType,
 |  | bool | forceFmt = true
 | ) |  |

Builds a string representation from the specified value.

Parameters
value | The value to build the string for
format | The value format
dataType | The data type (only important if format is raw)
forceFmt | false, if values should not be rounded to the value's phsical format
Returns
the string representation

◆ toStringValue() [5/5]

string toStringValue | ( | double | value,
 |  | ValueObjectFormat | format,
 |  | DATA_TYPE | dataType,
 |  | out bool | lowerLimitViolated,
 |  | out bool | upperLimitViolated
 | ) |  |

Builds a string representation from the specified value.

Parameters
value | The value to build the string for
format | The value format
dataType | The data type (only important if format is raw)
lowerLimitViolated | true if the lower limit is violated
upperLimitViolated | true if the upper limit is violated
Returns
the string representation

Property Documentation

◆ ByteOrder

BYTEORDER_TYPE??? ByteOrder
getset

Gets or sets the Byte order (optional).

  • If the local value is NotSet, the value from A2LMOD_COMMON is taken.
  • The setter initialises the byte order cache (e.g. if the MOD_COMMON vbyte order is changed).
  • The local member is explicitely set.

◆ Conversion

string Conversion
getset

Gets or sets the conversion's name.

Reference to the relevant record of the description of the conversion method (see A2LCOMPU_METHOD). If there is no conversion method, as in the case of CURVE_AXIS, the parameter ‘Conversion’ should be set to "NO_COMPU_METHOD" (measurement and calibration systems must be able to handle this case).

◆ Format

string????? Format
getset

Gets or sets the format.

With deviation from the display format specified with keyword COMPU_TAB referenced by parameter Conversion a special display format can be specified to be used to display the table values.

◆ IsFormatNotSet

bool IsFormatNotSet
get

Indicates if a format string is not set.

A not set format occurs if it is not explicitly defined by the Format property and (the referenced CompuMethod is defined as a NO_COMPU_METHOD or the referenced CompuMethod is not found and replaced by a default one)


ASAP2Library interface: Member List

  • ASAP2
  • A2LCONVERSION_REF
A2LCONVERSION_REF Member List

This is the complete list of members for A2LCONVERSION_REF, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCONVERSION_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv) | A2LCONVERSION_REF | protected
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
ByteOrder | A2LCONVERSION_REF |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LCONVERSION_REF |
DecimalCount | A2LCONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LCONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDecimalCount(string format) | A2LCONVERSION_REF | static
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LADDRESS | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySize() | A2LADDRESS | pure virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LCONVERSION_REF | virtual
getRefNodes() | A2LNODE | virtual
IsFormatNotSet | A2LCONVERSION_REF |
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
LowerLimit | A2LCONVERSION_REF |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mByteOrder (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mConversion (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
MemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mFormat (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mMemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
ModelLink | A2LADDRESS |
mPhysUnit (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefCompuMethod | A2LCONVERSION_REF |
RefFunctions | A2LCONVERSION_REF |
RefInstance | A2LADDRESS |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount) | A2LCONVERSION_REF | static
toStringValue(double physValue) | A2LCONVERSION_REF |
toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true) | A2LCONVERSION_REF |
toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF |
toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF | static
Type | A2LNODE |
Unit | A2LCONVERSION_REF |
UpperLimit | A2LCONVERSION_REF |


ASAP2Library interface: A2LDEF_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LDEF_CHARACTERISTIC
List of all members
A2LDEF_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LDEF_CHARACTERISTIC
A2LDEF_CHARACTERISTIC Member List

This is the complete list of members for A2LDEF_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LDEPENDENT_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LDEPENDENT_CHARACTERISTIC
Properties | List of all members
A2LDEPENDENT_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Properties

string | Formula [getset]
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LDEPENDENT_CHARACTERISTIC
A2LDEPENDENT_CHARACTERISTIC Member List

This is the complete list of members for A2LDEPENDENT_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Formula (defined in A2LDEPENDENT_CHARACTERISTIC) | A2LDEPENDENT_CHARACTERISTIC |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LFIX_AXIS_PAR_LIST Class Reference

  • ASAP2
  • A2LFIX_AXIS_PAR_LIST
Properties | List of all members
A2LFIX_AXIS_PAR_LIST Class Reference

see ASAP2 specification More...

Properties

List< double > | Values = new List<double>() [get]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LFIX_AXIS_PAR_LIST
A2LFIX_AXIS_PAR_LIST Member List

This is the complete list of members for A2LFIX_AXIS_PAR_LIST, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
Values (defined in A2LFIX_AXIS_PAR_LIST) | A2LFIX_AXIS_PAR_LIST |


ASAP2Library interface: A2LFORMULA Class Reference

  • ASAP2
  • A2LFORMULA
Properties | List of all members
A2LFORMULA Class Reference

see ASAP2 specification More...

Properties

string | Formula [getset]
string | FormulaInv [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LFORMULA
A2LFORMULA Member List

This is the complete list of members for A2LFORMULA, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Formula (defined in A2LFORMULA) | A2LFORMULA |
FormulaInv (defined in A2LFORMULA) | A2LFORMULA |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LFRAME Class Reference

  • ASAP2
  • A2LFRAME
Public Member Functions | Properties | List of all members
A2LFRAME Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

string | Description [getset]
long | Rate [getset]
A2LNODE[] | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string > | References [getset]
int | ScalingUnit [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.


ASAP2Library interface: Member List

  • ASAP2
  • A2LFRAME
A2LFRAME Member List

This is the complete list of members for A2LFRAME, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LFRAME) | A2LFRAME |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LFRAME |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Rate (defined in A2LFRAME) | A2LFRAME |
ReferencedNodes | A2LFRAME |
References (defined in A2LFRAME) | A2LFRAME |
ScalingUnit (defined in A2LFRAME) | A2LFRAME |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LFUNCTION Class Reference

  • ASAP2
  • A2LFUNCTION
Properties | List of all members
A2LFUNCTION Class Reference

see ASAP2 specification More...

Properties

override List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
string | Version [getset]
- Properties inherited from A2LREFBASE
string | Description [getset]
virtual List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LREFBASE
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
void | resetReferences ()
Resets cached references.
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LREFBASE
A2LREFBASE (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LREFBASE
List< A2LNAMEDNODE > | mReferencedNodes
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LFUNCTION
A2LFUNCTION Member List

This is the complete list of members for A2LFUNCTION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LREFBASE(int startLine) (defined in A2LREFBASE) | A2LREFBASE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LREFBASE) | A2LREFBASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFBASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mReferencedNodes (defined in A2LREFBASE) | A2LREFBASE | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LFUNCTION |
resetReferences() | A2LREFBASE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
Version (defined in A2LFUNCTION) | A2LFUNCTION |


ASAP2Library interface: A2LFUNCTION_LIST Class Reference

  • ASAP2
  • A2LFUNCTION_LIST
List of all members
A2LFUNCTION_LIST Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LFUNCTION_LIST
A2LFUNCTION_LIST Member List

This is the complete list of members for A2LFUNCTION_LIST, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LGROUP Class Reference

  • ASAP2
  • A2LGROUP
Properties | List of all members
A2LGROUP Class Reference

see ASAP2 specification More...

Properties

override List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
bool | Root [getset]
- Properties inherited from A2LREFBASE
string | Description [getset]
virtual List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LREFBASE
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
void | resetReferences ()
Resets cached references.
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LREFBASE
A2LREFBASE (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LREFBASE
List< A2LNAMEDNODE > | mReferencedNodes
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LGROUP
A2LGROUP Member List

This is the complete list of members for A2LGROUP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LREFBASE(int startLine) (defined in A2LREFBASE) | A2LREFBASE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LREFBASE) | A2LREFBASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFBASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mReferencedNodes (defined in A2LREFBASE) | A2LREFBASE | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LGROUP |
resetReferences() | A2LREFBASE |
Root (defined in A2LGROUP) | A2LGROUP |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LHEADER Class Reference

  • ASAP2
  • A2LHEADER
Properties | List of all members
A2LHEADER Class Reference

see ASAP2 specification More...

Properties

string | Comment [getset]
string | PROJECT_NO [getset]
string | VERSION [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LHEADER
A2LHEADER Member List

This is the complete list of members for A2LHEADER, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
Comment (defined in A2LHEADER) | A2LHEADER |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PROJECT_NO (defined in A2LHEADER) | A2LHEADER |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
VERSION (defined in A2LHEADER) | A2LHEADER |


ASAP2Library interface: A2LIF_DATA Class Reference

  • ASAP2
  • A2LIF_DATA
Properties | List of all members
A2LIF_DATA Class Reference

see ASAP2 specification More...

Properties

sealed override string | Name [getset]
- Properties inherited from A2LUNSUPPORTEDNODE
string | Content [getset]
Represents the original content from the ASAP2 file as a string. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LUNSUPPORTEDNODE
A2LUNSUPPORTEDNODE (int startLine)
Creates a new instance of A2LUNSUPPORTEDNODE with the specified parameter. More...
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LIF_DATA
A2LIF_DATA Member List

This is the complete list of members for A2LIF_DATA, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LUNSUPPORTEDNODE(int startLine) | A2LUNSUPPORTEDNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
Content | A2LUNSUPPORTEDNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name (defined in A2LIF_DATA) | A2LIF_DATA |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LIN_MEASUREMENT Class Reference

  • ASAP2
  • A2LIN_MEASUREMENT
List of all members
A2LIN_MEASUREMENT Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LIN_MEASUREMENT
A2LIN_MEASUREMENT Member List

This is the complete list of members for A2LIN_MEASUREMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LINSTANCE Class Reference

  • ASAP2
  • A2LINSTANCE
Public Member Functions | Properties | List of all members
A2LINSTANCE Class Reference

see ASAP2 specification More...

Public Member Functions

override string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override int | getMemorySize ()
Gets the size of used memory in bytes. More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2L instanced nodes. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

INDEX_MODE | Layout [getset]
Gets or sets the layout. More...
int[] | MatrixDim [getset]
Gets the 3-value (x, y, z) integer matrix dimensions.
bool | ReadWrite [getset]
Gets or sets the READ_WRITE flag. More...
A2LTYPEDEF | RefTypedef [get]
Gets the direct reference to the corresponding typedef.
string | TypedefName [getset]
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

override string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
virtual

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Reimplemented from A2LADDRESS.

◆ getMemorySize()

override int getMemorySize ( )
virtual

Gets the size of used memory in bytes.

Returns

Implements A2LADDRESS.

◆ getRefNodes()

sealed override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2L instanced nodes.

Returns
List of referenced instance nodes.

Reimplemented from A2LNODE.

Property Documentation

◆ Layout

INDEX_MODE Layout
getset

Gets or sets the layout.

For multi-dimensional measurement arrays this keyword can be used to specify the layout of the array. If the keyword is missing, multi-dimensional measurement arrays are interpreted row by row (ROW_DIR).

◆ ReadWrite

bool ReadWrite
getset

Gets or sets the READ_WRITE flag.

Keyword to mark this measurement object as 'writeable'.


ASAP2Library interface: Member List

  • ASAP2
  • A2LINSTANCE
A2LINSTANCE Member List

This is the complete list of members for A2LINSTANCE, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LINSTANCE | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySize() | A2LINSTANCE | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LINSTANCE | virtual
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
Layout | A2LINSTANCE |
MatrixDim | A2LINSTANCE |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
ModelLink | A2LADDRESS |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadWrite | A2LINSTANCE |
RefInstance | A2LADDRESS |
RefTypedef | A2LINSTANCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
TypedefName (defined in A2LINSTANCE) | A2LINSTANCE |


ASAP2Library interface: A2LLOC_MEASUREMENT Class Reference

  • ASAP2
  • A2LLOC_MEASUREMENT
List of all members
A2LLOC_MEASUREMENT Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LLOC_MEASUREMENT
A2LLOC_MEASUREMENT Member List

This is the complete list of members for A2LLOC_MEASUREMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LMEASUREMENT Class Reference

  • ASAP2
  • A2LMEASUREMENT
Public Member Functions | Static Public Member Functions | Properties | List of all members
A2LMEASUREMENT Class Reference

see ASAP2 specification More...

Public Member Functions

void | addPresetDAQEvent (DAQEventType eventType, ushort evt, int index=-1)
Adds a new DAQ event reference. More...
uint | getAddressOffset (int x, int y)
Gets the address offset for a specific value if this is a multi value measurement (MATRIX_DIM defined). More...
int | getArraySize ()
Gets the array size of the measurement, the minimum is 1 (single value). More...
override string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override int | getMemorySize ()
Gets the size of used memory in bytes. More...
ushort | getPresetDAQEvent (DAQEventType eventType)
Gets the first defined preset event/raster channel. More...
ushort[] | getPresetDAQEvents (DAQEventType eventType)
Gets the defined preset event/raster channels. More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCONVERSION_REFs. More...
string | toStringValue (double value, ValueObjectFormat format)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LCONVERSION_REF
override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
sealed override string | ToString ()
string | toStringValue (double physValue)
Builds a string representation from the specified physical value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true)
Builds a string representation from the specified value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...

Static Public Member Functions

static IList< DAQMeasurement > | buildDAQMeasurements (IEnumerable< A2LMEASUREMENT > measurements, DAQEventType eventType=DAQEventType.None)
Expands the contained measurement arrays to a indexed result. More...
- Static Public Member Functions inherited from A2LCONVERSION_REF
static int | getDecimalCount (string format)
Gets the decimal count from an A2L format string. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount)
Builds a string representation from the specified value. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Properties

double | Accuracy [getset]
Gets or sets the possible variation from exact value in %. More...
ADDR_TYPE | AddrType [getset]
ulong | BitMask = ulong.MaxValue [getset]
Gets or sets the bitmask. More...
DATA_TYPE | DataType [getset]
Gets the data type of the measurement.
bool | Discrete [getset]
Gets or sets the discrete flag. More...
ulong | ErrorMask [getset]
Gets or sets the errormask. More...
INDEX_MODE | Layout [getset]
Gets or sets the layout. More...
int[] | MatrixDim [getset]
Gets the 3-value (x, y, z) integer matrix dimensions.
bool | ReadWrite [getset]
Gets or sets the READ_WRITE flag. More...
int | Resolution = 1 [getset]
Gets or sets the smallest possible change in bits. More...
- Properties inherited from A2LCONVERSION_REF
BYTEORDER_TYPE??? | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
Gets or sets the conversion's name. More...
int | DecimalCount [get]
Gets the decimal count of the corresponding Format value.
string????? | Format [getset]
Gets or sets the format. More...
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
Gets or sets the plausible range of table values, lower limit.
string | MemorySegmentRef [get]
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
IEnumerable< A2LREFBASE > | RefFunctions [get]
Gets the list of functions referring this node.
string? | Unit [getset]
Gets or sets the Unit.
double | UpperLimit [getset]
Gets or sets the plausible range of table values, upper limit.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LCONVERSION_REF
A2LCONVERSION_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Protected Attributes inherited from A2LCONVERSION_REF
BYTEORDER_TYPE | mByteOrder
string | mConversion
string | mFormat = string.Empty
string | mMemorySegmentRef
string | mPhysUnit
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

The ARRAY_SIZE parameter is always interpreted as MATRIX_DIM parameter!

Member Function Documentation

◆ addPresetDAQEvent()

void addPresetDAQEvent | ( | DAQEventType | eventType,
 |  | ushort | evt,
 |  | int | index = -1
 | ) |  |

Adds a new DAQ event reference.

Parameters
eventType | Set XCP or CCP value
evt | The evt channel to add
index | If an index is set it is used to replace an existing DAQ event reference

◆ buildDAQMeasurements()

static IList< DAQMeasurement > buildDAQMeasurements | ( | IEnumerable< A2LMEASUREMENT > | measurements,
 |  | DAQEventType | eventType = DAQEventType.None
 | ) |  |
static

Expands the contained measurement arrays to a indexed result.

Parameters
measurements | List of measurements
eventType | The interface type of to get the preset event channels for
Returns
List of DAQ configurations

◆ getAddressOffset()

uint getAddressOffset | ( | int | x,
 |  | int | y
 | ) |  |

Gets the address offset for a specific value if this is a multi value measurement (MATRIX_DIM defined).

If MATRIX_DIM is not defined, the return value is 0.

Parameters
x | Matrix index in X direction
y | Matrix index in Y direction
Returns
The address offset for the specified matrix indizes

◆ getArraySize()

int getArraySize ( )

Gets the array size of the measurement, the minimum is 1 (single value).

Returns
the array size or 1 if the measurement is a single value

◆ getDescriptionAndAnnotation()

override string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
virtual

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Reimplemented from A2LADDRESS.

◆ getMemorySize()

override int getMemorySize ( )
virtual

Gets the size of used memory in bytes.

Returns

Implements A2LADDRESS.

◆ getPresetDAQEvent()

ushort getPresetDAQEvent ( DAQEventType eventType )

Gets the first defined preset event/raster channel.

Parameters
eventType Request XCP or CCP value
Returns
ushort.MaxValue if not set, else a valid raster/event number

◆ getPresetDAQEvents()

ushort[] getPresetDAQEvents ( DAQEventType eventType )

Gets the defined preset event/raster channels.

Parameters
eventType Request XCP or CCP values
Returns
null if not set, else a valid raster/event number list

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCONVERSION_REFs.

Returns
May be null or empty if not referenced by any node.

Reimplemented from A2LNODE.

◆ toStringValue()

string toStringValue | ( | double | value,
 |  | ValueObjectFormat | format
 | ) |  |

Builds a string representation from the specified value.

Parameters
value | The value to build the string for
format | The value format
Returns
the string representation

Property Documentation

◆ Accuracy

double Accuracy
getset

Gets or sets the possible variation from exact value in %.

This parameter is currently not interpreted by any known MC-System.It can be ignored.

◆ BitMask

ulong BitMask = ulong.MaxValue
getset

Gets or sets the bitmask.

With deviation from the standard value 0xFFFFFFFFFFFFFFFF this parameter can be used to mask out bits.

◆ Discrete

bool Discrete
getset

Gets or sets the discrete flag.

This keyword indicates that the measurement values are discrete values which should not be interpolated – e.g. in graphic display windows or further calculations. This flag can be used e.g. for integer objects describing states. If the keyword is not specified the values are interpreted as continuous values which can be interpolated.

◆ ErrorMask

ulong ErrorMask
getset

Gets or sets the errormask.

With deviation from the standard value 0x0000000000000000 this parameter can be used to mask bits of a MEASUREMENT which indicate that the value is in error.

◆ Layout

INDEX_MODE Layout
getset

Gets or sets the layout.

For multi-dimensional measurement arrays this keyword can be used to specify the layout of the array. If the keyword is missing, multi-dimensional measurement arrays are interpreted row by row (ROW_DIR).

◆ ReadWrite

bool ReadWrite
getset

Gets or sets the READ_WRITE flag.

Keyword to mark this measurement object as 'writeable'.

◆ Resolution

int Resolution = 1
getset

Gets or sets the smallest possible change in bits.

This parameter is currently not interpreted by any known MC-System.It can be ignored.


ASAP2Library interface: Member List

  • ASAP2
  • A2LMEASUREMENT
A2LMEASUREMENT Member List

This is the complete list of members for A2LMEASUREMENT, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCONVERSION_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv) | A2LCONVERSION_REF | protected
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
Accuracy | A2LMEASUREMENT |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
addPresetDAQEvent(DAQEventType eventType, ushort evt, int index=-1) | A2LMEASUREMENT |
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
AddrType (defined in A2LMEASUREMENT) | A2LMEASUREMENT |
BitMask | A2LMEASUREMENT |
buildDAQMeasurements(IEnumerable< A2LMEASUREMENT > measurements, DAQEventType eventType=DAQEventType.None) | A2LMEASUREMENT | static
ByteOrder | A2LCONVERSION_REF |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LCONVERSION_REF |
DataType | A2LMEASUREMENT |
DecimalCount | A2LCONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
Discrete | A2LMEASUREMENT |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
ErrorMask | A2LMEASUREMENT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LCONVERSION_REF |
getAddressOffset(int x, int y) | A2LMEASUREMENT |
getArraySize() | A2LMEASUREMENT |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDecimalCount(string format) | A2LCONVERSION_REF | static
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LMEASUREMENT | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySize() | A2LMEASUREMENT | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getPresetDAQEvent(DAQEventType eventType) | A2LMEASUREMENT |
getPresetDAQEvents(DAQEventType eventType) | A2LMEASUREMENT |
getRefFunctions() | A2LCONVERSION_REF | virtual
getRefNodes() | A2LMEASUREMENT | virtual
IsFormatNotSet | A2LCONVERSION_REF |
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
Layout | A2LMEASUREMENT |
LowerLimit | A2LCONVERSION_REF |
MatrixDim | A2LMEASUREMENT |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mByteOrder (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mConversion (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
MemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mFormat (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mMemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
ModelLink | A2LADDRESS |
mPhysUnit (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadWrite | A2LMEASUREMENT |
RefCompuMethod | A2LCONVERSION_REF |
RefFunctions | A2LCONVERSION_REF |
RefInstance | A2LADDRESS |
Resolution | A2LMEASUREMENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
toStringValue(double value, ValueObjectFormat format) | A2LMEASUREMENT |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount) | A2LCONVERSION_REF | static
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double physValue) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF | static
Type | A2LNODE |
Unit | A2LCONVERSION_REF |
UpperLimit | A2LCONVERSION_REF |


ASAP2Library interface: A2LMEMORY_LAYOUT Class Reference

  • ASAP2
  • A2LMEMORY_LAYOUT
Public Member Functions | Properties | List of all members
A2LMEMORY_LAYOUT Class Reference

see ASAP2 specification More...

Public Member Functions

override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCHARACTERISTICs. More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

uint | Address [getset]
int[] | Offsets = (int[])mDefaultOffsets.Clone() [getset]
PRG_TYPE | PrgType [getset]
uint | Size [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LMemory
uint | Address [get]
Gets the memory address.
bool | IsReadOnly [get]
Returns a value indicating if the memory segment is a readonly segment. More...
int[] | Offsets [getset]
Gets the memory offsets.
uint | Size [get]
Gets the memory size.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCHARACTERISTICs.

Returns
May be null or empty if not referenced by any characateristic.

Reimplemented from A2LNODE.


ASAP2Library interface: Member List

  • ASAP2
  • A2LMEMORY_LAYOUT
A2LMEMORY_LAYOUT Member List

This is the complete list of members for A2LMEMORY_LAYOUT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address (defined in A2LMEMORY_LAYOUT) | A2LMEMORY_LAYOUT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LMEMORY_LAYOUT | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Offsets (defined in A2LMEMORY_LAYOUT) | A2LMEMORY_LAYOUT |
Parent | A2LNODE |
PrgType (defined in A2LMEMORY_LAYOUT) | A2LMEMORY_LAYOUT |
Size (defined in A2LMEMORY_LAYOUT) | A2LMEMORY_LAYOUT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LMEMORY_SEGMENT Class Reference

  • ASAP2
  • A2LMEMORY_SEGMENT
Public Member Functions | Properties | List of all members
A2LMEMORY_SEGMENT Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCHARACTERISTICs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

uint | Address [getset]
string | Description [getset]
MEMORY_ATTRIBUTE | MemoryAttribute [getset]
MEMORY_TYPE | MemoryType [getset]
int[] | Offsets = (int[])mDefaultOffsets.Clone() [getset]
MEMORYPRG_TYPE | PrgType [getset]
uint | Size [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LMemory
uint | Address [get]
Gets the memory address.
bool | IsReadOnly [get]
Returns a value indicating if the memory segment is a readonly segment. More...
int[] | Offsets [getset]
Gets the memory offsets.
uint | Size [get]
Gets the memory size.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCHARACTERISTICs.

Returns
List of referenced characateristics.

Reimplemented from A2LNODE.


ASAP2Library interface: Member List

  • ASAP2
  • A2LMEMORY_SEGMENT
A2LMEMORY_SEGMENT Member List

This is the complete list of members for A2LMEMORY_SEGMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LMEMORY_SEGMENT |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LMEMORY_SEGMENT | virtual
IsInstanced | A2LNODE |
MemoryAttribute (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
MemoryType (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Offsets (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
Parent | A2LNODE |
PrgType (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
Size (defined in A2LMEMORY_SEGMENT) | A2LMEMORY_SEGMENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LMOD_COMMON Class Reference

  • ASAP2
  • A2LMOD_COMMON
Static Public Member Functions | Properties | List of all members
A2LMOD_COMMON Class Reference

see ASAP2 specification More...

Static Public Member Functions

static A2LMOD_COMMON | createDefault (BYTEORDER_TYPE byteOrder)
Creates a default MOD_COMMON node. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Properties

int[] | Alignments = (int[])mDefaultAlignments.Clone() [getset]
The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5, FLOAT16_IEEE=6.
BYTEORDER_TYPE | BYTE_ORDER [getset]
string | Comment [getset]
int | DATA_SIZE [getset]
DEPOSIT_TYPE | DEPOSIT = DEPOSIT_TYPE.ABSOLUTE [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ createDefault()

static A2LMOD_COMMON createDefault ( BYTEORDER_TYPE byteOrder )
static

Creates a default MOD_COMMON node.

If the A2L file doesn't contain a MOD_COMMON node, this method creates a default one.

Parameters
byteOrder The byte order
Returns
A default MOD_COMMON Instance


ASAP2Library interface: Member List

  • ASAP2
  • A2LMOD_COMMON
A2LMOD_COMMON Member List

This is the complete list of members for A2LMOD_COMMON, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignments | A2LMOD_COMMON |
BYTE_ORDER (defined in A2LMOD_COMMON) | A2LMOD_COMMON |
ChangedType | A2LNODE |
Childs | A2LNODE |
Comment (defined in A2LMOD_COMMON) | A2LMOD_COMMON |
createDefault(BYTEORDER_TYPE byteOrder) | A2LMOD_COMMON | static
DATA_SIZE (defined in A2LMOD_COMMON) | A2LMOD_COMMON |
deleteFromModel(A2LNODE node) | A2LNODE | static
DEPOSIT (defined in A2LMOD_COMMON) | A2LMOD_COMMON |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LMOD_PAR Class Reference

  • ASAP2
  • A2LMOD_PAR
Public Member Functions | Properties | List of all members
A2LMOD_PAR Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
uint | mapAddress (uint address, bool useXCP=true, bool revert=false)
Maps the specified address using XCP or CCP specified address mapping tables More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

string | CPU [getset]
string | Customer [getset]
string | CustomerNo [getset]
string | Description [getset]
string | ECU [getset]
uint | ECUCalibrationOffset [getset]
string | EPK [getset]
uint | EPKAddress = uint.MaxValue [getset]
int | NoOfInterfaces = -1 [getset]
string | PhoneNo [getset]
string | Supplier [getset]
Dictionary< string, string > | SystemConstants = new Dictionary<string, string>() [get]
DictionaryProxy< string, string > | SystemConstants_ [getset]
This is just to serialize and deserialize to XML, use the SystemConstants property to access.
string | User [getset]
string | Version [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ mapAddress()

uint mapAddress | ( | uint | address,
 |  | bool | useXCP = true,
 |  | bool | revert = false
 | ) |  |

Maps the specified address using XCP or CCP specified address mapping tables

Parameters
address | The address to translate
useXCP | true to use XCP, false to use CCP mapping tables
revert | true if an address translation should be reverted
Returns
the translated or reverted address


ASAP2Library interface: Member List

  • ASAP2
  • A2LMOD_PAR
A2LMOD_PAR Member List

This is the complete list of members for A2LMOD_PAR, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CPU (defined in A2LMOD_PAR) | A2LMOD_PAR |
Customer (defined in A2LMOD_PAR) | A2LMOD_PAR |
CustomerNo (defined in A2LMOD_PAR) | A2LMOD_PAR |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LMOD_PAR) | A2LMOD_PAR |
ECU (defined in A2LMOD_PAR) | A2LMOD_PAR |
ECUCalibrationOffset (defined in A2LMOD_PAR) | A2LMOD_PAR |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
EPK (defined in A2LMOD_PAR) | A2LMOD_PAR |
EPKAddress (defined in A2LMOD_PAR) | A2LMOD_PAR |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LMOD_PAR |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mapAddress(uint address, bool useXCP=true, bool revert=false) | A2LMOD_PAR |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
NoOfInterfaces (defined in A2LMOD_PAR) | A2LMOD_PAR |
Parent | A2LNODE |
PhoneNo (defined in A2LMOD_PAR) | A2LMOD_PAR |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Supplier (defined in A2LMOD_PAR) | A2LMOD_PAR |
SystemConstants (defined in A2LMOD_PAR) | A2LMOD_PAR |
SystemConstants_ | A2LMOD_PAR |
Tag | A2LNODE |
Type | A2LNODE |
User (defined in A2LMOD_PAR) | A2LMOD_PAR |
Version (defined in A2LMOD_PAR) | A2LMOD_PAR |


ASAP2Library interface: A2LMODULE Class Reference

  • ASAP2
  • A2LMODULE
Public Member Functions | Static Public Member Functions | Properties | List of all members
A2LMODULE Class Reference

see ASAP2 specification More...

Public Member Functions

MemorySegmentList | createInitialMemorySegments (bool excludeRAM)
Creates initial memory segments from the A2LMEMORY_LAYOUT or A2LMEMORY_SEGMENT nodes. More...
A2LCCP_TP_BLOB getCCPInterface ()
Gets the ASAP1B CCP interface. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
MemoryRangeList getMemoryRanges ()
Gets all memory ranges used from contained characteristics. More...
IList< A2LXCP_MEDIA > | getXCPInterfaces ()
Gets the defined XCP (UDP/TCP/CAN/USB/...) media(s). More...
bool | getXCPSettings (ref List< A2LXCP_MEDIA > xcpMediaList, out A2LXCP_PROTOCOL_LAYER xcpProtocolLayer, out A2LXCP_CHECKSUM xcpChecksum, out A2LXCP_PAG xcpPAG, out A2LXCP_DAQ xcpDAQ, out A2LXCP_PGM xcpPGM)
Gets the XCP (UDP/TCP/CAN) related settings from the XCP IF_DATA section. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Static Public Member Functions

static MemoryRangeList | getMemoryRanges (List< A2LRECORD_LAYOUT_REF > characteristics)
Gets all memory ranges used by the specified characteristics. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Properties

string | Description [getset]
A2LMOD_COMMON | RefModCommon [get]
Access to contained ModCommon instance
A2LMOD_PAR | RefModPar [get]
Access to contained ModPar instance
A2LVARIANT_CODING | RefVariantCoding [get]
Access to contained Cariant Coing instance
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ createInitialMemorySegments()

MemorySegmentList createInitialMemorySegments ( bool excludeRAM )

Creates initial memory segments from the A2LMEMORY_LAYOUT or A2LMEMORY_SEGMENT nodes.

  1. If no memory segments exist, the method tries to create memory segments from a potential CCP page definition.
  2. Adjacent segments are merged if their MEMORYPRG_TYPE matches
  3. If there aren't any XCP, CCP nor CCP defined pages, the method tries to create default segments from all characteristics.
Parameters
excludeRAM true, if RAM segments should be excluded. Note, that A2LMEMORY_LAYOUTs are always interpreted as Non-RAM segments.
Returns
Initial memory segments or null if no segments are created

◆ getCCPInterface()

A2LCCP_TP_BLOB getCCPInterface ( )

Gets the ASAP1B CCP interface.

The returned A2LCCP_TP_BLOB node contains all CCP settings as childs.

Returns
CCP interface instance (may be null)

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getMemoryRanges() [1/2]

MemoryRangeList getMemoryRanges ( )

Gets all memory ranges used from contained characteristics.

Returns
a list of memory ranges

◆ getMemoryRanges() [2/2]

static MemoryRangeList getMemoryRanges ( List< A2LRECORD_LAYOUT_REF > characteristics )
static

Gets all memory ranges used by the specified characteristics.

Parameters
characteristics
Returns
a list of memory ranges

◆ getXCPInterfaces()

IList< A2LXCP_MEDIA > getXCPInterfaces ( )

Gets the defined XCP (UDP/TCP/CAN/USB/...) media(s).

Use the A2LXCP_MEDIA.getSettings method to get additional media settings.

Returns
The list of defined XCP media (may be empty)

◆ getXCPSettings()

bool getXCPSettings | ( | ref List< A2LXCP_MEDIA > | xcpMediaList,
 |  | out A2LXCP_PROTOCOL_LAYER | xcpProtocolLayer,
 |  | out A2LXCP_CHECKSUM | xcpChecksum,
 |  | out A2LXCP_PAG | xcpPAG,
 |  | out A2LXCP_DAQ | xcpDAQ,
 |  | out A2LXCP_PGM | xcpPGM
 | ) |  |

Gets the XCP (UDP/TCP/CAN) related settings from the XCP IF_DATA section.

Parameters
xcpMediaList | only valid if return value is true
xcpProtocolLayer | only valid if return value is true
xcpChecksum | may be null and may only valid if return value is true
xcpPAG | The XCP PAG section (may be null and may only valid if return value is true)
xcpDAQ | The XCP DAQ section (may be null and may only valid if return value is true)
xcpPGM | The XCP PGM section (may be null and may only valid if return value is true)
Returns
false is no XCP (UDP or TCP or CAN) IF_DATA section is found


ASAP2Library interface: Member List

  • ASAP2
  • A2LMODULE
A2LMODULE Member List

This is the complete list of members for A2LMODULE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
createInitialMemorySegments(bool excludeRAM) | A2LMODULE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LMODULE) | A2LMODULE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCCPInterface() | A2LMODULE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LMODULE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemoryRanges() | A2LMODULE |
getMemoryRanges(List< A2LRECORD_LAYOUT_REF > characteristics) | A2LMODULE | static
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getXCPInterfaces() | A2LMODULE |
getXCPSettings(ref List< A2LXCP_MEDIA > xcpMediaList, out A2LXCP_PROTOCOL_LAYER xcpProtocolLayer, out A2LXCP_CHECKSUM xcpChecksum, out A2LXCP_PAG xcpPAG, out A2LXCP_DAQ xcpDAQ, out A2LXCP_PGM xcpPGM) | A2LMODULE |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefModCommon | A2LMODULE |
RefModPar | A2LMODULE |
RefVariantCoding | A2LMODULE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LNAMEDNODE Class Reference

  • ASAP2
  • A2LNAMEDNODE
Public Member Functions | Protected Member Functions | Properties | List of all members
A2LNAMEDNODE Class Reference

Base class for all A2L entities with specific names. More...

Public Member Functions

override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L entities with specific names.

Constructor & Destructor Documentation

◆ A2LNAMEDNODE() [1/2]

A2LNAMEDNODE ( int startLine )
protected

Initialises a new instance of A2LNAMEDNODE with the specified parameters.

Parameters
startLine The starting line

◆ A2LNAMEDNODE() [2/2]

A2LNAMEDNODE | ( | int | startLine,
 |  | string | mA2MLType
 | ) |  |
protected

Initialises a new instance of A2LNAMEDNODE with the specified parameters.

Parameters
startLine | The starting line
mA2MLType | The A2ML type

Property Documentation

◆ Name

override string Name
getset

Gets the name of the node.

Use the setter with care! Changing the name requires to adjust all references to this instance.


ASAP2Library interface: Member List

  • ASAP2
  • A2LNAMEDNODE
A2LNAMEDNODE Member List

This is the complete list of members for A2LNAMEDNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LNODE Class Reference

  • ASAP2
  • A2LNODE
Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Static Protected Member Functions | Static Protected Attributes | Properties | List of all members
A2LNODE Class Referenceabstract

Base class for any A2L entity. More...

Public Member Functions

void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Static Public Member Functions

static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...

Static Public Attributes

const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion

Protected Member Functions

A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Static Protected Member Functions

static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...

Static Protected Attributes

const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Properties

virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Detailed Description

Base class for any A2L entity.

Any A2LNODE based type and therfore ASAP2 entity is defined as an uppercase'd class starting with A2L. This is done to reflect the direct reference to the ASAP2 specification.

Any A2LNode derived Type needs to implement a parameterless default constructor to support the XML export.

Remarks to ASAP2 optional parameters and therefore to properties of created A2LNode instances:

Many properties of an A2LNode instance are optional (please refer to the ASAP2 specification). As an A2LNode instance contains any defined parameter as a property the implementation behaves as follows:

  • for an optional value type property (e.g a property of type int) if the property is optional, a proper default value according the ASAP2 specification is set
  • for an optional reference type property (e.g a property of type string) The property instance is not created by the parser, so you have to always check against the null value before accessing them)

Constructor & Destructor Documentation

◆ A2LNODE()

A2LNODE ( int startLine )
protected

Initialises a new instance of A2LNODE with the specified parameters.

Parameters
startLine The starting line

Member Function Documentation

◆ addChild()

void addChild | ( | A2LNODE | childNode,
 |  | bool | setState = true
 | ) |  |

Adds a child node to the node.

Parameters
childNode | The node to add
setState | true to set the added state

◆ addMaxText()

static void addMaxText | ( | StringBuilder | sb,
 |  | string | text
 | ) |  |
staticprotected

Adds a mximum of 1024 characters to the specified string builder.

appends ... for oversized text.

Parameters
sb | The string builder to add the text to
text | The text to add

◆ deleteFromModel()

static bool deleteFromModel ( A2LNODE node )
static

Deletes the specified node from the containing model.

Parameters
node The (named) node to delete
Returns
false if node is not found nor deleted

◆ enumChildNodes< T >()

IEnumerable< T > enumChildNodes< T > ( )

Enumerates over all child nodes corresponding to the specified type from the calling instance.

  • The search is recursive over all child nodes

Example code:

// enumerating measurements over the whole project
using (A2LParser a2lParser = new A2LParser())
{
a2lParser.parse("file.a2l");
foreach(A2LMEASUREMENT measurement in parser.Project.enumChildNodes<A2LMEASUREMENT>())
Console.WriteLine("Measurement: {0}", measurement.Name);
}
Template Parameters
T The node type to search
Returns
An enumerable instance
Type Constraints
T : A2LNODE

◆ findNode()

A2LNODE findNode ( int line )

Gets the A2LNode covering the specified content line.

Parameters
line Content line number
node
Returns
The node instance found or null

◆ findNode< T >() [1/2]

T findNode< T > ( string name )

Searches for the specified node name starting from the calling instance.

  • The search is case sensitive.
  • The calling instance is included in the search.
  • The search is recursive over all child nodes
Template Parameters
T The A2LNODE type to search to
Parameters
name The node name to search
Returns
The instance found or null
Type Constraints
T : A2LNODE

◆ findNode< T >() [2/2]

T findNode< T > | ( | string | name,
 |  | StringComparison | comparison
 | ) |  |

Searches for the specified node name starting from the calling instance.

  • The calling instance is included in the search.
  • The search is recursive over all child nodes
Template Parameters
T The A2LNODE type to search to
Parameters
name | The node name to search
comparison | the comparison type to use
Returns
The instance found or null
Type Constraints
T : A2LNODE

◆ getCompuMethod()

static void getCompuMethod | ( | IDictionary< string, A2LCOMPU_METHOD > | compuMethodDict,
 |  | string | conversionName,
 |  | out A2LCOMPU_METHOD | compuMethod
 | ) |  |
staticprotected

Gets available compu methods from the compu method dictionary.

Parameters
compuMethodDict
conversionName | The name of the compu method
compuMethod | [out] The copu method found

◆ getContext()

string getContext ( char delimiter )

Gets the context of the node instance up to the root node.

Parameters
delimiter The delimiter to use between the nodes
Returns
a context string

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | string | description,
 |  | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |
protected

Creates a description from the specified description and a potential existing annotation.

Parameters
description
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The combined description/annotation string (may be empty)

◆ getNode< T >()

T getNode< T > ( bool recursive )

Gets the first node of the specified type found in the underlying childs.

Example code:

// get the first a2l measurement from the first a2l module
using (A2LParser a2lParser = new A2LParser())
{
a2lParser.parse("file.a2l");
A2LMEASUREMENT a2lMeasurement = a2lParser.Project.getNode<A2LMODULE>(false).getNode<A2LMEASUREMENT>(false);
Console.WriteLine("First measurement: {0}", a2lMeasurement.Name);
}
Template Parameters
T Type of element to be returned
Parameters
recursive True if the child nodes should be searched recursively
Returns
a node instance of the specified type or null if no one exists
Type Constraints
T : A2LNODE

◆ getNodeDepth()

int getNodeDepth ( )

Gets the depth of the node within the ASAP2 hierarchy.

Examples:

  • An A2LPROJECT returns 0
  • An A2LMEASUREMENT returns 2
Returns
the depth of the node

◆ getNodeList< T >()

List< T > getNodeList< T > ( bool recursive = false )

Returns a list of child nodes of the specified type.

Example code:

// get all CompuMethods from the first a2l module
using (A2LParser a2lParser = new A2LParser())
{
a2lParser.parse("file.a2l");
List<A2LCOMPU_METHOD> a2lCompuMethods = a2lParser.Project.getNode<A2LMODULE>(false).getNodeList<A2LCOMPU_METHOD>();
foreach ( A2LCOMPU_METHOD method in a2lCompuMethods)
Console.WriteLine("CompuMethod: {0}", method.Name);
}
Parameters
recursive True if the child nodes should be searched recursively
Template Parameters
T Type of elements to be returned.
Returns
List of found elements (may be empty).
Type Constraints
T : A2LNODE

◆ getParent< T >()

T getParent< T > ( )

Gets the corresponding parent with the specified type from the current instance.

  • Steps up the hierarchy until the corresponding parentType is found, else returns null.

Example code:

using (A2LParser a2lParser = new A2LParser())
{
a2lParser.parse("file.a2l");
A2LMEASUREMENT a2lMeasurement = a2lParser.Project.getNode<A2LMODULE>(false).getNode<A2LMEASUREMENT>(false);
Console.WriteLine("Parent module: {0}", a2lMeasurement.getParent<A2LMODULE>().Name);
}
Template Parameters
T The node type to search
Returns
a found parent or null
Type Constraints
T : A2LNODE

◆ getRefFunctions()

virtual IEnumerable< A2LREFBASE > getRefFunctions ( )
virtual

Gets the referencing functions.

Ususally only valid for A2LMEASUREMENT and A2LCHARACTERISTIC.

Returns
May be null or empty if not referenced by any node.

Reimplemented in A2LRECORD_LAYOUT, and A2LCONVERSION_REF.

◆ getRefNodes()

virtual IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing nodes.

Returns
May be null or empty if not referenced by any node.

Reimplemented in A2LMEMORY_SEGMENT, A2LMEMORY_LAYOUT, A2LAXIS_PTS, A2LRECORD_LAYOUT, A2LMEASUREMENT, A2LCOMPU_METHOD, A2LTYPEDEF, A2LINSTANCE, A2LTRANSFORMER, and A2LCOMPU_TAB_BASE.

◆ sortByAddress()

static int sortByAddress | ( | A2LNODE | x,
 |  | A2LNODE | y
 | ) |  |
static

Sorts the nodes.

  • Sort according the node's address
Parameters
x | first node
y | second node
Returns
See CompareTo return value

◆ sortByAddressAndName()

static int sortByAddressAndName | ( | A2LNODE | x,
 |  | A2LNODE | y
 | ) |  |
static

Sorts the nodes for output.

  • Sort according the node's address
  • Sort according the node's name
Parameters
x | first node
y | second node
Returns
See CompareTo return value

◆ sortByName()

static int sortByName | ( | A2LNODE | x,
 |  | A2LNODE | y
 | ) |  |
static

Sorts the nodes for output.

  • Sort according the node's name
Parameters
x | first node
y | second node
Returns
See CompareTo return value

◆ sortByTypeAndName()

static int sortByTypeAndName | ( | A2LNODE | x,
 |  | A2LNODE | y
 | ) |  |
static

Sorts the nodes for output.

  • Sort according the node's type
  • Sort A2LCHARACTERISTIC according it's type.
  • Sort according the node's name
Parameters
x | first node
y | second node
Returns
See CompareTo return value

Property Documentation

◆ Parent

A2LNODE Parent
getprotected set

The direct parent of the node instance.

  • For the root node (A2LPROJECT) this member is always null.
  • For any other node instances, this value always leads to the direct parent instance.
  • XMLExport: Never export this instance!

◆ StartLine

int StartLine = -1
get

Gets the starting line of the Node within the source file.

If the startline is not valid (no text content reference), the value is int.MaxValue.

◆ Tag

object Tag
getset

Gets or sets the Tag property.

  • This property may be used to bind any user reference to this instance.
  • XMLExport: Never export this (maybe an unknown type) instance!


ASAP2Library interface: Member List

  • ASAP2
  • A2LNODE
A2LNODE Member List

This is the complete list of members for A2LNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LOUT_MEASUREMENT Class Reference

  • ASAP2
  • A2LOUT_MEASUREMENT
List of all members
A2LOUT_MEASUREMENT Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LOUT_MEASUREMENT
A2LOUT_MEASUREMENT Member List

This is the complete list of members for A2LOUT_MEASUREMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LOVERWRITE Class Reference

  • ASAP2
  • A2LOVERWRITE
Properties | List of all members
A2LOVERWRITE Class Reference

see ASAP2 specification More...

Properties

ushort | AxisNo [getset]
string | Conversion [getset]
string | Format [getset]
string | InputQuantity [getset]
double | LowerLimit = double.NaN [getset]
double | LowerLimitEx [getset]
MONOTONY_TYPE | Monotony [getset]
see A2LAXIS_PTS.Monotony.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit = double.NaN [getset]
double | UpperLimitEx [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LOVERWRITE
A2LOVERWRITE Member List

This is the complete list of members for A2LOVERWRITE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AxisNo (defined in A2LOVERWRITE) | A2LOVERWRITE |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion (defined in A2LOVERWRITE) | A2LOVERWRITE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format (defined in A2LOVERWRITE) | A2LOVERWRITE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
InputQuantity (defined in A2LOVERWRITE) | A2LOVERWRITE |
IsInstanced | A2LNODE |
LowerLimit (defined in A2LOVERWRITE) | A2LOVERWRITE |
LowerLimitEx (defined in A2LOVERWRITE) | A2LOVERWRITE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Monotony | A2LOVERWRITE |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PhysUnit | A2LOVERWRITE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit (defined in A2LOVERWRITE) | A2LOVERWRITE |
UpperLimitEx (defined in A2LOVERWRITE) | A2LOVERWRITE |


ASAP2Library interface: A2LParser Class Reference

  • ASAP2
  • A2LParser
Public Member Functions | Properties | Events | List of all members
A2LParser Class Reference

The ASAP2 parser. More...

Public Member Functions

A2LParser ()
Creates a new instance of the A2LParser.
void | Dispose ()
Deletes the created temporary file.
void | onParserMessage (ParserEventArgs e)
Send parser messages to registered listeners. More...
bool | parse (Stream stream, bool deleteEmptyNodes=false, Encoding encoding=null, bool createTempFile=false)
Parses the specified stream and builds the A2L object model. More...
bool | parse (string filename, bool deleteEmptyNodes=false, Encoding encoding=null, bool createTempFile=false)
Parses the specified file and builds the A2L object model. More...
void | readFromXML (Stream stream, string filename=null)
Recreates the object model in an A2LParser instance from a writeToXML created XML stream. More...
void | readFromXML (string filename)
Recreates the object model in an A2LParser instance from a writeToXML created XML file. More...
bool | write (string filename, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false, bool useOriginalVersion=true)
Write the ASAP2 model to the specified file. More...
bool | writeToXML (Stream stream, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false)
Write the ASAP2 object model in XML format to the specified stream. More...
bool | writeToXML (string filename, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false)
Write the ASAP2 object model in XML format to the specified file. More...

Properties

int | CountErrors [get]
Gets a value indicating the count of errors occured while the file was parsed.
int | CountWarnings [get]
Gets a value indicating the count of warnings occured while the file was parsed.
string | FileName [get]
Gets the fully qualified path to the file parsed from (may be null).
List< string > | IncludedFiles [get]
List of (successfully) included files. More...
bool | KeepDuplicateNodes [getset]
Set to true if duplicate defined nodes should be kept in the tree
bool | LogUnsupportedNodes = true [getset]
Set this to false if Unsupported Node events should be prevented
int | MajorVersion [get]
Gets the major version of the loaded ASAP2 document. More...
int | MinorVersion [get]
Gets the minor version of the loaded ASAP2 document. More...
A2LPROJECT | Project [getset]
Gets or sets the Project node (this is the root node of any ASAP2 file). More...
bool | StrictParsing = true [getset]
Set to false to disable the standard Strict parsing (case insensitive names)
string | TmpFileName [get]
A potential temporary filename if the A2L contains Include commands. More...
static string | Version [get]
Gets the parser version string in the format Release.Revision.Build.

Events

EventHandler< ParserEventArgs > | ParserMessage
Register here for parser messages.
EventHandler< A2LParserProgressEventArgs > | ProgressChanged
Register here for parser progress messages.

Detailed Description

The ASAP2 parser.

Depending on the Settings.Default.ParseStrict value, the parser acts strictly against the ASAP2 specification. In perticular this means

  • Case sensitive identifier referencing
  • No regognition of MEMORY_SEGMENT without begin..end tags
  • No regognition of FORMULA, FORMULA_INV without begin..end tags

Getting started with parsing (code example):

using jnsoft.ASAP2;
void parse(string a2lFilename)
{
// Instantiate an new parser instance
using ( var a2lParser = new A2LParser())
{
// register delegate for tracking parser messages
a2lParser.ParserMessage += new EventHandler<ParserEventArgs>(onParserMessage);
// register delegate for tracking parser progress
mA2lParser.ProgressChanged += new EventHandler<A2LParserProgressEventArgs>(onProgressChanged);
// starting the parser process (synchronous call)
a2lParser.parse(a2lFilename);
if (null == mA2lParser.Project)
// failed completely to parse or not an a2l file.
return;
// Complete A2L object model now in mA2LParser.Project
// do something with it
}
}
void onParserMessage(object sender, EventArgs e)
{
var message = e as ParserEventArgs;
// do domething with the parser message
switch (message.Type)
{
case MessageType.Error:
break;
case MessageType.Warning:
break;
case MessageType.Info:
break;
}
}
void onProgressChanged(object sender, EventArgs e )
{
var message = e as A2LParserProgressEventArgs;
Console.WriteLine("parsed " + message.LinesProcessed + " from " + message.LinesMax);
}
jnsoft.ASAP2.A2LParser.onParserMessage
void onParserMessage(ParserEventArgs e)
Send parser messages to registered listeners.
Definition: ASAP2Parser.cs:1670
jnsoft.ASAP2.A2LParser.parse
bool parse(string filename, bool deleteEmptyNodes=false, Encoding encoding=null, bool createTempFile=false)
Parses the specified file and builds the A2L object model.
Definition: ASAP2Parser.cs:350
jnsoft.ASAP2
Contains the ASAP2 parser base and the ASAP2 object model implementation...
Definition: ASAP2.cs:53
jnsoft.Helpers.MessageType
MessageType
Possible types of parser messages.
Definition: Helpers.cs:1302
jnsoft
Definition: ASAP2.cs:53

Getting started with writing an a2lFile (code example):

using jnsoft.ASAP2;
void loadAndSaveFile(string a2lFilename)
{
// Instantiate an new parser instance
using(var a2lParser = new A2LParser())
{
// starting the parser process (synchronous call)
a2lParser.parse(a2lFilename);
// Rewriting the ASAP2 file
a2lParser.write(Path.ChangeExtension(a2lFilename, ".out")+".a2l", WriterSortMode.ByTypeAndName);
}
}

Member Function Documentation

◆ onParserMessage()

void onParserMessage ( ParserEventArgs e )

Send parser messages to registered listeners.

Parameters
e The parser event arguments

◆ parse() [1/2]

bool parse | ( | Stream | stream,
 |  | bool | deleteEmptyNodes = false,
 |  | Encoding | encoding = null,
 |  | bool | createTempFile = false
 | ) |  |

Parses the specified stream and builds the A2L object model.

  • You may request the properties CountErrors and CountWarnings after parsing to check if parsing was completely successful
Parameters
stream | The a2l content stream to read from
deleteEmptyNodes | Delete nodes which does not contain any information
encoding | Potential file content encoding (maybe null, Encoding.Default is used if not set)
createTempFile | Indicates if the parser should create a temporary file (only useful for a content reader)
Returns
true if successful
Exceptions
IOException | If specified file is not acccessible
NonCompliantException | Thrown if file is not a2l compliant

◆ parse() [2/2]

bool parse | ( | string | filename,
 |  | bool | deleteEmptyNodes = false,
 |  | Encoding | encoding = null,
 |  | bool | createTempFile = false
 | ) |  |

Parses the specified file and builds the A2L object model.

  • You may request the properties CountErrors and CountWarnings after parsing to check if parsing was completely successful
Parameters
filename | The fully qualified path to the a2l source
deleteEmptyNodes | Delete nodes which does not contain any information
encoding | Potential file content encoding (maybe null, Encoding.Default is used if not set)
createTempFile | Indicates if the parser should create a temporary file (only useful for a content reader)
Returns
true if successful
Exceptions
IOException | If specified file is not acccessible
NonCompliantException | Thrown if file is not a2l compliant

◆ readFromXML() [1/2]

void readFromXML | ( | Stream | stream,
 |  | string | filename = null
 | ) |  |

Recreates the object model in an A2LParser instance from a writeToXML created XML stream.

Parameters
stream | the stream to read from
filename | An optional source file name
Exceptions
Exception Project couldn't be loaded

◆ readFromXML() [2/2]

void readFromXML ( string filename )

Recreates the object model in an A2LParser instance from a writeToXML created XML file.

Parameters
filename the fully qualified path to the XML file to read
Exceptions
Exception Project couldn't be loaded

◆ write()

bool write | ( | string | filename,
 |  | WriterSortMode | sortMode = WriterSortMode.None,
 |  | bool | optimize = false,
 |  | bool | optimizeCaseInsensitive = false,
 |  | bool | useOriginalVersion = true
 | ) |  |

Write the ASAP2 model to the specified file.

  • All unsupported A2L nodes (e.g the A2ML node and unsupported IF_DATA childs) are written in their original form
  • Any managed A2L node gets completely rewritten
  • Comments get lost (this is by design, they are not parsed from the source)
Parameters
filename | the fully qualified path to the ASAP2 file to create
sortMode | The sort mode to apply before writing
optimize | true if the output should be optimized (remove redundant objects)
optimizeCaseInsensitive | true if the output optimizer should use case insensitivity
useOriginalVersion | true, if the ASAP2 version from the orginal document should be written
Returns
true if sucessful

◆ writeToXML() [1/2]

bool writeToXML | ( | Stream | stream,
 |  | WriterSortMode | sortMode = WriterSortMode.None,
 |  | bool | optimize = false,
 |  | bool | optimizeCaseInsensitive = false
 | ) |  |

Write the ASAP2 object model in XML format to the specified stream.

  • All unsupported A2L nodes (e.g the A2ML node and unsupported IF_DATA childs) are written as empty nodes.
  • Comments get lost (this is by design, they are not parsed from the source)
Parameters
stream | the fully qualified path to the XML file to create
sortMode | The sort mode to apply before writing
optimize | true if the output should be optimized (remove redundant objects)
optimizeCaseInsensitive | true if the output optimizer should use case insensitivity
Returns
true if sucessful

◆ writeToXML() [2/2]

bool writeToXML | ( | string | filename,
 |  | WriterSortMode | sortMode = WriterSortMode.None,
 |  | bool | optimize = false,
 |  | bool | optimizeCaseInsensitive = false
 | ) |  |

Write the ASAP2 object model in XML format to the specified file.

  • All unsupported A2L nodes (e.g the A2ML node and unsupported IF_DATA childs) are written as empty nodes.
  • Comments get lost (this is by design, they are not parsed from the source)
Parameters
filename | the fully qualified path to the XML file to create
sortMode | The sort mode to apply before writing
optimize | true if the output should be optimized (remove redundant objects)
optimizeCaseInsensitive | true if the output optimizer should use case insensitivity
Returns
true if sucessful

Property Documentation

◆ IncludedFiles

List<string> IncludedFiles
get

List of (successfully) included files.

This is a result of contained 'include' commands in the A2L content.

◆ MajorVersion

int MajorVersion
get

Gets the major version of the loaded ASAP2 document.

Returns -1 if not valid.

◆ MinorVersion

int MinorVersion
get

Gets the minor version of the loaded ASAP2 document.

Returns -1 if not valid.

◆ Project

A2LPROJECT Project
getset

Gets or sets the Project node (this is the root node of any ASAP2 file).

  • The root node and the main entrance into the ASAP2 model. Therefore the Parent of this instance is always null.
  • If this node is null, parsing was not started or failed.
  • The setter is usually used to be able to create an a2L file from scratch

◆ TmpFileName

string TmpFileName
get

A potential temporary filename if the A2L contains Include commands.

This file is created while parsing the source A2L file and contains merged file from contained /include commands, too.


ASAP2Library interface: Member List

  • ASAP2
  • A2LParser
A2LParser Member List

This is the complete list of members for A2LParser, including all inherited members.

A2LParser() | A2LParser |
CountErrors | A2LParser |
CountWarnings | A2LParser |
Dispose() | A2LParser |
FileName | A2LParser |
IncludedFiles | A2LParser |
KeepDuplicateNodes | A2LParser |
LogUnsupportedNodes | A2LParser |
MajorVersion | A2LParser |
MinorVersion | A2LParser |
onParserMessage(ParserEventArgs e) | A2LParser |
parse(string filename, bool deleteEmptyNodes=false, Encoding encoding=null, bool createTempFile=false) | A2LParser |
parse(Stream stream, bool deleteEmptyNodes=false, Encoding encoding=null, bool createTempFile=false) | A2LParser |
ParserMessage | A2LParser |
ProgressChanged | A2LParser |
Project | A2LParser |
readFromXML(Stream stream, string filename=null) | A2LParser |
readFromXML(string filename) | A2LParser |
StrictParsing | A2LParser |
TmpFileName | A2LParser |
Version | A2LParser | static
write(string filename, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false, bool useOriginalVersion=true) | A2LParser |
writeToXML(Stream stream, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false) | A2LParser |
writeToXML(string filename, WriterSortMode sortMode=WriterSortMode.None, bool optimize=false, bool optimizeCaseInsensitive=false) | A2LParser |


ASAP2Library interface: A2LParserProgressEventArgs Class Reference

  • ASAP2
  • A2LParserProgressEventArgs
Public Attributes | List of all members
A2LParserProgressEventArgs Class Reference

Progress EventArgument generated while parsing a file. More...

Public Attributes

readonly int | LinesMax
Gets line count to process
readonly int | LinesProcessed
Gets the currently processed lines

Detailed Description

Progress EventArgument generated while parsing a file.


ASAP2Library interface: Member List

  • ASAP2
  • A2LParserProgressEventArgs
A2LParserProgressEventArgs Member List

This is the complete list of members for A2LParserProgressEventArgs, including all inherited members.

LinesMax | A2LParserProgressEventArgs
LinesProcessed | A2LParserProgressEventArgs


ASAP2Library interface: A2LPROJECT Class Reference

  • ASAP2
  • A2LPROJECT
Public Member Functions | Public Attributes | Properties | Events | List of all members
A2LPROJECT Class Reference

The one and only root node of an A2L source file. More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
HashSet< string > | getSymbols ()
Gets all symbols defined. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Public Attributes

IDictionary< A2LRECORD_LAYOUT_REF, A2LFUNCTION > DefFunctionDict
Maps a characteristic to it's defining function. More...

Properties

IDictionary< string, A2LBLOB > | BlobDict [getset]
Gets the A2LBLOB dictionary. More...
IDictionary< string, A2LRECORD_LAYOUT_REF > | CharDict [getset]
Gets the A2LCHARACTERISTIC dictionary. More...
IDictionary< string, A2LCOMPU_METHOD > | CompDict [getset]
Gets the A2LCOMPU_METHOD dictionary. More...
IDictionary< string, A2LCOMPU_TAB > | CompTabDict [getset]
Gets the A2LCOMPU_TAB dictionary. More...
IDictionary< string, A2LCOMPU_VTAB > | CompVTabDict [getset]
Gets the A2LCOMPU_VTAB dictionary. More...
IDictionary< string, A2LCOMPU_VTAB_RANGE > | CompVTabRangeDict [getset]
Gets the A2LCOMPU_VTABRANGE dictionary. More...
string | Description [getset]
A2LFormulaDict | FormulaDict [getset]
Gets the A2LFormula dictionary. More...
IDictionary< string, A2LREFBASE > | FuncDict [getset]
Gets the A2LFUNCTION dictionary. More...
IDictionary< string, A2LREFBASE > | GroupDict [getset]
Gets the A2LGROUP dictionary. More...
IDictionary< string, A2LINSTANCE > | InstanceDict [getset]
Gets the A2LINSTANCE dictionary. More...
IDictionary< string, A2LMEASUREMENT > | MeasDict [getset]
Gets the A2LMEASUREMENT dictionary. More...
IDictionary< string, A2LRECORD_LAYOUT > | RecLayDict [getset]
Gets the A2LRECORD_LAYOUT dictionary. More...
IDictionary< string, A2LTRANSFORMER > | TransformerDict [getset]
Gets the A2LTRANSFORMER dictionary. More...
IDictionary< string, A2LTYPEDEF > | TypeDefDict [getset]
Gets the A2LTYPEDEF dictionary. More...
IDictionary< string, A2LUNIT > | UnitDict [getset]
Gets the A2LUNIT dictionary. More...
IDictionary< string, A2LVIRTUAL > | VirtualDict [getset]
Gets the A2LVIRTUAL dictionary. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Events

EventHandler< AdditiveDescriptionEventArgs > | GetAdditiveDescription
EventHandler< ModelChangedEventArgs > | ModelChanged
Called, when nodes are added, removed or changed.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

The one and only root node of an A2L source file.

At least this node is required.

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getSymbols()

HashSet< string > getSymbols ( )

Gets all symbols defined.

  • Symbols are A2LObject's containing an ECU address (A2LADDRESS based classes, ususally measurements and characteristics).
  • These objects may define a symbol name by it's SYMBOL_LINK property.
  • If no SYMBOL_LINK property is defined, the A2L object's name is used.
Returns
Dictionary of symbols

Member Data Documentation

◆ DefFunctionDict

IDictionary<A2LRECORD_LAYOUT_REF, A2LFUNCTION> DefFunctionDict

Maps a characteristic to it's defining function.

Used mainly in exporting characteristics to DCM, PAR

Property Documentation

◆ BlobDict

IDictionary<string, A2LBLOB> BlobDict
getset

Gets the A2LBLOB dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a blob instance by name
var blob = a2lParser.Project.BlobDict["Blob1"];
}

◆ CharDict

IDictionary<string, A2LRECORD_LAYOUT_REF> CharDict
getset

Gets the A2LCHARACTERISTIC dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific characteristic by name
var characteristic1 = (A2LCHARACTERISTIC)a2lParser.Project.CharDict["characteristic1"];
}

◆ CompDict

IDictionary<string, A2LCOMPU_METHOD> CompDict
getset

Gets the A2LCOMPU_METHOD dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific compu method by name
var compuMethod1 = a2lParser.Project.CompDict["CompuMethod1"];
}

◆ CompTabDict

IDictionary<string, A2LCOMPU_TAB> CompTabDict
getset

Gets the A2LCOMPU_TAB dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific compu tab by name
var compuTab1 = a2lParser.Project.CompTabDict["compuTab1"];
}

◆ CompVTabDict

IDictionary<string, A2LCOMPU_VTAB> CompVTabDict
getset

Gets the A2LCOMPU_VTAB dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific compu vtab by name
var compuVTab1 = a2lParser.Project.CompVTabDict["compuVTab1"];
}

◆ CompVTabRangeDict

IDictionary<string, A2LCOMPU_VTAB_RANGE> CompVTabRangeDict
getset

Gets the A2LCOMPU_VTABRANGE dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific compu vtab range by name
var compuVTabRange1 = a2lParser.Project.CompVTabRangeDict["compuVTabRange1"];
}

◆ FormulaDict

A2LFormulaDict FormulaDict
getset

Gets the A2LFormula dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Compute a SYSTEM_CONSTANT or a Formula
double result = a2lParser.Project.FormulaDict["Constant 1"].toPhysical(0);
}

◆ FuncDict

IDictionary<string, A2LREFBASE> FuncDict
getset

Gets the A2LFUNCTION dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific function by name
var function1 = a2lParser.Project.FuncDict["function1"];
}

◆ GroupDict

IDictionary<string, A2LREFBASE> GroupDict
getset

Gets the A2LGROUP dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific group by name
var group1 = a2lParser.Project.GroupDict["Group1"];
}

◆ InstanceDict

IDictionary<string, A2LINSTANCE> InstanceDict
getset

Gets the A2LINSTANCE dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a typedef instance by name
var instance1 = a2lParser.Project.InstanceDict["Instance1"];
}

◆ MeasDict

IDictionary<string, A2LMEASUREMENT> MeasDict
getset

Gets the A2LMEASUREMENT dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific measurement by name
var gear = a2lParser.Project.MeasDict["gear"];
}

◆ RecLayDict

IDictionary<string, A2LRECORD_LAYOUT> RecLayDict
getset

Gets the A2LRECORD_LAYOUT dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific record layout by name
var recordLayout1 = a2lParser.Project.RecLayDict["recordLayout1"];
}

◆ TransformerDict

IDictionary<string, A2LTRANSFORMER> TransformerDict
getset

Gets the A2LTRANSFORMER dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a transformer instance by name
var transformer1 = a2lParser.Project.TransformerDict["Transformer1"];
}

◆ TypeDefDict

IDictionary<string, A2LTYPEDEF> TypeDefDict
getset

Gets the A2LTYPEDEF dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a typedef instance by name
var typedef1 = a2lParser.Project.TypeDefDict["TypeDef1"];
}

◆ UnitDict

IDictionary<string, A2LUNIT> UnitDict
getset

Gets the A2LUNIT dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a specific unit by name
var mph = a2lParser.Project.UnitDict["mph"];
}

◆ VirtualDict

IDictionary<string, A2LVIRTUAL> VirtualDict
getset

Gets the A2LVIRTUAL dictionary.

Usage example:

using (var a2lParser = new A2LParser())
{
// parse test.a2l
a2lParser.parse("test.a2l");
// Access a virtual instance by name
var virtual_entity = a2lParser.Project.VirtualDict["virtual_entity1"];
}


ASAP2Library interface: Member List

  • ASAP2
  • A2LPROJECT
A2LPROJECT Member List

This is the complete list of members for A2LPROJECT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
BlobDict | A2LPROJECT |
ChangedType | A2LNODE |
CharDict | A2LPROJECT |
Childs | A2LNODE |
CompDict | A2LPROJECT |
CompTabDict | A2LPROJECT |
CompVTabDict | A2LPROJECT |
CompVTabRangeDict | A2LPROJECT |
DefFunctionDict | A2LPROJECT |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LPROJECT) | A2LPROJECT |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FormulaDict | A2LPROJECT |
FuncDict | A2LPROJECT |
GetAdditiveDescription (defined in A2LPROJECT) | A2LPROJECT |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LPROJECT |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
getSymbols() | A2LPROJECT |
GroupDict | A2LPROJECT |
InstanceDict | A2LPROJECT |
IsInstanced | A2LNODE |
MeasDict | A2LPROJECT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
ModelChanged | A2LPROJECT |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RecLayDict | A2LPROJECT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
TransformerDict | A2LPROJECT |
Type | A2LNODE |
TypeDefDict | A2LPROJECT |
UnitDict | A2LPROJECT |
VirtualDict | A2LPROJECT |


ASAP2Library interface: A2LRECORD_LAYOUT Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT
Classes | Public Member Functions | Properties | List of all members
A2LRECORD_LAYOUT Class Reference

Record layout. More...

Classes

class | AxisPtsLayoutDesc
Layout description for axis points. More...
class | AxisRescaleLayoutDesc
Layout description for axis rescale value pairs. More...
class | FncValuesLayoutDesc
Layout description for function values More...
class | ItemLayoutDesc
Base class for record layout items. More...

Public Member Functions

int | getAlignment (DATA_TYPE dataType)
Gets the alignment value for the specified data type. More...
sealed override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LCHARACTERISTICs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...

Properties

int[]??? | Alignments [getset]
The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5, FLOAT16_IEEE=6. More...
int[] | Alignments_ [getset]
This is just to serialize and deserialize to XML, use the Alignments property to access.
AxisPtsLayoutDesc[] | AxisPts = new AxisPtsLayoutDesc[5] [getset]
Description of the X, Y, Z, Z4 or Z5 axis points in the memory. More...
AxisRescaleLayoutDesc | AxisRescaleX [getset]
Describes where the rescale mapping for the X axis is deposited in memory.
NoAxisPtsLayoutDesc[] | DistOp = new NoAxisPtsLayoutDesc[5] [getset]
'Distance' parameter to compute the axis points of fixed Characteristics. More...
int[] | FixNoAxisPts = (int[])mDefaultOffsets.Clone() [getset]
Indicates that a fixed number of axis points is allocated. More...
FncValuesLayoutDesc | FncValues [getset]
This keyword describes how the table values (function values) of the adjustable object are deposited in memory.
NoAxisPtsLayoutDesc | Identification [getset]
This keyword is used to describe that an 'identifier' is deposited in a specific position in the adjustable object.
IList< ItemLayoutDesc > | LayoutEntries [get]
Represents all layout entries sorted in a single list by it's position in ascending order.
NoAxisPtsLayoutDesc[] | NoAxisPts = new NoAxisPtsLayoutDesc[5] [getset]
Describes in which position the parameter 'number of axis points' is deposited in memory. More...
NoAxisPtsLayoutDesc | NoRescaleX [getset]
Describes at which position the parameter ‘current number of rescale pairs for the X axis is deposited.
NoAxisPtsLayoutDesc[] | Offset = new NoAxisPtsLayoutDesc[5] [getset]
Offset to compute the axis points of fixed Characteristics. More...
List< NoAxisPtsLayoutDesc > | Reserved = new List<NoAxisPtsLayoutDesc>() [getset]
This keyword can be used to skip specific elements in the adjustable object whose meaning must not be interpreted by the measurement and calibration system (e.g. for extensions: new parameters in the adjustable objects).
NoAxisPtsLayoutDesc[] | RipAddr = new NoAxisPtsLayoutDesc[5] [getset]
Is used to describe at which position the address of this RIP_X, RIP_Y, RIP_Z, RIP_Z4 or RIP_Z5 quantity is deposited, which contains the current value of the ECU-internal interpolation. (input values). More...
NoAxisPtsLayoutDesc | RipAddrW [getset]
Final result (table value) of the ECU-internal interpolation. (output value).
NoAxisPtsLayoutDesc[] | ShiftOp = new NoAxisPtsLayoutDesc[5] [getset]
Shift operand to compute the axis points of fixed Characteristics. More...
NoAxisPtsLayoutDesc[] | SrcAddress = new NoAxisPtsLayoutDesc[5] [getset]
Describes at which position the address of the input quantity of the axis is deposited in memory. More...
bool | StaticAddressOffsets [getset]
For calibration objects with dynamic number of axis points this keyword indicates that the start addresses of axes and function values do not change when removing or inserting axis points, however the addresses of the single data cells will change if the dimension of the map changes
bool | StaticRecordLayout [getset]
For calibration objects with dynamic number of axis points this keyword indicates that the calibration object does not compact or expand data when removing resp. inserting axis points. All record layout elements are stored at the same address as for the max. number of axis points specified at the calibration object - independent of the actual number of axis points. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Record layout.

The 'RECORD_LAYOUT' keyword is used to specify the various data structures of the adjustable objects in the memory. The structural buildup of the various adjustable object types must be described in such a way that a standard measurement and calibration system will be able to process all adjustable object types (reading, writing, operating point display etc.). In particular, if the ALTERNATE option is used with FNC_VALUES, the position parameter determines the order of values and axis points.

Note: To describe the record layouts, use is made of a predefined list of parameters which may be part of an adjustable object (characteristic) in the emulation memory. This list represents the current status of the record layouts. With each change or extension of the record layouts contained in this predefined list of parameters the ASAM MCD-2MC description file format must be modified accordingly.

Note: The keywords describing axis parameters for CUBE_4 and CUBE_5 are extended by _X, _Y, _Z, _4, _5. This allows an easier understanding which dimension the axis description belongs to. In the textual description the axes for CUBE_4 and CUBE_5 are named X, Y, Z, Z4, Z5. This allows textual description without a reference to a keyword (Z4-axis describes the axis better as 4-axis)

Note: For CUBOID, CUBE_4 and CUBE_5 the RECORD_LAYOUT supports only one dedicated way to sort the data in the memory. These objects are always stored as array of MAP with incremented or decremented axes. The exchange of dimensions (e.g. X, Z, Y, Z5, Z4) in the memory is not supported.

see ASAP2 specification, too.

Member Function Documentation

◆ getAlignment()

int getAlignment ( DATA_TYPE dataType )

Gets the alignment value for the specified data type.

Parameters
dataType The data type
Returns
The alignment value

◆ getRefFunctions()

sealed override IEnumerable< A2LREFBASE > getRefFunctions ( )
virtual

Gets the referencing functions.

Ususally only valid for A2LMEASUREMENT and A2LCHARACTERISTIC.

Returns
May be null or empty if not referenced by any node.

Reimplemented from A2LNODE.

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LCHARACTERISTICs.

Returns
May be null or empty if not referenced by any characateristic.

Reimplemented from A2LNODE.

Property Documentation

◆ Alignments

int []??? Alignments
getset

The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5, FLOAT16_IEEE=6.

If not explicitely set, the alignments are taken from the A2LMOD_COMMON intance.

◆ AxisPts

AxisPtsLayoutDesc [] AxisPts = new AxisPtsLayoutDesc[5]
getset

Description of the X, Y, Z, Z4 or Z5 axis points in the memory.

Note: If the Alternate option is used with FNC_VALUES, the position parameter determines the order of values and axis points.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ DistOp

NoAxisPtsLayoutDesc [] DistOp = new NoAxisPtsLayoutDesc[5]
getset

'Distance' parameter to compute the axis points of fixed Characteristics.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ FixNoAxisPts

int [] FixNoAxisPts = (int[])mDefaultOffsets.Clone()
getset

Indicates that a fixed number of axis points is allocated.

Note: In a RECORD_LAYOUT data record, this keyword may not be used simultaneously with the keyword 'NO_AXIS_PTS_X / _Y / _Z / _4 / _5'.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ NoAxisPts

NoAxisPtsLayoutDesc [] NoAxisPts = new NoAxisPtsLayoutDesc[5]
getset

Describes in which position the parameter 'number of axis points' is deposited in memory.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ Offset

NoAxisPtsLayoutDesc [] Offset = new NoAxisPtsLayoutDesc[5]
getset

Offset to compute the axis points of fixed Characteristics.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ RipAddr

NoAxisPtsLayoutDesc [] RipAddr = new NoAxisPtsLayoutDesc[5]
getset

Is used to describe at which position the address of this RIP_X, RIP_Y, RIP_Z, RIP_Z4 or RIP_Z5 quantity is deposited, which contains the current value of the ECU-internal interpolation. (input values).

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ ShiftOp

NoAxisPtsLayoutDesc [] ShiftOp = new NoAxisPtsLayoutDesc[5]
getset

Shift operand to compute the axis points of fixed Characteristics.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ SrcAddress

NoAxisPtsLayoutDesc [] SrcAddress = new NoAxisPtsLayoutDesc[5]
getset

Describes at which position the address of the input quantity of the axis is deposited in memory.

Indizes mapped to: X=0, Y=1, Z=2, _4=3, _5=4.

◆ StaticRecordLayout

bool StaticRecordLayout
getset

For calibration objects with dynamic number of axis points this keyword indicates that the calibration object does not compact or expand data when removing resp. inserting axis points. All record layout elements are stored at the same address as for the max. number of axis points specified at the calibration object - independent of the actual number of axis points.

If the parameter STATIC_RECORD_LAYOUT is missing, the calibration objects referencing this record layout do compact / extend data when removing resp. inserting axis points and the addresses of the record layout elements depend on the actual number of axis points.

This parameter may be used only together with NO_AXIS_PTS_X/_Y/_Z/_4/_5.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT
A2LRECORD_LAYOUT Member List

This is the complete list of members for A2LRECORD_LAYOUT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Alignments | A2LRECORD_LAYOUT |
Alignments_ | A2LRECORD_LAYOUT |
AxisPts | A2LRECORD_LAYOUT |
AxisRescaleX | A2LRECORD_LAYOUT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
DistOp | A2LRECORD_LAYOUT |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
FixNoAxisPts | A2LRECORD_LAYOUT |
FncValues | A2LRECORD_LAYOUT |
getAlignment(DATA_TYPE dataType) | A2LRECORD_LAYOUT |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LRECORD_LAYOUT | virtual
getRefNodes() | A2LRECORD_LAYOUT | virtual
Identification | A2LRECORD_LAYOUT |
IsInstanced | A2LNODE |
LayoutEntries | A2LRECORD_LAYOUT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoAxisPts | A2LRECORD_LAYOUT |
NoCompuMethod | A2LNODE | static
NoRescaleX | A2LRECORD_LAYOUT |
Offset | A2LRECORD_LAYOUT |
Parent | A2LNODE |
Reserved | A2LRECORD_LAYOUT |
RipAddr | A2LRECORD_LAYOUT |
RipAddrW | A2LRECORD_LAYOUT |
ShiftOp | A2LRECORD_LAYOUT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
SrcAddress | A2LRECORD_LAYOUT |
StartLine | A2LNODE |
StaticAddressOffsets | A2LRECORD_LAYOUT |
StaticRecordLayout | A2LRECORD_LAYOUT |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LRECORD_LAYOUT.AxisPtsLayoutDesc Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT
  • AxisPtsLayoutDesc
Public Member Functions | Properties | List of all members
A2LRECORD_LAYOUT.AxisPtsLayoutDesc Class Reference

Layout description for axis points. More...

Public Member Functions

AxisPtsLayoutDesc (string name, int position, DATA_TYPE dataType, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx)
Creates a new instance of AxisPtsLayoutDesc More...
override string ToString ()

Properties

ADDR_TYPE | AdressType [getset]
Gets or sets the addressing type of the table values.
INDEX_ORDER | IndexOrder [getset]
Gets or sets the index order of the values.
- Properties inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
int | AxisIdx = -1 [getset]
The corresponding axis index (-1 if no axis corresponds).
DATA_TYPE | DataType [getset]
Gets or sets the data type.
string | Name [getset]
int | Position [getset]
Gets or sets Position of the axis point values in the deposit structure (description of sequence of elements in the data record).

Additional Inherited Members

- Protected Member Functions inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
bool equals (ItemLayoutDesc y)

Detailed Description

Layout description for axis points.

Constructor & Destructor Documentation

◆ AxisPtsLayoutDesc()

AxisPtsLayoutDesc | ( | string | name,
 |  | int | position,
 |  | DATA_TYPE | dataType,
 |  | INDEX_ORDER | indexOrder,
 |  | ADDR_TYPE | adressType,
 |  | int | axisIdx
 | ) |  |

Creates a new instance of AxisPtsLayoutDesc

Parameters
name | instance name
position | Position
dataType | Data type
indexOrder | Index Order mode
adressType | Address type
axisIdx | Axis index

Member Function Documentation

◆ ToString()

override string ToString ( )
virtual

Implements A2LRECORD_LAYOUT.ItemLayoutDesc.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT
  • AxisPtsLayoutDesc
A2LRECORD_LAYOUT.AxisPtsLayoutDesc Member List

This is the complete list of members for A2LRECORD_LAYOUT.AxisPtsLayoutDesc, including all inherited members.

AdressType | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
AxisIdx | A2LRECORD_LAYOUT.ItemLayoutDesc |
AxisPtsLayoutDesc(string name, int position, DATA_TYPE dataType, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx) | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
DataType | A2LRECORD_LAYOUT.ItemLayoutDesc |
equals(ItemLayoutDesc y) (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc | protected
IndexOrder | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
Name (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc |
Position | A2LRECORD_LAYOUT.ItemLayoutDesc |
ToString() (defined in A2LRECORD_LAYOUT.AxisPtsLayoutDesc) | A2LRECORD_LAYOUT.AxisPtsLayoutDesc | virtual


ASAP2Library interface: A2LRECORD_LAYOUT.AxisRescaleLayoutDesc Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT
  • AxisRescaleLayoutDesc
Public Member Functions | Properties | List of all members
A2LRECORD_LAYOUT.AxisRescaleLayoutDesc Class Reference

Layout description for axis rescale value pairs. More...

Public Member Functions

AxisRescaleLayoutDesc (int position, DATA_TYPE dataType, int maxNoRescalePairs, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx)
override string ToString ()
- Public Member Functions inherited from A2LRECORD_LAYOUT.AxisPtsLayoutDesc
AxisPtsLayoutDesc (string name, int position, DATA_TYPE dataType, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx)
Creates a new instance of AxisPtsLayoutDesc More...

Properties

int | MaxNoRescalePairs [getset]
Gets or sets the maximum number of
- Properties inherited from A2LRECORD_LAYOUT.AxisPtsLayoutDesc
ADDR_TYPE | AdressType [getset]
Gets or sets the addressing type of the table values.
INDEX_ORDER | IndexOrder [getset]
Gets or sets the index order of the values.
- Properties inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
int | AxisIdx = -1 [getset]
The corresponding axis index (-1 if no axis corresponds).
DATA_TYPE | DataType [getset]
Gets or sets the data type.
string | Name [getset]
int | Position [getset]
Gets or sets Position of the axis point values in the deposit structure (description of sequence of elements in the data record).

Additional Inherited Members

- Protected Member Functions inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
bool equals (ItemLayoutDesc y)

Detailed Description

Layout description for axis rescale value pairs.

Member Function Documentation

◆ ToString()

override string ToString ( )
virtual

Reimplemented from A2LRECORD_LAYOUT.AxisPtsLayoutDesc.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT
  • AxisRescaleLayoutDesc
A2LRECORD_LAYOUT.AxisRescaleLayoutDesc Member List

This is the complete list of members for A2LRECORD_LAYOUT.AxisRescaleLayoutDesc, including all inherited members.

AdressType | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
AxisIdx | A2LRECORD_LAYOUT.ItemLayoutDesc |
AxisPtsLayoutDesc(string name, int position, DATA_TYPE dataType, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx) | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
AxisRescaleLayoutDesc(int position, DATA_TYPE dataType, int maxNoRescalePairs, INDEX_ORDER indexOrder, ADDR_TYPE adressType, int axisIdx) (defined in A2LRECORD_LAYOUT.AxisRescaleLayoutDesc) | A2LRECORD_LAYOUT.AxisRescaleLayoutDesc |
DataType | A2LRECORD_LAYOUT.ItemLayoutDesc |
equals(ItemLayoutDesc y) (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc | protected
IndexOrder | A2LRECORD_LAYOUT.AxisPtsLayoutDesc |
MaxNoRescalePairs | A2LRECORD_LAYOUT.AxisRescaleLayoutDesc |
Name (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc |
Position | A2LRECORD_LAYOUT.ItemLayoutDesc |
ToString() (defined in A2LRECORD_LAYOUT.AxisRescaleLayoutDesc) | A2LRECORD_LAYOUT.AxisRescaleLayoutDesc | virtual


ASAP2Library interface: A2LRECORD_LAYOUT.FncValuesLayoutDesc Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT
  • FncValuesLayoutDesc
Public Member Functions | Properties | List of all members
A2LRECORD_LAYOUT.FncValuesLayoutDesc Class Reference

Layout description for function values More...

Public Member Functions

FncValuesLayoutDesc (int position, DATA_TYPE dataType, INDEX_MODE indexMode, ADDR_TYPE adressType)
override string ToString ()

Properties

ADDR_TYPE | AdressType [getset]
Gets or sets the addressing type of the table values.
INDEX_MODE | IndexMode [getset]
Gets or sets the indexing mode of the values.
- Properties inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
int | AxisIdx = -1 [getset]
The corresponding axis index (-1 if no axis corresponds).
DATA_TYPE | DataType [getset]
Gets or sets the data type.
string | Name [getset]
int | Position [getset]
Gets or sets Position of the axis point values in the deposit structure (description of sequence of elements in the data record).

Additional Inherited Members

- Protected Member Functions inherited from A2LRECORD_LAYOUT.ItemLayoutDesc
bool equals (ItemLayoutDesc y)

Detailed Description

Layout description for function values

Member Function Documentation

◆ ToString()

override string ToString ( )
virtual

Implements A2LRECORD_LAYOUT.ItemLayoutDesc.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT
  • FncValuesLayoutDesc
A2LRECORD_LAYOUT.FncValuesLayoutDesc Member List

This is the complete list of members for A2LRECORD_LAYOUT.FncValuesLayoutDesc, including all inherited members.

AdressType | A2LRECORD_LAYOUT.FncValuesLayoutDesc |
AxisIdx | A2LRECORD_LAYOUT.ItemLayoutDesc |
DataType | A2LRECORD_LAYOUT.ItemLayoutDesc |
equals(ItemLayoutDesc y) (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc | protected
FncValuesLayoutDesc(int position, DATA_TYPE dataType, INDEX_MODE indexMode, ADDR_TYPE adressType) (defined in A2LRECORD_LAYOUT.FncValuesLayoutDesc) | A2LRECORD_LAYOUT.FncValuesLayoutDesc |
IndexMode | A2LRECORD_LAYOUT.FncValuesLayoutDesc |
Name (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc |
Position | A2LRECORD_LAYOUT.ItemLayoutDesc |
ToString() (defined in A2LRECORD_LAYOUT.FncValuesLayoutDesc) | A2LRECORD_LAYOUT.FncValuesLayoutDesc | virtual


ASAP2Library interface: A2LRECORD_LAYOUT.ItemLayoutDesc Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT
  • ItemLayoutDesc
Public Member Functions | Protected Member Functions | Properties | List of all members
A2LRECORD_LAYOUT.ItemLayoutDesc Class Referenceabstract

Base class for record layout items. More...

Public Member Functions

abstract override string ToString ()

Protected Member Functions

bool equals (ItemLayoutDesc y)

Properties

int | AxisIdx = -1 [getset]
The corresponding axis index (-1 if no axis corresponds).
DATA_TYPE | DataType [getset]
Gets or sets the data type.
string | Name [getset]
int | Position [getset]
Gets or sets Position of the axis point values in the deposit structure (description of sequence of elements in the data record).

Detailed Description

Base class for record layout items.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT
  • ItemLayoutDesc
A2LRECORD_LAYOUT.ItemLayoutDesc Member List

This is the complete list of members for A2LRECORD_LAYOUT.ItemLayoutDesc, including all inherited members.

AxisIdx | A2LRECORD_LAYOUT.ItemLayoutDesc |
DataType | A2LRECORD_LAYOUT.ItemLayoutDesc |
equals(ItemLayoutDesc y) (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc | protected
Name (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc |
Position | A2LRECORD_LAYOUT.ItemLayoutDesc |
ToString() (defined in A2LRECORD_LAYOUT.ItemLayoutDesc) | A2LRECORD_LAYOUT.ItemLayoutDesc | pure virtual


ASAP2Library interface: A2LRECORD_LAYOUT_REF Class Reference

  • ASAP2
  • A2LRECORD_LAYOUT_REF
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
A2LRECORD_LAYOUT_REF Class Referenceabstract

Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT. More...

Public Member Functions

uint | getAddress (IList< string > criterionValues=null)
Gets the effective address supporting a potentially defined variant coding. More...
A2LFUNCTION getDefCharacteristicFunction ()
Gets the function which holds the current instance as the DEF_CHARACTERISTIC. More...
IA2LMemory getMemorySegment ()
Gets the corresponding memory segment (may be null). More...
sealed override int | getMemorySize ()
Gets the size of used memory in bytes. More...
abstract int | getSize ()
Gets the size in bytes of the characteristic. More...
bool | isReadOnly ()
Returns a value indicating if the characteristic value should not be changed. More...
string | toStringValue (double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LCONVERSION_REF
override IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
sealed override string | ToString ()
string | toStringValue (double physValue)
Builds a string representation from the specified physical value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true)
Builds a string representation from the specified value. More...
string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Public Member Functions inherited from A2LADDRESS
virtual string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LRECORD_LAYOUT_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LCONVERSION_REF
A2LCONVERSION_REF (A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv)
Creates instance from an A2LINSTANCE. More...
- Protected Member Functions inherited from A2LADDRESS
A2LADDRESS (A2LMODULE module, A2LINSTANCE instance)
Creates instance from an A2LINSTANCE. More...
void | addFromInstance (A2LMODULE module, A2LType type, A2LTYPEDEF typedef)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Protected Attributes

string | mRecordLayout
- Protected Attributes inherited from A2LCONVERSION_REF
BYTEORDER_TYPE | mByteOrder
string | mConversion
string | mFormat = string.Empty
string | mMemorySegmentRef
string | mPhysUnit
- Protected Attributes inherited from A2LADDRESS
string | mDisplayName = string.Empty

Properties

bool | GuardRails [getset]
Gets or sets the guard rails. More...
double | LowerLimitEx [getset]
Gets or sets the extended lower limit.
double | MaxDiff [getset]
Gets or sets the maximum float with respect to an adjustment of a table value.
bool | ReadOnly [getset]
Gets or sets the readonly state. More...
string | RecordLayout [getset]
Gets a reference to the corresponding data record for description of the record layout (see A2LRECORD_LAYOUT) More...
A2LRECORD_LAYOUT | RefRecordLayout [get]
Gets the direct reference to the corresponding record layout. More...
double | StepSize = double.NaN [getset]
Gets or sets the step size. More...
double | UpperLimitEx [getset]
Gets or sets the extended upper limit.
- Properties inherited from A2LCONVERSION_REF
BYTEORDER_TYPE??? | ByteOrder [getset]
Gets or sets the Byte order (optional). More...
string | Conversion [getset]
Gets or sets the conversion's name. More...
int | DecimalCount [get]
Gets the decimal count of the corresponding Format value.
string????? | Format [getset]
Gets or sets the format. More...
bool | IsFormatNotSet [get]
Indicates if a format string is not set. More...
double | LowerLimit [getset]
Gets or sets the plausible range of table values, lower limit.
string | MemorySegmentRef [get]
A2LCOMPU_METHOD | RefCompuMethod [get]
Gets the direct reference to the corresponding compu method.
IEnumerable< A2LREFBASE > | RefFunctions [get]
Gets the list of functions referring this node.
string? | Unit [getset]
Gets or sets the Unit.
double | UpperLimit [getset]
Gets or sets the plausible range of table values, upper limit.
- Properties inherited from A2LADDRESS
uint | Address = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
int | AddressExtension [getset]
Gets the address extension. More...
CALIBRATION_ACCESS | CalibAccess [getset]
string | Description [getset]
Gets or sets the comment, description.
sealed override string? | DisplayName [getset]
Gets the display name. More...
sealed override bool | IsInstanced [get]
int | MaxRefreshRate [getset]
ScalingUnits | MaxRefreshUnit = ScalingUnits.NotSet [getset]
string | ModelLink [getset]
Object model's name. More...
A2LINSTANCE | RefInstance [get]
A reference to an A2L instance (May occur with since ASAP2 v1.7.0 specification).
string | SymbolLink [getset]
Name of the symbol within the corresponding linker map file.
int | SymbolOffset [getset]
Offset of the Symbol relative to the symbol’s address in the linker map file. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LCONVERSION_REF
static int | getDecimalCount (string format)
Gets the decimal count from an A2L format string. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount)
Builds a string representation from the specified value. More...
static string | toStringValue (double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated)
Builds a string representation from the specified value. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT.

These derived classes are:

  • A2LCHARACTERISTIC
  • A2LAXIS_PTS

Constructor & Destructor Documentation

◆ A2LRECORD_LAYOUT_REF()

A2LRECORD_LAYOUT_REF | ( | A2LMODULE | module,
 |  | A2LINSTANCE | instance,
 |  | A2LTYPEDEF_RECORDLAYOUT_REF | tdRecLayout
 | ) |  |
protected

Creates instance from an A2LINSTANCE.

Parameters
module | The module to add the instance to
instance | The instance to create from
tdRecLayout | The axis typedef reference

Member Function Documentation

◆ getAddress()

uint getAddress ( IList< string > criterionValues = null )

Gets the effective address supporting a potentially defined variant coding.

Parameters
criterionValues Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
The effective address
Exceptions
ArgumentException Thrown if the CriterionValues parameter contains invalid values or A2L definition isn't complete

◆ getDefCharacteristicFunction()

A2LFUNCTION getDefCharacteristicFunction ( )

Gets the function which holds the current instance as the DEF_CHARACTERISTIC.

Returns
The A2LFUNCTION instance or null if not found

◆ getMemorySegment()

IA2LMemory getMemorySegment ( )

Gets the corresponding memory segment (may be null).

Returns
The memory segment or null if not available

◆ getMemorySize()

sealed override int getMemorySize ( )
virtual

Gets the size of used memory in bytes.

Returns

Implements A2LADDRESS.

◆ getSize()

abstract int getSize ( )
pure virtual

Gets the size in bytes of the characteristic.

The size is calculated from

  • the corresponding record layout
  • the number of elements from MatrixDim
  • external references (like A2LAXIS_PTS) of the characteristic is not taken into account

Together with the characteristic's address, the characteristic's complete value could be read or written directly from/to a MemorySegment or device.

Returns
The size in bytes

Implemented in A2LAXIS_PTS, and A2LCHARACTERISTIC.

◆ isReadOnly()

bool isReadOnly ( )

Returns a value indicating if the characteristic value should not be changed.

Additionally to the direct ReadOnly flag, the corresponding ReadOnly state of the memory segment is taken into account.

Returns
true if values should never be written

◆ toStringValue()

string toStringValue | ( | double | rawValue,
 |  | ValueObjectFormat | format,
 |  | DATA_TYPE | dt,
 |  | out bool | lowerLimitViolated,
 |  | out bool | upperLimitViolated,
 |  | out bool | lowerLimitExViolated,
 |  | out bool | upperLimitExViolated
 | ) |  |

Builds a string representation from the specified value.

Parameters
rawValue | The raw value to build the string for
format | The value format
dt | The data type (only important if format is raw)
lowerLimitViolated | true if the lower limit is violated
upperLimitViolated | true if the upper limit is violated
lowerLimitExViolated | true if the extended lower limit is violated
upperLimitExViolated | true if the extended upper limit is violated
Returns
the string representation

Property Documentation

◆ GuardRails

bool GuardRails
getset

Gets or sets the guard rails.

This keyword is used to indicate that an adjustable CURVE or MAP uses guard rails. The Measurement and Calibration System does not allow the user to edit the outermost values of the adjustable object (see GUARD_RAILS).

◆ ReadOnly

bool ReadOnly
getset

Gets or sets the readonly state.

This keyword can be used to indicate that the adjustable object cannot be changed (but can be read only). This keyword indicates the adjustable object to be read only at all (table values and axis points). The optional keyword used at AXIS_DESCR record indicates the related axis points to be read only.

◆ RecordLayout

string RecordLayout
getset

Gets a reference to the corresponding data record for description of the record layout (see A2LRECORD_LAYOUT)

For a direct reference use RefRecordLayout!

◆ RefRecordLayout

A2LRECORD_LAYOUT RefRecordLayout
get

Gets the direct reference to the corresponding record layout.

may be (never should be) null!

◆ StepSize

double StepSize = double.NaN
getset

Gets or sets the step size.

This keyword can be used to define a delta value which is added to or subtracted from the current value when using up/down keys while calibrating.


ASAP2Library interface: Member List

  • ASAP2
  • A2LRECORD_LAYOUT_REF
A2LRECORD_LAYOUT_REF Member List

This is the complete list of members for A2LRECORD_LAYOUT_REF, including all inherited members.

A2LADDRESS(A2LMODULE module, A2LINSTANCE instance) | A2LADDRESS | protected
A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LCONVERSION_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_CONVERSION_REF tdConv) | A2LCONVERSION_REF | protected
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LRECORD_LAYOUT_REF(A2LMODULE module, A2LINSTANCE instance, A2LTYPEDEF_RECORDLAYOUT_REF tdRecLayout) | A2LRECORD_LAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addFromInstance(A2LMODULE module, A2LType type, A2LTYPEDEF typedef) | A2LADDRESS | protected
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Address | A2LADDRESS |
AddressExtension | A2LADDRESS |
ByteOrder | A2LCONVERSION_REF |
CalibAccess (defined in A2LADDRESS) | A2LADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LCONVERSION_REF |
DecimalCount | A2LCONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description | A2LADDRESS |
DisplayName | A2LADDRESS |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LCONVERSION_REF |
getAddress(IList< string > criterionValues=null) | A2LRECORD_LAYOUT_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDecimalCount(string format) | A2LCONVERSION_REF | static
getDefCharacteristicFunction() | A2LRECORD_LAYOUT_REF |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LADDRESS | virtual
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getMemorySegment() | A2LRECORD_LAYOUT_REF |
getMemorySize() | A2LRECORD_LAYOUT_REF | virtual
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LCONVERSION_REF | virtual
getRefNodes() | A2LNODE | virtual
getSize() | A2LRECORD_LAYOUT_REF | pure virtual
GuardRails | A2LRECORD_LAYOUT_REF |
IsFormatNotSet | A2LCONVERSION_REF |
IsInstanced (defined in A2LADDRESS) | A2LADDRESS |
isReadOnly() | A2LRECORD_LAYOUT_REF |
LowerLimit | A2LCONVERSION_REF |
LowerLimitEx | A2LRECORD_LAYOUT_REF |
MaxDiff | A2LRECORD_LAYOUT_REF |
MaxRefreshRate (defined in A2LADDRESS) | A2LADDRESS |
MaxRefreshUnit (defined in A2LADDRESS) | A2LADDRESS |
mByteOrder (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mConversion (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mDisplayName (defined in A2LADDRESS) | A2LADDRESS | protected
MemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mFormat (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mMemorySegmentRef (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
ModelLink | A2LADDRESS |
mPhysUnit (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF | protected
mRecordLayout (defined in A2LRECORD_LAYOUT_REF) | A2LRECORD_LAYOUT_REF | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadOnly | A2LRECORD_LAYOUT_REF |
RecordLayout | A2LRECORD_LAYOUT_REF |
RefCompuMethod | A2LCONVERSION_REF |
RefFunctions | A2LCONVERSION_REF |
RefInstance | A2LADDRESS |
RefRecordLayout | A2LRECORD_LAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LRECORD_LAYOUT_REF |
SymbolLink | A2LADDRESS |
SymbolOffset | A2LADDRESS |
Tag | A2LNODE |
ToString() (defined in A2LCONVERSION_REF) | A2LCONVERSION_REF |
toStringValue(double rawValue, ValueObjectFormat format, DATA_TYPE dt, out bool lowerLimitViolated, out bool upperLimitViolated, out bool lowerLimitExViolated, out bool upperLimitExViolated) | A2LRECORD_LAYOUT_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount) | A2LCONVERSION_REF | static
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double physValue) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, bool forceFmt=true) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF |
jnsoft::ASAP2::A2LCONVERSION_REF.toStringValue(double value, ValueObjectFormat format, DATA_TYPE dataType, A2LCOMPU_METHOD compuMethod, int decimalCount, double lowerLimit, double upperLimit, out bool lowerLimitViolated, out bool upperLimitViolated) | A2LCONVERSION_REF | static
Type | A2LNODE |
Unit | A2LCONVERSION_REF |
UpperLimit | A2LCONVERSION_REF |
UpperLimitEx | A2LRECORD_LAYOUT_REF |


ASAP2Library interface: A2LREF_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LREF_CHARACTERISTIC
List of all members
A2LREF_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LREF_CHARACTERISTIC
A2LREF_CHARACTERISTIC Member List

This is the complete list of members for A2LREF_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LREF_GROUP Class Reference

  • ASAP2
  • A2LREF_GROUP
List of all members
A2LREF_GROUP Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LREF_GROUP
A2LREF_GROUP Member List

This is the complete list of members for A2LREF_GROUP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LREF_MEASUREMENT Class Reference

  • ASAP2
  • A2LREF_MEASUREMENT
List of all members
A2LREF_MEASUREMENT Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LREF_MEASUREMENT
A2LREF_MEASUREMENT Member List

This is the complete list of members for A2LREF_MEASUREMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LREFBASE Class Reference

  • ASAP2
  • A2LREFBASE
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
A2LREFBASE Class Reference

Base class for A2LFUNCTION and A2LGROUP. More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
void | resetReferences ()
Resets cached references.
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Protected Member Functions

A2LREFBASE (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Protected Attributes

List< A2LNAMEDNODE > mReferencedNodes

Properties

string | Description [getset]
virtual List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for A2LFUNCTION and A2LGROUP.

This nodes typically reference a set of other nodes by name.

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.


ASAP2Library interface: Member List

  • ASAP2
  • A2LREFBASE
A2LREFBASE Member List

This is the complete list of members for A2LREFBASE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LREFBASE(int startLine) (defined in A2LREFBASE) | A2LREFBASE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LREFBASE) | A2LREFBASE |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFBASE |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mReferencedNodes (defined in A2LREFBASE) | A2LREFBASE | protected
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFBASE |
resetReferences() | A2LREFBASE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LREFERENCE Class Reference

  • ASAP2
  • A2LREFERENCE
Public Member Functions | Properties | List of all members
A2LREFERENCE Class Reference

Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs. More...

Public Member Functions

void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs.

This nodes typically reference a set of other nodes by name.

Examples: A2LREF_CHARACTERISTIC, A2LSUB_FUNCTION,...

Member Function Documentation

◆ deleteNode()

void deleteNode ( A2LNAMEDNODE node )

Deletes the specified node from the list of references.

Parameters
node

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.


ASAP2Library interface: Member List

  • ASAP2
  • A2LREFERENCE
A2LREFERENCE Member List

This is the complete list of members for A2LREFERENCE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LSTRUCTURE_COMPONENT Class Reference

  • ASAP2
  • A2LSTRUCTURE_COMPONENT
Properties | List of all members
A2LSTRUCTURE_COMPONENT Class Reference

see ASAP2 specification More...

Properties

uint | AddressOffset = uint.MaxValue [getset]
Gets or sets the address of the adjustable object in the emulation memory.
INDEX_MODE | Layout [getset]
Gets or sets the layout. More...
int[] | MatrixDim [getset]
Gets the 3-value (x, y, z) integer matrix dimensions.
A2LTYPEDEF | RefTypedef [get]
Gets the direct reference to the corresponding typedef.
string | SymbolTypeLink [getset]
Name of the symbol type link within the corresponding linker map file.
string | TypedefName [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Property Documentation

◆ Layout

INDEX_MODE Layout
getset

Gets or sets the layout.

For multi-dimensional measurement arrays this keyword can be used to specify the layout of the array. If the keyword is missing, multi-dimensional measurement arrays are interpreted row by row (ROW_DIR).


ASAP2Library interface: Member List

  • ASAP2
  • A2LSTRUCTURE_COMPONENT
A2LSTRUCTURE_COMPONENT Member List

This is the complete list of members for A2LSTRUCTURE_COMPONENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddressOffset | A2LSTRUCTURE_COMPONENT |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
Layout | A2LSTRUCTURE_COMPONENT |
MatrixDim | A2LSTRUCTURE_COMPONENT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefTypedef | A2LSTRUCTURE_COMPONENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolTypeLink | A2LSTRUCTURE_COMPONENT |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
TypedefName (defined in A2LSTRUCTURE_COMPONENT) | A2LSTRUCTURE_COMPONENT |


ASAP2Library interface: A2LSUB_FUNCTION Class Reference

  • ASAP2
  • A2LSUB_FUNCTION
List of all members
A2LSUB_FUNCTION Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LSUB_FUNCTION
A2LSUB_FUNCTION Member List

This is the complete list of members for A2LSUB_FUNCTION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LSUB_GROUP Class Reference

  • ASAP2
  • A2LSUB_GROUP
List of all members
A2LSUB_GROUP Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LSUB_GROUP
A2LSUB_GROUP Member List

This is the complete list of members for A2LSUB_GROUP, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LTRANSFORMER Class Reference

  • ASAP2
  • A2LTRANSFORMER
Public Member Functions | Properties | List of all members
A2LTRANSFORMER Class Reference

see ASAP2 specification More...

Public Member Functions

override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTRANSFORMER nodes. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Properties

string | Executable32 [getset]
string | Executable64 [getset]
string | InverseTransformer [getset]
A2LTRANSFORMER | RefInverseTransormer [get]
uint | Timeout [getset]
TriggerType | Trigger [getset]
string | Version [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getRefNodes()

override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LTRANSFORMER nodes.

Returns
List of referenced Transformer node.

Reimplemented from A2LNODE.


ASAP2Library interface: Member List

  • ASAP2
  • A2LTRANSFORMER
A2LTRANSFORMER Member List

This is the complete list of members for A2LTRANSFORMER, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
Executable32 (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
Executable64 (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTRANSFORMER | virtual
InverseTransformer (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefInverseTransormer (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Timeout (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Trigger (defined in A2LTRANSFORMER) | A2LTRANSFORMER |
Type | A2LNODE |
Version (defined in A2LTRANSFORMER) | A2LTRANSFORMER |


ASAP2Library interface: A2LTRANSFORMER_IN_OBJECTS Class Reference

  • ASAP2
  • A2LTRANSFORMER_IN_OBJECTS
List of all members
A2LTRANSFORMER_IN_OBJECTS Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTRANSFORMER_IN_OBJECTS
A2LTRANSFORMER_IN_OBJECTS Member List

This is the complete list of members for A2LTRANSFORMER_IN_OBJECTS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LTRANSFORMER_IN_OBJECTS() (defined in A2LTRANSFORMER_IN_OBJECTS) | A2LTRANSFORMER_IN_OBJECTS |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LTRANSFORMER_OUT_OBJECTS Class Reference

  • ASAP2
  • A2LTRANSFORMER_OUT_OBJECTS
List of all members
A2LTRANSFORMER_OUT_OBJECTS Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTRANSFORMER_OUT_OBJECTS
A2LTRANSFORMER_OUT_OBJECTS Member List

This is the complete list of members for A2LTRANSFORMER_OUT_OBJECTS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
A2LTRANSFORMER_OUT_OBJECTS() (defined in A2LTRANSFORMER_OUT_OBJECTS) | A2LTRANSFORMER_OUT_OBJECTS |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LTYPEDEF Class Reference

  • ASAP2
  • A2LTYPEDEF
Public Member Functions | Protected Member Functions | Properties | List of all members
A2LTYPEDEF Class Reference

Base class for all A2L typedef entities. More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...

Protected Member Functions

A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L typedef entities.

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

◆ getRefNodes()

sealed override IEnumerable< A2LNODE > getRefNodes ( )
virtual

Gets the referencing A2LTYPEDEFs.

Returns
List of referenced TYPEDEFs.

Reimplemented from A2LNODE.


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF
A2LTYPEDEF Member List

This is the complete list of members for A2LTYPEDEF, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LTYPEDEF_AXIS Class Reference

  • ASAP2
  • A2LTYPEDEF_AXIS
Properties | List of all members
A2LTYPEDEF_AXIS Class Reference

see ASAP2 specification More...

Properties

DEPOSIT_TYPE??? | Deposit [getset]
see A2LAXIS_PTS.Deposit.
string | InputQuantity [getset]
see A2LAXIS_PTS.InputQuantity.
int | MaxAxisPoints [getset]
see A2LAXIS_PTS.MaxAxisPoints.
MONOTONY_TYPE | Monotony [getset]
see A2LAXIS_PTS.Monotony.
- Properties inherited from A2LTYPEDEF_RECORDLAYOUT_REF
double | LowerLimitEx [getset]
see A2LRECORD_LAYOUT_REF.LowerLimitEx.
double | MaxDiff [getset]
see A2LRECORD_LAYOUT_REF.MaxDiff.
string | RecordLayout [getset]
see A2LRECORD_LAYOUT_REF.RecordLayout.
double | StepSize = double.NaN [getset]
see A2LRECORD_LAYOUT_REF.StepSize.
double | UpperLimitEx [getset]
see A2LRECORD_LAYOUT_REF.UpperLimitEx.
- Properties inherited from A2LTYPEDEF_CONVERSION_REF
BYTEORDER_TYPE | ByteOrder [getset]
see A2LCONVERSION_REF.ByteOrder.
string | Conversion [getset]
see A2LCONVERSION_REF.Conversion.
string | Format [getset]
see A2LCONVERSION_REF.Format.
double | LowerLimit [getset]
see A2LCONVERSION_REF.LowerLimit.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit [getset]
see A2LCONVERSION_REF.UpperLimit.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LTYPEDEF_RECORDLAYOUT_REF
A2LTYPEDEF_RECORDLAYOUT_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF_CONVERSION_REF
A2LTYPEDEF_CONVERSION_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_AXIS
A2LTYPEDEF_AXIS Member List

This is the complete list of members for A2LTYPEDEF_AXIS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
A2LTYPEDEF_CONVERSION_REF(int startLine) (defined in A2LTYPEDEF_CONVERSION_REF) | A2LTYPEDEF_CONVERSION_REF | protected
A2LTYPEDEF_RECORDLAYOUT_REF(int startLine) (defined in A2LTYPEDEF_RECORDLAYOUT_REF) | A2LTYPEDEF_RECORDLAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ByteOrder | A2LTYPEDEF_CONVERSION_REF |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LTYPEDEF_CONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Deposit | A2LTYPEDEF_AXIS |
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LTYPEDEF_CONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
InputQuantity | A2LTYPEDEF_AXIS |
IsInstanced | A2LNODE |
LowerLimit | A2LTYPEDEF_CONVERSION_REF |
LowerLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |
MaxAxisPoints | A2LTYPEDEF_AXIS |
MaxDiff | A2LTYPEDEF_RECORDLAYOUT_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
Monotony | A2LTYPEDEF_AXIS |
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PhysUnit | A2LTYPEDEF_CONVERSION_REF |
RecordLayout | A2LTYPEDEF_RECORDLAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LTYPEDEF_RECORDLAYOUT_REF |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit | A2LTYPEDEF_CONVERSION_REF |
UpperLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |


ASAP2Library interface: A2LTYPEDEF_BLOB Class Reference

  • ASAP2
  • A2LTYPEDEF_BLOB
Properties | List of all members
A2LTYPEDEF_BLOB Class Reference

see ASAP2 specification More...

Properties

ADDR_TYPE | AddrType [getset]
uint | Size [getset]
Gets or sets the size of the adjustable object in the emulation memory.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_BLOB
A2LTYPEDEF_BLOB Member List

This is the complete list of members for A2LTYPEDEF_BLOB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddrType (defined in A2LTYPEDEF_BLOB) | A2LTYPEDEF_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Size | A2LTYPEDEF_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LTYPEDEF_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LTYPEDEF_CHARACTERISTIC
Properties | List of all members
A2LTYPEDEF_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Properties

ulong | Bitmask = ulong.MaxValue [getset]
see A2LCHARACTERISTIC.Bitmask.
CHAR_TYPE | CharType [getset]
see A2LCHARACTERISTIC.CharType.
bool | Discrete [getset]
see A2LCHARACTERISTIC.Discrete.
EncodingType | Encoding [getset]
see A2LCHARACTERISTIC.Encoding.
int[] | MatrixDim [getset]
see A2LCHARACTERISTIC.MatrixDim.
int | Number [getset]
see A2LCHARACTERISTIC.Number.
- Properties inherited from A2LTYPEDEF_RECORDLAYOUT_REF
double | LowerLimitEx [getset]
see A2LRECORD_LAYOUT_REF.LowerLimitEx.
double | MaxDiff [getset]
see A2LRECORD_LAYOUT_REF.MaxDiff.
string | RecordLayout [getset]
see A2LRECORD_LAYOUT_REF.RecordLayout.
double | StepSize = double.NaN [getset]
see A2LRECORD_LAYOUT_REF.StepSize.
double | UpperLimitEx [getset]
see A2LRECORD_LAYOUT_REF.UpperLimitEx.
- Properties inherited from A2LTYPEDEF_CONVERSION_REF
BYTEORDER_TYPE | ByteOrder [getset]
see A2LCONVERSION_REF.ByteOrder.
string | Conversion [getset]
see A2LCONVERSION_REF.Conversion.
string | Format [getset]
see A2LCONVERSION_REF.Format.
double | LowerLimit [getset]
see A2LCONVERSION_REF.LowerLimit.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit [getset]
see A2LCONVERSION_REF.UpperLimit.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LTYPEDEF_RECORDLAYOUT_REF
A2LTYPEDEF_RECORDLAYOUT_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF_CONVERSION_REF
A2LTYPEDEF_CONVERSION_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_CHARACTERISTIC
A2LTYPEDEF_CHARACTERISTIC Member List

This is the complete list of members for A2LTYPEDEF_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
A2LTYPEDEF_CONVERSION_REF(int startLine) (defined in A2LTYPEDEF_CONVERSION_REF) | A2LTYPEDEF_CONVERSION_REF | protected
A2LTYPEDEF_RECORDLAYOUT_REF(int startLine) (defined in A2LTYPEDEF_RECORDLAYOUT_REF) | A2LTYPEDEF_RECORDLAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Bitmask | A2LTYPEDEF_CHARACTERISTIC |
ByteOrder | A2LTYPEDEF_CONVERSION_REF |
ChangedType | A2LNODE |
CharType | A2LTYPEDEF_CHARACTERISTIC |
Childs | A2LNODE |
Conversion | A2LTYPEDEF_CONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
Discrete | A2LTYPEDEF_CHARACTERISTIC |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
Encoding | A2LTYPEDEF_CHARACTERISTIC |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LTYPEDEF_CONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
LowerLimit | A2LTYPEDEF_CONVERSION_REF |
LowerLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |
MatrixDim | A2LTYPEDEF_CHARACTERISTIC |
MaxDiff | A2LTYPEDEF_RECORDLAYOUT_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Number | A2LTYPEDEF_CHARACTERISTIC |
Parent | A2LNODE |
PhysUnit | A2LTYPEDEF_CONVERSION_REF |
RecordLayout | A2LTYPEDEF_RECORDLAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LTYPEDEF_RECORDLAYOUT_REF |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit | A2LTYPEDEF_CONVERSION_REF |
UpperLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |


ASAP2Library interface: A2LTYPEDEF_CONVERSION_REF Class Reference

  • ASAP2
  • A2LTYPEDEF_CONVERSION_REF
Protected Member Functions | Properties | List of all members
A2LTYPEDEF_CONVERSION_REF Class Reference

Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method. More...

Protected Member Functions

A2LTYPEDEF_CONVERSION_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

BYTEORDER_TYPE | ByteOrder [getset]
see A2LCONVERSION_REF.ByteOrder.
string | Conversion [getset]
see A2LCONVERSION_REF.Conversion.
string | Format [getset]
see A2LCONVERSION_REF.Format.
double | LowerLimit [getset]
see A2LCONVERSION_REF.LowerLimit.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit [getset]
see A2LCONVERSION_REF.UpperLimit.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method.


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_CONVERSION_REF
A2LTYPEDEF_CONVERSION_REF Member List

This is the complete list of members for A2LTYPEDEF_CONVERSION_REF, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
A2LTYPEDEF_CONVERSION_REF(int startLine) (defined in A2LTYPEDEF_CONVERSION_REF) | A2LTYPEDEF_CONVERSION_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ByteOrder | A2LTYPEDEF_CONVERSION_REF |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LTYPEDEF_CONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LTYPEDEF_CONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
LowerLimit | A2LTYPEDEF_CONVERSION_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PhysUnit | A2LTYPEDEF_CONVERSION_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit | A2LTYPEDEF_CONVERSION_REF |


ASAP2Library interface: A2LTYPEDEF_MEASUREMENT Class Reference

  • ASAP2
  • A2LTYPEDEF_MEASUREMENT
Properties | List of all members
A2LTYPEDEF_MEASUREMENT Class Reference

see ASAP2 specification More...

Properties

double | Accuracy [getset]
see A2LMEASUREMENT.Accuracy.
ADDR_TYPE | AddrType [getset]
see A2LMEASUREMENT.AddrType.
ulong | BitMask = ulong.MaxValue [getset]
see A2LMEASUREMENT.BitMask.
DATA_TYPE | DataType [getset]
see A2LMEASUREMENT.DataType.
bool | Discrete [getset]
see A2LMEASUREMENT.Discrete.
ulong | ErrorMask [getset]
see A2LMEASUREMENT.ErrorMask.
INDEX_MODE | Layout [getset]
see A2LMEASUREMENT.Layout.
int[] | MatrixDim [getset]
see A2LMEASUREMENT.MatrixDim.
int | Resolution = 1 [getset]
see A2LMEASUREMENT.Resolution.
- Properties inherited from A2LTYPEDEF_CONVERSION_REF
BYTEORDER_TYPE | ByteOrder [getset]
see A2LCONVERSION_REF.ByteOrder.
string | Conversion [getset]
see A2LCONVERSION_REF.Conversion.
string | Format [getset]
see A2LCONVERSION_REF.Format.
double | LowerLimit [getset]
see A2LCONVERSION_REF.LowerLimit.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit [getset]
see A2LCONVERSION_REF.UpperLimit.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LTYPEDEF_CONVERSION_REF
A2LTYPEDEF_CONVERSION_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_MEASUREMENT
A2LTYPEDEF_MEASUREMENT Member List

This is the complete list of members for A2LTYPEDEF_MEASUREMENT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
A2LTYPEDEF_CONVERSION_REF(int startLine) (defined in A2LTYPEDEF_CONVERSION_REF) | A2LTYPEDEF_CONVERSION_REF | protected
Accuracy | A2LTYPEDEF_MEASUREMENT |
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddrType | A2LTYPEDEF_MEASUREMENT |
BitMask | A2LTYPEDEF_MEASUREMENT |
ByteOrder | A2LTYPEDEF_CONVERSION_REF |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LTYPEDEF_CONVERSION_REF |
DataType | A2LTYPEDEF_MEASUREMENT |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
Discrete | A2LTYPEDEF_MEASUREMENT |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
ErrorMask | A2LTYPEDEF_MEASUREMENT |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LTYPEDEF_CONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
Layout | A2LTYPEDEF_MEASUREMENT |
LowerLimit | A2LTYPEDEF_CONVERSION_REF |
MatrixDim | A2LTYPEDEF_MEASUREMENT |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PhysUnit | A2LTYPEDEF_CONVERSION_REF |
Resolution | A2LTYPEDEF_MEASUREMENT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit | A2LTYPEDEF_CONVERSION_REF |


ASAP2Library interface: A2LTYPEDEF_RECORDLAYOUT_REF Class Reference

  • ASAP2
  • A2LTYPEDEF_RECORDLAYOUT_REF
Protected Member Functions | Properties | List of all members
A2LTYPEDEF_RECORDLAYOUT_REF Class Reference

Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT. More...

Protected Member Functions

A2LTYPEDEF_RECORDLAYOUT_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF_CONVERSION_REF
A2LTYPEDEF_CONVERSION_REF (int startLine)
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

double | LowerLimitEx [getset]
see A2LRECORD_LAYOUT_REF.LowerLimitEx.
double | MaxDiff [getset]
see A2LRECORD_LAYOUT_REF.MaxDiff.
string | RecordLayout [getset]
see A2LRECORD_LAYOUT_REF.RecordLayout.
double | StepSize = double.NaN [getset]
see A2LRECORD_LAYOUT_REF.StepSize.
double | UpperLimitEx [getset]
see A2LRECORD_LAYOUT_REF.UpperLimitEx.
- Properties inherited from A2LTYPEDEF_CONVERSION_REF
BYTEORDER_TYPE | ByteOrder [getset]
see A2LCONVERSION_REF.ByteOrder.
string | Conversion [getset]
see A2LCONVERSION_REF.Conversion.
string | Format [getset]
see A2LCONVERSION_REF.Format.
double | LowerLimit [getset]
see A2LCONVERSION_REF.LowerLimit.
string | PhysUnit [getset]
see A2LCONVERSION_REF.PhysUnit.
double | UpperLimit [getset]
see A2LCONVERSION_REF.UpperLimit.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT.

These derived classes are:

  • A2LTYPEDEF_CHARACTERISTIC
  • A2LTYPEDEF_AXIS


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_RECORDLAYOUT_REF
A2LTYPEDEF_RECORDLAYOUT_REF Member List

This is the complete list of members for A2LTYPEDEF_RECORDLAYOUT_REF, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
A2LTYPEDEF_CONVERSION_REF(int startLine) (defined in A2LTYPEDEF_CONVERSION_REF) | A2LTYPEDEF_CONVERSION_REF | protected
A2LTYPEDEF_RECORDLAYOUT_REF(int startLine) (defined in A2LTYPEDEF_RECORDLAYOUT_REF) | A2LTYPEDEF_RECORDLAYOUT_REF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ByteOrder | A2LTYPEDEF_CONVERSION_REF |
ChangedType | A2LNODE |
Childs | A2LNODE |
Conversion | A2LTYPEDEF_CONVERSION_REF |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Format | A2LTYPEDEF_CONVERSION_REF |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
LowerLimit | A2LTYPEDEF_CONVERSION_REF |
LowerLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |
MaxDiff | A2LTYPEDEF_RECORDLAYOUT_REF |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
PhysUnit | A2LTYPEDEF_CONVERSION_REF |
RecordLayout | A2LTYPEDEF_RECORDLAYOUT_REF |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
StepSize | A2LTYPEDEF_RECORDLAYOUT_REF |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UpperLimit | A2LTYPEDEF_CONVERSION_REF |
UpperLimitEx | A2LTYPEDEF_RECORDLAYOUT_REF |


ASAP2Library interface: A2LTYPEDEF_STRUCTURE Class Reference

  • ASAP2
  • A2LTYPEDEF_STRUCTURE
Properties | List of all members
A2LTYPEDEF_STRUCTURE Class Reference

see ASAP2 specification More...

Properties

bool | ConsistentExchange [getset]
string | SymbolTypeLink [getset]
Name of the symbol type link within the corresponding linker map file.
- Properties inherited from A2LTYPEDEF_BLOB
ADDR_TYPE | AddrType [getset]
uint | Size [getset]
Gets or sets the size of the adjustable object in the emulation memory.
- Properties inherited from A2LTYPEDEF
string | Description [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Public Member Functions inherited from A2LTYPEDEF
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
sealed override IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing A2LTYPEDEFs. More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LTYPEDEF
A2LTYPEDEF (int startLine)
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LTYPEDEF_STRUCTURE
A2LTYPEDEF_STRUCTURE Member List

This is the complete list of members for A2LTYPEDEF_STRUCTURE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LTYPEDEF(int startLine) (defined in A2LTYPEDEF) | A2LTYPEDEF | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
AddrType (defined in A2LTYPEDEF_BLOB) | A2LTYPEDEF_BLOB |
ChangedType | A2LNODE |
Childs | A2LNODE |
ConsistentExchange (defined in A2LTYPEDEF_STRUCTURE) | A2LTYPEDEF_STRUCTURE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LTYPEDEF) | A2LTYPEDEF |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LTYPEDEF |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LTYPEDEF | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
Size | A2LTYPEDEF_BLOB |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
SymbolTypeLink | A2LTYPEDEF_STRUCTURE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LUNIT Class Reference

  • ASAP2
  • A2LUNIT
Public Member Functions | Properties | List of all members
A2LUNIT Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

string | Description [getset]
string | Display [getset]
string | RefUnit [getset]
int[] | SIExponents [getset]
Specification of the seven base dimensions required to define an extended SI unit: More...
double[] | UnitConversion [getset]
Gradient ([0]) and Offset ([1]) of the linear relationship between two measurement units: f(x) = gradient * x + offset. More...
UNIT_TYPE | UnitType [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.

Property Documentation

◆ SIExponents

int [] SIExponents
getset

Specification of the seven base dimensions required to define an extended SI unit:

  • [0]: Length - exponent of the base dimension length with unit metre
  • [1]: Mass - exponent of the base dimension mass with unit kilogram
  • [2]: Time - exponent of the base dimension time with unit second
  • [3]: ElectricCurrent - exponent of the base dimension electric current with unit ampere
  • [4]: Temperature - exponent of the base dimension thermodynamic temperature with unit kelvin
  • [5]: AmountOfSubstance - exponent of the base dimension amount of substance with unit mole
  • [6]: LuminousIntensity - exponent of the base dimension luminous intensity with unit candela

◆ UnitConversion

double [] UnitConversion
getset

Gradient ([0]) and Offset ([1]) of the linear relationship between two measurement units: f(x) = gradient * x + offset.

Specification of the linear relationship between two measurement units given by describing the conversion from the referenced unit to the derived unit:

derived_unit = f(referenced_unit)

The referenced measurement unit had to be specified with parameter REF_UNIT.


ASAP2Library interface: Member List

  • ASAP2
  • A2LUNIT
A2LUNIT Member List

This is the complete list of members for A2LUNIT, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LUNIT) | A2LUNIT |
Display (defined in A2LUNIT) | A2LUNIT |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LUNIT |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefUnit (defined in A2LUNIT) | A2LUNIT |
SIExponents | A2LUNIT |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
UnitConversion | A2LUNIT |
UnitType (defined in A2LUNIT) | A2LUNIT |


ASAP2Library interface: A2LUNSUPPORTEDNODE Class Reference

  • ASAP2
  • A2LUNSUPPORTEDNODE
Protected Member Functions | Properties | List of all members
A2LUNSUPPORTEDNODE Class Reference

Node type to store unsupported objects. More...

Protected Member Functions

A2LUNSUPPORTEDNODE (int startLine)
Creates a new instance of A2LUNSUPPORTEDNODE with the specified parameter. More...
virtual void | setContent (A2LParser parser, ref List< string > parameterList, int startIndex, StringBuilder content)
Try to recognize additional IF Data types. More...
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...

Properties

string | Content [getset]
Represents the original content from the ASAP2 file as a string. More...
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

Node type to store unsupported objects.

  • This type is used whenever an unsupported object is recognized (e.g with a newer specification as 1.7).
  • A basically unsupported node is A2ML.

Constructor & Destructor Documentation

◆ A2LUNSUPPORTEDNODE()

A2LUNSUPPORTEDNODE ( int startLine )
protected

Creates a new instance of A2LUNSUPPORTEDNODE with the specified parameter.

Parameters
startLine The starting line

Member Function Documentation

◆ setContent()

virtual void setContent | ( | A2LParser | parser,
 |  | ref List< string > | parameterList,
 |  | int | startIndex,
 |  | StringBuilder | content
 | ) |  |
protectedvirtual

Try to recognize additional IF Data types.

Possibly changes the current instance with a recognized IF_DATA instance in the model.

Parameters
parser | The parser object for notifiying messages
parameterList | The parameter list
startIndex | The index into the parameter list to start from
content | Represents the original content from the ASAP2 file as a string.

Property Documentation

◆ Content

string Content
getset

Represents the original content from the ASAP2 file as a string.

The XML Serialzer does not export this property.


ASAP2Library interface: Member List

  • ASAP2
  • A2LUNSUPPORTEDNODE
A2LUNSUPPORTEDNODE Member List

This is the complete list of members for A2LUNSUPPORTEDNODE, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
A2LUNSUPPORTEDNODE(int startLine) | A2LUNSUPPORTEDNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
Content | A2LUNSUPPORTEDNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
setContent(A2LParser parser, ref List< string > parameterList, int startIndex, StringBuilder content) | A2LUNSUPPORTEDNODE | protectedvirtual
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LUSER_RIGHTS Class Reference

  • ASAP2
  • A2LUSER_RIGHTS
Properties | List of all members
A2LUSER_RIGHTS Class Reference

see ASAP2 specification More...

Properties

bool | ReadOnly [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LUSER_RIGHTS
A2LUSER_RIGHTS Member List

This is the complete list of members for A2LUSER_RIGHTS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReadOnly (defined in A2LUSER_RIGHTS) | A2LUSER_RIGHTS |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LVAR_ADDRESS Class Reference

  • ASAP2
  • A2LVAR_ADDRESS
Properties | List of all members
A2LVAR_ADDRESS Class Reference

see ASAP2 specification More...

Properties

List< uint > | Addresses [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LVAR_ADDRESS
A2LVAR_ADDRESS Member List

This is the complete list of members for A2LVAR_ADDRESS, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
Addresses (defined in A2LVAR_ADDRESS) | A2LVAR_ADDRESS |
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LVAR_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LVAR_CHARACTERISTIC
Properties | List of all members
A2LVAR_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Properties

List< string > | CriterionValues [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LVAR_CHARACTERISTIC
A2LVAR_CHARACTERISTIC Member List

This is the complete list of members for A2LVAR_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CriterionValues (defined in A2LVAR_CHARACTERISTIC) | A2LVAR_CHARACTERISTIC |
deleteFromModel(A2LNODE node) | A2LNODE | static
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNAMEDNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |


ASAP2Library interface: A2LVAR_CRITERION Class Reference

  • ASAP2
  • A2LVAR_CRITERION
Public Member Functions | Properties | List of all members
A2LVAR_CRITERION Class Reference

see ASAP2 specification More...

Public Member Functions

string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNAMEDNODE
override string | ToString ()
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...

Properties

List< string > | CriterionValues [getset]
string | Description [getset]
A2LMEASUREMENT | RefVarMeasurement [get]
Gets the direct reference to the corresponding compu method.
A2LCHARACTERISTIC | RefVarSelectionCharacteristic [get]
Gets the direct reference to the corresponding Var Selection characteristic.
string | VarMeasurement [getset]
string | VarSelectionCharacteristic [getset]
- Properties inherited from A2LNAMEDNODE
virtual string | DisplayName [getset]
override string | Name [getset]
Gets the name of the node. More...
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Additional Inherited Members

- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNAMEDNODE
A2LNAMEDNODE (int startLine)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
A2LNAMEDNODE (int startLine, string mA2MLType)
Initialises a new instance of A2LNAMEDNODE with the specified parameters. More...
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implements IA2LDescription.


ASAP2Library interface: Member List

  • ASAP2
  • A2LVAR_CRITERION
A2LVAR_CRITERION Member List

This is the complete list of members for A2LVAR_CRITERION, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNAMEDNODE(int startLine) | A2LNAMEDNODE | protected
A2LNAMEDNODE(int startLine, string mA2MLType) | A2LNAMEDNODE | protected
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
CriterionValues (defined in A2LVAR_CRITERION) | A2LVAR_CRITERION |
deleteFromModel(A2LNODE node) | A2LNODE | static
Description (defined in A2LVAR_CRITERION) | A2LVAR_CRITERION |
DisplayName (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.DisplayName | IA2LDescription |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LVAR_CRITERION |
jnsoft::ASAP2::A2LNAMEDNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNAMEDNODE.Name | A2LNAMEDNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
RefVarMeasurement | A2LVAR_CRITERION |
RefVarSelectionCharacteristic | A2LVAR_CRITERION |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
ToString() (defined in A2LNAMEDNODE) | A2LNAMEDNODE |
Type | A2LNODE |
VarMeasurement (defined in A2LVAR_CRITERION) | A2LVAR_CRITERION |
VarSelectionCharacteristic (defined in A2LVAR_CRITERION) | A2LVAR_CRITERION |


ASAP2Library interface: A2LVAR_FORBIDDEN_COMB Class Reference

  • ASAP2
  • A2LVAR_FORBIDDEN_COMB
Properties | List of all members
A2LVAR_FORBIDDEN_COMB Class Reference

see ASAP2 specification More...

Properties

Dictionary< string, string > | ForbiddenDict = new Dictionary<string, string>() [get]
Dictionary of forbidden combinations (key = CriterionName, Value = CriterionValue).
DictionaryProxy< string, string > | ForbiddenDict_ [getset]
This is just to serialize and deserialize to XML, use the ForbiddenDict property to access.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LVAR_FORBIDDEN_COMB
A2LVAR_FORBIDDEN_COMB Member List

This is the complete list of members for A2LVAR_FORBIDDEN_COMB, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
ForbiddenDict | A2LVAR_FORBIDDEN_COMB |
ForbiddenDict_ | A2LVAR_FORBIDDEN_COMB |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LVARIANT_CODING Class Reference

  • ASAP2
  • A2LVARIANT_CODING
Properties | List of all members
A2LVARIANT_CODING Class Reference

See ASAP2 Specification > v1.6.0 . More...

Properties

VarNamingType | VAR_NAMING [getset]
This keyword defines the format of variant extension (index) of adjustable objects name. The extension is used at MCD to distinguish the different variants of adjustable objects.
string | VAR_SEPARATOR [getset]
This parameter defines the separating symbol of variant extension.
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.

Additional Inherited Members

- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."

Detailed Description

See ASAP2 Specification > v1.6.0 .


ASAP2Library interface: Member List

  • ASAP2
  • A2LVARIANT_CODING
A2LVARIANT_CODING Member List

This is the complete list of members for A2LVARIANT_CODING, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
Name | A2LNODE |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |
VAR_NAMING | A2LVARIANT_CODING |
VAR_SEPARATOR | A2LVARIANT_CODING |


ASAP2Library interface: A2LVIRTUAL Class Reference

  • ASAP2
  • A2LVIRTUAL
List of all members
A2LVIRTUAL Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LVIRTUAL
A2LVIRTUAL Member List

This is the complete list of members for A2LVIRTUAL, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: A2LVIRTUAL_CHARACTERISTIC Class Reference

  • ASAP2
  • A2LVIRTUAL_CHARACTERISTIC
List of all members
A2LVIRTUAL_CHARACTERISTIC Class Reference

see ASAP2 specification More...

Additional Inherited Members

- Public Member Functions inherited from A2LREFERENCE
void | deleteNode (A2LNAMEDNODE node)
Deletes the specified node from the list of references. More...
string | getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...
- Public Member Functions inherited from A2LNODE
void | addChild (A2LNODE childNode, bool setState=true)
Adds a child node to the node. More...
IEnumerable< T > | enumChildNodes< T > ()
Enumerates over all child nodes corresponding to the specified type from the calling instance. More...
A2LNODE | findNode (int line)
Gets the A2LNode covering the specified content line. More...
T | findNode< T > (string name)
Searches for the specified node name starting from the calling instance. More...
T | findNode< T > (string name, StringComparison comparison)
Searches for the specified node name starting from the calling instance. More...
string | getContext (char delimiter)
Gets the context of the node instance up to the root node. More...
T | getNode< T > (bool recursive)
Gets the first node of the specified type found in the underlying childs. More...
int | getNodeDepth ()
Gets the depth of the node within the ASAP2 hierarchy. More...
List< T > | getNodeList< T > (bool recursive=false)
Returns a list of child nodes of the specified type. More...
T | getParent< T > ()
Gets the corresponding parent with the specified type from the current instance. More...
virtual IEnumerable< A2LREFBASE > | getRefFunctions ()
Gets the referencing functions. More...
virtual IEnumerable< A2LNODE > | getRefNodes ()
Gets the referencing nodes. More...
- Static Public Member Functions inherited from A2LNODE
static bool | deleteFromModel (A2LNODE node)
Deletes the specified node from the containing model. More...
static int | sortByAddress (A2LNODE x, A2LNODE y)
Sorts the nodes. More...
static int | sortByAddressAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
static int | sortByTypeAndName (A2LNODE x, A2LNODE y)
Sorts the nodes for output. More...
- Static Public Attributes inherited from A2LNODE
const int | mFilterLine = int.MaxValue - 10
const string | NoCompuMethod = "NO_COMPU_METHOD"
Mark for default conversion
- Protected Member Functions inherited from A2LNODE
A2LNODE (int startLine)
Initialises a new instance of A2LNODE with the specified parameters. More...
string | getDescriptionAndAnnotation (string description, bool addUserObjects, int maxLines)
Creates a description from the specified description and a potential existing annotation. More...
- Static Protected Member Functions inherited from A2LNODE
static void | addMaxText (StringBuilder sb, string text)
Adds a mximum of 1024 characters to the specified string builder. More...
static void | getCompuMethod (IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod)
Gets available compu methods from the compu method dictionary. More...
- Static Protected Attributes inherited from A2LNODE
const string | A2LC_AddrEpk = "ADDR_EPK"
const string | A2LC_ADDRESS = "ADDRESS"
const string | A2LC_ADDRESS_MAPPING_XCP = "ADDRESS_MAPPING_XCP"
const string | A2LC_ADDRESS_TYPE = "ADDRESS_TYPE"
const string | A2LC_ADR_GRAN_BYTE = "ADDRESS_GRANULARITY_BYTE"
const string | A2LC_ADR_GRAN_DWORD = "ADDRESS_GRANULARITY_DWORD"
const string | A2LC_ADR_GRAN_WORD = "ADDRESS_GRANULARITY_WORD"
const string | A2LC_AdrExt = "ADDRESS_EXTENSION"
const string | A2LC_AlByte = "ALIGNMENT_BYTE"
const string | A2LC_AlFloat16 = "ALIGNMENT_FLOAT16_IEEE"
const string | A2LC_AlFloat32 = "ALIGNMENT_FLOAT32_IEEE"
const string | A2LC_AlFloat64 = "ALIGNMENT_FLOAT64_IEEE"
const string | A2LC_AlInt64 = "ALIGNMENT_INT64"
const string | A2LC_AlLong = "ALIGNMENT_LONG"
const string | A2LC_ALT_SAMPLE_COUNT = "ALT_SAMPLE_COUNT"
const string | A2LC_ALTERNATE_SETTING_NO = "ALTERNATE_SETTING_NO"
const string | A2LC_AlWord = "ALIGNMENT_WORD"
const string | A2LC_AR_PROTOTYPE_OF = "AR_PROTOTYPE_OF"
const string | A2LC_ASAP1B_CCP = "ASAP1B_CCP"
const string | A2LC_ASAP1B_KWP2000 = "ASAP1B_KWP2000"
const string | A2LC_ASYNCH_FULL_DUPLEX_MODE = "ASYNCH_FULL_DUPLEX_MODE"
const string | A2LC_AUTOSAR_SINGLE_POINTERED = "AUTOSAR_SINGLE_POINTERED"
const string | A2LC_AxisPtsRef = "AXIS_PTS_REF"
const string | A2LC_BAUD_DEF = "BAUD_DEF"
const string | A2LC_BAUDRATE = "BAUDRATE"
const string | A2LC_BD_PARA = "BD_PARA"
const string | A2LC_BIT_STIM_SUPPORTED = "BIT_STIM_SUPPORTED"
const string | A2LC_BitMask = "BIT_MASK"
const string | A2LC_BTL_CYCLES = "BTL_CYCLES"
const string | A2LC_ByteOrder = "BYTE_ORDER"
const string | A2LC_CalAccess = "CALIBRATION_ACCESS"
const string | A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE = "CAN_FD_DATA_TRANSFER_BAUDRATE"
const string | A2LC_CAN_ID_BROADCAST = "CAN_ID_BROADCAST"
const string | A2LC_CAN_ID_FIXED = "CAN_ID_FIXED"
const string | A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST = "CAN_ID_GET_DAQ_CLOCK_MULTICAST"
const string | A2LC_CAN_ID_MASTER = "CAN_ID_MASTER"
const string | A2LC_CAN_ID_MASTER_INCREMENTAL = "CAN_ID_MASTER_INCREMENTAL"
const string | A2LC_CAN_ID_SLAVE = "CAN_ID_SLAVE"
const string | A2LC_CAN_ID_VARIABLE = "CAN_ID_VARIABLE"
const string | A2LC_Coeffs = "COEFFS"
const string | A2LC_CoeffsLinear = "COEFFS_LINEAR"
const string | A2LC_COMM_MODE_SUPPORTED = "COMMUNICATION_MODE_SUPPORTED"
const string | A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER = "COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER"
const string | A2LC_CompuTabRef = "COMPU_TAB_REF"
const string | A2LC_CONSISTENCY = "CONSISTENCY"
const string | A2LC_CONSISTENT_EXCHANGE = "CONSISTENT_EXCHANGE"
const string | A2LC_CONVERSION = "CONVERSION"
const string | A2LC_COPY_FRAME = "COPY_FRAME"
const string | A2LC_COPY_PARA = "COPY_PARA"
const string | A2LC_CORE_LOAD_MAX_TOTAL = "CORE_LOAD_MAX_TOTAL"
const string | A2LC_CP_ADDRESS_UPDATE = "CANAPE_ADDRESS_UPDATE"
const string | A2LC_CP_EXT = "CANAPE_EXT"
const string | A2LC_CPU_LOAD_MAX = "CPU_LOAD_MAX"
const string | A2LC_CPU_LOAD_MAX_TOTAL = "CPU_LOAD_MAX_TOTAL"
const string | A2LC_CpuType = "CPU_TYPE"
const string | A2LC_CurveAxisRef = "CURVE_AXIS_REF"
const string | A2LC_Customer = "CUSTOMER"
const string | A2LC_CustomerNo = "CUSTOMER_NO"
const string | A2LC_DAQ_ALTERNATING_SUPPORTED = "DAQ_ALTERNATING_SUPPORTED"
const string | A2LC_DAQ_LIST_TYPE = "DAQ_LIST_TYPE"
const string | A2LC_DAQ_MODE = "DAQ_MODE"
const string | A2LC_DAQ_TIMESTAMPS_RELATE_TO = "DAQ_TIMESTAMPS_RELATE_TO"
const string | A2LC_DATA_ACCESS = "DATA_ACCESS"
const string | A2LC_DATA_SERAM = "SERAM"
const string | A2LC_DataSize = "DATA_SIZE"
const string | A2LC_DEFAULT_PAGE_NUMBER = "DEFAULT_PAGE_NUMBER"
const string | A2LC_DefaultValue = "DEFAULT_VALUE"
const string | A2LC_DefaultValueNum = "DEFAULT_VALUE_NUMERIC"
const string | A2LC_Deposit = "DEPOSIT"
const string | A2LC_Discrete = "DISCRETE"
const string | A2LC_DISPLAY = "DISPLAY"
const string | A2LC_DisplayId = "DISPLAY_IDENTIFIER"
const string | A2LC_DTO_CTR_DAQ_MODE = "DTO_CTR_DAQ_MODE"
const string | A2LC_DTO_CTR_DAQ_MODE_FIXED = A2LC_DTO_CTR_DAQ_MODE + "_FIXED"
const string | A2LC_DTO_CTR_FIELD_SUPPORTED = "DTO_CTR_FIELD_SUPPORTED"
const string | A2LC_DTO_CTR_STIM_MODE = "DTO_CTR_STIM_MODE"
const string | A2LC_DTO_CTR_STIM_MODE_FIXED = A2LC_DTO_CTR_STIM_MODE + "_FIXED"
const string | A2LC_Ecu = "ECU"
const string | A2LC_ECU_CAL_OFFSET = "ECU_CALIBRATION_OFFSET"
const string | A2LC_EcuAdr = "ECU_ADDRESS"
const string | A2LC_EcuAdrExt = "ECU_" + A2LC_AdrExt
const string | A2LC_EcuCalOffs = "ECU_CALIBRATION_OFFSET"
const string | A2LC_ENCODING = "ENCODING"
const string | A2LC_Epk = "EPK"
const string | A2LC_EPK_ADDRESS = "EPK_ADDRESS"
const string | A2LC_ErrorMask = "ERROR_MASK"
const string | A2LC_ESCAPE_CODE_PARA_GET = "ESCAPE_CODE_PARA_GET"
const string | A2LC_ESCAPE_CODE_PARA_SET = "ESCAPE_CODE_PARA_SET"
const string | A2LC_EVENT = "EVENT"
const string | A2LC_EVENT_COUNTER_PRESENT = "EVENT_COUNTER_PRESENT"
const string | A2LC_EVENT_FIXED = "EVENT_FIXED"
const string | A2LC_ExLimits = "EXTENDED_LIMITS"
const string | A2LC_EXTERNAL_FUNCTION = "EXTERNAL_FUNCTION"
const string | A2LC_FIRST = "FIRST"
const string | A2LC_FIRST_PID = "FIRST_PID"
const string | A2LC_FixAxisPar = "FIX_AXIS_PAR"
const string | A2LC_FixAxisParDist = "FIX_AXIS_PAR_DIST"
const string | A2LC_FIXED = "FIXED"
const string | A2LC_FIXED_EVENT_LIST = "FIXED_EVENT_LIST"
const string | A2LC_FLASH_SECTION = "FLASH_SECTION"
const string | A2LC_Format = "FORMAT"
const string | A2LC_FormulaInv = "FORMULA_INV"
const string | A2LC_FREEZE_SUPPORTED = "FREEZE_SUPPORTED"
const string | A2LC_GuardRails = "GUARD_RAILS"
const string | A2LC_HEADER_LEN_ = "HEADER_LEN_"
const string | A2LC_HOST_NAME = "HOST_NAME"
const string | A2LC_InCircuit2 = "InCircuit2"
const string | A2LC_INPUT_QUANTITY = "INPUT_QUANTITY"
const string | A2LC_INTERFACE_STRING_DESCRIPTOR = "INTERFACE_STRING_DESCRIPTOR"
const string | A2LC_IPV6 = "IPV6"
const string | A2LC_KLINE = "K_LINE"
const string | A2LC_LAST = "LAST"
const string | A2LC_Layout = "LAYOUT"
const string | A2LC_LENGTH = "LENGTH"
const string | A2LC_LIMITS = "LIMITS"
const string | A2LC_LINK_MAP = "LINK_MAP"
const string | A2LC_MatrixDim = "MATRIX_DIM"
const string | A2LC_MAX_BIT_RATE = "MAX_BIT_RATE"
const string | A2LC_MAX_BUS_LOAD = "MAX_BUS_LOAD"
const string | A2LC_MAX_DAQ_TOTAL = "MAX_DAQ_TOTAL"
const string | A2LC_MAX_DLC = "MAX_DLC"
const string | A2LC_MAX_DLC_REQUIRED = "MAX_DLC_REQUIRED"
const string | A2LC_MAX_DTO_STIM = "MAX_DTO_STIM"
const string | A2LC_MAX_ODT = "MAX_ODT"
const string | A2LC_MAX_ODT_DAQ_TOTAL = "MAX_ODT_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES = "MAX_ODT_ENTRIES"
const string | A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL = "MAX_ODT_ENTRIES_DAQ_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_STIM_TOTAL = "MAX_ODT_ENTRIES_STIM_TOTAL"
const string | A2LC_MAX_ODT_ENTRIES_TOTAL = "MAX_ODT_ENTRIES_TOTAL"
const string | A2LC_MAX_ODT_STIM_TOTAL = "MAX_ODT_STIM_TOTAL"
const string | A2LC_MAX_ODT_TOTAL = "MAX_ODT_TOTAL"
const string | A2LC_MaxGrad = "MAX_GRAD"
const string | A2LC_MaxRefresh = "MAX_REFRESH"
const string | A2LC_MEASUREMENT_SPLIT_ALLOWED = "MEASUREMENT_SPLIT_ALLOWED"
const string | A2LC_MIN_ST_STIM = "MIN_ST_STIM"
const string | A2LC_ModelLink = "MODEL_LINK"
const string | A2LC_Monotony = "MONOTONY"
const string | A2LC_MSB_FIRST = "BYTE_ORDER_MSB_FIRST"
const string | A2LC_MSB_LAST = "BYTE_ORDER_MSB_LAST"
const string | A2LC_MTA_BLOCK_SIZE_ALIGN = "MTA_BLOCK_SIZE_ALIGN"
const string | A2LC_NETWORK_LIMITS = "NETWORK_LIMITS"
const string | A2LC_NoOfIFs = "NO_OF_INTERFACES"
const string | A2LC_Number = "NUMBER"
const string | A2LC_ODT_ENTRY = "ODT_ENTRY"
const string | A2LC_OPTIONAL_CMD = "OPTIONAL_CMD"
const string | A2LC_OPTIONAL_TL_SUBCMD = "OPTIONAL_TL_SUBCMD"
const string | A2LC_ORIGINAL_POINTER_TABLE = "ORIGINAL_POINTER_TABLE"
const string | A2LC_PACKED_MODE_SUPPORTED = "DAQ_PACKED_MODE_SUPPORTED"
const string | A2LC_PAGE_CODE = "PAGE_CODE"
const string | A2LC_PARITY_ = "PARITY_"
const string | A2LC_PGM_VERIFY = "PGM_VERIFY"
const string | A2LC_PGMMODE_ABS = "PGM_MODE_ABSOLUTE"
const string | A2LC_PGMMODE_ABS_FUNC = "PGM_MODE_ABSOLUTE_AND_FUNCTIONAL"
const string | A2LC_PGMMODE_FUNC = "PGM_MODE_FUNCTIONAL"
const string | A2LC_PhoneNo = "PHONE_NO"
const string | A2LC_PhysUnit = "PHYS_UNIT"
const string | A2LC_PID_OFF_SUPPORTED = "PID_OFF_SUPPORTED"
const string | A2LC_PRESCALER_SUPPORTED = "PRESCALER_SUPPORTED"
const string | A2LC_ProjectNo = "PROJECT_NO"
const string | A2LC_QP_BLOB = "QP_BLOB"
const string | A2LC_RASTER = "RASTER"
const string | A2LC_ReadOnly = "READ_ONLY"
const string | A2LC_ReadWrite = "READ_WRITE"
const string | A2LC_RECOMMENDED_HOST_BUFSIZE = "RECOMMENDED_HOST_BUFSIZE"
const string | A2LC_RefMemSeg = "REF_MEMORY_SEGMENT"
const string | A2LC_RefUnit = "REF_UNIT"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER = "RELATED_EVENT_CHANNEL_NUMBER"
const string | A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED = "RELATED_EVENT_CHANNEL_NUMBER_FIXED"
const string | A2LC_RESUME_SUPPORTED = "RESUME_SUPPORTED"
const string | A2LC_RNC_RESULT = "RNC_RESULT"
const string | A2LC_SAMPLE_POINT = "SAMPLE_POINT"
const string | A2LC_SAMPLE_RATE = "SAMPLE_RATE"
const string | A2LC_SECONDARY_SAMPLE_POINT = "SECONDARY_SAMPLE_POINT"
const string | A2LC_SECURITY_ACCESS = "SECURITY_ACCESS"
const string | A2LC_SIExponents = "SI_EXPONENTS"
const string | A2LC_SignExtend = "SIGN_EXTEND"
const string | A2LC_SJW = "SJW"
const string | A2LC_SK_EXT_FUNC = "SEED_AND_KEY_" + A2LC_EXTERNAL_FUNCTION
const string | A2LC_START_STOP = "START_STOP"
const string | A2LC_STATIC_ADDRESS_OFFSETS = "STATIC_ADDRESS_OFFSETS"
const string | A2LC_STATIC_RECORD_LAYOUT = "STATIC_RECORD_LAYOUT"
const string | A2LC_StatStrRef = "STATUS_STRING_REF"
const string | A2LC_StepSize = "STEP_SIZE"
const string | A2LC_STIM_DTO_CTR_COPY_PRESENT = "STIM_DTO_CTR_COPY_PRESENT"
const string | A2LC_STIMULATION5BAUD = "Stimulation_5Baud"
const string | A2LC_STORE_DAQ_SUPPORTED = "STORE_DAQ_SUPPORTED"
const string | A2LC_Supplier = "SUPPLIER"
const string | A2LC_SymbolLink = "SYMBOL_LINK"
const string | A2LC_SymbolTypeLink = "SYMBOL_TYPE_LINK"
const string | A2LC_SYNC_EDGE = "SYNC_EDGE"
const string | A2LC_SYNCH_FULL_DUPLEX_MODE_ = "SYNCH_FULL_DUPLEX_MODE_"
const string | A2LC_SYNCH_MASTER_SLAVE_MODE_ = "SYNCH_MASTER_SLAVE_MODE_"
const string | A2LC_SysConst = "SYSTEM_CONSTANT"
const string | A2LC_TIME_DEF = "TIME_DEF"
const string | A2LC_TIMESTAMP_FIXED = "TIMESTAMP_FIXED"
const string | A2LC_TRANSCEIVER_DELAY_COMPENSATION = "TRANSCEIVER_DELAY_COMPENSATION"
const string | A2LC_TRANSPORT_LAYER_INSTANCE = "TRANSPORT_LAYER_INSTANCE"
const string | A2LC_UnitConv = "UNIT_CONVERSION"
const string | A2LC_User = "USER"
const string | A2LC_VAR_MEASUREMENT = "VAR_MEASUREMENT"
const string | A2LC_VAR_NAMING = "VAR_NAMING"
const string | A2LC_VAR_SELECTION_CHARACTERISTIC = "VAR_SELECTION_CHARACTERISTIC"
const string | A2LC_VAR_SEPARATOR = "VAR_SEPARATOR"
const string | A2LC_VARIABLE = "VARIABLE"
const string | A2LC_Version = "VERSION"
const string | A2LC_VIRTUAL_CONVERSION = "VIRTUAL_CONVERSION"
const string | A2LC_XCP = "XCP"
const string | A2LC_XCPPLUS = "XCPplus"
const string | mMappedAlignDesc = "The alignments mapped into indizes: BYTE=0, WORD=1, LONG=2, FLOAT32_IEEE=3, FLOAT64_IEEE=4, INT64=5."
const string | mStrHexByteMax = "0xFF"
const string | mStrHexDWordMax = "0xFFFFFFFF"
const string | mStrHexQWordMax = "0xFFFFFFFFFFFFFFFF"
const string | mStrHexQWordMin = "0x0000000000000000"
const string | mStrHexWordMax = "0xFFFF"
const string | mStrWordMax = "65535"
const string | mTrimStr = "..."
- Properties inherited from A2LDEPENDENT_CHARACTERISTIC
string | Formula [getset]
- Properties inherited from A2LREFERENCE
string | Description [get]
string | DisplayName [get]
List< A2LNAMEDNODE > | ReferencedNodes [get]
Gets the list of referenced nodes within the ASAP2 hierarchy.
List< string >? | References [getset]
- Properties inherited from A2LNODE
virtual A2LChangedType? | ChangedType [getset]
Indicates if the node is created or changed within the object model.
List< A2LNODE > | Childs [getset]
Gets or sets the list of (direct) child nodes.
int | EndLine = -1 [getprotected set]
Gets the ending line of the Node within the source file.
virtual bool | IsInstanced [get]
Indicates, if the object is instanced by an A2LINSTANCE.
virtual string | Name [getset]
Gets the name of the node.
A2LNODE | Parent [getprotected set]
The direct parent of the node instance. More...
int | StartLine = -1 [get]
Gets the starting line of the Node within the source file. More...
object | Tag [getset]
Gets or sets the Tag property. More...
A2LType | Type [getset]
Gets the type of the Node.
- Properties inherited from IA2LDescription
string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

see ASAP2 specification


ASAP2Library interface: Member List

  • ASAP2
  • A2LVIRTUAL_CHARACTERISTIC
A2LVIRTUAL_CHARACTERISTIC Member List

This is the complete list of members for A2LVIRTUAL_CHARACTERISTIC, including all inherited members.

A2LC_AddrEpk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_MAPPING_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADDRESS_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_BYTE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_DWORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ADR_GRAN_WORD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlByte (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat16 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat32 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlFloat64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlInt64 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlLong (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALT_SAMPLE_COUNT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ALTERNATE_SETTING_NO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AlWord (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AR_PROTOTYPE_OF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_CCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASAP1B_KWP2000 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ASYNCH_FULL_DUPLEX_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AUTOSAR_SINGLE_POINTERED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_AxisPtsRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUD_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BD_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BIT_STIM_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BitMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_BTL_CYCLES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ByteOrder (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CalAccess (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_FD_DATA_TRANSFER_BAUDRATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_BROADCAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_GET_DAQ_CLOCK_MULTICAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_MASTER_INCREMENTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_SLAVE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CAN_ID_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Coeffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CoeffsLinear (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMM_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CompuTabRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENCY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONSISTENT_EXCHANGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_FRAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_COPY_PARA (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CORE_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_ADDRESS_UPDATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CP_EXT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CPU_LOAD_MAX_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CpuType (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CurveAxisRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Customer (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_CustomerNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_ALTERNATING_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_LIST_TYPE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DAQ_TIMESTAMPS_RELATE_TO (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DATA_SERAM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DataSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DEFAULT_PAGE_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValue (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DefaultValueNum (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Deposit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Discrete (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DISPLAY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DisplayId (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_DAQ_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_FIELD_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_DTO_CTR_STIM_MODE_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Ecu (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ECU_CAL_OFFSET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdr (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuAdrExt (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EcuCalOffs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ENCODING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Epk (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EPK_ADDRESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ErrorMask (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_GET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ESCAPE_CODE_PARA_SET (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_COUNTER_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EVENT_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ExLimits (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_EXTERNAL_FUNCTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIRST_PID (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisPar (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FixAxisParDist (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FIXED_EVENT_LIST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FLASH_SECTION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Format (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FormulaInv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_FREEZE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_GuardRails (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HEADER_LEN_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_HOST_NAME (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_InCircuit2 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INPUT_QUANTITY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_INTERFACE_STRING_DESCRIPTOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_IPV6 (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_KLINE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Layout (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LENGTH (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_LINK_MAP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MatrixDim (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BIT_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_BUS_LOAD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DLC_REQUIRED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_DTO_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_DAQ_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_ENTRIES_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_STIM_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MAX_ODT_TOTAL (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxGrad (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MaxRefresh (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MEASUREMENT_SPLIT_ALLOWED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MIN_ST_STIM (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ModelLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Monotony (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_FIRST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MSB_LAST (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_MTA_BLOCK_SIZE_ALIGN (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NETWORK_LIMITS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_NoOfIFs (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Number (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ODT_ENTRY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_CMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_OPTIONAL_TL_SUBCMD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ORIGINAL_POINTER_TABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PACKED_MODE_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PAGE_CODE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PARITY_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGM_VERIFY (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_ABS_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PGMMODE_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhoneNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PhysUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PID_OFF_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_PRESCALER_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ProjectNo (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_QP_BLOB (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RASTER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadOnly (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_ReadWrite (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RECOMMENDED_HOST_BUFSIZE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefMemSeg (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RefUnit (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RELATED_EVENT_CHANNEL_NUMBER_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RESUME_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_RNC_RESULT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SAMPLE_RATE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECONDARY_SAMPLE_POINT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SECURITY_ACCESS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SIExponents (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SignExtend (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SJW (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SK_EXT_FUNC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_START_STOP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_ADDRESS_OFFSETS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STATIC_RECORD_LAYOUT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StatStrRef (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_StepSize (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIM_DTO_CTR_COPY_PRESENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STIMULATION5BAUD (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_STORE_DAQ_SUPPORTED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Supplier (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SymbolTypeLink (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNC_EDGE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_FULL_DUPLEX_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SYNCH_MASTER_SLAVE_MODE_ (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_SysConst (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIME_DEF (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TIMESTAMP_FIXED (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSCEIVER_DELAY_COMPENSATION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_TRANSPORT_LAYER_INSTANCE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_UnitConv (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_User (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_MEASUREMENT (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_NAMING (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SELECTION_CHARACTERISTIC (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VAR_SEPARATOR (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VARIABLE (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_Version (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_VIRTUAL_CONVERSION (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCP (defined in A2LNODE) | A2LNODE | protectedstatic
A2LC_XCPPLUS (defined in A2LNODE) | A2LNODE | protectedstatic
A2LNODE(int startLine) | A2LNODE | protected
addChild(A2LNODE childNode, bool setState=true) | A2LNODE |
addMaxText(StringBuilder sb, string text) | A2LNODE | protectedstatic
ChangedType | A2LNODE |
Childs | A2LNODE |
deleteFromModel(A2LNODE node) | A2LNODE | static
deleteNode(A2LNAMEDNODE node) | A2LREFERENCE |
Description (defined in A2LREFERENCE) | A2LREFERENCE |
DisplayName (defined in A2LREFERENCE) | A2LREFERENCE |
EndLine | A2LNODE |
enumChildNodes< T >() | A2LNODE |
findNode(int line) | A2LNODE |
findNode< T >(string name) | A2LNODE |
findNode< T >(string name, StringComparison comparison) | A2LNODE |
Formula (defined in A2LDEPENDENT_CHARACTERISTIC) | A2LDEPENDENT_CHARACTERISTIC |
getCompuMethod(IDictionary< string, A2LCOMPU_METHOD > compuMethodDict, string conversionName, out A2LCOMPU_METHOD compuMethod) | A2LNODE | protectedstatic
getContext(char delimiter) | A2LNODE |
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | A2LREFERENCE |
jnsoft::ASAP2::A2LNODE.getDescriptionAndAnnotation(string description, bool addUserObjects, int maxLines) | A2LNODE | protected
getNode< T >(bool recursive) | A2LNODE |
getNodeDepth() | A2LNODE |
getNodeList< T >(bool recursive=false) | A2LNODE |
getParent< T >() | A2LNODE |
getRefFunctions() | A2LNODE | virtual
getRefNodes() | A2LNODE | virtual
IsInstanced | A2LNODE |
mFilterLine (defined in A2LNODE) | A2LNODE | static
mMappedAlignDesc (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexByteMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexDWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexQWordMin (defined in A2LNODE) | A2LNODE | protectedstatic
mStrHexWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mStrWordMax (defined in A2LNODE) | A2LNODE | protectedstatic
mTrimStr (defined in A2LNODE) | A2LNODE | protectedstatic
jnsoft::ASAP2::A2LNODE.Name | A2LNODE |
jnsoft::ASAP2::IA2LDescription.Name | IA2LDescription |
NoCompuMethod | A2LNODE | static
Parent | A2LNODE |
ReferencedNodes | A2LREFERENCE |
References (defined in A2LREFERENCE) | A2LREFERENCE |
sortByAddress(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByAddressAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByName(A2LNODE x, A2LNODE y) | A2LNODE | static
sortByTypeAndName(A2LNODE x, A2LNODE y) | A2LNODE | static
StartLine | A2LNODE |
Tag | A2LNODE |
Type | A2LNODE |


ASAP2Library interface: AdditiveDescriptionEventArgs Class Reference

  • ASAP2
  • AdditiveDescriptionEventArgs
Properties | List of all members
AdditiveDescriptionEventArgs Class Reference

Used to get an additive description for a A2LNode from user code. More...

Properties

string DescriptionAddition [getset]
Add the additive description for the specified node.

Detailed Description

Used to get an additive description for a A2LNode from user code.


ASAP2Library interface: Member List

  • ASAP2
  • AdditiveDescriptionEventArgs
AdditiveDescriptionEventArgs Member List

This is the complete list of members for AdditiveDescriptionEventArgs, including all inherited members.

DescriptionAddition AdditiveDescriptionEventArgs


ASAP2Library interface: DAQMeasurement Class Reference

  • ASAP2
  • DAQMeasurement
Public Member Functions | Public Attributes | List of all members
DAQMeasurement Class Reference

Structure to specify a DAQ configuration for a single measurement. More...

Public Member Functions

DAQMeasurement (A2LMEASUREMENT measurement, int index=0, IList< ushort > desiredEventChannels=null)
Creates a new measurement configuration for the specified measurement. More...

Public Attributes

readonly IList< ushort > | DesiredEventChannels
A list of desired DAQ event channels to measure in Data acquisition.
readonly int | Index
A potential measurement array index. More...
readonly A2LMEASUREMENT | Measurement
A2L defined measurement.

Detailed Description

Structure to specify a DAQ configuration for a single measurement.

Constructor & Destructor Documentation

◆ DAQMeasurement()

DAQMeasurement | ( | A2LMEASUREMENT | measurement,
 |  | int | index = 0,
 |  | IList< ushort > | desiredEventChannels = null
 | ) |  |

Creates a new measurement configuration for the specified measurement.

Parameters
measurement | The A2L measurement
index | A potential measurement array index
desiredEventChannels | A list of desired DAQ event channels

Member Data Documentation

◆ Index

readonly int Index

A potential measurement array index.

Always 0 for non-array measurements.


ASAP2Library interface: Member List

  • ASAP2
  • DAQMeasurement
DAQMeasurement Member List

This is the complete list of members for DAQMeasurement, including all inherited members.

DAQMeasurement(A2LMEASUREMENT measurement, int index=0, IList< ushort > desiredEventChannels=null) | DAQMeasurement
DesiredEventChannels | DAQMeasurement
Index | DAQMeasurement
Measurement | DAQMeasurement


ASAP2Library interface: IA2LDescription Interface Reference

  • ASAP2
  • IA2LDescription
Public Member Functions | Properties | List of all members
IA2LDescription Interface Reference

Interface for nodes containing a description property. More...

Public Member Functions

string getDescriptionAndAnnotation (bool addUserObjects, int maxLines)
Gets the nodes description including a potential available annotation (may be null or empty). More...

Properties

string | Description [get]
Gets the nodes description (may be null or empty).
string | DisplayName [get]
Gets the node's display name.
string | Name [get]
Gets the nodes name.

Detailed Description

Interface for nodes containing a description property.

Member Function Documentation

◆ getDescriptionAndAnnotation()

string getDescriptionAndAnnotation | ( | bool | addUserObjects,
 |  | int | maxLines
 | ) |  |

Gets the nodes description including a potential available annotation (may be null or empty).

Parameters
addUserObjects | true if user objects should be added (if available)
maxLines | The maximum lines the return string may contain
Returns
The string created out of description and annotation

Implemented in A2LPROJECT, A2LMODULE, A2LMOD_PAR, A2LMEMORY_SEGMENT, A2LFRAME, A2LUNIT, A2LAXIS_PTS, A2LCHARACTERISTIC, A2LMEASUREMENT, A2LCOMPU_METHOD, A2LVAR_CRITERION, A2LTYPEDEF, A2LINSTANCE, A2LREFBASE, A2LREFERENCE, A2LADDRESS, and A2LCOMPU_TAB_BASE.


ASAP2Library interface: Member List

  • ASAP2
  • IA2LDescription
IA2LDescription Member List

This is the complete list of members for IA2LDescription, including all inherited members.

Description | IA2LDescription
DisplayName | IA2LDescription
getDescriptionAndAnnotation(bool addUserObjects, int maxLines) | IA2LDescription
Name | IA2LDescription


ASAP2Library interface: IA2LMemory Interface Reference

  • ASAP2
  • IA2LMemory
Public Member Functions | Properties | List of all members
IA2LMemory Interface Reference

Interface to access both types of memory. More...

Public Member Functions

bool | contains (uint address)
Returns a value, if the specified address is contained in the memory segment. More...
string | toUserDescriptrion ()
Builds user readable description. More...

Properties

uint | Address [get]
Gets the memory address.
bool | IsReadOnly [get]
Returns a value indicating if the memory segment is a readonly segment. More...
int[] | Offsets [getset]
Gets the memory offsets.
uint | Size [get]
Gets the memory size.

Detailed Description

Interface to access both types of memory.

Member Function Documentation

◆ contains()

bool contains ( uint address )

Returns a value, if the specified address is contained in the memory segment.

Parameters
address The address to test
Returns
true if the address is contained

◆ toUserDescriptrion()

string toUserDescriptrion ( )

Builds user readable description.

Returns

Property Documentation

◆ IsReadOnly

bool IsReadOnly
get

Returns a value indicating if the memory segment is a readonly segment.

Readonly segments are any code segments not defined as data segments.


ASAP2Library interface: Member List

  • ASAP2
  • IA2LMemory
IA2LMemory Member List

This is the complete list of members for IA2LMemory, including all inherited members.

Address | IA2LMemory
contains(uint address) | IA2LMemory
IsReadOnly | IA2LMemory
Offsets | IA2LMemory
Size | IA2LMemory
toUserDescriptrion() | IA2LMemory


ASAP2Library interface: ICharValue Interface Reference

  • ASAP2
  • ICharValue
Public Member Functions | Properties | List of all members
ICharValue Interface Reference

Interface for accessing a characteristic value representation. More...

Public Member Functions

bool | decrement (IDataFile dataFile, AxisValueType axis, int count, IEnumerable< int > indexes, IList< string > criterionValues=null)
Decrements the xis values of a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified decrement count. More...
bool | decrement (IDataFile dataFile, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
Decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified decrement count. More...
bool | decrement (IDataFile dataFile, int count, IList< string > criterionValues=null)
Decrements a single value. More...
double | getFncValue ()
Gets the first function value of the characteristic as double value. More...
double | getFncValue (int x, int y, int z)
Gets the function value of the characteristic as double value. More...
T | getFncValue< T > ()
Gets the typed function value. More...
IEnumerable< double > | GetFncValuesEnumerator ()
Gets a function values enumerator. More...
bool | increment (IDataFile dataFile, AxisValueType axis, int count, IEnumerable< int > indexes, IList< string > criterionValues=null)
Increments the xis values of a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment count. More...
bool | increment (IDataFile dataFile, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null)
Increments a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count. More...
bool | increment (IDataFile dataFile, int count, IList< string > criterionValues=null)
Increments a single value. More...
void | modifyValue (double newValue, bool treatValueAsPercent, ModifyFuncByValue modifyFunc)
Sets the new value to the characteristic. More...
void | modifyValue (double newValue, bool treatValueAsPercent, ModifyFuncByValue modifyFunc, IEnumerable< int[]> indexes)
Sets the new value to the characteristic. More...
void | modifyValue (ModifyFunc modifyFunc)
Modifies the value with the specified funtion. More...
void | modifyValue (ModifyFunc modifyFunc, IEnumerable< int[]> indexes)
Modifies the value with the specified funtion. More...
void | setFncValue (double value)
Sets the specified function value of the characteristic as double value. More...
void | setFncValue (double value, int x, int y, int z)
Sets the specified function value of the characteristic as double value. More...
string | toSingleValue (bool forceFmt=true)
Gets a string representing a single value of the characteristic. More...
string | toSingleValue (int x, int y, int z, bool forceFmt=true)
Gets a single value string from a multiple value type. More...

Properties

double[][] | AxisValue [getset]
The axis values. More...
A2LRECORD_LAYOUT_REF | Characteristic [getset]
The corresponding characteristic. More...
CHAR_TYPE | CharType [get]
Gets the characteristic type of the value (for A2LAXIS_PTS, CHAR_TYPE.VALBLK is delivered).
int | DecimalCount [getset]
The values decimal count (function value).
int[] | DecimalCountAxis [getset]
The axis decimal counts. More...
string | Unit [getset]
The values unit.
string[] | UnitAxis [getset]
The axis units. More...
object | Value [getset]
The value as an object. More...
ValueObjectFormat | ValueFormat [getset]
Gets or sets the format of the contained values.

Detailed Description

Interface for accessing a characteristic value representation.

Provides methods for

  • adjusting values
  • presenting values
  • copying to the clipboard (standard spreadsheet format)
  • pasting from the clipboard (standard spreadsheet format)

Member Function Documentation

◆ decrement() [1/3]

bool decrement | ( | IDataFile | dataFile,
 |  | AxisValueType | axis,
 |  | int | count,
 |  | IEnumerable< int > | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |

Decrements the xis values of a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified decrement count.

Parameters
dataFile | The datafile to read from
axis | The axis type
count | The count of increments or decrements to do
indexes | List containing the axis indexes
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ decrement() [2/3]

bool decrement | ( | IDataFile | dataFile,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |

Decrements a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ decrement() [3/3]

bool decrement | ( | IDataFile | dataFile,
 |  | int | count,
 |  | IList< string > | criterionValues = null
 | ) |  |

Decrements a single value.

Physical values will be prevented to exceed physical limits

Parameters
dataFile | The datafile to read from
count | Count of decrements to do
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ getFncValue() [1/2]

double getFncValue ( )

Gets the first function value of the characteristic as double value.

For a single value always the one and only.

Returns

◆ getFncValue() [2/2]

double getFncValue | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

Gets the function value of the characteristic as double value.

Parameters
x | The x (column) value
y | The y (row) value
z | The z (cuboid) value
Returns

◆ getFncValue< T >()

T getFncValue< T > ( )

Gets the typed function value.

The type depends on the charactristic's type.

Template Parameters
T
  • double for CHAR_TYPE.VALUE
  • string for CHAR_TYPE_ASCII
  • double[] for CHAR_TYPE.VAL_BLK
  • double[] for CHAR_TYPE.CURVE
  • double[,] for CHAR_TYPE.MAP
  • double[,,] for CHAR_TYPE.CUBOID
  • double[,,,] for CHAR_TYPE.CUBE_4
  • double[,,,,] for CHAR_TYPE.CUBE_5
Returns
The typed function value instance

◆ GetFncValuesEnumerator()

IEnumerable< double > GetFncValuesEnumerator ( )

Gets a function values enumerator.

Returns
An iterator iterating over all function values

Implemented in BaseValue.

◆ increment() [1/3]

bool increment | ( | IDataFile | dataFile,
 |  | AxisValueType | axis,
 |  | int | count,
 |  | IEnumerable< int > | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |

Increments the xis values of a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment count.

Parameters
dataFile | The datafile to read from
axis | The axis type
count | The count of increments or decrements to do
indexes | List containing the axis indexes
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ increment() [2/3]

bool increment | ( | IDataFile | dataFile,
 |  | int | count,
 |  | IEnumerable< int[]> | indexes,
 |  | IList< string > | criterionValues = null
 | ) |  |

Increments a CHAR_TYPE.CURVE, CHAR_TYPE.MAP or CHAR_TYPE.CUBOID value by the specified increment/decrement count.

Parameters
dataFile | The datafile to read from
increment | true for increment, false for decrement
count | The count of increments or decrements to do
indexes | List containing X, Y, Z,... (zero based) positions
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ increment() [3/3]

bool increment | ( | IDataFile | dataFile,
 |  | int | count,
 |  | IList< string > | criterionValues = null
 | ) |  |

Increments a single value.

Physical values will be prevented to exceed physical limits

Parameters
dataFile | The datafile to read from
count | Count of increments to do
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ modifyValue() [1/4]

void modifyValue | ( | double | newValue,
 |  | bool | treatValueAsPercent,
 |  | ModifyFuncByValue | modifyFunc
 | ) |  |

Sets the new value to the characteristic.

Parameters
newValue | A new value to modify with
treatValueAsPercent | true, if the value should be treated as percentage
modifyFunc | The modifying function
indexes | List containing X, Y, Z,... (zero based) positions

◆ modifyValue() [2/4]

void modifyValue | ( | double | newValue,
 |  | bool | treatValueAsPercent,
 |  | ModifyFuncByValue | modifyFunc,
 |  | IEnumerable< int[]> | indexes
 | ) |  |

Sets the new value to the characteristic.

Parameters
newValue | A new value to modify with
treatValueAsPercent | true, if the value should be treated as percentage
modifyFunc | The modifying function
indexes | List containing X, Y, Z,... (zero based) positions

◆ modifyValue() [3/4]

void modifyValue ( ModifyFunc modifyFunc )

Modifies the value with the specified funtion.

Parameters
modifyFunc

◆ modifyValue() [4/4]

void modifyValue | ( | ModifyFunc | modifyFunc,
 |  | IEnumerable< int[]> | indexes
 | ) |  |

Modifies the value with the specified funtion.

Parameters
modifyFunc
indexes List containing X, Y, Z,... (zero based) positions

◆ setFncValue() [1/2]

void setFncValue ( double value )

Sets the specified function value of the characteristic as double value.

For a single value always the one and only.

Parameters
value The new function value

◆ setFncValue() [2/2]

void setFncValue | ( | double | value,
 |  | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

Sets the specified function value of the characteristic as double value.

Parameters
value | The new function value
x | The x (column) value
y | The y (row) value
z | The z (cuboid) value

◆ toSingleValue() [1/2]

string toSingleValue ( bool forceFmt = true )

Gets a string representing a single value of the characteristic.

Parameters
forceFmt false, if values should not be rounded to the value's phsical format
Returns
a string representing the single value or string.Empty if the characteristic's type does not support a single value representation (CHAR_TYPE.CURVE, ...)

◆ toSingleValue() [2/2]

string toSingleValue | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | bool | forceFmt = true
 | ) |  |

Gets a single value string from a multiple value type.

Parameters
x | The x (column), -1 for the x axis value
y | The y (row), -1 for the y axis value
z | The z (cuboid), -1 for the z axis value
forceFmt | false, if values should not be rounded to the value's phsical format
Returns
a string representing the single value
Exceptions
NotSupportedException Thrown, if the type is not a value block, curve, map or cuboid

Property Documentation

◆ AxisValue

double [][] AxisValue
getset

The axis values.

The axis values mapped into indexes: X=0, Y=1, Z=2, _4=3, _5=4.

◆ Characteristic

A2LRECORD_LAYOUT_REF Characteristic
getset

The corresponding characteristic.

Maybe an A2LCHARACTERISTIC or an A2LAXIS_PTS reference.

◆ DecimalCountAxis

int [] DecimalCountAxis
getset

The axis decimal counts.

The axis decimal counts mapped into indexes: X=0, Y=1, Z=2, _4=3, _5=4.

◆ UnitAxis

string [] UnitAxis
getset

The axis units.

The axis units mapped into indexes: X=0, Y=1, Z=2, _4=3, _5=4.

◆ Value

object Value
getset

The value as an object.

The data gets typed according it's implementor.

  • double for CHAR_TYPE.VALUE
  • string for CHAR_TYPE_ASCII
  • double[] for CHAR_TYPE.VAL_BLK
  • double[] for CHAR_TYPE.CURVE
  • double[,] for CHAR_TYPE.MAP
  • double[,,] for CHAR_TYPE.CUBOID
  • double[,,,] for CHAR_TYPE.CUBE_4
  • double[,,,,] for CHAR_TYPE.CUBE_5


ASAP2Library interface: Member List

  • ASAP2
  • ICharValue
ICharValue Member List

This is the complete list of members for ICharValue, including all inherited members.

AxisValue | ICharValue
Characteristic | ICharValue
CharType | ICharValue
DecimalCount | ICharValue
DecimalCountAxis | ICharValue
decrement(IDataFile dataFile, int count, IList< string > criterionValues=null) | ICharValue
decrement(IDataFile dataFile, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) | ICharValue
decrement(IDataFile dataFile, AxisValueType axis, int count, IEnumerable< int > indexes, IList< string > criterionValues=null) | ICharValue
getFncValue() | ICharValue
getFncValue(int x, int y, int z) | ICharValue
getFncValue< T >() | ICharValue
GetFncValuesEnumerator() | ICharValue
increment(IDataFile dataFile, int count, IList< string > criterionValues=null) | ICharValue
increment(IDataFile dataFile, int count, IEnumerable< int[]> indexes, IList< string > criterionValues=null) | ICharValue
increment(IDataFile dataFile, AxisValueType axis, int count, IEnumerable< int > indexes, IList< string > criterionValues=null) | ICharValue
modifyValue(double newValue, bool treatValueAsPercent, ModifyFuncByValue modifyFunc) | ICharValue
modifyValue(double newValue, bool treatValueAsPercent, ModifyFuncByValue modifyFunc, IEnumerable< int[]> indexes) | ICharValue
modifyValue(ModifyFunc modifyFunc) | ICharValue
modifyValue(ModifyFunc modifyFunc, IEnumerable< int[]> indexes) | ICharValue
setFncValue(double value) | ICharValue
setFncValue(double value, int x, int y, int z) | ICharValue
toSingleValue(bool forceFmt=true) | ICharValue
toSingleValue(int x, int y, int z, bool forceFmt=true) | ICharValue
Unit | ICharValue
UnitAxis | ICharValue
Value | ICharValue
ValueFormat | ICharValue


ASAP2Library interface: IDataFile Interface Reference

  • ASAP2
  • IDataFile
Public Member Functions | Properties | List of all members
IDataFile Interface Reference

Interface for reading and writing data files (S19 and HEX) files. More...

Public Member Functions

bool | checkEPK (uint epkAddress, string expectedEPK)
Checks all segments to find the specified EPK string. More...
MemorySegment | findMemSeg (uint address)
Finds the memory segment the specified address is within. More...
void | import (IEnumerable< ICharValue > values)
Imports the specified values into the datafile. More...
void | reLoad ()
Reloads a datafile (if it is based on a valid file in filesystem).
bool | save (string fileName, bool onlyDataSegments=true, int dataBytesPerLine=0)
Saves the data file into the filesystem. More...
bool | setEPK (uint epkAddress, string epkToSet)
Set the EPK to the specified address. More...
void | setSegmentsData (MemorySegmentList segments)
Set segments data from the specified segments. More...

Properties

HashSet< A2LRECORD_LAYOUT_REF > | ChangedValues [get]
Gets the dictionary of changed characteristic values within the file. More...
bool | IsDirty [getset]
Gets a value indicating if the current file is changed in memory.
MemorySegmentList | SegmentList [get]
Gets the memory segment list.
string | SourceFilename [get]
Gets the fully qualified path to the source filename.

Detailed Description

Interface for reading and writing data files (S19 and HEX) files.

How to use the IDataFile interface:

class Program
{
static void Main(string[] args)
{
using (var a2lParser = new A2LParser())
{
// parse specified A2L file
if (!a2lParser.parse(args[0]))
// not an a2l file
return;
// get project
var project = a2lParser.Project;
// get module
var module = project.getNode<A2LMODULE>(false);
// create initial memory segments
var initialSegments = module.createInitialMemorySegments(true);
if (initialSegments == null)
return;
// Load the data file
var dataFile = DataFile.open(args[1], initialSegments);
// Do the EPK check on the file
var modPar = module.getNode<A2LMODPAR>(false);
if (!dataFile.checkEPK(modPar.EPKAddress, modPar.EPK))
// epk check failed
return;
// Required: pin the datafile to the A2L module instance
module.Tag = dataFile;
// Print out any single characteristic value
string templateformatStr = " = {{0:f{0}}}";
foreach (var characteristic in module.enumChildNodes<A2LCHARACTERISTIC>())
{
switch (characteristic.CharType)
{
case CHAR_TYPE.VALUE:
var value = CharacteristicValue.getValue<SingleValue>(characteristic, ValueObjectFormat.Physical);
var sb = new StringBuilder(characteristic.Name.PadRight(30));
// build format string according the values decimal count
string formatStr = string.Format(templateformatStr, value.DecimalCount)+"{1}";
// append value and unit
sb.AppendFormat(formatStr
, (double)value.Value
, string.IsNullOrEmpty(value.Unit)
? string.Empty
: string.Format(" [{0}]", value.Unit)
);
// print string
Console.WriteLine(sb.ToString());
break;
}
}
}
}
}
jnsoft.ASAP2.CHAR_TYPE
CHAR_TYPE
Possible characteristic types
Definition: ASAP2Base.cs:620
jnsoft.Helpers.ValueObjectFormat
ValueObjectFormat
Possible value object formats.
Definition: Helpers.cs:1418

Member Function Documentation

◆ checkEPK()

bool checkEPK | ( | uint | epkAddress,
 |  | string | expectedEPK
 | ) |  |

Checks all segments to find the specified EPK string.

Parameters
epkAddress | The EPK address
expectedEPK | The EPK string to compare to
Returns
true if the specified EPK is found

◆ findMemSeg()

MemorySegment findMemSeg ( uint address )

Finds the memory segment the specified address is within.

Parameters
address The address to find
Returns
The segment instance or null if not found

◆ import()

void import ( IEnumerable< ICharValue > values )

Imports the specified values into the datafile.

May be used e.g from a DCMFile import.

Parameters
values The values to import

◆ save()

bool save | ( | string | fileName,
 |  | bool | onlyDataSegments = true,
 |  | int | dataBytesPerLine = 0
 | ) |  |

Saves the data file into the filesystem.

Converts the memory segments to a certain format (Motorola-S or HEX) and saves it to a file.

Parameters
fileName | The fully qualified path of the data file to store to
onlyDataSegments | true if only data segments should be saved
dataBytesPerLine | Count of written data bytes per line (maybe 8, 16, 32,...)
Returns
true if successful
Exceptions
ArgumentException Thrown if specified arguments are not supported

◆ setEPK()

bool setEPK | ( | uint | epkAddress,
 |  | string | epkToSet
 | ) |  |

Set the EPK to the specified address.

Parameters
epkAddress | The epk address
epkToSet | The EPK string to set
Returns
true if the specified EPK is set

◆ setSegmentsData()

void setSegmentsData ( MemorySegmentList segments )

Set segments data from the specified segments.

  • A segment exists if only if the starting addresses and the length is the same
  • If a segment is not existing in the target, the data will not be added
  • If a segment exists, the specified data will override the data in the target.
Parameters
segments The segments to set data from

Property Documentation

◆ ChangedValues

HashSet<A2LRECORD_LAYOUT_REF> ChangedValues
get

Gets the dictionary of changed characteristic values within the file.

The dictionary contains A2L characteristic label names, which are changed by a jnsoft.ASAP2.Values.CharacteristicValue.SetValue call.

Key is the corresponding A2L instance, the value is not used.


ASAP2Library interface: Member List

  • ASAP2
  • IDataFile
IDataFile Member List

This is the complete list of members for IDataFile, including all inherited members.

ChangedValues | IDataFile
checkEPK(uint epkAddress, string expectedEPK) | IDataFile
findMemSeg(uint address) | IDataFile
import(IEnumerable< ICharValue > values) | IDataFile
IsDirty | IDataFile
reLoad() | IDataFile
save(string fileName, bool onlyDataSegments=true, int dataBytesPerLine=0) | IDataFile
SegmentList | IDataFile
setEPK(uint epkAddress, string epkToSet) | IDataFile
setSegmentsData(MemorySegmentList segments) | IDataFile
SourceFilename | IDataFile


ASAP2Library interface: MemorySegment Class Reference

  • ASAP2
  • MemorySegment
Public Member Functions | Properties | List of all members
MemorySegment Class Reference

Implements the representation of a memory segment of a data file. More...

Public Member Functions

MemorySegment (long address, uint size, MEMORYPRG_TYPE prgType)
Creates a new instance of MemorySegment with the specified size. More...
object | Clone ()
The clone method does a deep copy of the MemorySegment. More...
void | Dispose ()
byte[] | getDataBytes (long address, uint len)
Reads data from the memory segment. More...
double | getUsageInPercent (MemoryRangeList ranges)
Gets the used memory in percent of the segment. More...
long | getUsedBytes (MemoryRangeList ranges)
Gets the count of used bytes in the segment. More...
bool | isMemoryIn (long address, int len)
Checks if data is within the current MemorySegment. More...
void | setDataBytes (byte value)
Fills the memory segment with the specified fillByte. More...
void | setDataBytes (byte[] data, int size)
Copies data to the segment. More...
void | setDataBytes (byte[] data, uint address=0)
Copies data to the segment. More...
void | setDataBytes (int offset, byte[] data)
Copies data to the segment. More...
override string | ToString ()

Properties

long | Address [getset]
Gets the segment base address.
long | BinFileOffset [getset]
Gets a potential offset into the bin file from the segment's Address. More...
byte[] | Data [get]
Gets the data values for the segment.
IDataFile | DataFile [getset]
Gets or sets the owning data file for the segment (may be null).
bool | IsDataSegment [get]
Gets a value indicating if the segment is used as a data segment.
bool | IsInitialized [getset]
Gets a value if the segment is initialized.
MEMORYPRG_TYPE | PrgType [get]
Gets the segment type.
int | Size [get]
Gets the segment size.

Detailed Description

Implements the representation of a memory segment of a data file.

A memory segment may correspond to memory segments defined in an A2L source file (from A2LMEMORY_SEGMENT or A2LMEMORY_LAYOUT instances).

Constructor & Destructor Documentation

◆ MemorySegment()

MemorySegment | ( | long | address,
 |  | uint | size,
 |  | MEMORYPRG_TYPE | prgType
 | ) |  |

Creates a new instance of MemorySegment with the specified size.

  • The complete memory segment data will be initialised by 0xff bytes.
  • The initialisation state of a memory segment will be 'not initialized'.
Parameters
address | The start address of the memory segment
size | The size to initialize
prgType | The memory segment type

Member Function Documentation

◆ Clone()

object Clone ( )

The clone method does a deep copy of the MemorySegment.

Returns
a new instance cloned from the current instance

◆ getDataBytes()

byte[] getDataBytes | ( | long | address,
 |  | uint | len
 | ) |  |

Reads data from the memory segment.

Parameters
address | The (absolute) start address
len | The data length to read from
Returns
The data bytes read from the memory segment
Exceptions
ArgumentOutOfRangeException Thrown if address is not within segment

◆ getUsageInPercent()

double getUsageInPercent ( MemoryRangeList ranges )

Gets the used memory in percent of the segment.

Parameters
ranges The list of memory ranges
Returns
The used memory in percent of the segment.

◆ getUsedBytes()

long getUsedBytes ( MemoryRangeList ranges )

Gets the count of used bytes in the segment.

This algorithm supports:

  • Memory shared by or more characterisrtics
  • More than one segment used by a single characteristic
Parameters
ranges The memory ranges (see A2LMODULE.getMemoryRanges on how to create this list)
Returns
The count of used bytes in the segment.

◆ isMemoryIn()

bool isMemoryIn | ( | long | address,
 |  | int | len
 | ) |  |

Checks if data is within the current MemorySegment.

Parameters
address | The start address
len | The length
Returns
true if data is within the segment

◆ setDataBytes() [1/4]

void setDataBytes ( byte value )

Fills the memory segment with the specified fillByte.

Parameters
value The byte value to fill the memory with

◆ setDataBytes() [2/4]

void setDataBytes | ( | byte[] | data,
 |  | int | size
 | ) |  |

Copies data to the segment.

Only fitting data will be copied, the segment size will not be enhanced.

Parameters
data | Memory segment data
size | The source data size
Exceptions
ArgumentException Thrown if data is null

◆ setDataBytes() [3/4]

void setDataBytes | ( | byte[] | data,
 |  | uint | address = 0
 | ) |  |

Copies data to the segment.

Only fitting data will be copied, the segment size will not be enhanced.

Parameters
address | Absolute address
data | Memory segment data
Exceptions
ArgumentOutOfRangeException | Thrown if startIndex is < 0
ArgumentException | Thrown if data is null

◆ setDataBytes() [4/4]

void setDataBytes | ( | int | offset,
 |  | byte[] | data
 | ) |  |

Copies data to the segment.

Only fitting data will be copied, the segment size will not be enhanced.

Parameters
offset | Offset to the start of the segment
data | Memory segment data
Exceptions
ArgumentOutOfRangeException | Thrown if startIndex is < 0
ArgumentException | Thrown if data is null

Property Documentation

◆ BinFileOffset

long BinFileOffset
getset

Gets a potential offset into the bin file from the segment's Address.

  • This value is set after the segment is filled from reading a bin file.
  • Important only for segments read from a bin file.


ASAP2Library interface: Member List

  • ASAP2
  • MemorySegment
MemorySegment Member List

This is the complete list of members for MemorySegment, including all inherited members.

Address | MemorySegment
BinFileOffset | MemorySegment
Clone() | MemorySegment
Data | MemorySegment
DataFile | MemorySegment
Dispose() (defined in MemorySegment) | MemorySegment
getDataBytes(long address, uint len) | MemorySegment
getUsageInPercent(MemoryRangeList ranges) | MemorySegment
getUsedBytes(MemoryRangeList ranges) | MemorySegment
IsDataSegment | MemorySegment
IsInitialized | MemorySegment
isMemoryIn(long address, int len) | MemorySegment
MemorySegment(long address, uint size, MEMORYPRG_TYPE prgType) | MemorySegment
PrgType | MemorySegment
setDataBytes(byte value) | MemorySegment
setDataBytes(byte[] data, uint address=0) | MemorySegment
setDataBytes(int offset, byte[] data) | MemorySegment
setDataBytes(byte[] data, int size) | MemorySegment
Size | MemorySegment
ToString() (defined in MemorySegment) | MemorySegment


ASAP2Library interface: MemorySegmentList Class Reference

  • ASAP2
  • MemorySegmentList
Public Member Functions | Static Public Member Functions | List of all members
MemorySegmentList Class Reference

Memory segment list type. More...

Public Member Functions

MemorySegmentList ()
Default constructor.
MemorySegmentList (IEnumerable< MemorySegment > list)
Creates a new instance with the specified parameters. More...
object | Clone ()
The clone method does a deep copy of the memory segment list. More...
MemorySegment | findMemSeg (uint address, int len)
Find the corresponding memory segment to the address specified. More...
override string | ToString ()
Builds a string representation for the memory segment list. More...

Static Public Member Functions

static int sortDataSegsToFront (MemorySegment seg1, MemorySegment seg2)
Sorts data segments to the front of the list. More...

Detailed Description

Memory segment list type.

Memory segments may be constructed from a set of A2LMEMORY_SEGMENT or A2LMEMORY_LAYOUT instances defined in the A2L model.

Creating memory segments from a loaded A2L model:

// Creates all memory segments from the a2l information.
MemorySegmentList createEmptyMemorySegments()
{
var modPar = mA2lParser.Project.getNode<A2LMODPAR>(true);
bool filterCodeSegments = !Settings.Default.DataFileLoadAllSegments;
var memSegList = new MemorySegmentList();
// add segments
var segments = modPar.getNodeList<A2LMEMORY_SEGMENT>();
if (segments.Count > 0)
{
for (int i = segments.Count - 1; i >= 0; &ndash;i)
{
var segment = segments[i];
if (segment.PrgType == MEMORYPRG_TYPE.CODE && filterCodeSegments)
// filter code segments
continue;
memSegList.Add(new MemorySegment(segment.Address, segment.Size));
}
}
// add layouts
var layouts = modPar.getNodeList<A2LMEMORY_LAYOUT>();
if (layouts.Count > 0)
{
for (int i = layouts.Count - 1; i >= 0; &ndash;i)
{
var layout = layouts[i];
if (layout.PrgType == PRG_TYPE.PRG_CODE && filterCodeSegments)
// filter code segments
continue;
memSegList.Add(new MemorySegment(layout.Address, layout.Size));
}
}
return memSegList;
}
jnsoft.ASAP2.MemorySegmentList.MemorySegmentList
MemorySegmentList()
Default constructor.
Definition: MemorySegment.cs:530
jnsoft.ASAP2.MEMORYPRG_TYPE
MEMORYPRG_TYPE
see ASAP2 specification
Definition: ASAP2Base.cs:525
jnsoft.ASAP2.PRG_TYPE
PRG_TYPE
Description of the program segments
Definition: ASAP2Base.cs:584

Constructor & Destructor Documentation

◆ MemorySegmentList()

MemorySegmentList ( IEnumerable< MemorySegment > list )

Creates a new instance with the specified parameters.

Parameters
list A list of menmory segments

Member Function Documentation

◆ Clone()

object Clone ( )

The clone method does a deep copy of the memory segment list.

Returns
a new instance cloned from the current instance

◆ findMemSeg()

MemorySegment findMemSeg | ( | uint | address,
 |  | int | len
 | ) |  |

Find the corresponding memory segment to the address specified.

Parameters
address | The memory adress to search the memory segment for
len | The length of the data
Returns
The memory segment found or null if none is available

◆ sortDataSegsToFront()

static int sortDataSegsToFront | ( | MemorySegment | seg1,
 |  | MemorySegment | seg2
 | ) |  |
static

Sorts data segments to the front of the list.

Parameters
seg1 | First segment to compare
seg2 | Second segment to compare
Returns
Sorting algorithm return value

◆ ToString()

override string ToString ( )

Builds a string representation for the memory segment list.

Returns
The instance as a string


ASAP2Library interface: Member List

  • ASAP2
  • MemorySegmentList
MemorySegmentList Member List

This is the complete list of members for MemorySegmentList, including all inherited members.

Clone() | MemorySegmentList |
findMemSeg(uint address, int len) | MemorySegmentList |
MemorySegmentList() | MemorySegmentList |
MemorySegmentList(IEnumerable< MemorySegment > list) | MemorySegmentList |
sortDataSegsToFront(MemorySegment seg1, MemorySegment seg2) | MemorySegmentList | static
ToString() | MemorySegmentList |


ASAP2Library interface: ModelChangedEventArgs Class Reference

  • ASAP2
  • ModelChangedEventArgs
Public Attributes | List of all members
ModelChangedEventArgs Class Reference

Changed model event arguments. More...

Public Attributes

readonly IEnumerable< A2LNODE > | Nodes
Changed nodes
readonly A2LChangedType | Type
Changed type

Detailed Description

Changed model event arguments.


ASAP2Library interface: Member List

  • ASAP2
  • ModelChangedEventArgs
ModelChangedEventArgs Member List

This is the complete list of members for ModelChangedEventArgs, including all inherited members.

Nodes | ModelChangedEventArgs
Type | ModelChangedEventArgs


ASAP2Library interface: NonCompliantException Class Reference

  • ASAP2
  • NonCompliantException
List of all members
NonCompliantException Class Reference

Exception class for non ASAP2 compliant files. More...

Detailed Description

Exception class for non ASAP2 compliant files.

Occurs, if the input file is not ASAP2 compliant and therefore not usable.


ASAP2Library interface: Member List

  • ASAP2
  • NonCompliantException
NonCompliantException Member List

This is the complete list of members for NonCompliantException, including all inherited members.


ASAP2Library interface: WriterException Class Reference

  • ASAP2
  • WriterException
Properties | List of all members
WriterException Class Reference

Exception class representing an ASAP2 Writer exception. More...

Properties

A2LNODE Node [get]
Gets the node which caused the writer exception.

Detailed Description

Exception class representing an ASAP2 Writer exception.

Occurs, if the any exception is caught while writing the ASAP2 file.


ASAP2Library interface: Member List

  • ASAP2
  • WriterException
WriterException Member List

This is the complete list of members for WriterException, including all inherited members.

Node WriterException


ASAP2Library interface: jnsoft.BLF Namespace Reference

  • BLF
Classes | Enumerations
jnsoft.BLF Namespace Reference

Implements the Vector BLF file format reader/writer. More...

Classes

class | AppText
Application text More...
class | AppTextManaged
.NET Application text representation More...
class | BLFFile
BLF file Reader/Writer. More...
class | CANDriverError
CAN driver error More...
class | CANError
CAN Error More...
class | CANErrorExt
CAN Error (extended) More...
class | CANFDManaged
CAN FD message More...
class | CANFDMessage
CAN FD message More...
class | CANFDMessage64
CAN FD 64 message More...
class | CANMessage
CAN message More...
class | CANMessage2
Extended CAN message More...
class | CANStatistic
CAN driver statistic More...
class | Header
Header structure More...
class | LObj
Log object base class More...
class | LogContainer
Log container structure More...
class | ObjBase
Object base class More...
class | RestorePointContainer
Restore Point Container More...
class | RestorePointContainerManaged
.NET Restore Point Container More...
class | SysVariable
System variable More...
class | SysVariableManaged
.NET System variable More...

Enumerations

enum AppId : byte {
Unknown , CANalyzer , CANoe , CANstress ,
CANlog , CANape , CANCaseXLLog , VLConfig ,
Porschelogger = 200 , Caeteclogger , Vectornetworksimulator , Ipetroniklogger ,
RtPk , Piketec , Sparks
}
Application ID
enum CanFd64Flags {
R = 1 << 1 , NERR = R << 1 , HighVoltageWakeup = R << 2 , RRFrame = R << 3 ,
TxAck = R << 5 , TxReq = R << 6 , SRR = R << 8 , R0 = R << 9 ,
R1 = R << 10 , EDL = R << 11 , BRS = R << 12 , ESI = R << 13
}
CAN FD 64 Flags More...
enum | CANFdFlags : byte { EDL = 1 , BRS = EDL << 1 , ESI = EDL << 2 }
CAN FD flags More...
enum CANFlags : byte {
RX , TX , NERR = TX << 5 , WU = TX << 6 ,
RTR = TX << 7
}
CAN message flags More...
enum | ObjectFlagsType : uint { TimeTenMics = 1 , TimeOneNans = TimeTenMics << 1 }
Enumeration for object flags More...
enum ObjectType : uint {
CAN_MESSAGE = 1 , CAN_ERROR , CAN_OVERLOAD , CAN_STATISTIC ,
APP_TRIGGER , ENV_INTEGER , ENV_DOUBLE , ENV_STRING ,
ENV_DATA , LOG_CONTAINER , LIN_MESSAGE , LIN_CRC_ERROR ,
LIN_DLC_INFO , LIN_RCV_ERROR , LIN_SND_ERROR , LIN_SLV_TIMEOUT ,
LIN_SCHED_MODCH , LIN_SYN_ERROR , LIN_BAUDRATE , LIN_SLEEP ,
LIN_WAKEUP , MOST_SPY , MOST_CTRL , MOST_LIGHTLOCK ,
MOST_STATISTIC , FLEXRAY_DATA = 29 , FLEXRAY_SYNC , CAN_DRIVER_ERROR ,
MOST_PKT , MOST_PKT2 , MOST_HWMODE , MOST_REG ,
MOST_GENREG , MOST_NETSTATE , MOST_DATALOST , MOST_TRIGGER ,
FLEXRAY_CYCLE , FLEXRAY_MESSAGE , LIN_CHECKSUM_INFO , LIN_SPIKE_EVENT ,
CAN_DRIVER_SYNC , FLEXRAY_STATUS , GPS_EVENT , FR_ERROR ,
FR_STATUS , FR_STARTCYCLE , FR_RCVMESSAGE , REALTIMECLOCK ,
LIN_STATISTIC = 54 , J1708_MESSAGE , J1708_VIRTUAL_MSG , LIN_MESSAGE2 ,
LIN_SND_ERROR2 , LIN_SYN_ERROR2 , LIN_CRC_ERROR2 , LIN_RCV_ERROR2 ,
LIN_WAKEUP2 , LIN_SPIKE_EVENT2 , LIN_LONG_DOM_SIG , APP_TEXT ,
FR_RCVMESSAGE_EX , MOST_STATISTICEX , MOST_TXLIGHT , MOST_ALLOCTAB ,
MOST_STRESS , ETHERNET_FRAME , SYS_VARIABLE , CAN_ERROR_EXT ,
CAN_DRIVER_ERROR_EXT , LIN_LONG_DOM_SIG2 , MOST_150_MESSAGE , MOST_150_PKT ,
MOST_ETHERNET_PKT , MOST_150_MESSAGE_FRAGMENT , MOST_150_PKT_FRAGMENT , MOST_ETHERNET_PKT_FRAGMENT ,
MOST_SYSTEM_EVENT , MOST_150_ALLOCTAB , MOST_50_MESSAGE , MOST_50_PKT ,
CAN_MESSAGE2 , LIN_UNEXPECTED_WAKEUP , LIN_SHORT_OR_SLOW_RESPONSE , LIN_DISTURBANCE_EVENT ,
SERIAL_EVENT , OVERRUN_ERROR , EVENT_COMMENT , WLAN_FRAME ,
WLAN_STATISTIC , MOST_ECL , GLOBAL_MARKER , AFDX_FRAME ,
AFDX_STATISTIC , KLINE_STATUSEVENT , CAN_FD_MESSAGE , CAN_FD_MESSAGE_64 ,
ETHERNET_RX_ERROR , ETHERNET_STATUS , CAN_FD_ERROR_64 , LIN_SHORT_OR_SLOW_RESPONSE2 ,
AFDX_STATUS , AFDX_BUS_STATISTIC , AFDX_ERROR_EVENT = 109 , A429_ERROR ,
A429_STATUS , A429_BUS_STATISTIC , A429_MESSAGE , ETHERNET_STATISTIC ,
RESTOREPOINT_CONTAINER , TEST_STRUCTURE = 118 , DIAG_REQUEST_INTERPRETATION , ETHERNET_FRAME_EX ,
ETHERNET_FRAME_FORWARDED , ETHERNET_ERROR_EX , ETHERNET_ERROR_FORWARDED , FUNCTION_BUS ,
DATA_LOST_BEGIN , DATA_LOST_END , WATER_MARK_EVENT , TRIGGER_CONDITION ,
CAN_SETTING_CHANGED , DISTRIBUTED_OBJECT_MEMBER , ATTRIBUTE_EVENT
}
Supported object types.
enum SysVarDataType {
Double = 1 , Long , String , DoubleArray ,
LongArray , LongLong , ByteArray
}
System variable data types

Detailed Description

Implements the Vector BLF file format reader/writer.

Basic access to a BLF file is provided by the BLFFile class. It provides methods and properties to open, save and access the BLF model.

Getting started with reading and writing a BLF File (code example):

using jnsoft.BLF;
void openFile(string blfFilename)
{
// Open BLF file and iterate through objects
using (var blfFile = BLFFile.open(blfFilename))
{
Console.WriteLine("Opened BLC file {0} ObjectCount: {1}"
, blfFile.SourceFile, blfFile.Header.ObjectCount);
foreach (var o in blfFile.enumObjects())
{ // iterate through all BLF objects
switch (o)
{
case CANMessage cm:
// CAN message (do something with cm)
break;
case CANFDMessage cmFd:
// CAN FD message (do something with cmFD)
break;
}
}
foreach (var canFrame in blfFile.enumCANFrames(1))
{ // iterate through all CAN data frames on CAN Channel 1
// CAN message (do something with canFrame)
}
}
}
void recordFile(string blfFilename)
{
// create BLF file
var busID = "busId";
var blfFile = new BLFFile();
blfFile.addAppText("file start comment");
const uint maxObjects = 20;
var data = new byte[] { 0x1, 0x2, 0x3, 0x4 };
for (uint j = 0; j < maxObjects; ++j)
blfFile.addCANFrame(new CANFrame(ref busID, j, data, j % 2 == 0), j % 4 == 0, (byte)((j % 8) + 1));
blfFile.addAppText("file end comment");
blfFile.save(blfFilename);
}
jnsoft.BLF.BLFFile
BLF file Reader/Writer.
Definition: BLFFile.cs:105
jnsoft.BLF.BLFFile.open
static BLFFile open(string path)
Opens a BLF file and returns a BLFFile instance.
Definition: BLFFile.cs:297
jnsoft.BLF.CANFDMessage
CAN FD message
Definition: BLFTypes.cs:766
jnsoft.BLF.CANMessage
CAN message
Definition: BLFTypes.cs:548
jnsoft.BLF
Implements the Vector BLF file format reader/writer.
Definition: BLFFile.cs:100
jnsoft
Definition: ASAP2.cs:53

Enumeration Type Documentation

◆ CanFd64Flags

enum CanFd64Flags

CAN FD 64 Flags

Enumerator
R |
NERR | single wire on low speed CAN
HighVoltageWakeup |
RRFrame | Remote frame
TxAck | Tx Acknowledge
TxReq | Tx Request
SRR | SRR (CAN FD)
R0 |
R1 |
EDL | CAN FD frame
BRS | Bit rate switch (FD)
ESI | Error state indicator

◆ CANFdFlags

enum CANFdFlags : byte

CAN FD flags

Enumerator
EDL | extended data length
BRS | nit rate switch
ESI | Error state indicator

◆ CANFlags

enum CANFlags : byte

CAN message flags

Enumerator
RX | Rx direction
TX | Tx direction
NERR | single wire operation
WU | wake up message
RTR | remote transmission request

◆ ObjectFlagsType

enum ObjectFlagsType : uint

Enumeration for object flags

Enumerator
TimeTenMics | Timestamp representing 10 microseconds resolution
TimeOneNans | Timestamp representing 1 nanosecond resolution


ASAP2Library interface: AppText Class Reference

  • BLF
  • AppText
Public Attributes | List of all members
AppText Class Reference

Application text More...

Public Attributes

uint | Length
uint | Source
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

Application text


ASAP2Library interface: Member List

  • BLF
  • AppText
AppText Member List

This is the complete list of members for AppText, including all inherited members.

AppText() (defined in AppText) | AppText |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Length (defined in AppText) | AppText |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Source (defined in AppText) | AppText |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: AppTextManaged Class Reference

  • BLF
  • AppTextManaged
Public Attributes | List of all members
AppTextManaged Class Reference

.NET Application text representation More...

Public Attributes

readonly string | Text = string.Empty
- Public Attributes inherited from AppText
uint | Length
uint | Source
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

.NET Application text representation


ASAP2Library interface: Member List

  • BLF
  • AppTextManaged
AppTextManaged Member List

This is the complete list of members for AppTextManaged, including all inherited members.

AppText() (defined in AppText) | AppText |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Length (defined in AppText) | AppText |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Source (defined in AppText) | AppText |
Text (defined in AppTextManaged) | AppTextManaged |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: BLFFile Class Reference

  • BLF
  • BLFFile
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
BLFFile Class Reference

BLF file Reader/Writer. More...

Public Member Functions

BLFFile (bool compressed=true, ObjectFlagsType objectFlags=ObjectFlagsType.TimeOneNans, AppId appId=AppId.Unknown, byte appMajor=0, byte appMinor=0, byte appBuild=0)
Creates a new instance in order to record data. More...
bool | addAppText (string text, uint source=0)
Adds the specified text to the recording. More...
bool | addCANFrame (CANFrame frame, ushort channel=1)
Adds the specified CAN frame to the recording. More...
void | Dispose ()
IEnumerable< CANFrame > | enumCANFrames (int channel=-1, uint id=uint.MaxValue)
Iterates through CAN frames More...
IEnumerable< LObj > | enumObjects (IList< ObjectType > filter=null)
Iterates through BLF objects. More...
IEnumerable< KeyValuePair< ObjectType, int > > | getStatistics ()
Delivers the count of objects for each object type. More...
void | save (string path)
Saves the BLF data to the file system. More...

Static Public Member Functions

static BLFFile | open (Stream stream, string path=null)
Opens a BLF file from the specified stream and returns a BLFFile instance. More...
static BLFFile | open (string path)
Opens a BLF file and returns a BLFFile instance. More...

Static Public Attributes

static readonly ObjectType[] CAN_DATA_FRAMES = new[] { ObjectType.CAN_MESSAGE, ObjectType.CAN_MESSAGE2, ObjectType.CAN_FD_MESSAGE, ObjectType.CAN_FD_MESSAGE_64 }
Set of Objecttypes providing all kind of CAN data frames.

Properties

Header | Header [get]
Gets the BLF file Header.
uint | ObjectCount [get]
Gets the count of recorded objects so far.
string | SourceFile [get]
Gets the fully qualified path to the source file.

Detailed Description

BLF file Reader/Writer.

Constructor & Destructor Documentation

◆ BLFFile()

BLFFile | ( | bool | compressed = true,
 |  | ObjectFlagsType | objectFlags = ObjectFlagsType.TimeOneNans,
 |  | AppId | appId = AppId.Unknown,
 |  | byte | appMajor = 0,
 |  | byte | appMinor = 0,
 |  | byte | appBuild = 0
 | ) |  |

Creates a new instance in order to record data.

Parameters
compressed | Indicates if the file is saved in compressed mode
objectFlags | Time resolution flags
appId | Application ID
appMajor | Application major version
appMinor | Application minor version
appBuild | Application build number

Member Function Documentation

◆ addAppText()

bool addAppText | ( | string | text,
 |  | uint | source = 0
 | ) |  |

Adds the specified text to the recording.

Parameters
text | The text to add
source | The source number
Returns
true if successful

◆ addCANFrame()

bool addCANFrame | ( | CANFrame | frame,
 |  | ushort | channel = 1
 | ) |  |

Adds the specified CAN frame to the recording.

Parameters
frame | The CAN frame
channel | The CAN channel used
Returns
true if successful

◆ enumCANFrames()

IEnumerable< CANFrame > enumCANFrames | ( | int | channel = -1,
 |  | uint | id = uint.MaxValue
 | ) |  |

Iterates through CAN frames

Parameters
channel | The channel to filter to
id | The CAN ID to filter to
Returns
A CANFrame instance or null

◆ enumObjects()

IEnumerable< LObj > enumObjects ( IList< ObjectType > filter = null )

Iterates through BLF objects.

Parameters
filter List of object types to filter to
Returns
A LObj instance or null

◆ getStatistics()

IEnumerable< KeyValuePair< ObjectType, int > > getStatistics ( )

Delivers the count of objects for each object type.

Returns
List of KeyValuePairs

◆ open() [1/2]

static BLFFile open | ( | Stream | stream,
 |  | string | path = null
 | ) |  |
static

Opens a BLF file from the specified stream and returns a BLFFile instance.

Parameters
stream | Stream containing the BLF file content
path | the fully qualified BLF filename
Returns
A new BLFFile instance or null if failed

◆ open() [2/2]

static BLFFile open ( string path )
static

Opens a BLF file and returns a BLFFile instance.

Parameters
path the fully qualified BLF filename
Returns
A new BLFFile instance or null if failed

◆ save()

void save ( string path )

Saves the BLF data to the file system.

Parameters
path the fully qualified path to the destination file


ASAP2Library interface: Member List

  • BLF
  • BLFFile
BLFFile Member List

This is the complete list of members for BLFFile, including all inherited members.

addAppText(string text, uint source=0) | BLFFile |
addCANFrame(CANFrame frame, ushort channel=1) | BLFFile |
BLFFile(bool compressed=true, ObjectFlagsType objectFlags=ObjectFlagsType.TimeOneNans, AppId appId=AppId.Unknown, byte appMajor=0, byte appMinor=0, byte appBuild=0) | BLFFile |
CAN_DATA_FRAMES | BLFFile | static
Dispose() (defined in BLFFile) | BLFFile |
enumCANFrames(int channel=-1, uint id=uint.MaxValue) | BLFFile |
enumObjects(IList< ObjectType > filter=null) | BLFFile |
getStatistics() | BLFFile |
Header | BLFFile |
ObjectCount | BLFFile |
open(string path) | BLFFile | static
open(Stream stream, string path=null) | BLFFile | static
save(string path) | BLFFile |
SourceFile | BLFFile |


ASAP2Library interface: CANDriverError Class Reference

  • BLF
  • CANDriverError
Public Attributes | List of all members
CANDriverError Class Reference

CAN driver error More...

Public Attributes

readonly ushort | Channel
readonly uint | ErrorCode
readonly byte | RxErrors
readonly byte | TxErrors
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN driver error


ASAP2Library interface: Member List

  • BLF
  • CANDriverError
CANDriverError Member List

This is the complete list of members for CANDriverError, including all inherited members.

Channel (defined in CANDriverError) | CANDriverError |
ErrorCode (defined in CANDriverError) | CANDriverError |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
RxErrors (defined in CANDriverError) | CANDriverError |
TxErrors (defined in CANDriverError) | CANDriverError |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: CANError Class Reference

  • BLF
  • CANError
Public Attributes | List of all members
CANError Class Reference

CAN Error More...

Public Attributes

readonly ushort | Channel
Channel the frame was sent or received.
readonly ushort | Length
CAN error frame length.
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN Error


ASAP2Library interface: Member List

  • BLF
  • CANError
CANError Member List

This is the complete list of members for CANError, including all inherited members.

CANError() (defined in CANError) | CANError |
Channel | CANError |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Length | CANError |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: CANErrorExt Class Reference

  • BLF
  • CANErrorExt
Public Types | Public Member Functions | Public Attributes | List of all members
CANErrorExt Class Reference

CAN Error (extended) More...

Public Types

enum EccFlagsType : byte {
None , BitError , FormError = BitError << 1 , StuffError = BitError << 2 ,
OtherError = BitError << 3 , CrcError = BitError << 4 , AckDelError = BitError << 5 , TxNAKError = BitError << 6 ,
RxError = BitError << 7 , TxError = TxNAKError | RxError
}
ECC error flags. More...
enum FlagsType : ushort {
None , Rx = 1 << 4 , BitError = Rx << 1 , FormError = Rx << 2 ,
StuffError = Rx << 3 , OtherError = Rx << 4 , CrcError = Rx << 5 , AckDelError = Rx << 6 ,
TxNAKError = Rx << 7 , RxError = Rx << 8 , TxError = TxNAKError | RxError
}
Error flags. More...
enum ValidFlagsType {
NotSet , SJA1000Ecc , Ecc = SJA1000Ecc << 1 , Position = SJA1000Ecc << 2 ,
FrameLength = SJA1000Ecc << 3
}
Data valid flags. More...

Public Member Functions

CANErrorExt ()
Payload, only for CAN-Core. More...
- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()

Public Attributes

readonly ushort | Channel
Channel the frame was sent or received.
readonly byte | Dlc
Data length code of the corrupted message.
readonly EccFlagsType | Ecc
ECC Error Flags.
readonly FlagsType | Flags
Error Flags.
readonly uint | FrameLengthInNs
Length of the error frame in nanoseconds (time difference between Start Of Frame and End Of Frame)
readonly uint | Id
Message ID of the corrupted message
readonly ushort | Length
CAN error frame length.
readonly byte | Position
Bit position of the error frame in the corrupted
readonly ValidFlagsType | ValidFlags
Frame valid flags.
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN Error (extended)

Member Enumeration Documentation

◆ EccFlagsType

enum EccFlagsType : byte

ECC error flags.

Enumerator
BitError | Bit error
FormError | Form error
StuffError | Stuff error
OtherError | Other error
CrcError | Crc error
AckDelError | AckDel error
TxNAKError | Tx NAK error
RxError | RX error
TxError | TX error

◆ FlagsType

enum FlagsType : ushort

Error flags.

Bit 0-4: Segment (only SJA1000)

Enumerator
Rx | Rx frame
BitError | Bit error
FormError | Form error
StuffError | Stuff error
OtherError | Other error
CrcError | Crc error
AckDelError | AckDel error
TxNAKError | Tx NAK error
RxError | RX error
TxError | TX error

◆ ValidFlagsType

enum ValidFlagsType

Data valid flags.

Enumerator
SJA1000Ecc | SJA 1000 ECC is valid (member ecc)
Ecc | Ecc member is valid
Position | Position member is valid
FrameLength | FramLength member is valid

Constructor & Destructor Documentation

◆ CANErrorExt()

CANErrorExt ( )

Payload, only for CAN-Core.

Message data.


ASAP2Library interface: Member List

  • BLF
  • CANErrorExt
CANErrorExt Member List

This is the complete list of members for CANErrorExt, including all inherited members.

CANErrorExt() | CANErrorExt |
Channel | CANErrorExt |
Dlc | CANErrorExt |
Ecc | CANErrorExt |
EccFlagsType enum name | CANErrorExt |
Flags | CANErrorExt |
FlagsType enum name | CANErrorExt |
FrameLengthInNs | CANErrorExt |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id | CANErrorExt |
Length | CANErrorExt |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Position | CANErrorExt |
Type (defined in ObjBase) | ObjBase |
ValidFlags | CANErrorExt |
ValidFlagsType enum name | CANErrorExt |


ASAP2Library interface: CANFDManaged Class Reference

  • BLF
  • CANFDManaged
Public Attributes | List of all members
CANFDManaged Class Reference

CAN FD message More...

Public Attributes

readonly uint | BtrExtArb
readonly uint | btrExtData
readonly byte[] | Data
The frame data bytes.
- Public Attributes inherited from CANFDMessage64
ushort | BitCount
complete message length in bits
uint | BtrCfgArb
bit rate used in arbitration phase
uint | BtrCfgData
bit rate used in data phase
byte | Channel
Channel the frame was sent or received.
uint | Crc
CRC for CAN
byte | Dir
Direction of the message
byte | Dlc
The DLC value
byte | ExtDataOffset
offset if extDataOffset is used
CanFd64Flags | FdFlags
CAN FD related flags
uint | FrameLength
message length in ns
uint | Id
CAN Id
uint | TimeOffsetBrsNs
time offset of brs field
uint | TimeOffsetCrcDelNs
time offset of crc delimiter field
byte | TxCount
txRequiredCount (4 bits), txReqCount (4 Bits)
byte | ValidDataBytes
Valid payload length of data
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN FD message

Member Data Documentation

◆ BtrExtArb

readonly uint BtrExtArb

bit rate in arbitration phase

  • Bit 0-7: TSEG1-1
  • Bit 8-15: TSEG2-1
  • Bit 16-27: Prescaler
  • Bit 28-31: Quartz Frequency (enumeration). Supported values:
    • 0: 16 MHz
    • 1: 32 MHz
    • 2: 80 MHz

◆ btrExtData

readonly uint btrExtData

bit rate in data phase

  • Bit 0-7: TSEG1-1
  • Bit 8-15: TSEG2-1
  • Bit 16-27: Prescaler
  • Bit 28-31: Quartz Frequency (enumeration). Supported values:
    • 0: 16 MHz
    • 1: 32 MHz
    • 2: 80 MHz


ASAP2Library interface: Member List

  • BLF
  • CANFDManaged
CANFDManaged Member List

This is the complete list of members for CANFDManaged, including all inherited members.

BitCount | CANFDMessage64 |
BtrCfgArb | CANFDMessage64 |
BtrCfgData | CANFDMessage64 |
BtrExtArb | CANFDManaged |
btrExtData | CANFDManaged |
Channel | CANFDMessage64 |
Crc | CANFDMessage64 |
Data | CANFDManaged |
Dir | CANFDMessage64 |
Dlc | CANFDMessage64 |
ExtDataOffset | CANFDMessage64 |
FdFlags | CANFDMessage64 |
FrameLength | CANFDMessage64 |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id | CANFDMessage64 |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
TimeOffsetBrsNs | CANFDMessage64 |
TimeOffsetCrcDelNs | CANFDMessage64 |
TxCount | CANFDMessage64 |
Type (defined in ObjBase) | ObjBase |
ValidDataBytes | CANFDMessage64 |


ASAP2Library interface: CANFDMessage Class Reference

  • BLF
  • CANFDMessage
Public Attributes | List of all members
CANFDMessage Class Reference

CAN FD message More...

Public Attributes

readonly byte | ArbBitCount
readonly ushort | Channel
Channel the frame was sent or received.
readonly byte[] | Data
readonly byte | Dlc
readonly CANFdFlags | FdFlags
readonly CANFlags | Flags
readonly uint | FrameLength
readonly uint | Id
readonly byte | ValidDataBytes
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN FD message


ASAP2Library interface: CANFDMessage64 Class Reference

  • BLF
  • CANFDMessage64
Public Attributes | List of all members
CANFDMessage64 Class Reference

CAN FD 64 message More...

Public Attributes

ushort | BitCount
complete message length in bits
uint | BtrCfgArb
bit rate used in arbitration phase
uint | BtrCfgData
bit rate used in data phase
byte | Channel
Channel the frame was sent or received.
uint | Crc
CRC for CAN
byte | Dir
Direction of the message
byte | Dlc
The DLC value
byte | ExtDataOffset
offset if extDataOffset is used
CanFd64Flags | FdFlags
CAN FD related flags
uint | FrameLength
message length in ns
uint | Id
CAN Id
uint | TimeOffsetBrsNs
time offset of brs field
uint | TimeOffsetCrcDelNs
time offset of crc delimiter field
byte | TxCount
txRequiredCount (4 bits), txReqCount (4 Bits)
byte | ValidDataBytes
Valid payload length of data
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN FD 64 message


ASAP2Library interface: Member List

  • BLF
  • CANFDMessage64
CANFDMessage64 Member List

This is the complete list of members for CANFDMessage64, including all inherited members.

BitCount | CANFDMessage64 |
BtrCfgArb | CANFDMessage64 |
BtrCfgData | CANFDMessage64 |
Channel | CANFDMessage64 |
Crc | CANFDMessage64 |
Dir | CANFDMessage64 |
Dlc | CANFDMessage64 |
ExtDataOffset | CANFDMessage64 |
FdFlags | CANFDMessage64 |
FrameLength | CANFDMessage64 |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id | CANFDMessage64 |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
TimeOffsetBrsNs | CANFDMessage64 |
TimeOffsetCrcDelNs | CANFDMessage64 |
TxCount | CANFDMessage64 |
Type (defined in ObjBase) | ObjBase |
ValidDataBytes | CANFDMessage64 |


ASAP2Library interface: CANMessage Class Reference

  • BLF
  • CANMessage
Public Attributes | Protected Member Functions | List of all members
CANMessage Class Reference

CAN message More...

Public Attributes

readonly ushort | Channel
Channel the frame was sent or received.
readonly byte[] | Data
readonly byte | Dlc
readonly CANFlags | Flags
readonly uint | Id
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Protected Member Functions

CANMessage (ObjectType type, ObjectFlagsType flags, ulong timeStamp, ushort channel, CANFrame frame)
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()

Detailed Description

CAN message


ASAP2Library interface: CANMessage2 Class Reference

  • BLF
  • CANMessage2
Public Attributes | List of all members
CANMessage2 Class Reference

Extended CAN message More...

Public Attributes

readonly byte | BitCount
readonly uint | FrameLength
- Public Attributes inherited from CANMessage
readonly ushort | Channel
Channel the frame was sent or received.
readonly byte[] | Data
readonly byte | Dlc
readonly CANFlags | Flags
readonly uint | Id
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from CANMessage
CANMessage (ObjectType type, ObjectFlagsType flags, ulong timeStamp, ushort channel, CANFrame frame)
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

Extended CAN message


ASAP2Library interface: Member List

  • BLF
  • CANMessage2
CANMessage2 Member List

This is the complete list of members for CANMessage2, including all inherited members.

BitCount (defined in CANMessage2) | CANMessage2 |
CANMessage() (defined in CANMessage) | CANMessage |
CANMessage(ObjectType type, ObjectFlagsType flags, ulong timeStamp, ushort channel, CANFrame frame) (defined in CANMessage) | CANMessage | protected
CANMessage2() (defined in CANMessage2) | CANMessage2 |
Channel | CANMessage |
Data (defined in CANMessage) | CANMessage |
Dlc (defined in CANMessage) | CANMessage |
Flags (defined in CANMessage) | CANMessage |
FrameLength (defined in CANMessage2) | CANMessage2 |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id (defined in CANMessage) | CANMessage |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: CANStatistic Class Reference

  • BLF
  • CANStatistic
Public Attributes | List of all members
CANStatistic Class Reference

CAN driver statistic More...

Public Attributes

readonly ushort | BusLoad
readonly ushort | Channel
readonly uint | DataFrames
readonly uint | ErrorFrames
readonly uint | ExDataFrames
readonly uint | ExRemoteFrames
readonly uint | OverloadFrames
readonly uint | RemoteFrames
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

CAN driver statistic


ASAP2Library interface: Member List

  • BLF
  • CANStatistic
CANStatistic Member List

This is the complete list of members for CANStatistic, including all inherited members.

BusLoad (defined in CANStatistic) | CANStatistic |
Channel (defined in CANStatistic) | CANStatistic |
DataFrames (defined in CANStatistic) | CANStatistic |
ErrorFrames (defined in CANStatistic) | CANStatistic |
ExDataFrames (defined in CANStatistic) | CANStatistic |
ExRemoteFrames (defined in CANStatistic) | CANStatistic |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
OverloadFrames (defined in CANStatistic) | CANStatistic |
RemoteFrames (defined in CANStatistic) | CANStatistic |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: Header Class Reference

  • BLF
  • Header
Classes | Public Member Functions | Public Attributes | Properties | List of all members
Header Class Reference

Header structure More...

Classes

struct Time
BLF time representation More...

Public Member Functions

override string ToString ()

Public Attributes

readonly byte[] | ApiNumber
readonly byte | AppBuild
readonly AppId | AppID
readonly byte | AppMajor
readonly byte | AppMinor
readonly byte | Compression
Time | End
ulong | FileSize
readonly uint | HeaderSize
uint | ObjectCount
ulong | RestorePointOffset
readonly byte[] | Signature
Time | Start
ulong | UncompressedFileSize

Properties

TimeSpan | Duration [get]
Gets the recording duration.
DateTime | Ended [get]
Gets the recording end time.
DateTime | Started [get]
Gets the recording start time.

Detailed Description

Header structure


ASAP2Library interface: Member List

  • BLF
  • Header
Header Member List

This is the complete list of members for Header, including all inherited members.

ApiNumber (defined in Header) | Header
AppBuild (defined in Header) | Header
AppID (defined in Header) | Header
AppMajor (defined in Header) | Header
AppMinor (defined in Header) | Header
Compression (defined in Header) | Header
Duration | Header
End (defined in Header) | Header
Ended | Header
FileSize (defined in Header) | Header
Header() (defined in Header) | Header
HeaderSize (defined in Header) | Header
ObjectCount (defined in Header) | Header
RestorePointOffset (defined in Header) | Header
Signature (defined in Header) | Header
Start (defined in Header) | Header
Started | Header
ToString() (defined in Header) | Header
UncompressedFileSize (defined in Header) | Header


ASAP2Library interface: Header.Time Struct Reference

  • BLF
  • Header
  • Time
Public Member Functions | Public Attributes | List of all members
Header.Time Struct Reference

BLF time representation More...

Public Member Functions

override string ToString ()

Public Attributes

ushort | Day
ushort | DayOfWeek
ushort | Hour
ushort | Milliseconds
ushort | Minute
ushort | Month
ushort | Second
ushort | Year

Detailed Description

BLF time representation


ASAP2Library interface: Member List

  • BLF
  • Header
  • Time
Header.Time Member List

This is the complete list of members for Header.Time, including all inherited members.

Day (defined in Header.Time) | Header.Time
DayOfWeek (defined in Header.Time) | Header.Time
Hour (defined in Header.Time) | Header.Time
Milliseconds (defined in Header.Time) | Header.Time
Minute (defined in Header.Time) | Header.Time
Month (defined in Header.Time) | Header.Time
Second (defined in Header.Time) | Header.Time
ToString() (defined in Header.Time) | Header.Time
Year (defined in Header.Time) | Header.Time


ASAP2Library interface: LObj Class Reference

  • BLF
  • LObj
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
LObj Class Reference

Log object base class More...

Public Member Functions

double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()

Public Attributes

ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Protected Member Functions

LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

Log object base class

Member Function Documentation

◆ getTimestamp()

double getTimestamp ( )

Gets the object timestamp relative to the start in [s].

Returns
The object timestamp in [s]


ASAP2Library interface: Member List

  • BLF
  • LObj
LObj Member List

This is the complete list of members for LObj, including all inherited members.

getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: LogContainer Class Reference

  • BLF
  • LogContainer
Public Attributes | List of all members
LogContainer Class Reference

Log container structure More...

Public Attributes

readonly ushort | Compressedflag
readonly uint | Deflatebuffersize
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

Log container structure


ASAP2Library interface: Member List

  • BLF
  • LogContainer
LogContainer Member List

This is the complete list of members for LogContainer, including all inherited members.

Compressedflag (defined in LogContainer) | LogContainer |
Deflatebuffersize (defined in LogContainer) | LogContainer |
LogContainer() (defined in LogContainer) | LogContainer |
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: ObjBase Class Reference

  • BLF
  • ObjBase
Public Attributes | Protected Member Functions | List of all members
ObjBase Class Reference

Object base class More...

Public Attributes

ObjectType Type

Protected Member Functions

ObjBase (ObjectType type, int addSize=0)

Detailed Description

Object base class


ASAP2Library interface: Member List

  • BLF
  • ObjBase
ObjBase Member List

This is the complete list of members for ObjBase, including all inherited members.

ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: RestorePointContainer Class Reference

  • BLF
  • RestorePointContainer
Public Attributes | List of all members
RestorePointContainer Class Reference

Restore Point Container More...

Public Attributes

ushort | DataLength
restore point data size
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

Restore Point Container


ASAP2Library interface: Member List

  • BLF
  • RestorePointContainer
RestorePointContainer Member List

This is the complete list of members for RestorePointContainer, including all inherited members.

DataLength | RestorePointContainer |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
RestorePointContainer() (defined in RestorePointContainer) | RestorePointContainer |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: RestorePointContainerManaged Class Reference

  • BLF
  • RestorePointContainerManaged
Public Attributes | List of all members
RestorePointContainerManaged Class Reference

.NET Restore Point Container More...

Public Attributes

readonly byte[] | Data
Content bytes
- Public Attributes inherited from RestorePointContainer
ushort | DataLength
restore point data size
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

.NET Restore Point Container


ASAP2Library interface: Member List

  • BLF
  • RestorePointContainerManaged
RestorePointContainerManaged Member List

This is the complete list of members for RestorePointContainerManaged, including all inherited members.

Data | RestorePointContainerManaged |
DataLength | RestorePointContainer |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
RestorePointContainer() (defined in RestorePointContainer) | RestorePointContainer |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: SysVariable Class Reference

  • BLF
  • SysVariable
Public Attributes | List of all members
SysVariable Class Reference

System variable More...

Public Attributes

uint | DataLength
Length of the data of the environment variable in bytes.
SysVarDataType | DataType
Type of system variable
uint | NameLength
Length of the name of the system variable
uint | Representation
signed, later perhaps also string codepage
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

System variable


ASAP2Library interface: Member List

  • BLF
  • SysVariable
SysVariable Member List

This is the complete list of members for SysVariable, including all inherited members.

DataLength | SysVariable |
DataType | SysVariable |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
NameLength | SysVariable |
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Representation | SysVariable |
SysVariable() (defined in SysVariable) | SysVariable |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: SysVariableManaged Class Reference

  • BLF
  • SysVariableManaged
Public Attributes | List of all members
SysVariableManaged Class Reference

.NET System variable More...

Public Attributes

readonly byte[] | Data
Data value of the system variable
readonly string | Name = string.Empty
Name of the system variable
- Public Attributes inherited from SysVariable
uint | DataLength
Length of the data of the environment variable in bytes.
SysVarDataType | DataType
Type of system variable
uint | NameLength
Length of the name of the system variable
uint | Representation
signed, later perhaps also string codepage
- Public Attributes inherited from LObj
ObjectFlagsType | ObjectFlags
- Public Attributes inherited from ObjBase
ObjectType | Type

Additional Inherited Members

- Public Member Functions inherited from LObj
double | getTimestamp ()
Gets the object timestamp relative to the start in [s]. More...
string | getTimestampStr ()
- Protected Member Functions inherited from LObj
LObj (ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0)
- Protected Member Functions inherited from ObjBase
ObjBase (ObjectType type, int addSize=0)

Detailed Description

.NET System variable


ASAP2Library interface: Member List

  • BLF
  • SysVariableManaged
SysVariableManaged Member List

This is the complete list of members for SysVariableManaged, including all inherited members.

Data | SysVariableManaged |
DataLength | SysVariable |
DataType | SysVariable |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
Name | SysVariableManaged |
NameLength | SysVariable |
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Representation | SysVariable |
SysVariable() (defined in SysVariable) | SysVariable |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: jnsoft.Comm Namespace Reference

  • Comm
Namespaces | Classes | Enumerations
jnsoft.Comm Namespace Reference

Contains all the stuff to communicate over XCP, CCP and CAN. More...

Namespaces

namespace | CAN
All the stuff needed to communicate with CAN hardware.
namespace | CCP
Implements the CAN Calibration Protocol Version 2.1 (ASAM MCD-1 CCP)
namespace | ECUSimulator
Implements the ECU simulator.
namespace | LIN
All the stuff needed to communicate with LIN hardware.
namespace | XCP
Implements the XCP Protocol Version 1.3 (ASAM MCD-1 XCP V1.3.0)

Classes

class | CommKernel
Implements the Communication kernel. More...
class | CommMaster
Base class for both XCP and CCP master. More...
class | Communicator
Basic communicator implementation. More...
class | DAQCache
DAQ Record cache. More...
class | DAQDict
Holds the configured DAQ Lists for both XCP and CCP. More...
class | DAQList
DAQ List representation base class for both XCP and CCP. More...
class | DAQStore
Holds received DAQ records More...
class | DAQToEvtMapDict
Maps a XCP DAQList number to a specific XCP Event. More...
class | Frame
Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP). More...
class | FrameEventArgs
Frame queue event arguments. More...
class | FrameProvider
Provides CAN/LIN Frames for CAN and LIN providers. More...
class | FrameQueue
Base class for any frame type queue (CAN, CCP, XCP, UDS,...) More...
interface | IFrameProvider
Common Interface for the CAN/LIN/SxI frame providers. More...
interface | IResponse
Base class represents a CCP or XCP response. More...
class | ODTEntry
Represents an ODT entry. More...
class | ODTList
Holds the configured ODTEntries within an ODT. More...
class | ValuesReceivedEventArgs
Event arguments used on receiving acquisition data. More...
class | XCPPrgParams
Transfer structure holding (XCP) programming parameters. More...

Enumerations

enum | ConnectBehaviourType { Automatic , Manual }
Possible master connect behaviours. More...
enum | EPKCheckResult { Equal , NotEqual , Failed , NotApplicable }
Possible results from EPK check. More...
enum | MediaType { CAN , LIN }
Possible Mediatypes.
enum | StartStopMode : byte { Stop , Start , Select }
Possible DAQ Start/Stop modes. More...

Detailed Description

Contains all the stuff to communicate over XCP, CCP and CAN.

Enumeration Type Documentation

◆ ConnectBehaviourType

enum ConnectBehaviourType

Possible master connect behaviours.

Enumerator
Automatic | Master is connected and kept alive by GetStatus calls automatically by the XCPKernel.
Manual | Master is connected manually by the XCPMaster.

◆ EPKCheckResult

enum EPKCheckResult

Possible results from EPK check.

Enumerator
Equal | EPK is equal (means usually that the A2L and device layout fits)
NotEqual | EPK is different ()
Failed | EPK is defined, but failed to upload from the device
NotApplicable | EPK isn't defined, in this case there is no EPK check possible

◆ StartStopMode

enum StartStopMode : byte

Possible DAQ Start/Stop modes.

Enumerator
Stop | Stops the DAQ.
Start | Starts the DAQ.
Select | Selects to start the DAQ.


ASAP2Library interface: jnsoft.Comm.CAN Namespace Reference

  • Comm
  • CAN
Namespaces | Classes | Enumerations
jnsoft.Comm.CAN Namespace Reference

All the stuff needed to communicate with CAN hardware. More...

Namespaces

namespace | _8Devices
All the stuff needed to bind to the 8Devices CAN hardware.
namespace | Advantech
All the stuff needed to bind to the Advantech CAN hardware.
namespace | EbEl
All the stuff needed to bind to the Eberspächer electronics FlexCard CAN hardware.
namespace | ELM327
All the stuff needed to bind to the ELM327 CAN hardware.
namespace | ESD
All the stuff needed to bind to the ESD CAN hardware.
namespace | ETAS
All the stuff needed to bind to the ETAS CAN hardware (BOA).
namespace | IMEActia
All the stuff needed to bind to the IMEActia CAN hardware.
namespace | Intrepid
All the stuff needed to bind to the Intrepid CAN hardware.
namespace | IXXAT
All the stuff needed to bind to the IXXAT CAN hardware.
namespace | Kvaser
All the stuff needed to bind to the Kvaser CAN hardware.
namespace | Lawicel
All the stuff needed to bind to the Lawicel CAN hardware.
namespace | MHS
All the stuff needed to bind to the MHS Tiny-CAN CAN hardware.
namespace | NI
All the stuff needed to bind to the National Instruments CAN hardware (NI-CAN).
namespace | NIXNET
All the stuff needed to bind to the National Instruments CAN hardware (XNET).
namespace | Peak
All the stuff needed to bind to the Peak CAN hardware.
namespace | Softing
All the stuff needed to bind to the Softing CAN hardware.
namespace | Vector
All the stuff needed to bind to the Vector CAN hardware.

Classes

class | CANConfigException
CAN Configuration exception. More...
class | CANConfiguration
Represents the vendor(hardware) independant CAN configuration. More...
class | CANEventArgs
EventArgs class to notify transferred CAN frames. More...
class | CANFilterIDs
Serializes CAN filter IDs. More...
class | CANFrame
Represents a sent or received CAN message. More...
class | CANFrameQueue
Queue implementation to store CANFrame's. More...
class | CANProvider
Implements a base class for a vendor specific CAN provider. More...
interface | ICANProvider
CAN Adapter interface to implement for each CAN Bus provider. More...
class | J1939Frame
Represents a sent or received J1939 message. More...
class | J1939FrameQueue
Queue implementation to store J1939 Frame's. More...

Enumerations

enum CANBaudrate {
NotSet = 0 , _10kBit = 10000 , _20kBit = 20000 , _50kBit = 50000 ,
_100kBit = 100000 , _125kBit = 125000 , _250kBit = 250000 , _500kBit = 500000 ,
_800kBit = 800000 , _1MBit = 1000000 , _2MBit = 2000000 , _4MBit = 4000000 ,
_5MBit = 5000000 , _8MBit = 8000000 , _10MBit = 10000000
}
Defines possible CAN Baudrates. More...
enum CANFDBaudrate {
NotUsed , _500kBit = 500000 , _1MBit = 1000000 , _2MBit = 2000000 ,
_4MBit = 4000000 , _5MBit = 5000000 , _8MBit = 8000000 , _10MBit = 10000000
}
Defines possible CAN FD Baudrates. More...
enum | CANStandard { CAN20AB , CAN20A , CAN20B }
Possible CAN Standards. More...
enum | FrameType { CAN20B , FD , BRS = FD << 1 }
CAN frame types More...
enum | J1939PDUFormat { PDU1 , PDU2 }
J1939 PDU formats. More...

Detailed Description

All the stuff needed to communicate with CAN hardware.

Enumeration Type Documentation

◆ CANBaudrate

enum CANBaudrate

Defines possible CAN Baudrates.

Enumerator
NotSet | Not set value
_10kBit | 10 kBit/s
_20kBit | 20 kBit/s
_50kBit | 50 kBit/s
_100kBit | 100 kBit/s
_125kBit | 125 kBit/s
_250kBit | 250 kBit/s
_500kBit | 500 kBit/s
_800kBit | 800 kBit/s
_1MBit | 1 MBit/s
_2MBit | 2 MBit/s
_4MBit | 4 MBit/s
_5MBit | 5 MBit/s
_8MBit | 8 MBit/s
_10MBit | 10 MBit/s

◆ CANFDBaudrate

enum CANFDBaudrate

Defines possible CAN FD Baudrates.

Enumerator
NotUsed | CAN FD is not used
_500kBit | 500 kBit/s
_1MBit | 1 MBit/s
_2MBit | 2 MBit/s
_4MBit | 4 MBit/s
_5MBit | 5 MBit/s
_8MBit | 8 MBit/s
_10MBit | 10 MBit/s

◆ CANStandard

enum CANStandard

Possible CAN Standards.

Enumerator
CAN20AB | 11 and 29 Bit identifiers on the same Bus.
CAN20A | Only 11 Bit identifiers.
CAN20B | Only 29 Bit identifiers.

◆ FrameType

enum FrameType

CAN frame types

Enumerator
CAN20B | CAN 2.0B
FD | FD (Extended data length)
BRS | Bit rate switching (usually used in combination with FD)

◆ J1939PDUFormat

enum J1939PDUFormat

J1939 PDU formats.

Enumerator
PDU1 | PDU format 1
PDU2 | PDU format 2


ASAP2Library interface: jnsoft.Comm.CAN._8Devices Namespace Reference

  • Comm
  • CAN
  • _8Devices
Classes
jnsoft.Comm.CAN._8Devices Namespace Reference

All the stuff needed to bind to the 8Devices CAN hardware. More...

Classes

class _8DevicesCAN
The 8Devices version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the 8Devices CAN hardware.


ASAP2Library interface: _8DevicesCAN Class Reference

  • Comm
  • CAN
  • _8Devices
  • _8DevicesCAN
Public Member Functions | List of all members
_8DevicesCAN Class Reference

The 8Devices version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The 8Devices version of an ICANProvider.

  • Uses an installed 8Devices CAN driver
  • Supports only a 32Bit driver
  • Needs 'real' hardware connected!

Dependencies:

  • usb2can.dll (8Devices 32 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • _8Devices
  • _8DevicesCAN
_8DevicesCAN Member List

This is the complete list of members for _8DevicesCAN, including all inherited members.

_8DevicesCAN() (defined in _8DevicesCAN) | _8DevicesCAN |
CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in _8DevicesCAN) | _8DevicesCAN | virtual
Dispose() | _8DevicesCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | _8DevicesCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in _8DevicesCAN) | _8DevicesCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | _8DevicesCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | _8DevicesCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Advantech Namespace Reference

  • Comm
  • CAN
  • Advantech
Classes
jnsoft.Comm.CAN.Advantech Namespace Reference

All the stuff needed to bind to the Advantech CAN hardware. More...

Classes

class AdvantechCAN
The Advantech version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Advantech CAN hardware.


ASAP2Library interface: AdvantechCAN Class Reference

  • Comm
  • CAN
  • Advantech
  • AdvantechCAN
Public Member Functions | List of all members
AdvantechCAN Class Reference

The Advantech version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Advantech version of an ICANProvider.

  • Uses an installed Advantech CAN driver
  • Supports both 32Bit and 64Bit Advantech versions

Dependencies:

  • An installed Advantech CAN driver

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Advantech
  • AdvantechCAN
AdvantechCAN Member List

This is the complete list of members for AdvantechCAN, including all inherited members.

AdvantechCAN() (defined in AdvantechCAN) | AdvantechCAN |
CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in AdvantechCAN) | AdvantechCAN | virtual
Dispose() | AdvantechCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | AdvantechCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in AdvantechCAN) | AdvantechCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | AdvantechCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | AdvantechCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.EbEl Namespace Reference

  • Comm
  • CAN
  • EbEl
Classes
jnsoft.Comm.CAN.EbEl Namespace Reference

All the stuff needed to bind to the Eberspächer electronics FlexCard CAN hardware. More...

Classes

class EbElCAN
The Eberspächer electronics version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Eberspächer electronics FlexCard CAN hardware.

See also
http://www.eberspaecher-electronics.com/produkte/flexcard.html


ASAP2Library interface: EbElCAN Class Reference

  • Comm
  • CAN
  • EbEl
  • EbElCAN
Public Member Functions | List of all members
EbElCAN Class Reference

The Eberspächer electronics version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Eberspächer electronics version of an ICANProvider.

  • Uses an installed Eberspächer electronics CAN driver
  • Supports both 32Bit and 64Bit Eberspächer electronics versions

Dependencies:

  • fcbase.dll (Eberspächer electronics 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • EbEl
  • EbElCAN
EbElCAN Member List

This is the complete list of members for EbElCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in EbElCAN) | EbElCAN | virtual
Dispose() | EbElCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
EbElCAN() (defined in EbElCAN) | EbElCAN |
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | EbElCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in EbElCAN) | EbElCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | EbElCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | EbElCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.ELM327 Namespace Reference

  • Comm
  • CAN
  • ELM327
Classes | Enumerations
jnsoft.Comm.CAN.ELM327 Namespace Reference

All the stuff needed to bind to the ELM327 CAN hardware. More...

Classes

class ELM327CAN
The ELM327 version of an ICANProvider. More...

Enumerations

enum ELM327Protocols {
NONE = -1 , AUTO , SAEJ1850_41_6 , SAEJ1850_10_4 ,
ISO9141_2 , ISO14230 , ISO14230_fast , ISO15765_500k_11Bit ,
ISO15765_500k_29Bit , ISO15765_250k_11Bit , ISO15765_250k_29Bit , SAEJ1939 ,
USER_CAN_11Bit_125kBaud , USER_CAN_11Bit_50kBaud
}
Defined ELM327 protocols. More...

Detailed Description

All the stuff needed to bind to the ELM327 CAN hardware.

Enumeration Type Documentation

◆ ELM327Protocols

enum ELM327Protocols

Defined ELM327 protocols.

Enumerator
AUTO | Auto
SAEJ1850_41_6 | SAE J1850 (41.6 kBaud)
SAEJ1850_10_4 | SAE J1850 (10.4 kBaud)
ISO9141_2 | KWP 5 baud init, 10.4 kBaud
ISO14230 | KWP 5 baud init, 10.4 kBaud
ISO14230_fast | KWP fast init, 10.4 kBaud
ISO15765_500k_11Bit | CAN 11 Bit, 500 kBit/s
ISO15765_500k_29Bit | CAN 29 Bit, 500 kBit/s
ISO15765_250k_11Bit | CAN 11 Bit, 250 kBit/s
ISO15765_250k_29Bit | CAN 29 Bit, 250 kBit/s
SAEJ1939 | J1939
USER_CAN_11Bit_125kBaud | User CAN 11 Bit, 125 kBit/s
USER_CAN_11Bit_50kBaud | User CAN 11 Bit, 50 kBit/s


ASAP2Library interface: ELM327CAN Class Reference

  • Comm
  • CAN
  • ELM327
  • ELM327CAN
Public Member Functions | Properties | List of all members
ELM327CAN Class Reference

The ELM327 version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
string | sendCmd (string cmd)
Send an ELM327 command. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

string | ELMNname [get]
Get the ELM327 hardware read with AT@1
string | InitProtocol [get]
Gets the complete initialization string (comands/responses)
string | Version [get]
Get the version read with ATRI
string | Voltage [get]
Get the voltage string read with ATRV
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Detailed Description

The ELM327 version of an ICANProvider.

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.

◆ sendCmd()

string sendCmd ( string cmd )

Send an ELM327 command.

Parameters
cmd Command to send
Returns
Response


ASAP2Library interface: Member List

  • Comm
  • CAN
  • ELM327
  • ELM327CAN
ELM327CAN Member List

This is the complete list of members for ELM327CAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in ELM327CAN) | ELM327CAN | virtual
Dispose() | ELM327CAN | virtual
dlcToLength(byte dlc) | CANProvider | static
ELM327CAN() (defined in ELM327CAN) | ELM327CAN |
ELMNname | ELM327CAN |
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
InitProtocol | ELM327CAN |
isAvailable() | ELM327CAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in ELM327CAN) | ELM327CAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | ELM327CAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | ELM327CAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendCmd(string cmd) | ELM327CAN |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
Version | ELM327CAN |
Voltage | ELM327CAN |


ASAP2Library interface: jnsoft.Comm.CAN.ESD Namespace Reference

  • Comm
  • CAN
  • ESD
Classes
jnsoft.Comm.CAN.ESD Namespace Reference

All the stuff needed to bind to the ESD CAN hardware. More...

Classes

class ESDCAN
The ESD version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the ESD CAN hardware.

See also
https://esd.eu/en/products/can-interfaces


ASAP2Library interface: ESDCAN Class Reference

  • Comm
  • CAN
  • ESD
  • ESDCAN
Public Member Functions | List of all members
ESDCAN Class Reference

The ESD version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The ESD version of an ICANProvider.

  • Uses an installed ESD CAN driver library >= v4.8.
  • Supports both 32Bit and 64Bit Vector versions
  • Supports CAN FD on CAN FD supporting hardware

Dependencies:

  • ntcan.dll (ESD 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • ESD
  • ESDCAN
ESDCAN Member List

This is the complete list of members for ESDCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in ESDCAN) | ESDCAN | virtual
Dispose() | ESDCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
ESDCAN() (defined in ESDCAN) | ESDCAN |
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | ESDCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in ESDCAN) | ESDCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | ESDCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | ESDCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.ETAS Namespace Reference

  • Comm
  • CAN
  • ETAS
Classes
jnsoft.Comm.CAN.ETAS Namespace Reference

All the stuff needed to bind to the ETAS CAN hardware (BOA). More...

Classes

class ETASCAN
The ETAS BOA version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the ETAS CAN hardware (BOA).

Usually these are: , ...

See also
https://etas.com


ASAP2Library interface: ETASCAN Class Reference

  • Comm
  • CAN
  • ETAS
  • ETASCAN
Public Member Functions | Properties | List of all members
ETASCAN Class Reference

The ETAS BOA version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override IEnumerable< object > | GetAvailableHardware (MediaType type)
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

static string | BasePath [get]
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Detailed Description

The ETAS BOA version of an ICANProvider.

Dependencies:

  • ETAS BOA V2 distribution installation (dll-ocdProxy.dll)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ GetAvailableHardware()

override IEnumerable< object > GetAvailableHardware ( MediaType type )
virtual

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • ETAS
  • ETASCAN
ETASCAN Member List

This is the complete list of members for ETASCAN, including all inherited members.

BasePath (defined in ETASCAN) | ETASCAN | static
CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in ETASCAN) | ETASCAN | virtual
Dispose() | ETASCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
ETASCAN() (defined in ETASCAN) | ETASCAN |
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in ETASCAN) | ETASCAN | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | ETASCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in ETASCAN) | ETASCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | ETASCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | ETASCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.IMEActia Namespace Reference

  • Comm
  • CAN
  • IMEActia
Classes
jnsoft.Comm.CAN.IMEActia Namespace Reference

All the stuff needed to bind to the IMEActia CAN hardware. More...

Classes

class IMEActiaCAN
The IMEActia version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the IMEActia CAN hardware.

See also
http://www.esd-electronics-usa.com/CAN-SDK.html


ASAP2Library interface: IMEActiaCAN Class Reference

  • Comm
  • CAN
  • IMEActia
  • IMEActiaCAN
Public Member Functions | Properties | List of all members
IMEActiaCAN Class Reference

The IMEActia version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

static string | BasePath [get]
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Detailed Description

The IMEActia version of an ICANProvider.

  • Uses an installed IMEActia CAN driver library >= v4.8.
  • Supports both 32Bit and 64Bit Vector versions
  • Needs 'real' hardware connected!

Dependencies:

  • ntcan.dll (IMEActia 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • IMEActia
  • IMEActiaCAN
IMEActiaCAN Member List

This is the complete list of members for IMEActiaCAN, including all inherited members.

BasePath (defined in IMEActiaCAN) | IMEActiaCAN | static
CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in IMEActiaCAN) | IMEActiaCAN | virtual
Dispose() | IMEActiaCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
IMEActiaCAN() (defined in IMEActiaCAN) | IMEActiaCAN |
isAvailable() | IMEActiaCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in IMEActiaCAN) | IMEActiaCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | IMEActiaCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type) | IMEActiaCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Intrepid Namespace Reference

  • Comm
  • CAN
  • Intrepid
Classes
jnsoft.Comm.CAN.Intrepid Namespace Reference

All the stuff needed to bind to the Intrepid CAN hardware. More...

Classes

class IntrepidCAN
The Intrepid version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Intrepid CAN hardware.

See also
https://intrepidcs.com/products/vehicle-network-adapters/


ASAP2Library interface: IntrepidCAN Class Reference

  • Comm
  • CAN
  • Intrepid
  • IntrepidCAN
Public Member Functions | List of all members
IntrepidCAN Class Reference

The Intrepid version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Intrepid version of an ICANProvider.

  • Supports both 32Bit and 64Bit versions
  • Supports CAN FD on CAN FD supporting hardware

Dependencies:

  • icsneo40.dll (32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Intrepid
  • IntrepidCAN
IntrepidCAN Member List

This is the complete list of members for IntrepidCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in IntrepidCAN) | IntrepidCAN | virtual
Dispose() | IntrepidCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
IntrepidCAN() (defined in IntrepidCAN) | IntrepidCAN |
isAvailable() | IntrepidCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in IntrepidCAN) | IntrepidCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | IntrepidCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | IntrepidCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.IXXAT Namespace Reference

  • Comm
  • CAN
  • IXXAT
Classes
jnsoft.Comm.CAN.IXXAT Namespace Reference

All the stuff needed to bind to the IXXAT CAN hardware. More...

Classes

class IXXATCAN
The IXXAT version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the IXXAT CAN hardware.

See also
http://www.ixxat.de/overview-pc-can-interface-board_de.html


ASAP2Library interface: IXXATCAN Class Reference

  • Comm
  • CAN
  • IXXAT
  • IXXATCAN
Public Member Functions | List of all members
IXXATCAN Class Reference

The IXXAT version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The IXXAT version of an ICANProvider.

  • Uses an installed IXXAT CAN driver
  • Supports both 32Bit and 64Bit HMS/IXXAT versions (VCI3 and VCI4)
  • Supports simulation mode without any 'real' hardware installed only on VCI3!

Dependencies:

  • vcinpl.dll (32/64 bit Windows DLL, VCI3)
  • vcinpl2.dll (32/64 bit Windows DLL, VCI4)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • IXXAT
  • IXXATCAN
IXXATCAN Member List

This is the complete list of members for IXXATCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in IXXATCAN) | IXXATCAN | virtual
Dispose() | IXXATCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | IXXATCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
IXXATCAN() (defined in IXXATCAN) | IXXATCAN |
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in IXXATCAN) | IXXATCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | IXXATCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | IXXATCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Kvaser Namespace Reference

  • Comm
  • CAN
  • Kvaser
Classes
jnsoft.Comm.CAN.Kvaser Namespace Reference

All the stuff needed to bind to the Kvaser CAN hardware. More...

Classes

class KvaserCAN
The Kvaser version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Kvaser CAN hardware.

See also
http://www.kvaser.com/products-services/our-products/


ASAP2Library interface: KvaserCAN Class Reference

  • Comm
  • CAN
  • Kvaser
  • KvaserCAN
Public Member Functions | List of all members
KvaserCAN Class Reference

The Kvaser version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Kvaser version of an ICANProvider.

  • Uses an installed Kvaser CAN driver library >= v5.0.
  • Supports both 32Bit and 64Bit Kvaser versions
  • Supports simulation mode without any 'real' hardware installed
  • Supports CAN FD on CAN FD supporting hardware

Dependencies:

  • canLib32.dll (Kvaser 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Kvaser
  • KvaserCAN
KvaserCAN Member List

This is the complete list of members for KvaserCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in KvaserCAN) | KvaserCAN | virtual
Dispose() | KvaserCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | KvaserCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
KvaserCAN() (defined in KvaserCAN) | KvaserCAN |
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in KvaserCAN) | KvaserCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | KvaserCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | KvaserCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Lawicel Namespace Reference

  • Comm
  • CAN
  • Lawicel
Classes
jnsoft.Comm.CAN.Lawicel Namespace Reference

All the stuff needed to bind to the Lawicel CAN hardware. More...

Classes

class LawicelCAN
The Lawicel version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Lawicel CAN hardware.

See also
http://www.canusb.com/


ASAP2Library interface: LawicelCAN Class Reference

  • Comm
  • CAN
  • Lawicel
  • LawicelCAN
Public Member Functions | List of all members
LawicelCAN Class Reference

The Lawicel version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Lawicel version of an ICANProvider.

  • Uses an installed Lawicel CAN driver library
  • Supports both 32Bit and 64Bit versions
  • Needs 'real' hardware connected!

Dependencies:

  • canusbdrv.dll (Lawicel 32 bit Windows DLL)
  • canusbdrv64.dll (Lawicel 64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Lawicel
  • LawicelCAN
LawicelCAN Member List

This is the complete list of members for LawicelCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in LawicelCAN) | LawicelCAN | virtual
Dispose() | LawicelCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | LawicelCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
LawicelCAN() (defined in LawicelCAN) | LawicelCAN |
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in LawicelCAN) | LawicelCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | LawicelCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | LawicelCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.MHS Namespace Reference

  • Comm
  • CAN
  • MHS
Classes
jnsoft.Comm.CAN.MHS Namespace Reference

All the stuff needed to bind to the MHS Tiny-CAN CAN hardware. More...

Classes

class MHSCAN
The MHS Tiny-CAN version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the MHS Tiny-CAN CAN hardware.


ASAP2Library interface: MHSCAN Class Reference

  • Comm
  • CAN
  • MHS
  • MHSCAN
Public Member Functions | List of all members
MHSCAN Class Reference

The MHS Tiny-CAN version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The MHS Tiny-CAN version of an ICANProvider.

  • Uses an installed MHS Tiny-CAN CAN driver
  • Supports both 32Bit and 64Bit versions
  • Needs 'real' hardware connected!

Dependencies:

  • mhstcan.dll (MHS 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • MHS
  • MHSCAN
MHSCAN Member List

This is the complete list of members for MHSCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in MHSCAN) | MHSCAN | virtual
Dispose() | MHSCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | MHSCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
MHSCAN() (defined in MHSCAN) | MHSCAN |
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in MHSCAN) | MHSCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | MHSCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | MHSCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.NI Namespace Reference

  • Comm
  • CAN
  • NI
Classes
jnsoft.Comm.CAN.NI Namespace Reference

All the stuff needed to bind to the National Instruments CAN hardware (NI-CAN). More...

Classes

class NICAN
The National Instruments version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the National Instruments CAN hardware (NI-CAN).

Usually these are: USB 84XX, ...

NI-CAN is the legacy application programming interface (API) for National Instruments CAN hardware.

See also
https://ni.com


ASAP2Library interface: NICAN Class Reference

  • Comm
  • CAN
  • NI
  • NICAN
Public Member Functions | List of all members
NICAN Class Reference

The National Instruments version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The National Instruments version of an ICANProvider.

  • Supports only 32Bit as National instruments provides only a 32 Bit driver

Dependencies:

  • nican.dll (National instruments 32 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • NI
  • NICAN
NICAN Member List

This is the complete list of members for NICAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in NICAN) | NICAN | virtual
Dispose() | NICAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | NICAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
NICAN() (defined in NICAN) | NICAN |
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in NICAN) | NICAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | NICAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | NICAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.NIXNET Namespace Reference

  • Comm
  • CAN
  • NIXNET
Classes
jnsoft.Comm.CAN.NIXNET Namespace Reference

All the stuff needed to bind to the National Instruments CAN hardware (XNET). More...

Classes

class NIXNET
The National Instruments XNET version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the National Instruments CAN hardware (XNET).

Usually these are: PCI-85XX, USB-85XX, PCIE-85XX, PXI-85XX, ...

See also
https://ni.com


ASAP2Library interface: NIXNET Class Reference

  • Comm
  • CAN
  • NIXNET
  • NIXNET
Public Member Functions | List of all members
NIXNET Class Reference

The National Instruments XNET version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The National Instruments XNET version of an ICANProvider.

Dependencies:

  • nixnet.dll (National instruments 64/32 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • NIXNET
  • NIXNET
NIXNET Member List

This is the complete list of members for NIXNET, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in NIXNET) | NIXNET | virtual
Dispose() | NIXNET | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | NIXNET | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
NIXNET() (defined in NIXNET) | NIXNET |
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in NIXNET) | NIXNET |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | NIXNET | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | NIXNET | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Peak Namespace Reference

  • Comm
  • CAN
  • Peak
Classes
jnsoft.Comm.CAN.Peak Namespace Reference

All the stuff needed to bind to the Peak CAN hardware. More...

Classes

class PeakCAN
The Peak version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Peak CAN hardware.


ASAP2Library interface: PeakCAN Class Reference

  • Comm
  • CAN
  • Peak
  • PeakCAN
Public Member Functions | List of all members
PeakCAN Class Reference

The Peak version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Peak version of an ICANProvider.

  • Uses an installed Peak CAN driver
  • Supports both 32Bit and 64Bit Peak versions
  • Supports CAN FD on CAN FD supporting hardware
  • Needs 'real' hardware connected!

Dependencies:

  • pcanbasic.dll (Peak 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Peak
  • PeakCAN
PeakCAN Member List

This is the complete list of members for PeakCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in PeakCAN) | PeakCAN | virtual
Dispose() | PeakCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | PeakCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in PeakCAN) | PeakCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | PeakCAN | virtual
PeakCAN() (defined in PeakCAN) | PeakCAN |
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | PeakCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Softing Namespace Reference

  • Comm
  • CAN
  • Softing
Classes
jnsoft.Comm.CAN.Softing Namespace Reference

All the stuff needed to bind to the Softing CAN hardware. More...

Classes

class SoftingCAN
The Softing version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Softing CAN hardware.

See also
http://automotive.softing.com/en/products/communication-interfaces-can.html


ASAP2Library interface: SoftingCAN Class Reference

  • Comm
  • CAN
  • Softing
  • SoftingCAN
Public Member Functions | List of all members
SoftingCAN Class Reference

The Softing version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Softing version of an ICANProvider.

  • Uses an installed Softing CAN driver
  • Supports both 32Bit and 64Bit Softing versions
  • Needs 'real' hardware connected!

Dependencies:

  • CANL2.dll (Softing 32 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Softing
  • SoftingCAN
SoftingCAN Member List

This is the complete list of members for SoftingCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in SoftingCAN) | SoftingCAN | virtual
Dispose() | SoftingCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | SoftingCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in SoftingCAN) | SoftingCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | SoftingCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | SoftingCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
SoftingCAN() (defined in SoftingCAN) | SoftingCAN |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: jnsoft.Comm.CAN.Vector Namespace Reference

  • Comm
  • CAN
  • Vector
Classes
jnsoft.Comm.CAN.Vector Namespace Reference

All the stuff needed to bind to the Vector CAN hardware. More...

Classes

class VectorCAN
The Vector version of an ICANProvider. More...

Detailed Description

All the stuff needed to bind to the Vector CAN hardware.

See also
https://vector.com/vi_can_hardware_de.html


ASAP2Library interface: VectorCAN Class Reference

  • Comm
  • CAN
  • Vector
  • VectorCAN
Public Member Functions | List of all members
VectorCAN Class Reference

The Vector version of an ICANProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
override int | onReceive (out CANFrame frame)
override bool | open (CANConfiguration config)
Open the CAN resource More...
override int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
- Public Member Functions inherited from CANProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from CANProvider
static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...
- Static Public Attributes inherited from CANProvider
const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes
- Protected Member Functions inherited from CANProvider
CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from CANProvider
CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Vector version of an ICANProvider.

  • Uses an installed vector driver library >= 8.3.
  • Supports both 32Bit and 64Bit Vector versions
  • Supports simulation mode without any 'real' hardware installed
  • Supports CAN FD on CAN FD supporting hardware

Dependencies:

  • vxlapi.dll (Vector 32 bit Windows DLL)
  • vxlapi64.dll (Vector 64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from CANProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements CANProvider.

◆ open()

override bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Reimplemented from CANProvider.

◆ send()

override int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
jnsoft.Comm.CAN.CANProvider.CANProvider
CANProvider()
Initialises a new instance of CANProvider.
Definition: CANProvider.cs:84
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • Vector
  • VectorCAN
VectorCAN Member List

This is the complete list of members for VectorCAN, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
close() (defined in VectorCAN) | VectorCAN | virtual
Dispose() | VectorCAN | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | VectorCAN | virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out CANFrame frame) (defined in VectorCAN) | VectorCAN |
jnsoft::Comm::CAN::CANProvider.onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | VectorCAN | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | VectorCAN | virtual
jnsoft::Comm::CAN::CANProvider.send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
VectorCAN() (defined in VectorCAN) | VectorCAN |


ASAP2Library interface: CANConfigException Class Reference

  • Comm
  • CAN
  • CANConfigException
Public Member Functions | Public Attributes | List of all members
CANConfigException Class Reference

CAN Configuration exception. More...

Public Member Functions

CANConfigException (string hardwareId, string message)
Creates a new instance of CANConfigException with the specified parameter. More...

Public Attributes

readonly string HardwareId
Gets the CAN hardware Id.

Detailed Description

CAN Configuration exception.

Constructor & Destructor Documentation

◆ CANConfigException()

CANConfigException | ( | string | hardwareId,
 |  | string | message
 | ) |  |

Creates a new instance of CANConfigException with the specified parameter.

Parameters
hardwareId | The hardware Id.
message | An error message string


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANConfigException
CANConfigException Member List

This is the complete list of members for CANConfigException, including all inherited members.

CANConfigException(string hardwareId, string message) | CANConfigException
HardwareId | CANConfigException


ASAP2Library interface: CANConfiguration Class Reference

  • Comm
  • CAN
  • CANConfiguration
Classes | Public Member Functions | Public Attributes | Properties | List of all members
CANConfiguration Class Reference

Represents the vendor(hardware) independant CAN configuration. More...

Classes

class | BitRateConfig
CAN FD Bitrate configuration using common parameters. More...
struct | BitRatePar
Bitrate configuration from Brp, TSeg1, TSeg2, and SJw More...

Public Member Functions

CANConfiguration ()
Deserialization constructor.
CANConfiguration (int channel, BitRateConfig cfg)
Initialises a new instance with a specific CAN FD (nominal/data) Bitrate. More...
CANConfiguration (int channel=0, CANBaudrate baudrate=CANBaudrate.NotSet, CANFDBaudrate baudrateFD=CANFDBaudrate.NotUsed)
Initialises a new instance with the specified parameters. More...
CANConfiguration (string comPort, bool monitor=true, int cmdTimeout=200, int elm327Protocol=6)
Constructor for an ELM327. More...
string GetBitRateStr ()

Public Attributes

CANBaudrate | Baudrate
The baudrate to configure.
CANFDBaudrate BaudrateFD
The CAN FD baudrate to configure. More...
string | BusId
Unique Name set by a configured CAN provider.
int | Channel
The CAN channel to communicate on.
string | COMPort
A potentially used (virtual) COM port to access a CAN device.
string | COMPortConfig = DEFAULT_COMPORT_CFG
A potentially used COMPort configuration (default value = '9600,8,n,1').
int | ELM327CmdTimeout = 200
ELM327 Command timeout.
bool | ELM327Monitor
int | ELM327Protocol
Protocol number used for ELM327.
BitRateConfig FDBitRateConfig
CAN FD Bitrate configuration. More...
int | HardwareType
Hardwaretye (currently used for vector configuration).
CANStandard | Mode
The CAN Standard to configure.
int | TxTimeout
Sets an Tx Acknowledge timeout. More...

Properties

object Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Represents the vendor(hardware) independant CAN configuration.

  • May be used to serialize and deserialize CAN settings.
  • May be extended with additional settings for a CAN Bus configuration.

Constructor & Destructor Documentation

◆ CANConfiguration() [1/3]

CANConfiguration | ( | int | channel = 0,
 |  | CANBaudrate | baudrate = CANBaudrate.NotSet,
 |  | CANFDBaudrate | baudrateFD = CANFDBaudrate.NotUsed
 | ) |  |

Initialises a new instance with the specified parameters.

Parameters
channel | The channel to configure
baudrate | The baudrate to configure
baudrateFD | The CAN FD data baudrate to configure

◆ CANConfiguration() [2/3]

CANConfiguration | ( | int | channel,
 |  | BitRateConfig | cfg
 | ) |  |

Initialises a new instance with a specific CAN FD (nominal/data) Bitrate.

This is currently only implemented and by Vector, Peak, Kvaser, IXXAT CAN adapters!

Parameters
channel | The channel to configure
cfg | CANFD Bitrate configuration

◆ CANConfiguration() [3/3]

CANConfiguration | ( | string | comPort,
 |  | bool | monitor = true,
 |  | int | cmdTimeout = 200,
 |  | int | elm327Protocol = 6
 | ) |  |

Constructor for an ELM327.

Parameters
comPort | COM port to access the CAN device
monitor | true if all CAN frames should be monitored
cmdTimeout | ELM327 command timout
elm327Protocol | ELM327 CAN protocol index (usually 500 kBit/s/11 Bit

Member Data Documentation

◆ BaudrateFD

CANFDBaudrate BaudrateFD

The CAN FD baudrate to configure.

If this baudrate is used, the Baudrate member must be set to an concrete arbitration baudrate, too.

◆ FDBitRateConfig

BitRateConfig FDBitRateConfig

CAN FD Bitrate configuration.

  • Use this member to specify exact Arbitration/Data BitRate parameters.
  • This is currently only implemented by Vector/Kvaser/IXXAT/Peak CAN adapters!
  • Using this parameter overrrides the Baudrate/BaudrateFD settings.

◆ TxTimeout

int TxTimeout

Sets an Tx Acknowledge timeout.

  • 0 if the TxTimeout should not be used.
  • Positive values will wait for a TX Acknowledge after sending a CAN frame for the specified timeout in [ms]
  • Currently only supported by Vector CAN hardware.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance (e.g. this can be used to provide an alternative CANProvider initialisation based on the referenced data).


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANConfiguration
CANConfiguration Member List

This is the complete list of members for CANConfiguration, including all inherited members.

Baudrate | CANConfiguration
BaudrateFD | CANConfiguration
BusId | CANConfiguration
CANConfiguration() | CANConfiguration
CANConfiguration(int channel=0, CANBaudrate baudrate=CANBaudrate.NotSet, CANFDBaudrate baudrateFD=CANFDBaudrate.NotUsed) | CANConfiguration
CANConfiguration(int channel, BitRateConfig cfg) | CANConfiguration
CANConfiguration(string comPort, bool monitor=true, int cmdTimeout=200, int elm327Protocol=6) | CANConfiguration
Channel | CANConfiguration
COMPort | CANConfiguration
COMPortConfig | CANConfiguration
ELM327CmdTimeout | CANConfiguration
ELM327Monitor (defined in CANConfiguration) | CANConfiguration
ELM327Protocol | CANConfiguration
FDBitRateConfig | CANConfiguration
GetBitRateStr() (defined in CANConfiguration) | CANConfiguration
HardwareType | CANConfiguration
Mode | CANConfiguration
Tag | CANConfiguration
TxTimeout | CANConfiguration


ASAP2Library interface: CANConfiguration.BitRateConfig Class Reference

  • Comm
  • CAN
  • CANConfiguration
  • BitRateConfig
Public Member Functions | Public Attributes | List of all members
CANConfiguration.BitRateConfig Class Reference

CAN FD Bitrate configuration using common parameters. More...

Public Member Functions

BitRateConfig (BitRateConfig src)
Copy constructor More...

Public Attributes

int | Clock
Clock rate in [MHz] (supported only by Peak)
BitRatePar | Data
(CANFD) Data Bitrate
BitRatePar | Nominal
Nominal Bitrate
bool | NonISO
(CANFD) Non-ISO mode (supported by Vector/Kvaser/IXXAT)

Detailed Description

CAN FD Bitrate configuration using common parameters.

Constructor & Destructor Documentation

◆ BitRateConfig()

BitRateConfig ( BitRateConfig src )

Copy constructor

Parameters
src sorce to copy from


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANConfiguration
  • BitRateConfig
CANConfiguration.BitRateConfig Member List

This is the complete list of members for CANConfiguration.BitRateConfig, including all inherited members.

BitRateConfig() (defined in CANConfiguration.BitRateConfig) | CANConfiguration.BitRateConfig
BitRateConfig(BitRateConfig src) | CANConfiguration.BitRateConfig
Clock | CANConfiguration.BitRateConfig
Data | CANConfiguration.BitRateConfig
Nominal | CANConfiguration.BitRateConfig
NonISO | CANConfiguration.BitRateConfig


ASAP2Library interface: CANConfiguration.BitRatePar Struct Reference

  • Comm
  • CAN
  • CANConfiguration
  • BitRatePar
Public Attributes | List of all members
CANConfiguration.BitRatePar Struct Reference

Bitrate configuration from Brp, TSeg1, TSeg2, and SJw More...

Public Attributes

int | Brp
Bitrate
int | Sjw
int | TSeg1
int | TSeg2

Detailed Description

Bitrate configuration from Brp, TSeg1, TSeg2, and SJw


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANConfiguration
  • BitRatePar
CANConfiguration.BitRatePar Member List

This is the complete list of members for CANConfiguration.BitRatePar, including all inherited members.

Brp | CANConfiguration.BitRatePar
Sjw (defined in CANConfiguration.BitRatePar) | CANConfiguration.BitRatePar
TSeg1 (defined in CANConfiguration.BitRatePar) | CANConfiguration.BitRatePar
TSeg2 (defined in CANConfiguration.BitRatePar) | CANConfiguration.BitRatePar


ASAP2Library interface: CANEventArgs Class Reference

  • Comm
  • CAN
  • CANEventArgs
Public Member Functions | Public Attributes | List of all members
CANEventArgs Class Reference

EventArgs class to notify transferred CAN frames. More...

Public Member Functions

CANEventArgs (CANFrame frame)
Initialises a new instance of CANEventArgs with the specified paraneters. More...

Public Attributes

readonly CANFrame Frame
The transferred CAN frame.

Detailed Description

EventArgs class to notify transferred CAN frames.

Constructor & Destructor Documentation

◆ CANEventArgs()

CANEventArgs ( CANFrame frame )

Initialises a new instance of CANEventArgs with the specified paraneters.

Parameters
frame The transferred CAN frame


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANEventArgs
CANEventArgs Member List

This is the complete list of members for CANEventArgs, including all inherited members.

CANEventArgs(CANFrame frame) | CANEventArgs
Frame | CANEventArgs


ASAP2Library interface: CANFilterIDs Class Reference

  • Comm
  • CAN
  • CANFilterIDs
Public Member Functions | List of all members
CANFilterIDs Class Reference

Serializes CAN filter IDs. More...

Public Member Functions

CANFilterIDs (IEnumerable< uint > collection)

Detailed Description

Serializes CAN filter IDs.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANFilterIDs
CANFilterIDs Member List

This is the complete list of members for CANFilterIDs, including all inherited members.

CANFilterIDs() (defined in CANFilterIDs) | CANFilterIDs
CANFilterIDs(IEnumerable< uint > collection) (defined in CANFilterIDs) | CANFilterIDs


ASAP2Library interface: CANFrame Class Reference

  • Comm
  • CAN
  • CANFrame
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
CANFrame Class Reference

Represents a sent or received CAN message. More...

Public Member Functions

CANFrame (ref string busID, uint canID, byte[] data, bool isMasterFrame, FrameType type=FrameType.CAN20B)
Initialises a new instance of CANFrame with the specified parameters. More...
CANFrame (ref string busID, uint canID, byte[] data, byte len, bool isMasterFrame, FrameType type=FrameType.CAN20B)
Initialises a new instance of CANFrame with the specified parameters. More...
CANFrame (ref string busID, uint canID, ulong data, byte len, bool isMasterFrame)
Initialises a new instance of CANFrame with the specified parameters. More...
int | getRawFrameLength ()
Gets the frame length in Bits on the CAN Bus depending on the CAN ID used. More...
override string | toClipboard ()
Builds a tab delimited representation of the CAN frame. More...
override string | toCSV ()
Builds a CSV representation of the CAN frame. More...
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Static Public Member Functions

static int getRawFrameLength (uint canID, byte[] data)
Gets the frame length in Bits on the CAN Bus depending on the CAN ID used. More...

Public Attributes

string | BusID
The CAN Bus source identifcation (free text, maybe something like 'Vector virtual CAN Bus 1')
readonly uint | ID
Gets the CAN ID sent or received. More...
readonly FrameType | Type
CAN Frame type
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Properties

string | Address [get]
The address sent or received from.
bool | IsExtendedID [get]
Indicates if the ID is an extended CAN Id.
uint | RawID [get]
Gets the CAN ID sent or received always without a potential extended flag (Bit 31, zero based) set.
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Represents a sent or received CAN message.

Constructor & Destructor Documentation

◆ CANFrame() [1/3]

CANFrame | ( | ref string | busID,
 |  | uint | canID,
 |  | ulong | data,
 |  | byte | len,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of CANFrame with the specified parameters.

Parameters
busID | The CAN Bus identification
canID | The CAN ID from where the frame is sent or received
data | The complete frame data
len | The data length
isMasterFrame | true if the frame is sent by the master, else false

◆ CANFrame() [2/3]

CANFrame | ( | ref string | busID,
 |  | uint | canID,
 |  | byte[] | data,
 |  | bool | isMasterFrame,
 |  | FrameType | type = FrameType.CAN20B
 | ) |  |

Initialises a new instance of CANFrame with the specified parameters.

Parameters
busID | The CAN Bus identification
canID | The CAN ID from where the frame is sent or received
data | The complete frame data
isMasterFrame | true if the frame is sent by the master, else false
type | Frame type

◆ CANFrame() [3/3]

CANFrame | ( | ref string | busID,
 |  | uint | canID,
 |  | byte[] | data,
 |  | byte | len,
 |  | bool | isMasterFrame,
 |  | FrameType | type = FrameType.CAN20B
 | ) |  |

Initialises a new instance of CANFrame with the specified parameters.

Parameters
busID | The CAN Bus identification
canID | The CAN ID from where the frame is sent or received
data | The complete frame data
len | The length of data
isMasterFrame | true if the frame is sent by the master, else false
type | Frame type

Member Function Documentation

◆ getRawFrameLength() [1/2]

int getRawFrameLength ( )

Gets the frame length in Bits on the CAN Bus depending on the CAN ID used.

Returns
The frame length in Bits on the CAN bus

◆ getRawFrameLength() [2/2]

static int getRawFrameLength | ( | uint | canID,
 |  | byte[] | data
 | ) |  |
static

Gets the frame length in Bits on the CAN Bus depending on the CAN ID used.

Parameters
canID | The CAN Id used
data | The CAN msg data
Returns
The frame length in Bits on the CAN bus

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the CAN frame.

Returns
the string representation

Implements Frame.

Reimplemented in J1939Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the CAN frame.

Returns
the string representation

Implements Frame.

Reimplemented in J1939Frame.

Member Data Documentation

◆ ID

readonly uint ID

Gets the CAN ID sent or received.

Bit 31 is used to mark extended CAN IDs (see CANProvider.CAN_EXT_FLAG).


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANFrame
CANFrame Member List

This is the complete list of members for CANFrame, including all inherited members.

Address | CANFrame |
BusID | CANFrame |
CANFrame(ref string busID, uint canID, ulong data, byte len, bool isMasterFrame) | CANFrame |
CANFrame(ref string busID, uint canID, byte[] data, bool isMasterFrame, FrameType type=FrameType.CAN20B) | CANFrame |
CANFrame(ref string busID, uint canID, byte[] data, byte len, bool isMasterFrame, FrameType type=FrameType.CAN20B) | CANFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRawFrameLength() | CANFrame |
getRawFrameLength(uint canID, byte[] data) | CANFrame | static
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
ID | CANFrame |
IsExtendedID | CANFrame |
IsMasterFrame | Frame |
RawID | CANFrame |
toClipboard() | CANFrame | virtual
toCSV() | CANFrame | virtual
Type | CANFrame |


ASAP2Library interface: CANFrameQueue Class Reference

  • Comm
  • CAN
  • CANFrameQueue
Public Member Functions | Static Public Attributes | Properties | List of all members
CANFrameQueue Class Reference

Queue implementation to store CANFrame's. More...

Public Member Functions

override void | clear ()
Clears the frame queue. More...
void | enqueueFrame (CANFrame frame, CANProvider provider)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< CANFrame >
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Static Public Attributes

const string LOG_FILE = "CANLog.csv"

Properties

SortedDictionary< ulong, CANFrame > | FrameDict [get]
Gets the most recent unique CAN Frames. More...
static CANFrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< CANFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< CANFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< CANFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< CANFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store CANFrame's.

Member Function Documentation

◆ clear()

override void clear ( )
virtual

Clears the frame queue.

Reimplemented from FrameQueue< CANFrame >.

◆ enqueueFrame()

void enqueueFrame | ( | CANFrame | frame,
 |  | CANProvider | provider
 | ) |  |

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore acces to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame | The frame to add
provider | The CAN provider Instance (may be null)

Property Documentation

◆ FrameDict

SortedDictionary<ulong, CANFrame> FrameDict
get

Gets the most recent unique CAN Frames.

This can be cleared by clearFrameDict.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANFrameQueue
CANFrameQueue Member List

This is the complete list of members for CANFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< CANFrame > | protected
clear() | CANFrameQueue | virtual
Dispose() | FrameQueue< CANFrame > | virtual
enqueueFrame(CANFrame frame, CANProvider provider) | CANFrameQueue |
FrameDict | CANFrameQueue |
FrameEnqueued | FrameQueue< CANFrame > |
getFrames(out int cntFrames) | FrameQueue< CANFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< CANFrame > |
Instance | CANFrameQueue | static
IsWritingToFile | FrameQueue< CANFrame > |
LOG_FILE (defined in CANFrameQueue) | CANFrameQueue | static
LogFileCSVHeader (defined in CANFrameQueue) | CANFrameQueue |
LogFileName (defined in CANFrameQueue) | CANFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< CANFrame > |


ASAP2Library interface: CANProvider Class Reference

  • Comm
  • CAN
  • CANProvider
Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CANProvider Class Referenceabstract

Implements a base class for a vendor specific CAN provider. More...

Public Member Functions

override void | Dispose ()
Disposes all used resources from the instance. More...
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
abstract bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
virtual bool | open (CANConfiguration config)
Open the CAN resource More...
int | send (uint canID, byte[] data, bool sendAsCAN20=false)
Send data to the CAN resource. More...
abstract int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
abstract void | close ()
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Static Public Member Functions

static int | CANIDSort (uint a, uint b)
Sorts CAN Frames according its ID (ascending). More...
static byte | dlcToLength (byte dlc)
Converts the DLC byte to a length. More...
static uint | FromNICANId (uint id)
Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based). More...
static ulong | getDataFromArray (byte[] data)
Gets a UINT64 value from a CAN data message. More...
static int | getSendMsgLen (int payloadSize, int maxDLC=0)
Gets the required CAN (FD) message length from the specified payload size. More...
static bool | IsCANIdValid (uint id)
Tests a given CAN ID (maybe from a DBC file) if it is valid. More...
static byte | lengthToDLC (int length)
Converts a length to a DLC byte. More...
static string | toCANIDPairString (uint canID1, uint canID2)
Converts a CAN ID pair into a string in hexdecimal notation. More...
static string | toCANIDString (uint canID)
Converts a CAN ID into a string in hexdecimal notation. More...
static uint | ToNICANId (uint id)
Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based). More...

Static Public Attributes

const uint | CAN_EXT_FLAG = 0x80000000
Extended CAN Id flag
const uint | CAN_EXT_ID_MASK = 0x1fffffff
Allowed ID mask for extended CAN IDs
const uint | CAN_FD_XCP15_FLAG = 0x40000000
ASAP2 (XCP v1.5) defines this flag as CAN FD indicator
const uint | CAN_ID_LIBRARY_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG
Library valid bit mask for CAN IDs
const uint | CAN_ID_XCP15_VALID_MASK = CAN_EXT_ID_MASK | CAN_EXT_FLAG | CAN_FD_XCP15_FLAG
Valid bit mask for ASAP2 defined CAN IDs
const uint | CAN_STD_ID_MASK = 0x7ff
Allowed ID mask for standard CAN IDs
const int | MAX_DLC = 8
Maximum message size CAN in bytes
const int | MAX_FD_DLC = MAX_DLC * 8
Maximum message size CANFD in bytes

Protected Member Functions

CANProvider ()
Initialises a new instance of CANProvider.
int | hasSent (CANFrame frame)
Called when a frame has sent to the CAN Bus. More...
sealed override void | notifyThread ()
The CAN notify thread. More...
sealed override void | receiveThread ()
The CAN receive thread. More...
- Protected Member Functions inherited from FrameProvider< CANFrame, CANEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.

Protected Attributes

CANConfiguration | mConfig
Holds the current CAN configuration.
- Protected Attributes inherited from FrameProvider< CANFrame, CANEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Additional Inherited Members

- Properties inherited from FrameProvider< CANFrame, CANEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ICANProvider
int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

Implements a base class for a vendor specific CAN provider.

  • Provides access to a single CAN Bus channel.
  • Provides functionality for registering callbacks for multiple CAN clients.
  • Handles multiple XCPonCAN/CCP clients on a single CANProvider instance.
  • Decouples the CAN receive thread from notifying registered clients in case not to block receiving date from the CANProvider.

Member Function Documentation

◆ CANIDSort()

static int CANIDSort | ( | uint | a,
 |  | uint | b
 | ) |  |
static

Sorts CAN Frames according its ID (ascending).

Parameters
a | first CAN ID
b | second CAN ID
Returns

◆ Dispose()

override void Dispose ( )
virtual

Disposes all used resources from the instance.

  • The receiver thread
  • The notifier thread

Reimplemented from FrameProvider< CANFrame, CANEventArgs >.

Reimplemented in _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ dlcToLength()

static byte dlcToLength ( byte dlc )
static

Converts the DLC byte to a length.

Typically used for CAN FD frames.

Parameters
dlc A CAN DLC byte
Returns
The length of a CAN frame
Exceptions
NotSupportedException Thrown for all unsupported DLC values

◆ FromNICANId()

static uint FromNICANId ( uint id )
static

Replace the special NI CAN extended mark (Bit 29, zero based) with the standard extended mark (Bit 31, zero based).

Parameters
id
Returns
The CAN Id in standard CAN format

◆ getDataFromArray()

static ulong getDataFromArray ( byte[] data )
static

Gets a UINT64 value from a CAN data message.

Parameters
data The CAN payload data
Returns
The value

◆ getSendMsgLen()

static int getSendMsgLen | ( | int | payloadSize,
 |  | int | maxDLC = 0
 | ) |  |
static

Gets the required CAN (FD) message length from the specified payload size.

Parameters
payloadSize | payload size to send
maxDLC | if > 0 indicates the maximum allowed DLC size (on CAN usually 8, on CANFD maybe something >= 8)
Returns
allowed legth to send

◆ hasSent()

int hasSent ( CANFrame frame )
protected

Called when a frame has sent to the CAN Bus.

Parameters
frame The CAN frame sent
Returns
The data length of the frame sent

◆ isAvailable()

abstract bool isAvailable ( )
pure virtual

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implements ICANProvider.

Implemented in _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ IsCANIdValid()

static bool IsCANIdValid ( uint id )
static

Tests a given CAN ID (maybe from a DBC file) if it is valid.

  • Standard IDs are valid from 0..0x7ff.
  • Extended IDs are valid from 0..0x1fffffff.
Parameters
id The CAN id to test
Returns
true if the specified CAN ID is valid

◆ lengthToDLC()

static byte lengthToDLC ( int length )
static

Converts a length to a DLC byte.

  • Typically used for CAN FD frames.
Parameters
length Length to send (e.g. in a CAN FD frame)
Returns
DLC byte to set
Exceptions
NotSupportedException Thrown for all unsupported length values

◆ notifyThread()

sealed override void notifyThread ( )
protectedvirtual

The CAN notify thread.

  • Stops only if the thread is aborted from disposing the instance!
  • Any exceptions thrown from the registered CAN handler is caught!

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ open()

virtual bool open ( CANConfiguration config )
virtual

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Implements ICANProvider.

Reimplemented in _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ receiveThread()

sealed override void receiveThread ( )
protectedvirtual

The CAN receive thread.

  • Stops only if the thread is aborted from disposing the instance!
  • Ay exception thrown from the registered CAN handler is caught!

Implements FrameProvider< CANFrame, CANEventArgs >.

◆ send() [1/2]

int send | ( | uint | canID,
 |  | byte[] | data,
 |  | bool | sendAsCAN20 = false
 | ) |  |

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
sendAsCAN20 Set to true if the specified data should be send as a CAN20 frame rather than a CANFD frame on a CANFD connection.
  • If true, the data length is valid from 0..8 bytes
  • Meaningless on standard CAN connection
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements ICANProvider.

◆ send() [2/2]

abstract int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |
pure virtual

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements ICANProvider.

Implemented in IMEActiaCAN, _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ sendMsg()

int sendMsg | ( | uint | canID,
 |  | byte[] | data,
 |  | bool | sendAsCAN20,
 |  | int | maxDLC = 0,
 |  | byte | fillbyte = 0
 | ) |  |

Send data to the CAN resource.

Depending on the CAN configuration, the message will be automatically padded to match CANFD frame sizes.

  • padded with
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data | The data to send (the valid length of the data is within 0..64 bytes, depending if CAN or CANFD is used).
sendAsCAN20 Set to true if the specified data should be send as a CAN20 frame rather than a CANFD frame on a CANFD connection.
  • If true, the data length is valid from 0..8 bytes
  • Meaningless on standard CAN connection
maxDLC | if > 0 indicates the maximum allowed DLC size to fill with the specified fillByte (on CAN usually 8, on CANFD maybe something >= 8)
fillbyte | value the CAN message gets padded with
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements ICANProvider.

◆ toCANIDPairString()

static string toCANIDPairString | ( | uint | canID1,
 |  | uint | canID2
 | ) |  |
static

Converts a CAN ID pair into a string in hexdecimal notation.

  • The extended CAN ID Flags will be returned as postfixed (X).
Parameters
canID1 | The first CAN ID to convert
canID2 | The second CAN ID to convert
Returns
The CAN ID pair as string representation

◆ toCANIDString()

static string toCANIDString ( uint canID )
static

Converts a CAN ID into a string in hexdecimal notation.

  • The extended CAN ID Flag will be returned as postfixed (X).
Parameters
canID The CAN ID to convert
Returns
The CAN ID as string representation

◆ ToNICANId()

static uint ToNICANId ( uint id )
static

Replace the standard extended mark (Bit 31, zero based) with the special NI CAN extended mark (Bit 29, zero based).

Parameters
id
Returns
The CAN Id in NI CAN format


ASAP2Library interface: Member List

  • Comm
  • CAN
  • CANProvider
CANProvider Member List

This is the complete list of members for CANProvider, including all inherited members.

CAN_EXT_FLAG | CANProvider | static
CAN_EXT_ID_MASK | CANProvider | static
CAN_FD_XCP15_FLAG | CANProvider | static
CAN_ID_LIBRARY_VALID_MASK | CANProvider | static
CAN_ID_XCP15_VALID_MASK | CANProvider | static
CAN_STD_ID_MASK | CANProvider | static
CANIDSort(uint a, uint b) | CANProvider | static
CANProvider() | CANProvider | protected
jnsoft::Comm::CAN::ICANProvider.ClientCount | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.close() | IFrameProvider< CANEventArgs > |
Dispose() | CANProvider | virtual
dlcToLength(byte dlc) | CANProvider | static
FromNICANId(uint id) | CANProvider | static
GetAvailableHardware(MediaType type) (defined in CANProvider) | CANProvider | virtual
GetAvilableHardware() (defined in CANProvider) | CANProvider |
getDataFromArray(byte[] data) | CANProvider | static
getSendMsgLen(int payloadSize, int maxDLC=0) | CANProvider | static
hasSent(CANFrame frame) | CANProvider | protected
isAvailable() | CANProvider | pure virtual
IsCANIdValid(uint id) | CANProvider | static
lengthToDLC(int length) | CANProvider | static
MAX_DLC | CANProvider | static
MAX_FD_DLC | CANProvider | static
mConfig | CANProvider | protected
mRxEvent | FrameProvider< CANFrame, CANEventArgs > | protected
notifyThread() | CANProvider | protectedvirtual
onReceive(out T frame) | FrameProvider< CANFrame, CANEventArgs > | pure virtual
open(CANConfiguration config) | CANProvider | virtual
receiveThread() | CANProvider | protectedvirtual
jnsoft::Comm::CAN::ICANProvider.registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs > |
send(uint canID, byte[] data, bool sendAsCAN20=false) | CANProvider |
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | CANProvider | pure virtual
sendMsg(uint canID, byte[] data, bool sendAsCAN20, int maxDLC=0, byte fillbyte=0) | CANProvider |
start() | FrameProvider< CANFrame, CANEventArgs > | protected
stop() | FrameProvider< CANFrame, CANEventArgs > | protected
toCANIDPairString(uint canID1, uint canID2) | CANProvider | static
toCANIDString(uint canID) | CANProvider | static
ToNICANId(uint id) | CANProvider | static
ToString() (defined in CANProvider) | CANProvider |
FrameProvider< CANFrame, CANEventArgs >.UniqueBusID | FrameProvider< CANFrame, CANEventArgs > |
jnsoft::Comm::CAN::ICANProvider.UniqueBusID | ICANProvider |
jnsoft::Comm::CAN::ICANProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs > |


ASAP2Library interface: ICANProvider Interface Reference

  • Comm
  • CAN
  • ICANProvider
Public Member Functions | Properties | List of all members
ICANProvider Interface Reference

CAN Adapter interface to implement for each CAN Bus provider. More...

Public Member Functions

void | getBusload (out double bitsPerSec, out int msgPerSec)
Gets the current bus load. More...
bool | isAvailable ()
Returns true if the CAN adapter is available (installed). More...
bool | open (CANConfiguration config)
Open the CAN resource More...
int | send (uint canID, byte[] data, bool sendAsCAN20)
Send data to the CAN resource. More...
int | send (uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS)
Send data to the CAN resource. More...
int | sendMsg (uint canID, byte[] data, bool sendAsCAN20=false, int maxDLC=0, byte fillbyte=0)
Send data to the CAN resource. More...
- Public Member Functions inherited from IFrameProvider< CANEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

int | UniqueBusID [get]
Gets the unique CAN Bus ID.
- Properties inherited from IFrameProvider< CANEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

CAN Adapter interface to implement for each CAN Bus provider.

Member Function Documentation

◆ getBusload()

void getBusload | ( | out double | bitsPerSec,
 |  | out int | msgPerSec
 | ) |  |

Gets the current bus load.

  • Needs at least two calls in activated state to get correct values.
Parameters
bitsPerSec | Gets the count of bits transferred per second
msgPerSec | Gets the count of messages transferred per second

◆ isAvailable()

bool isAvailable ( )

Returns true if the CAN adapter is available (installed).

Returns
true if the CAN adapter is available

Implemented in CANProvider, _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ open()

bool open ( CANConfiguration config )

Open the CAN resource

Parameters
config The required CAN configuration
Returns
true if successfully opened

Implemented in CANProvider, _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ send() [1/2]

int send | ( | uint | canID,
 |  | byte[] | data,
 |  | bool | sendAsCAN20
 | ) |  |

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
sendAsCAN20 Set to true if the specified data should be send as a CAN20 frame rather than a CANFD frame on a CANFD connection.
  • If true, the data length is valid from 0..8 bytes
  • Meaningless on standard CAN connection
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implemented in CANProvider.

◆ send() [2/2]

int send | ( | uint | canID,
 |  | byte[] | data,
 |  | FrameType | type = FrameType.FD|FrameType.BRS
 | ) |  |

Send data to the CAN resource.

  • Use the uppermost Bit (Bit 31, zero based) to mark the canID as extended CAN ID (see CANProvider.CAN_EXT_FLAG).
  • If the canID to send is read from a DBC file (jnsoft.DBC.DBCFile.MsgType.ID), it is already in the correct format.

Usage example (send 2 bytes of data with a standard CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");

Usage example (send 2 bytes of data with an extended CAN ID):

var canProvider = new Comm.CAN.Vector.VectorCAN();
if (data.Length == canProvider.send(1 | CANProvider.CAN_EXT_FLAG, new byte[] { 0x01, 0x02 }))
Console.WriteLine("data successfully sent!");
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data The data to send (the valid length of the data depends on the configured CAN type and the caller is responsible for).
  • For CAN the data length is valid from 0..8 bytes
  • For CAN FD the data length is valid from 0..8, 12, 16, 20, 24, 32, 48 and 64 bytes.
type CAN frame type
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implemented in IMEActiaCAN, CANProvider, _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, and VectorCAN.

◆ sendMsg()

int sendMsg | ( | uint | canID,
 |  | byte[] | data,
 |  | bool | sendAsCAN20 = false,
 |  | int | maxDLC = 0,
 |  | byte | fillbyte = 0
 | ) |  |

Send data to the CAN resource.

Depending on the CAN configuration, the message will be automatically padded to match CANFD frame sizes.

  • padded with
Parameters
canID The CAN ID to send:
  • A standard CAN Identifier is valid between 0..0x7ff (11 Bit)
  • An extended CAN Identifier is valid between 0..1fffff (29 Bit). In this case you have to mark the canID parameter with the CANProvider.CAN_EXT_FLAG.
data | The data to send (the valid length of the data is within 0..64 bytes, depending if CAN or CANFD is used).
sendAsCAN20 Set to true if the specified data should be send as a CAN20 frame rather than a CANFD frame on a CANFD connection.
  • If true, the data length is valid from 0..8 bytes
  • Meaningless on standard CAN connection
maxDLC | if > 0 indicates the maximum allowed DLC size to fill with the specified fillByte (on CAN usually 8, on CANFD maybe something >= 8)
fillbyte | value the CAN message gets padded with
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implemented in CANProvider.


ASAP2Library interface: Member List

  • Comm
  • CAN
  • ICANProvider
ICANProvider Member List

This is the complete list of members for ICANProvider, including all inherited members.

ClientCount | IFrameProvider< CANEventArgs >
close() | IFrameProvider< CANEventArgs >
GetAvailableHardware(MediaType type) | IFrameProvider< CANEventArgs >
getBusload(out double bitsPerSec, out int msgPerSec) | ICANProvider
isAvailable() | ICANProvider
open(CANConfiguration config) | ICANProvider
registerClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs >
registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< CANEventArgs >
registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< CANEventArgs >
send(uint canID, byte[] data, bool sendAsCAN20) | ICANProvider
send(uint canID, byte[] data, FrameType type=FrameType.FD|FrameType.BRS) | ICANProvider
sendMsg(uint canID, byte[] data, bool sendAsCAN20=false, int maxDLC=0, byte fillbyte=0) | ICANProvider
UniqueBusID | ICANProvider
unregisterClient(EventHandler< T > handler) | IFrameProvider< CANEventArgs >


ASAP2Library interface: J1939Frame Class Reference

  • Comm
  • CAN
  • J1939Frame
Public Member Functions | Properties | List of all members
J1939Frame Class Reference

Represents a sent or received J1939 message. More...

Public Member Functions

J1939Frame (CANFrame frame)
Initialises the J1939 frame from a CAN frame More...
override string | toClipboard ()
Builds a tab delimited representation of the J1939 frame. More...
override string | toCSV ()
Builds a CSV representation of the J1939 frame. More...
- Public Member Functions inherited from CANFrame
CANFrame (ref string busID, uint canID, byte[] data, bool isMasterFrame, FrameType type=FrameType.CAN20B)
Initialises a new instance of CANFrame with the specified parameters. More...
CANFrame (ref string busID, uint canID, byte[] data, byte len, bool isMasterFrame, FrameType type=FrameType.CAN20B)
Initialises a new instance of CANFrame with the specified parameters. More...
CANFrame (ref string busID, uint canID, ulong data, byte len, bool isMasterFrame)
Initialises a new instance of CANFrame with the specified parameters. More...
int | getRawFrameLength ()
Gets the frame length in Bits on the CAN Bus depending on the CAN ID used. More...
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Properties

byte | DataPage [get]
Data Page (DP) bit. More...
byte | ExDataPage [get]
Extended Data Page (EDP) bit.
J1939PDUFormat | PDUFormat [get]
PDU Format (PF) field. More...
byte | PDUSpecific [get]
PDU Specific (PS). More...
uint | PGN [get]
Parameter Group.
byte | Priority [get]
Message priority. More...
byte | SourceAddress [get]
Source Address- More...
- Properties inherited from CANFrame
string | Address [get]
The address sent or received from.
bool | IsExtendedID [get]
Indicates if the ID is an extended CAN Id.
uint | RawID [get]
Gets the CAN ID sent or received always without a potential extended flag (Bit 31, zero based) set.
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Additional Inherited Members

- Static Public Member Functions inherited from CANFrame
static int | getRawFrameLength (uint canID, byte[] data)
Gets the frame length in Bits on the CAN Bus depending on the CAN ID used. More...
- Public Attributes inherited from CANFrame
string | BusID
The CAN Bus source identifcation (free text, maybe something like 'Vector virtual CAN Bus 1')
readonly uint | ID
Gets the CAN ID sent or received. More...
readonly FrameType | Type
CAN Frame type
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Detailed Description

Represents a sent or received J1939 message.

Constructor & Destructor Documentation

◆ J1939Frame()

J1939Frame ( CANFrame frame )

Initialises the J1939 frame from a CAN frame

Parameters
frame

Member Function Documentation

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the J1939 frame.

Returns
the string representation

Reimplemented from CANFrame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the J1939 frame.

Returns
the string representation

Reimplemented from CANFrame.

Property Documentation

◆ DataPage

byte DataPage
get

Data Page (DP) bit.

The DP bit is used as a page selector. Page 0 contains all the messages which are presently being defined. Page 1 provides additional expansion capacity for the future.

◆ PDUFormat

J1939PDUFormat PDUFormat
get

PDU Format (PF) field.

The PF field identifies one of two PDU formats able to be transmitted.

◆ PDUSpecific

byte PDUSpecific
get

PDU Specific (PS).

If the PF value is between 0 and 239 (PDU1), this PS field contains a destination address. If the PF field is between 240 and 255 (PDU2), the PS field contains a Group Extension(GE) to the PDU Format. The Group Extension provides a larger set of values to identify messages which can be broadcast to all ECUs on the network.

◆ Priority

byte Priority
get

Message priority.

A value of 0 has the highest priority. Higher priority messages would typically be used for high speed control messages.

◆ SourceAddress

byte SourceAddress
get

Source Address-


ASAP2Library interface: Member List

  • Comm
  • CAN
  • J1939Frame
J1939Frame Member List

This is the complete list of members for J1939Frame, including all inherited members.

Address | CANFrame |
BusID | CANFrame |
CANFrame(ref string busID, uint canID, ulong data, byte len, bool isMasterFrame) | CANFrame |
CANFrame(ref string busID, uint canID, byte[] data, bool isMasterFrame, FrameType type=FrameType.CAN20B) | CANFrame |
CANFrame(ref string busID, uint canID, byte[] data, byte len, bool isMasterFrame, FrameType type=FrameType.CAN20B) | CANFrame |
Data | Frame |
DataPage | J1939Frame |
Elapsed | Frame |
ExDataPage | J1939Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRawFrameLength() | CANFrame |
getRawFrameLength(uint canID, byte[] data) | CANFrame | static
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
ID | CANFrame |
IsExtendedID | CANFrame |
IsMasterFrame | Frame |
J1939Frame(CANFrame frame) | J1939Frame |
PDUFormat | J1939Frame |
PDUSpecific | J1939Frame |
PGN | J1939Frame |
Priority | J1939Frame |
RawID | CANFrame |
SourceAddress | J1939Frame |
toClipboard() | J1939Frame | virtual
toCSV() | J1939Frame | virtual
Type | CANFrame |


ASAP2Library interface: J1939FrameQueue Class Reference

  • Comm
  • CAN
  • J1939FrameQueue
Public Member Functions | Properties | List of all members
J1939FrameQueue Class Reference

Queue implementation to store J1939 Frame's. More...

Public Member Functions

void | enqueueFrame (J1939Frame frame, CANProvider provider)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< J1939Frame >
virtual void | clear ()
Clears the frame queue.
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

static J1939FrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< J1939Frame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< J1939Frame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< J1939Frame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< J1939Frame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store J1939 Frame's.

Member Function Documentation

◆ enqueueFrame()

void enqueueFrame | ( | J1939Frame | frame,
 |  | CANProvider | provider
 | ) |  |

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore acces to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame | The frame to add
provider | The CAN provider Instance (may be null)


ASAP2Library interface: Member List

  • Comm
  • CAN
  • J1939FrameQueue
J1939FrameQueue Member List

This is the complete list of members for J1939FrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< J1939Frame > | protected
clear() | FrameQueue< J1939Frame > | virtual
Dispose() | FrameQueue< J1939Frame > | virtual
enqueueFrame(J1939Frame frame, CANProvider provider) | J1939FrameQueue |
FrameEnqueued | FrameQueue< J1939Frame > |
getFrames(out int cntFrames) | FrameQueue< J1939Frame > |
getUnreadFrames(out int cntFrames) | FrameQueue< J1939Frame > |
Instance | J1939FrameQueue | static
IsWritingToFile | FrameQueue< J1939Frame > |
LogFileCSVHeader (defined in J1939FrameQueue) | J1939FrameQueue |
LogFileName (defined in J1939FrameQueue) | J1939FrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< J1939Frame > |


ASAP2Library interface: jnsoft.Comm.CCP Namespace Reference

  • Comm
  • CCP
Classes | Enumerations
jnsoft.Comm.CCP Namespace Reference

Implements the CAN Calibration Protocol Version 2.1 (ASAM MCD-1 CCP) More...

Classes

class | CCPErrorArgs
ErrorArgs class delivering received command errors. More...
class | CCPEventArgs
EventArgs class delivering received events. More...
class | CCPFrame
Represents an CCP frame. More...
class | CCPFrameQueue
Queue implementation to store CCPFrame's. More...
class | CCPMaster
Implements the CCP Master to communicate with a CCP Slave. More...
class | CCPMasterBase
Implements the CCP Master base communication with a CCP Slave. More...
class | CCPonCAN
Base class implementing the CCP based communication instance. More...
class | CmdActionDiagService
Supports CCP commands Diag and Action service. More...
class | CmdBase
Base class represents a CCP command. More...
class | CmdMoveClearBC
Supports CCP commands Move, Clear memory, BuildChksum. More...
class | DAQDictCCP
Holds a dictionary of configured DAQ Lists. More...
class | DAQListCCP
DAQ List representation. More...
class | RespActionDiagService
Response from Get Diagnostic or Action service. More...
class | RespBase
Base class represents a CCP response. More...
class | RespBuildChecksum
Response from Build Checksum. More...
class | RespDownload
Response from Get Size of DAQ list. More...
class | RespExchangeID
Response from Exchange Station Identifications. More...
class | RespGetActiveCALPage
Response from Get currently active Calibration Page. More...
class | RespGetCCPVersion
Response from Get implemented Version of CCP. More...
class | RespGetDAQSize
Response from Get Size of DAQ list. More...
class | RespGetSeed
Response from Get Seed for Key. More...
class | RespGetSStatus
Response from Get current session status from slave More...
class | RespUnlock
Response from Unlock Protection. More...

Enumerations

enum CmdResult {
OK , DAQProcOverload , CMDProcBusy = 0x10 , DAQActive ,
InternalTimeout , KeyRequest = 0x18 , SessionStateRequest , ColdStartRequest ,
CALDataInitRequest , DAQListInitRequest , CodeUpdateRequest , UnknownCommand = 0x30 ,
CommandSyntax , ParOutOfRange , AccessDenied , Overload ,
AccessLocked , ResFuncNotAvailable , SndCmdFailed = 0x100 , Timeout ,
InvalidArgument , ProtocolFailure = 0xfd , Generic = 0xfe
}
Possible command results. More...
enum CommandCode : byte {
Connect = 0x01 , GetCCPVersion = 0x1B , ExchangeID = 0x17 , GetSeed = 0x12 ,
Unlock = 0x13 , SetMTA = 0x02 , Dnload = 0x03 , Dnload6 = 0x23 ,
Upload = 0x04 , ShortUp = 0x0F , SelectCALPage = 0x11 , GetDAQSize = 0x14 ,
SetDAQPtr = 0x15 , WriteDAQ = 0x16 , StartStop = 0x06 , Disconnect = 0x07 ,
SetSStatus = 0x0C , GetSStatus = 0x0D , BuildChksum = 0x0E , ClearMemory = 0x10 ,
Program = 0x18 , Program6 = 0x22 , Move = 0x19 , Test = 0x05 ,
GetActiveCALPage = 0x09 , StartStopAll = 0x08 , DiagService = 0x20 , ActionService = 0x21
}
CCP command codes defined by the CCP specification.
enum | DisconnectMode : byte { Temporary , EndOfSession }
Possible disconnect modes. More...
enum | PIDSlaveMaster : byte { EV = 0xfe , RES }
Supported types of CCP communication. More...
enum | ResourceType : byte { None , CAL , DAQ = CAL << 1 , PGM = CAL << 6 }
Possible resource types More...
enum SessionState : byte {
None , CAL , DAQ = CAL << 1 , RESUME = CAL << 2 ,
STORE = CAL << 6 , RUN = CAL << 7
}
Possible session states. More...

Detailed Description

Implements the CAN Calibration Protocol Version 2.1 (ASAM MCD-1 CCP)

Enumeration Type Documentation

◆ CmdResult

enum CmdResult

Possible command results.

Enumerator
OK | acknowledge / no error
DAQProcOverload | DAQ processor overload
CMDProcBusy | command processor busy
DAQActive | DAQ processor busy
InternalTimeout | internal timeout
KeyRequest | key request
SessionStateRequest | session status request
ColdStartRequest | cold start request
CALDataInitRequest | cal. data init. request
DAQListInitRequest | DAQ list init. request
CodeUpdateRequest | code update request
UnknownCommand | unknown command
CommandSyntax | command syntax
ParOutOfRange | parameter(s) out of range
AccessDenied | access denied
Overload | overload
AccessLocked | access locked
ResFuncNotAvailable | resource/function not available
SndCmdFailed | Failed to send the command.
Timeout | Timeout (connection lost)
InvalidArgument | Invalid argument failure (e.g. a call to upload with 0 bytes length)
ProtocolFailure | Protocol failure (unexpected response length)
Generic | Generic (unspecified failure)

◆ DisconnectMode

enum DisconnectMode : byte

Possible disconnect modes.

Enumerator
Temporary | A temporary disconnect doesn’t stop the transmission of DAQ messages. The MTA values, the DAQ setup, the session status and the protection status are unaffected by the temporary disconnect and remain unchanged.
EndOfSession | Terminates the calibration session. Terminating the session invalidates all state information and resets the slave protection status.

◆ PIDSlaveMaster

enum PIDSlaveMaster : byte

Supported types of CCP communication.

Enumerator
EV | Event
RES | Response

◆ ResourceType

enum ResourceType : byte

Possible resource types

Used in RespConnect, RespGetStatus, CmdGetSeed, RespUnlock.

Enumerator
CAL | Calibration.
DAQ | Data acquisition.
PGM | Memory programming.

◆ SessionState

enum SessionState : byte

Possible session states.

Used in RespGetStatus.

Enumerator
CAL | Calibration data initialized.
DAQ | DAQ list(s) initialized.
RESUME | Request to save DAQ setup during shutdown in ECU. ECU automatically restarts DAQ after startup.
STORE | Request to save calibration data during shut-down in ECU.
RUN | Session in progress.


ASAP2Library interface: CCPErrorArgs Class Reference

  • Comm
  • CCP
  • CCPErrorArgs
Public Attributes | List of all members
CCPErrorArgs Class Reference

ErrorArgs class delivering received command errors. More...

Public Attributes

readonly CommandCode | Command
Gets the corresponding CCP command.
readonly CmdResult | ErrorCode
Gets the received CCP result code.

Detailed Description

ErrorArgs class delivering received command errors.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPErrorArgs
CCPErrorArgs Member List

This is the complete list of members for CCPErrorArgs, including all inherited members.

Command | CCPErrorArgs
ErrorCode | CCPErrorArgs


ASAP2Library interface: CCPEventArgs Class Reference

  • Comm
  • CCP
  • CCPEventArgs
Public Attributes | List of all members
CCPEventArgs Class Reference

EventArgs class delivering received events. More...

Public Attributes

readonly CmdResult ErrorCode
Gets the received CCP result code.

Detailed Description

EventArgs class delivering received events.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPEventArgs
CCPEventArgs Member List

This is the complete list of members for CCPEventArgs, including all inherited members.

ErrorCode CCPEventArgs


ASAP2Library interface: CCPFrame Class Reference

  • Comm
  • CCP
  • CCPFrame
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
CCPFrame Class Reference

Represents an CCP frame. More...

Public Member Functions

CCPFrame (ref string busID, uint canID, byte[] data, bool isMasterFrame)
Initialises a new instance of CCPFrame with the specified parameters. More...
int | getRawFrameLength ()
Gets the frame length in Bits on the Bus depending on the used CCP media type. More...
string | getTypeStr ()
Gets the frame's type. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Static Public Member Functions

static bool | convertToReference< T > (byte[] data, out T result)
Converts a byte array into the specified object reference. More...
static bool | convertToReference< T > (byte[] data, out T result, out byte[] additionalData)
Converts a byte array into the specified object reference. More...
static byte[] | toByteArray< T > (T objectToSend)
Creates the byte array from the specified object to send over the network. More...
static byte[] | toByteArray< T > (T objectToSend, byte[] additionalData)
Creates the byte array from the specified object to send over the network. More...

Public Attributes

string | BusID
The CAN Bus source identifcation (free text, maybe something like 'Vector XL virtual CAN Bus 1')
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Static Public Attributes

const int ResponseIndex = 0

Properties

string | Address [get]
The address sent or received from.
string???? | Ctr [get]
Gets the frame CTR. More...
uint | ID [get]
Gets the CAN IDa sent or received from.
bool | IsDAQ [get]
Indicates, if the frame is a data acquisition frame.
bool | IsError [get]
Indicates if the frame is an error response frame.
int | Len [get]
The Length value of the frame
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Represents an CCP frame.

Implements some static helper methds to convert

  • object references into byte arrays
  • byte array into object references

Constructor & Destructor Documentation

◆ CCPFrame()

CCPFrame | ( | ref string | busID,
 |  | uint | canID,
 |  | byte[] | data,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of CCPFrame with the specified parameters.

Parameters
busID | The CAN Bus ID of the message
canID | The CAN ID of he message
data | The complete frame data as byte array
isMasterFrame | true if the frame is sent by the master, else false

Member Function Documentation

◆ convertToReference< T >() [1/2]

static bool convertToReference< T > | ( | byte[] | data,
 |  | out T | result
 | ) |  |
static

Converts a byte array into the specified object reference.

Template Parameters
T The resulting object type
Parameters
data | The byte array to copy from
result | The resulting object
Returns
true if successful, false, if the memory size of the supplied data is smaller than the destination type
Type Constraints
T : class
T : new()

◆ convertToReference< T >() [2/2]

static bool convertToReference< T > | ( | byte[] | data,
 |  | out T | result,
 |  | out byte[] | additionalData
 | ) |  |
static

Converts a byte array into the specified object reference.

Template Parameters
T The resulting object type
Parameters
data | The byte array to copy from
result | The resulting object
additionalData | available additional data or null
Returns
true if successful, false, if the memory size of the supplied data is smaller than the destination type
Type Constraints
T : class
T : new()

◆ getRawFrameLength()

int getRawFrameLength ( )

Gets the frame length in Bits on the Bus depending on the used CCP media type.

Returns
The frame length in Bits on the bus

◆ getTypeStr()

string getTypeStr ( )

Gets the frame's type.

Returns
returns a type string representation

◆ toByteArray< T >() [1/2]

static byte[] toByteArray< T > ( T objectToSend )
static

Creates the byte array from the specified object to send over the network.

Template Parameters
T The sending object type
Parameters
objectToSend The object to send
Returns
The supplied object as a byte array
Type Constraints
T : class

◆ toByteArray< T >() [2/2]

static byte[] toByteArray< T > | ( | T | objectToSend,
 |  | byte[] | additionalData
 | ) |  |
static

Creates the byte array from the specified object to send over the network.

Template Parameters
T The sending object type
Parameters
objectToSend | The object to send
additionalData | Aditional dynamic data to send (may be null)
Returns
The supplied object as a byte array
Type Constraints
T : class

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the frame.

Returns
the string representation

Implements Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the frame.

Returns
the string representation

Implements Frame.

Property Documentation

◆ Ctr

string???? Ctr
get

Gets the frame CTR.

Only valid for Command and Response frames.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPFrame
CCPFrame Member List

This is the complete list of members for CCPFrame, including all inherited members.

Address | CCPFrame |
BusID | CCPFrame |
CCPFrame(ref string busID, uint canID, byte[] data, bool isMasterFrame) | CCPFrame |
convertToReference< T >(byte[] data, out T result) | CCPFrame | static
convertToReference< T >(byte[] data, out T result, out byte[] additionalData) | CCPFrame | static
Ctr | CCPFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRawFrameLength() | CCPFrame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
getTypeStr() | CCPFrame |
ID | CCPFrame |
IsDAQ | CCPFrame |
IsError | CCPFrame |
IsMasterFrame | Frame |
Len | CCPFrame |
ResponseIndex (defined in CCPFrame) | CCPFrame | static
toByteArray< T >(T objectToSend) | CCPFrame | static
toByteArray< T >(T objectToSend, byte[] additionalData) | CCPFrame | static
toClipboard() | CCPFrame | virtual
toCSV() | CCPFrame | virtual


ASAP2Library interface: CCPFrameQueue Class Reference

  • Comm
  • CCP
  • CCPFrameQueue
Public Member Functions | Properties | List of all members
CCPFrameQueue Class Reference

Queue implementation to store CCPFrame's. More...

Public Member Functions

void | enqueueFrame (CCPFrame frame)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< CCPFrame >
virtual void | clear ()
Clears the frame queue.
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

static CCPFrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< CCPFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< CCPFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< CCPFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< CCPFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store CCPFrame's.

Member Function Documentation

◆ enqueueFrame()

void enqueueFrame ( CCPFrame frame )

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore access to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame The frame to add


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPFrameQueue
CCPFrameQueue Member List

This is the complete list of members for CCPFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< CCPFrame > | protected
clear() | FrameQueue< CCPFrame > | virtual
Dispose() | FrameQueue< CCPFrame > | virtual
enqueueFrame(CCPFrame frame) | CCPFrameQueue |
FrameEnqueued | FrameQueue< CCPFrame > |
getFrames(out int cntFrames) | FrameQueue< CCPFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< CCPFrame > |
Instance | CCPFrameQueue | static
IsWritingToFile | FrameQueue< CCPFrame > |
LogFileCSVHeader (defined in CCPFrameQueue) | CCPFrameQueue |
LogFileName (defined in CCPFrameQueue) | CCPFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< CCPFrame > |


ASAP2Library interface: CCPMaster Class Reference

  • Comm
  • CCP
  • CCPMaster
Public Member Functions | Public Attributes | Properties | Events | List of all members
CCPMaster Class Reference

Implements the CCP Master to communicate with a CCP Slave. More...

Public Member Functions

CCPMaster (ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf, ICANProvider canProvider, EventHandler onConnectionStateChanged, EventHandler< CCPEventArgs > onCCPEventReceived, EventHandler< CCPErrorArgs > onCCPErrorReceived)
Creates a CCP communication master. More...
override void | configureMeasurements (IList< DAQMeasurement > measurements)
(Re)Configures the specified measurements for data acquisition. More...
override bool | copyPage2Page (ECUPage srcPage, ECUPage dstPage)
Copy data from one ECU page to another. More...
override bool | Disconnect (int useTimeout=-1)
Disconnect from slave. More...
override void | Dispose ()
Frees used resources. More...
override bool | getChecksum (byte addressExtension, uint address, uint size, out uint checksum)
Get the checksum from the slave. More...
override bool | isAllowedRequest (CommandCode cmd)
Returns true if the command is allowed to request. More...
override uint | mapAddress (uint address)
Maps the specified address using A2L defined mapping tables. More...
override void | onDAQFrameReceived (CCPFrame ccpFrame)
Called if a DAQ frame is received from the slave. More...
override void | onErrorReceived (CmdResult result, CommandCode code)
Called, if an error response is received from the slave. More...
override void | onEventReceived (CCPFrame ccpFrame)
Called if an event is received from the slave. More...
override bool | programSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null)
Program data synchronously to the ECU More...
override bool | readSync (int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Read data synchronously from the ECU. More...
override void | setConnectionState< T > (T respConnect)
Called if a a valid connect response is received. More...
override bool | setPage (ECUPage page)
Sets the specified page as active page. More...
override bool | startMeasurements (bool doSynchronized)
Starts a (previously configured by configureMeasurements) data acquisition. More...
override bool | stopMeasurements (bool doSynchronized)
Stops a running data acquisition. More...
CmdResult | unlockECU (NativeSKDLL seedAndKeyDAQDLL, NativeSKDLL seedAndKeyCALDLL, NativeSKDLL seedAndKeyPGMDLL, ResourceType resource)
Tries to unlock all protected ECU resources using the specified SeedKey DLLs. More...
CmdResult | unlockECU (NativeSKDLL seedAndKeyDLL, ResourceType resource)
Tries to unlock a specific protected ECU resource using the specified SeedKey DLL. More...
override bool | writeSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Write data synchronously to the ECU More...
- Public Member Functions inherited from CCPMasterBase
CCPMasterBase (ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf)
Creates a XCPonCAN communication master. More...
CmdResult | ActionService (ushort No, out RespActionDiagService response)
Action/Diagnostic Service More...
CmdResult | BuildChecksum (uint blockSize, out RespBuildChecksum response)
Build checksum over memory range. More...
CmdResult | ClearMemory (uint size)
Clear memory. More...
CmdResult Connect ()
Sets up connection with a CCP slave. More...
CmdResult | DiagService (ushort No, out RespActionDiagService response)
Diagnostic Service More...
bool | Disconnect (DisconnectMode mode, int useTimeout=-1)
Disconnect from slave. More...
override bool | Disconnect (int useTimeout=-1)
Disconnects the master from the slave. More...
CmdResult | Download (byte[] bytes, out RespDownload response)
Download from master to slave More...
CmdResult | Download6 (byte[] bytes, out RespDownload response)
Download 6 bytes from master to slave More...
CmdResult | ExchangeID (out RespExchangeID response)
Get the Exchange Station Identifications from slave. More...
CmdResult | GetActiveCALPage (out RespGetActiveCALPage response)
Get currently active Calibration Page from slave. More...
override int | getAliveCycleTime ()
Gets the alive cycle time in [ms]. More...
CmdResult | GetCCPVersions (byte desiredMain, byte desiredRelease, out RespGetCCPVersion response)
Get the CCP version from slave. More...
CmdResult | GetDAQSize (byte daqNo, uint canId, out RespGetDAQSize response)
Get the DAQ List size from slave. More...
CmdResult | GetSeed (ResourceType resource, out RespGetSeed response, out byte[] seed)
Get Seed for Key from slave. More...
CmdResult | GetStatus (out RespGetSStatus response)
Get current session status from slave. More...
sealed override bool | internalConnect ()
Tries to connect to a XCP/CCP slave More...
sealed override bool | internalGetStatus ()
Get current session status from slave. More...
CmdResult | Move (uint size)
Move memory block. More...
CmdResult | Program (byte[] bytes, out RespDownload response)
Program from master to slave More...
CmdResult | Program6 (byte[] bytes, out RespDownload response)
Program 6 bytes from master to slave More...
sealed override void | resetLastError ()
Reset the last error More...
CmdResult SelectCALPage ()
Select Calibration Data Page from slave. More...
override void | setConnectionState< T > (T respConnect)
Called from the CommKernel if the connection state gets changed. More...
CmdResult | SetDAQPtr (byte daqListNo, byte ODTNo, byte elmentNo)
Set DAQ list pointer. More...
CmdResult | SetMTA (byte mtaNo, byte addressExtension, uint address)
Set Memory Transfer Address. More...
CmdResult | SetStatus (SessionState state)
Set Session Status from slave. More...
CmdResult | ShortUp (byte size, byte addressExtension, uint address, out byte[] respData)
Get the short upload from slave. More...
CmdResult | StartStop (StartStopMode mode, byte daqNo, byte lastODTNo, byte evtChnNo, ushort prescaler)
Start / Stop Data transmission. More...
CmdResult | StartStopAll (StartStopMode mode)
Start / Stop Synchronised Data transmission. More...
CmdResult | Unlock (byte[] key, out RespUnlock response)
Get the Unlock Protection from slave. More...
CmdResult | Upload (byte size, out byte[] respData)
Get the Data upload from slave. More...
CmdResult | WriteDAQ (byte size, byte extension, uint address)
Write DAQ list entry. More...
- Public Member Functions inherited from CommMaster
CommMaster (ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf)
Creates a communication master. More...
void | addAdaptiveCharacteristics (A2LPROJECT project, List< IDataFile > dataFiles)
Adds all defined adaptive characteristics to the adaptive characteristic list. More...
EPKCheckResult | epkCheck (A2LMOD_PAR modPar, out string epkFromDevice)
Online EPK check. More...
EPKCheckResult | epkCheck (uint epkAddress, string expectedEPK, out string epkFromDevice)
Online EPK check. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
virtual bool | getDAQRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getDAQRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
double[] | getOperatingPoint (A2LCHARACTERISTIC characteristic)
Returns an array of operating points if available. More...
void | getTransmissionRate (out double bitsPerSec)
Gets the current transmission rate. More...
void | RaiseConnectionStateChanged ()
Raises the ConnectionStateChanged event.
void | RaiseOnValuesReceived (int daqListNo, double seconds, byte[] data)
Raises the OnValuesReceived event with the pecified parameters. More...
bool | readCharacteristic (ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null)
Read the characteristic value from the ECU into the specified datafile. More...
bool | writeCharacteristic (IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null)
Write the characteristic value read from the specified datafile to the device. More...

Public Attributes

readonly SortedDictionary< ushort, SourceAndRaster > SourceAndRasterMap = new SortedDictionary<ushort, SourceAndRaster>()
Source to raster mapping. More...

Properties

sealed override ECUPage? | ActivePage [get]
override bool? | CanWrite [get]
RespBase | ConnectResponse [get]
The last received Connect response. More...
RespExchangeID | ExchangeIDResponse [get]
The last received ExchangeID response. More...
string | ExchangeIDStr = string.Empty [get]
Gets the exchange ID string.
bool | IsDAQRunning [get]
Indicates if data acquisition is running.
RespGetSStatus | StatusResponse [get]
The last received GetStatus response. More...
string? | Version [get]
Gets the CCP version string. More...
- Properties inherited from CCPMasterBase
sealed override Enum | LastErrorEnum [get]
CmdResult | LastErrorResponse = CmdResult.OK [get]
The last error occured.
sealed override string | LastErrorText [get]
CCPFrame | LastResponse [getset]
Last received response.
- Properties inherited from CommMaster
abstract ECUPage | ActivePage [get]
The currently active calibration page More...
abstract bool | CanWrite [get]
Indicates if writing to the XCP/CCP mmaster is allowed. More...
bool | ChangeEndianess [getset]
Indicates if XCP Master and Slave byte orders differ. More...
ConnectBehaviourType | ConnectBehaviour [getset]
Gets or sets the connection behavior.
virtual bool | Connected [getprotected set]
Indicates, if the master is connected to the slave device.
DAQDict | DAQs [getprotected set]
The configured DAQ dictionary.
ulong | ErrorsReceived [getprotected set]
The amount of errors received since connection is established.
ulong | EventsReceived [getprotected set]
The amount of events received since connection is established.
ulong | FramesReceived [getprotected set]
The amount of frames received since connection is established.
ulong | FramesSent [getprotected set]
The amount of frames sent since connection is established.
A2LIF_DATA | Interface [get]
Gets the corresponding A2L communication interface.
abstract Enum | LastErrorEnum [get]
Gets the last error occured as enum.
abstract string | LastErrorText [get]
Gets the last error occured as text.
long | LastReceivedTime [getprotected set]
Indicates the timestamp the last byte was received from a slave.
DateTime | LastStateChange [getprotected set]
Returns the last state change (DateTime.MinValue if never changed).
ASAP2.Values.MeasurementAccessData | MeasurementAccessData [getset]
Gets or sets the measurement access data.
NativeSKDLL | SeedAndKeyDLL [getset]
Gets or sets the Seed&Key DLL.
ulong | ServicesReceived [getprotected set]
The amount of service requests received since connection is established.

Events

EventHandler< CCPErrorArgs > | CCPErrorReceived
Called if a CCP command error is received. More...
EventHandler< CCPEventArgs > | CCPEventReceived
Called if a CCP event is received. More...
- Events inherited from CommMaster
EventHandler | ConnectionStateChanged
Called if a XCP/CCP connection state changes. More...
EventHandler< ValuesReceivedEventArgs > | OnValuesReceived
Called if a XCP/CCP data acquisition data is received. More...

Additional Inherited Members

- Static Public Attributes inherited from CommMaster
static readonly char[] | mStrTrimmer = new char[] { '\0', '\xFF', ' ' }
Used to trim EPK or ID strings.
- Protected Attributes inherited from CCPMasterBase
A2LCCP_TP_BLOB | mCCPIf
- Protected Attributes inherited from CommMaster
IDictionary< ulong, AdaptiveState > | mAdaptiveCharDict = new Dictionary<ulong, AdaptiveState>()
The adaptive characteristics dictionary.
long | mBitsTransferred
List< IDataFile > | mDataFiles
The list of data files to write adaptive characteristics into.
NativeSKDLL | mSeedAndKeyDLL

Detailed Description

Implements the CCP Master to communicate with a CCP Slave.

Derived from CCPMasterBase, this is the class providing some convenience funtions for a CCP communication.

  • All commands are implemented as synchronous calls to the slave
  • All commands are thread-safe
  • The endianess of any command, response or event is converted automatically according the CCP protocol
  • Responses (out parameter) of commands are only valid if the CmdResult of the call is CmdResult.OK

Example to connect to a CCP slave device:

Constructor & Destructor Documentation

◆ CCPMaster()

CCPMaster | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LCCP_TP_BLOB | ccpIf,
 |  | ICANProvider | canProvider,
 |  | EventHandler | onConnectionStateChanged,
 |  | EventHandler< CCPEventArgs > | onCCPEventReceived,
 |  | EventHandler< CCPErrorArgs > | onCCPErrorReceived
 | ) |  |

Creates a CCP communication master.

Parameters
connectBehavior | Client's connect behaviour
ccpIf | A2L CCP interface instance (ASAP1B_CCP)
canProvider
onConnectionStateChanged | The callback to receive connection state changes (may be null)
onCCPEventReceived | The callback to receive CCP events (may be null)
onCCPErrorReceived | The callback to receive CCP command errors (may be null)

Member Function Documentation

◆ configureMeasurements()

override void configureMeasurements ( IList< DAQMeasurement > measurements )
virtual

(Re)Configures the specified measurements for data acquisition.

  • Interface is changed to accept now an array index and DAQ prset evnets with a measurement.
  • Use A2LMEASUREMENT.buildDAQMeasurements() to keep up with the previous interface.
  • A potentially existing configuration will be deleted.
Parameters
measurements [in/out] The measurement list (including an measurement array index and predefined events) to be configured, successfully configured measurements will be removed from this list after the call is completed.
Exceptions
ArgumentOutOfRangeException Thrown, if an measurement array index is out of range

Implements CommMaster.

◆ copyPage2Page()

override bool copyPage2Page | ( | ECUPage | srcPage,
 |  | ECUPage | dstPage
 | ) |  |
virtual

Copy data from one ECU page to another.

Parameters
srcPage | The page to copy data from
dstPage | The page to copy data to
Returns
true if successful
Exceptions
ArgumentException Thrown, if srcPage == dstPage

Implements CommMaster.

◆ Disconnect()

override bool Disconnect ( int useTimeout = -1 )
virtual

Disconnect from slave.

Brings the slave to the DISCONNECTED state. The DISCONNECTED state is described in Part 1, chapter “state machine”.

Parameters
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

Implements CommMaster.

◆ Dispose()

override void Dispose ( )
virtual

Frees used resources.

Potentially existing Seed and Key DLLs are unloaded here.

Reimplemented from CommMaster.

◆ getChecksum()

override bool getChecksum | ( | byte | addressExtension,
 |  | uint | address,
 |  | uint | size,
 |  | out uint | checksum
 | ) |  |
virtual

Get the checksum from the slave.

Parameters
addressExtension | The segment's address extension
address | The start address
size | The size of the data block to build the checksum over
checksum | The resulting checksum
Returns
true if successful

Implements CommMaster.

◆ isAllowedRequest()

override bool isAllowedRequest ( CommandCode cmd )
virtual

Returns true if the command is allowed to request.

Parameters
cmd The CCP command
Returns
true if the optional command is allowed to execute

Implements CCPMasterBase.

◆ mapAddress()

override uint mapAddress ( uint address )
virtual

Maps the specified address using A2L defined mapping tables.

Parameters
address The address to translate
Returns
the translated or address

Implements CommMaster.

◆ onDAQFrameReceived()

override void onDAQFrameReceived ( CCPFrame ccpFrame )
virtual

Called if a DAQ frame is received from the slave.

Parameters
ccpFrame The corresponding received frame

Reimplemented from CCPMasterBase.

◆ onErrorReceived()

override void onErrorReceived | ( | CmdResult | result,
 |  | CommandCode | code
 | ) |  |
virtual

Called, if an error response is received from the slave.

Parameters
result | The command result
code | The corresponding command code

Reimplemented from CCPMasterBase.

◆ onEventReceived()

override void onEventReceived ( CCPFrame ccpFrame )
virtual

Called if an event is received from the slave.

Parameters
ccpFrame The corresponding received frame

Reimplemented from CCPMasterBase.

◆ programSync()

override bool programSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null,
 |  | XCPPrgParams | modes = null
 | ) |  |
virtual

Program data synchronously to the ECU

Depending on the data length to be written Progrma or Program6 is used.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to write
progressHandler | Callback to receive progress, maybe null
modes | Unused here (only importatnt for an XCP connection)
Returns
true if successful

Implements CommMaster.

◆ readSync()

override bool readSync | ( | int | len,
 |  | byte | addressExtension,
 |  | uint | address,
 |  | out byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
virtual

Read data synchronously from the ECU.

Depending on the data length to be read CmdUpload or CmdShortUpload is used.

Parameters
len | The length to read
addressExtension | The address extension
address | The address to read from (If the adress is uint.MaxValue, the data should be read from the current MTA location)
data | The resulting data (only valid, if return value is CmdResult.Ok)
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implements CommMaster.

◆ setConnectionState< T >()

override void setConnectionState< T > ( T respConnect )
virtual

Called if a a valid connect response is received.

Template Parameters
T Connection type (XCP or CCP)
Parameters
respConnect The connect response

Implements CommMaster.

◆ setPage()

override bool setPage ( ECUPage page )
virtual

Sets the specified page as active page.

Pages of all segments got switched!

Parameters
page The page to set active
Returns
true if successful

Implements CommMaster.

◆ startMeasurements()

override bool startMeasurements ( bool doSynchronized )
virtual

Starts a (previously configured by configureMeasurements) data acquisition.

Parameters
doSynchronized true, if the DAQ List should be started synchronously
Returns
true if successful

Implements CommMaster.

◆ stopMeasurements()

override bool stopMeasurements ( bool doSynchronized )
virtual

Stops a running data acquisition.

The configured data acquisition could be restarted without calling configureMeasurements again with startMeasurements.

Parameters
doSynchronized true, if the DAQ List should be stopped synchronously (Only supported on XCP connections).
Returns
true if successful

Implements CommMaster.

◆ unlockECU() [1/2]

CmdResult unlockECU | ( | NativeSKDLL | seedAndKeyDAQDLL,
 |  | NativeSKDLL | seedAndKeyCALDLL,
 |  | NativeSKDLL | seedAndKeyPGMDLL,
 |  | ResourceType | resource
 | ) |  |

Tries to unlock all protected ECU resources using the specified SeedKey DLLs.

Parameters
seedAndKeyDAQDLL | The Seed&Key DLL to use for the DAQ resource (may be null, depending on the specified resource)
seedAndKeyCALDLL | The Seed&Key DLL to use for the CAL resource (may be null, depending on the specified resource)
seedAndKeyPGMDLL | The Seed&Key DLL to use for the PGM resource (may be null, depending on the specified resource)
resource | The resource(s) to unlock
Returns
A CmdResult value

◆ unlockECU() [2/2]

CmdResult unlockECU | ( | NativeSKDLL | seedAndKeyDLL,
 |  | ResourceType | resource
 | ) |  |

Tries to unlock a specific protected ECU resource using the specified SeedKey DLL.

Parameters
seedAndKeyDLL | The Seed&Key DLL
resource | Resource to unlock
Returns
A CmdResult value

◆ writeSync()

override bool writeSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
virtual

Write data synchronously to the ECU

Depending on the data length to be written Download or Download6 is used.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to write
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implements CommMaster.

Member Data Documentation

◆ SourceAndRasterMap

readonly SortedDictionary<ushort, SourceAndRaster> SourceAndRasterMap = new SortedDictionary<ushort, SourceAndRaster>()

Source to raster mapping.

Initialized form A2L, maybe modified by GetDAQSize ECU requests.

Property Documentation

◆ ConnectResponse

RespBase ConnectResponse
get

The last received Connect response.

Only valid in connected state!

◆ ExchangeIDResponse

RespExchangeID ExchangeIDResponse
get

The last received ExchangeID response.

Only valid in connected state!

◆ StatusResponse

RespGetSStatus StatusResponse
get

The last received GetStatus response.

Only valid in connected state!

◆ Version

string? Version
get

Gets the CCP version string.

Only valid in connected state!

Event Documentation

◆ CCPErrorReceived

EventHandler<CCPErrorArgs> CCPErrorReceived

Called if a CCP command error is received.

The event is invoked from a receiver thread (this is never the GUI thread)!

◆ CCPEventReceived

EventHandler<CCPEventArgs> CCPEventReceived

Called if a CCP event is received.

The event is invoked from a receiver thread (this is never the GUI thread)!


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPMaster
CCPMaster Member List

This is the complete list of members for CCPMaster, including all inherited members.

ActionService(ushort No, out RespActionDiagService response) | CCPMasterBase |
ActivePage (defined in CCPMaster) | CCPMaster |
addAdaptiveCharacteristics(A2LPROJECT project, List< IDataFile > dataFiles) | CommMaster |
BuildChecksum(uint blockSize, out RespBuildChecksum response) | CCPMasterBase |
CanWrite (defined in CCPMaster) | CCPMaster |
CCPErrorReceived | CCPMaster |
CCPEventReceived | CCPMaster |
CCPMaster(ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf, ICANProvider canProvider, EventHandler onConnectionStateChanged, EventHandler< CCPEventArgs > onCCPEventReceived, EventHandler< CCPErrorArgs > onCCPErrorReceived) | CCPMaster |
CCPMasterBase(ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf) | CCPMasterBase |
ChangeEndianess | CommMaster | protected
ClearMemory(uint size) | CCPMasterBase |
CommMaster(ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf) | CommMaster |
configureMeasurements(IList< DAQMeasurement > measurements) | CCPMaster | virtual
Connect() | CCPMasterBase |
ConnectBehaviour | CommMaster |
Connected | CommMaster |
ConnectionStateChanged | CommMaster |
ConnectResponse | CCPMaster |
copyPage2Page(ECUPage srcPage, ECUPage dstPage) | CCPMaster | virtual
DAQs | CommMaster |
DiagService(ushort No, out RespActionDiagService response) | CCPMasterBase |
Disconnect(int useTimeout=-1) | CCPMaster | virtual
jnsoft::Comm::CCP::CCPMasterBase.Disconnect(DisconnectMode mode, int useTimeout=-1) | CCPMasterBase |
Dispose() | CCPMaster | virtual
Download(byte[] bytes, out RespDownload response) | CCPMasterBase |
Download6(byte[] bytes, out RespDownload response) | CCPMasterBase |
epkCheck(A2LMOD_PAR modPar, out string epkFromDevice) | CommMaster |
epkCheck(uint epkAddress, string expectedEPK, out string epkFromDevice) | CommMaster |
ErrorsReceived | CommMaster |
EventsReceived | CommMaster |
ExchangeID(out RespExchangeID response) | CCPMasterBase |
ExchangeIDResponse | CCPMaster |
ExchangeIDStr | CCPMaster |
FramesReceived | CommMaster |
FramesSent | CommMaster |
GetActiveCALPage(out RespGetActiveCALPage response) | CCPMasterBase |
getAliveCycleTime() | CCPMasterBase | virtual
GetCCPVersions(byte desiredMain, byte desiredRelease, out RespGetCCPVersion response) | CCPMasterBase |
getChecksum(byte addressExtension, uint address, uint size, out uint checksum) | CCPMaster | virtual
getDAQPhysValue(A2LMEASUREMENT measurement, out double value) | CommMaster |
getDAQPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, out double rawValue) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | CommMaster | virtual
GetDAQSize(byte daqNo, uint canId, out RespGetDAQSize response) | CCPMasterBase |
getOperatingPoint(A2LCHARACTERISTIC characteristic) | CommMaster |
GetSeed(ResourceType resource, out RespGetSeed response, out byte[] seed) | CCPMasterBase |
GetStatus(out RespGetSStatus response) | CCPMasterBase |
getTransmissionRate(out double bitsPerSec) | CommMaster |
Interface | CommMaster |
internalConnect() | CCPMasterBase | virtual
internalGetStatus() | CCPMasterBase | virtual
isAllowedRequest(CommandCode cmd) | CCPMaster | virtual
IsDAQRunning | CCPMaster |
LastErrorEnum (defined in CCPMasterBase) | CCPMasterBase |
LastErrorResponse | CCPMasterBase |
LastErrorText (defined in CCPMasterBase) | CCPMasterBase |
LastReceivedTime | CommMaster |
LastResponse | CCPMasterBase |
LastStateChange | CommMaster |
mAdaptiveCharDict | CommMaster | protected
mapAddress(uint address) | CCPMaster | virtual
mBitsTransferred (defined in CommMaster) | CommMaster | protected
mCCPIf (defined in CCPMasterBase) | CCPMasterBase | protected
mDataFiles | CommMaster | protected
MeasurementAccessData | CommMaster |
Move(uint size) | CCPMasterBase |
mSeedAndKeyDLL (defined in CommMaster) | CommMaster | protected
mStrTrimmer | CommMaster | static
onDAQFrameReceived(CCPFrame ccpFrame) | CCPMaster | virtual
onErrorReceived(CmdResult result, CommandCode code) | CCPMaster | virtual
onEventReceived(CCPFrame ccpFrame) | CCPMaster | virtual
OnValuesReceived | CommMaster |
Program(byte[] bytes, out RespDownload response) | CCPMasterBase |
Program6(byte[] bytes, out RespDownload response) | CCPMasterBase |
programSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null) | CCPMaster | virtual
RaiseConnectionStateChanged() | CommMaster |
RaiseOnValuesReceived(int daqListNo, double seconds, byte[] data) | CommMaster |
readCharacteristic(ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
readSync(int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CCPMaster | virtual
resetLastError() | CCPMasterBase | virtual
SeedAndKeyDLL | CommMaster |
SelectCALPage() | CCPMasterBase |
ServicesReceived | CommMaster |
setConnectionState< T >(T respConnect) | CCPMaster | virtual
SetDAQPtr(byte daqListNo, byte ODTNo, byte elmentNo) | CCPMasterBase |
SetMTA(byte mtaNo, byte addressExtension, uint address) | CCPMasterBase |
setPage(ECUPage page) | CCPMaster | virtual
SetStatus(SessionState state) | CCPMasterBase |
ShortUp(byte size, byte addressExtension, uint address, out byte[] respData) | CCPMasterBase |
SourceAndRasterMap | CCPMaster |
startMeasurements(bool doSynchronized) | CCPMaster | virtual
StartStop(StartStopMode mode, byte daqNo, byte lastODTNo, byte evtChnNo, ushort prescaler) | CCPMasterBase |
StartStopAll(StartStopMode mode) | CCPMasterBase |
StatusResponse | CCPMaster |
stopMeasurements(bool doSynchronized) | CCPMaster | virtual
Unlock(byte[] key, out RespUnlock response) | CCPMasterBase |
unlockECU(NativeSKDLL seedAndKeyDLL, ResourceType resource) | CCPMaster |
unlockECU(NativeSKDLL seedAndKeyDAQDLL, NativeSKDLL seedAndKeyCALDLL, NativeSKDLL seedAndKeyPGMDLL, ResourceType resource) | CCPMaster |
Upload(byte size, out byte[] respData) | CCPMasterBase |
Version | CCPMaster |
writeCharacteristic(IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
WriteDAQ(byte size, byte extension, uint address) | CCPMasterBase |
writeSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CCPMaster | virtual


ASAP2Library interface: CCPMasterBase Class Reference

  • Comm
  • CCP
  • CCPMasterBase
Public Member Functions | Protected Attributes | Properties | List of all members
CCPMasterBase Class Referenceabstract

Implements the CCP Master base communication with a CCP Slave. More...

Public Member Functions

CCPMasterBase (ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf)
Creates a XCPonCAN communication master. More...
CmdResult | ActionService (ushort No, out RespActionDiagService response)
Action/Diagnostic Service More...
CmdResult | BuildChecksum (uint blockSize, out RespBuildChecksum response)
Build checksum over memory range. More...
CmdResult | ClearMemory (uint size)
Clear memory. More...
CmdResult Connect ()
Sets up connection with a CCP slave. More...
CmdResult | DiagService (ushort No, out RespActionDiagService response)
Diagnostic Service More...
bool | Disconnect (DisconnectMode mode, int useTimeout=-1)
Disconnect from slave. More...
override bool | Disconnect (int useTimeout=-1)
Disconnects the master from the slave. More...
CmdResult | Download (byte[] bytes, out RespDownload response)
Download from master to slave More...
CmdResult | Download6 (byte[] bytes, out RespDownload response)
Download 6 bytes from master to slave More...
CmdResult | ExchangeID (out RespExchangeID response)
Get the Exchange Station Identifications from slave. More...
CmdResult | GetActiveCALPage (out RespGetActiveCALPage response)
Get currently active Calibration Page from slave. More...
override int | getAliveCycleTime ()
Gets the alive cycle time in [ms]. More...
CmdResult | GetCCPVersions (byte desiredMain, byte desiredRelease, out RespGetCCPVersion response)
Get the CCP version from slave. More...
CmdResult | GetDAQSize (byte daqNo, uint canId, out RespGetDAQSize response)
Get the DAQ List size from slave. More...
CmdResult | GetSeed (ResourceType resource, out RespGetSeed response, out byte[] seed)
Get Seed for Key from slave. More...
CmdResult | GetStatus (out RespGetSStatus response)
Get current session status from slave. More...
sealed override bool | internalConnect ()
Tries to connect to a XCP/CCP slave More...
sealed override bool | internalGetStatus ()
Get current session status from slave. More...
abstract bool | isAllowedRequest (CommandCode cmd)
Returns true if the command is allowed to request. More...
CmdResult | Move (uint size)
Move memory block. More...
virtual void | onDAQFrameReceived (CCPFrame ccpFrame)
Called if a DAQ frame is received from the slave. More...
virtual void | onErrorReceived (CmdResult result, CommandCode code)
Called, if an error response is received from the slave. More...
virtual void | onEventReceived (CCPFrame ccpFrame)
Called if an event is received from the slave. More...
CmdResult | Program (byte[] bytes, out RespDownload response)
Program from master to slave More...
CmdResult | Program6 (byte[] bytes, out RespDownload response)
Program 6 bytes from master to slave More...
sealed override void | resetLastError ()
Reset the last error More...
CmdResult SelectCALPage ()
Select Calibration Data Page from slave. More...
override void | setConnectionState< T > (T respConnect)
Called from the CommKernel if the connection state gets changed. More...
CmdResult | SetDAQPtr (byte daqListNo, byte ODTNo, byte elmentNo)
Set DAQ list pointer. More...
CmdResult | SetMTA (byte mtaNo, byte addressExtension, uint address)
Set Memory Transfer Address. More...
CmdResult | SetStatus (SessionState state)
Set Session Status from slave. More...
CmdResult | ShortUp (byte size, byte addressExtension, uint address, out byte[] respData)
Get the short upload from slave. More...
CmdResult | StartStop (StartStopMode mode, byte daqNo, byte lastODTNo, byte evtChnNo, ushort prescaler)
Start / Stop Data transmission. More...
CmdResult | StartStopAll (StartStopMode mode)
Start / Stop Synchronised Data transmission. More...
CmdResult | Unlock (byte[] key, out RespUnlock response)
Get the Unlock Protection from slave. More...
CmdResult | Upload (byte size, out byte[] respData)
Get the Data upload from slave. More...
CmdResult | WriteDAQ (byte size, byte extension, uint address)
Write DAQ list entry. More...
- Public Member Functions inherited from CommMaster
CommMaster (ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf)
Creates a communication master. More...
void | addAdaptiveCharacteristics (A2LPROJECT project, List< IDataFile > dataFiles)
Adds all defined adaptive characteristics to the adaptive characteristic list. More...
abstract void | configureMeasurements (IList< DAQMeasurement > measurements)
(Re)Configures the specified measurements for data acquisition. More...
abstract bool | copyPage2Page (ECUPage srcPage, ECUPage dstPage)
Copy data from one ECU page to another. More...
virtual void | Dispose ()
Frees used resources. More...
EPKCheckResult | epkCheck (A2LMOD_PAR modPar, out string epkFromDevice)
Online EPK check. More...
EPKCheckResult | epkCheck (uint epkAddress, string expectedEPK, out string epkFromDevice)
Online EPK check. More...
abstract bool | getChecksum (byte addressExtension, uint address, uint size, out uint checksum)
Get the checksum from the slave. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
virtual bool | getDAQRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getDAQRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
double[] | getOperatingPoint (A2LCHARACTERISTIC characteristic)
Returns an array of operating points if available. More...
void | getTransmissionRate (out double bitsPerSec)
Gets the current transmission rate. More...
abstract uint | mapAddress (uint address)
Maps the specified address using A2L defined mapping tables. More...
abstract bool | programSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null)
Program data synchronously to the ECU. More...
void | RaiseConnectionStateChanged ()
Raises the ConnectionStateChanged event.
void | RaiseOnValuesReceived (int daqListNo, double seconds, byte[] data)
Raises the OnValuesReceived event with the pecified parameters. More...
bool | readCharacteristic (ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null)
Read the characteristic value from the ECU into the specified datafile. More...
abstract bool | readSync (int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Read data synchronously from the ECU. More...
abstract bool | setPage (ECUPage page)
Sets the specified page as active page. More...
abstract bool | startMeasurements (bool doSynchronized)
Starts a (previously configured by configureMeasurements) data acquisition. More...
abstract bool | stopMeasurements (bool doSynchronized)
Stops a running data acquisition. More...
bool | writeCharacteristic (IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null)
Write the characteristic value read from the specified datafile to the device. More...
abstract bool | writeSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Write data synchronously to the ECU. More...

Protected Attributes

A2LCCP_TP_BLOB | mCCPIf
- Protected Attributes inherited from CommMaster
IDictionary< ulong, AdaptiveState > | mAdaptiveCharDict = new Dictionary<ulong, AdaptiveState>()
The adaptive characteristics dictionary.
long | mBitsTransferred
List< IDataFile > | mDataFiles
The list of data files to write adaptive characteristics into.
NativeSKDLL | mSeedAndKeyDLL

Properties

sealed override Enum | LastErrorEnum [get]
CmdResult | LastErrorResponse = CmdResult.OK [get]
The last error occured.
sealed override string | LastErrorText [get]
CCPFrame | LastResponse [getset]
Last received response.
- Properties inherited from CommMaster
abstract ECUPage | ActivePage [get]
The currently active calibration page More...
abstract bool | CanWrite [get]
Indicates if writing to the XCP/CCP mmaster is allowed. More...
bool | ChangeEndianess [getset]
Indicates if XCP Master and Slave byte orders differ. More...
ConnectBehaviourType | ConnectBehaviour [getset]
Gets or sets the connection behavior.
virtual bool | Connected [getprotected set]
Indicates, if the master is connected to the slave device.
DAQDict | DAQs [getprotected set]
The configured DAQ dictionary.
ulong | ErrorsReceived [getprotected set]
The amount of errors received since connection is established.
ulong | EventsReceived [getprotected set]
The amount of events received since connection is established.
ulong | FramesReceived [getprotected set]
The amount of frames received since connection is established.
ulong | FramesSent [getprotected set]
The amount of frames sent since connection is established.
A2LIF_DATA | Interface [get]
Gets the corresponding A2L communication interface.
abstract Enum | LastErrorEnum [get]
Gets the last error occured as enum.
abstract string | LastErrorText [get]
Gets the last error occured as text.
long | LastReceivedTime [getprotected set]
Indicates the timestamp the last byte was received from a slave.
DateTime | LastStateChange [getprotected set]
Returns the last state change (DateTime.MinValue if never changed).
ASAP2.Values.MeasurementAccessData | MeasurementAccessData [getset]
Gets or sets the measurement access data.
NativeSKDLL | SeedAndKeyDLL [getset]
Gets or sets the Seed&Key DLL.
ulong | ServicesReceived [getprotected set]
The amount of service requests received since connection is established.

Additional Inherited Members

- Static Public Attributes inherited from CommMaster
static readonly char[] | mStrTrimmer = new char[] { '\0', '\xFF', ' ' }
Used to trim EPK or ID strings.
- Events inherited from CommMaster
EventHandler | ConnectionStateChanged
Called if a XCP/CCP connection state changes. More...
EventHandler< ValuesReceivedEventArgs > | OnValuesReceived
Called if a XCP/CCP data acquisition data is received. More...

Detailed Description

Implements the CCP Master base communication with a CCP Slave.

  • All commands are implemented as synchronous calls to the slave
  • All commands are thread-safe
  • The endianess of any command, response or event is converted automatically according the CCP protocol
  • Responses (out parameter) of commands are only valid if the CmdResult of the call is CmdResult.OK

Constructor & Destructor Documentation

◆ CCPMasterBase()

CCPMasterBase | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LCCP_TP_BLOB | ccpIf
 | ) |  |

Creates a XCPonCAN communication master.

Parameters
connectBehavior | Client's connect behaviour
ccpIf | A2L CCP interface instance (ASAP1B_CCP)

Member Function Documentation

◆ ActionService()

CmdResult ActionService | ( | ushort | No,
 |  | out RespActionDiagService | response
 | ) |  |

Action/Diagnostic Service

Parameters
No | Action service number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ BuildChecksum()

CmdResult BuildChecksum | ( | uint | blockSize,
 |  | out RespBuildChecksum | response
 | ) |  |

Build checksum over memory range.

Returns a checksum result of the memory block that is defined by MTA0 (memory transfer area start address) and block size.The checksum algorithm may be manufacturer and / or project specific, it is not part of this specification.

Parameters
blockSize | The block size
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ ClearMemory()

CmdResult ClearMemory ( uint size )

Clear memory.

This command may be used to erase FLASH EPROM prior to reprogramming. The MTA0 pointer points to the memory location to be erased.

Parameters
size Size (number of bytes) of data block to be cleared
Returns
The corresponding command result

◆ Connect()

CmdResult Connect ( )

Sets up connection with a CCP slave.

This command establishes a continuous, logical, point-to-point connection with a slave device. During a running a CCP session (CONNECTED) this command has no influence on any configuration of the CCP slave driver.

A slave device does not respond to any other commands (except auto detection) unless it is in the state CONNECTED.

Returns
The corresponding command result

◆ DiagService()

CmdResult DiagService | ( | ushort | No,
 |  | out RespActionDiagService | response
 | ) |  |

Diagnostic Service

Parameters
No | Diagnostic service number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ Disconnect() [1/2]

bool Disconnect | ( | DisconnectMode | mode,
 |  | int | useTimeout = -1
 | ) |  |

Disconnect from slave.

Brings the slave to the “DISCONNECTED” state. The DISCONNECTED” state is described in Part 1, chapter “state machine”.

Parameters
mode The disconnect mode
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

◆ Disconnect() [2/2]

override bool Disconnect ( int useTimeout = -1 )
virtual

Disconnects the master from the slave.

Parameters
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

Implements CommMaster.

◆ Download()

CmdResult Download | ( | byte[] | bytes,
 |  | out RespDownload | response
 | ) |  |

Download from master to slave

The data block of the specified length (size) contained in the CRO will be copied into memory, starting at the current Memory Transfer Address 0 (MTA0). The MTA0 pointer will be post-incremented by the value of 'size'.

Parameters
bytes | data to be transferred (up to 5 bytes)
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentOutOfRangeException Thrown if the length of bytes exceeds 5

◆ Download6()

CmdResult Download6 | ( | byte[] | bytes,
 |  | out RespDownload | response
 | ) |  |

Download 6 bytes from master to slave

The data block of the specified length (size) contained in the CRO will be copied into memory, starting at the current Memory Transfer Address 0 (MTA0). The MTA0 pointer will be post-incremented by the value of 'size'.

Parameters
bytes | 6 bytes of data to be transferred
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentOutOfRangeException Thrown if the length of bytes is not 6

◆ ExchangeID()

CmdResult ExchangeID ( out RespExchangeID response )

Get the Exchange Station Identifications from slave.

The CCP master and slave stations exchange IDs for automatic session configuration. This might include automatic assignment of a data acquisition setup file depending on the slave's returned ID (Plug´n´Play).

The slave device automatically sets the Memory Transfer Address 0 (MTA0) to the location from which the CCP master may subsequently upload the requested ID using UPLOAD. See also the SetMTA and Upload command description.

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetActiveCALPage()

CmdResult GetActiveCALPage ( out RespGetActiveCALPage response )

Get currently active Calibration Page from slave.

This command returns the start address of the calibration page that is currently active in the slave device.

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ getAliveCycleTime()

override int getAliveCycleTime ( )
virtual

Gets the alive cycle time in [ms].

Returns

Implements CommMaster.

◆ GetCCPVersions()

CmdResult GetCCPVersions | ( | byte | desiredMain,
 |  | byte | desiredRelease,
 |  | out RespGetCCPVersion | response
 | ) |  |

Get the CCP version from slave.

This command performs a mutual identification of the protocol version used in the master and in the slave device to aggree on a common protocol version. This command is expected to be executed prior to the EXCHANGE_ID command.

Parameters
desiredMain | The desired main version
desiredRelease | The desired release version
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQSize()

CmdResult GetDAQSize | ( | byte | daqNo,
 |  | uint | canId,
 |  | out RespGetDAQSize | response
 | ) |  |

Get the DAQ List size from slave.

Returns the size of the specified DAQ list as the number of available Object DescriptorTables (ODTs) and clears the current list. If the specified list number is not available, size = 0 should be returned. The DAQ list is initialized and data acquisition by this list is stopped. An individual CAN Identifier may be assigned to a DAQ list to configure multi ECU data acquisition. This feature is optional. If the given identifier isn’t possible, an error code is returned. 29 bit CAN identifiers are marked by the most significant bit set.

Parameters
daqNo | DAQ list number (0,1,...)
canId | CAN Identifier of DTO dedicated to list number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSeed()

CmdResult GetSeed | ( | ResourceType | resource,
 |  | out RespGetSeed | response,
 |  | out byte[] | seed
 | ) |  |

Get Seed for Key from slave.

See ExchangeID for a description of the resource mask. Only one resource or function may be requested with one GetSeed command If more than one resource is requested, the GetSeed command together with the following Unlock command has to be performed multiple times.

Returns ´seed´ data for a seed&key algorithm for computing the ´key´ to unlock the requested function for authorized access.

Parameters
resource | Requested slave resource or function (Resource Mask)
response | The slave response (only valid if return value is CMDResult.OK, else null)
seed | The seed bytes (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetStatus()

CmdResult GetStatus ( out RespGetSStatus response )

Get current session status from slave.

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ internalConnect()

sealed override bool internalConnect ( )
virtual

Tries to connect to a XCP/CCP slave

Used by the CommKernel.

Returns
true if successful

Reimplemented from CommMaster.

◆ internalGetStatus()

sealed override bool internalGetStatus ( )
virtual

Get current session status from slave.

Used by the CommKernel.

Returns
true if successful

Implements CommMaster.

◆ isAllowedRequest()

abstract bool isAllowedRequest ( CommandCode cmd )
pure virtual

Returns true if the command is allowed to request.

Parameters
cmd The CCP command
Returns
true if the optional command is allowed to execute

Implemented in CCPMaster.

◆ Move()

CmdResult Move ( uint size )

Move memory block.

A data block of the specified length (size) will be copied from the address defined by MTA 0 (source pointer) to the address defined by MTA 1 (destination pointer).

Parameters
size Size (number of bytes) of data block to be moved
Returns
The corresponding command result

◆ onDAQFrameReceived()

virtual void onDAQFrameReceived ( CCPFrame ccpFrame )
virtual

Called if a DAQ frame is received from the slave.

Parameters
ccpFrame The corresponding received frame

Reimplemented in CCPMaster.

◆ onErrorReceived()

virtual void onErrorReceived | ( | CmdResult | result,
 |  | CommandCode | code
 | ) |  |
virtual

Called, if an error response is received from the slave.

Parameters
result | The command result
code | The corresponding command code

Reimplemented in CCPMaster.

◆ onEventReceived()

virtual void onEventReceived ( CCPFrame ccpFrame )
virtual

Called if an event is received from the slave.

Parameters
ccpFrame The corresponding received frame

Reimplemented in CCPMaster.

◆ Program()

CmdResult Program | ( | byte[] | bytes,
 |  | out RespDownload | response
 | ) |  |

Program from master to slave

The data block of the specified length (size) contained in the CRO will be copied into memory, starting at the current Memory Transfer Address 0 (MTA0). The MTA0 pointer will be post-incremented by the value of 'size'.

Parameters
bytes | data to be transferred (up to 5 bytes)
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentOutOfRangeException Thrown if the length of bytes exceeds 5

◆ Program6()

CmdResult Program6 | ( | byte[] | bytes,
 |  | out RespDownload | response
 | ) |  |

Program 6 bytes from master to slave

The data block of the specified length (size) contained in the CRO will be copied into memory, starting at the current Memory Transfer Address 0 (MTA0). The MTA0 pointer will be post-incremented by the value of 'size'.

Parameters
bytes | 6 bytes of data to be transferred
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentOutOfRangeException Thrown if the length of bytes is not 6

◆ resetLastError()

sealed override void resetLastError ( )
virtual

Reset the last error

Implements CommMaster.

◆ SelectCALPage()

CmdResult SelectCALPage ( )

Select Calibration Data Page from slave.

This command's function depends on the ECU implementation. The previously initialized MTA0 points to the start of the calibration data page that is selected as the currently active page by this command.

Returns
The corresponding command result

◆ setConnectionState< T >()

override void setConnectionState< T > ( T respConnect )
virtual

Called from the CommKernel if the connection state gets changed.

Parameters
respConnect A valid connect response instance if the device gets connected, null if the device gets disconnected.

Implements CommMaster.

◆ SetDAQPtr()

CmdResult SetDAQPtr | ( | byte | daqListNo,
 |  | byte | ODTNo,
 |  | byte | elmentNo
 | ) |  |

Set DAQ list pointer.

Initializes the DAQ list pointer for a subsequent write to a DAQ list. See also 'Organization of Data Acquisition Messages'.

Parameters
daqListNo | DAQ list number
ODTNo | Object Descriptor Table ODT number
elmentNo | Element number within ODT
Returns
The corresponding command result

◆ SetMTA()

CmdResult SetMTA | ( | byte | mtaNo,
 |  | byte | addressExtension,
 |  | uint | address
 | ) |  |

Set Memory Transfer Address.

This command will initialize a base pointer (32Bit + extension) for all following memory transfers. The address extension depends on the slave controller's organization and may identify a switchable memory bank or a memory segment.

The MTA number (handle) is used to identify different transfer address locations (pointers). MTA0 is used by the commands DNLOAD, UPLOAD, DNLOAD_6 , SELECT_CAL_PAGE, CLEAR_MEMORY, PROGRAM and PROGRAM_6. MTA1 is used by the MOVE command. See also command ‘MOVE’.

Parameters
mtaNo | Memory transfer address MTA number (0,1)
addressExtension | Address extension
address | The address to set
Returns

◆ SetStatus()

CmdResult SetStatus ( SessionState state )

Set Session Status from slave.

Keeps the slave node informed about the current state of the calibration session.

Parameters
state The session status
Returns
The corresponding command result

◆ ShortUp()

CmdResult ShortUp | ( | byte | size,
 |  | byte | addressExtension,
 |  | uint | address,
 |  | out byte[] | respData
 | ) |  |

Get the short upload from slave.

A data block of the specified length (size), starting at source address will be copied into the corresponding DTO data field. The MTA0 pointer remains unchanged

Parameters
size | The count of elements to upload
addressExtension | The address extension
address | The address
respData | The uploaded data
Returns
The corresponding command result

◆ StartStop()

CmdResult StartStop | ( | StartStopMode | mode,
 |  | byte | daqNo,
 |  | byte | lastODTNo,
 |  | byte | evtChnNo,
 |  | ushort | prescaler
 | ) |  |

Start / Stop Data transmission.

This command is used to start or to stop the data acquisition or to prepare a synchronized start of the specified DAQ list.The Last ODT number specifies which ODTs (From 0 to Last ODT number) of this DAQ list should be transmitted.The Event Channel No. specifies the generic signal source that effectively determines the data transmission timing. To allow reduction of the desired transmission rate, a prescaler may be applied to the Event Channel.The prescaler value factor must be greater than or equal to 1. The mode parameter is defined as follows: 0x00 stops specified DAQ list, 0x01 starts specified DAQ list, 0x02 prepares DAQ list for synchronised start. The start/stop mode parameter = 0x02(prepare to start data transmission) configures the DAQ list with the provided parameters but does not start the data acquisition of the specified list.This parameter is used for a synchronized start of all configured DAQ lists. In case the slave device is not capable of performing the synchronized start of the data acquisition, the slave device may then start data transmission if this parameter is TRUE (not zero). The ECU specific properties of event channels and DAQ lists may be described in the slave device description(ASAP2).

Parameters
mode | Mode : start / stop / prepare data tranmission
daqNo | DAQ list number
lastODTNo | Last ODT number
evtChnNo | Event Channel No.
prescaler | Transmission rate prescaler
Returns
The corresponding command result

◆ StartStopAll()

CmdResult StartStopAll ( StartStopMode mode )

Start / Stop Synchronised Data transmission.

This command is used to start the periodic transmission of all DAQ lists configured with the previously sent START_STOP command(start/stop modus = 2) as „prepared to start“ in a synchronized manner.The command is used to stop the periodic transmission of all DAQ lists, including those not started synchronized.

Parameters
mode Stop or Start data transmission (The StartStopSynchMode.StopSelected is not valid on CCP)
Returns
The corresponding command result

◆ Unlock()

CmdResult Unlock | ( | byte[] | key,
 |  | out RespUnlock | response
 | ) |  |

Get the Unlock Protection from slave.

Unlocks the slave devices security protection (if applicable) using a ´key´ computed from ´seed´.

Parameters
key | Requested slave resource or function (Resource Mask)
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ Upload()

CmdResult Upload | ( | byte | size,
 |  | out byte[] | respData
 | ) |  |

Get the Data upload from slave.

A data block of the specified length (size), starting at current MTA0, will be copied into the corresponding DTO data field. The MTA0 pointer will be post-incremented by the value of 'size'.

Parameters
size | The count of elements to upload
respData | The uploaded data
Returns
The corresponding command result

◆ WriteDAQ()

CmdResult WriteDAQ | ( | byte | size,
 |  | byte | extension,
 |  | uint | address
 | ) |  |

Write DAQ list entry.

Writes one entry (description of single DAQ element) to a DAQ list defined by the DAQ list pointer(see SET_DAQ_PTR). The following DAQ element sizes are defined: 1 byte, 2 bytes(type word), 4 bytes(type long / Float).

An ECU may not support individual address extensions for each element and 2 or 4 byte element sizes.It is the responsibility of the master device to care for the ECU limitations. The limitations may be defined in the slave device description file(e.g.ASAP2). It is the responsibility of the slave device, that all bytes of a DAQ element are consistent upon transmission.

Parameters
size | Size of DAQ element in bytes { 1, 2, 4 }
extension | Address extension of DAQ element
address | Address of DAQ element
Returns
The corresponding command result


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPMasterBase
CCPMasterBase Member List

This is the complete list of members for CCPMasterBase, including all inherited members.

ActionService(ushort No, out RespActionDiagService response) | CCPMasterBase |
ActivePage | CommMaster |
addAdaptiveCharacteristics(A2LPROJECT project, List< IDataFile > dataFiles) | CommMaster |
BuildChecksum(uint blockSize, out RespBuildChecksum response) | CCPMasterBase |
CanWrite | CommMaster |
CCPMasterBase(ConnectBehaviourType connectBehavior, A2LCCP_TP_BLOB ccpIf) | CCPMasterBase |
ChangeEndianess | CommMaster | protected
ClearMemory(uint size) | CCPMasterBase |
CommMaster(ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf) | CommMaster |
configureMeasurements(IList< DAQMeasurement > measurements) | CommMaster | pure virtual
Connect() | CCPMasterBase |
ConnectBehaviour | CommMaster |
Connected | CommMaster |
ConnectionStateChanged | CommMaster |
copyPage2Page(ECUPage srcPage, ECUPage dstPage) | CommMaster | pure virtual
DAQs | CommMaster |
DiagService(ushort No, out RespActionDiagService response) | CCPMasterBase |
Disconnect(DisconnectMode mode, int useTimeout=-1) | CCPMasterBase |
Disconnect(int useTimeout=-1) | CCPMasterBase | virtual
Dispose() | CommMaster | virtual
Download(byte[] bytes, out RespDownload response) | CCPMasterBase |
Download6(byte[] bytes, out RespDownload response) | CCPMasterBase |
epkCheck(A2LMOD_PAR modPar, out string epkFromDevice) | CommMaster |
epkCheck(uint epkAddress, string expectedEPK, out string epkFromDevice) | CommMaster |
ErrorsReceived | CommMaster |
EventsReceived | CommMaster |
ExchangeID(out RespExchangeID response) | CCPMasterBase |
FramesReceived | CommMaster |
FramesSent | CommMaster |
GetActiveCALPage(out RespGetActiveCALPage response) | CCPMasterBase |
getAliveCycleTime() | CCPMasterBase | virtual
GetCCPVersions(byte desiredMain, byte desiredRelease, out RespGetCCPVersion response) | CCPMasterBase |
getChecksum(byte addressExtension, uint address, uint size, out uint checksum) | CommMaster | pure virtual
getDAQPhysValue(A2LMEASUREMENT measurement, out double value) | CommMaster |
getDAQPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, out double rawValue) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | CommMaster | virtual
GetDAQSize(byte daqNo, uint canId, out RespGetDAQSize response) | CCPMasterBase |
getOperatingPoint(A2LCHARACTERISTIC characteristic) | CommMaster |
GetSeed(ResourceType resource, out RespGetSeed response, out byte[] seed) | CCPMasterBase |
GetStatus(out RespGetSStatus response) | CCPMasterBase |
getTransmissionRate(out double bitsPerSec) | CommMaster |
Interface | CommMaster |
internalConnect() | CCPMasterBase | virtual
internalGetStatus() | CCPMasterBase | virtual
isAllowedRequest(CommandCode cmd) | CCPMasterBase | pure virtual
LastErrorEnum (defined in CCPMasterBase) | CCPMasterBase |
LastErrorResponse | CCPMasterBase |
LastErrorText (defined in CCPMasterBase) | CCPMasterBase |
LastReceivedTime | CommMaster |
LastResponse | CCPMasterBase |
LastStateChange | CommMaster |
mAdaptiveCharDict | CommMaster | protected
mapAddress(uint address) | CommMaster | pure virtual
mBitsTransferred (defined in CommMaster) | CommMaster | protected
mCCPIf (defined in CCPMasterBase) | CCPMasterBase | protected
mDataFiles | CommMaster | protected
MeasurementAccessData | CommMaster |
Move(uint size) | CCPMasterBase |
mSeedAndKeyDLL (defined in CommMaster) | CommMaster | protected
mStrTrimmer | CommMaster | static
onDAQFrameReceived(CCPFrame ccpFrame) | CCPMasterBase | virtual
onErrorReceived(CmdResult result, CommandCode code) | CCPMasterBase | virtual
onEventReceived(CCPFrame ccpFrame) | CCPMasterBase | virtual
OnValuesReceived | CommMaster |
Program(byte[] bytes, out RespDownload response) | CCPMasterBase |
Program6(byte[] bytes, out RespDownload response) | CCPMasterBase |
programSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null) | CommMaster | pure virtual
RaiseConnectionStateChanged() | CommMaster |
RaiseOnValuesReceived(int daqListNo, double seconds, byte[] data) | CommMaster |
readCharacteristic(ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
readSync(int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual
resetLastError() | CCPMasterBase | virtual
SeedAndKeyDLL | CommMaster |
SelectCALPage() | CCPMasterBase |
ServicesReceived | CommMaster |
setConnectionState< T >(T respConnect) | CCPMasterBase | virtual
SetDAQPtr(byte daqListNo, byte ODTNo, byte elmentNo) | CCPMasterBase |
SetMTA(byte mtaNo, byte addressExtension, uint address) | CCPMasterBase |
setPage(ECUPage page) | CommMaster | pure virtual
SetStatus(SessionState state) | CCPMasterBase |
ShortUp(byte size, byte addressExtension, uint address, out byte[] respData) | CCPMasterBase |
startMeasurements(bool doSynchronized) | CommMaster | pure virtual
StartStop(StartStopMode mode, byte daqNo, byte lastODTNo, byte evtChnNo, ushort prescaler) | CCPMasterBase |
StartStopAll(StartStopMode mode) | CCPMasterBase |
stopMeasurements(bool doSynchronized) | CommMaster | pure virtual
Unlock(byte[] key, out RespUnlock response) | CCPMasterBase |
Upload(byte size, out byte[] respData) | CCPMasterBase |
writeCharacteristic(IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
WriteDAQ(byte size, byte extension, uint address) | CCPMasterBase |
writeSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual


ASAP2Library interface: CCPonCAN Class Reference

  • Comm
  • CCP
  • CCPonCAN
Public Member Functions | Protected Member Functions | List of all members
CCPonCAN Class Reference

Base class implementing the CCP based communication instance. More...

Public Member Functions

override void Dispose ()
Disposes all used resources. More...

Protected Member Functions

override void close ()
Closes the communication (frees all used resources). More...

Detailed Description

Base class implementing the CCP based communication instance.

Member Function Documentation

◆ close()

override void close ( )
protectedvirtual

Closes the communication (frees all used resources).

  • Any derived class has to implement this method.

Reimplemented from Communicator.

◆ Dispose()

override void Dispose ( )
virtual

Disposes all used resources.

Inparticular:

  • The communication channel

Reimplemented from Communicator.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CCPonCAN
CCPonCAN Member List

This is the complete list of members for CCPonCAN, including all inherited members.

close() | CCPonCAN | protectedvirtual
Dispose() | CCPonCAN | virtual


ASAP2Library interface: CmdActionDiagService Class Reference

  • Comm
  • CCP
  • CmdActionDiagService
Public Member Functions | Public Attributes | List of all members
CmdActionDiagService Class Reference

Supports CCP commands Diag and Action service. More...

Public Member Functions

override void changeEndianness ()
- Public Member Functions inherited from CmdBase
CmdBase ()
Internal use only!

Public Attributes

ushort No

Detailed Description

Supports CCP commands Diag and Action service.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Reimplemented from CmdBase.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CmdActionDiagService
CmdActionDiagService Member List

This is the complete list of members for CmdActionDiagService, including all inherited members.

changeEndianness() (defined in CmdActionDiagService) | CmdActionDiagService | virtual
CmdActionDiagService() (defined in CmdActionDiagService) | CmdActionDiagService |
CmdBase() | CmdBase |
No (defined in CmdActionDiagService) | CmdActionDiagService |


ASAP2Library interface: CmdBase Class Reference

  • Comm
  • CCP
  • CmdBase
Public Member Functions | List of all members
CmdBase Class Reference

Base class represents a CCP command. More...

Public Member Functions

CmdBase ()
Internal use only!
virtual void changeEndianness ()

Detailed Description

Base class represents a CCP command.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CmdBase
CmdBase Member List

This is the complete list of members for CmdBase, including all inherited members.

changeEndianness() (defined in CmdBase) | CmdBase | virtual
CmdBase() | CmdBase |


ASAP2Library interface: CmdMoveClearBC Class Reference

  • Comm
  • CCP
  • CmdMoveClearBC
Public Member Functions | Public Attributes | List of all members
CmdMoveClearBC Class Reference

Supports CCP commands Move, Clear memory, BuildChksum. More...

Public Member Functions

override void changeEndianness ()
- Public Member Functions inherited from CmdBase
CmdBase ()
Internal use only!

Public Attributes

uint Size

Detailed Description

Supports CCP commands Move, Clear memory, BuildChksum.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Reimplemented from CmdBase.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • CmdMoveClearBC
CmdMoveClearBC Member List

This is the complete list of members for CmdMoveClearBC, including all inherited members.

changeEndianness() (defined in CmdMoveClearBC) | CmdMoveClearBC | virtual
CmdBase() | CmdBase |
CmdMoveClearBC() (defined in CmdMoveClearBC) | CmdMoveClearBC |
Size (defined in CmdMoveClearBC) | CmdMoveClearBC |


ASAP2Library interface: DAQDictCCP Class Reference

  • Comm
  • CCP
  • DAQDictCCP
List of all members
DAQDictCCP Class Reference

Holds a dictionary of configured DAQ Lists. More...

Additional Inherited Members

- Public Member Functions inherited from DAQDict
new void | Clear ()
Clears all the configured ODTs. More...
void | clearData ()
Clears all data received within the DAQ list dictionary.
ODTEntry | getODTEntry (A2LMEASUREMENT measurement)
Gets the ODTEntry corresponding to the specified measurement. More...
- Public Attributes inherited from DAQDict
readonly Dictionary< uint, ODTEntry > | ODTEntries = new Dictionary<uint, ODTEntry>()
Gets the mapping from measurement's address to the configured ODTEntry and therefore to it's measurement data.

Detailed Description

Holds a dictionary of configured DAQ Lists.

Maps a specific DAQ number to the corresponding DAQList.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • DAQDictCCP
DAQDictCCP Member List

This is the complete list of members for DAQDictCCP, including all inherited members.

Clear() | DAQDict
clearData() | DAQDict
getODTEntry(A2LMEASUREMENT measurement) | DAQDict
ODTEntries | DAQDict


ASAP2Library interface: DAQListCCP Class Reference

  • Comm
  • CCP
  • DAQListCCP
List of all members
DAQListCCP Class Reference

DAQ List representation. More...

Additional Inherited Members

- Public Member Functions inherited from DAQList
virtual void | clearData ()
Clears only the contained data, not the DAQ configuration. More...
- Public Attributes inherited from DAQList
readonly ushort | EvtNo = ushort.MaxValue
The corresponding event channel number.
readonly SortedDictionary< byte, ODTList > | ODTs = new SortedDictionary<byte, ODTList>()
List of configured ODTs
readonly string | TimeCycle
Minimal period duration of the acquisition raster
- Properties inherited from DAQList
uint | CANId [getset]
Gets the corresponding CAN ID
ushort | DAQNo [getset]
The (unique) DAQ number.
byte | FirstPID [getset]
Number of the FirstPID. More...

Detailed Description

DAQ List representation.

Holds a dictionary of configured ODTs.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • DAQListCCP
DAQListCCP Member List

This is the complete list of members for DAQListCCP, including all inherited members.

CANId | DAQList |
clearData() | DAQList | virtual
DAQNo | DAQList |
EvtNo | DAQList |
FirstPID | DAQList |
ODTs | DAQList |
TimeCycle | DAQList |


ASAP2Library interface: RespActionDiagService Class Reference

  • Comm
  • CCP
  • RespActionDiagService
Public Member Functions | Public Attributes | List of all members
RespActionDiagService Class Reference

Response from Get Diagnostic or Action service. More...

Public Member Functions

RespActionDiagService (byte ctr, byte length, byte dataTypeQualifier)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | DataTypeQualifier
byte | Length

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get Diagnostic or Action service.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespActionDiagService
RespActionDiagService Member List

This is the complete list of members for RespActionDiagService, including all inherited members.

changeEndianness() | RespBase | virtual
DataTypeQualifier (defined in RespActionDiagService) | RespActionDiagService |
Length (defined in RespActionDiagService) | RespActionDiagService |
RespActionDiagService() (defined in RespActionDiagService) | RespActionDiagService |
RespActionDiagService(byte ctr, byte length, byte dataTypeQualifier) (defined in RespActionDiagService) | RespActionDiagService |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
Result | RespBase |


ASAP2Library interface: RespBase Class Reference

  • Comm
  • CCP
  • RespBase
Public Member Functions | Properties | List of all members
RespBase Class Reference

Base class represents a CCP response. More...

Public Member Functions

RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Properties

CmdResult Result [get]
Gets the response result.

Detailed Description

Base class represents a CCP response.

Member Function Documentation

◆ changeEndianness()

virtual void changeEndianness ( )
virtual

Changes the endianess of the response.

Implements IResponse.

Reimplemented in RespDownload, RespGetActiveCALPage, and RespBuildChecksum.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespBase
RespBase Member List

This is the complete list of members for RespBase, including all inherited members.

changeEndianness() | RespBase | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
Result | RespBase |


ASAP2Library interface: RespBuildChecksum Class Reference

  • Comm
  • CCP
  • RespBuildChecksum
Public Member Functions | Public Attributes | List of all members
RespBuildChecksum Class Reference

Response from Build Checksum. More...

Public Member Functions

RespBuildChecksum (byte ctr, byte size, uint checksum)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)

Public Attributes

uint | Checksum
byte | Size

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Build Checksum.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespBuildChecksum
RespBuildChecksum Member List

This is the complete list of members for RespBuildChecksum, including all inherited members.

changeEndianness() | RespBuildChecksum | virtual
Checksum (defined in RespBuildChecksum) | RespBuildChecksum |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespBuildChecksum() (defined in RespBuildChecksum) | RespBuildChecksum |
RespBuildChecksum(byte ctr, byte size, uint checksum) (defined in RespBuildChecksum) | RespBuildChecksum |
Result | RespBase |
Size (defined in RespBuildChecksum) | RespBuildChecksum |


ASAP2Library interface: RespDownload Class Reference

  • Comm
  • CCP
  • RespDownload
Public Member Functions | List of all members
RespDownload Class Reference

Response from Get Size of DAQ list. More...

Public Member Functions

RespDownload (byte ctr, byte extension, uint address)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get Size of DAQ list.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespDownload
RespDownload Member List

This is the complete list of members for RespDownload, including all inherited members.

changeEndianness() | RespDownload | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespDownload() (defined in RespDownload) | RespDownload |
RespDownload(byte ctr, byte extension, uint address) (defined in RespDownload) | RespDownload |
Result | RespBase |


ASAP2Library interface: RespExchangeID Class Reference

  • Comm
  • CCP
  • RespExchangeID
Public Member Functions | Public Attributes | List of all members
RespExchangeID Class Reference

Response from Exchange Station Identifications. More...

Public Member Functions

RespExchangeID (byte ctr, byte lengthOdID, byte dataTypeQualifier, ResourceType availability, ResourceType protection)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

ResourceType | Availability
byte | DataTypeQualifier
byte | LengthOfID
ResourceType | Protection

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Exchange Station Identifications.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespExchangeID
RespExchangeID Member List

This is the complete list of members for RespExchangeID, including all inherited members.

Availability (defined in RespExchangeID) | RespExchangeID |
changeEndianness() | RespBase | virtual
DataTypeQualifier (defined in RespExchangeID) | RespExchangeID |
LengthOfID (defined in RespExchangeID) | RespExchangeID |
Protection (defined in RespExchangeID) | RespExchangeID |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespExchangeID() (defined in RespExchangeID) | RespExchangeID |
RespExchangeID(byte ctr, byte lengthOdID, byte dataTypeQualifier, ResourceType availability, ResourceType protection) (defined in RespExchangeID) | RespExchangeID |
Result | RespBase |


ASAP2Library interface: RespGetActiveCALPage Class Reference

  • Comm
  • CCP
  • RespGetActiveCALPage
Public Member Functions | Public Attributes | List of all members
RespGetActiveCALPage Class Reference

Response from Get currently active Calibration Page. More...

Public Member Functions

RespGetActiveCALPage (byte ctr, byte extension, uint address)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)

Public Attributes

uint | Address
byte | Extension

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get currently active Calibration Page.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespGetActiveCALPage
RespGetActiveCALPage Member List

This is the complete list of members for RespGetActiveCALPage, including all inherited members.

Address (defined in RespGetActiveCALPage) | RespGetActiveCALPage |
changeEndianness() | RespGetActiveCALPage | virtual
Extension (defined in RespGetActiveCALPage) | RespGetActiveCALPage |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespGetActiveCALPage() (defined in RespGetActiveCALPage) | RespGetActiveCALPage |
RespGetActiveCALPage(byte ctr, byte extension, uint address) (defined in RespGetActiveCALPage) | RespGetActiveCALPage |
Result | RespBase |


ASAP2Library interface: RespGetCCPVersion Class Reference

  • Comm
  • CCP
  • RespGetCCPVersion
Public Member Functions | Public Attributes | List of all members
RespGetCCPVersion Class Reference

Response from Get implemented Version of CCP. More...

Public Member Functions

RespGetCCPVersion (byte ctr, byte main, byte release)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | Main
byte | Release

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get implemented Version of CCP.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespGetCCPVersion
RespGetCCPVersion Member List

This is the complete list of members for RespGetCCPVersion, including all inherited members.

changeEndianness() | RespBase | virtual
Main (defined in RespGetCCPVersion) | RespGetCCPVersion |
Release (defined in RespGetCCPVersion) | RespGetCCPVersion |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespGetCCPVersion() (defined in RespGetCCPVersion) | RespGetCCPVersion |
RespGetCCPVersion(byte ctr, byte main, byte release) (defined in RespGetCCPVersion) | RespGetCCPVersion |
Result | RespBase |


ASAP2Library interface: RespGetDAQSize Class Reference

  • Comm
  • CCP
  • RespGetDAQSize
Public Member Functions | Public Attributes | List of all members
RespGetDAQSize Class Reference

Response from Get Size of DAQ list. More...

Public Member Functions

RespGetDAQSize (byte ctr, byte daqListSize, byte firstPID)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | DAQListSize
byte | FirstPID

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get Size of DAQ list.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespGetDAQSize
RespGetDAQSize Member List

This is the complete list of members for RespGetDAQSize, including all inherited members.

changeEndianness() | RespBase | virtual
DAQListSize (defined in RespGetDAQSize) | RespGetDAQSize |
FirstPID (defined in RespGetDAQSize) | RespGetDAQSize |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespGetDAQSize() (defined in RespGetDAQSize) | RespGetDAQSize |
RespGetDAQSize(byte ctr, byte daqListSize, byte firstPID) (defined in RespGetDAQSize) | RespGetDAQSize |
Result | RespBase |


ASAP2Library interface: RespGetSeed Class Reference

  • Comm
  • CCP
  • RespGetSeed
Public Member Functions | Public Attributes | List of all members
RespGetSeed Class Reference

Response from Get Seed for Key. More...

Public Member Functions

RespGetSeed (byte ctr, byte protetionState)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte ProtectionState

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get Seed for Key.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespGetSeed
RespGetSeed Member List

This is the complete list of members for RespGetSeed, including all inherited members.

changeEndianness() | RespBase | virtual
ProtectionState (defined in RespGetSeed) | RespGetSeed |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespGetSeed() (defined in RespGetSeed) | RespGetSeed |
RespGetSeed(byte ctr, byte protetionState) (defined in RespGetSeed) | RespGetSeed |
Result | RespBase |


ASAP2Library interface: RespGetSStatus Class Reference

  • Comm
  • CCP
  • RespGetSStatus
Public Member Functions | Public Attributes | List of all members
RespGetSStatus Class Reference

Response from Get current session status from slave More...

Public Member Functions

RespGetSStatus (byte ctr, SessionState sessionState)
override string | ToString ()
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void | changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

SessionState | SessionState
byte | StatusQualifier

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Get current session status from slave


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespGetSStatus
RespGetSStatus Member List

This is the complete list of members for RespGetSStatus, including all inherited members.

changeEndianness() | RespBase | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespGetSStatus() (defined in RespGetSStatus) | RespGetSStatus |
RespGetSStatus(byte ctr, SessionState sessionState) (defined in RespGetSStatus) | RespGetSStatus |
Result | RespBase |
SessionState (defined in RespGetSStatus) | RespGetSStatus |
StatusQualifier (defined in RespGetSStatus) | RespGetSStatus |
ToString() (defined in RespGetSStatus) | RespGetSStatus |


ASAP2Library interface: RespUnlock Class Reference

  • Comm
  • CCP
  • RespUnlock
Public Member Functions | Public Attributes | List of all members
RespUnlock Class Reference

Response from Unlock Protection. More...

Public Member Functions

RespUnlock (byte ctr, ResourceType privilegeState)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code, CmdResult _result, byte ctr)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

ResourceType PrivilegeState

Additional Inherited Members

- Properties inherited from RespBase
CmdResult Result [get]
Gets the response result.

Detailed Description

Response from Unlock Protection.


ASAP2Library interface: Member List

  • Comm
  • CCP
  • RespUnlock
RespUnlock Member List

This is the complete list of members for RespUnlock, including all inherited members.

changeEndianness() | RespBase | virtual
PrivilegeState (defined in RespUnlock) | RespUnlock |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code, CmdResult _result, byte ctr) (defined in RespBase) | RespBase |
RespUnlock() (defined in RespUnlock) | RespUnlock |
RespUnlock(byte ctr, ResourceType privilegeState) (defined in RespUnlock) | RespUnlock |
Result | RespBase |


ASAP2Library interface: jnsoft.Comm.ECUSimulator Namespace Reference

  • Comm
  • ECUSimulator
Classes | Enumerations
jnsoft.Comm.ECUSimulator Namespace Reference

Implements the ECU simulator. More...

Classes

class Program
Main class of the ECU simulator. More...

Enumerations

enum DataAlgorithm { Constant , Random , SineCurve , SawTooth }
Available simulation data algirithms. More...

Detailed Description

Implements the ECU simulator.

The simulator implements

  • Calibration and page processing
  • Data acquisition processing

The simulator does not implement:

  • Security (by using a seed&key DLL)
  • Stimulation from master

The simulator supports

  • XCP on UDP
  • XCP on TCP
  • XCP on SxI
  • XCP on CAN/CANFD
  • CCP
  • UDS on CAN

Architecture

  • Read in a specified A2L/data file and build the object model
  • Build a response dictionary from XCPCommandCode to the corresponding 'resp...' method
  • Build random DAQ data
  • Listen on the specified TCP/UDP/CAN/COM Port for incoming connection requests
  • For any received command the corresponding 'resp...' handler is called

Enumeration Type Documentation

◆ DataAlgorithm

enum DataAlgorithm

Available simulation data algirithms.

Enumerator
Constant | Deliver constant data
Random | Deliver random data
SineCurve | Deliver a sine curve
SawTooth | Deliver a sine curve


ASAP2Library interface: Program Class Reference

  • Comm
  • ECUSimulator
  • Program
Classes | Static Public Member Functions | List of all members
Program Class Reference

Main class of the ECU simulator. More...

Classes

class | CCPSim
Implements the CCP ECU simulator. More...
class | UDSSim
Implements the UDS ECU simulator. More...
class | XCPSim
Implements the XCP ECU simulator. More...

Static Public Member Functions

static void Main (string[] args)
Simulator main function More...

Detailed Description

Main class of the ECU simulator.

This implementation provides a fully functional ECU simulator. The simulator is configured by an A2L and by a corresponding data file (HEX/S19) provided by commandline arguments.

if a specific XCP command is not implemented, the answer will be the error code CmdResult.ERR_CMD_UNKNOWN.

Commandline usage: ECUSimulator TCP:Port|UDP:Port|CAN:CANHw:Port|CCP:CANHw:Port|UDS:CANHw:Port A2LFile|ODXFile [CalibrationDataFile]

Member Function Documentation

◆ Main()

static void Main ( string[] args )
static

Simulator main function

Parameters
args Commandline arguments


ASAP2Library interface: Member List

  • Comm
  • ECUSimulator
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.

Main(string[] args) Program static


ASAP2Library interface: Program.CCPSim Class Reference

  • Comm
  • ECUSimulator
  • Program
  • CCPSim
Static Public Member Functions | List of all members
Program.CCPSim Class Reference

Implements the CCP ECU simulator. More...

Static Public Member Functions

static bool | respActionService (byte[] cmdData)
Handles the CCP ActionService command. More...
static bool | respBuildChksum (byte[] cmdData)
Handles the CCP Build chksum command. More...
static bool | respClearMemory (byte[] cmdData)
Handles the CCP ClearMemory command. More...
static bool | respConnect (byte[] cmdData)
Handles the CCP Connect command. More...
static bool | respDiagService (byte[] cmdData)
Handles the CCP DiagService command. More...
static bool | respDisconnect (byte[] cmdData)
Handles the CCP Disconnect command. More...
static bool | respDownload (byte[] cmdData)
Handles the CCP Download command. More...
static bool | respDownload6 (byte[] cmdData)
Handles the CCP Download6 command. More...
static bool | respExchangeID (byte[] cmdData)
Handles the CCP ExchangeID command. More...
static bool | respGetActiveCALPage (byte[] cmdData)
Handles the CCP GetActiveCALPage command. More...
static bool | respGetCCPVersion (byte[] cmdData)
Handles the CCP GetCCPVersion command. More...
static bool | respGetDAQSize (byte[] cmdData)
Handles the CCP Get DAQ List size command. More...
static bool | respGetSeed (byte[] cmdData)
Handles the CCP GetSeed command. More...
static bool | respGetStatus (byte[] cmdData)
Handles the CCP GetSStatus command. More...
static bool | respMove (byte[] cmdData)
Handles the CCP Move command. More...
static bool | respProgram (byte[] cmdData)
Handles the CCP Program command. More...
static bool | respProgram6 (byte[] cmdData)
Handles the CCP Program6 command. More...
static bool | respSelectCALPage (byte[] cmdData)
Handles the CCP SelectCALPage command. More...
static bool | respSetDAQPtr (byte[] cmdData)
Handles the CCP Set DAQ Ptr command. More...
static bool | respSetMTA (byte[] cmdData)
Handles the CCP SetMTA command. More...
static bool | respSetSStatus (byte[] cmdData)
Handles the CCP SetSStatus command. More...
static bool | respShortUp (byte[] cmdData)
Handles the CCP ShortUp command. More...
static bool | respStartStop (byte[] cmdData)
Handles the CCP Start Stop command. More...
static bool | respStartStopAll (byte[] cmdData)
Handles the CCP Start Stop All command. More...
static bool | respTest (byte[] cmdData)
Handles the CCP Test command. More...
static bool | respUnlock (byte[] cmdData)
Handles the CCP Unlock command. More...
static bool | respUpload (byte[] cmdData)
Handles the CCP Upload command. More...
static bool | respWriteDAQ (byte[] cmdData)
Handles the CCP Write DAQ command. More...
static bool | sendEvent (CmdResult result)
Sends a result as an event. More...
static bool | sendResponse (CmdResult result, byte ctr)
Sends a CCP respponse. More...
static bool | sendResponse (CmdResult result, byte[] additionalData, byte ctr)
Sends a CCP respponse. More...
static bool | sendResponse (PIDSlaveMaster resp, CmdResult result, byte ctr, byte[] additionalData)
Sends a CCP respponse. More...

Detailed Description

Implements the CCP ECU simulator.

Member Function Documentation

◆ respActionService()

static bool respActionService ( byte[] cmdData )
static

Handles the CCP ActionService command.

Not implemented!

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respBuildChksum()

static bool respBuildChksum ( byte[] cmdData )
static

Handles the CCP Build chksum command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respClearMemory()

static bool respClearMemory ( byte[] cmdData )
static

Handles the CCP ClearMemory command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respConnect()

static bool respConnect ( byte[] cmdData )
static

Handles the CCP Connect command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respDiagService()

static bool respDiagService ( byte[] cmdData )
static

Handles the CCP DiagService command.

Not implemented!

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respDisconnect()

static bool respDisconnect ( byte[] cmdData )
static

Handles the CCP Disconnect command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respDownload()

static bool respDownload ( byte[] cmdData )
static

Handles the CCP Download command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respDownload6()

static bool respDownload6 ( byte[] cmdData )
static

Handles the CCP Download6 command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respExchangeID()

static bool respExchangeID ( byte[] cmdData )
static

Handles the CCP ExchangeID command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respGetActiveCALPage()

static bool respGetActiveCALPage ( byte[] cmdData )
static

Handles the CCP GetActiveCALPage command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respGetCCPVersion()

static bool respGetCCPVersion ( byte[] cmdData )
static

Handles the CCP GetCCPVersion command.

Always return version 2.1

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respGetDAQSize()

static bool respGetDAQSize ( byte[] cmdData )
static

Handles the CCP Get DAQ List size command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respGetSeed()

static bool respGetSeed ( byte[] cmdData )
static

Handles the CCP GetSeed command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respGetStatus()

static bool respGetStatus ( byte[] cmdData )
static

Handles the CCP GetSStatus command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respMove()

static bool respMove ( byte[] cmdData )
static

Handles the CCP Move command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respProgram()

static bool respProgram ( byte[] cmdData )
static

Handles the CCP Program command.

Not implemented!

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respProgram6()

static bool respProgram6 ( byte[] cmdData )
static

Handles the CCP Program6 command.

Not implemented!

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respSelectCALPage()

static bool respSelectCALPage ( byte[] cmdData )
static

Handles the CCP SelectCALPage command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respSetDAQPtr()

static bool respSetDAQPtr ( byte[] cmdData )
static

Handles the CCP Set DAQ Ptr command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respSetMTA()

static bool respSetMTA ( byte[] cmdData )
static

Handles the CCP SetMTA command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respSetSStatus()

static bool respSetSStatus ( byte[] cmdData )
static

Handles the CCP SetSStatus command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respShortUp()

static bool respShortUp ( byte[] cmdData )
static

Handles the CCP ShortUp command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respStartStop()

static bool respStartStop ( byte[] cmdData )
static

Handles the CCP Start Stop command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respStartStopAll()

static bool respStartStopAll ( byte[] cmdData )
static

Handles the CCP Start Stop All command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respTest()

static bool respTest ( byte[] cmdData )
static

Handles the CCP Test command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respUnlock()

static bool respUnlock ( byte[] cmdData )
static

Handles the CCP Unlock command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respUpload()

static bool respUpload ( byte[] cmdData )
static

Handles the CCP Upload command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ respWriteDAQ()

static bool respWriteDAQ ( byte[] cmdData )
static

Handles the CCP Write DAQ command.

Parameters
cmdData The command data in bytes
Returns
true if command is processed

◆ sendEvent()

static bool sendEvent ( CmdResult result )
static

Sends a result as an event.

Parameters
result The CCP result code
Returns
true if successful

◆ sendResponse() [1/3]

static bool sendResponse | ( | CmdResult | result,
 |  | byte | ctr
 | ) |  |
static

Sends a CCP respponse.

Parameters
result | The CCP result code
ctr | The received CCP counter value
Returns
true if successful

◆ sendResponse() [2/3]

static bool sendResponse | ( | CmdResult | result,
 |  | byte[] | additionalData,
 |  | byte | ctr
 | ) |  |
static

Sends a CCP respponse.

Parameters
result | The CCP result code
additionalData | Additional data bytes to send
ctr | The received CCP counter value
Returns
true if successful

◆ sendResponse() [3/3]

static bool sendResponse | ( | PIDSlaveMaster | resp,
 |  | CmdResult | result,
 |  | byte | ctr,
 |  | byte[] | additionalData
 | ) |  |
static

Sends a CCP respponse.

Parameters
resp | The response type
result | The CCP result code
ctr | The received CCP counter value
additionalData | Additional data bytes to send
Returns
true if successful


ASAP2Library interface: Member List

  • Comm
  • ECUSimulator
  • Program
  • CCPSim
Program.CCPSim Member List

This is the complete list of members for Program.CCPSim, including all inherited members.

respActionService(byte[] cmdData) | Program.CCPSim | static
respBuildChksum(byte[] cmdData) | Program.CCPSim | static
respClearMemory(byte[] cmdData) | Program.CCPSim | static
respConnect(byte[] cmdData) | Program.CCPSim | static
respDiagService(byte[] cmdData) | Program.CCPSim | static
respDisconnect(byte[] cmdData) | Program.CCPSim | static
respDownload(byte[] cmdData) | Program.CCPSim | static
respDownload6(byte[] cmdData) | Program.CCPSim | static
respExchangeID(byte[] cmdData) | Program.CCPSim | static
respGetActiveCALPage(byte[] cmdData) | Program.CCPSim | static
respGetCCPVersion(byte[] cmdData) | Program.CCPSim | static
respGetDAQSize(byte[] cmdData) | Program.CCPSim | static
respGetSeed(byte[] cmdData) | Program.CCPSim | static
respGetStatus(byte[] cmdData) | Program.CCPSim | static
respMove(byte[] cmdData) | Program.CCPSim | static
respProgram(byte[] cmdData) | Program.CCPSim | static
respProgram6(byte[] cmdData) | Program.CCPSim | static
respSelectCALPage(byte[] cmdData) | Program.CCPSim | static
respSetDAQPtr(byte[] cmdData) | Program.CCPSim | static
respSetMTA(byte[] cmdData) | Program.CCPSim | static
respSetSStatus(byte[] cmdData) | Program.CCPSim | static
respShortUp(byte[] cmdData) | Program.CCPSim | static
respStartStop(byte[] cmdData) | Program.CCPSim | static
respStartStopAll(byte[] cmdData) | Program.CCPSim | static
respTest(byte[] cmdData) | Program.CCPSim | static
respUnlock(byte[] cmdData) | Program.CCPSim | static
respUpload(byte[] cmdData) | Program.CCPSim | static
respWriteDAQ(byte[] cmdData) | Program.CCPSim | static
sendEvent(CmdResult result) | Program.CCPSim | static
sendResponse(CmdResult result, byte ctr) | Program.CCPSim | static
sendResponse(CmdResult result, byte[] additionalData, byte ctr) | Program.CCPSim | static
sendResponse(PIDSlaveMaster resp, CmdResult result, byte ctr, byte[] additionalData) | Program.CCPSim | static


ASAP2Library interface: Program.UDSSim Class Reference

  • Comm
  • ECUSimulator
  • Program
  • UDSSim
Static Public Member Functions | List of all members
Program.UDSSim Class Reference

Implements the UDS ECU simulator. More...

Static Public Member Functions

static bool sendPosResponse (SID service, byte[] data=null)
Send a positive service response without a subfunction. More...

Detailed Description

Implements the UDS ECU simulator.

Member Function Documentation

◆ sendPosResponse()

static bool sendPosResponse | ( | SID | service,
 |  | byte[] | data = null
 | ) |  |
static

Send a positive service response without a subfunction.

Parameters
service | Service Id
data | data to respond
Returns
true if successful


ASAP2Library interface: Member List

  • Comm
  • ECUSimulator
  • Program
  • UDSSim
Program.UDSSim Member List

This is the complete list of members for Program.UDSSim, including all inherited members.

sendPosResponse(SID service, byte[] data=null) Program.UDSSim static


ASAP2Library interface: Program.XCPSim Class Reference

  • Comm
  • ECUSimulator
  • Program
  • XCPSim
Static Public Member Functions | List of all members
Program.XCPSim Class Reference

Implements the XCP ECU simulator. More...

Static Public Member Functions

static bool | respAllocDAQ (byte[] cmdData, ushort ctr)
Handles the XCP AllocDAQ command. More...
static bool | respAllocODT (byte[] cmdData, ushort ctr)
Handles the XCP AllocODT command. More...
static bool | respAllocODTEntry (byte[] cmdData, ushort ctr)
Handles the XCP AllocODTEntry command. More...
static bool | respBuildChecksum (byte[] cmdData, ushort ctr)
Handles the XCP BuildChecksum command. More...
static bool | respClearDAQList (byte[] cmdData, ushort ctr)
Handles the XCP ClearDAQList command. More...
static bool | respConnect (byte[] cmdData, ushort ctr)
Handles the XCP Connect command. More...
static bool | respCopyCALPage (byte[] cmdData, ushort ctr)
Handles the XCP CopyCALPage command. More...
static bool | respDisconnect (byte[] cmdData, ushort ctr)
Handles the XCP Disconnect command. More...
static bool | respDownload (byte[] cmdData, ushort ctr)
Handles the XCP Download command. More...
static bool | respDownloadMax (byte[] cmdData, ushort ctr)
Handles the XCP Download command. More...
static bool | respFreeDAQ (byte[] cmdData, ushort ctr)
Handles the XCP FreeDAQ command. More...
static bool | respGetCalPage (byte[] cmdData, ushort ctr)
Handles the XCP GetCalPage command. More...
static bool | respGetCommModeInfo (byte[] cmdData, ushort ctr)
Handles the XCP Connect command. More...
static bool | respGetDAQClock (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQClock command. More...
static bool | respGetDAQEventInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQEventInfo command. More...
static bool | respGetDAQListInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQListInfo command. More...
static bool | respGetDAQListMode (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQListInfo command. More...
static bool | respGetDAQProcessorInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQProcessorInfo command. More...
static bool | respGetDAQResolutionInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetDAQResolutionInfo command. More...
static bool | respGetId (byte[] cmdData, ushort ctr)
Handles the XCP GetID command. More...
static bool | respGetPageInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetPageInfo command. More...
static bool | respGetPAGProcessorInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetPAGProcessorInfo command. More...
static bool | respGetSeed (byte[] cmdData, ushort ctr)
Handles the XCP GetSeed command. More...
static bool | respGetSegmentInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetSegmentInfo command. More...
static bool | respGetStatus (byte[] cmdData, ushort ctr)
Handles the XCP GetStatus command. More...
static bool | respModifyBits (byte[] cmdData, ushort ctr)
Handles the XCP ShortDownload command. More...
static bool | respPGMProcessorInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetPGMProcessorInfo command. More...
static bool | respProgram (byte[] cmdData, ushort ctr)
Handles the XCP Program command. More...
static bool | respProgramClear (byte[] cmdData, ushort ctr)
Handles the XCP ProgramClear command. More...
static bool | respProgramFormat (byte[] cmdData, ushort ctr)
Handles the XCP ProgramFormat command. More...
static bool | respProgramMax (byte[] cmdData, ushort ctr)
Handles the XCP Program command. More...
static bool | respProgramPrepare (byte[] cmdData, ushort ctr)
Handles the XCP ProgramPrepare command. More...
static bool | respProgramReset (byte[] cmdData, ushort ctr)
Handles the XCP ProgramReset command. More...
static bool | respProgramStart (byte[] cmdData, ushort ctr)
Handles the XCP ProgramStart command. More...
static bool | respProgramVerify (byte[] cmdData, ushort ctr)
Handles the XCP ProgramVerify command. More...
static bool | respSectorInfo (byte[] cmdData, ushort ctr)
Handles the XCP GetSectorInfo command. More...
static bool | respSetCalPage (byte[] cmdData, ushort ctr)
Handles the XCP SetCalPage command. More...
static bool | respSetDAQListMode (byte[] cmdData, ushort ctr)
Handles the XCP SetDAQListMode command. More...
static bool | respSetDAQPtr (byte[] cmdData, ushort ctr)
Handles the XCP SetDAQPtr command. More...
static bool | respSetMTA (byte[] cmdData, ushort ctr)
Handles the XCP SetMTA command. More...
static bool | respSetRequest (byte[] cmdData, ushort ctr)
Handles the XCP SetRequest command. More...
static bool | respSetSegmentMode (byte[] cmdData, ushort ctr)
Handles the XCP SetSegmentMode command. More...
static bool | respShortDownload (byte[] cmdData, ushort ctr)
Handles the XCP ShortDownload command. More...
static bool | respShortUpload (byte[] cmdData, ushort ctr)
Handles the XCP ShortUpload command. More...
static bool | respStartStopDAQList (byte[] cmdData, ushort ctr)
Handles the XCP StartStopDAQList command. More...
static bool | respStartStopSynch (byte[] cmdData, ushort ctr)
Handles the XCP StartStopSynch command. More...
static bool | respSynch (byte[] cmdData, ushort ctr)
Handles the XCP Sync command. More...
static bool | respTransportLayerCmd (byte[] cmdData, ushort ctr)
Handles the XCP TransportLayerCmd command. More...
static bool | respUnlock (byte[] cmdData, ushort ctr)
Handles the XCP Unlock command. More...
static bool | respUpload (byte[] cmdData, ushort ctr)
Handles the XCP Upload command. More...
static bool | respUserCmd (byte[] cmdData, ushort ctr)
Handles the XCP UserCmd command. More...
static bool | respWriteDAQ (byte[] cmdData, ushort ctr)
Handles the XCP WriteDAQ command. More...
static bool | respWriteDAQMultiple (byte[] cmdData, ushort ctr)
Handles the XCP WriteDAQMultiple command. More...
static bool | sendError (CmdResult errCode, byte[] additionalData=null)
Sends an XCP error respponse. More...
static bool | sendResponse (byte[] additionalData=null)
Sends a positive response with additional data. More...
static bool | sendServiceRequest (ServiceRequestCode srvCode)
Sends an event response. More...

Detailed Description

Implements the XCP ECU simulator.

Member Function Documentation

◆ respAllocDAQ()

static bool respAllocDAQ | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP AllocDAQ command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respAllocODT()

static bool respAllocODT | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP AllocODT command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respAllocODTEntry()

static bool respAllocODTEntry | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP AllocODTEntry command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respBuildChecksum()

static bool respBuildChecksum | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP BuildChecksum command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respClearDAQList()

static bool respClearDAQList | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ClearDAQList command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respConnect()

static bool respConnect | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Connect command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respCopyCALPage()

static bool respCopyCALPage | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP CopyCALPage command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respDisconnect()

static bool respDisconnect | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Disconnect command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respDownload()

static bool respDownload | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Download command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respDownloadMax()

static bool respDownloadMax | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Download command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respFreeDAQ()

static bool respFreeDAQ | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP FreeDAQ command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetCalPage()

static bool respGetCalPage | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetCalPage command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetCommModeInfo()

static bool respGetCommModeInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Connect command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQClock()

static bool respGetDAQClock | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQClock command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQEventInfo()

static bool respGetDAQEventInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQEventInfo command.

If a name length is returned, the MTA should be set to the location where the Event's name is defined. The master can get the evnt's name by a upload of the specified length.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQListInfo()

static bool respGetDAQListInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQListInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQListMode()

static bool respGetDAQListMode | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQListInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQProcessorInfo()

static bool respGetDAQProcessorInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQProcessorInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetDAQResolutionInfo()

static bool respGetDAQResolutionInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetDAQResolutionInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetId()

static bool respGetId | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetID command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetPageInfo()

static bool respGetPageInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetPageInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetPAGProcessorInfo()

static bool respGetPAGProcessorInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetPAGProcessorInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetSeed()

static bool respGetSeed | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetSeed command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetSegmentInfo()

static bool respGetSegmentInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetSegmentInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respGetStatus()

static bool respGetStatus | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetStatus command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respModifyBits()

static bool respModifyBits | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ShortDownload command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respPGMProcessorInfo()

static bool respPGMProcessorInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetPGMProcessorInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgram()

static bool respProgram | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Program command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramClear()

static bool respProgramClear | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramClear command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramFormat()

static bool respProgramFormat | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramFormat command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramMax()

static bool respProgramMax | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Program command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramPrepare()

static bool respProgramPrepare | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramPrepare command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramReset()

static bool respProgramReset | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramReset command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramStart()

static bool respProgramStart | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramStart command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respProgramVerify()

static bool respProgramVerify | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ProgramVerify command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSectorInfo()

static bool respSectorInfo | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP GetSectorInfo command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetCalPage()

static bool respSetCalPage | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetCalPage command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetDAQListMode()

static bool respSetDAQListMode | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetDAQListMode command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetDAQPtr()

static bool respSetDAQPtr | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetDAQPtr command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetMTA()

static bool respSetMTA | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetMTA command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetRequest()

static bool respSetRequest | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetRequest command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSetSegmentMode()

static bool respSetSegmentMode | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP SetSegmentMode command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respShortDownload()

static bool respShortDownload | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ShortDownload command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respShortUpload()

static bool respShortUpload | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP ShortUpload command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respStartStopDAQList()

static bool respStartStopDAQList | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP StartStopDAQList command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respStartStopSynch()

static bool respStartStopSynch | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP StartStopSynch command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respSynch()

static bool respSynch | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Sync command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respTransportLayerCmd()

static bool respTransportLayerCmd | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP TransportLayerCmd command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respUnlock()

static bool respUnlock | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Unlock command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respUpload()

static bool respUpload | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP Upload command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respUserCmd()

static bool respUserCmd | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP UserCmd command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respWriteDAQ()

static bool respWriteDAQ | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP WriteDAQ command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ respWriteDAQMultiple()

static bool respWriteDAQMultiple | ( | byte[] | cmdData,
 |  | ushort | ctr
 | ) |  |
static

Handles the XCP WriteDAQMultiple command.

Parameters
cmdData | The command data in bytes
ctr | The current XCP counter value
Returns
true if command is processed

◆ sendError()

static bool sendError | ( | CmdResult | errCode,
 |  | byte[] | additionalData = null
 | ) |  |
static

Sends an XCP error respponse.

Parameters
errCode | The XCP error code
additionalData | Additional error code data (may be null)
Returns
true if successful

◆ sendResponse()

static bool sendResponse ( byte[] additionalData = null )
static

Sends a positive response with additional data.

Parameters
additionalData Additional data bytes to send
Returns
true if successful

◆ sendServiceRequest()

static bool sendServiceRequest ( ServiceRequestCode srvCode )
static

Sends an event response.

Parameters
srvCode The XCP service request code
Returns
true if successful


ASAP2Library interface: Member List

  • Comm
  • ECUSimulator
  • Program
  • XCPSim
Program.XCPSim Member List

This is the complete list of members for Program.XCPSim, including all inherited members.

respAllocDAQ(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respAllocODT(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respAllocODTEntry(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respBuildChecksum(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respClearDAQList(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respConnect(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respCopyCALPage(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respDisconnect(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respDownload(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respDownloadMax(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respFreeDAQ(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetCalPage(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetCommModeInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQClock(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQEventInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQListInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQListMode(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQProcessorInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetDAQResolutionInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetId(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetPageInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetPAGProcessorInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetSeed(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetSegmentInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respGetStatus(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respModifyBits(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respPGMProcessorInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgram(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramClear(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramFormat(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramMax(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramPrepare(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramReset(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramStart(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respProgramVerify(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSectorInfo(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetCalPage(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetDAQListMode(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetDAQPtr(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetMTA(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetRequest(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSetSegmentMode(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respShortDownload(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respShortUpload(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respStartStopDAQList(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respStartStopSynch(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respSynch(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respTransportLayerCmd(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respUnlock(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respUpload(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respUserCmd(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respWriteDAQ(byte[] cmdData, ushort ctr) | Program.XCPSim | static
respWriteDAQMultiple(byte[] cmdData, ushort ctr) | Program.XCPSim | static
sendError(CmdResult errCode, byte[] additionalData=null) | Program.XCPSim | static
sendResponse(byte[] additionalData=null) | Program.XCPSim | static
sendServiceRequest(ServiceRequestCode srvCode) | Program.XCPSim | static


ASAP2Library interface: jnsoft.Comm.ETAS Namespace Reference

  • Comm
  • ETAS
jnsoft.Comm.ETAS Namespace Reference


ASAP2Library interface: jnsoft.Comm.Intrepid Namespace Reference

  • Comm
  • Intrepid
jnsoft.Comm.Intrepid Namespace Reference


ASAP2Library interface: jnsoft.Comm.IXXAT Namespace Reference

  • Comm
  • IXXAT
jnsoft.Comm.IXXAT Namespace Reference


ASAP2Library interface: jnsoft.Comm.LIN Namespace Reference

  • Comm
  • LIN
Namespaces | Classes | Enumerations
jnsoft.Comm.LIN Namespace Reference

All the stuff needed to communicate with LIN hardware. More...

Namespaces

namespace | ETAS
All the stuff needed to bind to the ETAS LIN hardware.
namespace | Intrepid
All the stuff needed to bind to the Intrepid LIN hardware.
namespace | IXXAT
All the stuff needed to bind to the IXXAT LIN hardware.
namespace | Kvaser
All the stuff needed to bind to the Kvaser LIN hardware.
namespace | Peak
All the stuff needed to bind to the Peak LIN hardware.
namespace | Vector
All the stuff needed to bind to the Vector LIN hardware.

Classes

interface | ILINProvider
LIN Adapter interface to implement for each LIN Bus provider. More...
class | LINConfiguration
Represents the vendor(hardware) independant LIN configuration. More...
class | LINEventArgs
EventArgs class to notify transferred LIN frames. More...
class | LINFilterIDs
Serializes LIN filter IDs. More...
class | LINFrame
Represents a sent or received LIN message. More...
class | LINFrameDict
Maps LIN Id to LIN frames. More...
class | LINFrameQueue
Queue implementation to store LINFrame's. More...
class | LINProvider
Implements a base class for a vendor specific LIN provider. More...

Enumerations

enum | ChecksumType { CALC_CHECKSUM , CALC_CHECKSUM_ENHANCED }
Possible checksum calculations. More...
enum LINBaudrate : ushort {
NotSet = 0 , _1200Baud = 1200 , _2400Baud = 2400 , _4800Baud = 4800 ,
_9600Baud = 9600 , _19200Baud = 19200
}
Defines possible LIN Baudrates. More...
enum | LinVersion { _1_3 , _2_0 , _2_1 }
Possible LIN versions to use. More...

Detailed Description

All the stuff needed to communicate with LIN hardware.

Enumeration Type Documentation

◆ ChecksumType

enum ChecksumType

Possible checksum calculations.

Enumerator
CALC_CHECKSUM | Use the classic checksum calculation (only databytes)
CALC_CHECKSUM_ENHANCED | Use the enhanced checksum calculation (databytes and id field)

◆ LINBaudrate

enum LINBaudrate : ushort

Defines possible LIN Baudrates.

Enumerator
NotSet | Not set value
_1200Baud | 1200 Baud
_2400Baud | 2400 Baud
_4800Baud | 2400 Baud
_9600Baud | 9600 Baud
_19200Baud | 19200 Baud

◆ LinVersion

enum LinVersion

Possible LIN versions to use.

Enumerator
_1_3 | LIN version 1.3
_2_0 | LIN version 2.0
_2_1 | LIN version 2.1


ASAP2Library interface: jnsoft.Comm.LIN.ETAS Namespace Reference

  • Comm
  • LIN
  • ETAS
Classes
jnsoft.Comm.LIN.ETAS Namespace Reference

All the stuff needed to bind to the ETAS LIN hardware. More...

Classes

class ETASLIN
The ETAS version of an ILINProvider. More...

Detailed Description

All the stuff needed to bind to the ETAS LIN hardware.


ASAP2Library interface: ETASLIN Class Reference

  • Comm
  • LIN
  • ETAS
  • ETASLIN
Public Member Functions | List of all members
ETASLIN Class Reference

The ETAS version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override IEnumerable< object > | GetAvailableHardware (MediaType type)
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The ETAS version of an ILINProvider.

  • Uses an installed ETAS LIN driver
  • Supports both 32Bit and 64Bit ETAS versions
  • Supports LIN supporting hardware

Dependencies:

  • ETAS BOA V2 distribution installation (dll-ocdProxy.dll)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ GetAvailableHardware()

override IEnumerable< object > GetAvailableHardware ( MediaType type )
virtual

Reimplemented from LINProvider.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • ETAS
  • ETASLIN
ETASLIN Member List

This is the complete list of members for ETASLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in ETASLIN) | ETASLIN | virtual
Dispose() | ETASLIN | virtual
ETASLIN() (defined in ETASLIN) | ETASLIN |
GetAvailableHardware(MediaType type) (defined in ETASLIN) | ETASLIN | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | ETASLIN | virtual
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in ETASLIN) | ETASLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | ETASLIN | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | ETASLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: jnsoft.Comm.LIN.Intrepid Namespace Reference

  • Comm
  • LIN
  • Intrepid
Classes
jnsoft.Comm.LIN.Intrepid Namespace Reference

All the stuff needed to bind to the Intrepid LIN hardware. More...

Classes

class IntrepidLIN
The Intrepid version of an ILINProvider. More...

Detailed Description

All the stuff needed to bind to the Intrepid LIN hardware.

See also
https://intrepidcs.com/products/vehicle-network-adapters/

Supported hardware types: VN16XX, VN7572, VN8900


ASAP2Library interface: IntrepidLIN Class Reference

  • Comm
  • LIN
  • Intrepid
  • IntrepidLIN
Public Member Functions | List of all members
IntrepidLIN Class Reference

The Intrepid version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Intrepid version of an ILINProvider.

  • Supports both 32Bit and 64Bit Vector versions
  • Supports LIN supporting hardware

Dependencies:

  • icsneo40.dll (32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • Intrepid
  • IntrepidLIN
IntrepidLIN Member List

This is the complete list of members for IntrepidLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in IntrepidLIN) | IntrepidLIN | virtual
Dispose() | IntrepidLIN | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
IntrepidLIN() (defined in IntrepidLIN) | IntrepidLIN |
isAvailable() | IntrepidLIN | virtual
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in IntrepidLIN) | IntrepidLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | IntrepidLIN | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | IntrepidLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: jnsoft.Comm.LIN.IXXAT Namespace Reference

  • Comm
  • LIN
  • IXXAT
Classes
jnsoft.Comm.LIN.IXXAT Namespace Reference

All the stuff needed to bind to the IXXAT LIN hardware. More...

Classes

class IXXATLIN
The IXXAT version of an ILINProvider. More...

Detailed Description

All the stuff needed to bind to the IXXAT LIN hardware.

See also
http://www.ixxat.de/overview-pc-can-interface-board_de.html


ASAP2Library interface: IXXATLIN Class Reference

  • Comm
  • LIN
  • IXXAT
  • IXXATLIN
Public Member Functions | List of all members
IXXATLIN Class Reference

The IXXAT version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The IXXAT version of an ILINProvider.

  • Uses an installed IXXAT LIN driver
  • Supports both 32Bit and 64Bit HMS/IXXAT versions (VCI3 and VCI4)

Dependencies:

  • vcinpl.dll (32/64 bit Windows DLL, VCI3)
  • vcinpl2.dll (32/64 bit Windows DLL, VCI4)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • IXXAT
  • IXXATLIN
IXXATLIN Member List

This is the complete list of members for IXXATLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in IXXATLIN) | IXXATLIN | virtual
Dispose() | IXXATLIN | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | IXXATLIN | virtual
IXXATLIN() (defined in IXXATLIN) | IXXATLIN |
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in IXXATLIN) | IXXATLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | IXXATLIN | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | IXXATLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: jnsoft.Comm.LIN.Kvaser Namespace Reference

  • Comm
  • LIN
  • Kvaser
Classes | Enumerations
jnsoft.Comm.LIN.Kvaser Namespace Reference

All the stuff needed to bind to the Kvaser LIN hardware. More...

Classes

class | KvaserLIN
The Kvaser version of an ILINProvider. More...
class | LINMessageInfo

Enumerations

enum LINFlags {
NONE , TX = 1 , RX = TX << 1 , WAKEUP_FRAME = TX << 2 ,
NODATA = TX << 3 , CSUM_ERROR = TX << 4 , PARITY_ERROR = TX << 5 , SYNCH_ERROR = TX << 6 ,
BIT_ERROR = TX << 7
}
LIN message flags More...
enum LINOpen { MASTER = 1 , SLAVE = 2 }
LIN Open types
enum LINStatus {
OK = 0 , ERR_NOMSG = -1 , ERR_NOTRUNNING = -3 , ERR_RUNNING = -4 ,
ERR_MASTERONLY = -5 , ERR_SLAVEONLY = -6 , ERR_PARAM = -7 , ERR_NOTFOUND = -8 ,
ERR_NOMEM = -9 , ERR_NOCHANNELS = -10 , ERR_TIMEOUT = -11 , ERR_NOTINITIALIZED = -12 ,
ERR_NOHANDLES = -13 , ERR_INVHANDLE = -14 , ERR_CANERROR = -15 , ERR_ERRRESP = -16 ,
ERR_WRONGRESP = -17 , ERR_DRIVER = -18 , ERR_DRIVERFAILED = -19 , ERR_NOCARD = -20 ,
ERR_LICENSE = -21 , ERR_INTERNAL = -22 , ERR_NO_ACCESS = -23 , ERR_VERSION = -24 ,
ERR_NO_REF_POWER = -25 , ERR_NOT_IMPLEMENTED = -26
}
LIN status codes

Detailed Description

All the stuff needed to bind to the Kvaser LIN hardware.

Enumeration Type Documentation

◆ LINFlags

enum LINFlags

LIN message flags

Enumerator
NONE | No flags
TX | The message was something we transmitted on the bus
RX | The message was something we received from the bus
WAKEUP_FRAME | A wake up frame was received. Id/msg/dlc are undefined
NODATA | No data, only a header
CSUM_ERROR | Checksum error
PARITY_ERROR | ID parity error
SYNCH_ERROR | A synch error
BIT_ERROR | Bit error when transmitting


ASAP2Library interface: KvaserLIN Class Reference

  • Comm
  • LIN
  • Kvaser
  • KvaserLIN
Public Member Functions | List of all members
KvaserLIN Class Reference

The Kvaser version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Kvaser version of an ILINProvider.

  • Supports both 32Bit and 64Bit Vector versions
  • Supports LIN supporting hardware

Dependencies:

  • linlib.dll (Kvaser 32 bit Windows DLL)
  • linlib.dll (Kvaser 64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • Kvaser
  • KvaserLIN
KvaserLIN Member List

This is the complete list of members for KvaserLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in KvaserLIN) | KvaserLIN | virtual
Dispose() | KvaserLIN | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | KvaserLIN | virtual
KvaserLIN() (defined in KvaserLIN) | KvaserLIN |
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in KvaserLIN) | KvaserLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | KvaserLIN | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | KvaserLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: LINMessageInfo Class Reference

  • Comm
  • LIN
  • Kvaser
  • LINMessageInfo
List of all members
LINMessageInfo Class Reference

Detailed Description

In certain LIN bus API calls, the following structure is used to provide more information about the LIN messages.

Note
The precision of the timing data given in us (microseconds) can be less than one microsecond; for low bitrates the lowest bits might always be zero.
The min and max values listed inside [] of the message timing values can be calculated from the LIN specification by using the shortest (0 bytes) or longest (8 bytes) messages at the lowest or highest allowed bitrate.
The LIN interface will accept messages that are a bit out-of-bounds as well.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • Kvaser
  • LINMessageInfo
LINMessageInfo Member List

This is the complete list of members for LINMessageInfo, including all inherited members.


ASAP2Library interface: jnsoft.Comm.LIN.Peak Namespace Reference

  • Comm
  • LIN
  • Peak
Classes | Enumerations
jnsoft.Comm.LIN.Peak Namespace Reference

All the stuff needed to bind to the Peak LIN hardware. More...

Classes

class PeakLIN
The Peak version of an ILINProvider. More...

Enumerations

enum HardwareType : ushort { Undefined , USB_PRO = 1 , USB_PRO_FD , PLIN_USB }
Hardware Types More...

Detailed Description

All the stuff needed to bind to the Peak LIN hardware.

Enumeration Type Documentation

◆ HardwareType

enum HardwareType : ushort

Hardware Types

Enumerator
USB_PRO | PCAN-USB Pro LIN
USB_PRO_FD | PCAN-USB Pro FD LIN
PLIN_USB | PLIN-USB


ASAP2Library interface: PeakLIN Class Reference

  • Comm
  • LIN
  • Peak
  • PeakLIN
Public Member Functions | List of all members
PeakLIN Class Reference

The Peak version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Peak version of an ILINProvider.

  • Uses an installed Peak LIN driver
  • Supports both 32Bit and 64Bit Peak versions
  • Supports LIN supporting hardware

Dependencies:

  • pLinApi.dll (Peak 32/64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • Peak
  • PeakLIN
PeakLIN Member List

This is the complete list of members for PeakLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in PeakLIN) | PeakLIN | virtual
Dispose() | PeakLIN | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | PeakLIN | virtual
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in PeakLIN) | PeakLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | PeakLIN | virtual
PeakLIN() (defined in PeakLIN) | PeakLIN |
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | PeakLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: jnsoft.Comm.LIN.Vector Namespace Reference

  • Comm
  • LIN
  • Vector
Classes
jnsoft.Comm.LIN.Vector Namespace Reference

All the stuff needed to bind to the Vector LIN hardware. More...

Classes

class VectorLIN
The Vector version of an ILINProvider. More...

Detailed Description

All the stuff needed to bind to the Vector LIN hardware.

See also
https://www.vector.com/us/en-us/know-how/technologies/bus-systems/lin/

Supported hardware types: VN16XX, VN7572, VN8900


ASAP2Library interface: VectorLIN Class Reference

  • Comm
  • LIN
  • Vector
  • VectorLIN
Public Member Functions | List of all members
VectorLIN Class Reference

The Vector version of an ILINProvider. More...

Public Member Functions

override void | close ()
override void | Dispose ()
free used resources. More...
override bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
override int | onReceive (out LINFrame frame)
override bool | open (LINConfiguration config)
Open the LIN resource More...
override int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from LINProvider
virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Additional Inherited Members

- Static Public Member Functions inherited from LINProvider
static string | toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...
- Protected Member Functions inherited from LINProvider
LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.
- Protected Attributes inherited from LINProvider
LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType
- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

The Vector version of an ILINProvider.

  • Uses an installed vector driver library >= 8.3.
  • Supports both 32Bit and 64Bit Vector versions
  • Supports LIN supporting hardware

Dependencies:

  • vxlapi.dll (Vector 32 bit Windows DLL)
  • vxlapi64.dll (Vector 64 bit Windows DLL)

Member Function Documentation

◆ close()

override void close ( )
virtual

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ Dispose()

override void Dispose ( )
virtual

free used resources.

Reimplemented from FrameProvider< LINFrame, LINEventArgs >.

◆ isAvailable()

override bool isAvailable ( )
virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements LINProvider.

◆ open()

override bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Reimplemented from LINProvider.

◆ send()

override int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements LINProvider.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • Vector
  • VectorLIN
VectorLIN Member List

This is the complete list of members for VectorLIN, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
close() (defined in VectorLIN) | VectorLIN | virtual
Dispose() | VectorLIN | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | VectorLIN | virtual
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out LINFrame frame) (defined in VectorLIN) | VectorLIN |
jnsoft::Comm::LIN::LINProvider.onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | VectorLIN | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | VectorLIN | virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
VectorLIN() (defined in VectorLIN) | VectorLIN |


ASAP2Library interface: ILINProvider Interface Reference

  • Comm
  • LIN
  • ILINProvider
Public Member Functions | Properties | List of all members
ILINProvider Interface Reference

LIN Adapter interface to implement for each LIN Bus provider. More...

Public Member Functions

bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
bool | open (LINConfiguration config)
Open the LIN resource More...
int | send (byte id, byte[] data)
Send data to the LIN resource. More...
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

LIN Adapter interface to implement for each LIN Bus provider.

Example usage with the vector LIN interface:

void LINTest
{
const byte masterId = 1;
const byte slaveId = 2;
const uint baudrate = 16500;
// Create and configure the LIN provider
mLINProvider = new Comm.LIN.Vector.VectorLIN();
var config = new LINConfiguration(masterId, baudrate);
config.HardwareType = (int)jnsoft.Comm.Vector.HWType.VN1610;
// Register a handler to receive all LIN messages
mLINProvider.registerClient((o, e) => receiveLINMessages(o, e));
// Open the LIN provider
var result = mLINProvider.open(config);
// try put a slave to sleep
result = mLINProvider.switchSlave(slaveId, SlaveMode.Off);
// try to awake a slave
result = mLINProvider.switchSlave(slaveId, SlaveMode.On);
// send a message to a LIN slave
byte[] data = new byte[] { 0, 1, 2, 3, 4, 5, 6, 7 };
var sentBytes = mLINProvider.send(slaveId, data);
}
void receiveLINMessages(object sender, LINEventArgs e)
{
Console.WriteLine($"Received LIN message with {e.Frame.Data.Length} bytes from {e.Frame.BusID} ID:{e.Frame.ID}({(e.Frame.IsMasterFrame ? "TX" : "RX")}) {e.Frame.Data.Length}");
}
jnsoft.Comm.Vector
Definition: VectorLibWrapper.cs:15
jnsoft.Comm
Contains all the stuff to communicate over XCP, CCP and CAN.
Definition: CCPDataAcquisition.cs:37
jnsoft
Definition: ASAP2.cs:53

Member Function Documentation

◆ isAvailable()

bool isAvailable ( )

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implemented in LINProvider, ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.

◆ open()

bool open ( LINConfiguration config )

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Implemented in LINProvider, ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.

◆ send()

int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implemented in LINProvider, ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • ILINProvider
ILINProvider Member List

This is the complete list of members for ILINProvider, including all inherited members.

ClientCount | IFrameProvider< LINEventArgs >
close() | IFrameProvider< LINEventArgs >
GetAvailableHardware(MediaType type) | IFrameProvider< LINEventArgs >
isAvailable() | ILINProvider
open(LINConfiguration config) | ILINProvider
registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs >
registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs >
registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs >
send(byte id, byte[] data) | ILINProvider
UniqueBusID | ILINProvider
unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs >


ASAP2Library interface: LINConfiguration Class Reference

  • Comm
  • LIN
  • LINConfiguration
Public Member Functions | Public Attributes | Properties | List of all members
LINConfiguration Class Reference

Represents the vendor(hardware) independant LIN configuration. More...

Public Member Functions

LINConfiguration ()
Deserialization constructor.
LINConfiguration (byte masterId, ushort baudrate, LinVersion version=LinVersion._2_1, byte dlc=8, ChecksumType checksumType=ChecksumType.CALC_CHECKSUM, int channel=0)
Initialises a new instance with the specified parameters. More...

Public Attributes

ushort | Baudrate
The baudrate to configure. More...
string | BusId
Unique Name set by a configured LIN provider.
int | Channel
The LIN channel to communicate on.
ChecksumType | ChecksumType
Checksum type for LIN messages.
byte | DLC
Default DLC for LIN messages.
int | HardwareType
Hardwaretye (currently used for vector configuration). More...
byte | MasterID
The LIN Master ID to use.
LinVersion Version
A value indicating the LIN version to use. More...

Properties

object Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Represents the vendor(hardware) independant LIN configuration.

  • May be used to serialize and deserialize LIN settings.
  • May be extended with additional settings for a LIN Bus configuration.

Constructor & Destructor Documentation

◆ LINConfiguration()

LINConfiguration | ( | byte | masterId,
 |  | ushort | baudrate,
 |  | LinVersion | version = LinVersion._2_1,
 |  | byte | dlc = 8,
 |  | ChecksumType | checksumType = ChecksumType.CALC_CHECKSUM,
 |  | int | channel = 0
 | ) |  |

Initialises a new instance with the specified parameters.

Parameters
masterId | The LIN Master ID to use
baudrate | The baudrate to configure (the baudrate range is 200…30000)
version | The LIN protocol version to use
dlc | Default DLC for LIN messages.
checksumType | Checksum type for LIN messages
channel | The channel to configure

Member Data Documentation

◆ Baudrate

ushort Baudrate

The baudrate to configure.

The baudrate range is 200…30000

◆ HardwareType

int HardwareType

Hardwaretye (currently used for vector configuration).

The following Vector devices suppoprts LIN:

  • jnsoft.Comm.Vector.HWType.VN16XX
  • jnsoft.Comm.Vector.HWType.VN7572
  • jnsoft.Comm.Vector.HWType.VN8900

◆ Version

LinVersion Version

A value indicating the LIN version to use.

e.g. Vector supports 1.3, 2.0, 2.1

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance (e.g. this can be used to provide an alternative LINProvider initialisation based on the referenced data).


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINConfiguration
LINConfiguration Member List

This is the complete list of members for LINConfiguration, including all inherited members.

Baudrate | LINConfiguration
BusId | LINConfiguration
Channel | LINConfiguration
ChecksumType | LINConfiguration
DLC | LINConfiguration
HardwareType | LINConfiguration
LINConfiguration() | LINConfiguration
LINConfiguration(byte masterId, ushort baudrate, LinVersion version=LinVersion._2_1, byte dlc=8, ChecksumType checksumType=ChecksumType.CALC_CHECKSUM, int channel=0) | LINConfiguration
MasterID | LINConfiguration
Tag | LINConfiguration
Version | LINConfiguration


ASAP2Library interface: LINEventArgs Class Reference

  • Comm
  • LIN
  • LINEventArgs
Public Member Functions | Public Attributes | List of all members
LINEventArgs Class Reference

EventArgs class to notify transferred LIN frames. More...

Public Member Functions

LINEventArgs (LINFrame frame)
Initialises a new instance of LINEventArgs with the specified paraneters. More...

Public Attributes

readonly LINFrame Frame
The transferred LIN frame.

Detailed Description

EventArgs class to notify transferred LIN frames.

Constructor & Destructor Documentation

◆ LINEventArgs()

LINEventArgs ( LINFrame frame )

Initialises a new instance of LINEventArgs with the specified paraneters.

Parameters
frame The transferred LIN frame


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINEventArgs
LINEventArgs Member List

This is the complete list of members for LINEventArgs, including all inherited members.

Frame | LINEventArgs
LINEventArgs(LINFrame frame) | LINEventArgs


ASAP2Library interface: LINFilterIDs Class Reference

  • Comm
  • LIN
  • LINFilterIDs
Public Member Functions | List of all members
LINFilterIDs Class Reference

Serializes LIN filter IDs. More...

Public Member Functions

LINFilterIDs (IEnumerable< byte > collection)

Detailed Description

Serializes LIN filter IDs.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINFilterIDs
LINFilterIDs Member List

This is the complete list of members for LINFilterIDs, including all inherited members.

LINFilterIDs() (defined in LINFilterIDs) | LINFilterIDs
LINFilterIDs(IEnumerable< byte > collection) (defined in LINFilterIDs) | LINFilterIDs


ASAP2Library interface: LINFrame Class Reference

  • Comm
  • LIN
  • LINFrame
Public Member Functions | Public Attributes | Properties | List of all members
LINFrame Class Reference

Represents a sent or received LIN message. More...

Public Member Functions

LINFrame (ref string busID, byte id, byte[] data, bool isMasterFrame)
Initialises a new instance of LINFrame with the specified parameters. More...
LINFrame (ref string busID, byte id, byte[] data, byte len, bool isMasterFrame)
Initialises a new instance of LINFrame with the specified parameters. More...
LINFrame (ref string busID, byte id, ulong data, byte len, bool isMasterFrame)
Initialises a new instance of CANFrame with the specified parameters. More...
override string | toClipboard ()
Builds a tab delimited representation of the LIN frame. More...
override string | toCSV ()
Builds a CSV representation of the LIN frame. More...
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Public Attributes

string | BusID
The LIN Bus source identifcation (free text, maybe something like 'Vector virtual LIN Bus 1')
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Properties

string | Address [get]
The address sent or received from.
byte | ID [get]
Gets the LIN message ID sent or received.
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Represents a sent or received LIN message.

Constructor & Destructor Documentation

◆ LINFrame() [1/3]

LINFrame | ( | ref string | busID,
 |  | byte | id,
 |  | byte[] | data,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of LINFrame with the specified parameters.

Parameters
busID | The LIN Bus identification
id | LIN message ID
data | The complete frame data
isMasterFrame | true if the frame is sent by the master, else false

◆ LINFrame() [2/3]

LINFrame | ( | ref string | busID,
 |  | byte | id,
 |  | byte[] | data,
 |  | byte | len,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of LINFrame with the specified parameters.

Parameters
busID | The LIN Bus identification
id | LIN message ID
data | The complete frame data
len | The length of data
isMasterFrame | true if the frame is sent by the master, else false

◆ LINFrame() [3/3]

LINFrame | ( | ref string | busID,
 |  | byte | id,
 |  | ulong | data,
 |  | byte | len,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of CANFrame with the specified parameters.

Parameters
busID | The LIN Bus identification
id | LIN message ID
data | The complete frame data
len | The data length
isMasterFrame | true if the frame is sent by the master, else false

Member Function Documentation

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the LIN frame.

Returns
the string representation

Implements Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the LIN frame.

Returns
the string representation

Implements Frame.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINFrame
LINFrame Member List

This is the complete list of members for LINFrame, including all inherited members.

Address | LINFrame |
BusID | LINFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
ID | LINFrame |
IsMasterFrame | Frame |
LINFrame(ref string busID, byte id, byte[] data, bool isMasterFrame) | LINFrame |
LINFrame(ref string busID, byte id, byte[] data, byte len, bool isMasterFrame) | LINFrame |
LINFrame(ref string busID, byte id, ulong data, byte len, bool isMasterFrame) | LINFrame |
toClipboard() | LINFrame | virtual
toCSV() | LINFrame | virtual


ASAP2Library interface: LINFrameDict Class Reference

  • Comm
  • LIN
  • LINFrameDict
LINFrameDict Class Reference

Maps LIN Id to LIN frames. More...

Detailed Description

Maps LIN Id to LIN frames.


ASAP2Library interface: LINFrameQueue Class Reference

  • Comm
  • LIN
  • LINFrameQueue
Public Member Functions | Properties | List of all members
LINFrameQueue Class Reference

Queue implementation to store LINFrame's. More...

Public Member Functions

override void | clear ()
Clears the frame queue. More...
void | enqueueFrame (LINFrame frame, LINProvider provider)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< LINFrame >
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

LINFrameDict | FrameDict [get]
Gets the most recent unique LIN Frames. More...
static LINFrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< LINFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< LINFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< LINFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< LINFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store LINFrame's.

Member Function Documentation

◆ clear()

override void clear ( )
virtual

Clears the frame queue.

Reimplemented from FrameQueue< LINFrame >.

◆ enqueueFrame()

void enqueueFrame | ( | LINFrame | frame,
 |  | LINProvider | provider
 | ) |  |

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore acces to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame | The frame to add
provider | The LIN provider Instance (may be null)

Property Documentation

◆ FrameDict

LINFrameDict FrameDict
get

Gets the most recent unique LIN Frames.

This can be cleared by clearFrameDict.


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINFrameQueue
LINFrameQueue Member List

This is the complete list of members for LINFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< LINFrame > | protected
clear() | LINFrameQueue | virtual
Dispose() | FrameQueue< LINFrame > | virtual
enqueueFrame(LINFrame frame, LINProvider provider) | LINFrameQueue |
FrameDict | LINFrameQueue |
FrameEnqueued | FrameQueue< LINFrame > |
getFrames(out int cntFrames) | FrameQueue< LINFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< LINFrame > |
Instance | LINFrameQueue | static
IsWritingToFile | FrameQueue< LINFrame > |
LogFileCSVHeader (defined in LINFrameQueue) | LINFrameQueue |
LogFileName (defined in LINFrameQueue) | LINFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< LINFrame > |


ASAP2Library interface: LINProvider Class Reference

  • Comm
  • LIN
  • LINProvider
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
LINProvider Class Referenceabstract

Implements a base class for a vendor specific LIN provider. More...

Public Member Functions

virtual IEnumerable< object > | GetAvailableHardware (MediaType type)
IEnumerable< object > | GetAvilableHardware ()
abstract bool | isAvailable ()
Returns true if the LIN adapter is available (installed). More...
virtual bool | open (LINConfiguration config)
Open the LIN resource More...
abstract int | send (byte id, byte[] data)
Send data to the LIN resource. More...
override string | ToString ()
- Public Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
abstract void | close ()
virtual void | Dispose ()
Disposes all used resources from the instance. More...
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)
- Public Member Functions inherited from IFrameProvider< LINEventArgs >
void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Static Public Member Functions

static string toLINIDString (byte id)
Converts a LIN ID into a string in hexdecimal notation. More...

Protected Member Functions

LINProvider ()
Initialises a new instance of LINProvider.
int | hasSent (LINFrame frame)
Called when a frame has sent to the LIN Bus. More...
sealed override void | notifyThread ()
The LIN notify thread. More...
sealed override void | receiveThread ()
The LIN receive thread. More...
- Protected Member Functions inherited from FrameProvider< LINFrame, LINEventArgs >
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.

Protected Attributes

LINConfiguration | mConfig
Holds the current LIN configuration.
- Protected Attributes inherited from FrameProvider< LINFrame, LINEventArgs >
long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent
volatile bool | mIsActivated
long | mLastBusloadQuery
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent
readonly List< T > | mNotifyFramesList
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict
readonly AutoResetEvent | mRxEvent
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Additional Inherited Members

- Properties inherited from FrameProvider< LINFrame, LINEventArgs >
int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.
- Properties inherited from ILINProvider
int | UniqueBusID [get]
Gets the unique LIN Bus ID.
- Properties inherited from IFrameProvider< LINEventArgs >
int | ClientCount [get]
Gets the number of registered clients.

Detailed Description

Implements a base class for a vendor specific LIN provider.

  • Provides access to a single LIN Bus channel.
  • Provides functionality for registering callbacks for multiple LIN clients.
  • Decouples the LIN receive thread from notifying registered clients in case not to block receiving date from the LINProvider.

Member Function Documentation

◆ hasSent()

int hasSent ( LINFrame frame )
protected

Called when a frame has sent to the LIN Bus.

Parameters
frame The LIN frame sent
Returns
The data length of the frame sent

◆ isAvailable()

abstract bool isAvailable ( )
pure virtual

Returns true if the LIN adapter is available (installed).

Returns
true if the LIN adapter is available

Implements ILINProvider.

Implemented in ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.

◆ notifyThread()

sealed override void notifyThread ( )
protectedvirtual

The LIN notify thread.

  • Stops only if the thread is aborted from disposing the instance!
  • Any exceptions thrown from the registered LIN handler is caught!

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ open()

virtual bool open ( LINConfiguration config )
virtual

Open the LIN resource

Parameters
config The required LIN configuration
Returns
true if successfully opened

Implements ILINProvider.

Reimplemented in ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.

◆ receiveThread()

sealed override void receiveThread ( )
protectedvirtual

The LIN receive thread.

  • Stops only if the thread is aborted from disposing the instance!
  • Ay exception thrown from the registered LIN handler is caught!

Implements FrameProvider< LINFrame, LINEventArgs >.

◆ send()

abstract int send | ( | byte | id,
 |  | byte[] | data
 | ) |  |
pure virtual

Send data to the LIN resource.

Parameters
id LIN Slave ID
data The data to send (the valid length of the data depends on the configured LIN DLC and the caller is responsible for).
  • For LIN the data length may be valid from 0..8 bytes
Returns
true if successful

Implements ILINProvider.

Implemented in ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, and VectorLIN.

◆ toLINIDString()

static string toLINIDString ( byte id )
static

Converts a LIN ID into a string in hexdecimal notation.

Parameters
id The LIN ID to convert
Returns
The LIN ID as string representation


ASAP2Library interface: Member List

  • Comm
  • LIN
  • LINProvider
LINProvider Member List

This is the complete list of members for LINProvider, including all inherited members.

jnsoft::Comm::LIN::ILINProvider.ClientCount | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.close() | IFrameProvider< LINEventArgs > |
Dispose() | FrameProvider< LINFrame, LINEventArgs > | virtual
GetAvailableHardware(MediaType type) (defined in LINProvider) | LINProvider | virtual
GetAvilableHardware() (defined in LINProvider) | LINProvider |
hasSent(LINFrame frame) | LINProvider | protected
isAvailable() | LINProvider | pure virtual
LINProvider() | LINProvider | protected
mConfig | LINProvider | protected
mRxEvent | FrameProvider< LINFrame, LINEventArgs > | protected
notifyThread() | LINProvider | protectedvirtual
onReceive(out T frame) | FrameProvider< LINFrame, LINEventArgs > | pure virtual
open(LINConfiguration config) | LINProvider | virtual
receiveThread() | LINProvider | protectedvirtual
jnsoft::Comm::LIN::ILINProvider.registerClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< LINEventArgs > |
send(byte id, byte[] data) | LINProvider | pure virtual
start() | FrameProvider< LINFrame, LINEventArgs > | protected
stop() | FrameProvider< LINFrame, LINEventArgs > | protected
toLINIDString(byte id) | LINProvider | static
ToString() (defined in LINProvider) | LINProvider |
FrameProvider< LINFrame, LINEventArgs >.UniqueBusID | FrameProvider< LINFrame, LINEventArgs > |
jnsoft::Comm::LIN::ILINProvider.UniqueBusID | ILINProvider |
jnsoft::Comm::LIN::ILINProvider.unregisterClient(EventHandler< T > handler) | IFrameProvider< LINEventArgs > |


ASAP2Library interface: jnsoft.Comm.Vector Namespace Reference

  • Comm
  • Vector
Enumerations
jnsoft.Comm.Vector Namespace Reference

Enumerations

enum HWType : byte {
NONE = 0 , Virtual = 1 , CANcardX = 2 , CANAC2PCI = 6 ,
CANcardY = 12 , CANcardXL = 15 , CANcaseXL = 21 , CANBOARDXL = 25 ,
CANBOARDXL_PXI = 27 , VN2600 = 29 , VN2610 = VN2600 , VN3300 = 37 ,
VN3600 = 39 , VN7600 = 41 , CANcardXLe = 43 , VN8900 = 45 ,
VN8950 = 47 , VN2640 = 53 , VN1610 = 55 , VN1630 = 57 ,
VN1640 = 59 , VN8970 = 61 , VN1611 = 63 , VN5240 ,
VN5610 , VN5620 , VN7570 , VN5650 ,
IPCLIENT , VX1121 = 73 , VX1131 = 75 , VT6204 = 77 ,
VN1630_LOG = 79 , VN7610 = 81 , VN7572 = 83 , VN8972 = 85 ,
VN0601 = 87 , VN5640 = 89 , VX0312 = 91 , VN8800 = 95 ,
IPCL8800 , IPSRV8800 , CSMCAN , VN5610A = 101 ,
VN7640 , VX1135 = 104 , VN4610 , VT6306 = 107 ,
VT6104A , VN5430 , VTSSERVICE , VN1530 = 112 ,
VN1531 , VX1161A , VX1161B
}
Vector hardware types.


ASAP2Library interface: jnsoft.Comm.XCP Namespace Reference

  • Comm
  • XCP
Namespaces | Classes | Enumerations
jnsoft.Comm.XCP Namespace Reference

Implements the XCP Protocol Version 1.3 (ASAM MCD-1 XCP V1.3.0) More...

Namespaces

namespace SxI
All the stuff needed to communicate with Serial interfaces.

Classes

class | CmdBase
Base class represents a XCP command. More...
class | CmdUserTransCmd
Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd. More...
class | DAQDictXCP
Holds a dictionary of configured DAQ Lists. More...
class | DAQListXCP
DAQ List representation. More...
class | EventBase
Base class represents a XCP event. More...
class | EventResumeMode
Event START IN RESUME MODE More...
class | EventResumeModeTS
Event START IN RESUME MODE. More...
class | EventStimTimeout
Event INDICATION OF TIME-OUT AT STIM. More...
class | EventTimeSync
Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP. More...
class | ODT
ECU Simulator: ODT representation. More...
class | ODTDict
ECUSimulator: Dictionary mapping PIDs to ODTs. More...
class | RespBase
Base class represents a XCP response. More...
class | RespBuildChecksum
Response from Build checksum over memory range More...
class | RespConnect
Response from Set up connection with slave More...
class | RespDTOCtrResp
Response from DTO CTR Properties command. More...
class | RespError
Error Response More...
class | RespEvent
Event response More...
class | RespGetCALPage
Response from Get calibration page More...
class | RespGetCommModeInfo
Response from Get current session status from slave More...
class | RespGetDAQClock
Response from Get DAQ clock from slave More...
class | RespGetDAQEventInfo
Response from Get specific information for an event channel More...
class | RespGetDAQListInfo
Response from Get specific information for a DAQ list More...
class | RespGetDAQListMode
Response from Get mode from DAQ list More...
class | RespGetDAQListUSBEndpoint
Response from Get DAQ List USB Endpoint. More...
class | RespGetDAQProcessorInfo
Response from Get general information on DAQ processor More...
class | RespGetDAQResolutionInfo
Response from Get general information on DAQ processing resolution More...
class | RespGetID
Response from Get identification from slave More...
class | RespGetPageInfo
Response from Get specific information for a PAGE More...
class | RespGetPAGProcessorInfo
Response from Get general information on PAG processor More...
class | RespGetPGMProcessorInfo
Response from Get general information on PGM processor More...
class | RespGetSectorInfoModeAddressOrLen
Response from Get specific information for a SECTOR More...
class | RespGetSectorInfoModeSectorNameLen
Response from Get specific information for a SECTOR More...
class | RespGetSeed
Response from Get seed for unlocking a protected resource More...
class | RespGetSegmentInfo
Response from Get address information for a SEGMENT More...
class | RespGetSegmentInfoAddress
Response from Get standard information for a SEGMENT More...
class | RespGetSegmentMode
Response from Set mode for a SEGMENT More...
class | RespGetStatus
Response from Get current session status from slave More...
class | RespProgramStart
Response from Indicate the beginning of a programming sequence More...
class | RespReadDAQ
Response from Read element from ODT entry More...
class | RespService
Base class represents a XCP service request. More...
class | RespStartStopDAQList
Response from Start/stop/select DAQ list More...
class | RespTimeCorrelation
Response from Time Correlation command. More...
class | RespUnlock
Response from Send key for unlocking a protected resource More...
class | XCPCommunicator
Base class supporting any XCP based communication instance. More...
class | XCPErrorArgs
ErrorArgs class delivering received command errors. More...
class | XCPEventArgs
EventArgs class delivering received events. More...
class | XCPFrame
Represents an XCP frame. More...
class | XCPFrameQueue
Queue implementation to store XCPFrame's. More...
class | XCPMaster
Implements the XCP Master to communicate with a XCP Slave. More...
class | XCPMasterBase
Implements the XCP Master base communication with a XCP Slave. More...
class | XCPonEth
Base class implementing the XCP on ethernet based communication instance. More...
class | XCPOnSxI
Implements the XCP on SxI based communication instance. More...
class | XCPonTCP
Implements the TCP based XCP communication. More...
class | XCPonUDP
Implements the UDP based XCP communication. More...
class | XCPOnUSB
Implements the XCP on USB based communication instance. More...
class | XCPReceiveBuffer
Implements a receive buffer for XCP frames. More...
class | XCPServiceRequestArgs
EventArgs class delivering received events. More...

Enumerations

enum | BasicAddressModeType : byte { Address , Length }
Possible segment address mode types. More...
enum | CalPageMode : byte { ECU = 1 , XCP = ECU << 1 , ALL = ECU << 7 }
Possible cal page modes. More...
enum ClockInfo : byte {
None , SLV_CLK_INFO , GRANDM_CLK_INFO = SLV_CLK_INFO << 1 , CLK_RELATION = SLV_CLK_INFO << 2 ,
ECU_CLK_INFO = SLV_CLK_INFO << 3 , ECU_GRANDM_CLK_INFO = SLV_CLK_INFO << 4
}
Time Correlation CLOCK_INFO parameter bit mask structure. More...
enum CmdResult {
ERR_CMD_SYNCH , ERR_CMD_BUSY = 0x10 , ERR_DAQ_ACTIVE , ERR_PGM_ACTIVE ,
ERR_CMD_UNKNOWN = 0x20 , ERR_CMD_SYNTAX , ERR_OUT_OF_RANGE , ERR_WRITE_PROTECTED ,
ERR_ACCESS_DENIED , ERR_ACCESS_LOCKED , ERR_PAGE_NOT_VALID , ERR_MODE_NOT_VALID ,
ERR_SEGMENT_NOT_VALID , ERR_SEQUENCE , ERR_DAQ_CONFIG , ERR_MEMORY_OVERFLOW = 0x30 ,
ERR_GENERIC , ERR_VERIFY , ERR_RESOURCE_TEMPORARY_NOT_ACCESSIBLE , ERR_SUBCMD_UNKNOWN ,
OK = 0xff , ERR_SND_CMD_FAILED , ERR_TIMEOUT , ERR_CANCELLED ,
ERR_INVALID_ARGUMENT , ERR_PROTOCOL_FAILURE
}
Possible command results. More...
enum CommandCode : byte {
Connect = 0xff , Disconnect = 0xfe , GetStatus = 0xfd , Synch = 0xfc ,
GetCommModeInfo = 0xfb , GetId = 0xfa , SetRequest = 0xf9 , GetSeed = 0xf8 ,
Unlock = 0xf7 , SetMTA = 0xf6 , Upload = 0xf5 , ShortUpload = 0xf4 ,
BuildChecksum = 0xf3 , TransportLayerCmd = 0xf2 , UserCmd = 0xf1 , Download = 0xf0 ,
DownloadNext = 0xef , DownloadMax = 0xee , ShortDownload = 0xed , ModifyBits = 0xec ,
SetCalPage = 0xeb , GetCalPage = 0xea , GetPAGProcessorInfo = 0xe9 , GetSegmentInfo = 0xe8 ,
GetPageInfo = 0xe7 , SetSegmentMode = 0xe6 , GetSegmentMode = 0xe5 , CopyCALPage = 0xe4 ,
SetDAQPtr = 0xe2 , WriteDAQ = 0xe1 , SetDAQListMode = 0xe0 , StartStopDAQList = 0xde ,
StartStopSynch = 0xdd , WriteDAQMultiple = 0xc7 , ReadDAQ = 0xdb , GetDAQClock = 0xdc ,
GetDAQProcessorInfo = 0xda , GetDAQResolutionInfo = 0xd9 , GetDAQListMode = 0xdf , GetDAQEventInfo = 0xd7 ,
DtoCtrPproperties = 0xc5 , ClearDaqList = 0xe3 , GetDAQListInfo = 0xd8 , FreeDAQ = 0xd6 ,
AllocDAQ = 0xd5 , AllocODT = 0xd4 , AllocODTEntry = 0xd3 , ProgramStart = 0xd2 ,
ProgramClear = 0xd1 , Program = 0xd0 , ProgramReset = 0xcf , GetPGMProcessorInfo = 0xce ,
GetSectorInfo = 0xcd , ProgramPrepare = 0xcc , ProgramFormat = 0xcb , ProgramNext = 0xca ,
ProgramMax = 0xc9 , ProgramVerify = 0xc8 , TimeCorrelationProperties = 0xc6
}
XCP command codes defined by the XCP specification.
enum | CommModeOptional : byte { None , MasterBlockMode , InterleavedMode }
Optional communication mode flags. More...
enum | CommModeProgram : byte { None , MasterBlockMode , InterleavedMode = MasterBlockMode << 1 , SlaveBlockMode = MasterBlockMode << 6 }
Communication modes for programming. More...
enum | ConnectMode : byte { Normal , UserDefined }
Possible connect modes. More...
enum | DAQEventProperties : byte { DAQ = 1 << 2 , STIM = DAQ << 1 , ConsistencyDAQ = DAQ << 4 , ConsistencyEvent = DAQ << 5 }
Properties for an event channelDAQ == STIM == 0 is not allowed! More...
enum DAQKeyByte : byte {
OptimisationType0 = 1 , OptimisationType1 = OptimisationType0 << 1 , OptimisationType01 = OptimisationType0 | OptimisationType1 , OptimisationType2 = OptimisationType0 << 2 ,
OptimisationType02 = OptimisationType0 | OptimisationType2 , OptimisationType3 = OptimisationType0 << 3 , AdrExtensionODT = OptimisationType0 << 4 , AdrExtensionDAQ = OptimisationType0 << 5 ,
AdrExtensionODTDAQ = AdrExtensionODT | AdrExtensionDAQ , IDFieldType0 = OptimisationType0 << 6 , IDFieldType1 = OptimisationType0 << 7 , IDFieldType11 = IDFieldType0 | IDFieldType1
}
Data acquisition key byte flags. More...
enum DAQListMode : byte {
None , Alternating , Selected = Alternating , Direction = Alternating << 1 ,
DtoCtr = Alternating << 3 , Timestamp = Alternating << 4 , PIDOff = Alternating << 5 , Running = Alternating << 6 ,
Resume = Alternating << 7
}
Possible DAQ list modes. More...
enum | DAQListProperties : byte { Predefined = 1 , EventFixed = Predefined << 1 , DAQ = Predefined << 2 , STIM = Predefined << 3 }
Properties for a DAQ list. More...
enum DAQProperties : byte {
Dynamic = 1 , PrescalerSupported = Dynamic << 1 , ResumeSupported = Dynamic << 2 , BitSTIMSupported = Dynamic << 3 ,
TimestampSupported = Dynamic << 4 , PIDOffSupported = Dynamic << 5 , OverloadMSB = Dynamic << 6 , OverloadEvent = Dynamic << 7
}
The DAQ_PROPERTIES parameter is a bit mask More...
enum DAQTimestampMode : byte {
Size0 = 1 , Size1 = Size0 << 1 , Size2 = Size0 << 2 , TimestampFixed = Size0 << 3 ,
Uint0 = Size0 << 4 , Uint1 = Size0 << 5 , Uint2 = Size0 << 6 , Uint3 = Size0 << 7
}
The TIMESTAMP_MODE parameter is a bit mask. More...
enum | DTOCtrMode : byte { None , DAQ , STIM = DAQ << 1 }
DtoCtrProperties MODE parameter bit mask coding. More...
enum | DTOCtrModifier : byte { None , STIM , DAQ = STIM << 1 , RELATED_EVENT = STIM << 2 }
DtoCtrProperties MODIFIER parameter bit mask coding. More...
enum DTOCtrProperties : byte {
RelatedEventFixed = 1 , DAQModeFixed = RelatedEventFixed<<1 , STIMModeFixed = RelatedEventFixed << 2 , RelatedEventPresent = RelatedEventFixed << 3 ,
DAQModePresent = RelatedEventFixed << 4 , STIMModePresent = RelatedEventFixed << 5 , STIMCtrCpyPresent = RelatedEventFixed << 6 , EctCtrPresent = RelatedEventFixed << 7
}
DtoCtrProperties PROPERTIES parameter bit mask coding. More...
enum EventCodes : byte {
ResumeMode = 0x00 , ClearDAQ = 0x01 , StoreDAQ = 0x02 , StoreCAL = 0x03 ,
CmdPending = 0x05 , DAQOverload = 0x06 , SessionTerminated = 0x07 , TimeSync = 0x08 ,
STIMTimeout = 0x09 , Sleep = 0x0a , WakeUp = 0x0b , DAQDataLost = 0xfd ,
User = 0xfe , Transport = 0xff
}
Possible XCP event codes. More...
enum | GetIDRespType : byte { TRANSFER_MODE = 1 , COMPRESSED_ENCRYPTED = TRANSFER_MODE << 1 }
Possible GetID transfer types. More...
enum GetIDType : byte {
ASCII , ASAP2FileNameWithoutExt , ASAP2FileName , ASAP2URL ,
ASAP2File2Upload
}
Possible GetID request types. More...
enum | GetSectorInfoMode : byte { StartAddress , Length , NameLength }
Possible sector info modes.
enum | GetSegmentModeType : byte { Address , Standard , Mapping }
Defines request modes. More...
enum | GetSlaveIDMode : byte { IdentifyByEcho , ConfirmByInverseEcho }
Possible XCPOnCAN GetSlaveID modes. More...
enum | GranODTEntrySize : byte { Byte = 1 , Word = Byte << 1 , DWord = Byte << 2 , QWord = Byte << 3 }
Granularity for size of ODT entry (STIM or DAQ). More...
enum | MappingInfoModeType : byte { SourceAddress , DestinationAddress , LengthAddress }
Possible mapping info modes
enum ObservableClocks : byte {
None , XCP_SLV_CLK_AVAIL , XCP_SLV_CLK_NOT_AVAIL = XCP_SLV_CLK_AVAIL << 1 , GRANDM_CLK_AVAIL = XCP_SLV_CLK_AVAIL << 2 ,
GRANDM_CLK_NOT_AVAIL = XCP_SLV_CLK_AVAIL << 3 , ECU_CLK_CAN_READ_RANDOM = XCP_SLV_CLK_AVAIL << 4 , ECU_CLK_CANNOT_READ_RANDOM = XCP_SLV_CLK_AVAIL << 5 , ECU_CLK_CANNOT_READ = ECU_CLK_CAN_READ_RANDOM | ECU_CLK_CANNOT_READ_RANDOM
}
Time Correlation OBSERVABLE_CLOCKS parameter bit mask coding. More...
enum PageProperties : byte {
ECUAccessWithoutXCP = 1 , ECUAccessWithXCP = ECUAccessWithoutXCP << 1 , XCPReadAccessWithoutECU = ECUAccessWithoutXCP << 2 , XCPReadAccessWithECU = ECUAccessWithoutXCP << 3 ,
XCPWriteAccessWithoutECU = ECUAccessWithoutXCP << 4 , XCPWriteAccessWithECU = ECUAccessWithoutXCP << 5
}
Possible page properties. More...
enum PayloadFmt : byte {
None , XCP_SLV_DWORD , XCP_SLV_DLONG = XCP_SLV_DWORD << 1 , GRANDM_DWORD = XCP_SLV_DWORD << 2 ,
GRANDM_DLONG = XCP_SLV_DWORD << 3 , ECU_DWORD = XCP_SLV_DWORD << 4 , ECU_DLONG = XCP_SLV_DWORD << 5 , CLUSTER_IDENTIFIER = XCP_SLV_DWORD << 6
}
GetDAQClock PAYLOAD_FMT parameter bit mask structure More...
enum | PIDSlaveMaster : byte { SERV = 0xfc , EV , ERR , RES }
Supported types of XCP communication. More...
enum | ProgramClearMode : byte { AbsoluteAccess , FunctionalAccess }
Possible modes to program clear. More...
enum ProgramProperties : byte {
None , AbsoluteMode , FunctionalMode = AbsoluteMode << 1 , CompressionSupported = AbsoluteMode << 2 ,
CompressionRequired = AbsoluteMode << 3 , EncryptionSupported = AbsoluteMode << 4 , EncryptionRequired = AbsoluteMode << 5 , NonSeqProgramSupported = AbsoluteMode << 6 ,
NonSeqProgramRequired = AbsoluteMode << 7
}
enum | ProgramVerifyMode : byte { RequestToStartInternalRoutine , SendingVerificationValue , None }
Possible verification modes. More...
enum ResourceType : byte {
None , CAL_PAG , DAQ = CAL_PAG << 2 , STIM = CAL_PAG << 3 ,
PGM = CAL_PAG << 4
}
Possible resource types More...
enum | SeedModeType : byte { FirstPart , RemainingPart }
Possible types of the GetSeed command. More...
enum | SegmentInfoMode : byte { GetBasicAddress , GetStandardInfo , GetAddressMapping }
Posible segment info modes. More...
enum | SegmentMode : byte { None , Freeze }
Possible segment modes More...
enum | ServiceRequestCode : byte { Reset , Text }
Possible service requests More...
enum SessionState : byte {
None , StoreCALRequest , StoreDAQRequest = StoreCALRequest << 2 , ClearDAQRequest = StoreCALRequest << 3 ,
DAQRunning = StoreCALRequest << 6 , Resume = StoreCALRequest << 7
}
Possible session states. More...
enum | SetRequestMode : byte { StoreCALRequest = 1 , StoreDAQRequestNoResume = StoreCALRequest << 1 , StoreDAQRequestResume = StoreCALRequest << 2 , ClearDAQRequest = StoreCALRequest << 3 }
Posoible Set Request modes. More...
enum SlaveConfig : byte {
None , ResponseFmtSendOnInitTrigger , ResponseFmtSendOnAllTrigger = ResponseFmtSendOnInitTrigger << 1 , DAQTsRelation = ResponseFmtSendOnInitTrigger << 2 ,
TimeSyncBridgeDisabled = ResponseFmtSendOnInitTrigger << 3 , TimeSyncBridgeEnabled = ResponseFmtSendOnInitTrigger << 4
}
Time Correlation SLAVE_CONFIG parameter bit mask coding. More...
enum | STIMTimeoutMode : byte { EventChannelNo , DAQListNo }
Possible STIM timeout modes. More...
enum SyncState : byte {
None , SLV_CLK_IS_SYNCRONIZED , SLV_CLK_IS_SYNTONIZED = SLV_CLK_IS_SYNCRONIZED | 0x02 , SLV_CLK_IS_NOT_SUPPORTED = 0x04 ,
GRANDM_CLK = SLV_CLK_IS_NOT_SUPPORTED << 1 , ECU_CLK = SLV_CLK_IS_NOT_SUPPORTED << 2 , ECU_CLK_UNKNOWN = SLV_CLK_IS_NOT_SUPPORTED << 3
}
Time Correlation SYNC_STATE parameter bit mask coding. More...
enum | TimeCorrGetPropsReq : byte { None , GET_CLK_INFO }
Time Correlation GET_PROPERTIES_REQUEST parameter bit mask structure. More...
enum TimeCorrSetProps : byte {
None , ResponseFmtSendOnInitTrigger , ResponseFmtSendOnAllTrigger = ResponseFmtSendOnInitTrigger << 1 , TimeSyncBridgeEnable = ResponseFmtSendOnInitTrigger << 2 ,
TimeSyncBridgeDisable = ResponseFmtSendOnInitTrigger << 3 , SetClusterId = ResponseFmtSendOnInitTrigger << 4
}
Time Correlation SET_PROPERTIES parameter bit mask structure. More...
enum | TimeOfTSSampling : byte { DuringCmdProcessing , LowJitter , PhysicalTransmission , PhysicalReception }
GetDAQClock Point in time when the XCP slave’s timestamp was sampled. More...
enum TriggerInitiator : byte {
HWTrigger , EventDerived , MultiCast , MultiCastViaTimeSync ,
StateChangeInSynSync , LeapSecondOccured , ReleaseECUReset , reserved
}
GetDAQClock Trigger Initiator. More...
enum | USBEndpointType : byte { Configurable , Fixxed }
Possible USB Endpoint types. More...
enum | XCPonCAN : byte { GetSlaveID = 0xff , GetDAQID = 0xfe , SetDAQID = 0xfd , GetDAQClockMulticast = 0xfa }
Possible subcommands defined in XCPonCAN for the TRANSPORT_LAYER_CMD. More...
enum XCPType {
Unknown , UDP , TCP , CAN ,
USB , FlexRay , SxI
}
Supported types of XCP communication. More...

Detailed Description

Implements the XCP Protocol Version 1.3 (ASAM MCD-1 XCP V1.3.0)

  • supported is XCPType.UDP, XCPType.TCP and XCPType.CAN

Enumeration Type Documentation

◆ BasicAddressModeType

enum BasicAddressModeType : byte

Possible segment address mode types.

Enumerator
Address | request segment's address.
Length | request segment's length.

◆ CalPageMode

enum CalPageMode : byte

Possible cal page modes.

Used in CmdSetCALPage.

Enumerator
ECU | The given page will be used by the slave device application.
XCP | The slave device XCP driver will access the given page.
ALL | The logical segment number is ignored. The command applies to all segments.

◆ ClockInfo

enum ClockInfo : byte

Time Correlation CLOCK_INFO parameter bit mask structure.

  • SLV_CLK_ parameter is only relevant if XCP_SLV_CLK parameter of OBSERVABLE_CLOCKS parameter is equal 1
Enumerator
SLV_CLK_INFO | 0 = XCP slave’s clock information not part of data block 1 = set MTA to start of XCP slave’s clock information data block
GRANDM_CLK_INFO | 0 = Grandmaster’s clock information not part of data block 1 = if there is no predecessor data block, MTA set to start of grandmaster’s clock information data block, else append grandmaster’s clock information block to predecessor data block
CLK_RELATION | 0 = clock relation not part of data block 1 = if there is no predecessor data block, MTA set to start of clock relation data block, else append clock relation data block to predecessor data block
ECU_CLK_INFO | 0 = ECU’s clock information not part of data block 1 = if there is no predecessor data block, MTA set to start of ECU’s clock information data block, else append ECU’s clock information block to predecessor data block
ECU_GRANDM_CLK_INFO | 0 = ECU’s grandmaster clock information not part of data block 1 = append ECU’s grandmaster clock information block to predecessor data block (there must be at least the ECU’s clock information block)

◆ CmdResult

enum CmdResult

Possible command results.

Enumerator
ERR_CMD_SYNCH | Command processor synchronization
ERR_CMD_BUSY | Command was not executed
ERR_DAQ_ACTIVE | Command rejected because DAQ is running
ERR_PGM_ACTIVE | Command rejected because PGM is running
ERR_CMD_UNKNOWN | Unknown command or not implemented optional command
ERR_CMD_SYNTAX | Command syntax invalid
ERR_OUT_OF_RANGE | Command syntax valid but command parameter(s) out of range
ERR_WRITE_PROTECTED | The memory location is write protected
ERR_ACCESS_DENIED | The memory location is not accessible
ERR_ACCESS_LOCKED | Access denied,Seed andKey is required
ERR_PAGE_NOT_VALID | Selected page not available
ERR_MODE_NOT_VALID | Selected page mode not available
ERR_SEGMENT_NOT_VALID | Selected segment not valid
ERR_SEQUENCE | Sequence error
ERR_DAQ_CONFIG | DAQ configuration not valid
ERR_MEMORY_OVERFLOW | Memory overflow error
ERR_GENERIC | Generic error
ERR_VERIFY | The slave internal program verify routine detects an error
ERR_RESOURCE_TEMPORARY_NOT_ACCESSIBLE | Access to the requested resource is temporary not possible
ERR_SUBCMD_UNKNOWN | Unknown sub command or not implemented optional sub command.
OK | OK (Command successful)
ERR_SND_CMD_FAILED | Failed to send the command.
ERR_TIMEOUT | Response wasn't received within the defined Timeout (disconnection?)
ERR_CANCELLED | Command cancelled by user
ERR_INVALID_ARGUMENT | Invalid argument failure (e.g. a call to upload with 0 bytes length)
ERR_PROTOCOL_FAILURE | Protocol failure (unexpected response length)

◆ CommModeOptional

enum CommModeOptional : byte

Optional communication mode flags.

Enumerator
None | None of the other 2 modes is available.
MasterBlockMode | Master block mode is available.
InterleavedMode | Interleaved mode is available.

◆ CommModeProgram

enum CommModeProgram : byte

Communication modes for programming.

Enumerator
None | Only standard mode is available.
MasterBlockMode | Master block mode is available.
InterleavedMode | Interleaved mode is available.
SlaveBlockMode | Slave block mode is available.

◆ ConnectMode

enum ConnectMode : byte

Possible connect modes.

Used in CmdConnect.

Enumerator
Normal | With a CONNECT(Mode = Normal), the master can start an XCP communication with the slave.
UserDefined | With a CONNECT(Mode = user defined), the master can start an XCP communication with the slave and at the same time tell the slave that it should go into a special (user defined) mode.

◆ DAQEventProperties

enum DAQEventProperties : byte

Properties for an event channelDAQ == STIM == 0 is not allowed!

Enumerator
DAQ | DAQ direction supported
STIM | STIM direction supported
ConsistencyDAQ | Indicates that for this Event Channel all data that belong to one and the same DAQ list are processed consistently.
ConsistencyEvent | Indicates that for this Event Channel all data are processed consistently.

◆ DAQKeyByte

enum DAQKeyByte : byte

Data acquisition key byte flags.

Used in RespGetDAQProcessorInfo.

IDFieldType:

The Identification_Field_Type flags indicate the Type of Identification Field the slave will use when transferring DAQ Packets to the master. The master has to use the same Type of Identification Field when transferring STIM Packets to the slave.

  • Not set: Absolute ODT number
  • IDFieldType0 set: Relative ODT number, absolute DAQ list number (BYTE)
  • IDFieldType1 set: Relative ODT number, absolute DAQ list number (WORD)
  • IDFieldType0, IDFieldType1 set: Relative ODT number, absolute DAQ list number (WORD, aligned)
Enumerator
OptimisationType0 | OM_ODT_TYPE_16
OptimisationType1 | OM_ODT_TYPE_32
OptimisationType01 | OM_ODT_TYPE_64
OptimisationType2 | OM_ODT_TYPE_ALIGNMENT
OptimisationType02 | OM_MAX_ENTRY_SIZE
AdrExtensionODT | address extension to be the same for all entries within one ODT.
AdrExtensionDAQ | Not allowed.
AdrExtensionODTDAQ | address extension to be the same for all entries within one DAQ.
IDFieldType0 | Relative ODT number, absolute DAQ list number (BYTE).
IDFieldType1 | Relative ODT number, absolute DAQ list number (WORD).
IDFieldType11 | Relative ODT number, absolute DAQ list number (WORD, aligned).

◆ DAQListMode

enum DAQListMode : byte

Possible DAQ list modes.

Valid for reading and setting modes.

Used in CmdSetDAQListMode.

Enumerator
None | Nothing is set.
Alternating | enable alternating display mode (only when set the mode).
Selected | (only when read the mode).
Direction | STIM set to Data Stimulation Mode (Master -> Slave).
DtoCtr | Use DTO CTR field.
Timestamp | enable timestamp mode.
PIDOff | transmit DTO without Identification Field.
Running | DAQ list is active.
Resume | DAQ list is part of a configuration used in RESUME mode.

◆ DAQListProperties

enum DAQListProperties : byte

Properties for a DAQ list.

DAQ == STIM == 0 is not allowed!

Enumerator
Predefined | indicates that the configuration of this DAQ list cannot be changed. The DAQ list is predefined and fixed in the slave device’s memory. 0 = DAQ list configuration can be changed 1 = DAQ list configuration is fixed
EventFixed | Indicates that the Event Channel for this DAQ list cannot be changed. 0 = Event Channel can be changed 1 = Event Channel is fixed
DAQ | DAQ direction supported
STIM | STIM direction supported

◆ DAQProperties

enum DAQProperties : byte

The DAQ_PROPERTIES parameter is a bit mask

Enumerator
PrescalerSupported | The PRESCALER_SUPPORTED flag indicates that all DAQ lists support the prescaler for reducing the transmission period.
ResumeSupported | The RESUME_SUPPORTED flag indicates that all DAQ lists can be put in RESUME mode.
BitSTIMSupported | The BIT_STIM_SUPPORTED flag indicates whether bitwise data stimulation through BIT_OFFSET in WRITE_DAQ is supported.
TimestampSupported | The TIMESTAMP_SUPPORTED flag indicates whether the slave supports time stamped data acquisition and stimulation. If the slave doesn’t support a time stamped mode, the parameters TIMESTAMP_MODE and TIMESTAMP_TICKS (GET_DAQ_RESOLUTION_INFO) are invalid.
PIDOffSupported | The PID_OFF_SUPPORTED flag in DAQ_PROPERTIES indicates that transfer of DTO Packets without Identification Field is possible.
OverloadMSB | Overload indication in MSB of PID
OverloadEvent | overload indication by Event Packet

◆ DAQTimestampMode

enum DAQTimestampMode : byte

The TIMESTAMP_MODE parameter is a bit mask.

Used in RespGetDAQResolutionInfo.

Enumerator
Size0 | Timestamp size is a Byte (8 Bit).
Size1 | Timestamp size is a Word (16 Bit).
Size2 | Timestamp size is a DWord (32 Bit).
TimestampFixed | Indicates that the Slave always will send DTO Packets in time.

◆ DTOCtrMode

enum DTOCtrMode : byte

DtoCtrProperties MODE parameter bit mask coding.

Enumerator
DAQ | When receiving DTOs with CTR field: 0 = DO_NOT_CHECK_COUNTER 1 = CHECK_COUNTER
STIM | When inserting the DTO CTR field: 0 = INSERT_COUNTER - use CTR of the related event 1 = INSERT_STIM_COUNTER_COPY - use STIM CTR copy of the related event

◆ DTOCtrModifier

enum DTOCtrModifier : byte

DtoCtrProperties MODIFIER parameter bit mask coding.

Enumerator
STIM | 0 = Keep the current mode setting 1 = Take the mode setting from the command
DAQ | 0 = Keep the current mode setting 1 = Take the mode setting from the command
RELATED_EVENT | 0 = Keep the current number 1 = Take the new number from the command

◆ DTOCtrProperties

enum DTOCtrProperties : byte

DtoCtrProperties PROPERTIES parameter bit mask coding.

Enumerator
RelatedEventFixed | Related event channel number of this event channel. 0 = can be modified 1 = cannot be modified
DAQModeFixed | DTO CTR DAQ mode of this event channel. 0 = can be modified 1 = cannot be modified
STIMModeFixed | DTO CTR STIM mode of this event channel. 0 = can be modified 1 = cannot be modified
RelatedEventPresent | This event channel 0 = does not have a related event channel 1 = has a related event channel
DAQModePresent | DTO CTR DAQ mode: for direction DAQ this event channel 0 = does not support DTO CTR handling 1 = supports DTO CTR handling
STIMModePresent | DTO CTR STIM mode: for direction STIM this event channel 0 = does not support DTO CTR handling 1 = supports DTO CTR handling
STIMCtrCpyPresent | STIM DTO CTR copy: on successful stimulation, this event channel 0 = can save the DTO CTR for later reference 1 = cannot save the DTO CTR for later reference
EctCtrPresent | Event counter 0 = This event channel has no cycle counter 1 = This event channel has a cycle counter

◆ EventCodes

enum EventCodes : byte

Possible XCP event codes.

Enumerator
ResumeMode | Slave starting in RESUME mode
ClearDAQ | The DAQ configuration in non-volatile memory has been cleared.
StoreDAQ | The DAQ configuration has been stored into non-volatile memory.
StoreCAL | The calibration data has been stored into non-volatile memory.
CmdPending | Slave requesting to restart time-out
DAQOverload | DAQ processor overload.
SessionTerminated | Session terminated by slave device.
TimeSync | Transfer of externally triggered timestamp
STIMTimeout | Indication of a STIM timeout
Sleep | Slave entering SLEEP mode
WakeUp | Slave leaving SLEEP mode
DAQDataLost | Raised from the master transport layer. if data acquisition data may be lost (This should only appear on UDP).
User | User-defined event
Transport | Transport layer specific event

◆ GetIDRespType

enum GetIDRespType : byte

Possible GetID transfer types.

Enumerator
TRANSFER_MODE
  • If TRANSFER_MODE is 1, the identification is transferred in the remaining bytes of the response.
  • If TRANSFER_MODE is 0, the slave device sets the Memory Transfer Address (MTA) to the location from which the master device may upload the requested identification using one or more UPLOAD commands.
COMPRESSED_ENCRYPTED

If COMPRESSED_ENCRYPTED is 1, the transferred data are compressed and/or encrypted. This is only allowed for identification type 4, i.e. “ASAM-MC2 file to upload”. The XCP master must decompress and/or decrypt the data using an implementation specific algorithm, implemented in an externally calculated function.

◆ GetIDType

enum GetIDType : byte

Possible GetID request types.

Enumerator
ASCII | ASCII text
ASAP2FileNameWithoutExt | ASAM-MC2 filename without path and extension
ASAP2FileName | ASAM-MC2 filename with path and extension
ASAP2URL | URL where the ASAM-MC2 file can be found
ASAP2File2Upload | ASAM-MC2 file to upload

◆ GetSegmentModeType

enum GetSegmentModeType : byte

Defines request modes.

Enumerator
Address | Request address info.
Standard | Request standard info.
Mapping | Request address mapping.

◆ GetSlaveIDMode

enum GetSlaveIDMode : byte

Possible XCPOnCAN GetSlaveID modes.

Enumerator
IdentifyByEcho | The response is sent as echo (should return "XCP")
ConfirmByInverseEcho | The response is sent as inversed echo (should return ~"XCP")

◆ GranODTEntrySize

enum GranODTEntrySize : byte

Granularity for size of ODT entry (STIM or DAQ).

Enumerator
Byte | 8 Bit
Word | 16 Bit
DWord | 32 Bit
QWord | 64 Bit

◆ ObservableClocks

enum ObservableClocks : byte

Time Correlation OBSERVABLE_CLOCKS parameter bit mask coding.

Enumerator
XCP_SLV_CLK_AVAIL | XCP slave clock might be syntonized or synchronized to a grandmaster clock and can be read randomly
XCP_SLV_CLK_NOT_AVAIL | There is no XCP slave clock. Nevertheless, DAQ timestamps might be related to a synchronized clock.
GRANDM_CLK_AVAIL | The XCP slave offers a dedicated clock that might be synchronized to a grandmaster clock and can be read randomly
GRANDM_CLK_NOT_AVAIL | The XCP slave offers a dedicated clock that might be synchronized to a grandmaster clock. The clock cannot be read randomly. However, the XCP slave autonomously generates EV_TIME_SYNC events containing timestamps related to the XCP slave’s clock and the clock which is synchronized to a grandmaster clock. Thereby, these timestamps have been sampled simultaneously.
ECU_CLK_CAN_READ_RANDOM | The XCP slave has access to the ECU clock and can read the clock randomly
ECU_CLK_CANNOT_READ_RANDOM | The XCP slave has access to the ECU clock but cannot read the clock randomly. However, the XCP slave autonomously generates EV_TIME_SYNC events containing timestamps related to the XCP slave’s clock and the ECU clock. Thereby, these timestamps have been sampled simultaneously.
ECU_CLK_CANNOT_READ | The XCP slave reports ECU clock based timestamps whereas the XCP slave cannot read the ECU clock

◆ PageProperties

enum PageProperties : byte

Possible page properties.

The ECUAccessX flags indicate whether and how the ECU can access this page. If the ECU can access this PAGE, the ECU_ACCESS_x flags indicate whether the ECU can access this PAGE only if the XCP master does NOT access this PAGE at the same time, only if the XCP master accesses this page at the same time, or the ECU doesn’t care whether the XCP master accesses this page at the same time or not.

The XCPReadAccessX XCPWriteAccessX flags indicate whether and how the XCP master can access this page. The flags make a distinction for the XCP_ACCESS_TYPE depending on the kind of access the XCP master can have on this page (READABLE and/or WRITEABLE).

Enumerator
ECUAccessWithoutXCP | Access Without XCP
ECUAccessWithXCP | Access With XCP
XCPReadAccessWithoutECU | Read access without ECU
XCPReadAccessWithECU | Read access with ECU
XCPWriteAccessWithoutECU | Write access without ECU
XCPWriteAccessWithECU | Wruite access with ECU

◆ PayloadFmt

enum PayloadFmt : byte

GetDAQClock PAYLOAD_FMT parameter bit mask structure

Enumerator
XCP_SLV_DWORD | XCP slave’s clock: size of payload containing timestamp: DWORD
XCP_SLV_DLONG | XCP slave’s clock: size of payload containing timestamp: DLONG (unsigned interpretation)
GRANDM_DWORD | Grandmaster’s clock: size of payload containing timestamp: DWORD
GRANDM_DLONG | Grandmaster’s clock: size of payload containing timestamp: DLONG (unsigned interpretation)
ECU_DWORD | ECU’s clock: size of payload containing timestamp: DWORD
ECU_DLONG | ECU’s clock: size of payload containing timestamp: DLONG (unsigned interpretation)
CLUSTER_IDENTIFIER | When event is sent as response to TRIGGER_INITIATOR 2 or 3; Cluster Identifier and Counter are added to event payload

◆ PIDSlaveMaster

enum PIDSlaveMaster : byte

Supported types of XCP communication.

Enumerator
SERV | Service request from slave
EV | Event
ERR | Error response
RES | Positive response

◆ ProgramClearMode

enum ProgramClearMode : byte

Possible modes to program clear.

Enumerator
AbsoluteAccess | Absolute access
FunctionalAccess | Functional access

◆ ProgramProperties

enum ProgramProperties : byte
Enumerator
AbsoluteMode | Absolute mode supported
FunctionalMode | Functional mode supported
CompressionSupported | Compression mode supported
CompressionRequired | Compression mode required
EncryptionSupported | Encryption supported
EncryptionRequired | Encryption required
NonSeqProgramSupported | Non Sequential program mode supported
NonSeqProgramRequired | Non Sequential program mode required

◆ ProgramVerifyMode

enum ProgramVerifyMode : byte

Possible verification modes.

Enumerator
RequestToStartInternalRoutine | The master can request the slave to start internal test routines to check whether the new flash contents fits to the rest of the flash. Only the result is of interest.
SendingVerificationValue | The Master can tell the slave that he will be sending a Verification Value to the slave.
None | No verification.

◆ ResourceType

enum ResourceType : byte

Possible resource types

Used in RespConnect, RespGetStatus, CmdGetSeed, RespUnlock.

Enumerator
CAL_PAG | Calibration and paging.
DAQ | Data acquisition.
STIM | Stimulation.
PGM | Programming.

◆ SeedModeType

enum SeedModeType : byte

Possible types of the GetSeed command.

Enumerator
FirstPart | Request first part of seed
RemainingPart | Request remaining part of seed

◆ SegmentInfoMode

enum SegmentInfoMode : byte

Posible segment info modes.

Enumerator
GetBasicAddress | Get basic address info.
GetStandardInfo | Get standard info.
GetAddressMapping | Get address mapping.

◆ SegmentMode

enum SegmentMode : byte

Possible segment modes

Used in RespGetSegmentMode.

Enumerator
None | Mode none or undefined.
Freeze | Freeze mode.

◆ ServiceRequestCode

enum ServiceRequestCode : byte

Possible service requests

Used in RespService.

Enumerator
Reset

Slave requesting to be reset

Text

Slave transferring a byte stream of plain ASCII text.

  • The line separator is LF or CR/LF.
  • The text can be transferred in consecutive packets.
  • The end of the overall text is indicated by the last packet containing a Null terminated string.

◆ SessionState

enum SessionState : byte

Possible session states.

Used in RespGetStatus.

Enumerator
StoreCALRequest | ReqQuest to STORE CALibration data.
StoreDAQRequest | Request to STORE DAQ list.
ClearDAQRequest | Request to CLEAR DAQ configuration.
DAQRunning | Indication of running Data Transfer.
Resume | RESUME Mode.

◆ SetRequestMode

enum SetRequestMode : byte

Posoible Set Request modes.

Used in CmdSetRequest.

Enumerator
StoreCALRequest | REQuest to STORE CALibration data.
StoreDAQRequestNoResume | REQuest to STORE DAQ list, no RESUME.
StoreDAQRequestResume | REQuest to STORE DAQ list, RESUME enabled.
ClearDAQRequest | REQuest to CLEAR DAQ configuratio.

◆ SlaveConfig

enum SlaveConfig : byte

Time Correlation SLAVE_CONFIG parameter bit mask coding.

Enumerator
ResponseFmtSendOnInitTrigger | Send EV_TIME_SYNC event packet as response to TRIGGER_INITIATOR 0, 2 and 3 only
ResponseFmtSendOnAllTrigger | Send EV_TIME_SYNC event packet for all trigger conditions
DAQTsRelation | DAQ timestamp relation 0 = DAQ timestamps are related to XCP slave clock 1 = DAQ timestamps are related to ECU clock
TimeSyncBridgeDisabled | XCP slave offers a Time Sync Bridge but Time Sync Bridge is disabled
TimeSyncBridgeEnabled | XCP slave offers a Time Sync Bridge with Time Sync Bridge enabled

◆ STIMTimeoutMode

enum STIMTimeoutMode : byte

Possible STIM timeout modes.

Enumerator
EventChannelNo | Event channel number
DAQListNo | DAQ list number

◆ SyncState

enum SyncState : byte

Time Correlation SYNC_STATE parameter bit mask coding.

  • SLV_CLK_ parameter is only relevant if XCP_SLV_CLK parameter of OBSERVABLE_CLOCKS parameter is equal 1
Enumerator
SLV_CLK_IS_SYNCRONIZED | XCP slave’s clock is synchronized to a grandmaster clock
SLV_CLK_IS_SYNTONIZED | XCP slave’s clock is syntonized to a grandmaster clock
SLV_CLK_IS_NOT_SUPPORTED | XCP slave’s clock does not support synchronization/syntonization to a grandmaster clock
GRANDM_CLK | Dedicated clock is synchronized to a grandmaster clock
ECU_CLK | ECU clock is synchronized to a grandmaster clock
ECU_CLK_UNKNOWN | The synchronization state of the ECU is unknown

◆ TimeCorrGetPropsReq

enum TimeCorrGetPropsReq : byte

Time Correlation GET_PROPERTIES_REQUEST parameter bit mask structure.

Enumerator
GET_CLK_INFO

The GET_CLK_INFO bit allows the XCP master to obtain detailed information of the observable clocks. Typically, the XCP master sets this bit when sending the first TIME_CORRELATION_PROPERTIES command. Based on the responses of its XCP slaves, the XCP master is able to derive a tree structure representing the relationship among the clocks in the system. In addition, when the XCP master detects that a clock has been syntonized or synchronized to a grandmaster clock – based on the information sent as part of the event – the XCP master will again send a TIME_CORRELATION_PROPERTIES command with this bit set to update its view on the relationship among the clocks in the system.

0 = No upload of information of the clocks requested

1 = Set MTA to start of clocks’ information data block

◆ TimeCorrSetProps

enum TimeCorrSetProps : byte

Time Correlation SET_PROPERTIES parameter bit mask structure.

Enumerator
ResponseFmtSendOnInitTrigger | Send EV_TIME_SYNC event packet as response to TRIGGER_INITIATOR 0, 2 and 3 only
ResponseFmtSendOnAllTrigger | Send EV_TIME_SYNC event packet for all trigger conditions
TimeSyncBridgeEnable | Enable time synchronization bridging functionality
TimeSyncBridgeDisable | Disable time synchronization bridging functionality
SetClusterId | Assign XCP slave to the logical time correlation cluster given by CLUSTER_ID parameter

◆ TimeOfTSSampling

enum TimeOfTSSampling : byte

GetDAQClock Point in time when the XCP slave’s timestamp was sampled.

For GET_DAQ_CLOCK_MULTICAST it is strongly recommended to implement variant 3

Enumerator
DuringCmdProcessing | during command processing at the protocol layer command processor
LowJitter | low jitter, measured in high-priority interrupt
PhysicalTransmission | upon physical transmission to XCP master
PhysicalReception | upon physical reception of command

◆ TriggerInitiator

enum TriggerInitiator : byte

GetDAQClock Trigger Initiator.

Enumerator
HWTrigger | Hardware trigger, i.e. Vector Syncline
EventDerived | Event derived from XCP-independent time synchronization event – e.g. globally synchronized pulse per second signal
MultiCast | GET_DAQ_CLOCK_MULTICAST
MultiCastViaTimeSync | GET_DAQ_CLOCK_MULTICAST via Time Sync Bridge
StateChangeInSynSync | State change in syntonization/synchronization to grandmaster clock (either established or lost, additional information is provided by the SYNC_STATE field - see Table 236)
LeapSecondOccured | Leap second occurred on grandmaster clock
ReleaseECUReset | Release of ECU reset

◆ USBEndpointType

enum USBEndpointType : byte

Possible USB Endpoint types.

Enumerator
Configurable | USB Endpoint can be configured.
Fixxed | USB Endpoint is fixed.

◆ XCPonCAN

enum XCPonCAN : byte

Possible subcommands defined in XCPonCAN for the TRANSPORT_LAYER_CMD.

Enumerator
GetSlaveID | Get Slave ID
GetDAQID | Get DAQ ID
SetDAQID | Set DAQ ID
GetDAQClockMulticast | Get DAQ Clock Multicast

◆ XCPType

enum XCPType

Supported types of XCP communication.

Enumerator
Unknown | Not known or not set...
UDP | XCP on UDP (Ethernet)
TCP | XCP on UDP (Ethernet)
CAN | XCP on CAN
USB | XCP on USB
FlexRay | XCP on FlexRay (not supported by this library)
SxI | XCP on SxI (Serial port communication)


ASAP2Library interface: jnsoft.Comm.XCP.Examples Namespace Reference

  • Comm
  • XCP
  • Examples
Classes
jnsoft.Comm.XCP.Examples Namespace Reference

Classes

class Program
ASAP2 XCP Sample console application. More...


ASAP2Library interface: Program Class Reference

  • Comm
  • XCP
  • Examples
  • Program
List of all members
Program Class Reference

ASAP2 XCP Sample console application. More...

Detailed Description

ASAP2 XCP Sample console application.

Demonstrating a simple create connection to an ECU. Usage: ASAP2XCPExample.exe ASAP2Example.a2l


ASAP2Library interface: Member List

  • Comm
  • XCP
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: jnsoft.Comm.XCP.SxI Namespace Reference

  • Comm
  • XCP
  • SxI
Classes
jnsoft.Comm.XCP.SxI Namespace Reference

All the stuff needed to communicate with Serial interfaces. More...

Classes

interface | ISxIProvider
Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...) More...
class | SxIEventArgs
EventArgs class to notify transferred SxI data. More...
class | SxIProvider
Implements a base class for serial interface specific SxI providers. More...

Detailed Description

All the stuff needed to communicate with Serial interfaces.


ASAP2Library interface: ISxIProvider Interface Reference

  • Comm
  • XCP
  • SxI
  • ISxIProvider
Public Member Functions | Properties | Events | List of all members
ISxIProvider Interface Reference

Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...) More...

Public Member Functions

void | close ()
Closes the serial interface. More...
bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
bool | isAvailable ()
Returns true if the SxI interface is successfully opened. More...
bool | open ()
Open the Serial interface. More...
void | reset ()
int | send (byte[] data)
Send data to the serial interface. More...
int | sendMsg (byte[] data)
Creates and sends the SxI frame. More...

Properties

string Port [get]
Name of the SxI Interface.

Events

EventHandler< SxIEventArgs > SxIDataReceived
Called if Data is received from a SxI interface.

Detailed Description

Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...)

Member Function Documentation

◆ close()

void close ( )

Closes the serial interface.

Implemented in SxIProvider.

◆ isAvailable()

bool isAvailable ( )

Returns true if the SxI interface is successfully opened.

Returns
true if the SxI interface is successfully opened

Implemented in SxIProvider.

◆ open()

bool open ( )

Open the Serial interface.

Returns
true if successfully opened

Implemented in SxIProvider.

◆ send()

int send ( byte[] data )

Send data to the serial interface.

Parameters
data The data to send
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implemented in SxIProvider.

◆ sendMsg()

int sendMsg ( byte[] data )

Creates and sends the SxI frame.

If a framing configuration is used, the framing bytes are added.

Parameters
data | The data to send
data | The data to send
Returns
data.Length if successful


ASAP2Library interface: Member List

  • Comm
  • XCP
  • SxI
  • ISxIProvider
ISxIProvider Member List

This is the complete list of members for ISxIProvider, including all inherited members.

close() | ISxIProvider
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) (defined in ISxIProvider) | ISxIProvider
isAvailable() | ISxIProvider
open() | ISxIProvider
Port | ISxIProvider
reset() (defined in ISxIProvider) | ISxIProvider
send(byte[] data) | ISxIProvider
sendMsg(byte[] data) | ISxIProvider
SxIDataReceived | ISxIProvider


ASAP2Library interface: SxIEventArgs Class Reference

  • Comm
  • XCP
  • SxI
  • SxIEventArgs
Public Member Functions | Public Attributes | List of all members
SxIEventArgs Class Reference

EventArgs class to notify transferred SxI data. More...

Public Member Functions

SxIEventArgs (byte[] data)
Initialises a new instance of SxIEventArgs with the specified paraneters. More...

Public Attributes

readonly byte[] Data
The received SxI data

Detailed Description

EventArgs class to notify transferred SxI data.

Constructor & Destructor Documentation

◆ SxIEventArgs()

SxIEventArgs ( byte[] data )

Initialises a new instance of SxIEventArgs with the specified paraneters.

Parameters
data The received SxI data


ASAP2Library interface: Member List

  • Comm
  • XCP
  • SxI
  • SxIEventArgs
SxIEventArgs Member List

This is the complete list of members for SxIEventArgs, including all inherited members.

Data | SxIEventArgs
SxIEventArgs(byte[] data) | SxIEventArgs


ASAP2Library interface: SxIProvider Class Reference

  • Comm
  • XCP
  • SxI
  • SxIProvider
Public Member Functions | Public Attributes | Protected Member Functions | Properties | Events | List of all members
SxIProvider Class Referenceabstract

Implements a base class for serial interface specific SxI providers. More...

Public Member Functions

abstract void | close ()
Closes the serial interface. More...
virtual void | Dispose ()
Disposes all used resources from the instance.
abstract bool | isAvailable ()
Returns true if the SxI interface is successfully opened. More...
abstract bool | open ()
Open the Serial interface. More...
virtual void | reset ()
abstract int | send (byte[] data)
Send data to the serial interface. More...

Public Attributes

readonly A2LXCP_ON_SxI SxI
The corresponding SxI configuration.

Protected Member Functions

SxIProvider (string port, A2LXCP_ON_SxI sxI)
Initialises a new instance of SxIProvider. More...

Properties

string | Port [get]
The used COM Port.
- Properties inherited from ISxIProvider
string | Port [get]
Name of the SxI Interface.

Events

EventHandler< SxIEventArgs > | SxIDataReceived
Called if serial port data is received.
- Events inherited from ISxIProvider
EventHandler< SxIEventArgs > | SxIDataReceived
Called if Data is received from a SxI interface.

Detailed Description

Implements a base class for serial interface specific SxI providers.

  • Provides access to a single serial interface.

Constructor & Destructor Documentation

◆ SxIProvider()

SxIProvider | ( | string | port,
 |  | A2LXCP_ON_SxI | sxI
 | ) |  |
protected

Initialises a new instance of SxIProvider.

Parameters
port | A unique name for the SxI provider instance
sxI | SxI configuration

Member Function Documentation

◆ close()

abstract void close ( )
pure virtual

Closes the serial interface.

Implements ISxIProvider.

◆ isAvailable()

abstract bool isAvailable ( )
pure virtual

Returns true if the SxI interface is successfully opened.

Returns
true if the SxI interface is successfully opened

Implements ISxIProvider.

◆ open()

abstract bool open ( )
pure virtual

Open the Serial interface.

Returns
true if successfully opened

Implements ISxIProvider.

◆ reset()

virtual void reset ( )
virtual

Implements ISxIProvider.

◆ send()

abstract int send ( byte[] data )
pure virtual

Send data to the serial interface.

Parameters
data The data to send
Returns
The count of bytes sent (without padding bytes, data.Length if successful)

Implements ISxIProvider.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • SxI
  • SxIProvider
SxIProvider Member List

This is the complete list of members for SxIProvider, including all inherited members.

close() | SxIProvider | pure virtual
Dispose() | SxIProvider | virtual
isAvailable() | SxIProvider | pure virtual
open() | SxIProvider | pure virtual
Port | SxIProvider |
reset() (defined in SxIProvider) | SxIProvider | virtual
send(byte[] data) | SxIProvider | pure virtual
SxI | SxIProvider |
SxIDataReceived | SxIProvider |
SxIProvider(string port, A2LXCP_ON_SxI sxI) | SxIProvider | protected


ASAP2Library interface: CmdBase Class Reference

  • Comm
  • XCP
  • CmdBase
Public Member Functions | Public Attributes | List of all members
CmdBase Class Reference

Base class represents a XCP command. More...

Public Member Functions

CmdBase ()
Internal use only!
virtual void changeEndianness ()

Public Attributes

CommandCode CmdCode

Detailed Description

Base class represents a XCP command.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • CmdBase
CmdBase Member List

This is the complete list of members for CmdBase, including all inherited members.

changeEndianness() (defined in CmdBase) | CmdBase | virtual
CmdBase() | CmdBase |
CmdCode (defined in CmdBase) | CmdBase |


ASAP2Library interface: CmdUserTransCmd Class Reference

  • Comm
  • XCP
  • CmdUserTransCmd
Public Attributes | List of all members
CmdUserTransCmd Class Reference

Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd. More...

Public Attributes

byte | SubCommand
- Public Attributes inherited from CmdBase
CommandCode | CmdCode

Additional Inherited Members

- Public Member Functions inherited from CmdBase
CmdBase ()
Internal use only!
virtual void changeEndianness ()

Detailed Description

Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • CmdUserTransCmd
CmdUserTransCmd Member List

This is the complete list of members for CmdUserTransCmd, including all inherited members.

changeEndianness() (defined in CmdBase) | CmdBase | virtual
CmdBase() | CmdBase |
CmdCode (defined in CmdBase) | CmdBase |
CmdUserTransCmd() (defined in CmdUserTransCmd) | CmdUserTransCmd |
SubCommand (defined in CmdUserTransCmd) | CmdUserTransCmd |


ASAP2Library interface: DAQDictXCP Class Reference

  • Comm
  • XCP
  • DAQDictXCP
Public Member Functions | List of all members
DAQDictXCP Class Reference

Holds a dictionary of configured DAQ Lists. More...

Public Member Functions

byte | getFirstPID (DAQList daqList)
Gets the first PID for the specified DAQ list. More...
- Public Member Functions inherited from DAQDict
new void | Clear ()
Clears all the configured ODTs. More...
void | clearData ()
Clears all data received within the DAQ list dictionary.
ODTEntry | getODTEntry (A2LMEASUREMENT measurement)
Gets the ODTEntry corresponding to the specified measurement. More...

Additional Inherited Members

- Public Attributes inherited from DAQDict
readonly Dictionary< uint, ODTEntry > ODTEntries = new Dictionary<uint, ODTEntry>()
Gets the mapping from measurement's address to the configured ODTEntry and therefore to it's measurement data.

Detailed Description

Holds a dictionary of configured DAQ Lists.

Maps a specific DAQ number to the corresponding DAQList.

Member Function Documentation

◆ getFirstPID()

byte getFirstPID ( DAQList daqList )

Gets the first PID for the specified DAQ list.

This method is only used by the simulator.

Parameters
daqList The DAQ list to compute the FirstPID for
Returns
The computed FirstPID


ASAP2Library interface: Member List

  • Comm
  • XCP
  • DAQDictXCP
DAQDictXCP Member List

This is the complete list of members for DAQDictXCP, including all inherited members.

Clear() | DAQDict
clearData() | DAQDict
getFirstPID(DAQList daqList) | DAQDictXCP
getODTEntry(A2LMEASUREMENT measurement) | DAQDict
ODTEntries | DAQDict


ASAP2Library interface: DAQListXCP Class Reference

  • Comm
  • XCP
  • DAQListXCP
Public Member Functions | Public Attributes | Properties | List of all members
DAQListXCP Class Reference

DAQ List representation. More...

Public Member Functions

DAQListXCP (ushort daqNo, A2LXCP_EVENT evt, byte firstPID=0)
Initializes a new DAQ List with the specified parameters. More...
DAQListXCP (ushort daqNo, A2LXCP_EVENT evt, ushort maxDTO, byte maxODT, byte maxODTEntries, int dataOffsetFirstPid, int dataOffset)
Initializes a new DAQ List with the specified parameters. More...
override void clearData ()
Clears only the contained data, not the DAQ configuration. More...

Public Attributes

readonly A2LXCP_EVENT | Evt
Gets the corresponding XCP event.
DAQListMode | Mode
StartStopMode | State
Gets or sets the current state of the DAQ list.
- Public Attributes inherited from DAQList
readonly ushort | EvtNo = ushort.MaxValue
The corresponding event channel number.
readonly SortedDictionary< byte, ODTList > | ODTs = new SortedDictionary<byte, ODTList>()
List of configured ODTs
readonly string | TimeCycle
Minimal period duration of the acquisition raster

Properties

ODTDict | ODTDict = new ODTDict() [get]
Gets the configured ODTs in the DAQ list.
- Properties inherited from DAQList
uint | CANId [getset]
Gets the corresponding CAN ID
ushort | DAQNo [getset]
The (unique) DAQ number.
byte | FirstPID [getset]
Number of the FirstPID. More...

Detailed Description

DAQ List representation.

Holds a dictionary of configured ODTs.

Constructor & Destructor Documentation

◆ DAQListXCP() [1/2]

DAQListXCP | ( | ushort | daqNo,
 |  | A2LXCP_EVENT | evt,
 |  | byte | firstPID = 0
 | ) |  |

Initializes a new DAQ List with the specified parameters.

Parameters
daqNo | DAQ Number.
evt | The corresponding XCP event
firstPID | a potential first PID

◆ DAQListXCP() [2/2]

DAQListXCP | ( | ushort | daqNo,
 |  | A2LXCP_EVENT | evt,
 |  | ushort | maxDTO,
 |  | byte | maxODT,
 |  | byte | maxODTEntries,
 |  | int | dataOffsetFirstPid,
 |  | int | dataOffset
 | ) |  |

Initializes a new DAQ List with the specified parameters.

Parameters
daqNo | DAQ list number
evt | The corresponding XCP event
maxDTO | Maximum DTO size
maxODT | Maximum ODTs
maxODTEntries | Maximum ODT entries
dataOffsetFirstPid | Computed offset to in receive values in a DAQ record (first PID)
dataOffset | Computed offset to receive values in a DAQ record

Member Function Documentation

◆ clearData()

override void clearData ( )
virtual

Clears only the contained data, not the DAQ configuration.

Reimplemented from DAQList.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • DAQListXCP
DAQListXCP Member List

This is the complete list of members for DAQListXCP, including all inherited members.

CANId | DAQList |
clearData() | DAQListXCP | virtual
DAQListXCP(ushort daqNo, A2LXCP_EVENT evt, byte firstPID=0) | DAQListXCP |
DAQListXCP(ushort daqNo, A2LXCP_EVENT evt, ushort maxDTO, byte maxODT, byte maxODTEntries, int dataOffsetFirstPid, int dataOffset) | DAQListXCP |
DAQNo | DAQList |
Evt | DAQListXCP |
EvtNo | DAQList |
FirstPID | DAQList |
Mode (defined in DAQListXCP) | DAQListXCP |
ODTDict | DAQListXCP |
ODTs | DAQList |
State | DAQListXCP |
TimeCycle | DAQList |


ASAP2Library interface: EventBase Class Reference

  • Comm
  • XCP
  • EventBase
Public Member Functions | Public Attributes | List of all members
EventBase Class Reference

Base class represents a XCP event. More...

Public Member Functions

EventBase ()
Internal use only!
EventBase (EventCodes code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

EventCodes EventCode

Detailed Description

Base class represents a XCP event.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • EventBase
EventBase Member List

This is the complete list of members for EventBase, including all inherited members.

changeEndianness() | RespBase | virtual
EventBase() | EventBase |
EventBase(EventCodes code) (defined in EventBase) | EventBase |
EventCode (defined in EventBase) | EventBase |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |


ASAP2Library interface: EventResumeMode Class Reference

  • Comm
  • XCP
  • EventResumeMode
Public Member Functions | Public Attributes | List of all members
EventResumeMode Class Reference

Event START IN RESUME MODE More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from EventBase
EventBase ()
Internal use only!
EventBase (EventCodes code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ushort | SessionId
- Public Attributes inherited from EventBase
EventCodes | EventCode

Detailed Description

Event START IN RESUME MODE

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.

Reimplemented in EventResumeModeTS.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • EventResumeMode
EventResumeMode Member List

This is the complete list of members for EventResumeMode, including all inherited members.

changeEndianness() | EventResumeMode | virtual
EventBase() | EventBase |
EventBase(EventCodes code) (defined in EventBase) | EventBase |
EventCode (defined in EventBase) | EventBase |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
SessionId (defined in EventResumeMode) | EventResumeMode |


ASAP2Library interface: EventResumeModeTS Class Reference

  • Comm
  • XCP
  • EventResumeModeTS
Public Member Functions | Public Attributes | List of all members
EventResumeModeTS Class Reference

Event START IN RESUME MODE. More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from EventBase
EventBase ()
Internal use only!
EventBase (EventCodes code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

uint | CurrentTimestamp
- Public Attributes inherited from EventResumeMode
ushort | SessionId
- Public Attributes inherited from EventBase
EventCodes | EventCode

Detailed Description

Event START IN RESUME MODE.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from EventResumeMode.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • EventResumeModeTS
EventResumeModeTS Member List

This is the complete list of members for EventResumeModeTS, including all inherited members.

changeEndianness() | EventResumeModeTS | virtual
CurrentTimestamp (defined in EventResumeModeTS) | EventResumeModeTS |
EventBase() | EventBase |
EventBase(EventCodes code) (defined in EventBase) | EventBase |
EventCode (defined in EventBase) | EventBase |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
SessionId (defined in EventResumeMode) | EventResumeMode |


ASAP2Library interface: EventStimTimeout Class Reference

  • Comm
  • XCP
  • EventStimTimeout
Public Member Functions | List of all members
EventStimTimeout Class Reference

Event INDICATION OF TIME-OUT AT STIM. More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from EventBase
EventBase ()
Internal use only!
EventBase (EventCodes code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Additional Inherited Members

- Public Attributes inherited from EventBase
EventCodes EventCode

Detailed Description

Event INDICATION OF TIME-OUT AT STIM.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • EventStimTimeout
EventStimTimeout Member List

This is the complete list of members for EventStimTimeout, including all inherited members.

changeEndianness() | EventStimTimeout | virtual
EventBase() | EventBase |
EventBase(EventCodes code) (defined in EventBase) | EventBase |
EventCode (defined in EventBase) | EventBase |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |


ASAP2Library interface: EventTimeSync Class Reference

  • Comm
  • XCP
  • EventTimeSync
Public Member Functions | Public Attributes | Properties | List of all members
EventTimeSync Class Reference

Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP. More...

Public Member Functions

EventTimeSync (uint timestamp)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from EventBase
EventBase ()
Internal use only!
EventBase (EventCodes code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

PayloadFmt | PayloadFmt
uint | Timestamp
- Public Attributes inherited from EventBase
EventCodes | EventCode

Properties

TimeOfTSSampling | TimeOfTSSampling [get]
TriggerInitiator | TriggerInitiator [get]

Detailed Description

Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • EventTimeSync
EventTimeSync Member List

This is the complete list of members for EventTimeSync, including all inherited members.

changeEndianness() | EventTimeSync | virtual
EventBase() | EventBase |
EventBase(EventCodes code) (defined in EventBase) | EventBase |
EventCode (defined in EventBase) | EventBase |
EventTimeSync() (defined in EventTimeSync) | EventTimeSync |
EventTimeSync(uint timestamp) (defined in EventTimeSync) | EventTimeSync |
PayloadFmt (defined in EventTimeSync) | EventTimeSync |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
TimeOfTSSampling (defined in EventTimeSync) | EventTimeSync |
Timestamp (defined in EventTimeSync) | EventTimeSync |
TriggerInitiator (defined in EventTimeSync) | EventTimeSync |


ASAP2Library interface: ODT Class Reference

  • Comm
  • XCP
  • ODT
Public Member Functions | Public Attributes | Properties | List of all members
ODT Class Reference

ECU Simulator: ODT representation. More...

Public Member Functions

ODT (DAQList daqList, byte pid, bool isFirstPID)
Creates a new ODT instamce with the specified parameters. More...
void addMeasurement (A2LMEASUREMENT measurement, int arrayOffset, byte size, int dataOffset)
Adds the specified measurement to the ODT. More...

Public Attributes

readonly DAQList DAQList

Properties

bool | IsFirstPID [get]
Indicates if this ODT is the first within the DAQ List.
List< ODTEntry > | ODTEntries = new List<ODTEntry>() [get]
Gets the configured measurements.
byte | PID [get]
Gets the PID.

Detailed Description

ECU Simulator: ODT representation.

  • Holds the list of configured ODTEntries.

Constructor & Destructor Documentation

◆ ODT()

ODT | ( | DAQList | daqList,
 |  | byte | pid,
 |  | bool | isFirstPID
 | ) |  |

Creates a new ODT instamce with the specified parameters.

Parameters
daqList | The corresponding DAQ List
pid | The corresponding PID
isFirstPID | Indicates if the PID is the first PID

Member Function Documentation

◆ addMeasurement()

void addMeasurement | ( | A2LMEASUREMENT | measurement,
 |  | int | arrayOffset,
 |  | byte | size,
 |  | int | dataOffset
 | ) |  |

Adds the specified measurement to the ODT.

Parameters
measurement | The measurement to configure in the ODT
arrayOffset | array offset to the base measurement
size | The used size (maybe a partial size of the measurement)
dataOffset | a potential data offset


ASAP2Library interface: Member List

  • Comm
  • XCP
  • ODT
ODT Member List

This is the complete list of members for ODT, including all inherited members.

addMeasurement(A2LMEASUREMENT measurement, int arrayOffset, byte size, int dataOffset) | ODT
DAQList (defined in ODT) | ODT
IsFirstPID | ODT
ODT(DAQList daqList, byte pid, bool isFirstPID) | ODT
ODTEntries | ODT
PID | ODT


ASAP2Library interface: ODTDict Class Reference

  • Comm
  • XCP
  • ODTDict
ODTDict Class Reference

ECUSimulator: Dictionary mapping PIDs to ODTs. More...

Detailed Description

ECUSimulator: Dictionary mapping PIDs to ODTs.


ASAP2Library interface: RespBase Class Reference

  • Comm
  • XCP
  • RespBase
Public Member Functions | List of all members
RespBase Class Reference

Base class represents a XCP response. More...

Public Member Functions

RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Detailed Description

Base class represents a XCP response.

Member Function Documentation

◆ changeEndianness()

virtual void changeEndianness ( )
virtual

Changes the endianess of the response.

Implements IResponse.

Reimplemented in RespConnect, RespGetStatus, RespGetID, RespBuildChecksum, RespGetSegmentInfoAddress, RespReadDAQ, RespGetDAQClock, RespGetDAQProcessorInfo, RespGetDAQResolutionInfo, RespGetDAQListMode, RespGetDAQListInfo, RespGetSectorInfoModeAddressOrLen, EventResumeMode, EventResumeModeTS, EventTimeSync, EventStimTimeout, RespDTOCtrResp, and RespTimeCorrelation.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespBase
RespBase Member List

This is the complete list of members for RespBase, including all inherited members.

changeEndianness() | RespBase | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |


ASAP2Library interface: RespBuildChecksum Class Reference

  • Comm
  • XCP
  • RespBuildChecksum
Public Member Functions | Public Attributes | Properties | List of all members
RespBuildChecksum Class Reference

Response from Build checksum over memory range More...

Public Member Functions

RespBuildChecksum (ChecksumType type, uint checksum)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

uint | Checksum
byte | XcpType

Properties

ChecksumType Type [get]
Gets the checksum type.

Detailed Description

Response from Build checksum over memory range

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespBuildChecksum
RespBuildChecksum Member List

This is the complete list of members for RespBuildChecksum, including all inherited members.

changeEndianness() | RespBuildChecksum | virtual
Checksum (defined in RespBuildChecksum) | RespBuildChecksum |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespBuildChecksum(ChecksumType type, uint checksum) (defined in RespBuildChecksum) | RespBuildChecksum |
RespBuildChecksum() (defined in RespBuildChecksum) | RespBuildChecksum |
Type | RespBuildChecksum |
XcpType (defined in RespBuildChecksum) | RespBuildChecksum |


ASAP2Library interface: RespConnect Class Reference

  • Comm
  • XCP
  • RespConnect
Public Member Functions | Public Attributes | List of all members
RespConnect Class Reference

Response from Set up connection with slave More...

Public Member Functions

RespConnect (ResourceType resource, CommModeBasic commModeBasic, byte maxCTO, ushort maxDTO, byte v1, byte v2)
override void | changeEndianness ()
Changes the endianess of the response. More...
override string | ToString ()
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

CommModeBasic | CommModeBasic
byte | MaxCTO
ushort | MaxDTO
ResourceType | Resource
ushort | Version

Detailed Description

Response from Set up connection with slave

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespConnect
RespConnect Member List

This is the complete list of members for RespConnect, including all inherited members.

changeEndianness() | RespConnect | virtual
CommModeBasic (defined in RespConnect) | RespConnect |
MaxCTO (defined in RespConnect) | RespConnect |
MaxDTO (defined in RespConnect) | RespConnect |
Resource (defined in RespConnect) | RespConnect |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespConnect() (defined in RespConnect) | RespConnect |
RespConnect(ResourceType resource, CommModeBasic commModeBasic, byte maxCTO, ushort maxDTO, byte v1, byte v2) (defined in RespConnect) | RespConnect |
ToString() (defined in RespConnect) | RespConnect |
Version (defined in RespConnect) | RespConnect |


ASAP2Library interface: RespDTOCtrResp Class Reference

  • Comm
  • XCP
  • RespDTOCtrResp
Public Member Functions | Public Attributes | List of all members
RespDTOCtrResp Class Reference

Response from DTO CTR Properties command. More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ushort | CurrentRelatedEventChannelNo
DTOCtrMode | Mode
DTOCtrProperties | Properties

Detailed Description

Response from DTO CTR Properties command.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespDTOCtrResp
RespDTOCtrResp Member List

This is the complete list of members for RespDTOCtrResp, including all inherited members.

changeEndianness() | RespDTOCtrResp | virtual
CurrentRelatedEventChannelNo (defined in RespDTOCtrResp) | RespDTOCtrResp |
Mode (defined in RespDTOCtrResp) | RespDTOCtrResp |
Properties (defined in RespDTOCtrResp) | RespDTOCtrResp |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespDTOCtrResp() (defined in RespDTOCtrResp) | RespDTOCtrResp |


ASAP2Library interface: RespError Class Reference

  • Comm
  • XCP
  • RespError
Public Member Functions | Properties | List of all members
RespError Class Reference

Error Response More...

Public Member Functions

RespError (CmdResult errorCode)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Properties

CmdResult ErrorCode [get]
Gets the ErrorCode.

Detailed Description

Error Response


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespError
RespError Member List

This is the complete list of members for RespError, including all inherited members.

changeEndianness() | RespBase | virtual
ErrorCode | RespError |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespError() (defined in RespError) | RespError |
RespError(CmdResult errorCode) (defined in RespError) | RespError |


ASAP2Library interface: RespEvent Class Reference

  • Comm
  • XCP
  • RespEvent
Public Member Functions | Public Attributes | List of all members
RespEvent Class Reference

Event response More...

Public Member Functions

RespEvent (EventCodes eventCode)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

EventCodes EventCode

Detailed Description

Event response


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespEvent
RespEvent Member List

This is the complete list of members for RespEvent, including all inherited members.

changeEndianness() | RespBase | virtual
EventCode (defined in RespEvent) | RespEvent |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespEvent(EventCodes eventCode) (defined in RespEvent) | RespEvent |


ASAP2Library interface: RespGetCALPage Class Reference

  • Comm
  • XCP
  • RespGetCALPage
Public Member Functions | Public Attributes | List of all members
RespGetCALPage Class Reference

Response from Get calibration page More...

Public Member Functions

RespGetCALPage (byte pageNo)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte PageNo

Detailed Description

Response from Get calibration page


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetCALPage
RespGetCALPage Member List

This is the complete list of members for RespGetCALPage, including all inherited members.

changeEndianness() | RespBase | virtual
PageNo (defined in RespGetCALPage) | RespGetCALPage |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetCALPage() (defined in RespGetCALPage) | RespGetCALPage |
RespGetCALPage(byte pageNo) (defined in RespGetCALPage) | RespGetCALPage |


ASAP2Library interface: RespGetCommModeInfo Class Reference

  • Comm
  • XCP
  • RespGetCommModeInfo
Public Member Functions | Public Attributes | List of all members
RespGetCommModeInfo Class Reference

Response from Get current session status from slave More...

Public Member Functions

RespGetCommModeInfo (CommModeOptional commMode, byte maxBS, byte minST, byte queueSize, byte driverVersion)
override string | ToString ()
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void | changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

CommModeOptional | CommMode
byte | DriverVersion
byte | MaxBS
byte | MinST
byte | QueueSize

Detailed Description

Response from Get current session status from slave


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetCommModeInfo
RespGetCommModeInfo Member List

This is the complete list of members for RespGetCommModeInfo, including all inherited members.

changeEndianness() | RespBase | virtual
CommMode (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
DriverVersion (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
MaxBS (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
MinST (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
QueueSize (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetCommModeInfo() (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
RespGetCommModeInfo(CommModeOptional commMode, byte maxBS, byte minST, byte queueSize, byte driverVersion) (defined in RespGetCommModeInfo) | RespGetCommModeInfo |
ToString() (defined in RespGetCommModeInfo) | RespGetCommModeInfo |


ASAP2Library interface: RespGetDAQClock Class Reference

  • Comm
  • XCP
  • RespGetDAQClock
Public Member Functions | Public Attributes | Properties | List of all members
RespGetDAQClock Class Reference

Response from Get DAQ clock from slave More...

Public Member Functions

RespGetDAQClock (uint timestamp)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

PayloadFmt | PayloadFmt
uint | Timestamp

Properties

TimeOfTSSampling | TimeOfTSSampling [get]
TriggerInitiator | TriggerInitiator [get]

Detailed Description

Response from Get DAQ clock from slave

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQClock
RespGetDAQClock Member List

This is the complete list of members for RespGetDAQClock, including all inherited members.

changeEndianness() | RespGetDAQClock | virtual
PayloadFmt (defined in RespGetDAQClock) | RespGetDAQClock |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQClock() (defined in RespGetDAQClock) | RespGetDAQClock |
RespGetDAQClock(uint timestamp) (defined in RespGetDAQClock) | RespGetDAQClock |
TimeOfTSSampling (defined in RespGetDAQClock) | RespGetDAQClock |
Timestamp (defined in RespGetDAQClock) | RespGetDAQClock |
TriggerInitiator (defined in RespGetDAQClock) | RespGetDAQClock |


ASAP2Library interface: RespGetDAQEventInfo Class Reference

  • Comm
  • XCP
  • RespGetDAQEventInfo
Public Member Functions | Public Attributes | List of all members
RespGetDAQEventInfo Class Reference

Response from Get specific information for an event channel More...

Public Member Functions

RespGetDAQEventInfo (DAQEventProperties properties, byte maxDAQList, byte nameLength, byte timeCycle, XCP_TIMESTAMP_RESOLUTION timeUnit, byte priority)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | MaxDAQList
byte | NameLength
byte | Priority
DAQEventProperties | Properties
byte | TimeCycle
XCP_TIMESTAMP_RESOLUTION | TimeUnit

Detailed Description

Response from Get specific information for an event channel


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQEventInfo
RespGetDAQEventInfo Member List

This is the complete list of members for RespGetDAQEventInfo, including all inherited members.

changeEndianness() | RespBase | virtual
MaxDAQList (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
NameLength (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
Priority (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
Properties (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQEventInfo() (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
RespGetDAQEventInfo(DAQEventProperties properties, byte maxDAQList, byte nameLength, byte timeCycle, XCP_TIMESTAMP_RESOLUTION timeUnit, byte priority) (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
TimeCycle (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |
TimeUnit (defined in RespGetDAQEventInfo) | RespGetDAQEventInfo |


ASAP2Library interface: RespGetDAQListInfo Class Reference

  • Comm
  • XCP
  • RespGetDAQListInfo
Public Member Functions | Public Attributes | List of all members
RespGetDAQListInfo Class Reference

Response from Get specific information for a DAQ list More...

Public Member Functions

RespGetDAQListInfo (DAQListProperties properties, byte maxODT, byte maxODTEntries, ushort fixedEvent)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ushort | FixedEvent
byte | MaxODT
byte | MaxODTEntries
DAQListProperties | Properties

Detailed Description

Response from Get specific information for a DAQ list

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQListInfo
RespGetDAQListInfo Member List

This is the complete list of members for RespGetDAQListInfo, including all inherited members.

changeEndianness() | RespGetDAQListInfo | virtual
FixedEvent (defined in RespGetDAQListInfo) | RespGetDAQListInfo |
MaxODT (defined in RespGetDAQListInfo) | RespGetDAQListInfo |
MaxODTEntries (defined in RespGetDAQListInfo) | RespGetDAQListInfo |
Properties (defined in RespGetDAQListInfo) | RespGetDAQListInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQListInfo() (defined in RespGetDAQListInfo) | RespGetDAQListInfo |
RespGetDAQListInfo(DAQListProperties properties, byte maxODT, byte maxODTEntries, ushort fixedEvent) (defined in RespGetDAQListInfo) | RespGetDAQListInfo |


ASAP2Library interface: RespGetDAQListMode Class Reference

  • Comm
  • XCP
  • RespGetDAQListMode
Public Member Functions | Public Attributes | List of all members
RespGetDAQListMode Class Reference

Response from Get mode from DAQ list More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ushort | EventChannelNo
DAQListMode | Mode
byte | Prescaler
byte | Priority

Detailed Description

Response from Get mode from DAQ list

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQListMode
RespGetDAQListMode Member List

This is the complete list of members for RespGetDAQListMode, including all inherited members.

changeEndianness() | RespGetDAQListMode | virtual
EventChannelNo (defined in RespGetDAQListMode) | RespGetDAQListMode |
Mode (defined in RespGetDAQListMode) | RespGetDAQListMode |
Prescaler (defined in RespGetDAQListMode) | RespGetDAQListMode |
Priority (defined in RespGetDAQListMode) | RespGetDAQListMode |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQListMode() (defined in RespGetDAQListMode) | RespGetDAQListMode |


ASAP2Library interface: RespGetDAQListUSBEndpoint Class Reference

  • Comm
  • XCP
  • RespGetDAQListUSBEndpoint
Public Attributes | List of all members
RespGetDAQListUSBEndpoint Class Reference

Response from Get DAQ List USB Endpoint. More...

Public Attributes

byte | EndPointNo
USB Endpoint Number of DTO dedicated to list number.
USBEndpointType | Type

Additional Inherited Members

- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Detailed Description

Response from Get DAQ List USB Endpoint.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQListUSBEndpoint
RespGetDAQListUSBEndpoint Member List

This is the complete list of members for RespGetDAQListUSBEndpoint, including all inherited members.

changeEndianness() | RespBase | virtual
EndPointNo | RespGetDAQListUSBEndpoint |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQListUSBEndpoint() (defined in RespGetDAQListUSBEndpoint) | RespGetDAQListUSBEndpoint |
Type (defined in RespGetDAQListUSBEndpoint) | RespGetDAQListUSBEndpoint |


ASAP2Library interface: RespGetDAQProcessorInfo Class Reference

  • Comm
  • XCP
  • RespGetDAQProcessorInfo
Public Member Functions | Public Attributes | List of all members
RespGetDAQProcessorInfo Class Reference

Response from Get general information on DAQ processor More...

Public Member Functions

RespGetDAQProcessorInfo (DAQProperties properties, ushort maxDAQ, ushort maxEvt, byte minDAQ, DAQKeyByte keyByte)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

DAQKeyByte | DAQKeyByte
ushort | MaxDAQ
ushort | MaxEventChannel
byte | MinDAQ
DAQProperties | Properties

Detailed Description

Response from Get general information on DAQ processor

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQProcessorInfo
RespGetDAQProcessorInfo Member List

This is the complete list of members for RespGetDAQProcessorInfo, including all inherited members.

changeEndianness() | RespGetDAQProcessorInfo | virtual
DAQKeyByte (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
MaxDAQ (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
MaxEventChannel (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
MinDAQ (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
Properties (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQProcessorInfo() (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |
RespGetDAQProcessorInfo(DAQProperties properties, ushort maxDAQ, ushort maxEvt, byte minDAQ, DAQKeyByte keyByte) (defined in RespGetDAQProcessorInfo) | RespGetDAQProcessorInfo |


ASAP2Library interface: RespGetDAQResolutionInfo Class Reference

  • Comm
  • XCP
  • RespGetDAQResolutionInfo
Public Member Functions | Public Attributes | List of all members
RespGetDAQResolutionInfo Class Reference

Response from Get general information on DAQ processing resolution More...

Public Member Functions

RespGetDAQResolutionInfo (XCP_ODT_ENTRY_SIZE granularityODTEntrySizeDAQ, byte maxODTEntrySizeDAQ, XCP_ODT_ENTRY_SIZE granularityODTEntrySizeSTIM, byte maxODTEntrySizeSTIM, DAQTimestampMode timestampMode, ushort timestampTicks)
override void | changeEndianness ()
Changes the endianess of the response. More...
int | getTSSize ()
Gets the timestamp size in bytes. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

XCP_ODT_ENTRY_SIZE | GranularityODTEntrySizeDAQ
XCP_ODT_ENTRY_SIZE | GranularityODTEntrySizeSTIM
byte | MaxODTEntrySizeDAQ
byte | MaxODTEntrySizeSTIM
DAQTimestampMode | TimestampMode
ushort | TimestampTicks

Detailed Description

Response from Get general information on DAQ processing resolution

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.

◆ getTSSize()

int getTSSize ( )

Gets the timestamp size in bytes.

Returns


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetDAQResolutionInfo
RespGetDAQResolutionInfo Member List

This is the complete list of members for RespGetDAQResolutionInfo, including all inherited members.

changeEndianness() | RespGetDAQResolutionInfo | virtual
getTSSize() | RespGetDAQResolutionInfo |
GranularityODTEntrySizeDAQ (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
GranularityODTEntrySizeSTIM (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
MaxODTEntrySizeDAQ (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
MaxODTEntrySizeSTIM (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetDAQResolutionInfo(XCP_ODT_ENTRY_SIZE granularityODTEntrySizeDAQ, byte maxODTEntrySizeDAQ, XCP_ODT_ENTRY_SIZE granularityODTEntrySizeSTIM, byte maxODTEntrySizeSTIM, DAQTimestampMode timestampMode, ushort timestampTicks) (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
RespGetDAQResolutionInfo() (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
TimestampMode (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |
TimestampTicks (defined in RespGetDAQResolutionInfo) | RespGetDAQResolutionInfo |


ASAP2Library interface: RespGetID Class Reference

  • Comm
  • XCP
  • RespGetID
Public Member Functions | Public Attributes | List of all members
RespGetID Class Reference

Response from Get identification from slave More...

Public Member Functions

RespGetID (GetIDRespType mode, uint length)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

uint | Length
GetIDRespType | Mode

Detailed Description

Response from Get identification from slave

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetID
RespGetID Member List

This is the complete list of members for RespGetID, including all inherited members.

changeEndianness() | RespGetID | virtual
Length (defined in RespGetID) | RespGetID |
Mode (defined in RespGetID) | RespGetID |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetID() (defined in RespGetID) | RespGetID |
RespGetID(GetIDRespType mode, uint length) (defined in RespGetID) | RespGetID |


ASAP2Library interface: RespGetPageInfo Class Reference

  • Comm
  • XCP
  • RespGetPageInfo
Public Member Functions | Public Attributes | List of all members
RespGetPageInfo Class Reference

Response from Get specific information for a PAGE More...

Public Member Functions

RespGetPageInfo (PageProperties pageProperties, byte initSegment)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | InitSegment
PageProperties | Properties

Detailed Description

Response from Get specific information for a PAGE


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetPageInfo
RespGetPageInfo Member List

This is the complete list of members for RespGetPageInfo, including all inherited members.

changeEndianness() | RespBase | virtual
InitSegment (defined in RespGetPageInfo) | RespGetPageInfo |
Properties (defined in RespGetPageInfo) | RespGetPageInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetPageInfo() (defined in RespGetPageInfo) | RespGetPageInfo |
RespGetPageInfo(PageProperties pageProperties, byte initSegment) (defined in RespGetPageInfo) | RespGetPageInfo |


ASAP2Library interface: RespGetPAGProcessorInfo Class Reference

  • Comm
  • XCP
  • RespGetPAGProcessorInfo
Public Member Functions | Public Attributes | List of all members
RespGetPAGProcessorInfo Class Reference

Response from Get general information on PAG processor More...

Public Member Functions

RespGetPAGProcessorInfo (byte maxSegment, PAGProperties properties)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | MaxSegment
PAGProperties | Properties

Detailed Description

Response from Get general information on PAG processor


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetPAGProcessorInfo
RespGetPAGProcessorInfo Member List

This is the complete list of members for RespGetPAGProcessorInfo, including all inherited members.

changeEndianness() | RespBase | virtual
MaxSegment (defined in RespGetPAGProcessorInfo) | RespGetPAGProcessorInfo |
Properties (defined in RespGetPAGProcessorInfo) | RespGetPAGProcessorInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetPAGProcessorInfo() (defined in RespGetPAGProcessorInfo) | RespGetPAGProcessorInfo |
RespGetPAGProcessorInfo(byte maxSegment, PAGProperties properties) (defined in RespGetPAGProcessorInfo) | RespGetPAGProcessorInfo |


ASAP2Library interface: RespGetPGMProcessorInfo Class Reference

  • Comm
  • XCP
  • RespGetPGMProcessorInfo
Public Member Functions | Public Attributes | List of all members
RespGetPGMProcessorInfo Class Reference

Response from Get general information on PGM processor More...

Public Member Functions

RespGetPGMProcessorInfo (ProgramProperties properties, byte maxSector)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | MaxSector
ProgramProperties | Properties

Detailed Description

Response from Get general information on PGM processor


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetPGMProcessorInfo
RespGetPGMProcessorInfo Member List

This is the complete list of members for RespGetPGMProcessorInfo, including all inherited members.

changeEndianness() | RespBase | virtual
MaxSector (defined in RespGetPGMProcessorInfo) | RespGetPGMProcessorInfo |
Properties (defined in RespGetPGMProcessorInfo) | RespGetPGMProcessorInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetPGMProcessorInfo() (defined in RespGetPGMProcessorInfo) | RespGetPGMProcessorInfo |
RespGetPGMProcessorInfo(ProgramProperties properties, byte maxSector) (defined in RespGetPGMProcessorInfo) | RespGetPGMProcessorInfo |


ASAP2Library interface: RespGetSectorInfoModeAddressOrLen Class Reference

  • Comm
  • XCP
  • RespGetSectorInfoModeAddressOrLen
Public Member Functions | Public Attributes | List of all members
RespGetSectorInfoModeAddressOrLen Class Reference

Response from Get specific information for a SECTOR More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

byte | ClearSequenceNo
byte | ProgrammingMethod
byte | ProgramSequenceNo
uint | SectorInfo

Detailed Description

Response from Get specific information for a SECTOR

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSectorInfoModeAddressOrLen
RespGetSectorInfoModeAddressOrLen Member List

This is the complete list of members for RespGetSectorInfoModeAddressOrLen, including all inherited members.

changeEndianness() | RespGetSectorInfoModeAddressOrLen | virtual
ClearSequenceNo (defined in RespGetSectorInfoModeAddressOrLen) | RespGetSectorInfoModeAddressOrLen |
ProgrammingMethod (defined in RespGetSectorInfoModeAddressOrLen) | RespGetSectorInfoModeAddressOrLen |
ProgramSequenceNo (defined in RespGetSectorInfoModeAddressOrLen) | RespGetSectorInfoModeAddressOrLen |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSectorInfoModeAddressOrLen() (defined in RespGetSectorInfoModeAddressOrLen) | RespGetSectorInfoModeAddressOrLen |
SectorInfo (defined in RespGetSectorInfoModeAddressOrLen) | RespGetSectorInfoModeAddressOrLen |


ASAP2Library interface: RespGetSectorInfoModeSectorNameLen Class Reference

  • Comm
  • XCP
  • RespGetSectorInfoModeSectorNameLen
Public Attributes | List of all members
RespGetSectorInfoModeSectorNameLen Class Reference

Response from Get specific information for a SECTOR More...

Public Attributes

byte SectorNameLen

Additional Inherited Members

- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Detailed Description

Response from Get specific information for a SECTOR


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSectorInfoModeSectorNameLen
RespGetSectorInfoModeSectorNameLen Member List

This is the complete list of members for RespGetSectorInfoModeSectorNameLen, including all inherited members.

changeEndianness() | RespBase | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSectorInfoModeSectorNameLen() (defined in RespGetSectorInfoModeSectorNameLen) | RespGetSectorInfoModeSectorNameLen |
SectorNameLen (defined in RespGetSectorInfoModeSectorNameLen) | RespGetSectorInfoModeSectorNameLen |


ASAP2Library interface: RespGetSeed Class Reference

  • Comm
  • XCP
  • RespGetSeed
Public Member Functions | Public Attributes | List of all members
RespGetSeed Class Reference

Response from Get seed for unlocking a protected resource More...

Public Member Functions

RespGetSeed (byte length)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte Length

Detailed Description

Response from Get seed for unlocking a protected resource


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSeed
RespGetSeed Member List

This is the complete list of members for RespGetSeed, including all inherited members.

changeEndianness() | RespBase | virtual
Length (defined in RespGetSeed) | RespGetSeed |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSeed() (defined in RespGetSeed) | RespGetSeed |
RespGetSeed(byte length) (defined in RespGetSeed) | RespGetSeed |


ASAP2Library interface: RespGetSegmentInfo Class Reference

  • Comm
  • XCP
  • RespGetSegmentInfo
Public Member Functions | Public Attributes | List of all members
RespGetSegmentInfo Class Reference

Response from Get address information for a SEGMENT More...

Public Member Functions

RespGetSegmentInfo (byte maxPages, byte addressExt, byte maxMap, byte compression, byte encryption)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte | AddressExtension
byte | CompressionMethod
byte | EncryptionMethod
byte | MaxMapping
byte | MaxPages

Detailed Description

Response from Get address information for a SEGMENT


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSegmentInfo
RespGetSegmentInfo Member List

This is the complete list of members for RespGetSegmentInfo, including all inherited members.

AddressExtension (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
changeEndianness() | RespBase | virtual
CompressionMethod (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
EncryptionMethod (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
MaxMapping (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
MaxPages (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSegmentInfo() (defined in RespGetSegmentInfo) | RespGetSegmentInfo |
RespGetSegmentInfo(byte maxPages, byte addressExt, byte maxMap, byte compression, byte encryption) (defined in RespGetSegmentInfo) | RespGetSegmentInfo |


ASAP2Library interface: RespGetSegmentInfoAddress Class Reference

  • Comm
  • XCP
  • RespGetSegmentInfoAddress
Public Member Functions | Public Attributes | List of all members
RespGetSegmentInfoAddress Class Reference

Response from Get standard information for a SEGMENT More...

Public Member Functions

RespGetSegmentInfoAddress (uint info)
override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

uint Info

Detailed Description

Response from Get standard information for a SEGMENT

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSegmentInfoAddress
RespGetSegmentInfoAddress Member List

This is the complete list of members for RespGetSegmentInfoAddress, including all inherited members.

changeEndianness() | RespGetSegmentInfoAddress | virtual
Info (defined in RespGetSegmentInfoAddress) | RespGetSegmentInfoAddress |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSegmentInfoAddress() (defined in RespGetSegmentInfoAddress) | RespGetSegmentInfoAddress |
RespGetSegmentInfoAddress(uint info) (defined in RespGetSegmentInfoAddress) | RespGetSegmentInfoAddress |


ASAP2Library interface: RespGetSegmentMode Class Reference

  • Comm
  • XCP
  • RespGetSegmentMode
Public Attributes | List of all members
RespGetSegmentMode Class Reference

Response from Set mode for a SEGMENT More...

Public Attributes

SegmentMode Mode

Additional Inherited Members

- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Detailed Description

Response from Set mode for a SEGMENT


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetSegmentMode
RespGetSegmentMode Member List

This is the complete list of members for RespGetSegmentMode, including all inherited members.

changeEndianness() | RespBase | virtual
Mode (defined in RespGetSegmentMode) | RespGetSegmentMode |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetSegmentMode() (defined in RespGetSegmentMode) | RespGetSegmentMode |


ASAP2Library interface: RespGetStatus Class Reference

  • Comm
  • XCP
  • RespGetStatus
Public Member Functions | Public Attributes | Properties | List of all members
RespGetStatus Class Reference

Response from Get current session status from slave More...

Public Member Functions

RespGetStatus (SessionState sessionState, ResourceType protectionState, ushort sessionId)
override void | changeEndianness ()
Changes the endianess of the response. More...
override string | ToString ()
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ResourceType | ResourceProtectionState
ushort | SessionConfigurationId
SessionState | SessionState

Properties

bool IsStoring [get]
Indicates if slave is currently storing.

Detailed Description

Response from Get current session status from slave

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespGetStatus
RespGetStatus Member List

This is the complete list of members for RespGetStatus, including all inherited members.

changeEndianness() | RespGetStatus | virtual
IsStoring | RespGetStatus |
ResourceProtectionState (defined in RespGetStatus) | RespGetStatus |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespGetStatus() (defined in RespGetStatus) | RespGetStatus |
RespGetStatus(SessionState sessionState, ResourceType protectionState, ushort sessionId) (defined in RespGetStatus) | RespGetStatus |
SessionConfigurationId (defined in RespGetStatus) | RespGetStatus |
SessionState (defined in RespGetStatus) | RespGetStatus |
ToString() (defined in RespGetStatus) | RespGetStatus |


ASAP2Library interface: RespProgramStart Class Reference

  • Comm
  • XCP
  • RespProgramStart
Public Member Functions | Public Attributes | List of all members
RespProgramStart Class Reference

Response from Indicate the beginning of a programming sequence More...

Public Member Functions

RespProgramStart (CommModeProgram commMode, byte maxCTO, byte maxBS, byte minST, byte queueSize)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

CommModeProgram | CommMode
byte | MaxBS
byte | MaxCTO
byte | MinST
byte | QueueSize

Detailed Description

Response from Indicate the beginning of a programming sequence


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespProgramStart
RespProgramStart Member List

This is the complete list of members for RespProgramStart, including all inherited members.

changeEndianness() | RespBase | virtual
CommMode (defined in RespProgramStart) | RespProgramStart |
MaxBS (defined in RespProgramStart) | RespProgramStart |
MaxCTO (defined in RespProgramStart) | RespProgramStart |
MinST (defined in RespProgramStart) | RespProgramStart |
QueueSize (defined in RespProgramStart) | RespProgramStart |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespProgramStart() (defined in RespProgramStart) | RespProgramStart |
RespProgramStart(CommModeProgram commMode, byte maxCTO, byte maxBS, byte minST, byte queueSize) (defined in RespProgramStart) | RespProgramStart |


ASAP2Library interface: RespReadDAQ Class Reference

  • Comm
  • XCP
  • RespReadDAQ
Public Member Functions | Public Attributes | List of all members
RespReadDAQ Class Reference

Response from Read element from ODT entry More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

uint | Address
Byte | AddressExtension
byte | BitOffset
byte | ElementSize

Detailed Description

Response from Read element from ODT entry

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespReadDAQ
RespReadDAQ Member List

This is the complete list of members for RespReadDAQ, including all inherited members.

Address (defined in RespReadDAQ) | RespReadDAQ |
AddressExtension (defined in RespReadDAQ) | RespReadDAQ |
BitOffset (defined in RespReadDAQ) | RespReadDAQ |
changeEndianness() | RespReadDAQ | virtual
ElementSize (defined in RespReadDAQ) | RespReadDAQ |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespReadDAQ() (defined in RespReadDAQ) | RespReadDAQ |


ASAP2Library interface: RespService Class Reference

  • Comm
  • XCP
  • RespService
Public Member Functions | Public Attributes | List of all members
RespService Class Reference

Base class represents a XCP service request. More...

Public Member Functions

RespService ()
Internal use only!
RespService (ServiceRequestCode code)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

ServiceRequestCode ServiceRequestCode

Detailed Description

Base class represents a XCP service request.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespService
RespService Member List

This is the complete list of members for RespService, including all inherited members.

changeEndianness() | RespBase | virtual
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespService() | RespService |
RespService(ServiceRequestCode code) (defined in RespService) | RespService |
ServiceRequestCode (defined in RespService) | RespService |


ASAP2Library interface: RespStartStopDAQList Class Reference

  • Comm
  • XCP
  • RespStartStopDAQList
Public Member Functions | Public Attributes | List of all members
RespStartStopDAQList Class Reference

Response from Start/stop/select DAQ list More...

Public Member Functions

RespStartStopDAQList (byte firstPID)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

byte FirstPID

Detailed Description

Response from Start/stop/select DAQ list

  • According to the specification, the FirstPID paramter could be ignored in some cases.
  • On some ECUs the FirstPID is parameter seems to be completely missing in the response...


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespStartStopDAQList
RespStartStopDAQList Member List

This is the complete list of members for RespStartStopDAQList, including all inherited members.

changeEndianness() | RespBase | virtual
FirstPID (defined in RespStartStopDAQList) | RespStartStopDAQList |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespStartStopDAQList() (defined in RespStartStopDAQList) | RespStartStopDAQList |
RespStartStopDAQList(byte firstPID) (defined in RespStartStopDAQList) | RespStartStopDAQList |


ASAP2Library interface: RespTimeCorrelation Class Reference

  • Comm
  • XCP
  • RespTimeCorrelation
Public Member Functions | Public Attributes | List of all members
RespTimeCorrelation Class Reference

Response from Time Correlation command. More...

Public Member Functions

override void changeEndianness ()
Changes the endianess of the response. More...
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)

Public Attributes

ClockInfo | ClockInfo
ushort | ClusterID
ObservableClocks | ObservableClocks
SlaveConfig | SlaveConfig
SyncState | SyncState

Detailed Description

Response from Time Correlation command.

Member Function Documentation

◆ changeEndianness()

override void changeEndianness ( )
virtual

Changes the endianess of the response.

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespTimeCorrelation
RespTimeCorrelation Member List

This is the complete list of members for RespTimeCorrelation, including all inherited members.

changeEndianness() | RespTimeCorrelation | virtual
ClockInfo (defined in RespTimeCorrelation) | RespTimeCorrelation |
ClusterID (defined in RespTimeCorrelation) | RespTimeCorrelation |
ObservableClocks (defined in RespTimeCorrelation) | RespTimeCorrelation |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespTimeCorrelation() (defined in RespTimeCorrelation) | RespTimeCorrelation |
SlaveConfig (defined in RespTimeCorrelation) | RespTimeCorrelation |
SyncState (defined in RespTimeCorrelation) | RespTimeCorrelation |


ASAP2Library interface: RespUnlock Class Reference

  • Comm
  • XCP
  • RespUnlock
Public Member Functions | Public Attributes | List of all members
RespUnlock Class Reference

Response from Send key for unlocking a protected resource More...

Public Member Functions

RespUnlock (ResourceType protectionState)
- Public Member Functions inherited from RespBase
RespBase ()
Internal use only!
RespBase (PIDSlaveMaster code)
virtual void changeEndianness ()
Changes the endianess of the response. More...

Public Attributes

ResourceType ProtectionState

Detailed Description

Response from Send key for unlocking a protected resource


ASAP2Library interface: Member List

  • Comm
  • XCP
  • RespUnlock
RespUnlock Member List

This is the complete list of members for RespUnlock, including all inherited members.

changeEndianness() | RespBase | virtual
ProtectionState (defined in RespUnlock) | RespUnlock |
RespBase() | RespBase |
RespBase(PIDSlaveMaster code) (defined in RespBase) | RespBase |
RespUnlock() (defined in RespUnlock) | RespUnlock |
RespUnlock(ResourceType protectionState) (defined in RespUnlock) | RespUnlock |


ASAP2Library interface: XCPCommunicator Class Reference

  • Comm
  • XCP
  • XCPCommunicator
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
XCPCommunicator Class Referenceabstract

Base class supporting any XCP based communication instance. More...

Public Member Functions

override void Dispose ()
Disposes all used resources. More...

Public Attributes

readonly XCP_HEADER_LEN FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)

Protected Member Functions

void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...
abstract bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from Communicator
virtual void | close ()
Closes the communication (frees all used resources). More...

Protected Attributes

readonly XCPMaster mMaster
Holds the corresponding XCP master instance.

Detailed Description

Base class supporting any XCP based communication instance.

This is the class to derive other XCP communication types from (XCP on CAN, FlexRay, USB, ...)

Member Function Documentation

◆ dataReceived()

void dataReceived | ( | string | source,
 |  | byte[] | buffer
 | ) |  |
protected

Called from the receive thread, when data is received.

Parameters
source | The data source
buffer | The data received

◆ Dispose()

override void Dispose ( )
virtual

Disposes all used resources.

Inparticular:

  • The communication channel

Reimplemented from Communicator.

◆ getFrameFromData()

abstract bool getFrameFromData | ( | XCPType | type,
 |  | string | source,
 |  | byte[] | data,
 |  | out XCPFrame | frame
 | ) |  |
protectedpure virtual

Gets an XCP frame from the specified data.

Parameters
type | The XCP type
source | The data source
data | The data itself
frame | The resulting frame (only valid if return value is true)
Returns
true if a valid frame is built

Implemented in XCPonEth, XCPOnSxI, and XCPOnUSB.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPCommunicator
XCPCommunicator Member List

This is the complete list of members for XCPCommunicator, including all inherited members.

close() | Communicator | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPCommunicator | protectedpure virtual
mMaster | XCPCommunicator | protected


ASAP2Library interface: XCPErrorArgs Class Reference

  • Comm
  • XCP
  • XCPErrorArgs
Public Attributes | List of all members
XCPErrorArgs Class Reference

ErrorArgs class delivering received command errors. More...

Public Attributes

readonly CommandCode | Command
Gets the corresponding XCP command.
readonly CmdResult | ErrorCode
Gets the received XCP result code.

Detailed Description

ErrorArgs class delivering received command errors.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPErrorArgs
XCPErrorArgs Member List

This is the complete list of members for XCPErrorArgs, including all inherited members.

Command | XCPErrorArgs
ErrorCode | XCPErrorArgs


ASAP2Library interface: XCPEventArgs Class Reference

  • Comm
  • XCP
  • XCPEventArgs
Public Attributes | List of all members
XCPEventArgs Class Reference

EventArgs class delivering received events. More...

Public Attributes

readonly EventBase ReceivedEvent
Gets the received XCP event.

Detailed Description

EventArgs class delivering received events.

To access data For specific events, simply cast the ReceivedEvent according the corresponding EventCodes.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPEventArgs
XCPEventArgs Member List

This is the complete list of members for XCPEventArgs, including all inherited members.

ReceivedEvent XCPEventArgs


ASAP2Library interface: XCPFrame Class Reference

  • Comm
  • XCP
  • XCPFrame
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
XCPFrame Class Reference

Represents an XCP frame. More...

Public Member Functions

XCPFrame (XCPType type, string source, byte[] data, bool isMasterFrame, XCP_HEADER_LEN frameFmt)
Initialises a new instance of XCPFrame with the specified parameters. More...
int | getRawFrameLength ()
Gets the frame length in Bits on the Bus depending on the used XCP media type. More...
string | getTypeStr ()
Gets the frame's type. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
override string | ToString ()
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Static Public Member Functions

static byte[] toByteArray< T > (XCP_HEADER_LEN frameFmt, ushort ctr, T objectToSend, byte[] additionalData=null)
Creates the byte array from the specified object to send over the network. More...

Static Public Attributes

const int | CmdIndex = 0
const int | EventCodeIndex = 1
const int | ResponseIndex = 0

Properties

string? | Address [get]
The address sent or received from.
ushort | Ctr [get]
The Counter value of the frame
bool | IsDAQ [get]
Indicates, if the frame is a data acquisition frame.
bool | IsError [get]
Indicates if the frame is an error response frame.
ushort | Len [get]
The Length value of the frame
XCPType | Type [get]
Gets the XCP type of the frame.
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Additional Inherited Members

- Public Attributes inherited from Frame
byte[] Data
The data bytes of the frame.

Detailed Description

Represents an XCP frame.

Implements some static helper methds to convert

  • object references into byte arrays
  • byte array into object references

Constructor & Destructor Documentation

◆ XCPFrame()

XCPFrame | ( | XCPType | type,
 |  | string | source,
 |  | byte[] | data,
 |  | bool | isMasterFrame,
 |  | XCP_HEADER_LEN | frameFmt
 | ) |  |

Initialises a new instance of XCPFrame with the specified parameters.

Parameters
type | The XCP type
source | The source from where the frame is sent/received
data | The complete frame data as byte array
isMasterFrame | true if the frame is sent by the master, else false
frameFmt | The header format

Member Function Documentation

◆ getRawFrameLength()

int getRawFrameLength ( )

Gets the frame length in Bits on the Bus depending on the used XCP media type.

Returns
The frame length in Bits on the bus

◆ getTypeStr()

string getTypeStr ( )

Gets the frame's type.

Returns
returns a type string representation

◆ toByteArray< T >()

static byte[] toByteArray< T > | ( | XCP_HEADER_LEN | frameFmt,
 |  | ushort | ctr,
 |  | T | objectToSend,
 |  | byte[] | additionalData = null
 | ) |  |
static

Creates the byte array from the specified object to send over the network.

Template Parameters
T The sending object type
Parameters
frameFmt | The frame format to use
ctr | The XCP counter
objectToSend | The object to send
additionalData | Aditional dynamic data to send (may be null)
Returns
The supplied object as a byte array
Type Constraints
T : class

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the frame.

Returns
the string representation

Implements Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the frame.

Returns
the string representation

Implements Frame.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPFrame
XCPFrame Member List

This is the complete list of members for XCPFrame, including all inherited members.

Address | XCPFrame |
CmdIndex (defined in XCPFrame) | XCPFrame | static
Ctr | XCPFrame |
Data | Frame |
Elapsed | Frame |
EventCodeIndex (defined in XCPFrame) | XCPFrame | static
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRawFrameLength() | XCPFrame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
getTypeStr() | XCPFrame |
IsDAQ | XCPFrame |
IsError | XCPFrame |
IsMasterFrame | Frame |
Len | XCPFrame |
ResponseIndex (defined in XCPFrame) | XCPFrame | static
toByteArray< T >(XCP_HEADER_LEN frameFmt, ushort ctr, T objectToSend, byte[] additionalData=null) | XCPFrame | static
toClipboard() | XCPFrame | virtual
toCSV() | XCPFrame | virtual
ToString() (defined in XCPFrame) | XCPFrame |
Type | XCPFrame |
XCPFrame(XCPType type, string source, byte[] data, bool isMasterFrame, XCP_HEADER_LEN frameFmt) | XCPFrame |


ASAP2Library interface: XCPFrameQueue Class Reference

  • Comm
  • XCP
  • XCPFrameQueue
Public Member Functions | Properties | List of all members
XCPFrameQueue Class Reference

Queue implementation to store XCPFrame's. More...

Public Member Functions

void | enqueueFrame (XCPFrame frame)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< XCPFrame >
virtual void | clear ()
Clears the frame queue.
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

static XCPFrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< XCPFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< XCPFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< XCPFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< XCPFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store XCPFrame's.

Member Function Documentation

◆ enqueueFrame()

void enqueueFrame ( XCPFrame frame )

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore access to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame The frame to add


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPFrameQueue
XCPFrameQueue Member List

This is the complete list of members for XCPFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< XCPFrame > | protected
clear() | FrameQueue< XCPFrame > | virtual
Dispose() | FrameQueue< XCPFrame > | virtual
enqueueFrame(XCPFrame frame) | XCPFrameQueue |
FrameEnqueued | FrameQueue< XCPFrame > |
getFrames(out int cntFrames) | FrameQueue< XCPFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< XCPFrame > |
Instance | XCPFrameQueue | static
IsWritingToFile | FrameQueue< XCPFrame > |
LogFileCSVHeader (defined in XCPFrameQueue) | XCPFrameQueue |
LogFileName (defined in XCPFrameQueue) | XCPFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< XCPFrame > |


ASAP2Library interface: XCPMaster Class Reference

  • Comm
  • XCP
  • XCPMaster
Public Member Functions | Properties | Events | List of all members
XCPMaster Class Reference

Implements the XCP Master to communicate with a XCP Slave. More...

Public Member Functions

XCPMaster (ConnectBehaviourType connectBahviour, ICANProvider canProvider, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null)
Creates a XCP on CAN communication master. More...
XCPMaster (ConnectBehaviourType connectBahviour, ISxIProvider sxiProvider, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null)
Creates a XCP on SxI communication master. More...
XCPMaster (ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null)
Creates a XCP on USB communication master. More...
XCPMaster (ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null)
Creates a XCP on Ethernet communication master. More...
override void | configureMeasurements (IList< DAQMeasurement > measurements)
(Re)Configures the specified measurements for data acquisition. More...
override bool | copyPage2Page (ECUPage srcPage, ECUPage dstPage)
Copy data from one ECU page to another. More...
override bool | Disconnect (int useTimeout=-1)
Disconnect from slave. More...
override void | Dispose ()
Frees used resources. More...
CmdResult | freezePage (byte segment, uint timeout)
Persists the current active page (after calibration data is downloaded) into flash memory. More...
override bool | getChecksum (byte addressExtension, uint address, uint size, out uint checksum)
Get the checksum from the slave. More...
bool | getID (GetIDType idType, out byte[] data)
Get identification from slave. More...
CmdResult | getSlaveIDs (ICANProvider canProvider, out IList< Tuple< uint, uint > > cmdRspPairs, ushort timeout=0)
Tries to detect available slave ECUs by using the A2L defined CAN Broadcast ID. More...
bool | isAllowedRequest (string cmd)
Returns true if the command is allowed to request. More...
bool | isSlaveBlockMode ()
Indicates if Slave Block Mode is supported. More...
override uint | mapAddress (uint address)
Maps the specified address using A2L defined mapping tables. More...
bool | modifyBits (byte addressExtension, uint address, byte s, ushort ma, ushort mx)
Modify Bits on the specific address. More...
override void | onDAQFrameReceived (XCPFrame xcpFrame)
Called if a DAQ frame is received from the slave. More...
override void | onErrorReceived (CmdResult result, CommandCode code)
Called, if an error response is received from the slave. More...
override void | onEventReceived (XCPFrame xcpFrame)
Called if an event is received from the slave. More...
override void | onServiceReceived (XCPFrame xcpFrame)
Called if an service request is received from the slave. More...
bool | programSync (byte addressExtension, MemorySegmentList segments, EventHandler< ProgressArgs > progressHandler=null, ConnectMode connectMode=ConnectMode.Normal, XCPPrgParams modes=null)
override bool | programSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null)
Program data synchronously to the ECU. More...
override bool | readSync (int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Read data synchronously from the ECU. More...
override void | setConnectionState< T > (T respConnect)
Called if a a valid connect response is received. More...
override bool | setPage (ECUPage page)
Sets the specified page as active page. More...
override bool | startMeasurements (bool doSynchronized)
Starts a (previously configured by configureMeasurements) data acquisition. More...
override bool | stopMeasurements (bool doSynchronized)
Stops a running data acquisition. More...
CmdResult | unlockECU (NativeSKDLL seedAndKeyDLL)
Tries to unlock all protected ECU resources using the specified Seed&Key DLL. More...
CmdResult | unlockECU (RespGetStatus status, NativeSKDLL seedAndKeyDLL, ResourceType resource)
Tries to unlock a specific protected ECU resource using the specified Seed&Key DLL. More...
override bool | writeSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Write data synchronously to the ECU. More...
- Public Member Functions inherited from XCPMasterBase
XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, string canProviderName)
Creates a XCPonCAN communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, string comPort)
Creates a XCPonCAN communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer)
Creates a XCPonUSB communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer)
Creates a XCPonEth (TCP pr UDP) communication master. More...
CmdResult | AllocDAQ (ushort dAQCount)
Allocate DAQ lists More...
CmdResult | AllocODT (ushort dAQListNo, byte oDTCount)
Allocate ODTs to a DAQ list More...
CmdResult | AllocODTEntry (ushort dAQListNo, byte oDTNo, byte oDTEntriesCount)
Allocate ODT entries to an ODT More...
CmdResult | BuildChecksum (uint blockSize, out RespBuildChecksum response)
Build checksum over memory range. More...
CmdResult | ClearDAQList (ushort dAQListNo)
Clear DAQ list configuration More...
CmdResult | Connect (ConnectMode mode, out RespConnect response)
Set up connection with slave. More...
CmdResult | CopyCalPage (byte srcSegmentNo, byte srcPageNo, byte dstSegmentNo, byte dstPageNo)
Copy page More...
override bool | Disconnect (int useTimeout=-1)
Disconnect from slave. More...
CmdResult | Download (byte noOfDataElements, byte[] bytes)
Download from master to slave. More...
CmdResult | DownloadMax (byte[] bytes)
Download from master to slave (fixed size). More...
CmdResult | DownloadNext (byte noOfDataElements, byte[] bytes)
Download from master to slave. More...
CmdResult | DtoCtrProperties (DTOCtrModifier modifier, ushort eventChannelNo, ushort relatedEventChannelNo, DTOCtrMode mode, out RespDTOCtrResp response)
DTO CTR Properties More...
CmdResult FreeDAQ ()
Clear dynamic DAQ configuration More...
override int | getAliveCycleTime ()
Gets the alive cycle time in [ms]. More...
CmdResult | GetCalPage (CalPageMode mode, byte segmentNo, out RespGetCALPage response)
Get calibration page More...
CmdResult | GetCommModeInfo (out RespGetCommModeInfo response)
Get current session status from slave. More...
CmdResult | GetDAQClock (out RespGetDAQClock response)
Get DAQ clock from slave More...
CmdResult | GetDAQClockMulitcast (ushort clusterID, byte counter)
DAQ Clock Multicast on CAN. More...
CmdResult | GetDAQEventInfo (ushort eventChannelNo, out RespGetDAQEventInfo response)
Get specific information for an event channel More...
CmdResult | GetDAQID (ushort daqListNo, out bool isFixed, out uint respCANID)
Gets the CAN identifier used for the specified DAQ list. More...
CmdResult | GetDAQListInfo (ushort dAQListNo, out RespGetDAQListInfo response)
Get specific information for a DAQ list More...
CmdResult | GetDAQListMode (ushort dAQListNo, out RespGetDAQListMode response)
Get mode from DAQ list More...
CmdResult | GetDAQListUSBEndpoint (ushort dAQListNo, out RespGetDAQListUSBEndpoint response)
Get DAQ List USB Endpoint. More...
CmdResult | GetDAQProcessorInfo (out RespGetDAQProcessorInfo response)
Get general information on DAQ processor More...
CmdResult | GetDAQResolutionInfo (out RespGetDAQResolutionInfo response)
Get general information on DAQ processing resolution More...
CmdResult | GetID (GetIDType idType, out RespGetID response, out byte[] respData)
Get identification from slave. More...
CmdResult | GetPageInfo (byte segmentNo, byte pageNo, out RespGetPageInfo response)
Get specific information for a PAGE More...
CmdResult | GetPAGProcessorInfo (out RespGetPAGProcessorInfo response)
Get general information on PAG processor More...
CmdResult | GetPGMProcessorInfo (out RespGetPGMProcessorInfo response)
Get general information on PGM processor More...
CmdResult | GetSectorInfo (GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeAddressOrLen response)
Get specific information for a SECTOR More...
CmdResult | GetSectorInfo (GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeSectorNameLen response)
Get specific information for a SECTOR More...
CmdResult | GetSeed (SeedModeType seedMode, ResourceType resource, out RespGetSeed response, out byte[] seed)
Get seed for unlocking a protected resource More...
CmdResult | GetSegmentInfo (byte segmentNo, out RespGetSegmentInfo response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentInfoAddress (BasicAddressModeType basicAddressMode, byte segmentNo, out RespGetSegmentInfoAddress response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentInfoMapping (MappingInfoModeType mappingMode, byte segmentNo, byte mappingIndex, out RespGetSegmentInfoAddress response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentMode (byte segmentNo, out RespGetSegmentMode response)
Get mode for a SEGMENT More...
CmdResult | GetStatus (out RespGetStatus response)
Get current session status from slave. More...
sealed override bool | internalConnect ()
Tries to connect to a XCP/CCP slave More...
sealed override bool | internalGetStatus ()
Get current session status from slave. More...
CmdResult | ModifyBits (byte s, ushort ma, ushort mx)
Modify Bits on slave. More...
CmdResult | Program (byte noOfDataElements, byte[] bytes)
Program a non-volatile memory segment. More...
CmdResult | ProgramClear (ProgramClearMode mode, uint clearRange)
Clear a part of non-volatile memory More...
CmdResult | ProgramFormat (byte compressionMethod, byte encryptionMethod, byte programmingMethod, byte accessMethod)
Set data format before programming More...
CmdResult | ProgramMax (byte[] bytes)
Program a non-volatile memory segment (fixed size) More...
CmdResult | ProgramNext (byte noOfDataElements, byte[] bytes)
Program a non-volatile memory segment. More...
CmdResult | ProgramPrepare (ushort codeSize)
Prepare non-volatile memory programming More...
CmdResult ProgramReset ()
Indicate the end of a programming sequence More...
CmdResult | ProgramStart (out RespProgramStart response)
DTO CTR Properties Indicate the beginning of a programming sequence More...
CmdResult | ProgramVerify (ProgramVerifyMode mode, ushort verificationType, uint verificationValue)
Clear a part of non-volatile memory More...
CmdResult | ReadDAQ (out RespReadDAQ response)
Read element from ODT entry More...
sealed override void | resetLastError ()
Reset the last error More...
CmdResult | SetCalPage (CalPageMode mode, byte segmentNo, byte pageNo)
Set calibration page More...
override void | setConnectionState< T > (T respConnect)
Called from the XCPKernel if the connection state gets changed. More...
CmdResult | SetDAQID (ushort daqListNo, uint CANID)
Sets the CAN identifier to use for the specified DAQ list. More...
CmdResult | SetDAQListMode (DAQListMode mode, ushort daqListNo, ushort eventChannelNo, byte prescaler, byte priority)
Set mode for DAQ list More...
CmdResult | SetDAQListUSBEndpoint (ushort dAQListNo, byte endPointNo)
Get DAQ List USB Endpoint. More...
CmdResult | SetDAQPtr (ushort DAQListNo, byte ODTNo, byte ODTEntryNo)
Set pointer to ODT entry More...
CmdResult | SetMTA (byte addressExtension, uint address)
Set Memory Transfer Address in slave. More...
CmdResult | SetRequest (SetRequestMode mode, ushort sessionId)
Request to save to non-volatile memory More...
CmdResult | SetSegmentMode (SegmentMode mode, byte segmentNo)
Set mode for a SEGMENT More...
CmdResult | ShortDownload (byte[] bytes, byte addressExtension, uint address)
Download from master to slave. More...
CmdResult | ShortUpload (byte numberOfElements, byte addressExtension, uint address, out byte[] respData)
Upload from slave to master (short version). More...
CmdResult | StartStopDAQList (StartStopMode mode, ushort dAQListNo, out RespStartStopDAQList response)
Start/stop/select DAQ list More...
CmdResult | StartStopSynch (StartStopMode mode)
Start/stop DAQ lists (synchronously) More...
CmdResult Synch ()
Synchronize command execution after time-out. More...
CmdResult | TimeCorrelationProperties (TimeCorrSetProps setProperties, TimeCorrGetPropsReq getPropertiesReq, ushort clusterID, out RespTimeCorrelation response)
Time Correlation More...
CmdResult | TransportLayerCmd (byte subCommand, byte[] bytes, out byte[] respData, int useTimeout=-1)
Refer to transport layer specific command. More...
CmdResult | Unlock (byte[] key, ref int offset, out RespUnlock response)
Send key for unlocking a protected resource. More...
CmdResult | Upload (byte numberOfElements, out byte[] respData)
Upload from slave to master. More...
CmdResult | UserCmd (byte subCommand, byte[] bytes, out byte[] respData)
Refer to user defined command. More...
CmdResult | WriteDAQ (byte bitOffset, byte elementSize, byte addressExtension, uint address)
Write element in ODT entry More...
CmdResult | WriteDAQMultiple (IList< ODTEntry > entries)
Write multiple elements in ODT. More...
- Public Member Functions inherited from CommMaster
CommMaster (ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf)
Creates a communication master. More...
void | addAdaptiveCharacteristics (A2LPROJECT project, List< IDataFile > dataFiles)
Adds all defined adaptive characteristics to the adaptive characteristic list. More...
EPKCheckResult | epkCheck (A2LMOD_PAR modPar, out string epkFromDevice)
Online EPK check. More...
EPKCheckResult | epkCheck (uint epkAddress, string expectedEPK, out string epkFromDevice)
Online EPK check. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
virtual bool | getDAQRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getDAQRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
double[] | getOperatingPoint (A2LCHARACTERISTIC characteristic)
Returns an array of operating points if available. More...
void | getTransmissionRate (out double bitsPerSec)
Gets the current transmission rate. More...
void | RaiseConnectionStateChanged ()
Raises the ConnectionStateChanged event.
void | RaiseOnValuesReceived (int daqListNo, double seconds, byte[] data)
Raises the OnValuesReceived event with the pecified parameters. More...
bool | readCharacteristic (ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null)
Read the characteristic value from the ECU into the specified datafile. More...
bool | writeCharacteristic (IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null)
Write the characteristic value read from the specified datafile to the device. More...

Properties

override ECUPage??? | ActivePage [get]
BYTEORDER_TYPE?? | ByteOrder [get]
Gets the byte order of the slave device. More...
override bool? | CanWrite [get]
RespGetCommModeInfo | CommModeInfoResponse [get]
The last received CommModeInfo response. More...
RespConnect | ConnectResponse [get]
The last received Connect response. More...
SortedDictionary< ushort, DAQAndEvt > | DAQAndEvtMap [get]
Gets the DAQ to Event mapping Dictionary. More...
uint | DAQClock [get]
The last received GetDAQProcessorInfo response. More...
RespGetDAQProcessorInfo | DAQProcInfo [get]
The last received GetDAQProcessorInfo response. More...
RespGetDAQResolutionInfo | DAQResolutionInfo [get]
The last received GetDAQResolutionInfo response. More...
bool | IsDAQRunning [get]
Indicates if data acquisition is running.
RespGetPAGProcessorInfo | PAGProcInfo [get]
The last received GetPagProcessorInfo response. More...
RespGetPGMProcessorInfo | PGMProcInfo [get]
The last received GetPGMProcessorInfo response. More...
bool | PreventDefaultRequests [getset]
Prevents requesting the default requests when a connection is established.
RespGetStatus | StatusResponse [get]
The last received GetStatus response. More...
string??? | StrAddressGranularity [get]
Gets the address granularity as a string. More...
string? | Version [get]
Gets the XCP version string. More...
- Properties inherited from XCPMasterBase
IPAddress | Address [get]
Gets the remote address used to connect to the XCP slave device.
sealed override Enum | LastErrorEnum [get]
CmdResult | LastErrorResponse = CmdResult.OK [get]
The last error occured.
sealed override string | LastErrorText [get]
XCPFrame | LastResponse [getset]
Last received response.
byte | MaxCTO [get]
MaxCTO (only valid if connected).
ushort | MaxDTO [get]
MaxDTO (only valid if connected).
int | Port [get]
Gets the remote port used to connect to the XCP slave device.
ushort[] | Timings [get]
Gets the timing settings used to connect to the XCP slave device.
XCPType | Type [get]
Gets the type of the XCP instance.
- Properties inherited from CommMaster
abstract ECUPage | ActivePage [get]
The currently active calibration page More...
abstract bool | CanWrite [get]
Indicates if writing to the XCP/CCP mmaster is allowed. More...
bool | ChangeEndianess [getset]
Indicates if XCP Master and Slave byte orders differ. More...
ConnectBehaviourType | ConnectBehaviour [getset]
Gets or sets the connection behavior.
virtual bool | Connected [getprotected set]
Indicates, if the master is connected to the slave device.
DAQDict | DAQs [getprotected set]
The configured DAQ dictionary.
ulong | ErrorsReceived [getprotected set]
The amount of errors received since connection is established.
ulong | EventsReceived [getprotected set]
The amount of events received since connection is established.
ulong | FramesReceived [getprotected set]
The amount of frames received since connection is established.
ulong | FramesSent [getprotected set]
The amount of frames sent since connection is established.
A2LIF_DATA | Interface [get]
Gets the corresponding A2L communication interface.
abstract Enum | LastErrorEnum [get]
Gets the last error occured as enum.
abstract string | LastErrorText [get]
Gets the last error occured as text.
long | LastReceivedTime [getprotected set]
Indicates the timestamp the last byte was received from a slave.
DateTime | LastStateChange [getprotected set]
Returns the last state change (DateTime.MinValue if never changed).
ASAP2.Values.MeasurementAccessData | MeasurementAccessData [getset]
Gets or sets the measurement access data.
NativeSKDLL | SeedAndKeyDLL [getset]
Gets or sets the Seed&Key DLL.
ulong | ServicesReceived [getprotected set]
The amount of service requests received since connection is established.

Events

EventHandler< XCPErrorArgs > | XCPErrorReceived
Called if a XCP command error is received. More...
EventHandler< XCPEventArgs > | XCPEventReceived
Called if a XCP event is received. More...
EventHandler< XCPServiceRequestArgs > | XCPServiceRequestReceived
Called if a XCP service request is received. More...
- Events inherited from CommMaster
EventHandler | ConnectionStateChanged
Called if a XCP/CCP connection state changes. More...
EventHandler< ValuesReceivedEventArgs > | OnValuesReceived
Called if a XCP/CCP data acquisition data is received. More...

Additional Inherited Members

- Static Public Member Functions inherited from XCPMasterBase
static int | getPaddingSize (int ag)
Gets the count of required padding bytes. More...
- Static Public Attributes inherited from CommMaster
static readonly char[] | mStrTrimmer = new char[] { '\0', '\xFF', ' ' }
Used to trim EPK or ID strings.
- Protected Member Functions inherited from XCPMasterBase
CmdResult | WriteBytes (CommandCode cmdCode, byte[] bytes, byte noOfDataElements=0, int useTimeout=-1)
Write the specified byte array to the slave device with the specified command code. More...
- Protected Attributes inherited from XCPMasterBase
int | mAG
Address granularity (only valid if connected).
- Protected Attributes inherited from CommMaster
IDictionary< ulong, AdaptiveState > | mAdaptiveCharDict = new Dictionary<ulong, AdaptiveState>()
The adaptive characteristics dictionary.
long | mBitsTransferred
List< IDataFile > | mDataFiles
The list of data files to write adaptive characteristics into.
NativeSKDLL | mSeedAndKeyDLL

Detailed Description

Implements the XCP Master to communicate with a XCP Slave.

Derived from XCPMasterBase, this is the class providing some convenience funtions for a XCP communication.

  • All commands are implemented as synchronous calls to the slave
  • All commands are thread-safe
  • The endianess of any command, response or event is converted automatically according the XCP protocol
  • Responses (out parameter) of commands are only valid if the CmdResult of the call is CmdResult.OK

Example to connect to a XCP slave device:

using jnsoft.ASAP2;
using jnsoft.ASAP2.XCP;
using jnsoft.ASAP2.Values;
using System;
using System.Text;
using System.Threading;
class Program
{
const string fTime = "HH:mm:ss,fff";
static void Main(string[] args)
{
using (var a2lParser = new A2LParser())
{
a2lParser.parse(args[0]);
var modPar = a2lParser.Project.getNode<A2LMODULE>(false).getNode<A2LMODPAR>(false);
var a2lEPK = modPar.EPK.Trim(new char[] { '\0', ' ' });
ConsoleColor prevColor = Console.ForegroundColor;
try
{
// Create a XCP communication master to connect to a slave
// using XCP over TCP to slave address 127.0.0.1:1800
var timings = new ushort[] { 100, 100, 100, 0, 0, 0 };
using (var xcpMaster = new XCPMaster(ConnectBehaviourType.Manual
, XCPType.TCP
, "127.0.0.1", 1800
, timings
, onConnectionStateChanged, onXCPEventReceived, onXCPServiceRequestReceived, onXCPErrorReceived
))
{ // try to connect to ECU
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: Connecting...EPK should be {a2lEPK}... (press any key to quit)");
CmdResult result;
while (CmdResult.OK != (result = xcpMaster.Connect(ConnectMode.Normal, out RespConnect respConnect)))
{ // wait until connected
Thread.Sleep(1000);
if (Console.KeyAvailable)
// exit process after keypress
return;
}
// connect sucessful -> query GetStatus
if (CmdResult.OK != (result = xcpMaster.GetStatus(out RespGetStatus respState)))
// exit process after failed query
return;
Console.ForegroundColor = ConsoleColor.Yellow;
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: Session state={respState.SessionState}");
// connect successful -> query EPK on Address 0, length 30
if (CmdResult.OK == xcpMaster.ShortUpload(30, 0, 0, out byte[] respData))
{ // upload successful
var deviceEPK = Encoding.Default.GetString(respData).Trim(new char[] { '\0', ' ', '\xff' });
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: EPK from device is: '{deviceEPK}'");
}
}
}
}
finally
{ // reset starting color
Console.ForegroundColor = prevColor;
}
}
// Callback receiving XCP service requests
static void onXCPServiceRequestReceived(object sender, XCPServiceRequestArgs e)
{
Console.ForegroundColor = ConsoleColor.White;
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: Received service request: {e.ReceivedServiceRequest.ServiceRequestCode}");
}
// Callback receiving XCP events
static void onXCPEventReceived(object sender, XCPEventArgs e)
{
Console.ForegroundColor = ConsoleColor.Green;
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: Received event: {e.ReceivedEvent.EventCode}");
}
// Callback receiving XCP errors
static void onXCPErrorReceived(object sender, XCPErrorArgs e)
{
Console.ForegroundColor = ConsoleColor.Red;
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: Received error: {e.ErrorCode}");
}
// Callback receiving XCP connection state changes
static void onConnectionStateChanged(object sender, EventArgs e)
{
Console.ForegroundColor = ConsoleColor.Red;
XCPMaster master = (XCPMaster)sender;
Console.WriteLine($"{DateTime.Now.ToString(fTime)}: State: {(master.Connected ? "connected" : "disconnected")}");
}
}
jnsoft.Comm.XCP.XCPMasterBase.Program
CmdResult Program(byte noOfDataElements, byte[] bytes)
Program a non-volatile memory segment.
Definition: XCPMasterBase.cs:1141
jnsoft.Comm.XCP.XCPMaster.XCPMaster
XCPMaster(ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null)
Creates a XCP on Ethernet communication master.
Definition: XCPMaster.cs:203
jnsoft.ASAP2.Values
Defines and implements stuff for reading, writing and modifying characteristic values.
Definition: CDFFile.cs:43
jnsoft.ASAP2.XCP
Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff.
Definition: ASAP2_XCP.cs:49
jnsoft.ASAP2
Contains the ASAP2 parser base and the ASAP2 object model implementation...
Definition: ASAP2.cs:53
jnsoft.Comm.XCP.CmdResult
CmdResult
Possible command results.
Definition: XCPProtcolDefinitions.cs:695
jnsoft.Comm.XCP.ConnectMode
ConnectMode
Possible connect modes.
Definition: XCPProtcolDefinitions.cs:948
jnsoft.Comm.XCP.XCPType
XCPType
Supported types of XCP communication.
Definition: XCPProtcolDefinitions.cs:51
jnsoft.Comm.ConnectBehaviourType
ConnectBehaviourType
Possible master connect behaviours.
Definition: CommMaster.cs:53
jnsoft
Definition: ASAP2.cs:53

Constructor & Destructor Documentation

◆ XCPMaster() [1/4]

XCPMaster | ( | ConnectBehaviourType | connectBehavior,
 |  | XCPType | type,
 |  | string | remoteAddress,
 |  | int | remotePort,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | A2LXCP_DAQ | daq,
 |  | EventHandler | onConnectionStateChanged = null,
 |  | EventHandler< XCPEventArgs > | onXCPEventReceived = null,
 |  | EventHandler< XCPServiceRequestArgs > | onXCPServiceRequestReceived = null,
 |  | EventHandler< XCPErrorArgs > | onXCPErrorReceived = null
 | ) |  |

Creates a XCP on Ethernet communication master.

Parameters
connectBehavior | Client's connect behaviour
type | Client's type
remoteAddress | The target address
remotePort | The target port
protocolLayer | XCP ProtocolLayer
daq | DAQ List definition (may be null)
onConnectionStateChanged | The callback to receive connection state changes (may be null)
onXCPEventReceived | The callback to receive XCP events (may be null)
onXCPServiceRequestReceived | The callback to receive XCP service requests (may be null)
onXCPErrorReceived | The callback to receive XCP command errors (may be null)
Exceptions
ArgumentException Thrown, if the remoteAddress is not resolvable

◆ XCPMaster() [2/4]

XCPMaster | ( | ConnectBehaviourType | connectBahviour,
 |  | ICANProvider | canProvider,
 |  | A2LXCP_ON_CAN | xcpCAN,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | A2LXCP_DAQ | daq,
 |  | EventHandler | onConnectionStateChanged = null,
 |  | EventHandler< XCPEventArgs > | onXCPEventReceived = null,
 |  | EventHandler< XCPServiceRequestArgs > | onXCPServiceRequestReceived = null,
 |  | EventHandler< XCPErrorArgs > | onXCPErrorReceived = null
 | ) |  |

Creates a XCP on CAN communication master.

Parameters
connectBahviour | Client's connect behaviour
canProvider | The CAN provider to use
xcpCAN | XCPonCAN definition
protocolLayer | XCP ProtocolLayer
daq | DAQ List definition (may be null)
onConnectionStateChanged | The callback to receive connection state changes (may be null)
onXCPEventReceived | The callback to receive XCP events (may be null)
onXCPServiceRequestReceived | The callback to receive XCP service requests (may be null)
onXCPErrorReceived | The callback to receive XCP command errors (may be null)
Exceptions
ArgumentException Thrown, if the remote address is not resolvable

◆ XCPMaster() [3/4]

XCPMaster | ( | ConnectBehaviourType | connectBahviour,
 |  | ISxIProvider | sxiProvider,
 |  | A2LXCP_ON_SxI | xcpSxI,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | A2LXCP_DAQ | daq,
 |  | EventHandler | onConnectionStateChanged = null,
 |  | EventHandler< XCPEventArgs > | onXCPEventReceived = null,
 |  | EventHandler< XCPServiceRequestArgs > | onXCPServiceRequestReceived = null,
 |  | EventHandler< XCPErrorArgs > | onXCPErrorReceived = null
 | ) |  |

Creates a XCP on SxI communication master.

Parameters
connectBahviour | Client's connect behaviour
sxiProvider | The SxI provider to use
xcpSxI | XCPonSxI definition
protocolLayer | XCP ProtocolLayer
daq | DAQ List definition (may be null)
onConnectionStateChanged | The callback to receive connection state changes (may be null)
onXCPEventReceived | The callback to receive XCP events (may be null)
onXCPServiceRequestReceived | The callback to receive XCP service requests (may be null)
onXCPErrorReceived | The callback to receive XCP command errors (may be null)
Exceptions
ArgumentException Thrown, if the remote address is not resolvable

◆ XCPMaster() [4/4]

XCPMaster | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LXCP_ON_USB | xcpUSB,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | A2LXCP_DAQ | daq,
 |  | EventHandler | onConnectionStateChanged = null,
 |  | EventHandler< XCPEventArgs > | onXCPEventReceived = null,
 |  | EventHandler< XCPServiceRequestArgs > | onXCPServiceRequestReceived = null,
 |  | EventHandler< XCPErrorArgs > | onXCPErrorReceived = null
 | ) |  |

Creates a XCP on USB communication master.

Parameters
connectBehavior | Client's connect behaviour
xcpUSB | XCPonUSB definition
protocolLayer | XCP ProtocolLayer
daq | DAQ List definition (may be null)
onConnectionStateChanged | The callback to receive connection state changes (may be null)
onXCPEventReceived | The callback to receive XCP events (may be null)
onXCPServiceRequestReceived | The callback to receive XCP service requests (may be null)
onXCPErrorReceived | The callback to receive XCP command errors (may be null)
Exceptions
ArgumentException Thrown, if the remoteAddress is not resolvable

Member Function Documentation

◆ configureMeasurements()

override void configureMeasurements ( IList< DAQMeasurement > measurements )
virtual

(Re)Configures the specified measurements for data acquisition.

  • Interface is changed to accept now an array index and DAQ prset evnets with a measurement.
  • Use A2LMEASUREMENT.buildDAQMeasurements() to keep up with the previous interface.
  • A potentially existing configuration will be deleted.
Parameters
measurements [in/out] The measurement list (including an measurement array index and predefined events) to be configured, successfully configured measurements will be removed from this list after the call is completed.
Exceptions
ArgumentOutOfRangeException Thrown, if an measurement array index is out of range

Implements CommMaster.

◆ copyPage2Page()

override bool copyPage2Page | ( | ECUPage | srcPage,
 |  | ECUPage | dstPage
 | ) |  |
virtual

Copy data from one ECU page to another.

Parameters
srcPage | The page to copy data from
dstPage | The page to copy data to
Returns
true if successful
Exceptions
ArgumentException Thrown, if srcPage == dstPage

Implements CommMaster.

◆ Disconnect()

override bool Disconnect ( int useTimeout = -1 )
virtual

Disconnect from slave.

Brings the slave to the “DISCONNECTED”state. The DISCONNECTED” state is described in Part 1, chapter “state machine”.

Parameters
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

Implements CommMaster.

◆ Dispose()

override void Dispose ( )
virtual

Frees used resources.

Potentially existing Seed and Key DLLs are unloaded here.

Reimplemented from CommMaster.

◆ freezePage()

CmdResult freezePage | ( | byte | segment,
 |  | uint | timeout
 | ) |  |

Persists the current active page (after calibration data is downloaded) into flash memory.

This is only successful on devices supporting freeze page (see PAGProperties.FreezeSupported).

Parameters
segment | segment number (usually 0)
timeout | timeout in ms
Returns
A CmdResult value

◆ getChecksum()

override bool getChecksum | ( | byte | addressExtension,
 |  | uint | address,
 |  | uint | size,
 |  | out uint | checksum
 | ) |  |
virtual

Get the checksum from the slave.

Parameters
addressExtension | The segment's address extension
address | The start address
size | The size of the data block to build the checksum over
checksum | The resulting checksum
Returns
true if successful

Implements CommMaster.

◆ getID()

bool getID | ( | GetIDType | idType,
 |  | out byte[] | data
 | ) |  |

Get identification from slave.

Automatically uploads the requested data if required.

Parameters
idType | The request type
data | Contains the ID data if return value is true
Returns
true if successful

◆ getSlaveIDs()

CmdResult getSlaveIDs | ( | ICANProvider | canProvider,
 |  | out IList< Tuple< uint, uint > > | cmdRspPairs,
 |  | ushort | timeout = 0
 | ) |  |

Tries to detect available slave ECUs by using the A2L defined CAN Broadcast ID.

  • Precondition: The A2L XCP on CAN interface must contain a CAN Broadcast ID.
  • This is XCP on CAN specific.
Parameters
canProvider | The CAN provider to use
cmdRspPairs | List of responded slaves (Cmd/Rsp CAN ID pairs received)
timeout | A timeout in [ms], if not set T1 from the protocol layer is used
Returns
The corresponding command result
Exceptions
InvalidOperationException Thrown if called instance isn't XCPonCAN based

◆ isAllowedRequest()

bool isAllowedRequest ( string cmd )

Returns true if the command is allowed to request.

Parameters
cmd The XCP command in the same form as in the A2LDescription (e.g. "GET_ID")
Returns
true if the optional command is allowed to execute

◆ isSlaveBlockMode()

bool isSlaveBlockMode ( )

Indicates if Slave Block Mode is supported.

Returns
Slave Block Mode is supported

◆ mapAddress()

override uint mapAddress ( uint address )
virtual

Maps the specified address using A2L defined mapping tables.

Parameters
address The address to translate
Returns
the translated or address

Implements CommMaster.

◆ modifyBits()

bool modifyBits | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte | s,
 |  | ushort | ma,
 |  | ushort | mx
 | ) |  |

Modify Bits on the specific address.

  • Calls XCPMasterBase.SetMTA with the specified address.
  • Calls XCPMasterBase.ModifyBits with the given parameters.
Parameters
addressExtension | The address extension
address | The address to modify
s | Shift Value (S)
ma | AND Mask (MA)
mx | XOR Mask (MX)
Returns
true if successful

◆ onDAQFrameReceived()

override void onDAQFrameReceived ( XCPFrame xcpFrame )
virtual

Called if a DAQ frame is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented from XCPMasterBase.

◆ onErrorReceived()

override void onErrorReceived | ( | CmdResult | result,
 |  | CommandCode | code
 | ) |  |
virtual

Called, if an error response is received from the slave.

Parameters
result | The command result
code | The corresponding command code

Reimplemented from XCPMasterBase.

◆ onEventReceived()

override void onEventReceived ( XCPFrame xcpFrame )
virtual

Called if an event is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented from XCPMasterBase.

◆ onServiceReceived()

override void onServiceReceived ( XCPFrame xcpFrame )
virtual

Called if an service request is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented from XCPMasterBase.

◆ programSync()

override bool programSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null,
 |  | XCPPrgParams | modes = null
 | ) |  |
virtual

Program data synchronously to the ECU.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to program
progressHandler | Callback to receive progress, maybe null
modes | Additional (XCP) programming parameters
Returns
true if successful

Implements CommMaster.

◆ readSync()

override bool readSync | ( | int | len,
 |  | byte | addressExtension,
 |  | uint | address,
 |  | out byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
virtual

Read data synchronously from the ECU.

Parameters
len | The length to read
addressExtension | The address extension
address | The address to read from (If the adress is uint.MaxValue, the data should be read from the current MTA location)
data | The resulting data (completely valid, if return value is CmdResult.OK else it may be null or only partly available)
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implements CommMaster.

◆ setConnectionState< T >()

override void setConnectionState< T > ( T respConnect )
virtual

Called if a a valid connect response is received.

Template Parameters
T Connection type (XCP or CCP)
Parameters
respConnect The connect response

Implements CommMaster.

◆ setPage()

override bool setPage ( ECUPage page )
virtual

Sets the specified page as active page.

Pages of all segments got switched!

Parameters
page The page to set active
Returns
true if successful

Implements CommMaster.

◆ startMeasurements()

override bool startMeasurements ( bool doSynchronized )
virtual

Starts a (previously configured by configureMeasurements) data acquisition.

Parameters
doSynchronized true, if the DAQ List should be started synchronously
Returns
true if successful

Implements CommMaster.

◆ stopMeasurements()

override bool stopMeasurements ( bool doSynchronized )
virtual

Stops a running data acquisition.

The configured data acquisition could be restarted without calling configureMeasurements again with startMeasurements.

Parameters
doSynchronized true, if the DAQ List should be stopped synchronously (Only supported on XCP connections).
Returns
true if successful

Implements CommMaster.

◆ unlockECU() [1/2]

CmdResult unlockECU ( NativeSKDLL seedAndKeyDLL )

Tries to unlock all protected ECU resources using the specified Seed&Key DLL.

Parameters
seedAndKeyDLL The Seed&Key DLL
Returns
A CmdResult value

◆ unlockECU() [2/2]

CmdResult unlockECU | ( | RespGetStatus | status,
 |  | NativeSKDLL | seedAndKeyDLL,
 |  | ResourceType | resource
 | ) |  |

Tries to unlock a specific protected ECU resource using the specified Seed&Key DLL.

Parameters
status | The current status
seedAndKeyDLL | The Seed&Key DLL
resource | Resource to unlock
Returns
A CmdResult value

◆ writeSync()

override bool writeSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
virtual

Write data synchronously to the ECU.

Depending on the data length to be written CmdDownload or CmdShortDownload is used.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to write
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implements CommMaster.

Property Documentation

◆ ByteOrder

BYTEORDER_TYPE?? ByteOrder
get

Gets the byte order of the slave device.

Only valid in connected state!

◆ CommModeInfoResponse

RespGetCommModeInfo CommModeInfoResponse
get

The last received CommModeInfo response.

Only valid in connected state and marked as optional in the A2L!

◆ ConnectResponse

RespConnect ConnectResponse
get

The last received Connect response.

Only valid in connected state!

◆ DAQAndEvtMap

SortedDictionary<ushort, DAQAndEvt> DAQAndEvtMap
get

Gets the DAQ to Event mapping Dictionary.

This is usually initialized from the A2L and reduced by an ECU request.

◆ DAQClock

uint DAQClock
get

The last received GetDAQProcessorInfo response.

Only valid in connected state and DAQ with Timestamp is supported!

◆ DAQProcInfo

RespGetDAQProcessorInfo DAQProcInfo
get

The last received GetDAQProcessorInfo response.

Only valid in connected state and DAQ is supported!

◆ DAQResolutionInfo

RespGetDAQResolutionInfo DAQResolutionInfo
get

The last received GetDAQResolutionInfo response.

Only valid in connected state and marked as optional in the A2L and DAQ is supported!

◆ PAGProcInfo

RespGetPAGProcessorInfo PAGProcInfo
get

The last received GetPagProcessorInfo response.

Only valid in connected state and CAL_PAG is supported!

◆ PGMProcInfo

RespGetPGMProcessorInfo PGMProcInfo
get

The last received GetPGMProcessorInfo response.

Only valid in connected state and PGM is supported!

◆ StatusResponse

RespGetStatus StatusResponse
get

The last received GetStatus response.

Only valid in connected state and marked as optional in the A2L!

◆ StrAddressGranularity

string??? StrAddressGranularity
get

Gets the address granularity as a string.

Only valid in connected state!

◆ Version

string? Version
get

Gets the XCP version string.

Only valid in connected state!

Event Documentation

◆ XCPErrorReceived

EventHandler<XCPErrorArgs> XCPErrorReceived

Called if a XCP command error is received.

The event is invoked from a receiver thread (this is never the GUI thread)!

◆ XCPEventReceived

EventHandler<XCPEventArgs> XCPEventReceived

Called if a XCP event is received.

The event is invoked from a receiver thread (this is never the GUI thread)!

◆ XCPServiceRequestReceived

EventHandler<XCPServiceRequestArgs> XCPServiceRequestReceived

Called if a XCP service request is received.

The event is invoked from a receiver thread (this is never the GUI thread)!


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPMaster
XCPMaster Member List

This is the complete list of members for XCPMaster, including all inherited members.

ActivePage (defined in XCPMaster) | XCPMaster |
addAdaptiveCharacteristics(A2LPROJECT project, List< IDataFile > dataFiles) | CommMaster |
Address | XCPMasterBase |
AllocDAQ(ushort dAQCount) | XCPMasterBase |
AllocODT(ushort dAQListNo, byte oDTCount) | XCPMasterBase |
AllocODTEntry(ushort dAQListNo, byte oDTNo, byte oDTEntriesCount) | XCPMasterBase |
BuildChecksum(uint blockSize, out RespBuildChecksum response) | XCPMasterBase |
ByteOrder | XCPMaster |
CanWrite (defined in XCPMaster) | XCPMaster |
ChangeEndianess | CommMaster | protected
ClearDAQList(ushort dAQListNo) | XCPMasterBase |
CommMaster(ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf) | CommMaster |
CommModeInfoResponse | XCPMaster |
configureMeasurements(IList< DAQMeasurement > measurements) | XCPMaster | virtual
Connect(ConnectMode mode, out RespConnect response) | XCPMasterBase |
ConnectBehaviour | CommMaster |
Connected | CommMaster |
ConnectionStateChanged | CommMaster |
ConnectResponse | XCPMaster |
CopyCalPage(byte srcSegmentNo, byte srcPageNo, byte dstSegmentNo, byte dstPageNo) | XCPMasterBase |
copyPage2Page(ECUPage srcPage, ECUPage dstPage) | XCPMaster | virtual
DAQAndEvtMap | XCPMaster |
DAQClock | XCPMaster |
DAQProcInfo | XCPMaster |
DAQResolutionInfo | XCPMaster |
DAQs | CommMaster |
Disconnect(int useTimeout=-1) | XCPMaster | virtual
Dispose() | XCPMaster | virtual
Download(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
DownloadMax(byte[] bytes) | XCPMasterBase |
DownloadNext(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
DtoCtrProperties(DTOCtrModifier modifier, ushort eventChannelNo, ushort relatedEventChannelNo, DTOCtrMode mode, out RespDTOCtrResp response) | XCPMasterBase |
epkCheck(A2LMOD_PAR modPar, out string epkFromDevice) | CommMaster |
epkCheck(uint epkAddress, string expectedEPK, out string epkFromDevice) | CommMaster |
ErrorsReceived | CommMaster |
EventsReceived | CommMaster |
FramesReceived | CommMaster |
FramesSent | CommMaster |
FreeDAQ() | XCPMasterBase |
freezePage(byte segment, uint timeout) | XCPMaster |
getAliveCycleTime() | XCPMasterBase | virtual
GetCalPage(CalPageMode mode, byte segmentNo, out RespGetCALPage response) | XCPMasterBase |
getChecksum(byte addressExtension, uint address, uint size, out uint checksum) | XCPMaster | virtual
GetCommModeInfo(out RespGetCommModeInfo response) | XCPMasterBase |
GetDAQClock(out RespGetDAQClock response) | XCPMasterBase |
GetDAQClockMulitcast(ushort clusterID, byte counter) | XCPMasterBase |
GetDAQEventInfo(ushort eventChannelNo, out RespGetDAQEventInfo response) | XCPMasterBase |
GetDAQID(ushort daqListNo, out bool isFixed, out uint respCANID) | XCPMasterBase |
GetDAQListInfo(ushort dAQListNo, out RespGetDAQListInfo response) | XCPMasterBase |
GetDAQListMode(ushort dAQListNo, out RespGetDAQListMode response) | XCPMasterBase |
GetDAQListUSBEndpoint(ushort dAQListNo, out RespGetDAQListUSBEndpoint response) | XCPMasterBase |
getDAQPhysValue(A2LMEASUREMENT measurement, out double value) | CommMaster |
getDAQPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | CommMaster |
GetDAQProcessorInfo(out RespGetDAQProcessorInfo response) | XCPMasterBase |
getDAQRawValue(A2LMEASUREMENT measurement, out double rawValue) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | CommMaster | virtual
GetDAQResolutionInfo(out RespGetDAQResolutionInfo response) | XCPMasterBase |
GetID(GetIDType idType, out RespGetID response, out byte[] respData) | XCPMasterBase |
getID(GetIDType idType, out byte[] data) | XCPMaster |
getOperatingPoint(A2LCHARACTERISTIC characteristic) | CommMaster |
getPaddingSize(int ag) | XCPMasterBase | static
GetPageInfo(byte segmentNo, byte pageNo, out RespGetPageInfo response) | XCPMasterBase |
GetPAGProcessorInfo(out RespGetPAGProcessorInfo response) | XCPMasterBase |
GetPGMProcessorInfo(out RespGetPGMProcessorInfo response) | XCPMasterBase |
GetSectorInfo(GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeAddressOrLen response) | XCPMasterBase |
GetSectorInfo(GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeSectorNameLen response) | XCPMasterBase |
GetSeed(SeedModeType seedMode, ResourceType resource, out RespGetSeed response, out byte[] seed) | XCPMasterBase |
GetSegmentInfo(byte segmentNo, out RespGetSegmentInfo response) | XCPMasterBase |
GetSegmentInfoAddress(BasicAddressModeType basicAddressMode, byte segmentNo, out RespGetSegmentInfoAddress response) | XCPMasterBase |
GetSegmentInfoMapping(MappingInfoModeType mappingMode, byte segmentNo, byte mappingIndex, out RespGetSegmentInfoAddress response) | XCPMasterBase |
GetSegmentMode(byte segmentNo, out RespGetSegmentMode response) | XCPMasterBase |
getSlaveIDs(ICANProvider canProvider, out IList< Tuple< uint, uint > > cmdRspPairs, ushort timeout=0) | XCPMaster |
GetStatus(out RespGetStatus response) | XCPMasterBase |
getTransmissionRate(out double bitsPerSec) | CommMaster |
Interface | CommMaster |
internalConnect() | XCPMasterBase | virtual
internalGetStatus() | XCPMasterBase | virtual
isAllowedRequest(string cmd) | XCPMaster |
IsDAQRunning | XCPMaster |
isSlaveBlockMode() | XCPMaster |
LastErrorEnum (defined in XCPMasterBase) | XCPMasterBase |
LastErrorResponse | XCPMasterBase |
LastErrorText (defined in XCPMasterBase) | XCPMasterBase |
LastReceivedTime | CommMaster |
LastResponse | XCPMasterBase |
LastStateChange | CommMaster |
mAdaptiveCharDict | CommMaster | protected
mAG | XCPMasterBase | protected
mapAddress(uint address) | XCPMaster | virtual
MaxCTO | XCPMasterBase |
MaxDTO | XCPMasterBase |
mBitsTransferred (defined in CommMaster) | CommMaster | protected
mDataFiles | CommMaster | protected
MeasurementAccessData | CommMaster |
ModifyBits(byte s, ushort ma, ushort mx) | XCPMasterBase |
modifyBits(byte addressExtension, uint address, byte s, ushort ma, ushort mx) | XCPMaster |
mSeedAndKeyDLL (defined in CommMaster) | CommMaster | protected
mStrTrimmer | CommMaster | static
onDAQFrameReceived(XCPFrame xcpFrame) | XCPMaster | virtual
onErrorReceived(CmdResult result, CommandCode code) | XCPMaster | virtual
onEventReceived(XCPFrame xcpFrame) | XCPMaster | virtual
onServiceReceived(XCPFrame xcpFrame) | XCPMaster | virtual
OnValuesReceived | CommMaster |
PAGProcInfo | XCPMaster |
PGMProcInfo | XCPMaster |
Port | XCPMasterBase |
PreventDefaultRequests | XCPMaster |
Program(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
ProgramClear(ProgramClearMode mode, uint clearRange) | XCPMasterBase |
ProgramFormat(byte compressionMethod, byte encryptionMethod, byte programmingMethod, byte accessMethod) | XCPMasterBase |
ProgramMax(byte[] bytes) | XCPMasterBase |
ProgramNext(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
ProgramPrepare(ushort codeSize) | XCPMasterBase |
ProgramReset() | XCPMasterBase |
ProgramStart(out RespProgramStart response) | XCPMasterBase |
programSync(byte addressExtension, MemorySegmentList segments, EventHandler< ProgressArgs > progressHandler=null, ConnectMode connectMode=ConnectMode.Normal, XCPPrgParams modes=null) (defined in XCPMaster) | XCPMaster |
programSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null) | XCPMaster | virtual
ProgramVerify(ProgramVerifyMode mode, ushort verificationType, uint verificationValue) | XCPMasterBase |
RaiseConnectionStateChanged() | CommMaster |
RaiseOnValuesReceived(int daqListNo, double seconds, byte[] data) | CommMaster |
readCharacteristic(ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
ReadDAQ(out RespReadDAQ response) | XCPMasterBase |
readSync(int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | XCPMaster | virtual
resetLastError() | XCPMasterBase | virtual
SeedAndKeyDLL | CommMaster |
ServicesReceived | CommMaster |
SetCalPage(CalPageMode mode, byte segmentNo, byte pageNo) | XCPMasterBase |
setConnectionState< T >(T respConnect) | XCPMaster | virtual
SetDAQID(ushort daqListNo, uint CANID) | XCPMasterBase |
SetDAQListMode(DAQListMode mode, ushort daqListNo, ushort eventChannelNo, byte prescaler, byte priority) | XCPMasterBase |
SetDAQListUSBEndpoint(ushort dAQListNo, byte endPointNo) | XCPMasterBase |
SetDAQPtr(ushort DAQListNo, byte ODTNo, byte ODTEntryNo) | XCPMasterBase |
SetMTA(byte addressExtension, uint address) | XCPMasterBase |
setPage(ECUPage page) | XCPMaster | virtual
SetRequest(SetRequestMode mode, ushort sessionId) | XCPMasterBase |
SetSegmentMode(SegmentMode mode, byte segmentNo) | XCPMasterBase |
ShortDownload(byte[] bytes, byte addressExtension, uint address) | XCPMasterBase |
ShortUpload(byte numberOfElements, byte addressExtension, uint address, out byte[] respData) | XCPMasterBase |
startMeasurements(bool doSynchronized) | XCPMaster | virtual
StartStopDAQList(StartStopMode mode, ushort dAQListNo, out RespStartStopDAQList response) | XCPMasterBase |
StartStopSynch(StartStopMode mode) | XCPMasterBase |
StatusResponse | XCPMaster |
stopMeasurements(bool doSynchronized) | XCPMaster | virtual
StrAddressGranularity | XCPMaster |
Synch() | XCPMasterBase |
TimeCorrelationProperties(TimeCorrSetProps setProperties, TimeCorrGetPropsReq getPropertiesReq, ushort clusterID, out RespTimeCorrelation response) | XCPMasterBase |
Timings | XCPMasterBase |
TransportLayerCmd(byte subCommand, byte[] bytes, out byte[] respData, int useTimeout=-1) | XCPMasterBase |
Type | XCPMasterBase |
Unlock(byte[] key, ref int offset, out RespUnlock response) | XCPMasterBase |
unlockECU(RespGetStatus status, NativeSKDLL seedAndKeyDLL, ResourceType resource) | XCPMaster |
unlockECU(NativeSKDLL seedAndKeyDLL) | XCPMaster |
Upload(byte numberOfElements, out byte[] respData) | XCPMasterBase |
UserCmd(byte subCommand, byte[] bytes, out byte[] respData) | XCPMasterBase |
Version | XCPMaster |
WriteBytes(CommandCode cmdCode, byte[] bytes, byte noOfDataElements=0, int useTimeout=-1) | XCPMasterBase | protected
writeCharacteristic(IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
WriteDAQ(byte bitOffset, byte elementSize, byte addressExtension, uint address) | XCPMasterBase |
WriteDAQMultiple(IList< ODTEntry > entries) | XCPMasterBase |
writeSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null) | XCPMaster | virtual
XCPErrorReceived | XCPMaster |
XCPEventReceived | XCPMaster |
XCPMaster(ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null) | XCPMaster |
XCPMaster(ConnectBehaviourType connectBahviour, ICANProvider canProvider, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null) | XCPMaster |
XCPMaster(ConnectBehaviourType connectBahviour, ISxIProvider sxiProvider, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null) | XCPMaster |
XCPMaster(ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer, A2LXCP_DAQ daq, EventHandler onConnectionStateChanged=null, EventHandler< XCPEventArgs > onXCPEventReceived=null, EventHandler< XCPServiceRequestArgs > onXCPServiceRequestReceived=null, EventHandler< XCPErrorArgs > onXCPErrorReceived=null) | XCPMaster |
XCPMasterBase(ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, string canProviderName) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, string comPort) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer) | XCPMasterBase |
XCPServiceRequestReceived | XCPMaster |


ASAP2Library interface: XCPMasterBase Class Reference

  • Comm
  • XCP
  • XCPMasterBase
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
XCPMasterBase Class Reference

Implements the XCP Master base communication with a XCP Slave. More...

Public Member Functions

XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, string canProviderName)
Creates a XCPonCAN communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, string comPort)
Creates a XCPonCAN communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer)
Creates a XCPonUSB communication master. More...
XCPMasterBase (ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer)
Creates a XCPonEth (TCP pr UDP) communication master. More...
CmdResult | AllocDAQ (ushort dAQCount)
Allocate DAQ lists More...
CmdResult | AllocODT (ushort dAQListNo, byte oDTCount)
Allocate ODTs to a DAQ list More...
CmdResult | AllocODTEntry (ushort dAQListNo, byte oDTNo, byte oDTEntriesCount)
Allocate ODT entries to an ODT More...
CmdResult | BuildChecksum (uint blockSize, out RespBuildChecksum response)
Build checksum over memory range. More...
CmdResult | ClearDAQList (ushort dAQListNo)
Clear DAQ list configuration More...
CmdResult | Connect (ConnectMode mode, out RespConnect response)
Set up connection with slave. More...
CmdResult | CopyCalPage (byte srcSegmentNo, byte srcPageNo, byte dstSegmentNo, byte dstPageNo)
Copy page More...
override bool | Disconnect (int useTimeout=-1)
Disconnect from slave. More...
CmdResult | Download (byte noOfDataElements, byte[] bytes)
Download from master to slave. More...
CmdResult | DownloadMax (byte[] bytes)
Download from master to slave (fixed size). More...
CmdResult | DownloadNext (byte noOfDataElements, byte[] bytes)
Download from master to slave. More...
CmdResult | DtoCtrProperties (DTOCtrModifier modifier, ushort eventChannelNo, ushort relatedEventChannelNo, DTOCtrMode mode, out RespDTOCtrResp response)
DTO CTR Properties More...
CmdResult FreeDAQ ()
Clear dynamic DAQ configuration More...
override int | getAliveCycleTime ()
Gets the alive cycle time in [ms]. More...
CmdResult | GetCalPage (CalPageMode mode, byte segmentNo, out RespGetCALPage response)
Get calibration page More...
CmdResult | GetCommModeInfo (out RespGetCommModeInfo response)
Get current session status from slave. More...
CmdResult | GetDAQClock (out RespGetDAQClock response)
Get DAQ clock from slave More...
CmdResult | GetDAQClockMulitcast (ushort clusterID, byte counter)
DAQ Clock Multicast on CAN. More...
CmdResult | GetDAQEventInfo (ushort eventChannelNo, out RespGetDAQEventInfo response)
Get specific information for an event channel More...
CmdResult | GetDAQID (ushort daqListNo, out bool isFixed, out uint respCANID)
Gets the CAN identifier used for the specified DAQ list. More...
CmdResult | GetDAQListInfo (ushort dAQListNo, out RespGetDAQListInfo response)
Get specific information for a DAQ list More...
CmdResult | GetDAQListMode (ushort dAQListNo, out RespGetDAQListMode response)
Get mode from DAQ list More...
CmdResult | GetDAQListUSBEndpoint (ushort dAQListNo, out RespGetDAQListUSBEndpoint response)
Get DAQ List USB Endpoint. More...
CmdResult | GetDAQProcessorInfo (out RespGetDAQProcessorInfo response)
Get general information on DAQ processor More...
CmdResult | GetDAQResolutionInfo (out RespGetDAQResolutionInfo response)
Get general information on DAQ processing resolution More...
CmdResult | GetID (GetIDType idType, out RespGetID response, out byte[] respData)
Get identification from slave. More...
CmdResult | GetPageInfo (byte segmentNo, byte pageNo, out RespGetPageInfo response)
Get specific information for a PAGE More...
CmdResult | GetPAGProcessorInfo (out RespGetPAGProcessorInfo response)
Get general information on PAG processor More...
CmdResult | GetPGMProcessorInfo (out RespGetPGMProcessorInfo response)
Get general information on PGM processor More...
CmdResult | GetSectorInfo (GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeAddressOrLen response)
Get specific information for a SECTOR More...
CmdResult | GetSectorInfo (GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeSectorNameLen response)
Get specific information for a SECTOR More...
CmdResult | GetSeed (SeedModeType seedMode, ResourceType resource, out RespGetSeed response, out byte[] seed)
Get seed for unlocking a protected resource More...
CmdResult | GetSegmentInfo (byte segmentNo, out RespGetSegmentInfo response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentInfoAddress (BasicAddressModeType basicAddressMode, byte segmentNo, out RespGetSegmentInfoAddress response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentInfoMapping (MappingInfoModeType mappingMode, byte segmentNo, byte mappingIndex, out RespGetSegmentInfoAddress response)
Get specific information for a SEGMENT More...
CmdResult | GetSegmentMode (byte segmentNo, out RespGetSegmentMode response)
Get mode for a SEGMENT More...
CmdResult | GetStatus (out RespGetStatus response)
Get current session status from slave. More...
sealed override bool | internalConnect ()
Tries to connect to a XCP/CCP slave More...
sealed override bool | internalGetStatus ()
Get current session status from slave. More...
CmdResult | ModifyBits (byte s, ushort ma, ushort mx)
Modify Bits on slave. More...
virtual void | onDAQFrameReceived (XCPFrame xcpFrame)
Called if a DAQ frame is received from the slave. More...
virtual void | onErrorReceived (CmdResult result, CommandCode code)
Called, if an error response is received from the slave. More...
virtual void | onEventReceived (XCPFrame xcpFrame)
Called if an event is received from the slave. More...
virtual void | onServiceReceived (XCPFrame xcpFrame)
Called if an service request is received from the slave. More...
CmdResult | Program (byte noOfDataElements, byte[] bytes)
Program a non-volatile memory segment. More...
CmdResult | ProgramClear (ProgramClearMode mode, uint clearRange)
Clear a part of non-volatile memory More...
CmdResult | ProgramFormat (byte compressionMethod, byte encryptionMethod, byte programmingMethod, byte accessMethod)
Set data format before programming More...
CmdResult | ProgramMax (byte[] bytes)
Program a non-volatile memory segment (fixed size) More...
CmdResult | ProgramNext (byte noOfDataElements, byte[] bytes)
Program a non-volatile memory segment. More...
CmdResult | ProgramPrepare (ushort codeSize)
Prepare non-volatile memory programming More...
CmdResult ProgramReset ()
Indicate the end of a programming sequence More...
CmdResult | ProgramStart (out RespProgramStart response)
DTO CTR Properties Indicate the beginning of a programming sequence More...
CmdResult | ProgramVerify (ProgramVerifyMode mode, ushort verificationType, uint verificationValue)
Clear a part of non-volatile memory More...
CmdResult | ReadDAQ (out RespReadDAQ response)
Read element from ODT entry More...
sealed override void | resetLastError ()
Reset the last error More...
CmdResult | SetCalPage (CalPageMode mode, byte segmentNo, byte pageNo)
Set calibration page More...
override void | setConnectionState< T > (T respConnect)
Called from the XCPKernel if the connection state gets changed. More...
CmdResult | SetDAQID (ushort daqListNo, uint CANID)
Sets the CAN identifier to use for the specified DAQ list. More...
CmdResult | SetDAQListMode (DAQListMode mode, ushort daqListNo, ushort eventChannelNo, byte prescaler, byte priority)
Set mode for DAQ list More...
CmdResult | SetDAQListUSBEndpoint (ushort dAQListNo, byte endPointNo)
Get DAQ List USB Endpoint. More...
CmdResult | SetDAQPtr (ushort DAQListNo, byte ODTNo, byte ODTEntryNo)
Set pointer to ODT entry More...
CmdResult | SetMTA (byte addressExtension, uint address)
Set Memory Transfer Address in slave. More...
CmdResult | SetRequest (SetRequestMode mode, ushort sessionId)
Request to save to non-volatile memory More...
CmdResult | SetSegmentMode (SegmentMode mode, byte segmentNo)
Set mode for a SEGMENT More...
CmdResult | ShortDownload (byte[] bytes, byte addressExtension, uint address)
Download from master to slave. More...
CmdResult | ShortUpload (byte numberOfElements, byte addressExtension, uint address, out byte[] respData)
Upload from slave to master (short version). More...
CmdResult | StartStopDAQList (StartStopMode mode, ushort dAQListNo, out RespStartStopDAQList response)
Start/stop/select DAQ list More...
CmdResult | StartStopSynch (StartStopMode mode)
Start/stop DAQ lists (synchronously) More...
CmdResult Synch ()
Synchronize command execution after time-out. More...
CmdResult | TimeCorrelationProperties (TimeCorrSetProps setProperties, TimeCorrGetPropsReq getPropertiesReq, ushort clusterID, out RespTimeCorrelation response)
Time Correlation More...
CmdResult | TransportLayerCmd (byte subCommand, byte[] bytes, out byte[] respData, int useTimeout=-1)
Refer to transport layer specific command. More...
CmdResult | Unlock (byte[] key, ref int offset, out RespUnlock response)
Send key for unlocking a protected resource. More...
CmdResult | Upload (byte numberOfElements, out byte[] respData)
Upload from slave to master. More...
CmdResult | UserCmd (byte subCommand, byte[] bytes, out byte[] respData)
Refer to user defined command. More...
CmdResult | WriteDAQ (byte bitOffset, byte elementSize, byte addressExtension, uint address)
Write element in ODT entry More...
CmdResult | WriteDAQMultiple (IList< ODTEntry > entries)
Write multiple elements in ODT. More...
- Public Member Functions inherited from CommMaster
CommMaster (ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf)
Creates a communication master. More...
void | addAdaptiveCharacteristics (A2LPROJECT project, List< IDataFile > dataFiles)
Adds all defined adaptive characteristics to the adaptive characteristic list. More...
abstract void | configureMeasurements (IList< DAQMeasurement > measurements)
(Re)Configures the specified measurements for data acquisition. More...
abstract bool | copyPage2Page (ECUPage srcPage, ECUPage dstPage)
Copy data from one ECU page to another. More...
virtual void | Dispose ()
Frees used resources. More...
EPKCheckResult | epkCheck (A2LMOD_PAR modPar, out string epkFromDevice)
Online EPK check. More...
EPKCheckResult | epkCheck (uint epkAddress, string expectedEPK, out string epkFromDevice)
Online EPK check. More...
abstract bool | getChecksum (byte addressExtension, uint address, uint size, out uint checksum)
Get the checksum from the slave. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
virtual bool | getDAQRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getDAQRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
double[] | getOperatingPoint (A2LCHARACTERISTIC characteristic)
Returns an array of operating points if available. More...
void | getTransmissionRate (out double bitsPerSec)
Gets the current transmission rate. More...
abstract uint | mapAddress (uint address)
Maps the specified address using A2L defined mapping tables. More...
abstract bool | programSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null)
Program data synchronously to the ECU. More...
void | RaiseConnectionStateChanged ()
Raises the ConnectionStateChanged event.
void | RaiseOnValuesReceived (int daqListNo, double seconds, byte[] data)
Raises the OnValuesReceived event with the pecified parameters. More...
bool | readCharacteristic (ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null)
Read the characteristic value from the ECU into the specified datafile. More...
abstract bool | readSync (int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Read data synchronously from the ECU. More...
abstract bool | setPage (ECUPage page)
Sets the specified page as active page. More...
abstract bool | startMeasurements (bool doSynchronized)
Starts a (previously configured by configureMeasurements) data acquisition. More...
abstract bool | stopMeasurements (bool doSynchronized)
Stops a running data acquisition. More...
bool | writeCharacteristic (IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null)
Write the characteristic value read from the specified datafile to the device. More...
abstract bool | writeSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Write data synchronously to the ECU. More...

Static Public Member Functions

static int getPaddingSize (int ag)
Gets the count of required padding bytes. More...

Protected Member Functions

CmdResult WriteBytes (CommandCode cmdCode, byte[] bytes, byte noOfDataElements=0, int useTimeout=-1)
Write the specified byte array to the slave device with the specified command code. More...

Protected Attributes

int | mAG
Address granularity (only valid if connected).
- Protected Attributes inherited from CommMaster
IDictionary< ulong, AdaptiveState > | mAdaptiveCharDict = new Dictionary<ulong, AdaptiveState>()
The adaptive characteristics dictionary.
long | mBitsTransferred
List< IDataFile > | mDataFiles
The list of data files to write adaptive characteristics into.
NativeSKDLL | mSeedAndKeyDLL

Properties

IPAddress | Address [get]
Gets the remote address used to connect to the XCP slave device.
sealed override Enum | LastErrorEnum [get]
CmdResult | LastErrorResponse = CmdResult.OK [get]
The last error occured.
sealed override string | LastErrorText [get]
XCPFrame | LastResponse [getset]
Last received response.
byte | MaxCTO [get]
MaxCTO (only valid if connected).
ushort | MaxDTO [get]
MaxDTO (only valid if connected).
int | Port [get]
Gets the remote port used to connect to the XCP slave device.
ushort[] | Timings [get]
Gets the timing settings used to connect to the XCP slave device.
XCPType | Type [get]
Gets the type of the XCP instance.
- Properties inherited from CommMaster
abstract ECUPage | ActivePage [get]
The currently active calibration page More...
abstract bool | CanWrite [get]
Indicates if writing to the XCP/CCP mmaster is allowed. More...
bool | ChangeEndianess [getset]
Indicates if XCP Master and Slave byte orders differ. More...
ConnectBehaviourType | ConnectBehaviour [getset]
Gets or sets the connection behavior.
virtual bool | Connected [getprotected set]
Indicates, if the master is connected to the slave device.
DAQDict | DAQs [getprotected set]
The configured DAQ dictionary.
ulong | ErrorsReceived [getprotected set]
The amount of errors received since connection is established.
ulong | EventsReceived [getprotected set]
The amount of events received since connection is established.
ulong | FramesReceived [getprotected set]
The amount of frames received since connection is established.
ulong | FramesSent [getprotected set]
The amount of frames sent since connection is established.
A2LIF_DATA | Interface [get]
Gets the corresponding A2L communication interface.
abstract Enum | LastErrorEnum [get]
Gets the last error occured as enum.
abstract string | LastErrorText [get]
Gets the last error occured as text.
long | LastReceivedTime [getprotected set]
Indicates the timestamp the last byte was received from a slave.
DateTime | LastStateChange [getprotected set]
Returns the last state change (DateTime.MinValue if never changed).
ASAP2.Values.MeasurementAccessData | MeasurementAccessData [getset]
Gets or sets the measurement access data.
NativeSKDLL | SeedAndKeyDLL [getset]
Gets or sets the Seed&Key DLL.
ulong | ServicesReceived [getprotected set]
The amount of service requests received since connection is established.

Additional Inherited Members

- Static Public Attributes inherited from CommMaster
static readonly char[] | mStrTrimmer = new char[] { '\0', '\xFF', ' ' }
Used to trim EPK or ID strings.
- Events inherited from CommMaster
EventHandler | ConnectionStateChanged
Called if a XCP/CCP connection state changes. More...
EventHandler< ValuesReceivedEventArgs > | OnValuesReceived
Called if a XCP/CCP data acquisition data is received. More...

Detailed Description

Implements the XCP Master base communication with a XCP Slave.

  • All commands are implemented as synchronous calls to the slave
  • All commands are thread-safe
  • The endianess of any command, response or event is converted automatically according the XCP protocol
  • Responses (out parameter) of commands are only valid if the CmdResult of the call is CmdResult.OK

Constructor & Destructor Documentation

◆ XCPMasterBase() [1/4]

XCPMasterBase | ( | ConnectBehaviourType | connectBehavior,
 |  | XCPType | type,
 |  | string | remoteAddress,
 |  | int | remotePort,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer
 | ) |  |

Creates a XCPonEth (TCP pr UDP) communication master.

Parameters
connectBehavior | Client's connect behaviour
type | Client's type
remoteAddress | The target address
remotePort | The target port
protocolLayer | XCP ProtocolLayer
Exceptions
ArgumentException Thrown, if the remoteAddress is not resolvable

◆ XCPMasterBase() [2/4]

XCPMasterBase | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LXCP_ON_CAN | xcpCAN,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | string | canProviderName
 | ) |  |

Creates a XCPonCAN communication master.

Parameters
connectBehavior | Client's connect behaviour
xcpCAN | XCPonCAN definition
protocolLayer | XCP ProtocolLayer
canProviderName | The CAN provider name

◆ XCPMasterBase() [3/4]

XCPMasterBase | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LXCP_ON_SxI | xcpSxI,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer,
 |  | string | comPort
 | ) |  |

Creates a XCPonCAN communication master.

Parameters
connectBehavior | Client's connect behaviour
xcpSxI | XCPonSxI definition
protocolLayer | XCP ProtocolLayer
comPort | The serial port name

◆ XCPMasterBase() [4/4]

XCPMasterBase | ( | ConnectBehaviourType | connectBehavior,
 |  | A2LXCP_ON_USB | xcpUSB,
 |  | A2LXCP_PROTOCOL_LAYER | protocolLayer
 | ) |  |

Creates a XCPonUSB communication master.

Parameters
connectBehavior | Client's connect behaviour
xcpUSB | XCPonUSB definition
protocolLayer | XCP ProtocolLayer

Member Function Documentation

◆ AllocDAQ()

CmdResult AllocDAQ ( ushort dAQCount )

Allocate DAQ lists

Parameters
dAQCount number of DAQ lists to be allocated
Returns
The corresponding command result

◆ AllocODT()

CmdResult AllocODT | ( | ushort | dAQListNo,
 |  | byte | oDTCount
 | ) |  |

Allocate ODTs to a DAQ list

Parameters
dAQListNo | DAQ list number
oDTCount | number of ODTs to be assigned to DAQ list
Returns
The corresponding command result

◆ AllocODTEntry()

CmdResult AllocODTEntry | ( | ushort | dAQListNo,
 |  | byte | oDTNo,
 |  | byte | oDTEntriesCount
 | ) |  |

Allocate ODT entries to an ODT

Parameters
dAQListNo | DAQ list number
oDTNo | ODT number
oDTEntriesCount | number of ODT entries to be assigned to ODT
Returns
The corresponding command result

◆ BuildChecksum()

CmdResult BuildChecksum | ( | uint | blockSize,
 |  | out RespBuildChecksum | response
 | ) |  |

Build checksum over memory range.

Returns a checksum result of the memory block that is defined by the MTA and Block size. The MTA will be post-incremented by the block size

Parameters
blockSize | The block size
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ ClearDAQList()

CmdResult ClearDAQList ( ushort dAQListNo )

Clear DAQ list configuration

Parameters
dAQListNo DAQ list number
Returns
The corresponding command result

◆ Connect()

CmdResult Connect | ( | ConnectMode | mode,
 |  | out RespConnect | response
 | ) |  |

Set up connection with slave.

This command establishes a continuous, logical, point-to-point connection with a slave device. During a running XCP session (CONNECTED) this command has no influence on any configuration of the XCP slave driver.

A slave device does not respond to any other commands (except auto detection) unless it is in the state CONNECTED.

Parameters
mode | The connect mode
response | The connect response
Returns
The corresponding command result

◆ CopyCalPage()

CmdResult CopyCalPage | ( | byte | srcSegmentNo,
 |  | byte | srcPageNo,
 |  | byte | dstSegmentNo,
 |  | byte | dstPageNo
 | ) |  |

Copy page

Parameters
srcSegmentNo | Logical data segment number source
srcPageNo | Logical data page number source
dstSegmentNo | Logical data segment number destination
dstPageNo | Logical data page number destination
Returns
The corresponding command result

◆ Disconnect()

override bool Disconnect ( int useTimeout = -1 )
virtual

Disconnect from slave.

Brings the slave to the “DISCONNECTED”state. The DISCONNECTED” state is described in Part 1, chapter “state machine”.

Parameters
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

Implements CommMaster.

◆ Download()

CmdResult Download | ( | byte | noOfDataElements,
 |  | byte[] | bytes
 | ) |  |

Download from master to slave.

The data block of the specified length (size) contained in the CMD will be copied into memory, starting at the MTA. The MTA will be post-incremented by the number of data elements.

Parameters
noOfDataElements | The number of data elements
bytes | The data bytes to download
Returns
The corresponding command result

◆ DownloadMax()

CmdResult DownloadMax ( byte[] bytes )

Download from master to slave (fixed size).

Parameters
bytes The data bytes to download
Returns
The corresponding command result

◆ DownloadNext()

CmdResult DownloadNext | ( | byte | noOfDataElements,
 |  | byte[] | bytes
 | ) |  |

Download from master to slave.

This command is used to transmit consecutive data elements for the DOWNLOAD command in block transfer mode.

Parameters
noOfDataElements | The number of data elements
bytes | The data bytes to download
Returns
The corresponding command result

◆ DtoCtrProperties()

CmdResult DtoCtrProperties | ( | DTOCtrModifier | modifier,
 |  | ushort | eventChannelNo,
 |  | ushort | relatedEventChannelNo,
 |  | DTOCtrMode | mode,
 |  | out RespDTOCtrResp | response
 | ) |  |

DTO CTR Properties

Returns the properties of a specific event channel addressed by a number in the range from 0 to MAX_EVENT_CHANNEL-1. The command can optionally also modify DTO CTR properties of this event channel.

Parameters
modifier | For each modifier which is set, the corresponding property (DTO CTR STIM mode, DTO CTR DAQ mode or related event channel number)of the event channel is overwritten with the appropriate command parameter, else it is kept at its current value. Command parameters which are unused, as their modifier is not set, should be written as 0.
eventChannelNo | Event channel number [0,1,..MAX_EVENT_CHANNEL-1]
relatedEventChannelNo | RELATED_EVENT_CHANNEL_NUMBER [0,1,..MAX_EVENT_CHANNEL-1]
mode
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ FreeDAQ()

CmdResult FreeDAQ ( )

Clear dynamic DAQ configuration

Returns
The corresponding command result

◆ getAliveCycleTime()

override int getAliveCycleTime ( )
virtual

Gets the alive cycle time in [ms].

Returns

Implements CommMaster.

◆ GetCalPage()

CmdResult GetCalPage | ( | CalPageMode | mode,
 |  | byte | segmentNo,
 |  | out RespGetCALPage | response
 | ) |  |

Get calibration page

Parameters
mode
segmentNo | Logical data segment number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetCommModeInfo()

CmdResult GetCommModeInfo ( out RespGetCommModeInfo response )

Get current session status from slave.

This command returns optional information on different Communication Modes supported by the slave.

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQClock()

CmdResult GetDAQClock ( out RespGetDAQClock response )

Get DAQ clock from slave

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQClockMulitcast()

CmdResult GetDAQClockMulitcast | ( | ushort | clusterID,
 |  | byte | counter
 | ) |  |

DAQ Clock Multicast on CAN.

When an XCP master makes use of GET_DAQ_CLOCK_MULTICAST command on transport layer CAN, a GET_DAQ_CLOCK_MULTICAST command must be sent every two seconds at the latest.

The command shall be sent on the CAN-ID “CAN_ID_GET_DAQ_CLOCK_MULTICAST”. This CAN-Id may be the same as the CAN-ID "CAN_ID_BROADCAST".

Upon reception of GET_DAQ_CLOCK_MULTICAST command, the XCP slave will respond an EV_TIME_SYNC event packet as defined in XCP Protocol Layer.

Parameters
clusterID | Cluster Identifier (Intel byte order = little endian)
counter | Counter (allows for consistency checks at XCP master)
Returns
The corresponding command result

◆ GetDAQEventInfo()

CmdResult GetDAQEventInfo | ( | ushort | eventChannelNo,
 |  | out RespGetDAQEventInfo | response
 | ) |  |

Get specific information for an event channel

Parameters
eventChannelNo | Event channel number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQID()

CmdResult GetDAQID | ( | ushort | daqListNo,
 |  | out bool | isFixed,
 |  | out uint | respCANID
 | ) |  |

Gets the CAN identifier used for the specified DAQ list.

  • With GetDAQID, the master can detect whether a DAQ list uses an individual CAN identifier and whether this Identifier is fixed or configurable.
  • This is XCPoverCAN specific.
Parameters
daqListNo | The DAQ list number
isFixed | true if the DAQ identifier is fixed to the DAQ list
respCANID | The configured CAN identifier
Returns
The corresponding command result

◆ GetDAQListInfo()

CmdResult GetDAQListInfo | ( | ushort | dAQListNo,
 |  | out RespGetDAQListInfo | response
 | ) |  |

Get specific information for a DAQ list

Parameters
dAQListNo | DAQ list number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQListMode()

CmdResult GetDAQListMode | ( | ushort | dAQListNo,
 |  | out RespGetDAQListMode | response
 | ) |  |

Get mode from DAQ list

Parameters
dAQListNo | DAQ list number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQListUSBEndpoint()

CmdResult GetDAQListUSBEndpoint | ( | ushort | dAQListNo,
 |  | out RespGetDAQListUSBEndpoint | response
 | ) |  |

Get DAQ List USB Endpoint.

Parameters
dAQListNo | DAQ list number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQProcessorInfo()

CmdResult GetDAQProcessorInfo ( out RespGetDAQProcessorInfo response )

Get general information on DAQ processor

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetDAQResolutionInfo()

CmdResult GetDAQResolutionInfo ( out RespGetDAQResolutionInfo response )

Get general information on DAQ processing resolution

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetID()

CmdResult GetID | ( | GetIDType | idType,
 |  | out RespGetID | response,
 |  | out byte[] | respData
 | ) |  |

Get identification from slave.

This command is used for automatic session configuration and for slave device identification.

Parameters
idType | The request type
response | may be null if mode is not supported!
respData | The uploaded data (only if the TRANSFER_MODE bit in RespGetID.Mode is set)
Returns
The corresponding command result

◆ getPaddingSize()

static int getPaddingSize ( int ag )
static

Gets the count of required padding bytes.

Parameters
ag The address granularity
Returns
the count of required padding bytes.

◆ GetPageInfo()

CmdResult GetPageInfo | ( | byte | segmentNo,
 |  | byte | pageNo,
 |  | out RespGetPageInfo | response
 | ) |  |

Get specific information for a PAGE

Parameters
segmentNo | The segment number
pageNo | The page number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetPAGProcessorInfo()

CmdResult GetPAGProcessorInfo ( out RespGetPAGProcessorInfo response )

Get general information on PAG processor

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetPGMProcessorInfo()

CmdResult GetPGMProcessorInfo ( out RespGetPGMProcessorInfo response )

Get general information on PGM processor

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSectorInfo() [1/2]

CmdResult GetSectorInfo | ( | GetSectorInfoMode | mode,
 |  | byte | sectorNo,
 |  | out RespGetSectorInfoModeAddressOrLen | response
 | ) |  |

Get specific information for a SECTOR

Parameters
mode
sectorNo | The sector number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentException Thrown if called with GetSectorInfoMode.NameLength

◆ GetSectorInfo() [2/2]

CmdResult GetSectorInfo | ( | GetSectorInfoMode | mode,
 |  | byte | sectorNo,
 |  | out RespGetSectorInfoModeSectorNameLen | response
 | ) |  |

Get specific information for a SECTOR

Parameters
mode
sectorNo | The sector number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result
Exceptions
ArgumentException Thrown if not called with GetSectorInfoMode.NameLength

◆ GetSeed()

CmdResult GetSeed | ( | SeedModeType | seedMode,
 |  | ResourceType | resource,
 |  | out RespGetSeed | response,
 |  | out byte[] | seed
 | ) |  |

Get seed for unlocking a protected resource

Parameters
seedMode | see XCP specification
resource | see XCP specification
response | The slave response (only valid if return value is CMDResult.OK, else null)
seed | The seed bytes (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSegmentInfo()

CmdResult GetSegmentInfo | ( | byte | segmentNo,
 |  | out RespGetSegmentInfo | response
 | ) |  |

Get specific information for a SEGMENT

Mode: get address mapping info for this SEGMENT

Parameters
segmentNo | The segment number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSegmentInfoAddress()

CmdResult GetSegmentInfoAddress | ( | BasicAddressModeType | basicAddressMode,
 |  | byte | segmentNo,
 |  | out RespGetSegmentInfoAddress | response
 | ) |  |

Get specific information for a SEGMENT

Mode: get basic address info for this SEGMENT.

Parameters
basicAddressMode | see XCP specification
segmentNo | The segment number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSegmentInfoMapping()

CmdResult GetSegmentInfoMapping | ( | MappingInfoModeType | mappingMode,
 |  | byte | segmentNo,
 |  | byte | mappingIndex,
 |  | out RespGetSegmentInfoAddress | response
 | ) |  |

Get specific information for a SEGMENT

Mode: get standard info for this SEGMENT

Parameters
mappingMode | The mapping mode
segmentNo | The segment number
mappingIndex | The mapping index
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetSegmentMode()

CmdResult GetSegmentMode | ( | byte | segmentNo,
 |  | out RespGetSegmentMode | response
 | ) |  |

Get mode for a SEGMENT

Parameters
segmentNo | The segment number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ GetStatus()

CmdResult GetStatus ( out RespGetStatus response )

Get current session status from slave.

This command returns all current status information of the slave device. This includes the status of the resource protection, pending store requests and the general status of data acquisition and stimulation.

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ internalConnect()

sealed override bool internalConnect ( )
virtual

Tries to connect to a XCP/CCP slave

Used by the CommKernel.

Returns
true if successful

Reimplemented from CommMaster.

◆ internalGetStatus()

sealed override bool internalGetStatus ( )
virtual

Get current session status from slave.

Used by the CommKernel.

Returns
true if successful

Implements CommMaster.

◆ ModifyBits()

CmdResult ModifyBits | ( | byte | s,
 |  | ushort | ma,
 |  | ushort | mx
 | ) |  |

Modify Bits on slave.

The 32 Bit memory location A referred by the MTA will be modified using the formula below: A = ((A) & ((~((uint) (((ushort)~MA) << S)))) ^ ((uint)(MX << S)))

The AND Mask(MA) specifies all the bits of A which have to be set to “0” by setting the corresponding bit in MA to “0” and all untouched bits to “1”. The XOR Mask(MX) specifies all bits of A which has to be toggled by setting the corresponding bit in MX to “1” and all untouched bits to “0”. To set bit 0 to “0”, use MA = 0xFFFE and MX = 0x0000. To set bit 0 to “1” first set it to “0” and then toggle it, so MA = 0xFFFE and MX = 0x0001. Via the masks MA and MX it is only possible to access a 16 bit wide memory location. Thus the shift parameter S is used to move both masks together with the specified number of bits into the more significant direction.

Parameters
s | Shift Value (S)
ma | AND Mask (MA)
mx | XOR Mask (MX)
Returns

◆ onDAQFrameReceived()

virtual void onDAQFrameReceived ( XCPFrame xcpFrame )
virtual

Called if a DAQ frame is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented in XCPMaster.

◆ onErrorReceived()

virtual void onErrorReceived | ( | CmdResult | result,
 |  | CommandCode | code
 | ) |  |
virtual

Called, if an error response is received from the slave.

Parameters
result | The command result
code | The corresponding command code

Reimplemented in XCPMaster.

◆ onEventReceived()

virtual void onEventReceived ( XCPFrame xcpFrame )
virtual

Called if an event is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented in XCPMaster.

◆ onServiceReceived()

virtual void onServiceReceived ( XCPFrame xcpFrame )
virtual

Called if an service request is received from the slave.

Parameters
xcpFrame The corresponding received frame

Reimplemented in XCPMaster.

◆ Program()

CmdResult Program | ( | byte | noOfDataElements,
 |  | byte[] | bytes
 | ) |  |

Program a non-volatile memory segment.

This command is used to program data inside the slave.

Parameters
noOfDataElements | The number of data elements
bytes | The bytes to program
Returns
The corresponding command result

◆ ProgramClear()

CmdResult ProgramClear | ( | ProgramClearMode | mode,
 |  | uint | clearRange
 | ) |  |

Clear a part of non-volatile memory

Parameters
mode | Access mode
clearRange | The Clear Range indicates the length of the memory part to be cleared.

The PROGRAM_CLEAR service clears a complete sector or multiple sectors at once.

Returns
The corresponding command result

◆ ProgramFormat()

CmdResult ProgramFormat | ( | byte | compressionMethod,
 |  | byte | encryptionMethod,
 |  | byte | programmingMethod,
 |  | byte | accessMethod
 | ) |  |

Set data format before programming

Parameters
compressionMethod | see XCP specification
encryptionMethod | see XCP specification
programmingMethod | see XCP specification
accessMethod | see XCP specification
Returns
The corresponding command result

◆ ProgramMax()

CmdResult ProgramMax ( byte[] bytes )

Program a non-volatile memory segment (fixed size)

Parameters
bytes The bytes to program
Returns
The corresponding command result

◆ ProgramNext()

CmdResult ProgramNext | ( | byte | noOfDataElements,
 |  | byte[] | bytes
 | ) |  |

Program a non-volatile memory segment.

This command is used to transmit consecutive data bytes for the PROGRAM command in block transfer mode.

Parameters
noOfDataElements | The number of data elements
bytes | The bytes to program
Returns
The corresponding command result

◆ ProgramPrepare()

CmdResult ProgramPrepare ( ushort codeSize )

Prepare non-volatile memory programming

Parameters
codeSize
Returns
The corresponding command result

◆ ProgramReset()

CmdResult ProgramReset ( )

Indicate the end of a programming sequence

This optional command indicates the end of a non-volatile memory programming sequence.It may or may not have a response.It either case, the slave device will go to the disconnected state. This command may be used to force a slave device reset for other purposes.

Returns
The corresponding command result

◆ ProgramStart()

CmdResult ProgramStart ( out RespProgramStart response )

DTO CTR Properties Indicate the beginning of a programming sequence

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ ProgramVerify()

CmdResult ProgramVerify | ( | ProgramVerifyMode | mode,
 |  | ushort | verificationType,
 |  | uint | verificationValue
 | ) |  |

Clear a part of non-volatile memory

Parameters
mode | Verification mode
verificationType | see XCP specification
verificationValue | see XCP specification
Returns
The corresponding command result

◆ ReadDAQ()

CmdResult ReadDAQ ( out RespReadDAQ response )

Read element from ODT entry

Parameters
response The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ resetLastError()

sealed override void resetLastError ( )
virtual

Reset the last error

Implements CommMaster.

◆ SetCalPage()

CmdResult SetCalPage | ( | CalPageMode | mode,
 |  | byte | segmentNo,
 |  | byte | pageNo
 | ) |  |

Set calibration page

Parameters
mode
segmentNo | Logical data segment number
pageNo | Logical data page number
Returns
The corresponding command result

◆ setConnectionState< T >()

override void setConnectionState< T > ( T respConnect )
virtual

Called from the XCPKernel if the connection state gets changed.

Parameters
respConnect A valid connect response instance if the device gets connected, null if the device gets disconnected.

Implements CommMaster.

◆ SetDAQID()

CmdResult SetDAQID | ( | ushort | daqListNo,
 |  | uint | CANID
 | ) |  |

Sets the CAN identifier to use for the specified DAQ list.

  • If the given identifier isn’t possible, the slave returns an ERR_OUT_OF_RANGE.
  • This is XCPoverCAN specific.
Parameters
daqListNo | The DAQ list number
CANID | The CAN identifier to configure
Returns
The corresponding command result

◆ SetDAQListMode()

CmdResult SetDAQListMode | ( | DAQListMode | mode,
 |  | ushort | daqListNo,
 |  | ushort | eventChannelNo,
 |  | byte | prescaler,
 |  | byte | priority
 | ) |  |

Set mode for DAQ list

Parameters
mode
daqListNo | DAQ list number
eventChannelNo | Event channel number
prescaler | see XCP specification
priority | see XCP specification
Returns
The corresponding command result

◆ SetDAQListUSBEndpoint()

CmdResult SetDAQListUSBEndpoint | ( | ushort | dAQListNo,
 |  | byte | endPointNo
 | ) |  |

Get DAQ List USB Endpoint.

Parameters
dAQListNo | DAQ list number
endPointNo | USB Endpoint of DTO dedicated to list number
Returns
The corresponding command result

◆ SetDAQPtr()

CmdResult SetDAQPtr | ( | ushort | DAQListNo,
 |  | byte | ODTNo,
 |  | byte | ODTEntryNo
 | ) |  |

Set pointer to ODT entry

Parameters
DAQListNo | DAQ list number
ODTNo | ODT number
ODTEntryNo | ODT entry number
Returns
The corresponding command result

◆ SetMTA()

CmdResult SetMTA | ( | byte | addressExtension,
 |  | uint | address
 | ) |  |

Set Memory Transfer Address in slave.

This command will initialize a pointer (32Bit address + 8Bit extension) for following memory transfer commands.

Parameters
addressExtension
address The
Returns
The corresponding command result

◆ SetRequest()

CmdResult SetRequest | ( | SetRequestMode | mode,
 |  | ushort | sessionId
 | ) |  |

Request to save to non-volatile memory

Parameters
mode
sessionId Session configuration id
Returns
The corresponding command result

◆ SetSegmentMode()

CmdResult SetSegmentMode | ( | SegmentMode | mode,
 |  | byte | segmentNo
 | ) |  |

Set mode for a SEGMENT

Parameters
mode
segmentNo The segment number
Returns
The corresponding command result

◆ ShortDownload()

CmdResult ShortDownload | ( | byte[] | bytes,
 |  | byte | addressExtension,
 |  | uint | address
 | ) |  |

Download from master to slave.

Parameters
bytes The data bytes to download
addressExtension
address
Returns
The corresponding command result
Exceptions
ArgumentOutOfRangeException Thrown if the length of bytes does not fit with the current address granularity

◆ ShortUpload()

CmdResult ShortUpload | ( | byte | numberOfElements,
 |  | byte | addressExtension,
 |  | uint | address,
 |  | out byte[] | respData
 | ) |  |

Upload from slave to master (short version).

A data block of the specified length, starting at address will be returned. The MTA pointer is set to the first data byte behind the uploaded data block. The error handling and the response structure is identical to the UPLOAD command.

The use of the proper address granularity is done automatically.

Parameters
numberOfElements | The count of elements to upload
addressExtension
address | The address to upload from
respData | The uploaded data
Returns
The corresponding command result

◆ StartStopDAQList()

CmdResult StartStopDAQList | ( | StartStopMode | mode,
 |  | ushort | dAQListNo,
 |  | out RespStartStopDAQList | response
 | ) |  |

Start/stop/select DAQ list

  • According to the specification, the FirstPID paramter in the response could be ignored in some cases.
  • On some ECUs the FirstPID is parameter seems to be completely missing in the response...
Parameters
mode
dAQListNo | DAQ list number
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ StartStopSynch()

CmdResult StartStopSynch ( StartStopMode mode )

Start/stop DAQ lists (synchronously)

Parameters
mode
Returns
The corresponding command result

◆ Synch()

CmdResult Synch ( )

Synchronize command execution after time-out.

This command is used to synchronize command execution after timeout conditions. The SYNCH command will always have a negative response with the error code ERR_CMD_SYNCH. There is no other command using this error code, therefore the response to a SYNCH command may be distinguished from the response to any other command.

Returns
The corresponding command result

◆ TimeCorrelationProperties()

CmdResult TimeCorrelationProperties | ( | TimeCorrSetProps | setProperties,
 |  | TimeCorrGetPropsReq | getPropertiesReq,
 |  | ushort | clusterID,
 |  | out RespTimeCorrelation | response
 | ) |  |

Time Correlation

This command allows obtaining general information regarding the synchronization status of the clocks available in the XCP slave as well as their characteristics.Also, the command provides all the functionality needed by the XCP master for configuration of XCP slave’s behaviour targeting advanced time correlation features.

Parameters
setProperties | Set properties
getPropertiesReq | Get properties request
clusterID | Cluster ID
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ TransportLayerCmd()

CmdResult TransportLayerCmd | ( | byte | subCommand,
 |  | byte[] | bytes,
 |  | out byte[] | respData,
 |  | int | useTimeout = -1
 | ) |  |

Refer to transport layer specific command.

  • This command is defined in the Transport Layer specification.
  • It is used to perform Transport Layer specific actions.
  • It is usually used on XCPoverCAN.
Parameters
subCommand | The subcommand
bytes | Additional bytes to send
respData | The uploaded data
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
The corresponding command result

◆ Unlock()

CmdResult Unlock | ( | byte[] | key,
 |  | ref int | offset,
 |  | out RespUnlock | response
 | ) |  |

Send key for unlocking a protected resource.

Call this method in consecutive calls until offset == key.Length!

Parameters
key | The computed key from the seed & key DLL
offset | The current offset (must be 0 on the first call!)
response | The slave response (only valid if return value is CMDResult.OK, else null)
Returns
The corresponding command result

◆ Upload()

CmdResult Upload | ( | byte | numberOfElements,
 |  | out byte[] | respData
 | ) |  |

Upload from slave to master.

A data block of the specified length, starting at the current MTA, will be returned. The MTA will be post-incremented by the given number of data elements.

The use of the proper address granularity is done automatically.

Parameters
numberOfElements | The count of elements to upload
respData | The uploaded data
Returns
The corresponding command result

◆ UserCmd()

CmdResult UserCmd | ( | byte | subCommand,
 |  | byte[] | bytes,
 |  | out byte[] | respData
 | ) |  |

Refer to user defined command.

This command is user defined. It mustn’t be used to implement functionalities done by other services.

Parameters
subCommand | The subcommand
bytes | Additional bytes to send
respData | The uploaded data
Returns
The corresponding command result

◆ WriteBytes()

CmdResult WriteBytes | ( | CommandCode | cmdCode,
 |  | byte[] | bytes,
 |  | byte | noOfDataElements = 0,
 |  | int | useTimeout = -1
 | ) |  |
protected

Write the specified byte array to the slave device with the specified command code.

Parameters
cmdCode | CommandCode to use
bytes | The byte array to write (This is the payload of the write command)
noOfDataElements | For CommandCode.DownloadMax, CommandCode.ProgramMax ignored For CommandCode.Program,CommandCode.Download,CommandCode.ProgramNext,CommandCode.DownloadNext the no of elements to write (may be greater than bytes.Length).
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
The corresponding command result
Exceptions
ArgumentException Thrown if cmdCode isn't one of the Program or Download commands

◆ WriteDAQ()

CmdResult WriteDAQ | ( | byte | bitOffset,
 |  | byte | elementSize,
 |  | byte | addressExtension,
 |  | uint | address
 | ) |  |

Write element in ODT entry

Parameters
bitOffset | see XCP specification
elementSize | see XCP specification
addressExtension | see XCP specification
address | see XCP specification
Returns
The corresponding command result

◆ WriteDAQMultiple()

CmdResult WriteDAQMultiple ( IList< ODTEntry > entries )

Write multiple elements in ODT.

This command is used to write consecutive ODT entries to a DAQ list defined by the DAQ list pointer (see SET_DAQ_PTR).

Parameters
entries The list of ODT entries to write
Returns
The corresponding command result


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPMasterBase
XCPMasterBase Member List

This is the complete list of members for XCPMasterBase, including all inherited members.

ActivePage | CommMaster |
addAdaptiveCharacteristics(A2LPROJECT project, List< IDataFile > dataFiles) | CommMaster |
Address | XCPMasterBase |
AllocDAQ(ushort dAQCount) | XCPMasterBase |
AllocODT(ushort dAQListNo, byte oDTCount) | XCPMasterBase |
AllocODTEntry(ushort dAQListNo, byte oDTNo, byte oDTEntriesCount) | XCPMasterBase |
BuildChecksum(uint blockSize, out RespBuildChecksum response) | XCPMasterBase |
CanWrite | CommMaster |
ChangeEndianess | CommMaster | protected
ClearDAQList(ushort dAQListNo) | XCPMasterBase |
CommMaster(ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf) | CommMaster |
configureMeasurements(IList< DAQMeasurement > measurements) | CommMaster | pure virtual
Connect(ConnectMode mode, out RespConnect response) | XCPMasterBase |
ConnectBehaviour | CommMaster |
Connected | CommMaster |
ConnectionStateChanged | CommMaster |
CopyCalPage(byte srcSegmentNo, byte srcPageNo, byte dstSegmentNo, byte dstPageNo) | XCPMasterBase |
copyPage2Page(ECUPage srcPage, ECUPage dstPage) | CommMaster | pure virtual
DAQs | CommMaster |
Disconnect(int useTimeout=-1) | XCPMasterBase | virtual
Dispose() | CommMaster | virtual
Download(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
DownloadMax(byte[] bytes) | XCPMasterBase |
DownloadNext(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
DtoCtrProperties(DTOCtrModifier modifier, ushort eventChannelNo, ushort relatedEventChannelNo, DTOCtrMode mode, out RespDTOCtrResp response) | XCPMasterBase |
epkCheck(A2LMOD_PAR modPar, out string epkFromDevice) | CommMaster |
epkCheck(uint epkAddress, string expectedEPK, out string epkFromDevice) | CommMaster |
ErrorsReceived | CommMaster |
EventsReceived | CommMaster |
FramesReceived | CommMaster |
FramesSent | CommMaster |
FreeDAQ() | XCPMasterBase |
getAliveCycleTime() | XCPMasterBase | virtual
GetCalPage(CalPageMode mode, byte segmentNo, out RespGetCALPage response) | XCPMasterBase |
getChecksum(byte addressExtension, uint address, uint size, out uint checksum) | CommMaster | pure virtual
GetCommModeInfo(out RespGetCommModeInfo response) | XCPMasterBase |
GetDAQClock(out RespGetDAQClock response) | XCPMasterBase |
GetDAQClockMulitcast(ushort clusterID, byte counter) | XCPMasterBase |
GetDAQEventInfo(ushort eventChannelNo, out RespGetDAQEventInfo response) | XCPMasterBase |
GetDAQID(ushort daqListNo, out bool isFixed, out uint respCANID) | XCPMasterBase |
GetDAQListInfo(ushort dAQListNo, out RespGetDAQListInfo response) | XCPMasterBase |
GetDAQListMode(ushort dAQListNo, out RespGetDAQListMode response) | XCPMasterBase |
GetDAQListUSBEndpoint(ushort dAQListNo, out RespGetDAQListUSBEndpoint response) | XCPMasterBase |
getDAQPhysValue(A2LMEASUREMENT measurement, out double value) | CommMaster |
getDAQPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | CommMaster |
GetDAQProcessorInfo(out RespGetDAQProcessorInfo response) | XCPMasterBase |
getDAQRawValue(A2LMEASUREMENT measurement, out double rawValue) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | CommMaster | virtual
GetDAQResolutionInfo(out RespGetDAQResolutionInfo response) | XCPMasterBase |
GetID(GetIDType idType, out RespGetID response, out byte[] respData) | XCPMasterBase |
getOperatingPoint(A2LCHARACTERISTIC characteristic) | CommMaster |
getPaddingSize(int ag) | XCPMasterBase | static
GetPageInfo(byte segmentNo, byte pageNo, out RespGetPageInfo response) | XCPMasterBase |
GetPAGProcessorInfo(out RespGetPAGProcessorInfo response) | XCPMasterBase |
GetPGMProcessorInfo(out RespGetPGMProcessorInfo response) | XCPMasterBase |
GetSectorInfo(GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeAddressOrLen response) | XCPMasterBase |
GetSectorInfo(GetSectorInfoMode mode, byte sectorNo, out RespGetSectorInfoModeSectorNameLen response) | XCPMasterBase |
GetSeed(SeedModeType seedMode, ResourceType resource, out RespGetSeed response, out byte[] seed) | XCPMasterBase |
GetSegmentInfo(byte segmentNo, out RespGetSegmentInfo response) | XCPMasterBase |
GetSegmentInfoAddress(BasicAddressModeType basicAddressMode, byte segmentNo, out RespGetSegmentInfoAddress response) | XCPMasterBase |
GetSegmentInfoMapping(MappingInfoModeType mappingMode, byte segmentNo, byte mappingIndex, out RespGetSegmentInfoAddress response) | XCPMasterBase |
GetSegmentMode(byte segmentNo, out RespGetSegmentMode response) | XCPMasterBase |
GetStatus(out RespGetStatus response) | XCPMasterBase |
getTransmissionRate(out double bitsPerSec) | CommMaster |
Interface | CommMaster |
internalConnect() | XCPMasterBase | virtual
internalGetStatus() | XCPMasterBase | virtual
LastErrorEnum (defined in XCPMasterBase) | XCPMasterBase |
LastErrorResponse | XCPMasterBase |
LastErrorText (defined in XCPMasterBase) | XCPMasterBase |
LastReceivedTime | CommMaster |
LastResponse | XCPMasterBase |
LastStateChange | CommMaster |
mAdaptiveCharDict | CommMaster | protected
mAG | XCPMasterBase | protected
mapAddress(uint address) | CommMaster | pure virtual
MaxCTO | XCPMasterBase |
MaxDTO | XCPMasterBase |
mBitsTransferred (defined in CommMaster) | CommMaster | protected
mDataFiles | CommMaster | protected
MeasurementAccessData | CommMaster |
ModifyBits(byte s, ushort ma, ushort mx) | XCPMasterBase |
mSeedAndKeyDLL (defined in CommMaster) | CommMaster | protected
mStrTrimmer | CommMaster | static
onDAQFrameReceived(XCPFrame xcpFrame) | XCPMasterBase | virtual
onErrorReceived(CmdResult result, CommandCode code) | XCPMasterBase | virtual
onEventReceived(XCPFrame xcpFrame) | XCPMasterBase | virtual
onServiceReceived(XCPFrame xcpFrame) | XCPMasterBase | virtual
OnValuesReceived | CommMaster |
Port | XCPMasterBase |
Program(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
ProgramClear(ProgramClearMode mode, uint clearRange) | XCPMasterBase |
ProgramFormat(byte compressionMethod, byte encryptionMethod, byte programmingMethod, byte accessMethod) | XCPMasterBase |
ProgramMax(byte[] bytes) | XCPMasterBase |
ProgramNext(byte noOfDataElements, byte[] bytes) | XCPMasterBase |
ProgramPrepare(ushort codeSize) | XCPMasterBase |
ProgramReset() | XCPMasterBase |
ProgramStart(out RespProgramStart response) | XCPMasterBase |
programSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null) | CommMaster | pure virtual
ProgramVerify(ProgramVerifyMode mode, ushort verificationType, uint verificationValue) | XCPMasterBase |
RaiseConnectionStateChanged() | CommMaster |
RaiseOnValuesReceived(int daqListNo, double seconds, byte[] data) | CommMaster |
readCharacteristic(ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
ReadDAQ(out RespReadDAQ response) | XCPMasterBase |
readSync(int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual
resetLastError() | XCPMasterBase | virtual
SeedAndKeyDLL | CommMaster |
ServicesReceived | CommMaster |
SetCalPage(CalPageMode mode, byte segmentNo, byte pageNo) | XCPMasterBase |
setConnectionState< T >(T respConnect) | XCPMasterBase | virtual
SetDAQID(ushort daqListNo, uint CANID) | XCPMasterBase |
SetDAQListMode(DAQListMode mode, ushort daqListNo, ushort eventChannelNo, byte prescaler, byte priority) | XCPMasterBase |
SetDAQListUSBEndpoint(ushort dAQListNo, byte endPointNo) | XCPMasterBase |
SetDAQPtr(ushort DAQListNo, byte ODTNo, byte ODTEntryNo) | XCPMasterBase |
SetMTA(byte addressExtension, uint address) | XCPMasterBase |
setPage(ECUPage page) | CommMaster | pure virtual
SetRequest(SetRequestMode mode, ushort sessionId) | XCPMasterBase |
SetSegmentMode(SegmentMode mode, byte segmentNo) | XCPMasterBase |
ShortDownload(byte[] bytes, byte addressExtension, uint address) | XCPMasterBase |
ShortUpload(byte numberOfElements, byte addressExtension, uint address, out byte[] respData) | XCPMasterBase |
startMeasurements(bool doSynchronized) | CommMaster | pure virtual
StartStopDAQList(StartStopMode mode, ushort dAQListNo, out RespStartStopDAQList response) | XCPMasterBase |
StartStopSynch(StartStopMode mode) | XCPMasterBase |
stopMeasurements(bool doSynchronized) | CommMaster | pure virtual
Synch() | XCPMasterBase |
TimeCorrelationProperties(TimeCorrSetProps setProperties, TimeCorrGetPropsReq getPropertiesReq, ushort clusterID, out RespTimeCorrelation response) | XCPMasterBase |
Timings | XCPMasterBase |
TransportLayerCmd(byte subCommand, byte[] bytes, out byte[] respData, int useTimeout=-1) | XCPMasterBase |
Type | XCPMasterBase |
Unlock(byte[] key, ref int offset, out RespUnlock response) | XCPMasterBase |
Upload(byte numberOfElements, out byte[] respData) | XCPMasterBase |
UserCmd(byte subCommand, byte[] bytes, out byte[] respData) | XCPMasterBase |
WriteBytes(CommandCode cmdCode, byte[] bytes, byte noOfDataElements=0, int useTimeout=-1) | XCPMasterBase | protected
writeCharacteristic(IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
WriteDAQ(byte bitOffset, byte elementSize, byte addressExtension, uint address) | XCPMasterBase |
WriteDAQMultiple(IList< ODTEntry > entries) | XCPMasterBase |
writeSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual
XCPMasterBase(ConnectBehaviourType connectBehavior, XCPType type, string remoteAddress, int remotePort, A2LXCP_PROTOCOL_LAYER protocolLayer) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_CAN xcpCAN, A2LXCP_PROTOCOL_LAYER protocolLayer, string canProviderName) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_SxI xcpSxI, A2LXCP_PROTOCOL_LAYER protocolLayer, string comPort) | XCPMasterBase |
XCPMasterBase(ConnectBehaviourType connectBehavior, A2LXCP_ON_USB xcpUSB, A2LXCP_PROTOCOL_LAYER protocolLayer) | XCPMasterBase |


ASAP2Library interface: XCPonEth Class Reference

  • Comm
  • XCP
  • XCPonEth
Protected Member Functions | Protected Attributes | List of all members
XCPonEth Class Reference

Base class implementing the XCP on ethernet based communication instance. More...

Protected Member Functions

XCPonEth (XCPMaster master, IPEndPoint slave)
Creates a new instance of XCPonEth. More...
sealed override bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from XCPCommunicator
void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...
- Protected Member Functions inherited from Communicator
virtual void | close ()
Closes the communication (frees all used resources). More...

Protected Attributes

readonly XCPReceiveBuffer | mReceivedBuffer
IPEndPoint | Slave
- Protected Attributes inherited from XCPCommunicator
readonly XCPMaster | mMaster
Holds the corresponding XCP master instance.

Additional Inherited Members

- Public Member Functions inherited from XCPCommunicator
override void | Dispose ()
Disposes all used resources. More...
- Public Attributes inherited from XCPCommunicator
readonly XCP_HEADER_LEN | FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)

Detailed Description

Base class implementing the XCP on ethernet based communication instance.

Constructor & Destructor Documentation

◆ XCPonEth()

XCPonEth | ( | XCPMaster | master,
 |  | IPEndPoint | slave
 | ) |  |
protected

Creates a new instance of XCPonEth.

Parameters
master | The corresponding master instance
slave | The XCP slave

Member Function Documentation

◆ getFrameFromData()

sealed override bool getFrameFromData | ( | XCPType | type,
 |  | string | source,
 |  | byte[] | data,
 |  | out XCPFrame | frame
 | ) |  |
protectedvirtual

Gets an XCP frame from the specified data.

Parameters
type | The XCP type
source | The data source
data | The data itself
frame | The resulting frame (only valid if return value is true)
Returns
true if a valid frame is built

Implements XCPCommunicator.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPonEth
XCPonEth Member List

This is the complete list of members for XCPonEth, including all inherited members.

close() | Communicator | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPonEth | protectedvirtual
mMaster | XCPCommunicator | protected
mReceivedBuffer (defined in XCPonEth) | XCPonEth | protected
Slave (defined in XCPonEth) | XCPonEth | protected
XCPonEth(XCPMaster master, IPEndPoint slave) | XCPonEth | protected


ASAP2Library interface: XCPOnSxI Class Reference

  • Comm
  • XCP
  • XCPOnSxI
Protected Member Functions | List of all members
XCPOnSxI Class Reference

Implements the XCP on SxI based communication instance. More...

Protected Member Functions

override void | close ()
Implement closing the USB interface here. More...
override bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from XCPCommunicator
void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...

Additional Inherited Members

- Public Member Functions inherited from XCPCommunicator
override void | Dispose ()
Disposes all used resources. More...
- Public Attributes inherited from XCPCommunicator
readonly XCP_HEADER_LEN | FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)
- Protected Attributes inherited from XCPCommunicator
readonly XCPMaster | mMaster
Holds the corresponding XCP master instance.

Detailed Description

Implements the XCP on SxI based communication instance.

Member Function Documentation

◆ close()

override void close ( )
protectedvirtual

Implement closing the USB interface here.

Reimplemented from Communicator.

◆ getFrameFromData()

override bool getFrameFromData | ( | XCPType | type,
 |  | string | source,
 |  | byte[] | data,
 |  | out XCPFrame | frame
 | ) |  |
protectedvirtual

Gets an XCP frame from the specified data.

Parameters
type | The XCP type
source | The data source
data | The data itself
frame | The resulting frame (only valid if return value is true)
Returns
true if a valid frame is built

Implements XCPCommunicator.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPOnSxI
XCPOnSxI Member List

This is the complete list of members for XCPOnSxI, including all inherited members.

close() | XCPOnSxI | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPOnSxI | protectedvirtual
mMaster | XCPCommunicator | protected


ASAP2Library interface: XCPonTCP Class Reference

  • Comm
  • XCP
  • XCPonTCP
Protected Member Functions | List of all members
XCPonTCP Class Reference

Implements the TCP based XCP communication. More...

Protected Member Functions

override void | close ()
Closes the communication (frees all used resources). More...
- Protected Member Functions inherited from XCPonEth
XCPonEth (XCPMaster master, IPEndPoint slave)
Creates a new instance of XCPonEth. More...
sealed override bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from XCPCommunicator
void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...

Additional Inherited Members

- Public Member Functions inherited from XCPCommunicator
override void | Dispose ()
Disposes all used resources. More...
- Public Attributes inherited from XCPCommunicator
readonly XCP_HEADER_LEN | FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)
- Protected Attributes inherited from XCPonEth
readonly XCPReceiveBuffer | mReceivedBuffer
IPEndPoint | Slave
- Protected Attributes inherited from XCPCommunicator
readonly XCPMaster | mMaster
Holds the corresponding XCP master instance.

Detailed Description

Implements the TCP based XCP communication.

Member Function Documentation

◆ close()

override void close ( )
protectedvirtual

Closes the communication (frees all used resources).

  • Any derived class has to implement this method.

Reimplemented from Communicator.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPonTCP
XCPonTCP Member List

This is the complete list of members for XCPonTCP, including all inherited members.

close() | XCPonTCP | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPonEth | protectedvirtual
mMaster | XCPCommunicator | protected
mReceivedBuffer (defined in XCPonEth) | XCPonEth | protected
Slave (defined in XCPonEth) | XCPonEth | protected
XCPonEth(XCPMaster master, IPEndPoint slave) | XCPonEth | protected


ASAP2Library interface: XCPonUDP Class Reference

  • Comm
  • XCP
  • XCPonUDP
Public Member Functions | Protected Member Functions | List of all members
XCPonUDP Class Reference

Implements the UDP based XCP communication. More...

Public Member Functions

XCPonUDP (XCPMaster master, IPEndPoint slave)
Creates a new instance of XCPonUDP. More...
- Public Member Functions inherited from XCPCommunicator
override void Dispose ()
Disposes all used resources. More...

Protected Member Functions

override void | close ()
Closes the communication (frees all used resources). More...
- Protected Member Functions inherited from XCPonEth
XCPonEth (XCPMaster master, IPEndPoint slave)
Creates a new instance of XCPonEth. More...
sealed override bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from XCPCommunicator
void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...

Additional Inherited Members

- Public Attributes inherited from XCPCommunicator
readonly XCP_HEADER_LEN | FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)
- Protected Attributes inherited from XCPonEth
readonly XCPReceiveBuffer | mReceivedBuffer
IPEndPoint | Slave
- Protected Attributes inherited from XCPCommunicator
readonly XCPMaster | mMaster
Holds the corresponding XCP master instance.

Detailed Description

Implements the UDP based XCP communication.

Constructor & Destructor Documentation

◆ XCPonUDP()

XCPonUDP | ( | XCPMaster | master,
 |  | IPEndPoint | slave
 | ) |  |

Creates a new instance of XCPonUDP.

Parameters
master | The corresponding master instance
slave | The XCP slave

Member Function Documentation

◆ close()

override void close ( )
protectedvirtual

Closes the communication (frees all used resources).

  • Any derived class has to implement this method.

Reimplemented from Communicator.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPonUDP
XCPonUDP Member List

This is the complete list of members for XCPonUDP, including all inherited members.

close() | XCPonUDP | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPonEth | protectedvirtual
mMaster | XCPCommunicator | protected
mReceivedBuffer (defined in XCPonEth) | XCPonEth | protected
Slave (defined in XCPonEth) | XCPonEth | protected
XCPonEth(XCPMaster master, IPEndPoint slave) | XCPonEth | protected
XCPonUDP(XCPMaster master, IPEndPoint slave) | XCPonUDP |


ASAP2Library interface: XCPOnUSB Class Reference

  • Comm
  • XCP
  • XCPOnUSB
Protected Member Functions | List of all members
XCPOnUSB Class Reference

Implements the XCP on USB based communication instance. More...

Protected Member Functions

override void | close ()
Implement closing the USB interface here. More...
override bool | getFrameFromData (XCPType type, string source, byte[] data, out XCPFrame frame)
Gets an XCP frame from the specified data. More...
- Protected Member Functions inherited from XCPCommunicator
void | dataReceived (string source, byte[] buffer)
Called from the receive thread, when data is received. More...

Additional Inherited Members

- Public Member Functions inherited from XCPCommunicator
override void | Dispose ()
Disposes all used resources. More...
- Public Attributes inherited from XCPCommunicator
readonly XCP_HEADER_LEN | FrameFmt
Gets the frame format depending on the XCP Media used (CAN, Ethernet, USB)
- Protected Attributes inherited from XCPCommunicator
readonly XCPMaster | mMaster
Holds the corresponding XCP master instance.

Detailed Description

Implements the XCP on USB based communication instance.

Member Function Documentation

◆ close()

override void close ( )
protectedvirtual

Implement closing the USB interface here.

Reimplemented from Communicator.

◆ getFrameFromData()

override bool getFrameFromData | ( | XCPType | type,
 |  | string | source,
 |  | byte[] | data,
 |  | out XCPFrame | frame
 | ) |  |
protectedvirtual

Gets an XCP frame from the specified data.

Parameters
type | The XCP type
source | The data source
data | The data itself
frame | The resulting frame (only valid if return value is true)
Returns
true if a valid frame is built

Implements XCPCommunicator.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPOnUSB
XCPOnUSB Member List

This is the complete list of members for XCPOnUSB, including all inherited members.

close() | XCPOnUSB | protectedvirtual
dataReceived(string source, byte[] buffer) | XCPCommunicator | protected
Dispose() | XCPCommunicator | virtual
FrameFmt | XCPCommunicator |
getFrameFromData(XCPType type, string source, byte[] data, out XCPFrame frame) | XCPOnUSB | protectedvirtual
mMaster | XCPCommunicator | protected


ASAP2Library interface: XCPReceiveBuffer Class Reference

  • Comm
  • XCP
  • XCPReceiveBuffer
Public Member Functions | List of all members
XCPReceiveBuffer Class Reference

Implements a receive buffer for XCP frames. More...

Public Member Functions

XCPReceiveBuffer (A2LXCP_ON_SxI sxI)
Creates a new instance of XCPReceiveBuffer. More...
XCPReceiveBuffer (XCP_HEADER_LEN frameFmt=XCP_HEADER_LEN.CTR_WORD, XCP_ALIGNMENT alignment=XCP_ALIGNMENT._8_BIT)
Creates a new instance of XCPReceiveBuffer. More...
bool | getFrameFromData (XCPType type, string source, IEnumerable< byte > data, out XCPFrame frame)
Delivers a frame as long as enough data is in buffer. More...
void | reset ()
Resets the buffer (clean). More...

Detailed Description

Implements a receive buffer for XCP frames.

On calling XCPReceiveBuffer.getFrameFromData a valid frame from received data may be decoded.

Constructor & Destructor Documentation

◆ XCPReceiveBuffer() [1/2]

XCPReceiveBuffer | ( | XCP_HEADER_LEN | frameFmt = XCP_HEADER_LEN.CTR_WORD,
 |  | XCP_ALIGNMENT | alignment = XCP_ALIGNMENT._8_BIT
 | ) |  |

Creates a new instance of XCPReceiveBuffer.

Parameters
frameFmt | Header format (Only valid for XCPonEthernet, XCPonUSB).
alignment | Alignment for XCPonUSB messages

◆ XCPReceiveBuffer() [2/2]

XCPReceiveBuffer ( A2LXCP_ON_SxI sxI )

Creates a new instance of XCPReceiveBuffer.

Parameters
sxI Sxi configuration

Member Function Documentation

◆ getFrameFromData()

bool getFrameFromData | ( | XCPType | type,
 |  | string | source,
 |  | IEnumerable< byte > | data,
 |  | out XCPFrame | frame
 | ) |  |

Delivers a frame as long as enough data is in buffer.

  • If a frame could not be built (missing data) the supplied data is taken into an internal buffer for the next call.
Parameters
type | The XCP type
source | The source from where the frame is received (may be null)
data | The data to build the frame from
frame | The built XCP frame
Returns
true if a valid frame is built

◆ reset()

void reset ( )

Resets the buffer (clean).

Maybe this is appropriate if connection is lost.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPReceiveBuffer
XCPReceiveBuffer Member List

This is the complete list of members for XCPReceiveBuffer, including all inherited members.

getFrameFromData(XCPType type, string source, IEnumerable< byte > data, out XCPFrame frame) | XCPReceiveBuffer
reset() | XCPReceiveBuffer
XCPReceiveBuffer(XCP_HEADER_LEN frameFmt=XCP_HEADER_LEN.CTR_WORD, XCP_ALIGNMENT alignment=XCP_ALIGNMENT._8_BIT) | XCPReceiveBuffer
XCPReceiveBuffer(A2LXCP_ON_SxI sxI) | XCPReceiveBuffer


ASAP2Library interface: XCPServiceRequestArgs Class Reference

  • Comm
  • XCP
  • XCPServiceRequestArgs
Public Attributes | List of all members
XCPServiceRequestArgs Class Reference

EventArgs class delivering received events. More...

Public Attributes

readonly RespService ReceivedServiceRequest
Gets the received XCP event.

Detailed Description

EventArgs class delivering received events.

To access data For specific events, simply cast the ReceivedEvent according the corresponding EventCodes.


ASAP2Library interface: Member List

  • Comm
  • XCP
  • XCPServiceRequestArgs
XCPServiceRequestArgs Member List

This is the complete list of members for XCPServiceRequestArgs, including all inherited members.

ReceivedServiceRequest XCPServiceRequestArgs


ASAP2Library interface: CommKernel Class Reference

  • Comm
  • CommKernel
Static Public Member Functions | List of all members
CommKernel Class Reference

Implements the Communication kernel. More...

Static Public Member Functions

static void | DeregisterClient (CommMaster master)
Deregisters a Master from communication. More...
static bool | IsRegistered (CommMaster commMaster)
Gets a value indicating if the specified master is currently registered for communication. More...
static void | RegisterClient (CommMaster master)
Registers a new CCP/XCPMaster for communication. More...

Detailed Description

Implements the Communication kernel.

  • Steering of communication of several (XCP/CCP) Master's with their slaves
  • (XCP/CCP) Master instances get registered for communication with XCPKernel.RegisterClient
  • (XCP/CCP) Master instances created with ConnectBehaviourType.Automatic get connected and kept alive (by XCPMaster.GetStatus calls) automatically .

Member Function Documentation

◆ DeregisterClient()

static void DeregisterClient ( CommMaster master )
static

Deregisters a Master from communication.

If the master is connected, a disconnect will be sent before closing communication.

Parameters
master The instance to remove from communication

◆ IsRegistered()

static bool IsRegistered ( CommMaster commMaster )
static

Gets a value indicating if the specified master is currently registered for communication.

Parameters
commMaster The XCP/CCP master instance
Returns
true if the specified master is currently registered for communication.

◆ RegisterClient()

static void RegisterClient ( CommMaster master )
static

Registers a new CCP/XCPMaster for communication.

Parameters
master The instance to register for communication
Exceptions
InvalidOperationException Thrown if xcpMaster is already registered


ASAP2Library interface: Member List

  • Comm
  • CommKernel
CommKernel Member List

This is the complete list of members for CommKernel, including all inherited members.

DeregisterClient(CommMaster master) | CommKernel | static
IsRegistered(CommMaster commMaster) | CommKernel | static
RegisterClient(CommMaster master) | CommKernel | static


ASAP2Library interface: CommMaster Class Reference

  • Comm
  • CommMaster
Public Member Functions | Static Public Attributes | Protected Attributes | Properties | Events | List of all members
CommMaster Class Referenceabstract

Base class for both XCP and CCP master. More...

Public Member Functions

CommMaster (ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf)
Creates a communication master. More...
void | addAdaptiveCharacteristics (A2LPROJECT project, List< IDataFile > dataFiles)
Adds all defined adaptive characteristics to the adaptive characteristic list. More...
abstract void | configureMeasurements (IList< DAQMeasurement > measurements)
(Re)Configures the specified measurements for data acquisition. More...
abstract bool | copyPage2Page (ECUPage srcPage, ECUPage dstPage)
Copy data from one ECU page to another. More...
abstract bool | Disconnect (int useTimeout=-1)
Disconnects the master from the slave. More...
virtual void | Dispose ()
Frees used resources. More...
EPKCheckResult | epkCheck (A2LMOD_PAR modPar, out string epkFromDevice)
Online EPK check. More...
EPKCheckResult | epkCheck (uint epkAddress, string expectedEPK, out string epkFromDevice)
Online EPK check. More...
abstract int | getAliveCycleTime ()
Gets the alive cycle time in [ms]. More...
abstract bool | getChecksum (byte addressExtension, uint address, uint size, out uint checksum)
Get the checksum from the slave. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, int x, int y, out double value)
Gets the last received physical value for the specified measurement address. More...
bool | getDAQPhysValue (A2LMEASUREMENT measurement, out double value)
Gets the last received physical value for the specified measurement address. More...
virtual bool | getDAQRawValue (A2LMEASUREMENT measurement, int x, int y, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
bool | getDAQRawValue (A2LMEASUREMENT measurement, out double rawValue)
Gets the last received raw value for the specified measurement address. More...
double[] | getOperatingPoint (A2LCHARACTERISTIC characteristic)
Returns an array of operating points if available. More...
void | getTransmissionRate (out double bitsPerSec)
Gets the current transmission rate. More...
virtual bool | internalConnect ()
Tries to connect to a XCP/CCP slave More...
abstract bool | internalGetStatus ()
Get current session status from slave. More...
abstract uint | mapAddress (uint address)
Maps the specified address using A2L defined mapping tables. More...
abstract bool | programSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null)
Program data synchronously to the ECU. More...
void | RaiseConnectionStateChanged ()
Raises the ConnectionStateChanged event.
void | RaiseOnValuesReceived (int daqListNo, double seconds, byte[] data)
Raises the OnValuesReceived event with the pecified parameters. More...
bool | readCharacteristic (ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null)
Read the characteristic value from the ECU into the specified datafile. More...
abstract bool | readSync (int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Read data synchronously from the ECU. More...
abstract void | resetLastError ()
Reset the last error More...
abstract void | setConnectionState< T > (T respConnect)
Called if a a valid connect response is received. More...
abstract bool | setPage (ECUPage page)
Sets the specified page as active page. More...
abstract bool | startMeasurements (bool doSynchronized)
Starts a (previously configured by configureMeasurements) data acquisition. More...
abstract bool | stopMeasurements (bool doSynchronized)
Stops a running data acquisition. More...
bool | writeCharacteristic (IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null)
Write the characteristic value read from the specified datafile to the device. More...
abstract bool | writeSync (byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Write data synchronously to the ECU. More...

Static Public Attributes

static readonly char[] mStrTrimmer = new char[] { '\0', '\xFF', ' ' }
Used to trim EPK or ID strings.

Protected Attributes

IDictionary< ulong, AdaptiveState > | mAdaptiveCharDict = new Dictionary<ulong, AdaptiveState>()
The adaptive characteristics dictionary.
long | mBitsTransferred
List< IDataFile > | mDataFiles
The list of data files to write adaptive characteristics into.
NativeSKDLL | mSeedAndKeyDLL

Properties

abstract ECUPage | ActivePage [get]
The currently active calibration page More...
abstract bool | CanWrite [get]
Indicates if writing to the XCP/CCP mmaster is allowed. More...
bool | ChangeEndianess [getset]
Indicates if XCP Master and Slave byte orders differ. More...
ConnectBehaviourType | ConnectBehaviour [getset]
Gets or sets the connection behavior.
virtual bool | Connected [getprotected set]
Indicates, if the master is connected to the slave device.
DAQDict | DAQs [getprotected set]
The configured DAQ dictionary.
ulong | ErrorsReceived [getprotected set]
The amount of errors received since connection is established.
ulong | EventsReceived [getprotected set]
The amount of events received since connection is established.
ulong | FramesReceived [getprotected set]
The amount of frames received since connection is established.
ulong | FramesSent [getprotected set]
The amount of frames sent since connection is established.
A2LIF_DATA | Interface [get]
Gets the corresponding A2L communication interface.
abstract Enum | LastErrorEnum [get]
Gets the last error occured as enum.
abstract string | LastErrorText [get]
Gets the last error occured as text.
long | LastReceivedTime [getprotected set]
Indicates the timestamp the last byte was received from a slave.
DateTime | LastStateChange [getprotected set]
Returns the last state change (DateTime.MinValue if never changed).
ASAP2.Values.MeasurementAccessData | MeasurementAccessData [getset]
Gets or sets the measurement access data.
NativeSKDLL | SeedAndKeyDLL [getset]
Gets or sets the Seed&Key DLL.
ulong | ServicesReceived [getprotected set]
The amount of service requests received since connection is established.

Events

EventHandler | ConnectionStateChanged
Called if a XCP/CCP connection state changes. More...
EventHandler< ValuesReceivedEventArgs > | OnValuesReceived
Called if a XCP/CCP data acquisition data is received. More...

Detailed Description

Base class for both XCP and CCP master.

Provides common XCP/CCP functions.

Constructor & Destructor Documentation

◆ CommMaster()

CommMaster | ( | ConnectBehaviourType | connectBehaviour,
 |  | A2LIF_DATA | srcIf
 | ) |  |

Creates a communication master.

Parameters
connectBehaviour | Client's connect behavior
srcIf | The used A2L interface (may be null)

Member Function Documentation

◆ addAdaptiveCharacteristics()

void addAdaptiveCharacteristics | ( | A2LPROJECT | project,
 |  | List< IDataFile > | dataFiles
 | ) |  |

Adds all defined adaptive characteristics to the adaptive characteristic list.

  • Adaptive characteristics gets cyclically refreshed by the Master.
  • The refresh time is defined by the MaxRefreshUnit and MaxRefreshRate members on a characteristic.
Parameters
project | The project containing refreshable characteristics
dataFiles | The list of datafiles to write the values read to

◆ configureMeasurements()

abstract void configureMeasurements ( IList< DAQMeasurement > measurements )
pure virtual

(Re)Configures the specified measurements for data acquisition.

  • Interface is changed to accept now an array index and DAQ prset evnets with a measurement.
  • Use A2LMEASUREMENT.buildDAQMeasurements() to keep up with the previous interface.
  • A potentially existing configuration will be deleted.
Parameters
measurements [in/out] The measurement list (including an measurement array index and predefined events) to be configured, successfully configured measurements will be removed from this list after the call is completed.
Exceptions
ArgumentOutOfRangeException Thrown, if an measurement array index is out of range

Implemented in CCPMaster, and XCPMaster.

◆ copyPage2Page()

abstract bool copyPage2Page | ( | ECUPage | srcPage,
 |  | ECUPage | dstPage
 | ) |  |
pure virtual

Copy data from one ECU page to another.

Parameters
srcPage | The page to copy data from
dstPage | The page to copy data to
Returns
true if successful
Exceptions
ArgumentException Thrown, if srcPage == dstPage

Implemented in CCPMaster, and XCPMaster.

◆ Disconnect()

abstract bool Disconnect ( int useTimeout = -1 )
pure virtual

Disconnects the master from the slave.

Parameters
useTimeout
  • -1 - for standard timeout and wait for response
  • 0 - don't wait for any response (used for Master Block Mode)
  • greater than 0 - timeout in [ms] to wait for an response
Returns
true if successful

Implemented in CCPMaster, CCPMasterBase, XCPMaster, and XCPMasterBase.

◆ Dispose()

virtual void Dispose ( )
virtual

Frees used resources.

Potentially existing Seed and Key DLLs are unloaded here.

Reimplemented in CCPMaster, and XCPMaster.

◆ epkCheck() [1/2]

EPKCheckResult epkCheck | ( | A2LMOD_PAR | modPar,
 |  | out string | epkFromDevice
 | ) |  |

Online EPK check.

Checks the expected EPK from the specified MODPAR node against the device stored EPK.

Parameters
modPar | The A2L MODPAR node
epkFromDevice | Received EPK from device (may be null)
Returns
EPK check result

◆ epkCheck() [2/2]

EPKCheckResult epkCheck | ( | uint | epkAddress,
 |  | string | expectedEPK,
 |  | out string | epkFromDevice
 | ) |  |

Online EPK check.

Checks the expected EPK (usually defined in the A2L MODPAR node), against the device stored EPK.

Parameters
epkAddress | Address to upload from
expectedEPK | expected EPK (usually defined in A2L MODPAR)
epkFromDevice | Received EPK from device (may be null)
Returns
EPK check result

◆ getAliveCycleTime()

abstract int getAliveCycleTime ( )
pure virtual

Gets the alive cycle time in [ms].

Returns

Implemented in CCPMasterBase, and XCPMasterBase.

◆ getChecksum()

abstract bool getChecksum | ( | byte | addressExtension,
 |  | uint | address,
 |  | uint | size,
 |  | out uint | checksum
 | ) |  |
pure virtual

Get the checksum from the slave.

Parameters
addressExtension | The segment's address extension
address | The start address
size | The size of the data block to build the checksum over
checksum | The resulting checksum
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ getDAQPhysValue() [1/2]

bool getDAQPhysValue | ( | A2LMEASUREMENT | measurement,
 |  | int | x,
 |  | int | y,
 |  | out double | value
 | ) |  |

Gets the last received physical value for the specified measurement address.

This is the version for an A2LMEASUREMENT with ARRAY_SIZE > 1 or a MATRIX_DIM specification.

Parameters
measurement | The measurement to get the physical value for
x | The column
y | The row
value | [out] the value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getDAQPhysValue() [2/2]

bool getDAQPhysValue | ( | A2LMEASUREMENT | measurement,
 |  | out double | value
 | ) |  |

Gets the last received physical value for the specified measurement address.

Parameters
measurement | The measurement to get the raw value for
value | [out] the value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getDAQRawValue() [1/2]

virtual bool getDAQRawValue | ( | A2LMEASUREMENT | measurement,
 |  | int | x,
 |  | int | y,
 |  | out double | rawValue
 | ) |  |
virtual

Gets the last received raw value for the specified measurement address.

This is the version for an A2LMEASUREMENT with ARRAY_SIZE > 1 or a MATRIX_DIM specification.

Parameters
measurement | The measurement to get the raw value for
x | The column
y | The row
rawValue | [out] the raw value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getDAQRawValue() [2/2]

bool getDAQRawValue | ( | A2LMEASUREMENT | measurement,
 |  | out double | rawValue
 | ) |  |

Gets the last received raw value for the specified measurement address.

Parameters
measurement | The measurement to get the raw value for
rawValue | [out] the raw value (double.NaN if not measured)
Returns
true if the value is measured, else false

◆ getOperatingPoint()

double[] getOperatingPoint ( A2LCHARACTERISTIC characteristic )

Returns an array of operating points if available.

  • Current values of axis input measurements are returned
  • This means that the axis input measurements must be measured when calling this function
  • Only curves, maps and cube's are supported.
Parameters
characteristic The characteristic to get the operating point for
Returns
null if not supported or not available (not measuring), else an array of values (length is depending on the axis count)

◆ getTransmissionRate()

void getTransmissionRate ( out double bitsPerSec )

Gets the current transmission rate.

  • Needs at least two calls in activated state to get correct values.
Parameters
bitsPerSec Gets the count of bits transferred per second

◆ internalConnect()

virtual bool internalConnect ( )
virtual

Tries to connect to a XCP/CCP slave

Used by the CommKernel.

Returns
true if successful

Reimplemented in CCPMasterBase, and XCPMasterBase.

◆ internalGetStatus()

abstract bool internalGetStatus ( )
pure virtual

Get current session status from slave.

Used by the CommKernel.

Returns
true if successful

Implemented in CCPMasterBase, and XCPMasterBase.

◆ mapAddress()

abstract uint mapAddress ( uint address )
pure virtual

Maps the specified address using A2L defined mapping tables.

Parameters
address The address to translate
Returns
the translated or address

Implemented in CCPMaster, and XCPMaster.

◆ programSync()

abstract bool programSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null,
 |  | XCPPrgParams | modes = null
 | ) |  |
pure virtual

Program data synchronously to the ECU.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to program
progressHandler | Callback to receive progress, maybe null
modes | Additional (XCP) programming parameters
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ RaiseOnValuesReceived()

void RaiseOnValuesReceived | ( | int | daqListNo,
 |  | double | seconds,
 |  | byte[] | data
 | ) |  |

Raises the OnValuesReceived event with the pecified parameters.

Parameters
daqListNo | Unique DAQ list number (or MDF Writer handle)
seconds | The timestamp
data | The data received

◆ readCharacteristic()

bool readCharacteristic | ( | ECUPage | pageToReadFrom,
 |  | IDataFile | dataFile,
 |  | A2LRECORD_LAYOUT_REF | layoutRef,
 |  | bool | readAxisRefs = true,
 |  | IList< string > | criterionValues = null
 | ) |  |

Read the characteristic value from the ECU into the specified datafile.

Parameters
pageToReadFrom | ECU page to read from
dataFile | The datafile to write the data into
layoutRef | The characteristic to read
readAxisRefs | true, if referenced AxisPts should be read, too
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ readSync()

abstract bool readSync | ( | int | len,
 |  | byte | addressExtension,
 |  | uint | address,
 |  | out byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
pure virtual

Read data synchronously from the ECU.

Parameters
len | The length to read
addressExtension | The address extension
address | The address to read from (If the adress is uint.MaxValue, the data should be read from the current MTA location)
data | The resulting data (completely valid, if return value is CmdResult.OK else it may be null or only partly available)
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ resetLastError()

abstract void resetLastError ( )
pure virtual

Reset the last error

Implemented in CCPMasterBase, and XCPMasterBase.

◆ setConnectionState< T >()

abstract void setConnectionState< T > ( T respConnect )
pure virtual

Called if a a valid connect response is received.

Template Parameters
T Connection type (XCP or CCP)
Parameters
respConnect The connect response

Implemented in CCPMaster, CCPMasterBase, XCPMaster, and XCPMasterBase.

Type Constraints
T : IResponse

◆ setPage()

abstract bool setPage ( ECUPage page )
pure virtual

Sets the specified page as active page.

Pages of all segments got switched!

Parameters
page The page to set active
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ startMeasurements()

abstract bool startMeasurements ( bool doSynchronized )
pure virtual

Starts a (previously configured by configureMeasurements) data acquisition.

Parameters
doSynchronized true, if the DAQ List should be started synchronously
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ stopMeasurements()

abstract bool stopMeasurements ( bool doSynchronized )
pure virtual

Stops a running data acquisition.

The configured data acquisition could be restarted without calling configureMeasurements again with startMeasurements.

Parameters
doSynchronized true, if the DAQ List should be stopped synchronously (Only supported on XCP connections).
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

◆ writeCharacteristic()

bool writeCharacteristic | ( | IDataFile | dataFile,
 |  | A2LRECORD_LAYOUT_REF | layoutRef,
 |  | bool | writeAxisRefs = true,
 |  | IList< string > | criterionValues = null
 | ) |  |

Write the characteristic value read from the specified datafile to the device.

  • The ECU get switched to the RAM page if not already done.
Parameters
dataFile | The data file to read from
layoutRef | The characteristic to write to the data file
writeAxisRefs | true, if referenced AxisPts should be written, too
criterionValues | Set of criterion values (must be ordered by Criterion occurence in A2L content)
Returns
true if successful

◆ writeSync()

abstract bool writeSync | ( | byte | addressExtension,
 |  | uint | address,
 |  | byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
pure virtual

Write data synchronously to the ECU.

Depending on the data length to be written CmdDownload or CmdShortDownload is used.

Parameters
addressExtension | The address extension
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to write
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Implemented in CCPMaster, and XCPMaster.

Property Documentation

◆ ActivePage

abstract ECUPage ActivePage
get

The currently active calibration page

Only valid in connected state!

◆ CanWrite

abstract bool CanWrite
get

Indicates if writing to the XCP/CCP mmaster is allowed.

Writing is allowed, if

  • The XCP/CCP master is connected
  • The XCP/CCP master supports calibration

◆ ChangeEndianess

bool ChangeEndianess
getsetprotected

Indicates if XCP Master and Slave byte orders differ.

Gets a value if 16/32/64 Bit values have to be turned around in case the host and the slave byte order differs.

Event Documentation

◆ ConnectionStateChanged

EventHandler ConnectionStateChanged

Called if a XCP/CCP connection state changes.

The event is invoked from a receiver thread (this is never the GUI thread)!

◆ OnValuesReceived

EventHandler<ValuesReceivedEventArgs> OnValuesReceived

Called if a XCP/CCP data acquisition data is received.

The event is invoked from a receiver thread (this is never the GUI thread)!


ASAP2Library interface: Member List

  • Comm
  • CommMaster
CommMaster Member List

This is the complete list of members for CommMaster, including all inherited members.

ActivePage | CommMaster |
addAdaptiveCharacteristics(A2LPROJECT project, List< IDataFile > dataFiles) | CommMaster |
CanWrite | CommMaster |
ChangeEndianess | CommMaster | protected
CommMaster(ConnectBehaviourType connectBehaviour, A2LIF_DATA srcIf) | CommMaster |
configureMeasurements(IList< DAQMeasurement > measurements) | CommMaster | pure virtual
ConnectBehaviour | CommMaster |
Connected | CommMaster |
ConnectionStateChanged | CommMaster |
copyPage2Page(ECUPage srcPage, ECUPage dstPage) | CommMaster | pure virtual
DAQs | CommMaster |
Disconnect(int useTimeout=-1) | CommMaster | pure virtual
Dispose() | CommMaster | virtual
epkCheck(A2LMOD_PAR modPar, out string epkFromDevice) | CommMaster |
epkCheck(uint epkAddress, string expectedEPK, out string epkFromDevice) | CommMaster |
ErrorsReceived | CommMaster |
EventsReceived | CommMaster |
FramesReceived | CommMaster |
FramesSent | CommMaster |
getAliveCycleTime() | CommMaster | pure virtual
getChecksum(byte addressExtension, uint address, uint size, out uint checksum) | CommMaster | pure virtual
getDAQPhysValue(A2LMEASUREMENT measurement, out double value) | CommMaster |
getDAQPhysValue(A2LMEASUREMENT measurement, int x, int y, out double value) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, out double rawValue) | CommMaster |
getDAQRawValue(A2LMEASUREMENT measurement, int x, int y, out double rawValue) | CommMaster | virtual
getOperatingPoint(A2LCHARACTERISTIC characteristic) | CommMaster |
getTransmissionRate(out double bitsPerSec) | CommMaster |
Interface | CommMaster |
internalConnect() | CommMaster | virtual
internalGetStatus() | CommMaster | pure virtual
LastErrorEnum | CommMaster |
LastErrorText | CommMaster |
LastReceivedTime | CommMaster |
LastStateChange | CommMaster |
mAdaptiveCharDict | CommMaster | protected
mapAddress(uint address) | CommMaster | pure virtual
mBitsTransferred (defined in CommMaster) | CommMaster | protected
mDataFiles | CommMaster | protected
MeasurementAccessData | CommMaster |
mSeedAndKeyDLL (defined in CommMaster) | CommMaster | protected
mStrTrimmer | CommMaster | static
OnValuesReceived | CommMaster |
programSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null, XCPPrgParams modes=null) | CommMaster | pure virtual
RaiseConnectionStateChanged() | CommMaster |
RaiseOnValuesReceived(int daqListNo, double seconds, byte[] data) | CommMaster |
readCharacteristic(ECUPage pageToReadFrom, IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool readAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
readSync(int len, byte addressExtension, uint address, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual
resetLastError() | CommMaster | pure virtual
SeedAndKeyDLL | CommMaster |
ServicesReceived | CommMaster |
setConnectionState< T >(T respConnect) | CommMaster | pure virtual
setPage(ECUPage page) | CommMaster | pure virtual
startMeasurements(bool doSynchronized) | CommMaster | pure virtual
stopMeasurements(bool doSynchronized) | CommMaster | pure virtual
writeCharacteristic(IDataFile dataFile, A2LRECORD_LAYOUT_REF layoutRef, bool writeAxisRefs=true, IList< string > criterionValues=null) | CommMaster |
writeSync(byte addressExtension, uint address, byte[] data, EventHandler< ProgressArgs > progressHandler=null) | CommMaster | pure virtual


ASAP2Library interface: Communicator Class Reference

  • Comm
  • Communicator
Public Member Functions | Protected Member Functions | List of all members
Communicator Class Referenceabstract

Basic communicator implementation. More...

Public Member Functions

virtual void Dispose ()
Disposes all used resources. More...

Protected Member Functions

virtual void close ()
Closes the communication (frees all used resources). More...

Detailed Description

Basic communicator implementation.

Acts as something like an endpoint for XCP/CCP Master communication.

Member Function Documentation

◆ close()

virtual void close ( )
protectedvirtual

Closes the communication (frees all used resources).

  • Any derived class has to implement this method.

Reimplemented in CCPonCAN, XCPonUDP, XCPonTCP, XCPOnSxI, and XCPOnUSB.

◆ Dispose()

virtual void Dispose ( )
virtual

Disposes all used resources.

Inparticular:

  • The communication channel

Reimplemented in CCPonCAN, and XCPCommunicator.


ASAP2Library interface: Member List

  • Comm
  • Communicator
Communicator Member List

This is the complete list of members for Communicator, including all inherited members.

close() | Communicator | protectedvirtual
Dispose() | Communicator | virtual


ASAP2Library interface: DAQCache Class Reference

  • Comm
  • DAQCache
Public Member Functions | List of all members
DAQCache Class Reference

DAQ Record cache. More...

Public Member Functions

DAQCache (int expectedODTCount, int expectedSize)
void | Add (byte[] data, int offset, int unusedBytes)
Adds data to the cache. More...
byte[] | getData ()
Gets the received data as a flat stream. More...

Detailed Description

DAQ Record cache.

Used to collect DAQ records until all records of a single DAQList are complete.

Member Function Documentation

◆ Add()

void Add | ( | byte[] | data,
 |  | int | offset,
 |  | int | unusedBytes
 | ) |  |

Adds data to the cache.

Parameters
data | The data stream from the received DAQ record. The first byte is always interpreted as PID
offset | Offset from start of record to start of data
unusedBytes | Count of unused bytes at the end of the record

◆ getData()

byte[] getData ( )

Gets the received data as a flat stream.

Returns
The stream instance, null if incomplete


ASAP2Library interface: Member List

  • Comm
  • DAQCache
DAQCache Member List

This is the complete list of members for DAQCache, including all inherited members.

Add(byte[] data, int offset, int unusedBytes) | DAQCache
DAQCache(int expectedODTCount, int expectedSize) (defined in DAQCache) | DAQCache
getData() | DAQCache


ASAP2Library interface: DAQDict Class Reference

  • Comm
  • DAQDict
Public Member Functions | Public Attributes | List of all members
DAQDict Class Reference

Holds the configured DAQ Lists for both XCP and CCP. More...

Public Member Functions

new void | Clear ()
Clears all the configured ODTs. More...
void | clearData ()
Clears all data received within the DAQ list dictionary.
ODTEntry | getODTEntry (A2LMEASUREMENT measurement)
Gets the ODTEntry corresponding to the specified measurement. More...

Public Attributes

readonly Dictionary< uint, ODTEntry > ODTEntries = new Dictionary<uint, ODTEntry>()
Gets the mapping from measurement's address to the configured ODTEntry and therefore to it's measurement data.

Detailed Description

Holds the configured DAQ Lists for both XCP and CCP.

Member Function Documentation

◆ Clear()

new void Clear ( )

Clears all the configured ODTs.

If resources (received data) should be released, too, a call to clearData is required before.

◆ getODTEntry()

ODTEntry getODTEntry ( A2LMEASUREMENT measurement )

Gets the ODTEntry corresponding to the specified measurement.

Parameters
measurement The measurement to get the ODT entry for
Returns
The ODT entry instance if found, else null


ASAP2Library interface: Member List

  • Comm
  • DAQDict
DAQDict Member List

This is the complete list of members for DAQDict, including all inherited members.

Clear() | DAQDict
clearData() | DAQDict
getODTEntry(A2LMEASUREMENT measurement) | DAQDict
ODTEntries | DAQDict


ASAP2Library interface: DAQList Class Reference

  • Comm
  • DAQList
Public Member Functions | Public Attributes | Properties | List of all members
DAQList Class Reference

DAQ List representation base class for both XCP and CCP. More...

Public Member Functions

virtual void clearData ()
Clears only the contained data, not the DAQ configuration. More...

Public Attributes

readonly ushort | EvtNo = ushort.MaxValue
The corresponding event channel number.
readonly SortedDictionary< byte, ODTList > | ODTs = new SortedDictionary<byte, ODTList>()
List of configured ODTs
readonly string | TimeCycle
Minimal period duration of the acquisition raster

Properties

uint | CANId [getset]
Gets the corresponding CAN ID
ushort | DAQNo [getset]
The (unique) DAQ number.
byte | FirstPID [getset]
Number of the FirstPID. More...

Detailed Description

DAQ List representation base class for both XCP and CCP.

Holds a dictionary of configured ODTs.

Member Function Documentation

◆ clearData()

virtual void clearData ( )
virtual

Clears only the contained data, not the DAQ configuration.

Reimplemented in DAQListXCP.

Property Documentation

◆ FirstPID

byte FirstPID
getset

Number of the FirstPID.

Usually 0, except in absolute PID mode (XCP_ID_FIELD_TYPE.ABSOLUTE).


ASAP2Library interface: Member List

  • Comm
  • DAQList
DAQList Member List

This is the complete list of members for DAQList, including all inherited members.

CANId | DAQList |
clearData() | DAQList | virtual
DAQNo | DAQList |
EvtNo | DAQList |
FirstPID | DAQList |
ODTs | DAQList |
TimeCycle | DAQList |


ASAP2Library interface: DAQStore Class Reference

  • Comm
  • DAQStore
Public Member Functions | List of all members
DAQStore Class Reference

Holds received DAQ records More...

Public Member Functions

void getData (ODTEntry entry, ValueObjectFormat format, IList< double > xValues, IList< double > yValues, double start=double.MinValue, double end=double.MaxValue, bool append=false)
Gets the physical data from rthe ODT entry. More...

Detailed Description

Holds received DAQ records

Member Function Documentation

◆ getData()

void getData | ( | ODTEntry | entry,
 |  | ValueObjectFormat | format,
 |  | IList< double > | xValues,
 |  | IList< double > | yValues,
 |  | double | start = double.MinValue,
 |  | double | end = double.MaxValue,
 |  | bool | append = false
 | ) |  |

Gets the physical data from rthe ODT entry.

Parameters
entry | The ODT entry
format | Format of the delivered values (raw or physical)
xValues | [out] list of resulting x values
yValues | [out] list of resulting y values
start | start time in seconds
end | end time in seconds
append | true, if data should be appended to the xValues/YValues


ASAP2Library interface: Member List

  • Comm
  • DAQStore
DAQStore Member List

This is the complete list of members for DAQStore, including all inherited members.

getData(ODTEntry entry, ValueObjectFormat format, IList< double > xValues, IList< double > yValues, double start=double.MinValue, double end=double.MaxValue, bool append=false) DAQStore


ASAP2Library interface: DAQToEvtMapDict Class Reference

  • Comm
  • DAQToEvtMapDict
DAQToEvtMapDict Class Reference

Maps a XCP DAQList number to a specific XCP Event. More...

Detailed Description

Maps a XCP DAQList number to a specific XCP Event.


ASAP2Library interface: Frame Class Reference

  • Comm
  • Frame
Public Member Functions | Public Attributes | Properties | List of all members
Frame Class Referenceabstract

Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP). More...

Public Member Functions

Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...
abstract string | toClipboard ()
Builds a tab delimited representation of the frame. More...
abstract string | toCSV ()
Builds a CSV representation of the frame. More...

Public Attributes

byte[] Data
The data bytes of the frame.

Properties

TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP).

Constructor & Destructor Documentation

◆ Frame()

Frame ( bool isMasterFrame )

Creates a new instance of FrameQueue.

Parameters
isMasterFrame Indicates if the frame is a master frame

Member Function Documentation

◆ getDataASCIIStr()

string getDataASCIIStr ( char notAllowedChar )

Gets the frame's data in ASCII representation.

Not printable characters are filtered by default.

Parameters
notAllowedChar Defines a printable character which get filtered from the resulting string
Returns
returns the frame's data in ASCII representation

◆ getDataStr()

string getDataStr ( )

Gets the frame's data.

Returns
returns the frame's data as string representation

◆ getRWIndicator()

char getRWIndicator ( )

Gets the sender/responder indicator.

Returns

◆ getTimeStr()

string getTimeStr ( double offset = 0.0 )

Gets the timestamp string.

Returns

◆ toClipboard()

abstract string toClipboard ( )
pure virtual

Builds a tab delimited representation of the frame.

Returns
the string representation

Implemented in CCPFrame, XCPFrame, BaseFrame, UDSFrame, CANFrame, J1939Frame, and LINFrame.

◆ toCSV()

abstract string toCSV ( )
pure virtual

Builds a CSV representation of the frame.

Returns
the string representation

Implemented in CCPFrame, XCPFrame, BaseFrame, UDSFrame, CANFrame, J1939Frame, and LINFrame.

Property Documentation

◆ Elapsed

TimeSpan Elapsed
get

The time elapsed since the start.

The Elapsed time is set by the FrameQueue, when the frame is queued.


ASAP2Library interface: Member List

  • Comm
  • Frame
Frame Member List

This is the complete list of members for Frame, including all inherited members.

Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
IsMasterFrame | Frame |
toClipboard() | Frame | pure virtual
toCSV() | Frame | pure virtual


ASAP2Library interface: FrameEventArgs< T > Class Template Reference

  • Comm
  • FrameEventArgs
Public Attributes | List of all members
FrameEventArgs< T > Class Template Reference

Frame queue event arguments. More...

Public Attributes

readonly ushort | Channel
Frame channel
readonly T | Frame
The frame added to the queue

Detailed Description

Frame queue event arguments.

Template Parameters
T
Type Constraints
T : Frame


ASAP2Library interface: Member List

  • Comm
  • FrameEventArgs
FrameEventArgs< T > Member List

This is the complete list of members for FrameEventArgs< T >, including all inherited members.

Channel | FrameEventArgs< T >
Frame | FrameEventArgs< T >


ASAP2Library interface: FrameProvider< T, V > Class Template Reference

  • Comm
  • FrameProvider
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
FrameProvider< T, V > Class Template Referenceabstract

Provides CAN/LIN Frames for CAN and LIN providers. More...

Public Member Functions

abstract void | close ()
virtual void | Dispose ()
Disposes all used resources from the instance. More...
abstract int | onReceive (out T frame)
Cyclically called to receive CAN or LIN frames. More...
void | registerClient (EventHandler< V > handler)
void | registerClient (IEnumerable< uint > Ids, EventHandler< V > handler)
void | registerClient (uint Id, EventHandler< V > handler)
void | unregisterClient (EventHandler< V > handler)

Protected Member Functions

abstract void | notifyThread ()
abstract void | receiveThread ()
void | start ()
Starts the CANProvider.
void | stop ()
Stops the CANProvider.

Protected Attributes

long | mBitsTransferred
readonly ManualResetEvent | mCancelEvent = new ManualResetEvent(false)
volatile bool | mIsActivated
long | mLastBusloadQuery = -1
long | mMsgTransferred
readonly AutoResetEvent | mNotifyEvent = new AutoResetEvent(false)
readonly List< T > | mNotifyFramesList = new List<T>()
readonly Dictionary< uint, List< EventHandler< V > > > | mNotifyHandlerDict = new Dictionary<uint, List<EventHandler<V>>>()
readonly AutoResetEvent | mRxEvent = new AutoResetEvent(false)
This could be used from a specific CAN Provider to indicate if a data is received.
readonly MediaType | mType

Properties

int | ClientCount [get]
int | UniqueBusID [get]
Gets the unique bus id of any instantiated frame providers.

Detailed Description

Provides CAN/LIN Frames for CAN and LIN providers.

Template Parameters
T | CANFrame or LINFrame
V | CANEventArgs or LINEventArgs
Type Constraints
T : Frame
V : EventArgs

Member Function Documentation

◆ Dispose()

virtual void Dispose ( )
virtual

Disposes all used resources from the instance.

  • The receiver thread
  • The notifier thread

Reimplemented in CANProvider, _8DevicesCAN, AdvantechCAN, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ETASLIN, IMEActiaCAN, IntrepidCAN, IntrepidLIN, IXXATCAN, IXXATLIN, KvaserCAN, KvaserLIN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, PeakLIN, SoftingCAN, VectorCAN, and VectorLIN.

◆ notifyThread()

abstract void notifyThread ( )
protectedpure virtual

Implemented in CANProvider, and LINProvider.

◆ onReceive()

abstract int onReceive ( out T frame )
pure virtual

Cyclically called to receive CAN or LIN frames.

  • Provides all CAN/LIN frames read from the CAN/LIN bus
  • The method should never block
Parameters
frame The CAN/LIN frame received or sent, or null if no frame is received or sent
Returns
0 if no error occured (The frame parameter may be null in this case, too)

◆ receiveThread()

abstract void receiveThread ( )
protectedpure virtual

Implemented in CANProvider, and LINProvider.


ASAP2Library interface: Member List

  • Comm
  • FrameProvider
FrameProvider< T, V > Member List

This is the complete list of members for FrameProvider< T, V >, including all inherited members.

ClientCount (defined in FrameProvider< T, V >) | FrameProvider< T, V > |
close() (defined in FrameProvider< T, V >) | FrameProvider< T, V > | pure virtual
Dispose() | FrameProvider< T, V > | virtual
mBitsTransferred (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mCancelEvent (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mIsActivated (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mLastBusloadQuery (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mMsgTransferred (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mNotifyEvent (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mNotifyFramesList (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mNotifyHandlerDict (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
mRxEvent | FrameProvider< T, V > | protected
mType (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protected
notifyThread() (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protectedpure virtual
onReceive(out T frame) | FrameProvider< T, V > | pure virtual
receiveThread() (defined in FrameProvider< T, V >) | FrameProvider< T, V > | protectedpure virtual
registerClient(EventHandler< V > handler) (defined in FrameProvider< T, V >) | FrameProvider< T, V > |
registerClient(uint Id, EventHandler< V > handler) (defined in FrameProvider< T, V >) | FrameProvider< T, V > |
registerClient(IEnumerable< uint > Ids, EventHandler< V > handler) (defined in FrameProvider< T, V >) | FrameProvider< T, V > |
start() | FrameProvider< T, V > | protected
stop() | FrameProvider< T, V > | protected
UniqueBusID | FrameProvider< T, V > |
unregisterClient(EventHandler< V > handler) (defined in FrameProvider< T, V >) | FrameProvider< T, V > |


ASAP2Library interface: FrameQueue< T > Class Template Reference

  • Comm
  • FrameQueue
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
FrameQueue< T > Class Template Reference

Base class for any frame type queue (CAN, CCP, XCP, UDS,...) More...

Public Member Functions

virtual void | clear ()
Clears the frame queue. More...
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Protected Member Functions

void addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...

Protected Attributes

readonly List< T > mFrames = new List<T>(mMaxFramesToClear)

Properties

bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Events

EventHandler< FrameEventArgs< T > > FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Base class for any frame type queue (CAN, CCP, XCP, UDS,...)

Type Constraints
T : Frame

Member Function Documentation

◆ addFrame()

void addFrame | ( | T | frame,
 |  | ushort | channel = 1
 | ) |  |
protected

Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns.

Parameters
frame | frame
channel | Channel Id

◆ clear()

virtual void clear ( )
virtual

Clears the frame queue.

Reimplemented in CANFrameQueue, and LINFrameQueue.

◆ getFrames()

T[] getFrames ( out int cntFrames )

Gets all available frames (in order of occurence).

Parameters
cntFrames Count of available frames
Returns
all available frames

◆ getUnreadFrames()

T[] getUnreadFrames ( out int cntFrames )

Gets all available unread frames (in order of occurence).

Parameters
cntFrames Count of available frames
Returns
all unread frames

◆ updateFileLogSetting()

void updateFileLogSetting | ( | bool | logToFile,
 |  | string | logFilePath
 | ) |  |

Starts or stops logging of frames to file.

Parameters
logToFile | true to start logging to logFilePath, false to stop logging
logFilePath | The path to log the frames to


ASAP2Library interface: Member List

  • Comm
  • FrameQueue
FrameQueue< T > Member List

This is the complete list of members for FrameQueue< T >, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< T > | protected
clear() | FrameQueue< T > | virtual
Dispose() | FrameQueue< T > | virtual
FrameEnqueued | FrameQueue< T > |
getFrames(out int cntFrames) | FrameQueue< T > |
getUnreadFrames(out int cntFrames) | FrameQueue< T > |
IsWritingToFile | FrameQueue< T > |
LogFileCSVHeader | FrameQueue< T > |
LogFileName | FrameQueue< T > |
mFrames (defined in FrameQueue< T >) | FrameQueue< T > | protected
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< T > |


ASAP2Library interface: IFrameProvider< T > Interface Template Reference

  • Comm
  • IFrameProvider
Public Member Functions | Properties | List of all members
IFrameProvider< T > Interface Template Reference

Common Interface for the CAN/LIN/SxI frame providers. More...

Public Member Functions

void | close ()
Close the CAN resource
IEnumerable< object > | GetAvailableHardware (MediaType type)
Used to get available hardware instances (currently not implemented with each CAN/LIN provider). More...
void | registerClient (EventHandler< T > handler)
Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs. More...
void | registerClient (IEnumerable< uint > Ids, EventHandler< T > handler)
Registers a specific CAN/LIN handler. More...
void | registerClient (uint Id, EventHandler< T > handler)
Registers a CAN/LIN listener for a specific CAN/LIN ID. More...
void | unregisterClient (EventHandler< T > handler)
Unregisters a CAN/LIN/SxI listener. More...

Properties

int ClientCount [get]
Gets the number of registered clients.

Detailed Description

Common Interface for the CAN/LIN/SxI frame providers.

Template Parameters
T CANEventArgs, LINEventArgs, SxIEventArgs
Type Constraints
T : EventArgs

Member Function Documentation

◆ GetAvailableHardware()

IEnumerable< object > GetAvailableHardware ( MediaType type )

Used to get available hardware instances (currently not implemented with each CAN/LIN provider).

Parameters
type
Returns
List of hardware instances

◆ registerClient() [1/3]

void registerClient ( EventHandler< T > handler )

Registers a CAN/LIN/SxI listener for all CAN/LIN/SxI IDs.

To avoid memory leaks any registered handler must be unregistered on disposing the client instance by calling unregisterClient!

Parameters
handler The CAN listener event handler instance

◆ registerClient() [2/3]

void registerClient | ( | IEnumerable< uint > | Ids,
 |  | EventHandler< T > | handler
 | ) |  |

Registers a specific CAN/LIN handler.

To avoid memory leaks this handler must be unregistered on disposing the client instance by calling unregisterClient!

Parameters
Ids | The list of specific CAN/LIN IDs
handler | The handler to be called

◆ registerClient() [3/3]

void registerClient | ( | uint | Id,
 |  | EventHandler< T > | handler
 | ) |  |

Registers a CAN/LIN listener for a specific CAN/LIN ID.

To avoid memory leaks any registered handler must be unregistered on disposing the client instance by calling unregisterClient!

Parameters
Id | The CAN/LIN ID to listen to
handler | The CAN listener event handler instance

◆ unregisterClient()

void unregisterClient ( EventHandler< T > handler )

Unregisters a CAN/LIN/SxI listener.

To avoid memory leaks this method must be called on disposing the client instance!

Parameters
handler The CAN listener event handler instance


ASAP2Library interface: Member List

  • Comm
  • IFrameProvider
IFrameProvider< T > Member List

This is the complete list of members for IFrameProvider< T >, including all inherited members.

ClientCount | IFrameProvider< T >
close() | IFrameProvider< T >
GetAvailableHardware(MediaType type) | IFrameProvider< T >
registerClient(EventHandler< T > handler) | IFrameProvider< T >
registerClient(uint Id, EventHandler< T > handler) | IFrameProvider< T >
registerClient(IEnumerable< uint > Ids, EventHandler< T > handler) | IFrameProvider< T >
unregisterClient(EventHandler< T > handler) | IFrameProvider< T >


ASAP2Library interface: IResponse Interface Reference

  • Comm
  • IResponse
Public Member Functions | List of all members
IResponse Interface Reference

Base class represents a CCP or XCP response. More...

Public Member Functions

void changeEndianness ()
Changes the endianess of the response. More...

Detailed Description

Base class represents a CCP or XCP response.

Member Function Documentation

◆ changeEndianness()

void changeEndianness ( )

Changes the endianess of the response.

Implemented in RespBase, RespDownload, RespGetActiveCALPage, RespBuildChecksum, RespBase, RespConnect, RespGetStatus, RespGetID, RespBuildChecksum, RespGetSegmentInfoAddress, RespReadDAQ, RespGetDAQClock, RespGetDAQProcessorInfo, RespGetDAQResolutionInfo, RespGetDAQListMode, RespGetDAQListInfo, RespGetSectorInfoModeAddressOrLen, EventResumeMode, EventResumeModeTS, EventTimeSync, EventStimTimeout, RespDTOCtrResp, and RespTimeCorrelation.


ASAP2Library interface: Member List

  • Comm
  • IResponse
IResponse Member List

This is the complete list of members for IResponse, including all inherited members.

changeEndianness() IResponse


ASAP2Library interface: ODTEntry Class Reference

  • Comm
  • ODTEntry
Public Member Functions | Public Attributes | Properties | List of all members
ODTEntry Class Reference

Represents an ODT entry. More...

Public Member Functions

ODTEntry (DAQList daqList, A2LMEASUREMENT measurement, int arrayOffset, int dataOffset, byte size)
Creates a new instance of an ODTEntry with the specified parameters. More...
double | getCurrentValue (ValueObjectFormat format)
Gets the most recently received value. More...
void | getData (ValueObjectFormat format, IList< double > xValues, IList< double > yValues, double start=double.MinValue, double end=double.MaxValue, bool append=false)
Gets the physical data from rthe ODT entry. More...
bool | getValue (int idx, ValueObjectFormat format, out DataPoint dataPoint)
Gets the data point from the specified index More...

Public Attributes

readonly int | ArrayOffset
Gets the offset to the specified measurement base address (> 0 if ArraySize of the base measurement is > 1).
readonly DAQList | DAQList
The corresponding DAQ List
readonly int | DataOffset
Gets the offset to the specified measurement address (> 0 is only a part of a measurement).
readonly A2LMEASUREMENT | Measurement
Gets the corresponding measurement.
readonly byte | Size
Gets the size of this ODT entry.

Properties

uint | Address [get]
The absolute address of the ODTEntry.
byte | BitOffset [get]
Gets the bit offset value.
int | Count [get]
Received count of data, The next index to write received data to.
int | DAQPosition = -1 [getset]
Gets the position of the raw data in the DAQ record.
int | Index [get]
Gets the index of the measurmeent (maybe > 0 for measurement array types)
double | Value [get]
Gets the current raw value depending on the current time (double.NaN if nothing is received yet).

Detailed Description

Represents an ODT entry.

  • Holds configuration data to configure an ODT entry.
  • Holds received history data of an A2LMEASUREMENT.

Constructor & Destructor Documentation

◆ ODTEntry()

ODTEntry | ( | DAQList | daqList,
 |  | A2LMEASUREMENT | measurement,
 |  | int | arrayOffset,
 |  | int | dataOffset,
 |  | byte | size
 | ) |  |

Creates a new instance of an ODTEntry with the specified parameters.

Parameters
daqList | The corresponding DAQ List
measurement | The measurement
arrayOffset | the (array) offset to the specified measurement base address (ArraySize > 1)
dataOffset | The offset within the measurements data
size | Size in bytes

Member Function Documentation

◆ getCurrentValue()

double getCurrentValue ( ValueObjectFormat format )

Gets the most recently received value.

Parameters
format Physical or Raw format
Returns
The most recently received value

◆ getData()

void getData | ( | ValueObjectFormat | format,
 |  | IList< double > | xValues,
 |  | IList< double > | yValues,
 |  | double | start = double.MinValue,
 |  | double | end = double.MaxValue,
 |  | bool | append = false
 | ) |  |

Gets the physical data from rthe ODT entry.

Parameters
format | Format of the delivered values (raw or physical)
xValues | [out] list of resulting x values
yValues | [out] list of resulting y values
start | start time in seconds
end | end time in seconds
append | true, if data should be appended to the xValues/YValues

◆ getValue()

bool getValue | ( | int | idx,
 |  | ValueObjectFormat | format,
 |  | out DataPoint | dataPoint
 | ) |  |

Gets the data point from the specified index

Parameters
idx | record index
format | data value format
dataPoint | Contains X=timestamp and Y = value
Returns
true if the record is available and the dataPoint is valid


ASAP2Library interface: Member List

  • Comm
  • ODTEntry
ODTEntry Member List

This is the complete list of members for ODTEntry, including all inherited members.

Address | ODTEntry
ArrayOffset | ODTEntry
BitOffset | ODTEntry
Count | ODTEntry
DAQList | ODTEntry
DAQPosition | ODTEntry
DataOffset | ODTEntry
getCurrentValue(ValueObjectFormat format) | ODTEntry
getData(ValueObjectFormat format, IList< double > xValues, IList< double > yValues, double start=double.MinValue, double end=double.MaxValue, bool append=false) | ODTEntry
getValue(int idx, ValueObjectFormat format, out DataPoint dataPoint) | ODTEntry
Index | ODTEntry
Measurement | ODTEntry
ODTEntry(DAQList daqList, A2LMEASUREMENT measurement, int arrayOffset, int dataOffset, byte size) | ODTEntry
Size | ODTEntry
Value | ODTEntry


ASAP2Library interface: ODTList Class Reference

  • Comm
  • ODTList
List of all members
ODTList Class Reference

Holds the configured ODTEntries within an ODT. More...

Detailed Description

Holds the configured ODTEntries within an ODT.


ASAP2Library interface: Member List

  • Comm
  • ODTList
ODTList Member List

This is the complete list of members for ODTList, including all inherited members.


ASAP2Library interface: ValuesReceivedEventArgs Class Reference

  • Comm
  • ValuesReceivedEventArgs
Public Member Functions | Public Attributes | List of all members
ValuesReceivedEventArgs Class Reference

Event arguments used on receiving acquisition data. More...

Public Member Functions

ValuesReceivedEventArgs (int daqListNo, double seconds, byte[] data)

Public Attributes

readonly int | DAQListNo
The DAQ list number
readonly byte[] | Data
received data
readonly double | Seconds
The timestamp in relative seconds

Detailed Description

Event arguments used on receiving acquisition data.


ASAP2Library interface: Member List

  • Comm
  • ValuesReceivedEventArgs
ValuesReceivedEventArgs Member List

This is the complete list of members for ValuesReceivedEventArgs, including all inherited members.

DAQListNo | ValuesReceivedEventArgs
Data | ValuesReceivedEventArgs
Seconds | ValuesReceivedEventArgs
ValuesReceivedEventArgs(int daqListNo, double seconds, byte[] data) (defined in ValuesReceivedEventArgs) | ValuesReceivedEventArgs


ASAP2Library interface: XCPPrgParams Class Reference

  • Comm
  • XCPPrgParams
Public Member Functions | Public Attributes | List of all members
XCPPrgParams Class Reference

Transfer structure holding (XCP) programming parameters. More...

Public Member Functions

XCPPrgParams (ProgramClearMode clearMode=ProgramClearMode.AbsoluteAccess, ProgramVerifyMode verifyMode=ProgramVerifyMode.None, ushort verifyType=0, uint verifyValue=0)

Public Attributes

readonly ProgramClearMode | ClearMode
readonly ProgramVerifyMode | VerifyMode
readonly ushort | VerifyType
readonly uint | VerifyValue

Detailed Description

Transfer structure holding (XCP) programming parameters.


ASAP2Library interface: Member List

  • Comm
  • XCPPrgParams
XCPPrgParams Member List

This is the complete list of members for XCPPrgParams, including all inherited members.

ClearMode (defined in XCPPrgParams) | XCPPrgParams
VerifyMode (defined in XCPPrgParams) | XCPPrgParams
VerifyType (defined in XCPPrgParams) | XCPPrgParams
VerifyValue (defined in XCPPrgParams) | XCPPrgParams
XCPPrgParams(ProgramClearMode clearMode=ProgramClearMode.AbsoluteAccess, ProgramVerifyMode verifyMode=ProgramVerifyMode.None, ushort verifyType=0, uint verifyValue=0) (defined in XCPPrgParams) | XCPPrgParams


ASAP2Library interface: jnsoft.DBC Namespace Reference

  • DBC
Classes
jnsoft.DBC Namespace Reference

Implements the DBC (Vector CANDb++) file format reader/writer. More...

Classes

class DBCFile
Implements the DBC (Vector CANDb++) file format reader/writer. More...

Detailed Description

Implements the DBC (Vector CANDb++) file format reader/writer.

Basic access to a DBC file is provided by the DBCFile class. It provides methods and properties to open, save and access the DBC model.

Getting started with reading and writing a DBC File (code example):

using jnsoft.DBC;
void loadAndSaveFile(string dbcFilename)
{
// Open DBC file
var dbcFile = DBCFile.open(dbcFilename);
Console.WriteLine("Opened DBC file {0} version: {1} contained signals: {2}"
, dbcFile.SourceFile, dbcFile.Version, dbcFile.getCountSignals()
);
// change a value
dbcFile.Comment = "Changed comment in dbc file";
// save the changed DBC file
dbcFile.save(dbcFilename+".out.dbc");
}
jnsoft.DBC.DBCFile
Implements the DBC (Vector CANDb++) file format reader/writer.
Definition: DBCFile.cs:81
jnsoft.DBC.DBCFile.Comment
string Comment
Gets or set the CANdb++ file comment.
Definition: DBCFile.cs:2315
jnsoft.DBC.DBCFile.open
static DBCFile open(string path)
Opens a DBC file and returns a DBCFile instance.
Definition: DBCFile.cs:2368
jnsoft.DBC
Implements the DBC (Vector CANDb++) file format reader/writer.
Definition: DBCFile.cs:76
jnsoft
Definition: ASAP2.cs:53


ASAP2Library interface: jnsoft.DBC.Examples Namespace Reference

  • DBC
  • Examples
Classes
jnsoft.DBC.Examples Namespace Reference

Classes

class Program
ASAP2ibrary DBC handling demonstration. More...


ASAP2Library interface: Program Class Reference

  • DBC
  • Examples
  • Program
List of all members
Program Class Reference

ASAP2ibrary DBC handling demonstration. More...

Detailed Description

ASAP2ibrary DBC handling demonstration.

  • Loading an DBC file
  • Register to receive CAN frames on a kvaser (as an example) CAN hardware.
  • Print a first valid signal while receiving CAN frames.

Usage: DBCExample DBCFile.dbc


ASAP2Library interface: Member List

  • DBC
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: DBCFile Class Reference

  • DBC
  • DBCFile
Classes | Public Types | Public Member Functions | Static Public Member Functions | Properties | Events | List of all members
DBCFile Class Reference

Implements the DBC (Vector CANDb++) file format reader/writer. More...

Classes

class | AttribDefDict
Attributes dictionary type. More...
class | AttribDefType
CANDb++ Attribute definition type. More...
class | AttributeType
CANDb++ Attribute type. More...
class | AttributeTypeDict
CANDb++ Attributes dictionary. More...
class | EnumDict
Defines a value table dictionary (mapping double values to strings). More...
class | EnvironmentDict
Environment dictionary type. More...
class | EnvironmentType
CANDb++ Environment type. More...
interface | IDBCAttribute
Interface any DBC base class attributes must implement. More...
interface | IDBCBase
Interface any DBC base class must implement. More...
interface | IDBCComment
Interface any DBC base class supporting comments must implement. More...
interface | IDBCSignal
Interface any DBC base class supporting signals must implement. More...
class | MsgType
CANDb++ (DBC) Message type. More...
class | SignalGroupDict
Defines a signal group table dictionary (mapping signal group IDs to signal groups). More...
class | SignalGroupType
Defines the CANDb++ signal group table. More...
class | SignalType
CANDb++ (DBC) Signal type. More...
class | SourceDict
Source dictionary type. More...
class | SourceType
CANDb++ (DBC) Device type. More...
class | ValueTable
Defines the CANDb++ value table. More...
class | ValueTableDict
Defines a value table dictionary (mapping value table idents to value tables). More...

Public Types

enum AttribDefObjectType {
Network , BU_ , BO_ , SG_ ,
EV_ , BU_BO_REL_ , BU_SG_REL_ , BU_EV_REL_
}
Possible attribute definition object types. More...
enum AttribDefValueType {
STRING , INT , FLOAT , HEX ,
ENUM
}
Possible attribute definition value types. More...
enum | EnvAccessType { Unrestricted = 0 , Write = 2 , ReadWrite = 3 , Read = 8001 }
Possible environment access types. More...
enum | EnvType { Integer , Float }
Possible environment data types. More...
enum | SignalFlagsType : byte { BigEndian = 0x01 , Signed = BigEndian << 1 , MultiplexSignal = BigEndian << 2 , Multiplexed = BigEndian << 3 }
Signal flags (may be combined). More...
enum | SignalFloatType { Integer , IEEEFloat32 , IEEEFloat64 }
Possible signal float types. More...
enum | SortMode { None , ByName , ByValue }
Possible sort mode for the DBC file writer. More...

Public Member Functions

DBCFile ()
Creates an (empty) instance of DBCFile.
DBCFile (string version)
Creates an (empty) instance of DBCFile. More...
Dictionary< IDBCBase, List< string > > | doPlausibilityCheck ()
Checks the content for plausibility. More...
int | getCountMessages ()
Gets the count of Messages. More...
int | getCountSignals ()
Gets the count of Signals. More...
int | getCountSources ()
Gets the count of Sources. More...
bool | onCANReceived (CANFrame frame, out MsgType msg)
Handles received CAN frames. More...
void | resetReceiverCache ()
Reset the receiver cache More...
void | save (string path)
Saves the CanDb++ in DBC file format. More...

Static Public Member Functions

static bool | checkIdentifier (DBCFile dbcFile, IDBCBase dbcBase, string identifier)
Checks if the specified identifier is valid. More...
static DBCFile | open (Stream stream, string path=null)
Opens a DBC file from the specified stream and returns a DBCFile instance. More...
static DBCFile | open (string path)
Opens a DBC file and returns a DBCFile instance. More...

Properties

AttribDefDict | AttributeDefinitions [getset]
Gets or sets the Attributes dictionary.
AttributeTypeDict | Attributes [getset]
Gets or sets the Attributes dictionary.
string | Comment [getset]
Gets or set the CANdb++ file comment.
EnvironmentDict | Environments [getset]
Gets or sets the enviroments dictionary.
List< string > | NS [getset]
Gets or sets the namespace.
SignalGroupDict | SignalGroups [getset]
Gets or sets the contained signal groups.
string | SourceFile [get]
Gets the fully qualified path to the source file.
SourceDict | Sources [getset]
Gets or sets the contained sources. More...
ValueTableDict | ValueTables [getset]
Gets or sets the contained value tables.
string | Version [getset]
Gets or set the CANdb++ file version.

Events

EventHandler NameChanged
Indicates name changes of IDBCBase instances.

Detailed Description

Implements the DBC (Vector CANDb++) file format reader/writer.

Member Enumeration Documentation

◆ AttribDefObjectType

enum AttribDefObjectType

Possible attribute definition object types.

Enumerator
Network | Network
BU_ | Node
BO_ | Message
SG_ | Signal
EV_ | Environment
BU_BO_REL_ | Node - TX message
BU_SG_REL_ | Node - mapped RX Signal
BU_EV_REL_ | Device - Environment relative

◆ AttribDefValueType

enum AttribDefValueType

Possible attribute definition value types.

Enumerator
STRING | Value is represented as string.
INT | Value is represented as integer.
FLOAT | Value is represented as float.
HEX | Value is represented as integer (displayed in hex format).
ENUM | Value is represented as a enumeration value (string).

◆ EnvAccessType

enum EnvAccessType

Possible environment access types.

Enumerator
Unrestricted | Not restricted
Write | Write
ReadWrite | Read
Read | Read/Write

◆ EnvType

enum EnvType

Possible environment data types.

Enumerator
Integer | integer data type
Float | float data type

◆ SignalFlagsType

enum SignalFlagsType : byte

Signal flags (may be combined).

Enumerator
BigEndian | The signal raw value is in big endian format.
Signed | The signal raw value is a signed value.
MultiplexSignal | The signal is the multiplexer signal.
Multiplexed | The signal is available only if the corresponding multiplexer value is set in the message

◆ SignalFloatType

enum SignalFloatType

Possible signal float types.

Enumerator
Integer | An integer value type
IEEEFloat32 | IEEE Float (32 Bit)
IEEEFloat64 | IEEE float (64 Bit)

◆ SortMode

enum SortMode

Possible sort mode for the DBC file writer.

Enumerator
None | Not sorted.
ByName | Sort by name.
ByValue | Sort by value.

Constructor & Destructor Documentation

◆ DBCFile()

DBCFile ( string version )

Creates an (empty) instance of DBCFile.

Parameters
version A version to set

Member Function Documentation

◆ checkIdentifier()

static bool checkIdentifier | ( | DBCFile | dbcFile,
 |  | IDBCBase | dbcBase,
 |  | string | identifier
 | ) |  |
static

Checks if the specified identifier is valid.

Parameters
dbcFile | The dbc file instance
dbcBase | A potential available IDBCBase instance (may be null)
identifier | The identifier to check
Returns
true if the specified identifier is valid.
Exceptions
ApplicationException Thrown, if the identifier is not valid

◆ doPlausibilityCheck()

Dictionary< IDBCBase, List< string > > doPlausibilityCheck ( )

Checks the content for plausibility.

Returns

◆ getCountMessages()

int getCountMessages ( )

Gets the count of Messages.

Returns
the count of Messages.

◆ getCountSignals()

int getCountSignals ( )

Gets the count of Signals.

Returns
the count of Signals.

◆ getCountSources()

int getCountSources ( )

Gets the count of Sources.

Returns
the count of Sources.

◆ onCANReceived()

bool onCANReceived | ( | CANFrame | frame,
 |  | out MsgType | msg
 | ) |  |

Handles received CAN frames.

Parameters
frame | The received CAN frame
msg | The message which was updated
Returns
true if a contained message is updated

◆ open() [1/2]

static DBCFile open | ( | Stream | stream,
 |  | string | path = null
 | ) |  |
static

Opens a DBC file from the specified stream and returns a DBCFile instance.

Parameters
stream | Stream containing the DBC file content
path | the fully qualified DBC filename
Returns
A new DBCFile instance or null if failed

◆ open() [2/2]

static DBCFile open ( string path )
static

Opens a DBC file and returns a DBCFile instance.

Parameters
path the fully qualified DBC filename
Returns
A new DBCFile instance or null if failed

◆ resetReceiverCache()

void resetReceiverCache ( )

Reset the receiver cache

Useful after msg IDs are changed while receiving data.

◆ save()

void save ( string path )

Saves the CanDb++ in DBC file format.

Parameters
path the fully qualified path to the destination file

Property Documentation

◆ Sources

SourceDict Sources
getset

Gets or sets the contained sources.

Maps CANdb++ source names to it's corresponding messages.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
DBCFile Member List

This is the complete list of members for DBCFile, including all inherited members.

AttribDefObjectType enum name | DBCFile |
AttribDefValueType enum name | DBCFile |
AttributeDefinitions | DBCFile |
Attributes | DBCFile |
checkIdentifier(DBCFile dbcFile, IDBCBase dbcBase, string identifier) | DBCFile | static
Comment | DBCFile |
DBCFile() | DBCFile |
DBCFile(string version) | DBCFile |
doPlausibilityCheck() | DBCFile |
EnvAccessType enum name | DBCFile |
Environments | DBCFile |
EnvType enum name | DBCFile |
getCountMessages() | DBCFile |
getCountSignals() | DBCFile |
getCountSources() | DBCFile |
NameChanged | DBCFile |
NS | DBCFile |
onCANReceived(CANFrame frame, out MsgType msg) | DBCFile |
open(string path) | DBCFile | static
open(Stream stream, string path=null) | DBCFile | static
resetReceiverCache() | DBCFile |
save(string path) | DBCFile |
SignalFlagsType enum name | DBCFile |
SignalFloatType enum name | DBCFile |
SignalGroups | DBCFile |
SortMode enum name | DBCFile |
SourceFile | DBCFile |
Sources | DBCFile |
ValueTables | DBCFile |
Version | DBCFile |


ASAP2Library interface: DBCFile.AttribDefDict Class Reference

  • DBC
  • DBCFile
  • AttribDefDict
Properties | List of all members
DBCFile.AttribDefDict Class Reference

Attributes dictionary type. More...

Properties

object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

Detailed Description

Attributes dictionary type.

Maps CANdb++ environment names to it's corresponding messages.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • AttribDefDict
DBCFile.AttribDefDict Member List

This is the complete list of members for DBCFile.AttribDefDict, including all inherited members.

Tag DBCFile.AttribDefDict


ASAP2Library interface: DBCFile.AttribDefType Class Reference

  • DBC
  • DBCFile
  • AttribDefType
Public Member Functions | Properties | List of all members
DBCFile.AttribDefType Class Reference

CANDb++ Attribute definition type. More...

Public Member Functions

AttribDefType (string name)
Creates a new instance of AttribDefType with the specified parameters. More...
override string ToString ()
Gets the object's identifier.

Properties

AttribDefValueType | DataType [getset]
Gets or sets the data type of the attribute.
List< string > | Enums [getset]
Gets or sets the enumeration values of the attribute. (may be null)
double | Max [getset]
Gets or sets the maximum value of the attribute.
double | Min [getset]
Gets or sets the minimum value of the attribute.
string | Name [getset]
Gets or sets the ident name.
AttribDefObjectType | ObjectType [getset]
Gets or sets the object type of the attribute.
object | Tag [getset]
Gets or sets the Tag property. More...
object | Value [getset]
Gets or sets the default value of the attribute.
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

CANDb++ Attribute definition type.

Constructor & Destructor Documentation

◆ AttribDefType()

AttribDefType ( string name )

Creates a new instance of AttribDefType with the specified parameters.

Parameters
name The unique attribute name

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • AttribDefType
DBCFile.AttribDefType Member List

This is the complete list of members for DBCFile.AttribDefType, including all inherited members.

AttribDefType(string name) | DBCFile.AttribDefType
DataType | DBCFile.AttribDefType
Enums | DBCFile.AttribDefType
Max | DBCFile.AttribDefType
Min | DBCFile.AttribDefType
Name | DBCFile.AttribDefType
ObjectType | DBCFile.AttribDefType
Tag | DBCFile.AttribDefType
ToString() | DBCFile.AttribDefType
Value | DBCFile.AttribDefType


ASAP2Library interface: DBCFile.AttributeType Class Reference

  • DBC
  • DBCFile
  • AttributeType
Public Member Functions | Properties | List of all members
DBCFile.AttributeType Class Reference

CANDb++ Attribute type. More...

Public Member Functions

AttributeType (AttribDefType attribDef, string value)
override string ToString ()

Properties

AttribDefType | AttribDef [getset]
string | Value [getset]

Detailed Description

CANDb++ Attribute type.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • AttributeType
DBCFile.AttributeType Member List

This is the complete list of members for DBCFile.AttributeType, including all inherited members.

AttribDef (defined in DBCFile.AttributeType) | DBCFile.AttributeType
AttributeType(AttribDefType attribDef, string value) (defined in DBCFile.AttributeType) | DBCFile.AttributeType
ToString() (defined in DBCFile.AttributeType) | DBCFile.AttributeType
Value (defined in DBCFile.AttributeType) | DBCFile.AttributeType


ASAP2Library interface: DBCFile.AttributeTypeDict Class Reference

  • DBC
  • DBCFile
  • AttributeTypeDict
DBCFile.AttributeTypeDict Class Reference

CANDb++ Attributes dictionary. More...

Detailed Description

CANDb++ Attributes dictionary.


ASAP2Library interface: DBCFile.EnumDict Class Reference

  • DBC
  • DBCFile
  • EnumDict
DBCFile.EnumDict Class Reference

Defines a value table dictionary (mapping double values to strings). More...

Detailed Description

Defines a value table dictionary (mapping double values to strings).


ASAP2Library interface: DBCFile.EnvironmentDict Class Reference

  • DBC
  • DBCFile
  • EnvironmentDict
Properties | List of all members
DBCFile.EnvironmentDict Class Reference

Environment dictionary type. More...

Properties

object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

Detailed Description

Environment dictionary type.

Maps CANdb++ environment names to it's corresponding messages.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • EnvironmentDict
DBCFile.EnvironmentDict Member List

This is the complete list of members for DBCFile.EnvironmentDict, including all inherited members.

Tag DBCFile.EnvironmentDict


ASAP2Library interface: DBCFile.EnvironmentType Class Reference

  • DBC
  • DBCFile
  • EnvironmentType
Public Member Functions | Properties | List of all members
DBCFile.EnvironmentType Class Reference

CANDb++ Environment type. More...

Public Member Functions

EnvironmentType (string name, string description)
Creates a new instance of EnvironmentType with the specified parameters. More...
override string ToString ()
Gets the object's identifier.

Properties

EnvAccessType | Access [getset]
Gets or sets the access type of the environment.
AttributeTypeDict | Attributes [getset]
Gets or sets the Attributes dictionary.
string | Comment [getset]
Gets or sets the signal comment.
int | Index [getset]
Gets or sets the start value of the environment.
double | Max [getset]
Gets or sets physical maximum of the environment.
double | Min [getset]
Gets or sets the physical minimum of the environment.
string | Name [getset]
Gets or sets the ident name.
List< string > | Receivers [getset]
Gets or sets the list of receivers.
double | StartValue [getset]
Gets or sets the start value of the environment.
object | Tag [getset]
Gets or sets the Tag property. More...
EnvType | Type [getset]
Gets or sets the type of the environment.
string | Unit [getset]
Gets or sets the unit of the environment.
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

CANDb++ Environment type.

Constructor & Destructor Documentation

◆ EnvironmentType()

EnvironmentType | ( | string | name,
 |  | string | description
 | ) |  |

Creates a new instance of EnvironmentType with the specified parameters.

Parameters
name | The environment name
description | The description (may be null or empty)

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • EnvironmentType
DBCFile.EnvironmentType Member List

This is the complete list of members for DBCFile.EnvironmentType, including all inherited members.

Access | DBCFile.EnvironmentType
Attributes | DBCFile.EnvironmentType
Comment | DBCFile.EnvironmentType
EnvironmentType(string name, string description) | DBCFile.EnvironmentType
Index | DBCFile.EnvironmentType
Max | DBCFile.EnvironmentType
Min | DBCFile.EnvironmentType
Name | DBCFile.EnvironmentType
Receivers | DBCFile.EnvironmentType
StartValue | DBCFile.EnvironmentType
Tag | DBCFile.EnvironmentType
ToString() | DBCFile.EnvironmentType
Type | DBCFile.EnvironmentType
Unit | DBCFile.EnvironmentType


ASAP2Library interface: DBCFile.IDBCAttribute Interface Reference

  • DBC
  • DBCFile
  • IDBCAttribute
Public Member Functions | List of all members
DBCFile.IDBCAttribute Interface Reference

Interface any DBC base class attributes must implement. More...

Public Member Functions

string | toFileDefaultString ()
Builds the DBC default representation string. More...
- Public Member Functions inherited from DBCFile.IDBCBase
string | toFileString ()
Builds the DBC representation string. More...

Additional Inherited Members

- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Interface any DBC base class attributes must implement.

Member Function Documentation

◆ toFileDefaultString()

string toFileDefaultString ( )

Builds the DBC default representation string.

Returns
the DBC default representation string.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • IDBCAttribute
DBCFile.IDBCAttribute Member List

This is the complete list of members for DBCFile.IDBCAttribute, including all inherited members.

Name (defined in DBCFile.IDBCBase) | DBCFile.IDBCBase
Tag | DBCFile.IDBCBase
toFileDefaultString() | DBCFile.IDBCAttribute
toFileString() | DBCFile.IDBCBase


ASAP2Library interface: DBCFile.IDBCBase Interface Reference

  • DBC
  • DBCFile
  • IDBCBase
Public Member Functions | Properties | List of all members
DBCFile.IDBCBase Interface Reference

Interface any DBC base class must implement. More...

Public Member Functions

string toFileString ()
Builds the DBC representation string. More...

Properties

string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Interface any DBC base class must implement.

Member Function Documentation

◆ toFileString()

string toFileString ( )

Builds the DBC representation string.

Returns
the DBC representation string.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • IDBCBase
DBCFile.IDBCBase Member List

This is the complete list of members for DBCFile.IDBCBase, including all inherited members.

Name (defined in DBCFile.IDBCBase) | DBCFile.IDBCBase
Tag | DBCFile.IDBCBase
toFileString() | DBCFile.IDBCBase


ASAP2Library interface: DBCFile.IDBCComment Interface Reference

  • DBC
  • DBCFile
  • IDBCComment
Public Member Functions | List of all members
DBCFile.IDBCComment Interface Reference

Interface any DBC base class supporting comments must implement. More...

Public Member Functions

string | toFileComment ()
Builds the DBC comment string. More...
string | toToolTipString ()
Builds the DBC tooltip string More...
- Public Member Functions inherited from DBCFile.IDBCBase
string | toFileString ()
Builds the DBC representation string. More...

Additional Inherited Members

- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Interface any DBC base class supporting comments must implement.

Member Function Documentation

◆ toFileComment()

string toFileComment ( )

Builds the DBC comment string.

Returns
the DBC comment string.

◆ toToolTipString()

string toToolTipString ( )

Builds the DBC tooltip string

Returns


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • IDBCComment
DBCFile.IDBCComment Member List

This is the complete list of members for DBCFile.IDBCComment, including all inherited members.

Name (defined in DBCFile.IDBCBase) | DBCFile.IDBCBase
Tag | DBCFile.IDBCBase
toFileComment() | DBCFile.IDBCComment
toFileString() | DBCFile.IDBCBase
toToolTipString() | DBCFile.IDBCComment


ASAP2Library interface: DBCFile.IDBCSignal Interface Reference

  • DBC
  • DBCFile
  • IDBCSignal
Public Member Functions | List of all members
DBCFile.IDBCSignal Interface Reference

Interface any DBC base class supporting signals must implement. More...

Public Member Functions

string | toValString ()
Builds the DBC VAL_ string More...
- Public Member Functions inherited from DBCFile.IDBCComment
string | toFileComment ()
Builds the DBC comment string. More...
string | toToolTipString ()
Builds the DBC tooltip string More...
- Public Member Functions inherited from DBCFile.IDBCBase
string | toFileString ()
Builds the DBC representation string. More...

Additional Inherited Members

- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Interface any DBC base class supporting signals must implement.

Member Function Documentation

◆ toValString()

string toValString ( )

Builds the DBC VAL_ string

Returns
a VAL_ string or string.Empty


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • IDBCSignal
DBCFile.IDBCSignal Member List

This is the complete list of members for DBCFile.IDBCSignal, including all inherited members.

Name (defined in DBCFile.IDBCBase) | DBCFile.IDBCBase
Tag | DBCFile.IDBCBase
toFileComment() | DBCFile.IDBCComment
toFileString() | DBCFile.IDBCBase
toToolTipString() | DBCFile.IDBCComment
toValString() | DBCFile.IDBCSignal


ASAP2Library interface: DBCFile.MsgType Class Reference

  • DBC
  • DBCFile
  • MsgType
Public Member Functions | Properties | List of all members
DBCFile.MsgType Class Reference

CANDb++ (DBC) Message type. More...

Public Member Functions

MsgType (string name, string description)
Creates a new instance of MsgType with the specified parameters. More...
void | addSignal (SignalType signal)
Adds a signal to the message. More...
byte[] | createRawData (IDictionary< string, double > signalValues, bool doLimitCheck=false)
Creates a raw data frame for a CAN message with the specified physical signal values. More...
SignalType getMultiplexSignal ()
Gets the defined multiplexor signal within the message (if available, may be null). More...
SignalType | getSignal (string signalName)
Gets the signal to the corresponding signal name. More...
override string | ToString ()

Properties

AttributeTypeDict | Attributes = new AttributeTypeDict() [getset]
Gets or sets the Attributes dictionary.
string | BusID [getset]
Gets the CAN Bus ID from which the value is received.
string | Comment [getset]
Gets or sets the message comment.
byte | DLC [getset]
Gets or sets the message length.
uint | ID [getset]
Gets or sets the raw CAN ID.
string | IDString [get]
Gets a string representation for the CAN ID.
bool | IsValid [get]
Indicates, if the ID is valid (depending on Standard or extended flags).
DateTime | LastUpdate [get]
Gets the timestamp of the last frame value received.
string? | Name [getset]
Gets or sets the ident name.
BigInteger | RawValue [get]
The received rawValue.
int | RawValueLen [get]
Length in byte of received raw value.
List< SignalType > | Signals = new List<SignalType>() [get]
Gets all signals of the message.
SourceType | Source [getset]
Gets or sets the source device.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

CANDb++ (DBC) Message type.

Constructor & Destructor Documentation

◆ MsgType()

MsgType | ( | string | name,
 |  | string | description
 | ) |  |

Creates a new instance of MsgType with the specified parameters.

Parameters
name | The message name
description | The description (may be null or empty)

Member Function Documentation

◆ addSignal()

void addSignal ( SignalType signal )

Adds a signal to the message.

A potential multplexor signal is always inserted in the top of the list.

Parameters
signal The signal to add to the msg

◆ createRawData()

byte[] createRawData | ( | IDictionary< string, double > | signalValues,
 |  | bool | doLimitCheck = false
 | ) |  |

Creates a raw data frame for a CAN message with the specified physical signal values.

Usage example:

var dbcFile = DBCFile.open("CANDbExample.dbc");
var msg = dbcFile.Sources.Values.First(x => x.Name == "RAWDATA_TEST").Messages.First(x => x.Name == "TEST_FLOAT");
var frameData = msg.createRawData(new Dictionary<string, double>() {{ "Value" , -1.253}, { "Muxer", 9 }});
// send without padding (DLC=frameData.Length)
canProvider.send(msg.ID, frameData);
// send with padding bytes (DLC=8, 64)
canProvider.sendMsg(msg.ID, frameData, false, true);
Parameters
signalValues | Specifies a dictionary containing signalName/value pairs
doLimitCheck | Check specified signalValues against the signal's limits
Returns
the raw data frame bytes
Exceptions
ArgumentException Thrown if doLimitCheck is true and a specified value is violating it's defined limits.

◆ getMultiplexSignal()

SignalType getMultiplexSignal ( )

Gets the defined multiplexor signal within the message (if available, may be null).

Returns
the multiplexor signal instance or null.

◆ getSignal()

SignalType getSignal ( string signalName )

Gets the signal to the corresponding signal name.

Parameters
signalName signal's name
Returns
the signal to the corresponding signal name or null if not found.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • MsgType
DBCFile.MsgType Member List

This is the complete list of members for DBCFile.MsgType, including all inherited members.

addSignal(SignalType signal) | DBCFile.MsgType
Attributes | DBCFile.MsgType
BusID | DBCFile.MsgType
Comment | DBCFile.MsgType
createRawData(IDictionary< string, double > signalValues, bool doLimitCheck=false) | DBCFile.MsgType
DLC | DBCFile.MsgType
getMultiplexSignal() | DBCFile.MsgType
getSignal(string signalName) | DBCFile.MsgType
ID | DBCFile.MsgType
IDString | DBCFile.MsgType
IsValid | DBCFile.MsgType
LastUpdate | DBCFile.MsgType
MsgType(string name, string description) | DBCFile.MsgType
Name | DBCFile.MsgType
RawValue | DBCFile.MsgType
RawValueLen | DBCFile.MsgType
Signals | DBCFile.MsgType
Source | DBCFile.MsgType
Tag | DBCFile.MsgType
ToString() (defined in DBCFile.MsgType) | DBCFile.MsgType


ASAP2Library interface: DBCFile.SignalGroupDict Class Reference

  • DBC
  • DBCFile
  • SignalGroupDict
Properties | List of all members
DBCFile.SignalGroupDict Class Reference

Defines a signal group table dictionary (mapping signal group IDs to signal groups). More...

Properties

object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

Detailed Description

Defines a signal group table dictionary (mapping signal group IDs to signal groups).

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • SignalGroupDict
DBCFile.SignalGroupDict Member List

This is the complete list of members for DBCFile.SignalGroupDict, including all inherited members.

Tag DBCFile.SignalGroupDict


ASAP2Library interface: DBCFile.SignalGroupType Class Reference

  • DBC
  • DBCFile
  • SignalGroupType
Properties | List of all members
DBCFile.SignalGroupType Class Reference

Defines the CANDb++ signal group table. More...

Properties

uint | ID [getset]
Gets or sets the ID.
string | Name [getset]
Gets or sets the ident name.
int | Number [getset]
Gets or sets the number.
HashSet< string > | SignalRefs [getset]
Gets or sets the signal references.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

Detailed Description

Defines the CANDb++ signal group table.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • SignalGroupType
DBCFile.SignalGroupType Member List

This is the complete list of members for DBCFile.SignalGroupType, including all inherited members.

ID | DBCFile.SignalGroupType
Name | DBCFile.SignalGroupType
Number | DBCFile.SignalGroupType
SignalRefs | DBCFile.SignalGroupType
Tag | DBCFile.SignalGroupType


ASAP2Library interface: DBCFile.SignalType Class Reference

  • DBC
  • DBCFile
  • SignalType
Public Member Functions | Properties | List of all members
DBCFile.SignalType Class Reference

CANDb++ (DBC) Signal type. More...

Public Member Functions

SignalType (string name, string description)
Creates a new instance of SignalType with the specified parameters. More...
bool | getRawValue (out ulong ui64, out DateTime received)
Gets the most recent raw value received. More...
double | toPhyical ()
Gets the current physical (numerical) value from the signal. More...
double | toPhyical (ulong rawValue)
Gets the current physical (numerical) value from the specified raw value. More...
byte[] | toRaw (double value)
Gets the specified physical value as raw value. More...
override string | ToString ()
Gets the object's identifier.
string | toStringValue (ulong rawValue, ValueObjectFormat format, int decimalCount=3)
Gets the current value as a string representation. More...
string | toStringValue (ValueObjectFormat format=ValueObjectFormat.Physical, int decimalCount=3)
Gets the current value as a string representation. More...

Properties

AttributeTypeDict | Attributes = new AttributeTypeDict() [getset]
Gets or sets the Attributes dictionary.
string | Comment [getset]
Gets or sets the signal comment.
DATA_TYPE???? | DataType [get]
Gets the data type of the raw value.
EnumDict | Enums [getset]
Gets or sets the enum dictionary for the value (may be null).
double | Factor [getset]
Gets or sets the factor value of the signal.
SignalFlagsType | Flags [getset]
Gets or sets the signal flags.
SignalFloatType | FloatType [getset]
Gets or sets the float type of the value.
bool | IsLittleEndian [getset]
Gets or sets the little endian property.
bool | IsMultiplexed [getset]
Gets or sets a value if the signal is multiplexed. More...
bool | IsMultiplexSignal [getset]
Gets or sets the multiplex signal property.
bool | IsSigned [getset]
Gets or sets the signed property.
DateTime? | LastUpdate [get]
Gets the timestamp of the last value received. More...
ushort | Len [getset]
Gets or sets the length of the signal in bits.
ulong | Mask [get]
Gets the computed mask for the raw value.
double | Max [getset]
Gets or sets physical maximum of the signal.
double | Min [getset]
Gets or sets the physical minimum of the signal.
MsgType | Msg [getset]
Gets or sets the message reference.
uint | MultiplexValue [getset]
Gets or sets the multiplex value when the signal is valid. More...
string? | Name [getset]
Gets or sets the ident name.
double | Offset [getset]
Gets or sets the offset value of the signal.
ushort | OriginalStart [get]
Gets the orignal start of the signal.
List< string > | Receivers [getset]
Gets or sets the list of receivers.
ushort | Start [getset]
Gets or sets the start bit of the signal.
object | Tag [getset]
Gets or sets the Tag property. More...
string | Unit [getset]
Gets or sets the unit of the signal.
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

CANDb++ (DBC) Signal type.

Constructor & Destructor Documentation

◆ SignalType()

SignalType | ( | string | name,
 |  | string | description
 | ) |  |

Creates a new instance of SignalType with the specified parameters.

Parameters
name | The signal name
description | The description (may be null or empty)

Member Function Documentation

◆ getRawValue()

bool getRawValue | ( | out ulong | ui64,
 |  | out DateTime | received
 | ) |  |

Gets the most recent raw value received.

Parameters
ui64 | Result if return value is true
received | last received timestamp
Returns
true, if a valid value is available

◆ toPhyical() [1/2]

double toPhyical ( )

Gets the current physical (numerical) value from the signal.

Enumeration values are delivered in their numerical representation.

Returns
double.NaN if the rawValue is undefined else the physical value

◆ toPhyical() [2/2]

double toPhyical ( ulong rawValue )

Gets the current physical (numerical) value from the specified raw value.

Parameters
rawValue The raw value
Returns
the physical value

◆ toRaw()

byte[] toRaw ( double value )

Gets the specified physical value as raw value.

Parameters
value The physical value
Returns
the physical value

◆ toStringValue() [1/2]

string toStringValue | ( | ulong | rawValue,
 |  | ValueObjectFormat | format,
 |  | int | decimalCount = 3
 | ) |  |

Gets the current value as a string representation.

Parameters
rawValue | The raw value
format | The value format to display
decimalCount | Specify a decimal count formatting value (applies only for numerical values if ValueObjectFormat.Physical is set)
Returns
The string represntation of the value (string.Empty if no value is available)

◆ toStringValue() [2/2]

string toStringValue | ( | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | int | decimalCount = 3
 | ) |  |

Gets the current value as a string representation.

Parameters
format | The value format to display
decimalCount | Specify a decimal count formatting value (applies only for numerical values if ValueObjectFormat.Physical is set)
Returns
The string represntation of the value (string.Empty if no value is available)

Property Documentation

◆ IsMultiplexed

bool IsMultiplexed
getset

Gets or sets a value if the signal is multiplexed.

In this case the MultiplexValue is valid.

◆ LastUpdate

DateTime? LastUpdate
get

Gets the timestamp of the last value received.

Returns DateTime:minValue if the signal vaue isn't received yet.

◆ MultiplexValue

uint MultiplexValue
getset

Gets or sets the multiplex value when the signal is valid.

Only valid if the signal is a multiplexed signal (see IsMultiplexed).

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • SignalType
DBCFile.SignalType Member List

This is the complete list of members for DBCFile.SignalType, including all inherited members.

Attributes | DBCFile.SignalType
Comment | DBCFile.SignalType
DataType | DBCFile.SignalType
Enums | DBCFile.SignalType
Factor | DBCFile.SignalType
Flags | DBCFile.SignalType
FloatType | DBCFile.SignalType
getRawValue(out ulong ui64, out DateTime received) | DBCFile.SignalType
IsLittleEndian | DBCFile.SignalType
IsMultiplexed | DBCFile.SignalType
IsMultiplexSignal | DBCFile.SignalType
IsSigned | DBCFile.SignalType
LastUpdate | DBCFile.SignalType
Len | DBCFile.SignalType
Mask | DBCFile.SignalType
Max | DBCFile.SignalType
Min | DBCFile.SignalType
Msg | DBCFile.SignalType
MultiplexValue | DBCFile.SignalType
Name | DBCFile.SignalType
Offset | DBCFile.SignalType
OriginalStart | DBCFile.SignalType
Receivers | DBCFile.SignalType
SignalType(string name, string description) | DBCFile.SignalType
Start | DBCFile.SignalType
Tag | DBCFile.SignalType
toPhyical(ulong rawValue) | DBCFile.SignalType
toPhyical() | DBCFile.SignalType
toRaw(double value) | DBCFile.SignalType
ToString() | DBCFile.SignalType
toStringValue(ValueObjectFormat format=ValueObjectFormat.Physical, int decimalCount=3) | DBCFile.SignalType
toStringValue(ulong rawValue, ValueObjectFormat format, int decimalCount=3) | DBCFile.SignalType
Unit | DBCFile.SignalType


ASAP2Library interface: DBCFile.SourceDict Class Reference

  • DBC
  • DBCFile
  • SourceDict
List of all members
DBCFile.SourceDict Class Reference

Source dictionary type. More...

Detailed Description

Source dictionary type.

Maps CANdb++ source names to it's corresponding messages.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • SourceDict
DBCFile.SourceDict Member List

This is the complete list of members for DBCFile.SourceDict, including all inherited members.


ASAP2Library interface: DBCFile.SourceType Class Reference

  • DBC
  • DBCFile
  • SourceType
Public Member Functions | Properties | List of all members
DBCFile.SourceType Class Reference

CANDb++ (DBC) Device type. More...

Public Member Functions

SourceType (string name, DBCFile parent)
override string ToString ()
Gets the object's identifier.

Properties

AttributeTypeDict | Attributes = new AttributeTypeDict() [getset]
Gets or sets the Attributes dictionary.
string | Comment [getset]
Gets or sets the source comment.
List< MsgType > | Messages = new List<MsgType>() [get]
Gets or sets the source messages.
string? | Name [getset]
Gets or sets the ident name.
DBCFile | Parent [get]
Gets the DBC file instance.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

CANDb++ (DBC) Device type.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • SourceType
DBCFile.SourceType Member List

This is the complete list of members for DBCFile.SourceType, including all inherited members.

Attributes | DBCFile.SourceType
Comment | DBCFile.SourceType
Messages | DBCFile.SourceType
Name | DBCFile.SourceType
Parent | DBCFile.SourceType
SourceType(string name, DBCFile parent) (defined in DBCFile.SourceType) | DBCFile.SourceType
Tag | DBCFile.SourceType
ToString() | DBCFile.SourceType


ASAP2Library interface: DBCFile.ValueTable Class Reference

  • DBC
  • DBCFile
  • ValueTable
Public Member Functions | Properties | List of all members
DBCFile.ValueTable Class Reference

Defines the CANDb++ value table. More...

Public Member Functions

ValueTable (string name)
Creates a new instance of ValueTable with the specified parameters. More...
override string ToString ()
Gets the object's identifier.

Properties

EnumDict | Enum [getset]
Gets or sets the corresponding enumerations.
string | Name [getset]
Gets or sets the ident name.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Defines the CANDb++ value table.

Constructor & Destructor Documentation

◆ ValueTable()

ValueTable ( string name )

Creates a new instance of ValueTable with the specified parameters.

Parameters
name The value table's name

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • ValueTable
DBCFile.ValueTable Member List

This is the complete list of members for DBCFile.ValueTable, including all inherited members.

Enum | DBCFile.ValueTable
Name | DBCFile.ValueTable
Tag | DBCFile.ValueTable
ToString() | DBCFile.ValueTable
ValueTable(string name) | DBCFile.ValueTable


ASAP2Library interface: DBCFile.ValueTableDict Class Reference

  • DBC
  • DBCFile
  • ValueTableDict
Properties | List of all members
DBCFile.ValueTableDict Class Reference

Defines a value table dictionary (mapping value table idents to value tables). More...

Properties

object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from DBCFile.IDBCBase
string | Name [getset]
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

Detailed Description

Defines a value table dictionary (mapping value table idents to value tables).

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • DBC
  • DBCFile
  • ValueTableDict
DBCFile.ValueTableDict Member List

This is the complete list of members for DBCFile.ValueTableDict, including all inherited members.

Tag DBCFile.ValueTableDict


ASAP2Library interface: jnsoft.Diagnose Namespace Reference

  • Diagnose
Namespaces
jnsoft.Diagnose Namespace Reference

Namespaces

namespace | Comm
All the stuff to support various diagnostic service protocols.
namespace | ODX
All the ODX (Open Diagnostic Data Format) stuff.


ASAP2Library interface: jnsoft.Diagnose.Comm Namespace Reference

  • Diagnose
  • Comm
Namespaces | Classes | Enumerations
jnsoft.Diagnose.Comm Namespace Reference

All the stuff to support various diagnostic service protocols. More...

Namespaces

namespace | DoIp
Implements the DoIP (ISO 13400) protocol.
namespace | UDS
Implements the UDS Protocol (ISO 14229-1).

Classes

class | IsoTp
Implements the ISO 15765-2 (IsoTp) protocol. More...
class | IsoTpFSM
Represents the state machine to process an IsoTp message. More...

Enumerations

enum | FlowStatus : byte { ClearToSend , Wait , Overflow }
Possible flow control states. More...
enum | FrameType : byte { SF = 0x00 , FF = 0x01 << 4 , CF = 0x02 << 4 , FC = 0x03 << 4 }
IsoTp frame types. More...
enum | IsoTpType { CAN , CANFD , FlexRay }
Supported IsoTp media types. More...
enum MsgState {
PendingSnd = -4 , PendingSndFC , PendingRcvFC , PendingRcv ,
Success , ErrRequestLenExceeded , ErrMsgInProcess , ErrSendRequest ,
ErrUnexpectedSequenceNo , ErrTimeoutAwaitingCFFrame , ErrReceivedUnexpectedFCFrame , ErrFlowControlOverflow ,
ErrTimeout , ErrUnexpectedRSID , ErrGeneric
}
IsoTp state machine states. More...

Detailed Description

All the stuff to support various diagnostic service protocols.

in particular:

  • ISO 15765-2 (IsoTp) protocol.
  • ISO 14229 (UDS) protocol.
  • ISO 14230 (KWP) protocol (currently not implemented).

See basic documentation ISO 15765-2 (IsoTp) protocol.

Enumeration Type Documentation

◆ FlowStatus

enum FlowStatus : byte

Possible flow control states.

Enumerator
ClearToSend | Next block is allowed to send
Wait | Wait for a further flow control
Overflow | Overflow state

◆ FrameType

enum FrameType : byte

IsoTp frame types.

Enumerator
SF | single frame
FF | first frame
CF | consecutiuve frame
FC | flow control frame

◆ IsoTpType

enum IsoTpType

Supported IsoTp media types.

Enumerator
CAN | IsoTp on CAN (maximum message length = 4096 bytes)
CANFD | IsoTp on CAN FD (maximum message length = 4GB)
FlexRay | IsoTp on FlexRay (maximum message length = 4GB, maximum single frame message = 250 bytes). Not implemented

◆ MsgState

enum MsgState

IsoTp state machine states.

Enumerator
PendingSnd | message needs to send data
PendingSndFC | message needs to send a flow control frame
PendingRcvFC | message waits for flow control frame
PendingRcv | message waits for response data
Success | message is complete (request is successfully sent, response is received (if expected)
ErrRequestLenExceeded | Message request length exeeded
ErrMsgInProcess | A request is already in process
ErrSendRequest | Failed to send a request frame!
ErrUnexpectedSequenceNo | unexpected sequence number
ErrTimeoutAwaitingCFFrame | Timeout awaiting consecutive frame
ErrReceivedUnexpectedFCFrame | received an unexpected flow control frame
ErrFlowControlOverflow | Server reported a Flow control overflow
ErrTimeout | Global request timeout
ErrUnexpectedRSID | Unexpected response service id
ErrGeneric | Generic (unknown) error


ASAP2Library interface: jnsoft.Diagnose.Comm.DoIp Namespace Reference

  • Diagnose
  • Comm
  • DoIp
Classes | Enumerations
jnsoft.Diagnose.Comm.DoIp Namespace Reference

Implements the DoIP (ISO 13400) protocol. More...

Classes

class | AnnoncementEventArgs
Vehicle announcemnet event arguments More...
class | BaseFrame
Base DoIP Frame. More...
class | DiagnosticMessage
Diagnostic message. More...
class | DiagnosticPowerModeResponse
Diagnostic Powermode response. More...
class | DoIPBase
Base class for a DoIP client or server. More...
class | DoIPClient
Implements the DoIP Client. More...
class | DoIPFrameQueue
Queue implementation to store DoIPFrame's. More...
class | DoIPServer
Implements the DoIP Server (this is just used for simulating). More...
class | EntityData
Holds a single Entity. More...
class | EntityStatusResponse
Entity status response More...
class | RespBase
Response base class. More...
class | RoutingActivationResponse
Routing activation response. More...
class | SrcDstFrame
Frame containing a source and destination address. More...
class | SrcFrame
Frame containing a source address. More...
class | VehicleIdResponse
VehicleId response. More...

Enumerations

enum | ActionType : byte { NoFurtherActionRequired , RoutingActivationRequired = 0x10 , Unknown = byte.MaxValue }
Further Action Code Values. More...
enum | Activation : byte { Default , WWH_OBD , CentralSecurity = 0xe0 }
enum ActivationCode : byte {
UnknowSource , DeniedSocketsExceeded , DeniedDifferentSA , DeniedRegisteredSA ,
DeniedMissingAuth , DeniedRejectedConfirmation , DeniedUnsupportedActivationType , DeniedActivationTypeRequiresASecureSocket ,
RoutingActivated = 0x10 , RoutingActivationConfirmationRequired = 0x11
}
Routing Activate codes. More...
enum DiagMsgNackCode : byte {
InvalidSA = 0x02 , UnknownTA = 0x03 , MessageTooLarge = 0x04 , OutOfMemory = 0x05 ,
TargetUnreachable = 0x06 , UnknownNetwork = 0x07 , TpError = 0x08 , None = 0xff
}
Diagnostic message negative acknowledge codes More...
enum DoIPType : ushort {
Nack , VehicleIdRequest , VehicleIdRequestEID , VehicleIdRequestVIN ,
VehicleIdResponse , RoutingActivationRequest , RoutingActivationResponse , AliveCheckRequest ,
AliveCheckResponse , EntityStatusRequest = 0x4001 , EntityStatusResponse , DiagnosticPowerModeRequest ,
DiagnosticPowerModeResponse , DiagnosticMessage = 0x8001 , DiagnosticMessageAck , DiagnosticMessageNack ,
PeriodicDiagnosticMessage
}
DoIP frame payload types. More...
enum NackCode : byte {
IncorrectPatternFormat , UnknownPayloadType , MessageTooLarge , OutOfMemory ,
InvalidPayloadLength , None = 0xff
}
Possible DoIP negative acknowledge codes. More...
enum | NodeType : byte { Gateway , Node }
DoIP entity node types. More...
enum | PowerMode : byte { NotReady , Ready , NotSupported }
Diagnostic power modes. More...
enum | ProtocolVersion : byte { ISO_13400_2010 = 1 , ISO_13400_2012 , ISO_13400_2019 }
Supported DoIP versions. More...
enum ResponseState {
Timeout , SendFailed , Nack , Ack ,
Ok
}
Request response states. More...
enum | SynchStatus : byte { Synchronized , Incomplete = 0x10 , Unknown = byte.MaxValue }
VIN/GID synchronization status code values More...

Detailed Description

Implements the DoIP (ISO 13400) protocol.

Enumeration Type Documentation

◆ ActionType

enum ActionType : byte

Further Action Code Values.

Enumerator
NoFurtherActionRequired | No Further Action Required
RoutingActivationRequired | Routing activation required
Unknown | Undefined value

◆ Activation

enum Activation : byte

Routing activation types.

◆ ActivationCode

enum ActivationCode : byte

Routing Activate codes.

Enumerator
UnknowSource | Routing activation denied due to unknown source address.
DeniedSocketsExceeded | Routing activation denied because all concurrently supported TCP_DATA sockets are registered and active.
DeniedDifferentSA | Routing activation denied because an SA different from the table connection entry was received on the already activated TCP_DATA socket.
DeniedRegisteredSA | Routing activation denied because the SA is already registered and active on a different TCP_DATA socket.
DeniedMissingAuth | Routing activation denied due to missing authentication.
DeniedRejectedConfirmation | Routing activation denied due to rejected confirmation.
DeniedUnsupportedActivationType | Routing activation denied due to unsupported routing activation type.
DeniedActivationTypeRequiresASecureSocket | Routing activation denied, because the specified activation type requires a secure TLS TCP_DATA socket.
RoutingActivated | Routing successfully activated.
RoutingActivationConfirmationRequired | Routing will be activated; confirmation required.

◆ DiagMsgNackCode

enum DiagMsgNackCode : byte

Diagnostic message negative acknowledge codes

Enumerator
InvalidSA | Invalid Source Address
UnknownTA | Unknown Target Address
MessageTooLarge | Diagnostic Message too large
OutOfMemory | Out of memory
TargetUnreachable | Target unreachable
UnknownNetwork | Unknown network
TpError | Transport protocol error
None | No NACK code received so far

◆ DoIPType

enum DoIPType : ushort

DoIP frame payload types.

Enumerator
Nack | Generic DoIP header negative acknowledge
VehicleIdRequest | Vehicle identification request message
VehicleIdRequestEID | Vehicle identification request message with EID
VehicleIdRequestVIN | Vehicle identification request message with VIN
VehicleIdResponse | Vehicle announcement message/Vehicle identification response message
RoutingActivationRequest | Routing activbation request
RoutingActivationResponse | Routing activbation response
AliveCheckRequest | Alive check request
AliveCheckResponse | Alive check response
EntityStatusRequest | Entity status request
EntityStatusResponse | Entity status repsonse
DiagnosticPowerModeRequest | Diagnostic PowerMode request
DiagnosticPowerModeResponse | Diagnostic PowerMode response
DiagnosticMessage | Diagnostic message
DiagnosticMessageAck | Diagnostic message positive response
DiagnosticMessageNack | Diagnostic message negative response
PeriodicDiagnosticMessage | Periodic Diagnostic message

◆ NackCode

enum NackCode : byte

Possible DoIP negative acknowledge codes.

Enumerator
IncorrectPatternFormat | Required action: Close socket.
UnknownPayloadType | Required action: Discard message.
MessageTooLarge | Required action: Discard message.
OutOfMemory | Required action: Discard message.
InvalidPayloadLength | Required action: Close socket.
None | No NACK code received so far

◆ NodeType

enum NodeType : byte

DoIP entity node types.

Enumerator
Gateway | Entity is a Gateway.
Node | Entity is itself a DoIP node.

◆ PowerMode

enum PowerMode : byte

Diagnostic power modes.

Enumerator
NotReady | Not Ready
Ready | Ready
NotSupported | Not Supported

◆ ProtocolVersion

enum ProtocolVersion : byte

Supported DoIP versions.

Enumerator
ISO_13400_2010 | DoIP standard 2010
ISO_13400_2012 | DoIP standard 2012
ISO_13400_2019 | DoIP standard 2019

◆ ResponseState

enum ResponseState

Request response states.

Enumerator
Timeout | Timeout occured.
SendFailed | Send request failed.
Nack | Negative acknowledge (used by Diagnose request)
Ack | Acknowledged (used by Diagnose request)
Ok | Response successully received.

◆ SynchStatus

enum SynchStatus : byte

VIN/GID synchronization status code values

Enumerator
Synchronized | all DoIP entities have synchronized their information about the VIN or GID of the vehicle
Incomplete | synchronization is incomplete
Unknown | Undefined value


ASAP2Library interface: jnsoft.Diagnose.Comm.DoIp.Examples Namespace Reference

  • Diagnose
  • Comm
  • DoIp
  • Examples
Classes
jnsoft.Diagnose.Comm.DoIp.Examples Namespace Reference

Classes

class Program
ASAP2 DoIP Example. More...


ASAP2Library interface: Program Class Reference

  • Diagnose
  • Comm
  • DoIp
  • Examples
  • Program
List of all members
Program Class Reference

ASAP2 DoIP Example. More...

Detailed Description

ASAP2 DoIP Example.

This example collects DoIP Vehicle announcements on the specified local IPAddress.

  • A DoIP Client is created to access a DoIP gateway
  • Two UDS client are created to request TesterPresent commands

Usage: ASAP2DoIPExample 192.168.0.2


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: AnnoncementEventArgs Class Reference

  • Diagnose
  • Comm
  • DoIp
  • AnnoncementEventArgs
Public Attributes | List of all members
AnnoncementEventArgs Class Reference

Vehicle announcemnet event arguments More...

Public Attributes

readonly EntityData Entity
The Vehicle ID response.

Detailed Description

Vehicle announcemnet event arguments


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • AnnoncementEventArgs
AnnoncementEventArgs Member List

This is the complete list of members for AnnoncementEventArgs, including all inherited members.

Entity AnnoncementEventArgs


ASAP2Library interface: BaseFrame Class Reference

  • Diagnose
  • Comm
  • DoIp
  • BaseFrame
Public Member Functions | Public Attributes | Properties | List of all members
BaseFrame Class Reference

Base DoIP Frame. More...

Public Member Functions

BaseFrame (ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
virtual byte[] | ToArray ()
Gets the raw frame bytes. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
override string | ToString ()
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Public Attributes

readonly EndPoint | Sender
Frame sender
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Properties

bool | IsError [get]
Indicates if the frame is an erro frame.
SocketType | SocketType [getset]
Media type
DoIPType | Type [getset]
Frame type
ProtocolVersion | Version [getset]
Protocol version
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Base DoIP Frame.

Converts DoIP frames from and to plain data bytes.

Constructor & Destructor Documentation

◆ BaseFrame()

BaseFrame | ( | ProtocolVersion | version,
 |  | DoIPType | type,
 |  | SocketType | socketType,
 |  | EndPoint | sender,
 |  | byte[] | data = null,
 |  | bool | isMasterFrame = false
 | ) |  |

Builds a frame from the specified parameters.

Parameters
version | Protocol version
type | Frame type
socketType | Socket type
sender | Received from
data | Payload data
isMasterFrame | Indicates if the frame is a master frame

Member Function Documentation

◆ ToArray()

virtual byte[] ToArray ( )
virtual

Gets the raw frame bytes.

Returns

Reimplemented in SrcFrame, and SrcDstFrame.

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the frame.

Returns
the string representation

Implements Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the frame.

Returns
the string representation

Implements Frame.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • BaseFrame
BaseFrame Member List

This is the complete list of members for BaseFrame, including all inherited members.

BaseFrame(ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | BaseFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
IsError | BaseFrame |
IsMasterFrame | Frame |
Sender | BaseFrame |
SocketType | BaseFrame |
ToArray() | BaseFrame | virtual
toClipboard() | BaseFrame | virtual
toCSV() | BaseFrame | virtual
ToString() (defined in BaseFrame) | BaseFrame |
Type | BaseFrame |
Version | BaseFrame |


ASAP2Library interface: DiagnosticMessage Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DiagnosticMessage
List of all members
DiagnosticMessage Class Reference

Diagnostic message. More...

Additional Inherited Members

- Properties inherited from RespBase
BaseFrame Frame [getset]
The reponse frame itself.

Detailed Description

Diagnostic message.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DiagnosticMessage
DiagnosticMessage Member List

This is the complete list of members for DiagnosticMessage, including all inherited members.

Frame RespBase


ASAP2Library interface: DiagnosticPowerModeResponse Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DiagnosticPowerModeResponse
Properties | List of all members
DiagnosticPowerModeResponse Class Reference

Diagnostic Powermode response. More...

Properties

PowerMode | PowerMode [get]
Power mode
- Properties inherited from RespBase
BaseFrame | Frame [getset]
The reponse frame itself.

Detailed Description

Diagnostic Powermode response.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DiagnosticPowerModeResponse
DiagnosticPowerModeResponse Member List

This is the complete list of members for DiagnosticPowerModeResponse, including all inherited members.

Frame | RespBase
PowerMode | DiagnosticPowerModeResponse


ASAP2Library interface: DoIPBase Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | Static Protected Member Functions | Protected Attributes | Properties | List of all members
DoIPBase Class Reference

Base class for a DoIP client or server. More...

Classes

class | Communicator
Holds a Socket, sender endpoint, receive buffer and stream length/position. More...
class | ResponseEvent
Used to wait for and handle responses. More...

Public Member Functions

DoIPBase (ProtocolVersion version)
Create a new instance with the specified paramter. More...
virtual void | Dispose ()
virtual void | OnResponseReceived (Communicator comm, EndPoint sender, BaseFrame frame)
Called for any received frame. More...

Static Public Attributes

const ushort | DefaultPort = 13400
DoIP Port
const ushort | DefaultTLSPort = 3496
Secure (TLS) DoIP Port .

Protected Member Functions

virtual void | OnNackReceived (NackCode nack)
void | receive (IAsyncResult ar)
TCP/UDP data received handler. More...

Static Protected Member Functions

static Socket | createBroadcastSocket (AddressFamily addressFamily)
Creates an UDP broadcast socket. More...
static IPAddress | getBroadcastIp (AddressFamily addressFamily)
Gets the broadcast IP address depending on IP/IPV6 More...
static IPAddress | getBroadcastIp (IPEndPoint endPoint)
Gets the broadcast IP address depending on IP/IPV6 More...
static ResponseState | sendAndWait< T > (Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response)
Sends the specified diagnostic frame and waits for an response using Tcp. More...
static bool | tryAcquire (Communicator comm, EndPoint sender, out BaseFrame frame)
Tries to acquire a DoIP frame from the specified data. More...

Protected Attributes

List< Communicator > | mComms = new List<Communicator>()
TcpListener | mListener
readonly ProtocolVersion | mVersion
Used protocol version.

Properties

DiagMsgNackCode | LastDiagNackCode = DiagMsgNackCode.None [getset]
Last Diagnostic message NACK code received.
NackCode | LastNackCode = NackCode.None [getset]
Last NACK code received.
bool | ReflectDiagMessageOnAcknowledge [getset]
If set, a the Diagnostic message acknowledge echoes the diagnostic message data.
static int | Timeout = 200 [getset]
DoIP timeout to wait for responses.

Detailed Description

Base class for a DoIP client or server.

Does the Tcp/Udp socket handling and acquires received DoIPFrames.

Constructor & Destructor Documentation

◆ DoIPBase()

DoIPBase ( ProtocolVersion version )

Create a new instance with the specified paramter.

Parameters
timeout | Response timeout for requests in [ms]
version | The protocol version

Member Function Documentation

◆ createBroadcastSocket()

static Socket createBroadcastSocket ( AddressFamily addressFamily )
staticprotected

Creates an UDP broadcast socket.

Parameters
addressFamily The address family
Returns
The Udp socket

◆ getBroadcastIp() [1/2]

static IPAddress getBroadcastIp ( AddressFamily addressFamily )
staticprotected

Gets the broadcast IP address depending on IP/IPV6

Parameters
addressFamily The address family
Returns
The broadcast Ip

◆ getBroadcastIp() [2/2]

static IPAddress getBroadcastIp ( IPEndPoint endPoint )
staticprotected

Gets the broadcast IP address depending on IP/IPV6

Parameters
endPoint The local address
Returns
The broadcast Ip

◆ OnResponseReceived()

virtual void OnResponseReceived | ( | Communicator | comm,
 |  | EndPoint | sender,
 |  | BaseFrame | frame
 | ) |  |
virtual

Called for any received frame.

Parameters
comm | The communicator the frame was received from
sender | The sending Endpoint
frame

Reimplemented in DoIPClient, and DoIPServer.

◆ receive()

void receive ( IAsyncResult ar )
protected

TCP/UDP data received handler.

Parameters
ar

◆ sendAndWait< T >()

static ResponseState sendAndWait< T > | ( | Communicator | comm,
 |  | BaseFrame | frame,
 |  | int | timeout,
 |  | EndPoint | remoteEp,
 |  | out T | response
 | ) |  |
staticprotected

Sends the specified diagnostic frame and waits for an response using Tcp.

Parameters
comm | The communicator to use
frame | Request frame
timeout | timeout in [ms]
remoteEp | The target Endpoint
response | Received response is return value is ResponseState.Ok
Returns
The response state
Type Constraints
T : RespBase
T : new()

◆ tryAcquire()

static bool tryAcquire | ( | Communicator | comm,
 |  | EndPoint | sender,
 |  | out BaseFrame | frame
 | ) |  |
staticprotected

Tries to acquire a DoIP frame from the specified data.

Parameters
comm | The communicator to read from
sender | The sending Endpoint
frame | The frame read, if return value is true
Returns
true if a complete frame is acquired


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
DoIPBase Member List

This is the complete list of members for DoIPBase, including all inherited members.

createBroadcastSocket(AddressFamily addressFamily) | DoIPBase | protectedstatic
DefaultPort | DoIPBase | static
DefaultTLSPort | DoIPBase | static
Dispose() (defined in DoIPBase) | DoIPBase | virtual
DoIPBase(ProtocolVersion version) | DoIPBase |
getBroadcastIp(AddressFamily addressFamily) | DoIPBase | protectedstatic
getBroadcastIp(IPEndPoint endPoint) | DoIPBase | protectedstatic
LastDiagNackCode | DoIPBase |
LastNackCode | DoIPBase |
mComms (defined in DoIPBase) | DoIPBase | protected
mListener (defined in DoIPBase) | DoIPBase | protected
mVersion | DoIPBase | protected
OnNackReceived(NackCode nack) (defined in DoIPBase) | DoIPBase | protectedvirtual
OnResponseReceived(Communicator comm, EndPoint sender, BaseFrame frame) | DoIPBase | virtual
receive(IAsyncResult ar) | DoIPBase | protected
ReflectDiagMessageOnAcknowledge | DoIPBase |
sendAndWait< T >(Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response) | DoIPBase | protectedstatic
Timeout | DoIPBase | static
tryAcquire(Communicator comm, EndPoint sender, out BaseFrame frame) | DoIPBase | protectedstatic


ASAP2Library interface: DoIPBase.Communicator Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
  • Communicator
Public Member Functions | Public Attributes | Properties | List of all members
DoIPBase.Communicator Class Reference

Holds a Socket, sender endpoint, receive buffer and stream length/position. More...

Public Member Functions

Communicator (Socket socket, AsyncCallback receive, IPEndPoint localEP=null, bool logTo=false)
Creates a new DoIP communicator (usually a Tcp or UdP socket). More...
void | Dispose ()
bool | sendTo (BaseFrame frame, EndPoint ep)

Public Attributes

readonly ResponseEvent | Event
Used to handle Request/Response messages stuff.
readonly EndPoint | TcpRemoteEP
Remote endpoint on a Tcp connection.

Properties

Socket Socket [getset]

Detailed Description

Holds a Socket, sender endpoint, receive buffer and stream length/position.

Constructor & Destructor Documentation

◆ Communicator()

Communicator | ( | Socket | socket,
 |  | AsyncCallback | receive,
 |  | IPEndPoint | localEP = null,
 |  | bool | logTo = false
 | ) |  |

Creates a new DoIP communicator (usually a Tcp or UdP socket).

Parameters
socket | Socket to use
receive | Receive method
localEP | Local endpoint
logTo | true if frames should logged


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
  • Communicator
DoIPBase.Communicator Member List

This is the complete list of members for DoIPBase.Communicator, including all inherited members.

Communicator(Socket socket, AsyncCallback receive, IPEndPoint localEP=null, bool logTo=false) | DoIPBase.Communicator
Dispose() (defined in DoIPBase.Communicator) | DoIPBase.Communicator
Event | DoIPBase.Communicator
sendTo(BaseFrame frame, EndPoint ep) (defined in DoIPBase.Communicator) | DoIPBase.Communicator
Socket (defined in DoIPBase.Communicator) | DoIPBase.Communicator
TcpRemoteEP | DoIPBase.Communicator


ASAP2Library interface: DoIPBase.ResponseEvent Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
  • ResponseEvent
Public Member Functions | Public Attributes | Properties | List of all members
DoIPBase.ResponseEvent Class Reference

Used to wait for and handle responses. More...

Public Member Functions

void | Dispose ()
void | OnReceived (ResponseState state, BaseFrame frame)
Called if the response event is signalled More...
void | Restart (BaseFrame request)
Called if a new request is started More...

Public Attributes

readonly ManualResetEvent | Ev = new ManualResetEvent(false)
ResponseState | State

Properties

BaseFrame | Request [get]
BaseFrame | Response [get]

Detailed Description

Used to wait for and handle responses.

Member Function Documentation

◆ OnReceived()

void OnReceived | ( | ResponseState | state,
 |  | BaseFrame | frame
 | ) |  |

Called if the response event is signalled

Parameters
state | Response state from frame
frame | Response frame

◆ Restart()

void Restart ( BaseFrame request )

Called if a new request is started

Parameters
request The request frame


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPBase
  • ResponseEvent
DoIPBase.ResponseEvent Member List

This is the complete list of members for DoIPBase.ResponseEvent, including all inherited members.

Dispose() (defined in DoIPBase.ResponseEvent) | DoIPBase.ResponseEvent
Ev (defined in DoIPBase.ResponseEvent) | DoIPBase.ResponseEvent
OnReceived(ResponseState state, BaseFrame frame) | DoIPBase.ResponseEvent
Request (defined in DoIPBase.ResponseEvent) | DoIPBase.ResponseEvent
Response (defined in DoIPBase.ResponseEvent) | DoIPBase.ResponseEvent
Restart(BaseFrame request) | DoIPBase.ResponseEvent
State (defined in DoIPBase.ResponseEvent) | DoIPBase.ResponseEvent


ASAP2Library interface: DoIPClient Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPClient
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Properties | Events | List of all members
DoIPClient Class Reference

Implements the DoIP Client. More...

Public Member Functions

DoIPClient (IPAddress localIp, AnnoncementEventArgs announcement, Activation activationType=Activation.Default, ushort srcAdr=DefaultTesterAdr)
Creates a DoIP client from a More...
DoIPClient (IPAddress remoteIp, IPAddress localIp, Activation activationType=Activation.Default, ushort srcAdr=DefaultTesterAdr, ushort dstAdr=DefaultEntityAdr, ProtocolVersion version=ProtocolVersion.ISO_13400_2019)
Creates an Diagnose over IP Tester. More...
MsgState | DiagnoseRequest (int p2Client, List< byte > reqData, List< byte > resData)
Executes a diagnose request (to support the UDS protocol). More...
ResponseState | DiagnosticPowerMode (out DiagnosticPowerModeResponse response, int timeout=0)
Requests the diagnostic power mode. More...
ResponseState | EntityStatus (out EntityStatusResponse response, int timeout=0)
Requests the entity status. More...
override void | OnResponseReceived (Communicator comm, EndPoint sender, BaseFrame frame)
Called for any received frame. More...
ResponseState | RoutingActivation (out RoutingActivationResponse response, Activation type=Activation.Default, uint reservedByIso=0, uint reservedByOEM=0, int timeout=0)
Routing activation request. More...
- Public Member Functions inherited from DoIPBase
DoIPBase (ProtocolVersion version)
Create a new instance with the specified paramter. More...
virtual void | Dispose ()

Static Public Member Functions

static void | StartListenToEntityAnnouncement (IPAddress localIp, ushort port=DefaultPort)
Starts listeniing to entity announcements. More...
static void | StopListenToEntityAnnouncement ()
Starts listeniing to entity announcements. More...
static void | VehicleIdRequest (ProtocolVersion version, byte[] EID, ushort remotePort=DefaultPort)
Requests Vehicle announcements filtered by the EID. More...
static void | VehicleIdRequest (ProtocolVersion version, string VIN, ushort remotePort=DefaultPort)
Requests Vehicle announcements filtered by the VIN. More...
static void | VehicleIdRequest (ProtocolVersion version, ushort remotePort=DefaultPort)
Requests Vehicle announcements. More...

Public Attributes

readonly Activation | ActivationType
Type of routing activation to use.
readonly IPAddress | LocalIp
The local EndPoint.
readonly IPEndPoint | RemoteEp
The remote EndPoint.
readonly ushort | SrcAdr
Logical source address of the client.

Static Public Attributes

const ushort | DefaultEntityAdr = 0x1000
Default DoIP entity logical address.
const ushort | DefaultTesterAdr = 0xE80
Default Tester logical address.
static readonly IDictionary< string, EntityData > | Entities = new Dictionary<string, EntityData>()
Received DoIP Entities. More...
static readonly IDictionary< string, Tuple< IPAddress, NetworkInterface > > | Interfaces = new SortedDictionary<string, Tuple<IPAddress, NetworkInterface>>()
Currently known IPV4/IPV6 enabled networks. More...
- Static Public Attributes inherited from DoIPBase
const ushort | DefaultPort = 13400
DoIP Port
const ushort | DefaultTLSPort = 3496
Secure (TLS) DoIP Port .

Properties

ushort | DstAdr [getset]
Logical destination address.
- Properties inherited from DoIPBase
DiagMsgNackCode | LastDiagNackCode = DiagMsgNackCode.None [getset]
Last Diagnostic message NACK code received.
NackCode | LastNackCode = NackCode.None [getset]
Last NACK code received.
bool | ReflectDiagMessageOnAcknowledge [getset]
If set, a the Diagnostic message acknowledge echoes the diagnostic message data.
static int | Timeout = 200 [getset]
DoIP timeout to wait for responses.

Events

static EventHandler< AnnoncementEventArgs > | EntityAnnounced
Event to receive Entity announcments. More...
static EventHandler | NetworkInterfaceChanged
Network interface is changed

Additional Inherited Members

- Protected Member Functions inherited from DoIPBase
virtual void | OnNackReceived (NackCode nack)
void | receive (IAsyncResult ar)
TCP/UDP data received handler. More...
- Static Protected Member Functions inherited from DoIPBase
static Socket | createBroadcastSocket (AddressFamily addressFamily)
Creates an UDP broadcast socket. More...
static IPAddress | getBroadcastIp (AddressFamily addressFamily)
Gets the broadcast IP address depending on IP/IPV6 More...
static IPAddress | getBroadcastIp (IPEndPoint endPoint)
Gets the broadcast IP address depending on IP/IPV6 More...
static ResponseState | sendAndWait< T > (Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response)
Sends the specified diagnostic frame and waits for an response using Tcp. More...
static bool | tryAcquire (Communicator comm, EndPoint sender, out BaseFrame frame)
Tries to acquire a DoIP frame from the specified data. More...
- Protected Attributes inherited from DoIPBase
List< Communicator > | mComms = new List<Communicator>()
TcpListener | mListener
readonly ProtocolVersion | mVersion
Used protocol version.

Detailed Description

Implements the DoIP Client.

Constructor & Destructor Documentation

◆ DoIPClient() [1/2]

DoIPClient | ( | IPAddress | remoteIp,
 |  | IPAddress | localIp,
 |  | Activation | activationType = Activation.Default,
 |  | ushort | srcAdr = DefaultTesterAdr,
 |  | ushort | dstAdr = DefaultEntityAdr,
 |  | ProtocolVersion | version = ProtocolVersion.ISO_13400_2019
 | ) |  |

Creates an Diagnose over IP Tester.

Parameters
remoteIp | The IP address of the DoIP entity
localIp | The IP address of a local machine network card to use the DoIP client on
activationType | Routing Activation Type to use
srcAdr | Logical source address of the client.
dstAdr | Logical destination address
version | The DoIP version to use
Exceptions
TimeoutException Thrown, if the remote server is not reachable

◆ DoIPClient() [2/2]

DoIPClient | ( | IPAddress | localIp,
 |  | AnnoncementEventArgs | announcement,
 |  | Activation | activationType = Activation.Default,
 |  | ushort | srcAdr = DefaultTesterAdr
 | ) |  |

Creates a DoIP client from a

Parameters
localIp
announcement
activationType | Routing Activation Type to use
srcAdr | Logical source address of the client.
Exceptions
TimeoutException Thrown, if the remote server is not reachable

Member Function Documentation

◆ DiagnoseRequest()

MsgState DiagnoseRequest | ( | int | p2Client,
 |  | List< byte > | reqData,
 |  | List< byte > | resData
 | ) |  |

Executes a diagnose request (to support the UDS protocol).

Parameters
p2Client | Time between end of tester request and start of ECU response
reqData | Request data bytes (UDS request)
resData | [out] responded data bytes (UDS response)
Returns
The DoIP response state

◆ DiagnosticPowerMode()

ResponseState DiagnosticPowerMode | ( | out DiagnosticPowerModeResponse | response,
 |  | int | timeout = 0
 | ) |  |

Requests the diagnostic power mode.

Parameters
response | Response if return value is ResponseState.Ok
timeout | set a timeout to override the default
Returns
The DoIP response state

◆ EntityStatus()

ResponseState EntityStatus | ( | out EntityStatusResponse | response,
 |  | int | timeout = 0
 | ) |  |

Requests the entity status.

Parameters
response | Response if return value is ResponseState.Ok
timeout | set a timeout to override the default
Returns
The DoIP response state

◆ OnResponseReceived()

override void OnResponseReceived | ( | Communicator | comm,
 |  | EndPoint | sender,
 |  | BaseFrame | frame
 | ) |  |
virtual

Called for any received frame.

Parameters
comm | The communicator the frame was received from
sender | The sending Endpoint
frame

Reimplemented from DoIPBase.

◆ RoutingActivation()

ResponseState RoutingActivation | ( | out RoutingActivationResponse | response,
 |  | Activation | type = Activation.Default,
 |  | uint | reservedByIso = 0,
 |  | uint | reservedByOEM = 0,
 |  | int | timeout = 0
 | ) |  |

Routing activation request.

Parameters
response | The response if the return value is ResponseState.Ok
type | The routing type
reservedByIso
reservedByOEM
timeout | set a timeout to override the default
Returns
The DoIP response state

◆ StartListenToEntityAnnouncement()

static void StartListenToEntityAnnouncement | ( | IPAddress | localIp,
 |  | ushort | port = DefaultPort
 | ) |  |
static

Starts listeniing to entity announcements.

Use the VehicleAnnounced event to handle the announcements.

Parameters
localIp | The IP address of a local machine network card to use the DoIP client on
port | Usually the default port 13400

◆ StopListenToEntityAnnouncement()

static void StopListenToEntityAnnouncement ( )
static

Starts listeniing to entity announcements.

Use the event EntityAnnounced to receive the announcements.

◆ VehicleIdRequest() [1/3]

static void VehicleIdRequest | ( | ProtocolVersion | version,
 |  | byte[] | EID,
 |  | ushort | remotePort = DefaultPort
 | ) |  |
static

Requests Vehicle announcements filtered by the EID.

The request is done as a UDP broadcast, responses are delivered with the EntityAnnounced event.

Parameters
version | The DoIP protocol version to use
EID | This is the DoIP entity's 6 bytes long unique ID. (e.g. network interface's MAC address) that shall respond to the vehicle identification request message.
remotePort | Usually the default DoIP port 13400

◆ VehicleIdRequest() [2/3]

static void VehicleIdRequest | ( | ProtocolVersion | version,
 |  | string | VIN,
 |  | ushort | remotePort = DefaultPort
 | ) |  |
static

Requests Vehicle announcements filtered by the VIN.

The request is done as a UDP broadcast, responses are delivered with the EntityAnnounced event.

Parameters
version | The DoIP protocol version to use
VIN | VIN (usually a 17 byte string)
remotePort | Usually the default DoIP port 13400

◆ VehicleIdRequest() [3/3]

static void VehicleIdRequest | ( | ProtocolVersion | version,
 |  | ushort | remotePort = DefaultPort
 | ) |  |
static

Requests Vehicle announcements.

The request is done as a UDP broadcast, responses are delivered with the EntityAnnounced event.

Parameters
version | The DoIP protocol version to use
remotePort | Usually the default DoIP port 13400

Member Data Documentation

◆ Entities

readonly IDictionary<string, EntityData> Entities = new Dictionary<string, EntityData>()
static

Received DoIP Entities.

Access to this property requires always synchronsiation!

Example: lock(DoIPClient.Entities) { var if = DoIPClient.Entities.First(); }

◆ Interfaces

readonly IDictionary<string, Tuple<IPAddress, NetworkInterface> > Interfaces = new SortedDictionary<string, Tuple<IPAddress, NetworkInterface>>()
static

Currently known IPV4/IPV6 enabled networks.

Access to this property requires always synchronsiation!

Example: lock(DoIPClient.Interfaces) { var if = DoIPClient.Interfaces.First(); }

Event Documentation

◆ EntityAnnounced

EventHandler<AnnoncementEventArgs> EntityAnnounced
static

Event to receive Entity announcments.

The local port 34000 is used to receive vehicle announcements.

  • It is usual that the same vehciles are announced more than once (e.g. if they're rebooted)
  • It is usaul that Vehicle from multiple DoIP entities are received here.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPClient
DoIPClient Member List

This is the complete list of members for DoIPClient, including all inherited members.

ActivationType | DoIPClient |
createBroadcastSocket(AddressFamily addressFamily) | DoIPBase | protectedstatic
DefaultEntityAdr | DoIPClient | static
DefaultPort | DoIPBase | static
DefaultTesterAdr | DoIPClient | static
DefaultTLSPort | DoIPBase | static
DiagnoseRequest(int p2Client, List< byte > reqData, List< byte > resData) | DoIPClient |
DiagnosticPowerMode(out DiagnosticPowerModeResponse response, int timeout=0) | DoIPClient |
Dispose() (defined in DoIPBase) | DoIPBase | virtual
DoIPBase(ProtocolVersion version) | DoIPBase |
DoIPClient(IPAddress remoteIp, IPAddress localIp, Activation activationType=Activation.Default, ushort srcAdr=DefaultTesterAdr, ushort dstAdr=DefaultEntityAdr, ProtocolVersion version=ProtocolVersion.ISO_13400_2019) | DoIPClient |
DoIPClient(IPAddress localIp, AnnoncementEventArgs announcement, Activation activationType=Activation.Default, ushort srcAdr=DefaultTesterAdr) | DoIPClient |
DstAdr | DoIPClient |
Entities | DoIPClient | static
EntityAnnounced | DoIPClient | static
EntityStatus(out EntityStatusResponse response, int timeout=0) | DoIPClient |
getBroadcastIp(AddressFamily addressFamily) | DoIPBase | protectedstatic
getBroadcastIp(IPEndPoint endPoint) | DoIPBase | protectedstatic
Interfaces | DoIPClient | static
LastDiagNackCode | DoIPBase |
LastNackCode | DoIPBase |
LocalIp | DoIPClient |
mComms (defined in DoIPBase) | DoIPBase | protected
mListener (defined in DoIPBase) | DoIPBase | protected
mVersion | DoIPBase | protected
NetworkInterfaceChanged | DoIPClient | static
OnNackReceived(NackCode nack) (defined in DoIPBase) | DoIPBase | protectedvirtual
OnResponseReceived(Communicator comm, EndPoint sender, BaseFrame frame) | DoIPClient | virtual
receive(IAsyncResult ar) | DoIPBase | protected
ReflectDiagMessageOnAcknowledge | DoIPBase |
RemoteEp | DoIPClient |
RoutingActivation(out RoutingActivationResponse response, Activation type=Activation.Default, uint reservedByIso=0, uint reservedByOEM=0, int timeout=0) | DoIPClient |
sendAndWait< T >(Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response) | DoIPBase | protectedstatic
SrcAdr | DoIPClient |
StartListenToEntityAnnouncement(IPAddress localIp, ushort port=DefaultPort) | DoIPClient | static
StopListenToEntityAnnouncement() | DoIPClient | static
Timeout | DoIPBase | static
tryAcquire(Communicator comm, EndPoint sender, out BaseFrame frame) | DoIPBase | protectedstatic
VehicleIdRequest(ProtocolVersion version, ushort remotePort=DefaultPort) | DoIPClient | static
VehicleIdRequest(ProtocolVersion version, string VIN, ushort remotePort=DefaultPort) | DoIPClient | static
VehicleIdRequest(ProtocolVersion version, byte[] EID, ushort remotePort=DefaultPort) | DoIPClient | static


ASAP2Library interface: DoIPFrameQueue Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPFrameQueue
Public Member Functions | Properties | List of all members
DoIPFrameQueue Class Reference

Queue implementation to store DoIPFrame's. More...

Public Member Functions

void | enqueueFrame (BaseFrame frame)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< BaseFrame >
virtual void | clear ()
Clears the frame queue.
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

static DoIPFrameQueue | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< BaseFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< BaseFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< BaseFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< BaseFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store DoIPFrame's.

Member Function Documentation

◆ enqueueFrame()

void enqueueFrame ( BaseFrame frame )

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore access to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame The frame to add


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPFrameQueue
DoIPFrameQueue Member List

This is the complete list of members for DoIPFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< BaseFrame > | protected
clear() | FrameQueue< BaseFrame > | virtual
Dispose() | FrameQueue< BaseFrame > | virtual
enqueueFrame(BaseFrame frame) | DoIPFrameQueue |
FrameEnqueued | FrameQueue< BaseFrame > |
getFrames(out int cntFrames) | FrameQueue< BaseFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< BaseFrame > |
Instance | DoIPFrameQueue | static
IsWritingToFile | FrameQueue< BaseFrame > |
LogFileCSVHeader (defined in DoIPFrameQueue) | DoIPFrameQueue |
LogFileName (defined in DoIPFrameQueue) | DoIPFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< BaseFrame > |


ASAP2Library interface: DoIPServer Class Reference

  • Diagnose
  • Comm
  • DoIp
  • DoIPServer
Public Member Functions | Public Attributes | List of all members
DoIPServer Class Reference

Implements the DoIP Server (this is just used for simulating). More...

Public Member Functions

DoIPServer (ProtocolVersion version, IPAddress localIp, ushort port=DefaultPort, ushort logicalAdr=DoIPClient.DefaultEntityAdr)
Creates an Diagnose over IP Tester. More...
ResponseState | AliveRequest (Communicator comm, out RespBase response, int timeout=0)
override void | Dispose ()
void | executeAliveRequests ()
DOes an Alive request on all connected TCP clients. More...
override void | OnResponseReceived (Communicator comm, EndPoint sender, BaseFrame frame)
Called for any received frame. More...
- Public Member Functions inherited from DoIPBase
DoIPBase (ProtocolVersion version)
Create a new instance with the specified paramter. More...

Public Attributes

readonly IPEndPoint | LocalEp
The locel Endpoint
readonly ushort | LogicalAdr
The logical server DoIP source address.

Additional Inherited Members

- Static Public Attributes inherited from DoIPBase
const ushort | DefaultPort = 13400
DoIP Port
const ushort | DefaultTLSPort = 3496
Secure (TLS) DoIP Port .
- Protected Member Functions inherited from DoIPBase
virtual void | OnNackReceived (NackCode nack)
void | receive (IAsyncResult ar)
TCP/UDP data received handler. More...
- Static Protected Member Functions inherited from DoIPBase
static Socket | createBroadcastSocket (AddressFamily addressFamily)
Creates an UDP broadcast socket. More...
static IPAddress | getBroadcastIp (AddressFamily addressFamily)
Gets the broadcast IP address depending on IP/IPV6 More...
static IPAddress | getBroadcastIp (IPEndPoint endPoint)
Gets the broadcast IP address depending on IP/IPV6 More...
static ResponseState | sendAndWait< T > (Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response)
Sends the specified diagnostic frame and waits for an response using Tcp. More...
static bool | tryAcquire (Communicator comm, EndPoint sender, out BaseFrame frame)
Tries to acquire a DoIP frame from the specified data. More...
- Protected Attributes inherited from DoIPBase
List< Communicator > | mComms = new List<Communicator>()
TcpListener | mListener
readonly ProtocolVersion | mVersion
Used protocol version.
- Properties inherited from DoIPBase
DiagMsgNackCode | LastDiagNackCode = DiagMsgNackCode.None [getset]
Last Diagnostic message NACK code received.
NackCode | LastNackCode = NackCode.None [getset]
Last NACK code received.
bool | ReflectDiagMessageOnAcknowledge [getset]
If set, a the Diagnostic message acknowledge echoes the diagnostic message data.
static int | Timeout = 200 [getset]
DoIP timeout to wait for responses.

Detailed Description

Implements the DoIP Server (this is just used for simulating).

Simulates 4 Vehicle on DoIP requests.

Constructor & Destructor Documentation

◆ DoIPServer()

DoIPServer | ( | ProtocolVersion | version,
 |  | IPAddress | localIp,
 |  | ushort | port = DefaultPort,
 |  | ushort | logicalAdr = DoIPClient.DefaultEntityAdr
 | ) |  |

Creates an Diagnose over IP Tester.

Parameters
version | Protocol version (default is 2)
localIp | The IP address of a local machine network card to use the DoIP server on
port | Tester local port (default is 13400)
logicalAdr | The DoIP server's logical address

Member Function Documentation

◆ Dispose()

override void Dispose ( )
virtual

Reimplemented from DoIPBase.

◆ executeAliveRequests()

void executeAliveRequests ( )

DOes an Alive request on all connected TCP clients.

Returns

◆ OnResponseReceived()

override void OnResponseReceived | ( | Communicator | comm,
 |  | EndPoint | sender,
 |  | BaseFrame | frame
 | ) |  |
virtual

Called for any received frame.

Parameters
comm | The communicator the frame was received from
sender | The sending Endpoint
frame

Reimplemented from DoIPBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • DoIPServer
DoIPServer Member List

This is the complete list of members for DoIPServer, including all inherited members.

AliveRequest(Communicator comm, out RespBase response, int timeout=0) (defined in DoIPServer) | DoIPServer |
createBroadcastSocket(AddressFamily addressFamily) | DoIPBase | protectedstatic
DefaultPort | DoIPBase | static
DefaultTLSPort | DoIPBase | static
Dispose() (defined in DoIPServer) | DoIPServer | virtual
DoIPBase(ProtocolVersion version) | DoIPBase |
DoIPServer(ProtocolVersion version, IPAddress localIp, ushort port=DefaultPort, ushort logicalAdr=DoIPClient.DefaultEntityAdr) | DoIPServer |
executeAliveRequests() | DoIPServer |
getBroadcastIp(AddressFamily addressFamily) | DoIPBase | protectedstatic
getBroadcastIp(IPEndPoint endPoint) | DoIPBase | protectedstatic
LastDiagNackCode | DoIPBase |
LastNackCode | DoIPBase |
LocalEp | DoIPServer |
LogicalAdr | DoIPServer |
mComms (defined in DoIPBase) | DoIPBase | protected
mListener (defined in DoIPBase) | DoIPBase | protected
mVersion | DoIPBase | protected
OnNackReceived(NackCode nack) (defined in DoIPBase) | DoIPBase | protectedvirtual
OnResponseReceived(Communicator comm, EndPoint sender, BaseFrame frame) | DoIPServer | virtual
receive(IAsyncResult ar) | DoIPBase | protected
ReflectDiagMessageOnAcknowledge | DoIPBase |
sendAndWait< T >(Communicator comm, BaseFrame frame, int timeout, EndPoint remoteEp, out T response) | DoIPBase | protectedstatic
Timeout | DoIPBase | static
tryAcquire(Communicator comm, EndPoint sender, out BaseFrame frame) | DoIPBase | protectedstatic


ASAP2Library interface: EntityData Class Reference

  • Diagnose
  • Comm
  • DoIp
  • EntityData
Public Member Functions | Public Attributes | List of all members
EntityData Class Reference

Holds a single Entity. More...

Public Member Functions

EntityData (VehicleIdResponse vehicleId)
void | Dispose ()
override string | ToString ()

Public Attributes

DoIPClient | Client
EntityStatusResponse | EntityStatus
DiagnosticPowerModeResponse | PowerMode
VehicleIdResponse | VehicleId

Detailed Description

Holds a single Entity.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • EntityData
EntityData Member List

This is the complete list of members for EntityData, including all inherited members.

Client (defined in EntityData) | EntityData
Dispose() (defined in EntityData) | EntityData
EntityData(VehicleIdResponse vehicleId) (defined in EntityData) | EntityData
EntityStatus (defined in EntityData) | EntityData
PowerMode (defined in EntityData) | EntityData
ToString() (defined in EntityData) | EntityData
VehicleId (defined in EntityData) | EntityData


ASAP2Library interface: EntityStatusResponse Class Reference

  • Diagnose
  • Comm
  • DoIp
  • EntityStatusResponse
Properties | List of all members
EntityStatusResponse Class Reference

Entity status response More...

Properties

uint | MaxDataSize [get]
Maximum data size
byte | MaxSockets [get]
Maximum sockets
NodeType | NodeType [get]
Type of node
byte | OpenSockets [get]
Currently Opened sockets
- Properties inherited from RespBase
BaseFrame | Frame [getset]
The reponse frame itself.

Detailed Description

Entity status response


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • EntityStatusResponse
EntityStatusResponse Member List

This is the complete list of members for EntityStatusResponse, including all inherited members.

Frame | RespBase
MaxDataSize | EntityStatusResponse
MaxSockets | EntityStatusResponse
NodeType | EntityStatusResponse
OpenSockets | EntityStatusResponse


ASAP2Library interface: RespBase Class Reference

  • Diagnose
  • Comm
  • DoIp
  • RespBase
Properties | List of all members
RespBase Class Reference

Response base class. More...

Properties

BaseFrame Frame [getset]
The reponse frame itself.

Detailed Description

Response base class.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • RespBase
RespBase Member List

This is the complete list of members for RespBase, including all inherited members.

Frame RespBase


ASAP2Library interface: RoutingActivationResponse Class Reference

  • Diagnose
  • Comm
  • DoIp
  • RoutingActivationResponse
Properties | List of all members
RoutingActivationResponse Class Reference

Routing activation response. More...

Properties

ActivationCode | ActivationResult [get]
Routing Activation code
- Properties inherited from RespBase
BaseFrame | Frame [getset]
The reponse frame itself.

Detailed Description

Routing activation response.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • RoutingActivationResponse
RoutingActivationResponse Member List

This is the complete list of members for RoutingActivationResponse, including all inherited members.

ActivationResult | RoutingActivationResponse
Frame | RespBase


ASAP2Library interface: SrcDstFrame Class Reference

  • Diagnose
  • Comm
  • DoIp
  • SrcDstFrame
Public Member Functions | Public Attributes | List of all members
SrcDstFrame Class Reference

Frame containing a source and destination address. More...

Public Member Functions

SrcDstFrame (ProtocolVersion version, DoIPType type, ushort srcAdr, ushort dstAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
SrcDstFrame (SrcDstFrame request, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null)
Builds a frame from the specified parameters. More...
override byte[] | ToArray ()
Gets the raw frame bytes. More...
override string | ToString ()
- Public Member Functions inherited from SrcFrame
SrcFrame (ProtocolVersion version, DoIPType type, ushort srcAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
override string | ToString ()
- Public Member Functions inherited from BaseFrame
BaseFrame (ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
override string | ToString ()
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Public Attributes

readonly ushort | DstAdr
Target address
- Public Attributes inherited from SrcFrame
readonly ushort | SrcAdr
Source address
- Public Attributes inherited from BaseFrame
readonly EndPoint | Sender
Frame sender
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Additional Inherited Members

- Properties inherited from BaseFrame
bool | IsError [get]
Indicates if the frame is an erro frame.
SocketType | SocketType [getset]
Media type
DoIPType | Type [getset]
Frame type
ProtocolVersion | Version [getset]
Protocol version
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Frame containing a source and destination address.

Constructor & Destructor Documentation

◆ SrcDstFrame() [1/2]

SrcDstFrame | ( | ProtocolVersion | version,
 |  | DoIPType | type,
 |  | ushort | srcAdr,
 |  | ushort | dstAdr,
 |  | SocketType | socketType,
 |  | EndPoint | sender,
 |  | byte[] | data = null,
 |  | bool | isMasterFrame = false
 | ) |  |

Builds a frame from the specified parameters.

Parameters
version | Protocol version
type | Frame type
srcAdr | Source address
dstAdr | Target address
socketType | Socket type
sender | Received from
data | Payload data
isMasterFrame | Indicates if the frame is a master frame

◆ SrcDstFrame() [2/2]

SrcDstFrame | ( | SrcDstFrame | request,
 |  | DoIPType | type,
 |  | SocketType | socketType,
 |  | EndPoint | sender,
 |  | byte[] | data = null
 | ) |  |

Builds a frame from the specified parameters.

Parameters
sender | Received from
request | The original frame
type | Frame type
socketType | Socket type
sender | Received from
data | Payload data

Member Function Documentation

◆ ToArray()

override byte[] ToArray ( )
virtual

Gets the raw frame bytes.

Returns

Reimplemented from SrcFrame.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • SrcDstFrame
SrcDstFrame Member List

This is the complete list of members for SrcDstFrame, including all inherited members.

BaseFrame(ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | BaseFrame |
Data | Frame |
DstAdr | SrcDstFrame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
IsError | BaseFrame |
IsMasterFrame | Frame |
Sender | BaseFrame |
SocketType | BaseFrame |
SrcAdr | SrcFrame |
SrcDstFrame(ProtocolVersion version, DoIPType type, ushort srcAdr, ushort dstAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | SrcDstFrame |
SrcDstFrame(SrcDstFrame request, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null) | SrcDstFrame |
SrcFrame(ProtocolVersion version, DoIPType type, ushort srcAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | SrcFrame |
ToArray() | SrcDstFrame | virtual
toClipboard() | BaseFrame | virtual
toCSV() | BaseFrame | virtual
ToString() (defined in SrcDstFrame) | SrcDstFrame |
Type | BaseFrame |
Version | BaseFrame |


ASAP2Library interface: SrcFrame Class Reference

  • Diagnose
  • Comm
  • DoIp
  • SrcFrame
Public Member Functions | Public Attributes | List of all members
SrcFrame Class Reference

Frame containing a source address. More...

Public Member Functions

SrcFrame (ProtocolVersion version, DoIPType type, ushort srcAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
override byte[] | ToArray ()
Gets the raw frame bytes. More...
override string | ToString ()
- Public Member Functions inherited from BaseFrame
BaseFrame (ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false)
Builds a frame from the specified parameters. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
override string | ToString ()
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Public Attributes

readonly ushort | SrcAdr
Source address
- Public Attributes inherited from BaseFrame
readonly EndPoint | Sender
Frame sender
- Public Attributes inherited from Frame
byte[] | Data
The data bytes of the frame.

Additional Inherited Members

- Properties inherited from BaseFrame
bool | IsError [get]
Indicates if the frame is an erro frame.
SocketType | SocketType [getset]
Media type
DoIPType | Type [getset]
Frame type
ProtocolVersion | Version [getset]
Protocol version
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Detailed Description

Frame containing a source address.

Constructor & Destructor Documentation

◆ SrcFrame()

SrcFrame | ( | ProtocolVersion | version,
 |  | DoIPType | type,
 |  | ushort | srcAdr,
 |  | SocketType | socketType,
 |  | EndPoint | sender,
 |  | byte[] | data = null,
 |  | bool | isMasterFrame = false
 | ) |  |

Builds a frame from the specified parameters.

Parameters
version | Protocol version
type | Frame type
socketType | Socket type
sender | Received from
srcAdr | Source address
data | Payload data
sender | Received from
isMasterFrame | Indicates if the frame is a master frame

Member Function Documentation

◆ ToArray()

override byte[] ToArray ( )
virtual

Gets the raw frame bytes.

Returns

Reimplemented from BaseFrame.

Reimplemented in SrcDstFrame.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • SrcFrame
SrcFrame Member List

This is the complete list of members for SrcFrame, including all inherited members.

BaseFrame(ProtocolVersion version, DoIPType type, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | BaseFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
IsError | BaseFrame |
IsMasterFrame | Frame |
Sender | BaseFrame |
SocketType | BaseFrame |
SrcAdr | SrcFrame |
SrcFrame(ProtocolVersion version, DoIPType type, ushort srcAdr, SocketType socketType, EndPoint sender, byte[] data=null, bool isMasterFrame=false) | SrcFrame |
ToArray() | SrcFrame | virtual
toClipboard() | BaseFrame | virtual
toCSV() | BaseFrame | virtual
ToString() (defined in SrcFrame) | SrcFrame |
Type | BaseFrame |
Version | BaseFrame |


ASAP2Library interface: VehicleIdResponse Class Reference

  • Diagnose
  • Comm
  • DoIp
  • VehicleIdResponse
Properties | List of all members
VehicleIdResponse Class Reference

VehicleId response. More...

Properties

byte[] | EID [get]
This is a unique identification of the DoIP entities in order to separate their responses even before the VIN is programmed to, or recognized by, the DoIP devices (e.g.during the vehicle assembly process). More...
ActionType? | FurtherAction [get]
This is the additional information to notify the client DoIP entity that there are either DoIP entities with no initial connectivity or that a centralized security approach is used.
byte[] | GID [get]
This is a unique identification of a group of DoIP entities within the same vehicle in the case that a VIN is not configured for that vehicle... More...
string | Key [get]
Builds a unique key from the Vehicle ID.
ushort? | LogicalAdr [get]
This is the logical address that is assigned to the responding DoIP entity (see 7.8 for further details). More...
SynchStatus? | SynchronizationStatus [get]
This is the additional information to notify the client DoIP entity that all DoIP entities have synchronized their information about the VIN or GID of the vehicle
string? | VIN [get]
This is the vehicle’s VIN as specified in ISO 3779. More...
- Properties inherited from RespBase
BaseFrame | Frame [getset]
The reponse frame itself.

Detailed Description

VehicleId response.

Property Documentation

◆ EID

byte [] EID
get

This is a unique identification of the DoIP entities in order to separate their responses even before the VIN is programmed to, or recognized by, the DoIP devices (e.g.during the vehicle assembly process).

It is recommended that the MAC address information of the DoIP entity's network interface be used (one of the interfaces if multiple network interfaces are implemented).

◆ GID

byte [] GID
get

This is a unique identification of a group of DoIP entities within the same vehicle in the case that a VIN is not configured for that vehicle...

If the GID is not available at the time of transmission of this message, this shall be indicated using the specific invalidity" ("not set") value of 0x00 or 0xff.

◆ LogicalAdr

ushort? LogicalAdr
get

This is the logical address that is assigned to the responding DoIP entity (see 7.8 for further details).

The logical address can be used, for example, to address diagnostic requests directly to the DoIP entity.

◆ VIN

string? VIN
get

This is the vehicle’s VIN as specified in ISO 3779.

If the VIN is not configured at the time of transmission of this message, this should be indicated using the invalidity value {0x00 or 0xff}... In this case, the GID is used to associate DoIP nodes with a certain vehicle...


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • DoIp
  • VehicleIdResponse
VehicleIdResponse Member List

This is the complete list of members for VehicleIdResponse, including all inherited members.

EID | VehicleIdResponse
Frame | RespBase
FurtherAction | VehicleIdResponse
GID | VehicleIdResponse
Key | VehicleIdResponse
LogicalAdr | VehicleIdResponse
SynchronizationStatus | VehicleIdResponse
VIN | VehicleIdResponse


ASAP2Library interface: jnsoft.Diagnose.Comm.UDS Namespace Reference

  • Diagnose
  • Comm
  • UDS
Classes | Enumerations
jnsoft.Diagnose.Comm.UDS Namespace Reference

Implements the UDS Protocol (ISO 14229-1). More...

Classes

struct | DTCAndStatusRecord
Defines a single DTC record. More...
class | RespBase
Base class for UDS protocol responses. More...
class | RespControlDTCSetting
Response on Control DTC setting. More...
class | RespData
Base class for UDS protocol responses with no Subfunction and a byte stream. More...
class | RespDTCCount
DTC Count Response. More...
class | RespDTCRecords
DTC records response. More...
class | RespDTCSeverityRecords
DTC records with severity response. More...
class | RespDynamicallyDefine
Base class for DynamicallyDefineDataIdentifier service. More...
class | RespIdentfier
InputOutputControlByIdentifier/WriteDatByIdentifier response. More...
class | RespLinkControl
Response on Event response. More...
class | RespRequestUpDownload
Request upload/download service response. More...
class | RespReset
ECUReset response. More...
class | RespResponseOnEvent
Response on Event response. More...
class | RespRoutineControl
Request Routine control service response. More...
class | RespSecurityAccess
Security access response. More...
class | RespSession
DiagnosticSessionControl response. More...
class | RespSFBase
Base class for UDS protocol responses with Subfunction. More...
class | RespTimingParameter
Timing parameter response. More...
class | RespTransferData
Request TransferData service response. More...
class | RespWriteMemoryByAddress
WriteMemoryByAddress response. More...
class | ServiceProperties
Holds specification defined Service properties. More...
struct | ServiceType
Service properties. More...
struct | SrcDataIdentifier
Dynamically Define Identifier by Id request. More...
struct | SrcDataMemory
Dynamically Define Identifier by memory address request. More...
class | UDSClient
Implements the UDS client (Tester) Application protocol. More...
class | UDSClientBase
Implements the UDS client base Application protocol. More...
class | UDSFrame
Represents an UDS frame. More...
class | UDSFrameQueue
Queue implementation to store UDSFrame's. More...

Enumerations

enum CommunicationControlType : byte {
EnableRxAndTx , EnableRxAndDisableTx , DisableRxAndEnableTx , DisableRxAndTx ,
EnableRxAndDisableTxWithEnhancedAddressInformation , EnableRxAndTxWithEnhancedAddressInformation
}
Communication control subfunction. More...
enum CommunicationType : byte {
NormalCommunicationMessages = 0x01 , NetworkCommunicationMessages = 0x02 , NormalAndNetworkCommunicationMessages = NormalCommunicationMessages | NetworkCommunicationMessages , Reserverd1 = 0x04 ,
Reserverd2 = Reserverd1 << 1
}
Communication message defintion. More...
enum | DefinitionType : byte { DefineByIdentifier = 0x01 , DefineByMemoryAddress = 0x02 , ClearDynamicallyDefinedDataIdentifier = 0x03 }
DynamicallyDefineDataIdentifier subfunctions. More...
enum | DiagnosticSessionType : byte { Default = 0x01 , Programming = 0x02 , Extended = 0x03 , SafetySystem = 0x04 }
Diagnostic session types. More...
enum DTCFormatIdentifier {
SAE_J2012_DA_DTCFormat_00 , ISO_14229_1_DTCFormat , SAE_J1939_73_DTCFormat , ISO_11992_4_DTCFormat ,
SAE_J2012_DA_DTCFormat_04
}
The format of a DTC reported by the server. More...
enum | DTCSettingType : byte { On = 0x01 , Off = 0x02 }
DTC Setting subfunction. More...
enum DTCStatusMaskType : byte {
TestFailed = 0x01 , TestFailedThisOperationCycle = TestFailed << 1 , PendingDTC = TestFailed << 2 , ConfirmedDTC = TestFailed << 3 ,
TestNotCompletedSinceLastClear = TestFailed << 4 , TestFailedSinceLastClear = TestFailed << 5 , TestNotCompletedThisOperationCycle = TestFailed << 6 , WarningIndicatorRequested = TestFailed << 7
}
DTC Status bits. More...
enum | LinkControlType : byte { VerifyModeTransitionWithFixedParameter = 0x01 , VerifyModeTransitionWithSpecificParameter , TransitionMode }
Link control subfunction. More...
enum ModeOfOperationType {
AddFile = 0x01 , DeleteFile , ReplaceFile , ReadFile ,
ReadDir
}
Definition of Mode Of Operation values. More...
enum NegRespCode : byte {
Positive = 0 , GeneralReject = 0x10 , ServiceNotSupported = 0x011 , SubFunctionNotSupported = 0x12 ,
IncorrectMessageLengthOrInvalidFormat = 0x13 , ResponseTooLong = 0x14 , BusyRepeatRequest = 0x21 , ConditionsNotCorrect = 0x22 ,
RequestSequenceError = 0x24 , NoResponseFromSubnetComponent = 0x25 , FailurePreventsExecutionOfRequestedAction = 0x26 , RequestOutOfRange = 0x31 ,
SecurityAccessDenied = 0x33 , InvalidKey = 0x35 , ExceededNumberOfAttempts = 0x36 , RequiredTimeDelayNotExpired = 0x37 ,
UploadDownloadNotAccepted = 0x70 , TransferDataSuspended = 0x71 , GeneralProgrammingFailure = 0x72 , WrongBlockSequenceCounter = 0x73 ,
RequestCorrectlyReceivedResponsePending = 0x78 , SubFunctionNotSupportedInActiveSession = 0x7e , ServiceNotSupportedInActiveSession = 0x7f , RpmTooHigh = 0x81 ,
RpmTooLow = 0x82 , EngineIsRunning = 0x83 , EngineIsNotRunning = 0x84 , EngineRunTimeTooLow = 0x85 ,
TemperatureTooHigh = 0x86 , TemperatureTooLow = 0x87 , VehicleSpeedTooHigh = 0x88 , VehicleSpeedTooLow = 0x89 ,
ThrottlePedalTooHigh = 0x8A , ThrottlePedalTooLow = 0x8B , TransmissionRangeNotInNeutral = 0x8C , TransmissionRangeNotInGear = 0x8D ,
BrakeSwitchesNotClosed = 0x8F , ShifterLeverNotInPark = 0x90 , TorqueConverterClutchLocked = 0x91 , VoltageTooHigh = 0x92 ,
VoltageTooLow = 0x93 , UserCancelled = 0xfe , Timeout
}
Possible negative response codes. More...
enum ReportDTCType : byte {
ReportNumberOfDTCByStatusMask = 0x01 , ReportDTCByStatusMask , ReportDTCSnapshotIdentification , ReportDTCSnapshotRecordByDTCNumber ,
ReportDTCStoredDataByRecordNumber , ReportDTCExtDataRecordByDTCNumber , ReportNumberOfDTCBySeverityMaskRecord , ReportDTCBySeverityMaskRecord ,
ReportSeverityInformationOfDTC , ReportSupportedDTC , ReportFirstTestFailedDTC , ReportFirstConfirmedDTC ,
ReportMostRecentTestFailedDTC , ReportMostRecentConfirmedDTC , ReportMirrorMemoryDTCByStatusMask , ReportMirrorMemoryDTCExtDataRecordByDTCNumber ,
ReportNumberOfMirrorMemoryDTCByStatusMask , ReportNumberOfEmissionsOBDDTCByStatusMask , ReportEmissionsOBDDTCByStatusMask , ReportDTCFaultDetectionCounter ,
ReportDTCWithPermanentStatus , ReportDTCExtDataRecordByRecordNumber , ReportUserDefMemoryDTCByStatusMask , ReportUserDefMemoryDTCSnapshotRecordByDTCNumber ,
ReportUserDefMemoryDTCExtDataRecordByDTCNumber , ReportWWHOBDDTCByMaskRecord = 0x42 , ReportWWHOBDDTCWithPermanentStatus
}
DTC report subfunction More...
enum ResetType {
HardReset = 1 , KeyOffOnReset , SoftReset , EnableRapidPowerShutDown ,
DisableRapidPowerShutDown
}
Available Reset types. More...
enum ResponseOnEventType : byte {
StopResponseOnEvent = 0x00 , OnDTCStatusChange = 0x01 , OnTimerInterrupt = 0x02 , OnChangeOfDataIdentifier = 0x03 ,
ReportActivatedEvents = 0x04 , StartResponseOnEvent = 0x05 , ClearResponseOnEvent = 0x06 , OnComparisonOfValues = 0x07 ,
StoreEvent = 0x40
}
Response on Event subfunction. More...
enum | RoutineControlType : byte { StartRoutine = 1 , StopRoutine , RequestRoutineResults }
Routine control subfunction. More...
enum | RoutineIdentifierType : ushort { DeployLoopRoutineID = 0xE200 , EraseMemory = 0xff00 , CheckProgrammingDependencies = 0xFF01 , EraseMirrorMemoryDTCs = 0xFF02 }
RoutineIdentifier (RID) definition. More...
enum SID : byte {
DiagnosticSessionControl = 0x10 , ECUReset = 0x11 , SecurityAccess = 0x27 , CommunicationControl = 0x28 ,
TesterPresent = 0x3E , AccessTimingParameter = 0x83 , SecuredDataTransmission = 0x84 , ControlDTCSetting = 0x85 ,
ResponseOnEvent = 0x86 , LinkControl = 0x87 , ReadDataByIdentifier = 0x22 , ReadMemoryByAddress = 0x23 ,
ReadScalingDataByIdentifier = 0x24 , ReadDataByPeriodicIdentifier = 0x2A , DynamicallyDefineDataIdentifier = 0x2C , WriteDataByIdentifier = 0x2E ,
WriteMemoryByAddress = 0x3D , ClearDiagnosticInformation = 0x14 , ReadDTCInformation = 0x19 , InputOutputControlByIdentifier = 0x2F ,
RoutineControl = 0x31 , RequestDownload = 0x34 , RequestUpload = 0x35 , TransferData = 0x36 ,
RequestTransferExit = 0x37 , RequestFileTransfer = 0x38
}
UDS Diagnostic services.
enum | TimingParameterAccessType : byte { ReadExtendedTimingParameterSet = 0x01 , SetTimingParametersToDefaultValues , ReadCurrentlyActiveTimingParameters , SetTimingParametersToGivenValues }
Timing Parameter Access subfunction. More...
enum | TransmissionModeType : byte { SendAtSlowRate = 0x01 , SendAtMediumRate , SendAtFastRate , StopSending }
Transmission mode types. More...

Detailed Description

Implements the UDS Protocol (ISO 14229-1).

Enumeration Type Documentation

◆ CommunicationControlType

enum CommunicationControlType : byte

Communication control subfunction.

Enumerator
EnableRxAndTx | This value indicates that the reception and transmission of messages shall be nabled for the specified communicationType.
EnableRxAndDisableTx | This value indicates that the reception of messages shall be enabled and the transmission shall be disabled for the specified communicationType.
DisableRxAndEnableTx | This value indicates that the reception of messages shall be disabled and the transmission shall be enabled for the specified communicationType
DisableRxAndTx | This value indicates that the reception and transmission of messages shall be disabled for the specified communicationType.
EnableRxAndDisableTxWithEnhancedAddressInformation | This value indicates that the addressed bus master shall switch the related sub-bus segment to the diagnostic-only scheduling mode
EnableRxAndTxWithEnhancedAddressInformation | This value indicates that the addressed bus master shall switch the related sub-bus segment to the application scheduling mode.

◆ CommunicationType

enum CommunicationType : byte

Communication message defintion.

Enumerator
NormalCommunicationMessages | This value references all application-related communication (interapplication signal exchange between multiple in-vehicle servers).
NetworkCommunicationMessages | This value references all network management related communication.
NormalAndNetworkCommunicationMessages | This value references all network management and application-related communication.
Reserverd1 | Reserved 1
Reserverd2 | Reserved 2

◆ DefinitionType

enum DefinitionType : byte

DynamicallyDefineDataIdentifier subfunctions.

Enumerator
DefineByIdentifier | This value shall be used to specify to the server that definition of the dynamic data identifier shall occur via a data identifier reference.
DefineByMemoryAddress | This value shall be used to specify to the server that definition of the dynamic data identifier shall occur via an address reference.
ClearDynamicallyDefinedDataIdentifier | This value shall be used to clear the specified dynamic data identifier. Note that the server shall positively respond to a clear request from the client, even if the specified dynamic data identifier doesn’t exist at the time of the request. However, the specified dynamic data identifier is required to be within a valid range (see C.1 for allowable ranges). If the specified dynamic data identifier is being reported periodically at the time of the request, the dynamic identifier shall first be stopped and then cleared.

◆ DiagnosticSessionType

enum DiagnosticSessionType : byte

Diagnostic session types.

The sub-function parameter diagnosticSessionType is used by the DiagnosticSessionControl service to select the specific behaviour of the server.

Enumerator
Default | This diagnostic session enables the default diagnostic session in the server(s) and does not support any diagnostic application timeout handling provisions (e.g. no TesterPresent service is necessary to keep the session active).
Programming | This diagnosticSession enables all diagnostic services required to support the memory programming of a server.
Extended | This diagnosticSession can be used to enable all diagnostic services required to support the adjustment of functions like "Idle Speed, CO Value, etc." in the server's memory.
SafetySystem | This diagnosticSession enables all diagnostic services required to support safety system related functions (e.g., airbag deployment).

◆ DTCFormatIdentifier

enum DTCFormatIdentifier

The format of a DTC reported by the server.

Enumerator
SAE_J2012_DA_DTCFormat_00 | This parameter value identifies the DTC format reported by the server as defined in ISO 15031-6 [12] specification.
ISO_14229_1_DTCFormat | This parameter value identifies the DTC format reported by the server as defined in this table by the parameter DTCAndStatusRecord.
SAE_J1939_73_DTCFormat | This parameter value identifies the DTC format reported by the server as defined in SAE J1939-73 [19].
ISO_11992_4_DTCFormat | This parameter value identifies the DTC format reported by the server as defined in ISO 11992-4 [5] specification.
SAE_J2012_DA_DTCFormat_04 | This parameter value identifies the DTC format reported by the server as defined in ISO 27145-2 [16] specification.

◆ DTCSettingType

enum DTCSettingType : byte

DTC Setting subfunction.

Enumerator
On | The server(s) shall resume the updating of diagnostic trouble code status bits according to normal operating conditions.
Off | The server(s) shall stop the updating of diagnostic trouble code status bits.

◆ DTCStatusMaskType

enum DTCStatusMaskType : byte

DTC Status bits.

Enumerator
TestFailed | This bit shall indicate the result of the most recently performed test.
TestFailedThisOperationCycle | This bit shall indicate whether or not a diagnostic test has reported a testFailed result at any time during the current operation cycle (or that a testFailed result has been reported during the current operation cycle and after the last time a call was made to ClearDiagnosticInformation).
PendingDTC | This bit shall indicate whether or not a diagnostic test has reported a testFailed result at any time during the current or last completed operation cycle.
ConfirmedDTC | This bit shall indicate whether a malfunction was detected enough times to warrant that the DTC is desired to be stored in long-term memory.
TestNotCompletedSinceLastClear | This bit shall indicate whether a DTC test has ever run and completed since the last time a call was made to ClearDiagnosticInformation.
TestFailedSinceLastClear | This bit shall indicate whether a DTC test has completed with a failed result since the last time a call was made to ClearDiagnosticInformation (i.e., this is a latched testFailedThisOperationCycle = '1').
TestNotCompletedThisOperationCycle | This bit shall indicate whether a DTC test has ever run and completed during the current operation cycle (or completed during the current operation cycle after the last time a call was made to ClearDiagnosticInformation).
WarningIndicatorRequested | This bit shall report the status of any warning indicators associated with a particular DTC.

◆ LinkControlType

enum LinkControlType : byte

Link control subfunction.

Enumerator
VerifyModeTransitionWithFixedParameter | This parameter is used to verify if a transition with a pre-defined parameter, which is specified by the linkControlModeIdentifier data-parameter can be performed.
VerifyModeTransitionWithSpecificParameter | This parameter is used to verify if a transition to a specifically defined parameter (e.g., specific baudrate), which is specified by the linkRecord data-parameter can be performed.
TransitionMode | This sub-function parameter requests the server(s) to transition the data link into the mode which was requested in the preceding verification message.

◆ ModeOfOperationType

enum ModeOfOperationType

Definition of Mode Of Operation values.

Enumerator
AddFile | This value shall be used to add the file (download) defined in the filePathAndName parameter.
DeleteFile | This value shall be used to delete the file defined in the filePathAndName parameter.
ReplaceFile | This value shall be used to replace the file (download) defined in the filePathAndName parameter. If the file is not stored at the location the file shall be added.
ReadFile | This value shall be used to read the file (upload) at the location defined by the filePathAndName parameter.
ReadDir | This value shall be used to read the directory defined in the filePathAndName parameter. This value implies that the request does not include a fileName.

◆ NegRespCode

enum NegRespCode : byte

Possible negative response codes.

Enumerator
GeneralReject | This NRC indicates that the requested action has been rejected by the server.
ServiceNotSupported | This NRC indicates that the requested action will not be taken because the server does not support the requested service.
SubFunctionNotSupported | This NRC shall be sent if the sub-function parameter is not supported.
IncorrectMessageLengthOrInvalidFormat | This NRC shall be sent if the length of the message is wrong.</summary
ResponseTooLong | This NRC shall be sent if the total length of the response message exceeds the limit of the underlying transport protocol (e.g., when multiple DIDs are requested in a single request).
BusyRepeatRequest | This NRC indicates that the server is temporarily too busy to perform the requested operation.
ConditionsNotCorrect | This NRC indicates that the requested action will not be taken because the server prerequisite conditions are not met.
RequestSequenceError | This NRC indicates that the requested action will not be taken because the server expects a different sequence of request messages or message as sent by the client.
NoResponseFromSubnetComponent | This NRC indicates that the server has received the request but the requested action could not be performed by the server as a subnet component which is necessary to supply the requested information did not respond within the specified time.
FailurePreventsExecutionOfRequestedAction | This NRC indicates that the requested action will not be taken because a failure condition, identified by a DTC (with at least one DTC status bit for TestFailed,Pending, Confirmed or TestFailedSinceLastClear set to 1), has occurred and that this failure condition prevents the server from performing the requested action.
RequestOutOfRange | This NRC indicates that the requested action will not be taken because the server has detected that the request message contains a parameter which attempts to substitute a value beyond its range of authority (e.g. attempting to substitute a data byte of 111 when the data is only defined to 100), or which attempts to access a dataIdentifier/routineIdentifer that is not supported or not supported in active session.
SecurityAccessDenied | This NRC indicates that the requested action will not be taken because the server's security strategy has not been satisfied by the client
InvalidKey | This NRC indicates that the server has not given security access because the key sent by the client did not match with the key in the server's memory.
ExceededNumberOfAttempts | This NRC indicates that the requested action will not be taken because the client has unsuccessfully attempted to gain security access more times than the server's security strategy will allow.
RequiredTimeDelayNotExpired | This NRC indicates that the requested action will not be taken because the client's latest attempt to gain security access was initiated before the server's required timeout period had elapsed.
UploadDownloadNotAccepted | This NRC indicates that an attempt to upload/download to a server's memory cannot be accomplished due to some fault conditions
TransferDataSuspended | This NRC indicates that a data transfer operation was halted due to some fault. The active transferData sequence shall be aborted.
GeneralProgrammingFailure | This NRC indicates that the server detected an error when erasing or programming a memory location in the permanent memory device (e.g. Flash Memory).
WrongBlockSequenceCounter | This NRC indicates that the server detected an error in the sequence of blockSequenceCounter values. Note that the repetition of a TransferData request message with a blockSequenceCounter equal to the one included in the previous TransferData request message shall be accepted by the server.
RequestCorrectlyReceivedResponsePending | This NRC indicates that the request message was received correctly, and that all parameters in the request message were valid, but the action to be performed is not yet completed and the server is not yet ready to receive another request. As soon as the requested service has been completed, the server shall send a positive response message or negative response message with a response code different from this.
SubFunctionNotSupportedInActiveSession | This NRC indicates that the requested action will not be taken because the server does not support the requested sub-function in the session currently active.
ServiceNotSupportedInActiveSession | This NRC indicates that the requested action will not be taken because the server does not support the requested service in the session currently active.
RpmTooHigh | This NRC indicates that the requested action will not be taken because the server prerequisite condition for RPM is not met (current RPM is above a pre-programmed maximum threshold).
RpmTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for RPM is not met (current RPM is below a pre-programmed minimum threshold).
EngineIsRunning | This NRC is required for those actuator tests which cannot be actuated while the Engine is running. This is different from RPM too high negative response, and needs to be allowed.
EngineIsNotRunning | This NRC is required for those actuator tests which cannot be actuated unless the Engine is running. This is different from RPM too low negative response, and needs to be allowed.
EngineRunTimeTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for engine run time is not met (current engine run time is below a pre-programmed limit)
TemperatureTooHigh | This NRC indicates that the requested action will not be taken because the server prerequisite condition for temperature is not met (current temperature is above a pre-programmed maximum threshold)
TemperatureTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for temperature is not met (current temperature is below a pre-programmed minimum threshold).
VehicleSpeedTooHigh | This NRC indicates that the requested action will not be taken because the server prerequisite condition for vehicle speed is not met (current VS is above a pre-programmed maximum threshold).
VehicleSpeedTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for vehicle speed is not met (current VS is below a pre-programmed minimum threshold).
ThrottlePedalTooHigh | This NRC indicates that the requested action will not be taken because the server prerequisite condition for throttle/pedal position is not met (current TP/APP is above a pre-programmed maximum threshold).
ThrottlePedalTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for throttle/pedal position is not met (current TP/APP is below a pre-programmed minimum threshold)
TransmissionRangeNotInNeutral | This NRC indicates that the requested action will not be taken because the server prerequisite condition for being in neutral is not met (current transmission range is not in neutral).
TransmissionRangeNotInGear | This NRC indicates that the requested action will not be taken because the server prerequisite condition for being in gear is not met (current transmission range is not in gear).
BrakeSwitchesNotClosed | This NRC indicates that for safety reasons, this is required for certain tests before it begins, and must be maintained for the entire duration of the test.
ShifterLeverNotInPark | This NRC indicates that for safety reasons, this is required for certain tests before it begins, and must be maintained for the entire duration of the test.
TorqueConverterClutchLocked | This NRC indicates that the requested action will not be taken because the server prerequisite condition for torque converter clutch is not met (current TCC status above a pre-programmed limit or locked)
VoltageTooHigh | This NRC indicates that the requested action will not be taken because the server prerequisite condition for voltage at the primary pin of the server (ECU) is not met (current voltage is above a pre-programmed maximum threshold).
VoltageTooLow | This NRC indicates that the requested action will not be taken because the server prerequisite condition for voltage at the primary pin of the server (ECU) is not met (current voltage is below a pre-programmed maximum threshold).
UserCancelled | No response from server
Timeout | No response from server

◆ ReportDTCType

enum ReportDTCType : byte

DTC report subfunction

Enumerator
ReportNumberOfDTCByStatusMask

This parameter specifies that the server shall transmit to the client the number of DTCs matching a client defined status mask.

ReportDTCByStatusMask

This parameter specifies that the server shall transmit to the client a list of DTCs and corresponding statuses matching a client defined status mask.

ReportDTCSnapshotIdentification

This parameter specifies that the server shall transmit to the client all DTCSnapshot data record identifications (DTC number(s) and DTCSnapshot record number(s)).

ReportDTCSnapshotRecordByDTCNumber

This parameter specifies that the server shall transmit to the client the DTCSnapshot record(s) associated with a client defined DTC number and DTCSnapshot record number (0xFF for all records).

ReportDTCStoredDataByRecordNumber

This parameter specifies that the server shall transmit to the client the DTCStoredDatarecord(s) associated with a client defined DTCStoredData record number (0xFF for all records).

ReportDTCExtDataRecordByDTCNumber

This parameter specifies that the server shall transmit to the client the DTCExtendedData record(s) associated with a client defined DTC number and DTCExtendedData record number (0xFF for all records, 0xFE for all OBD records).

ReportNumberOfDTCBySeverityMaskRecord

This parameter specifies that the server shall transmit to the client the number of DTCs matching a client defined severity mask record.

ReportDTCBySeverityMaskRecord

This parameter specifies that the server shall transmit to the client a list of DTCs and corresponding statuses matching a client defined severity mask record.

ReportSeverityInformationOfDTC

This parameter specifies that the server shall transmit to the client the severity information of a specific DTC specified in the client request message.

ReportSupportedDTC

This parameter specifies that the server shall transmit to the client a list of all DTCs and corresponding statuses supported within the server.

ReportFirstTestFailedDTC

This parameter specifies that the server shall transmit to the client the first failed DTC to be detected by the server since the last clear of diagnostic information. Note that the information reported via this sub-function parameter shall be independent of whether or not the DTC was confirmed or aged.

ReportFirstConfirmedDTC

This parameter specifies that the server shall transmit to the client the first confirmed DTC to be detected by the server since the last clear of diagnostic information. The information reported via this sub-function parameter shall be independent of the aging process of confirmed DTCs (e.g. if a DTC ages such that its status is allowed to be reset, the first confirmed DTC record shall continue to be preserved by the server, regardless of any other DTCs that become confirmed afterwards)

ReportMostRecentTestFailedDTC

This parameter specifies that the server shall transmit to the client the most recent failed DTC to be detected by the server since the last clear of diagnostic information. Note that the information reported via this sub- function parameter shall be independent of whether or not the DTC was confirmed or aged.

ReportMostRecentConfirmedDTC

This parameter specifies that the server shall transmit to the client the most recent confirmed DTC to be detected by the server since the last clear of diagnostic information. Note that the information reported via this sub-function parameter shall be independent of the aging process of confirmed DTCs (e.g. if a DTC ages such that its status is allowed to be reset, the first confirmed DTC record shall continue to be preserved by the server assuming no other DTCs become confirmed afterwards).

ReportMirrorMemoryDTCByStatusMask

This parameter specifies that the server shall transmit to the client a list of DTCs out of the DTC mirror memory and corresponding statuses matching a client defined status mask.

ReportMirrorMemoryDTCExtDataRecordByDTCNumber

This parameter specifies that the server shall transmit to the client the DTCExtendedData record(s) - out of the DTC mirror memory - associated with a client defined DTC number and DTCExtendedData record number (0xFF for all records, 0xFE for all OBD records) DTCs.

ReportNumberOfMirrorMemoryDTCByStatusMask

This parameter specifies that the server shall transmit to the client the number of DTCs out of mirror memory matching a client defined status mask.

ReportNumberOfEmissionsOBDDTCByStatusMask

This parameter specifies that the server shall transmit to the client the number of emissions-related OBD DTCs matching a client defined status mask. The number of OBD DTCs reported shall only be those which are required to be compatible with emissions-related legal requirements.

ReportEmissionsOBDDTCByStatusMask

This parameter specifies that the server shall transmit to the client a list of emissions-related OBD DTCs and corresponding statuses matching a client defined status mask. The list of OBD DTCs reported shall only be those which are required to be compatible with emissions-related legal requirements.

ReportDTCFaultDetectionCounter

This parameter specifies that the server shall transmit to the client a list of current "prefailed" DTCs which have or have not yet been detected as "pending" or "confirmed". The intention of the DTCFaultDetectionCounter is a simple method to identify a growing or intermittent problem which can not be identified / read by the statusOfDTC byte of a particular DTC.The internal implementation of the DTCFaultDetectionCounter shall be vehicle manufacturer specific (e.g., number of bytes, signed versus unsigned, etc.) but the reported value shall be a scaled 1 byte signed value so that +127 (0x7F) represents a test result of "failed" and any other non-zero positive value represents a test result of "prefailed". However DTCs with DTCFaultDetectionCounter with the value +127 shall not be reported according to below stated rule. The DTCFaultDetectionCounter shall be incremented by a vehicle manufacturer specific amount each time the test logic runs and indicates a fail for that test run. A reported DTCFaultDetectionCounter value greater than zero and less than +127 (i.e., 0x01 – 0x7E) indicates that the DTC enable criteria was met and that a non completed test result prefailed at least in one condition or threshold. Only DTCs with DTCFaultDetectionCounters with a non-zero positive value less than +127 (0x7F) shall be reported. The DTCFaultDetectionCounter shall be decremented by a vehicle manufacturer specific amount each time the test logic runs and indicates a pass for that test run.If the DTCFaultDetectionCounter is decremented to zero or below the DTC shall no longer be reported in the positive response message.The value of the DTCFaultDetectionCounter shall not be maintained between operation cycles. If a ClearDiagnosticInformation service request is received the DTCFaultDetectionCounter value shall be reset to zero for all DTCs. Additional reset conditions shall be defined by the vehicle manufacturer. Refer to D.5 for example implementation details.

ReportDTCWithPermanentStatus

This parameter specifies that the server shall transmit to the client a list of DTCs with "permanent DTC" status as described in 3.1.

ReportDTCExtDataRecordByRecordNumber

This parameter specifies that the server shall transmit to the client the DTCExtendedData records associated with a client defined DTCExtendedData record number less than 0xF0.

ReportUserDefMemoryDTCByStatusMask

This parameter specifies that the server shall transmit to the client a list of DTCs out of the user defined DTC memory and corresponding statuses matching a client defined status mask.

ReportUserDefMemoryDTCSnapshotRecordByDTCNumber

This parameter specifies that the server shall transmit to the client the DTCSnapshot record(s) – out of the user defined DTC memory - associated with a client defined DTC number and DTCSnapshot record number (0xFF for all records).

ReportUserDefMemoryDTCExtDataRecordByDTCNumber

This parameter specifies that the server shall transmit to the client the DTCExtendedData record(s) – out of the user defined DTC memory - associated with a client defined DTC number and DTCExtendedData record number (0xFF for all records)

ReportWWHOBDDTCByMaskRecord

This parameter specifies that the server shall transmit to the client a list of WWH OBD DTCs and corresponding status and severity information matching a client defined status mask and severity mask record

ReportWWHOBDDTCWithPermanentStatus

This parameter specifies that the server shall transmit to the client a list of WWH OBD DTCs with "permanent DTC" status as described in 3.1.

◆ ResetType

enum ResetType

Available Reset types.

Enumerator
HardReset

This value identifies a "hard reset" condition which simulates the power-on / start-up sequence typically performed after a server has been previously disconnected from its power supply (i.e. battery). The performed action is implementation specific and not defined by the standard. It might result in the re-initialization of both volatile memory and non-volatile memory locations to predetermined values.

KeyOffOnReset

This value identifies a condition similar to the driver turning the ignition key off and back on. This reset condition should simulate a key-off-on sequence (i.e. interrupting the switched power supply). The performed action is implementation specific and not defined by the standard. Typically the values of non-volatile memory locations are preserved; volatile memory will be initialized.

SoftReset

This value identifies a "soft reset" condition, which causes the server to immediately restart the application program if applicable. The performed action is implementation specific and not defined by the standard. A typical action is to restart the application without reinitializing of previously learned configuration data, adaptive factors and other long-term adjustments.

EnableRapidPowerShutDown

This subfunction applies to ECUs which are not ignition powered but battery powered only. Therefore a shutdown forces the sleep mode rather than a power off. Sleep means power off but still ready for wake-up (battery powered). The intention of the subfunction is to reduce the stand-by time of an ECU after ignition is turned into the off position. This value requests the server to enable and perform a "rapid power shut down" function. The server shall execute the function immediately once the "key/ignition” is switched off. While the server executes the power down function, it shall transition either directly or after a defined stand-by-time to sleep mode. If the client requires a response message and the server is already prepared to execute the "rapid power shut down" function, the server shall send the positive response message prior to the start of the "rapid power shut down" function. The next occurrence of a "key on" or "ignition on" signal terminates the "rapid power shut down" function. NOTE This sub-function is only applicable to a server supporting a stand-by-mode!

DisableRapidPowerShutDown

This value requests the server to disable the previously enabled "rapid power shut down" function.

◆ ResponseOnEventType

enum ResponseOnEventType : byte

Response on Event subfunction.

Enumerator
StopResponseOnEvent | This value is used to stop the server sending responses on event. The event logic that has been set up is not cleared but can be restarted with the startResponseOnEvent sub-function parameter. Length of eventTypeRecord: 0 byte
OnDTCStatusChange | This value identifies the event as a new DTC detected matching the DTCStatusMask specified for this event. Length of eventTypeRecord: 1 byte
OnTimerInterrupt | This value identifies the event as a timer interrupt, but the timer and its values are not part of the ResponseOnEvent service. This eventType requires the specification of more details in the request message (eventTypeRecord). Length of eventTypeRecord: 1 byte
OnChangeOfDataIdentifier | This value identifies the event as a new internal data record identified by dataIdentifier. The data values are vehicle manufacturer specific. This eventType requires the specification of more details in the request message (eventTypeRecord). Length of eventTypeRecord: 2 bytes
ReportActivatedEvents | This value is used to indicate that in the positive response all events are reported that have been activated in the server with the ResponseOnEvent service (and are currently active). Length of eventTypeRecord: 0 bytes
StartResponseOnEvent | This value is used to indicate to the server to activate the event logic (including event window timer) that has been set up and start sending responses on event. Length of eventTypeRecord: 0 byte.
ClearResponseOnEvent | This value is used to clear the event logic that has been set up in the server (This also stops the server sending responses on event.) Length of eventTypeRecord: 0 byte.
OnComparisonOfValues | A defined alteration of a data value out of a specific record identified by a dataIdentifier which identifies a data value event. With this sub-function the user shall have the possibility to define an event at the occurrence of a specific result gathered from a defined measurement value comparison. A specific measurement value included in a data record assigned to a defined dataIdentifier is compared with a given comparison value. The specified operator defines the kind of comparison. The event occurs if the comparison result is positive. Length of eventTypeRecord: 10 bytes
StoreEvent | This value indicates 1) On ROE start or stop request in the default session, that the event shall resume or stop sending serviceToRespondTo-responses according to the ResponseOnEvent-set up after a reset or power on (i.e. the ResponseOnEvent service is resumed). 2) On any ROE setup event logic request, that requested event logic shall be stored persistently till the event logic is explicitly cleared (via clearResponseOnEvent) or the event logic is overwritten by a new ROE setup event logic request of the same category.

◆ RoutineControlType

enum RoutineControlType : byte

Routine control subfunction.

Enumerator
StartRoutine | This parameter specifies that the server shall start the routine specified by the routineIdentifier.
StopRoutine | This parameter specifies that the server shall stop the routine specified by the routineIdentifier.
RequestRoutineResults | This parameter specifies that the server shall return result values of the routine specified by the routineIdentifier.

◆ RoutineIdentifierType

enum RoutineIdentifierType : ushort

RoutineIdentifier (RID) definition.

Enumerator
DeployLoopRoutineID | This value shall be used to initiate the deployment of the previously selected ignition loop.
EraseMemory | This value shall be used to start the server's memory erase routine. The Control option and status record format shall be ECU specific and defined by the vehicle manufacturer.
CheckProgrammingDependencies | This value shall be used to check the server's memory programming dependencies. The Control option and status record format shall be ECU specific and defined by the vehicle manufacturer.
EraseMirrorMemoryDTCs | This value shall be used to erase the server's mirror memory DTCs.

◆ TimingParameterAccessType

enum TimingParameterAccessType : byte

Timing Parameter Access subfunction.

Enumerator
ReadExtendedTimingParameterSet

Upon receiving an AccessTimingParameter indication primitive with timingParameterAccessType = readExtendedTimingParameterSet, the server shall read the extended timing parameter set, i.e. the values that the server is capable of supporting. If the read access to the timing parameter set is successful, the server shall send an AccessTimingParameter response primitive with the positive response parameters. If the read access to the timing parameters set is not successful, the server shall send a negative response message with the appropriate negative response code. This sub-function is used to provide an extra set of timing parameters for the currently active diagnostic session. With the timingParameterAccessType = setTimingParametersToGivenValues only this set (read by timingParameterAccessType = readExtendedTimingParameterSet) of timing parameters can be set.

SetTimingParametersToDefaultValues

Upon receiving an AccessTimingParameter indication primitive with timingParameterAccessType = setTimingParametersToDefaultValues, the server shall change all timing parameters to the default values and send an AccessTimingParameter response primitive with the positive response parameters before the default timing parameters become active (if suppressPosRspMsgIndicationBit is set to 'FALSE', otherwise the timing parameters shall become active after the successful evaluation of the request message). If the timing parameters cannot be changed to default values for any reason, the server shall maintain the currently active timing parameters and send a negative response message with the appropriate negative response code. The definition of the default timing values depends on the used data link and is specified in the implementation specification(s) of ISO 14229.

ReadCurrentlyActiveTimingParameters

Upon receiving an AccessTimingParameter indication primitive with timingParameterAccessType = readCurrentlyActiveTimingParameters, the server shall read the currently used timing parameters. If the read access to the timing parameters is successful, the server shall send an AccessTimingParameter response primitive with the positive response parameters. If the read access to the currently used timing parameters is impossible for any reason, the server shall send a negative response message with the appropriate negative response code.

SetTimingParametersToGivenValues

Upon receiving an AccessTimingParameter indication primitive with timingParameterAccessType = setTimingParametersToGivenValues, the server shall check if the timing parameters can be changed under the present conditions. If the conditions are valid, the server shall perform all actions necessary to change the timing parameters and send an AccessTimingParameter response primitive with the positive response parameters before the new timing parameter values become active(suppressPosRspMsgIndicationBit is set to 'FALSE', otherwise the timing parameters shall become active after the successful evaluation of the request message). If the timing parameters cannot be changed by any reason, the server shall maintain the currently active timing parameters and send a negative response message with the appropriate negative response code. It is not possible to set the timing parameters of the server to any set of values between the minimum and maximum values read via timingParameterAccessType = readExtendedTimingParameterSet.The timing parameters of the server can only be set to exactly the timing parameters read via timingParameterAccessType = readExtendedTimingParameterSet.A request to do so shall be rejected by the server.

◆ TransmissionModeType

enum TransmissionModeType : byte

Transmission mode types.

Enumerator
SendAtSlowRate | This parameter specifies that the server shall transmit the requested dataRecord information at a slow rate in response to the request message (where the # of responses to be sent = maximumNumberOfResponsesToSend). The repetition rate specified by the transmissionMode parameter slow is vehicle manufacturer specific, and predefined in the server.
SendAtMediumRate | This parameter specifies that the server shall transmit the requested dataRecord information at a medium rate in response to the request message (where the # of responses to be sent = maximumNumberOfResponsesToSend). The repetition rate specified by the transmissionMode parameter medium is vehicle manufacturer specific, and re-defined in the server.
SendAtFastRate | This parameter specifies that the server shall transmit the requested dataRecord information at a fast rate in response to the request message (where the # of responses to be sent = maximumNumberOfResponsesToSend). The repetition rate specified by the transmissionMode parameter fast is vehicle manufacturer specific, and pre-defined in the server.
StopSending | The server stops transmitting positive response messages send periodically/repeatedly. Note that maximumNumberOfResponsesToSend parameter should be set to 0x01 if transmissionMode = stopSending (otherwise, server operation could be undefined).


ASAP2Library interface: DTCAndStatusRecord Struct Reference

  • Diagnose
  • Comm
  • UDS
  • DTCAndStatusRecord
Properties | List of all members
DTCAndStatusRecord Struct Reference

Defines a single DTC record. More...

Properties

uint | DTC [get]
DTC unique Id
DTCStatusMaskType | StatusOfDTC [get]
DTC status

Detailed Description

Defines a single DTC record.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • DTCAndStatusRecord
DTCAndStatusRecord Member List

This is the complete list of members for DTCAndStatusRecord, including all inherited members.

DTC | DTCAndStatusRecord
StatusOfDTC | DTCAndStatusRecord


ASAP2Library interface: RespBase Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespBase
Public Member Functions | Properties | List of all members
RespBase Class Reference

Base class for UDS protocol responses. More...

Public Member Functions

virtual bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Base class for UDS protocol responses.

Member Function Documentation

◆ Initialize()

virtual bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented in RespSFBase, RespDynamicallyDefine, RespData, RespSession, RespReset, RespSecurityAccess, RespTimingParameter, RespResponseOnEvent, RespDTCCount, RespDTCRecords, RespDTCSeverityRecords, RespWriteMemoryByAddress, RespIdentfier, RespRequestUpDownload, RespTransferData, and RespRoutineControl.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespBase
RespBase Member List

This is the complete list of members for RespBase, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespBase | virtual
ServiceID | RespBase |


ASAP2Library interface: RespControlDTCSetting Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespControlDTCSetting
Properties | List of all members
RespControlDTCSetting Class Reference

Response on Control DTC setting. More...

Properties

DTCSettingType | Type [get]
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Additional Inherited Members

- Public Member Functions inherited from RespSFBase
override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Detailed Description

Response on Control DTC setting.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespControlDTCSetting
RespControlDTCSetting Member List

This is the complete list of members for RespControlDTCSetting, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespSFBase | virtual
RespControlDTCSetting() (defined in RespControlDTCSetting) | RespControlDTCSetting |
ServiceID | RespBase |
SubFunction | RespSFBase |
Type (defined in RespControlDTCSetting) | RespControlDTCSetting |


ASAP2Library interface: RespData Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespData
Public Member Functions | Properties | List of all members
RespData Class Reference

Base class for UDS protocol responses with no Subfunction and a byte stream. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte[] | Data [get]
Raw data response stream.
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Base class for UDS protocol responses with no Subfunction and a byte stream.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespData
RespData Member List

This is the complete list of members for RespData, including all inherited members.

Data | RespData |
ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespData | virtual
ServiceID | RespBase |


ASAP2Library interface: RespDTCCount Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespDTCCount
Public Member Functions | Properties | List of all members
RespDTCCount Class Reference

DTC Count Response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ushort | Count [get]
DTC count
DTCFormatIdentifier | FormatIdentifier [get]
DTCStatusMaskType | StatusAvailabilityMask [get]
DTC status
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

DTC Count Response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespDTCCount
RespDTCCount Member List

This is the complete list of members for RespDTCCount, including all inherited members.

Count | RespDTCCount |
ErrorCode | RespBase |
FormatIdentifier | RespDTCCount |
Initialize(List< byte > response, ref int offset) | RespDTCCount | virtual
ServiceID | RespBase |
StatusAvailabilityMask | RespDTCCount |
SubFunction | RespSFBase |


ASAP2Library interface: RespDTCRecords Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespDTCRecords
Public Member Functions | Properties | List of all members
RespDTCRecords Class Reference

DTC records response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

DTCAndStatusRecord[] | DTCs [get]
List of DTCs
DTCStatusMaskType | StatusAvailabilityMask [get]
DTC status mask
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

DTC records response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespDTCRecords
RespDTCRecords Member List

This is the complete list of members for RespDTCRecords, including all inherited members.

DTCs | RespDTCRecords |
ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespDTCRecords | virtual
ServiceID | RespBase |
StatusAvailabilityMask | RespDTCRecords |
SubFunction | RespSFBase |


ASAP2Library interface: RespDTCSeverityRecords Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespDTCSeverityRecords
Public Member Functions | Properties | List of all members
RespDTCSeverityRecords Class Reference

DTC records with severity response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

DTCAndStatusRecord[] | DTCs [get]
List of DTCs
ushort | SeverityDTCs [get]
DTC severity
DTCStatusMaskType | StatusAvailabilityMask [get]
DTC status mask
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

DTC records with severity response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespDTCSeverityRecords
RespDTCSeverityRecords Member List

This is the complete list of members for RespDTCSeverityRecords, including all inherited members.

DTCs | RespDTCSeverityRecords |
ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespDTCSeverityRecords | virtual
ServiceID | RespBase |
SeverityDTCs | RespDTCSeverityRecords |
StatusAvailabilityMask | RespDTCSeverityRecords |
SubFunction | RespSFBase |


ASAP2Library interface: RespDynamicallyDefine Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespDynamicallyDefine
Public Member Functions | Properties | List of all members
RespDynamicallyDefine Class Reference

Base class for DynamicallyDefineDataIdentifier service. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ushort | Identifier [getprotected set]
The Identifier
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Base class for DynamicallyDefineDataIdentifier service.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespDynamicallyDefine
RespDynamicallyDefine Member List

This is the complete list of members for RespDynamicallyDefine, including all inherited members.

ErrorCode | RespBase |
Identifier | RespDynamicallyDefine |
Initialize(List< byte > response, ref int offset) | RespDynamicallyDefine | virtual
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespIdentfier Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespIdentfier
Public Member Functions | Properties | List of all members
RespIdentfier Class Reference

InputOutputControlByIdentifier/WriteDatByIdentifier response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ushort | Identifier [get]
The data identifier
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

InputOutputControlByIdentifier/WriteDatByIdentifier response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespIdentfier
RespIdentfier Member List

This is the complete list of members for RespIdentfier, including all inherited members.

ErrorCode | RespBase |
Identifier | RespIdentfier |
Initialize(List< byte > response, ref int offset) | RespIdentfier | virtual
ServiceID | RespBase |


ASAP2Library interface: RespLinkControl Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespLinkControl
Properties | List of all members
RespLinkControl Class Reference

Response on Event response. More...

Properties

LinkControlType | EventType [get]
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Additional Inherited Members

- Public Member Functions inherited from RespSFBase
override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Detailed Description

Response on Event response.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespLinkControl
RespLinkControl Member List

This is the complete list of members for RespLinkControl, including all inherited members.

ErrorCode | RespBase |
EventType (defined in RespLinkControl) | RespLinkControl |
Initialize(List< byte > response, ref int offset) | RespSFBase | virtual
RespLinkControl() (defined in RespLinkControl) | RespLinkControl |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespRequestUpDownload Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespRequestUpDownload
Public Member Functions | Properties | List of all members
RespRequestUpDownload Class Reference

Request upload/download service response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ulong | MaxNumberOfBlockLength [get]
This parameter is used by the requestUpload/requestDownload positive response message to inform the client how many data bytes shall be included in each TransferData positive response message from the server.
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Request upload/download service response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespRequestUpDownload
RespRequestUpDownload Member List

This is the complete list of members for RespRequestUpDownload, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespRequestUpDownload | virtual
MaxNumberOfBlockLength | RespRequestUpDownload |
ServiceID | RespBase |


ASAP2Library interface: RespReset Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespReset
Public Member Functions | Properties | List of all members
RespReset Class Reference

ECUReset response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte | PowerDownTime [get]
This parameter is present if the sub-function parameter is set to the enableRapidPowerShutDown value.
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

ECUReset response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespReset
RespReset Member List

This is the complete list of members for RespReset, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespReset | virtual
PowerDownTime | RespReset |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespResponseOnEvent Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespResponseOnEvent
Public Member Functions | Properties | List of all members
RespResponseOnEvent Class Reference

Response on Event response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ResponseOnEventType | EventType [get]
byte | EventWindowTime [get]
Valid if EventType = ResponseOnEventType.ReportActivatedEvents
byte | NumberOfIdentifiedEvents [get]
Identified events count
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Response on Event response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespResponseOnEvent
RespResponseOnEvent Member List

This is the complete list of members for RespResponseOnEvent, including all inherited members.

ErrorCode | RespBase |
EventType (defined in RespResponseOnEvent) | RespResponseOnEvent |
EventWindowTime | RespResponseOnEvent |
Initialize(List< byte > response, ref int offset) | RespResponseOnEvent | virtual
NumberOfIdentifiedEvents | RespResponseOnEvent |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespRoutineControl Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespRoutineControl
Public Member Functions | Properties | List of all members
RespRoutineControl Class Reference

Request Routine control service response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ushort | RoutineIdentifier [get]
The routine control identifier
byte | RoutineInfo [get]
The RoutineInfo byte specifies a scheme (e.g., StartRoutine, StopRoutine, RequestRoutineResults)
byte[] | RoutineStatusRecord [get]
The RoutineStatusByte 'm' is only to be included in the routineStatusRecord[] if specified for the routineIdentifier (RID) by the vehicle manufacturer.
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Request Routine control service response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespRoutineControl
RespRoutineControl Member List

This is the complete list of members for RespRoutineControl, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespRoutineControl | virtual
RoutineIdentifier | RespRoutineControl |
RoutineInfo | RespRoutineControl |
RoutineStatusRecord | RespRoutineControl |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespSecurityAccess Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespSecurityAccess
Public Member Functions | Properties | List of all members
RespSecurityAccess Class Reference

Security access response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte[] | SecuritySeed [get]
The seed parameter is a data value sent by the server and is used by the client when calculating the key needed to access security.The securitySeed data bytes are only present in the response message if the request message was sent with the sub-function set to a value which requests the seed of the server.
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Security access response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespSecurityAccess
RespSecurityAccess Member List

This is the complete list of members for RespSecurityAccess, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespSecurityAccess | virtual
SecuritySeed | RespSecurityAccess |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespSession Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespSession
Public Member Functions | Properties | List of all members
RespSession Class Reference

DiagnosticSessionControl response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

uint | P2ExServerMax [get]
Enhanced (NRC 0x78) P2 Server_max supported by the server for the activated diagnostic session (10 ms resolution).
ushort | P2ServerMax [get]
Default P2 Server_max timing supported by the server for the activated diagnostic session (1 ms resolution).
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

DiagnosticSessionControl response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespSession
RespSession Member List

This is the complete list of members for RespSession, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespSession | virtual
P2ExServerMax | RespSession |
P2ServerMax | RespSession |
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespSFBase Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespSFBase
Public Member Functions | Properties | List of all members
RespSFBase Class Reference

Base class for UDS protocol responses with Subfunction. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Base class for UDS protocol responses with Subfunction.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.

Reimplemented in RespDynamicallyDefine, RespSession, RespReset, RespSecurityAccess, RespTimingParameter, RespResponseOnEvent, RespDTCCount, RespDTCRecords, RespDTCSeverityRecords, and RespRoutineControl.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespSFBase
RespSFBase Member List

This is the complete list of members for RespSFBase, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespSFBase | virtual
ServiceID | RespBase |
SubFunction | RespSFBase |


ASAP2Library interface: RespTimingParameter Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespTimingParameter
Public Member Functions | Properties | List of all members
RespTimingParameter Class Reference

Timing parameter response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte[] | TimingParameters [get]
This parameter is present if the sub-function parameter is set to the readExtendedTimingParameterSet or readCurrentlyActiveTimingParameters value.
- Properties inherited from RespSFBase
ushort | SubFunction [getprotected set]
The Subfunction
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Timing parameter response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespSFBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespTimingParameter
RespTimingParameter Member List

This is the complete list of members for RespTimingParameter, including all inherited members.

ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespTimingParameter | virtual
ServiceID | RespBase |
SubFunction | RespSFBase |
TimingParameters | RespTimingParameter |


ASAP2Library interface: RespTransferData Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespTransferData
Public Member Functions | Properties | List of all members
RespTransferData Class Reference

Request TransferData service response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte | BlockSequenceCounter [get]
This parameter is an echo of the blockSequenceCounter parameter from the request message.
byte[] | UploadedData [get]
Raw data response stream. More...
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

Request TransferData service response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.

Property Documentation

◆ UploadedData

byte [] UploadedData
get

Raw data response stream.

  • For an upload, the parameter include the uploaded data.
  • For a download, the parameter transferResponseParameterRecord could include a checksum computed by the server.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespTransferData
RespTransferData Member List

This is the complete list of members for RespTransferData, including all inherited members.

BlockSequenceCounter | RespTransferData |
ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespTransferData | virtual
ServiceID | RespBase |
UploadedData | RespTransferData |


ASAP2Library interface: RespWriteMemoryByAddress Class Reference

  • Diagnose
  • Comm
  • UDS
  • RespWriteMemoryByAddress
Public Member Functions | Properties | List of all members
RespWriteMemoryByAddress Class Reference

WriteMemoryByAddress response. More...

Public Member Functions

override bool Initialize (List< byte > response, ref int offset)
Initialize properties from response data. More...

Properties

byte | AdrLen [get]
Length of memory address
ulong | MemoryAddress [get]
The memory address
ulong | MemorySize [get]
The memory size
byte | SizeLen [get]
Length of memory size
- Properties inherited from RespBase
byte | ErrorCode [getprotected set]
The errorcode (0 for success)
SID | ServiceID [getprotected set]
The Service Id

Detailed Description

WriteMemoryByAddress response.

Member Function Documentation

◆ Initialize()

override bool Initialize | ( | List< byte > | response,
 |  | ref int | offset
 | ) |  |
virtual

Initialize properties from response data.

base.initialize method should always be called first.

Parameters
response | Received response data
offset | [in/out] offset to additional data
Returns
true, if additional data could be parsed

Reimplemented from RespBase.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • RespWriteMemoryByAddress
RespWriteMemoryByAddress Member List

This is the complete list of members for RespWriteMemoryByAddress, including all inherited members.

AdrLen | RespWriteMemoryByAddress |
ErrorCode | RespBase |
Initialize(List< byte > response, ref int offset) | RespWriteMemoryByAddress | virtual
MemoryAddress | RespWriteMemoryByAddress |
MemorySize | RespWriteMemoryByAddress |
ServiceID | RespBase |
SizeLen | RespWriteMemoryByAddress |


ASAP2Library interface: ServiceProperties Class Reference

  • Diagnose
  • Comm
  • UDS
  • ServiceProperties
Static Public Member Functions | List of all members
ServiceProperties Class Reference

Holds specification defined Service properties. More...

Static Public Member Functions

static bool HasSubfunction (SID sid)
Indictaes, if the specified service got a subfunction. More...

Detailed Description

Holds specification defined Service properties.

(e.g. like if a service got a subfunction).

Member Function Documentation

◆ HasSubfunction()

static bool HasSubfunction ( SID sid )
static

Indictaes, if the specified service got a subfunction.

Parameters
sid Service Id
Returns


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • ServiceProperties
ServiceProperties Member List

This is the complete list of members for ServiceProperties, including all inherited members.

HasSubfunction(SID sid) ServiceProperties static


ASAP2Library interface: ServiceType Struct Reference

  • Diagnose
  • Comm
  • UDS
  • ServiceType
List of all members
ServiceType Struct Reference

Service properties. More...

Detailed Description

Service properties.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • ServiceType
ServiceType Member List

This is the complete list of members for ServiceType, including all inherited members.


ASAP2Library interface: SrcDataIdentifier Struct Reference

  • Diagnose
  • Comm
  • UDS
  • SrcDataIdentifier
Public Member Functions | Properties | List of all members
SrcDataIdentifier Struct Reference

Dynamically Define Identifier by Id request. More...

Public Member Functions

SrcDataIdentifier (ushort identifier, byte positionInSrcDataRecord, byte memorySize)
byte[] toArray ()

Properties

ushort | Identifier [get]
The data identifier
byte | MemorySize [get]
The memory size
byte | PositionInSrcDataRecord [get]
The position within the data record

Detailed Description

Dynamically Define Identifier by Id request.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • SrcDataIdentifier
SrcDataIdentifier Member List

This is the complete list of members for SrcDataIdentifier, including all inherited members.

Identifier | SrcDataIdentifier
MemorySize | SrcDataIdentifier
PositionInSrcDataRecord | SrcDataIdentifier
SrcDataIdentifier(ushort identifier, byte positionInSrcDataRecord, byte memorySize) (defined in SrcDataIdentifier) | SrcDataIdentifier
toArray() (defined in SrcDataIdentifier) | SrcDataIdentifier


ASAP2Library interface: SrcDataMemory Struct Reference

  • Diagnose
  • Comm
  • UDS
  • SrcDataMemory
Public Member Functions | Properties | List of all members
SrcDataMemory Struct Reference

Dynamically Define Identifier by memory address request. More...

Public Member Functions

SrcDataMemory (ulong address, byte sizeLen, ulong size)
byte[] toArray (byte adrLen, byte sizeLen)

Properties

ulong | Address [get]
Memory address
ulong | Size [get]
The memory size

Detailed Description

Dynamically Define Identifier by memory address request.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • SrcDataMemory
SrcDataMemory Member List

This is the complete list of members for SrcDataMemory, including all inherited members.

Address | SrcDataMemory
Size | SrcDataMemory
SrcDataMemory(ulong address, byte sizeLen, ulong size) (defined in SrcDataMemory) | SrcDataMemory
toArray(byte adrLen, byte sizeLen) (defined in SrcDataMemory) | SrcDataMemory


ASAP2Library interface: UDSClient Class Reference

  • Diagnose
  • Comm
  • UDS
  • UDSClient
Classes | Public Member Functions | Properties | List of all members
UDSClient Class Reference

Implements the UDS client (Tester) Application protocol. More...

Classes

class IdentifierRequest
Represents a cyclic Identifier request and its response data. More...

Public Member Functions

UDSClient (DoIPClient doIPClient, uint p2Client=50, uint p3Client=50, IDictionary< byte, string > errorCodes=null)
Creates a new instance of the UDS Client (Tester) application protocol using DoIP. More...
UDSClient (ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff, IDictionary< byte, string > errorCodes=null)
Creates a new instance of the UDS Client (Tester) application protocol. More...
void | addIdentifier (IdentifierRecord record, int updateCycle)
Adds the specified Identifier to the set of cyclically requested values. More...
void | clearServices ()
Clears all for a cyclic request configured services.
override void | Dispose ()
Frees used resources. More...
byte | download (long address, byte[] data, byte adrAndLenFmt=0, EventHandler< ProgressArgs > progressHandler=null)
Download data synchronously to the ECU. More...
string | getNegResCode (byte errorCode)
Gets a text value for a specified negative response code. More...
IdentifierRequest | getResponse (ushort identifier)
byte | readMemory (long address, long len, long maxLen, out byte[] data, EventHandler< ProgressArgs > progressHandler=null)
Reads memory by address synchronously from the ECU. More...
void | removeIdentifier (IdentifierRecord record)
Removes the sprecified Identifier from the set of cyclically requested values. More...
byte | unlock (byte requestSeedSf, NativeSKDLL skDLL, byte[] variant=null)
Unlock session. More...
byte | upload (long address, long len, out byte[] data, byte adrAndLenFmt=0, EventHandler< ProgressArgs > progressHandler=null)
Upload data synchronously from the ECU. More...
byte | writeMemory (long address, byte[] data, long maxLen, EventHandler< ProgressArgs > progressHandler=null)
Write memory by address synchronously to the ECU. More...
- Public Member Functions inherited from UDSClientBase
UDSClientBase (DoIPClient doIPClient, uint p2Client=50, uint p3Client=50)
Creates a new instance of the UDS Client (Tester) application protocol using DoIP. More...
UDSClientBase (ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff)
Creates a new instance of the UDS Client (Tester) application protocol. More...
MsgState | AccessTimingSercice (out RespTimingParameter response, TimingParameterAccessType sf, byte[] data, bool awaitResponse=true)
AccessTimingParameter service. More...
MsgState | ClearDiagnosticInformation (out RespBase response, uint groupOfDTC=0xffffff)
ClearDiagnosticInformation Service. More...
MsgState | CommunicationControl (out RespSFBase response, CommunicationControlType sf, byte communicationType, ushort nodeId, bool awaitResponse=true)
CommunicationControl service. More...
MsgState | ControlDTCSetting (out RespControlDTCSetting response, DTCSettingType sf, bool awaitResponse=true)
ControlDTCSetting service. More...
MsgState | DiagnosticSessionControl (out RespSession response, DiagnosticSessionType sf, bool awaitResponse=true)
The DiagnosticSessionControl service is used to enable different diagnostic sessions in the server(s). More...
MsgState | DynamicallyClearDataIdentifier (out RespDynamicallyDefine response, ushort dynId, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction ClearDynamicallyDefinedDataIdentifier. More...
MsgState | DynamicallyDefineDataIdentifierByAdr (out RespDynamicallyDefine response, ushort dynId, byte srcAdrLen, byte srcSizeLen, SrcDataMemory[] src, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction DefineByMemoryAddress. More...
MsgState | DynamicallyDefineDataIdentifierById (out RespDynamicallyDefine response, ushort dynId, SrcDataIdentifier[] src, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction DefineByIdentifier. More...
MsgState | EcuReset (out RespReset response, ResetType sf, bool awaitResponse=true)
The ECUReset service is used by the client to request a server reset. More...
MsgState | executeService< T > (out T response, SID service, byte subFunction, byte[] data=null, bool awaitResponse=true)
Generic method to execute an UDS service. More...
MsgState | executeService< T > (out T response, SID service, byte[] data=null)
Generic method to execute an UDS service. More...
MsgState | InputOutputControlByIdentifier (out RespIdentfier response, ushort identifier)
InputOutputControlByIdentifier service. More...
MsgState | LinkControl (out RespLinkControl response, LinkControlType sf, byte[] data=null, bool awaitResponse=true)
LinkControl service. More...
MsgState | ReadDataByIdentifier (out RespData response, ushort[] identifiers)
ReadDataByIdentifier service. More...
MsgState | ReadDataByPeriodicIdentifier (out RespData response, TransmissionModeType sf, byte[] identifierIds=null)
ReadDataByPeriodicIdentifier service. More...
MsgState | ReadDTCInformation (out RespSFBase response, ReportDTCType sf, uint groupOfDTC=0, byte snapshotRecordNumber=0, bool awaitResponse=true)
ReadDTCInformation Service. More...
MsgState | ReadDTCInformationCount (out RespDTCCount response, ReportDTCType sf, DTCStatusMaskType statusMask, ushort severityMask=0)
ReadDTCInformationCount Service. More...
MsgState | ReadDTCInformationRecords (out RespDTCRecords response, ReportDTCType sf, DTCStatusMaskType statusMask=0)
ReadDTCInformation Service. More...
MsgState | ReadMemoryByAddress (out RespData response, long address, long size)
ReadMemoryByAddress service. More...
MsgState | ReadScalingDataByIdentifier (out RespData response, ushort identifier)
ReadScalingDataByIdentifier service. More...
MsgState | RequestDownload (out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0)
RequestDownload service. More...
MsgState | RequestFileTransfer (out RespBase response, ModeOfOperationType sf, string filePathAndName)
RequestFileTransfer service. More...
MsgState | RequestTransferExit (out RespData response, byte[] data=null)
RequestTransferExit service. More...
MsgState | RequestUpload (out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0)
RequestUpload service. More...
MsgState | ResponseOnEvent (out RespResponseOnEvent response, ResponseOnEventType sf, byte eventWindowTime, byte[] data=null, bool awaitResponse=true)
ResponseOnEvent service. More...
MsgState | RoutineControl (out RespRoutineControl response, RoutineControlType sf, RoutineIdentifierType routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true)
Routine service. More...
MsgState | RoutineControl (out RespRoutineControl response, RoutineControlType sf, ushort routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true)
Routine service. More...
MsgState | SecuredDataTransmission (out RespBase response, byte[] data)
SecuredDataTransmission service. More...
MsgState | SecurityAccessRequestSeed (out RespSecurityAccess response, byte securityAccessType, byte[] securityAccessDataRecord=null)
SecurityAccess Request Seed service. More...
MsgState | SecurityAccessSendKey (out RespSecurityAccess response, byte securityAccessType, byte[] securityKey, bool awaitResponse=true)
SecurityAccess Send key service. More...
MsgState | TesterPresent (out RespSFBase response, bool awaitResponse=true)
TesterPresent service. More...
override string | ToString ()
MsgState | TransferData (out RespTransferData response, byte blockSequenceCounter, byte[] dataToDownload=null)
TransferData service. More...
MsgState | WriteDataByIdentifier (out RespIdentfier response, ushort identifier, byte[] data)
WriteDataByIdentifier service. More...
MsgState | WriteMemoryByAddress (out RespWriteMemoryByAddress response, long address, long size, byte[] data)
WriteMemoryByAddress service. More...

Properties

Dictionary< byte, string > | NegativeResponseCodes [get]
Gets the negative response codes dictionary.
bool | NoResponseTesterPresent [getset]
Gets or sets a value if the cyclic TesterPresent service request should inquire a positive repsonse.
- Properties inherited from UDSClientBase
uint | CmdId [getset]
Gets the CAN command ID.
byte | CurrentDiagSession [get]
Gets the curent diag session.
byte | FillByte [getset]
Gets or sets the fill byte value
long | MaxMsgLen [get]
Maximum message length according the Type.
uint | P2Client [getset]
Gets or sets the P2 timing
uint | P3Client [getset]
Gets or sets the P3 timing
uint | RspId [getset]
Gets the CAN response ID.
bool | UseCANFD [get]
Gets an indication if CANFD is used
bool | UseFillByte [getset]
Gets or sets the fill byte usage

Additional Inherited Members

- Public Attributes inherited from UDSClientBase
readonly DoIPClient | DoIPClient
The DoIP client (may be null using UDS on CAN).
- Static Public Attributes inherited from UDSClientBase
const byte | NEG_RESPONSE_VALUE = 0x7f
Negative response (first byte)
const byte | POS_RESPONSE_MASK = 0x40
Mask for ServiceID byte in responses
- Protected Attributes inherited from UDSClientBase
int | mLastHandledMessage

Detailed Description

Implements the UDS client (Tester) Application protocol.

Provides all UDS protocol services and extends UDSClientBase with the following:

  • Cyclic TesterPresent calls for non default sessions.

Constructor & Destructor Documentation

◆ UDSClient() [1/2]

UDSClient | ( | ICANProvider | canProvider,
 |  | uint | cmdId,
 |  | uint | rspId,
 |  | bool | useCANFD = false,
 |  | uint | p2Client = 50,
 |  | uint | p3Client = 50,
 |  | bool | useFillByte = true,
 |  | byte | fillByte = 0xff,
 |  | IDictionary< byte, string > | errorCodes = null
 | ) |  |

Creates a new instance of the UDS Client (Tester) application protocol.

Parameters
canProvider | A can provider instance to use
cmdId | CAN Command ID to use
rspId | CAN response ID to use
useCANFD | true, if the protocol should use CAN FD frames (extended length).
p2Client | Time between end of tester request and start of ECU response
p3Client | >Time between end of ECU response and start of new tester request
useFillByte
fillByte
errorCodes | A potential dictionary with additional errorCodes (maybe from an ODX file with jnsoft.Diagnose.ODX.ODXRoot.getNegResCodes)

◆ UDSClient() [2/2]

UDSClient | ( | DoIPClient | doIPClient,
 |  | uint | p2Client = 50,
 |  | uint | p3Client = 50,
 |  | IDictionary< byte, string > | errorCodes = null
 | ) |  |

Creates a new instance of the UDS Client (Tester) application protocol using DoIP.

Parameters
doIPClient | The DoIP client to use
p2Client | Time between end of tester request and start of ECU response
p3Client | >Time between end of ECU response and start of new tester request
errorCodes | A potential dictionary with additional errorCodes (maybe from an ODX file with jnsoft.Diagnose.ODX.ODXRoot.getNegResCodes)

Member Function Documentation

◆ addIdentifier()

void addIdentifier | ( | IdentifierRecord | record,
 |  | int | updateCycle
 | ) |  |

Adds the specified Identifier to the set of cyclically requested values.

Parameters
record | The identifier record to add
updateCycle | Update cycle in [ms]

◆ Dispose()

override void Dispose ( )
virtual

Frees used resources.

Reimplemented from UDSClientBase.

◆ download()

byte download | ( | long | address,
 |  | byte[] | data,
 |  | byte | adrAndLenFmt = 0,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |

Download data synchronously to the ECU.

Parameters
address | The address to write to
data | The data to download
adrAndLenFmt Address and Length format byte This parameter is a one byte value with each nibble encoded separately: ⎯ bit 7 - 4: Length(number of bytes) of the memorySize parameter ⎯ bit 3 - 0: Length(number of bytes) of the memoryAddress parameter
  • The default(0) tries to find a suitable value
progressHandler | Callback to receive progress, maybe null
Returns
A response code (NegRespCode)

◆ getNegResCode()

string getNegResCode ( byte errorCode )

Gets a text value for a specified negative response code.

Parameters
errorCode
Returns

◆ readMemory()

byte readMemory | ( | long | address,
 |  | long | len,
 |  | long | maxLen,
 |  | out byte[] | data,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |

Reads memory by address synchronously from the ECU.

Parameters
address | The address to read from
len | The data length to read
maxLen | The maximum blocksize to use
data | The data to write the data to
progressHandler | Callback to receive progress, maybe null
Returns
A response code (NegRespCode)

◆ removeIdentifier()

void removeIdentifier ( IdentifierRecord record )

Removes the sprecified Identifier from the set of cyclically requested values.

Parameters
record The identifier record to remove

◆ unlock()

byte unlock | ( | byte | requestSeedSf,
 |  | NativeSKDLL | skDLL,
 |  | byte[] | variant = null
 | ) |  |

Unlock session.

  • Unlocks the current session using the specified request seed subfunction and 6the specified seed&key DLL.
  • Calls the 'GenerateKeyEx' function in the specified sed&key DLL.
Parameters
requestSeedSf
skDLL
variant A potential variant string for the SeedKey DLL call
Returns
A response code (NegRespCode)

◆ upload()

byte upload | ( | long | address,
 |  | long | len,
 |  | out byte[] | data,
 |  | byte | adrAndLenFmt = 0,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |

Upload data synchronously from the ECU.

Parameters
address | The address to upload from
len | The data length to upload
data | The data to write the uploaded data to
adrAndLenFmt Address and Length format byte This parameter is a one byte value with each nibble encoded separately: ⎯ bit 7 - 4: Length(number of bytes) of the memorySize parameter ⎯ bit 3 - 0: Length(number of bytes) of the memoryAddress parameter
  • The default(0) tries to find a suitable value
progressHandler | Callback to receive progress, maybe null
Returns
A response code (NegRespCode)

◆ writeMemory()

byte writeMemory | ( | long | address,
 |  | byte[] | data,
 |  | long | maxLen,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |

Write memory by address synchronously to the ECU.

Parameters
address | The address to write to (If the adress is uint.MaxValue, the data should be written to the current MTA location)
data | The data to download
maxLen | The maximum blocksize to use
progressHandler | Callback to receive progress, maybe null
Returns
A response code (NegRespCode)


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • UDSClient
UDSClient Member List

This is the complete list of members for UDSClient, including all inherited members.

AccessTimingSercice(out RespTimingParameter response, TimingParameterAccessType sf, byte[] data, bool awaitResponse=true) | UDSClientBase |
addIdentifier(IdentifierRecord record, int updateCycle) | UDSClient |
ClearDiagnosticInformation(out RespBase response, uint groupOfDTC=0xffffff) | UDSClientBase |
clearServices() | UDSClient |
CmdId | UDSClientBase |
CommunicationControl(out RespSFBase response, CommunicationControlType sf, byte communicationType, ushort nodeId, bool awaitResponse=true) | UDSClientBase |
ControlDTCSetting(out RespControlDTCSetting response, DTCSettingType sf, bool awaitResponse=true) | UDSClientBase |
CurrentDiagSession | UDSClientBase |
DiagnosticSessionControl(out RespSession response, DiagnosticSessionType sf, bool awaitResponse=true) | UDSClientBase |
Dispose() | UDSClient | virtual
DoIPClient | UDSClientBase |
download(long address, byte[] data, byte adrAndLenFmt=0, EventHandler< ProgressArgs > progressHandler=null) | UDSClient |
DynamicallyClearDataIdentifier(out RespDynamicallyDefine response, ushort dynId, bool awaitResponse=true) | UDSClientBase |
DynamicallyDefineDataIdentifierByAdr(out RespDynamicallyDefine response, ushort dynId, byte srcAdrLen, byte srcSizeLen, SrcDataMemory[] src, bool awaitResponse=true) | UDSClientBase |
DynamicallyDefineDataIdentifierById(out RespDynamicallyDefine response, ushort dynId, SrcDataIdentifier[] src, bool awaitResponse=true) | UDSClientBase |
EcuReset(out RespReset response, ResetType sf, bool awaitResponse=true) | UDSClientBase |
executeService< T >(out T response, SID service, byte subFunction, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
executeService< T >(out T response, SID service, byte[] data=null) | UDSClientBase |
FillByte | UDSClientBase |
getNegResCode(byte errorCode) | UDSClient |
getResponse(ushort identifier) (defined in UDSClient) | UDSClient |
InputOutputControlByIdentifier(out RespIdentfier response, ushort identifier) | UDSClientBase |
LinkControl(out RespLinkControl response, LinkControlType sf, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
MaxMsgLen | UDSClientBase |
mLastHandledMessage (defined in UDSClientBase) | UDSClientBase | protected
NEG_RESPONSE_VALUE | UDSClientBase | static
NegativeResponseCodes | UDSClient |
NoResponseTesterPresent | UDSClient |
P2Client | UDSClientBase |
P3Client | UDSClientBase |
POS_RESPONSE_MASK | UDSClientBase | static
ReadDataByIdentifier(out RespData response, ushort[] identifiers) | UDSClientBase |
ReadDataByPeriodicIdentifier(out RespData response, TransmissionModeType sf, byte[] identifierIds=null) | UDSClientBase |
ReadDTCInformation(out RespSFBase response, ReportDTCType sf, uint groupOfDTC=0, byte snapshotRecordNumber=0, bool awaitResponse=true) | UDSClientBase |
ReadDTCInformationCount(out RespDTCCount response, ReportDTCType sf, DTCStatusMaskType statusMask, ushort severityMask=0) | UDSClientBase |
ReadDTCInformationRecords(out RespDTCRecords response, ReportDTCType sf, DTCStatusMaskType statusMask=0) | UDSClientBase |
readMemory(long address, long len, long maxLen, out byte[] data, EventHandler< ProgressArgs > progressHandler=null) | UDSClient |
ReadMemoryByAddress(out RespData response, long address, long size) | UDSClientBase |
ReadScalingDataByIdentifier(out RespData response, ushort identifier) | UDSClientBase |
removeIdentifier(IdentifierRecord record) | UDSClient |
RequestDownload(out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0) | UDSClientBase |
RequestFileTransfer(out RespBase response, ModeOfOperationType sf, string filePathAndName) | UDSClientBase |
RequestTransferExit(out RespData response, byte[] data=null) | UDSClientBase |
RequestUpload(out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0) | UDSClientBase |
ResponseOnEvent(out RespResponseOnEvent response, ResponseOnEventType sf, byte eventWindowTime, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
RoutineControl(out RespRoutineControl response, RoutineControlType sf, ushort routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true) | UDSClientBase |
RoutineControl(out RespRoutineControl response, RoutineControlType sf, RoutineIdentifierType routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true) | UDSClientBase |
RspId | UDSClientBase |
SecuredDataTransmission(out RespBase response, byte[] data) | UDSClientBase |
SecurityAccessRequestSeed(out RespSecurityAccess response, byte securityAccessType, byte[] securityAccessDataRecord=null) | UDSClientBase |
SecurityAccessSendKey(out RespSecurityAccess response, byte securityAccessType, byte[] securityKey, bool awaitResponse=true) | UDSClientBase |
TesterPresent(out RespSFBase response, bool awaitResponse=true) | UDSClientBase |
ToString() (defined in UDSClientBase) | UDSClientBase |
TransferData(out RespTransferData response, byte blockSequenceCounter, byte[] dataToDownload=null) | UDSClientBase |
UDSClient(ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff, IDictionary< byte, string > errorCodes=null) | UDSClient |
UDSClient(DoIPClient doIPClient, uint p2Client=50, uint p3Client=50, IDictionary< byte, string > errorCodes=null) | UDSClient |
UDSClientBase(ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff) | UDSClientBase |
UDSClientBase(DoIPClient doIPClient, uint p2Client=50, uint p3Client=50) | UDSClientBase |
unlock(byte requestSeedSf, NativeSKDLL skDLL, byte[] variant=null) | UDSClient |
upload(long address, long len, out byte[] data, byte adrAndLenFmt=0, EventHandler< ProgressArgs > progressHandler=null) | UDSClient |
UseCANFD | UDSClientBase |
UseFillByte | UDSClientBase |
WriteDataByIdentifier(out RespIdentfier response, ushort identifier, byte[] data) | UDSClientBase |
writeMemory(long address, byte[] data, long maxLen, EventHandler< ProgressArgs > progressHandler=null) | UDSClient |
WriteMemoryByAddress(out RespWriteMemoryByAddress response, long address, long size, byte[] data) | UDSClientBase |


ASAP2Library interface: UDSClient.IdentifierRequest Class Reference

  • Diagnose
  • Comm
  • UDS
  • UDSClient
  • IdentifierRequest
Public Member Functions | Public Attributes | Properties | List of all members
UDSClient.IdentifierRequest Class Reference

Represents a cyclic Identifier request and its response data. More...

Public Member Functions

IdentifierRequest (IdentifierRecord record, int cycle)
Creates a new instance of IdentifierRequest. More...

Public Attributes

readonly IdentifierRecord Record
Identifier record

Properties

int | Cycle [getset]
Update cycle in [ms]
RespData | LastResponse [get]
Last received raw response
int | LastUpdate [get]
most recently response received

Detailed Description

Represents a cyclic Identifier request and its response data.

Constructor & Destructor Documentation

◆ IdentifierRequest()

IdentifierRequest | ( | IdentifierRecord | record,
 |  | int | cycle
 | ) |  |

Creates a new instance of IdentifierRequest.

Parameters
record | The identifier record to execute
cycle | Update cycle in [ms]


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • UDSClient
  • IdentifierRequest
UDSClient.IdentifierRequest Member List

This is the complete list of members for UDSClient.IdentifierRequest, including all inherited members.

Cycle | UDSClient.IdentifierRequest
IdentifierRequest(IdentifierRecord record, int cycle) | UDSClient.IdentifierRequest
LastResponse | UDSClient.IdentifierRequest
LastUpdate | UDSClient.IdentifierRequest
Record | UDSClient.IdentifierRequest


ASAP2Library interface: UDSClientBase Class Reference

  • Diagnose
  • Comm
  • UDS
  • UDSClientBase
Public Member Functions | Public Attributes | Static Public Attributes | Protected Attributes | Properties | List of all members
UDSClientBase Class Reference

Implements the UDS client base Application protocol. More...

Public Member Functions

UDSClientBase (DoIPClient doIPClient, uint p2Client=50, uint p3Client=50)
Creates a new instance of the UDS Client (Tester) application protocol using DoIP. More...
UDSClientBase (ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff)
Creates a new instance of the UDS Client (Tester) application protocol. More...
MsgState | AccessTimingSercice (out RespTimingParameter response, TimingParameterAccessType sf, byte[] data, bool awaitResponse=true)
AccessTimingParameter service. More...
MsgState | ClearDiagnosticInformation (out RespBase response, uint groupOfDTC=0xffffff)
ClearDiagnosticInformation Service. More...
MsgState | CommunicationControl (out RespSFBase response, CommunicationControlType sf, byte communicationType, ushort nodeId, bool awaitResponse=true)
CommunicationControl service. More...
MsgState | ControlDTCSetting (out RespControlDTCSetting response, DTCSettingType sf, bool awaitResponse=true)
ControlDTCSetting service. More...
MsgState | DiagnosticSessionControl (out RespSession response, DiagnosticSessionType sf, bool awaitResponse=true)
The DiagnosticSessionControl service is used to enable different diagnostic sessions in the server(s). More...
virtual void | Dispose ()
Frees used resources. More...
MsgState | DynamicallyClearDataIdentifier (out RespDynamicallyDefine response, ushort dynId, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction ClearDynamicallyDefinedDataIdentifier. More...
MsgState | DynamicallyDefineDataIdentifierByAdr (out RespDynamicallyDefine response, ushort dynId, byte srcAdrLen, byte srcSizeLen, SrcDataMemory[] src, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction DefineByMemoryAddress. More...
MsgState | DynamicallyDefineDataIdentifierById (out RespDynamicallyDefine response, ushort dynId, SrcDataIdentifier[] src, bool awaitResponse=true)
DynamicallyDefineDataIdentifier service, subfunction DefineByIdentifier. More...
MsgState | EcuReset (out RespReset response, ResetType sf, bool awaitResponse=true)
The ECUReset service is used by the client to request a server reset. More...
MsgState | executeService< T > (out T response, SID service, byte subFunction, byte[] data=null, bool awaitResponse=true)
Generic method to execute an UDS service. More...
MsgState | executeService< T > (out T response, SID service, byte[] data=null)
Generic method to execute an UDS service. More...
MsgState | InputOutputControlByIdentifier (out RespIdentfier response, ushort identifier)
InputOutputControlByIdentifier service. More...
MsgState | LinkControl (out RespLinkControl response, LinkControlType sf, byte[] data=null, bool awaitResponse=true)
LinkControl service. More...
MsgState | ReadDataByIdentifier (out RespData response, ushort[] identifiers)
ReadDataByIdentifier service. More...
MsgState | ReadDataByPeriodicIdentifier (out RespData response, TransmissionModeType sf, byte[] identifierIds=null)
ReadDataByPeriodicIdentifier service. More...
MsgState | ReadDTCInformation (out RespSFBase response, ReportDTCType sf, uint groupOfDTC=0, byte snapshotRecordNumber=0, bool awaitResponse=true)
ReadDTCInformation Service. More...
MsgState | ReadDTCInformationCount (out RespDTCCount response, ReportDTCType sf, DTCStatusMaskType statusMask, ushort severityMask=0)
ReadDTCInformationCount Service. More...
MsgState | ReadDTCInformationRecords (out RespDTCRecords response, ReportDTCType sf, DTCStatusMaskType statusMask=0)
ReadDTCInformation Service. More...
MsgState | ReadMemoryByAddress (out RespData response, long address, long size)
ReadMemoryByAddress service. More...
MsgState | ReadScalingDataByIdentifier (out RespData response, ushort identifier)
ReadScalingDataByIdentifier service. More...
MsgState | RequestDownload (out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0)
RequestDownload service. More...
MsgState | RequestFileTransfer (out RespBase response, ModeOfOperationType sf, string filePathAndName)
RequestFileTransfer service. More...
MsgState | RequestTransferExit (out RespData response, byte[] data=null)
RequestTransferExit service. More...
MsgState | RequestUpload (out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0)
RequestUpload service. More...
MsgState | ResponseOnEvent (out RespResponseOnEvent response, ResponseOnEventType sf, byte eventWindowTime, byte[] data=null, bool awaitResponse=true)
ResponseOnEvent service. More...
MsgState | RoutineControl (out RespRoutineControl response, RoutineControlType sf, RoutineIdentifierType routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true)
Routine service. More...
MsgState | RoutineControl (out RespRoutineControl response, RoutineControlType sf, ushort routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true)
Routine service. More...
MsgState | SecuredDataTransmission (out RespBase response, byte[] data)
SecuredDataTransmission service. More...
MsgState | SecurityAccessRequestSeed (out RespSecurityAccess response, byte securityAccessType, byte[] securityAccessDataRecord=null)
SecurityAccess Request Seed service. More...
MsgState | SecurityAccessSendKey (out RespSecurityAccess response, byte securityAccessType, byte[] securityKey, bool awaitResponse=true)
SecurityAccess Send key service. More...
MsgState | TesterPresent (out RespSFBase response, bool awaitResponse=true)
TesterPresent service. More...
override string | ToString ()
MsgState | TransferData (out RespTransferData response, byte blockSequenceCounter, byte[] dataToDownload=null)
TransferData service. More...
MsgState | WriteDataByIdentifier (out RespIdentfier response, ushort identifier, byte[] data)
WriteDataByIdentifier service. More...
MsgState | WriteMemoryByAddress (out RespWriteMemoryByAddress response, long address, long size, byte[] data)
WriteMemoryByAddress service. More...

Public Attributes

readonly DoIPClient DoIPClient
The DoIP client (may be null using UDS on CAN).

Static Public Attributes

const byte | NEG_RESPONSE_VALUE = 0x7f
Negative response (first byte)
const byte | POS_RESPONSE_MASK = 0x40
Mask for ServiceID byte in responses

Protected Attributes

int mLastHandledMessage

Properties

uint | CmdId [getset]
Gets the CAN command ID.
byte | CurrentDiagSession [get]
Gets the curent diag session.
byte | FillByte [getset]
Gets or sets the fill byte value
long | MaxMsgLen [get]
Maximum message length according the Type.
uint | P2Client [getset]
Gets or sets the P2 timing
uint | P3Client [getset]
Gets or sets the P3 timing
uint | RspId [getset]
Gets the CAN response ID.
bool | UseCANFD [get]
Gets an indication if CANFD is used
bool | UseFillByte [getset]
Gets or sets the fill byte usage

Detailed Description

Implements the UDS client base Application protocol.

  • Provides generic methods to exeute services (UDSClientBase.executeService) with additional or special parameters.
  • Provides standard methods for each defined UDS service.

Constructor & Destructor Documentation

◆ UDSClientBase() [1/2]

UDSClientBase | ( | ICANProvider | canProvider,
 |  | uint | cmdId,
 |  | uint | rspId,
 |  | bool | useCANFD = false,
 |  | uint | p2Client = 50,
 |  | uint | p3Client = 50,
 |  | bool | useFillByte = true,
 |  | byte | fillByte = 0xff
 | ) |  |

Creates a new instance of the UDS Client (Tester) application protocol.

Parameters
canProvider | A can provider instance to use
cmdId | CAN Command ID to use
rspId | CAN response ID to use
useCANFD | true, if the protocol should use CAN FD frames (extended length).
p2Client | Time between end of tester request and start of ECU response
p3Client | >Time between end of ECU response and start of new tester request
useFillByte | true if a fillbytes should be used
fillByte | The fillbyte to use

◆ UDSClientBase() [2/2]

UDSClientBase | ( | DoIPClient | doIPClient,
 |  | uint | p2Client = 50,
 |  | uint | p3Client = 50
 | ) |  |

Creates a new instance of the UDS Client (Tester) application protocol using DoIP.

Parameters
doIPClient | The DoIP client instance to use
p2Client | Time between end of tester request and start of ECU response
p3Client | >Time between end of ECU response and start of new tester request

Member Function Documentation

◆ AccessTimingSercice()

MsgState AccessTimingSercice | ( | out RespTimingParameter | response,
 |  | TimingParameterAccessType | sf,
 |  | byte[] | data,
 |  | bool | awaitResponse = true
 | ) |  |

AccessTimingParameter service.

The AccessTimingParameter service is used to read and change the default timing parameters of a communication link for the duration this communication link is active.

Parameters
response | Service response
sf | Subfunction type
data | Must be non null for t = TimingParameterAccessType.SetTimingParametersToGivenValues
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ ClearDiagnosticInformation()

MsgState ClearDiagnosticInformation | ( | out RespBase | response,
 |  | uint | groupOfDTC = 0xffffff
 | ) |  |

ClearDiagnosticInformation Service.

The ClearDiagnosticInformation service is used by the client to clear diagnostic information in one or multiple servers’ memory.

Parameters
groupOfDTC | This parameter contains a 3-byte value indicating the group of DTCs (e.g., Powertrain, Body, Chassis) or the particular DTC to be cleared.
response | The service response
Returns
A MsgState

◆ CommunicationControl()

MsgState CommunicationControl | ( | out RespSFBase | response,
 |  | CommunicationControlType | sf,
 |  | byte | communicationType,
 |  | ushort | nodeId,
 |  | bool | awaitResponse = true
 | ) |  |

CommunicationControl service.

The purpose of this service is to switch on/off the transmission and/or the reception of certain messages of (a) server(s) (e.g.application communication messages).

Parameters
response | Service response
sf | Subfunction type
communicationType
nodeId | Used only if type =CommunicationControlType.EnableRxAndDisableTxWithEnhancedAddressInformation|CommunicationControlType.EnableRxAndTxWithEnhancedAddressInformation
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ ControlDTCSetting()

MsgState ControlDTCSetting | ( | out RespControlDTCSetting | response,
 |  | DTCSettingType | sf,
 |  | bool | awaitResponse = true
 | ) |  |

ControlDTCSetting service.

The ControlDTCSetting service shall be used by a client to stop or resume the updating of DTC status bits in the server(s). DTC status bits are reported in the statusOfDTC parameter of the positive response to certain subfunctions of ReadDTCInformation.

Parameters
response | Service response
sf | Subfunction type
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ DiagnosticSessionControl()

MsgState DiagnosticSessionControl | ( | out RespSession | response,
 |  | DiagnosticSessionType | sf,
 |  | bool | awaitResponse = true
 | ) |  |

The DiagnosticSessionControl service is used to enable different diagnostic sessions in the server(s).

A diagnostic session enables a specific set of diagnostic services and/or functionality in the server(s). This service provides the capability that the server(s) can report data link layer specific parameter values valid for the enabled diagnostic session(e.g.timing parameter values). The user of this International Standard shall define the exact set of services and/or functionality enabled in each diagnostic session.

Parameters
response | Service response
sf | Subfunction type
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ Dispose()

virtual void Dispose ( )
virtual

Frees used resources.

Reimplemented in UDSClient.

◆ DynamicallyClearDataIdentifier()

MsgState DynamicallyClearDataIdentifier | ( | out RespDynamicallyDefine | response,
 |  | ushort | dynId,
 |  | bool | awaitResponse = true
 | ) |  |

DynamicallyDefineDataIdentifier service, subfunction ClearDynamicallyDefinedDataIdentifier.

Parameters
response | Service response
dynId | The identifier to clear
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ DynamicallyDefineDataIdentifierByAdr()

MsgState DynamicallyDefineDataIdentifierByAdr | ( | out RespDynamicallyDefine | response,
 |  | ushort | dynId,
 |  | byte | srcAdrLen,
 |  | byte | srcSizeLen,
 |  | SrcDataMemory[] | src,
 |  | bool | awaitResponse = true
 | ) |  |

DynamicallyDefineDataIdentifier service, subfunction DefineByMemoryAddress.

Parameters
response | Service response
dynId | The identifier to define (0xF200-0xF3FF)
srcAdrLen | Length of memory address parameters (must be smaller than 0x10)
srcSizeLen | Length of memory size parameters (must be smaller than 0x10)
src | List of source memory addresses
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ DynamicallyDefineDataIdentifierById()

MsgState DynamicallyDefineDataIdentifierById | ( | out RespDynamicallyDefine | response,
 |  | ushort | dynId,
 |  | SrcDataIdentifier[] | src,
 |  | bool | awaitResponse = true
 | ) |  |

DynamicallyDefineDataIdentifier service, subfunction DefineByIdentifier.

Parameters
response | Service response
dynId | The identifier to define (0xF200-0xF3FF)
src | List of source Identifiers
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ EcuReset()

MsgState EcuReset | ( | out RespReset | response,
 |  | ResetType | sf,
 |  | bool | awaitResponse = true
 | ) |  |

The ECUReset service is used by the client to request a server reset.

This service requests the server to effectively perform a server reset based on the content of the resetType parameter value embedded in the ECUReset request message.The ECUReset positive response message (if required) shall be sent before the reset is executed in the server(s). After a successful server reset the server shall activate the defaultSession.

Parameters
response | Service response
sf | Subfunction type
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ executeService< T >() [1/2]

MsgState executeService< T > | ( | out T | response,
 |  | SID | service,
 |  | byte | subFunction,
 |  | byte[] | data = null,
 |  | bool | awaitResponse = true
 | ) |  |

Generic method to execute an UDS service.

Template Parameters
T The Response type
Parameters
response | Valid Response if awaitResponse is true
service | Service ID
subFunction | Service Subfunction
data | Additional data
awaitResponse | Wait for a response?
Returns
A MsgState
Type Constraints
T : RespSFBase
T : new()

◆ executeService< T >() [2/2]

MsgState executeService< T > | ( | out T | response,
 |  | SID | service,
 |  | byte[] | data = null
 | ) |  |

Generic method to execute an UDS service.

Template Parameters
T The Response type
Parameters
response | Valid Response if return Value is MsgState.Success
service | Service ID
data | Additional data
Returns
A MsgState
Type Constraints
T : RespBase
T : new()

◆ InputOutputControlByIdentifier()

MsgState InputOutputControlByIdentifier | ( | out RespIdentfier | response,
 |  | ushort | identifier
 | ) |  |

InputOutputControlByIdentifier service.

The InputOutputControlByIdentifier service is used by the client to substitute a value for an input signal, internal server function and/or force control to a value for an output(actuator) of an electronic system.

Parameters
response | Service response
identifier | This parameter identifies an server local input signal(s), internal parameter(s) and/or output signal(s).
Returns
A MsgState

◆ LinkControl()

MsgState LinkControl | ( | out RespLinkControl | response,
 |  | LinkControlType | sf,
 |  | byte[] | data = null,
 |  | bool | awaitResponse = true
 | ) |  |

LinkControl service.

The LinkControl service is used to control the communication between the client and the server(s) in order to gain bus bandwidth for diagnostic purposes(e.g., programming). This service optionally applies to those data link layers, which provides the capability to reconfigure its communication parameter(e.g.change the baudrate on CAN or reconfigure a FlexRay cycle design) during a non-default diagnostic session.

Parameters
response | Service response
sf | Subfunction type
data | LinkControlModeIdentifier if t=LinkControlType.VerifyModeTransitionWithFixedParameter, linkRecord[] if t=LinkControlType.VerifyModeTransitionWithSpecificParameter
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ ReadDataByIdentifier()

MsgState ReadDataByIdentifier | ( | out RespData | response,
 |  | ushort[] | identifiers
 | ) |  |

ReadDataByIdentifier service.

The ReadDataByIdentifier service allows the client to request data record values from the server identified by one or more dataIdentifiers.

Parameters
response | Service response
identifiers | The list of identifiers to request
Returns
A MsgState

◆ ReadDataByPeriodicIdentifier()

MsgState ReadDataByPeriodicIdentifier | ( | out RespData | response,
 |  | TransmissionModeType | sf,
 |  | byte[] | identifierIds = null
 | ) |  |

ReadDataByPeriodicIdentifier service.

The ReadDataByPeriodicIdentifier service allows the client to request the periodic transmission of data record values from the server identified by one or more periodicDataIdentifiers.

Parameters
response | Service response
sf | This parameter identifies the transmission rate of the requested periodicDataIdentifiers to be used by the server.
identifierIds | The identifiers to request periodically
Returns
A MsgState

◆ ReadDTCInformation()

MsgState ReadDTCInformation | ( | out RespSFBase | response,
 |  | ReportDTCType | sf,
 |  | uint | groupOfDTC = 0,
 |  | byte | snapshotRecordNumber = 0,
 |  | bool | awaitResponse = true
 | ) |  |

ReadDTCInformation Service.

This service allows a client to read the status of server resident Diagnostic Trouble Code (DTC) information from any server, or group of servers within a vehicle. Unless otherwise required by the particular subfunction, the server shall return all DTC information(e.g., emissions-related and non emissions-related).

Parameters
sf | DTC report type
groupOfDTC | This parameter contains a 3-byte value indicating the group of DTCs (e.g., Powertrain, Body, Chassis) or the particular DTC to be cleared.
snapshotRecordNumber | Only used if t = ReportDTCType.ReportDTCSnapshotIdentification | ReportDTCType.ReportDTCSnapshotRecordByDTCNumber
response | The service response
awaitResponse | Wait for a response?
Returns
A MsgState

◆ ReadDTCInformationCount()

MsgState ReadDTCInformationCount | ( | out RespDTCCount | response,
 |  | ReportDTCType | sf,
 |  | DTCStatusMaskType | statusMask,
 |  | ushort | severityMask = 0
 | ) |  |

ReadDTCInformationCount Service.

This service allows a client to read the status of server resident Diagnostic Trouble Code (DTC) information from any server, or group of servers within a vehicle. Unless otherwise required by the particular subfunction, the server shall return all DTC information(e.g., emissions-related and non emissions-related).

Parameters
response | The service response
sf | The subfunction
statusMask | DTC status mask
severityMask
Returns
A MsgState

◆ ReadDTCInformationRecords()

MsgState ReadDTCInformationRecords | ( | out RespDTCRecords | response,
 |  | ReportDTCType | sf,
 |  | DTCStatusMaskType | statusMask = 0
 | ) |  |

ReadDTCInformation Service.

This service allows a client to read the status of server resident Diagnostic Trouble Code (DTC) information from any server, or group of servers within a vehicle. Unless otherwise required by the particular subfunction, the server shall return all DTC information(e.g., emissions-related and non emissions-related).

Parameters
response | The service response
sf | The subfunction
statusMask | DTC status mask
Returns
A MsgState

◆ ReadMemoryByAddress()

MsgState ReadMemoryByAddress | ( | out RespData | response,
 |  | long | address,
 |  | long | size
 | ) |  |

ReadMemoryByAddress service.

The ReadMemoryByAddress service allows the client to request memory data from the server via provided starting address and size of memory to be read.

Parameters
response | Service response
address | The parameter address is the starting address of server memory from which data is to be retrieved.
size | The parameter memorySize in the ReadMemoryByAddress request message specifies the number of bytes to be read starting at the address specified by address in the server's memory.
Returns
A MsgState

◆ ReadScalingDataByIdentifier()

MsgState ReadScalingDataByIdentifier | ( | out RespData | response,
 |  | ushort | identifier
 | ) |  |

ReadScalingDataByIdentifier service.

The ReadScalingDataByIdentifier service allows the client to request scaling data record information from the server identified by a dataIdentifier.

Parameters
response | Service response
identifier | The identifier to request
Returns
A MsgState

◆ RequestDownload()

MsgState RequestDownload | ( | out RespRequestUpDownload | response,
 |  | long | address,
 |  | long | size,
 |  | byte | adrAndLenFmt = 0,
 |  | byte | compressionMethod = 0,
 |  | byte | encryptionMethod = 0
 | ) |  |

RequestDownload service.

The requestDownload service is used by the client to initiate a data transfer from the client to the server (download).

Parameters
response | The service response
address | The parameter memoryAddress is the starting address of the server memory where the data is to be written to.
size | This parameter shall be used by the server to compare the memory size with the total amount of data transferred during the TransferData service.
adrAndLenFmt Address and Length format byte This parameter is a one byte value with each nibble encoded separately: ⎯ bit 7 - 4: Length(number of bytes) of the memorySize parameter ⎯ bit 3 - 0: Length(number of bytes) of the memoryAddress parameter
  • The default(0) tries to find a suitable value
compressionMethod | Manufacturer specific compression method
encryptionMethod | Manufacturer specific encryption method
Returns
A MsgState

◆ RequestFileTransfer()

MsgState RequestFileTransfer | ( | out RespBase | response,
 |  | ModeOfOperationType | sf,
 |  | string | filePathAndName
 | ) |  |

RequestFileTransfer service.

The requestFileTransfer service is used by the client to initiate a file data transfer from either the client to the server or from the server to the client(download or upload). Additionally, this service has capabilities to retrieve information about the file system.

Parameters
response | The service response
sf | This data-parameter defines the type of operation to be applied to the file or directory indicated in the filePathAndName parameter.
filePathAndName Defines the file system location of the server where the file which shall be added, deleted, replaced or read from depending on the parameter modeOfOperation parameter.
In addition this parameter includes the file name of the file which shall be added, deleted, replaced or read as part of the file path.
If the modeOfOperation parameter equals 0x05 (ReadDir), this parameter indicates the directory to be read. Each byte of this parameter shall be encoded in ASCII format
Returns
A MsgState

◆ RequestTransferExit()

MsgState RequestTransferExit | ( | out RespData | response,
 |  | byte[] | data = null
 | ) |  |

RequestTransferExit service.

This service is used by the client to terminate a data transfer between client and server (upload or download).

Parameters
response | The service response
data | This parameter record contains parameter(s), which are required by the server to support the transfer of data. Format and length of this parameter(s) are vehicle manufacturer specific.
Returns
A MsgState

◆ RequestUpload()

MsgState RequestUpload | ( | out RespRequestUpDownload | response,
 |  | long | address,
 |  | long | size,
 |  | byte | adrAndLenFmt = 0,
 |  | byte | compressionMethod = 0,
 |  | byte | encryptionMethod = 0
 | ) |  |

RequestUpload service.

The RequestUpload service is used by the client to initiate a data transfer from the server to the client (upload).

Parameters
response | The service response
address | The parameter address is the starting address of server memory from which data is to be retrieved.
size | This parameter shall be used by the server to compare the memory size with the total amount of data transferred during the TransferData service.
adrAndLenFmt Address and Length format byte This parameter is a one byte value with each nibble encoded separately: ⎯ bit 7 - 4: Length(number of bytes) of the memorySize parameter ⎯ bit 3 - 0: Length(number of bytes) of the memoryAddress parameter
  • The default(0) tries to find a suitable value
compressionMethod | Manufacturer specific compression method
encryptionMethod | Manufacturer specific encryption method
Returns
A MsgState

◆ ResponseOnEvent()

MsgState ResponseOnEvent | ( | out RespResponseOnEvent | response,
 |  | ResponseOnEventType | sf,
 |  | byte | eventWindowTime,
 |  | byte[] | data = null,
 |  | bool | awaitResponse = true
 | ) |  |

ResponseOnEvent service.

The ResponseOnEvent service requests a server to start or stop transmission of responses on a specified event. This service provides the possibility to automatically execute a diagnostic service in case a specified event occurs in the server. The client specifies the event (including optional event parameters) and the service (including service parameters) to be executed in case the event occurs.See Figure 10 for a brief overview about the client and server behaviour.

Parameters
response | Service response
sf | Subfunction type
eventWindowTime | The parameter eventWindowTime is used to specify a window for the event logic to be active in the server. If the parameter value of eventWindowTime is set to 0x02 then the response time is infinite.In case of an infinite event window and storageState equal to doNotStoreEvent it is recommended to close the event window by a certain signal(e.g.power off). See B.2 for specified eventWindowTimes. A combination of finite event window and storageState equal to storeEvent shall not be used. NOTE This parameter is not applicable to be evaluated by the server in case the eventType is equal to a ROE control sub-function.
data
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ RoutineControl() [1/2]

MsgState RoutineControl | ( | out RespRoutineControl | response,
 |  | RoutineControlType | sf,
 |  | RoutineIdentifierType | routineIdentifier,
 |  | byte[] | routineControlOptionRecord = null,
 |  | bool | awaitResponse = true
 | ) |  |

Routine service.

The RoutineControl service is used by the client to execute a defined sequence of steps and obtain any relevant results.

Parameters
response | Service response
sf | Subfunction type
routineIdentifier | This parameter identifies a server local routine and is out of the range of defined dataIdentifiers
routineControlOptionRecord This parameter record contains either
  • Routine entry option parameters, which optionally specify start conditions of the routine(e.g.timeToRun, startUpVariables, etc.), or
  • Routine exit option parameters which optionally specify stop conditions of the routine.(e.g. timeToExpireBeforeRoutineStops, variables, etc.).
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ RoutineControl() [2/2]

MsgState RoutineControl | ( | out RespRoutineControl | response,
 |  | RoutineControlType | sf,
 |  | ushort | routineIdentifier,
 |  | byte[] | routineControlOptionRecord = null,
 |  | bool | awaitResponse = true
 | ) |  |

Routine service.

The RoutineControl service is used by the client to execute a defined sequence of steps and obtain any relevant results.

Parameters
response | Service response
sf | Subfunction type
routineIdentifier | This parameter identifies a server local routine and is out of the range of defined dataIdentifiers
routineControlOptionRecord This parameter record contains either
  • Routine entry option parameters, which optionally specify start conditions of the routine(e.g.timeToRun, startUpVariables, etc.), or
  • Routine exit option parameters which optionally specify stop conditions of the routine.(e.g. timeToExpireBeforeRoutineStops, variables, etc.).
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ SecuredDataTransmission()

MsgState SecuredDataTransmission | ( | out RespBase | response,
 |  | byte[] | data
 | ) |  |

SecuredDataTransmission service.

The purpose of this service is to transmit data that is protected against attacks from third parties - which could endanger data security.

Parameters
response | Service response
data | Secured service request data record
Returns
A MsgState

◆ SecurityAccessRequestSeed()

MsgState SecurityAccessRequestSeed | ( | out RespSecurityAccess | response,
 |  | byte | securityAccessType,
 |  | byte[] | securityAccessDataRecord = null
 | ) |  |

SecurityAccess Request Seed service.

The client shall request the server to "unlock" by sending the service SecurityAccess ‘requestSeed’ message. The server shall respond by sending a "seed" using the service SecurityAccess ‘requestSeed’ positive response message.

Parameters
response Service response
securityAccessType
securityAccessDataRecord
Returns
A MsgState

◆ SecurityAccessSendKey()

MsgState SecurityAccessSendKey | ( | out RespSecurityAccess | response,
 |  | byte | securityAccessType,
 |  | byte[] | securityKey,
 |  | bool | awaitResponse = true
 | ) |  |

SecurityAccess Send key service.

The client shall request the server to "unlock" by sending the service SecurityAccess ‘requestSeed’ message. The server shall respond by sending a "seed" using the service SecurityAccess ‘requestSeed’ positive response message.

Parameters
response | Service response
securityAccessType
securityKey
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ TesterPresent()

MsgState TesterPresent | ( | out RespSFBase | response,
 |  | bool | awaitResponse = true
 | ) |  |

TesterPresent service.

This service is used to indicate to a server (or servers) that a client is still connected to the vehicle and that certain diagnostic services and/or communication that have been previously activated are to remain active.

Parameters
response | Service response
awaitResponse | false if a response is not expected
Returns
A MsgState

◆ TransferData()

MsgState TransferData | ( | out RespTransferData | response,
 |  | byte | blockSequenceCounter,
 |  | byte[] | dataToDownload = null
 | ) |  |

TransferData service.

Parameters
response | The service response
blockSequenceCounter | The blockSequenceCounter parameter value starts at 0x01 with the first TransferData request that follows the RequestDownload(0x34) or RequestUpload(0x35) service. Its value is incremented by 1 for each subsequent TransferData request.At the value of 0xFF the blockSequenceCounter rolls over and starts at 0x00 with the next TransferData request message.
dataToDownload | For a download, the dataToDownload include the data to be transferred
Returns
A MsgState

◆ WriteDataByIdentifier()

MsgState WriteDataByIdentifier | ( | out RespIdentfier | response,
 |  | ushort | identifier,
 |  | byte[] | data
 | ) |  |

WriteDataByIdentifier service.

The WriteDataByIdentifier service allows the client to write information into the server at an internal location specified by the provided data identifier.

Parameters
response | Service response
identifier | This parameter identifies the server data record that the client is requesting to write to (see C.1 for detailed parameter definition).
data | This parameter provides the data record associated with the dataIdentifier that the client is requesting to write to.
Returns
A MsgState

◆ WriteMemoryByAddress()

MsgState WriteMemoryByAddress | ( | out RespWriteMemoryByAddress | response,
 |  | long | address,
 |  | long | size,
 |  | byte[] | data
 | ) |  |

WriteMemoryByAddress service.

The WriteMemoryByAddress service allows the client to write information into the server at one or more contiguous memory locations.

Parameters
response | Service response
address | The parameter memoryAddress is the starting address of server memory to which data is to be written.
size | The parameter memorySize in the WriteMemoryByAddress request message specifies the number of bytes to be written starting at the address specified by memoryAddress in the server's memory.
data | This parameter provides the data that the client is actually attempting to write into the server memory addresses within the interval {0xMA, (0xMA + 0xMS - 0x01)}
Returns
A MsgState


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • UDSClientBase
UDSClientBase Member List

This is the complete list of members for UDSClientBase, including all inherited members.

AccessTimingSercice(out RespTimingParameter response, TimingParameterAccessType sf, byte[] data, bool awaitResponse=true) | UDSClientBase |
ClearDiagnosticInformation(out RespBase response, uint groupOfDTC=0xffffff) | UDSClientBase |
CmdId | UDSClientBase |
CommunicationControl(out RespSFBase response, CommunicationControlType sf, byte communicationType, ushort nodeId, bool awaitResponse=true) | UDSClientBase |
ControlDTCSetting(out RespControlDTCSetting response, DTCSettingType sf, bool awaitResponse=true) | UDSClientBase |
CurrentDiagSession | UDSClientBase |
DiagnosticSessionControl(out RespSession response, DiagnosticSessionType sf, bool awaitResponse=true) | UDSClientBase |
Dispose() | UDSClientBase | virtual
DoIPClient | UDSClientBase |
DynamicallyClearDataIdentifier(out RespDynamicallyDefine response, ushort dynId, bool awaitResponse=true) | UDSClientBase |
DynamicallyDefineDataIdentifierByAdr(out RespDynamicallyDefine response, ushort dynId, byte srcAdrLen, byte srcSizeLen, SrcDataMemory[] src, bool awaitResponse=true) | UDSClientBase |
DynamicallyDefineDataIdentifierById(out RespDynamicallyDefine response, ushort dynId, SrcDataIdentifier[] src, bool awaitResponse=true) | UDSClientBase |
EcuReset(out RespReset response, ResetType sf, bool awaitResponse=true) | UDSClientBase |
executeService< T >(out T response, SID service, byte subFunction, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
executeService< T >(out T response, SID service, byte[] data=null) | UDSClientBase |
FillByte | UDSClientBase |
InputOutputControlByIdentifier(out RespIdentfier response, ushort identifier) | UDSClientBase |
LinkControl(out RespLinkControl response, LinkControlType sf, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
MaxMsgLen | UDSClientBase |
mLastHandledMessage (defined in UDSClientBase) | UDSClientBase | protected
NEG_RESPONSE_VALUE | UDSClientBase | static
P2Client | UDSClientBase |
P3Client | UDSClientBase |
POS_RESPONSE_MASK | UDSClientBase | static
ReadDataByIdentifier(out RespData response, ushort[] identifiers) | UDSClientBase |
ReadDataByPeriodicIdentifier(out RespData response, TransmissionModeType sf, byte[] identifierIds=null) | UDSClientBase |
ReadDTCInformation(out RespSFBase response, ReportDTCType sf, uint groupOfDTC=0, byte snapshotRecordNumber=0, bool awaitResponse=true) | UDSClientBase |
ReadDTCInformationCount(out RespDTCCount response, ReportDTCType sf, DTCStatusMaskType statusMask, ushort severityMask=0) | UDSClientBase |
ReadDTCInformationRecords(out RespDTCRecords response, ReportDTCType sf, DTCStatusMaskType statusMask=0) | UDSClientBase |
ReadMemoryByAddress(out RespData response, long address, long size) | UDSClientBase |
ReadScalingDataByIdentifier(out RespData response, ushort identifier) | UDSClientBase |
RequestDownload(out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0) | UDSClientBase |
RequestFileTransfer(out RespBase response, ModeOfOperationType sf, string filePathAndName) | UDSClientBase |
RequestTransferExit(out RespData response, byte[] data=null) | UDSClientBase |
RequestUpload(out RespRequestUpDownload response, long address, long size, byte adrAndLenFmt=0, byte compressionMethod=0, byte encryptionMethod=0) | UDSClientBase |
ResponseOnEvent(out RespResponseOnEvent response, ResponseOnEventType sf, byte eventWindowTime, byte[] data=null, bool awaitResponse=true) | UDSClientBase |
RoutineControl(out RespRoutineControl response, RoutineControlType sf, ushort routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true) | UDSClientBase |
RoutineControl(out RespRoutineControl response, RoutineControlType sf, RoutineIdentifierType routineIdentifier, byte[] routineControlOptionRecord=null, bool awaitResponse=true) | UDSClientBase |
RspId | UDSClientBase |
SecuredDataTransmission(out RespBase response, byte[] data) | UDSClientBase |
SecurityAccessRequestSeed(out RespSecurityAccess response, byte securityAccessType, byte[] securityAccessDataRecord=null) | UDSClientBase |
SecurityAccessSendKey(out RespSecurityAccess response, byte securityAccessType, byte[] securityKey, bool awaitResponse=true) | UDSClientBase |
TesterPresent(out RespSFBase response, bool awaitResponse=true) | UDSClientBase |
ToString() (defined in UDSClientBase) | UDSClientBase |
TransferData(out RespTransferData response, byte blockSequenceCounter, byte[] dataToDownload=null) | UDSClientBase |
UDSClientBase(ICANProvider canProvider, uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff) | UDSClientBase |
UDSClientBase(DoIPClient doIPClient, uint p2Client=50, uint p3Client=50) | UDSClientBase |
UseCANFD | UDSClientBase |
UseFillByte | UDSClientBase |
WriteDataByIdentifier(out RespIdentfier response, ushort identifier, byte[] data) | UDSClientBase |
WriteMemoryByAddress(out RespWriteMemoryByAddress response, long address, long size, byte[] data) | UDSClientBase |


ASAP2Library interface: UDSFrame Class Reference

  • Diagnose
  • Comm
  • UDS
  • UDSFrame
Public Member Functions | Properties | List of all members
UDSFrame Class Reference

Represents an UDS frame. More...

Public Member Functions

UDSFrame (uint canId, byte[] data, bool isMasterFrame)
Initialises a new instance of UDSFrame with the specified parameters. More...
override string | toClipboard ()
Builds a tab delimited representation of the frame. More...
override string | toCSV ()
Builds a CSV representation of the frame. More...
- Public Member Functions inherited from Frame
Frame (bool isMasterFrame)
Creates a new instance of FrameQueue. More...
string | getDataASCIIStr (char notAllowedChar)
Gets the frame's data in ASCII representation. More...
string | getDataStr ()
Gets the frame's data. More...
char | getRWIndicator ()
Gets the sender/responder indicator. More...
string | getTimeStr (double offset=0.0)
Gets the timestamp string. More...

Properties

string | Address [get]
The address sent or received from.
uint | ID [get]
Gets the CAN IDa sent or received from.
bool | IsError [get]
Indicates if the frame is an error response frame.
uint | Len [get]
The Length value of the frame
SID | Service [get]
Gets the Service ID.
string | ServiceStr [get]
Gets the Service ID as string representation. More...
byte | Subfunction [get]
Gets the Subfunction. More...
string? | SubfunctionStr [get]
Gets the Subfunction as string value.
- Properties inherited from Frame
TimeSpan | Elapsed [get]
The time elapsed since the start. More...
bool | IsMasterFrame [get]
Indicates if the frame is sent by the master or sent by the slave.

Additional Inherited Members

- Public Attributes inherited from Frame
byte[] Data
The data bytes of the frame.

Detailed Description

Represents an UDS frame.

Constructor & Destructor Documentation

◆ UDSFrame()

UDSFrame | ( | uint | canId,
 |  | byte[] | data,
 |  | bool | isMasterFrame
 | ) |  |

Initialises a new instance of UDSFrame with the specified parameters.

Parameters
canId | CAN Id
data | CAN frame data
isMasterFrame | true if the frame is sent by the master, else false

Member Function Documentation

◆ toClipboard()

override string toClipboard ( )
virtual

Builds a tab delimited representation of the frame.

Returns
the string representation

Implements Frame.

◆ toCSV()

override string toCSV ( )
virtual

Builds a CSV representation of the frame.

Returns
the string representation

Implements Frame.

Property Documentation

◆ ServiceStr

string ServiceStr
get

Gets the Service ID as string representation.

For negative responses the negative response code is added.

◆ Subfunction

byte Subfunction
get

Gets the Subfunction.

If the frame is a negative response or the Sevice ID doesn't provide a subfunction the returned value is byte.MaxValue.


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • UDSFrame
UDSFrame Member List

This is the complete list of members for UDSFrame, including all inherited members.

Address | UDSFrame |
Data | Frame |
Elapsed | Frame |
Frame(bool isMasterFrame) | Frame |
getDataASCIIStr(char notAllowedChar) | Frame |
getDataStr() | Frame |
getRWIndicator() | Frame |
getTimeStr(double offset=0.0) | Frame |
ID | UDSFrame |
IsError | UDSFrame |
IsMasterFrame | Frame |
Len | UDSFrame |
Service | UDSFrame |
ServiceStr | UDSFrame |
Subfunction | UDSFrame |
SubfunctionStr | UDSFrame |
toClipboard() | UDSFrame | virtual
toCSV() | UDSFrame | virtual
UDSFrame(uint canId, byte[] data, bool isMasterFrame) | UDSFrame |


ASAP2Library interface: UDSFrameQueue Class Reference

  • Diagnose
  • Comm
  • UDS
  • UDSFrameQueue
Public Member Functions | Properties | List of all members
UDSFrameQueue Class Reference

Queue implementation to store UDSFrame's. More...

Public Member Functions

void | enqueueFrame (UDSFrame frame)
Adds a sent or received frame to the frame queue. More...
- Public Member Functions inherited from FrameQueue< UDSFrame >
virtual void | clear ()
Clears the frame queue.
virtual void | Dispose ()
Closes am opened log.
T[] | getFrames (out int cntFrames)
Gets all available frames (in order of occurence). More...
T[] | getUnreadFrames (out int cntFrames)
Gets all available unread frames (in order of occurence). More...
void | updateFileLogSetting (bool logToFile, string logFilePath)
Starts or stops logging of frames to file. More...

Properties

static UDSFrameQueue?? | Instance [get]
Returns the singleton instance of the queue.
override string | LogFileCSVHeader [get]
override string | LogFileName [get]
- Properties inherited from FrameQueue< UDSFrame >
bool | IsWritingToFile [get]
Indicates if writing to file is enabled.
abstract string | LogFileCSVHeader [get]
Gets the constant CSV header for the CSV log
abstract string | LogFileName [get]
Get constant Filename without path

Additional Inherited Members

- Protected Member Functions inherited from FrameQueue< UDSFrame >
void | addFrame (T frame, ushort channel=1)
Sets the time elapsed to the frame, logs if the file log is activated, removes frames preventing memory overruns. More...
- Protected Attributes inherited from FrameQueue< UDSFrame >
readonly List< T > | mFrames
- Events inherited from FrameQueue< UDSFrame >
EventHandler< FrameEventArgs< T > > | FrameEnqueued
Called if a frame is enqueued.

Detailed Description

Queue implementation to store UDSFrame's.

Member Function Documentation

◆ enqueueFrame()

void enqueueFrame ( UDSFrame frame )

Adds a sent or received frame to the frame queue.

This method gets called from various receive threads, therefore access to members is synchronized.

The frames are filtered according the global user settings.

Parameters
frame The frame to add


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • UDS
  • UDSFrameQueue
UDSFrameQueue Member List

This is the complete list of members for UDSFrameQueue, including all inherited members.

addFrame(T frame, ushort channel=1) | FrameQueue< UDSFrame > | protected
clear() | FrameQueue< UDSFrame > | virtual
Dispose() | FrameQueue< UDSFrame > | virtual
enqueueFrame(UDSFrame frame) | UDSFrameQueue |
FrameEnqueued | FrameQueue< UDSFrame > |
getFrames(out int cntFrames) | FrameQueue< UDSFrame > |
getUnreadFrames(out int cntFrames) | FrameQueue< UDSFrame > |
Instance | UDSFrameQueue | static
IsWritingToFile | FrameQueue< UDSFrame > |
LogFileCSVHeader (defined in UDSFrameQueue) | UDSFrameQueue |
LogFileName (defined in UDSFrameQueue) | UDSFrameQueue |
updateFileLogSetting(bool logToFile, string logFilePath) | FrameQueue< UDSFrame > |


ASAP2Library interface: IsoTp Class Reference

  • Diagnose
  • Comm
  • IsoTp
Public Member Functions | Static Public Attributes | Properties | List of all members
IsoTp Class Reference

Implements the ISO 15765-2 (IsoTp) protocol. More...

Public Member Functions

IsoTp (uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff)
Initialises a new instance of IsoTp (CAN type). More...
void | Dispose ()
bool | onReceived (CANFrame frame)
Called with received frames. More...
MsgState | sendRequest (ICANProvider canProvider, List< byte > reqData, List< byte > resData=null, bool awaitResponse=true)
Gets or sets the block size More...

Static Public Attributes

const byte NO_RESPONSE_MASK = 0x80

Properties

uint | CmdId [getset]
Gets or sets the CAN command ID (only valid with Type!=IsoTpType.FlexRay).
byte | FillByte [getset]
Gets or sets the fill byte value
long | MaxMsgLen [get]
Maximum message length according the Type.
uint | P2Client [getset]
Gets or sets the P2 timing
uint | P3Client [getset]
Gets or sets the P3 timing
uint | RspId [getset]
Gets or sets the CAN response ID (only valid with Type!=IsoTpType.FlexRay).
ushort | SA [getset]
Gets or sets the Flexray source address (only valid with Type=IsoTpType.FlexRay).
ushort | TA [getset]
Gets or sets the Flexray target address (only valid with Type=IsoTpType.FlexRay).
IsoTpType | Type [get]
Gets or the IsoTp type
bool | UseFillByte [getset]
Gets or sets the fill byte usage

Detailed Description

Implements the ISO 15765-2 (IsoTp) protocol.

  • Represents the UDS/KWP transport layer.
  • Extended to use with CAN FD.

Constructor & Destructor Documentation

◆ IsoTp()

IsoTp | ( | uint | cmdId,
 |  | uint | rspId,
 |  | bool | useCANFD = false,
 |  | uint | p2Client = 50,
 |  | uint | p3Client = 50,
 |  | bool | useFillByte = true,
 |  | byte | fillByte = 0xff
 | ) |  |

Initialises a new instance of IsoTp (CAN type).

Parameters
cmdId | request CAN Id
rspId | response CAN Id
useCANFD | true, if the protocol should use CAN FD frames (extended length).
p2Client | Time between end of tester request and start of ECU response
p3Client | >Time between end of ECU response and start of new tester request
useFillByte | true if resulting frames should always filled up to the frame size
fillByte | frame fillbyte value to use

Member Function Documentation

◆ onReceived()

bool onReceived ( CANFrame frame )

Called with received frames.

Parameters
frame
Returns
true if handled

◆ sendRequest()

MsgState sendRequest | ( | ICANProvider | canProvider,
 |  | List< byte > | reqData,
 |  | List< byte > | resData = null,
 |  | bool | awaitResponse = true
 | ) |  |

Gets or sets the block size

Send a synchronous request to the ECU and wait for a response (if requested).

Parameters
canProvider | The CAN provider instance to use
reqData | The request data, if null, the receive state will be entered immediately.
resData | Must be non-null if a response is awaited (filled with the response if return value is MsgState.Success)
awaitResponse | false if a positive response is not expected
Returns
A MsgState value >= MsgState.Succsess


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • IsoTp
IsoTp Member List

This is the complete list of members for IsoTp, including all inherited members.

CmdId | IsoTp |
Dispose() (defined in IsoTp) | IsoTp |
FillByte | IsoTp |
IsoTp(uint cmdId, uint rspId, bool useCANFD=false, uint p2Client=50, uint p3Client=50, bool useFillByte=true, byte fillByte=0xff) | IsoTp |
MaxMsgLen | IsoTp |
NO_RESPONSE_MASK (defined in IsoTp) | IsoTp | static
onReceived(CANFrame frame) | IsoTp |
P2Client | IsoTp |
P3Client | IsoTp |
RspId | IsoTp |
SA | IsoTp |
sendRequest(ICANProvider canProvider, List< byte > reqData, List< byte > resData=null, bool awaitResponse=true) | IsoTp |
TA | IsoTp |
Type | IsoTp |
UseFillByte | IsoTp |


ASAP2Library interface: IsoTpFSM Class Reference

  • Diagnose
  • Comm
  • IsoTpFSM
Public Member Functions | Public Attributes | List of all members
IsoTpFSM Class Reference

Represents the state machine to process an IsoTp message. More...

Public Member Functions

IsoTpFSM (List< byte > dataToSend, bool awaitResponse, byte frameSize, byte blockSize, byte stMin)
Initialises a new instance with the specified parameters. More...
MsgState | onReceived (byte[] data)
Processes received CAN/CANFD messages. More...
MsgState | onReceived (CANFrame frame)
Processes received CAN messages. More...
MsgState | onReceivedFR (byte[] data)
Receive method for FlexRay. More...

Public Attributes

int RequestSTMin
st_min for multi request in micro seconds

Detailed Description

Represents the state machine to process an IsoTp message.

Constructor & Destructor Documentation

◆ IsoTpFSM()

IsoTpFSM | ( | List< byte > | dataToSend,
 |  | bool | awaitResponse,
 |  | byte | frameSize,
 |  | byte | blockSize,
 |  | byte | stMin
 | ) |  |

Initialises a new instance with the specified parameters.

Parameters
dataToSend | The request data to send
awaitResponse | true if a response should be awaited
frameSize | frame size for request and response frames (e.g. 8 for CAN 2.0 frames, 64 for CANFD frames)
blockSize | block size to use (0 for a disabled flow control)
stMin | stMin to use

Member Function Documentation

◆ onReceived() [1/2]

MsgState onReceived ( byte[] data )

Processes received CAN/CANFD messages.

Parameters
data received data
Returns
New state of the FSM

◆ onReceived() [2/2]

MsgState onReceived ( CANFrame frame )

Processes received CAN messages.

Parameters
frame the received CAN frame
Returns
New state of the FSM

◆ onReceivedFR()

MsgState onReceivedFR ( byte[] data )

Receive method for FlexRay.

Use this method for receiving FleyRay messages.

Parameters
data
Returns
New state of the FSM


ASAP2Library interface: Member List

  • Diagnose
  • Comm
  • IsoTpFSM
IsoTpFSM Member List

This is the complete list of members for IsoTpFSM, including all inherited members.

IsoTpFSM(List< byte > dataToSend, bool awaitResponse, byte frameSize, byte blockSize, byte stMin) | IsoTpFSM
onReceived(CANFrame frame) | IsoTpFSM
onReceived(byte[] data) | IsoTpFSM
onReceivedFR(byte[] data) | IsoTpFSM
RequestSTMin | IsoTpFSM


ASAP2Library interface: jnsoft.Diagnose.ODX Namespace Reference

  • Diagnose
  • ODX
Classes | Enumerations
jnsoft.Diagnose.ODX Namespace Reference

All the ODX (Open Diagnostic Data Format) stuff. More...

Classes

class | AdminData
Administrative data definition. More...
class | Audience
Defines user class types. More...
class | BaseDocInfoContainer
Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash. More...
class | BaseVariant
Diagnostic base variant definition. More...
class | BaseVariantRef
Reference to base variant used in PARENT-REFS. More...
class | Case
Multiplexer case. More...
class | ChartContainer
Chart container. More...
class | CompanyData
Definition of Company data. More...
class | CompanySpecificInfo
Company specific info definition. More...
class | ComParam
Communication parameter definition. More...
class | ComParamBase
Communication paramter base class. More...
class | COMParamRef
Communication parameters. More...
class | ComParamSpec
Communication parameter specification definition. More...
class | ComParamSubset
Communication parameter subset definition. More...
class | ComplexComParam
Complex communication parameter definition. More...
class | CompuInternalToPhys
Computation from a raw value to a physical value. More...
class | CompuMethod
Compu method base definition. More...
class | CompuRationalCoeffs
Compu method rational coefficients. More...
class | CompuScale
Compu scale definition. More...
class | DataBlock
Data block definition. More...
struct | DataFile
Data file definition. More...
struct | DataFormat
Data format definition. More...
class | DataObjectProp
Data object property specification. More...
class | DefaultCase
Multiplexer default case definition. More...
class | DetermineNumberOfItems
Part of dynamic length field part. More...
class | DiagCodedTypeBase
Base class for diagnose coded types. More...
class | DiagCodedTypeLL
Leading length diagnose coded type. More...
class | DiagCodedTypeMinMax
Minimum-Maximum diagnose coded type. More...
class | DiagCodedTypePL
Param length diagnose coded type. More...
class | DiagCodedTypeStd
Standard diagnose coded type. More...
class | DiagDataDictionarySpec
Diagnostic dictionary specification. More...
class | DiagDataDictSpec
Non serialized class used internally to hold DiagDataDictionarySpec instances. More...
class | DiagLayerContainer
Diagnostic layer container. More...
class | DiagService
Diagnostic service definition. More...
class | DocRevision
Definition of a document revision. More...
class | Dtc
Diagnostic trouble code. More...
class | DtcDop
Diagnostic trouble codes specification. More...
class | DynamicLengthField
Dynamic length field definition. More...
class | EcuMem
ECU memory definition. More...
class | EcuMemConnector
ECU memory connector definition. More...
class | EcuSharedData
ECU shared data definition. More...
class | EcuSharedDataRef
Reference to ECU shared data used in used in PARENT-REFS. More...
class | EcuVariant
ECU variant definition. More...
class | EcuVariantPatternContainer
ECU variant pattern container. More...
class | EndOfPDUField
End of PDU filed definition. More...
class | EnvDataDesc
Environment data description. More...
class | EnvDataParamContainer
Environment data parameter container. More...
struct | Filter
Filter definition. More...
class | Flash
Flash data definition. More...
class | FlashDataExtern
Flash data definition (External). More...
class | FlashDataIntern
Flash data definition (Internal). More...
class | FunctClass
ODX function class element. More...
class | FunctionalGroup
Functional group definition. More...
class | FunctionalGroupRef
Reference to functional group used in PARENT-REFS. More...
class | IcEcuProxy
Info Component ECU-PROXY. More...
class | IcModelYear
Info Component MODEL-YEAR. More...
class | IcOEM
Info Component OEM. More...
class | IcVehicleModel
Info Component VEHICLE-MODEL. More...
class | IcVehicleType
Info Component VEHICLE-TYPE. More...
class | Id
Id tagged ODX element. More...
class | Ident
Ident definition. More...
class | IdentDesc
Ident descriptor definition. More...
class | IdentifierRecord
Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22) More...
interface | IDescription
Used to indicate description supporting ODX nodes. More...
class | IdRef
Id Reference. More...
interface | IId
Interface used to initialize ID dictionary while loading the ODX file. More...
class | InternalConstr
Internal constraints definition. More...
class | LimitBase
Base class for Limit containing scales. More...
class | MatchingParameterContainer
Matching parameter container. More...
class | Mem
Memory definition. More...
class | MemberLogicalLink
Member logical link type definition. More...
class | Modification
Definition of a document revision modification. More...
class | Mux
Multiplexer definition. More...
class | NamedDescId
ODX base class for named elements with description. More...
class | NamedId
ODX base class for named elements. More...
class | NonCompliantException
Exception class for non ODX compliant files. More...
struct | NotInheritedDiagComm
Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant. More...
class | ODXFile
Open Diagnostic eXchange format (ODX) reader/writer. More...
class | ODXRoot
ODX root. More...
class | ParamContainer
Paramter container definition. More...
class | ParBaseDef
Parameter base definitiob. More...
class | ParCodedConst
Coded parameter definition. More...
class | ParDynamic
Paramneter with length reference. More...
class | ParIdBase
Base class for ID referenced parameters. More...
class | ParLength
Paramneter with length reference. More...
class | ParMatchRequestParam
Matching request parameter. More...
class | ParNrcConst
Used tp represent Negative response code constants. More...
class | ParPhysConst
Physical constant parameter definition. More...
class | ParReserved
Reserved Parameter definition. More...
class | ParSystem
Parameter system definition. More...
class | ParTableEntry
Parameter table entry definition. More...
class | ParTableKey
Parameter table key definition. More...
class | ParTableStruct
Parameter table entry definition. More...
class | ParValue
Parameter value definition. More...
class | PDXIndex
PDX index.xml file. More...
class | PhysicalDimension
Defines the physical dimension of a unit. More...
struct | PhysicalType
Defines the physical type in a data object property specification. More...
class | PhysMem
Physical memory definition. More...
class | PhysSegmentAddr
Physical memory segment definition with End Address. More...
class | PhysSegmentBase
Base physical memory segment definition. More...
class | PhysSegmentSize
Physical memory segment definition with Size. More...
class | PkysicalVehicleLink
Physical vehicle link defintition. More...
class | Protocol
Diagnostic Protocol definition. More...
class | ProtocolRef
Reference to a diagnostic protocol used in PARENT-REFS. More...
class | ProtStack
Protocol stack definition. More...
struct | RelatedDoc
Related document definition. More...
class | ScaleConstr
Scale constraints definition. More...
class | Sdg
SD group definition. More...
struct | Security
Security settings. More...
class | Segment
Data segment definition. More...
class | Session
ECU Session definition. More...
class | SessionDesc
Session descriptor definition. More...
class | SnRef
SHORT-NAME reference definition. More...
class | StateTransitionContainer
State transition container. More...
class | StaticField
Structure definition. More...
class | Structure
Structure definition. More...
class | SwitchKey
Multiplexer switch key definition. More...
class | Table
Table definition. More...
class | TableRow
Tablerow definition. More...
class | TeamMember
Definition of a Team member. More...
struct | TypeValueElement
XML element with a TYPE Attribute and a Value text. More...
class | Unit
ODX Unit element. More...
class | UnitSpec
Specification of supported units. More...
class | UnitSpecs
Non serialized class used internally to hold a UnitSpec instance. More...
class | VehicleConnector
Vehicle connector definition. More...
class | VehicleConnectorPin
Vehicle connector pin definition. More...
class | VehicleInformation
Vehicle information. More...
class | VehicleInfoSpec
Vehicle information specification. More...
struct | XDoc
External document definition. More...

Enumerations

enum | AddressingType { PHYSICAL , FUNCTIONAL , FUNCTIONAL_OR_PHYSICAL }
Possible types of addressing. More...
enum BaseDataType {
A_INT8 , A_UINT8 , A_INT16 , A_UINT16 ,
A_INT32 , A_UINT32 , A_FLOAT32 , A_FLOAT64 ,
A_ASCIISTRING , A_UNICODE2STRING , A_UTF8STRING , A_BYTEFIELD
}
Possible ODX base data types. More...
enum CMCategory {
IDENTICAL , TEXTTABLE , LINEAR , SCALE_LINEAR ,
RAT_FUNC , SCALE_RAT_FUNC , TAB_INTP , COMPUCODE
}
Possible CompuMethod types. More...
enum | DataBlockType { UNKNOWN , BOOT , CODE , DATA }
Possible data block types. More...
enum | DataFormatType { BINARY , INTEL_HEX , MOTOROLA_S }
Possible data format types. More...
enum PinType {
HI , LOW , K , L ,
TX , RX , PLUS , MINUS ,
SINGLE
}
Pin type definitions. More...
enum | RowFragment { KEY , STRUCT , KEY_AND_STRUCT }
Possible values for ROW fragemnet.
enum SysParmType {
TIMEZONE , YEAR , MONTH , DAY ,
HOUR , MINUTE , SECOND , TESTERID ,
USERID , CENTURY , WEEK , TIMESTAMP
}
Possible SYS Params. More...
enum | TerminationType { ZERO , END_OF_PDU , HEX_FF = 0xff }
Possible termination types. More...
enum | ValidType { VALID , NOT_VALID , NOT_DEFINED , NOT_AVAILABLE }
Possible Valid types. More...

Detailed Description

All the ODX (Open Diagnostic Data Format) stuff.

Basic access to an ODX file is provided by the ODXFile class. It provides methods and properties to open, save and access the ODX model.

Getting started with reading and writing an ODX File (code example):

using jnsoft.ODX;
void loadAndSaveFile(string odxFilename)
{
// Open ODX file
var odxFile = ODXFile.open(odxFilename);
Console.WriteLine("Opened ODX file {0} version: {1}", odxFile.SourceFile, odxFile.MODEL_VERSION);
// change a value
odxFile.ODX.MODEL_VERSION = "2.0.2";
// save the changed ODX file
odxFile.save(odxFilename+".out.odx");
}
jnsoft.Diagnose.ODX.ODXFile
Open Diagnostic eXchange format (ODX) reader/writer.
Definition: ODXFile.cs:75
jnsoft.Diagnose.ODX.ODXFile.open
static ODXFile open(string path)
Opens a ODX file and returns a ODXFile instance.
Definition: ODXFile.cs:427
jnsoft.Diagnose.ODX.ODXFile.ODX
readonly ODXRoot ODX
Gets the ODX root node.
Definition: ODXFile.cs:101
jnsoft
Definition: ASAP2.cs:53

Enumeration Type Documentation

◆ AddressingType

enum AddressingType

Possible types of addressing.

Enumerator
PHYSICAL | Physical addressing allowed
FUNCTIONAL | Functional addressing allowed
FUNCTIONAL_OR_PHYSICAL | Physical or Functional addressing allowed

◆ BaseDataType

enum BaseDataType

Possible ODX base data types.

Enumerator
A_INT8 | 8 Bit integer, signed
A_UINT8 | 8 Bit integer, unsigned
A_INT16 | 16 Bit integer, signed
A_UINT16 | 16 Bit integer, unsigned
A_INT32 | 32 Bit integer, signed
A_UINT32 | 32 Bit integer, unsigned
A_FLOAT32 | 32 Bit float
A_FLOAT64 | 64 Bit float
A_ASCIISTRING | ASCII string
A_UNICODE2STRING | Unicode string
A_UTF8STRING | Unicode string
A_BYTEFIELD | Bytefield

◆ CMCategory

enum CMCategory

Possible CompuMethod types.

Enumerator
IDENTICAL | no compu method, raw value = physical value
TEXTTABLE | text table
LINEAR | linear
SCALE_LINEAR | scaled linear
RAT_FUNC | rational function
SCALE_RAT_FUNC | scaled rational function
TAB_INTP | curve interpolation
COMPUCODE | scaled linear

◆ DataBlockType

enum DataBlockType

Possible data block types.

Enumerator
UNKNOWN | Proprietary block type
BOOT | Boot block data
CODE | code segment data block
DATA | data segment data block

◆ DataFormatType

enum DataFormatType

Possible data format types.

Enumerator
BINARY | Binary data format
INTEL_HEX | Intel HEX data format
MOTOROLA_S | Motorola-S record data format

◆ PinType

enum PinType

Pin type definitions.

Enumerator
HI | High line/wire of a two wired physical data link
LOW | Low line/wire of a two wired physical data link
K | K line/wire of a ISO_9141_2_UART or ISO_14230_1_UART physical data link
L | L line/wire of a ISO_9141_2_UART or ISO_14230_1_UART physical data link
TX | High line/wire of a two wired physical data link
RX | High line/wire of a two wired physical data link
PLUS | "Positive(+) line/wire of a two wired physical data link
MINUS | Negative(-) line/wire of a two wired physical data link
SINGLE | Single line/wire of a one wired physical data link (e.g. GMW_3089_SWCAN)

◆ SysParmType

enum SysParmType

Possible SYS Params.

Enumerator
TIMEZONE | Count of minutes to UTC
YEAR | YYYY
MONTH | MM
DAY | DD 01 (first day of month)
HOUR | hh 22 (10 pm)
MINUTE | mm 00 (full hour)
SECOND | ss 00 (full minute)
TESTERID |
USERID |
CENTURY | CC 20 (in year 2004)
WEEK |
TIMESTAMP | The number of elapsed milliseconds since 1970-01-01 00:00:00 GMT coded as 64bit-Integer (most significant byte first)

◆ TerminationType

enum TerminationType

Possible termination types.

Enumerator
ZERO | The termination is done by a Byte with the value 00hex.
END_OF_PDU | The termination is done by the end of the PDU.
HEX_FF | The termination is done by a Byte with the value FFhex.

◆ ValidType

enum ValidType

Possible Valid types.

Enumerator
VALID | Valid area. Current value is within a valid range and can be presented to user.
NOT_VALID | Invalid area. The ECU cannot process the requested data.
NOT_DEFINED | Indicates an area, which is marked in a specification (e.g. as reserved). Shall usually not be set by the ECU but is used by a tester to verify correct ECU behaviour. Also prevents usage of areas during editing process.
NOT_AVAILABLE | Currently invalid area. The value usually is presented by the ECU but can currently not be performed due to e.g. initialisation or temporary problems. This behaviour appears during runtime and cannot be handled while data is edited.


ASAP2Library interface: jnsoft.Diagnose.ODX.Examples Namespace Reference

  • Diagnose
  • ODX
  • Examples
Classes
jnsoft.Diagnose.ODX.Examples Namespace Reference

Classes

class Program
Sample console application. More...


ASAP2Library interface: Program Class Reference

  • Diagnose
  • ODX
  • Examples
  • Program
List of all members
Program Class Reference

Sample console application. More...

Detailed Description

Sample console application.

Demonstrates parsing, changing, (re)writing an ODX file and printing some information from the object model.

Usage: ASAP2ODXExample ODXFile.odx


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: AdminData Class Reference

  • Diagnose
  • ODX
  • AdminData
Properties | List of all members
AdminData Class Reference

Administrative data definition. More...

Properties

List< DocRevision > | DOC_REVISIONS [getset]
string | LANGUAGE [getset]

Detailed Description

Administrative data definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • AdminData
AdminData Member List

This is the complete list of members for AdminData, including all inherited members.

AdminData() (defined in AdminData) | AdminData
DOC_REVISIONS (defined in AdminData) | AdminData
LANGUAGE (defined in AdminData) | AdminData


ASAP2Library interface: Audience Class Reference

  • Diagnose
  • ODX
  • Audience
Properties | List of all members
Audience Class Reference

Defines user class types. More...

Properties

bool | IS_AFTERMARKET = true [getset]
bool | IS_AFTERSALES = true [getset]
bool | IS_DEVELOPMENT = true [getset]
bool | IS_MANUFACTURING = true [getset]
bool | IS_SUPPLIER = true [getset]

Detailed Description

Defines user class types.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Audience
Audience Member List

This is the complete list of members for Audience, including all inherited members.

IS_AFTERMARKET (defined in Audience) | Audience
IS_AFTERSALES (defined in Audience) | Audience
IS_DEVELOPMENT (defined in Audience) | Audience
IS_MANUFACTURING (defined in Audience) | Audience
IS_SUPPLIER (defined in Audience) | Audience


ASAP2Library interface: BaseDocInfoContainer Class Reference

  • Diagnose
  • ODX
  • BaseDocInfoContainer
Properties | List of all members
BaseDocInfoContainer Class Reference

Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash. More...

Properties

AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • BaseDocInfoContainer
BaseDocInfoContainer Member List

This is the complete list of members for BaseDocInfoContainer, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: BaseVariant Class Reference

  • Diagnose
  • ODX
  • BaseVariant
Public Member Functions | Properties | List of all members
BaseVariant Class Reference

Diagnostic base variant definition. More...

Public Member Functions

override void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from EcuVariant
Protocol[] getSupportedProtocols ()
Gets the supported diagnose communication protocols. More...
- Public Member Functions inherited from EcuSharedData
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Properties

override BaseVariant | Parent [get]
List< Protocol > | Protocols [getset]
Supported protocols.
- Properties inherited from EcuVariant
List< EcuVariantPatternContainer > | ECU_VARIANT_PATTERNS [getset]
virtual BaseVariant | Parent [get]
List< IdRef > | PARENT_REFS [getset]
- Properties inherited from EcuSharedData
List< COMParamRef > | COMPARAM_REFS [getset]
List< COMParamRef > | ComparamRefs = new List<COMParamRef>() [get]
List< DiagService > | DIAG_COMMS [getset]
DiagDataDictionarySpec | DIAG_DATA_DICTIONARY_SPEC [getset]
DiagDataDictSpec | DiagDataDictionarySpec = new DiagDataDictSpec() [get]
List< DiagService > | DiagServices = new List<DiagService>() [get]
List< FunctClass > | FUNCT_CLASSS [getset]
List< FunctClass > | FunctClasses = new List<FunctClass>() [get]
List< ParamContainer > | GLOBAL_NEG_RESPONSES [getset]
List< IdRef > | IMPORT_REFS [getset]
List< ParamContainer > | NEG_RESPONSES [getset]
List< ParamContainer > | NegResponses = new List<ParamContainer>() [get]
List< ParamContainer > | POS_RESPONSES [getset]
List< ParamContainer > | PosResponses = new List<ParamContainer>() [get]
List< ParamContainer > | Requests = new List<ParamContainer>() [get]
List< ParamContainer > | REQUESTS_ [getset]
List< ChartContainer > | STATE_CHARTS [getset]
List< ChartContainer > | StateCharts = new List<ChartContainer>() [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from EcuVariant
readonly List< EcuVariantPatternContainer > | EcuVariantPatterns = new List<EcuVariantPatternContainer>()
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Diagnostic base variant definition.

Member Function Documentation

◆ buildRefs()

override void buildRefs ( ODXRoot odx )
virtual

Reimplemented from EcuVariant.

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from EcuVariant.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • BaseVariant
BaseVariant Member List

This is the complete list of members for BaseVariant, including all inherited members.

BaseVariant() (defined in BaseVariant) | BaseVariant |
buildRefs(ODXRoot odx) (defined in BaseVariant) | BaseVariant | virtual
COMPARAM_REFS (defined in EcuSharedData) | EcuSharedData |
ComparamRefs (defined in EcuSharedData) | EcuSharedData |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_COMMS (defined in EcuSharedData) | EcuSharedData |
DIAG_DATA_DICTIONARY_SPEC (defined in EcuSharedData) | EcuSharedData |
DiagDataDictionarySpec (defined in EcuSharedData) | EcuSharedData |
DiagServices (defined in EcuSharedData) | EcuSharedData |
ECU_VARIANT_PATTERNS (defined in EcuVariant) | EcuVariant |
EcuVariant() (defined in EcuVariant) | EcuVariant |
EcuVariantPatterns (defined in EcuVariant) | EcuVariant |
FUNCT_CLASSS (defined in EcuSharedData) | EcuSharedData |
FunctClasses (defined in EcuSharedData) | EcuSharedData |
getSupportedProtocols() | EcuVariant |
GLOBAL_NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
ID (defined in Id) | Id |
IMPORT_REFS (defined in EcuSharedData) | EcuSharedData |
initialize(ODXRoot odx) | BaseVariant | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
NegResponses (defined in EcuSharedData) | EcuSharedData |
Odx | Id |
Parent (defined in BaseVariant) | BaseVariant |
PARENT_REFS (defined in EcuVariant) | EcuVariant |
POS_RESPONSES (defined in EcuSharedData) | EcuSharedData |
PosResponses (defined in EcuSharedData) | EcuSharedData |
Protocols | BaseVariant |
Requests (defined in EcuSharedData) | EcuSharedData |
REQUESTS_ (defined in EcuSharedData) | EcuSharedData |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_CHARTS (defined in EcuSharedData) | EcuSharedData |
StateCharts (defined in EcuSharedData) | EcuSharedData |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: BaseVariantRef Class Reference

  • Diagnose
  • ODX
  • BaseVariantRef
Properties | List of all members
BaseVariantRef Class Reference

Reference to base variant used in PARENT-REFS. More...

Properties

List< NotInheritedDiagComm > | NOT_INHERITED_DIAG_COMMS [getset]
- Properties inherited from IdRef
string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]

Additional Inherited Members

- Public Member Functions inherited from IdRef
IdRef (string idRef)
override string ToString ()

Detailed Description

Reference to base variant used in PARENT-REFS.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • BaseVariantRef
BaseVariantRef Member List

This is the complete list of members for BaseVariantRef, including all inherited members.

DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef() (defined in IdRef) | IdRef
IdRef(string idRef) (defined in IdRef) | IdRef
NOT_INHERITED_DIAG_COMMS (defined in BaseVariantRef) | BaseVariantRef
ToString() (defined in IdRef) | IdRef


ASAP2Library interface: Case Class Reference

  • Diagnose
  • ODX
  • Case
Properties | List of all members
Case Class Reference

Multiplexer case. More...

Properties

string | LOWER_LIMIT [getset]
string | UPPER_LIMIT [getset]
- Properties inherited from DefaultCase
string | SHORT_NAME [getset]
Structure | StructureRef [get]

Additional Inherited Members

- Public Member Functions inherited from DefaultCase
void | buildRefs (ODXRoot odx)
- Public Attributes inherited from DefaultCase
IdRef | STRUCTURE_REF

Detailed Description

Multiplexer case.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Case
Case Member List

This is the complete list of members for Case, including all inherited members.

buildRefs(ODXRoot odx) (defined in DefaultCase) | DefaultCase
LOWER_LIMIT (defined in Case) | Case
SHORT_NAME (defined in DefaultCase) | DefaultCase
STRUCTURE_REF (defined in DefaultCase) | DefaultCase
StructureRef (defined in DefaultCase) | DefaultCase
UPPER_LIMIT (defined in Case) | Case


ASAP2Library interface: ChartContainer Class Reference

  • Diagnose
  • ODX
  • ChartContainer
Properties | List of all members
ChartContainer Class Reference

Chart container. More...

Properties

List< StateTransitionContainer > | STATE_TRANSITIONS [getset]
List< NamedDescId > | STATES [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Chart container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ChartContainer
ChartContainer Member List

This is the complete list of members for ChartContainer, including all inherited members.

ChartContainer() (defined in ChartContainer) | ChartContainer |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_TRANSITIONS (defined in ChartContainer) | ChartContainer |
STATES (defined in ChartContainer) | ChartContainer |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: CompanyData Class Reference

  • Diagnose
  • ODX
  • CompanyData
Properties | List of all members
CompanyData Class Reference

Definition of Company data. More...

Properties

CompanySpecificInfo | COMPANY_SPECIFIC_INFO [getset]
List< TeamMember > | TEAM_MEMBERS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Definition of Company data.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompanyData
CompanyData Member List

This is the complete list of members for CompanyData, including all inherited members.

COMPANY_SPECIFIC_INFO (defined in CompanyData) | CompanyData |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
TEAM_MEMBERS (defined in CompanyData) | CompanyData |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: CompanySpecificInfo Class Reference

  • Diagnose
  • ODX
  • CompanySpecificInfo
Properties | List of all members
CompanySpecificInfo Class Reference

Company specific info definition. More...

Properties

RelatedDoc[] RELATED_DOCS [getset]

Detailed Description

Company specific info definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompanySpecificInfo
CompanySpecificInfo Member List

This is the complete list of members for CompanySpecificInfo, including all inherited members.

RELATED_DOCS (defined in CompanySpecificInfo) CompanySpecificInfo


ASAP2Library interface: ComParam Class Reference

  • Diagnose
  • ODX
  • ComParam
Public Member Functions | Public Attributes | Properties | List of all members
ComParam Class Reference

Communication parameter definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | DATA_OBJECT_PROP_REF
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

DataObjectProp | DataObjectPropRef [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
- Properties inherited from ComParamBase
string | CPTYPE [getset]
string | CPUSAGE [getset]
int | DISPLAY_LEVEL [getset]
string | PARAM_CLASS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Communication parameter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ComParam
ComParam Member List

This is the complete list of members for ComParam, including all inherited members.

buildRefs(ODXRoot odx) (defined in ComParam) | ComParam |
CPTYPE (defined in ComParamBase) | ComParamBase |
CPUSAGE (defined in ComParamBase) | ComParamBase |
DATA_OBJECT_PROP_REF (defined in ComParam) | ComParam |
DataObjectPropRef (defined in ComParam) | ComParam |
DESC | NamedDescId |
Description | NamedDescId |
DISPLAY_LEVEL (defined in ComParamBase) | ComParamBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PARAM_CLASS (defined in ComParamBase) | ComParamBase |
PHYSICAL_DEFAULT_VALUE (defined in ComParam) | ComParam |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: ComParamBase Class Reference

  • Diagnose
  • ODX
  • ComParamBase
Properties | List of all members
ComParamBase Class Reference

Communication paramter base class. More...

Properties

string | CPTYPE [getset]
string | CPUSAGE [getset]
int | DISPLAY_LEVEL [getset]
string | PARAM_CLASS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Communication paramter base class.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ComParamBase
ComParamBase Member List

This is the complete list of members for ComParamBase, including all inherited members.

CPTYPE (defined in ComParamBase) | ComParamBase |
CPUSAGE (defined in ComParamBase) | ComParamBase |
DESC | NamedDescId |
Description | NamedDescId |
DISPLAY_LEVEL (defined in ComParamBase) | ComParamBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PARAM_CLASS (defined in ComParamBase) | ComParamBase |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: COMParamRef Class Reference

  • Diagnose
  • ODX
  • COMParamRef
Public Member Functions | Public Attributes | Properties | List of all members
COMParamRef Class Reference

Communication parameters. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override string | ToString ()
- Public Member Functions inherited from IdRef
IdRef (string idRef)
override string | ToString ()

Public Attributes

XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
SnRef | PROTOCOL_SNREF

Properties

string[] | COMPLEX_VALUE [getset]
string??? | Description [getset]
Usually an HTML coded node description.
Id | IdRef [get]
Protocol | Protocol [get]
string | SIMPLE_VALUE [getset]
string | VALUE [getset]
- Properties inherited from IdRef
string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Communication parameters.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • COMParamRef
COMParamRef Member List

This is the complete list of members for COMParamRef, including all inherited members.

buildRefs(ODXRoot odx) (defined in COMParamRef) | COMParamRef
COMPLEX_VALUE (defined in COMParamRef) | COMParamRef
DESC | COMParamRef
Description | COMParamRef
DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef (defined in COMParamRef) | COMParamRef
IdRef(string idRef) (defined in IdRef) | IdRef
Protocol (defined in COMParamRef) | COMParamRef
PROTOCOL_SNREF (defined in COMParamRef) | COMParamRef
SIMPLE_VALUE (defined in COMParamRef) | COMParamRef
ToString() (defined in COMParamRef) | COMParamRef
VALUE (defined in COMParamRef) | COMParamRef


ASAP2Library interface: ComParamSpec Class Reference

  • Diagnose
  • ODX
  • ComParamSpec
Properties | List of all members
ComParamSpec Class Reference

Communication parameter specification definition. More...

Properties

ComParam[] | COMPARAMS [getset]
DataObjectProp[] | DATA_OBJECT_PROPS [getset]
ProtStack[] | PROT_STACKS [getset]
UnitSpec | UNIT_SPEC [getset]
- Properties inherited from BaseDocInfoContainer
AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Communication parameter specification definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ComParamSpec
ComParamSpec Member List

This is the complete list of members for ComParamSpec, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPARAMS (defined in ComParamSpec) | ComParamSpec |
DATA_OBJECT_PROPS (defined in ComParamSpec) | ComParamSpec |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PROT_STACKS (defined in ComParamSpec) | ComParamSpec |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
UNIT_SPEC (defined in ComParamSpec) | ComParamSpec |


ASAP2Library interface: ComParamSubset Class Reference

  • Diagnose
  • ODX
  • ComParamSubset
Properties | List of all members
ComParamSubset Class Reference

Communication parameter subset definition. More...

Properties

string | CATEGORY [getset]
ComParam[] | COMPARAMS [getset]
ComplexComParam[] | COMPLEX_COMPARAM [getset]
DataObjectProp[] | DATA_OBJECT_PROPS [getset]
UnitSpec | UNIT_SPEC [getset]
- Properties inherited from BaseDocInfoContainer
AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Communication parameter subset definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ComParamSubset
ComParamSubset Member List

This is the complete list of members for ComParamSubset, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
CATEGORY (defined in ComParamSubset) | ComParamSubset |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPARAMS (defined in ComParamSubset) | ComParamSubset |
COMPLEX_COMPARAM (defined in ComParamSubset) | ComParamSubset |
DATA_OBJECT_PROPS (defined in ComParamSubset) | ComParamSubset |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
UNIT_SPEC (defined in ComParamSubset) | ComParamSubset |


ASAP2Library interface: ComplexComParam Class Reference

  • Diagnose
  • ODX
  • ComplexComParam
Properties | List of all members
ComplexComParam Class Reference

Complex communication parameter definition. More...

Properties

bool | ALLOW_MULTIPLE_VALUES [getset]
ComParam[] | COMPARAMS [getset]
- Properties inherited from ComParamBase
string | CPTYPE [getset]
string | CPUSAGE [getset]
int | DISPLAY_LEVEL [getset]
string | PARAM_CLASS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Complex communication parameter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ComplexComParam
ComplexComParam Member List

This is the complete list of members for ComplexComParam, including all inherited members.

ALLOW_MULTIPLE_VALUES (defined in ComplexComParam) | ComplexComParam |
COMPARAMS (defined in ComplexComParam) | ComplexComParam |
CPTYPE (defined in ComParamBase) | ComParamBase |
CPUSAGE (defined in ComParamBase) | ComParamBase |
DESC | NamedDescId |
Description | NamedDescId |
DISPLAY_LEVEL (defined in ComParamBase) | ComParamBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PARAM_CLASS (defined in ComParamBase) | ComParamBase |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: CompuInternalToPhys Class Reference

  • Diagnose
  • ODX
  • CompuInternalToPhys
Properties | List of all members
CompuInternalToPhys Class Reference

Computation from a raw value to a physical value. More...

Properties

CompuScale[] COMPU_SCALES [getset]
Valid for non-identity compu methods.

Detailed Description

Computation from a raw value to a physical value.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompuInternalToPhys
CompuInternalToPhys Member List

This is the complete list of members for CompuInternalToPhys, including all inherited members.

COMPU_SCALES CompuInternalToPhys


ASAP2Library interface: CompuMethod Class Reference

  • Diagnose
  • ODX
  • CompuMethod
Public Member Functions | Properties | List of all members
CompuMethod Class Reference

Compu method base definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override string | ToString ()

Properties

string | CATEGORY [getset]
Could be IDENTICAL,TEXTTABLE,LINEAR,SCALE-LINEAR
CompuInternalToPhys | COMPU_INTERNAL_TO_PHYS [getset]
Raw value to phiscal value conversion.
Dictionary< long, string > | TextTable [get]
CMCategory | Type [getset]
Defines the category. More...

Detailed Description

Compu method base definition.

Property Documentation

◆ Type

CMCategory Type
getset

Defines the category.

Typed member of the CATEGORY property.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompuMethod
CompuMethod Member List

This is the complete list of members for CompuMethod, including all inherited members.

buildRefs(ODXRoot odx) (defined in CompuMethod) | CompuMethod
CATEGORY | CompuMethod
COMPU_INTERNAL_TO_PHYS | CompuMethod
TextTable (defined in CompuMethod) | CompuMethod
ToString() (defined in CompuMethod) | CompuMethod
Type | CompuMethod


ASAP2Library interface: CompuRationalCoeffs Class Reference

  • Diagnose
  • ODX
  • CompuRationalCoeffs
Public Member Functions | Properties | List of all members
CompuRationalCoeffs Class Reference

Compu method rational coefficients. More...

Public Member Functions

double toPhysical (double rawValue)

Properties

double[] | DENOMINATOR [getset]
double[] | NUMERATOR [getset]
string | SHORT_LABEL [getset]

Detailed Description

Compu method rational coefficients.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompuRationalCoeffs
CompuRationalCoeffs Member List

This is the complete list of members for CompuRationalCoeffs, including all inherited members.

DENOMINATOR (defined in CompuRationalCoeffs) | CompuRationalCoeffs
NUMERATOR (defined in CompuRationalCoeffs) | CompuRationalCoeffs
SHORT_LABEL (defined in CompuRationalCoeffs) | CompuRationalCoeffs
toPhysical(double rawValue) (defined in CompuRationalCoeffs) | CompuRationalCoeffs


ASAP2Library interface: CompuScale Class Reference

  • Diagnose
  • ODX
  • CompuScale
Properties | List of all members
CompuScale Class Reference

Compu scale definition. More...

Properties

object[] | COMPU_CONST [getset]
object[] | COMPU_INVERSE_VALUE [getset]
CompuRationalCoeffs | COMPU_RATIONAL_COEFFS [getset]
string | SHORT_LABEL [getset]
- Properties inherited from LimitBase
string??? | Description [getset]
Usually an HTML coded node description.
string? | LOWER_LIMIT [getset]
string? | UPPER_LIMIT [getset]
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from LimitBase
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
double | LowerLimit
double | UpperLimit

Detailed Description

Compu scale definition.

The properties are valid depending on type of the containing CompuMethod.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • CompuScale
CompuScale Member List

This is the complete list of members for CompuScale, including all inherited members.

COMPU_CONST (defined in CompuScale) | CompuScale
COMPU_INVERSE_VALUE (defined in CompuScale) | CompuScale
COMPU_RATIONAL_COEFFS (defined in CompuScale) | CompuScale
DESC | LimitBase
Description | LimitBase
LOWER_LIMIT (defined in LimitBase) | LimitBase
LowerLimit (defined in LimitBase) | LimitBase
SHORT_LABEL (defined in CompuScale) | CompuScale
UPPER_LIMIT (defined in LimitBase) | LimitBase
UpperLimit (defined in LimitBase) | LimitBase


ASAP2Library interface: DataBlock Class Reference

  • Diagnose
  • ODX
  • DataBlock
Public Member Functions | Public Attributes | Properties | List of all members
DataBlock Class Reference

Data block definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

string | TYPE_
The member TYPE describes the kind of datablock More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

Filter[] | FILTERS [getset]
IdRef | FLASHDATA_REF [getset]
NamedId | FlashDataRef [get]
Ident[] | OWN_IDENTS [getset]
Security[] | SECURITYS [getset]
Segment[] | SEGMENTS [getset]
DataBlockType? | Type [getset]
Typed member of the TYPE property.
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Data block definition.

Member Data Documentation

◆ TYPE_

string TYPE_

The member TYPE describes the kind of datablock

(e.g. "BOOT", "CODE", "DATA", or other values, this TYPE is just a classification and any other proprietary TYPE could be used).


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DataBlock
DataBlock Member List

This is the complete list of members for DataBlock, including all inherited members.

buildRefs(ODXRoot odx) (defined in DataBlock) | DataBlock |
DESC | NamedDescId |
Description | NamedDescId |
FILTERS (defined in DataBlock) | DataBlock |
FLASHDATA_REF (defined in DataBlock) | DataBlock |
FlashDataRef (defined in DataBlock) | DataBlock |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
OWN_IDENTS (defined in DataBlock) | DataBlock |
SDGS (defined in NamedId) | NamedId |
SECURITYS (defined in DataBlock) | DataBlock |
SEGMENTS (defined in DataBlock) | DataBlock |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
Type | DataBlock |
TYPE_ | DataBlock |


ASAP2Library interface: DataFile Struct Reference

  • Diagnose
  • ODX
  • DataFile
Properties | List of all members
DataFile Struct Reference

Data file definition. More...

Properties

bool | LATEBOUND_DATAFILE [getset]
True, if data is referenced as an external file.
string | TEXT [getset]
Reference to a filename, if LATEBOUND_DATAFILE is true.

Detailed Description

Data file definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DataFile
DataFile Member List

This is the complete list of members for DataFile, including all inherited members.

LATEBOUND_DATAFILE | DataFile
TEXT | DataFile


ASAP2Library interface: DataFormat Struct Reference

  • Diagnose
  • ODX
  • DataFormat
Public Attributes | Properties | List of all members
DataFormat Struct Reference

Data format definition. More...

Public Attributes

DataFormatType mSelection

Properties

DataFormatType | Selection [getset]
Describes the data format. More...
string | SELECTION_ [getset]
Describes the data format. More...

Detailed Description

Data format definition.

Property Documentation

◆ Selection

DataFormatType Selection
getset

Describes the data format.

Typed member of the SELECTION_ property.

◆ SELECTION_

string SELECTION_
getset

Describes the data format.

Selection could be one of these values [BINARY,INTEL-HEX,MOTOROLA-S]


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DataFormat
DataFormat Member List

This is the complete list of members for DataFormat, including all inherited members.

mSelection (defined in DataFormat) | DataFormat
Selection | DataFormat
SELECTION_ | DataFormat


ASAP2Library interface: DataObjectProp Class Reference

  • Diagnose
  • ODX
  • DataObjectProp
Public Member Functions | Public Attributes | Properties | List of all members
DataObjectProp Class Reference

Data object property specification. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef | UNIT_REF
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

CompuMethod | COMPU_METHOD [getset]
DiagCodedTypeBase | DIAG_CODED_TYPE [getset]
InternalConstr | INTERNAL_CONSTR [getset]
PhysicalType | PHYSICAL_TYPE [getset]
Unit | UnitRef [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Data object property specification.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DataObjectProp
DataObjectProp Member List

This is the complete list of members for DataObjectProp, including all inherited members.

buildRefs(ODXRoot odx) (defined in DataObjectProp) | DataObjectProp |
COMPU_METHOD (defined in DataObjectProp) | DataObjectProp |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_CODED_TYPE (defined in DataObjectProp) | DataObjectProp |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | DataObjectProp | virtual
INTERNAL_CONSTR (defined in DataObjectProp) | DataObjectProp |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PHYSICAL_TYPE (defined in DataObjectProp) | DataObjectProp |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
UNIT_REF (defined in DataObjectProp) | DataObjectProp |
UnitRef (defined in DataObjectProp) | DataObjectProp |


ASAP2Library interface: DefaultCase Class Reference

  • Diagnose
  • ODX
  • DefaultCase
Public Member Functions | Public Attributes | Properties | List of all members
DefaultCase Class Reference

Multiplexer default case definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef STRUCTURE_REF

Properties

string | SHORT_NAME [getset]
Structure | StructureRef [get]

Detailed Description

Multiplexer default case definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DefaultCase
DefaultCase Member List

This is the complete list of members for DefaultCase, including all inherited members.

buildRefs(ODXRoot odx) (defined in DefaultCase) | DefaultCase
SHORT_NAME (defined in DefaultCase) | DefaultCase
STRUCTURE_REF (defined in DefaultCase) | DefaultCase
StructureRef (defined in DefaultCase) | DefaultCase


ASAP2Library interface: DetermineNumberOfItems Class Reference

  • Diagnose
  • ODX
  • DetermineNumberOfItems
Public Member Functions | Public Attributes | Properties | List of all members
DetermineNumberOfItems Class Reference

Part of dynamic length field part. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef DATA_OBJECT_PROP_REF

Properties

byte | BYTE_POSITION [getset]
Id | DataObjectPropRef [getset]

Detailed Description

Part of dynamic length field part.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DetermineNumberOfItems
DetermineNumberOfItems Member List

This is the complete list of members for DetermineNumberOfItems, including all inherited members.

buildRefs(ODXRoot odx) (defined in DetermineNumberOfItems) | DetermineNumberOfItems
BYTE_POSITION (defined in DetermineNumberOfItems) | DetermineNumberOfItems
DATA_OBJECT_PROP_REF (defined in DetermineNumberOfItems) | DetermineNumberOfItems
DataObjectPropRef (defined in DetermineNumberOfItems) | DetermineNumberOfItems


ASAP2Library interface: DiagCodedTypeBase Class Reference

  • Diagnose
  • ODX
  • DiagCodedTypeBase
Public Member Functions | Properties | List of all members
DiagCodedTypeBase Class Reference

Base class for diagnose coded types. More...

Public Member Functions

sealed override string ToString ()

Properties

BaseDataType | BASE_DATA_TYPE [getset]
string | BASE_TYPE_ENCODING [getset]
Could be NONE, BCD-P,ISO-8859-1

Detailed Description

Base class for diagnose coded types.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagCodedTypeBase
DiagCodedTypeBase Member List

This is the complete list of members for DiagCodedTypeBase, including all inherited members.

BASE_DATA_TYPE (defined in DiagCodedTypeBase) | DiagCodedTypeBase
BASE_TYPE_ENCODING | DiagCodedTypeBase
DiagCodedTypeBase() (defined in DiagCodedTypeBase) | DiagCodedTypeBase
ToString() (defined in DiagCodedTypeBase) | DiagCodedTypeBase


ASAP2Library interface: DiagCodedTypeLL Class Reference

  • Diagnose
  • ODX
  • DiagCodedTypeLL
Properties | List of all members
DiagCodedTypeLL Class Reference

Leading length diagnose coded type. More...

Properties

ulong | BIT_LENGTH [getset]
bool | IS_HIGHLOW_BYTE_ORDER = true [getset]
- Properties inherited from DiagCodedTypeBase
BaseDataType | BASE_DATA_TYPE [getset]
string | BASE_TYPE_ENCODING [getset]
Could be NONE, BCD-P,ISO-8859-1

Additional Inherited Members

- Public Member Functions inherited from DiagCodedTypeBase
sealed override string ToString ()

Detailed Description

Leading length diagnose coded type.

BIT_LENGTH contains the size of the following length information.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagCodedTypeLL
DiagCodedTypeLL Member List

This is the complete list of members for DiagCodedTypeLL, including all inherited members.

BASE_DATA_TYPE (defined in DiagCodedTypeBase) | DiagCodedTypeBase
BASE_TYPE_ENCODING | DiagCodedTypeBase
BIT_LENGTH (defined in DiagCodedTypeLL) | DiagCodedTypeLL
DiagCodedTypeBase() (defined in DiagCodedTypeBase) | DiagCodedTypeBase
DiagCodedTypeLL() (defined in DiagCodedTypeLL) | DiagCodedTypeLL
IS_HIGHLOW_BYTE_ORDER (defined in DiagCodedTypeLL) | DiagCodedTypeLL
ToString() (defined in DiagCodedTypeBase) | DiagCodedTypeBase


ASAP2Library interface: DiagCodedTypeMinMax Class Reference

  • Diagnose
  • ODX
  • DiagCodedTypeMinMax
Properties | List of all members
DiagCodedTypeMinMax Class Reference

Minimum-Maximum diagnose coded type. More...

Properties

bool | IS_HIGHLOW_BYTE_ORDER = true [getset]
int | MAX_LENGTH [getset]
int | MIN_LENGTH [getset]
TerminationType | Termination [getset]
Defines the termination. More...
string | TERMINATION_ [getset]
Defines the termination.
- Properties inherited from DiagCodedTypeBase
BaseDataType | BASE_DATA_TYPE [getset]
string | BASE_TYPE_ENCODING [getset]
Could be NONE, BCD-P,ISO-8859-1

Additional Inherited Members

- Public Member Functions inherited from DiagCodedTypeBase
sealed override string ToString ()

Detailed Description

Minimum-Maximum diagnose coded type.

Property Documentation

◆ Termination

TerminationType Termination
getset

Defines the termination.

Typed member of the TERMINATION_ property.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagCodedTypeMinMax
DiagCodedTypeMinMax Member List

This is the complete list of members for DiagCodedTypeMinMax, including all inherited members.

BASE_DATA_TYPE (defined in DiagCodedTypeBase) | DiagCodedTypeBase
BASE_TYPE_ENCODING | DiagCodedTypeBase
DiagCodedTypeBase() (defined in DiagCodedTypeBase) | DiagCodedTypeBase
DiagCodedTypeMinMax() (defined in DiagCodedTypeMinMax) | DiagCodedTypeMinMax
IS_HIGHLOW_BYTE_ORDER (defined in DiagCodedTypeMinMax) | DiagCodedTypeMinMax
MAX_LENGTH (defined in DiagCodedTypeMinMax) | DiagCodedTypeMinMax
MIN_LENGTH (defined in DiagCodedTypeMinMax) | DiagCodedTypeMinMax
Termination | DiagCodedTypeMinMax
TERMINATION_ | DiagCodedTypeMinMax
ToString() (defined in DiagCodedTypeBase) | DiagCodedTypeBase


ASAP2Library interface: DiagCodedTypePL Class Reference

  • Diagnose
  • ODX
  • DiagCodedTypePL
Public Member Functions | Public Attributes | Properties | List of all members
DiagCodedTypePL Class Reference

Param length diagnose coded type. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from DiagCodedTypeBase
sealed override string | ToString ()

Public Attributes

IdRef LENGTH_KEY_REF

Properties

ParLength | LengthKeyRef [get]
- Properties inherited from DiagCodedTypeBase
BaseDataType | BASE_DATA_TYPE [getset]
string | BASE_TYPE_ENCODING [getset]
Could be NONE, BCD-P,ISO-8859-1

Detailed Description

Param length diagnose coded type.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagCodedTypePL
DiagCodedTypePL Member List

This is the complete list of members for DiagCodedTypePL, including all inherited members.

BASE_DATA_TYPE (defined in DiagCodedTypeBase) | DiagCodedTypeBase
BASE_TYPE_ENCODING | DiagCodedTypeBase
buildRefs(ODXRoot odx) (defined in DiagCodedTypePL) | DiagCodedTypePL
DiagCodedTypeBase() (defined in DiagCodedTypeBase) | DiagCodedTypeBase
DiagCodedTypePL() (defined in DiagCodedTypePL) | DiagCodedTypePL
LENGTH_KEY_REF (defined in DiagCodedTypePL) | DiagCodedTypePL
LengthKeyRef (defined in DiagCodedTypePL) | DiagCodedTypePL
ToString() (defined in DiagCodedTypeBase) | DiagCodedTypeBase


ASAP2Library interface: DiagCodedTypeStd Class Reference

  • Diagnose
  • ODX
  • DiagCodedTypeStd
Properties | List of all members
DiagCodedTypeStd Class Reference

Standard diagnose coded type. More...

Properties

ulong | BIT_LENGTH [getset]
bool | IS_HIGHLOW_BYTE_ORDER = true [getset]
- Properties inherited from DiagCodedTypeBase
BaseDataType | BASE_DATA_TYPE [getset]
string | BASE_TYPE_ENCODING [getset]
Could be NONE, BCD-P,ISO-8859-1

Additional Inherited Members

- Public Member Functions inherited from DiagCodedTypeBase
sealed override string ToString ()

Detailed Description

Standard diagnose coded type.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagCodedTypeStd
DiagCodedTypeStd Member List

This is the complete list of members for DiagCodedTypeStd, including all inherited members.

BASE_DATA_TYPE (defined in DiagCodedTypeBase) | DiagCodedTypeBase
BASE_TYPE_ENCODING | DiagCodedTypeBase
BIT_LENGTH (defined in DiagCodedTypeStd) | DiagCodedTypeStd
DiagCodedTypeBase() (defined in DiagCodedTypeBase) | DiagCodedTypeBase
IS_HIGHLOW_BYTE_ORDER (defined in DiagCodedTypeStd) | DiagCodedTypeStd
ToString() (defined in DiagCodedTypeBase) | DiagCodedTypeBase


ASAP2Library interface: DiagDataDictionarySpec Class Reference

  • Diagnose
  • ODX
  • DiagDataDictionarySpec
Properties | List of all members
DiagDataDictionarySpec Class Reference

Diagnostic dictionary specification. More...

Properties

List< DataObjectProp > | DATA_OBJECT_PROPS [getset]
List< DtcDop > | DTC_DOPS [getset]
List< DynamicLengthField > | DYNAMIC_LENGTH_FIELDS [getset]
List< EndOfPDUField > | END_OF_PDU_FIELDS [getset]
List< EnvDataDesc > | ENV_DATA_DESCS [getset]
List< EnvDataParamContainer > | ENV_DATAS [getset]
List< Mux > | MUXS [getset]
List< StaticField > | STATIC_FIELDS [getset]
List< Structure > | STRUCTURES [getset]
List< Table > | TABLES [getset]
UnitSpec | UNIT_SPEC [getset]

Detailed Description

Diagnostic dictionary specification.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagDataDictionarySpec
DiagDataDictionarySpec Member List

This is the complete list of members for DiagDataDictionarySpec, including all inherited members.

DATA_OBJECT_PROPS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
DTC_DOPS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
DYNAMIC_LENGTH_FIELDS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
END_OF_PDU_FIELDS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
ENV_DATA_DESCS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
ENV_DATAS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
MUXS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
STATIC_FIELDS (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
STRUCTURES (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
TABLES (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec
UNIT_SPEC (defined in DiagDataDictionarySpec) | DiagDataDictionarySpec


ASAP2Library interface: DiagDataDictSpec Class Reference

  • Diagnose
  • ODX
  • DiagDataDictSpec
Public Attributes | List of all members
DiagDataDictSpec Class Reference

Non serialized class used internally to hold DiagDataDictionarySpec instances. More...

Public Attributes

readonly List< DataObjectProp > | DataObjectProps = new List<DataObjectProp>()
readonly List< DtcDop > | DtcDops = new List<DtcDop>()
readonly List< DynamicLengthField > | DynamicLengthFields = new List<DynamicLengthField>()
readonly List< EndOfPDUField > | EndOfPDUFields = new List<EndOfPDUField>()
readonly List< EnvDataDesc > | EnvDataDescs = new List<EnvDataDesc>()
readonly List< Mux > | Muxs = new List<Mux>()
readonly List< StaticField > | StaticFields = new List<StaticField>()
readonly List< Structure > | Structures = new List<Structure>()
readonly List< Table > | Tables = new List<Table>()
readonly UnitSpecs | UnitSpec = new UnitSpecs()

Detailed Description

Non serialized class used internally to hold DiagDataDictionarySpec instances.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagDataDictSpec
DiagDataDictSpec Member List

This is the complete list of members for DiagDataDictSpec, including all inherited members.

DataObjectProps (defined in DiagDataDictSpec) | DiagDataDictSpec
DtcDops (defined in DiagDataDictSpec) | DiagDataDictSpec
DynamicLengthFields (defined in DiagDataDictSpec) | DiagDataDictSpec
EndOfPDUFields (defined in DiagDataDictSpec) | DiagDataDictSpec
EnvDataDescs (defined in DiagDataDictSpec) | DiagDataDictSpec
Muxs (defined in DiagDataDictSpec) | DiagDataDictSpec
StaticFields (defined in DiagDataDictSpec) | DiagDataDictSpec
Structures (defined in DiagDataDictSpec) | DiagDataDictSpec
Tables (defined in DiagDataDictSpec) | DiagDataDictSpec
UnitSpec (defined in DiagDataDictSpec) | DiagDataDictSpec


ASAP2Library interface: DiagLayerContainer Class Reference

  • Diagnose
  • ODX
  • DiagLayerContainer
Properties | List of all members
DiagLayerContainer Class Reference

Diagnostic layer container. More...

Properties

List< BaseVariant > | BASE_VARIANTS [getset]
List< EcuSharedData > | ECU_SHARED_DATAS [getset]
List< EcuVariant > | ECU_VARIANTS [getset]
List< FunctionalGroup > | FUNCTIONAL_GROUPS [getset]
List< Protocol > | PROTOCOLS [getset]
- Properties inherited from BaseDocInfoContainer
AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Diagnostic layer container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagLayerContainer
DiagLayerContainer Member List

This is the complete list of members for DiagLayerContainer, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
BASE_VARIANTS (defined in DiagLayerContainer) | DiagLayerContainer |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
DESC | NamedDescId |
Description | NamedDescId |
ECU_SHARED_DATAS (defined in DiagLayerContainer) | DiagLayerContainer |
ECU_VARIANTS (defined in DiagLayerContainer) | DiagLayerContainer |
FUNCTIONAL_GROUPS (defined in DiagLayerContainer) | DiagLayerContainer |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PROTOCOLS (defined in DiagLayerContainer) | DiagLayerContainer |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: DiagService Class Reference

  • Diagnose
  • ODX
  • DiagService
Public Member Functions | Public Attributes | Properties | List of all members
DiagService Class Reference

Diagnostic service definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

List< IdRef > | FUNCT_CLASS_REFS
List< IdRef > | NEG_RESPONSE_REFS
List< IdRef > | POS_RESPONSE_REFS
List< IdRef > | PRE_CONDITION_STATE_REFS
IdRef | REQUEST_REF
List< IdRef > | STATE_TRANSITION_REFS

Properties

AddressingType | Addressing [getset]
Defines the addressing mode used by the DIAG-SERVICE. More...
string | ADDRESSING_ [getset]
Audience | AUDIENCE [getset]
List< FunctClass > | FunctClassRefs = new List<FunctClass>() [get]
List< IdentifierRecord > | Identifiers [get]
Holds available (ReadDataBy)Identifiers and it's response data info.
List< ParamContainer > | NegResponseRefs = new List<ParamContainer>() [get]
List< ParamContainer > | PosResponseRefs = new List<ParamContainer>() [get]
List< NamedDescId > | PreConditionStatesRefs = new List<NamedDescId>() [get]
List< ParamDataInfo > | RequestParamInfo [get]
ParamContainer | RequestRef [get]
List< ParamDataInfo > | ResponseParamInfo [get]
Gets the response info.
string | SEMANTIC [getset]
byte | SID [get]
Service ID.
List< StateTransitionContainer > | StateTransitionRefs = new List<StateTransitionContainer>() [get]
byte | Subfunction [get]
Subfunction {byte.MaxValue if not defined/not used).
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Diagnostic service definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.

Property Documentation

◆ Addressing

AddressingType Addressing
getset

Defines the addressing mode used by the DIAG-SERVICE.

Typed member of the ADDRESSING property.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DiagService
DiagService Member List

This is the complete list of members for DiagService, including all inherited members.

Addressing | DiagService |
ADDRESSING_ (defined in DiagService) | DiagService |
AUDIENCE (defined in DiagService) | DiagService |
buildRefs(ODXRoot odx) (defined in DiagService) | DiagService |
DiagService() (defined in DiagService) | DiagService |
FUNCT_CLASS_REFS (defined in DiagService) | DiagService |
FunctClassRefs (defined in DiagService) | DiagService |
ID (defined in Id) | Id |
Identifiers | DiagService |
initialize(ODXRoot odx) | DiagService | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSE_REFS (defined in DiagService) | DiagService |
NegResponseRefs (defined in DiagService) | DiagService |
Odx | Id |
POS_RESPONSE_REFS (defined in DiagService) | DiagService |
PosResponseRefs (defined in DiagService) | DiagService |
PRE_CONDITION_STATE_REFS (defined in DiagService) | DiagService |
PreConditionStatesRefs (defined in DiagService) | DiagService |
REQUEST_REF (defined in DiagService) | DiagService |
RequestParamInfo (defined in DiagService) | DiagService |
RequestRef (defined in DiagService) | DiagService |
ResponseParamInfo | DiagService |
SDGS (defined in NamedId) | NamedId |
SEMANTIC (defined in DiagService) | DiagService |
SHORT_NAME (defined in NamedId) | NamedId |
SID | DiagService |
STATE_TRANSITION_REFS (defined in DiagService) | DiagService |
StateTransitionRefs (defined in DiagService) | DiagService |
Subfunction | DiagService |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: DocRevision Class Reference

  • Diagnose
  • ODX
  • DocRevision
Public Member Functions | Public Attributes | Properties | List of all members
DocRevision Class Reference

Definition of a document revision. More...

Public Member Functions

DocRevision (string revLabel, TeamMember tm, string state)
void | buildRefs (ODXRoot odx)
override string | ToString ()

Public Attributes

IdRef TEAM_MEMBER_REF

Properties

DateTime | DATE [getset]
Modification[] | MODIFICATIONS [getset]
string | REVISION_LABEL [getset]
string | STATE [getset]
TeamMember | TeamMemberRef [getset]
Reference to team member.
string | TOOL [getset]

Detailed Description

Definition of a document revision.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DocRevision
DocRevision Member List

This is the complete list of members for DocRevision, including all inherited members.

buildRefs(ODXRoot odx) (defined in DocRevision) | DocRevision
DATE (defined in DocRevision) | DocRevision
DocRevision() (defined in DocRevision) | DocRevision
DocRevision(string revLabel, TeamMember tm, string state) (defined in DocRevision) | DocRevision
MODIFICATIONS (defined in DocRevision) | DocRevision
REVISION_LABEL (defined in DocRevision) | DocRevision
STATE (defined in DocRevision) | DocRevision
TEAM_MEMBER_REF (defined in DocRevision) | DocRevision
TeamMemberRef | DocRevision
TOOL (defined in DocRevision) | DocRevision
ToString() (defined in DocRevision) | DocRevision


ASAP2Library interface: Dtc Class Reference

  • Diagnose
  • ODX
  • Dtc
Properties | List of all members
Dtc Class Reference

Diagnostic trouble code. More...

Properties

string | DISPLAY_TROUBLE_CODE [getset]
string | TEXT [getset]
int | TROUBLE_CODE [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Diagnostic trouble code.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Dtc
Dtc Member List

This is the complete list of members for Dtc, including all inherited members.

DISPLAY_TROUBLE_CODE (defined in Dtc) | Dtc |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
TEXT (defined in Dtc) | Dtc |
ToString() (defined in NamedId) | NamedId |
TROUBLE_CODE (defined in Dtc) | Dtc |


ASAP2Library interface: DtcDop Class Reference

  • Diagnose
  • ODX
  • DtcDop
Properties | List of all members
DtcDop Class Reference

Diagnostic trouble codes specification. More...

Properties

Dictionary< int, Dtc > | Dtcs [get]
List< object > | DTCS_ [getset]
Just for Serializing, use Dtcs to access.
- Properties inherited from DataObjectProp
CompuMethod | COMPU_METHOD [getset]
DiagCodedTypeBase | DIAG_CODED_TYPE [getset]
InternalConstr | INTERNAL_CONSTR [getset]
PhysicalType | PHYSICAL_TYPE [getset]
Unit | UnitRef [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from DataObjectProp
void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Attributes inherited from DataObjectProp
IdRef | UNIT_REF
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Diagnostic trouble codes specification.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DtcDop
DtcDop Member List

This is the complete list of members for DtcDop, including all inherited members.

buildRefs(ODXRoot odx) (defined in DataObjectProp) | DataObjectProp |
COMPU_METHOD (defined in DataObjectProp) | DataObjectProp |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_CODED_TYPE (defined in DataObjectProp) | DataObjectProp |
Dtcs (defined in DtcDop) | DtcDop |
DTCS_ | DtcDop |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | DataObjectProp | virtual
INTERNAL_CONSTR (defined in DataObjectProp) | DataObjectProp |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PHYSICAL_TYPE (defined in DataObjectProp) | DataObjectProp |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
UNIT_REF (defined in DataObjectProp) | DataObjectProp |
UnitRef (defined in DataObjectProp) | DataObjectProp |


ASAP2Library interface: DynamicLengthField Class Reference

  • Diagnose
  • ODX
  • DynamicLengthField
Properties | List of all members
DynamicLengthField Class Reference

Dynamic length field definition. More...

Properties

DetermineNumberOfItems | DETERMINE_NUMBER_OF_ITEMS [getset]
long | OFFSET [getset]
- Properties inherited from EndOfPDUField
Structure | BasicStructureRef [get]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from EndOfPDUField
void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Attributes inherited from EndOfPDUField
IdRef | BASIC_STRUCTURE_REF

Detailed Description

Dynamic length field definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • DynamicLengthField
DynamicLengthField Member List

This is the complete list of members for DynamicLengthField, including all inherited members.

BASIC_STRUCTURE_REF (defined in EndOfPDUField) | EndOfPDUField |
BasicStructureRef (defined in EndOfPDUField) | EndOfPDUField |
buildRefs(ODXRoot odx) (defined in EndOfPDUField) | EndOfPDUField |
DETERMINE_NUMBER_OF_ITEMS (defined in DynamicLengthField) | DynamicLengthField |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | EndOfPDUField | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
OFFSET (defined in DynamicLengthField) | DynamicLengthField |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EcuMem Class Reference

  • Diagnose
  • ODX
  • EcuMem
Properties | List of all members
EcuMem Class Reference

ECU memory definition. More...

Properties

Mem | MEM [getset]
PhysMem | PHYS_MEM [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

ECU memory definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuMem
EcuMem Member List

This is the complete list of members for EcuMem, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
MEM (defined in EcuMem) | EcuMem |
Odx | Id |
PHYS_MEM (defined in EcuMem) | EcuMem |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EcuMemConnector Class Reference

  • Diagnose
  • ODX
  • EcuMemConnector
Public Member Functions | Public Attributes | Properties | List of all members
EcuMemConnector Class Reference

ECU memory connector definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | ECU_MEM_REF
IdRef[] | LAYER_REFS

Properties

EcuMem | EcuMemRef [get]
NamedDescId[] | FLASH_CLASSS [getset]
IdentDesc[] | IDENT_DESCS [getset]
List< IId > | LayerRefs = new List<IId>() [get]
SessionDesc[] | SESSION_DESCS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

ECU memory connector definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuMemConnector
EcuMemConnector Member List

This is the complete list of members for EcuMemConnector, including all inherited members.

buildRefs(ODXRoot odx) (defined in EcuMemConnector) | EcuMemConnector |
ECU_MEM_REF (defined in EcuMemConnector) | EcuMemConnector |
EcuMemRef (defined in EcuMemConnector) | EcuMemConnector |
FLASH_CLASSS (defined in EcuMemConnector) | EcuMemConnector |
ID (defined in Id) | Id |
IDENT_DESCS (defined in EcuMemConnector) | EcuMemConnector |
initialize(ODXRoot odx) | Id | virtual
LAYER_REFS (defined in EcuMemConnector) | EcuMemConnector |
LayerRefs (defined in EcuMemConnector) | EcuMemConnector |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SESSION_DESCS (defined in EcuMemConnector) | EcuMemConnector |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EcuSharedData Class Reference

  • Diagnose
  • ODX
  • EcuSharedData
Public Member Functions | Properties | List of all members
EcuSharedData Class Reference

ECU shared data definition. More...

Public Member Functions

override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Properties

List< COMParamRef > | COMPARAM_REFS [getset]
List< COMParamRef > | ComparamRefs = new List<COMParamRef>() [get]
List< DiagService > | DIAG_COMMS [getset]
DiagDataDictionarySpec | DIAG_DATA_DICTIONARY_SPEC [getset]
DiagDataDictSpec | DiagDataDictionarySpec = new DiagDataDictSpec() [get]
List< DiagService > | DiagServices = new List<DiagService>() [get]
List< FunctClass > | FUNCT_CLASSS [getset]
List< FunctClass > | FunctClasses = new List<FunctClass>() [get]
List< ParamContainer > | GLOBAL_NEG_RESPONSES [getset]
List< IdRef > | IMPORT_REFS [getset]
List< ParamContainer > | NEG_RESPONSES [getset]
List< ParamContainer > | NegResponses = new List<ParamContainer>() [get]
List< ParamContainer > | POS_RESPONSES [getset]
List< ParamContainer > | PosResponses = new List<ParamContainer>() [get]
List< ParamContainer > | Requests = new List<ParamContainer>() [get]
List< ParamContainer > | REQUESTS_ [getset]
List< ChartContainer > | STATE_CHARTS [getset]
List< ChartContainer > | StateCharts = new List<ChartContainer>() [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from NamedDescId
XmlNode DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

ECU shared data definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuSharedData
EcuSharedData Member List

This is the complete list of members for EcuSharedData, including all inherited members.

COMPARAM_REFS (defined in EcuSharedData) | EcuSharedData |
ComparamRefs (defined in EcuSharedData) | EcuSharedData |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_COMMS (defined in EcuSharedData) | EcuSharedData |
DIAG_DATA_DICTIONARY_SPEC (defined in EcuSharedData) | EcuSharedData |
DiagDataDictionarySpec (defined in EcuSharedData) | EcuSharedData |
DiagServices (defined in EcuSharedData) | EcuSharedData |
FUNCT_CLASSS (defined in EcuSharedData) | EcuSharedData |
FunctClasses (defined in EcuSharedData) | EcuSharedData |
GLOBAL_NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
ID (defined in Id) | Id |
IMPORT_REFS (defined in EcuSharedData) | EcuSharedData |
initialize(ODXRoot odx) | EcuSharedData | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
NegResponses (defined in EcuSharedData) | EcuSharedData |
Odx | Id |
POS_RESPONSES (defined in EcuSharedData) | EcuSharedData |
PosResponses (defined in EcuSharedData) | EcuSharedData |
Requests (defined in EcuSharedData) | EcuSharedData |
REQUESTS_ (defined in EcuSharedData) | EcuSharedData |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_CHARTS (defined in EcuSharedData) | EcuSharedData |
StateCharts (defined in EcuSharedData) | EcuSharedData |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EcuSharedDataRef Class Reference

  • Diagnose
  • ODX
  • EcuSharedDataRef
List of all members
EcuSharedDataRef Class Reference

Reference to ECU shared data used in used in PARENT-REFS. More...

Additional Inherited Members

- Public Member Functions inherited from IdRef
IdRef (string idRef)
override string | ToString ()
- Properties inherited from IdRef
string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]

Detailed Description

Reference to ECU shared data used in used in PARENT-REFS.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuSharedDataRef
EcuSharedDataRef Member List

This is the complete list of members for EcuSharedDataRef, including all inherited members.

DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef() (defined in IdRef) | IdRef
IdRef(string idRef) (defined in IdRef) | IdRef
ToString() (defined in IdRef) | IdRef


ASAP2Library interface: EcuVariant Class Reference

  • Diagnose
  • ODX
  • EcuVariant
Public Member Functions | Public Attributes | Properties | List of all members
EcuVariant Class Reference

ECU variant definition. More...

Public Member Functions

virtual void | buildRefs (ODXRoot odx)
Protocol[] getSupportedProtocols ()
Gets the supported diagnose communication protocols. More...
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from EcuSharedData
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

readonly List< EcuVariantPatternContainer > | EcuVariantPatterns = new List<EcuVariantPatternContainer>()
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

List< EcuVariantPatternContainer > | ECU_VARIANT_PATTERNS [getset]
virtual BaseVariant | Parent [get]
List< IdRef > | PARENT_REFS [getset]
- Properties inherited from EcuSharedData
List< COMParamRef > | COMPARAM_REFS [getset]
List< COMParamRef > | ComparamRefs = new List<COMParamRef>() [get]
List< DiagService > | DIAG_COMMS [getset]
DiagDataDictionarySpec | DIAG_DATA_DICTIONARY_SPEC [getset]
DiagDataDictSpec | DiagDataDictionarySpec = new DiagDataDictSpec() [get]
List< DiagService > | DiagServices = new List<DiagService>() [get]
List< FunctClass > | FUNCT_CLASSS [getset]
List< FunctClass > | FunctClasses = new List<FunctClass>() [get]
List< ParamContainer > | GLOBAL_NEG_RESPONSES [getset]
List< IdRef > | IMPORT_REFS [getset]
List< ParamContainer > | NEG_RESPONSES [getset]
List< ParamContainer > | NegResponses = new List<ParamContainer>() [get]
List< ParamContainer > | POS_RESPONSES [getset]
List< ParamContainer > | PosResponses = new List<ParamContainer>() [get]
List< ParamContainer > | Requests = new List<ParamContainer>() [get]
List< ParamContainer > | REQUESTS_ [getset]
List< ChartContainer > | STATE_CHARTS [getset]
List< ChartContainer > | StateCharts = new List<ChartContainer>() [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

ECU variant definition.

Member Function Documentation

◆ getSupportedProtocols()

Protocol[] getSupportedProtocols ( )

Gets the supported diagnose communication protocols.

Returns
List of protocols or null

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.

Reimplemented in BaseVariant.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuVariant
EcuVariant Member List

This is the complete list of members for EcuVariant, including all inherited members.

buildRefs(ODXRoot odx) (defined in EcuVariant) | EcuVariant | virtual
COMPARAM_REFS (defined in EcuSharedData) | EcuSharedData |
ComparamRefs (defined in EcuSharedData) | EcuSharedData |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_COMMS (defined in EcuSharedData) | EcuSharedData |
DIAG_DATA_DICTIONARY_SPEC (defined in EcuSharedData) | EcuSharedData |
DiagDataDictionarySpec (defined in EcuSharedData) | EcuSharedData |
DiagServices (defined in EcuSharedData) | EcuSharedData |
ECU_VARIANT_PATTERNS (defined in EcuVariant) | EcuVariant |
EcuVariant() (defined in EcuVariant) | EcuVariant |
EcuVariantPatterns (defined in EcuVariant) | EcuVariant |
FUNCT_CLASSS (defined in EcuSharedData) | EcuSharedData |
FunctClasses (defined in EcuSharedData) | EcuSharedData |
getSupportedProtocols() | EcuVariant |
GLOBAL_NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
ID (defined in Id) | Id |
IMPORT_REFS (defined in EcuSharedData) | EcuSharedData |
initialize(ODXRoot odx) | EcuVariant | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
NegResponses (defined in EcuSharedData) | EcuSharedData |
Odx | Id |
Parent (defined in EcuVariant) | EcuVariant |
PARENT_REFS (defined in EcuVariant) | EcuVariant |
POS_RESPONSES (defined in EcuSharedData) | EcuSharedData |
PosResponses (defined in EcuSharedData) | EcuSharedData |
Requests (defined in EcuSharedData) | EcuSharedData |
REQUESTS_ (defined in EcuSharedData) | EcuSharedData |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_CHARTS (defined in EcuSharedData) | EcuSharedData |
StateCharts (defined in EcuSharedData) | EcuSharedData |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EcuVariantPatternContainer Class Reference

  • Diagnose
  • ODX
  • EcuVariantPatternContainer
Properties | List of all members
EcuVariantPatternContainer Class Reference

ECU variant pattern container. More...

Properties

List< MatchingParameterContainer > MATCHING_PARAMETERS [getset]

Detailed Description

ECU variant pattern container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EcuVariantPatternContainer
EcuVariantPatternContainer Member List

This is the complete list of members for EcuVariantPatternContainer, including all inherited members.

EcuVariantPatternContainer() (defined in EcuVariantPatternContainer) | EcuVariantPatternContainer
MATCHING_PARAMETERS (defined in EcuVariantPatternContainer) | EcuVariantPatternContainer


ASAP2Library interface: EndOfPDUField Class Reference

  • Diagnose
  • ODX
  • EndOfPDUField
Public Member Functions | Public Attributes | Properties | List of all members
EndOfPDUField Class Reference

End of PDU filed definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef BASIC_STRUCTURE_REF

Properties

Structure | BasicStructureRef [get]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

End of PDU filed definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EndOfPDUField
EndOfPDUField Member List

This is the complete list of members for EndOfPDUField, including all inherited members.

BASIC_STRUCTURE_REF (defined in EndOfPDUField) | EndOfPDUField |
BasicStructureRef (defined in EndOfPDUField) | EndOfPDUField |
buildRefs(ODXRoot odx) (defined in EndOfPDUField) | EndOfPDUField |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | EndOfPDUField | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EnvDataDesc Class Reference

  • Diagnose
  • ODX
  • EnvDataDesc
Public Member Functions | Public Attributes | Properties | List of all members
EnvDataDesc Class Reference

Environment data description. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

List< IdRef > | ENV_DATA_REFS
SnRef | PARAM_SNREF

Properties

List< EnvDataParamContainer > | ENV_DATAS [getset]
List< EnvDataParamContainer > | EnvDataRefs = new List<EnvDataParamContainer>() [getset]
ParBase | ParamRef [get]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Environment data description.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EnvDataDesc
EnvDataDesc Member List

This is the complete list of members for EnvDataDesc, including all inherited members.

buildRefs(ODXRoot odx) (defined in EnvDataDesc) | EnvDataDesc |
ENV_DATA_REFS (defined in EnvDataDesc) | EnvDataDesc |
ENV_DATAS (defined in EnvDataDesc) | EnvDataDesc |
EnvDataRefs (defined in EnvDataDesc) | EnvDataDesc |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PARAM_SNREF (defined in EnvDataDesc) | EnvDataDesc |
ParamRef (defined in EnvDataDesc) | EnvDataDesc |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: EnvDataParamContainer Class Reference

  • Diagnose
  • ODX
  • EnvDataParamContainer
Properties | List of all members
EnvDataParamContainer Class Reference

Environment data parameter container. More...

Properties

List< uint > | DTCs [getset]
- Properties inherited from ParamContainer
List< ParBase > | PARAMS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from ParamContainer
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Environment data parameter container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • EnvDataParamContainer
EnvDataParamContainer Member List

This is the complete list of members for EnvDataParamContainer, including all inherited members.

DESC | NamedDescId |
Description | NamedDescId |
DTCs (defined in EnvDataParamContainer) | EnvDataParamContainer |
EnvDataParamContainer() (defined in EnvDataParamContainer) | EnvDataParamContainer |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | ParamContainer | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
ParamContainer() (defined in ParamContainer) | ParamContainer |
PARAMS (defined in ParamContainer) | ParamContainer |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: Filter Struct Reference

  • Diagnose
  • ODX
  • Filter
Properties | List of all members
Filter Struct Reference

Filter definition. More...

Properties

string | FILTER_END [getset]
string | FILTER_START [getset]

Detailed Description

Filter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Filter
Filter Member List

This is the complete list of members for Filter, including all inherited members.

FILTER_END (defined in Filter) | Filter
FILTER_START (defined in Filter) | Filter


ASAP2Library interface: Flash Class Reference

  • Diagnose
  • ODX
  • Flash
Properties | List of all members
Flash Class Reference

Flash data definition. More...

Properties

EcuMemConnector[] | ECU_MEM_CONNECTORS [getset]
EcuMem[] | ECU_MEMS [getset]
- Properties inherited from BaseDocInfoContainer
AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Flash data definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Flash
Flash Member List

This is the complete list of members for Flash, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
DESC | NamedDescId |
Description | NamedDescId |
ECU_MEM_CONNECTORS (defined in Flash) | Flash |
ECU_MEMS (defined in Flash) | Flash |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: FlashDataExtern Class Reference

  • Diagnose
  • ODX
  • FlashDataExtern
Properties | List of all members
FlashDataExtern Class Reference

Flash data definition (External). More...

Properties

DataFile | DATAFILE [getset]
DataFormat | DATAFORMAT [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Flash data definition (External).


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • FlashDataExtern
FlashDataExtern Member List

This is the complete list of members for FlashDataExtern, including all inherited members.

DATAFILE (defined in FlashDataExtern) | FlashDataExtern |
DATAFORMAT (defined in FlashDataExtern) | FlashDataExtern |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: FlashDataIntern Class Reference

  • Diagnose
  • ODX
  • FlashDataIntern
Properties | List of all members
FlashDataIntern Class Reference

Flash data definition (Internal). More...

Properties

byte[]? | Data [getset]
Gets or sets binary data.
string | DATA_ [getset]
Binary data
DataFormat | DATAFORMAT [getset]
TypeValueElement | ENCRYPT_COMPRESS_METHOD [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Flash data definition (Internal).


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • FlashDataIntern
FlashDataIntern Member List

This is the complete list of members for FlashDataIntern, including all inherited members.

Data | FlashDataIntern |
DATA_ | FlashDataIntern |
DATAFORMAT (defined in FlashDataIntern) | FlashDataIntern |
ENCRYPT_COMPRESS_METHOD (defined in FlashDataIntern) | FlashDataIntern |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: FunctClass Class Reference

  • Diagnose
  • ODX
  • FunctClass
Public Member Functions | List of all members
FunctClass Class Reference

ODX function class element. More...

Public Member Functions

int | CompareTo (FunctClass other)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Additional Inherited Members

- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

ODX function class element.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • FunctClass
FunctClass Member List

This is the complete list of members for FunctClass, including all inherited members.

CompareTo(FunctClass other) (defined in FunctClass) | FunctClass |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: FunctionalGroup Class Reference

  • Diagnose
  • ODX
  • FunctionalGroup
Public Member Functions | Public Attributes | Properties | List of all members
FunctionalGroup Class Reference

Functional group definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from EcuSharedData
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef[] | PARENT_REFS
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

List< IId > | ParentRefs = new List<IId>() [get]
- Properties inherited from EcuSharedData
List< COMParamRef > | COMPARAM_REFS [getset]
List< COMParamRef > | ComparamRefs = new List<COMParamRef>() [get]
List< DiagService > | DIAG_COMMS [getset]
DiagDataDictionarySpec | DIAG_DATA_DICTIONARY_SPEC [getset]
DiagDataDictSpec | DiagDataDictionarySpec = new DiagDataDictSpec() [get]
List< DiagService > | DiagServices = new List<DiagService>() [get]
List< FunctClass > | FUNCT_CLASSS [getset]
List< FunctClass > | FunctClasses = new List<FunctClass>() [get]
List< ParamContainer > | GLOBAL_NEG_RESPONSES [getset]
List< IdRef > | IMPORT_REFS [getset]
List< ParamContainer > | NEG_RESPONSES [getset]
List< ParamContainer > | NegResponses = new List<ParamContainer>() [get]
List< ParamContainer > | POS_RESPONSES [getset]
List< ParamContainer > | PosResponses = new List<ParamContainer>() [get]
List< ParamContainer > | Requests = new List<ParamContainer>() [get]
List< ParamContainer > | REQUESTS_ [getset]
List< ChartContainer > | STATE_CHARTS [getset]
List< ChartContainer > | StateCharts = new List<ChartContainer>() [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Functional group definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • FunctionalGroup
FunctionalGroup Member List

This is the complete list of members for FunctionalGroup, including all inherited members.

buildRefs(ODXRoot odx) (defined in FunctionalGroup) | FunctionalGroup |
COMPARAM_REFS (defined in EcuSharedData) | EcuSharedData |
ComparamRefs (defined in EcuSharedData) | EcuSharedData |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_COMMS (defined in EcuSharedData) | EcuSharedData |
DIAG_DATA_DICTIONARY_SPEC (defined in EcuSharedData) | EcuSharedData |
DiagDataDictionarySpec (defined in EcuSharedData) | EcuSharedData |
DiagServices (defined in EcuSharedData) | EcuSharedData |
FUNCT_CLASSS (defined in EcuSharedData) | EcuSharedData |
FunctClasses (defined in EcuSharedData) | EcuSharedData |
GLOBAL_NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
ID (defined in Id) | Id |
IMPORT_REFS (defined in EcuSharedData) | EcuSharedData |
initialize(ODXRoot odx) | EcuSharedData | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
NegResponses (defined in EcuSharedData) | EcuSharedData |
Odx | Id |
PARENT_REFS (defined in FunctionalGroup) | FunctionalGroup |
ParentRefs (defined in FunctionalGroup) | FunctionalGroup |
POS_RESPONSES (defined in EcuSharedData) | EcuSharedData |
PosResponses (defined in EcuSharedData) | EcuSharedData |
Requests (defined in EcuSharedData) | EcuSharedData |
REQUESTS_ (defined in EcuSharedData) | EcuSharedData |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_CHARTS (defined in EcuSharedData) | EcuSharedData |
StateCharts (defined in EcuSharedData) | EcuSharedData |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: FunctionalGroupRef Class Reference

  • Diagnose
  • ODX
  • FunctionalGroupRef
List of all members
FunctionalGroupRef Class Reference

Reference to functional group used in PARENT-REFS. More...

Additional Inherited Members

- Public Member Functions inherited from IdRef
IdRef (string idRef)
override string | ToString ()
- Properties inherited from IdRef
string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]

Detailed Description

Reference to functional group used in PARENT-REFS.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • FunctionalGroupRef
FunctionalGroupRef Member List

This is the complete list of members for FunctionalGroupRef, including all inherited members.

DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef() (defined in IdRef) | IdRef
IdRef(string idRef) (defined in IdRef) | IdRef
ToString() (defined in IdRef) | IdRef


ASAP2Library interface: IcEcuProxy Class Reference

  • Diagnose
  • ODX
  • IcEcuProxy
List of all members
IcEcuProxy Class Reference

Info Component ECU-PROXY. More...

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Info Component ECU-PROXY.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IcEcuProxy
IcEcuProxy Member List

This is the complete list of members for IcEcuProxy, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: IcModelYear Class Reference

  • Diagnose
  • ODX
  • IcModelYear
List of all members
IcModelYear Class Reference

Info Component MODEL-YEAR. More...

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Info Component MODEL-YEAR.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IcModelYear
IcModelYear Member List

This is the complete list of members for IcModelYear, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: IcOEM Class Reference

  • Diagnose
  • ODX
  • IcOEM
List of all members
IcOEM Class Reference

Info Component OEM. More...

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Info Component OEM.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IcOEM
IcOEM Member List

This is the complete list of members for IcOEM, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: IcVehicleModel Class Reference

  • Diagnose
  • ODX
  • IcVehicleModel
List of all members
IcVehicleModel Class Reference

Info Component VEHICLE-MODEL. More...

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Info Component VEHICLE-MODEL.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IcVehicleModel
IcVehicleModel Member List

This is the complete list of members for IcVehicleModel, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: IcVehicleType Class Reference

  • Diagnose
  • ODX
  • IcVehicleType
List of all members
IcVehicleType Class Reference

Info Component VEHICLE-TYPE. More...

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Info Component VEHICLE-TYPE.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IcVehicleType
IcVehicleType Member List

This is the complete list of members for IcVehicleType, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: Id Class Reference

  • Diagnose
  • ODX
  • Id
Public Member Functions | Properties | List of all members
Id Class Reference

Id tagged ODX element. More...

Public Member Functions

virtual void initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Properties

string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Id tagged ODX element.

Member Function Documentation

◆ initialize()

virtual void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Implements IId.

Reimplemented in ProtStack, Protocol, ParamContainer, Structure, EndOfPDUField, DataObjectProp, Mux, DiagService, EcuVariant, BaseVariant, EcuSharedData, and Session.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Id
Id Member List

This is the complete list of members for Id, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
Odx | Id |


ASAP2Library interface: Ident Class Reference

  • Diagnose
  • ODX
  • Ident
Properties | List of all members
Ident Class Reference

Ident definition. More...

Properties

TypeValueElement | IDENT_VALUE [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Ident definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Ident
Ident Member List

This is the complete list of members for Ident, including all inherited members.

ID (defined in Id) | Id |
IDENT_VALUE (defined in Ident) | Ident |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: IdentDesc Class Reference

  • Diagnose
  • ODX
  • IdentDesc
Public Member Functions | Public Attributes | Properties | List of all members
IdentDesc Class Reference

Ident descriptor definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

SnRef | DIAG_COMM_SNREF
SnRef | OUT_PARAM_IF_SNREF

Properties

DiagService | DiagCommRef [get]
SnRef | IDENT_IF_SNREF [getset]
ParBase | OutParamIfRef [get]

Detailed Description

Ident descriptor definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IdentDesc
IdentDesc Member List

This is the complete list of members for IdentDesc, including all inherited members.

buildRefs(ODXRoot odx) (defined in IdentDesc) | IdentDesc
DIAG_COMM_SNREF (defined in IdentDesc) | IdentDesc
DiagCommRef (defined in IdentDesc) | IdentDesc
IDENT_IF_SNREF (defined in IdentDesc) | IdentDesc
OUT_PARAM_IF_SNREF (defined in IdentDesc) | IdentDesc
OutParamIfRef (defined in IdentDesc) | IdentDesc


ASAP2Library interface: IdentifierRecord Class Reference

  • Diagnose
  • ODX
  • IdentifierRecord
Public Member Functions | Properties | List of all members
IdentifierRecord Class Reference

Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22) More...

Public Member Functions

void | toPhysical (byte[] data)
Computes all physical values from a received ReadDataByIdentifier response. More...
override string | ToString ()

Properties

ushort | Identifier [get]
(ReadDataBy)Identifier key.
string | Name [get]
Name of the (ReadDataBy)Identifier record.
List< ParamDataInfo > | ResponseParamInfo [get]
(Flat) List of response parameters

Detailed Description

Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22)

Member Function Documentation

◆ toPhysical()

void toPhysical ( byte[] data )

Computes all physical values from a received ReadDataByIdentifier response.

Parameters
data The received response


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IdentifierRecord
IdentifierRecord Member List

This is the complete list of members for IdentifierRecord, including all inherited members.

Identifier | IdentifierRecord
Name | IdentifierRecord
ResponseParamInfo | IdentifierRecord
toPhysical(byte[] data) | IdentifierRecord
ToString() (defined in IdentifierRecord) | IdentifierRecord


ASAP2Library interface: IDescription Interface Reference

  • Diagnose
  • ODX
  • IDescription
Properties | List of all members
IDescription Interface Reference

Used to indicate description supporting ODX nodes. More...

Properties

string Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Used to indicate description supporting ODX nodes.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IDescription
IDescription Member List

This is the complete list of members for IDescription, including all inherited members.

Description IDescription


ASAP2Library interface: IdRef Class Reference

  • Diagnose
  • ODX
  • IdRef
Public Member Functions | Properties | List of all members
IdRef Class Reference

Id Reference. More...

Public Member Functions

IdRef (string idRef)
override string ToString ()

Properties

string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]

Detailed Description

Id Reference.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IdRef
IdRef Member List

This is the complete list of members for IdRef, including all inherited members.

DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef() (defined in IdRef) | IdRef
IdRef(string idRef) (defined in IdRef) | IdRef
ToString() (defined in IdRef) | IdRef


ASAP2Library interface: IId Interface Reference

  • Diagnose
  • ODX
  • IId
Public Member Functions | Properties | List of all members
IId Interface Reference

Interface used to initialize ID dictionary while loading the ODX file. More...

Public Member Functions

void initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Properties

string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Interface used to initialize ID dictionary while loading the ODX file.

ANy ODX instance with an ID attribute must implement this interface.

Member Function Documentation

◆ initialize()

void initialize ( ODXRoot odx )

Initialises the ODX node instance.

Parameters
odx The ODX root node

Implemented in Id, ProtStack, ParIdBase, Protocol, ParamContainer, Structure, EndOfPDUField, DataObjectProp, Mux, DiagService, EcuVariant, BaseVariant, EcuSharedData, and Session.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • IId
IId Member List

This is the complete list of members for IId, including all inherited members.

ID | IId
initialize(ODXRoot odx) | IId
Odx | IId


ASAP2Library interface: InternalConstr Class Reference

  • Diagnose
  • ODX
  • InternalConstr
Properties | List of all members
InternalConstr Class Reference

Internal constraints definition. More...

Properties

ScaleConstr[] | SCALE_CONSTRS [getset]
- Properties inherited from LimitBase
string??? | Description [getset]
Usually an HTML coded node description.
string? | LOWER_LIMIT [getset]
string? | UPPER_LIMIT [getset]
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from LimitBase
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
double | LowerLimit
double | UpperLimit

Detailed Description

Internal constraints definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • InternalConstr
InternalConstr Member List

This is the complete list of members for InternalConstr, including all inherited members.

DESC | LimitBase
Description | LimitBase
LOWER_LIMIT (defined in LimitBase) | LimitBase
LowerLimit (defined in LimitBase) | LimitBase
SCALE_CONSTRS (defined in InternalConstr) | InternalConstr
UPPER_LIMIT (defined in LimitBase) | LimitBase
UpperLimit (defined in LimitBase) | LimitBase


ASAP2Library interface: LimitBase Class Reference

  • Diagnose
  • ODX
  • LimitBase
Public Attributes | Properties | List of all members
LimitBase Class Reference

Base class for Limit containing scales. More...

Public Attributes

XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
double | LowerLimit
double | UpperLimit

Properties

string??? | Description [getset]
Usually an HTML coded node description.
string? | LOWER_LIMIT [getset]
string? | UPPER_LIMIT [getset]
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Base class for Limit containing scales.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • LimitBase
LimitBase Member List

This is the complete list of members for LimitBase, including all inherited members.

DESC | LimitBase
Description | LimitBase
LOWER_LIMIT (defined in LimitBase) | LimitBase
LowerLimit (defined in LimitBase) | LimitBase
UPPER_LIMIT (defined in LimitBase) | LimitBase
UpperLimit (defined in LimitBase) | LimitBase


ASAP2Library interface: MatchingParameterContainer Class Reference

  • Diagnose
  • ODX
  • MatchingParameterContainer
Public Member Functions | Public Attributes | Properties | List of all members
MatchingParameterContainer Class Reference

Matching parameter container. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

SnRef | DIAG_COMM_SNREF
SnRef | OUT_PARAM_IF_SNREF

Properties

DiagService | DiagCommRef [get]
string | EXPECTED_VALUE [getset]
ParBase | ParBaseRef [get]

Detailed Description

Matching parameter container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • MatchingParameterContainer
MatchingParameterContainer Member List

This is the complete list of members for MatchingParameterContainer, including all inherited members.

buildRefs(ODXRoot odx) (defined in MatchingParameterContainer) | MatchingParameterContainer
DIAG_COMM_SNREF (defined in MatchingParameterContainer) | MatchingParameterContainer
DiagCommRef (defined in MatchingParameterContainer) | MatchingParameterContainer
EXPECTED_VALUE (defined in MatchingParameterContainer) | MatchingParameterContainer
MatchingParameterContainer() (defined in MatchingParameterContainer) | MatchingParameterContainer
OUT_PARAM_IF_SNREF (defined in MatchingParameterContainer) | MatchingParameterContainer
ParBaseRef (defined in MatchingParameterContainer) | MatchingParameterContainer


ASAP2Library interface: Mem Class Reference

  • Diagnose
  • ODX
  • Mem
Properties | List of all members
Mem Class Reference

Memory definition. More...

Properties

DataBlock[] | DATABLOCKS [getset]
NamedId[] | FLASHDATAS [getset]
Session[] | SESSIONS [getset]

Detailed Description

Memory definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Mem
Mem Member List

This is the complete list of members for Mem, including all inherited members.

DATABLOCKS (defined in Mem) | Mem
FLASHDATAS (defined in Mem) | Mem
SESSIONS (defined in Mem) | Mem


ASAP2Library interface: MemberLogicalLink Class Reference

  • Diagnose
  • ODX
  • MemberLogicalLink
List of all members
MemberLogicalLink Class Reference

Member logical link type definition. More...

Detailed Description

Member logical link type definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • MemberLogicalLink
MemberLogicalLink Member List

This is the complete list of members for MemberLogicalLink, including all inherited members.

BASE_VARIANT_REF (defined in LogicalLink) | LogicalLink |
BaseVariantRef (defined in LogicalLink) | LogicalLink |
buildRefs(ODXRoot odx) (defined in LogicalLink) | LogicalLink |
buildRefs(ODXRoot odx) (defined in IBuildReferences) | IBuildReferences |
GATEWAY_LOGICAL_LINK_REFS (defined in LogicalLink) | LogicalLink |
GatewayLogicalLinkRefs (defined in LogicalLink) | LogicalLink |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PHYSICAL_VEHICLE_LINK_REF (defined in LogicalLink) | LogicalLink |
PkysicalVehicleLinkRef (defined in LogicalLink) | LogicalLink |
PROTOCOL_REF (defined in LogicalLink) | LogicalLink |
ProtocolRef (defined in LogicalLink) | LogicalLink |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: Modification Class Reference

  • Diagnose
  • ODX
  • Modification
Public Member Functions | Properties | List of all members
Modification Class Reference

Definition of a document revision modification. More...

Public Member Functions

Modification (string change, string reason)

Properties

string | CHANGE [getset]
string | REASON [getset]

Detailed Description

Definition of a document revision modification.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Modification
Modification Member List

This is the complete list of members for Modification, including all inherited members.

CHANGE (defined in Modification) | Modification
Modification() (defined in Modification) | Modification
Modification(string change, string reason) (defined in Modification) | Modification
REASON (defined in Modification) | Modification


ASAP2Library interface: Mux Class Reference

  • Diagnose
  • ODX
  • Mux
Public Member Functions | Properties | List of all members
Mux Class Reference

Multiplexer definition. More...

Public Member Functions

override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Properties

byte | BYTE_POSITION [getset]
Case[] | CASES [getset]
DefaultCase | DEFAULT_CASE [getset]
SwitchKey | SWITCH_KEY [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from NamedDescId
XmlNode DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Multiplexer definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Mux
Mux Member List

This is the complete list of members for Mux, including all inherited members.

BYTE_POSITION (defined in Mux) | Mux |
CASES (defined in Mux) | Mux |
DEFAULT_CASE (defined in Mux) | Mux |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Mux | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
SWITCH_KEY (defined in Mux) | Mux |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: NamedDescId Class Reference

  • Diagnose
  • ODX
  • NamedDescId
Public Attributes | Properties | List of all members
NamedDescId Class Reference

ODX base class for named elements with description. More...

Public Attributes

XmlNode DESC
This is only the XML representation, use the Description property to access its contents!

Properties

string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

ODX base class for named elements with description.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • NamedDescId
NamedDescId Member List

This is the complete list of members for NamedDescId, including all inherited members.

DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: NamedId Class Reference

  • Diagnose
  • ODX
  • NamedId
Public Member Functions | Properties | List of all members
NamedId Class Reference

ODX base class for named elements. More...

Public Member Functions

override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Properties

string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

ODX base class for named elements.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • NamedId
NamedId Member List

This is the complete list of members for NamedId, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: NonCompliantException Class Reference

  • Diagnose
  • ODX
  • NonCompliantException
List of all members
NonCompliantException Class Reference

Exception class for non ODX compliant files. More...

Detailed Description

Exception class for non ODX compliant files.

Occurs, if the input file is not ODX 2.0.1 compliant and therefore not usable.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • NonCompliantException
NonCompliantException Member List

This is the complete list of members for NonCompliantException, including all inherited members.


ASAP2Library interface: NotInheritedDiagComm Struct Reference

  • Diagnose
  • ODX
  • NotInheritedDiagComm
Public Member Functions | Public Attributes | Properties | List of all members
NotInheritedDiagComm Struct Reference

Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

SnRef DIAG_COMM_SNREF

Properties

DiagService DiagCommRef [get]

Detailed Description

Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • NotInheritedDiagComm
NotInheritedDiagComm Member List

This is the complete list of members for NotInheritedDiagComm, including all inherited members.

buildRefs(ODXRoot odx) (defined in NotInheritedDiagComm) | NotInheritedDiagComm
DIAG_COMM_SNREF (defined in NotInheritedDiagComm) | NotInheritedDiagComm
DiagCommRef (defined in NotInheritedDiagComm) | NotInheritedDiagComm


ASAP2Library interface: ODXFile Class Reference

  • Diagnose
  • ODX
  • ODXFile
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
ODXFile Class Reference

Open Diagnostic eXchange format (ODX) reader/writer. More...

Public Member Functions

string | buildHtmlFromDescription (string content)
Builds the html description with the resource defined css configuration. More...
string | getOverviewAsHtml ()
Gets an file description overview in html format. More...
void | save (string path)
Saves the ODX data to the specified file. More...

Static Public Member Functions

static ODXRoot | getPDXRoot (string path, out IList< string > files)
Gets the DIAG_LAYER_CONATINER Root file and available files to reference. More...
static ODXFile | open (ODXRoot root, IList< string > files)
Opens a ODX file and returns an ODXFile instance. More...
static ODXFile | open (Stream mainOdxStream, IEnumerable< Stream > odxReferencesStream=null)
Opens a ODX file and returns a ODXFile instance with external references. More...
static ODXFile | open (string path)
Opens a ODX file and returns a ODXFile instance. More...

Public Attributes

readonly ODXRoot ODX
Gets the ODX root node.

Properties

string SourceFile [get]
Gets the original ODX file path.

Detailed Description

Open Diagnostic eXchange format (ODX) reader/writer.

Member Function Documentation

◆ buildHtmlFromDescription()

string buildHtmlFromDescription ( string content )

Builds the html description with the resource defined css configuration.

Resolves external document references.

Parameters
content content to display in Html format
Returns
html formatted string

◆ getOverviewAsHtml()

string getOverviewAsHtml ( )

Gets an file description overview in html format.

Returns
HTML string representing an ODX file content overview

◆ getPDXRoot()

static ODXRoot getPDXRoot | ( | string | path,
 |  | out IList< string > | files
 | ) |  |
static

Gets the DIAG_LAYER_CONATINER Root file and available files to reference.

Parameters
path | Path to the extracted pdx content
subODXs | available referenced files
Returns
The root ODX instance or null if nothing is found

◆ open() [1/3]

static ODXFile open | ( | ODXRoot | root,
 |  | IList< string > | files
 | ) |  |
static

Opens a ODX file and returns an ODXFile instance.

Use getPDXRoot to get the parameters from an extracted PDX archive to call this method.

Parameters
root | The ODX root
files | Set of potential ODX files in the file path
Returns
A new ODXFile instance or null if failed

◆ open() [2/3]

static ODXFile open | ( | Stream | mainOdxStream,
 |  | IEnumerable< Stream > | odxReferencesStream = null
 | ) |  |
static

Opens a ODX file and returns a ODXFile instance with external references.

Parameters
mainOdxStream | Main odx stream to read from - DLC must contain base variant
odxReferencesStream | Referenced streams
Returns
A new ODXFile instance or null if failed

◆ open() [3/3]

static ODXFile open ( string path )
static

Opens a ODX file and returns a ODXFile instance.

Parameters
path the fully qualified odx filename
Returns
A new ODXFile instance or null if failed

◆ save()

void save ( string path )

Saves the ODX data to the specified file.

Parameters
path the fully qualified path to the destination file


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ODXFile
ODXFile Member List

This is the complete list of members for ODXFile, including all inherited members.

buildHtmlFromDescription(string content) | ODXFile |
getOverviewAsHtml() | ODXFile |
getPDXRoot(string path, out IList< string > files) | ODXFile | static
ODX | ODXFile |
open(string path) | ODXFile | static
open(ODXRoot root, IList< string > files) | ODXFile | static
open(Stream mainOdxStream, IEnumerable< Stream > odxReferencesStream=null) | ODXFile | static
save(string path) | ODXFile |
SourceFile | ODXFile |


ASAP2Library interface: ODXRoot Class Reference

  • Diagnose
  • ODX
  • ODXRoot
Public Member Functions | Public Attributes | Properties | List of all members
ODXRoot Class Reference

ODX root. More...

Public Member Functions

void | addModification (Modification mod, string revision, string stateText, TeamMember tm, CompanyData company)
Adds a new modification instance. More...
void | buildNewId (IId idInstance)
Gets a new valid Id (used for creating instances). More...
void | changeId (IId odxObjectToChangeId, string newIdRefValue)
Changes the id of an existing object. More...
IId | findId (string id)
Finds the ODX object with the specified ID. More...
Dtc | getDTC (int troubleCode, string variantName=null)
Gets a defined DTC for the specified trouble code. More...
IDictionary< int, Dtc > | getDTCs (string variantName=null)
Gets all defined DTCs. More...
IDictionary< byte, string > | getNegResCodes (string variantName=null)
Gets defined negative response codes. More...
List< DiagService > | getSecurityAccessRequests (string variantName=null)
DiagService | getService (byte serviceId, string variantName=null, byte subfunction=byte.MaxValue, ushort identifier=ushort.MaxValue, bool filterNoResponse=true)
Get the specified service definition. More...
DiagService | getService (byte serviceId, ushort identifier, string variantName=null)
Get the specified service definition. More...
DiagService[] | getServices (byte serviceId, string variantName=null, bool filterNoResponse=true)
Gets defined service for the specified service id. More...
EcuVariant | getVariant (string variantName)
Gets a single ECU variant. More...
EcuVariant[] | getVariants (bool includeBaseVariants=false)
Gets defined ECU variants from the ODX definition. More...
override string | ToString ()

Public Attributes

EventHandler< ParserEventArgs > ParserMessage
Register here for parser messages.

Properties

IList< string > | AvailableFiles [getset]
ComParamSpec | COMPARAM_SPEC [getset]
ComParamSubset | COMPARAM_SUBSET [getset]
int | CountErrors [get]
Gets the count of errors occured.
int | CountWarnings [get]
Gets the count of warnings occured.
DiagLayerContainer | DIAG_LAYER_CONTAINER [getset]
IList< ODXRoot > | ExternalReferences [getset]
Gets all initialized ODX files.
Flash | FLASH [getset]
string | MODEL_VERSION [getset]
List< ParserEventArgs > | ParserEvents [getset]
Gets events the ODX object model has created.
Protocol?????? | PhysicalProtocol [get]
Get the first physical protocol defined.
string | SourceFile [getset]
Gets the fully qualified path to the source file.
VehicleInfoSpec | VEHICLE_INFO_SPEC [getset]

Detailed Description

ODX root.

Proides a navigable Object model for ODX files.

  • All direct XML properties are defined in upper case LETTERS.
  • Computed properties are defined in CamelCase Letters.

Member Function Documentation

◆ addModification()

void addModification | ( | Modification | mod,
 |  | string | revision,
 |  | string | stateText,
 |  | TeamMember | tm,
 |  | CompanyData | company
 | ) |  |

Adds a new modification instance.

Parameters
mod | The modification to add
revision | The revision to create (or use)
stateText | The revision state
tm | The (existing or new) team member
company | The (existing or new) company

◆ buildNewId()

void buildNewId ( IId idInstance )

Gets a new valid Id (used for creating instances).

Parameters
idInstance Instance to set the id
Returns
a new unique id

◆ changeId()

void changeId | ( | IId | odxObjectToChangeId,
 |  | string | newIdRefValue
 | ) |  |

Changes the id of an existing object.

Updates automatically all references to the object.

Parameters
odxObjectToChangeId | The object instance to change the id
newIdRefValue | new id reference value

◆ findId()

IId findId ( string id )

Finds the ODX object with the specified ID.

Parameters
id id to find
Returns
Id instance or null if not found

◆ getDTC()

Dtc getDTC | ( | int | troubleCode,
 |  | string | variantName = null
 | ) |  |

Gets a defined DTC for the specified trouble code.

Parameters
troubleCode | raw trouble code (usually a 3-byte value)
variantName | a potential variant name (SHORT_NAME) as a filter
Returns
The DTC instance or null if not found

◆ getDTCs()

IDictionary< int, Dtc > getDTCs ( string variantName = null )

Gets all defined DTCs.

Parameters
variantName a potential variant name (SHORT_NAME) as a filter
Returns
Dictionary of DTCs

◆ getNegResCodes()

IDictionary< byte, string > getNegResCodes ( string variantName = null )

Gets defined negative response codes.

Parameters
variantName a potential variant name (SHORT_NAME) as a filter
Returns
A dictionary mapping error response code to the string definition

◆ getSecurityAccessRequests()

List< DiagService > getSecurityAccessRequests ( string variantName = null )

Parameters
variantName a potential variant name (SHORT_NAME) as a filter
Returns

◆ getService() [1/2]

DiagService getService | ( | byte | serviceId,
 |  | string | variantName = null,
 |  | byte | subfunction = byte.MaxValue,
 |  | ushort | identifier = ushort.MaxValue,
 |  | bool | filterNoResponse = true
 | ) |  |

Get the specified service definition.

Parameters
serviceId | The service ID to get
variantName | a potential variant name (SHORT_NAME) as a filter
subfunction | The subfunction to get
identifier | The identifier to get
filterNoResponse | Filter service requests tagged with 'no response' (duplicated)
Returns
The defined service or null if not found

◆ getService() [2/2]

DiagService getService | ( | byte | serviceId,
 |  | ushort | identifier,
 |  | string | variantName = null
 | ) |  |

Get the specified service definition.

Used for services with no subfunction, but an identifier.

Parameters
serviceId | The service ID to get
identifier | The identifier to get
variantName | a potential variant name (SHORT_NAME) as a filter
Returns
The defined service or null if not found

◆ getServices()

DiagService[] getServices | ( | byte | serviceId,
 |  | string | variantName = null,
 |  | bool | filterNoResponse = true
 | ) |  |

Gets defined service for the specified service id.

This method is usually used if multiple services exists with the same service Id.

Parameters
serviceId | The service ID to get
variantName | a potential variant name (SHORT_NAME) as a filter
filterNoResponse | Filter service requests tagged with 'no response' (usually a duplicate of service requests with response).
Returns
List of defined services

◆ getVariant()

EcuVariant getVariant ( string variantName )

Gets a single ECU variant.

Parameters
variantName Variant name (SHORT_NAME) of the ECU variant
Returns
The ECU variant instance or null if not found

◆ getVariants()

EcuVariant[] getVariants ( bool includeBaseVariants = false )

Gets defined ECU variants from the ODX definition.

Parameters
includeBaseVariants true if base variants should be delivered, too.
Returns
The list of ECU variants


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ODXRoot
ODXRoot Member List

This is the complete list of members for ODXRoot, including all inherited members.

addModification(Modification mod, string revision, string stateText, TeamMember tm, CompanyData company) | ODXRoot
AvailableFiles (defined in ODXRoot) | ODXRoot
buildNewId(IId idInstance) | ODXRoot
changeId(IId odxObjectToChangeId, string newIdRefValue) | ODXRoot
COMPARAM_SPEC (defined in ODXRoot) | ODXRoot
COMPARAM_SUBSET (defined in ODXRoot) | ODXRoot
CountErrors | ODXRoot
CountWarnings | ODXRoot
DIAG_LAYER_CONTAINER (defined in ODXRoot) | ODXRoot
ExternalReferences | ODXRoot
findId(string id) | ODXRoot
FLASH (defined in ODXRoot) | ODXRoot
getDTC(int troubleCode, string variantName=null) | ODXRoot
getDTCs(string variantName=null) | ODXRoot
getNegResCodes(string variantName=null) | ODXRoot
getSecurityAccessRequests(string variantName=null) | ODXRoot
getService(byte serviceId, ushort identifier, string variantName=null) | ODXRoot
getService(byte serviceId, string variantName=null, byte subfunction=byte.MaxValue, ushort identifier=ushort.MaxValue, bool filterNoResponse=true) | ODXRoot
getServices(byte serviceId, string variantName=null, bool filterNoResponse=true) | ODXRoot
getVariant(string variantName) | ODXRoot
getVariants(bool includeBaseVariants=false) | ODXRoot
MODEL_VERSION (defined in ODXRoot) | ODXRoot
ODXRoot() (defined in ODXRoot) | ODXRoot
ParserEvents | ODXRoot
ParserMessage | ODXRoot
PhysicalProtocol | ODXRoot
SourceFile | ODXRoot
ToString() (defined in ODXRoot) | ODXRoot
VEHICLE_INFO_SPEC (defined in ODXRoot) | ODXRoot


ASAP2Library interface: ParamContainer Class Reference

  • Diagnose
  • ODX
  • ParamContainer
Public Member Functions | Properties | List of all members
ParamContainer Class Reference

Paramter container definition. More...

Public Member Functions

override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Properties

List< ParBase > | PARAMS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from NamedDescId
XmlNode DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Paramter container definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.

Reimplemented in Structure.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParamContainer
ParamContainer Member List

This is the complete list of members for ParamContainer, including all inherited members.

DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | ParamContainer | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
ParamContainer() (defined in ParamContainer) | ParamContainer |
PARAMS (defined in ParamContainer) | ParamContainer |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: ParBaseDef Class Reference

  • Diagnose
  • ODX
  • ParBaseDef
Properties | List of all members
ParBaseDef Class Reference

Parameter base definitiob. More...

Properties

uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Parameter base definitiob.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParBaseDef
ParBaseDef Member List

This is the complete list of members for ParBaseDef, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParCodedConst Class Reference

  • Diagnose
  • ODX
  • ParCodedConst
Properties | List of all members
ParCodedConst Class Reference

Coded parameter definition. More...

Properties

long | CODED_VALUE [getset]
DiagCodedTypeBase | DIAG_CODED_TYPE [getset]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Coded parameter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParCodedConst
ParCodedConst Member List

This is the complete list of members for ParCodedConst, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
CODED_VALUE (defined in ParCodedConst) | ParCodedConst
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DIAG_CODED_TYPE (defined in ParCodedConst) | ParCodedConst
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParDynamic Class Reference

  • Diagnose
  • ODX
  • ParDynamic
List of all members
ParDynamic Class Reference

Paramneter with length reference. More...

Detailed Description

Paramneter with length reference.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParDynamic
ParDynamic Member List

This is the complete list of members for ParDynamic, including all inherited members.

DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
LONG_NAME (defined in ParBase) | ParBase
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParIdBase Class Reference

  • Diagnose
  • ODX
  • ParIdBase
Public Member Functions | Properties | List of all members
ParIdBase Class Reference

Base class for ID referenced parameters. More...

Public Member Functions

void initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Properties

string | ID [getset]
ODXRoot | Odx [get]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Base class for ID referenced parameters.

Member Function Documentation

◆ initialize()

void initialize ( ODXRoot odx )

Initialises the ODX node instance.

Parameters
odx The ODX root node

Implements IId.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParIdBase
ParIdBase Member List

This is the complete list of members for ParIdBase, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
ID (defined in ParIdBase) | ParIdBase
initialize(ODXRoot odx) | ParIdBase
LONG_NAME (defined in ParBase) | ParBase
Odx (defined in ParIdBase) | ParIdBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParLength Class Reference

  • Diagnose
  • ODX
  • ParLength
Public Member Functions | Public Attributes | Properties | List of all members
ParLength Class Reference

Paramneter with length reference. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from ParIdBase
void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | DOP_REF
SnRef | DOP_SNREF

Properties

Id | DopRef [get]
- Properties inherited from ParIdBase
string | ID [getset]
ODXRoot | Odx [get]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Paramneter with length reference.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParLength
ParLength Member List

This is the complete list of members for ParLength, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParLength) | ParLength
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DOP_REF (defined in ParLength) | ParLength
DOP_SNREF (defined in ParLength) | ParLength
DopRef (defined in ParLength) | ParLength
ID (defined in ParIdBase) | ParIdBase
initialize(ODXRoot odx) | ParIdBase
LONG_NAME (defined in ParBase) | ParBase
Odx (defined in ParIdBase) | ParIdBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParMatchRequestParam Class Reference

  • Diagnose
  • ODX
  • ParMatchRequestParam
Properties | List of all members
ParMatchRequestParam Class Reference

Matching request parameter. More...

Properties

byte | BYTE_LENGTH [getset]
byte | REQUEST_BYTE_POS [getset]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Matching request parameter.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParMatchRequestParam
ParMatchRequestParam Member List

This is the complete list of members for ParMatchRequestParam, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_LENGTH (defined in ParMatchRequestParam) | ParMatchRequestParam
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
REQUEST_BYTE_POS (defined in ParMatchRequestParam) | ParMatchRequestParam
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParNrcConst Class Reference

  • Diagnose
  • ODX
  • ParNrcConst
Public Member Functions | Properties | List of all members
ParNrcConst Class Reference

Used tp represent Negative response code constants. More...

Public Member Functions

byte getErrorCode ()
Gets the errorcode as byte. More...

Properties

List< long > | CODED_VALUES [getset]
DiagCodedTypeStd | DIAG_CODED_TYPE [getset]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Used tp represent Negative response code constants.

Member Function Documentation

◆ getErrorCode()

byte getErrorCode ( )

Gets the errorcode as byte.

Returns 0 if not defined.

Returns


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParNrcConst
ParNrcConst Member List

This is the complete list of members for ParNrcConst, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
CODED_VALUES (defined in ParNrcConst) | ParNrcConst
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DIAG_CODED_TYPE (defined in ParNrcConst) | ParNrcConst
getErrorCode() | ParNrcConst
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParPhysConst Class Reference

  • Diagnose
  • ODX
  • ParPhysConst
Properties | List of all members
ParPhysConst Class Reference

Physical constant parameter definition. More...

Properties

string | PHYS_CONSTANT_VALUE [getset]
- Properties inherited from ParValue
Id | DopRef [get]
This instance could be of Type DataObjectProp or Structure.
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Additional Inherited Members

- Public Member Functions inherited from ParValue
void | buildRefs (ODXRoot odx)
- Public Attributes inherited from ParValue
IdRef | DOP_REF
SnRef | DOP_SNREF

Detailed Description

Physical constant parameter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParPhysConst
ParPhysConst Member List

This is the complete list of members for ParPhysConst, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParValue) | ParValue
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DOP_REF (defined in ParValue) | ParValue
DOP_SNREF (defined in ParValue) | ParValue
DopRef | ParValue
LONG_NAME (defined in ParBase) | ParBase
PHYS_CONSTANT_VALUE (defined in ParPhysConst) | ParPhysConst
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParReserved Class Reference

  • Diagnose
  • ODX
  • ParReserved
Properties | List of all members
ParReserved Class Reference

Reserved Parameter definition. More...

Properties

ulong | BIT_LENGTH = 8 [getset]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Reserved Parameter definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParReserved
ParReserved Member List

This is the complete list of members for ParReserved, including all inherited members.

BIT_LENGTH (defined in ParReserved) | ParReserved
BIT_POSITION (defined in ParBaseDef) | ParBaseDef
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParSystem Class Reference

  • Diagnose
  • ODX
  • ParSystem
Public Member Functions | Public Attributes | Properties | List of all members
ParSystem Class Reference

Parameter system definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef | DOP_REF
SnRef | DOP_SNREF

Properties

uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
Id | DopRef [get]
This instance could be of Type DataObjectProp or Structure.
SysParmType | SYSPARAM [getset]

Detailed Description

Parameter system definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParSystem
ParSystem Member List

This is the complete list of members for ParSystem, including all inherited members.

BIT_POSITION (defined in ParSystem) | ParSystem
buildRefs(ODXRoot odx) (defined in ParSystem) | ParSystem
BYTE_POSITION (defined in ParSystem) | ParSystem
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DOP_REF (defined in ParSystem) | ParSystem
DOP_SNREF (defined in ParSystem) | ParSystem
DopRef | ParSystem
LONG_NAME (defined in ParBase) | ParBase
SHORT_NAME (defined in ParBase) | ParBase
SYSPARAM (defined in ParSystem) | ParSystem
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParTableEntry Class Reference

  • Diagnose
  • ODX
  • ParTableEntry
Public Member Functions | Public Attributes | Properties | List of all members
ParTableEntry Class Reference

Parameter table entry definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from ParIdBase
void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef TABLE_ROW_REF

Properties

string | ROW_FRAGMENT_ [getset]
RowFragment | RowFragment [getset]
Defines the Row fragment type. More...
TableRow | TableRowRef [get]
- Properties inherited from ParIdBase
string | ID [getset]
ODXRoot | Odx [get]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Parameter table entry definition.

This parameter type should be used for grouping of TABLE-ROWs that is multiple-stage structuring of data.TABLE-ENTRY has an attribute TARGET to indicate whether the ID is also part of the common data structure.The compound data structure is a sequence without a gap.This parameter type can only be used in a structure referenced by a TABLE.

Property Documentation

◆ RowFragment

RowFragment RowFragment
getset

Defines the Row fragment type.

Typed member of the ROW_FRAGMENT_ property.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParTableEntry
ParTableEntry Member List

This is the complete list of members for ParTableEntry, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParTableEntry) | ParTableEntry
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
ID (defined in ParIdBase) | ParIdBase
initialize(ODXRoot odx) | ParIdBase
LONG_NAME (defined in ParBase) | ParBase
Odx (defined in ParIdBase) | ParIdBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
ROW_FRAGMENT_ (defined in ParTableEntry) | ParTableEntry
RowFragment | ParTableEntry
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
TABLE_ROW_REF (defined in ParTableEntry) | ParTableEntry
TableRowRef (defined in ParTableEntry) | ParTableEntry
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParTableKey Class Reference

  • Diagnose
  • ODX
  • ParTableKey
Public Member Functions | Public Attributes | Properties | List of all members
ParTableKey Class Reference

Parameter table key definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from ParIdBase
void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | TABLE_REF
IdRef | TABLE_ROW_REF

Properties

Table | TableRef [get]
TableRow | TableRowRef [get]
- Properties inherited from ParIdBase
string | ID [getset]
ODXRoot | Odx [get]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Parameter table key definition.

A parameter of type TABLE-KEY is the part of the PDU where the KEY(data identifier) has to be read in the case of response or written in the case of request. The parameter can refer the TABLE for dynamic parameter definition or it refers a TABLE- ROW for static definition similar to parameter type PHYS-CONST.The TABLE-KEY-parameter in the response shows the position where the KEY should be extracted using the DATA-OBJECT-PROP referenced by TABLE.The physical result must match with exactly one KEY-value in the TABLE. The TABLE-ROW containing the matching KEY refers the STRUCTURE necessary to the data extraction of all TABLESTRUCT-parameters that belongs to the TABLE-KEY-parameter.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParTableKey
ParTableKey Member List

This is the complete list of members for ParTableKey, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParTableKey) | ParTableKey
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
ID (defined in ParIdBase) | ParIdBase
initialize(ODXRoot odx) | ParIdBase
LONG_NAME (defined in ParBase) | ParBase
Odx (defined in ParIdBase) | ParIdBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
TABLE_REF (defined in ParTableKey) | ParTableKey
TABLE_ROW_REF (defined in ParTableKey) | ParTableKey
TableRef (defined in ParTableKey) | ParTableKey
TableRowRef (defined in ParTableKey) | ParTableKey
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParTableStruct Class Reference

  • Diagnose
  • ODX
  • ParTableStruct
Public Member Functions | Public Attributes | Properties | List of all members
ParTableStruct Class Reference

Parameter table entry definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef TABLE_KEY_REF

Properties

ParTableKey | TableKeyRef [get]
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Parameter table entry definition.

This parameter type defines the position of the data to be extracted by using the TABLEROW-referenced STRUCTURE.The corresponding TABLE-KEY-parameter is referenced by an odx-link.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParTableStruct
ParTableStruct Member List

This is the complete list of members for ParTableStruct, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParTableStruct) | ParTableStruct
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
TABLE_KEY_REF (defined in ParTableStruct) | ParTableStruct
TableKeyRef (defined in ParTableStruct) | ParTableStruct
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: ParValue Class Reference

  • Diagnose
  • ODX
  • ParValue
Public Member Functions | Public Attributes | Properties | List of all members
ParValue Class Reference

Parameter value definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef | DOP_REF
SnRef | DOP_SNREF

Properties

Id | DopRef [get]
This instance could be of Type DataObjectProp or Structure.
- Properties inherited from ParBaseDef
uint | BIT_POSITION [getset]
uint | BYTE_POSITION [getset]
string | PHYSICAL_DEFAULT_VALUE [getset]
string | SEMANTIC [getset]
Coule be one of these values [SUBFUNCTION,SERVICE-ID,ROUTINE-ID,DYN-ID]

Detailed Description

Parameter value definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ParValue
ParValue Member List

This is the complete list of members for ParValue, including all inherited members.

BIT_POSITION (defined in ParBaseDef) | ParBaseDef
buildRefs(ODXRoot odx) (defined in ParValue) | ParValue
BYTE_POSITION (defined in ParBaseDef) | ParBaseDef
DESC (defined in ParBase) | ParBase
Description (defined in ParBase) | ParBase
DOP_REF (defined in ParValue) | ParValue
DOP_SNREF (defined in ParValue) | ParValue
DopRef | ParValue
LONG_NAME (defined in ParBase) | ParBase
PHYSICAL_DEFAULT_VALUE (defined in ParBaseDef) | ParBaseDef
SEMANTIC | ParBaseDef
SHORT_NAME (defined in ParBase) | ParBase
ToString() (defined in ParBase) | ParBase


ASAP2Library interface: PDXIndex Class Reference

  • Diagnose
  • ODX
  • PDXIndex
Classes | Public Types | Public Member Functions | Properties | List of all members
PDXIndex Class Reference

PDX index.xml file. More...

Classes

class | ABLOCK
XML ABLOCK definition. More...
struct | FILE
XML FILE type definition. More...

Public Types

enum UpdType {
NEW , CHANGED , UNCHANGED , UNUSED ,
REUSED , DELETED , UNDEFINED
}
Possible update types.

Public Member Functions

IEnumerable< string > getFiles (string category, string prefixPath)
Gets the referenced files from the index.xml file. More...

Properties

ABLOCK[] | ABLOCKS [getset]
ABLOCK set
string | SHORT_NAME [getset]
Short name

Detailed Description

PDX index.xml file.

Proides the PDX index.xml file content.

Member Function Documentation

◆ getFiles()

IEnumerable< string > getFiles | ( | string | category,
 |  | string | prefixPath
 | ) |  |

Gets the referenced files from the index.xml file.

The prefix path is added to the front

Parameters
category | The ABlock category to filter to
prefixPath | the path to the files
Returns
A set of file paths


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PDXIndex
PDXIndex Member List

This is the complete list of members for PDXIndex, including all inherited members.

ABLOCKS | PDXIndex
getFiles(string category, string prefixPath) | PDXIndex
PDXIndex() (defined in PDXIndex) | PDXIndex
SHORT_NAME | PDXIndex
UpdType enum name | PDXIndex


ASAP2Library interface: PDXIndex.ABLOCK Class Reference

  • Diagnose
  • ODX
  • PDXIndex
  • ABLOCK
Properties | List of all members
PDXIndex.ABLOCK Class Reference

XML ABLOCK definition. More...

Properties

string | CATEGORY = ODX_DATA [getset]
Files category
FILE[] | FILES [getset]
File set
string | SHORT_NAME [getset]
Short name
UpdType | UPD [getset]
Update type

Detailed Description

XML ABLOCK definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PDXIndex
  • ABLOCK
PDXIndex.ABLOCK Member List

This is the complete list of members for PDXIndex.ABLOCK, including all inherited members.

CATEGORY | PDXIndex.ABLOCK
FILES | PDXIndex.ABLOCK
SHORT_NAME | PDXIndex.ABLOCK
UPD | PDXIndex.ABLOCK


ASAP2Library interface: PDXIndex.FILE Struct Reference

  • Diagnose
  • ODX
  • PDXIndex
  • FILE
Properties | List of all members
PDXIndex.FILE Struct Reference

XML FILE type definition. More...

Properties

DateTime | CREATION_DATE [getset]
Creation date
string | MIME_TYPE [getset]
MIME type
string | TEXT [getset]
File name

Detailed Description

XML FILE type definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PDXIndex
  • FILE
PDXIndex.FILE Member List

This is the complete list of members for PDXIndex.FILE, including all inherited members.

CREATION_DATE | PDXIndex.FILE
MIME_TYPE | PDXIndex.FILE
TEXT | PDXIndex.FILE


ASAP2Library interface: PhysicalDimension Class Reference

  • Diagnose
  • ODX
  • PhysicalDimension
Properties | List of all members
PhysicalDimension Class Reference

Defines the physical dimension of a unit. More...

Properties

int | CURRENT_EXP [getset]
int | LENGTH_EXP [getset]
int | LUMINOUS_INTENSITY_EXP [getset]
int | MASS_EXP [getset]
int | MOLAR_AMOUNT_EXP [getset]
int | TEMPERATURE_EXP [getset]
int | TIME_EXP [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Defines the physical dimension of a unit.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysicalDimension
PhysicalDimension Member List

This is the complete list of members for PhysicalDimension, including all inherited members.

CURRENT_EXP (defined in PhysicalDimension) | PhysicalDimension |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LENGTH_EXP (defined in PhysicalDimension) | PhysicalDimension |
LONG_NAME (defined in NamedId) | NamedId |
LUMINOUS_INTENSITY_EXP (defined in PhysicalDimension) | PhysicalDimension |
MASS_EXP (defined in PhysicalDimension) | PhysicalDimension |
MOLAR_AMOUNT_EXP (defined in PhysicalDimension) | PhysicalDimension |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
TEMPERATURE_EXP (defined in PhysicalDimension) | PhysicalDimension |
TIME_EXP (defined in PhysicalDimension) | PhysicalDimension |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: PhysicalType Struct Reference

  • Diagnose
  • ODX
  • PhysicalType
Public Member Functions | Properties | List of all members
PhysicalType Struct Reference

Defines the physical type in a data object property specification. More...

Public Member Functions

override string ToString ()

Properties

BaseDataType | BASE_DATA_TYPE [getset]
string | DISPLAY_RADIX [getset]
int | PRECISION [getset]

Detailed Description

Defines the physical type in a data object property specification.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysicalType
PhysicalType Member List

This is the complete list of members for PhysicalType, including all inherited members.

BASE_DATA_TYPE (defined in PhysicalType) | PhysicalType
DISPLAY_RADIX (defined in PhysicalType) | PhysicalType
PRECISION (defined in PhysicalType) | PhysicalType
ToString() (defined in PhysicalType) | PhysicalType


ASAP2Library interface: PhysMem Class Reference

  • Diagnose
  • ODX
  • PhysMem
Properties | List of all members
PhysMem Class Reference

Physical memory definition. More...

Properties

PhysSegmentBase[] | PHYS_SEGMENTS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Physical memory definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysMem
PhysMem Member List

This is the complete list of members for PhysMem, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PHYS_SEGMENTS (defined in PhysMem) | PhysMem |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: PhysSegmentAddr Class Reference

  • Diagnose
  • ODX
  • PhysSegmentAddr
Properties | List of all members
PhysSegmentAddr Class Reference

Physical memory segment definition with End Address. More...

Properties

string | END_ADDRESS [getset]
- Properties inherited from PhysSegmentBase
string | BLOCK_SIZE [getset]
string | FILLBYTE [getset]
string | START_ADDRESS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Physical memory segment definition with End Address.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysSegmentAddr
PhysSegmentAddr Member List

This is the complete list of members for PhysSegmentAddr, including all inherited members.

BLOCK_SIZE (defined in PhysSegmentBase) | PhysSegmentBase |
END_ADDRESS (defined in PhysSegmentAddr) | PhysSegmentAddr |
FILLBYTE (defined in PhysSegmentBase) | PhysSegmentBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
START_ADDRESS (defined in PhysSegmentBase) | PhysSegmentBase |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: PhysSegmentBase Class Reference

  • Diagnose
  • ODX
  • PhysSegmentBase
Properties | List of all members
PhysSegmentBase Class Reference

Base physical memory segment definition. More...

Properties

string | BLOCK_SIZE [getset]
string | FILLBYTE [getset]
string | START_ADDRESS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Base physical memory segment definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysSegmentBase
PhysSegmentBase Member List

This is the complete list of members for PhysSegmentBase, including all inherited members.

BLOCK_SIZE (defined in PhysSegmentBase) | PhysSegmentBase |
FILLBYTE (defined in PhysSegmentBase) | PhysSegmentBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
START_ADDRESS (defined in PhysSegmentBase) | PhysSegmentBase |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: PhysSegmentSize Class Reference

  • Diagnose
  • ODX
  • PhysSegmentSize
Properties | List of all members
PhysSegmentSize Class Reference

Physical memory segment definition with Size. More...

Properties

string | SIZE [getset]
- Properties inherited from PhysSegmentBase
string | BLOCK_SIZE [getset]
string | FILLBYTE [getset]
string | START_ADDRESS [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Physical memory segment definition with Size.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PhysSegmentSize
PhysSegmentSize Member List

This is the complete list of members for PhysSegmentSize, including all inherited members.

BLOCK_SIZE (defined in PhysSegmentBase) | PhysSegmentBase |
FILLBYTE (defined in PhysSegmentBase) | PhysSegmentBase |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
SIZE (defined in PhysSegmentSize) | PhysSegmentSize |
START_ADDRESS (defined in PhysSegmentBase) | PhysSegmentBase |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: PkysicalVehicleLink Class Reference

  • Diagnose
  • ODX
  • PkysicalVehicleLink
Public Member Functions | Public Attributes | Properties | List of all members
PkysicalVehicleLink Class Reference

Physical vehicle link defintition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef[] | VEHICLE_CONNECTOR_PIN_REFS
readonly List< VehicleConnectorPin > | VehicleConnectorPinRefs = new List<VehicleConnectorPin>()

Properties

string | TYPE [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Physical vehicle link defintition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • PkysicalVehicleLink
PkysicalVehicleLink Member List

This is the complete list of members for PkysicalVehicleLink, including all inherited members.

buildRefs(ODXRoot odx) (defined in PkysicalVehicleLink) | PkysicalVehicleLink |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
TYPE (defined in PkysicalVehicleLink) | PkysicalVehicleLink |
VEHICLE_CONNECTOR_PIN_REFS (defined in PkysicalVehicleLink) | PkysicalVehicleLink |
VehicleConnectorPinRefs (defined in PkysicalVehicleLink) | PkysicalVehicleLink |


ASAP2Library interface: Protocol Class Reference

  • Diagnose
  • ODX
  • Protocol
Public Member Functions | Public Attributes | Properties | List of all members
Protocol Class Reference

Diagnostic Protocol definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from EcuSharedData
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef | COMPARAM_SPEC_REF
readonly List< COMParamRef > | Parameters = new List<COMParamRef>()
SnRef | PROT_STACK_SNREF
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

CANBaudrate | Baudrate [getset]
byte | CANFillerByte = 0xff [getset]
CAN frame fill byte value.
bool | CANFillerByteHandling [getset]
Indicates if a CAN filler byte should be used.
ComParamSpec | COMParamSpecRef [get]
uint | FuncReqCANId = uint.MaxValue [getset]
Functional request raw CAN ID.
uint | P2Client = 50 [getset]
P2 Client timing
uint | P3Client = 50 [getset]
P3 Client timing
uint | PhysReqCANId = uint.MaxValue [getset]
Physical request raw CAN ID.
uint | PhysRespCANId = uint.MaxValue [getset]
Physical response raw CAN ID.
ProtStack | ProtStackRef [get]
string | TYPE [getset]
- Properties inherited from EcuSharedData
List< COMParamRef > | COMPARAM_REFS [getset]
List< COMParamRef > | ComparamRefs = new List<COMParamRef>() [get]
List< DiagService > | DIAG_COMMS [getset]
DiagDataDictionarySpec | DIAG_DATA_DICTIONARY_SPEC [getset]
DiagDataDictSpec | DiagDataDictionarySpec = new DiagDataDictSpec() [get]
List< DiagService > | DiagServices = new List<DiagService>() [get]
List< FunctClass > | FUNCT_CLASSS [getset]
List< FunctClass > | FunctClasses = new List<FunctClass>() [get]
List< ParamContainer > | GLOBAL_NEG_RESPONSES [getset]
List< IdRef > | IMPORT_REFS [getset]
List< ParamContainer > | NEG_RESPONSES [getset]
List< ParamContainer > | NegResponses = new List<ParamContainer>() [get]
List< ParamContainer > | POS_RESPONSES [getset]
List< ParamContainer > | PosResponses = new List<ParamContainer>() [get]
List< ParamContainer > | Requests = new List<ParamContainer>() [get]
List< ParamContainer > | REQUESTS_ [getset]
List< ChartContainer > | STATE_CHARTS [getset]
List< ChartContainer > | StateCharts = new List<ChartContainer>() [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Diagnostic Protocol definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Protocol
Protocol Member List

This is the complete list of members for Protocol, including all inherited members.

Baudrate (defined in Protocol) | Protocol |
buildRefs(ODXRoot odx) (defined in Protocol) | Protocol |
CANFillerByte | Protocol |
CANFillerByteHandling | Protocol |
COMPARAM_REFS (defined in EcuSharedData) | EcuSharedData |
COMPARAM_SPEC_REF (defined in Protocol) | Protocol |
ComparamRefs (defined in EcuSharedData) | EcuSharedData |
COMParamSpecRef (defined in Protocol) | Protocol |
DESC | NamedDescId |
Description | NamedDescId |
DIAG_COMMS (defined in EcuSharedData) | EcuSharedData |
DIAG_DATA_DICTIONARY_SPEC (defined in EcuSharedData) | EcuSharedData |
DiagDataDictionarySpec (defined in EcuSharedData) | EcuSharedData |
DiagServices (defined in EcuSharedData) | EcuSharedData |
FuncReqCANId | Protocol |
FUNCT_CLASSS (defined in EcuSharedData) | EcuSharedData |
FunctClasses (defined in EcuSharedData) | EcuSharedData |
GLOBAL_NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
ID (defined in Id) | Id |
IMPORT_REFS (defined in EcuSharedData) | EcuSharedData |
initialize(ODXRoot odx) | Protocol | virtual
LONG_NAME (defined in NamedId) | NamedId |
NEG_RESPONSES (defined in EcuSharedData) | EcuSharedData |
NegResponses (defined in EcuSharedData) | EcuSharedData |
Odx | Id |
P2Client | Protocol |
P3Client | Protocol |
Parameters (defined in Protocol) | Protocol |
PhysReqCANId | Protocol |
PhysRespCANId | Protocol |
POS_RESPONSES (defined in EcuSharedData) | EcuSharedData |
PosResponses (defined in EcuSharedData) | EcuSharedData |
PROT_STACK_SNREF (defined in Protocol) | Protocol |
Protocol() (defined in Protocol) | Protocol |
ProtStackRef (defined in Protocol) | Protocol |
Requests (defined in EcuSharedData) | EcuSharedData |
REQUESTS_ (defined in EcuSharedData) | EcuSharedData |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STATE_CHARTS (defined in EcuSharedData) | EcuSharedData |
StateCharts (defined in EcuSharedData) | EcuSharedData |
ToString() (defined in NamedId) | NamedId |
TYPE (defined in Protocol) | Protocol |


ASAP2Library interface: ProtocolRef Class Reference

  • Diagnose
  • ODX
  • ProtocolRef
List of all members
ProtocolRef Class Reference

Reference to a diagnostic protocol used in PARENT-REFS. More...

Additional Inherited Members

- Public Member Functions inherited from IdRef
IdRef (string idRef)
override string | ToString ()
- Properties inherited from IdRef
string | DOCREF [getset]
string | DOCTYPE [getset]
Possible values: FLASH, CONTAINER, LAYER, MULTIPLE-ECU-JOB-SPEC, COMPARAM-SPEC, VEHICLE-INFO-SPEC, ECU-CONFIG, FUNCTION-DICTOINARY-SPEC
bool | FailedToLoad [getset]
string | ID_REF [getset]

Detailed Description

Reference to a diagnostic protocol used in PARENT-REFS.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ProtocolRef
ProtocolRef Member List

This is the complete list of members for ProtocolRef, including all inherited members.

DOCREF (defined in IdRef) | IdRef
DOCTYPE | IdRef
FailedToLoad (defined in IdRef) | IdRef
ID_REF (defined in IdRef) | IdRef
IdRef() (defined in IdRef) | IdRef
IdRef(string idRef) (defined in IdRef) | IdRef
ToString() (defined in IdRef) | IdRef


ASAP2Library interface: ProtStack Class Reference

  • Diagnose
  • ODX
  • ProtStack
Public Member Functions | Public Attributes | Properties | List of all members
ProtStack Class Reference

Protocol stack definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef[] | COMPARAM_SUBSET_REFS
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

List< ComParamSubset > | COMParamSubsetRefs = new List<ComParamSubset>() [get]
string | PDU_PROTOCOL_TYPE [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Protocol stack definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ProtStack
ProtStack Member List

This is the complete list of members for ProtStack, including all inherited members.

buildRefs(ODXRoot odx) (defined in ProtStack) | ProtStack |
COMPARAM_SUBSET_REFS (defined in ProtStack) | ProtStack |
COMParamSubsetRefs (defined in ProtStack) | ProtStack |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | ProtStack | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PDU_PROTOCOL_TYPE (defined in ProtStack) | ProtStack |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: RelatedDoc Struct Reference

  • Diagnose
  • ODX
  • RelatedDoc
Properties | List of all members
RelatedDoc Struct Reference

Related document definition. More...

Properties

XDoc XDOC [getset]

Detailed Description

Related document definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • RelatedDoc
RelatedDoc Member List

This is the complete list of members for RelatedDoc, including all inherited members.

XDOC (defined in RelatedDoc) RelatedDoc


ASAP2Library interface: ScaleConstr Class Reference

  • Diagnose
  • ODX
  • ScaleConstr
Public Attributes | Properties | List of all members
ScaleConstr Class Reference

Scale constraints definition. More...

Public Attributes

ValidType | mValidity
- Public Attributes inherited from LimitBase
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!
double | LowerLimit
double | UpperLimit

Properties

string | SHORT_LABEL [getset]
ValidType | Validity [getset]
Defines the Validity. More...
string | VALIDITY_ [getset]
Defines the Validity.
- Properties inherited from LimitBase
string??? | Description [getset]
Usually an HTML coded node description.
string? | LOWER_LIMIT [getset]
string? | UPPER_LIMIT [getset]
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

Scale constraints definition.

Property Documentation

◆ Validity

ValidType Validity
getset

Defines the Validity.

Typed member of the VALIDITY_ property.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • ScaleConstr
ScaleConstr Member List

This is the complete list of members for ScaleConstr, including all inherited members.

DESC | LimitBase
Description | LimitBase
LOWER_LIMIT (defined in LimitBase) | LimitBase
LowerLimit (defined in LimitBase) | LimitBase
mValidity (defined in ScaleConstr) | ScaleConstr
SHORT_LABEL (defined in ScaleConstr) | ScaleConstr
UPPER_LIMIT (defined in LimitBase) | LimitBase
UpperLimit (defined in LimitBase) | LimitBase
Validity | ScaleConstr
VALIDITY_ | ScaleConstr


ASAP2Library interface: Sdg Class Reference

  • Diagnose
  • ODX
  • Sdg
Public Member Functions | Public Attributes | Properties | List of all members
Sdg Class Reference

SD group definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef SDG_CAPTION_REF
Caption reference

Properties

NamedDescId | Caption [get]
The caption (maybe locally defined or by reference).
NamedDescId | SDG_CAPTION [getset]
Caption
Sdg[] | SDGS [getset]
Sub SDGs
XmlNode[] | SDs [getset]

Detailed Description

SD group definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Sdg
Sdg Member List

This is the complete list of members for Sdg, including all inherited members.

buildRefs(ODXRoot odx) (defined in Sdg) | Sdg
Caption | Sdg
SDG_CAPTION | Sdg
SDG_CAPTION_REF | Sdg
SDGS | Sdg
SDs (defined in Sdg) | Sdg


ASAP2Library interface: Security Struct Reference

  • Diagnose
  • ODX
  • Security
Properties | List of all members
Security Struct Reference

Security settings. More...

Properties

TypeValueElement | FW_CHECKSUM [getset]
TypeValueElement | FW_SIGNATURE [getset]
TypeValueElement | SECURITY_METHOD [getset]
TypeValueElement | VALIDITY_FOR [getset]

Detailed Description

Security settings.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Security
Security Member List

This is the complete list of members for Security, including all inherited members.

FW_CHECKSUM (defined in Security) | Security
FW_SIGNATURE (defined in Security) | Security
SECURITY_METHOD (defined in Security) | Security
VALIDITY_FOR (defined in Security) | Security


ASAP2Library interface: Segment Class Reference

  • Diagnose
  • ODX
  • Segment
Properties | List of all members
Segment Class Reference

Data segment definition. More...

Properties

string | SOURCE_END_ADDRESS [getset]
string | SOURCE_START_ADDRESS [getset]
uint | UNCOMPRESSED_SIZE [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Data segment definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Segment
Segment Member List

This is the complete list of members for Segment, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
SOURCE_END_ADDRESS (defined in Segment) | Segment |
SOURCE_START_ADDRESS (defined in Segment) | Segment |
ToString() (defined in NamedId) | NamedId |
UNCOMPRESSED_SIZE (defined in Segment) | Segment |


ASAP2Library interface: Session Class Reference

  • Diagnose
  • ODX
  • Session
Public Member Functions | Public Attributes | Properties | List of all members
Session Class Reference

ECU Session definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Public Attributes

IdRef[] | DATABLOCK_REFS
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

List< DataBlock > | DataBlockRefs = new List<DataBlock>() [get]
Ident[] | EXPECTED_IDENTS [getset]
Security[] | SECURITYS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

ECU Session definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from Id.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Session
Session Member List

This is the complete list of members for Session, including all inherited members.

buildRefs(ODXRoot odx) (defined in Session) | Session |
DATABLOCK_REFS (defined in Session) | Session |
DataBlockRefs (defined in Session) | Session |
DESC | NamedDescId |
Description | NamedDescId |
EXPECTED_IDENTS (defined in Session) | Session |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Session | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SECURITYS (defined in Session) | Session |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: SessionDesc Class Reference

  • Diagnose
  • ODX
  • SessionDesc
Public Member Functions | Public Attributes | Properties | List of all members
SessionDesc Class Reference

Session descriptor definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override string | ToString ()

Public Attributes

SnRef | DIAG_COMM_SNREF
IdRef[] | FLASH_CLASS_REFS
SnRef | SESSION_SNREF

Properties

DiagService | DiagServiceRef [get]
string | DIRECTION [getset]
List< NamedDescId > | FlashClassRefs = new List<NamedDescId>() [get]
string | LONG_NAME [getset]
string | PARTNUMBER [getset]
int | PRIORITY [getset]
Session | SessionRef [get]
string | SHORT_NAME [getset]

Detailed Description

Session descriptor definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • SessionDesc
SessionDesc Member List

This is the complete list of members for SessionDesc, including all inherited members.

buildRefs(ODXRoot odx) (defined in SessionDesc) | SessionDesc
DIAG_COMM_SNREF (defined in SessionDesc) | SessionDesc
DiagServiceRef (defined in SessionDesc) | SessionDesc
DIRECTION (defined in SessionDesc) | SessionDesc
FLASH_CLASS_REFS (defined in SessionDesc) | SessionDesc
FlashClassRefs (defined in SessionDesc) | SessionDesc
LONG_NAME (defined in SessionDesc) | SessionDesc
PARTNUMBER (defined in SessionDesc) | SessionDesc
PRIORITY (defined in SessionDesc) | SessionDesc
SESSION_SNREF (defined in SessionDesc) | SessionDesc
SessionRef (defined in SessionDesc) | SessionDesc
SHORT_NAME (defined in SessionDesc) | SessionDesc
ToString() (defined in SessionDesc) | SessionDesc


ASAP2Library interface: SnRef Class Reference

  • Diagnose
  • ODX
  • SnRef
Properties | List of all members
SnRef Class Reference

SHORT-NAME reference definition. More...

Properties

string SHORT_NAME [getset]

Detailed Description

SHORT-NAME reference definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • SnRef
SnRef Member List

This is the complete list of members for SnRef, including all inherited members.

SHORT_NAME (defined in SnRef) SnRef


ASAP2Library interface: StateTransitionContainer Class Reference

  • Diagnose
  • ODX
  • StateTransitionContainer
Properties | List of all members
StateTransitionContainer Class Reference

State transition container. More...

Properties

SnRef | SOURCE_SNREF [getset]
SnRef | TARGET_SNREF [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

State transition container.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • StateTransitionContainer
StateTransitionContainer Member List

This is the complete list of members for StateTransitionContainer, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
SOURCE_SNREF (defined in StateTransitionContainer) | StateTransitionContainer |
StateTransitionContainer() (defined in StateTransitionContainer) | StateTransitionContainer |
TARGET_SNREF (defined in StateTransitionContainer) | StateTransitionContainer |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: StaticField Class Reference

  • Diagnose
  • ODX
  • StaticField
Public Attributes | Properties | List of all members
StaticField Class Reference

Structure definition. More...

Public Attributes

Structure | BasicStructureRef
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

IdRef | BASIC_STRUCTURE_REF [getset]
long | FIXED_NUMBER_OF_ITEMS [getset]
bool | IS_VISIBLE [getset]
long | ITEM_BYTE_SIZE [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Structure definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • StaticField
StaticField Member List

This is the complete list of members for StaticField, including all inherited members.

BASIC_STRUCTURE_REF (defined in StaticField) | StaticField |
BasicStructureRef (defined in StaticField) | StaticField |
DESC | NamedDescId |
Description | NamedDescId |
FIXED_NUMBER_OF_ITEMS (defined in StaticField) | StaticField |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
IS_VISIBLE (defined in StaticField) | StaticField |
ITEM_BYTE_SIZE (defined in StaticField) | StaticField |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: Structure Class Reference

  • Diagnose
  • ODX
  • Structure
Public Member Functions | Properties | List of all members
Structure Class Reference

Structure definition. More...

Public Member Functions

override void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Member Functions inherited from NamedId
override string | ToString ()

Properties

long | BYTE_SIZE [getset]
bool | IS_VISIBLE [getset]
- Properties inherited from ParamContainer
List< ParBase > | PARAMS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Attributes inherited from NamedDescId
XmlNode DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Structure definition.

Member Function Documentation

◆ initialize()

override void initialize ( ODXRoot odx )
virtual

Initialises the ODX node instance.

Parameters
odx The ODX root node

Reimplemented from ParamContainer.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Structure
Structure Member List

This is the complete list of members for Structure, including all inherited members.

BYTE_SIZE (defined in Structure) | Structure |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Structure | virtual
IS_VISIBLE (defined in Structure) | Structure |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
ParamContainer() (defined in ParamContainer) | ParamContainer |
PARAMS (defined in ParamContainer) | ParamContainer |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: SwitchKey Class Reference

  • Diagnose
  • ODX
  • SwitchKey
Public Member Functions | Public Attributes | Properties | List of all members
SwitchKey Class Reference

Multiplexer switch key definition. More...

Public Member Functions

void buildRefs (ODXRoot odx)

Public Attributes

IdRef DATA_OBJECT_PROP_REF

Properties

byte | BYTE_POSITION [getset]
Id | DataObjectPropRef [get]

Detailed Description

Multiplexer switch key definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • SwitchKey
SwitchKey Member List

This is the complete list of members for SwitchKey, including all inherited members.

buildRefs(ODXRoot odx) (defined in SwitchKey) | SwitchKey
BYTE_POSITION (defined in SwitchKey) | SwitchKey
DATA_OBJECT_PROP_REF (defined in SwitchKey) | SwitchKey
DataObjectPropRef (defined in SwitchKey) | SwitchKey


ASAP2Library interface: Table Class Reference

  • Diagnose
  • ODX
  • Table
Public Member Functions | Public Attributes | Properties | List of all members
Table Class Reference

Table definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | KEY_DOP_REF
IdRef[] | TABLE_ROW_REFs

Properties

Id | KeyDopRef [get]
TableRow[] | ROWS [getset]
List< TableRow > | TableRows = new List<TableRow>() [get]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Table definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Table
Table Member List

This is the complete list of members for Table, including all inherited members.

buildRefs(ODXRoot odx) (defined in Table) | Table |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
KEY_DOP_REF (defined in Table) | Table |
KeyDopRef (defined in Table) | Table |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
ROWS (defined in Table) | Table |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
TABLE_ROW_REFs (defined in Table) | Table |
TableRows (defined in Table) | Table |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: TableRow Class Reference

  • Diagnose
  • ODX
  • TableRow
Public Member Functions | Public Attributes | Properties | List of all members
TableRow Class Reference

Tablerow definition. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef STRUCTURE_REF

Properties

string | KEY [getset]
Structure | StructureRef [get]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Detailed Description

Tablerow definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • TableRow
TableRow Member List

This is the complete list of members for TableRow, including all inherited members.

buildRefs(ODXRoot odx) (defined in TableRow) | TableRow |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
KEY (defined in TableRow) | TableRow |
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
STRUCTURE_REF (defined in TableRow) | TableRow |
StructureRef (defined in TableRow) | TableRow |
ToString() (defined in NamedId) | NamedId |


ASAP2Library interface: TeamMember Class Reference

  • Diagnose
  • ODX
  • TeamMember
Properties | List of all members
TeamMember Class Reference

Definition of a Team member. More...

Properties

string | ADDRESS [getset]
string | CITY [getset]
string | DEPARTMENT [getset]
string | EMAIL [getset]
string | FAX [getset]
string | PHONE [getset]
string | ZIP [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Definition of a Team member.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • TeamMember
TeamMember Member List

This is the complete list of members for TeamMember, including all inherited members.

ADDRESS (defined in TeamMember) | TeamMember |
CITY (defined in TeamMember) | TeamMember |
DEPARTMENT (defined in TeamMember) | TeamMember |
EMAIL (defined in TeamMember) | TeamMember |
FAX (defined in TeamMember) | TeamMember |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PHONE (defined in TeamMember) | TeamMember |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
ZIP (defined in TeamMember) | TeamMember |


ASAP2Library interface: TypeValueElement Struct Reference

  • Diagnose
  • ODX
  • TypeValueElement
Properties | List of all members
TypeValueElement Struct Reference

XML element with a TYPE Attribute and a Value text. More...

Properties

BaseDataType | TYPE [getset]
string | VALUE [getset]

Detailed Description

XML element with a TYPE Attribute and a Value text.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • TypeValueElement
TypeValueElement Member List

This is the complete list of members for TypeValueElement, including all inherited members.

TYPE (defined in TypeValueElement) | TypeValueElement
VALUE (defined in TypeValueElement) | TypeValueElement


ASAP2Library interface: Unit Class Reference

  • Diagnose
  • ODX
  • Unit
Public Member Functions | Public Attributes | Properties | List of all members
Unit Class Reference

ODX Unit element. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override string | ToString ()
- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Public Attributes

IdRef | PHYSICAL_DIMENSION_REF
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Properties

string | DISPLAY_NAME [getset]
double | FACTOR [getset]
double | OFFSET [getset]
PhysicalDimension | PhsyicalDimensionRef [get]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Detailed Description

ODX Unit element.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • Unit
Unit Member List

This is the complete list of members for Unit, including all inherited members.

buildRefs(ODXRoot odx) (defined in Unit) | Unit |
DESC | NamedDescId |
Description | NamedDescId |
DISPLAY_NAME (defined in Unit) | Unit |
FACTOR (defined in Unit) | Unit |
ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
OFFSET (defined in Unit) | Unit |
PhsyicalDimensionRef (defined in Unit) | Unit |
PHYSICAL_DIMENSION_REF (defined in Unit) | Unit |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in Unit) | Unit |


ASAP2Library interface: UnitSpec Class Reference

  • Diagnose
  • ODX
  • UnitSpec
Properties | List of all members
UnitSpec Class Reference

Specification of supported units. More...

Properties

PhysicalDimension[] | PHYSICAL_DIMENSIONS [getset]
Unit[] | UNITS [getset]

Detailed Description

Specification of supported units.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • UnitSpec
UnitSpec Member List

This is the complete list of members for UnitSpec, including all inherited members.

PHYSICAL_DIMENSIONS (defined in UnitSpec) | UnitSpec
UNITS (defined in UnitSpec) | UnitSpec


ASAP2Library interface: UnitSpecs Class Reference

  • Diagnose
  • ODX
  • UnitSpecs
Public Attributes | List of all members
UnitSpecs Class Reference

Non serialized class used internally to hold a UnitSpec instance. More...

Public Attributes

readonly List< PhysicalDimension > | PhysicalDimensions = new List<PhysicalDimension>()
readonly List< Unit > | Units = new List<Unit>()

Detailed Description

Non serialized class used internally to hold a UnitSpec instance.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • UnitSpecs
UnitSpecs Member List

This is the complete list of members for UnitSpecs, including all inherited members.

PhysicalDimensions (defined in UnitSpecs) | UnitSpecs
Units (defined in UnitSpecs) | UnitSpecs
UnitSpecs() (defined in UnitSpecs) | UnitSpecs


ASAP2Library interface: VehicleConnector Class Reference

  • Diagnose
  • ODX
  • VehicleConnector
Public Member Functions | Properties | List of all members
VehicleConnector Class Reference

Vehicle connector definition. More...

Public Member Functions

override string ToString ()

Properties

string | LONG_NAME [getset]
string | SHORT_NAME [getset]
VehicleConnectorPin[] | VEHICLE_CONNECTOR_PINS [getset]

Detailed Description

Vehicle connector definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • VehicleConnector
VehicleConnector Member List

This is the complete list of members for VehicleConnector, including all inherited members.

LONG_NAME (defined in VehicleConnector) | VehicleConnector
SHORT_NAME (defined in VehicleConnector) | VehicleConnector
ToString() (defined in VehicleConnector) | VehicleConnector
VEHICLE_CONNECTOR_PINS (defined in VehicleConnector) | VehicleConnector


ASAP2Library interface: VehicleConnectorPin Class Reference

  • Diagnose
  • ODX
  • VehicleConnectorPin
Properties | List of all members
VehicleConnectorPin Class Reference

Vehicle connector pin definition. More...

Properties

int | PIN_NUMBER [getset]
PinType | TYPE [getset]
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...

Detailed Description

Vehicle connector pin definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • VehicleConnectorPin
VehicleConnectorPin Member List

This is the complete list of members for VehicleConnectorPin, including all inherited members.

ID (defined in Id) | Id |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
PIN_NUMBER (defined in VehicleConnectorPin) | VehicleConnectorPin |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
TYPE (defined in VehicleConnectorPin) | VehicleConnectorPin |


ASAP2Library interface: VehicleInformation Class Reference

  • Diagnose
  • ODX
  • VehicleInformation
Public Member Functions | Public Attributes | Properties | List of all members
VehicleInformation Class Reference

Vehicle information. More...

Public Member Functions

void | buildRefs (ODXRoot odx)
override string | ToString ()

Public Attributes

IdRef[] INFO_COMPONENT_REFS

Properties

List< NamedId > | InfoComponentRefs = new List<NamedId>() [get]
LogicalLink[] | LOGICAL_LINKS [getset]
string | LONG_NAME [getset]
PkysicalVehicleLink[] | PHYSICAL_VEHICLE_LINKS [getset]
string | SHORT_NAME [getset]
VehicleConnector[] | VEHICLE_CONNECTORS [getset]

Detailed Description

Vehicle information.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • VehicleInformation
VehicleInformation Member List

This is the complete list of members for VehicleInformation, including all inherited members.

buildRefs(ODXRoot odx) (defined in VehicleInformation) | VehicleInformation
INFO_COMPONENT_REFS (defined in VehicleInformation) | VehicleInformation
InfoComponentRefs (defined in VehicleInformation) | VehicleInformation
LOGICAL_LINKS (defined in VehicleInformation) | VehicleInformation
LONG_NAME (defined in VehicleInformation) | VehicleInformation
PHYSICAL_VEHICLE_LINKS (defined in VehicleInformation) | VehicleInformation
SHORT_NAME (defined in VehicleInformation) | VehicleInformation
ToString() (defined in VehicleInformation) | VehicleInformation
VEHICLE_CONNECTORS (defined in VehicleInformation) | VehicleInformation


ASAP2Library interface: VehicleInfoSpec Class Reference

  • Diagnose
  • ODX
  • VehicleInfoSpec
Properties | List of all members
VehicleInfoSpec Class Reference

Vehicle information specification. More...

Properties

NamedId[] | INFO_COMPONENTS [getset]
VehicleInformation[] | VEHICLE_INFORMATIONS [getset]
- Properties inherited from BaseDocInfoContainer
AdminData | ADMIN_DATA [getset]
List< CompanyData > | COMPANY_DATAS [getset]
- Properties inherited from NamedDescId
string??? | Description [getset]
Usually an HTML coded node description.
- Properties inherited from NamedId
string | LONG_NAME [getset]
Sdg[] | SDGS [getset]
string | SHORT_NAME [getset]
- Properties inherited from Id
string | ID [getset]
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IId
string | ID [getset]
Gets or sets a unique ODX instance Id.
ODXRoot | Odx [get]
Gets the containing file.
- Properties inherited from IDescription
string | Description [get]
Gets the description of an description supporting ODX node.

Additional Inherited Members

- Public Member Functions inherited from NamedId
override string | ToString ()
- Public Member Functions inherited from Id
virtual void | initialize (ODXRoot odx)
Initialises the ODX node instance. More...
- Public Attributes inherited from NamedDescId
XmlNode | DESC
This is only the XML representation, use the Description property to access its contents!

Detailed Description

Vehicle information specification.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • VehicleInfoSpec
VehicleInfoSpec Member List

This is the complete list of members for VehicleInfoSpec, including all inherited members.

ADMIN_DATA (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
COMPANY_DATAS (defined in BaseDocInfoContainer) | BaseDocInfoContainer |
DESC | NamedDescId |
Description | NamedDescId |
ID (defined in Id) | Id |
INFO_COMPONENTS (defined in VehicleInfoSpec) | VehicleInfoSpec |
initialize(ODXRoot odx) | Id | virtual
LONG_NAME (defined in NamedId) | NamedId |
Odx | Id |
SDGS (defined in NamedId) | NamedId |
SHORT_NAME (defined in NamedId) | NamedId |
ToString() (defined in NamedId) | NamedId |
VEHICLE_INFORMATIONS (defined in VehicleInfoSpec) | VehicleInfoSpec |


ASAP2Library interface: XDoc Struct Reference

  • Diagnose
  • ODX
  • XDoc
Public Member Functions | Properties | List of all members
XDoc Struct Reference

External document definition. More...

Public Member Functions

override string ToString ()

Properties

DateTime | DATE [getset]
string | LONG_NAME [getset]
string | NUMBER [getset]
string | PUBLISHER [getset]
string | SHORT_NAME [getset]
string | STATE [getset]

Detailed Description

External document definition.


ASAP2Library interface: Member List

  • Diagnose
  • ODX
  • XDoc
XDoc Member List

This is the complete list of members for XDoc, including all inherited members.

DATE (defined in XDoc) | XDoc
LONG_NAME (defined in XDoc) | XDoc
NUMBER (defined in XDoc) | XDoc
PUBLISHER (defined in XDoc) | XDoc
SHORT_NAME (defined in XDoc) | XDoc
STATE (defined in XDoc) | XDoc
ToString() (defined in XDoc) | XDoc


ASAP2Library interface: jnsoft.Helpers Namespace Reference

  • Helpers
Classes | Enumerations
jnsoft.Helpers Namespace Reference

Defines and implememts common helper types. More...

Classes

class | Adler32Computer
Computes the Adler checksum used for zlib compressed files. More...
class | Constants
Globally used constants. More...
struct | DataLimits
Represents data limits. More...
struct | DataPoint
Represents a data point in double floating point (64 Bit) precision. More...
struct | DataPointF
Represents a data point in single floating point (32 Bit) precision. More...
class | DLLWrapper
Implements the ability to dynamically load a native windows DLL. More...
class | Extensions
Implements basic helper stuff. More...
class | IgnoreNSXmlTextReader
XML text reader ignoring any namespace. More...
class | MemoryRange
Holds a memory range. More...
class | MemoryRangeList
Holds a range of memory. More...
class | NativeSKDLL
Allows access to (native Windows) Seed&Key DLLs. More...
class | ParserEventArgs
Parser message EventArgument generated while parsing a file. More...
class | ProgressArgs
EventArgs class to notify progress and support a cancel possibility. More...
struct | sRange
Represents a value range with a Min and Max border. More...
class | TCByteOrder
Typeconverter to edit a reference the Byte order. More...
class | TCByteOrderWithNotSet
Typeconverter to edit a reference the Byte order. More...
class | TCHexType
Typeconverter to display and edit hex values. More...
class | TcpSocketWithTimeout
Tcp socket using a configurable connect timeout. More...
class | TimeBase
Provides system/application time functions. More...

Enumerations

enum BYTEORDER_TYPE {
MSB_FIRST = 1 , BIG_ENDIAN = MSB_FIRST , MSB_LAST = 2 , LITTLE_ENDIAN = MSB_LAST ,
NotSet = 0
}
Enumeration for description of the byte order in the control unit program. More...
enum DATA_TYPE {
UBYTE , SBYTE , UWORD , SWORD ,
ULONG , SLONG , FLOAT32_IEEE , A_UINT64 ,
A_INT64 , FLOAT64_IEEE , FLOAT16_IEEE , BITFIELD
}
Enumeration for description of the basic data types in the ECU program More...
enum | MessageType { Info , Warning , Error }
Possible types of parser messages. More...
enum | SKType { Unknown , CCP = 0x01 , XCP = CCP << 1 , UDS = CCP << 2 }
Available Seed and key DLL type. More...
enum | ValueObjectFormat { Physical , Raw , RawHex , RawBin }
Possible value object formats. More...

Detailed Description

Defines and implememts common helper types.

Enumeration Type Documentation

◆ BYTEORDER_TYPE

enum BYTEORDER_TYPE

Enumeration for description of the byte order in the control unit program.

Note: Use of LITTLE_ENDIAN and BIG_ENDIAN defined with keyword BYTE_ORDER leads to mistakes because it is in contradiction to general use of terms „little endian“ and „big endian“. The keywords LITTLE_ENDIAN and BIG_ENDIAN should no longer be used, they should be replaced by MSB_LAST and MSB_FIRST which are equivalent (definition of MSB_LAST and MSB_FIRST: see keyword BYTE_ORDER).

Enumerator
MSB_FIRST | Big endian
BIG_ENDIAN | Big endian (compatibility with former ASAP standard)
MSB_LAST | Little endian
LITTLE_ENDIAN | Little endian (compatibility with former ASAP standard)
NotSet | Used when byteorder is 'not set'.

◆ DATA_TYPE

enum DATA_TYPE

Enumeration for description of the basic data types in the ECU program

Note: If ECU values of type integer 64 are converted in physical values depending on the computation formula a higher precision in the physical area is necessary. The currently used float 64 format supports less precision than int 64. Therefore the precision of the physical representation is reduced to the precision of float 64. This is relevant for ASAM MCD-3 standards [ASAM MCD-3] where data transfer is defined as physical. This is additionally relevant for all tools working on PCs / Operating systems that do not support higher precision than float 64. Here the representation is rounded for physical and maybe also for internal representation.

Enumerator
UBYTE | unsigned byte (8 Bit)
SBYTE | signed byte (8 Bit)
UWORD | unsigned word (16 Bit)
SWORD | signed word (16 Bit)
ULONG | unsigned long (32 Bit)
SLONG | signed long (32 Bit)
FLOAT32_IEEE | float (32 Bit)
A_UINT64 | unsigned longlong (64 Bit)
A_INT64 | signed longlong (64 Bit)
FLOAT64_IEEE | double (64 Bit)
FLOAT16_IEEE | Half (16 Bit, Computation using this data type is only supported with .NET 6 or gereater.
BITFIELD | a bitfield (not defined by ASAP2, but in CANDb++)

◆ MessageType

enum MessageType

Possible types of parser messages.

Enumerator
Info | parser info
Warning | parser warning
Error | parser error

◆ SKType

enum SKType

Available Seed and key DLL type.

Enumerator
Unknown | Does not contain CCP nor XCP nor UDS Seed and Key methods.
CCP | Contains the CCP Seed and key method.
XCP | Contains XCP Seed and key methods.
UDS | Contains UDS Seed and key methods.

◆ ValueObjectFormat

enum ValueObjectFormat

Possible value object formats.

Enumerator
Physical | Values are physical values. Currently only double values are supported (not verbal values as strings). This means a verbal value is represented by it's raw value, even if the physical value is requested.
Raw | Values are raw values (in decimal representation).
RawHex | Values are raw values (in hexadezimal representation).
RawBin | Values are raw values (in binary representation).


ASAP2Library interface: Adler32Computer Class Reference

  • Helpers
  • Adler32Computer
Public Member Functions | Properties | List of all members
Adler32Computer Class Reference

Computes the Adler checksum used for zlib compressed files. More...

Public Member Functions

void Update (byte[] data, int offset, int length)

Properties

int Checksum [get]

Detailed Description

Computes the Adler checksum used for zlib compressed files.


ASAP2Library interface: Member List

  • Helpers
  • Adler32Computer
Adler32Computer Member List

This is the complete list of members for Adler32Computer, including all inherited members.

Checksum (defined in Adler32Computer) | Adler32Computer
Update(byte[] data, int offset, int length) (defined in Adler32Computer) | Adler32Computer


ASAP2Library interface: Constants Class Reference

  • Helpers
  • Constants
Static Public Attributes | List of all members
Constants Class Reference

Globally used constants. More...

Static Public Attributes

const string | CATData = "Data"
const string | CATDataLimit = "Data.Limit"
const string | CATDataLink = "Data.Link"
const string | CATDataXCPplus = "Data.XCPpLus"
const string | CATNavigation = "Navigation"
static readonly char[] | CRLF_DELIMITER = new char[] { '\r', '\n' }
NewLine delimiter definition.
const string | DESC = "DESC"
const string | DESCTagProperty = "This property may be used to bind any user reference to this instance."
const int | FILE_CACHE = (ushort.MaxValue + 1) << 4
Maximum file buffer to use to write/read files.
const string | LONG_NAME = "LONG-NAME"
const int | MAX_FRAMES_IN_MEMORY = 100000
Maximum amount of logged CAN/LIN/J1939/CCP/XCP frames in memory.
const int | MAX_POINTS_IN_MEMORY = 100000
Maximum count of DAQ data records in memory.
const int | MAX_UNCOMPRESSED_ZIP = (ushort.MaxValue + 1) << 6
The maximum size of uncompressed data to compress into a single DZBLOCKV4, 4 MByte
const string | SHORT_NAME = "SHORT-NAME"
static readonly char[] | WS_DELIMITER = new char[] { ' ', '\t' }
Whitespace delimiter definition.
static readonly byte[] | ZLIB_HEADER = new byte[] { 0x78, 0x01 }
ZLIB header bytes

Detailed Description

Globally used constants.


ASAP2Library interface: Member List

  • Helpers
  • Constants
Constants Member List

This is the complete list of members for Constants, including all inherited members.

CATData (defined in Constants) | Constants | static
CATDataLimit (defined in Constants) | Constants | static
CATDataLink (defined in Constants) | Constants | static
CATDataXCPplus (defined in Constants) | Constants | static
CATNavigation (defined in Constants) | Constants | static
CRLF_DELIMITER | Constants | static
DESC (defined in Constants) | Constants | static
DESCTagProperty (defined in Constants) | Constants | static
FILE_CACHE | Constants | static
LONG_NAME (defined in Constants) | Constants | static
MAX_FRAMES_IN_MEMORY | Constants | static
MAX_POINTS_IN_MEMORY | Constants | static
MAX_UNCOMPRESSED_ZIP | Constants | static
SHORT_NAME (defined in Constants) | Constants | static
WS_DELIMITER | Constants | static
ZLIB_HEADER | Constants | static


ASAP2Library interface: DataLimits Struct Reference

  • Helpers
  • DataLimits
Public Member Functions | Public Attributes | Properties | List of all members
DataLimits Struct Reference

Represents data limits. More...

Public Member Functions

DataLimits (double min, double max)

Public Attributes

double | Max
The data maximum
double | Min
The data minimum

Properties

double AbsoluteDiff [get]
Returns the absolute difference between the limits.

Detailed Description

Represents data limits.


ASAP2Library interface: Member List

  • Helpers
  • DataLimits
DataLimits Member List

This is the complete list of members for DataLimits, including all inherited members.

AbsoluteDiff | DataLimits
DataLimits(double min, double max) (defined in DataLimits) | DataLimits
Max | DataLimits
Min | DataLimits


ASAP2Library interface: DataPoint Struct Reference

  • Helpers
  • DataPoint
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
DataPoint Struct Reference

Represents a data point in double floating point (64 Bit) precision. More...

Public Member Functions

DataPoint (double x, double y)
Creates a new instance with the specified coordinates. More...
override string ToString ()
Gets a string representation More...

Public Attributes

readonly double | X
The X-Coordinate.
readonly double | Y
The Y-Coordinate.

Static Public Attributes

static int Size = Marshal.SizeOf(typeof(DataPoint))
Size in bytes of the DatatPoint.

Detailed Description

Represents a data point in double floating point (64 Bit) precision.

Constructor & Destructor Documentation

◆ DataPoint()

DataPoint | ( | double | x,
 |  | double | y
 | ) |  |

Creates a new instance with the specified coordinates.

Parameters
x | The x coordinate
y | The y coordinate

Member Function Documentation

◆ ToString()

override string ToString ( )

Gets a string representation

Returns
a string representation


ASAP2Library interface: Member List

  • Helpers
  • DataPoint
DataPoint Member List

This is the complete list of members for DataPoint, including all inherited members.

DataPoint(double x, double y) | DataPoint |
Size | DataPoint | static
ToString() | DataPoint |
X | DataPoint |
Y | DataPoint |


ASAP2Library interface: DataPointF Struct Reference

  • Helpers
  • DataPointF
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
DataPointF Struct Reference

Represents a data point in single floating point (32 Bit) precision. More...

Public Member Functions

DataPointF (float x, float y)
Creates a new instance with the specified coordinates. More...
override string ToString ()
Gets a string representation More...

Public Attributes

readonly float | X
The X-Coordinate.
readonly float | Y
The Y-Coordinate.

Static Public Attributes

static int Size = Marshal.SizeOf(typeof(DataPointF))
Size in bytes of the DatatPoint.

Detailed Description

Represents a data point in single floating point (32 Bit) precision.

Constructor & Destructor Documentation

◆ DataPointF()

DataPointF | ( | float | x,
 |  | float | y
 | ) |  |

Creates a new instance with the specified coordinates.

Parameters
x | The x coordinate
y | The y coordinate

Member Function Documentation

◆ ToString()

override string ToString ( )

Gets a string representation

Returns
a string representation


ASAP2Library interface: Member List

  • Helpers
  • DataPointF
DataPointF Member List

This is the complete list of members for DataPointF, including all inherited members.

DataPointF(float x, float y) | DataPointF |
Size | DataPointF | static
ToString() | DataPointF |
X | DataPointF |
Y | DataPointF |


ASAP2Library interface: DLLWrapper Class Reference

  • Helpers
  • DLLWrapper
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
DLLWrapper Class Reference

Implements the ability to dynamically load a native windows DLL. More...

Public Member Functions

DLLWrapper (string pathToDLL)
Creates a new instance of DLLWrapper with the specified parameters. More...
T | createDelegate< T > (string functionName)
Creates the managed delegate for the specified function. More...
T | createDelegate< T > (uint ordinal)
Creates the managed delegate for the specified function ordinal. More...
virtual void | Dispose ()
frees used resources.
void | Dispose (bool dispose)
frees used resources. More...

Static Public Member Functions

static T createDelegate< T > (IntPtr procAddress)
Creates the managed delegate for the specified proc address. More...

Protected Member Functions

static IntPtr | GetProcAddress (IntPtr module, string name)
Imported Windows API function. More...
static IntPtr | GetProcAddress (IntPtr module, uint ordinal)
Imported Windows API function. More...

Protected Attributes

IntPtr mHandle = IntPtr.Zero
The handle to the loaded library.

Properties

string FilePath [get]
Gets the file path of the library.

Detailed Description

Implements the ability to dynamically load a native windows DLL.

Use the Dispose method to free (unload the loaded native DLL).

Constructor & Destructor Documentation

◆ DLLWrapper()

DLLWrapper ( string pathToDLL )

Creates a new instance of DLLWrapper with the specified parameters.

Parameters
pathToDLL The fully qualified path to a windows native DLL
Exceptions
ArgumentException Thrown, if the specified file is not found or accessible or isn't a windows native DLL

Member Function Documentation

◆ createDelegate< T >() [1/3]

static T createDelegate< T > ( IntPtr procAddress )
static

Creates the managed delegate for the specified proc address.

Template Parameters
T Delegate type
Parameters
procAddress
Returns
the managed delegate for the specified proc address.
Type Constraints
T : class

◆ createDelegate< T >() [2/3]

T createDelegate< T > ( string functionName )

Creates the managed delegate for the specified function.

Template Parameters
T Delegate type
Parameters
functionName The function name
Returns
the managed delegate for the specified proc address.
Type Constraints
T : class

◆ createDelegate< T >() [3/3]

T createDelegate< T > ( uint ordinal )

Creates the managed delegate for the specified function ordinal.

Template Parameters
T Delegate type
Parameters
ordinal The function ordinal
Returns
the managed delegate for the specified proc address.
Type Constraints
T : class

◆ Dispose()

void Dispose ( bool dispose )

frees used resources.

Parameters
dispose

◆ GetProcAddress() [1/2]

static IntPtr GetProcAddress | ( | IntPtr | module,
 |  | string | name
 | ) |  |
protected

Imported Windows API function.

Parameters
module | the handle to the loaded library
name | the name of the function within the library
Returns
a function handle to the named function

◆ GetProcAddress() [2/2]

static IntPtr GetProcAddress | ( | IntPtr | module,
 |  | uint | ordinal
 | ) |  |
protected

Imported Windows API function.

Parameters
module | the handle to the loaded library
ordinal | the ordinal number of the function
Returns
a function handle to the function


ASAP2Library interface: Member List

  • Helpers
  • DLLWrapper
DLLWrapper Member List

This is the complete list of members for DLLWrapper, including all inherited members.

createDelegate< T >(IntPtr procAddress) | DLLWrapper | static
createDelegate< T >(string functionName) | DLLWrapper |
createDelegate< T >(uint ordinal) | DLLWrapper |
Dispose(bool dispose) | DLLWrapper |
Dispose() | DLLWrapper | virtual
DLLWrapper(string pathToDLL) | DLLWrapper |
FilePath | DLLWrapper |
GetProcAddress(IntPtr module, string name) | DLLWrapper | protected
GetProcAddress(IntPtr module, uint ordinal) | DLLWrapper | protected
mHandle | DLLWrapper | protected


ASAP2Library interface: Extensions Class Reference

  • Helpers
  • Extensions
Static Public Member Functions | Static Public Attributes | Properties | List of all members
Extensions Class Reference

Implements basic helper stuff. More...

Static Public Member Functions

static void | _ (Type type)
static int | alignDown (int address, int dataSize)
Aligns address down to a dataSize byte boundary. dataSize must be a power of 2. More...
static int | alignUp (int address, int dataSize)
Aligns address up to a dataSize byte boundary. dataSize must be a power of 2. More...
static long | arrayToNum (IList< byte > data, ref int offset, int size)
Converts a (big endian) byte array to a number. More...
static ulong | buildBitmask (int length)
Builds a bitmask using the specified length in Bits. More...
static string | buildHtmlTableLine (string[] args, string id=null)
Builds a HTML table line. More...
static byte[] | changeEndianess (byte[] data, int offset, int len)
Turns the endianess around (from/to little/big endian). More...
static double | changeEndianess (double value)
Turns the endianess around (from/to little/big endian). More...
static float | changeEndianess (float value)
Turns the endianess around (from/to little/big endian). More...
static uint | changeEndianess (uint value)
Turns the endianess around (from/to little/big endian). More...
static ulong | changeEndianess (ulong value)
Turns the endianess around (from/to little/big endian). More...
static ushort | changeEndianess (ushort value)
Turns the endianess around (from/to little/big endian). More...
static byte[] | convertToByte< T > (T instance)
Converts a (marshallable) class to a byte array. More...
static byte[] | convertToByte< T > (T instance, byte[] additionalBytes)
Converts a (marshallable) class to a byte array. More...
static bool | convertToReference< T > (byte[] data, int offset, out T result)
Converts a byte array into the specified object reference. More...
static bool | convertToReference< T > (byte[] data, out T result)
Converts a byte array into the specified object reference. More...
static bool | convertToReference< T > (List< byte > data, out T result, out byte[] additionalData)
Converts a byte array into the specified object reference. More...
static unsafe void | copyMemory (IntPtr dst, IntPtr src, uint count)
Copies a block of memory from one location to another. More...
static T | deserialize< T > (Stream stream, Type[] extraTypes=null)
Deserializes from XML into the specified root type. More...
static unsafe void | fillMemory (byte[] dst, byte fillByte)
Sets memory in an array in a fast but unsafe manner. More...
static unsafe void | fillMemory (IntPtr dst, int len, byte fill)
Fills a block of memory with a specified value. More...
static int | fromHexStr (string s, ref int offset, int len=0)
Decodes a hex string (repreented as character nibbles (e.g. '7E8' to it's value) More...
static IList< string > | getAvailableCOMPorts (bool checkForOpen=true)
Gets the available COM ports. More...
static int | getByteLenFromBitLen (int bitLength)
Converts a bit length to a byte length. More...
static int | getShiftCount (ulong bitmask)
Gets the shift count for a specified bitmask (also known as bit offset). More...
static double | getSingleRawValue (byte[] buffer, int offset, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue, int bitfieldLen=1)
Gets the raw value from a data buffer on the specified location. More...
static double | getSingleRawValue (IntPtr buffer, int offset, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue)
Gets the raw value from a data buffer on the specified location. More...
static byte[] | getSingleRawValueBuffer (double rawValue, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue, int bitfieldLen=1)
Gets a byte buffer for a single raw value. More...
static int | getSizeInBit (this DATA_TYPE instance)
Gets the length in bits of a DATA_TYPE instance. More...
static int | getSizeInByte (this DATA_TYPE instance)
Gets the length in bytes of a DATA_TYPE instance. More...
static string | getTrimmedText (string text, int maxColumns)
Trim text to a maximum size of columns (word wrap). More...
static XmlSerializer | getXmlSerializer (Type type, Type[] extraTypes=null)
Gets an XMLSerializer Instance. More...
static bool | isValidDesignator (string name)
Check if the specified name is valid as an A2L or DBC name. More...
static byte[] | numToArray (long num, int size)
Converts a number with the specified size to a big endian byte array. More...
static double | parse2DoubleVal (string par, bool odx=false)
Parses a string into a double double value. More...
static long | parse2IntVal (string par)
Parses a string into a 64 Bit integer value. More...
static float | parse2SingleVal (string par)
Parses a string into a float value. More...
static byte | reverse (byte b)
Reverse the bits of a byte. More...
static long | setBitmask (long i64Value, DATA_TYPE dt, bool shiftdown, ulong bm=ulong.MaxValue)
Combines the bitmask with the specified raw value. More...
static string | toBinaryString (double rawValue, DATA_TYPE dataType, bool removeLeadingZeros)
Delivers a binary string representation for the specified raw value. More...
static string | toBinaryString (ulong rawValue, DATA_TYPE dataType, bool removeLeadingZeros)
Delivers a binary string representation for the specified raw value. More...
static byte | toByte (string s, int offset)
Computes the byte value from a 2 digit hex string. More...
static string | toDecimalString (double rawValue, DATA_TYPE dataType)
Delivers a decimal string representation for the specified raw value. More...
static string | toDecimalString (ulong rawValue, DATA_TYPE dataType)
Delivers a decimal string representation for the specified raw value. More...
static void | toHexStr (StringBuilder s, int value, int len)
Adds the specified value as character nibbles to the specified string More...
static string | toHexString (double rawValue, DATA_TYPE dataType, bool removeLeadingZeros)
Delivers a hexadecimal string representation for the specified raw value. More...
static string | toHexString (ulong rawValue, bool removeLeadingZeros)
static Stream | tryGetMemoryMappedStream (string file, out MemoryMappedFile mmHandle)
Tries to get a memory mapped file stream. More...
static bool | tryParse2DoubleVal (string par, out double result)
Tries to parse a string into a double value. More...
static bool | tryParse2IntVal (string par, out long result)
Tries to parse a string into a 64 Bit integer value. More...

Static Public Attributes

static readonly Regex | IdentifierMatch = new Regex(IdentifierRegEx, RegexOptions.IgnoreCase | RegexOptions.Singleline)
Used to check for a valid A2L/DBC name.
const string | IdentifierRegEx = "[A-Z_]+[A-Z0-9_]*(\\[\\d+\\])*"
Defines a Regex to check for a valid A2L/DBC name.

Properties

static string | AppName [get]
Gets the executing application name.
static Version | AppVersion [get]
Get the executing application version

Detailed Description

Implements basic helper stuff.

Member Function Documentation

◆ alignDown()

static int alignDown | ( | int | address,
 |  | int | dataSize
 | ) |  |
static

Aligns address down to a dataSize byte boundary. dataSize must be a power of 2.

Taken from Linux kernel align.h

Parameters
address | address
dataSize | size of data
Returns
The aligned address

◆ alignUp()

static int alignUp | ( | int | address,
 |  | int | dataSize
 | ) |  |
static

Aligns address up to a dataSize byte boundary. dataSize must be a power of 2.

Taken from Linux kernel align.h

Parameters
address | address
dataSize | size of data
Returns
The aligned address

◆ arrayToNum()

static long arrayToNum | ( | IList< byte > | data,
 |  | ref int | offset,
 |  | int | size
 | ) |  |
static

Converts a (big endian) byte array to a number.

Parameters
data | data stream to read from
offset | [in/out] offset into data
size | size (in bytes) of result
Returns
result

◆ buildBitmask()

static ulong buildBitmask ( int length )
static

Builds a bitmask using the specified length in Bits.

Parameters
length Length in Bits
Returns
The bitmask
Exceptions
ArgumentOutOfRangeException Thrown if length is smaller than 1

◆ buildHtmlTableLine()

static string buildHtmlTableLine | ( | string[] | args,
 |  | string | id = null
 | ) |  |
static

Builds a HTML table line.

Parameters
args | html table columns
id | Optional id use as anchor
Returns
html table column string

◆ changeEndianess() [1/6]

static byte[] changeEndianess | ( | byte[] | data,
 |  | int | offset,
 |  | int | len
 | ) |  |
static

Turns the endianess around (from/to little/big endian).

This method should be used for float/double values in a byte array format.

Parameters
data | The data
offset | The offset into the array
len | The length (4 or 8 bytes)
Returns
The value in the 'other' endianess

◆ changeEndianess() [2/6]

static double changeEndianess ( double value )
static

Turns the endianess around (from/to little/big endian).

Parameters
value
Returns
The value in the 'other' endianess

◆ changeEndianess() [3/6]

static float changeEndianess ( float value )
static

Turns the endianess around (from/to little/big endian).

Parameters
value
Returns
The value in the 'other' endianess

◆ changeEndianess() [4/6]

static uint changeEndianess ( uint value )
static

Turns the endianess around (from/to little/big endian).

Parameters
value
Returns
The value in the 'other' endianess

◆ changeEndianess() [5/6]

static ulong changeEndianess ( ulong value )
static

Turns the endianess around (from/to little/big endian).

Parameters
value
Returns
The value in the 'other' endianess

◆ changeEndianess() [6/6]

static ushort changeEndianess ( ushort value )
static

Turns the endianess around (from/to little/big endian).

Parameters
value
Returns
The value in the 'other' endianess

◆ convertToByte< T >() [1/2]

static byte[] convertToByte< T > ( T instance )
static

Converts a (marshallable) class to a byte array.

Template Parameters
T The instance type
Parameters
instance The instance to serialize
Returns
The byte array representation
Type Constraints
T : class

◆ convertToByte< T >() [2/2]

static byte[] convertToByte< T > | ( | T | instance,
 |  | byte[] | additionalBytes
 | ) |  |
static

Converts a (marshallable) class to a byte array.

Template Parameters
T The instance type
Parameters
instance | The instance to serialize
additionalBytes | Additional bytes to add
Returns
The byte array representation
Type Constraints
T : class

◆ convertToReference< T >() [1/3]

static bool convertToReference< T > | ( | byte[] | data,
 |  | int | offset,
 |  | out T | result
 | ) |  |
static

Converts a byte array into the specified object reference.

Template Parameters
T The resulting object type
Parameters
data | The byte array to copy from
offset | Offset to the data to convert
result | The resulting object
Returns
true if successful, false, if the memory size of the supplied data is smaller than the destination type
Type Constraints
T : class

◆ convertToReference< T >() [2/3]

static bool convertToReference< T > | ( | byte[] | data,
 |  | out T | result
 | ) |  |
static

Converts a byte array into the specified object reference.

Template Parameters
T The resulting object type
Parameters
data | The byte array to copy from
result | The resulting object
Returns
true if successful, false, if the memory size of the supplied data is smaller than the destination type
Type Constraints
T : class

◆ convertToReference< T >() [3/3]

static bool convertToReference< T > | ( | List< byte > | data,
 |  | out T | result,
 |  | out byte[] | additionalData
 | ) |  |
static

Converts a byte array into the specified object reference.

Template Parameters
T The resulting object type
Parameters
data | The byte array to copy from
result | The resulting object
additionalData | available additional data or null
Returns
true if successful, false, if the memory size of the supplied data is smaller than the destination type
Type Constraints
T : class

◆ copyMemory()

static unsafe void copyMemory | ( | IntPtr | dst,
 |  | IntPtr | src,
 |  | uint | count
 | ) |  |
static

Copies a block of memory from one location to another.

Parameters
dst | A pointer to the starting address of the copied block's destination.
src | A pointer to the starting address of the block of memory to copy.
count | The size of the block of memory to copy, in bytes.

◆ deserialize< T >()

static T deserialize< T > | ( | Stream | stream,
 |  | Type[] | extraTypes = null
 | ) |  |
static

Deserializes from XML into the specified root type.

Template Parameters
T The XML root type
Parameters
stream | Stream to read from
extraTypes | A System.Type array of additional object types to deserialize.
Returns
An deserialized instance

◆ fillMemory() [1/2]

static unsafe void fillMemory | ( | byte[] | dst,
 |  | byte | fillByte
 | ) |  |
static

Sets memory in an array in a fast but unsafe manner.

Parameters
dst | The destination array
fillByte | The byte value to fill in

◆ fillMemory() [2/2]

static unsafe void fillMemory | ( | IntPtr | dst,
 |  | int | len,
 |  | byte | fill
 | ) |  |
static

Fills a block of memory with a specified value.

Parameters
dst | A pointer to the starting address of the block of memory to fill
len | The size of the block of memory to fill, in bytes. This value must be less than the size of the Destination buffer
fill | The byte value with which to fill the memory block

◆ fromHexStr()

static int fromHexStr | ( | string | s,
 |  | ref int | offset,
 |  | int | len = 0
 | ) |  |
static

Decodes a hex string (repreented as character nibbles (e.g. '7E8' to it's value)

Parameters
s | The string to decode
offset | Offset into the string
len | The length (count in nibbles)
Returns
The decoded value
Exceptions
ArgumentException Thrown, if offset + len exceeds the string length

◆ getAvailableCOMPorts()

static IList< string > getAvailableCOMPorts ( bool checkForOpen = true )
static

Gets the available COM ports.

Parameters
checkForOpen
Returns
List of COM ports

◆ getByteLenFromBitLen()

static int getByteLenFromBitLen ( int bitLength )
static

Converts a bit length to a byte length.

Parameters
bitLength The length in bits
Returns
The length in bytes

◆ getShiftCount()

static int getShiftCount ( ulong bitmask )
static

Gets the shift count for a specified bitmask (also known as bit offset).

Parameters
bitmask The bitmask
Returns
The count of left shift to get the first bit as 1

◆ getSingleRawValue() [1/2]

static double getSingleRawValue | ( | byte[] | buffer,
 |  | int | offset,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | ulong | bm = ulong.MaxValue,
 |  | int | bitfieldLen = 1
 | ) |  |
static

Gets the raw value from a data buffer on the specified location.

  • Reads the raw value according the datatype from the buffer
  • corrects endianess if required
  • Shift the raw data according the specified bitmask
Parameters
buffer | The corresponding raw byte bufer
offset | Offset withing the buffer
dt | the raw datatype of input value
bo | the byteOrder of the raw value
bm | the bitmask
bitfieldLen | Length in bit if dt is a bitfield
Returns
the raw value of a single raw data buffer
Exceptions
ArgumentException Thrown if bitfieldLen is not between 1..64

◆ getSingleRawValue() [2/2]

static double getSingleRawValue | ( | IntPtr | buffer,
 |  | int | offset,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | ulong | bm = ulong.MaxValue
 | ) |  |
static

Gets the raw value from a data buffer on the specified location.

  • Reads the raw value according the datatype from the buffer
  • corrects endianess if required
  • Shift the raw data according the specified bitmask
Parameters
buffer | The corresponding raw byte bufer
offset | Offset withing the buffer
dt | the raw datatype of input value
bo | the byteOrder of the raw value
bm | The bitmask
Returns
the raw value of a single value

◆ getSingleRawValueBuffer()

static byte[] getSingleRawValueBuffer | ( | double | rawValue,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | ulong | bm = ulong.MaxValue,
 |  | int | bitfieldLen = 1
 | ) |  |
static

Gets a byte buffer for a single raw value.

The endianess is taken into account.

Parameters
rawValue | the raw value
dt | the datatype of the raw value
bo | the byteOrder of the raw value
bitfieldLen | Length in bit if dt is a bitfield
bm | the bitmask
Returns
the buffer (the length of the buffer is the length of the resulting datatype)
Exceptions
ArgumentException Thrown if bitfieldLen is not between 1..64

◆ getSizeInBit()

static int getSizeInBit ( this DATA_TYPE instance )
static

Gets the length in bits of a DATA_TYPE instance.

Parameters
instance
Returns
length in bits

◆ getSizeInByte()

static int getSizeInByte ( this DATA_TYPE instance )
static

Gets the length in bytes of a DATA_TYPE instance.

Parameters
instance
Returns
length in bytes

◆ getTrimmedText()

static string getTrimmedText | ( | string | text,
 |  | int | maxColumns
 | ) |  |
static

Trim text to a maximum size of columns (word wrap).

Parameters
text | text to trim
maxColumns | maximum column size
Returns
trimmed text

◆ getXmlSerializer()

static XmlSerializer getXmlSerializer | ( | Type | type,
 |  | Type[] | extraTypes = null
 | ) |  |
static

Gets an XMLSerializer Instance.

Works around a .NET framework problem (see http://connect.microsoft.com/VisualStudio/feedback/details/422414/xmlserializer-crashes-if-environment-currentdirectory-is-invalid)

Parameters
type | The type of the object that this System.Xml.Serialization.XmlSerializer can serialize
extraTypes | A System.Type array of additional object types to serialize.
Returns
An XmlSerializer instance

◆ isValidDesignator()

static bool isValidDesignator ( string name )
static

Check if the specified name is valid as an A2L or DBC name.

Parameters
name The name to check
Returns
true if valid

◆ numToArray()

static byte[] numToArray | ( | long | num,
 |  | int | size
 | ) |  |
static

Converts a number with the specified size to a big endian byte array.

Parameters
num | Number to convert
size | Size of number
Returns
byte array instance

◆ parse2DoubleVal()

static double parse2DoubleVal | ( | string | par,
 |  | bool | odx = false
 | ) |  |
static

Parses a string into a double double value.

The string may contain a hexadecimal value.

Parameters
par | The parameter string
odx | true if the ODX version should be used
Returns
The double value

◆ parse2IntVal()

static long parse2IntVal ( string par )
static

Parses a string into a 64 Bit integer value.

The string may contain a hexadecimal value.

Parameters
par The parameter string
Returns
The int value

◆ parse2SingleVal()

static float parse2SingleVal ( string par )
static

Parses a string into a float value.

The string may contain a hexadecimal value.

Parameters
par The parameter string
Returns
The float value

◆ reverse()

static byte reverse ( byte b )
static

Reverse the bits of a byte.

Parameters
b value to reverse
Returns
reversed byte

◆ setBitmask()

static long setBitmask | ( | long | i64Value,
 |  | DATA_TYPE | dt,
 |  | bool | shiftdown,
 |  | ulong | bm = ulong.MaxValue
 | ) |  |
static

Combines the bitmask with the specified raw value.

Parameters
i64Value | raw value
dt | the raw datatype of input value
shiftdown | true if value should be shifted down by the bitmask offset, else the value is shifted up
bm | The bitmask
Returns
the bitmasked raw value

◆ toBinaryString() [1/2]

static string toBinaryString | ( | double | rawValue,
 |  | DATA_TYPE | dataType,
 |  | bool | removeLeadingZeros
 | ) |  |
static

Delivers a binary string representation for the specified raw value.

Parameters
rawValue | The raw value
dataType | The corresponding raw value data type
removeLeadingZeros | true, if leading zeros should not be displayed
Returns
The string representation

◆ toBinaryString() [2/2]

static string toBinaryString | ( | ulong | rawValue,
 |  | DATA_TYPE | dataType,
 |  | bool | removeLeadingZeros
 | ) |  |
static

Delivers a binary string representation for the specified raw value.

Parameters
rawValue | The raw value
dataType | The corresponding raw value data type
removeLeadingZeros | true, if leading zeros should not be displayed
Returns
The string representation

◆ toByte()

static byte toByte | ( | string | s,
 |  | int | offset
 | ) |  |
static

Computes the byte value from a 2 digit hex string.

Parameters
s | The string to parse
offset | The offset to parse into
Returns
The byte value

◆ toDecimalString() [1/2]

static string toDecimalString | ( | double | rawValue,
 |  | DATA_TYPE | dataType
 | ) |  |
static

Delivers a decimal string representation for the specified raw value.

Parameters
rawValue | The raw value
dataType | The corresponding raw value data type
Returns
The string representation

◆ toDecimalString() [2/2]

static string toDecimalString | ( | ulong | rawValue,
 |  | DATA_TYPE | dataType
 | ) |  |
static

Delivers a decimal string representation for the specified raw value.

Parameters
rawValue | The raw value
dataType | The corresponding raw value data type
Returns
The string representation

◆ toHexStr()

static void toHexStr | ( | StringBuilder | s,
 |  | int | value,
 |  | int | len
 | ) |  |
static

Adds the specified value as character nibbles to the specified string

Parameters
s | The string to add to
value | The value to add
len | The length of the value to add (count in nibbles)
Exceptions
ArgumentException

◆ toHexString()

static string toHexString | ( | double | rawValue,
 |  | DATA_TYPE | dataType,
 |  | bool | removeLeadingZeros
 | ) |  |
static

Delivers a hexadecimal string representation for the specified raw value.

Parameters
rawValue | The raw value
dataType | The corresponding raw value data type
removeLeadingZeros | true, if leading zeros should not be displayed
Returns
The string representation

◆ tryGetMemoryMappedStream()

static Stream tryGetMemoryMappedStream | ( | string | file,
 |  | out MemoryMappedFile | mmHandle
 | ) |  |
static

Tries to get a memory mapped file stream.

If the file is too big to be handled by a memory mapped file, a standard file stream is returned.

Parameters
file | fully qualified file name
mmHandle | memory mapped file handle (if used), the caller is responsible to dispose this instance
Returns
A file stream to read from

◆ tryParse2DoubleVal()

static bool tryParse2DoubleVal | ( | string | par,
 |  | out double | result
 | ) |  |
static

Tries to parse a string into a double value.

The string may contain a hexadecimal value.

Parameters
par | The parameter string
result | The result or double.NaN if failed
Returns
true if succesfully parsed

◆ tryParse2IntVal()

static bool tryParse2IntVal | ( | string | par,
 |  | out long | result
 | ) |  |
static

Tries to parse a string into a 64 Bit integer value.

The string may contain a hexadecimal value.

Parameters
par | The parameter string
result | The result
Returns
true if succesfully parsed


ASAP2Library interface: Member List

  • Helpers
  • Extensions
Extensions Member List

This is the complete list of members for Extensions, including all inherited members.

_(Type type) (defined in Extensions) | Extensions | static
alignDown(int address, int dataSize) | Extensions | static
alignUp(int address, int dataSize) | Extensions | static
AppName | Extensions | static
AppVersion | Extensions | static
arrayToNum(IList< byte > data, ref int offset, int size) | Extensions | static
buildBitmask(int length) | Extensions | static
buildHtmlTableLine(string[] args, string id=null) | Extensions | static
changeEndianess(ulong value) | Extensions | static
changeEndianess(uint value) | Extensions | static
changeEndianess(ushort value) | Extensions | static
changeEndianess(float value) | Extensions | static
changeEndianess(double value) | Extensions | static
changeEndianess(byte[] data, int offset, int len) | Extensions | static
convertToByte< T >(T instance) | Extensions | static
convertToByte< T >(T instance, byte[] additionalBytes) | Extensions | static
convertToReference< T >(byte[] data, out T result) | Extensions | static
convertToReference< T >(byte[] data, int offset, out T result) | Extensions | static
convertToReference< T >(List< byte > data, out T result, out byte[] additionalData) | Extensions | static
copyMemory(IntPtr dst, IntPtr src, uint count) | Extensions | static
deserialize< T >(Stream stream, Type[] extraTypes=null) | Extensions | static
fillMemory(IntPtr dst, int len, byte fill) | Extensions | static
fillMemory(byte[] dst, byte fillByte) | Extensions | static
fromHexStr(string s, ref int offset, int len=0) | Extensions | static
getAvailableCOMPorts(bool checkForOpen=true) | Extensions | static
getByteLenFromBitLen(int bitLength) | Extensions | static
getShiftCount(ulong bitmask) | Extensions | static
getSingleRawValue(IntPtr buffer, int offset, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue) | Extensions | static
getSingleRawValue(byte[] buffer, int offset, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue, int bitfieldLen=1) | Extensions | static
getSingleRawValueBuffer(double rawValue, DATA_TYPE dt, BYTEORDER_TYPE bo, ulong bm=ulong.MaxValue, int bitfieldLen=1) | Extensions | static
getSizeInBit(this DATA_TYPE instance) | Extensions | static
getSizeInByte(this DATA_TYPE instance) | Extensions | static
getTrimmedText(string text, int maxColumns) | Extensions | static
getXmlSerializer(Type type, Type[] extraTypes=null) | Extensions | static
IdentifierMatch | Extensions | static
IdentifierRegEx | Extensions | static
isValidDesignator(string name) | Extensions | static
numToArray(long num, int size) | Extensions | static
parse2DoubleVal(string par, bool odx=false) | Extensions | static
parse2IntVal(string par) | Extensions | static
parse2SingleVal(string par) | Extensions | static
reverse(byte b) | Extensions | static
setBitmask(long i64Value, DATA_TYPE dt, bool shiftdown, ulong bm=ulong.MaxValue) | Extensions | static
toBinaryString(double rawValue, DATA_TYPE dataType, bool removeLeadingZeros) | Extensions | static
toBinaryString(ulong rawValue, DATA_TYPE dataType, bool removeLeadingZeros) | Extensions | static
toByte(string s, int offset) | Extensions | static
toDecimalString(double rawValue, DATA_TYPE dataType) | Extensions | static
toDecimalString(ulong rawValue, DATA_TYPE dataType) | Extensions | static
toHexStr(StringBuilder s, int value, int len) | Extensions | static
toHexString(double rawValue, DATA_TYPE dataType, bool removeLeadingZeros) | Extensions | static
toHexString(ulong rawValue, bool removeLeadingZeros) (defined in Extensions) | Extensions | static
tryGetMemoryMappedStream(string file, out MemoryMappedFile mmHandle) | Extensions | static
tryParse2DoubleVal(string par, out double result) | Extensions | static
tryParse2IntVal(string par, out long result) | Extensions | static


ASAP2Library interface: IgnoreNSXmlTextReader Class Reference

  • Helpers
  • IgnoreNSXmlTextReader
Public Member Functions | Properties | List of all members
IgnoreNSXmlTextReader Class Reference

XML text reader ignoring any namespace. More...

Public Member Functions

IgnoreNSXmlTextReader (TextReader reader)

Properties

override string NamespaceURI [get]

Detailed Description

XML text reader ignoring any namespace.


ASAP2Library interface: Member List

  • Helpers
  • IgnoreNSXmlTextReader
IgnoreNSXmlTextReader Member List

This is the complete list of members for IgnoreNSXmlTextReader, including all inherited members.

IgnoreNSXmlTextReader(TextReader reader) (defined in IgnoreNSXmlTextReader) | IgnoreNSXmlTextReader
NamespaceURI (defined in IgnoreNSXmlTextReader) | IgnoreNSXmlTextReader


ASAP2Library interface: MemoryRange Class Reference

  • Helpers
  • MemoryRange
Public Member Functions | Public Attributes | Properties | List of all members
MemoryRange Class Reference

Holds a memory range. More...

Public Member Functions

MemoryRange (uint start, uint next)
Initialises a new instance of Range. More...

Public Attributes

uint | Next
Next address after the segment end.
uint | Start
Start address.

Properties

int Size [get]
Gets the size of the range.

Detailed Description

Holds a memory range.

Constructor & Destructor Documentation

◆ MemoryRange()

MemoryRange | ( | uint | start,
 |  | uint | next
 | ) |  |

Initialises a new instance of Range.

Parameters
start | The start address
next | The Next address after the segment end


ASAP2Library interface: Member List

  • Helpers
  • MemoryRange
MemoryRange Member List

This is the complete list of members for MemoryRange, including all inherited members.

MemoryRange(uint start, uint next) | MemoryRange
Next | MemoryRange
Size | MemoryRange
Start | MemoryRange


ASAP2Library interface: MemoryRangeList Class Reference

  • Helpers
  • MemoryRangeList
Public Member Functions | Properties | List of all members
MemoryRangeList Class Reference

Holds a range of memory. More...

Public Member Functions

new void | Add (MemoryRange range)
Adds a new memory range to the list. More...
int | findRangeIndex (uint address, int size)
FInds the memory range index containing the specified address and size. More...
void | reduce (int minGapSize=0, int maxBlockSize=0)
Reduces the amount of memory ranges by connecting ranges. More...

Properties

int Size [get]
Gets the overall size of tcontained ranges.

Detailed Description

Holds a range of memory.

Member Function Documentation

◆ Add()

new void Add ( MemoryRange range )

Adds a new memory range to the list.

Parameters
range range to add

◆ findRangeIndex()

int findRangeIndex | ( | uint | address,
 |  | int | size
 | ) |  |

FInds the memory range index containing the specified address and size.

Requires an instance sorted by start(address).

Parameters
address | The start address
size | The size
Returns
-1 if corresponding range is not found, else a valid index

◆ reduce()

void reduce | ( | int | minGapSize = 0,
 |  | int | maxBlockSize = 0
 | ) |  |

Reduces the amount of memory ranges by connecting ranges.

Parameters
minGapSize | if > 0, memory ranges are connected together accepting gaps smaller than the specified size
maxBlockSize | if > 0, blocks gets splitted to the specified block size


ASAP2Library interface: Member List

  • Helpers
  • MemoryRangeList
MemoryRangeList Member List

This is the complete list of members for MemoryRangeList, including all inherited members.

Add(MemoryRange range) | MemoryRangeList
findRangeIndex(uint address, int size) | MemoryRangeList
reduce(int minGapSize=0, int maxBlockSize=0) | MemoryRangeList
Size | MemoryRangeList


ASAP2Library interface: NativeSKDLL Class Reference

  • Helpers
  • NativeSKDLL
Public Types | Public Member Functions | Properties | List of all members
NativeSKDLL Class Reference

Allows access to (native Windows) Seed&Key DLLs. More...

Public Types

enum ResultSk {
FncAck , ErrPrivilegeNotAvailable , ErrInvalidSeedLength , ErrUnsufficientKeyLength ,
ErrGlobal
}
XCP: Possible native Seed&Key return values. More...
enum VKeyGenResultEx {
Ok , BufferToSmall , SecurityLevelInvalid , VariantInvalid ,
UnspecifiedError
}
UDS GenerateKeyEx result. More...

Public Member Functions

NativeSKDLL (string pathToDLL)
Creates a new instance of DLLWrapper with the specified parameters. More...
ResultSk | ComputeKeyFromSeed (byte privilege, byte[] seed, out byte[] resultingKey)
XCP: Computes the key from a specified seed. More...
bool | ComputeKeyFromSeed (byte[] seed, out byte[] resultingKey)
CCP: Computes the key from a specified seed. More...
VKeyGenResultEx | ComputeKeyFromSeed (uint securityLevel, byte[] variant, byte[] seed, out byte[] resultingKey)
UDS: Computes the key from a specified seed. More...
ResultSk | GetAvailablePrivileges (ref byte privileges)
XCP: Gets the supported privileges of the Seed&Key dll. More...
- Public Member Functions inherited from DLLWrapper
DLLWrapper (string pathToDLL)
Creates a new instance of DLLWrapper with the specified parameters. More...
T | createDelegate< T > (string functionName)
Creates the managed delegate for the specified function. More...
T | createDelegate< T > (uint ordinal)
Creates the managed delegate for the specified function ordinal. More...
virtual void | Dispose ()
frees used resources.
void | Dispose (bool dispose)
frees used resources. More...

Properties

SKType | Type [get]
Gets the type of the DLL. More...
- Properties inherited from DLLWrapper
string | FilePath [get]
Gets the file path of the library.

Additional Inherited Members

- Static Public Member Functions inherited from DLLWrapper
static T | createDelegate< T > (IntPtr procAddress)
Creates the managed delegate for the specified proc address. More...
- Protected Member Functions inherited from DLLWrapper
static IntPtr | GetProcAddress (IntPtr module, string name)
Imported Windows API function. More...
static IntPtr | GetProcAddress (IntPtr module, uint ordinal)
Imported Windows API function. More...
- Protected Attributes inherited from DLLWrapper
IntPtr | mHandle = IntPtr.Zero
The handle to the loaded library.

Detailed Description

Allows access to (native Windows) Seed&Key DLLs.

  • To compute a CCP key from a seed, the DLL must contain the function ASAP1A_CCP_ComputeKeyFromSeed
  • To compute a XCP key from a seed, the DLL must contain the functions XCP_GetAvailablePrivileges and XCP_ComputeKeyFromSeed
  • When running In a 64 Bit Process the DLL must be a 64 Bit DLL too!

Member Enumeration Documentation

◆ ResultSk

enum ResultSk

XCP: Possible native Seed&Key return values.

Enumerator
FncAck | Function call was successful
ErrPrivilegeNotAvailable | Requested privilege is not available
ErrInvalidSeedLength | Seed length is invalid.
ErrUnsufficientKeyLength | Key length is not sufficient
ErrGlobal | All other errors

◆ VKeyGenResultEx

enum VKeyGenResultEx

UDS GenerateKeyEx result.

Enumerator
Ok | Ok
BufferToSmall | Specified buffer too small
SecurityLevelInvalid | Specified security level is invalid
VariantInvalid | Specified variant is invalid
UnspecifiedError | Unspecified error

Constructor & Destructor Documentation

◆ NativeSKDLL()

NativeSKDLL ( string pathToDLL )

Creates a new instance of DLLWrapper with the specified parameters.

Parameters
pathToDLL The fully qualified path to a windows native DLL
Exceptions
ArgumentException Thrown, if the specified file is not found or accessible or isn't a windows native DLL

Member Function Documentation

◆ ComputeKeyFromSeed() [1/3]

ResultSk ComputeKeyFromSeed | ( | byte | privilege,
 |  | byte[] | seed,
 |  | out byte[] | resultingKey
 | ) |  |

XCP: Computes the key from a specified seed.

Parameters
privilege | The privilege (jnsoft.Comm.XCP.ResourceType) to compute the seed for
seed | The seed
resultingKey | The resulting key
Returns
A ResultSk value

◆ ComputeKeyFromSeed() [2/3]

bool ComputeKeyFromSeed | ( | byte[] | seed,
 |  | out byte[] | resultingKey
 | ) |  |

CCP: Computes the key from a specified seed.

Parameters
seed | The seed to get the key for
resultingKey | The resulting key (may be null if return value is false)
Returns
true if successful

◆ ComputeKeyFromSeed() [3/3]

VKeyGenResultEx ComputeKeyFromSeed | ( | uint | securityLevel,
 |  | byte[] | variant,
 |  | byte[] | seed,
 |  | out byte[] | resultingKey
 | ) |  |

UDS: Computes the key from a specified seed.

Parameters
securityLevel | The security level
variant | The used variant
seed | The seed to get the key for
resultingKey | The resulting key (may be null if return value is false)
Returns
true if successful

◆ GetAvailablePrivileges()

ResultSk GetAvailablePrivileges ( ref byte privileges )

XCP: Gets the supported privileges of the Seed&Key dll.

Parameters
privileges The privileges (jnsoft.Comm.XCP.ResourceType)
Returns
A ResultSk value

Property Documentation

◆ Type

SKType Type
get

Gets the type of the DLL.

May be a combination of CCP, XCP, UDS.


ASAP2Library interface: Member List

  • Helpers
  • NativeSKDLL
NativeSKDLL Member List

This is the complete list of members for NativeSKDLL, including all inherited members.

ComputeKeyFromSeed(byte[] seed, out byte[] resultingKey) | NativeSKDLL |
ComputeKeyFromSeed(byte privilege, byte[] seed, out byte[] resultingKey) | NativeSKDLL |
ComputeKeyFromSeed(uint securityLevel, byte[] variant, byte[] seed, out byte[] resultingKey) | NativeSKDLL |
createDelegate< T >(IntPtr procAddress) | DLLWrapper | static
createDelegate< T >(string functionName) | DLLWrapper |
createDelegate< T >(uint ordinal) | DLLWrapper |
Dispose(bool dispose) | DLLWrapper |
Dispose() | DLLWrapper | virtual
DLLWrapper(string pathToDLL) | DLLWrapper |
FilePath | DLLWrapper |
GetAvailablePrivileges(ref byte privileges) | NativeSKDLL |
GetProcAddress(IntPtr module, string name) | DLLWrapper | protected
GetProcAddress(IntPtr module, uint ordinal) | DLLWrapper | protected
mHandle | DLLWrapper | protected
NativeSKDLL(string pathToDLL) | NativeSKDLL |
ResultSk enum name | NativeSKDLL |
Type | NativeSKDLL |
VKeyGenResultEx enum name | NativeSKDLL |


ASAP2Library interface: ParserEventArgs Class Reference

  • Helpers
  • ParserEventArgs
Public Member Functions | Properties | List of all members
ParserEventArgs Class Reference

Parser message EventArgument generated while parsing a file. More...

Public Member Functions

ParserEventArgs (object source, MessageType type, string message)
Creates a new instance of ODXParserEventArgs. More...

Properties

string | Message [get]
Gets the parser message
object | Source [get]
Gets the corresponding a2l object
DateTime | TimeStamp [get]
Get the time the message occured
MessageType | Type [get]
Gets the message type

Detailed Description

Parser message EventArgument generated while parsing a file.

Constructor & Destructor Documentation

◆ ParserEventArgs()

ParserEventArgs | ( | object | source,
 |  | MessageType | type,
 |  | string | message
 | ) |  |

Creates a new instance of ODXParserEventArgs.

Parameters
source | The source object instance
type | Message type
message | Message as string


ASAP2Library interface: Member List

  • Helpers
  • ParserEventArgs
ParserEventArgs Member List

This is the complete list of members for ParserEventArgs, including all inherited members.

Message | ParserEventArgs
ParserEventArgs(object source, MessageType type, string message) | ParserEventArgs
Source | ParserEventArgs
TimeStamp | ParserEventArgs
Type | ParserEventArgs


ASAP2Library interface: ProgressArgs Class Reference

  • Helpers
  • ProgressArgs
Public Member Functions | Public Attributes | List of all members
ProgressArgs Class Reference

EventArgs class to notify progress and support a cancel possibility. More...

Public Member Functions

ProgressArgs (int percent)
Creates a new instance of ProgressArgs with the specified arguments. More...

Public Attributes

bool | Cancel
Set to true to cancel process
readonly int | Percent
Progress in percent

Detailed Description

EventArgs class to notify progress and support a cancel possibility.

Constructor & Destructor Documentation

◆ ProgressArgs()

ProgressArgs ( int percent )

Creates a new instance of ProgressArgs with the specified arguments.

Parameters
percent


ASAP2Library interface: Member List

  • Helpers
  • ProgressArgs
ProgressArgs Member List

This is the complete list of members for ProgressArgs, including all inherited members.

Cancel | ProgressArgs
Percent | ProgressArgs
ProgressArgs(int percent) | ProgressArgs


ASAP2Library interface: sRange Struct Reference

  • Helpers
  • sRange
Public Member Functions | Public Attributes | List of all members
sRange Struct Reference

Represents a value range with a Min and Max border. More...

Public Member Functions

override string ToString ()

Public Attributes

double | Max
Gets or sets the maximum
double | Min
Gets or sets the minimum

Detailed Description

Represents a value range with a Min and Max border.


ASAP2Library interface: Member List

  • Helpers
  • sRange
sRange Member List

This is the complete list of members for sRange, including all inherited members.

Max | sRange
Min | sRange
ToString() (defined in sRange) | sRange


ASAP2Library interface: TCByteOrder Class Reference

  • Helpers
  • TCByteOrder
Public Member Functions | List of all members
TCByteOrder Class Reference

Typeconverter to edit a reference the Byte order. More...

Public Member Functions

TCByteOrder (Type type)
override StandardValuesCollection GetStandardValues (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference the Byte order.


ASAP2Library interface: Member List

  • Helpers
  • TCByteOrder
TCByteOrder Member List

This is the complete list of members for TCByteOrder, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCByteOrder) | TCByteOrder
TCByteOrder(Type type) (defined in TCByteOrder) | TCByteOrder


ASAP2Library interface: TCByteOrderWithNotSet Class Reference

  • Helpers
  • TCByteOrderWithNotSet
Public Member Functions | List of all members
TCByteOrderWithNotSet Class Reference

Typeconverter to edit a reference the Byte order. More...

Public Member Functions

TCByteOrderWithNotSet (Type type)
override StandardValuesCollection GetStandardValues (ITypeDescriptorContext context)

Detailed Description

Typeconverter to edit a reference the Byte order.


ASAP2Library interface: Member List

  • Helpers
  • TCByteOrderWithNotSet
TCByteOrderWithNotSet Member List

This is the complete list of members for TCByteOrderWithNotSet, including all inherited members.

GetStandardValues(ITypeDescriptorContext context) (defined in TCByteOrderWithNotSet) | TCByteOrderWithNotSet
TCByteOrderWithNotSet(Type type) (defined in TCByteOrderWithNotSet) | TCByteOrderWithNotSet


ASAP2Library interface: TCHexType Class Reference

  • Helpers
  • TCHexType
Public Member Functions | List of all members
TCHexType Class Reference

Typeconverter to display and edit hex values. More...

Public Member Functions

override bool | CanConvertFrom (ITypeDescriptorContext context, Type sourceType)
override bool | CanConvertTo (ITypeDescriptorContext context, Type destinationType)
override object | ConvertFrom (ITypeDescriptorContext context, CultureInfo culture, object value)
override object | ConvertTo (ITypeDescriptorContext context, CultureInfo culture, object value, Type destinationType)

Detailed Description

Typeconverter to display and edit hex values.


ASAP2Library interface: Member List

  • Helpers
  • TCHexType
TCHexType Member List

This is the complete list of members for TCHexType, including all inherited members.

CanConvertFrom(ITypeDescriptorContext context, Type sourceType) (defined in TCHexType) | TCHexType
CanConvertTo(ITypeDescriptorContext context, Type destinationType) (defined in TCHexType) | TCHexType
ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) (defined in TCHexType) | TCHexType
ConvertTo(ITypeDescriptorContext context, CultureInfo culture, object value, Type destinationType) (defined in TCHexType) | TCHexType


ASAP2Library interface: TcpSocketWithTimeout Class Reference

  • Helpers
  • TcpSocketWithTimeout
Public Member Functions | List of all members
TcpSocketWithTimeout Class Reference

Tcp socket using a configurable connect timeout. More...

Public Member Functions

TcpSocketWithTimeout (EndPoint endPoint, int timeout=200, short ttl=32, bool reuseAddress=true)
Create a Tcp stream socket and tries to connect. More...
bool TryConnect (EndPoint endPoint, int timeout)
Try to reconnect the socket. More...

Detailed Description

Tcp socket using a configurable connect timeout.

Constructor & Destructor Documentation

◆ TcpSocketWithTimeout()

TcpSocketWithTimeout | ( | EndPoint | endPoint,
 |  | int | timeout = 200,
 |  | short | ttl = 32,
 |  | bool | reuseAddress = true
 | ) |  |

Create a Tcp stream socket and tries to connect.

Parameters
endPoint | Remote host to connect to
timeout | Timeout in [ms] to wait for a result
ttl | Time to live
reuseAddress | true to set the socket to reuse address
Exceptions
TimeoutException Thrown if specified server is not reachable

Member Function Documentation

◆ TryConnect()

bool TryConnect | ( | EndPoint | endPoint,
 |  | int | timeout
 | ) |  |

Try to reconnect the socket.

Parameters
endPoint | Remote host to connect to
timeout | Timeout in [ms] to wait for a result


ASAP2Library interface: Member List

  • Helpers
  • TcpSocketWithTimeout
TcpSocketWithTimeout Member List

This is the complete list of members for TcpSocketWithTimeout, including all inherited members.

TcpSocketWithTimeout(EndPoint endPoint, int timeout=200, short ttl=32, bool reuseAddress=true) | TcpSocketWithTimeout
TryConnect(EndPoint endPoint, int timeout) | TcpSocketWithTimeout


ASAP2Library interface: TimeBase Class Reference

  • Helpers
  • TimeBase
Static Public Member Functions | Properties | List of all members
TimeBase Class Reference

Provides system/application time functions. More...

Static Public Member Functions

static void | BlockForMicroSecs (long microSecs, EventWaitHandle waithandle=null)
Blocks the calling thread for the specified amount of micro seconds. More...
static double | getDAQTime ()
Gets the current measuring time set for displaying measured values. More...
static void | resetDAQTime ()
Resets the measured time.
static void | setCurrentDAQTimeFromSeconds (double time)
Sets the measured time from seconds. More...
static void | stopDAQTime ()
Stops the data acquisition time.

Properties

static double | DAQLastTimestamp [getset]
Gets or sets the most recently received data acquisition time.
static TimeSpan | Elapsed [get]
Gets the time elapsed since Application start.
static double | ElapsedDAQSeconds [get]
Gets the seconds elapsed since resetDAQTime is called.
static long | ElapsedTicks [get]
Gets the stop watch ticks elapsed since Application start.

Detailed Description

Provides system/application time functions.

Member Function Documentation

◆ BlockForMicroSecs()

static void BlockForMicroSecs | ( | long | microSecs,
 |  | EventWaitHandle | waithandle = null
 | ) |  |
static

Blocks the calling thread for the specified amount of micro seconds.

This method is used to wait small amounts of time (STMin settings on UDS, XCP protocol)

Parameters
microSecs | amount of microseconds to block for
waithandle | returns if wait handle is signalled

◆ getDAQTime()

static double getDAQTime ( )
static

Gets the current measuring time set for displaying measured values.

Returns
The time in ticks

◆ setCurrentDAQTimeFromSeconds()

static void setCurrentDAQTimeFromSeconds ( double time )
static

Sets the measured time from seconds.

Parameters
time The time in seconds


ASAP2Library interface: Member List

  • Helpers
  • TimeBase
TimeBase Member List

This is the complete list of members for TimeBase, including all inherited members.

BlockForMicroSecs(long microSecs, EventWaitHandle waithandle=null) | TimeBase | static
DAQLastTimestamp | TimeBase | static
Elapsed | TimeBase | static
ElapsedDAQSeconds | TimeBase | static
ElapsedTicks | TimeBase | static
getDAQTime() | TimeBase | static
resetDAQTime() | TimeBase | static
setCurrentDAQTimeFromSeconds(double time) | TimeBase | static
stopDAQTime() | TimeBase | static


ASAP2Library interface: jnsoft.LIN Namespace Reference

  • LIN
jnsoft.LIN Namespace Reference


ASAP2Library interface: jnsoft.LIN.Examples Namespace Reference

  • LIN
  • Examples
Classes
jnsoft.LIN.Examples Namespace Reference

Classes

class Program
ASAP2ibrary LION handling demonstration. More...


ASAP2Library interface: Program Class Reference

  • LIN
  • Examples
  • Program
List of all members
Program Class Reference

ASAP2ibrary LION handling demonstration. More...

Detailed Description

ASAP2ibrary LION handling demonstration.

  • Loading an LDF (LIN description file) file
  • Register to receive LIN frames on a Vector (as an example) LIN hardware.
  • Print a first valid signal while receiving LIN frames.

Usage: LINExample LDFFile.ldf


ASAP2Library interface: Member List

  • LIN
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: jnsoft.Logging Namespace Reference

  • Logging
Classes
jnsoft.Logging Namespace Reference

Defines logging support. More...

Classes

interface | ILog
Logging interface More...
class | LogManager
Default LogManager (no log support at all). More...

Detailed Description

Defines logging support.


ASAP2Library interface: ILog Interface Reference

  • Logging
  • ILog
Public Member Functions | Properties | List of all members
ILog Interface Reference

Logging interface More...

Public Member Functions

void | Debug (object message)
void | Debug (object message, Exception exception)
void | DebugFormat (string format, params object[] args)
void | Error (object message)
void | Error (object message, Exception exception)
void | ErrorFormat (string format, params object[] args)
void | Fatal (object message)
void | Fatal (object message, Exception exception)
void | FatalFormat (string format, params object[] args)
void | Info (object message)
void | Info (object message, Exception exception)
void | InfoFormat (string format, params object[] args)
void | Warn (object message)
void | Warn (object message, Exception exception)
void | WarnFormat (string format, params object[] args)

Properties

bool | IsDebugEnabled [get]
bool | IsErrorEnabled [get]
bool | IsFatalEnabled [get]
bool | IsInfoEnabled [get]
bool | IsWarnEnabled [get]

Detailed Description

Logging interface


ASAP2Library interface: Member List

  • Logging
  • ILog
ILog Member List

This is the complete list of members for ILog, including all inherited members.

Debug(object message) (defined in ILog) | ILog
Debug(object message, Exception exception) (defined in ILog) | ILog
DebugFormat(string format, params object[] args) (defined in ILog) | ILog
Error(object message) (defined in ILog) | ILog
Error(object message, Exception exception) (defined in ILog) | ILog
ErrorFormat(string format, params object[] args) (defined in ILog) | ILog
Fatal(object message) (defined in ILog) | ILog
Fatal(object message, Exception exception) (defined in ILog) | ILog
FatalFormat(string format, params object[] args) (defined in ILog) | ILog
Info(object message) (defined in ILog) | ILog
Info(object message, Exception exception) (defined in ILog) | ILog
InfoFormat(string format, params object[] args) (defined in ILog) | ILog
IsDebugEnabled (defined in ILog) | ILog
IsErrorEnabled (defined in ILog) | ILog
IsFatalEnabled (defined in ILog) | ILog
IsInfoEnabled (defined in ILog) | ILog
IsWarnEnabled (defined in ILog) | ILog
Warn(object message) (defined in ILog) | ILog
Warn(object message, Exception exception) (defined in ILog) | ILog
WarnFormat(string format, params object[] args) (defined in ILog) | ILog


ASAP2Library interface: LogManager Class Reference

  • Logging
  • LogManager
Static Public Member Functions | List of all members
LogManager Class Reference

Default LogManager (no log support at all). More...

Static Public Member Functions

static void | addColoredConsoleAppender ()
Add the managed colored console appender (does nothing in thos case).
static void | configureLogOutput (string configFile, string logFileName=null)
Configures the logger using the specified log configuration file and the specified log file name. More...
static ILog | GetLogger (Type type)
Get the default logger (no log support) More...

Additional Inherited Members

- Properties inherited from ILog
bool | IsDebugEnabled [get]
bool | IsErrorEnabled [get]
bool | IsFatalEnabled [get]
bool | IsInfoEnabled [get]
bool | IsWarnEnabled [get]

Detailed Description

Default LogManager (no log support at all).

Member Function Documentation

◆ configureLogOutput()

static void configureLogOutput | ( | string | configFile,
 |  | string | logFileName = null
 | ) |  |
static

Configures the logger using the specified log configuration file and the specified log file name.

This default configures nothing.

Parameters
configFile | The logger configuration file
logFileName | An optional log output filename

◆ GetLogger()

static ILog GetLogger ( Type type )
static

Get the default logger (no log support)

Parameters
type
Returns
default logger


ASAP2Library interface: Member List

  • Logging
  • LogManager
LogManager Member List

This is the complete list of members for LogManager, including all inherited members.

addColoredConsoleAppender() | LogManager | static
configureLogOutput(string configFile, string logFileName=null) | LogManager | static
GetLogger(Type type) | LogManager | static


ASAP2Library interface: jnsoft.MDF Namespace Reference

  • MDF
Namespaces | Classes | Enumerations
jnsoft.MDF Namespace Reference

All the MDF (Measurement Data Format) stuff. More...

Namespaces

namespace | V3
Implements the MDF V1.XX..V3.XX specific stuff.
namespace | V4
Implements the MDF V4.XX specific stuff.

Classes

struct | Annotation
Structure holding a single annotation and it's timestamp. More...
class | AnnotationList
Holds a list of Annotations. More...
class | DataBlockExpander
Handles sorting of Datablocks. More...
class | DataReader
MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression. More...
class | DataStream
Handles a temporary stream per data handle. More...
class | DependencyType
Dependency data. More...
class | Helpers
MDF Helper functions and constants. More...
interface | ICCBLOCK
Channel computation Block interface. More...
interface | ICGBLOCK
Channel group Block interface. More...
interface | ICNBLOCK
Channel Block interface. More...
interface | IDataContainer
Interface for Data containers like SRBLOCK and DGBLOCK. More...
interface | IDGBLOCK
Data Group Block interface.. More...
interface | IHDBLOCK
Header Block interface. More...
interface | IIDBLOCK
ID Block interface. More...
interface | IMDFBlock
Basic MDF block interface. More...
interface | IMDFComment
Interface to access TXBLOCK comments. More...
interface | ISRBLOCK
Sample reduction Block interface. More...
class | MDFReader
Implements the MDF (Measurement Data Format) reader. More...
class | MDFWriter
Implements the MDF (Measurement Data Format) recorder. More...
class | RawDataRecord
Used to transfer MDF raw data record. More...
class | WriteRawDataEventArgs
EVent arguments to request the MDFWriter to write the raw data to the stream. More...

Enumerations

enum ChannelType {
Data , VariableData , Master , VirtualMaster ,
Sync , MaxLenData , VirtualData
}
Channel types More...
enum ConversionType {
ParametricLinear = 0 , TabInt = 1 , Tab = 2 , Polynomial = 6 ,
Exponential = 7 , Logarithmic = 8 , Rational = 9 , TextFormula = 10 ,
TextTable = 11 , TextRange = 12 , Date = 132 , Time = 133 ,
TabRange , TextToValue , TextToText , None = 0xFFFF
}
Conversion types More...
enum | CustomFlagsType
Custom Flags for unfinalized MDF. More...
enum | MDFFileExtension { dat , mdf , mf3 , mf4 }
Specifies possible MDF file extensions. More...
enum | MDFType { V3 , V4 }
Specifies the MDF type. More...
enum RecordIDType {
None , Before8Bit , Before16Bit = Before8Bit << 1 , Before32Bit = Before8Bit << 2 ,
Before64Bit = Before8Bit << 3 , BeforeAndAfter8Bit = 0xff
}
Number of record IDs in the data block. More...
enum SignalType {
UINT_LE , UINT_BE , SINT_LE , SINT_BE ,
FLOAT_LE , FLOAT_BE , STRING , STRING_UTF8 ,
STRING_UTF16_LE , STRING_UTF16_BE , BYTE_ARRAY , MIME_SAMPLE ,
MIME_STREAM , CANOPEN_DATA , CANOPEN_TIME
}
MDF Signal types (V4 specification) More...
enum SyncType {
None = 0 , Time = 1 , Angle = 2 , Distance = 3 ,
Index = 4
}
Synchronisation type More...
enum | TimeFlagsType { LocalTime = 1 , OffsetsValid = 2 }
Time flags (MDF V4) More...
enum | TimeQualityType { LocalPC = 0 , ExternalSource = 10 , ExternalAbsolute = 16 }
Time quality. More...
enum UnfinalizedFlagsType {
None , UpdateCGBlockRequired , UpdateSRBlockRequired = UpdateCGBlockRequired << 1 , InvalLengthLastDT = UpdateCGBlockRequired << 2 ,
InvalVLSDCGBlockSDLength = UpdateCGBlockRequired << 5
}
Standard Flags for unfinalized MDF. More...

Detailed Description

All the MDF (Measurement Data Format) stuff.

  • This module supports any MDF version up to V4.XX.
  • An additional goal of the MDF module is to have a common interface to read/write MDF files for any MDF Version (V1.XX..V3.XX and V4.XX).
  • Use MDFReader to read MDF files
  • Use MDFWriter to write MDF files

Enumeration Type Documentation

◆ ChannelType

enum ChannelType

Channel types

Enumerator
Data

Fixed length data channel. Channel value is contained in record.

VariableData

Also denoted as "variable length signal data" (VLSD) channel. Channel value in the record is an unsigned integer value (LE/Intel Byte order) of the specified number of bits. This value is the offset to a variable length signal value in the data section of the SDBLOCK referenced by cn_data. Channel data type and CC rule refer to data in SDBLOCK, not to record data. Signal data must point to an SDBLOCK or a DLBLOCK with list of SDBLOCKs. For unsorted data groups, alternatively it can point to a VLSD CGBLOCK, see explanation in 5.14.3 Variable Length Signal Data (VLSD) CGBLOCKV4.

Master

Master channel for all signals of this group. Must be combined with one of the following sync types: 1,2,3 (see table line for CNBLOCKV4.SyncType). In each channel group, not more than one channel can be defined as master or virtual master channel for each possible sync type. Value decoding is equal to a fixed length data channel. Physical values of this channel must return the SI unit (see [SI]) of the respective sync type, with or without CCBLOCK, i.e. seconds for a time master channel. Values of this channel listed over the record index must be strictly monotonic increasing. They are always relative to the respective start value in the HDBLOCK.

VirtualMaster

Like a master channel, except that the channel value is not contained in the record.

Instead the physical value must be calculated by feeding the zero-based record index to the conversion rule. The data type of the virtual master channel must be unsigned integer with Little Endian byte order.

Sync

Must be combined with one of the following sync types: 1,2,3,4 (see table line for CNBLOCKV4.SyncType). A synchronization channel is used to synchronize the records of this channel group with samples in some other stream, e.g. AVI frames. Physical values of this channel must return the unit of the respective synchronization domain, i.e. seconds for CNBLOCKV4.SyncType = 1, or an index value for CNBLOCKV4.SyncType = 4. These values are used for synchronization with the stream. Hence, the stream must use the same synchronization domain, i.e. a data row with synchronization values or index-based samples (only for CNBLOCKV4.SyncType = 4). The signal data link (cn_data) must refer to an ATBLOCK in the global list of attachments. The ATBLOCK contains the stream data or a reference to a stream file.

MaxLenData

Also denoted as "maximum length signal data" (MLSD) channel Record contains range with maximum number of Bytes for channel value like for a fixed length data channel (cn_type = 0), but the number of currently valid Bytes is given by the value of a channel referenced by cn_data (denoted as "size signal"). Since the size signal defines the number of Bytes to use, its physical values must be Integer values between 0 and (cn_bit_count>>3), i.e. its values must not exceed the number of Bytes reserved in the record for this channel. Usually, the size signal should have some Integer data type (cn_data_type smaller than 4) without conversion rule and without unit. The value of the size signal must be contained in the same record as the current channel, i.e. both channels must be in the same channel group. Note: this channel type must not be used with numeric or CANopen data types, i.e. it can occur only for (cn_data_type between 6 and 12). valid since MDF 4.1.0, should not occur for earlier versions.

VirtualData

Similar to a virtual master channel the channel value is not contained in the record (cn_bit_count must be zero). Instead the physical value must be calculated by feeding the zero-based record index to the conversion rule. The data type of the virtual master channel must be unsigned integer with Little Endian byte order (cn_data_type = 0). Except of this, the same rules apply as for a fixed length data channel (cn_type = 0). A virtual data channel may be used to specify a channel with constant values without consuming any space in the record. The constant value can be given by the offset of a linear conversion rule with factor equal to zero. valid since MDF 4.1.0, should not occur for earlier versions.

◆ ConversionType

enum ConversionType

Conversion types

Enumerator
ParametricLinear | parametric, linear
TabInt | tabular with interpolatio
Tab | tabular
Polynomial | polynomial function, V3 only
Exponential | exponential function, V3 only
Logarithmic | logarithmic function, V3 only
Rational | rational conversion formula
TextFormula | ASAM-MCD2 Text formula.
TextTable | ASAM-MCD2 Text Table, (COMPU_VTAB).
TextRange | ASAM-MCD2 Text Range Table (COMPU_VTAB_RANGE).
Date | date (Based on 7 Byte Date data structure, V3 only).
Time | time (Based on 6 Byte Time data structure, V3 only).
TabRange | value range to value tabular look-up (V4 only)
TextToValue | text to value tabular look-up (V4 only)
TextToText | text to text tabular look-up (translation, V4 only)
None | 1:1 conversion formula (Int = Phys).

◆ CustomFlagsType

enum CustomFlagsType

Custom Flags for unfinalized MDF.

Bit combination of flags that indicate custom steps required to finalize the MDF file. For a finalized MDF file, the value must be 0 (no flag set). See also 3.3.2 Unfinalized MDF. Custom flags should only be used to handle cases that are not covered by the (currently known) standard flags(see above). The meaning of the flags depends on the creator tool, i.e. the application that has written the MDF file(see id_prog). Finalization should only be done by the creator tool or a tool that is familiar with all custom finalization steps required for a file from this creator tool.

◆ MDFFileExtension

enum MDFFileExtension

Specifies possible MDF file extensions.

Enumerator
dat | V3, V4
mdf | V3, V4
mf3 | V3
mf4 | V4

◆ MDFType

enum MDFType

Specifies the MDF type.

As the format is radically changed between MDF Versions V3 and V4

Enumerator
V3 | MDF Version V3 (all MDF versions < V4.00)
V4 | MDF Version >= V4.00

◆ RecordIDType

enum RecordIDType

Number of record IDs in the data block.

Enumerator
None | data records without record ID
Before8Bit | record ID (UINT8) before each data record
Before16Bit | record ID (UINT16) before each data record
Before32Bit | record ID (UINT32) before each data record
Before64Bit | record ID (UINT64) before each data record
BeforeAndAfter8Bit | record ID (UINT8) before and after each data record (V3 only)

◆ SignalType

enum SignalType

MDF Signal types (V4 specification)

Enumerator
UINT_LE | unsigned integer little endian
UINT_BE | unsigned integer big endian
SINT_LE | signed integer little endian
SINT_BE | signed integer big endian
FLOAT_LE | IEEE 754 floating-point format little endian
FLOAT_BE | IEEE 754 floating-point format big endian
STRING | String (NULL terminated)
STRING_UTF8 | UTF8 String (NULL terminated)
STRING_UTF16_LE | UTF16 String (NULL terminated) little endian
STRING_UTF16_BE | UTF16 String (NULL terminated) big endian
BYTE_ARRAY | Byte Array with unknown content (e.g. structure)
MIME_SAMPLE | MIME sample (sample is Byte Array with MIME content-type specified in cn_md_unit)
MIME_STREAM | MIME stream (all samples of channel represent a stream with MIME content-type specified in cn_md_unit)
CANOPEN_DATA | CANopen date (Based on 7 Byte CANopen Date data structure, see Table 35)
CANOPEN_TIME | CANopen date (Based on 6 Byte CANopen Time data structure, see Table 35)

◆ SyncType

enum SyncType

Synchronisation type

Enumerator
None | None (to be used for normal data channels)
Time | Time (physical values must be seconds)
Angle | Angle (physical values must be radians)
Distance | Distance (physical values must be meters)
Index | Index (physical values must be zero-based index values)

◆ TimeFlagsType

enum TimeFlagsType

Time flags (MDF V4)

Enumerator
LocalTime | Local time is valid
OffsetsValid | Offsets are valid

◆ TimeQualityType

enum TimeQualityType

Time quality.

Enumerator
LocalPC | Local PC reference time (Default).
ExternalSource | external time source.
ExternalAbsolute | external absolute synchronized time.

◆ UnfinalizedFlagsType

enum UnfinalizedFlagsType

Standard Flags for unfinalized MDF.

Bit combination of flags that indicate the steps required to finalize the MDF file. For a finalized MDF file, the value must be 0 (no flag set).

Enumerator
UpdateCGBlockRequired

Update of record counters for CGBLOCKs required.

The value for the number of records (i.e. number of samples) in a CGBLCOK may be wrong (zero or not up-to-date). This flag must only be set in case a successful restoration is possible, i.e. if any of the following restrictions for the data block of the parent DGBLOCK is fulfilled: The data block is limited by the end of the file (EOF).

  • The data block is limited by the start of another MDF block within the block hierarchy of the MDF file.
  • The data block is limited by a value not used as record ID (only in case a record ID is used).
  • The data block is limited by a record that contains an invalid time stamp, e.g. a time stamp smaller than the previous time stamp within the same channel group.

A correction of the record counters usually requires the iteration over all records, so this may also be done during sorting an unsorted data block (see 4.2).

UpdateSRBlockRequired

Update of reduced sample counters for SRBLOCKs required The value for the number of reduced samples in a SRBLOCKs may be wrong (zero or not up-to-date). This flag must only be set in case a successful restoration is possible, i.e. if any of the following restrictions for the data block of the SRBLOCK is fulfilled:

  • The data block is limited by the end of the file (EOF).
  • The data block is limited by the start of another MDF block within the block hierarchy of the MDF file.
  • The data block is limited by a record that contains an invalid time stamp for the interval start, e.g. a time stamp smaller than the previous time stamp.

A correction of the reduced sample counters usually requires the iteration over all records.


ASAP2Library interface: jnsoft.MDF.Examples Namespace Reference

  • MDF
  • Examples
jnsoft.MDF.Examples Namespace Reference


ASAP2Library interface: jnsoft.MDF.Examples.Reader Namespace Reference

  • MDF
  • Examples
  • Reader
Classes
jnsoft.MDF.Examples.Reader Namespace Reference

Classes

class Program
MDF Reader example. More...


ASAP2Library interface: Program Class Reference

  • MDF
  • Examples
  • Reader
  • Program
List of all members
Program Class Reference

MDF Reader example. More...

Detailed Description

MDF Reader example.

  • Loading an MDF file
  • Read data as raw data samples.
  • Iterating over measurement data

Usage: ASAP2MDFReaderExample MDFFile.mdf


ASAP2Library interface: Member List

  • MDF
  • Examples
  • Reader
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: jnsoft.MDF.Examples.Writer Namespace Reference

  • MDF
  • Examples
  • Writer
Classes
jnsoft.MDF.Examples.Writer Namespace Reference

Classes

class Program
MDF Writer example. More...


ASAP2Library interface: Program Class Reference

  • MDF
  • Examples
  • Writer
  • Program
List of all members
Program Class Reference

MDF Writer example. More...

Detailed Description

MDF Writer example.

  • Loading an A2L file
  • Recording sample data for all Measurements contained in the specified A2L file
  • Recording a 4k raw data sample block.

Usage: ASAP2MDFWriterExample A2LFile.a2l


ASAP2Library interface: Member List

  • MDF
  • Examples
  • Writer
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: jnsoft.MDF.V3 Namespace Reference

  • MDF
  • V3
Classes | Enumerations
jnsoft.MDF.V3 Namespace Reference

Implements the MDF V1.XX..V3.XX specific stuff. More...

Classes

class | BLOCKBASE
Base class for all MDF V3 BLOCK types (except the IDBLOCK). More...
class | CCBLOCK
MDF V3 CCBLOCK. More...
class | CDBLOCK
The Channel Dependency Block. More...
class | CEBLOCK
The Channel Extension Block. More...
class | CGBLOCK
The Channel Group Block. More...
class | CNBLOCK
The Channel Block. More...
class | DGBLOCK
The Data Group Block. More...
class | HDBLOCK
The Header Block. More...
class | IDBLOCK
The File Identification Block More...
class | SRBLOCK
The Sample Reduction Block. More...
class | TRBLOCK
The Trigger Block More...
class | TXBLOCK
The Text Block. More...

Enumerations

enum | ExtensionType { DIM = 2 , VectorCAN = 19 }
Extension type identifier More...
enum | FPFormatType { IEEE_754 , G_FLOAT , D_FLOAT }
Floating point format types More...

Detailed Description

Implements the MDF V1.XX..V3.XX specific stuff.

Enumeration Type Documentation

◆ ExtensionType

enum ExtensionType

Extension type identifier

Note:

  • for CAN signals, ExtensionType.VectorCAN (19) should be used
  • for ECU signals (CCP, XCP), ExtensionType.DIM should be used
Enumerator
DIM | DIM block supplement
VectorCAN | Vector CAN block supplement

◆ FPFormatType

enum FPFormatType

Floating point format types

Enumerator
IEEE_754 | Floating-point format compliant with IEEE 754 standard.
G_FLOAT | Floating-point format compliant with G_Float (VAX architecture) (obsolete).
D_FLOAT | Floating-point format compliant with D_Float (VAX architecture) (obsolete).


ASAP2Library interface: BLOCKBASE Class Reference

  • MDF
  • V3
  • BLOCKBASE
Public Member Functions | Protected Member Functions | Properties | List of all members
BLOCKBASE Class Reference

Base class for all MDF V3 BLOCK types (except the IDBLOCK). More...

Public Member Functions

override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Protected Member Functions

BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Properties

long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Base class for all MDF V3 BLOCK types (except the IDBLOCK).

Constructor & Destructor Documentation

◆ BLOCKBASE()

BLOCKBASE | ( | string | id,
 |  | int | blockSize
 | ) |  |
protected

Creates a new instance of BLOCKBASE with the specified parameters.

Parameters
id | The block id (always 2 characters)
blockSize | The structure size

Member Function Documentation

◆ writeBlock()

virtual long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Implements IMDFBlock.

Reimplemented in TXBLOCK, CEBLOCK, CDBLOCK, CCBLOCK, CNBLOCK, SRBLOCK, CGBLOCK, TRBLOCK, DGBLOCK, and HDBLOCK.


ASAP2Library interface: Member List

  • MDF
  • V3
  • BLOCKBASE
BLOCKBASE Member List

This is the complete list of members for BLOCKBASE, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
Id | BLOCKBASE |
Name (defined in BLOCKBASE) | BLOCKBASE |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASE | virtual


ASAP2Library interface: CCBLOCK Class Reference

  • MDF
  • V3
  • CCBLOCK
Public Member Functions | Properties | List of all members
CCBLOCK Class Reference

MDF V3 CCBLOCK. More...

Public Member Functions

CCBLOCK (ConversionType conversionType, string unit, double min=double.NaN, double max=double.NaN)
double | toPhysical (double rawValue, bool useInversed=false)
Computes the physical value from a raw value. More...
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

string | Comment [get]
ConversionType | ConversionType [get]
DateType | Date [get]
Data for ConversionType.Date
string | DefaultText = string.Empty [getset]
string | Formula = string.Empty [getset]
ICCBLOCK | InvCCBlock [get]
SortedList< object, object > | KeyValuePairs = new SortedList<object, object>() [getset]
double | Max = double.NaN [getset]
double | Min = double.NaN [getset]
double[] | Params [getset]
ushort | TabSize [getset]
TimeType | Time [get]
Data for ConversionType.Time
string | Unit [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICCBLOCK
ConversionType | ConversionType [get]
string | DefaultText [getset]
DefaultText for ConversionType.TextRange
string | Formula [getset]
Formula string for ConversionType.TextFormula
ICCBLOCK | InvCCBlock [get]
Link to inverse CCBlock (V4 only).
SortedList< object, object > | KeyValuePairs [getset]
Key/Value pairs for ConversionType.TextTable, ConversionType.Tab, ConversionType.TabInt
double | Max [getset]
Maximum physical signal value
double | Min [getset]
Minimum physical signal value
double[] | Params [getset]
Formula string for ConversionType.ParametricLinear, ConversionType.Polynomial, ConversionType.Exponential, ConversionType.Logarithmic, ConversionType.Rational
ushort | TabSize [get]
string | Unit [get]
Physical unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

MDF V3 CCBLOCK.

Member Function Documentation

◆ toPhysical()

double toPhysical | ( | double | rawValue,
 |  | bool | useInversed = false
 | ) |  |

Computes the physical value from a raw value.

Parameters
rawValue | The raw value to convert
useInversed | Use inversed rational function parameters
Returns
the physical value

Implements ICCBLOCK.

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • CCBLOCK
CCBLOCK Member List

This is the complete list of members for CCBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CCBLOCK(ConversionType conversionType, string unit, double min=double.NaN, double max=double.NaN) (defined in CCBLOCK) | CCBLOCK |
Comment (defined in CCBLOCK) | CCBLOCK |
ConversionType (defined in CCBLOCK) | CCBLOCK |
Date | CCBLOCK |
DefaultText (defined in CCBLOCK) | CCBLOCK |
Formula (defined in CCBLOCK) | CCBLOCK |
Id | BLOCKBASE |
InvCCBlock (defined in CCBLOCK) | CCBLOCK |
KeyValuePairs (defined in CCBLOCK) | CCBLOCK |
Max (defined in CCBLOCK) | CCBLOCK |
Min (defined in CCBLOCK) | CCBLOCK |
Name (defined in BLOCKBASE) | BLOCKBASE |
Params (defined in CCBLOCK) | CCBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
TabSize (defined in CCBLOCK) | CCBLOCK |
Tag (defined in BLOCKBASE) | BLOCKBASE |
Time | CCBLOCK |
toPhysical(double rawValue, bool useInversed=false) | CCBLOCK |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
Unit (defined in CCBLOCK) | CCBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | CCBLOCK | virtual


ASAP2Library interface: CDBLOCK Class Reference

  • MDF
  • V3
  • CDBLOCK
Public Member Functions | Properties | List of all members
CDBLOCK Class Reference

The Channel Dependency Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

List< DependencyType > | Dependencies = new List<DependencyType>() [get]
ushort | DependencyType [get]
Dependency type. More...
override string | Name [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Channel Dependency Block.

A signal may be a composition of other signals, e.g. for a map/curve or a structure. When saving such a compound signal, this can be modelled in MDF by a CNBLOCK for the compound signal itself having a link to a CDBLOCK. The CDBLOCK then lists all signal dependencies, i.e. all signals the compound signal consists of.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.

Property Documentation

◆ DependencyType

ushort DependencyType
get

Dependency type.

0 = no dependency 1 = linear dependency (vector) 2 = matrix dependency (signals for each matrix line in a separate CGBLOCK) Since version 3.01: 255 + N = N-dimensional dependency (size of each dimension is listed after the variable length LINK list, dependent signals can be stored in same CGBLOCK)


ASAP2Library interface: Member List

  • MDF
  • V3
  • CDBLOCK
CDBLOCK Member List

This is the complete list of members for CDBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CDBLOCK() (defined in CDBLOCK) | CDBLOCK |
Dependencies (defined in CDBLOCK) | CDBLOCK |
DependencyType | CDBLOCK |
Id | BLOCKBASE |
Name (defined in CDBLOCK) | CDBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
writeBlock(BinaryWriter bw, bool isLast=true) | CDBLOCK | virtual


ASAP2Library interface: CEBLOCK Class Reference

  • MDF
  • V3
  • CEBLOCK
Public Member Functions | Properties | List of all members
CEBLOCK Class Reference

The Channel Extension Block. More...

Public Member Functions

CEBLOCK (DIMType dim)
CEBLOCK (VectorCANType vectorCAN)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

DIMType | DIM [getset]
DIM block supplement
ExtensionType | ExtensionType [get]
override string | Name [get]
VectorCANType | VectorCAN [getset]
Vector CAN block supplement
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Channel Extension Block.

The CEBLOCK serves to specify source specific properties of a channel, e.g. name of the ECU or name and sender of the CAN message.

Note:

  • for CAN signals, type Vector CAN(19) should be used
  • for ECU signals(CCP, XCP), type DIM(2) should be used

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • CEBLOCK
CEBLOCK Member List

This is the complete list of members for CEBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CEBLOCK(DIMType dim) (defined in CEBLOCK) | CEBLOCK |
CEBLOCK(VectorCANType vectorCAN) (defined in CEBLOCK) | CEBLOCK |
DIM | CEBLOCK |
ExtensionType (defined in CEBLOCK) | CEBLOCK |
Id | BLOCKBASE |
Name (defined in CEBLOCK) | CEBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
VectorCAN | CEBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | CEBLOCK | virtual


ASAP2Library interface: CGBLOCK Class Reference

  • MDF
  • V3
  • CGBLOCK
Public Member Functions | Properties | List of all members
CGBLOCK Class Reference

The Channel Group Block. More...

Public Member Functions

CGBLOCK (IDGBLOCK dgBlock, string comment=null)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

List< ICNBLOCK > | CNBlocks = new List<ICNBLOCK>() [get]
string | Comment [getset]
IDGBLOCK | DGBlock [getset]
override string | Name [get]
ulong | RecordCount [getset]
ulong | RecordID [get]
Record ID, i.e. value of the identifier for a record if the DGBLOCK defines a number of record IDs > 0
uint | RecordSize [getset]
List< ISRBLOCK > | SRBlocks = new List<ISRBLOCK>() [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICGBLOCK
List< ICNBLOCK > | CNBlocks [get]
Gets the corresponding CNBLOCK (Channel reduction) children.
IDGBLOCK | DGBlock [get]
Gets the parent data group of the channel group.
ulong | RecordCount [getset]
Number of records of this type in the data block, i.e. number of samples for this channel group.
ulong | RecordID [get]
Record ID, i.e. value of the identifier for a record if the DGBLOCK defines a number of record IDs > 0
uint | RecordSize [getset]
Size of data record in Bytes (without record ID), i.e. size of plain data (including the time channel) for a each recorded sample of this channel group.
List< ISRBLOCK > | SRBlocks [get]
List of SRBlocks.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Channel Group Block.

The CGBLOCK contains a collection of channels which are stored in a record, i.e. which have the same time sampling.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • CGBLOCK
CGBLOCK Member List

This is the complete list of members for CGBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CGBLOCK(IDGBLOCK dgBlock, string comment=null) (defined in CGBLOCK) | CGBLOCK |
CNBlocks (defined in CGBLOCK) | CGBLOCK |
Comment (defined in CGBLOCK) | CGBLOCK |
DGBlock (defined in CGBLOCK) | CGBLOCK |
Id | BLOCKBASE |
Name (defined in CGBLOCK) | CGBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
RecordCount (defined in CGBLOCK) | CGBLOCK |
RecordID | CGBLOCK |
RecordSize (defined in CGBLOCK) | CGBLOCK |
SRBlocks (defined in CGBLOCK) | CGBLOCK |
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
writeBlock(BinaryWriter bw, bool isLast=true) | CGBLOCK | virtual


ASAP2Library interface: CNBLOCK Class Reference

  • MDF
  • V3
  • CNBLOCK
Public Member Functions | Properties | List of all members
CNBLOCK Class Reference

The Channel Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

uint | AddOffset [getset]
ulong | BitmaskCache [getset]
ushort | BitOffset [getset]
ICCBLOCK | CCBlock [get]
IMDFBlock | CDBlock [get]
IMDFBlock | CEBlock [get]
ICGBLOCK | CGBlock [get]
ChannelType | ChannelType [get]
IList< ICNBLOCK > | CNBlocks [get]
string | Comment = string.Empty [getset]
string | Description [get]
string | DisplayName = string.Empty [getset]
string | LongName = string.Empty [getset]
double? | Max [get]
double | MaxEx [get]
double | MaxRaw = double.NaN [getset]
double? | Min [get]
double | MinEx [get]
double | MinRaw = double.NaN [getset]
override string | Name [getprotected set]
uint | NoOfBits [getset]
double | Rate [getset]
Sampling rate for a virtual time channel in [s].
SignalType | SignalType [get]
SyncType | SyncType [get]
string? | Unit [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICNBLOCK
uint | AddOffset [get]
Gets the Offset to the first Byte in the data record that contains bits of the signal value. More...
ulong | BitmaskCache [getset]
Internal used cache for already computed bitmasks
ushort | BitOffset [get]
Gets the the Bit offset (0-7): first bit (=LSB) of signal value after Byte offset has been applied(see 5.21.4.2 Reading the Signal Value). More...
ICCBLOCK | CCBlock [get]
Gets the corresponding CCBLOCK.
IMDFBlock | CDBlock [get]
Gets the corresponding CDBlock (only valid format smaller than V4.00).
IMDFBlock | CEBlock [get]
Gets the coresponding CEBlock (only valid format smaller than V4.00).
ICGBLOCK | CGBlock [get]
Gets the parent channel group of the channel.
ChannelType | ChannelType [get]
Gets the channel's type
IList< ICNBLOCK > | CNBlocks [get]
Gets the corresponding Sub-CNBLOCKs (Only V4 supported).
string | Description [get]
Gets the channel's description
double | Max [get]
Maximum signal value that occurred for this signal (physical value)
double | MaxEx [get]
Extende Maximum signal value that occurred for this signal (physical value)
double | MaxRaw [getset]
Maximum signal value that occurred for this signal (raw value)
double | Min [get]
Minimum signal value that occurred for this signal (physical value)
double | MinEx [get]
Extende Minimum signal value that occurred for this signal (physical value)
double | MinRaw [getset]
Minimum signal value that occurred for this signal (raw value)
uint | NoOfBits [getset]
Gets the Number of bits for signal value in record.
double | Rate [get]
Gets the channel's rate
SignalType | SignalType [get]
Gets the signal type.
SyncType | SyncType [get]
Gets the synchronization type
string | Unit [get]
Gets the chanels' Unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Channel Block.

The channel block contains detailed information about a signal and how it is stored in the record.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • CNBLOCK
CNBLOCK Member List

This is the complete list of members for CNBLOCK, including all inherited members.

AddOffset (defined in CNBLOCK) | CNBLOCK |
BitmaskCache (defined in CNBLOCK) | CNBLOCK |
BitOffset (defined in CNBLOCK) | CNBLOCK |
BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CCBlock (defined in CNBLOCK) | CNBLOCK |
CDBlock (defined in CNBLOCK) | CNBLOCK |
CEBlock (defined in CNBLOCK) | CNBLOCK |
CGBlock (defined in CNBLOCK) | CNBLOCK |
ChannelType (defined in CNBLOCK) | CNBLOCK |
CNBlocks (defined in CNBLOCK) | CNBLOCK |
Comment (defined in CNBLOCK) | CNBLOCK |
Description (defined in CNBLOCK) | CNBLOCK |
DisplayName (defined in CNBLOCK) | CNBLOCK |
Id | BLOCKBASE |
LongName (defined in CNBLOCK) | CNBLOCK |
Max (defined in CNBLOCK) | CNBLOCK |
MaxEx (defined in CNBLOCK) | CNBLOCK |
MaxRaw (defined in CNBLOCK) | CNBLOCK |
Min (defined in CNBLOCK) | CNBLOCK |
MinEx (defined in CNBLOCK) | CNBLOCK |
MinRaw (defined in CNBLOCK) | CNBLOCK |
Name (defined in CNBLOCK) | CNBLOCK |
NoOfBits (defined in CNBLOCK) | CNBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
Rate | CNBLOCK |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
SignalType (defined in CNBLOCK) | CNBLOCK |
SyncType (defined in CNBLOCK) | CNBLOCK |
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
Unit (defined in CNBLOCK) | CNBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | CNBLOCK | virtual


ASAP2Library interface: DGBLOCK Class Reference

  • MDF
  • V3
  • DGBLOCK
Public Member Functions | Properties | Events | List of all members
DGBLOCK Class Reference

The Data Group Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

List< ICGBLOCK > | CGBlocks = new List<ICGBLOCK>() [get]
string | Comment [get]
override string | Name [get]
RecordIDType | RecordIDType [get]
TRBLOCK | TRBlock [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IDGBLOCK
List< ICGBLOCK > | CGBlocks [get]
Gets the corresponding CGBLOCK (Channel group) children.
RecordIDType | RecordIDType [get]
Gets the record ID type.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Events

EventHandler< WriteRawDataEventArgs > | OnWriteRawData
- Events inherited from IDGBLOCK
EventHandler< WriteRawDataEventArgs > | OnWriteRawData
The handler to write recorded raw Data. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Data Group Block.

The DGBLOCK gathers information and links related to its data block. Thus the branch in the tree of MDF blocks that is opened by the DGBLOCK contains all information necessary to understand and decode the data block referenced by the DGBLOCK.

The DGBLOCK can contain several channel groups. In this case the MDF file is "unsorted". If there is only one channel group in the DGBLOCK, the MDF file is "sorted" (please refer to chapter 4 for details).

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • DGBLOCK
DGBLOCK Member List

This is the complete list of members for DGBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
CGBlocks (defined in DGBLOCK) | DGBLOCK |
Comment (defined in DGBLOCK) | DGBLOCK |
DGBLOCK() (defined in DGBLOCK) | DGBLOCK |
Id | BLOCKBASE |
Name (defined in DGBLOCK) | DGBLOCK |
OnWriteRawData (defined in DGBLOCK) | DGBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
RecordIDType (defined in DGBLOCK) | DGBLOCK |
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
TRBlock (defined in DGBLOCK) | DGBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | DGBLOCK | virtual


ASAP2Library interface: HDBLOCK Class Reference

  • MDF
  • V3
  • HDBLOCK
Public Member Functions | Properties | List of all members
HDBLOCK Class Reference

The Header Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

string | Author [getset]
string | Comment = string.Empty [getset]
string | Date [get]
List< IDGBLOCK > | DGBlocks = new List<IDGBLOCK>() [get]
override string? | Name [get]
string | Organization [getset]
string | ProgramSpecificData = string.Empty [getset]
PRBLOCK Data.
string | Project [getset]
DateTime? | RecordingTime [get]
string | Subject [getset]
string | Time [get]
TimeQualityType | TimeQuality [get]
string | TimerID [get]
DateTime | TimeStamp [get]
short | UTCOffset [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IHDBLOCK
List< IDGBLOCK > | DGBlocks [get]
Gets the corresponding DGBLOCK (Data group) children.
DateTime | RecordingTime [get]
Time, the recording was started
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Header Block.

The HDBLOCK always begins at file position 64. It contains general information about the contents of the measured data file.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • HDBLOCK
HDBLOCK Member List

This is the complete list of members for HDBLOCK, including all inherited members.

Author (defined in HDBLOCK) | HDBLOCK |
BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
Comment (defined in HDBLOCK) | HDBLOCK |
Date (defined in HDBLOCK) | HDBLOCK |
DGBlocks (defined in HDBLOCK) | HDBLOCK |
Id | BLOCKBASE |
Name (defined in HDBLOCK) | HDBLOCK |
Organization (defined in HDBLOCK) | HDBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
ProgramSpecificData | HDBLOCK |
Project (defined in HDBLOCK) | HDBLOCK |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
RecordingTime (defined in HDBLOCK) | HDBLOCK |
Subject (defined in HDBLOCK) | HDBLOCK |
Tag (defined in BLOCKBASE) | BLOCKBASE |
Time (defined in HDBLOCK) | HDBLOCK |
TimeQuality (defined in HDBLOCK) | HDBLOCK |
TimerID (defined in HDBLOCK) | HDBLOCK |
TimeStamp (defined in HDBLOCK) | HDBLOCK |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
UTCOffset (defined in HDBLOCK) | HDBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | HDBLOCK | virtual


ASAP2Library interface: IDBLOCK Class Reference

  • MDF
  • V3
  • IDBLOCK
Public Member Functions | Properties | List of all members
IDBLOCK Class Reference

The File Identification Block More...

Public Member Functions

IDBLOCK (string programID, ushort codePage, ushort version=330, FPFormatType fpFormat=FPFormatType.IEEE_754)
Creates a standard conformant IDBlock with the specified programID. More...
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

long | BlockSize [get]
BYTEORDER_TYPE | ByteOrder [get]
ushort | CodePage [get]
CustomFlagsType | CustomFlags [get]
string | FileID [get]
string | FormatId [get]
FPFormatType | FPFormat [get]
string | Name [get]
IMDFBlock | Parent [get]
string | ProgramId [getset]
object | Tag [getset]
MDFType | Type [get]
UnfinalizedFlagsType | UnfinalizedFlags [get]
ushort | Version [get]
- Properties inherited from IIDBLOCK
CustomFlagsType | CustomFlags [get]
Custom Flags for unfinalized MDF.
string | FileID [get]
File identifier, always contains "MDF␣␣␣␣␣"
string | ProgramId [getset]
Program ID
MDFType | Type [get]
V1..V3 or V4 MDF type. (not contained in file content)
UnfinalizedFlagsType | UnfinalizedFlags [get]
Standard Flags for unfinalized MDF.
ushort | Version [get]
Version number of MDF format
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

The File Identification Block

The IDBLOCK always begins at file position 0 and has a constant length of 64 Bytes. It contains information to identify the file. This includes information about the source of the file and general format specifications.

Constructor & Destructor Documentation

◆ IDBLOCK()

IDBLOCK | ( | string | programID,
 |  | ushort | codePage,
 |  | ushort | version = 330,
 |  | FPFormatType | fpFormat = FPFormatType.IEEE_754
 | ) |  |

Creates a standard conformant IDBlock with the specified programID.

Parameters
programID | programID String (max 8 Bytes)
codePage | Codepage
version | Version
fpFormat | floating point format

Member Function Documentation

◆ writeBlock()

long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Implements IMDFBlock.


ASAP2Library interface: Member List

  • MDF
  • V3
  • IDBLOCK
IDBLOCK Member List

This is the complete list of members for IDBLOCK, including all inherited members.

BlockSize (defined in IDBLOCK) | IDBLOCK
ByteOrder (defined in IDBLOCK) | IDBLOCK
CodePage (defined in IDBLOCK) | IDBLOCK
CustomFlags (defined in IDBLOCK) | IDBLOCK
FileID (defined in IDBLOCK) | IDBLOCK
FormatId (defined in IDBLOCK) | IDBLOCK
FPFormat (defined in IDBLOCK) | IDBLOCK
IDBLOCK(string programID, ushort codePage, ushort version=330, FPFormatType fpFormat=FPFormatType.IEEE_754) | IDBLOCK
Name (defined in IDBLOCK) | IDBLOCK
Parent (defined in IDBLOCK) | IDBLOCK
ProgramId (defined in IDBLOCK) | IDBLOCK
Tag (defined in IDBLOCK) | IDBLOCK
Type (defined in IDBLOCK) | IDBLOCK
UnfinalizedFlags (defined in IDBLOCK) | IDBLOCK
Version (defined in IDBLOCK) | IDBLOCK
writeBlock(BinaryWriter bw, bool isLast=true) | IDBLOCK


ASAP2Library interface: SRBLOCK Class Reference

  • MDF
  • V3
  • SRBLOCK
Public Member Functions | Properties | List of all members
SRBLOCK Class Reference

The Sample Reduction Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

double | LenOfTimeInt [get]
ulong | NrOfRedSamples [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ISRBLOCK
double | LenOfTimeInt [get]
Length of time interval [s] used to calculate the reduced samples.
ulong | NrOfRedSamples [get]
Number of reduced samples in the data block

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Sample Reduction Block.

The SRBLOCK serves to describe a sample reduction for a channel group, i.e. an alternative sampling of the signals in the channel group with a usually lower number of sampling points. There can be several sample reductions for the same channel group which are stored in a forward linked list of SRBLOCKs starting at the CGBLOCK. Each SRBLOCK describes a sample reduction calculated with a specific time interval. Roughly explained, the reduction divides the time axis into intervals of the given fixed length and compresses all samples within one interval to three values: mean, minimum and maximum value. Each sample reduction applies to all signals of its parent channel group. For details of calculating and storing a sample reduction for a channel group, see below. Sample reductions are only "convenience" information to accelerate graphical display or offline analysis of the signal data. It may be omitted without any loss of information. If not present, it can be added later by offline processing of the file.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • SRBLOCK
SRBLOCK Member List

This is the complete list of members for SRBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
Id | BLOCKBASE |
LenOfTimeInt (defined in SRBLOCK) | SRBLOCK |
Name (defined in BLOCKBASE) | BLOCKBASE |
NrOfRedSamples (defined in SRBLOCK) | SRBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
writeBlock(BinaryWriter bw, bool isLast=true) | SRBLOCK | virtual


ASAP2Library interface: TRBLOCK Class Reference

  • MDF
  • V3
  • TRBLOCK
Classes | Public Member Functions | Properties | List of all members
TRBLOCK Class Reference

The Trigger Block More...

Classes

class TriggerEvent
Trigger event data. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

string | Comment [getset]
override string | Name [get]
List< TriggerEvent > | TriggerEvents = new List<TriggerEvent>() [get]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Trigger Block

The TRBLOCK serves to describe trigger events that occurred during the recording. The trigger events are related to a data group. For each trigger event, the time when the trigger occurred is recorded. As additional information, the pre and post trigger times of the trigger event can be stated, i.e. the time periods recorded before and after the trigger occurred. The comment might be used to give information about the trigger source or condition.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • TRBLOCK
TRBLOCK Member List

This is the complete list of members for TRBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
Comment (defined in TRBLOCK) | TRBLOCK |
Id | BLOCKBASE |
Name (defined in TRBLOCK) | TRBLOCK |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
TriggerEvents (defined in TRBLOCK) | TRBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | TRBLOCK | virtual


ASAP2Library interface: TRBLOCK.TriggerEvent Class Reference

  • MDF
  • V3
  • TRBLOCK
  • TriggerEvent
Public Member Functions | Properties | List of all members
TRBLOCK.TriggerEvent Class Reference

Trigger event data. More...

Public Member Functions

TriggerEvent (double time, double preTime, double postTime)

Properties

double | PostTime [get]
double | PreTime [get]
double | Time [get]

Detailed Description

Trigger event data.


ASAP2Library interface: Member List

  • MDF
  • V3
  • TRBLOCK
  • TriggerEvent
TRBLOCK.TriggerEvent Member List

This is the complete list of members for TRBLOCK.TriggerEvent, including all inherited members.

PostTime (defined in TRBLOCK.TriggerEvent) | TRBLOCK.TriggerEvent
PreTime (defined in TRBLOCK.TriggerEvent) | TRBLOCK.TriggerEvent
Time (defined in TRBLOCK.TriggerEvent) | TRBLOCK.TriggerEvent
TriggerEvent(double time, double preTime, double postTime) (defined in TRBLOCK.TriggerEvent) | TRBLOCK.TriggerEvent


ASAP2Library interface: TXBLOCK Class Reference

  • MDF
  • V3
  • TXBLOCK
Public Member Functions | Properties | List of all members
TXBLOCK Class Reference

The Text Block. More...

Public Member Functions

TXBLOCK (string text)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASE
override string | ToString ()

Properties

string | Text = string.Empty [getset]
- Properties inherited from BLOCKBASE
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
IMDFBlock | Parent [getset]
object | Tag [getset]
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASE
BLOCKBASE (string id, int blockSize)
Creates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Detailed Description

The Text Block.

The TXBLOCK contains an optional comment for the measured data file, channel group or signal, or the long name of a signal.The text length results from the block size.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Reimplemented from BLOCKBASE.


ASAP2Library interface: Member List

  • MDF
  • V3
  • TXBLOCK
TXBLOCK Member List

This is the complete list of members for TXBLOCK, including all inherited members.

BLOCKBASE() (defined in BLOCKBASE) | BLOCKBASE | protected
BLOCKBASE(string id, int blockSize) | BLOCKBASE | protected
BlockSize (defined in BLOCKBASE) | BLOCKBASE |
Id | BLOCKBASE |
Name (defined in BLOCKBASE) | BLOCKBASE |
Parent (defined in BLOCKBASE) | BLOCKBASE |
readData(BinaryReader br) (defined in BLOCKBASE) | BLOCKBASE | protected
Tag (defined in BLOCKBASE) | BLOCKBASE |
Text (defined in TXBLOCK) | TXBLOCK |
ToString() (defined in BLOCKBASE) | BLOCKBASE |
TXBLOCK(string text) (defined in TXBLOCK) | TXBLOCK |
writeBlock(BinaryWriter bw, bool isLast=true) | TXBLOCK | virtual


ASAP2Library interface: jnsoft.MDF.V4 Namespace Reference

  • MDF
  • V4
Classes | Enumerations
jnsoft.MDF.V4 Namespace Reference

Implements the MDF V4.XX specific stuff. More...

Classes

class | ATBLOCKV4
Container for binary data or a reference to an external file. More...
class | BaseNames
Base class SI and CN comments More...
class | BLOCKBASEV4
Base class for all BLOCKV4 types (except the IDBLOCK). More...
class | CABLOCKV4
The channel array block. More...
class | CCBLOCKV4
MDF V4 CCBLOCK. More...
class | CGBLOCKV4
The Channel Group Block. More...
class | CHBLOCKV4
Channel hierarchy block. More...
class | CNBLOCKV4
The Channel Block. More...
class | CNcomment
MDF V4 Xml CNBLOCKV4 comment More...
class | CommentBase
Base class for TXBLOCK references More...
class | DataContainerV4
Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4. More...
class | DescType
Description of object. May exist in defferent languages. More...
class | DGBLOCKV4
The Data Group Block V4. More...
class | DisplayType
Display name of object. May exist in different languages. More...
class | DLBLOCKV4
DL Block. More...
class | DTBLOCKV4
Container for data records with signal values. More...
class | DZBLOCKV4
DZ Block. More...
class | EBase
Base class for e and tree node. More...
class | EType
MDF V4 Xml e Node More...
class | EVBLOCKV4
Event block. More...
class | FHBLOCKV4
File history block. More...
class | FHcomment
MDF V4 Xml HDBLOCKV4 comment More...
class | HDBLOCKV4
The Header Block V4. More...
class | HDcomment
MDF V4 Xml HDBLOCKV4 comment More...
class | HLBLOCKV4
Header information for linked list of data blocks. More...
class | IDBLOCKV4
The File Identification Block V4 More...
class | NamesBase
Base Name More...
class | NamesType
Name of object in different languages More...
class | RasterType
MDF V4 Xml Raster structure More...
class | RDSDBLOCKV4
Base class for SD, MD or RD blocks. More...
class | SIBLOCKV4
Source information block. More...
class | SIcomment
MDF V4 Xml SIBLOCKV4 comment More...
class | SRBLOCKV4
The Sample Reduction Block. More...
class | TreeType
MDF V4 Xml Tree More...
class | VendorType
Vendor specific name, e.g. name as used in a specific tool. More...
class | XmlBase
Base implementation for any MDF V4 Xml structure. More...

Enumerations

enum | AttachmentFlags { EmbeddedData = 0x01 , CompressedEmbbeddedData = EmbeddedData << 1 , MD5ChecksumValid = EmbeddedData << 2 }
Attachment flags. More...
enum BusType {
NONE , OTHER , CAN , LIN ,
MOST , FLEXRAY , K_LINE , ETHERNET ,
USB
}
Bus type, additional classification of used bus(should be 0 for SourceType ≥ SourceType.TOOL):
enum CAFlags {
None , DynamicSize , InputQuantity = DynamicSize << 1 , OutputQuantity = DynamicSize << 2 ,
ComparisonQuantity = DynamicSize << 3 , Axis = DynamicSize << 4 , FixedAxis = DynamicSize << 5 , InverseLayout = DynamicSize << 6
}
enum | CATemplate : byte { CN , CG , DG }
Storage (template) types More...
enum | CAType : byte { Array , Axis , LookUp }
Array types More...
enum CauseType {
Other , Error , Tool , Script ,
User
}
Cause of event More...
enum ChannelFlags {
None , Invalid = 1 , InvalBytesValid = Invalid << 1 , PrecisionValid = Invalid << 2 ,
ValueRangeValid = Invalid << 3 , LimitRangeValid = Invalid << 4 , ExtendedLimitRangeValid = Invalid << 5 , DiscreteValue = Invalid << 6 ,
Calibration = Invalid << 7 , Calculated = Invalid << 8 , Virtual = Invalid << 9 , BusEvent = Invalid << 10 ,
Montonous = Invalid << 11 , DefaultXAxis = Invalid << 12
}
Supported Channel Flags. More...
enum | ChannelGroupFlags { VLSD = 1 , BusEvent = VLSD << 1 , PlainBusEvent = VLSD << 2 }
SUpported Channel group flags. More...
enum | ConversionFlags { PrecisionValid = 0x01 , LimitRangeValid = PrecisionValid << 1 , StatusString = PrecisionValid << 2 }
Supported converson flags. More...
enum | DataBlockFlags { EqualLength = 1 }
Datablock flags. More...
enum | EventFlags { PostProcessing = 0x01 }
Event flags More...
enum EventType {
Recording , RecordingInterrupt , AcquisitionInterrupt , StartRecordingTrigger ,
StopRecordingTrigger , Trigger , Marker
}
Event type flags. More...
enum HierarchyType {
Group , Function , Structure , MapList ,
InMeasurement , OutMeasurement , LocMeasurement , DefCharacteristic ,
RefCharacteristic
}
Type of hierarchy level More...
enum | RangeType { Point , BeginRange , EndRange }
Range type More...
enum | SourceFlags { None , SimulatedSource = 0x01 }
Source information flags. More...
enum SourceType {
OTHER , ECU , BUS , IO ,
TOOL , USER
}
Source type. More...
enum | SRFlags { InvalidationBytes = 0x01 }
Sample reduction flags. More...
enum | ZipType { Deflate , TransposeAndDeflate , None }
Supported zip types. More...

Detailed Description

Implements the MDF V4.XX specific stuff.

Advantages over previous MDF versions:

  • File size could be greater than 4 GB
  • Measurement data could be compressed

Enumeration Type Documentation

◆ AttachmentFlags

enum AttachmentFlags

Attachment flags.

Enumerator
EmbeddedData | If set, the attachment data is embedded, otherwise it is contained in an external file referenced by file path and name in ATBLOCKV4.Filename.
CompressedEmbbeddedData | If set, the stream for the embedded data is compressed using the Deflate zip algorithm (see[DEF] and[ZLIB]). Can only be set if "embedded data" flag(bit 0) is set.
MD5ChecksumValid | If set, the at_md5_checksum field contains the MD5 check sum of the data.

◆ CAFlags

enum CAFlags

Enumerator
DynamicSize | If set, the number of scaling points for the array is not fixed but can vary over time.
InputQuantity | If set, a channel for the input quantity is specified for each dimension by ca_input_quantity
OutputQuantity | If set, a channel for the output quantity is specified by ca_output_quantity.
ComparisonQuantity | If set, a channel for the comparison quantity is specified by ca_comparison_quantity.
Axis | If set, a scaling axis is given for each dimension of the array, either as fixed or as dynamic axis, depending on "fixed axis" flag (bit 5).
FixedAxis | If set, the scaling axis is fixed and the axis points are stored as raw values in ca_axis_value list.
InverseLayout | If set, the record layout is "column oriented" instead of "row oriented".

◆ CATemplate

enum CATemplate : byte

Storage (template) types

Enumerator
CN | Values of all elements of the array are stored in the same record (i.e. all elements are measured together).
CG | Value for each element of the array is stored in a separate record (i.e. elements are stored independently of each other).
DG | Similar to CG template, the value of each element of the array is stored in a separate record (i.e. elements are stored independently of each other).

◆ CAType

enum CAType : byte

Array types

Enumerator
Array | The array is a simple D-dimensional value array (value block) without axes and without input/output/comparison quantities.
Axis | The array is an axis (1-dimensional vector), possibly referenced by one or more arrays of type "look-up" (ca_type = 2).
LookUp | The array is a D-dimensional array with axes. It can have input/output/comparison quantities.

◆ CauseType

enum CauseType

Cause of event

Enumerator
Other | cause of event is not known or does not fit into given categories.
Error | event was caused by some error.
Tool | event was caused by tool-internal condition, e.g. trigger condition or reconfiguration.
Script | event was caused by a scripting command.
User | event was caused directly by user, e.g. user input or some other interaction with GUI.

◆ ChannelFlags

enum ChannelFlags

Supported Channel Flags.

Enumerator
Invalid | If set, all values of this channel are invalid. If in addition an invalidation bit is used (bit 1 set), then the value of the invalidation bit must be set (high) for every value of this channel. Must not be set for a master channel (channel types 2 and 3).
InvalBytesValid | If set, this channel uses an invalidation bit (position specified by cn_inval_bit_pos). Must not be set if cg_inval_bytes is zero. Must not be set for a master channel (channel types 2 and 3).
PrecisionValid | If set, the precision value for display of floating point values specified in cn_precision is valid and overrules a possibly specified precision value of the conversion rule (cc_precision).
ValueRangeValid | If set, both the minimum and the maximum raw value that occurred for this signal within the samples recorded in this file are known and stored in cn_val_range_min and cn_val_range_max. Otherwise the two fields are not valid. Note: the raw value range can only be expressed for numeric channel data types (cn_data_type smaller 6). For all other data types, the flag must not be set.
LimitRangeValid | If set, the limits of the signal value are known and stored in cn_limit_min and cn_limit_max. Otherwise the two fields are not valid (see [MCD-2 MC] keywords LowerLimit/UpperLimit for MEASUREMENT and CHARACTERISTIC). This limit range defines the range of plausible values for this channel and may be used for display a warning. Note: the (extended) limit range can only be expressed for a channel whose conversion rule returns a numeric value (REAL) or which has a numeric channel data type (cn_data_type smaller or equal 5). In all other cases, the flag must not be set. Depending on the type of conversion, the limit values are interpreted as physical or raw values. If the conversion rule results in numeric values, the limits must be interpreted as physical values, otherwise (e.g. for verbal / scale conversion) as raw values.
ExtendedLimitRangeValid | If set, the extended limits of the signal value are known and stored in cn_limit_ext_min and cn_limit_ext_max. Otherwise the two fields are not valid. (see [MCD-2 MC] keyword EXTENDED_LIMITS) The extended limit range must be larger or equal to the limit range (if valid). Values outside the extended limit range indicate an error during measurement acquisition. The extended limit range can be used for any limits, e.g. physical ranges from analog sensors. See also remarks for 'limit range valid' flag (bit 4).
DiscreteValue | If set, the signal values of this channel are discrete and must not be interpolated. (see [MCD-2 MC] keyword DISCRETE).
Calibration | If set, the signal values of this channel correspond to a calibration object, otherwise to a measurement object (see [MCD-2 MC] keywords MEASUREMENT and CHARACTERISTIC).
Calculated | If set, the values of this channel have been calculated from other channel inputs. (see [MCD-2 MC] keywords VIRTUAL and DEPENDENT_CHARACTERISTIC) In MDBLOCK for cn_md_comment the used input signals and the calculation formula can be documented, see Table 37.
Virtual | If set, this channel is virtual, i.e. it is simulated by the recording tool. (see [MCD-2 MC] keywords VIRTUAL and VIRTUAL_CHARACTERISTIC) Note: for a virtual measurement according to MCD-2 MC both the 'Virtual' flag (bit 9) and the 'Calculated' flag (bit 8) should be set.
BusEvent | If set, this channel contains information about a bus event. For details please refer to [MDFBL]. Valid since MDF 4.1.0, should not be set for earlier versions.
Montonous | If set, this channel contains only strictly monotonous increasing/decreasing values. The flag is optional. valid since MDF 4.1.0, should not be set for earlier versions.
DefaultXAxis | If set, a channel to be preferably used as X axis is specified by cn_default_x. This is only a recommendation, a tool may choose to use a different X axis. Valid since MDF 4.1.0, should not be set for earlier versions.

◆ ChannelGroupFlags

enum ChannelGroupFlags

SUpported Channel group flags.

Enumerator
VLSD | If set, this is a "variable length signal data" (VLSD) channel group. See explanation in 5.14.3 Variable Length Signal Data (VLSD) CGBLOCKV4.
BusEvent | If set, this channel group contains information about a bus event, i.e. it contains a structure channel with bit 10 (bus event flag) set in cn_flags. For details please refer to [MDF-BL]. valid since MDF 4.1.0, should not be set for earlier versions.
PlainBusEvent | Only relevant if "bus event channel group" flag (bit 1) is set. If set, this indicates that only the plain bus event is stored in this channel group, but no channels describing the signals transported in the payload of the bus event. If not set, at least one channel for a signal transported in the payload of the bus event (data frame/PDU) must be present. For details please refer to [MDF-BL]. valid since MDF 4.1.0, should not be set for earlier versions.

◆ ConversionFlags

enum ConversionFlags

Supported converson flags.

Enumerator
PrecisionValid | If set, the precision value for display of floating point values specified in cc_precision is valid
LimitRangeValid | If set, both the minimum and the maximum physical value that occurred after conversion for this signal within the samples recorded in this file are known and stored in cc_phy_range_min and cc_phy_range_max. Otherwise the two fields are not valid. Note: the physical value range can only be expressed for conversions which return a numeric value (REAL). For conversions returning a string value or for the inverse conversion rule the flag must not be set.
StatusString | This flag indicates for conversion types 7 and 8 (value/value range to text/scale conversion tabular look-up) that the normal table entries are status strings (only reference to TXBLOCK), and the actual conversion rule is given in CCBLOCK referenced by default value. This also implies special handling of limits, see [MCD-2 MC] keyword STATUS_STRING_REF. Can only be set for cc_type between 7 and 8.

◆ DataBlockFlags

enum DataBlockFlags

Datablock flags.

Enumerator
EqualLength

If set, each DLBLOCK in the linked list has the same number of referenced blocks (dl_count) and the (uncompressed) data sections of the blocks referenced by dl_data have a common length given by dl_equal_length. The only exception is that for the last DLBLOCK in the list (dl_dl_next = NIL), its number of referenced blocks dl_count can be less than or equal to dl_count of the previous DLBLOCK, and the data section length of its last referenced block (dl_data[dl_count-1]) can be less than or equal to dl_equal_length.

If not set, the number of referenced blocks dl_count may be different for each DLBLOCK in the linked list, and the data section lengths of the referenced blocks may be different and a table of offsets is given in dl_offset. Note: The value of the "equal length" flag must be equal for all DLBLOCKs in the linked list.

◆ EventFlags

enum EventFlags

Event flags

Enumerator
PostProcessing

If set, the event has been generated during post processing of the file.

◆ EventType

enum EventType

Event type flags.

Enumerator
Recording | This event type specifies a recording period, i.e. the first and last time a signal value could theoretically be recorded. Recording events must always define a range, i.e. ev_range_type between 1 and 2. All recording events in the MDF file must only occur on exactly one scope level: either all have a global scope, e.g. if file has been created by a single recorder; or all of them have a scope on CG level (ev_scope list must contain links to one or more CGBLOCKs), e.g. after combining two files. Recording events which apply to single channels only (CN level scope) generally is not possible. Within one scope, there can be several recording periods, e.g. if the recording was paused between these periods (although this should be modeled by a recording interrupt event, see below). However, these periods must not overlap.
RecordingInterrupt | This event type indicates that the recording has been interrupted. It can only occur within the range of a matching recording period. Like the recording event type, it can only have a global scope or a CG level scope. It should be either on the same scope level as the recording event, or on a lower level, i.e. if the recording events have a global scope, the recording interrupt event can either have a global or a CG level scope. A recording interrupt can be defined as point single event) or as range (pair of events as explained for ev_ev_range). If it defines a point, the interruption should be considered to automatically have finished when the next sample for a signal value for a channel in its scope level occurred. Since a recording interrupt event is closely related to a recording period, its ev_ev_parent should point to the respective "range begin" recording event.
AcquisitionInterrupt | This event type indicates that not only the recording, but already the acquisition of the signal values has been interrupted. Except of this, the same rules apply as for the recording interrupt event type.
StartRecordingTrigger | This event type specifies an event which started the recording of signal values due to some condition (including user interaction). The trigger condition can be specified in the ev_md_comment MDBLOCK, (see Table 27). Here also a pre and post trigger interval can be specified. A start recording trigger event can only occur as point (ev_range_type = 0), not as range. It usually is closely related to a recording period, i.e. it should have the same scope as the respective recording events (note that due to the pre-trigger interval, the matching "range begin" recording event can be before this event). Here ev_ev_parent may be used to point to the "range begin" recording event. For some other use case, ev_ev_parent instead might point to another trigger event, e.g. if this trigger activated the condition for the start recording trigger.
StopRecordingTrigger | Symmetrically to the "start recording trigger" event type, this event type specifies an event which stopped the recording of signal values due to some condition. The same rules apply as for the start recording trigger event type. Note that the two event types may occur in pairs, but they do not have to.
Trigger | This event type generally specifies an event that occurred due to some condition (except of the special start and stop recording trigger event types). The trigger condition can be specified in the ev_md_comment MDBLOCK, (see Table 27). A trigger event can only occur as point (ev_range_type = 0), not as range.
Marker | This event type specifies a marker for a point or a range. As examples, a marker could be a user-generated comment or an automatically generated bookmark.

◆ HierarchyType

enum HierarchyType

Type of hierarchy level

Enumerator
Group

All elements and children of this hierarchy level form a logical group (see [MCD-2 MC] keyword GROUP).

Function

All children of this hierarchy level form a functional group (see [MCD-2 MC] keyword FUNCTION).

For this type, the hierarchy must not contain CNBLOCK references (ch_element_count must be 0).

Structure

All elements and children of this hierarchy level form a 'fragmented' structure, see 5.18.1 Structures.

Note: Do not use 'fragmented' and 'compact' structure in parallel. If possible prefer a 'compact' structure.

MapList

All elements of this hierarchy level form a map list (see [MCD-2 MC] keyword MAP_LIST):

  • the first element represents the z axis (must be a curve, i.e. CNBLOCK with CABLOCK of type 'scaling axis')
  • all other elements represent the maps (must be 2-dimensional map, i.e. CNBLOCK with CABLOCK of type 'lookup')
InMeasurement

input variables of function (see [MCD-2 MC] keyword IN_MEASUREMENT). All referenced channels must be measurement objects (Calibration flag not set in CNBLOCKV4.Flags).

OutMeasurement

output variables of function see [MCD-2 MC] keyword OUT_MEASUREMENT). All referenced channels must be measurement objects (Calibration flag not set in CNBLOCKV4.Flags).

LocMeasurement

local variables of function (see [MCD-2 MC] keyword LOC_MEASUREMENT). All referenced channels must be measurement objects (Calibration flag not set in CNBLOCKV4.Flags).

DefCharacteristic

calibration objects defined in function (see [MCD-2 MC] keyword DEF_CHARACTERISTIC). All referenced channels must be calibration objects (Calibration flag set in CNBLOCKV4.Flags).

RefCharacteristic

calibration objects referenced in function (see [MCD-2 MC] keyword REF_CHARACTERISTIC). All referenced channel must be calibration objects (Calibration flag set in CNBLOCKV4.Flags).

◆ RangeType

enum RangeType

Range type

Enumerator
Point | event defines a point
BeginRange | event defines the beginning of a range
EndRange | event defines the end of a range

◆ SourceFlags

enum SourceFlags

Source information flags.

Enumerator
SimulatedSource

Source is only a simulation (can be hardware or software simulated). Cannot be set for SourceType.TOOL.

◆ SourceType

enum SourceType

Source type.

Enumerator
OTHER | A source type which does not fit into given categories or is unknown
ECU | The ECU
BUS | a bus (e.g. for bus monitoring)
IO | I/O device (e.g. analog I/O)
TOOL | a software tool (e.g. for tool generated signals/events)
USER | a user interaction/input (e.g. for user generated events)

◆ SRFlags

enum SRFlags

Sample reduction flags.

Enumerator
InvalidationBytes

If set, the sample reduction record contains invalidation Bytes, i.e. after the three data Byte sections for mean, minimum and maximum values, there is one invalidation Byte section. If not set, the invalidation Bytes are omitted. Must only be set if cg_inval_bytes > 0. If invalidation Bytes are used, and if the invalidation bit of the respective channel is valid (i.e. "invalidation bit valid" flag (bit 1) is set in cn_flags), then a set invalidation bit in the invalidation Bytes of the sample reduction record means that within the sample interval all signal values of the respective channel have been invalid.

◆ ZipType

enum ZipType

Supported zip types.

Enumerator
Deflate | The Deflate zip algorithm as used in various zip implementations (see ZLIB).
TransposeAndDeflate | Before compression, the data block is transposed as explained in 5.26.2 Transposition of Data. Typically only used for sorted data groups and DT or RD block types.
None | Internal value to indicate that no zip algorithm is used.


ASAP2Library interface: ATBLOCKV4 Class Reference

  • MDF
  • V4
  • ATBLOCKV4
Properties | List of all members
ATBLOCKV4 Class Reference

Container for binary data or a reference to an external file. More...

Properties

AttachmentFlags | AttachmentFlags [get]
string | Comment = string.Empty [getset]
ushort | CreatorIndex [get]
Creator index. More...
string | Filename = string.Empty [get]
string | MimeType = string.Empty [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Container for binary data or a reference to an external file.

Property Documentation

◆ CreatorIndex

ushort CreatorIndex
get

Creator index.

i.e. zero-based index of FHBLOCK in global list of FHBLOCKs that specifies which application has created this attachment, or changed it most recently.


ASAP2Library interface: Member List

  • MDF
  • V4
  • ATBLOCKV4
ATBLOCKV4 Member List

This is the complete list of members for ATBLOCKV4, including all inherited members.

AttachmentFlags (defined in ATBLOCKV4) | ATBLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Comment (defined in ATBLOCKV4) | ATBLOCKV4 |
CreatorIndex | ATBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Filename (defined in ATBLOCKV4) | ATBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
MimeType (defined in ATBLOCKV4) | ATBLOCKV4 |
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: BaseNames Class Reference

  • MDF
  • V4
  • BaseNames
Public Attributes | List of all members
BaseNames Class Reference

Base class SI and CN comments More...

Public Attributes

List< NamesBase > | names
Alternative source names and descriptions
- Public Attributes inherited from CommentBase
List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Protected Member Functions inherited from XmlBase
abstract string | serialize ()
string | serialize (XmlSerializer serializer)
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

Base class SI and CN comments


ASAP2Library interface: Member List

  • MDF
  • V4
  • BaseNames
BaseNames Member List

This is the complete list of members for BaseNames, including all inherited members.

common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
names | BaseNames |
serialize() (defined in XmlBase) | XmlBase | protectedpure virtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
TX | CommentBase |


ASAP2Library interface: BLOCKBASEV4 Class Reference

  • MDF
  • V4
  • BLOCKBASEV4
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | Properties | List of all members
BLOCKBASEV4 Class Reference

Base class for all BLOCKV4 types (except the IDBLOCK). More...

Public Member Functions

override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Protected Member Functions

BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Protected Attributes

long[] | mLinkList
ulong | mNoLinks

Static Protected Attributes

const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Properties

long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Base class for all BLOCKV4 types (except the IDBLOCK).

Constructor & Destructor Documentation

◆ BLOCKBASEV4()

BLOCKBASEV4 | ( | string | id,
 |  | long | structSize,
 |  | int | noLinks
 | ) |  |
protected

CReates a new instance of BLOCKBASE with the specified parameters.

Parameters
id | The block id (always 2 characters)
structSize | The structure size
noLinks | Number of links

Member Function Documentation

◆ writeBlock()

virtual long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Implements IMDFBlock.

Reimplemented in RDSDBLOCKV4, FHBLOCKV4, HDBLOCKV4, DGBLOCKV4, HLBLOCKV4, DZBLOCKV4, DLBLOCKV4, SIBLOCKV4, CGBLOCKV4, SRBLOCKV4, CNBLOCKV4, and CCBLOCKV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • BLOCKBASEV4
BLOCKBASEV4 Member List

This is the complete list of members for BLOCKBASEV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: CABLOCKV4 Class Reference

  • MDF
  • V4
  • CABLOCKV4
Properties | List of all members
CABLOCKV4 Class Reference

The channel array block. More...

Properties

double[] | AxisValue [getset]
List of raw values for (fixed) axis points of each axis.
uint | ByteOffsetBase [getset]
Base factor for calculation of Byte offsets for CN template storage type.
ulong[] | CycleCount [getset]
List of cycle counts for each element in case of "CG/DG template" storage.
ulong | DimSize [getset]
Maximum number of elements for each dimension N(d).
CAFlags | Flags [getset]
uint | InvalBitPosBase [getset]
Base factor for calculation of invalidation bit positions for CN template storage type.
ushort | NDim [getset]
Number of dimensions
CATemplate | TemplateType [getset]
Storage type (defines how the element values are stored).
CAType | Type [getset]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The channel array block.

The CABLOCK is used to model an array.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CABLOCKV4
CABLOCKV4 Member List

This is the complete list of members for CABLOCKV4, including all inherited members.

AxisValue | CABLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
ByteOffsetBase | CABLOCKV4 |
CycleCount | CABLOCKV4 |
DimSize | CABLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in CABLOCKV4) | CABLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
InvalBitPosBase | CABLOCKV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
NDim | CABLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
TemplateType | CABLOCKV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Type (defined in CABLOCKV4) | CABLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: CCBLOCKV4 Class Reference

  • MDF
  • V4
  • CCBLOCKV4
Public Member Functions | Properties | List of all members
CCBLOCKV4 Class Reference

MDF V4 CCBLOCK. More...

Public Member Functions

CCBLOCKV4 (BinaryReader br)
CCBLOCKV4 (ConversionType conversionType, string unit, double min=double.NaN, double max=double.NaN)
double | toPhysical (double rawValue, bool useInversed=false)
Computes the physical value from a raw value. More...
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

string | Comment = string.Empty [get]
ConversionType | ConversionType [get]
string | DefaultText = string.Empty [getset]
ConversionFlags | Flags [get]
string | Formula = string.Empty [getset]
ICCBLOCK | InvCCBlock [get]
SortedList< object, object > | KeyValuePairs = new SortedList<object, object>() [getset]
double | Max = double.NaN [getset]
double | Min = double.NaN [getset]
override string | Name = string.Empty [getprotected set]
double[] | Params [getset]
byte | Precision [get]
ushort | RefCount [get]
ushort | TabSize [getset]
string | Unit = string.Empty [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICCBLOCK
ConversionType | ConversionType [get]
string | DefaultText [getset]
DefaultText for ConversionType.TextRange
string | Formula [getset]
Formula string for ConversionType.TextFormula
ICCBLOCK | InvCCBlock [get]
Link to inverse CCBlock (V4 only).
SortedList< object, object > | KeyValuePairs [getset]
Key/Value pairs for ConversionType.TextTable, ConversionType.Tab, ConversionType.TabInt
double | Max [getset]
Maximum physical signal value
double | Min [getset]
Minimum physical signal value
double[] | Params [getset]
Formula string for ConversionType.ParametricLinear, ConversionType.Polynomial, ConversionType.Exponential, ConversionType.Logarithmic, ConversionType.Rational
ushort | TabSize [get]
string | Unit [get]
Physical unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

MDF V4 CCBLOCK.

Member Function Documentation

◆ toPhysical()

double toPhysical | ( | double | rawValue,
 |  | bool | useInversed = false
 | ) |  |

Computes the physical value from a raw value.

Parameters
rawValue | The raw value to convert
useInversed | Use inversed rational function parameters
Returns
the physical value

Implements ICCBLOCK.

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CCBLOCKV4
CCBLOCKV4 Member List

This is the complete list of members for CCBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CCBLOCKV4(BinaryReader br) (defined in CCBLOCKV4) | CCBLOCKV4 |
CCBLOCKV4(ConversionType conversionType, string unit, double min=double.NaN, double max=double.NaN) (defined in CCBLOCKV4) | CCBLOCKV4 |
CCBLOCKV4() (defined in CCBLOCKV4) | CCBLOCKV4 |
Comment (defined in CCBLOCKV4) | CCBLOCKV4 |
ConversionType (defined in CCBLOCKV4) | CCBLOCKV4 |
DefaultText (defined in CCBLOCKV4) | CCBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in CCBLOCKV4) | CCBLOCKV4 |
Formula (defined in CCBLOCKV4) | CCBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
InvCCBlock (defined in CCBLOCKV4) | CCBLOCKV4 |
KeyValuePairs (defined in CCBLOCKV4) | CCBLOCKV4 |
Max (defined in CCBLOCKV4) | CCBLOCKV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Min (defined in CCBLOCKV4) | CCBLOCKV4 |
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in CCBLOCKV4) | CCBLOCKV4 |
Params (defined in CCBLOCKV4) | CCBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Precision (defined in CCBLOCKV4) | CCBLOCKV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
RefCount (defined in CCBLOCKV4) | CCBLOCKV4 |
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
TabSize (defined in CCBLOCKV4) | CCBLOCKV4 |
Tag | BLOCKBASEV4 |
toPhysical(double rawValue, bool useInversed=false) | CCBLOCKV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Unit (defined in CCBLOCKV4) | CCBLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | CCBLOCKV4 | virtual


ASAP2Library interface: CGBLOCKV4 Class Reference

  • MDF
  • V4
  • CGBLOCKV4
Public Member Functions | Properties | List of all members
CGBLOCKV4 Class Reference

The Channel Group Block. More...

Public Member Functions

CGBLOCKV4 (IDGBLOCK dgBlock, string comment=null)
void | Dispose ()
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

string | AcquisitionName [getset]
SIBLOCKV4 | AcquisitionSource [getset]
List< ICNBLOCK > | CNBlocks = new List<ICNBLOCK>() [get]
string | Comment [getset]
IDGBLOCK | DGBlock [getset]
ChannelGroupFlags | Flags [get]
uint | InvalSize [get]
Number of additional Bytes for record used for invalidation bits. More...
override string | Name [get]
char | PathSeparator [get]
ulong | RecordCount [getset]
Number of records of this type in the data block, i.e. number of samples for this channel group.
ulong | RecordID [get]
Record ID, i.e. value of the identifier for a record if the DGBLOCK defines a number of record IDs > 0
uint | RecordSize [getset]
Size of data record in Bytes (without record ID), i.e. size of plain data for a each recorded sample of this channel group.
List< ISRBLOCK > | SRBlocks = new List<ISRBLOCK>() [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICGBLOCK
List< ICNBLOCK > | CNBlocks [get]
Gets the corresponding CNBLOCK (Channel reduction) children.
IDGBLOCK | DGBlock [get]
Gets the parent data group of the channel group.
ulong | RecordCount [getset]
Number of records of this type in the data block, i.e. number of samples for this channel group.
ulong | RecordID [get]
Record ID, i.e. value of the identifier for a record if the DGBLOCK defines a number of record IDs > 0
uint | RecordSize [getset]
Size of data record in Bytes (without record ID), i.e. size of plain data (including the time channel) for a each recorded sample of this channel group.
List< ISRBLOCK > | SRBlocks [get]
List of SRBlocks.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The Channel Group Block.

The CGBLOCK contains a collection of channels which are stored in a record, i.e. which have the same time sampling.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.

Property Documentation

◆ InvalSize

uint InvalSize
get

Number of additional Bytes for record used for invalidation bits.

Can be zero if no invalidation bits are used at all. Invalidation bits may only occur in the specified number of Bytes after the data Bytes, not within the data Bytes that contain the signal values.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CGBLOCKV4
CGBLOCKV4 Member List

This is the complete list of members for CGBLOCKV4, including all inherited members.

AcquisitionName (defined in CGBLOCKV4) | CGBLOCKV4 |
AcquisitionSource (defined in CGBLOCKV4) | CGBLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CGBLOCKV4(IDGBLOCK dgBlock, string comment=null) (defined in CGBLOCKV4) | CGBLOCKV4 |
CNBlocks (defined in CGBLOCKV4) | CGBLOCKV4 |
Comment (defined in CGBLOCKV4) | CGBLOCKV4 |
DGBlock (defined in CGBLOCKV4) | CGBLOCKV4 |
Dispose() (defined in CGBLOCKV4) | CGBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in CGBLOCKV4) | CGBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
InvalSize | CGBLOCKV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in CGBLOCKV4) | CGBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
PathSeparator (defined in CGBLOCKV4) | CGBLOCKV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
RecordCount | CGBLOCKV4 |
RecordID | CGBLOCKV4 |
RecordSize | CGBLOCKV4 |
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SRBlocks (defined in CGBLOCKV4) | CGBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | CGBLOCKV4 | virtual


ASAP2Library interface: CHBLOCKV4 Class Reference

  • MDF
  • V4
  • CHBLOCKV4
Properties | List of all members
CHBLOCKV4 Class Reference

Channel hierarchy block. More...

Properties

List< CHBLOCKV4 > | CHBlocks = new List<CHBLOCKV4>() [get]
string | Comment = string.Empty [getset]
List< DependencyType > | Dependencies = new List<DependencyType>() [get]
HierarchyType | HierarchyType [get]
override string | Name = string.Empty [getprotected set]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Channel hierarchy block.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CHBLOCKV4
CHBLOCKV4 Member List

This is the complete list of members for CHBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CHBlocks (defined in CHBLOCKV4) | CHBLOCKV4 |
Comment (defined in CHBLOCKV4) | CHBLOCKV4 |
Dependencies (defined in CHBLOCKV4) | CHBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
HierarchyType (defined in CHBLOCKV4) | CHBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in CHBLOCKV4) | CHBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: CNBLOCKV4 Class Reference

  • MDF
  • V4
  • CNBLOCKV4
Public Member Functions | Properties | List of all members
CNBLOCKV4 Class Reference

The Channel Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

uint | AddOffset [get]
List< ATBLOCKV4 > | Attachments = new List<ATBLOCKV4>() [get]
ulong | BitmaskCache [getset]
ushort | BitOffset [get]
CABLOCKV4 | CABlock [getset]
Channel array block(CABLOCK) (can be NIL).
ICCBLOCK | CCBlock [getset]
IMDFBlock | CDBlock [getset]
IMDFBlock | CEBlock [getset]
ICGBLOCK | CGBlock [get]
ChannelType | ChannelType [get]
Gets the channel's type
IList< ICNBLOCK > | CNBlocks = new List<ICNBLOCK>() [get]
List of Sub CN Blocks
string | Comment = string.Empty [getset]
string | Description [get]
ChannelFlags | Flags [get]
Channel specific flags
uint | InvalBitPos [get]
double | Max = double.NaN [getset]
double | MaxEx = double.NaN [getset]
double | MaxRaw = double.NaN [getset]
double | Min = double.NaN [getset]
double | MinEx = double.NaN [getset]
double | MinRaw = double.NaN [getset]
override string | Name [getprotected set]
uint | NoOfBits [getset]
byte | Precision [get]
double | Rate [get]
BLOCKBASEV4 | SDBlock [getset]
SIBLOCKV4 | SIBlock [get]
SignalType | SignalType [get]
Gets the signal type.
SyncType | SyncType [get]
string?? | Unit [getset]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ICNBLOCK
uint | AddOffset [get]
Gets the Offset to the first Byte in the data record that contains bits of the signal value. More...
ulong | BitmaskCache [getset]
Internal used cache for already computed bitmasks
ushort | BitOffset [get]
Gets the the Bit offset (0-7): first bit (=LSB) of signal value after Byte offset has been applied(see 5.21.4.2 Reading the Signal Value). More...
ICCBLOCK | CCBlock [get]
Gets the corresponding CCBLOCK.
IMDFBlock | CDBlock [get]
Gets the corresponding CDBlock (only valid format smaller than V4.00).
IMDFBlock | CEBlock [get]
Gets the coresponding CEBlock (only valid format smaller than V4.00).
ICGBLOCK | CGBlock [get]
Gets the parent channel group of the channel.
ChannelType | ChannelType [get]
Gets the channel's type
IList< ICNBLOCK > | CNBlocks [get]
Gets the corresponding Sub-CNBLOCKs (Only V4 supported).
string | Description [get]
Gets the channel's description
double | Max [get]
Maximum signal value that occurred for this signal (physical value)
double | MaxEx [get]
Extende Maximum signal value that occurred for this signal (physical value)
double | MaxRaw [getset]
Maximum signal value that occurred for this signal (raw value)
double | Min [get]
Minimum signal value that occurred for this signal (physical value)
double | MinEx [get]
Extende Minimum signal value that occurred for this signal (physical value)
double | MinRaw [getset]
Minimum signal value that occurred for this signal (raw value)
uint | NoOfBits [getset]
Gets the Number of bits for signal value in record.
double | Rate [get]
Gets the channel's rate
SignalType | SignalType [get]
Gets the signal type.
SyncType | SyncType [get]
Gets the synchronization type
string | Unit [get]
Gets the chanels' Unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The Channel Block.

The channel block contains detailed information about a signal and how it is stored in the record.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CNBLOCKV4
CNBLOCKV4 Member List

This is the complete list of members for CNBLOCKV4, including all inherited members.

AddOffset (defined in CNBLOCKV4) | CNBLOCKV4 |
Attachments (defined in CNBLOCKV4) | CNBLOCKV4 |
BitmaskCache (defined in CNBLOCKV4) | CNBLOCKV4 |
BitOffset (defined in CNBLOCKV4) | CNBLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CABlock | CNBLOCKV4 |
CCBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
CDBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
CEBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
CGBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
ChannelType | CNBLOCKV4 |
CNBlocks | CNBLOCKV4 |
Comment (defined in CNBLOCKV4) | CNBLOCKV4 |
Description (defined in CNBLOCKV4) | CNBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags | CNBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
InvalBitPos (defined in CNBLOCKV4) | CNBLOCKV4 |
Max (defined in CNBLOCKV4) | CNBLOCKV4 |
MaxEx (defined in CNBLOCKV4) | CNBLOCKV4 |
MaxRaw (defined in CNBLOCKV4) | CNBLOCKV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Min (defined in CNBLOCKV4) | CNBLOCKV4 |
MinEx (defined in CNBLOCKV4) | CNBLOCKV4 |
MinRaw (defined in CNBLOCKV4) | CNBLOCKV4 |
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in CNBLOCKV4) | CNBLOCKV4 |
NoOfBits (defined in CNBLOCKV4) | CNBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Precision (defined in CNBLOCKV4) | CNBLOCKV4 |
Rate (defined in CNBLOCKV4) | CNBLOCKV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SDBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
SIBlock (defined in CNBLOCKV4) | CNBLOCKV4 |
SignalType | CNBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SyncType (defined in CNBLOCKV4) | CNBLOCKV4 |
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Unit (defined in CNBLOCKV4) | CNBLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | CNBLOCKV4 | virtual


ASAP2Library interface: CNcomment Class Reference

  • MDF
  • V4
  • CNcomment
Public Attributes | Protected Member Functions | List of all members
CNcomment Class Reference

MDF V4 Xml CNBLOCKV4 comment More...

Public Attributes

MONOTONY_TYPE | axis_monotony = MONOTONY_TYPE.NotSet
Axis monotony
AddressType | linker_address
Linker address
string | linker_name
Linker name
RasterType | raster
Raster definition
- Public Attributes inherited from BaseNames
List< NamesBase > | names
Alternative source names and descriptions
- Public Attributes inherited from CommentBase
List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Protected Member Functions

override string | serialize ()
- Protected Member Functions inherited from XmlBase
string | serialize (XmlSerializer serializer)

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

MDF V4 Xml CNBLOCKV4 comment

Member Function Documentation

◆ serialize()

override string serialize ( )
protectedvirtual

Implements XmlBase.


ASAP2Library interface: Member List

  • MDF
  • V4
  • CNcomment
CNcomment Member List

This is the complete list of members for CNcomment, including all inherited members.

axis_monotony | CNcomment |
common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
linker_address | CNcomment |
linker_name | CNcomment |
MDF_NS (defined in XmlBase) | XmlBase | static
names | BaseNames |
raster | CNcomment |
serialize() (defined in CNcomment) | CNcomment | protectedvirtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
TX | CommentBase |


ASAP2Library interface: CommentBase Class Reference

  • MDF
  • V4
  • CommentBase
Public Attributes | List of all members
CommentBase Class Reference

Base class for TXBLOCK references More...

Public Attributes

List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Protected Member Functions inherited from XmlBase
abstract string | serialize ()
string | serialize (XmlSerializer serializer)
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

Base class for TXBLOCK references


ASAP2Library interface: Member List

  • MDF
  • V4
  • CommentBase
CommentBase Member List

This is the complete list of members for CommentBase, including all inherited members.

common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
serialize() (defined in XmlBase) | XmlBase | protectedpure virtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
TX | CommentBase |


ASAP2Library interface: DataContainerV4 Class Reference

  • MDF
  • V4
  • DataContainerV4
Protected Member Functions | Protected Attributes | Properties | List of all members
DataContainerV4 Class Reference

Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4. More...

Protected Member Functions

DataContainerV4 (string id, long structSize, int noLinks)
Creates a new instance of DataContainerV4 with the specified parameters. More...
BinaryReader | getReader (long offset, out long maxSize)
void | readDataContainer (BinaryReader br, int dataLinkIdx)
Creates data container from the specified (data container)linkList. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)

Protected Attributes

BinaryReader | mBr
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks

Properties

List< BLOCKBASEV4 > | Blocks = new List<BLOCKBASEV4>() [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4.

Constructor & Destructor Documentation

◆ DataContainerV4()

DataContainerV4 | ( | string | id,
 |  | long | structSize,
 |  | int | noLinks
 | ) |  |
protected

Creates a new instance of DataContainerV4 with the specified parameters.

Parameters
id | The block id (always 2 characters)
structSize | The structure size
noLinks | Number of links

Member Function Documentation

◆ readDataContainer()

void readDataContainer | ( | BinaryReader | br,
 |  | int | dataLinkIdx
 | ) |  |
protected

Creates data container from the specified (data container)linkList.

The containers will be added to the Blocks property.

Parameters
br | data stream to read from
dataLinkIdx | Index into the LinkList to identify the data container link


ASAP2Library interface: Member List

  • MDF
  • V4
  • DataContainerV4
DataContainerV4 Member List

This is the complete list of members for DataContainerV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
Blocks (defined in DataContainerV4) | DataContainerV4 |
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DataContainerV4(string id, long structSize, int noLinks) | DataContainerV4 | protected
DataContainerV4() (defined in DataContainerV4) | DataContainerV4 | protected
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
getReader(long offset, out long maxSize) (defined in DataContainerV4) | DataContainerV4 | protected
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
mBr (defined in DataContainerV4) | DataContainerV4 | protected
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
readDataContainer(BinaryReader br, int dataLinkIdx) | DataContainerV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: DescType Class Reference

  • MDF
  • V4
  • DescType
List of all members
DescType Class Reference

Description of object. May exist in defferent languages. More...

Additional Inherited Members

- Public Attributes inherited from NamesBase
int | ci
Zero-based index into the list of FH blocks.
string | Text
Name Text

Detailed Description

Description of object. May exist in defferent languages.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DescType
DescType Member List

This is the complete list of members for DescType, including all inherited members.

ci | NamesBase
Text | NamesBase


ASAP2Library interface: DGBLOCKV4 Class Reference

  • MDF
  • V4
  • DGBLOCKV4
Public Member Functions | Properties | Events | List of all members
DGBLOCKV4 Class Reference

The Data Group Block V4. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

List< ICGBLOCK > | CGBlocks = new List<ICGBLOCK>() [get]
string | Comment [get]
override string | Name [get]
RecordIDType | RecordIDType [get]
Gets the record ID type.
- Properties inherited from DataContainerV4
List< BLOCKBASEV4 > | Blocks = new List<BLOCKBASEV4>() [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IDGBLOCK
List< ICGBLOCK > | CGBlocks [get]
Gets the corresponding CGBLOCK (Channel group) children.
RecordIDType | RecordIDType [get]
Gets the record ID type.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Events

EventHandler< WriteRawDataEventArgs > | OnWriteRawData
- Events inherited from IDGBLOCK
EventHandler< WriteRawDataEventArgs > | OnWriteRawData
The handler to write recorded raw Data. More...

Additional Inherited Members

- Protected Member Functions inherited from DataContainerV4
DataContainerV4 (string id, long structSize, int noLinks)
Creates a new instance of DataContainerV4 with the specified parameters. More...
BinaryReader | getReader (long offset, out long maxSize)
void | readDataContainer (BinaryReader br, int dataLinkIdx)
Creates data container from the specified (data container)linkList. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from DataContainerV4
BinaryReader | mBr
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The Data Group Block V4.

The DGBLOCK gathers information and links related to its data block. Thus the branch in the tree of MDF blocks that is opened by the DGBLOCK contains all information necessary to understand and decode the data block referenced by the DGBLOCK.

The DGBLOCK can contain several channel groups. In this case the MDF file is "unsorted". If there is only one channel group in the DGBLOCK, the MDF file is "sorted" (please refer to chapter 4 for details).

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DGBLOCKV4
DGBLOCKV4 Member List

This is the complete list of members for DGBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
Blocks (defined in DataContainerV4) | DataContainerV4 |
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CGBlocks (defined in DGBLOCKV4) | DGBLOCKV4 |
Comment (defined in DGBLOCKV4) | DGBLOCKV4 |
DataContainerV4(string id, long structSize, int noLinks) | DataContainerV4 | protected
DataContainerV4() (defined in DataContainerV4) | DataContainerV4 | protected
DGBLOCKV4() (defined in DGBLOCKV4) | DGBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
getReader(long offset, out long maxSize) (defined in DataContainerV4) | DataContainerV4 | protected
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
mBr (defined in DataContainerV4) | DataContainerV4 | protected
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in DGBLOCKV4) | DGBLOCKV4 |
OnWriteRawData (defined in DGBLOCKV4) | DGBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
jnsoft::MDF::IDGBLOCK.readData(long offset, byte[] buffer) | IDataContainer |
readDataContainer(BinaryReader br, int dataLinkIdx) | DataContainerV4 | protected
RecordIDType | DGBLOCKV4 |
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | DGBLOCKV4 | virtual


ASAP2Library interface: DisplayType Class Reference

  • MDF
  • V4
  • DisplayType
List of all members
DisplayType Class Reference

Display name of object. May exist in different languages. More...

Additional Inherited Members

- Public Attributes inherited from NamesBase
int | ci
Zero-based index into the list of FH blocks.
string | Text
Name Text

Detailed Description

Display name of object. May exist in different languages.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DisplayType
DisplayType Member List

This is the complete list of members for DisplayType, including all inherited members.

ci | NamesBase
Text | NamesBase


ASAP2Library interface: DLBLOCKV4 Class Reference

  • MDF
  • V4
  • DLBLOCKV4
Public Member Functions | Properties | List of all members
DLBLOCKV4 Class Reference

DL Block. More...

Public Member Functions

DLBLOCKV4 (DataBlockFlags flags, int count)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

uint | Count [get]
List< BLOCKBASEV4 > | DataBlocks = new List<BLOCKBASEV4>() [get]
ulong | EqualLength [get]
DataBlockFlags | Flags [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

DL Block.

Ordered list of links to (signal/reduction) data blocks if the data is spread over multiple blocks.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DLBLOCKV4
DLBLOCKV4 Member List

This is the complete list of members for DLBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Count (defined in DLBLOCKV4) | DLBLOCKV4 |
DataBlocks (defined in DLBLOCKV4) | DLBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DLBLOCKV4(DataBlockFlags flags, int count) (defined in DLBLOCKV4) | DLBLOCKV4 |
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
EqualLength (defined in DLBLOCKV4) | DLBLOCKV4 |
Flags (defined in DLBLOCKV4) | DLBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | DLBLOCKV4 | virtual


ASAP2Library interface: DTBLOCKV4 Class Reference

  • MDF
  • V4
  • DTBLOCKV4
Properties | List of all members
DTBLOCKV4 Class Reference

Container for data records with signal values. More...

Properties

long | BasePosition [get]
long | Size [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Container for data records with signal values.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DTBLOCKV4
DTBLOCKV4 Member List

This is the complete list of members for DTBLOCKV4, including all inherited members.

BasePosition (defined in DTBLOCKV4) | DTBLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Size (defined in DTBLOCKV4) | DTBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: DZBLOCKV4 Class Reference

  • MDF
  • V4
  • DZBLOCKV4
Public Member Functions | Properties | List of all members
DZBLOCKV4 Class Reference

DZ Block. More...

Public Member Functions

DZBLOCKV4 (ulong compressedSize, long uncompressedSize, ZipType zipType, uint zipParameter, string blockType=DT)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

ulong | Length [get]
Compressed size of data block.
long | Size [get]
Uncompressed size of data block.
uint | ZipParameter [get]
ZipType | ZipType [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

DZ Block.

Container for zipped (compressed) data section of a DT/SD/RD block as replacement of such a block.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • DZBLOCKV4
DZBLOCKV4 Member List

This is the complete list of members for DZBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZBLOCKV4(ulong compressedSize, long uncompressedSize, ZipType zipType, uint zipParameter, string blockType=DT) (defined in DZBLOCKV4) | DZBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
Length | DZBLOCKV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Size | DZBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | DZBLOCKV4 | virtual
ZipParameter (defined in DZBLOCKV4) | DZBLOCKV4 |
ZipType (defined in DZBLOCKV4) | DZBLOCKV4 |


ASAP2Library interface: EBase Class Reference

  • MDF
  • V4
  • EBase
Public Attributes | List of all members
EBase Class Reference

Base class for e and tree node. More...

Public Attributes

string | desc
Description
string | name
Name

Detailed Description

Base class for e and tree node.


ASAP2Library interface: Member List

  • MDF
  • V4
  • EBase
EBase Member List

This is the complete list of members for EBase, including all inherited members.

desc | EBase
name | EBase


ASAP2Library interface: EType Class Reference

  • MDF
  • V4
  • EType
Public Attributes | List of all members
EType Class Reference

MDF V4 Xml e Node More...

Public Attributes

int | ci
Zero-based index into the list of FH blocks.
bool | ro
Readonly indicator
string | Text
Value
string | type
Datatype
string | unit
Display string for unit
string | unit_ref
ASAM Unit reference
- Public Attributes inherited from EBase
string | desc
Description
string | name
Name

Detailed Description

MDF V4 Xml e Node


ASAP2Library interface: Member List

  • MDF
  • V4
  • EType
EType Member List

This is the complete list of members for EType, including all inherited members.

ci | EType
desc | EBase
name | EBase
ro | EType
Text | EType
type | EType
unit | EType
unit_ref | EType


ASAP2Library interface: EVBLOCKV4 Class Reference

  • MDF
  • V4
  • EVBLOCKV4
Properties | List of all members
EVBLOCKV4 Class Reference

Event block. More...

Properties

CauseType | Cause [get]
string | Comment = string.Empty [getset]
ushort | CreatorIndex [get]
Creator index. More...
EventFlags | Flags [get]
RangeType | Range [get]
SyncType | Sync [get]
long | SyncBaseValue [get]
The synchronization value of the event is the product of base value and factor (ev_sync_base_value x ev_sync_factor). See also remark for ev_sync_factor. More...
double | SyncFactor [get]
Factor for event synchronization value. More...
EventType | Type [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()
virtual long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Event block.

Description of an event.

Property Documentation

◆ CreatorIndex

ushort CreatorIndex
get

Creator index.

i.e. zero-based index of FHBLOCK in global list of FHBLOCKs that specifies which application has created or changed this event (e.g. when generating event offline).

◆ SyncBaseValue

long SyncBaseValue
get

The synchronization value of the event is the product of base value and factor (ev_sync_base_value x ev_sync_factor). See also remark for ev_sync_factor.

The calculated synchronization value depends on ev_sync_type:

  • For ev_sync_type smaller 4, the synchronization value is a time/angle/distance value relative to the respective start value in HDBLOCK.Negative synchronization values can be used for events that occurred before the start value.
  • For ev_sync_type = 4, the synchronization value is the absolute record index in the channel group specified by the scope.The event thus occurred at the same time as the record indicated by the index. In this case, the value must be rounded to an Integer value between 0 and cg_cycle_count, i.e. it must be less than the number of cycles specified for the channel group.

◆ SyncFactor

double SyncFactor
get

Factor for event synchronization value.

The event synchronization value is the product of base value and factor (ev_sync_base_value x ev_sync_factor). Generally, base value and factor can be chosen arbitrarily, but as recommendation they should be used to reflect the raw value and conversion factor of the master channel to be synchronized with. For instance, assume a time master channel using a 64-bit Integer channel data type to store the raw time value in nanoseconds using a linear conversion with offset 0 and factor 1e-9. In this case, ev_sync_factor could be set to 1e-9 and ev_sync_base_value could store the nanosecond time stamp value. Thus, a higher precision is available than when just specifying the time value in seconds as REAL value. For ev_sync_type = 4, ev_sync_factor generally could be set to 1.0, so that the record index will be given by ev_sync_base_value.


ASAP2Library interface: Member List

  • MDF
  • V4
  • EVBLOCKV4
EVBLOCKV4 Member List

This is the complete list of members for EVBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Cause (defined in EVBLOCKV4) | EVBLOCKV4 |
Comment (defined in EVBLOCKV4) | EVBLOCKV4 |
CreatorIndex | EVBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in EVBLOCKV4) | EVBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Range (defined in EVBLOCKV4) | EVBLOCKV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Sync (defined in EVBLOCKV4) | EVBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SyncBaseValue | EVBLOCKV4 |
SyncFactor | EVBLOCKV4 |
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Type (defined in EVBLOCKV4) | EVBLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | BLOCKBASEV4 | virtual


ASAP2Library interface: FHBLOCKV4 Class Reference

  • MDF
  • V4
  • FHBLOCKV4
Public Member Functions | Properties | List of all members
FHBLOCKV4 Class Reference

File history block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

string | Comment = string.Empty [getset]
short | DstOffset [get]
Daylight saving time (DST) offset in minutes for start time stamp.
TimeFlagsType | Flags [get]
DateTime | TimeStamp [get]
short | UTCOffset [get]
Time zone offset in minutes. The value is not necessarily a multiple of 60 and can be negative!
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

File history block.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • FHBLOCKV4
FHBLOCKV4 Member List

This is the complete list of members for FHBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Comment (defined in FHBLOCKV4) | FHBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DstOffset | FHBLOCKV4 |
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in FHBLOCKV4) | FHBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
TimeStamp (defined in FHBLOCKV4) | FHBLOCKV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
UTCOffset | FHBLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | FHBLOCKV4 | virtual


ASAP2Library interface: FHcomment Class Reference

  • MDF
  • V4
  • FHcomment
Public Attributes | Protected Member Functions | List of all members
FHcomment Class Reference

MDF V4 Xml HDBLOCKV4 comment More...

Public Attributes

string | tool_id = string.Empty
Name/identification of the tool that has written this log entry
string | tool_vendor = string.Empty
Name of the vendor/author of the tool
string | tool_version = string.Empty
Version info about the tool that has written this log entry
string | user_name = string.Empty
Name/identification of the user who has written this log entry
- Public Attributes inherited from CommentBase
List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Protected Member Functions

override string | serialize ()
- Protected Member Functions inherited from XmlBase
string | serialize (XmlSerializer serializer)

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

MDF V4 Xml HDBLOCKV4 comment

Member Function Documentation

◆ serialize()

override string serialize ( )
protectedvirtual

Implements XmlBase.


ASAP2Library interface: Member List

  • MDF
  • V4
  • FHcomment
FHcomment Member List

This is the complete list of members for FHcomment, including all inherited members.

common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
serialize() (defined in FHcomment) | FHcomment | protectedvirtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
tool_id | FHcomment |
tool_vendor | FHcomment |
tool_version | FHcomment |
TX | CommentBase |
user_name | FHcomment |


ASAP2Library interface: HDBLOCKV4 Class Reference

  • MDF
  • V4
  • HDBLOCKV4
Public Member Functions | Properties | List of all members
HDBLOCKV4 Class Reference

The Header Block V4. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

List< ATBLOCKV4 > | ATBlocks = new List<ATBLOCKV4>() [get]
List< CHBLOCKV4 > | CHBlocks = new List<CHBLOCKV4>() [get]
string | Comment = string.Empty [getset]
List< IDGBLOCK > | DGBlocks = new List<IDGBLOCK>() [get]
short | DstOffset [get]
Daylight saving time (DST) offset in minutes for start time stamp.
List< EVBLOCKV4 > | EVBlocks = new List<EVBLOCKV4>() [get]
List< FHBLOCKV4 > | FHBlocks = new List<FHBLOCKV4>() [get]
TimeFlagsType | Flags [get]
override string | Name [get]
DateTime | RecordingTime [get]
double | StartAngle = double.NaN [get]
double | StartDistance = double.NaN [get]
TimeQualityType | TimeQuality [get]
short | UTCOffset [get]
Time zone offset in minutes. The value is not necessarily a multiple of 60 and can be negative!
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IHDBLOCK
List< IDGBLOCK > | DGBlocks [get]
Gets the corresponding DGBLOCK (Data group) children.
DateTime | RecordingTime [get]
Time, the recording was started
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The Header Block V4.

The HDBLOCK always begins at file position 64. It contains general information about the contents of the measured data file.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • HDBLOCKV4
HDBLOCKV4 Member List

This is the complete list of members for HDBLOCKV4, including all inherited members.

ATBlocks (defined in HDBLOCKV4) | HDBLOCKV4 |
BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
CHBlocks (defined in HDBLOCKV4) | HDBLOCKV4 |
Comment (defined in HDBLOCKV4) | HDBLOCKV4 |
DGBlocks (defined in HDBLOCKV4) | HDBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DstOffset | HDBLOCKV4 |
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
EVBlocks (defined in HDBLOCKV4) | HDBLOCKV4 |
FHBlocks (defined in HDBLOCKV4) | HDBLOCKV4 |
Flags (defined in HDBLOCKV4) | HDBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in HDBLOCKV4) | HDBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
RecordingTime (defined in HDBLOCKV4) | HDBLOCKV4 |
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
StartAngle (defined in HDBLOCKV4) | HDBLOCKV4 |
StartDistance (defined in HDBLOCKV4) | HDBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
TimeQuality (defined in HDBLOCKV4) | HDBLOCKV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
UTCOffset | HDBLOCKV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | HDBLOCKV4 | virtual


ASAP2Library interface: HDcomment Class Reference

  • MDF
  • V4
  • HDcomment
Public Attributes | Protected Member Functions | List of all members
HDcomment Class Reference

MDF V4 Xml HDBLOCKV4 comment More...

Public Attributes

string | time_source
Time source
- Public Attributes inherited from CommentBase
List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Protected Member Functions

override string | serialize ()
- Protected Member Functions inherited from XmlBase
string | serialize (XmlSerializer serializer)

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

MDF V4 Xml HDBLOCKV4 comment

Member Function Documentation

◆ serialize()

override string serialize ( )
protectedvirtual

Implements XmlBase.


ASAP2Library interface: Member List

  • MDF
  • V4
  • HDcomment
HDcomment Member List

This is the complete list of members for HDcomment, including all inherited members.

common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
serialize() (defined in HDcomment) | HDcomment | protectedvirtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
time_source | HDcomment |
TX | CommentBase |


ASAP2Library interface: HLBLOCKV4 Class Reference

  • MDF
  • V4
  • HLBLOCKV4
Public Member Functions | Properties | List of all members
HLBLOCKV4 Class Reference

Header information for linked list of data blocks. More...

Public Member Functions

HLBLOCKV4 (ZipType zipType, DataBlockFlags flags=DataBlockFlags.EqualLength)
override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

List< DLBLOCKV4 > | DLBlocks = new List<DLBLOCKV4>() [get]
DataBlockFlags | Flags [get]
ZipType | ZipType [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Header information for linked list of data blocks.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • HLBLOCKV4
HLBLOCKV4 Member List

This is the complete list of members for HLBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DLBlocks (defined in HLBLOCKV4) | HLBLOCKV4 |
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in HLBLOCKV4) | HLBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
HLBLOCKV4(ZipType zipType, DataBlockFlags flags=DataBlockFlags.EqualLength) (defined in HLBLOCKV4) | HLBLOCKV4 |
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | HLBLOCKV4 | virtual
ZipType (defined in HLBLOCKV4) | HLBLOCKV4 |


ASAP2Library interface: IDBLOCKV4 Class Reference

  • MDF
  • V4
  • IDBLOCKV4
Public Member Functions | Properties | List of all members
IDBLOCKV4 Class Reference

The File Identification Block V4 More...

Public Member Functions

IDBLOCKV4 (string programID, ushort version=410)
Creates a standard conformant IDBlock with the specified programID. More...
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

long | BlockSize [get]
CustomFlagsType | CustomFlags [get]
string | FileID [get]
string | FormatId [get]
string | Name [get]
IMDFBlock | Parent [get]
string | ProgramId [getset]
object | Tag [getset]
MDFType | Type [get]
UnfinalizedFlagsType | UnfinalizedFlags [get]
ushort | Version [get]
- Properties inherited from IIDBLOCK
CustomFlagsType | CustomFlags [get]
Custom Flags for unfinalized MDF.
string | FileID [get]
File identifier, always contains "MDF␣␣␣␣␣"
string | ProgramId [getset]
Program ID
MDFType | Type [get]
V1..V3 or V4 MDF type. (not contained in file content)
UnfinalizedFlagsType | UnfinalizedFlags [get]
Standard Flags for unfinalized MDF.
ushort | Version [get]
Version number of MDF format
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

The File Identification Block V4

The IDBLOCK always begins at file position 0 and has a constant length of 64 Bytes. It contains information to identify the file. This includes information about the source of the file and general format specifications.

Constructor & Destructor Documentation

◆ IDBLOCKV4()

IDBLOCKV4 | ( | string | programID,
 |  | ushort | version = 410
 | ) |  |

Creates a standard conformant IDBlock with the specified programID.

Parameters
programID | programID String (max 8 Bytes)
version | Version

Member Function Documentation

◆ writeBlock()

long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Implements IMDFBlock.


ASAP2Library interface: Member List

  • MDF
  • V4
  • IDBLOCKV4
IDBLOCKV4 Member List

This is the complete list of members for IDBLOCKV4, including all inherited members.

BlockSize (defined in IDBLOCKV4) | IDBLOCKV4
CustomFlags (defined in IDBLOCKV4) | IDBLOCKV4
FileID (defined in IDBLOCKV4) | IDBLOCKV4
FormatId (defined in IDBLOCKV4) | IDBLOCKV4
IDBLOCKV4(string programID, ushort version=410) | IDBLOCKV4
Name (defined in IDBLOCKV4) | IDBLOCKV4
Parent (defined in IDBLOCKV4) | IDBLOCKV4
ProgramId (defined in IDBLOCKV4) | IDBLOCKV4
Tag (defined in IDBLOCKV4) | IDBLOCKV4
Type (defined in IDBLOCKV4) | IDBLOCKV4
UnfinalizedFlags (defined in IDBLOCKV4) | IDBLOCKV4
Version (defined in IDBLOCKV4) | IDBLOCKV4
writeBlock(BinaryWriter bw, bool isLast=true) | IDBLOCKV4


ASAP2Library interface: NamesBase Class Reference

  • MDF
  • V4
  • NamesBase
Public Attributes | List of all members
NamesBase Class Reference

Base Name More...

Public Attributes

int | ci
Zero-based index into the list of FH blocks.
string | Text
Name Text

Detailed Description

Base Name


ASAP2Library interface: Member List

  • MDF
  • V4
  • NamesBase
NamesBase Member List

This is the complete list of members for NamesBase, including all inherited members.

ci | NamesBase
Text | NamesBase


ASAP2Library interface: NamesType Class Reference

  • MDF
  • V4
  • NamesType
List of all members
NamesType Class Reference

Name of object in different languages More...

Additional Inherited Members

- Public Attributes inherited from NamesBase
int | ci
Zero-based index into the list of FH blocks.
string | Text
Name Text

Detailed Description

Name of object in different languages


ASAP2Library interface: Member List

  • MDF
  • V4
  • NamesType
NamesType Member List

This is the complete list of members for NamesType, including all inherited members.

ci | NamesBase
Text | NamesBase


ASAP2Library interface: RasterType Class Reference

  • MDF
  • V4
  • RasterType
Public Attributes | List of all members
RasterType Class Reference

MDF V4 Xml Raster structure More...

Public Attributes

double | max
Raster value maximum
double | min
Raster value minimum
string | unit
Display string for unit
string | unit_ref
ASAM Unit reference
double | value
Raster value (usually in seconds)

Detailed Description

MDF V4 Xml Raster structure


ASAP2Library interface: Member List

  • MDF
  • V4
  • RasterType
RasterType Member List

This is the complete list of members for RasterType, including all inherited members.

max | RasterType
min | RasterType
unit | RasterType
unit_ref | RasterType
value | RasterType


ASAP2Library interface: RDSDBLOCKV4 Class Reference

  • MDF
  • V4
  • RDSDBLOCKV4
Public Member Functions | Protected Member Functions | Properties | List of all members
RDSDBLOCKV4 Class Reference

Base class for SD, MD or RD blocks. More...

Public Member Functions

sealed override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Protected Member Functions

RDSDBLOCKV4 (string text, bool asMDBlock)
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void readData (BinaryReader br)

Properties

byte[] | Data [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Base class for SD, MD or RD blocks.

Container for signal values of variable length (SD) or Container for data record triples with result of a sample reduction (RD).

Member Function Documentation

◆ writeBlock()

sealed override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • RDSDBLOCKV4
RDSDBLOCKV4 Member List

This is the complete list of members for RDSDBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Data (defined in RDSDBLOCKV4) | RDSDBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
RDSDBLOCKV4(string text, bool asMDBlock) (defined in RDSDBLOCKV4) | RDSDBLOCKV4 | protected
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | RDSDBLOCKV4 | virtual


ASAP2Library interface: SIBLOCKV4 Class Reference

  • MDF
  • V4
  • SIBLOCKV4
Public Member Functions | Properties | List of all members
SIBLOCKV4 Class Reference

Source information block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

BusType | Bus [getset]
string | Comment = string.Empty [getset]
SourceFlags | Flags [getset]
override string | Name [getprotected set]
string | Path = string.Empty [getset]
SourceType | Source [getset]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.

Additional Inherited Members

- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

Source information block.

Specifies source information for a channel or for the acquisition of a channel group.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |
virtual

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
Position from where the write started

Reimplemented from BLOCKBASEV4.


ASAP2Library interface: Member List

  • MDF
  • V4
  • SIBLOCKV4
SIBLOCKV4 Member List

This is the complete list of members for SIBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Bus (defined in SIBLOCKV4) | SIBLOCKV4 |
Comment (defined in SIBLOCKV4) | SIBLOCKV4 |
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in SIBLOCKV4) | SIBLOCKV4 |
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name (defined in SIBLOCKV4) | SIBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
Path (defined in SIBLOCKV4) | SIBLOCKV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Source (defined in SIBLOCKV4) | SIBLOCKV4 |
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | SIBLOCKV4 | virtual


ASAP2Library interface: SIcomment Class Reference

  • MDF
  • V4
  • SIcomment
Public Attributes | Protected Member Functions | List of all members
SIcomment Class Reference

MDF V4 Xml SIBLOCKV4 comment More...

Public Attributes

NamesBase | bus
Bus name and alternative names and descriptions
NamesBase | path
Bus name and alternative names and descriptions
string | protocol
Protocol name
- Public Attributes inherited from BaseNames
List< NamesBase > | names
Alternative source names and descriptions
- Public Attributes inherited from CommentBase
List< EBase > | common_properties
Common properties
string | TX = string.Empty
Text

Protected Member Functions

override string | serialize ()
- Protected Member Functions inherited from XmlBase
string | serialize (XmlSerializer serializer)

Additional Inherited Members

- Static Public Attributes inherited from XmlBase
const string | MDF_NS = "http://www.asam.net/mdf/v4"
- Static Protected Member Functions inherited from XmlBase
static T | deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

MDF V4 Xml SIBLOCKV4 comment

Member Function Documentation

◆ serialize()

override string serialize ( )
protectedvirtual

Implements XmlBase.


ASAP2Library interface: Member List

  • MDF
  • V4
  • SIcomment
SIcomment Member List

This is the complete list of members for SIcomment, including all inherited members.

bus | SIcomment |
common_properties | CommentBase |
deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
names | BaseNames |
path | SIcomment |
protocol | SIcomment |
serialize() (defined in SIcomment) | SIcomment | protectedvirtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected
TX | CommentBase |


ASAP2Library interface: SRBLOCKV4 Class Reference

  • MDF
  • V4
  • SRBLOCKV4
Public Member Functions | Properties | Events | List of all members
SRBLOCKV4 Class Reference

The Sample Reduction Block. More...

Public Member Functions

override long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from BLOCKBASEV4
override string | ToString ()

Properties

SRFlags | Flags [get]
double | LenOfTimeInt [get]
ulong | NrOfRedSamples [get]
- Properties inherited from DataContainerV4
List< BLOCKBASEV4 > | Blocks = new List<BLOCKBASEV4>() [get]
- Properties inherited from BLOCKBASEV4
long | BlockSize [getprotected set]
string | Id [get]
Gets the Blocktype (id).
virtual string | Name [getprotected set]
Gets the name of the instance
IMDFBlock | Parent [getset]
object | Tag [getset]
Gets or sets a reference to a user object.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...
- Properties inherited from ISRBLOCK
double | LenOfTimeInt [get]
Length of time interval [s] used to calculate the reduced samples.
ulong | NrOfRedSamples [get]
Number of reduced samples in the data block

Events

EventHandler< WriteRawDataEventArgs > OnWriteRawData

Additional Inherited Members

- Protected Member Functions inherited from DataContainerV4
DataContainerV4 (string id, long structSize, int noLinks)
Creates a new instance of DataContainerV4 with the specified parameters. More...
BinaryReader | getReader (long offset, out long maxSize)
void | readDataContainer (BinaryReader br, int dataLinkIdx)
Creates data container from the specified (data container)linkList. More...
- Protected Member Functions inherited from BLOCKBASEV4
BLOCKBASEV4 (BinaryReader br)
BLOCKBASEV4 (string id, long structSize, int noLinks)
CReates a new instance of BLOCKBASE with the specified parameters. More...
void | readData (BinaryReader br)
- Protected Attributes inherited from DataContainerV4
BinaryReader | mBr
- Protected Attributes inherited from BLOCKBASEV4
long[] | mLinkList
ulong | mNoLinks
- Static Protected Attributes inherited from BLOCKBASEV4
const string | DL = "DL"
const string | DT = "DT"
const string | DZ = "DZ"
const string | HL = "HL"
const string | MD = "MD"
const string | RD = "RD"
const string | SD = "SD"
const string | SYNC_TYPE = "Sync type"

Detailed Description

The Sample Reduction Block.

Member Function Documentation

◆ writeBlock()

override long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Implements IMDFBlock.


ASAP2Library interface: Member List

  • MDF
  • V4
  • SRBLOCKV4
SRBLOCKV4 Member List

This is the complete list of members for SRBLOCKV4, including all inherited members.

BLOCKBASEV4() (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
BLOCKBASEV4(string id, long structSize, int noLinks) | BLOCKBASEV4 | protected
Blocks (defined in DataContainerV4) | DataContainerV4 |
BlockSize (defined in BLOCKBASEV4) | BLOCKBASEV4 |
DataContainerV4(string id, long structSize, int noLinks) | DataContainerV4 | protected
DataContainerV4() (defined in DataContainerV4) | DataContainerV4 | protected
DL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DT (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
DZ (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Flags (defined in SRBLOCKV4) | SRBLOCKV4 |
getReader(long offset, out long maxSize) (defined in DataContainerV4) | DataContainerV4 | protected
HL (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Id | BLOCKBASEV4 |
LenOfTimeInt (defined in SRBLOCKV4) | SRBLOCKV4 |
mBr (defined in DataContainerV4) | DataContainerV4 | protected
MD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
mLinkList (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
mNoLinks (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
Name | BLOCKBASEV4 |
NrOfRedSamples (defined in SRBLOCKV4) | SRBLOCKV4 |
OnWriteRawData (defined in SRBLOCKV4) | SRBLOCKV4 |
Parent (defined in BLOCKBASEV4) | BLOCKBASEV4 |
RD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
readData(BinaryReader br) (defined in BLOCKBASEV4) | BLOCKBASEV4 | protected
readDataContainer(BinaryReader br, int dataLinkIdx) | DataContainerV4 | protected
SD (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
SYNC_TYPE (defined in BLOCKBASEV4) | BLOCKBASEV4 | protectedstatic
Tag | BLOCKBASEV4 |
ToString() (defined in BLOCKBASEV4) | BLOCKBASEV4 |
writeBlock(BinaryWriter bw, bool isLast=true) | SRBLOCKV4 |


ASAP2Library interface: TreeType Class Reference

  • MDF
  • V4
  • TreeType
Public Attributes | List of all members
TreeType Class Reference

MDF V4 Xml Tree More...

Public Attributes

List< EBase > | SubNodes
Subnodes (Tree or e Nodes)
- Public Attributes inherited from EBase
string | desc
Description
string | name
Name

Detailed Description

MDF V4 Xml Tree


ASAP2Library interface: Member List

  • MDF
  • V4
  • TreeType
TreeType Member List

This is the complete list of members for TreeType, including all inherited members.

desc | EBase
name | EBase
SubNodes | TreeType


ASAP2Library interface: VendorType Class Reference

  • MDF
  • V4
  • VendorType
List of all members
VendorType Class Reference

Vendor specific name, e.g. name as used in a specific tool. More...

Additional Inherited Members

- Public Attributes inherited from NamesBase
int | ci
Zero-based index into the list of FH blocks.
string | Text
Name Text

Detailed Description

Vendor specific name, e.g. name as used in a specific tool.


ASAP2Library interface: Member List

  • MDF
  • V4
  • VendorType
VendorType Member List

This is the complete list of members for VendorType, including all inherited members.

ci | NamesBase
Text | NamesBase


ASAP2Library interface: XmlBase Class Reference

  • MDF
  • V4
  • XmlBase
Static Public Attributes | Protected Member Functions | Static Protected Member Functions | List of all members
XmlBase Class Referenceabstract

Base implementation for any MDF V4 Xml structure. More...

Static Public Attributes

const string MDF_NS = "http://www.asam.net/mdf/v4"

Protected Member Functions

abstract string | serialize ()
string | serialize (XmlSerializer serializer)

Static Protected Member Functions

static T deserialize< T > (XmlSerializer serializer, string s)

Detailed Description

Base implementation for any MDF V4 Xml structure.

Member Function Documentation

◆ deserialize< T >()

static T deserialize< T > | ( | XmlSerializer | serializer,
 |  | string | s
 | ) |  |
staticprotected
Type Constraints
T : CommentBase


ASAP2Library interface: Member List

  • MDF
  • V4
  • XmlBase
XmlBase Member List

This is the complete list of members for XmlBase, including all inherited members.

deserialize< T >(XmlSerializer serializer, string s) (defined in XmlBase) | XmlBase | protectedstatic
MDF_NS (defined in XmlBase) | XmlBase | static
serialize() (defined in XmlBase) | XmlBase | protectedpure virtual
serialize(XmlSerializer serializer) (defined in XmlBase) | XmlBase | protected


ASAP2Library interface: Annotation Struct Reference

  • MDF
  • Annotation
Public Member Functions | Public Attributes | List of all members
Annotation Struct Reference

Structure holding a single annotation and it's timestamp. More...

Public Member Functions

Annotation (double timestamp, string text)
Creates a new instance of Annotation. More...

Public Attributes

string | Text
The annotation's text
double | Timestamp
Timestamp in [s].

Detailed Description

Structure holding a single annotation and it's timestamp.

Constructor & Destructor Documentation

◆ Annotation()

Annotation | ( | double | timestamp,
 |  | string | text
 | ) |  |

Creates a new instance of Annotation.

Parameters
timestamp
text


ASAP2Library interface: Member List

  • MDF
  • Annotation
Annotation Member List

This is the complete list of members for Annotation, including all inherited members.

Annotation(double timestamp, string text) | Annotation
Text | Annotation
Timestamp | Annotation


ASAP2Library interface: AnnotationList Class Reference

  • MDF
  • AnnotationList
Public Member Functions | Properties | List of all members
AnnotationList Class Reference

Holds a list of Annotations. More...

Public Member Functions

new void Add (Annotation annotation)
Adds a new annotation. More...

Properties

int MaxLength [get]
Gets the maximum length contained Annotation's.

Detailed Description

Holds a list of Annotations.

Member Function Documentation

◆ Add()

new void Add ( Annotation annotation )

Adds a new annotation.

Parameters
annotation


ASAP2Library interface: Member List

  • MDF
  • AnnotationList
AnnotationList Member List

This is the complete list of members for AnnotationList, including all inherited members.

Add(Annotation annotation) | AnnotationList
MaxLength | AnnotationList


ASAP2Library interface: DataBlockExpander Class Reference

  • MDF
  • DataBlockExpander
Public Member Functions | List of all members
DataBlockExpander Class Reference

Handles sorting of Datablocks. More...

Public Member Functions

void Dispose ()

Detailed Description

Handles sorting of Datablocks.


ASAP2Library interface: Member List

  • MDF
  • DataBlockExpander
DataBlockExpander Member List

This is the complete list of members for DataBlockExpander, including all inherited members.

Dispose() (defined in DataBlockExpander) DataBlockExpander


ASAP2Library interface: DataReader Class Reference

  • MDF
  • DataReader
Public Member Functions | List of all members
DataReader Class Reference

MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression. More...

Public Member Functions

void Dispose ()
Frees local resources.

Detailed Description

MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression.


ASAP2Library interface: Member List

  • MDF
  • DataReader
DataReader Member List

This is the complete list of members for DataReader, including all inherited members.

Dispose() DataReader


ASAP2Library interface: DataStream Class Reference

  • MDF
  • DataStream
Public Member Functions | Properties | List of all members
DataStream Class Reference

Handles a temporary stream per data handle. More...

Public Member Functions

DataStream (DataStream src)
Copy constructor. More...
DataStream (ZipType zipType=ZipType.None, uint zipParameter=0)
Creates a new instance with the specified parameters. More...
void | addData (double timeStamp, byte[] data, int size)
void | close (bool writeAsync=false)
void | Dispose ()

Properties

bool | Done [get]
string | Filename [get]
long | Size [get]
long | UncompressedSize [get]
uint | ZipParameter [get]
ZipType | ZipType [get]

Detailed Description

Handles a temporary stream per data handle.

Constructor & Destructor Documentation

◆ DataStream() [1/2]

DataStream | ( | ZipType | zipType = ZipType.None,
 |  | uint | zipParameter = 0
 | ) |  |

Creates a new instance with the specified parameters.

Parameters
zipType
zipParameter

◆ DataStream() [2/2]

DataStream ( DataStream src )

Copy constructor.

Parameters
src source to copy parameters from


ASAP2Library interface: Member List

  • MDF
  • DataStream
DataStream Member List

This is the complete list of members for DataStream, including all inherited members.

addData(double timeStamp, byte[] data, int size) (defined in DataStream) | DataStream
close(bool writeAsync=false) (defined in DataStream) | DataStream
DataStream(ZipType zipType=ZipType.None, uint zipParameter=0) | DataStream
DataStream(DataStream src) | DataStream
Dispose() (defined in DataStream) | DataStream
Done (defined in DataStream) | DataStream
Filename (defined in DataStream) | DataStream
Size (defined in DataStream) | DataStream
UncompressedSize (defined in DataStream) | DataStream
ZipParameter (defined in DataStream) | DataStream
ZipType (defined in DataStream) | DataStream


ASAP2Library interface: DependencyType Class Reference

  • MDF
  • DependencyType
Public Member Functions | Properties | List of all members
DependencyType Class Reference

Dependency data. More...

Public Member Functions

DependencyType (long linkDG, long linkCG, long linkCN)

Properties

ICNBLOCK | Channel [get]
Channel
ICGBLOCK | ChannelGroup [get]
Channel Group
IDGBLOCK | DataGroup [get]
Data Group
long | LinkCG [get]
Channel Group link
long | LinkCN [get]
Channel link
long | LinkDG [get]
Data Group link

Detailed Description

Dependency data.


ASAP2Library interface: Member List

  • MDF
  • DependencyType
DependencyType Member List

This is the complete list of members for DependencyType, including all inherited members.

Channel | DependencyType
ChannelGroup | DependencyType
DataGroup | DependencyType
DependencyType(long linkDG, long linkCG, long linkCN) (defined in DependencyType) | DependencyType
LinkCG | DependencyType
LinkCN | DependencyType
LinkDG | DependencyType


ASAP2Library interface: Helpers Class Reference

  • MDF
  • Helpers
List of all members
Helpers Class Reference

MDF Helper functions and constants. More...

Detailed Description

MDF Helper functions and constants.


ASAP2Library interface: Member List

  • MDF
  • Helpers
Helpers Member List

This is the complete list of members for Helpers, including all inherited members.


ASAP2Library interface: ICCBLOCK Interface Reference

  • MDF
  • ICCBLOCK
Public Member Functions | Properties | List of all members
ICCBLOCK Interface Reference

Channel computation Block interface. More...

Public Member Functions

void | recalcCoeffs ()
Recalculate the coeffients.
double | toPhysical (double rawValue, bool useInversed=false)
Computes the physical value from a raw value. More...
- Public Member Functions inherited from IMDFBlock
long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

ConversionType | ConversionType [get]
string | DefaultText [getset]
DefaultText for ConversionType.TextRange
string | Formula [getset]
Formula string for ConversionType.TextFormula
ICCBLOCK | InvCCBlock [get]
Link to inverse CCBlock (V4 only).
SortedList< object, object > | KeyValuePairs [getset]
Key/Value pairs for ConversionType.TextTable, ConversionType.Tab, ConversionType.TabInt
double | Max [getset]
Maximum physical signal value
double | Min [getset]
Minimum physical signal value
double[] | Params [getset]
Formula string for ConversionType.ParametricLinear, ConversionType.Polynomial, ConversionType.Exponential, ConversionType.Logarithmic, ConversionType.Rational
ushort | TabSize [get]
string | Unit [get]
Physical unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Channel computation Block interface.

Member Function Documentation

◆ toPhysical()

double toPhysical | ( | double | rawValue,
 |  | bool | useInversed = false
 | ) |  |

Computes the physical value from a raw value.

Parameters
rawValue | The raw value to convert
useInversed | Use inversed rational function parameters
Returns
the physical value

Implemented in CCBLOCK, and CCBLOCKV4.


ASAP2Library interface: Member List

  • MDF
  • ICCBLOCK
ICCBLOCK Member List

This is the complete list of members for ICCBLOCK, including all inherited members.

BlockSize | IMDFBlock
Comment | IMDFComment
ConversionType (defined in ICCBLOCK) | ICCBLOCK
DefaultText | ICCBLOCK
Formula | ICCBLOCK
InvCCBlock | ICCBLOCK
KeyValuePairs | ICCBLOCK
Max | ICCBLOCK
Min | ICCBLOCK
Name | IMDFBlock
Params | ICCBLOCK
Parent | IMDFBlock
recalcCoeffs() | ICCBLOCK
TabSize (defined in ICCBLOCK) | ICCBLOCK
Tag | IMDFBlock
toPhysical(double rawValue, bool useInversed=false) | ICCBLOCK
Unit | ICCBLOCK
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: ICGBLOCK Interface Reference

  • MDF
  • ICGBLOCK
Public Member Functions | Properties | List of all members
ICGBLOCK Interface Reference

Channel group Block interface. More...

Public Member Functions

long | getRecordSize ()
Gets the size of a single data record (inclusive record id). More...
- Public Member Functions inherited from IMDFBlock
long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

List< ICNBLOCK > | CNBlocks [get]
Gets the corresponding CNBLOCK (Channel reduction) children.
IDGBLOCK | DGBlock [get]
Gets the parent data group of the channel group.
ulong | RecordCount [getset]
Number of records of this type in the data block, i.e. number of samples for this channel group.
ulong | RecordID [get]
Record ID, i.e. value of the identifier for a record if the DGBLOCK defines a number of record IDs > 0
uint | RecordSize [getset]
Size of data record in Bytes (without record ID), i.e. size of plain data (including the time channel) for a each recorded sample of this channel group.
List< ISRBLOCK > | SRBlocks [get]
List of SRBlocks.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Channel group Block interface.

Member Function Documentation

◆ getRecordSize()

long getRecordSize ( )

Gets the size of a single data record (inclusive record id).

Returns


ASAP2Library interface: Member List

  • MDF
  • ICGBLOCK
ICGBLOCK Member List

This is the complete list of members for ICGBLOCK, including all inherited members.

BlockSize | IMDFBlock
CNBlocks | ICGBLOCK
Comment | IMDFComment
DGBlock | ICGBLOCK
getRecordSize() | ICGBLOCK
Name | IMDFBlock
Parent | IMDFBlock
RecordCount | ICGBLOCK
RecordID | ICGBLOCK
RecordSize | ICGBLOCK
SRBlocks | ICGBLOCK
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: ICNBLOCK Interface Reference

  • MDF
  • ICNBLOCK
Public Member Functions | Properties | List of all members
ICNBLOCK Interface Reference

Channel Block interface. More...

Public Member Functions

long | getReadPosition (long recordIndex)
Gets the read position for a specific record. More...
- Public Member Functions inherited from IMDFBlock
long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

uint | AddOffset [get]
Gets the Offset to the first Byte in the data record that contains bits of the signal value. More...
ulong | BitmaskCache [getset]
Internal used cache for already computed bitmasks
ushort | BitOffset [get]
Gets the the Bit offset (0-7): first bit (=LSB) of signal value after Byte offset has been applied(see 5.21.4.2 Reading the Signal Value). More...
ICCBLOCK | CCBlock [get]
Gets the corresponding CCBLOCK.
IMDFBlock | CDBlock [get]
Gets the corresponding CDBlock (only valid format smaller than V4.00).
IMDFBlock | CEBlock [get]
Gets the coresponding CEBlock (only valid format smaller than V4.00).
ICGBLOCK | CGBlock [get]
Gets the parent channel group of the channel.
ChannelType | ChannelType [get]
Gets the channel's type
IList< ICNBLOCK > | CNBlocks [get]
Gets the corresponding Sub-CNBLOCKs (Only V4 supported).
string | Description [get]
Gets the channel's description
double | Max [get]
Maximum signal value that occurred for this signal (physical value)
double | MaxEx [get]
Extende Maximum signal value that occurred for this signal (physical value)
double | MaxRaw [getset]
Maximum signal value that occurred for this signal (raw value)
double | Min [get]
Minimum signal value that occurred for this signal (physical value)
double | MinEx [get]
Extende Minimum signal value that occurred for this signal (physical value)
double | MinRaw [getset]
Minimum signal value that occurred for this signal (raw value)
uint | NoOfBits [getset]
Gets the Number of bits for signal value in record.
double | Rate [get]
Gets the channel's rate
SignalType | SignalType [get]
Gets the signal type.
SyncType | SyncType [get]
Gets the synchronization type
string | Unit [get]
Gets the chanels' Unit
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Channel Block interface.

Member Function Documentation

◆ getReadPosition()

long getReadPosition ( long recordIndex )

Gets the read position for a specific record.

Parameters
recordIndex The record's index
Returns
The read position

Property Documentation

◆ AddOffset

uint AddOffset
get

Gets the Offset to the first Byte in the data record that contains bits of the signal value.

The offset is applied to the plain record data, i.e.skipping the IDGBLOCK.RecordIDType.

◆ BitOffset

ushort BitOffset
get

Gets the the Bit offset (0-7): first bit (=LSB) of signal value after Byte offset has been applied(see 5.21.4.2 Reading the Signal Value).

If zero, the signal value is 1-Byte aligned.A value different to zero is only allowed for Integer data types and if the Integer signal value fits into 8 contiguous Bytes (ICNBLOCK.NoOfBits + ICNBLOCK.BitOffset within 64). For all other cases, ICNBLOCK.BitOffset must be zero.


ASAP2Library interface: Member List

  • MDF
  • ICNBLOCK
ICNBLOCK Member List

This is the complete list of members for ICNBLOCK, including all inherited members.

AddOffset | ICNBLOCK
BitmaskCache | ICNBLOCK
BitOffset | ICNBLOCK
BlockSize | IMDFBlock
CCBlock | ICNBLOCK
CDBlock | ICNBLOCK
CEBlock | ICNBLOCK
CGBlock | ICNBLOCK
ChannelType | ICNBLOCK
CNBlocks | ICNBLOCK
Comment | IMDFComment
Description | ICNBLOCK
getReadPosition(long recordIndex) | ICNBLOCK
Max | ICNBLOCK
MaxEx | ICNBLOCK
MaxRaw | ICNBLOCK
Min | ICNBLOCK
MinEx | ICNBLOCK
MinRaw | ICNBLOCK
Name | IMDFBlock
NoOfBits | ICNBLOCK
Parent | IMDFBlock
Rate | ICNBLOCK
SignalType | ICNBLOCK
SyncType | ICNBLOCK
Tag | IMDFBlock
Unit | ICNBLOCK
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: IDataContainer Interface Reference

  • MDF
  • IDataContainer
Public Member Functions | List of all members
IDataContainer Interface Reference

Interface for Data containers like SRBLOCK and DGBLOCK. More...

Public Member Functions

void readData (long offset, byte[] buffer)
Reads recorded data from the specific offset into the specified buffer. More...

Detailed Description

Interface for Data containers like SRBLOCK and DGBLOCK.

Member Function Documentation

◆ readData()

void readData | ( | long | offset,
 |  | byte[] | buffer
 | ) |  |

Reads recorded data from the specific offset into the specified buffer.

Parameters
offset | Offset to recording start
buffer | buffer to store the data read


ASAP2Library interface: Member List

  • MDF
  • IDataContainer
IDataContainer Member List

This is the complete list of members for IDataContainer, including all inherited members.

readData(long offset, byte[] buffer) IDataContainer


ASAP2Library interface: IDGBLOCK Interface Reference

  • MDF
  • IDGBLOCK
Properties | Events | List of all members
IDGBLOCK Interface Reference

Data Group Block interface.. More...

Properties

List< ICGBLOCK > | CGBlocks [get]
Gets the corresponding CGBLOCK (Channel group) children.
RecordIDType | RecordIDType [get]
Gets the record ID type.
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Events

EventHandler< WriteRawDataEventArgs > OnWriteRawData
The handler to write recorded raw Data. More...

Additional Inherited Members

- Public Member Functions inherited from IMDFBlock
long | writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...
- Public Member Functions inherited from IDataContainer
void | readData (long offset, byte[] buffer)
Reads recorded data from the specific offset into the specified buffer. More...

Detailed Description

Data Group Block interface..

Event Documentation

◆ OnWriteRawData

EventHandler<WriteRawDataEventArgs> OnWriteRawData

The handler to write recorded raw Data.

Called for each IDGBLOCK when MDFWriter.save is called.


ASAP2Library interface: Member List

  • MDF
  • IDGBLOCK
IDGBLOCK Member List

This is the complete list of members for IDGBLOCK, including all inherited members.

BlockSize | IMDFBlock
CGBlocks | IDGBLOCK
Comment | IMDFComment
Name | IMDFBlock
OnWriteRawData | IDGBLOCK
Parent | IMDFBlock
readData(long offset, byte[] buffer) | IDataContainer
RecordIDType | IDGBLOCK
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: IHDBLOCK Interface Reference

  • MDF
  • IHDBLOCK
Properties | List of all members
IHDBLOCK Interface Reference

Header Block interface. More...

Properties

List< IDGBLOCK > | DGBlocks [get]
Gets the corresponding DGBLOCK (Data group) children.
DateTime | RecordingTime [get]
Time, the recording was started
- Properties inherited from IMDFComment
string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from IMDFBlock
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Detailed Description

Header Block interface.


ASAP2Library interface: Member List

  • MDF
  • IHDBLOCK
IHDBLOCK Member List

This is the complete list of members for IHDBLOCK, including all inherited members.

BlockSize | IMDFBlock
Comment | IMDFComment
DGBlocks | IHDBLOCK
Name | IMDFBlock
Parent | IMDFBlock
RecordingTime | IHDBLOCK
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: IIDBLOCK Interface Reference

  • MDF
  • IIDBLOCK
Properties | List of all members
IIDBLOCK Interface Reference

ID Block interface. More...

Properties

CustomFlagsType | CustomFlags [get]
Custom Flags for unfinalized MDF.
string | FileID [get]
File identifier, always contains "MDF␣␣␣␣␣"
string | ProgramId [getset]
Program ID
MDFType | Type [get]
V1..V3 or V4 MDF type. (not contained in file content)
UnfinalizedFlagsType | UnfinalizedFlags [get]
Standard Flags for unfinalized MDF.
ushort | Version [get]
Version number of MDF format
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from IMDFBlock
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Detailed Description

ID Block interface.


ASAP2Library interface: Member List

  • MDF
  • IIDBLOCK
IIDBLOCK Member List

This is the complete list of members for IIDBLOCK, including all inherited members.

BlockSize | IMDFBlock
CustomFlags | IIDBLOCK
FileID | IIDBLOCK
Name | IMDFBlock
Parent | IMDFBlock
ProgramId | IIDBLOCK
Tag | IMDFBlock
Type | IIDBLOCK
UnfinalizedFlags | IIDBLOCK
Version | IIDBLOCK
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: IMDFBlock Interface Reference

  • MDF
  • IMDFBlock
Public Member Functions | Properties | List of all members
IMDFBlock Interface Reference

Basic MDF block interface. More...

Public Member Functions

long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Properties

long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Detailed Description

Basic MDF block interface.

Member Function Documentation

◆ writeBlock()

long writeBlock | ( | BinaryWriter | bw,
 |  | bool | isLast = true
 | ) |  |

Writes the block to stream.

Parameters
bw | The stream to write to
isLast | true if the last block of a block list is written
Returns
The position the block is written to

Implemented in IDBLOCK, BLOCKBASE, TXBLOCK, CEBLOCK, CDBLOCK, CCBLOCK, CNBLOCK, SRBLOCK, CGBLOCK, TRBLOCK, DGBLOCK, HDBLOCK, IDBLOCKV4, BLOCKBASEV4, RDSDBLOCKV4, FHBLOCKV4, HDBLOCKV4, DGBLOCKV4, HLBLOCKV4, DZBLOCKV4, DLBLOCKV4, SIBLOCKV4, CGBLOCKV4, SRBLOCKV4, CNBLOCKV4, and CCBLOCKV4.

Property Documentation

◆ Tag

object Tag
getset

Gets or sets the Tag property.

  • This property may be used to bind any user reference to this instance.


ASAP2Library interface: Member List

  • MDF
  • IMDFBlock
IMDFBlock Member List

This is the complete list of members for IMDFBlock, including all inherited members.

BlockSize | IMDFBlock
Name | IMDFBlock
Parent | IMDFBlock
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: IMDFComment Interface Reference

  • MDF
  • IMDFComment
Properties | List of all members
IMDFComment Interface Reference

Interface to access TXBLOCK comments. More...

Properties

string | Comment [get]
Gets the corresponding comment.
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from IMDFBlock
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Detailed Description

Interface to access TXBLOCK comments.


ASAP2Library interface: Member List

  • MDF
  • IMDFComment
IMDFComment Member List

This is the complete list of members for IMDFComment, including all inherited members.

BlockSize | IMDFBlock
Comment | IMDFComment
Name | IMDFBlock
Parent | IMDFBlock
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: ISRBLOCK Interface Reference

  • MDF
  • ISRBLOCK
Properties | List of all members
ISRBLOCK Interface Reference

Sample reduction Block interface. More...

Properties

double | LenOfTimeInt [get]
Length of time interval [s] used to calculate the reduced samples.
ulong | NrOfRedSamples [get]
Number of reduced samples in the data block
- Properties inherited from IMDFBlock
long | BlockSize [get]
Gets the size of the MDF block.
string | Name [get]
Gets the Name.
IMDFBlock | Parent [get]
The parent block of this block.
object | Tag [getset]
Gets or sets the Tag property. More...

Additional Inherited Members

- Public Member Functions inherited from IMDFBlock
long writeBlock (BinaryWriter bw, bool isLast=true)
Writes the block to stream. More...

Detailed Description

Sample reduction Block interface.


ASAP2Library interface: Member List

  • MDF
  • ISRBLOCK
ISRBLOCK Member List

This is the complete list of members for ISRBLOCK, including all inherited members.

BlockSize | IMDFBlock
LenOfTimeInt | ISRBLOCK
Name | IMDFBlock
NrOfRedSamples | ISRBLOCK
Parent | IMDFBlock
Tag | IMDFBlock
writeBlock(BinaryWriter bw, bool isLast=true) | IMDFBlock


ASAP2Library interface: MDFReader Class Reference

  • MDF
  • MDFReader
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
MDFReader Class Reference

Implements the MDF (Measurement Data Format) reader. More...

Public Member Functions

void | Dispose ()
Frees the opened stream.
IEnumerable< DataPoint[]> | enumArraySamples (CNBLOCKV4 cnBlock, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue)
Enumerates a array channel's data. More...
IEnumerable< DataPoint > | enumSamples (ICNBLOCK cnBlock, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue)
Enumerates a channel's data. More...
int | fixRationalParameters ()
Fixes rational parameters in an opened MDF file written by ASAP2Library versions smaller than v8.0.63 More...
Annotation[] getAnnotations ()
Gets all available annotations from the MDF File. More...
bool | getData (ICGBLOCK cgBlock, out double[][] channelValues, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue)
Gets all numeric data from a specific channel group within the specified time. More...
void | getData (IList< ICNBLOCK > channels, out IList< DataPoint[]> Values, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue)
Gets the corresponding data to the specified channels. More...
bool | getData (ValueObjectFormat format, double startTime, double endTime, ICNBLOCK[] cnBlocks, uint[] maxPoints, IntPtr[] points, out DataLimits[] limitsX, out DataLimits[] limitsY)
Gets data for the specified signals in double precision (a set of DataPoint, double version). More...
double | getData (ValueObjectFormat format, ICNBLOCK cnBlock, long recordIndex)
Gets the value for the specified signal from the specified record index. More...
void | getDataF (IList< ICNBLOCK > channels, out IList< DataPointF[]> Values, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue)
Gets the corresponding data to the specified channels. More...
bool | getDataF (ValueObjectFormat format, double startTime, double endTime, ICNBLOCK[] cnBlocks, uint[] maxPoints, IntPtr[] points, out DataLimits[] limitsX, out DataLimits[] limitsY)
Gets data for the specified signals in double precision (a set of DataPointF, float version). More...
double | getLength ()
Gets the overall relative length in seconds of an opened file. More...
bool | getRawData (double startTime, double endTime, ICNBLOCK cnBlock, out IList< RawDataRecord > data, out DataLimits limitsX)
Gets data for the specified signal as raw data blocks (a set of RawDataRecord). More...
ulong | getSamplePointCount ()
Returns the count of sample points in the file. More...
void | save (string file)
Rewrites the structure of an opened file onto a copied origional. More...
bool | ToCSV (string targetPath, byte masterDecimalPlaces, List< ICNBLOCK > channels=null, EventHandler< ProgressArgs > progressHandler=null)
Exports the specified channels into CSV format. More...
override string | ToString ()

Static Public Member Functions

static DataPointF | getDataFfromMemory (IntPtr dataMem, int channelIndex)
Gets a DatapointF from the specified memory on the specified channelindex. More...
static DataPoint | getDatafromMemory (IntPtr dataMem, int channelIndex)
Gets a Datapoint from the specified memory on the specified channelindex. More...
static MDFReader | open (string path, EventHandler< ProgressArgs > progressHandler=null)
Opens a MDF file and returns a MDFFile instance. More...

Public Attributes

readonly IHDBLOCK | Header
Gets the HDBlock instance. More...
readonly IIDBLOCK | ID
Gets the IDBlock instance.
readonly HashSet< CNBLOCKV4 > | OpenArrays = new HashSet<CNBLOCKV4>()
Gets the opened (available) channel arrays dictionary. More...
readonly HashSet< ICGBLOCK > | OpenChannelGroups = new HashSet<ICGBLOCK>()
Gets the opened (available) channel group dictionary.
readonly HashSet< ICNBLOCK > | OpenChannels = new HashSet<ICNBLOCK>()
Gets the opened (available) channels dictionary.
EventHandler< ParserEventArgs > | ParserMessage
Register here for parser messages.
readonly string | SourceFile
Gets the fully qualified path to the source file.

Properties

int | CountErrors [get]
Gets the count of errors occured.
int | CountWarnings [get]
Gets the count of warnings occured.
DataLimits | MasterLimits [get]
Gets the start and End of all Master channels.
List< ParserEventArgs > | ParserEvents [getset]
Gets events the MDF object has created.

Detailed Description

Implements the MDF (Measurement Data Format) reader.

  • Supports MDF versions (up to 4.x)
  • If possible, uses a memory mapped file to provide maximum performance when reading data from the MDF file.

Example code to request records of the first second for each of the contained CNBLOCK instances:

using(var mdfFile = MDFReader.open("test.mdf"))
{
var channels = new List<ICNBLOCK>(mdfFile.OpenChannels.Keys);
var dataMem = new IntPtr[channels.Length];
var maxPoints = new uint[channels.Length];
DataLimits[] limitsX, limitsY;
for(int i = 0; i < channels.Length; ++i)
{ // create memory for a maximum of 1000 samples
dataMem[i] = new IntPtr(DataPoint.Size * 1000);
maxPoints[i] = 1000;
}
bool result = mdfFile.getData(ValueObjectFormat.Physical, 0, 1, channels.ToArray(), maxPoints, dataMem, out limitsX, out limitsY);
// print values
for(int i = 0; i < channels.Length; ++i )
{ // Iterate over channels
for (int j = 0; j < maxPoints[i]; ++j)
{ // Iterate over sample points
DataPoint p = MDFReader.getDatafromMemory(dataMem[i], j);
Console.WriteLine("channel={0} value[{1}]={2}", channels[i].getName(mdfFile.Reader), j, p);
}
}
// cleanup memory
foreach (IntPtr ptr in dataMem)
Marshal.FreeHGlobal(ptr);
}
jnsoft.Helpers.ValueObjectFormat
ValueObjectFormat
Possible value object formats.
Definition: Helpers.cs:1418

Member Function Documentation

◆ enumArraySamples()

IEnumerable< DataPoint[]> enumArraySamples | ( | CNBLOCKV4 | cnBlock,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | double | startTime = double.MinValue,
 |  | double | endTime = double.MaxValue
 | ) |  |

Enumerates a array channel's data.

Useful to read sequential data from a MDF file without consuming any memory.

Parameters
cnBlock | Channel instance
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
Returns
Array channel sample points enumeration

◆ enumSamples()

IEnumerable< DataPoint > enumSamples | ( | ICNBLOCK | cnBlock,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | double | startTime = double.MinValue,
 |  | double | endTime = double.MaxValue
 | ) |  |

Enumerates a channel's data.

Useful to read sequential data from a MDF file without consuming any memory.

Parameters
cnBlock | Channel instance
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
Returns
Channel sample points enumeration

◆ fixRationalParameters()

int fixRationalParameters ( )

Fixes rational parameters in an opened MDF file written by ASAP2Library versions smaller than v8.0.63

Returns

The count of adjusted parameters,

-1 if parameters are already converted

-2 if file isn't written by ASAP2Library

◆ getAnnotations()

Annotation[] getAnnotations ( )

Gets all available annotations from the MDF File.

Returns
The annotation array (may be empty)

◆ getData() [1/4]

bool getData | ( | ICGBLOCK | cgBlock,
 |  | out double | channelValues[][],
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | double | startTime = double.MinValue,
 |  | double | endTime = double.MaxValue
 | ) |  |

Gets all numeric data from a specific channel group within the specified time.

Keep in mind that reading data without specifiying a startTime and/or an endTime could easily exceed available memory depening on the channel's group record count.

Use the more selective getData(IList<ICNBLOCK> channels, ...) method to prevent from an OutOfMemoryException.

Parameters
cgBlock | The channel group to get data from
channelValues | The channel values read (inclusive the timestamp channel)
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
Returns
true if data is found and delivered
Exceptions
OutOfMemoryException Thrown if the OS couldn't provide enough memory to read the data specified.

◆ getData() [2/4]

void getData | ( | IList< ICNBLOCK > | channels,
 |  | out IList< DataPoint[]> | Values,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | double | startTime = double.MinValue,
 |  | double | endTime = double.MaxValue
 | ) |  |

Gets the corresponding data to the specified channels.

Keep in mind that reading data without specifiying a startTime and/or an endTime could easily exceed available memory depening on the channel's group record count. Reduce the count of channels to read from or reduce the startTime/endTime to prevent from an OutOfMemoryException exception.

Parameters
channels | Set of data channels
Values | Resulting values
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
Exceptions
OutOfMemoryException Thrown if the OS couldn't provide enough memory to read the data specified.

◆ getData() [3/4]

bool getData | ( | ValueObjectFormat | format,
 |  | double | startTime,
 |  | double | endTime,
 |  | ICNBLOCK[] | cnBlocks,
 |  | uint[] | maxPoints,
 |  | IntPtr[] | points,
 |  | out DataLimits[] | limitsX,
 |  | out DataLimits[] | limitsY
 | ) |  |

Gets data for the specified signals in double precision (a set of DataPoint, double version).

  • This method delivers double data points.
  • Calling this method ensures to get the full precision provided by the MDF file.
Parameters
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
cnBlocks | The list of signals to get data for
maxPoints
  • [in] The list of maximum count of points returnable in the points parameter
  • [out] The list of points returned in the points parameter
points | [in/out]An IntPtr (as memory) for each channel to store the data into. The IntPtr should provide enough memory for DataPoint.Size (16 Bytes * maxPoints[n])Attention: The application memory gets corrupted if the provided size is too small to hold the requested size of DataPoints!
limitsX | [out] Supplies limits in X-direction (time axis)
limitsY | [out] Supplies limits in Y-Direction (Value axis)
Returns
true if successful
Exceptions
ArgumentException Thrown, if the arrays got a different size

◆ getData() [4/4]

double getData | ( | ValueObjectFormat | format,
 |  | ICNBLOCK | cnBlock,
 |  | long | recordIndex
 | ) |  |

Gets the value for the specified signal from the specified record index.

Parameters
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
cnBlock | The channel
recordIndex | The recordindex
Returns
The value or double.NaN if failed

◆ getDataF() [1/2]

void getDataF | ( | IList< ICNBLOCK > | channels,
 |  | out IList< DataPointF[]> | Values,
 |  | ValueObjectFormat | format = ValueObjectFormat.Physical,
 |  | double | startTime = double.MinValue,
 |  | double | endTime = double.MaxValue
 | ) |  |

Gets the corresponding data to the specified channels.

Keep in mind that reading data without specifiying a startTime and/or an endTime could easily exceed available memory depening on the channel's group record count. Reduce the count of channels to read from or reduce the startTime/endTime to prevent from an OutOfMemoryException exception.

Parameters
channels | Set of data channels
Values | Resulting values
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
Exceptions
OutOfMemoryException Thrown if the OS couldn't provide enough memory to read the data specified.

◆ getDataF() [2/2]

bool getDataF | ( | ValueObjectFormat | format,
 |  | double | startTime,
 |  | double | endTime,
 |  | ICNBLOCK[] | cnBlocks,
 |  | uint[] | maxPoints,
 |  | IntPtr[] | points,
 |  | out DataLimits[] | limitsX,
 |  | out DataLimits[] | limitsY
 | ) |  |

Gets data for the specified signals in double precision (a set of DataPointF, float version).

  • This method delivers float data points.
  • This saves memory but results in a loss of data precision.
  • To get the full precision provided by a MDF file, use the getData method.
Parameters
format | The data format (supported is ValueObjectFormat.Physical and ValueObjectFormat.Raw in this case)
startTime | The start time to get data
endTime | The end time to get data
cnBlocks | The list of signals to get data for
maxPoints
  • [in] The list of maximum count of points returnable in the points parameter
  • [out] The list of points returned in the points parameter
points | [in/out]An IntPtr (as memory) for each channel to store the data into. The IntPtr should provide enough memory for DataPoint.Size (8 Bytes * maxPoints[n])Attention: The application memory gets corrupted if the provided size is too small to hold the requested size of DataPoints!
limitsX | [out] Supplies limits in X-direction (time axis)
limitsY | [out] Supplies limits in Y-Direction (Value axis)
Returns
true if successful
Exceptions
ArgumentException Thrown, if the arrays got a different size

◆ getDataFfromMemory()

static DataPointF getDataFfromMemory | ( | IntPtr | dataMem,
 |  | int | channelIndex
 | ) |  |
static

Gets a DatapointF from the specified memory on the specified channelindex.

Parameters
dataMem | Memory of DataPoint structures
channelIndex | The index to get the DataPointF from
Returns
The DataPointF instance

◆ getDatafromMemory()

static DataPoint getDatafromMemory | ( | IntPtr | dataMem,
 |  | int | channelIndex
 | ) |  |
static

Gets a Datapoint from the specified memory on the specified channelindex.

Parameters
dataMem | Memory of DataPoint structures
channelIndex | The index to get the DataPoint from
Returns
The DataPoint instance

◆ getLength()

double getLength ( )

Gets the overall relative length in seconds of an opened file.

Returns
The relative length in seconds.

◆ getRawData()

bool getRawData | ( | double | startTime,
 |  | double | endTime,
 |  | ICNBLOCK | cnBlock,
 |  | out IList< RawDataRecord > | data,
 |  | out DataLimits | limitsX
 | ) |  |

Gets data for the specified signal as raw data blocks (a set of RawDataRecord).

Parameters
startTime | The start time to get data
endTime | The end time to get data
cnBlock | The signals to get raw data for
data | [out] Data record.
limitsX | [out] Supplies limits in X-direction (time axis)
Returns
true if successful

◆ getSamplePointCount()

ulong getSamplePointCount ( )

Returns the count of sample points in the file.

Returns
the count of sample points

◆ open()

static MDFReader open | ( | string | path,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |
static

Opens a MDF file and returns a MDFFile instance.

Parameters
path | the fully qualified MDF file filename
progressHandler | Callback to receive progress, maybe null
Returns
A new MDFFile instance or null if failed

◆ save()

void save ( string file )

Rewrites the structure of an opened file onto a copied origional.

Before opening a source file it must be copied before the the desired destination file.

◆ ToCSV()

bool ToCSV | ( | string | targetPath,
 |  | byte | masterDecimalPlaces,
 |  | List< ICNBLOCK > | channels = null,
 |  | EventHandler< ProgressArgs > | progressHandler = null
 | ) |  |

Exports the specified channels into CSV format.

Parameters
targetPath | The destination path
masterDecimalPlaces | The count of decimal places to round the master axis values to
channels | The channels to filter to (may be null for exporting all channels)
progressHandler | Callback to receive progress, maybe null
Returns
true if successful

Member Data Documentation

◆ Header

readonly IHDBLOCK Header

Gets the HDBlock instance.

  • This is the root node of the MDF file.
  • All childs are reachable from this instance.

◆ OpenArrays

readonly HashSet<CNBLOCKV4> OpenArrays = new HashSet<CNBLOCKV4>()

Gets the opened (available) channel arrays dictionary.

This is only supported in MDF V4 formats.


ASAP2Library interface: Member List

  • MDF
  • MDFReader
MDFReader Member List

This is the complete list of members for MDFReader, including all inherited members.

CountErrors | MDFReader |
CountWarnings | MDFReader |
Dispose() | MDFReader |
enumArraySamples(CNBLOCKV4 cnBlock, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue) | MDFReader |
enumSamples(ICNBLOCK cnBlock, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue) | MDFReader |
fixRationalParameters() | MDFReader |
getAnnotations() | MDFReader |
getData(ValueObjectFormat format, ICNBLOCK cnBlock, long recordIndex) | MDFReader |
getData(ValueObjectFormat format, double startTime, double endTime, ICNBLOCK[] cnBlocks, uint[] maxPoints, IntPtr[] points, out DataLimits[] limitsX, out DataLimits[] limitsY) | MDFReader |
getData(IList< ICNBLOCK > channels, out IList< DataPoint[]> Values, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue) | MDFReader |
getData(ICGBLOCK cgBlock, out double[][] channelValues, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue) | MDFReader |
getDataF(ValueObjectFormat format, double startTime, double endTime, ICNBLOCK[] cnBlocks, uint[] maxPoints, IntPtr[] points, out DataLimits[] limitsX, out DataLimits[] limitsY) | MDFReader |
getDataF(IList< ICNBLOCK > channels, out IList< DataPointF[]> Values, ValueObjectFormat format=ValueObjectFormat.Physical, double startTime=double.MinValue, double endTime=double.MaxValue) | MDFReader |
getDataFfromMemory(IntPtr dataMem, int channelIndex) | MDFReader | static
getDatafromMemory(IntPtr dataMem, int channelIndex) | MDFReader | static
getLength() | MDFReader |
getRawData(double startTime, double endTime, ICNBLOCK cnBlock, out IList< RawDataRecord > data, out DataLimits limitsX) | MDFReader |
getSamplePointCount() | MDFReader |
Header | MDFReader |
ID | MDFReader |
MasterLimits | MDFReader |
open(string path, EventHandler< ProgressArgs > progressHandler=null) | MDFReader | static
OpenArrays | MDFReader |
OpenChannelGroups | MDFReader |
OpenChannels | MDFReader |
ParserEvents | MDFReader |
ParserMessage | MDFReader |
save(string file) | MDFReader |
SourceFile | MDFReader |
ToCSV(string targetPath, byte masterDecimalPlaces, List< ICNBLOCK > channels=null, EventHandler< ProgressArgs > progressHandler=null) | MDFReader |
ToString() (defined in MDFReader) | MDFReader |


ASAP2Library interface: MDFWriter Class Reference

  • MDF
  • MDFWriter
Public Member Functions | Properties | List of all members
MDFWriter Class Reference

Implements the MDF (Measurement Data Format) recorder. More...

Public Member Functions

MDFWriter (string author="", string organization="", string project="", string subject="", string headerComment="", MDFType type=MDFType.V4, bool compress=false)
Creates a new instance of MDFWriter with the specified arguments. More...
void | addAnnotation (double timestamp, string text)
Adds an annotation with the specified timestamp. More...
bool | addDataEntry (int handle, double timestamp, byte[] data, List< double > readBackValues=null)
Adds data to the specified channel group. More...
void | addMeasurement (int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, IDictionary< double, sRange > rangeTable, string defaultText, string description=null, int bitOffset=0)
Add a new measurement to the specified channel group handle. More...
void | addMeasurement (int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, IDictionary< double, string > textTable, string description=null, int bitOffset=0)
Add a new measurement to the specified channel group handle. More...
void | addMeasurement (int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, string description=null, double[] para=null, int bitOffset=0)
Add a new measurement to the specified channel group handle. More...
int | addMeasurements (int daqListNo, IEnumerable< A2LCONVERSION_REF > convRefs, uint arrayIndexBase=0, string cgComment=null)
Adds the specified A2L measurements and/or characteristics to the MDF writer instance. More...
int | addMeasurements (int daqListNo, IEnumerable< DAQMeasurement > measurements, uint arrayIndexBase=0, string cgComment=null)
Adds the specified A2L measurements and/or characteristics to the MDF writer instance. More...
int | addRawData (string cgComment, uint recordSize, string name, string description=null, SignalType signalType=SignalType.BYTE_ARRAY)
Creates a new Data- and Channel Group, a time channel and adds the specified raw data size to them. More...
void | addSourceInformation (int handle, SourceType source, BusType bus=BusType.NONE, string name=null, string path=null, string comment=null, SourceFlags flags=SourceFlags.None)
Adds source information to the specified channel group. More...
int | createChannelGroup (string cgComment=null)
Create a new channel group. More...
void | Dispose ()
Frees used resources.
bool | save (string path)
Saves the MDF file structure to the specified file path. More...

Properties

bool | Compress [get]
Indicates if the recorded data will be compressed.
bool | DataReceived [get]
Indicates if data is received so far.
ICGBLOCK?? | this[int handle] [get]
Get the corresponding CGBLOCK to the specified handle. More...
MDFType | Type [get]
Gets the MDF format to write the measurement data to.

Detailed Description

Implements the MDF (Measurement Data Format) recorder.

Constructor & Destructor Documentation

◆ MDFWriter()

MDFWriter | ( | string | author = "",
 |  | string | organization = "",
 |  | string | project = "",
 |  | string | subject = "",
 |  | string | headerComment = "",
 |  | MDFType | type = MDFType.V4,
 |  | bool | compress = false
 | ) |  |

Creates a new instance of MDFWriter with the specified arguments.

Parameters
author | The author (32 bytes supported)
organization | The organization (32 bytes supported)
project | The project (32 bytes supported)
subject | The subject (32 bytes supported)
headerComment | The comment on the header block
type | MDF format used to write
compress | true to compress data (only supported with type = MDFType.V4)
Exceptions
ArgumentException Thrown, if compressed is true on a MDF V3 recording

Member Function Documentation

◆ addAnnotation()

void addAnnotation | ( | double | timestamp,
 |  | string | text
 | ) |  |

Adds an annotation with the specified timestamp.

Parameters
timestamp | The timestamp in (relative) seconds
text | The annotation text

◆ addDataEntry()

bool addDataEntry | ( | int | handle,
 |  | double | timestamp,
 |  | byte[] | data,
 |  | List< double > | readBackValues = null
 | ) |  |

Adds data to the specified channel group.

If the method returns false, the specified data length did not fit to the configured data length or there is no more space available to store data.

  • data longer than the specifed length doesn't get written
  • data smaller than the specified length will be filled up with zero's.
Parameters
handle | The channel group handle, refers to the handle given in addMeasurements or returned by addRawData
timestamp | The timestamp in (recording relative) seconds
data | The raw data
readBackValues
  • If an instance is specified, it gets cleared and filled with the corresponding physical values (in the writing order).
  • For Values who don't result in a double value (e.g. strings or raw data blocks), a double.NaN is added to the list.
Returns
true if successful
Exceptions
ArgumentException Thrown, if the specified handle is not found

◆ addMeasurement() [1/3]

void addMeasurement | ( | int | handle,
 |  | string | name,
 |  | string | unit,
 |  | double | lowerLimit,
 |  | double | upperLimit,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | IDictionary< double, sRange > | rangeTable,
 |  | string | defaultText,
 |  | string | description = null,
 |  | int | bitOffset = 0
 | ) |  |

Add a new measurement to the specified channel group handle.

Usage:

  • After calling createChannelGroup consecutive calls to this method could be done (until the recordsize is exceeded, 64k for MDF V3, 4G for MDF V4).
  • Consecutive calls to this method must be done in the order the raw data is written later by calls to addDataEntry.
Parameters
handle | The handle returned by createChannelGroup
name | The signal name
unit | Unit
lowerLimit | The lower channel limit
upperLimit | The upper channel limit
dt | Data type
bo | Byte order
rangeTable | A potential range table to use
defaultText | Default text for the range table
description | Signal's description
bitOffset | greater 0 for exact positioning (The Recordsize of the corresponding ChannelGroup can be set explicitely using this[handle] on the MDF writer instance
Exceptions
ArgumentException Thrown if
  • The specified handle isn't created previously by createChannelGroup
  • Method is called while data is already added by addDataEntry
  • Record size is exceeded.

◆ addMeasurement() [2/3]

void addMeasurement | ( | int | handle,
 |  | string | name,
 |  | string | unit,
 |  | double | lowerLimit,
 |  | double | upperLimit,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | IDictionary< double, string > | textTable,
 |  | string | description = null,
 |  | int | bitOffset = 0
 | ) |  |

Add a new measurement to the specified channel group handle.

Usage:

  • After calling createChannelGroup consecutive calls to this method could be done (until the recordsize is exceeded, 64k for MDF V3, 4G for MDF V4).
  • Consecutive calls to this method must be done in the order the raw data is written later by calls to addDataEntry.
Parameters
handle | The handle returned by createChannelGroup
name | The signal name
unit | Unit
lowerLimit | The lower channel limit
upperLimit | The upper channel limit
dt | Data type
bo | Byte order
textTable | A potential text table to use
description | Signal's description
bitOffset | greater 0 for exact positioning (The Recordsize of the corresponding ChannelGroup can be set explicitely using this[handle] on the MDF writer instance
Exceptions
ArgumentException Thrown if
  • The specified handle isn't created previously by createChannelGroup
  • Method is called while data is already added by addDataEntry
  • Record size is exceeded.

◆ addMeasurement() [3/3]

void addMeasurement | ( | int | handle,
 |  | string | name,
 |  | string | unit,
 |  | double | lowerLimit,
 |  | double | upperLimit,
 |  | DATA_TYPE | dt,
 |  | BYTEORDER_TYPE | bo,
 |  | string | description = null,
 |  | double[] | para = null,
 |  | int | bitOffset = 0
 | ) |  |

Add a new measurement to the specified channel group handle.

Usage:

  • After calling createChannelGroup consecutive calls to this method could be done (until the recordsize is exceeded, 64k for MDF V3, 4G for MDF V4).
  • Consecutive calls to this method must be done in the order the raw data is written later by calls to addDataEntry.
Parameters
handle | The handle returned by createChannelGroup
name | The signal name
unit | Unit
lowerLimit | The lower channel limit
upperLimit | The upper channel limit
dt | Data type
bo | Byte order
description | Signal's description
para | Parameter set for two different CONVERSION_TYPE's.
  • null for CONVERSION_TYPE.None
  • 2 values for CONVERSION_TYPE.ParametricLinear (linear function of the following type: f(x)=ax + b) ATTENTION: para[0] = b, para[1] = a
  • 6 values for CONVERSION_TYPE.Rational (fractional rational function of the following type f(x)=(axx + bx + c)/(dxx + ex + f) para[0] = a, para[1] = b, para[2] = c, para[3] = d, para[4] = e, para[5] = f
Parameters
bitOffset greater 0 for exact positioning (The Recordsize of the corresponding ChannelGroup can be set explicitely using this[handle] on the MDF writer instance
Exceptions
ArgumentException Thrown if
  • The specified handle isn't created previously by createChannelGroup
  • Method is called while data is already added by addDataEntry
  • Record size is exceeded.
  • Parameter count mismatch not in [2,6]

◆ addMeasurements() [1/2]

int addMeasurements | ( | int | daqListNo,
 |  | IEnumerable< A2LCONVERSION_REF > | convRefs,
 |  | uint | arrayIndexBase = 0,
 |  | string | cgComment = null
 | ) |  |

Adds the specified A2L measurements and/or characteristics to the MDF writer instance.

Creates a new Data- and Channel Group, a time channel and adds the specified channels to them. Important: The list of measurement channels requires to be in the same order as the data in addDataEntry gets added!

Parameters
daqListNo | A unique id (usually the DAQ list number)
convRefs | The measurements/characteristics to add
arrayIndexBase | Index base for name suffix on measurement arrays
cgComment | A comment string for the channel group
Exceptions
ArgumentException Thrown if the MDF limits are exceeded or the specified daqListNo is already existing
Returns
The handle returned by createChannelGroup

◆ addMeasurements() [2/2]

int addMeasurements | ( | int | daqListNo,
 |  | IEnumerable< DAQMeasurement > | measurements,
 |  | uint | arrayIndexBase = 0,
 |  | string | cgComment = null
 | ) |  |

Adds the specified A2L measurements and/or characteristics to the MDF writer instance.

Creates a new Data- and Channel Group, a time channel and adds the specified channels to them. Important: The list of measurement channels requires to be in the same order as the data in addDataEntry gets added!

Parameters
daqListNo | A unique id (usually the DAQ list number)
measurements | The measurements to add
arrayIndexBase | Index base for name suffix on measurement arrays
cgComment | A comment string for the channel group
Exceptions
ArgumentOutOfRangeException Thrown if the MDF limits are exceeded or the specified daqListNo is already existing
Returns
The handle returned by createChannelGroup

◆ addRawData()

int addRawData | ( | string | cgComment,
 |  | uint | recordSize,
 |  | string | name,
 |  | string | description = null,
 |  | SignalType | signalType = SignalType.BYTE_ARRAY
 | ) |  |

Creates a new Data- and Channel Group, a time channel and adds the specified raw data size to them.

Parameters
cgComment | The comment on the channel group (may be null or empty)
recordSize | The size of data to write with a single addDataEntry call
name | The raw data block's name
description | The raw data block's description
signalType | The raw data block's signal type
Returns
The handle to use in the addDataEntry method
Exceptions
ArgumentException Thrown if the allowed record size is exceeded

◆ addSourceInformation()

void addSourceInformation | ( | int | handle,
 |  | SourceType | source,
 |  | BusType | bus = BusType.NONE,
 |  | string | name = null,
 |  | string | path = null,
 |  | string | comment = null,
 |  | SourceFlags | flags = SourceFlags.None
 | ) |  |

Adds source information to the specified channel group.

This method is only supported by MDF V4.

Parameters
handle | The channel group handle, refers to the handle given in addMeasurements or returned by addRawData
source | The source type
bus | The bus type
name | The acquisition source name
path | The acquisition source path
comment | The acquisition source comment
flags | The acquisition source flags
Exceptions
ArgumentException Thrown, if type is not V4 or the specified handle is not found

◆ createChannelGroup()

int createChannelGroup ( string cgComment = null )

Create a new channel group.

Call this method before calling the addMeasurement method.

Parameters
cgComment | A comment string for the channel group
forceHandle | Use the given handle (only used internally)
Returns
The handle to use in the addDataEntry/addMeasurement methods

◆ save()

bool save ( string path )

Saves the MDF file structure to the specified file path.

Parameters
path The file path to store
Returns
true if measured data is stored

Property Documentation

◆ this[int handle]

ICGBLOCK?? this[int handle]
get

Get the corresponding CGBLOCK to the specified handle.

Parameters
handle The channel group handle, refers to the handle returned by createChannelGroup, addMeasurements or addRawData
Returns
A ICGBLOCK Instance or null if not found


ASAP2Library interface: Member List

  • MDF
  • MDFWriter
MDFWriter Member List

This is the complete list of members for MDFWriter, including all inherited members.

addAnnotation(double timestamp, string text) | MDFWriter
addDataEntry(int handle, double timestamp, byte[] data, List< double > readBackValues=null) | MDFWriter
addMeasurement(int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, IDictionary< double, string > textTable, string description=null, int bitOffset=0) | MDFWriter
addMeasurement(int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, IDictionary< double, sRange > rangeTable, string defaultText, string description=null, int bitOffset=0) | MDFWriter
addMeasurement(int handle, string name, string unit, double lowerLimit, double upperLimit, DATA_TYPE dt, BYTEORDER_TYPE bo, string description=null, double[] para=null, int bitOffset=0) | MDFWriter
addMeasurements(int daqListNo, IEnumerable< A2LCONVERSION_REF > convRefs, uint arrayIndexBase=0, string cgComment=null) | MDFWriter
addMeasurements(int daqListNo, IEnumerable< DAQMeasurement > measurements, uint arrayIndexBase=0, string cgComment=null) | MDFWriter
addRawData(string cgComment, uint recordSize, string name, string description=null, SignalType signalType=SignalType.BYTE_ARRAY) | MDFWriter
addSourceInformation(int handle, SourceType source, BusType bus=BusType.NONE, string name=null, string path=null, string comment=null, SourceFlags flags=SourceFlags.None) | MDFWriter
Compress | MDFWriter
createChannelGroup(string cgComment=null) | MDFWriter
DataReceived | MDFWriter
Dispose() | MDFWriter
MDFWriter(string author="", string organization="", string project="", string subject="", string headerComment="", MDFType type=MDFType.V4, bool compress=false) | MDFWriter
save(string path) | MDFWriter
this[int handle] | MDFWriter
Type | MDFWriter


ASAP2Library interface: RawDataRecord Class Reference

  • MDF
  • RawDataRecord
Public Attributes | List of all members
RawDataRecord Class Reference

Used to transfer MDF raw data record. More...

Public Attributes

byte[] | Data
The raw data.
double | Timestamp
The timestamp (in physical format).

Detailed Description

Used to transfer MDF raw data record.


ASAP2Library interface: Member List

  • MDF
  • RawDataRecord
RawDataRecord Member List

This is the complete list of members for RawDataRecord, including all inherited members.

Data | RawDataRecord
Timestamp | RawDataRecord


ASAP2Library interface: WriteRawDataEventArgs Class Reference

  • MDF
  • WriteRawDataEventArgs
Public Attributes | List of all members
WriteRawDataEventArgs Class Reference

EVent arguments to request the MDFWriter to write the raw data to the stream. More...

Public Attributes

readonly IMDFBlock | Block
Calling Block
readonly BinaryWriter | Bw
Stream to write the raw data to.

Detailed Description

EVent arguments to request the MDFWriter to write the raw data to the stream.


ASAP2Library interface: Member List

  • MDF
  • WriteRawDataEventArgs
WriteRawDataEventArgs Member List

This is the complete list of members for WriteRawDataEventArgs, including all inherited members.

Block | WriteRawDataEventArgs
Bw | WriteRawDataEventArgs


ASAP2Library interface: jnsoft.Symbols Namespace Reference

  • Symbols
Namespaces | Classes | Enumerations
jnsoft.Symbols Namespace Reference

Implements the Symbol support. More...

Namespaces

namespace | ELF
Implements the ELF file format reader (supports 32 and 64 Bit).
namespace | MAP
Implements the MAP file format reader.

Classes

class | SymbolFile
Implements the base class for specific Symbol files (like ELF or MAP). More...
class | UpdateData
Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition. More...
class | UpdaterSymbols
Created symbols by ELF, DWARF or MAP interpretation. More...

Enumerations

enum UpdateType { NotMatched , Matched , AdjustAddress , AdjustAddressAndSize }
Computed synchronizing states between A2L definition and ELF file definition. More...

Detailed Description

Implements the Symbol support.

Used to interprete Symhol files (e.g ELF/MAP files) in order to update A2L object addresses.

Enumeration Type Documentation

◆ UpdateType

enum UpdateType

Computed synchronizing states between A2L definition and ELF file definition.

Enumerator
NotMatched

A2L Symbol is not defined anymore in the ELF file. In this case the A2L definition may be deleted.

Matched

Symbol is matched, there is no address or size adjustment required.

AdjustAddress

Address and size could be adjusted (ELF object size equals to A2L size).

AdjustAddressAndSize

The ELF object size does not match the A2L object size.

This may be caused by

  • A single element is matched only by it's index on an ELF symbol (in this case this warning could be ignored and handled the same way as UpdateType.AdjustAddress).
  • A datatype or array size change. In this case an A2L redefinition should be done, too.


ASAP2Library interface: jnsoft.Symbols.ELF Namespace Reference

  • Symbols
  • ELF
Namespaces | Classes
jnsoft.Symbols.ELF Namespace Reference

Implements the ELF file format reader (supports 32 and 64 Bit). More...

Namespaces

namespace DWARF
All the stuff to support the DWARF Debugging Information Format Version 5.

Classes

class ELFFile
Implements the ELF file format reader. More...

Detailed Description

Implements the ELF file format reader (supports 32 and 64 Bit).

Basic access to a ELF file is provided by the ELFFile class.

  • Provides methods and properties to open and access the ELF model.
  • Supports DWARF (at least version 2) formatted debug information contained in the ELF file.
  • Provides methods to update and rewrite an opened A2L object model.


ASAP2Library interface: jnsoft.Symbols.ELF.DWARF Namespace Reference

  • Symbols
  • ELF
  • DWARF
Classes | Enumerations
jnsoft.Symbols.ELF.DWARF Namespace Reference

All the stuff to support the DWARF Debugging Information Format Version 5. More...

Classes

class | AbbrevEntry
DWARF abbreviation entry representation. More...
class | AbbrevEntryArray
Represents an abbreviation array type. More...
class | AbbrevEntryCU
Represents an abbreviation compilation unit. More...
class | AbbrevEntryMember
Represents an abbreviation member. More...
class | AbbrevEntryVarBase
Represents a base class for variables and members More...
class | AbbrevEntryVariable
Represents an abbreviation variable. More...
class | Attribute
DWARF attribute representation. More...
class | CompilationUnitHeader
DWARF compilation unit header. More...
class | DWARFInfo
Implements a parser to support the DWARF Debugging Information Format Version 5. More...
class | TypeUnitHeader
Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section. More...

Enumerations

enum DW_AT {
none , sibling , location , name ,
ordering = 0x09 , subscr_data , byte_size , bit_offset ,
bit_size , element_list = 0x0f , stmt_list , low_pc ,
high_pc , language , member , discr ,
discr_value , visibility , import , string_length ,
common_reference , comp_dir , const_value , containing_type ,
default_value , inline = 0x20 , is_optional , lower_bound ,
producer = 0x25 , prototyped = 0x27 , return_addr = 0x2a , start_scope = 0x2c ,
bit_stride = 0x2e , upper_bound , abstract_origin = 0x31 , accessibility ,
address_class , artificial , base_types , calling_convention ,
count , data_member_location , decl_column , decl_file ,
decl_line , declaration , discr_list , encoding ,
external , frame_base , friend , identifier_case ,
macro_info , namelist_item , priority , segment ,
specification , static_link , type , use_location ,
variable_parameter , virtuality , vtable_elem_location , allocated ,
associated , data_location , byte_stride , entry_pc ,
use_UTF8 , extension , ranges , trampoline ,
call_column , call_file , call_line , description ,
binary_scale , decimal_scale , small , decimal_sign ,
digit_count , picture_string , mutable , threads_scaled ,
explicite , object_pointer , endianity , elemental ,
pure , recursive , signature , main_subprogram ,
data_bit_offset , const_expr , enum_class , linkage_name ,
lo_user = 0x2000 , hi_user = 0x3fff
}
DWARF Attribute encodings.
enum DW_FORM : byte {
addr = 0x01 , block2 = 0x03 , block4 , data2 ,
data4 , data8 , strng , block ,
block1 , data1 , flag , sdata ,
strp , udata , ref_addr , ref1 ,
ref2 , ref4 , ref8 , ref_udata ,
indirect , sec_offset , exprloc , flag_present ,
ref_sig8 = 0x20
}
DWARF Form encodings.
enum DW_LANG {
Unknown , C89 , C , Ada83 ,
C_plus_plus , Cobol74 , Cobol85 , Fortran77 ,
Fortran90 , Pascal83 , Modula2 , Java ,
C99 , Ada95 , Fortran95 , PLI ,
ObjC , ObjC_plus_plus , UPC , D ,
Python , Go = 0x0016 , C_plus_plus_11 = 0x001a , C11 = 0x001d ,
C_plus_plus_14 = 0x0021 , Fortran03 , Fortran08 , lo_user = 0x8000 ,
hi_user = 0xffff , Mips_Assembler = 0x8001 , Upc = 0x8765 , HP_Bliss = 0x8003 ,
HP_Basic91 , HP_Pascal91 , HP_IMacro , HP_Assembler
}
Possible source languages of the compilation unit.
enum DW_TAG : uint {
array_type = 0x01 , class_type , entry_point , enumeration_type ,
formal_parameter , imported_declaration = 0x08 , label = 0x0a , lexical_block ,
member = 0x0d , pointer_type = 0x0f , reference_type , compile_unit ,
string_type , structure_type , subroutine_type = 0x15 , typedef ,
union_type , unspecified_parameters , variant , common_block ,
common_inclusion , inheritance , inlined_subroutine , module ,
ptr_to_member_type , set_type , subrange_type , with_stmt ,
access_declaration , base_type , catch_block , const_type ,
constant , enumerator , friend = 0x2a , namelist ,
namelist_item , packed_type , subprogram , template_type_parameter ,
template_value_parameter , thrown_type , try_block , variant_part ,
variable , volatile_type , dwarf_procedure , restrict_type ,
interface_type , namespace_ , imported_module , unspecified_type ,
partial_unit , imported_unit , condition = 0x3f , shared_type ,
type_unit , rvalue_reference_type , template_alias , lo_user = 0x4080 ,
hi_user = 0xffff
}
DWARF Tag encodings.

Detailed Description

All the stuff to support the DWARF Debugging Information Format Version 5.


ASAP2Library interface: AbbrevEntry Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntry
Public Member Functions | Public Attributes | Static Protected Member Functions | Protected Attributes | Properties | List of all members
AbbrevEntry Class Reference

DWARF abbreviation entry representation. More...

Public Member Functions

Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...

Public Attributes

readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag

Static Protected Member Functions

static ulong decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)

Protected Attributes

AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry

Properties

List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Detailed Description

DWARF abbreviation entry representation.

Member Function Documentation

◆ getAttribute()

Attribute getAttribute ( DW_AT tag )

Gets the attribute with the specified attribute tag.

Parameters
tag The attribute tag to get
Returns
The attribute instance or null if not found

◆ getBitOffset()

uint getBitOffset ( )

Gets the bit offset to the Address, if available.

Returns

◆ getByteSize()

ulong getByteSize ( )

Gets the byte size if available.

Returns

◆ getParent< T >()

T getParent< T > ( )

Gets the parent of the specified type.

Template Parameters
T The parent's type
Returns
the parent's instance or null if not found
Type Constraints
T : AbbrevEntry

◆ getSize()

ulong getSize ( )

Gets the size in bits if available.

Returns

◆ getVariable()

AbbrevEntry getVariable ( )

Gets the exporting variable instance.

Returns

Property Documentation

◆ HasTypeInfo

bool HasTypeInfo
get

Indicates if type info is available.

Returns

◆ Name

string??? Name
get

Gets the name if available.

Returns

◆ RootEntry

AbbrevEntryCU RootEntry
get

Gets the root entry (usually the compilation unit).

Returns
the root entry


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntry
AbbrevEntry Member List

This is the complete list of members for AbbrevEntry, including all inherited members.

Attributes | AbbrevEntry |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsPrototyped | AbbrevEntry |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |


ASAP2Library interface: AbbrevEntryArray Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryArray
List of all members
AbbrevEntryArray Class Reference

Represents an abbreviation array type. More...

Additional Inherited Members

- Public Member Functions inherited from AbbrevEntry
Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...
- Public Attributes inherited from AbbrevEntry
readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag
- Static Protected Member Functions inherited from AbbrevEntry
static ulong | decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)
- Protected Attributes inherited from AbbrevEntry
AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry
- Properties inherited from AbbrevEntry
List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Detailed Description

Represents an abbreviation array type.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryArray
AbbrevEntryArray Member List

This is the complete list of members for AbbrevEntryArray, including all inherited members.

Attributes | AbbrevEntry |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsPrototyped | AbbrevEntry |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |


ASAP2Library interface: AbbrevEntryCU Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryCU
Public Attributes | Properties | List of all members
AbbrevEntryCU Class Reference

Represents an abbreviation compilation unit. More...

Public Attributes

readonly CompilationUnitHeader | UH
The containing compilation/type unit header, only valid if Parent property is null (RootEntry).
- Public Attributes inherited from AbbrevEntry
readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag

Properties

DW_LANG? | Language [get]
Gets the language
string? | Producer [get]
Gets the producer
- Properties inherited from AbbrevEntry
List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Additional Inherited Members

- Public Member Functions inherited from AbbrevEntry
Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...
- Static Protected Member Functions inherited from AbbrevEntry
static ulong | decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)
- Protected Attributes inherited from AbbrevEntry
AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry

Detailed Description

Represents an abbreviation compilation unit.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryCU
AbbrevEntryCU Member List

This is the complete list of members for AbbrevEntryCU, including all inherited members.

Attributes | AbbrevEntry |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsPrototyped | AbbrevEntry |
Language | AbbrevEntryCU |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
Producer | AbbrevEntryCU |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |
UH | AbbrevEntryCU |


ASAP2Library interface: AbbrevEntryMember Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryMember
Properties | List of all members
AbbrevEntryMember Class Reference

Represents an abbreviation member. More...

Properties

long | BitOffset [get]
Gets the offset to the contained parent address in bits
- Properties inherited from AbbrevEntryVarBase
virtual ulong | Location [get]
Gets the variable location
- Properties inherited from AbbrevEntry
List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Additional Inherited Members

- Public Member Functions inherited from AbbrevEntry
Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...
- Public Attributes inherited from AbbrevEntry
readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag
- Static Protected Member Functions inherited from AbbrevEntry
static ulong | decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)
- Protected Attributes inherited from AbbrevEntry
AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry

Detailed Description

Represents an abbreviation member.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryMember
AbbrevEntryMember Member List

This is the complete list of members for AbbrevEntryMember, including all inherited members.

Attributes | AbbrevEntry |
BitOffset | AbbrevEntryMember |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsPrototyped | AbbrevEntry |
Location | AbbrevEntryVarBase |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |


ASAP2Library interface: AbbrevEntryVarBase Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryVarBase
Properties | List of all members
AbbrevEntryVarBase Class Reference

Represents a base class for variables and members More...

Properties

virtual ulong | Location [get]
Gets the variable location
- Properties inherited from AbbrevEntry
List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Additional Inherited Members

- Public Member Functions inherited from AbbrevEntry
Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...
- Public Attributes inherited from AbbrevEntry
readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag
- Static Protected Member Functions inherited from AbbrevEntry
static ulong | decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)
- Protected Attributes inherited from AbbrevEntry
AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry

Detailed Description

Represents a base class for variables and members


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryVarBase
AbbrevEntryVarBase Member List

This is the complete list of members for AbbrevEntryVarBase, including all inherited members.

Attributes | AbbrevEntry |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsPrototyped | AbbrevEntry |
Location | AbbrevEntryVarBase |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |


ASAP2Library interface: AbbrevEntryVariable Class Reference

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryVariable
Properties | List of all members
AbbrevEntryVariable Class Reference

Represents an abbreviation variable. More...

Properties

bool | IsExternal [get]
Indicates if the variable is externally visible
bool | IsExternalSymbol [get]
Indicates if the variable could be used as an external symbol.
bool | IsSymbol [get]
Indicates if the variable is a symbol
override ulong? | Location [get]
- Properties inherited from AbbrevEntryVarBase
virtual ulong | Location [get]
Gets the variable location
- Properties inherited from AbbrevEntry
List< AbbrevEntry > | Childs = new List<AbbrevEntry>() [getset]
Gets all child entries
bool | HasTypeInfo [get]
Indicates if type info is available. More...
bool | IsDeclaration [get]
Indicates if the declaration flag is set.
bool | IsPrototyped [get]
Indicates if the prototyped flag is set.
string??? | Name [get]
Gets the name if available. More...
AbbrevEntry | Parent [getset]
Gets the parent entry, or null (Rootentry)
AbbrevEntryCU | RootEntry [get]
Gets the root entry (usually the compilation unit). More...

Additional Inherited Members

- Public Member Functions inherited from AbbrevEntry
Attribute | getAttribute (DW_AT tag)
Gets the attribute with the specified attribute tag. More...
uint | getBitOffset ()
Gets the bit offset to the Address, if available. More...
ulong | getByteSize ()
Gets the byte size if available. More...
T | getParent< T > ()
Gets the parent of the specified type. More...
ulong | getSize ()
Gets the size in bits if available. More...
AbbrevEntry getVariable ()
Gets the exporting variable instance. More...
- Public Attributes inherited from AbbrevEntry
readonly List< Tuple< DW_AT, Attribute > > | Attributes = new List<Tuple<DW_AT, Attribute>>()
Gets the attributes
readonly bool | HasChilds
Indicates if childs are available
readonly long | RefId
Offset to begin of debug_info section
readonly DW_TAG | TAG
Gets the DWARF Tag
- Static Protected Member Functions inherited from AbbrevEntry
static ulong | decodeLocationExpression (byte[] data, CompilationUnitHeader cuh)
- Protected Attributes inherited from AbbrevEntry
AbbrevEntryCU | mRootEntry
readonly AbbrevEntry | mSpecEntry

Detailed Description

Represents an abbreviation variable.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • AbbrevEntryVariable
AbbrevEntryVariable Member List

This is the complete list of members for AbbrevEntryVariable, including all inherited members.

Attributes | AbbrevEntry |
Childs | AbbrevEntry |
decodeLocationExpression(byte[] data, CompilationUnitHeader cuh) (defined in AbbrevEntry) | AbbrevEntry | protectedstatic
getAttribute(DW_AT tag) | AbbrevEntry |
getBitOffset() | AbbrevEntry |
getByteSize() | AbbrevEntry |
getParent< T >() | AbbrevEntry |
getSize() | AbbrevEntry |
getVariable() | AbbrevEntry |
HasChilds | AbbrevEntry |
HasTypeInfo | AbbrevEntry |
IsDeclaration | AbbrevEntry |
IsExternal | AbbrevEntryVariable |
IsExternalSymbol | AbbrevEntryVariable |
IsPrototyped | AbbrevEntry |
IsSymbol | AbbrevEntryVariable |
Location (defined in AbbrevEntryVariable) | AbbrevEntryVariable |
mRootEntry (defined in AbbrevEntry) | AbbrevEntry | protected
mSpecEntry (defined in AbbrevEntry) | AbbrevEntry | protected
Name | AbbrevEntry |
Parent | AbbrevEntry |
RefId | AbbrevEntry |
RootEntry | AbbrevEntry |
TAG | AbbrevEntry |


ASAP2Library interface: Attribute Class Reference

  • Symbols
  • ELF
  • DWARF
  • Attribute
Public Member Functions | Public Attributes | Properties | List of all members
Attribute Class Reference

DWARF attribute representation. More...

Public Member Functions

override string ToString ()

Public Attributes

readonly DW_AT | AT
Gets the attribute type
readonly DW_FORM | FORM
Gets the attribute format

Properties

object Value [getset]
Gets the attribute value/summary>

Detailed Description

DWARF attribute representation.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • Attribute
Attribute Member List

This is the complete list of members for Attribute, including all inherited members.

AT | Attribute
FORM | Attribute
ToString() (defined in Attribute) | Attribute
Value | Attribute


ASAP2Library interface: CompilationUnitHeader Class Reference

  • Symbols
  • ELF
  • DWARF
  • CompilationUnitHeader
Public Attributes | List of all members
CompilationUnitHeader Class Reference

DWARF compilation unit header. More...

Public Attributes

readonly byte | AddressSize
A 1-byte unsigned integer representing the size in bytes of an address on the target architecture
readonly bool | ChangeEndianess
true, if endianess should be changed on reading values.
readonly bool | Is64Bit
Is 64Bit DWARF
readonly ulong | Length
A 4-byte or 12-byte unsigned integer representing the length of the .debug_types contribution for that compilation unit
readonly ulong | Offset
A 4-byte or 8-byte unsigned offset into the .debug_abbrev section
readonly IList< AbbrevEntry > | RootEntries = new List<AbbrevEntry>()
The level 0 entrie of the compilation unit
readonly ushort | Version
A 2-byte unsigned integer representing the version of the DWARF information for the compilation unit

Detailed Description

DWARF compilation unit header.

Represents the header for the series of debugging information entries contributed by a single normal or partial compilation unit, within the .debug_info section.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • CompilationUnitHeader
CompilationUnitHeader Member List

This is the complete list of members for CompilationUnitHeader, including all inherited members.

AddressSize | CompilationUnitHeader
ChangeEndianess | CompilationUnitHeader
Is64Bit | CompilationUnitHeader
Length | CompilationUnitHeader
Offset | CompilationUnitHeader
RootEntries | CompilationUnitHeader
Version | CompilationUnitHeader


ASAP2Library interface: DWARFInfo Class Reference

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
Classes | Public Member Functions | Public Attributes | List of all members
DWARFInfo Class Reference

Implements a parser to support the DWARF Debugging Information Format Version 5. More...

Classes

class | SymbolsTree
DWARF symbols Tree. More...
class | SymbolValue
Represents a DWARF symbol. More...

Public Member Functions

void | expandSymbol (SymbolValue symbol)
Recursively expands the symbol analysing all it's members. More...
AbbrevEntry | getTypeRef (AbbrevEntry entry, Stack< AbbrevEntry > typeAttrStack, IDictionary< long, AbbrevEntry > abbrevDict, out ulong byteSize)
Gets the basic type of a variable/member. More...
string | getTypeStr (AbbrevEntry abbrevEntry)
Delivers a type string. More...

Public Attributes

readonly IList< CompilationUnitHeader > | CompilationUnits = new List<CompilationUnitHeader>()
Gets the DWARF compilation units.
readonly SymbolsTree | Symbols
Holds available symbols from the DAWRF information

Detailed Description

Implements a parser to support the DWARF Debugging Information Format Version 5.

The DWARF file format is usually content of an ELFFile using the ELFile sections '.debug_*'. DWARF sections are created by the compiler/linker (e.g. using the -g3 compiler switch with GCC).

Member Function Documentation

◆ expandSymbol()

void expandSymbol ( SymbolValue symbol )

Recursively expands the symbol analysing all it's members.

Parameters
symbol The symbol to expand

◆ getTypeRef()

AbbrevEntry getTypeRef | ( | AbbrevEntry | entry,
 |  | Stack< AbbrevEntry > | typeAttrStack,
 |  | IDictionary< long, AbbrevEntry > | abbrevDict,
 |  | out ulong | byteSize
 | ) |  |

Gets the basic type of a variable/member.

Recursive method to get a base_type or structure information.

Parameters
entry | teh entry to search for
typeAttrStack | [out] The traversed stack of abbrecentries between first call und result
abbrevDict | Abbreviation dictionary to use
byteSize | The types size in bytes
Returns
resulting AbbrevEntry representing a base_type or structure.

◆ getTypeStr()

string getTypeStr ( AbbrevEntry abbrevEntry )

Delivers a type string.

Parameters
abbrevEntry Enty type to search on
Returns
type string representation


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
DWARFInfo Member List

This is the complete list of members for DWARFInfo, including all inherited members.

CompilationUnits | DWARFInfo
expandSymbol(SymbolValue symbol) | DWARFInfo
getTypeRef(AbbrevEntry entry, Stack< AbbrevEntry > typeAttrStack, IDictionary< long, AbbrevEntry > abbrevDict, out ulong byteSize) | DWARFInfo
getTypeStr(AbbrevEntry abbrevEntry) | DWARFInfo
Symbols | DWARFInfo


ASAP2Library interface: DWARFInfo.SymbolsTree Class Reference

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
  • SymbolsTree
Public Member Functions | List of all members
DWARFInfo.SymbolsTree Class Reference

DWARF symbols Tree. More...

Public Member Functions

IEnumerable< Tuple< string, UpdaterSymbols > > enumSymbols ()
Enumerate symbols. More...

Detailed Description

DWARF symbols Tree.

Member Function Documentation

◆ enumSymbols()

IEnumerable< Tuple< string, UpdaterSymbols > > enumSymbols ( )

Enumerate symbols.

Returns
Tuple of symbol name and symbol data


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
  • SymbolsTree
DWARFInfo.SymbolsTree Member List

This is the complete list of members for DWARFInfo.SymbolsTree, including all inherited members.

enumSymbols() DWARFInfo.SymbolsTree


ASAP2Library interface: DWARFInfo.SymbolValue Class Reference

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
  • SymbolValue
Public Member Functions | Public Attributes | Properties | List of all members
DWARFInfo.SymbolValue Class Reference

Represents a DWARF symbol. More...

Public Member Functions

IList< string > | buildArrayIndexes ()
Build array index strings More...
long | getArrayElementCount ()
Gets the count of array elements if th symbol is an array More...
override string | ToString ()

Public Attributes

readonly ulong | Address
Memory address
readonly long[] | ArrayDim
Array dimensions
readonly uint | BitOffset
readonly ulong | EntrySize
Array entry size in byte symbol/member is an array
readonly SymbolValue | Parent
Parent symbol (may be null if symbol is root)
readonly ulong | Size
Size in Bits
readonly AbbrevEntry | Type
Corresponding DWARF type
readonly AbbrevEntryVarBase | VarBase
Corresponding DWARF entry

Properties

IList< SymbolValue > | Childs [get]
List of child symbols (may be null)
bool | IsExpanded [get]
Indicates if the symbol is already expanded
string | Name [get]
Symbol/Member name

Detailed Description

Represents a DWARF symbol.

Member Function Documentation

◆ buildArrayIndexes()

IList< string > buildArrayIndexes ( )

Build array index strings

Returns
List of array indexes

◆ getArrayElementCount()

long getArrayElementCount ( )

Gets the count of array elements if th symbol is an array

Returns
Count of elemements, 0 if this is not an array


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • DWARFInfo
  • SymbolValue
DWARFInfo.SymbolValue Member List

This is the complete list of members for DWARFInfo.SymbolValue, including all inherited members.

Address | DWARFInfo.SymbolValue
ArrayDim | DWARFInfo.SymbolValue
BitOffset (defined in DWARFInfo.SymbolValue) | DWARFInfo.SymbolValue
buildArrayIndexes() | DWARFInfo.SymbolValue
Childs | DWARFInfo.SymbolValue
EntrySize | DWARFInfo.SymbolValue
getArrayElementCount() | DWARFInfo.SymbolValue
IsExpanded | DWARFInfo.SymbolValue
Name | DWARFInfo.SymbolValue
Parent | DWARFInfo.SymbolValue
Size | DWARFInfo.SymbolValue
ToString() (defined in DWARFInfo.SymbolValue) | DWARFInfo.SymbolValue
Type | DWARFInfo.SymbolValue
VarBase | DWARFInfo.SymbolValue


ASAP2Library interface: TypeUnitHeader Class Reference

  • Symbols
  • ELF
  • DWARF
  • TypeUnitHeader
List of all members
TypeUnitHeader Class Reference

Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section. More...

Additional Inherited Members

- Public Attributes inherited from CompilationUnitHeader
readonly byte | AddressSize
A 1-byte unsigned integer representing the size in bytes of an address on the target architecture
readonly bool | ChangeEndianess
true, if endianess should be changed on reading values.
readonly bool | Is64Bit
Is 64Bit DWARF
readonly ulong | Length
A 4-byte or 12-byte unsigned integer representing the length of the .debug_types contribution for that compilation unit
readonly ulong | Offset
A 4-byte or 8-byte unsigned offset into the .debug_abbrev section
readonly IList< AbbrevEntry > | RootEntries = new List<AbbrevEntry>()
The level 0 entrie of the compilation unit
readonly ushort | Version
A 2-byte unsigned integer representing the version of the DWARF information for the compilation unit

Detailed Description

Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • DWARF
  • TypeUnitHeader
TypeUnitHeader Member List

This is the complete list of members for TypeUnitHeader, including all inherited members.

AddressSize | CompilationUnitHeader
ChangeEndianess | CompilationUnitHeader
Is64Bit | CompilationUnitHeader
Length | CompilationUnitHeader
Offset | CompilationUnitHeader
RootEntries | CompilationUnitHeader
Version | CompilationUnitHeader


ASAP2Library interface: jnsoft.Symbols.ELF.Examples Namespace Reference

  • Symbols
  • ELF
  • Examples
Classes
jnsoft.Symbols.ELF.Examples Namespace Reference

Classes

class Program
ASAP2ELFExample. More...


ASAP2Library interface: Program Class Reference

  • Symbols
  • ELF
  • Examples
  • Program
List of all members
Program Class Reference

ASAP2ELFExample. More...

Detailed Description

ASAP2ELFExample.

  • Loading an ELF file
  • Updating addresses of a corresponding A2L file.
  • (Re)write the A2L file.

Usage: ASAP2ELFExample ELFFile.elf A2LFile.a2l


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • Examples
  • Program
Program Member List

This is the complete list of members for Program, including all inherited members.


ASAP2Library interface: ELFFile Class Reference

  • Symbols
  • ELF
  • ELFFile
Classes | Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
ELFFile Class Reference

Implements the ELF file format reader. More...

Classes

class | ELFHeader
ELF File Header definition. More...
class | ELFSection
ELF Section definition. More...
class | ELFSymbol
ELF File Symbol definition. More...
class | SectionList
List of ELF Sections. More...
class | SectionValue
Maps a ELF Section name to an ELFSection instance. More...
class | SymbolValue
ELF Symbol Value representation. More...

Public Types

enum | EndiannessType : byte { LittleEndian = 1 , BigEndian }
Endianess of the ELF file content. More...
enum FlagsType : ulong {
WRITE = 0x1 , ALLOC = WRITE << 1 , EXECINSTR = WRITE << 2 , MERGE = WRITE << 4 ,
STRINGS = WRITE << 5 , INFO_LINK = WRITE << 6 , LINK_ORDER = WRITE << 7 , OS_NONCONFORMING = WRITE << 8 ,
GROUP = WRITE << 9 , TLS = WRITE << 10 , COMPRESSED = WRITE << 11
}
Possible section flags. More...
enum | FormatType : byte { _32Bit = 1 , _64Bit }
ELF file format. More...
enum MachineType : ushort {
NONE , M32 , SPARC , _386 ,
_68K , _88K , IAMCU , __860 ,
MIPS , S370 , MIPS_RS3_LE , PARISC = 15 ,
VPP500 = 17 , SPARC32PLUS , _960 , PPC ,
PPC64 , S390 , SPU , V800 = 36 ,
FR20 , RH32 , RCE , ARM ,
ALPHA , SH , SPARCV9 , TRICORE ,
ARC , H8_300 , H8_300H , H8S ,
H8_500 , IA_64 , MIPS_X , COLDFIRE ,
_68HC12 , MMA , PCP , NCPU ,
NDR1 , STARCORE , ME16 , ST100 ,
TINYJ , X86_64 , PDSP , PDP10 ,
PDP11 , FX66 , ST9PLUS , ST7 ,
_68HC16 , _68HC11 , _68HC08 , _68HC05 ,
SVX , ST19 , VAX , CRIS ,
JAVELIN , FIREPATH , ZSP , MMIX ,
HUANY , PRISM , AVR , FR30 ,
D10V , D30V , V850 , M32R ,
MN10300 , MN10200 , PJ , OPENRISC ,
ARC_COMPACT , XTENSA , VIDEOCORE , TMM_GPP ,
NS32K , TPC , SNP1K , ST200 ,
IP2K , MAX , CR , F2MC16 ,
MSP430 , BLACKFIN , SE_C33 , SEP ,
ARCA , UNICORE , EXCESS , DXP ,
ALTERA_NIOS2 , CRX , XGATE , C166 ,
M16C , DSPIC30F , CE , M32C ,
TSK3000 = 131 , RS08 , SHARC , ECOG2 ,
SCORE7 , DSP24 , VIDEOCORE3 , LATTICEMICO32 ,
SE_C17 , C6000 , C2000 , C5500 ,
ARP32 , PRU , MMDSP_PLUS = 160 , CYPRESS_M8C ,
R32C , TRIMEDIA , QDSP6 , _8051 ,
STXP7X , NDS32 , ECOG1 , MAXQ30 ,
XIMO16 , MANIK , CRAYNV2 , RX ,
METAG , MCST_ELBRUS , ECOG16 , CR16 ,
ETPU , SLE9X , L10M , K10M ,
AARCH64 = 183 , AVR32 = 185 , STM8 , TILE64 ,
TILEPRO , MICROBLAZE , CUDA , TILEGX ,
CLOUDSHIELD , COREA_1ST , COREA_2ST , ARC_COMPACT2 ,
OPEN8 , RL78 , VIDEOCORE5 , _78KOR ,
_56800EX , BA1 , BA2 , XCORE ,
MCHP_PIC , _205 , _206 , _207 ,
_208 , _209 , KM32 , KMX32 ,
KMX16 , KMX8 , KVARC , CDP ,
COGE , COOL , NORC , CSR_KALIMBA ,
Z80 , VISIUM , FT32 , MOXIE ,
AMDGPU , RISCV = 243 , EM_LANAI , EM_BPF = 247
}
Possible machine types.
enum OSType : byte {
SystemV , HPUX , NetBSD , Linux ,
Solaris = 0x06 , AIX , IRIX , FreeBSD ,
OpenBSD = 0x0c
}
Possible OS types, almost always 0 (SystemV)
enum SectionType : uint {
NULL , PROGBITS , SYMTAB , STRTAB ,
RELA , HASH , DYNAMIC , NOTE ,
NOBITS , REL , SHLIB , DYNSYM ,
INIT_ARRAY = 14 , FINI_ARRAY , PREINIT_ARRAY , GROUP ,
SYMTAB_SHNDX , SHT_RELR
}
Possible section types More...
enum SymbolBindType {
Local = 0 , Global , Weak , LoProc = 13 ,
HiProc = 15
}
ELF file symbol binding types. More...
enum SymbolType {
None , Object , Function , Section ,
File , Common , TLS , LoProc = 13 ,
HiProc = 15
}
ELF file symbol types. More...
enum TypeType : ushort {
None , Relocatable , Executable , Shared ,
Core
}
Possible ELF file types. More...
enum | VersionType : byte { Original = 1 }
Version types.

Public Member Functions

void | analyzeDwarf (HashSet< string > a2lSymbols=null, int maxVarDepth=1)
void | Dispose ()
Frees the ELF file reader.
SectionValue | getSection (ELFSymbol symbol)
Gets the coorresponding section for the specified symbol. More...
override IList< UpdateData > | getValuesToSynchronize (A2LParser parser, out ulong dataSegStart, out ulong dataSegLen)
Gets the List of values to synchronize with the specified A2L file. More...
- Public Member Functions inherited from SymbolFile
uint | updateAndWriteA2L (IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true)
Updates the specified A2L object model and writes it to an A2L file. More...

Static Public Member Functions

static ELFFile open (string path, bool copyFileToMemory=true, bool useDwarf=true)
Opens a ELF file and returns an ELFFile instance. More...

Public Attributes

readonly ELFHeader | Header
The ELF file Header.
readonly BinaryReader | Reader
Gets the binary reader of opened ELF file instance.
readonly SectionList | Sections = new SectionList()
Gets section list.
readonly IDictionary< string, SymbolValue > | Symbols = new Dictionary<string, SymbolValue>()
Gets the symbols dictionary.

Properties

DWARFInfo | Dwarf [get]
DWARF content (maybe null if no debug info is provided in the ELFFile)
- Properties inherited from SymbolFile
string | SourceFile [get]
Gets the fully qualified path to the source file. More...

Additional Inherited Members

- Protected Member Functions inherited from SymbolFile
SymbolFile (string sourceFile=null)

Detailed Description

Implements the ELF file format reader.

Member Enumeration Documentation

◆ EndiannessType

enum EndiannessType : byte

Endianess of the ELF file content.

Enumerator
LittleEndian | Little endian (Intel, LSB) format.
BigEndian | Big endian (Motorola, MSB) format.

◆ FlagsType

enum FlagsType : ulong

Possible section flags.

Enumerator
WRITE | The section contains data that should be writable during process execution.
ALLOC | The section occupies memory during process execution. Some control sections do not reside in the memory image of an object file; this attribute is off for those sections.
EXECINSTR | The section contains executable machine instructions.
MERGE | Might be merged
STRINGS | Contains nul-terminated strings
INFO_LINK | 'sh_info' contains SHT index
LINK_ORDER | Preserve order after combining
OS_NONCONFORMING | Non-standard OS specific handling required
GROUP | Section is member of a group.
TLS | Section hold thread-local data.
COMPRESSED | Section with compressed data.

◆ FormatType

enum FormatType : byte

ELF file format.

Enumerator
_32Bit | 32 Bit machine file content.
_64Bit | 64 Bit machine file content.

◆ SectionType

enum SectionType : uint

Possible section types

Enumerator
NULL | This value marks the section header as inactive; it does not have an associated section. Other members of the section header have undefined values.
PROGBITS | The section holds information defined by the program, whose format and meaning are determined solely by the program.
SYMTAB | These sections hold a symbol table. Currently, an object file may have only one section of each type, but this restriction may be relaxed in the future. Typically, SHT_SYMTAB provides symbols for link editing, though it may also be used for dynamic linking. As a complete symbol table, it may contain many symbols unnecessary for dynamic linking. Consequently, an object file may also contain a SHT_DYNSYM section, which holds a minimal set of dynamic linking symbols, to save space.
STRTAB | The section holds a string table. An object file may have multiple string table sections.
RELA | The section holds relocation entries with explicit addends, such as type Elf32_Rela for the 32-bit class of object files. An object file may have multiple relocation sections.
HASH | The section holds a symbol hash table. All objects participating in dynamic linking must contain a symbol hash table. Currently, an object file may have only one hashtable, but this restriction may be relaxed in the future.
DYNAMIC | The section holds information for dynamic linking. Currently, an object file may have only one dynamic section, but this restriction may be relaxed in the future.
NOTE | The section holds information that marks the file in some way.
NOBITS | A section of this type occupies no space in the file but otherwise resembles SHT_PROGBITS. Although this section contains no bytes, the sh_offset member contains the conceptual file offset.
REL | The section holds relocation entries without explicit addends, such as type Elf32_Rel for the 32-bit class of object files. An object file may have multiple relocation sections.
SHLIB | This section type is reserved but has unspecified semantics. Programs that contain a section of this type do not conform to the ABI.
DYNSYM | These sections hold a symbol table. Currently, an object file may have only one section of each type, but this restriction may be relaxed in the future. Typically, SHT_SYMTAB provides symbols for link editing, though it may also be used for dynamic linking. As a complete symbol table, it may contain many symbols unnecessary for dynamic linking. Consequently, an object file may also contain a SHT_DYNSYM section, which holds a minimal set of dynamic linking symbols, to save space.
INIT_ARRAY | Array of constructors
FINI_ARRAY | Array of destructors
PREINIT_ARRAY | Array of pre-constructors
GROUP | Section group
SYMTAB_SHNDX | Extended section indeces
SHT_RELR | Relocation entries; only offsets.

◆ SymbolBindType

enum SymbolBindType

ELF file symbol binding types.

Enumerator
Local | Local symbols are not visible outside the object file containing their definition. Local symbols of the same name may exist in multiple files without interfering with each other.
Global | Global symbols are visible to all object files being combined. One file’s definition of a global symbol will satisfy another file’s undefined reference to the same global symbol.
Weak | Weak symbols resemble global symbols, but their definitions have lower precedence.
LoProc | Values in this inclusive range (LoProc-HiProc) are reserved for processor-specific semantics.
HiProc | Values in this inclusive range (LoProc-HiProc) are reserved for processor-specific semantics.

◆ SymbolType

enum SymbolType

ELF file symbol types.

Enumerator
None | Symbol type is unspecified
Object | Symbol is a data object
Function | Symbol is a code object
Section | Symbol associated with a section
File | Symbol's name is file name
Common | Symbol is a common data object
TLS | Symbol is thread-local data object
LoProc | Start of processor-specific
HiProc | End of processor-specific

◆ TypeType

enum TypeType : ushort

Possible ELF file types.

Enumerator
None | No file type
Relocatable | Relocatable file
Executable | Executable file
Shared | Shared object file
Core | Core file

Member Function Documentation

◆ getSection()

SectionValue getSection ( ELFSymbol symbol )

Gets the coorresponding section for the specified symbol.

Parameters
symbol The symbol to get the scetion for
Returns
A section instance or null if not defined

◆ getValuesToSynchronize()

override IList< UpdateData > getValuesToSynchronize | ( | A2LParser | parser,
 |  | out ulong | dataSegStart,
 |  | out ulong | dataSegLen
 | ) |  |
virtual

Gets the List of values to synchronize with the specified A2L file.

Parameters
parser | A loaded A2L parser instance
dataSegStart | Returns start of datasegment
dataSegLen | Returns end of datasegment
Returns
List of values to synchronize in the specified A2L file

Implements SymbolFile.

◆ open()

static ELFFile open | ( | string | path,
 |  | bool | copyFileToMemory = true,
 |  | bool | useDwarf = true
 | ) |  |
static

Opens a ELF file and returns an ELFFile instance.

Parameters
path | the fully qualified ELF filename
copyFileToMemory
  • true if the specified file fits into memory (increased performance)
  • false if the specified file shouldn't load into memory (decreases performance)
useDwarf | set to false to disable DWARF support
Returns
A new ELFFile instance or null if failed


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
ELFFile Member List

This is the complete list of members for ELFFile, including all inherited members.

analyzeDwarf(HashSet< string > a2lSymbols=null, int maxVarDepth=1) (defined in ELFFile) | ELFFile |
Dispose() | ELFFile |
Dwarf | ELFFile |
EndiannessType enum name | ELFFile |
FlagsType enum name | ELFFile |
FormatType enum name | ELFFile |
getSection(ELFSymbol symbol) | ELFFile |
getValuesToSynchronize(A2LParser parser, out ulong dataSegStart, out ulong dataSegLen) | ELFFile | virtual
Header | ELFFile |
MachineType enum name | ELFFile |
open(string path, bool copyFileToMemory=true, bool useDwarf=true) | ELFFile | static
OSType enum name | ELFFile |
Reader | ELFFile |
Sections | ELFFile |
SectionType enum name | ELFFile |
SourceFile | SymbolFile |
SymbolBindType enum name | ELFFile |
SymbolFile(string sourceFile=null) (defined in SymbolFile) | SymbolFile | protected
Symbols | ELFFile |
SymbolType enum name | ELFFile |
TypeType enum name | ELFFile |
updateAndWriteA2L(IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true) | SymbolFile |
VersionType enum name | ELFFile |


ASAP2Library interface: ELFFile.ELFHeader Class Reference

  • Symbols
  • ELF
  • ELFFile
  • ELFHeader
Public Attributes | Properties | List of all members
ELFFile.ELFHeader Class Reference

ELF File Header definition. More...

Public Attributes

EndiannessType | Endianness
FormatType | Format
MachineType | Machine
uint | MagicNumber
OSType | OS
byte | OSVersion
TypeType | Type
VersionType | Version
uint | VersionNo

Properties

virtual ulong | ProcAddress [get]
virtual ulong | ProgHdrOffs [get]
virtual ushort | SectHdrEntryCount [get]
virtual ushort | SectHdrEntryIdxName [get]
virtual ushort | SectHdrEntrySize [get]
virtual ulong | SectHdrOffs [get]
virtual ushort | Size [get]

Detailed Description

ELF File Header definition.

  • Supports both 32 and 64 Bit versions.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • ELFHeader
ELFFile.ELFHeader Member List

This is the complete list of members for ELFFile.ELFHeader, including all inherited members.

Endianness (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
Format (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
Machine (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
MagicNumber (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
OS (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
OSVersion (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
ProcAddress (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
ProgHdrOffs (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
SectHdrEntryCount (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
SectHdrEntryIdxName (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
SectHdrEntrySize (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
SectHdrOffs (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
Size (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
Type (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
Version (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader
VersionNo (defined in ELFFile.ELFHeader) | ELFFile.ELFHeader


ASAP2Library interface: ELFFile.ELFSection Class Reference

  • Symbols
  • ELF
  • ELFFile
  • ELFSection
Public Attributes | Properties | List of all members
ELFFile.ELFSection Class Reference

ELF Section definition. More...

Public Attributes

uint | Name
Section name, index in string table.
SectionType | Type
Type of section.

Properties

virtual ulong | Adr [get]
Section virtual addr at execution
virtual ulong | AdrAlign [get]
Section alignment
virtual ulong | EntSize [get]
Entry size if section holds table
virtual FlagsType | Flags [get]
Miscellaneous section attributes.
virtual uint | Info [get]
Additional section information
virtual uint | Link [get]
Index of another section
virtual ulong | Ofs [get]
Section file offset
virtual ulong | Size [get]
Size of section in bytes

Detailed Description

ELF Section definition.

  • Supports both 32 and 64 Bit versions.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • ELFSection
ELFFile.ELFSection Member List

This is the complete list of members for ELFFile.ELFSection, including all inherited members.

Adr | ELFFile.ELFSection
AdrAlign | ELFFile.ELFSection
EntSize | ELFFile.ELFSection
Flags | ELFFile.ELFSection
Info | ELFFile.ELFSection
Link | ELFFile.ELFSection
Name | ELFFile.ELFSection
Ofs | ELFFile.ELFSection
Size | ELFFile.ELFSection
Type | ELFFile.ELFSection


ASAP2Library interface: ELFFile.ELFSymbol Class Reference

  • Symbols
  • ELF
  • ELFFile
  • ELFSymbol
Public Attributes | Properties | List of all members
ELFFile.ELFSymbol Class Reference

ELF File Symbol definition. More...

Public Attributes

uint Name

Properties

SymbolBindType | Bind [get]
Symbol's bind type
virtual ushort | Shndx [get]
virtual ulong | Size [get]
Symbol size in Bytes
SymbolType | Type [get]
Symbol's type
virtual ulong | Value [get]
Symbol's address

Detailed Description

ELF File Symbol definition.

  • Supports both 32 and 64 Bit versions.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • ELFSymbol
ELFFile.ELFSymbol Member List

This is the complete list of members for ELFFile.ELFSymbol, including all inherited members.

Bind | ELFFile.ELFSymbol
Name (defined in ELFFile.ELFSymbol) | ELFFile.ELFSymbol
Shndx (defined in ELFFile.ELFSymbol) | ELFFile.ELFSymbol
Size | ELFFile.ELFSymbol
Type | ELFFile.ELFSymbol
Value | ELFFile.ELFSymbol


ASAP2Library interface: ELFFile.SectionList Class Reference

  • Symbols
  • ELF
  • ELFFile
  • SectionList
Public Member Functions | List of all members
ELFFile.SectionList Class Reference

List of ELF Sections. More...

Public Member Functions

bool | getData (BinaryReader br, ulong address, ulong size, out byte[] data)
Reads data from the ELF file. More...
IEnumerable< SectionValue > | getDataSections ()
Gets the ELF File data section values. More...
IEnumerable< Tuple< SectionValue, SectionValue > > | getSymTabs ()
Gets the symbol tabs and the corresponding string tables. More...

Detailed Description

List of ELF Sections.

Member Function Documentation

◆ getData()

bool getData | ( | BinaryReader | br,
 |  | ulong | address,
 |  | ulong | size,
 |  | out byte[] | data
 | ) |  |

Reads data from the ELF file.

Parameters
br | The ELF file binary reader
address | Start address to read from
size | Data Size to read
data | Data
Returns
true if successful

◆ getDataSections()

IEnumerable< SectionValue > getDataSections ( )

Gets the ELF File data section values.

Returns

◆ getSymTabs()

IEnumerable< Tuple< SectionValue, SectionValue > > getSymTabs ( )

Gets the symbol tabs and the corresponding string tables.

Returns


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • SectionList
ELFFile.SectionList Member List

This is the complete list of members for ELFFile.SectionList, including all inherited members.

getData(BinaryReader br, ulong address, ulong size, out byte[] data) | ELFFile.SectionList
getDataSections() | ELFFile.SectionList
getSymTabs() | ELFFile.SectionList


ASAP2Library interface: ELFFile.SectionValue Class Reference

  • Symbols
  • ELF
  • ELFFile
  • SectionValue
Public Member Functions | Properties | List of all members
ELFFile.SectionValue Class Reference

Maps a ELF Section name to an ELFSection instance. More...

Public Member Functions

byte[] | getData (BinaryReader br)
Gets the sections data from the ELF file. More...
string | readUTF8String (BinaryReader br, long offset)
Reads a null-terminated string from the specified offset. More...

Properties

string | Name [getset]
Section name
ELFSection | Section [get]
Section file content

Detailed Description

Maps a ELF Section name to an ELFSection instance.

Member Function Documentation

◆ getData()

byte[] getData ( BinaryReader br )

Gets the sections data from the ELF file.

Parameters
br The ELF file binary reader
Returns

◆ readUTF8String()

string readUTF8String | ( | BinaryReader | br,
 |  | long | offset
 | ) |  |

Reads a null-terminated string from the specified offset.

Restores the reader position after string is read.

Parameters
br | The ELF file binary reader
offset | offset to read from
Returns
resulting string


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • SectionValue
ELFFile.SectionValue Member List

This is the complete list of members for ELFFile.SectionValue, including all inherited members.

getData(BinaryReader br) | ELFFile.SectionValue
Name | ELFFile.SectionValue
readUTF8String(BinaryReader br, long offset) | ELFFile.SectionValue
Section | ELFFile.SectionValue


ASAP2Library interface: ELFFile.SymbolValue Class Reference

  • Symbols
  • ELF
  • ELFFile
  • SymbolValue
Properties | List of all members
ELFFile.SymbolValue Class Reference

ELF Symbol Value representation. More...

Properties

string | Name [get]
Symbol Name
ELFSymbol | Symbol [get]
Symbol file content

Detailed Description

ELF Symbol Value representation.


ASAP2Library interface: Member List

  • Symbols
  • ELF
  • ELFFile
  • SymbolValue
ELFFile.SymbolValue Member List

This is the complete list of members for ELFFile.SymbolValue, including all inherited members.

Name | ELFFile.SymbolValue
Symbol | ELFFile.SymbolValue


ASAP2Library interface: jnsoft.Symbols.MAP Namespace Reference

  • Symbols
  • MAP
Classes
jnsoft.Symbols.MAP Namespace Reference

Implements the MAP file format reader. More...

Classes

class MAPFile
Parses MAP files. More...

Detailed Description

Implements the MAP file format reader.

Basic access to a MAP file is provided by the MAPFile class.

  • Provides methods and properties to open and access the MAP entries.
  • Provides methods to update and rewrite an opened A2L object model.


ASAP2Library interface: MAPFile Class Reference

  • Symbols
  • MAP
  • MAPFile
Classes | Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
MAPFile Class Reference

Parses MAP files. More...

Classes

class SymbolValue
Contains a map file smbol entry (Name, address) More...

Public Member Functions

override IList< UpdateData > | getValuesToSynchronize (A2LParser parser, out ulong dataSegStart, out ulong dataSegLen)
Gets the List of values to synchronize with the specified A2L file. More...
- Public Member Functions inherited from SymbolFile
uint | updateAndWriteA2L (IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true)
Updates the specified A2L object model and writes it to an A2L file. More...

Static Public Member Functions

static MAPFile | open (Stream stream, string sourceFile=null)
Opens a MAP file from a given stream. More...
static MAPFile | open (string filename)
Opens a MAP file from a given file. More...

Public Attributes

readonly IDictionary< string, SymbolValue > Symbols = new Dictionary<string, SymbolValue>()
Maps variable names to its addresses.

Additional Inherited Members

- Protected Member Functions inherited from SymbolFile
SymbolFile (string sourceFile=null)
- Properties inherited from SymbolFile
string SourceFile [get]
Gets the fully qualified path to the source file. More...

Detailed Description

Parses MAP files.

  • Open a Map file with the Open method.
  • The Variables property contains the content after file is read.

Member Function Documentation

◆ getValuesToSynchronize()

override IList< UpdateData > getValuesToSynchronize | ( | A2LParser | parser,
 |  | out ulong | dataSegStart,
 |  | out ulong | dataSegLen
 | ) |  |
virtual

Gets the List of values to synchronize with the specified A2L file.

Parameters
parser | A loaded A2L parser instance
dataSegStart | Returns start of datasegment
dataSegLen | Returns end of datasegment
Returns
List of values to synchronize in the specified A2L file

Implements SymbolFile.

◆ open() [1/2]

static MAPFile open | ( | Stream | stream,
 |  | string | sourceFile = null
 | ) |  |
static

Opens a MAP file from a given stream.

Parameters
stream | The stream to read from
sourceFile | a potential source file name
Returns
The MAPFile instance containing the data read

◆ open() [2/2]

static MAPFile open ( string filename )
static

Opens a MAP file from a given file.

Parameters
filename The file to read from
Returns
The MAPFile instance containing the data read


ASAP2Library interface: Member List

  • Symbols
  • MAP
  • MAPFile
MAPFile Member List

This is the complete list of members for MAPFile, including all inherited members.

getValuesToSynchronize(A2LParser parser, out ulong dataSegStart, out ulong dataSegLen) | MAPFile | virtual
open(string filename) | MAPFile | static
open(Stream stream, string sourceFile=null) | MAPFile | static
SourceFile | SymbolFile |
SymbolFile(string sourceFile=null) (defined in SymbolFile) | SymbolFile | protected
Symbols | MAPFile |
updateAndWriteA2L(IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true) | SymbolFile |


ASAP2Library interface: MAPFile.SymbolValue Class Reference

  • Symbols
  • MAP
  • MAPFile
  • SymbolValue
Properties | List of all members
MAPFile.SymbolValue Class Reference

Contains a map file smbol entry (Name, address) More...

Properties

ulong | Address [get]
Address of the symbol.
int | Index = int.MaxValue [get]
Index of the symbol. More...
string | Name [get]
Name of the symbol.

Detailed Description

Contains a map file smbol entry (Name, address)

Property Documentation

◆ Index

int Index = int.MaxValue
get

Index of the symbol.

int.MaxValue if not defined.


ASAP2Library interface: Member List

  • Symbols
  • MAP
  • MAPFile
  • SymbolValue
MAPFile.SymbolValue Member List

This is the complete list of members for MAPFile.SymbolValue, including all inherited members.

Address | MAPFile.SymbolValue
Index | MAPFile.SymbolValue
Name | MAPFile.SymbolValue


ASAP2Library interface: SymbolFile Class Reference

  • Symbols
  • SymbolFile
Public Member Functions | Protected Member Functions | Properties | List of all members
SymbolFile Class Referenceabstract

Implements the base class for specific Symbol files (like ELF or MAP). More...

Public Member Functions

abstract IList< UpdateData > | getValuesToSynchronize (A2LParser parser, out ulong dataSegStart, out ulong dataSegLen)
Gets the List of values to synchronize with the specified A2L file. More...
uint | updateAndWriteA2L (IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true)
Updates the specified A2L object model and writes it to an A2L file. More...

Protected Member Functions

SymbolFile (string sourceFile=null)

Properties

string SourceFile [get]
Gets the fully qualified path to the source file. More...

Detailed Description

Implements the base class for specific Symbol files (like ELF or MAP).

Member Function Documentation

◆ getValuesToSynchronize()

abstract IList< UpdateData > getValuesToSynchronize | ( | A2LParser | parser,
 |  | out ulong | dataSegStart,
 |  | out ulong | dataSegLen
 | ) |  |
pure virtual

Gets the List of values to synchronize with the specified A2L file.

Parameters
parser | A loaded A2L parser instance
dataSegStart | Returns start of datasegment
dataSegLen | Returns end of datasegment
Returns
List of values to synchronize in the specified A2L file

Implemented in ELFFile, and MAPFile.

◆ updateAndWriteA2L()

uint updateAndWriteA2L | ( | IEnumerable< UpdateData > | updateRecords,
 |  | string | targetFile,
 |  | A2LParser | parser,
 |  | bool | ignoreSizeChanges = false,
 |  | bool | deleteNotMatchedFromModel = true
 | ) |  |

Updates the specified A2L object model and writes it to an A2L file.

Parameters
updateRecords | Records from a getSynchronizeValues call
targetFile | fully qualified path to the A2L to write to
parser | A loaded A2L parser instance
ignoreSizeChanges | Updates A2L objects with a changed size
deleteNotMatchedFromModel | true, if not matched A2L objects should be not written into the target A2L file
Returns
Count of updated A2L objects

Property Documentation

◆ SourceFile

string SourceFile
get

Gets the fully qualified path to the source file.

Maybe null if loaded from stream.


ASAP2Library interface: Member List

  • Symbols
  • SymbolFile
SymbolFile Member List

This is the complete list of members for SymbolFile, including all inherited members.

getValuesToSynchronize(A2LParser parser, out ulong dataSegStart, out ulong dataSegLen) | SymbolFile | pure virtual
SourceFile | SymbolFile |
SymbolFile(string sourceFile=null) (defined in SymbolFile) | SymbolFile | protected
updateAndWriteA2L(IEnumerable< UpdateData > updateRecords, string targetFile, A2LParser parser, bool ignoreSizeChanges=false, bool deleteNotMatchedFromModel=true) | SymbolFile |


ASAP2Library interface: UpdateData Class Reference

  • Symbols
  • UpdateData
Public Member Functions | Public Attributes | List of all members
UpdateData Class Reference

Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition. More...

Public Member Functions

UpdateData (A2LADDRESS addressRef, UpdateType type, ulong address=ulong.MaxValue, ulong size=0ul)
Constructs a new instance of UpdateData. More...

Public Attributes

readonly ulong | Address
The new address to set (read from the symbol file). More...
readonly A2LADDRESS | AddressRef
An A2LCHARACTERISTIC, A2LAXIS_PTS or A2LMEASURMENT instance.
readonly ulong | Size
The new size to set (read from the symbol file). More...
readonly UpdateType | Type
The synchronisation state computed between the A2L and the symbol file definition.

Detailed Description

Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition.

Constructor & Destructor Documentation

◆ UpdateData()

UpdateData | ( | A2LADDRESS | addressRef,
 |  | UpdateType | type,
 |  | ulong | address = ulong.MaxValue,
 |  | ulong | size = 0ul
 | ) |  |

Constructs a new instance of UpdateData.

Parameters
addressRef | The original A2LCHARACTERISTIC, A2LAXIS_PTS or A2LMEASURMENT instance
type | The computed symchronisation type
address | The object address from the symbol file
size | The object size from the symbol file

Member Data Documentation

◆ Address

readonly ulong Address

The new address to set (read from the symbol file).

Only valid if Type != UpdateType.NotMatched.

◆ Size

readonly ulong Size

The new size to set (read from the symbol file).

Only valid if Type != UpdateType.NotMatched.


ASAP2Library interface: Member List

  • Symbols
  • UpdateData
UpdateData Member List

This is the complete list of members for UpdateData, including all inherited members.

Address | UpdateData
AddressRef | UpdateData
Size | UpdateData
Type | UpdateData
UpdateData(A2LADDRESS addressRef, UpdateType type, ulong address=ulong.MaxValue, ulong size=0ul) | UpdateData


ASAP2Library interface: UpdaterSymbols Class Reference

  • Symbols
  • UpdaterSymbols
Public Attributes | Properties | List of all members
UpdaterSymbols Class Reference

Created symbols by ELF, DWARF or MAP interpretation. More...

Public Attributes

readonly ulong | Address
The symbol's address
readonly int[] | ArrayDim
Array dimensions (may be null)
readonly long | ArrayIdx
The flat array Index.
readonly uint | BitOffset
The symbol's bit offset relative to the Address)
readonly ulong | Size
The symbol's size in Bit
readonly object | Tag
The corresponding analyzer object. More...

Properties

ulong? | ByteSize [get]
The used size in bytes
bool | IsBitfield [get]
Indicates if the symbol is a bitfield.

Detailed Description

Created symbols by ELF, DWARF or MAP interpretation.

Member Data Documentation

◆ Tag

readonly object Tag

The corresponding analyzer object.

This may be an instance of

  • ELFFile.SymbolValue
  • MAPFile.SymbolValue
  • DWARFInfo.SymbolValue


ASAP2Library interface: Member List

  • Symbols
  • UpdaterSymbols
UpdaterSymbols Member List

This is the complete list of members for UpdaterSymbols, including all inherited members.

Address | UpdaterSymbols
ArrayDim | UpdaterSymbols
ArrayIdx | UpdaterSymbols
BitOffset | UpdaterSymbols
ByteSize | UpdaterSymbols
IsBitfield | UpdaterSymbols
Size | UpdaterSymbols
Tag | UpdaterSymbols


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • A2LChangedType : jnsoft.ASAP2
  • A2LType : jnsoft.ASAP2
  • ActionType : jnsoft.Diagnose.Comm.DoIp
  • Activation : jnsoft.Diagnose.Comm.DoIp
  • ActivationCode : jnsoft.Diagnose.Comm.DoIp
  • ADDR_TYPE : jnsoft.ASAP2
  • AddressingType : jnsoft.Diagnose.ODX
  • AddressLocation : jnsoft.ASAP2.KWP
  • AppId : jnsoft.BLF
  • AttachmentFlags : jnsoft.MDF.V4
  • AXIS_TYPE : jnsoft.ASAP2
  • AxisValueType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- b -

  • BaseDataType : jnsoft.Diagnose.ODX
  • BasicAddressModeType : jnsoft.Comm.XCP
  • BITOPERATION_TYPE : jnsoft.ASAP2
  • BusType : jnsoft.MDF.V4
  • BYTEORDER_TYPE : jnsoft.Helpers


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- c -

  • CAFlags : jnsoft.MDF.V4
  • CALIBRATION_ACCESS : jnsoft.ASAP2
  • CalPageMode : jnsoft.Comm.XCP
  • CANBaudrate : jnsoft.Comm.CAN
  • CanFd64Flags : jnsoft.BLF
  • CANFDBaudrate : jnsoft.Comm.CAN
  • CANFdFlags : jnsoft.BLF
  • CANFlags : jnsoft.BLF
  • CANStandard : jnsoft.Comm.CAN
  • CATemplate : jnsoft.MDF.V4
  • CAType : jnsoft.MDF.V4
  • CauseType : jnsoft.MDF.V4
  • CCP_ADDRESS_MODE : jnsoft.ASAP2.CCP
  • CCP_CHECKSUM_CALC_TYPE : jnsoft.ASAP2.CCP
  • CCP_DAQ_MODE : jnsoft.ASAP2.CCP
  • CCP_MEMORY_PAGE_TYPE : jnsoft.ASAP2.CCP
  • CCP_SCALING_UNIT : jnsoft.ASAP2.CCP
  • ChannelFlags : jnsoft.MDF.V4
  • ChannelGroupFlags : jnsoft.MDF.V4
  • ChannelType : jnsoft.MDF
  • CHAR_TYPE : jnsoft.ASAP2
  • ChecksumSxI : jnsoft.ASAP2.XCP
  • ChecksumType : jnsoft.ASAP2, jnsoft.Comm.LIN
  • ClockInfo : jnsoft.Comm.XCP
  • CMCategory : jnsoft.Diagnose.ODX
  • CmdResult : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • CommandCode : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • CommModeBasic : jnsoft.ASAP2.XCP
  • CommModeOptional : jnsoft.Comm.XCP
  • CommModeProgram : jnsoft.Comm.XCP
  • CommunicationControlType : jnsoft.Diagnose.Comm.UDS
  • CommunicationType : jnsoft.Diagnose.Comm.UDS
  • ConnectBehaviourType : jnsoft.Comm
  • ConnectMode : jnsoft.Comm.XCP
  • CONVERSION_TYPE : jnsoft.ASAP2
  • ConversionFlags : jnsoft.MDF.V4
  • ConversionType : jnsoft.MDF
  • CustomFlagsType : jnsoft.MDF


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- d -

  • DAQEventProperties : jnsoft.Comm.XCP
  • DAQEventType : jnsoft.ASAP2
  • DAQKeyByte : jnsoft.Comm.XCP
  • DAQListMode : jnsoft.Comm.XCP
  • DAQListProperties : jnsoft.Comm.XCP
  • DAQProperties : jnsoft.Comm.XCP
  • DAQTimestampMode : jnsoft.Comm.XCP
  • DATA_SIZE : jnsoft.ASAP2
  • DATA_TYPE : jnsoft.Helpers
  • DataAlgorithm : jnsoft.Comm.ECUSimulator
  • DataBlockFlags : jnsoft.MDF.V4
  • DataBlockType : jnsoft.Diagnose.ODX
  • DataFileType : jnsoft.ASAP2.Values
  • DataFormatType : jnsoft.Diagnose.ODX
  • DefinitionType : jnsoft.Diagnose.Comm.UDS
  • DEPOSIT_TYPE : jnsoft.ASAP2
  • DiagMsgNackCode : jnsoft.Diagnose.Comm.DoIp
  • DiagnosticSessionType : jnsoft.Diagnose.Comm.UDS
  • DisconnectMode : jnsoft.Comm.CCP
  • DoIPType : jnsoft.Diagnose.Comm.DoIp
  • DTCFormatIdentifier : jnsoft.Diagnose.Comm.UDS
  • DTCSettingType : jnsoft.Diagnose.Comm.UDS
  • DTCStatusMaskType : jnsoft.Diagnose.Comm.UDS
  • DTO_CTR_DAQ_MODE : jnsoft.ASAP2.XCP
  • DTO_CTR_STIM_MODE : jnsoft.ASAP2.XCP
  • DTOCtrMode : jnsoft.Comm.XCP
  • DTOCtrModifier : jnsoft.Comm.XCP
  • DTOCtrProperties : jnsoft.Comm.XCP
  • DW_AT : jnsoft.Symbols.ELF.DWARF
  • DW_FORM : jnsoft.Symbols.ELF.DWARF
  • DW_LANG : jnsoft.Symbols.ELF.DWARF
  • DW_TAG : jnsoft.Symbols.ELF.DWARF


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- e -

  • ECUPage : jnsoft.ASAP2
  • ELM327Protocols : jnsoft.Comm.CAN.ELM327
  • EncodingType : jnsoft.ASAP2
  • EPKCheckResult : jnsoft.Comm
  • EventCodes : jnsoft.Comm.XCP
  • EventFlags : jnsoft.MDF.V4
  • EventType : jnsoft.MDF.V4
  • ExtensionType : jnsoft.MDF.V3


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- f -

  • FlowStatus : jnsoft.Diagnose.Comm
  • FPFormatType : jnsoft.MDF.V3
  • FrameType : jnsoft.Comm.CAN, jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- g -

  • GetIDRespType : jnsoft.Comm.XCP
  • GetIDType : jnsoft.Comm.XCP
  • GetSectorInfoMode : jnsoft.Comm.XCP
  • GetSegmentModeType : jnsoft.Comm.XCP
  • GetSlaveIDMode : jnsoft.Comm.XCP
  • GranODTEntrySize : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- h -

  • HardwareType : jnsoft.Comm.LIN.Peak
  • HierarchyType : jnsoft.MDF.V4
  • HWType : jnsoft.Comm.Vector


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- i -

  • INDEX_MODE : jnsoft.ASAP2
  • INDEX_ORDER : jnsoft.ASAP2
  • IsoTpType : jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- j -

  • J1939PDUFormat : jnsoft.Comm.CAN


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- k -

  • KWP_COPY_MODE : jnsoft.ASAP2.KWP
  • KWP_DATA_ACCESS_FLAGS : jnsoft.ASAP2.KWP
  • KWP_FLASH_MODE : jnsoft.ASAP2.KWP
  • KWP_FLASH_RESULT : jnsoft.ASAP2.KWP
  • KWP_MEASUREMENT_MODE : jnsoft.ASAP2.KWP
  • KWP_PAGE_SWITCH_MODE : jnsoft.ASAP2.KWP
  • KWP_PHYSICAL_LAYER : jnsoft.ASAP2.KWP
  • KWP_STIMULATION_MODE : jnsoft.ASAP2.KWP
  • KWP_VERSION : jnsoft.ASAP2.KWP


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- l -

  • LINBaudrate : jnsoft.Comm.LIN
  • LINFlags : jnsoft.Comm.LIN.Kvaser
  • LinkControlType : jnsoft.Diagnose.Comm.UDS
  • LINOpen : jnsoft.Comm.LIN.Kvaser
  • LINStatus : jnsoft.Comm.LIN.Kvaser
  • LinVersion : jnsoft.Comm.LIN


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- m -

  • MappingInfoModeType : jnsoft.Comm.XCP
  • MDFFileExtension : jnsoft.MDF
  • MDFType : jnsoft.MDF
  • MediaType : jnsoft.Comm
  • MEMORY_ATTRIBUTE : jnsoft.ASAP2
  • MEMORY_TYPE : jnsoft.ASAP2
  • MEMORYPRG_TYPE : jnsoft.ASAP2
  • MessageType : jnsoft.Helpers
  • ModeOfOperationType : jnsoft.Diagnose.Comm.UDS
  • ModifyFunc() : jnsoft.ASAP2
  • ModifyFuncByValue() : jnsoft.ASAP2
  • MONOTONY_TYPE : jnsoft.ASAP2
  • MotorolaFileType : jnsoft.ASAP2.Values
  • MsgState : jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- n -

  • NackCode : jnsoft.Diagnose.Comm.DoIp
  • NegRespCode : jnsoft.Diagnose.Comm.UDS
  • NodeType : jnsoft.Diagnose.Comm.DoIp


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- o -

  • ObjectFlagsType : jnsoft.BLF
  • ObjectType : jnsoft.BLF
  • ObservableClocks : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- p -

  • PageProperties : jnsoft.Comm.XCP
  • PAGProperties : jnsoft.ASAP2.XCP
  • ParityType : jnsoft.ASAP2.XCP
  • PayloadFmt : jnsoft.Comm.XCP
  • PIDSlaveMaster : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • PinType : jnsoft.Diagnose.ODX
  • PowerMode : jnsoft.Diagnose.Comm.DoIp
  • PRG_TYPE : jnsoft.ASAP2
  • ProgramClearMode : jnsoft.Comm.XCP
  • ProgramProperties : jnsoft.Comm.XCP
  • ProgramVerifyMode : jnsoft.Comm.XCP
  • ProtocolVersion : jnsoft.Diagnose.Comm.DoIp


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- r -

  • RangeType : jnsoft.MDF.V4
  • RecordIDType : jnsoft.MDF
  • ReportDTCType : jnsoft.Diagnose.Comm.UDS
  • ResetType : jnsoft.Diagnose.Comm.UDS
  • ResourceType : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • ResponseOnEventType : jnsoft.Diagnose.Comm.UDS
  • ResponseState : jnsoft.Diagnose.Comm.DoIp
  • RoutineControlType : jnsoft.Diagnose.Comm.UDS
  • RoutineIdentifierType : jnsoft.Diagnose.Comm.UDS
  • RowFragment : jnsoft.Diagnose.ODX


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- s -

  • ScalingUnits : jnsoft.ASAP2
  • SeedModeType : jnsoft.Comm.XCP
  • SegmentInfoMode : jnsoft.Comm.XCP
  • SegmentMode : jnsoft.Comm.XCP
  • ServiceRequestCode : jnsoft.Comm.XCP
  • SessionState : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • SetRequestMode : jnsoft.Comm.XCP
  • SID : jnsoft.Diagnose.Comm.UDS
  • SignalType : jnsoft.MDF
  • SKType : jnsoft.Helpers
  • SlaveConfig : jnsoft.Comm.XCP
  • SourceFlags : jnsoft.MDF.V4
  • SourceType : jnsoft.MDF.V4
  • SRFlags : jnsoft.MDF.V4
  • StartStopMode : jnsoft.Comm
  • STIMTimeoutMode : jnsoft.Comm.XCP
  • StopBitsType : jnsoft.ASAP2.XCP
  • SynchStatus : jnsoft.Diagnose.Comm.DoIp
  • SyncModeSize : jnsoft.ASAP2.XCP
  • SyncState : jnsoft.Comm.XCP
  • SyncType : jnsoft.MDF
  • SysParmType : jnsoft.Diagnose.ODX
  • SysVarDataType : jnsoft.BLF


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- t -

  • TerminationType : jnsoft.Diagnose.ODX
  • TimeCorrGetPropsReq : jnsoft.Comm.XCP
  • TimeCorrSetProps : jnsoft.Comm.XCP
  • TimeFlagsType : jnsoft.MDF
  • TimeOfTSSampling : jnsoft.Comm.XCP
  • TimeQualityType : jnsoft.MDF
  • TimingParameterAccessType : jnsoft.Diagnose.Comm.UDS
  • TransmissionModeType : jnsoft.Diagnose.Comm.UDS
  • TriggerInitiator : jnsoft.Comm.XCP
  • TriggerType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- u -

  • UnfinalizedFlagsType : jnsoft.MDF
  • UNIT_TYPE : jnsoft.ASAP2
  • UpdateType : jnsoft.Symbols
  • USBEndpointType : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- v -

  • ValidType : jnsoft.Diagnose.ODX
  • ValueObjectFormat : jnsoft.Helpers
  • VarNamingType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- w -

  • WriterIndent : jnsoft.ASAP2


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- x -

  • XCP_ADDRESS_EXT : jnsoft.ASAP2.XCP
  • XCP_ADDRESS_MODE : jnsoft.ASAP2.XCP
  • XCP_ALIGNMENT : jnsoft.ASAP2.XCP
  • XCP_BLOCK_MODE : jnsoft.ASAP2.XCP
  • XCP_CLOCK_EPOCH : jnsoft.ASAP2.XCP
  • XCP_CLOCK_MODE : jnsoft.ASAP2.XCP
  • XCP_CLOCK_READABILITY : jnsoft.ASAP2.XCP
  • XCP_CLOCK_SYNC_FEATURE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_CAN_SAMPLE_RATE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_CAN_TYPE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_TYPE : jnsoft.ASAP2.XCP
  • XCP_DAQ_MODE : jnsoft.ASAP2.XCP
  • XCP_ECU_ACCESS : jnsoft.ASAP2.XCP
  • XCP_ENDPOINT : jnsoft.ASAP2.XCP
  • XCP_GROUP_MODE : jnsoft.ASAP2.XCP
  • XCP_HEADER_LEN : jnsoft.ASAP2.XCP
  • XCP_ID_FIELD_TYPE : jnsoft.ASAP2.XCP
  • XCP_MEMORY_ACCESS : jnsoft.ASAP2.XCP
  • XCP_MESSAGE_PACKING : jnsoft.ASAP2.XCP
  • XCP_NATIVE_TIMESTAMP_SIZE : jnsoft.ASAP2.XCP
  • XCP_ODT_ENTRY_SIZE : jnsoft.ASAP2.XCP
  • XCP_OPTIMISATION_TYPE : jnsoft.ASAP2.XCP
  • XCP_OVERLOAD_IND : jnsoft.ASAP2.XCP
  • XCP_PACK_MODE : jnsoft.ASAP2.XCP
  • XCP_PACKET_ALIGMENT : jnsoft.ASAP2.XCP
  • XCP_PGM_MODE : jnsoft.ASAP2.XCP
  • XCP_READ_WRITE_ACCESS : jnsoft.ASAP2.XCP
  • XCP_RESOURCE_STATE : jnsoft.ASAP2.XCP
  • XCP_STS_MODE : jnsoft.ASAP2.XCP
  • XCP_SYNCEDGE : jnsoft.ASAP2.XCP
  • XCP_TIMESTAMP_RESOLUTION : jnsoft.ASAP2.XCP
  • XCP_TIMESTAMP_SIZE : jnsoft.ASAP2.XCP
  • XCP_TRANSCEIVER_DELAY_COMPENSATION : jnsoft.ASAP2.XCP
  • XCP_TRANSFER : jnsoft.ASAP2.XCP
  • XCP_TS_RELATION : jnsoft.ASAP2.XCP
  • XCPonCAN : jnsoft.Comm.XCP
  • XCPType : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:

- z -

  • ZipType : jnsoft.MDF.V4


ASAP2Library interface: Package Functions

  • ModifyFunc() : jnsoft.ASAP2
  • ModifyFuncByValue() : jnsoft.ASAP2


ASAP2Library interface: Package Functions

- a -

  • A2LChangedType : jnsoft.ASAP2
  • A2LType : jnsoft.ASAP2
  • ActionType : jnsoft.Diagnose.Comm.DoIp
  • Activation : jnsoft.Diagnose.Comm.DoIp
  • ActivationCode : jnsoft.Diagnose.Comm.DoIp
  • ADDR_TYPE : jnsoft.ASAP2
  • AddressingType : jnsoft.Diagnose.ODX
  • AddressLocation : jnsoft.ASAP2.KWP
  • AppId : jnsoft.BLF
  • AttachmentFlags : jnsoft.MDF.V4
  • AXIS_TYPE : jnsoft.ASAP2
  • AxisValueType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

- b -

  • BaseDataType : jnsoft.Diagnose.ODX
  • BasicAddressModeType : jnsoft.Comm.XCP
  • BITOPERATION_TYPE : jnsoft.ASAP2
  • BusType : jnsoft.MDF.V4
  • BYTEORDER_TYPE : jnsoft.Helpers


ASAP2Library interface: Package Functions

- c -

  • CAFlags : jnsoft.MDF.V4
  • CALIBRATION_ACCESS : jnsoft.ASAP2
  • CalPageMode : jnsoft.Comm.XCP
  • CANBaudrate : jnsoft.Comm.CAN
  • CanFd64Flags : jnsoft.BLF
  • CANFDBaudrate : jnsoft.Comm.CAN
  • CANFdFlags : jnsoft.BLF
  • CANFlags : jnsoft.BLF
  • CANStandard : jnsoft.Comm.CAN
  • CATemplate : jnsoft.MDF.V4
  • CAType : jnsoft.MDF.V4
  • CauseType : jnsoft.MDF.V4
  • CCP_ADDRESS_MODE : jnsoft.ASAP2.CCP
  • CCP_CHECKSUM_CALC_TYPE : jnsoft.ASAP2.CCP
  • CCP_DAQ_MODE : jnsoft.ASAP2.CCP
  • CCP_MEMORY_PAGE_TYPE : jnsoft.ASAP2.CCP
  • CCP_SCALING_UNIT : jnsoft.ASAP2.CCP
  • ChannelFlags : jnsoft.MDF.V4
  • ChannelGroupFlags : jnsoft.MDF.V4
  • ChannelType : jnsoft.MDF
  • CHAR_TYPE : jnsoft.ASAP2
  • ChecksumSxI : jnsoft.ASAP2.XCP
  • ChecksumType : jnsoft.ASAP2, jnsoft.Comm.LIN
  • ClockInfo : jnsoft.Comm.XCP
  • CMCategory : jnsoft.Diagnose.ODX
  • CmdResult : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • CommandCode : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • CommModeBasic : jnsoft.ASAP2.XCP
  • CommModeOptional : jnsoft.Comm.XCP
  • CommModeProgram : jnsoft.Comm.XCP
  • CommunicationControlType : jnsoft.Diagnose.Comm.UDS
  • CommunicationType : jnsoft.Diagnose.Comm.UDS
  • ConnectBehaviourType : jnsoft.Comm
  • ConnectMode : jnsoft.Comm.XCP
  • CONVERSION_TYPE : jnsoft.ASAP2
  • ConversionFlags : jnsoft.MDF.V4
  • ConversionType : jnsoft.MDF
  • CustomFlagsType : jnsoft.MDF


ASAP2Library interface: Package Functions

- d -

  • DAQEventProperties : jnsoft.Comm.XCP
  • DAQEventType : jnsoft.ASAP2
  • DAQKeyByte : jnsoft.Comm.XCP
  • DAQListMode : jnsoft.Comm.XCP
  • DAQListProperties : jnsoft.Comm.XCP
  • DAQProperties : jnsoft.Comm.XCP
  • DAQTimestampMode : jnsoft.Comm.XCP
  • DATA_SIZE : jnsoft.ASAP2
  • DATA_TYPE : jnsoft.Helpers
  • DataAlgorithm : jnsoft.Comm.ECUSimulator
  • DataBlockFlags : jnsoft.MDF.V4
  • DataBlockType : jnsoft.Diagnose.ODX
  • DataFileType : jnsoft.ASAP2.Values
  • DataFormatType : jnsoft.Diagnose.ODX
  • DefinitionType : jnsoft.Diagnose.Comm.UDS
  • DEPOSIT_TYPE : jnsoft.ASAP2
  • DiagMsgNackCode : jnsoft.Diagnose.Comm.DoIp
  • DiagnosticSessionType : jnsoft.Diagnose.Comm.UDS
  • DisconnectMode : jnsoft.Comm.CCP
  • DoIPType : jnsoft.Diagnose.Comm.DoIp
  • DTCFormatIdentifier : jnsoft.Diagnose.Comm.UDS
  • DTCSettingType : jnsoft.Diagnose.Comm.UDS
  • DTCStatusMaskType : jnsoft.Diagnose.Comm.UDS
  • DTO_CTR_DAQ_MODE : jnsoft.ASAP2.XCP
  • DTO_CTR_STIM_MODE : jnsoft.ASAP2.XCP
  • DTOCtrMode : jnsoft.Comm.XCP
  • DTOCtrModifier : jnsoft.Comm.XCP
  • DTOCtrProperties : jnsoft.Comm.XCP
  • DW_AT : jnsoft.Symbols.ELF.DWARF
  • DW_FORM : jnsoft.Symbols.ELF.DWARF
  • DW_LANG : jnsoft.Symbols.ELF.DWARF
  • DW_TAG : jnsoft.Symbols.ELF.DWARF


ASAP2Library interface: Package Functions

- e -

  • ECUPage : jnsoft.ASAP2
  • ELM327Protocols : jnsoft.Comm.CAN.ELM327
  • EncodingType : jnsoft.ASAP2
  • EPKCheckResult : jnsoft.Comm
  • EventCodes : jnsoft.Comm.XCP
  • EventFlags : jnsoft.MDF.V4
  • EventType : jnsoft.MDF.V4
  • ExtensionType : jnsoft.MDF.V3


ASAP2Library interface: Package Functions

- f -

  • FlowStatus : jnsoft.Diagnose.Comm
  • FPFormatType : jnsoft.MDF.V3
  • FrameType : jnsoft.Comm.CAN, jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

- g -

  • GetIDRespType : jnsoft.Comm.XCP
  • GetIDType : jnsoft.Comm.XCP
  • GetSectorInfoMode : jnsoft.Comm.XCP
  • GetSegmentModeType : jnsoft.Comm.XCP
  • GetSlaveIDMode : jnsoft.Comm.XCP
  • GranODTEntrySize : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

- h -

  • HardwareType : jnsoft.Comm.LIN.Peak
  • HierarchyType : jnsoft.MDF.V4
  • HWType : jnsoft.Comm.Vector


ASAP2Library interface: Package Functions

- i -

  • INDEX_MODE : jnsoft.ASAP2
  • INDEX_ORDER : jnsoft.ASAP2
  • IsoTpType : jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

- j -

  • J1939PDUFormat : jnsoft.Comm.CAN


ASAP2Library interface: Package Functions

- k -

  • KWP_COPY_MODE : jnsoft.ASAP2.KWP
  • KWP_DATA_ACCESS_FLAGS : jnsoft.ASAP2.KWP
  • KWP_FLASH_MODE : jnsoft.ASAP2.KWP
  • KWP_FLASH_RESULT : jnsoft.ASAP2.KWP
  • KWP_MEASUREMENT_MODE : jnsoft.ASAP2.KWP
  • KWP_PAGE_SWITCH_MODE : jnsoft.ASAP2.KWP
  • KWP_PHYSICAL_LAYER : jnsoft.ASAP2.KWP
  • KWP_STIMULATION_MODE : jnsoft.ASAP2.KWP
  • KWP_VERSION : jnsoft.ASAP2.KWP


ASAP2Library interface: Package Functions

- l -

  • LINBaudrate : jnsoft.Comm.LIN
  • LINFlags : jnsoft.Comm.LIN.Kvaser
  • LinkControlType : jnsoft.Diagnose.Comm.UDS
  • LINOpen : jnsoft.Comm.LIN.Kvaser
  • LINStatus : jnsoft.Comm.LIN.Kvaser
  • LinVersion : jnsoft.Comm.LIN


ASAP2Library interface: Package Functions

- m -

  • MappingInfoModeType : jnsoft.Comm.XCP
  • MDFFileExtension : jnsoft.MDF
  • MDFType : jnsoft.MDF
  • MediaType : jnsoft.Comm
  • MEMORY_ATTRIBUTE : jnsoft.ASAP2
  • MEMORY_TYPE : jnsoft.ASAP2
  • MEMORYPRG_TYPE : jnsoft.ASAP2
  • MessageType : jnsoft.Helpers
  • ModeOfOperationType : jnsoft.Diagnose.Comm.UDS
  • MONOTONY_TYPE : jnsoft.ASAP2
  • MotorolaFileType : jnsoft.ASAP2.Values
  • MsgState : jnsoft.Diagnose.Comm


ASAP2Library interface: Package Functions

- n -

  • NackCode : jnsoft.Diagnose.Comm.DoIp
  • NegRespCode : jnsoft.Diagnose.Comm.UDS
  • NodeType : jnsoft.Diagnose.Comm.DoIp


ASAP2Library interface: Package Functions

- o -

  • ObjectFlagsType : jnsoft.BLF
  • ObjectType : jnsoft.BLF
  • ObservableClocks : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

- p -

  • PageProperties : jnsoft.Comm.XCP
  • PAGProperties : jnsoft.ASAP2.XCP
  • ParityType : jnsoft.ASAP2.XCP
  • PayloadFmt : jnsoft.Comm.XCP
  • PIDSlaveMaster : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • PinType : jnsoft.Diagnose.ODX
  • PowerMode : jnsoft.Diagnose.Comm.DoIp
  • PRG_TYPE : jnsoft.ASAP2
  • ProgramClearMode : jnsoft.Comm.XCP
  • ProgramProperties : jnsoft.Comm.XCP
  • ProgramVerifyMode : jnsoft.Comm.XCP
  • ProtocolVersion : jnsoft.Diagnose.Comm.DoIp


ASAP2Library interface: Package Functions

- r -

  • RangeType : jnsoft.MDF.V4
  • RecordIDType : jnsoft.MDF
  • ReportDTCType : jnsoft.Diagnose.Comm.UDS
  • ResetType : jnsoft.Diagnose.Comm.UDS
  • ResourceType : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • ResponseOnEventType : jnsoft.Diagnose.Comm.UDS
  • ResponseState : jnsoft.Diagnose.Comm.DoIp
  • RoutineControlType : jnsoft.Diagnose.Comm.UDS
  • RoutineIdentifierType : jnsoft.Diagnose.Comm.UDS
  • RowFragment : jnsoft.Diagnose.ODX


ASAP2Library interface: Package Functions

- s -

  • ScalingUnits : jnsoft.ASAP2
  • SeedModeType : jnsoft.Comm.XCP
  • SegmentInfoMode : jnsoft.Comm.XCP
  • SegmentMode : jnsoft.Comm.XCP
  • ServiceRequestCode : jnsoft.Comm.XCP
  • SessionState : jnsoft.Comm.CCP, jnsoft.Comm.XCP
  • SetRequestMode : jnsoft.Comm.XCP
  • SID : jnsoft.Diagnose.Comm.UDS
  • SignalType : jnsoft.MDF
  • SKType : jnsoft.Helpers
  • SlaveConfig : jnsoft.Comm.XCP
  • SourceFlags : jnsoft.MDF.V4
  • SourceType : jnsoft.MDF.V4
  • SRFlags : jnsoft.MDF.V4
  • StartStopMode : jnsoft.Comm
  • STIMTimeoutMode : jnsoft.Comm.XCP
  • StopBitsType : jnsoft.ASAP2.XCP
  • SynchStatus : jnsoft.Diagnose.Comm.DoIp
  • SyncModeSize : jnsoft.ASAP2.XCP
  • SyncState : jnsoft.Comm.XCP
  • SyncType : jnsoft.MDF
  • SysParmType : jnsoft.Diagnose.ODX
  • SysVarDataType : jnsoft.BLF


ASAP2Library interface: Package Functions

- t -

  • TerminationType : jnsoft.Diagnose.ODX
  • TimeCorrGetPropsReq : jnsoft.Comm.XCP
  • TimeCorrSetProps : jnsoft.Comm.XCP
  • TimeFlagsType : jnsoft.MDF
  • TimeOfTSSampling : jnsoft.Comm.XCP
  • TimeQualityType : jnsoft.MDF
  • TimingParameterAccessType : jnsoft.Diagnose.Comm.UDS
  • TransmissionModeType : jnsoft.Diagnose.Comm.UDS
  • TriggerInitiator : jnsoft.Comm.XCP
  • TriggerType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

- u -

  • UnfinalizedFlagsType : jnsoft.MDF
  • UNIT_TYPE : jnsoft.ASAP2
  • UpdateType : jnsoft.Symbols
  • USBEndpointType : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

- v -

  • ValidType : jnsoft.Diagnose.ODX
  • ValueObjectFormat : jnsoft.Helpers
  • VarNamingType : jnsoft.ASAP2


ASAP2Library interface: Package Functions

- w -

  • WriterIndent : jnsoft.ASAP2


ASAP2Library interface: Package Functions

- x -

  • XCP_ADDRESS_EXT : jnsoft.ASAP2.XCP
  • XCP_ADDRESS_MODE : jnsoft.ASAP2.XCP
  • XCP_ALIGNMENT : jnsoft.ASAP2.XCP
  • XCP_BLOCK_MODE : jnsoft.ASAP2.XCP
  • XCP_CLOCK_EPOCH : jnsoft.ASAP2.XCP
  • XCP_CLOCK_MODE : jnsoft.ASAP2.XCP
  • XCP_CLOCK_READABILITY : jnsoft.ASAP2.XCP
  • XCP_CLOCK_SYNC_FEATURE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_CAN_SAMPLE_RATE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_CAN_TYPE : jnsoft.ASAP2.XCP
  • XCP_DAQ_LIST_TYPE : jnsoft.ASAP2.XCP
  • XCP_DAQ_MODE : jnsoft.ASAP2.XCP
  • XCP_ECU_ACCESS : jnsoft.ASAP2.XCP
  • XCP_ENDPOINT : jnsoft.ASAP2.XCP
  • XCP_GROUP_MODE : jnsoft.ASAP2.XCP
  • XCP_HEADER_LEN : jnsoft.ASAP2.XCP
  • XCP_ID_FIELD_TYPE : jnsoft.ASAP2.XCP
  • XCP_MEMORY_ACCESS : jnsoft.ASAP2.XCP
  • XCP_MESSAGE_PACKING : jnsoft.ASAP2.XCP
  • XCP_NATIVE_TIMESTAMP_SIZE : jnsoft.ASAP2.XCP
  • XCP_ODT_ENTRY_SIZE : jnsoft.ASAP2.XCP
  • XCP_OPTIMISATION_TYPE : jnsoft.ASAP2.XCP
  • XCP_OVERLOAD_IND : jnsoft.ASAP2.XCP
  • XCP_PACK_MODE : jnsoft.ASAP2.XCP
  • XCP_PACKET_ALIGMENT : jnsoft.ASAP2.XCP
  • XCP_PGM_MODE : jnsoft.ASAP2.XCP
  • XCP_READ_WRITE_ACCESS : jnsoft.ASAP2.XCP
  • XCP_RESOURCE_STATE : jnsoft.ASAP2.XCP
  • XCP_STS_MODE : jnsoft.ASAP2.XCP
  • XCP_SYNCEDGE : jnsoft.ASAP2.XCP
  • XCP_TIMESTAMP_RESOLUTION : jnsoft.ASAP2.XCP
  • XCP_TIMESTAMP_SIZE : jnsoft.ASAP2.XCP
  • XCP_TRANSCEIVER_DELAY_COMPENSATION : jnsoft.ASAP2.XCP
  • XCP_TRANSFER : jnsoft.ASAP2.XCP
  • XCP_TS_RELATION : jnsoft.ASAP2.XCP
  • XCPonCAN : jnsoft.Comm.XCP
  • XCPType : jnsoft.Comm.XCP


ASAP2Library interface: Package Functions

- z -

  • ZipType : jnsoft.MDF.V4


ASAP2Library interface: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123456]
▼N jnsoft |
▼N ASAP2 | Contains the ASAP2 parser base and the ASAP2 object model implementation..
▼N CCP | Implements the ASAP2 CCP (IF_DATA) Interface stuff.
C A2LCCP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CAN_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_DEFINED_PAGES | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_DP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_EVENT_GROUP | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_KP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LCCP_NODE | Base class for all A2L node definitions concerning CCP.
C A2LCCP_QP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_RASTER | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SEED_KEY | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SOURCE | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_TP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C SourceAndRaster | Hold a CCP Source with it's attached CCP Raster.
▼N Examples |
C Program | Sample console application
▼N Formulas | Contains all the stuff for dynamically compiled formulas.
C A2LFormula | Represents a constant or a formula definition
C A2LFormulaDict | A A2LFormula dictionary (key = NodeName, value = A2LFormula)
C IEvaluator | Interface for dynamically compiled formulas
▼N Helpers | Contains the ASAP2 parser helper stuff.
C AdaptiveState | Holds a Timestamp together with a MemoryRange to read from an ECU.
C Checksum | Provides methods for building checksums over data
C CToCSharpMath | Maps standard math C functions to .NET framework math function strings
▼C DictionaryProxy | Proxy class to permit XML Serialization of generic dictionaries
C KeyAndValue | Holds the keys and values
▼C DictionaryProxyComplex | Proxy class to permit XML Serialization of generic dictionaries with a complex value
C KeyAndValueComplex | Holds the keys and values
C Extensions | Implements basic helper stuff.
C RationalCoeffs | Rational coefficients of an A2LCOMPU_METHOD.
C TabCoeffs | Tab conversion computations.
C TCConversionRef | Typeconverter to edit a reference to A2LCOMPUMETHOD.
C TCFormatRef | Typeconverter to edit a reference to A2L Format string.
C TCMeasurementRef | Typeconverter to edit a reference to a A2LMEASUREMENT.
C TCTransformerRef | Typeconverter to edit a reference to A2LTRANSFORMER.
C TCTypedefRef | Typeconverter to edit a reference to A2LTYPEDEF.
C TCUnitRef | Typeconverter to edit a reference to A2LUNIT.
▼N KWP | Implements the ASAP2 KWP (IF_DATA) Interface stuff.
C A2LKWP_ADDRESS | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
▼C A2LKWP_CAN | See ASAP1B_KWP (COMMON_PARAMETERS)
C NETWORK_LIMITS | KWP QP_BLOB definition smaller v2000
C A2LKWP_CHECKSUM | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_DIAG_BAUD | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_DP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_FLASH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_FLASH_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_K_LINE | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_KP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LKWP_NODE | Base class for all A2L node definitions concerning KWP.
C A2LKWP_PAGE_SWITCH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_ROUTINE_PARA | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_SOURCE | See ASAP1B_KWP (COMMON_PARAMETERS)
C QP_BLOB | KWP QP_BLOB definition smaller v2000
C A2LKWP_TIME_DEF | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_TP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C BAUD_DEF | KWP Baudrate definition smaller v2000
C KWP_DATA_ACCESS | DATA ACCESS definition smaller v2000
C KWP_K_LINE | KLINE definition smaller v2000
C KWP_SERAM | KWP SERAM definition smaller v2000
C SECURITY_ACCESS | KWP SERAM definition smaller v2000
C KWP_TIME_DEF | Timing definition smaller v2000
C KWP_USDTP_TIMING | Timing definition smaller v2000
▼N Values | Defines and implements stuff for reading, writing and modifying characteristic values.
▼N CDF | Contains the classes mapping the Calibration Data Format (XML).
C MSRSW | The root element of the file.
C SWAXISCONT | Physical axis values.
C SWINSTANCE | Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.
C SWINSTANCESPEC | The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items.
C SWINSTANCETREE | Receives one particular set of calibration items
C SWSYSTEM | Describes one particular system within the current file
C SWVALUECONT | Physical values.
C VG | Holds double, text or group values.
▼N Examples |
C Program | Demo console application
C ASCIIValue | Class representing a characteristic CHAR_TYPE.ASCII value
C BaseValue | Base class for a characteristic value representation.
C CDFFile | Implements the Calibration Data File format reader/writer.
C CharacteristicValue | Creates a value representation for the different characteristic value types
C Cube4Value | Class representing a characteristic CHAR_TYPE.CUBE_4 value
C Cube5Value | Class representing a characteristic CHAR_TYPE.CUBE_5 value
C CuboidValue | Class representing a characteristic CHAR_TYPE.CUBOID value
C CurveValue | Class representing a characteristic CHAR_TYPE.CURVE value
C DataConservation | Base class for any import and export calibration data file formats
C DataFile | Base class for reading/writing S19 and HEX files
C DataFileBin | Class for reading/writing binary data files
C DataFileBinDlg | Dialog to get a start address for a data binary file.
C DataFileHex | Class for reading/writing Intel HEX files
C DataFileS19 | Class for reading/writing Motorola S files
C DCMFile | Implements the ETAS INCA DCM file format 2.x reader/writer
C MapValue | Class representing a characteristic CHAR_TYPE.MAP value
C MatlabFile | Implements the Matlab (*.m) file format reader/writer.
C MeasurementAccessData | Manages static memory data for A2LMEASUREMENTs.
C PARFile | Implements the CANape PAR data File format reader/writer
C SingleValue | Class representing a characteristic CHAR_TYPE.VALUE value
C ValBlkValue | Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value
▼N XCP | Implements the ASAP2 XCP/XCPplus (IF_DATA) Interface stuff.
C A2LXCP_ADDRESS_MAPPING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_BUFFER_RESERVE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT)
C A2LXCP_CAN_FD | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_CHECKSUM |
C A2LXCP_CLOCK | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation)
C A2LXCP_CORE_LOAD | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core)
C A2LXCP_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_CAN_ID | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_USB_ENDPOINT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_DAQ_MEMORY_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LXCP_ECU_STATES_MEMORY_ACCESS | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State)
C A2LXCP_ECU_STATES_STATE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States)
C A2LXCP_ENDPOINT | Base class for all endpoint classes.
C A2LXCP_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CAN_ID_LIST | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue)
C A2LXCP_EVENT_DAQ_PACKED_MODE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists).
C A2LXCP_EVENT_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_MIN_CYCLE_TIME | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels)
C A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table)
C A2LXCP_FRAMING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI
C A2LXCP_IN_EP_ONLY_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_ONLY_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_RESERR_DAQ_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_MEDIA | Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...)
C A2LXCP_NAMEDNODE | Base class for all A2LXCP entities with specific names.
C A2LXCP_NODE | Base class for all A2L node definitions concerning XCP.
▼C A2LXCP_ODT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED)
C ODT_ENTRY | Represents a single ODT entry.
C A2LXCP_ON_CAN | XCP on CAN parameters
C A2LXCP_ON_ETHERNET | Base class for the XCP ethernet media (UDP/TCP)
C A2LXCP_ON_SxI | XCP on SxI parameters
C A2LXCP_ON_TCP_IP | XCP on TCP parameters
C A2LXCP_ON_UDP_IP | XCP on UDP parameters
C A2LXCP_ON_USB | XCP on USB parameters
C A2LXCP_OUT_EP_CMD_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_OUT_EP_ONLY_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_PAG | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PAGE | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PGM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PROTOCOL_LAYER | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SECTOR | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SEGMENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_TIME_CORRELATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LXCP_TIMESTAMP_CHARACTERIZATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock)
C A2LXCP_TIMESTAMP_SUPPORTED | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C DAQAndEvt | Hold a DAQList with it's attached Event.
C OptionalCommandSet | Represents a set of unique strings used to optional commands.
C XCPCommModes | Supported communication modes.
C A2LA2ML | This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA).
C A2LADDRESS | Base class for all A2L entities containing an ECU address.
C A2LANNOTATION | see ASAP2 specification
C A2LANNOTATION_TEXT | see ASAP2 specification
C A2LAR_COMPONENT | see ASAP2 specification
C A2LAXIS_DESCR | see ASAP2 specification
C A2LAXIS_PTS | see ASAP2 specification
C A2LBIT_OPERATION | The BIT_OPERATION keyword can be used to perform operation on the masked out value
C A2LBLOB | see ASAP2 specification
C A2LCALIBRATION_HANDLE | see ASAP2 specification
C A2LCALIBRATION_METHOD | see ASAP2 specification
▼C A2LCANAPE_ADDRESS_UPDATE | ASAP2 CANAPE_ADDRESS_UPDATE Interface support.
C AdrMapType | Adress map type
C CALIBRATION_METHOD | CANAPE calibration method.
C ExSymbolType | Extended Symbol type
C FirstLastNode | Base class for MapSymbol and MemorySegment
C FlashSectionType | Flash section type
C MAP_SYMBOL | CANAPE map symbol
C MEMORY_SEGMENT | CANAPE memory segment
C SymbolType | Symbol type
▼C A2LCANAPE_EXT | ASAP2 CANAPE_EXT Interface support.
C DisplayType | Display setting definition
C LinkMapType | Linker map definition
C VirtualConvType | Virtual conversion definition
C A2LCHARACTERISTIC | see ASAP2 specification
C A2LCOMPU_METHOD | see ASAP2 specification
C A2LCOMPU_TAB | see ASAP2 specification
C A2LCOMPU_TAB_BASE | Base class for dictionary based compu methods.
C A2LCOMPU_VTAB | see ASAP2 specification
C A2LCOMPU_VTAB_RANGE | see ASAP2 specification
C A2LCONVERSION_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method.
C A2LDEF_CHARACTERISTIC | see ASAP2 specification
C A2LDEPENDENT_CHARACTERISTIC | see ASAP2 specification
C A2LFIX_AXIS_PAR_LIST | see ASAP2 specification
C A2LFORMULA | see ASAP2 specification
C A2LFRAME | see ASAP2 specification
C A2LFUNCTION | see ASAP2 specification
C A2LFUNCTION_LIST | see ASAP2 specification
C A2LGROUP | see ASAP2 specification
C A2LHEADER | see ASAP2 specification
C A2LIF_DATA | see ASAP2 specification
C A2LIN_MEASUREMENT | see ASAP2 specification
C A2LINSTANCE | see ASAP2 specification
C A2LLOC_MEASUREMENT | see ASAP2 specification
C A2LMEASUREMENT | see ASAP2 specification
C A2LMEMORY_LAYOUT | see ASAP2 specification
C A2LMEMORY_SEGMENT | see ASAP2 specification
C A2LMOD_COMMON | see ASAP2 specification
C A2LMOD_PAR | see ASAP2 specification
C A2LMODULE | see ASAP2 specification
C A2LNAMEDNODE | Base class for all A2L entities with specific names.
C A2LNODE | Base class for any A2L entity
C A2LOUT_MEASUREMENT | see ASAP2 specification
C A2LOVERWRITE | see ASAP2 specification
C A2LParser | The ASAP2 parser
C A2LParserProgressEventArgs | Progress EventArgument generated while parsing a file.
C A2LPROJECT | The one and only root node of an A2L source file
▼C A2LRECORD_LAYOUT | Record layout
C AxisPtsLayoutDesc | Layout description for axis points.
C AxisRescaleLayoutDesc | Layout description for axis rescale value pairs.
C FncValuesLayoutDesc | Layout description for function values
C ItemLayoutDesc | Base class for record layout items.
C A2LRECORD_LAYOUT_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LREF_CHARACTERISTIC | see ASAP2 specification
C A2LREF_GROUP | see ASAP2 specification
C A2LREF_MEASUREMENT | see ASAP2 specification
C A2LREFBASE | Base class for A2LFUNCTION and A2LGROUP
C A2LREFERENCE | Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs
C A2LSTRUCTURE_COMPONENT | see ASAP2 specification
C A2LSUB_FUNCTION | see ASAP2 specification
C A2LSUB_GROUP | see ASAP2 specification
C A2LTRANSFORMER | see ASAP2 specification
C A2LTRANSFORMER_IN_OBJECTS | see ASAP2 specification
C A2LTRANSFORMER_OUT_OBJECTS | see ASAP2 specification
C A2LTYPEDEF | Base class for all A2L typedef entities.
C A2LTYPEDEF_AXIS | see ASAP2 specification
C A2LTYPEDEF_BLOB | see ASAP2 specification
C A2LTYPEDEF_CHARACTERISTIC | see ASAP2 specification
C A2LTYPEDEF_CONVERSION_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method.
C A2LTYPEDEF_MEASUREMENT | see ASAP2 specification
C A2LTYPEDEF_RECORDLAYOUT_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LTYPEDEF_STRUCTURE | see ASAP2 specification
C A2LUNIT | see ASAP2 specification
C A2LUNSUPPORTEDNODE | Node type to store unsupported objects
C A2LUSER_RIGHTS | see ASAP2 specification
C A2LVAR_ADDRESS | see ASAP2 specification
C A2LVAR_CHARACTERISTIC | see ASAP2 specification
C A2LVAR_CRITERION | see ASAP2 specification
C A2LVAR_FORBIDDEN_COMB | see ASAP2 specification
C A2LVARIANT_CODING | See ASAP2 Specification > v1.6.0 .
C A2LVIRTUAL | see ASAP2 specification
C A2LVIRTUAL_CHARACTERISTIC | see ASAP2 specification
C AdditiveDescriptionEventArgs | Used to get an additive description for a A2LNode from user code.
C DAQMeasurement | Structure to specify a DAQ configuration for a single measurement.
C IA2LDescription | Interface for nodes containing a description property.
C IA2LMemory | Interface to access both types of memory.
C ICharValue | Interface for accessing a characteristic value representation
C IDataFile | Interface for reading and writing data files (S19 and HEX) files.
C MemorySegment | Implements the representation of a memory segment of a data file
C MemorySegmentList | Memory segment list type
C ModelChangedEventArgs | Changed model event arguments.
C NonCompliantException | Exception class for non ASAP2 compliant files
C WriterException | Exception class representing an ASAP2 Writer exception
▼N BLF | Implements the Vector BLF file format reader/writer
C AppText | Application text
C AppTextManaged | .NET Application text representation
C BLFFile | BLF file Reader/Writer.
C CANDriverError | CAN driver error
C CANError | CAN Error
C CANErrorExt | CAN Error (extended)
C CANFDManaged | CAN FD message
C CANFDMessage | CAN FD message
C CANFDMessage64 | CAN FD 64 message
C CANMessage | CAN message
C CANMessage2 | Extended CAN message
C CANStatistic | CAN driver statistic
▼C Header | Header structure
C Time | BLF time representation
C LObj | Log object base class
C LogContainer | Log container structure
C ObjBase | Object base class
C RestorePointContainer | Restore Point Container
C RestorePointContainerManaged | .NET Restore Point Container
C SysVariable | System variable
C SysVariableManaged | .NET System variable
▼N Comm | Contains all the stuff to communicate over XCP, CCP and CAN.
▼N CAN | All the stuff needed to communicate with CAN hardware.
▼N _8Devices | All the stuff needed to bind to the 8Devices CAN hardware.
C _8DevicesCAN | The 8Devices version of an ICANProvider
▼N Advantech | All the stuff needed to bind to the Advantech CAN hardware.
C AdvantechCAN | The Advantech version of an ICANProvider
▼N EbEl | All the stuff needed to bind to the Eberspächer electronics FlexCard CAN hardware
C EbElCAN | The Eberspächer electronics version of an ICANProvider
▼N ELM327 | All the stuff needed to bind to the ELM327 CAN hardware.
C ELM327CAN | The ELM327 version of an ICANProvider.
▼N ESD | All the stuff needed to bind to the ESD CAN hardware
C ESDCAN | The ESD version of an ICANProvider
▼N ETAS | All the stuff needed to bind to the ETAS CAN hardware (BOA)
C ETASCAN | The ETAS BOA version of an ICANProvider
▼N IMEActia | All the stuff needed to bind to the IMEActia CAN hardware
C IMEActiaCAN | The IMEActia version of an ICANProvider
▼N Intrepid | All the stuff needed to bind to the Intrepid CAN hardware
C IntrepidCAN | The Intrepid version of an ICANProvider
▼N IXXAT | All the stuff needed to bind to the IXXAT CAN hardware
C IXXATCAN | The IXXAT version of an ICANProvider
▼N Kvaser | All the stuff needed to bind to the Kvaser CAN hardware
C KvaserCAN | The Kvaser version of an ICANProvider
▼N Lawicel | All the stuff needed to bind to the Lawicel CAN hardware
C LawicelCAN | The Lawicel version of an ICANProvider
▼N MHS | All the stuff needed to bind to the MHS Tiny-CAN CAN hardware.
C MHSCAN | The MHS Tiny-CAN version of an ICANProvider
▼N NI | All the stuff needed to bind to the National Instruments CAN hardware (NI-CAN)
C NICAN | The National Instruments version of an ICANProvider
▼N NIXNET | All the stuff needed to bind to the National Instruments CAN hardware (XNET)
C NIXNET | The National Instruments XNET version of an ICANProvider
▼N Peak | All the stuff needed to bind to the Peak CAN hardware.
C PeakCAN | The Peak version of an ICANProvider
▼N Softing | All the stuff needed to bind to the Softing CAN hardware
C SoftingCAN | The Softing version of an ICANProvider
▼N Vector | All the stuff needed to bind to the Vector CAN hardware
C VectorCAN | The Vector version of an ICANProvider
C CANConfigException | CAN Configuration exception.
▼C CANConfiguration | Represents the vendor(hardware) independant CAN configuration
C BitRateConfig | CAN FD Bitrate configuration using common parameters.
C BitRatePar | Bitrate configuration from Brp, TSeg1, TSeg2, and SJw
C CANEventArgs | EventArgs class to notify transferred CAN frames.
C CANFilterIDs | Serializes CAN filter IDs.
C CANFrame | Represents a sent or received CAN message.
C CANFrameQueue | Queue implementation to store CANFrame's.
C CANProvider | Implements a base class for a vendor specific CAN provider
C ICANProvider | CAN Adapter interface to implement for each CAN Bus provider.
C J1939Frame | Represents a sent or received J1939 message.
C J1939FrameQueue | Queue implementation to store J1939 Frame's.
▼N CCP | Implements the CAN Calibration Protocol Version 2.1 (ASAM MCD-1 CCP)
C CCPErrorArgs | ErrorArgs class delivering received command errors.
C CCPEventArgs | EventArgs class delivering received events.
C CCPFrame | Represents an CCP frame
C CCPFrameQueue | Queue implementation to store CCPFrame's.
C CCPMaster | Implements the CCP Master to communicate with a CCP Slave
C CCPMasterBase | Implements the CCP Master base communication with a CCP Slave
C CCPonCAN | Base class implementing the CCP based communication instance.
C CmdActionDiagService | Supports CCP commands Diag and Action service.
C CmdBase | Base class represents a CCP command.
C CmdMoveClearBC | Supports CCP commands Move, Clear memory, BuildChksum.
C DAQDictCCP | Holds a dictionary of configured DAQ Lists
C DAQListCCP | DAQ List representation
C RespActionDiagService | Response from Get Diagnostic or Action service.
C RespBase | Base class represents a CCP response.
C RespBuildChecksum | Response from Build Checksum.
C RespDownload | Response from Get Size of DAQ list.
C RespExchangeID | Response from Exchange Station Identifications.
C RespGetActiveCALPage | Response from Get currently active Calibration Page.
C RespGetCCPVersion | Response from Get implemented Version of CCP.
C RespGetDAQSize | Response from Get Size of DAQ list.
C RespGetSeed | Response from Get Seed for Key.
C RespGetSStatus | Response from Get current session status from slave
C RespUnlock | Response from Unlock Protection.
▼N ECUSimulator | Implements the ECU simulator
▼C Program | Main class of the ECU simulator
C CCPSim | Implements the CCP ECU simulator.
C UDSSim | Implements the UDS ECU simulator.
C XCPSim | Implements the XCP ECU simulator.
▼N LIN | All the stuff needed to communicate with LIN hardware.
▼N ETAS | All the stuff needed to bind to the ETAS LIN hardware.
C ETASLIN | The ETAS version of an ILINProvider
▼N Intrepid | All the stuff needed to bind to the Intrepid LIN hardware
C IntrepidLIN | The Intrepid version of an ILINProvider
▼N IXXAT | All the stuff needed to bind to the IXXAT LIN hardware
C IXXATLIN | The IXXAT version of an ILINProvider
▼N Kvaser | All the stuff needed to bind to the Kvaser LIN hardware.
C KvaserLIN | The Kvaser version of an ILINProvider
C LINMessageInfo |
▼N Peak | All the stuff needed to bind to the Peak LIN hardware.
C PeakLIN | The Peak version of an ILINProvider
▼N Vector | All the stuff needed to bind to the Vector LIN hardware
C VectorLIN | The Vector version of an ILINProvider
C ILINProvider | LIN Adapter interface to implement for each LIN Bus provider.
C LINConfiguration | Represents the vendor(hardware) independant LIN configuration
C LINEventArgs | EventArgs class to notify transferred LIN frames.
C LINFilterIDs | Serializes LIN filter IDs.
C LINFrame | Represents a sent or received LIN message.
C LINFrameDict | Maps LIN Id to LIN frames.
C LINFrameQueue | Queue implementation to store LINFrame's.
C LINProvider | Implements a base class for a vendor specific LIN provider
▼N XCP | Implements the XCP Protocol Version 1.3 (ASAM MCD-1 XCP V1.3.0)
▼N Examples |
C Program | ASAP2 XCP Sample console application
▼N SxI | All the stuff needed to communicate with Serial interfaces.
C ISxIProvider | Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...)
C SxIEventArgs | EventArgs class to notify transferred SxI data.
C SxIProvider | Implements a base class for serial interface specific SxI providers
C CmdBase | Base class represents a XCP command.
C CmdUserTransCmd | Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd.
C DAQDictXCP | Holds a dictionary of configured DAQ Lists
C DAQListXCP | DAQ List representation
C EventBase | Base class represents a XCP event.
C EventResumeMode | Event START IN RESUME MODE
C EventResumeModeTS | Event START IN RESUME MODE.
C EventStimTimeout | Event INDICATION OF TIME-OUT AT STIM.
C EventTimeSync | Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP.
C ODT | ECU Simulator: ODT representation
C ODTDict | ECUSimulator: Dictionary mapping PIDs to ODTs.
C RespBase | Base class represents a XCP response.
C RespBuildChecksum | Response from Build checksum over memory range
C RespConnect | Response from Set up connection with slave
C RespDTOCtrResp | Response from DTO CTR Properties command.
C RespError | Error Response
C RespEvent | Event response
C RespGetCALPage | Response from Get calibration page
C RespGetCommModeInfo | Response from Get current session status from slave
C RespGetDAQClock | Response from Get DAQ clock from slave
C RespGetDAQEventInfo | Response from Get specific information for an event channel
C RespGetDAQListInfo | Response from Get specific information for a DAQ list
C RespGetDAQListMode | Response from Get mode from DAQ list
C RespGetDAQListUSBEndpoint | Response from Get DAQ List USB Endpoint.
C RespGetDAQProcessorInfo | Response from Get general information on DAQ processor
C RespGetDAQResolutionInfo | Response from Get general information on DAQ processing resolution
C RespGetID | Response from Get identification from slave
C RespGetPageInfo | Response from Get specific information for a PAGE
C RespGetPAGProcessorInfo | Response from Get general information on PAG processor
C RespGetPGMProcessorInfo | Response from Get general information on PGM processor
C RespGetSectorInfoModeAddressOrLen | Response from Get specific information for a SECTOR
C RespGetSectorInfoModeSectorNameLen | Response from Get specific information for a SECTOR
C RespGetSeed | Response from Get seed for unlocking a protected resource
C RespGetSegmentInfo | Response from Get address information for a SEGMENT
C RespGetSegmentInfoAddress | Response from Get standard information for a SEGMENT
C RespGetSegmentMode | Response from Set mode for a SEGMENT
C RespGetStatus | Response from Get current session status from slave
C RespProgramStart | Response from Indicate the beginning of a programming sequence
C RespReadDAQ | Response from Read element from ODT entry
C RespService | Base class represents a XCP service request.
C RespStartStopDAQList | Response from Start/stop/select DAQ list
C RespTimeCorrelation | Response from Time Correlation command.
C RespUnlock | Response from Send key for unlocking a protected resource
C XCPCommunicator | Base class supporting any XCP based communication instance
C XCPErrorArgs | ErrorArgs class delivering received command errors.
C XCPEventArgs | EventArgs class delivering received events
C XCPFrame | Represents an XCP frame
C XCPFrameQueue | Queue implementation to store XCPFrame's.
C XCPMaster | Implements the XCP Master to communicate with a XCP Slave
C XCPMasterBase | Implements the XCP Master base communication with a XCP Slave
C XCPonEth | Base class implementing the XCP on ethernet based communication instance.
C XCPOnSxI | Implements the XCP on SxI based communication instance.
C XCPonTCP | Implements the TCP based XCP communication.
C XCPonUDP | Implements the UDP based XCP communication.
C XCPOnUSB | Implements the XCP on USB based communication instance.
C XCPReceiveBuffer | Implements a receive buffer for XCP frames
C XCPServiceRequestArgs | EventArgs class delivering received events
C CommKernel | Implements the Communication kernel
C CommMaster | Base class for both XCP and CCP master
C Communicator | Basic communicator implementation
C DAQCache | DAQ Record cache
C DAQDict | Holds the configured DAQ Lists for both XCP and CCP.
C DAQList | DAQ List representation base class for both XCP and CCP
C DAQStore | Holds received DAQ records
C DAQToEvtMapDict | Maps a XCP DAQList number to a specific XCP Event.
C Frame | Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP).
C FrameEventArgs | Frame queue event arguments.
C FrameProvider | Provides CAN/LIN Frames for CAN and LIN providers.
C FrameQueue | Base class for any frame type queue (CAN, CCP, XCP, UDS,...)
C IFrameProvider | Common Interface for the CAN/LIN/SxI frame providers.
C IResponse | Base class represents a CCP or XCP response.
C ODTEntry | Represents an ODT entry
C ODTList | Holds the configured ODTEntries within an ODT.
C ValuesReceivedEventArgs | Event arguments used on receiving acquisition data.
C XCPPrgParams | Transfer structure holding (XCP) programming parameters.
▼N DBC | Implements the DBC (Vector CANDb++) file format reader/writer
▼N Examples |
C Program | ASAP2ibrary DBC handling demonstration
▼C DBCFile | Implements the DBC (Vector CANDb++) file format reader/writer.
C AttribDefDict | Attributes dictionary type
C AttribDefType | CANDb++ Attribute definition type.
C AttributeType | CANDb++ Attribute type.
C AttributeTypeDict | CANDb++ Attributes dictionary.
C EnumDict | Defines a value table dictionary (mapping double values to strings).
C EnvironmentDict | Environment dictionary type
C EnvironmentType | CANDb++ Environment type.
C IDBCAttribute | Interface any DBC base class attributes must implement.
C IDBCBase | Interface any DBC base class must implement.
C IDBCComment | Interface any DBC base class supporting comments must implement.
C IDBCSignal | Interface any DBC base class supporting signals must implement.
C MsgType | CANDb++ (DBC) Message type.
C SignalGroupDict | Defines a signal group table dictionary (mapping signal group IDs to signal groups).
C SignalGroupType | Defines the CANDb++ signal group table.
C SignalType | CANDb++ (DBC) Signal type.
C SourceDict | Source dictionary type
C SourceType | CANDb++ (DBC) Device type.
C ValueTable | Defines the CANDb++ value table.
C ValueTableDict | Defines a value table dictionary (mapping value table idents to value tables).
▼N Diagnose |
▼N Comm | All the stuff to support various diagnostic service protocols
▼N DoIp | Implements the DoIP (ISO 13400) protocol.
▼N Examples |
C Program | ASAP2 DoIP Example
C AnnoncementEventArgs | Vehicle announcemnet event arguments
C BaseFrame | Base DoIP Frame
C DiagnosticMessage | Diagnostic message.
C DiagnosticPowerModeResponse | Diagnostic Powermode response.
▼C DoIPBase | Base class for a DoIP client or server
C Communicator | Holds a Socket, sender endpoint, receive buffer and stream length/position.
C ResponseEvent | Used to wait for and handle responses.
C DoIPClient | Implements the DoIP Client
C DoIPFrameQueue | Queue implementation to store DoIPFrame's.
C DoIPServer | Implements the DoIP Server (this is just used for simulating)
C EntityData | Holds a single Entity.
C EntityStatusResponse | Entity status response
C RespBase | Response base class.
C RoutingActivationResponse | Routing activation response.
C SrcDstFrame | Frame containing a source and destination address.
C SrcFrame | Frame containing a source address.
C VehicleIdResponse | VehicleId response.
▼N UDS | Implements the UDS Protocol (ISO 14229-1).
C DTCAndStatusRecord | Defines a single DTC record.
C RespBase | Base class for UDS protocol responses.
C RespControlDTCSetting | Response on Control DTC setting.
C RespData | Base class for UDS protocol responses with no Subfunction and a byte stream.
C RespDTCCount | DTC Count Response.
C RespDTCRecords | DTC records response.
C RespDTCSeverityRecords | DTC records with severity response.
C RespDynamicallyDefine | Base class for DynamicallyDefineDataIdentifier service.
C RespIdentfier | InputOutputControlByIdentifier/WriteDatByIdentifier response.
C RespLinkControl | Response on Event response.
C RespRequestUpDownload | Request upload/download service response.
C RespReset | ECUReset response.
C RespResponseOnEvent | Response on Event response.
C RespRoutineControl | Request Routine control service response.
C RespSecurityAccess | Security access response.
C RespSession | DiagnosticSessionControl response.
C RespSFBase | Base class for UDS protocol responses with Subfunction.
C RespTimingParameter | Timing parameter response.
C RespTransferData | Request TransferData service response.
C RespWriteMemoryByAddress | WriteMemoryByAddress response.
C ServiceProperties | Holds specification defined Service properties
C ServiceType | Service properties.
C SrcDataIdentifier | Dynamically Define Identifier by Id request.
C SrcDataMemory | Dynamically Define Identifier by memory address request.
▼C UDSClient | Implements the UDS client (Tester) Application protocol
C IdentifierRequest | Represents a cyclic Identifier request and its response data.
C UDSClientBase | Implements the UDS client base Application protocol
C UDSFrame | Represents an UDS frame.
C UDSFrameQueue | Queue implementation to store UDSFrame's.
C IsoTp | Implements the ISO 15765-2 (IsoTp) protocol
C IsoTpFSM | Represents the state machine to process an IsoTp message.
▼N ODX | All the ODX (Open Diagnostic Data Format) stuff
▼N Examples |
C Program | Sample console application
C AdminData | Administrative data definition.
C Audience | Defines user class types.
C BaseDocInfoContainer | Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash.
C BaseVariant | Diagnostic base variant definition.
C BaseVariantRef | Reference to base variant used in PARENT-REFS.
C Case | Multiplexer case.
C ChartContainer | Chart container.
C CompanyData | Definition of Company data.
C CompanySpecificInfo | Company specific info definition.
C ComParam | Communication parameter definition.
C ComParamBase | Communication paramter base class.
C COMParamRef | Communication parameters.
C ComParamSpec | Communication parameter specification definition.
C ComParamSubset | Communication parameter subset definition.
C ComplexComParam | Complex communication parameter definition.
C CompuInternalToPhys | Computation from a raw value to a physical value.
C CompuMethod | Compu method base definition.
C CompuRationalCoeffs | Compu method rational coefficients.
C CompuScale | Compu scale definition
C DataBlock | Data block definition.
C DataFile | Data file definition.
C DataFormat | Data format definition.
C DataObjectProp | Data object property specification.
C DefaultCase | Multiplexer default case definition.
C DetermineNumberOfItems | Part of dynamic length field part.
C DiagCodedTypeBase | Base class for diagnose coded types.
C DiagCodedTypeLL | Leading length diagnose coded type
C DiagCodedTypeMinMax | Minimum-Maximum diagnose coded type.
C DiagCodedTypePL | Param length diagnose coded type.
C DiagCodedTypeStd | Standard diagnose coded type.
C DiagDataDictionarySpec | Diagnostic dictionary specification.
C DiagDataDictSpec | Non serialized class used internally to hold DiagDataDictionarySpec instances.
C DiagLayerContainer | Diagnostic layer container.
C DiagService | Diagnostic service definition.
C DocRevision | Definition of a document revision.
C Dtc | Diagnostic trouble code.
C DtcDop | Diagnostic trouble codes specification.
C DynamicLengthField | Dynamic length field definition.
C EcuMem | ECU memory definition.
C EcuMemConnector | ECU memory connector definition.
C EcuSharedData | ECU shared data definition.
C EcuSharedDataRef | Reference to ECU shared data used in used in PARENT-REFS.
C EcuVariant | ECU variant definition.
C EcuVariantPatternContainer | ECU variant pattern container.
C EndOfPDUField | End of PDU filed definition.
C EnvDataDesc | Environment data description.
C EnvDataParamContainer | Environment data parameter container.
C Filter | Filter definition.
C Flash | Flash data definition.
C FlashDataExtern | Flash data definition (External).
C FlashDataIntern | Flash data definition (Internal).
C FunctClass | ODX function class element.
C FunctionalGroup | Functional group definition.
C FunctionalGroupRef | Reference to functional group used in PARENT-REFS.
C IcEcuProxy | Info Component ECU-PROXY.
C IcModelYear | Info Component MODEL-YEAR.
C IcOEM | Info Component OEM.
C IcVehicleModel | Info Component VEHICLE-MODEL.
C IcVehicleType | Info Component VEHICLE-TYPE.
C Id | Id tagged ODX element.
C Ident | Ident definition.
C IdentDesc | Ident descriptor definition.
C IdentifierRecord | Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22)
C IDescription | Used to indicate description supporting ODX nodes.
C IdRef | Id Reference.
C IId | Interface used to initialize ID dictionary while loading the ODX file
C InternalConstr | Internal constraints definition.
C LimitBase | Base class for Limit containing scales.
C MatchingParameterContainer | Matching parameter container.
C Mem | Memory definition.
C MemberLogicalLink | Member logical link type definition.
C Modification | Definition of a document revision modification.
C Mux | Multiplexer definition.
C NamedDescId | ODX base class for named elements with description.
C NamedId | ODX base class for named elements.
C NonCompliantException | Exception class for non ODX compliant files
C NotInheritedDiagComm | Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant.
C ODXFile | Open Diagnostic eXchange format (ODX) reader/writer.
C ODXRoot | ODX root
C ParamContainer | Paramter container definition.
C ParBaseDef | Parameter base definitiob.
C ParCodedConst | Coded parameter definition.
C ParDynamic | Paramneter with length reference.
C ParIdBase | Base class for ID referenced parameters.
C ParLength | Paramneter with length reference.
C ParMatchRequestParam | Matching request parameter.
C ParNrcConst | Used tp represent Negative response code constants.
C ParPhysConst | Physical constant parameter definition.
C ParReserved | Reserved Parameter definition.
C ParSystem | Parameter system definition.
C ParTableEntry | Parameter table entry definition
C ParTableKey | Parameter table key definition
C ParTableStruct | Parameter table entry definition
C ParValue | Parameter value definition.
▼C PDXIndex | PDX index.xml file
C ABLOCK | XML ABLOCK definition.
C FILE | XML FILE type definition.
C PhysicalDimension | Defines the physical dimension of a unit.
C PhysicalType | Defines the physical type in a data object property specification.
C PhysMem | Physical memory definition.
C PhysSegmentAddr | Physical memory segment definition with End Address.
C PhysSegmentBase | Base physical memory segment definition.
C PhysSegmentSize | Physical memory segment definition with Size.
C PkysicalVehicleLink | Physical vehicle link defintition.
C Protocol | Diagnostic Protocol definition.
C ProtocolRef | Reference to a diagnostic protocol used in PARENT-REFS.
C ProtStack | Protocol stack definition.
C RelatedDoc | Related document definition.
C ScaleConstr | Scale constraints definition.
C Sdg | SD group definition.
C Security | Security settings.
C Segment | Data segment definition.
C Session | ECU Session definition.
C SessionDesc | Session descriptor definition.
C SnRef | SHORT-NAME reference definition.
C StateTransitionContainer | State transition container.
C StaticField | Structure definition.
C Structure | Structure definition.
C SwitchKey | Multiplexer switch key definition.
C Table | Table definition.
C TableRow | Tablerow definition.
C TeamMember | Definition of a Team member.
C TypeValueElement | XML element with a TYPE Attribute and a Value text.
C Unit | ODX Unit element.
C UnitSpec | Specification of supported units.
C UnitSpecs | Non serialized class used internally to hold a UnitSpec instance.
C VehicleConnector | Vehicle connector definition.
C VehicleConnectorPin | Vehicle connector pin definition.
C VehicleInformation | Vehicle information.
C VehicleInfoSpec | Vehicle information specification.
C XDoc | External document definition.
▼N Helpers | Defines and implememts common helper types.
C Adler32Computer | Computes the Adler checksum used for zlib compressed files.
C Constants | Globally used constants.
C DataLimits | Represents data limits.
C DataPoint | Represents a data point in double floating point (64 Bit) precision.
C DataPointF | Represents a data point in single floating point (32 Bit) precision.
C DLLWrapper | Implements the ability to dynamically load a native windows DLL
C Extensions | Implements basic helper stuff.
C IgnoreNSXmlTextReader | XML text reader ignoring any namespace.
C MemoryRange | Holds a memory range.
C MemoryRangeList | Holds a range of memory.
C NativeSKDLL | Allows access to (native Windows) Seed&Key DLLs
C ParserEventArgs | Parser message EventArgument generated while parsing a file.
C ProgressArgs | EventArgs class to notify progress and support a cancel possibility.
C sRange | Represents a value range with a Min and Max border.
C TCByteOrder | Typeconverter to edit a reference the Byte order.
C TCByteOrderWithNotSet | Typeconverter to edit a reference the Byte order.
C TCHexType | Typeconverter to display and edit hex values.
C TcpSocketWithTimeout | Tcp socket using a configurable connect timeout.
C TimeBase | Provides system/application time functions.
▼N LIN |
▼N Examples |
C Program | ASAP2ibrary LION handling demonstration
▼N Logging | Defines logging support.
C ILog | Logging interface
C LogManager | Default LogManager (no log support at all).
▼N MDF | All the MDF (Measurement Data Format) stuff
▼N Examples |
▼N Reader |
C Program | MDF Reader example
▼N Writer |
C Program | MDF Writer example
▼N V3 | Implements the MDF V1.XX..V3.XX specific stuff.
C BLOCKBASE | Base class for all MDF V3 BLOCK types (except the IDBLOCK).
C CCBLOCK | MDF V3 CCBLOCK.
C CDBLOCK | The Channel Dependency Block
C CEBLOCK | The Channel Extension Block
C CGBLOCK | The Channel Group Block
C CNBLOCK | The Channel Block
C DGBLOCK | The Data Group Block
C HDBLOCK | The Header Block
C IDBLOCK | The File Identification Block
C SRBLOCK | The Sample Reduction Block
▼C TRBLOCK | The Trigger Block
C TriggerEvent | Trigger event data.
C TXBLOCK | The Text Block
▼N V4 | Implements the MDF V4.XX specific stuff
C ATBLOCKV4 | Container for binary data or a reference to an external file.
C BaseNames | Base class SI and CN comments
C BLOCKBASEV4 | Base class for all BLOCKV4 types (except the IDBLOCK).
C CABLOCKV4 | The channel array block
C CCBLOCKV4 | MDF V4 CCBLOCK.
C CGBLOCKV4 | The Channel Group Block
C CHBLOCKV4 | Channel hierarchy block.
C CNBLOCKV4 | The Channel Block
C CNcomment | MDF V4 Xml CNBLOCKV4 comment
C CommentBase | Base class for TXBLOCK references
C DataContainerV4 | Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4.
C DescType | Description of object. May exist in defferent languages.
C DGBLOCKV4 | The Data Group Block V4
C DisplayType | Display name of object. May exist in different languages.
C DLBLOCKV4 | DL Block
C DTBLOCKV4 | Container for data records with signal values.
C DZBLOCKV4 | DZ Block
C EBase | Base class for e and tree node.
C EType | MDF V4 Xml e Node
C EVBLOCKV4 | Event block
C FHBLOCKV4 | File history block.
C FHcomment | MDF V4 Xml HDBLOCKV4 comment
C HDBLOCKV4 | The Header Block V4
C HDcomment | MDF V4 Xml HDBLOCKV4 comment
C HLBLOCKV4 | Header information for linked list of data blocks.
C IDBLOCKV4 | The File Identification Block V4
C NamesBase | Base Name
C NamesType | Name of object in different languages
C RasterType | MDF V4 Xml Raster structure
C RDSDBLOCKV4 | Base class for SD, MD or RD blocks
C SIBLOCKV4 | Source information block
C SIcomment | MDF V4 Xml SIBLOCKV4 comment
C SRBLOCKV4 | The Sample Reduction Block.
C TreeType | MDF V4 Xml Tree
C VendorType | Vendor specific name, e.g. name as used in a specific tool.
C XmlBase | Base implementation for any MDF V4 Xml structure.
C Annotation | Structure holding a single annotation and it's timestamp.
C AnnotationList | Holds a list of Annotations.
C DataBlockExpander | Handles sorting of Datablocks.
C DataReader | MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression.
C DataStream | Handles a temporary stream per data handle.
C DependencyType | Dependency data.
C Helpers | MDF Helper functions and constants.
C ICCBLOCK | Channel computation Block interface.
C ICGBLOCK | Channel group Block interface.
C ICNBLOCK | Channel Block interface.
C IDataContainer | Interface for Data containers like SRBLOCK and DGBLOCK.
C IDGBLOCK | Data Group Block interface..
C IHDBLOCK | Header Block interface.
C IIDBLOCK | ID Block interface.
C IMDFBlock | Basic MDF block interface.
C IMDFComment | Interface to access TXBLOCK comments.
C ISRBLOCK | Sample reduction Block interface.
C MDFReader | Implements the MDF (Measurement Data Format) reader
C MDFWriter | Implements the MDF (Measurement Data Format) recorder.
C RawDataRecord | Used to transfer MDF raw data record.
C WriteRawDataEventArgs | EVent arguments to request the MDFWriter to write the raw data to the stream.
▼N Symbols | Implements the Symbol support
▼N ELF | Implements the ELF file format reader (supports 32 and 64 Bit)
▼N DWARF | All the stuff to support the DWARF Debugging Information Format Version 5.
C AbbrevEntry | DWARF abbreviation entry representation.
C AbbrevEntryArray | Represents an abbreviation array type.
C AbbrevEntryCU | Represents an abbreviation compilation unit.
C AbbrevEntryMember | Represents an abbreviation member.
C AbbrevEntryVarBase | Represents a base class for variables and members
C AbbrevEntryVariable | Represents an abbreviation variable.
C Attribute | DWARF attribute representation.
C CompilationUnitHeader | DWARF compilation unit header
▼C DWARFInfo | Implements a parser to support the DWARF Debugging Information Format Version 5
C SymbolsTree | DWARF symbols Tree.
C SymbolValue | Represents a DWARF symbol.
C TypeUnitHeader | Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section.
▼N Examples |
C Program | ASAP2ELFExample
▼C ELFFile | Implements the ELF file format reader.
C ELFHeader | ELF File Header definition
C ELFSection | ELF Section definition
C ELFSymbol | ELF File Symbol definition
C SectionList | List of ELF Sections.
C SectionValue | Maps a ELF Section name to an ELFSection instance.
C SymbolValue | ELF Symbol Value representation.
▼N MAP | Implements the MAP file format reader
▼C MAPFile | Parses MAP files
C SymbolValue | Contains a map file smbol entry (Name, address)
C SymbolFile | Implements the base class for specific Symbol files (like ELF or MAP).
C UpdateData | Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition.
C UpdaterSymbols | Created symbols by ELF, DWARF or MAP interpretation.


ASAP2Library interface: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 123456]
C A2LFormula | Represents a constant or a formula definition
C A2LFormulaDict | A A2LFormula dictionary (key = NodeName, value = A2LFormula)
▼C A2LNODE | Base class for any A2L entity
C A2LANNOTATION | see ASAP2 specification
C A2LANNOTATION_TEXT | see ASAP2 specification
C A2LAR_COMPONENT | see ASAP2 specification
C A2LAXIS_DESCR | see ASAP2 specification
C A2LBIT_OPERATION | The BIT_OPERATION keyword can be used to perform operation on the masked out value
C A2LCALIBRATION_HANDLE | see ASAP2 specification
C A2LCALIBRATION_METHOD | see ASAP2 specification
C A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD | CANAPE calibration method.
▼C A2LCANAPE_ADDRESS_UPDATE.FirstLastNode | Base class for MapSymbol and MemorySegment
C A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL | CANAPE map symbol
C A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT | CANAPE memory segment
C A2LCANAPE_EXT | ASAP2 CANAPE_EXT Interface support.
C A2LFIX_AXIS_PAR_LIST | see ASAP2 specification
C A2LFORMULA | see ASAP2 specification
C A2LHEADER | see ASAP2 specification
C A2LMEMORY_LAYOUT | see ASAP2 specification
C A2LMOD_COMMON | see ASAP2 specification
C A2LMOD_PAR | see ASAP2 specification
▼C A2LNAMEDNODE | Base class for all A2L entities with specific names.
▼C A2LADDRESS | Base class for all A2L entities containing an ECU address.
C A2LBLOB | see ASAP2 specification
▼C A2LCONVERSION_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method.
C A2LMEASUREMENT | see ASAP2 specification
▼C A2LRECORD_LAYOUT_REF | Base class for all A2L entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LAXIS_PTS | see ASAP2 specification
C A2LCHARACTERISTIC | see ASAP2 specification
C A2LINSTANCE | see ASAP2 specification
C A2LCANAPE_ADDRESS_UPDATE | ASAP2 CANAPE_ADDRESS_UPDATE Interface support.
C A2LCOMPU_METHOD | see ASAP2 specification
▼C A2LCOMPU_TAB_BASE | Base class for dictionary based compu methods.
C A2LCOMPU_TAB | see ASAP2 specification
C A2LCOMPU_VTAB | see ASAP2 specification
C A2LCOMPU_VTAB_RANGE | see ASAP2 specification
C A2LFRAME | see ASAP2 specification
C A2LMEMORY_SEGMENT | see ASAP2 specification
C A2LMODULE | see ASAP2 specification
C A2LOVERWRITE | see ASAP2 specification
C A2LPROJECT | The one and only root node of an A2L source file
C A2LRECORD_LAYOUT | Record layout
▼C A2LREFBASE | Base class for A2LFUNCTION and A2LGROUP
C A2LFUNCTION | see ASAP2 specification
C A2LGROUP | see ASAP2 specification
C A2LSTRUCTURE_COMPONENT | see ASAP2 specification
C A2LTRANSFORMER | see ASAP2 specification
▼C A2LTYPEDEF | Base class for all A2L typedef entities.
▼C A2LTYPEDEF_BLOB | see ASAP2 specification
C A2LTYPEDEF_STRUCTURE | see ASAP2 specification
▼C A2LTYPEDEF_CONVERSION_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method.
C A2LTYPEDEF_MEASUREMENT | see ASAP2 specification
▼C A2LTYPEDEF_RECORDLAYOUT_REF | Base class for all A2L typedef entities referencing an A2L_COMPUMETHOD method and an A2LRECORD_LAYOUT
C A2LTYPEDEF_AXIS | see ASAP2 specification
C A2LTYPEDEF_CHARACTERISTIC | see ASAP2 specification
C A2LUNIT | see ASAP2 specification
▼C A2LUNSUPPORTEDNODE | Node type to store unsupported objects
C A2LA2ML | This entity is never parsed as it contains the A2L supplier specific Transport interfaces (A2LIF_DATA).
C A2LIF_DATA | see ASAP2 specification
C A2LUSER_RIGHTS | see ASAP2 specification
C A2LVAR_CHARACTERISTIC | see ASAP2 specification
C A2LVAR_CRITERION | see ASAP2 specification
▼C A2LREFERENCE | Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs
C A2LDEF_CHARACTERISTIC | see ASAP2 specification
▼C A2LDEPENDENT_CHARACTERISTIC | see ASAP2 specification
C A2LVIRTUAL_CHARACTERISTIC | see ASAP2 specification
C A2LFUNCTION_LIST | see ASAP2 specification
C A2LIN_MEASUREMENT | see ASAP2 specification
C A2LLOC_MEASUREMENT | see ASAP2 specification
C A2LOUT_MEASUREMENT | see ASAP2 specification
C A2LREF_CHARACTERISTIC | see ASAP2 specification
C A2LREF_GROUP | see ASAP2 specification
C A2LREF_MEASUREMENT | see ASAP2 specification
C A2LSUB_FUNCTION | see ASAP2 specification
C A2LSUB_GROUP | see ASAP2 specification
C A2LTRANSFORMER_IN_OBJECTS | see ASAP2 specification
C A2LTRANSFORMER_OUT_OBJECTS | see ASAP2 specification
C A2LVIRTUAL | see ASAP2 specification
C A2LVARIANT_CODING | See ASAP2 Specification > v1.6.0 .
C A2LVAR_ADDRESS | see ASAP2 specification
C A2LVAR_FORBIDDEN_COMB | see ASAP2 specification
▼C A2LCCP_NODE | Base class for all A2L node definitions concerning CCP.
C A2LCCP_CAN_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_CHECKSUM_PARAM | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_DEFINED_PAGES | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_EVENT_GROUP | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
▼C A2LCCP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LCCP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
▼C A2LCCP_DP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_KP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_QP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_RASTER | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SEED_KEY | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_SOURCE | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LCCP_TP_BLOB | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
▼C A2LKWP_NODE | Base class for all A2L node definitions concerning KWP.
C A2LKWP_ADDRESS | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_CAN | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_CHECKSUM | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_DIAG_BAUD | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_FLASH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_FLASH_COPY | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_K_LINE | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LKWP_NAMEDNODE | Base class for all A2LCCP entities with specific names.
C A2LKWP_ADDRESS_MAPPING | See CCP Version 2.1, ASAP1B_CCP (COMMON_PARAMETERS)
C A2LKWP_DP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_KP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_PAGE_SWITCH | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_ROUTINE_PARA | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_SOURCE | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_TIME_DEF | See ASAP1B_KWP (COMMON_PARAMETERS)
C A2LKWP_TP_BLOB | See ASAP1B_KWP (COMMON_PARAMETERS)
▼C A2LXCP_NODE | Base class for all A2L node definitions concerning XCP.
C A2LXCP_ADDRESS_MAPPING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_BUFFER_RESERVE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, overrules default BUFFER_RESERVE for this EVENT)
C A2LXCP_CAN_FD | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_CHECKSUM |
C A2LXCP_CLOCK | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation)
C A2LXCP_CORE_LOAD | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load max,consumption; max load on single core)
C A2LXCP_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_CAN_ID | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_DAQ_LIST_USB_ENDPOINT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_DAQ_MEMORY_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LXCP_ECU_STATES_MEMORY_ACCESS | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States, State)
C A2LXCP_ECU_STATES_STATE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Protocol Layer, ECU States)
▼C A2LXCP_ENDPOINT | Base class for all endpoint classes.
C A2LXCP_IN_EP_ONLY_DAQ | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_ONLY_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_IN_EP_RESERR_DAQ_EVSERV | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_OUT_EP_CMD_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_OUT_EP_ONLY_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on USB
C A2LXCP_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CAN_ID_LIST | See XCP Version > 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption)
C A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, CPU load consumption queue)
C A2LXCP_EVENT_DAQ_PACKED_MODE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, DAQ packed mode, applies for all associated DAQ lists).
C A2LXCP_EVENT_LIST | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_EVENT_MIN_CYCLE_TIME | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Event channels)
C A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, ODT Entry size factor table)
C A2LXCP_FRAMING | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP Part 3 - Transport Layer Specification XCP on SxI
▼C A2LXCP_MEDIA | Base class for any XCP supported media (Ethernet, USB, CAN, FlexRay,...)
C A2LXCP_ON_CAN | XCP on CAN parameters
▼C A2LXCP_ON_ETHERNET | Base class for the XCP ethernet media (UDP/TCP)
C A2LXCP_ON_TCP_IP | XCP on TCP parameters
C A2LXCP_ON_UDP_IP | XCP on UDP parameters
C A2LXCP_ON_SxI | XCP on SxI parameters
C A2LXCP_ON_USB | XCP on USB parameters
▼C A2LXCP_NAMEDNODE | Base class for all A2LXCP entities with specific names.
C A2LXCP_DAQ_EVENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_ODT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (PREDEFINED)
C A2LXCP_PAG | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PAGE | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PGM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_PROTOCOL_LAYER | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SECTOR | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_SEGMENT | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_STIM | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_TIMESTAMP_CHARACTERIZATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus, Time correlation, Clock)
C A2LXCP_TIMESTAMP_SUPPORTED | See XCP Version 1.1, ASAM MCD 2MC AML FOR XCP (COMMON_PARAMETERS)
C A2LXCP_TIME_CORRELATION | See XCP Version 1.3, ASAM MCD 2MC AML FOR XCP (XCPPlus)
C A2LParser | The ASAP2 parser
C A2LParserProgressEventArgs | Progress EventArgument generated while parsing a file.
▼C AbbrevEntry | DWARF abbreviation entry representation.
C AbbrevEntryArray | Represents an abbreviation array type.
C AbbrevEntryCU | Represents an abbreviation compilation unit.
▼C AbbrevEntryVarBase | Represents a base class for variables and members
C AbbrevEntryMember | Represents an abbreviation member.
C AbbrevEntryVariable | Represents an abbreviation variable.
C PDXIndex.ABLOCK | XML ABLOCK definition.
C AdaptiveState | Holds a Timestamp together with a MemoryRange to read from an ECU.
C AdditiveDescriptionEventArgs | Used to get an additive description for a A2LNode from user code.
C Adler32Computer | Computes the Adler checksum used for zlib compressed files.
C AdminData | Administrative data definition.
C A2LCANAPE_ADDRESS_UPDATE.AdrMapType | Adress map type
C AnnoncementEventArgs | Vehicle announcemnet event arguments
C Annotation | Structure holding a single annotation and it's timestamp.
C AnnotationList | Holds a list of Annotations.
C Attribute | DWARF attribute representation.
C DBCFile.AttributeType | CANDb++ Attribute type.
C DBCFile.AttributeTypeDict | CANDb++ Attributes dictionary.
C Audience | Defines user class types.
C A2LKWP_TP_BLOB.BAUD_DEF | KWP Baudrate definition smaller v2000
C CANConfiguration.BitRateConfig | CAN FD Bitrate configuration using common parameters.
C CANConfiguration.BitRatePar | Bitrate configuration from Brp, TSeg1, TSeg2, and SJw
C BLFFile | BLF file Reader/Writer.
C CANConfigException | CAN Configuration exception.
C CANConfiguration | Represents the vendor(hardware) independant CAN configuration
C CANEventArgs | EventArgs class to notify transferred CAN frames.
C CANFilterIDs | Serializes CAN filter IDs.
C CCPErrorArgs | ErrorArgs class delivering received command errors.
C CCPEventArgs | EventArgs class delivering received events.
C Program.CCPSim | Implements the CCP ECU simulator.
C LibWrapper.ChannelConfig | Representation of a channel configuration.
C CharacteristicValue | Creates a value representation for the different characteristic value types
C Checksum | Provides methods for building checksums over data
▼C CmdBase | Base class represents a CCP command.
C CmdActionDiagService | Supports CCP commands Diag and Action service.
C CmdMoveClearBC | Supports CCP commands Move, Clear memory, BuildChksum.
▼C CmdBase | Base class represents a XCP command.
C CmdUserTransCmd | Used for CommandCode.UserCmd and CommandCode.TransportLayerCmd.
C CommKernel | Implements the Communication kernel
▼C CommMaster | Base class for both XCP and CCP master
▼C CCPMasterBase | Implements the CCP Master base communication with a CCP Slave
C CCPMaster | Implements the CCP Master to communicate with a CCP Slave
▼C XCPMasterBase | Implements the XCP Master base communication with a XCP Slave
C XCPMaster | Implements the XCP Master to communicate with a XCP Slave
▼C Communicator | Basic communicator implementation
C CCPonCAN | Base class implementing the CCP based communication instance.
▼C XCPCommunicator | Base class supporting any XCP based communication instance
C XCPOnSxI | Implements the XCP on SxI based communication instance.
C XCPOnUSB | Implements the XCP on USB based communication instance.
▼C XCPonEth | Base class implementing the XCP on ethernet based communication instance.
C XCPonTCP | Implements the TCP based XCP communication.
C XCPonUDP | Implements the UDP based XCP communication.
C DoIPBase.Communicator | Holds a Socket, sender endpoint, receive buffer and stream length/position.
C CompanySpecificInfo | Company specific info definition.
▼C CompilationUnitHeader | DWARF compilation unit header
C TypeUnitHeader | Represents the header for the series of debugging information entries contributing to the description of a type that has been placed in its own type unit, within the .debug_types section.
C CompuInternalToPhys | Computation from a raw value to a physical value.
C CompuMethod | Compu method base definition.
C CompuRationalCoeffs | Compu method rational coefficients.
C Constants | Globally used constants.
C CToCSharpMath | Maps standard math C functions to .NET framework math function strings
C DAQAndEvt | Hold a DAQList with it's attached Event.
C DAQCache | DAQ Record cache
▼C DAQDict | Holds the configured DAQ Lists for both XCP and CCP.
C DAQDictCCP | Holds a dictionary of configured DAQ Lists
C DAQDictXCP | Holds a dictionary of configured DAQ Lists
▼C DAQList | DAQ List representation base class for both XCP and CCP
C DAQListCCP | DAQ List representation
C DAQListXCP | DAQ List representation
C DAQMeasurement | Structure to specify a DAQ configuration for a single measurement.
C DAQStore | Holds received DAQ records
C DAQToEvtMapDict | Maps a XCP DAQList number to a specific XCP Event.
C DataBlockExpander | Handles sorting of Datablocks.
▼C DataConservation | Base class for any import and export calibration data file formats
C CDFFile | Implements the Calibration Data File format reader/writer.
C DCMFile | Implements the ETAS INCA DCM file format 2.x reader/writer
C MatlabFile | Implements the Matlab (*.m) file format reader/writer.
C PARFile | Implements the CANape PAR data File format reader/writer
▼C DataFile | Base class for reading/writing S19 and HEX files
C DataFileBin | Class for reading/writing binary data files
C DataFileHex | Class for reading/writing Intel HEX files
C DataFileS19 | Class for reading/writing Motorola S files
C DataFile | Data file definition.
C DataFileBinDlg | Dialog to get a start address for a data binary file.
C DataFormat | Data format definition.
C DataLimits | Represents data limits.
C DataPoint | Represents a data point in double floating point (64 Bit) precision.
C DataPointF | Represents a data point in single floating point (32 Bit) precision.
C DataReader | MDF DataReader handling data blocks (DTBLOCKV4) and zipped data blocks (DZBLOCKV4) and decompression.
C DataStream | Handles a temporary stream per data handle.
C DBCFile | Implements the DBC (Vector CANDb++) file format reader/writer.
▼C DefaultCase | Multiplexer default case definition.
C Case | Multiplexer case.
C DependencyType | Dependency data.
C DetermineNumberOfItems | Part of dynamic length field part.
▼C DiagCodedTypeBase | Base class for diagnose coded types.
C DiagCodedTypeLL | Leading length diagnose coded type
C DiagCodedTypeMinMax | Minimum-Maximum diagnose coded type.
C DiagCodedTypePL | Param length diagnose coded type.
C DiagCodedTypeStd | Standard diagnose coded type.
C DiagDataDictionarySpec | Diagnostic dictionary specification.
C DiagDataDictSpec | Non serialized class used internally to hold DiagDataDictionarySpec instances.
C DictionaryProxy< k, v > | Proxy class to permit XML Serialization of generic dictionaries
C DictionaryProxyComplex< k, v > | Proxy class to permit XML Serialization of generic dictionaries with a complex value
C A2LCANAPE_EXT.DisplayType | Display setting definition
▼C DLLWrapper | Implements the ability to dynamically load a native windows DLL
C NativeSKDLL | Allows access to (native Windows) Seed&Key DLLs
C DocRevision | Definition of a document revision.
▼C DoIPBase | Base class for a DoIP client or server
C DoIPClient | Implements the DoIP Client
C DoIPServer | Implements the DoIP Server (this is just used for simulating)
C LibWrapper.DriverConfig | Repsentation of a driver configuration
C DTCAndStatusRecord | Defines a single DTC record.
C DWARFInfo | Implements a parser to support the DWARF Debugging Information Format Version 5
▼C EBase | Base class for e and tree node.
C EType | MDF V4 Xml e Node
C TreeType | MDF V4 Xml Tree
C EcuVariantPatternContainer | ECU variant pattern container.
C ELFFile.ELFHeader | ELF File Header definition
C ELFFile.ELFSection | ELF Section definition
C ELFFile.ELFSymbol | ELF File Symbol definition
C EntityData | Holds a single Entity.
C DBCFile.EnumDict | Defines a value table dictionary (mapping double values to strings).
C Extensions | Implements basic helper stuff.
C Extensions | Implements basic helper stuff.
C PDXIndex.FILE | XML FILE type definition.
C Filter | Filter definition.
C A2LCANAPE_ADDRESS_UPDATE.FlashSectionType | Flash section type
▼C Frame | Base class for any frame type (CAN, CCP, XCP, UDS, J1939, DoIP).
▼C CANFrame | Represents a sent or received CAN message.
C J1939Frame | Represents a sent or received J1939 message.
C CCPFrame | Represents an CCP frame
C LINFrame | Represents a sent or received LIN message.
C XCPFrame | Represents an XCP frame
▼C BaseFrame | Base DoIP Frame
▼C SrcFrame | Frame containing a source address.
C SrcDstFrame | Frame containing a source and destination address.
C UDSFrame | Represents an UDS frame.
C FrameEventArgs< T > | Frame queue event arguments.
C FrameProvider< T, V > | Provides CAN/LIN Frames for CAN and LIN providers.
▼C FrameProvider< CANFrame, CANEventArgs > |
▼C CANProvider | Implements a base class for a vendor specific CAN provider
C AdvantechCAN | The Advantech version of an ICANProvider
C ELM327CAN | The ELM327 version of an ICANProvider.
C ESDCAN | The ESD version of an ICANProvider
C ETASCAN | The ETAS BOA version of an ICANProvider
C EbElCAN | The Eberspächer electronics version of an ICANProvider
C IMEActiaCAN | The IMEActia version of an ICANProvider
C IXXATCAN | The IXXAT version of an ICANProvider
C IntrepidCAN | The Intrepid version of an ICANProvider
C KvaserCAN | The Kvaser version of an ICANProvider
C LawicelCAN | The Lawicel version of an ICANProvider
C MHSCAN | The MHS Tiny-CAN version of an ICANProvider
C NICAN | The National Instruments version of an ICANProvider
C NIXNET | The National Instruments XNET version of an ICANProvider
C PeakCAN | The Peak version of an ICANProvider
C SoftingCAN | The Softing version of an ICANProvider
C VectorCAN | The Vector version of an ICANProvider
C _8DevicesCAN | The 8Devices version of an ICANProvider
▼C FrameProvider< LINFrame, LINEventArgs > |
▼C LINProvider | Implements a base class for a vendor specific LIN provider
C ETASLIN | The ETAS version of an ILINProvider
C IXXATLIN | The IXXAT version of an ILINProvider
C IntrepidLIN | The Intrepid version of an ILINProvider
C KvaserLIN | The Kvaser version of an ILINProvider
C PeakLIN | The Peak version of an ILINProvider
C VectorLIN | The Vector version of an ILINProvider
C FrameQueue< T > | Base class for any frame type queue (CAN, CCP, XCP, UDS,...)
▼C FrameQueue< BaseFrame > |
C DoIPFrameQueue | Queue implementation to store DoIPFrame's.
▼C FrameQueue< CANFrame > |
C CANFrameQueue | Queue implementation to store CANFrame's.
▼C FrameQueue< CCPFrame > |
C CCPFrameQueue | Queue implementation to store CCPFrame's.
▼C FrameQueue< J1939Frame > |
C J1939FrameQueue | Queue implementation to store J1939 Frame's.
▼C FrameQueue< LINFrame > |
C LINFrameQueue | Queue implementation to store LINFrame's.
▼C FrameQueue< UDSFrame > |
C UDSFrameQueue | Queue implementation to store UDSFrame's.
▼C FrameQueue< XCPFrame > |
C XCPFrameQueue | Queue implementation to store XCPFrame's.
C Header | Header structure
C Helpers | MDF Helper functions and constants.
▼C IA2LDescription | Interface for nodes containing a description property.
C A2LADDRESS | Base class for all A2L entities containing an ECU address.
C A2LCOMPU_METHOD | see ASAP2 specification
C A2LCOMPU_TAB_BASE | Base class for dictionary based compu methods.
C A2LFRAME | see ASAP2 specification
C A2LMEMORY_SEGMENT | see ASAP2 specification
C A2LMODULE | see ASAP2 specification
C A2LMOD_PAR | see ASAP2 specification
C A2LPROJECT | The one and only root node of an A2L source file
C A2LREFBASE | Base class for A2LFUNCTION and A2LGROUP
C A2LREFERENCE | Base class for all unnamed A2L entities referencing A2LMEASUREMENTs or a A2LCHARACTERISTICs
C A2LTYPEDEF | Base class for all A2L typedef entities.
C A2LUNIT | see ASAP2 specification
C A2LVAR_CRITERION | see ASAP2 specification
▼C IA2LMemory | Interface to access both types of memory.
C A2LMEMORY_LAYOUT | see ASAP2 specification
C A2LMEMORY_SEGMENT | see ASAP2 specification
▼C ICharValue | Interface for accessing a characteristic value representation
▼C BaseValue | Base class for a characteristic value representation.
C ASCIIValue | Class representing a characteristic CHAR_TYPE.ASCII value
C Cube4Value | Class representing a characteristic CHAR_TYPE.CUBE_4 value
C Cube5Value | Class representing a characteristic CHAR_TYPE.CUBE_5 value
C CuboidValue | Class representing a characteristic CHAR_TYPE.CUBOID value
C CurveValue | Class representing a characteristic CHAR_TYPE.CURVE value
C MapValue | Class representing a characteristic CHAR_TYPE.MAP value
C SingleValue | Class representing a characteristic CHAR_TYPE.VALUE value
C ValBlkValue | Class representing a characteristic CHAR_TYPE.VALUE_BLOCK value
▼C IDataContainer | Interface for Data containers like SRBLOCK and DGBLOCK.
▼C IDGBLOCK | Data Group Block interface..
C DGBLOCK | The Data Group Block
C DGBLOCKV4 | The Data Group Block V4
C DGBLOCK | The Data Group Block
▼C DataContainerV4 | Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4.
C DGBLOCKV4 | The Data Group Block V4
C SRBLOCKV4 | The Sample Reduction Block.
▼C IDataFile | Interface for reading and writing data files (S19 and HEX) files.
C DataFileBin | Class for reading/writing binary data files
C DataFileHex | Class for reading/writing Intel HEX files
C DataFileS19 | Class for reading/writing Motorola S files
▼C DBCFile.IDBCBase | Interface any DBC base class must implement.
C DBCFile.EnvironmentDict | Environment dictionary type
▼C DBCFile.IDBCAttribute | Interface any DBC base class attributes must implement.
C DBCFile.AttribDefDict | Attributes dictionary type
C DBCFile.AttribDefType | CANDb++ Attribute definition type.
▼C DBCFile.IDBCComment | Interface any DBC base class supporting comments must implement.
C DBCFile.EnvironmentType | CANDb++ Environment type.
▼C DBCFile.IDBCSignal | Interface any DBC base class supporting signals must implement.
C DBCFile.SignalType | CANDb++ (DBC) Signal type.
C DBCFile.MsgType | CANDb++ (DBC) Message type.
C DBCFile.SourceType | CANDb++ (DBC) Device type.
C DBCFile.SignalGroupDict | Defines a signal group table dictionary (mapping signal group IDs to signal groups).
C DBCFile.SignalGroupType | Defines the CANDb++ signal group table.
C DBCFile.ValueTable | Defines the CANDb++ value table.
C DBCFile.ValueTableDict | Defines a value table dictionary (mapping value table idents to value tables).
C IdentDesc | Ident descriptor definition.
C IdentifierRecord | Used to keep identifiers and it's response parameters for ReadDataByIdentifier (22)
C UDSClient.IdentifierRequest | Represents a cyclic Identifier request and its response data.
▼C IDescription | Used to indicate description supporting ODX nodes.
C COMParamRef | Communication parameters.
▼C LimitBase | Base class for Limit containing scales.
C CompuScale | Compu scale definition
C InternalConstr | Internal constraints definition.
C ScaleConstr | Scale constraints definition.
▼C NamedDescId | ODX base class for named elements with description.
▼C BaseDocInfoContainer | Basic doument info contained in DiagLayerContainer, VehicleInfoSpec and Flash.
C ComParamSpec | Communication parameter specification definition.
C ComParamSubset | Communication parameter subset definition.
C DiagLayerContainer | Diagnostic layer container.
C Flash | Flash data definition.
C VehicleInfoSpec | Vehicle information specification.
C ChartContainer | Chart container.
▼C ComParamBase | Communication paramter base class.
C ComParam | Communication parameter definition.
C ComplexComParam | Complex communication parameter definition.
C DataBlock | Data block definition.
▼C DataObjectProp | Data object property specification.
C DtcDop | Diagnostic trouble codes specification.
▼C EcuSharedData | ECU shared data definition.
▼C EcuVariant | ECU variant definition.
C BaseVariant | Diagnostic base variant definition.
C FunctionalGroup | Functional group definition.
C Protocol | Diagnostic Protocol definition.
C FunctClass | ODX function class element.
C Mux | Multiplexer definition.
▼C ParamContainer | Paramter container definition.
C EnvDataParamContainer | Environment data parameter container.
C Structure | Structure definition.
C PhysicalDimension | Defines the physical dimension of a unit.
C ProtStack | Protocol stack definition.
C Session | ECU Session definition.
C StaticField | Structure definition.
C Unit | ODX Unit element.
▼C IdRef | Id Reference.
C BaseVariantRef | Reference to base variant used in PARENT-REFS.
C COMParamRef | Communication parameters.
C EcuSharedDataRef | Reference to ECU shared data used in used in PARENT-REFS.
C FunctionalGroupRef | Reference to functional group used in PARENT-REFS.
C ProtocolRef | Reference to a diagnostic protocol used in PARENT-REFS.
C IEvaluator | Interface for dynamically compiled formulas
C IFrameProvider< T > | Common Interface for the CAN/LIN/SxI frame providers.
▼C IFrameProvider< CANEventArgs > |
▼C ICANProvider | CAN Adapter interface to implement for each CAN Bus provider.
C CANProvider | Implements a base class for a vendor specific CAN provider
▼C IFrameProvider< LINEventArgs > |
▼C ILINProvider | LIN Adapter interface to implement for each LIN Bus provider.
C LINProvider | Implements a base class for a vendor specific LIN provider
C IgnoreNSXmlTextReader | XML text reader ignoring any namespace.
▼C IId | Interface used to initialize ID dictionary while loading the ODX file
▼C Id | Id tagged ODX element.
▼C NamedId | ODX base class for named elements.
C CompanyData | Definition of Company data.
C DiagService | Diagnostic service definition.
C Dtc | Diagnostic trouble code.
C EcuMem | ECU memory definition.
C EcuMemConnector | ECU memory connector definition.
▼C EndOfPDUField | End of PDU filed definition.
C DynamicLengthField | Dynamic length field definition.
C EnvDataDesc | Environment data description.
C FlashDataExtern | Flash data definition (External).
C FlashDataIntern | Flash data definition (Internal).
C IcEcuProxy | Info Component ECU-PROXY.
C IcModelYear | Info Component MODEL-YEAR.
C IcOEM | Info Component OEM.
C IcVehicleModel | Info Component VEHICLE-MODEL.
C IcVehicleType | Info Component VEHICLE-TYPE.
C Ident | Ident definition.
C NamedDescId | ODX base class for named elements with description.
C PhysMem | Physical memory definition.
▼C PhysSegmentBase | Base physical memory segment definition.
C PhysSegmentAddr | Physical memory segment definition with End Address.
C PhysSegmentSize | Physical memory segment definition with Size.
C PkysicalVehicleLink | Physical vehicle link defintition.
C Segment | Data segment definition.
C StateTransitionContainer | State transition container.
C Table | Table definition.
C TableRow | Tablerow definition.
C TeamMember | Definition of a Team member.
C VehicleConnectorPin | Vehicle connector pin definition.
▼C ParIdBase | Base class for ID referenced parameters.
C ParLength | Paramneter with length reference.
C ParTableEntry | Parameter table entry definition
C ParTableKey | Parameter table key definition
▼C ILog | Logging interface
C LogManager | Default LogManager (no log support at all).
▼C IMDFBlock | Basic MDF block interface.
▼C IIDBLOCK | ID Block interface.
C IDBLOCK | The File Identification Block
C IDBLOCKV4 | The File Identification Block V4
▼C IMDFComment | Interface to access TXBLOCK comments.
▼C ICCBLOCK | Channel computation Block interface.
C CCBLOCK | MDF V3 CCBLOCK.
C CCBLOCKV4 | MDF V4 CCBLOCK.
▼C ICGBLOCK | Channel group Block interface.
C CGBLOCK | The Channel Group Block
C CGBLOCKV4 | The Channel Group Block
▼C ICNBLOCK | Channel Block interface.
C CNBLOCK | The Channel Block
C CNBLOCKV4 | The Channel Block
C IDGBLOCK | Data Group Block interface..
▼C IHDBLOCK | Header Block interface.
C HDBLOCK | The Header Block
C HDBLOCKV4 | The Header Block V4
C TRBLOCK | The Trigger Block
C EVBLOCKV4 | Event block
C FHBLOCKV4 | File history block.
C SIBLOCKV4 | Source information block
▼C ISRBLOCK | Sample reduction Block interface.
C SRBLOCK | The Sample Reduction Block
C SRBLOCKV4 | The Sample Reduction Block.
▼C BLOCKBASE | Base class for all MDF V3 BLOCK types (except the IDBLOCK).
C CCBLOCK | MDF V3 CCBLOCK.
C CDBLOCK | The Channel Dependency Block
C CEBLOCK | The Channel Extension Block
C CGBLOCK | The Channel Group Block
C CNBLOCK | The Channel Block
C DGBLOCK | The Data Group Block
C HDBLOCK | The Header Block
C SRBLOCK | The Sample Reduction Block
C TRBLOCK | The Trigger Block
C TXBLOCK | The Text Block
C ATBLOCKV4 | Container for binary data or a reference to an external file.
▼C BLOCKBASEV4 | Base class for all BLOCKV4 types (except the IDBLOCK).
C ATBLOCKV4 | Container for binary data or a reference to an external file.
C CABLOCKV4 | The channel array block
C CCBLOCKV4 | MDF V4 CCBLOCK.
C CGBLOCKV4 | The Channel Group Block
C CHBLOCKV4 | Channel hierarchy block.
C CNBLOCKV4 | The Channel Block
C DLBLOCKV4 | DL Block
C DTBLOCKV4 | Container for data records with signal values.
C DZBLOCKV4 | DZ Block
C DataContainerV4 | Base class for V4 DataGroups like SRBLOCKV4 and DGBLOCKV4.
C EVBLOCKV4 | Event block
C FHBLOCKV4 | File history block.
C HDBLOCKV4 | The Header Block V4
C HLBLOCKV4 | Header information for linked list of data blocks.
C RDSDBLOCKV4 | Base class for SD, MD or RD blocks
C SIBLOCKV4 | Source information block
▼C IResponse | Base class represents a CCP or XCP response.
▼C RespBase | Base class represents a CCP response.
C RespActionDiagService | Response from Get Diagnostic or Action service.
C RespBuildChecksum | Response from Build Checksum.
C RespDownload | Response from Get Size of DAQ list.
C RespExchangeID | Response from Exchange Station Identifications.
C RespGetActiveCALPage | Response from Get currently active Calibration Page.
C RespGetCCPVersion | Response from Get implemented Version of CCP.
C RespGetDAQSize | Response from Get Size of DAQ list.
C RespGetSStatus | Response from Get current session status from slave
C RespGetSeed | Response from Get Seed for Key.
C RespUnlock | Response from Unlock Protection.
▼C RespBase | Base class represents a XCP response.
▼C EventBase | Base class represents a XCP event.
▼C EventResumeMode | Event START IN RESUME MODE
C EventResumeModeTS | Event START IN RESUME MODE.
C EventStimTimeout | Event INDICATION OF TIME-OUT AT STIM.
C EventTimeSync | Event TRANSFER OF EXTERNALLY TRIGGERED TIMESTAMP.
C RespBuildChecksum | Response from Build checksum over memory range
C RespConnect | Response from Set up connection with slave
C RespDTOCtrResp | Response from DTO CTR Properties command.
C RespError | Error Response
C RespEvent | Event response
C RespGetCALPage | Response from Get calibration page
C RespGetCommModeInfo | Response from Get current session status from slave
C RespGetDAQClock | Response from Get DAQ clock from slave
C RespGetDAQEventInfo | Response from Get specific information for an event channel
C RespGetDAQListInfo | Response from Get specific information for a DAQ list
C RespGetDAQListMode | Response from Get mode from DAQ list
C RespGetDAQListUSBEndpoint | Response from Get DAQ List USB Endpoint.
C RespGetDAQProcessorInfo | Response from Get general information on DAQ processor
C RespGetDAQResolutionInfo | Response from Get general information on DAQ processing resolution
C RespGetID | Response from Get identification from slave
C RespGetPAGProcessorInfo | Response from Get general information on PAG processor
C RespGetPGMProcessorInfo | Response from Get general information on PGM processor
C RespGetPageInfo | Response from Get specific information for a PAGE
C RespGetSectorInfoModeAddressOrLen | Response from Get specific information for a SECTOR
C RespGetSectorInfoModeSectorNameLen | Response from Get specific information for a SECTOR
C RespGetSeed | Response from Get seed for unlocking a protected resource
C RespGetSegmentInfo | Response from Get address information for a SEGMENT
C RespGetSegmentInfoAddress | Response from Get standard information for a SEGMENT
C RespGetSegmentMode | Response from Set mode for a SEGMENT
C RespGetStatus | Response from Get current session status from slave
C RespProgramStart | Response from Indicate the beginning of a programming sequence
C RespReadDAQ | Response from Read element from ODT entry
C RespService | Base class represents a XCP service request.
C RespStartStopDAQList | Response from Start/stop/select DAQ list
C RespTimeCorrelation | Response from Time Correlation command.
C RespUnlock | Response from Send key for unlocking a protected resource
C IsoTp | Implements the ISO 15765-2 (IsoTp) protocol
C IsoTpFSM | Represents the state machine to process an IsoTp message.
▼C ISxIProvider | Interface to implement for each different Serial interface provider (e.g. Serial Port, BLE, SPI, ...)
C SxIProvider | Implements a base class for serial interface specific SxI providers
▼C A2LRECORD_LAYOUT.ItemLayoutDesc | Base class for record layout items.
▼C A2LRECORD_LAYOUT.AxisPtsLayoutDesc | Layout description for axis points.
C A2LRECORD_LAYOUT.AxisRescaleLayoutDesc | Layout description for axis rescale value pairs.
C A2LRECORD_LAYOUT.FncValuesLayoutDesc | Layout description for function values
C DictionaryProxy< k, v >.KeyAndValue | Holds the keys and values
C DictionaryProxyComplex< k, v >.KeyAndValueComplex | Holds the keys and values
C A2LKWP_TP_BLOB.KWP_DATA_ACCESS | DATA ACCESS definition smaller v2000
C A2LKWP_TP_BLOB.KWP_K_LINE | KLINE definition smaller v2000
C A2LKWP_TP_BLOB.KWP_SERAM | KWP SERAM definition smaller v2000
C KWP_TIME_DEF | Timing definition smaller v2000
C KWP_USDTP_TIMING | Timing definition smaller v2000
C LINConfiguration | Represents the vendor(hardware) independant LIN configuration
C LINEventArgs | EventArgs class to notify transferred LIN frames.
C LINFilterIDs | Serializes LIN filter IDs.
C LINFrameDict | Maps LIN Id to LIN frames.
C A2LCANAPE_EXT.LinkMapType | Linker map definition
C LINMessageInfo |
C MatchingParameterContainer | Matching parameter container.
C MDFReader | Implements the MDF (Measurement Data Format) reader
C MDFWriter | Implements the MDF (Measurement Data Format) recorder.
C MeasurementAccessData | Manages static memory data for A2LMEASUREMENTs.
C Mem | Memory definition.
C MemoryRange | Holds a memory range.
C MemoryRangeList | Holds a range of memory.
C MemorySegment | Implements the representation of a memory segment of a data file
C MemorySegmentList | Memory segment list type
C ModelChangedEventArgs | Changed model event arguments.
C Modification | Definition of a document revision modification.
C MSRSW | The root element of the file.
▼C NamesBase | Base Name
C DescType | Description of object. May exist in defferent languages.
C DisplayType | Display name of object. May exist in different languages.
C NamesType | Name of object in different languages
C VendorType | Vendor specific name, e.g. name as used in a specific tool.
C A2LKWP_CAN.NETWORK_LIMITS | KWP QP_BLOB definition smaller v2000
C NonCompliantException | Exception class for non ASAP2 compliant files
C NonCompliantException | Exception class for non ODX compliant files
C NotInheritedDiagComm | Holds references (by SHORT-NAME) to DiagServices not inherited from the base variant.
▼C ObjBase | Object base class
▼C LObj | Log object base class
▼C AppText | Application text
C AppTextManaged | .NET Application text representation
C CANDriverError | CAN driver error
C CANError | CAN Error
C CANErrorExt | CAN Error (extended)
C CANFDMessage | CAN FD message
▼C CANFDMessage64 | CAN FD 64 message
C CANFDManaged | CAN FD message
▼C CANMessage | CAN message
C CANMessage2 | Extended CAN message
C CANStatistic | CAN driver statistic
▼C RestorePointContainer | Restore Point Container
C RestorePointContainerManaged | .NET Restore Point Container
▼C SysVariable | System variable
C SysVariableManaged | .NET System variable
C LogContainer | Log container structure
C ODT | ECU Simulator: ODT representation
C A2LXCP_ODT.ODT_ENTRY | Represents a single ODT entry.
C ODTDict | ECUSimulator: Dictionary mapping PIDs to ODTs.
C ODTEntry | Represents an ODT entry
C ODTList | Holds the configured ODTEntries within an ODT.
C ODXFile | Open Diagnostic eXchange format (ODX) reader/writer.
C ODXRoot | ODX root
C OptionalCommandSet | Represents a set of unique strings used to optional commands.
C ParserEventArgs | Parser message EventArgument generated while parsing a file.
C PDXIndex | PDX index.xml file
C PhysicalType | Defines the physical type in a data object property specification.
C Program | Sample console application
C Program | Demo console application
C Program | Main class of the ECU simulator
C Program | ASAP2 XCP Sample console application
C Program | ASAP2ibrary DBC handling demonstration
C Program | ASAP2 DoIP Example
C Program | Sample console application
C Program | ASAP2ibrary LION handling demonstration
C Program | MDF Reader example
C Program | MDF Writer example
C Program | ASAP2ELFExample
C ProgressArgs | EventArgs class to notify progress and support a cancel possibility.
C A2LKWP_SOURCE.QP_BLOB | KWP QP_BLOB definition smaller v2000
C RasterType | MDF V4 Xml Raster structure
C RationalCoeffs | Rational coefficients of an A2LCOMPU_METHOD.
C RawDataRecord | Used to transfer MDF raw data record.
C RelatedDoc | Related document definition.
▼C RespBase | Response base class.
C DiagnosticMessage | Diagnostic message.
C DiagnosticPowerModeResponse | Diagnostic Powermode response.
C EntityStatusResponse | Entity status response
C RoutingActivationResponse | Routing activation response.
C VehicleIdResponse | VehicleId response.
▼C RespBase | Base class for UDS protocol responses.
C RespData | Base class for UDS protocol responses with no Subfunction and a byte stream.
C RespIdentfier | InputOutputControlByIdentifier/WriteDatByIdentifier response.
C RespRequestUpDownload | Request upload/download service response.
▼C RespSFBase | Base class for UDS protocol responses with Subfunction.
C RespControlDTCSetting | Response on Control DTC setting.
C RespDTCCount | DTC Count Response.
C RespDTCRecords | DTC records response.
C RespDTCSeverityRecords | DTC records with severity response.
C RespDynamicallyDefine | Base class for DynamicallyDefineDataIdentifier service.
C RespLinkControl | Response on Event response.
C RespReset | ECUReset response.
C RespResponseOnEvent | Response on Event response.
C RespRoutineControl | Request Routine control service response.
C RespSecurityAccess | Security access response.
C RespSession | DiagnosticSessionControl response.
C RespTimingParameter | Timing parameter response.
C RespTransferData | Request TransferData service response.
C RespWriteMemoryByAddress | WriteMemoryByAddress response.
C DoIPBase.ResponseEvent | Used to wait for and handle responses.
C Sdg | SD group definition.
C ELFFile.SectionList | List of ELF Sections.
C ELFFile.SectionValue | Maps a ELF Section name to an ELFSection instance.
C Security | Security settings.
C A2LKWP_TP_BLOB.SECURITY_ACCESS | KWP SERAM definition smaller v2000
C LibWrapper.ServiceId |
C ServiceProperties | Holds specification defined Service properties
C ServiceType | Service properties.
C SessionDesc | Session descriptor definition.
C SnRef | SHORT-NAME reference definition.
C SourceAndRaster | Hold a CCP Source with it's attached CCP Raster.
C DBCFile.SourceDict | Source dictionary type
C sRange | Represents a value range with a Min and Max border.
C SrcDataIdentifier | Dynamically Define Identifier by Id request.
C SrcDataMemory | Dynamically Define Identifier by memory address request.
C SWAXISCONT | Physical axis values.
C SWINSTANCE | Represents one particular calibration item and therefore corresponds to CAL-ITEM in CDF.
C SWINSTANCESPEC | The section within a SWSYSTEM which takes all information about the instances of data items within the ECU, in particular the calibration items.
C SWINSTANCETREE | Receives one particular set of calibration items
C SwitchKey | Multiplexer switch key definition.
C SWSYSTEM | Describes one particular system within the current file
C SWVALUECONT | Physical values.
C SxIEventArgs | EventArgs class to notify transferred SxI data.
▼C SymbolFile | Implements the base class for specific Symbol files (like ELF or MAP).
C ELFFile | Implements the ELF file format reader.
C MAPFile | Parses MAP files
C DWARFInfo.SymbolsTree | DWARF symbols Tree.
▼C A2LCANAPE_ADDRESS_UPDATE.SymbolType | Symbol type
C A2LCANAPE_ADDRESS_UPDATE.ExSymbolType | Extended Symbol type
C DWARFInfo.SymbolValue | Represents a DWARF symbol.
C ELFFile.SymbolValue | ELF Symbol Value representation.
C MAPFile.SymbolValue | Contains a map file smbol entry (Name, address)
C TabCoeffs | Tab conversion computations.
C TCByteOrder | Typeconverter to edit a reference the Byte order.
C TCByteOrderWithNotSet | Typeconverter to edit a reference the Byte order.
C TCConversionRef | Typeconverter to edit a reference to A2LCOMPUMETHOD.
C TCFormatRef | Typeconverter to edit a reference to A2L Format string.
C TCHexType | Typeconverter to display and edit hex values.
C TCMeasurementRef | Typeconverter to edit a reference to a A2LMEASUREMENT.
C TcpSocketWithTimeout | Tcp socket using a configurable connect timeout.
C TCTransformerRef | Typeconverter to edit a reference to A2LTRANSFORMER.
C TCTypedefRef | Typeconverter to edit a reference to A2LTYPEDEF.
C TCUnitRef | Typeconverter to edit a reference to A2LUNIT.
C Header.Time | BLF time representation
C TimeBase | Provides system/application time functions.
C TRBLOCK.TriggerEvent | Trigger event data.
C TypeValueElement | XML element with a TYPE Attribute and a Value text.
▼C UDSClientBase | Implements the UDS client base Application protocol
C UDSClient | Implements the UDS client (Tester) Application protocol
C Program.UDSSim | Implements the UDS ECU simulator.
C UnitSpec | Specification of supported units.
C UnitSpecs | Non serialized class used internally to hold a UnitSpec instance.
C UpdateData | Data structure holding the result of a symbol synchronization between an A2L characteristic/measurement object instance and the symbol file definition.
C UpdaterSymbols | Created symbols by ELF, DWARF or MAP interpretation.
C ValuesReceivedEventArgs | Event arguments used on receiving acquisition data.
C VehicleConnector | Vehicle connector definition.
C VehicleInformation | Vehicle information.
C VG | Holds double, text or group values.
C A2LCANAPE_EXT.VirtualConvType | Virtual conversion definition
C WriteRawDataEventArgs | EVent arguments to request the MDFWriter to write the raw data to the stream.
C WriterException | Exception class representing an ASAP2 Writer exception
C XCPCommModes | Supported communication modes.
C XCPErrorArgs | ErrorArgs class delivering received command errors.
C XCPEventArgs | EventArgs class delivering received events
C XCPPrgParams | Transfer structure holding (XCP) programming parameters.
C XCPReceiveBuffer | Implements a receive buffer for XCP frames
C XCPServiceRequestArgs | EventArgs class delivering received events
C Program.XCPSim | Implements the XCP ECU simulator.
C XDoc | External document definition.
▼C XmlBase | Base implementation for any MDF V4 Xml structure.
▼C CommentBase | Base class for TXBLOCK references
▼C BaseNames | Base class SI and CN comments
C CNcomment | MDF V4 Xml CNBLOCKV4 comment
C SIcomment | MDF V4 Xml SIBLOCKV4 comment
C FHcomment | MDF V4 Xml HDBLOCKV4 comment
C HDcomment | MDF V4 Xml HDBLOCKV4 comment


ASAP2Library interface: LibWrapper.ChannelConfig Struct Reference

  • Comm
  • Vector
  • LibWrapper
  • ChannelConfig
Public Attributes | List of all members
LibWrapper.ChannelConfig Struct Reference

Representation of a channel configuration. More...

Public Attributes

uint | articleNumber
ushort | breakOffset
compensation for edge asymmetry in ns
byte[] | busParams
BusType | busType
ushort | channelBusActiveCapabilities
like channelBusCapabilities (but without core dependencies)
uint | channelBusCapabilities
uint | channelCapabilities
capabilities which are supported (e.g CHANNEL_FLAG_XXX)
byte | channelIndex
Global channel index (0,1,...)
ulong | channelMask
Global channel mask (=1<<channelIndex)
ushort | configError
XL_CHANNEL_CONFIG_ERROR_XXX (see above)
uint | connectedBusType
currently selected bus

byte | connectionInfo
XL_CONNECTION_INFO_XXX.
byte | currentlyAvailableTimestamps
XL_CURRENTLY_AVAILABLE_TIMESTAMP...
ushort | delimiterOffset
compensation for edgdfde asymmetry in ns
byte | dominantRecessiveDelay
Delay in us.
uint | dominantTimeout
Dominant Timeout in us.
uint | doNotUse
uint | driverVersion
byte | fpgaCoreCapabilities
e.g.: XL_FPGA_CORE_TYPE_XXX
byte | hwChannel
Index of the channel (same hardware) (0,1,...)
byte | hwIndex
Index of the hardware (same type) (0,1,...)
HWType | hwType
HWTYPE_xxxx (see above)
uint | interfaceVersion
version of interface with driver
byte | isOnBus
The channel is on bus.
uint | maximalBaudrate
Maximal supported LIN baudrate.
ushort | maximalSupplyVoltage
Maximal Supply Voltage of the Cab/Piggy in 1/100 V.
ushort | minimalSupplyVoltage
Minimal Supply Voltage of the Cab/Piggy in 1/100 V.
byte[] | name
uint[] | raw_data
byte | recessiveDominantDelay
Delay in us.
uint[] | reserved
uint | serialNumber
uint | specialCabFlags
XL_SPECIAL_CAB_LIN_RECESSIVE_STRESS, XL_SPECIAL_CAB_LIN_DOMINANT_TIMEOUT flags.
byte | specialDeviceStatus
e.g.: XL_SPECIAL_DEVICE_STAT_XXX
byte[] | transceiverName
name for CANcab or another transceiver
ushort | transceiverState
transceiver state (XL_TRANSCEIVER_STATUS...)
ushort | transceiverType
TRANSCEIVER_TYPE_xxxx (see above)

Detailed Description

Representation of a channel configuration.

Member Data Documentation

◆ channelBusCapabilities

uint channelBusCapabilities

what buses are supported and which are possible to be activated (e.g. XXX_BUS_ACTIVE_CAP_CAN)


ASAP2Library interface: Member List

  • Comm
  • Vector
  • LibWrapper
  • ChannelConfig
LibWrapper.ChannelConfig Member List

This is the complete list of members for LibWrapper.ChannelConfig, including all inherited members.

articleNumber (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
breakOffset | LibWrapper.ChannelConfig
busParams (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
busType (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
channelBusActiveCapabilities | LibWrapper.ChannelConfig
channelBusCapabilities | LibWrapper.ChannelConfig
channelCapabilities | LibWrapper.ChannelConfig
channelIndex | LibWrapper.ChannelConfig
channelMask | LibWrapper.ChannelConfig
configError | LibWrapper.ChannelConfig
connectedBusType | LibWrapper.ChannelConfig
connectionInfo | LibWrapper.ChannelConfig
currentlyAvailableTimestamps | LibWrapper.ChannelConfig
delimiterOffset | LibWrapper.ChannelConfig
dominantRecessiveDelay | LibWrapper.ChannelConfig
dominantTimeout | LibWrapper.ChannelConfig
doNotUse (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
driverVersion (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
fpgaCoreCapabilities | LibWrapper.ChannelConfig
hwChannel | LibWrapper.ChannelConfig
hwIndex | LibWrapper.ChannelConfig
hwType | LibWrapper.ChannelConfig
interfaceVersion | LibWrapper.ChannelConfig
isOnBus | LibWrapper.ChannelConfig
maximalBaudrate | LibWrapper.ChannelConfig
maximalSupplyVoltage | LibWrapper.ChannelConfig
minimalSupplyVoltage | LibWrapper.ChannelConfig
name (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
raw_data (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
recessiveDominantDelay | LibWrapper.ChannelConfig
reserved (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
serialNumber (defined in LibWrapper.ChannelConfig) | LibWrapper.ChannelConfig
specialCabFlags | LibWrapper.ChannelConfig
specialDeviceStatus | LibWrapper.ChannelConfig
transceiverName | LibWrapper.ChannelConfig
transceiverState | LibWrapper.ChannelConfig
transceiverType | LibWrapper.ChannelConfig


ASAP2Library interface: LibWrapper.DriverConfig Struct Reference

  • Comm
  • Vector
  • LibWrapper
  • DriverConfig
Public Attributes | List of all members
LibWrapper.DriverConfig Struct Reference

Repsentation of a driver configuration More...

Public Attributes

ChannelConfig[] | channel
uint | channelCount
uint | dllVersion
uint[] | reserved

Detailed Description

Repsentation of a driver configuration


ASAP2Library interface: Member List

  • Comm
  • Vector
  • LibWrapper
  • DriverConfig
LibWrapper.DriverConfig Member List

This is the complete list of members for LibWrapper.DriverConfig, including all inherited members.

channel (defined in LibWrapper.DriverConfig) | LibWrapper.DriverConfig
channelCount (defined in LibWrapper.DriverConfig) | LibWrapper.DriverConfig
dllVersion (defined in LibWrapper.DriverConfig) | LibWrapper.DriverConfig
reserved (defined in LibWrapper.DriverConfig) | LibWrapper.DriverConfig


ASAP2Library interface: LibWrapper.ServiceId Struct Reference

  • Comm
  • ETAS
  • LibWrapper
  • ServiceId
Public Attributes | List of all members
LibWrapper.ServiceId Struct Reference

Public Attributes

UuidVersion | access
UuidVersion | api

Detailed Description

Service Identification based on the functional api and access protocol.


ASAP2Library interface: Member List

  • Comm
  • ETAS
  • LibWrapper
  • ServiceId
LibWrapper.ServiceId Member List

This is the complete list of members for LibWrapper.ServiceId, including all inherited members.

access (defined in LibWrapper.ServiceId) | LibWrapper.ServiceId
api (defined in LibWrapper.ServiceId) | LibWrapper.ServiceId


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • A : A2LKWP_TP_BLOB.KWP_SERAM
  • A2LADDRESS() : A2LADDRESS
  • A2LCCP_NAMEDNODE() : A2LCCP_NAMEDNODE
  • A2LCONVERSION_REF() : A2LCONVERSION_REF
  • A2LFormulaDict() : A2LFormulaDict
  • A2LKWP_NAMEDNODE() : A2LKWP_NAMEDNODE
  • A2LNAMEDNODE() : A2LNAMEDNODE
  • A2LNODE() : A2LNODE
  • A2LParser() : A2LParser
  • A2LRECORD_LAYOUT_REF() : A2LRECORD_LAYOUT_REF
  • A2LUNSUPPORTEDNODE() : A2LUNSUPPORTEDNODE
  • A2LXCP_ON_CAN() : A2LXCP_ON_CAN
  • A2LXCP_ON_ETHERNET() : A2LXCP_ON_ETHERNET
  • A2LXCP_ON_TCP_IP() : A2LXCP_ON_TCP_IP
  • A2LXCP_ON_UDP_IP() : A2LXCP_ON_UDP_IP
  • ABLOCKS : PDXIndex
  • AbsoluteDiff : DataLimits
  • Access : DBCFile.EnvironmentType
  • AccessECU : A2LXCP_PAGE
  • AccessMode : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • AccessRead : A2LXCP_PAGE
  • AccessTimingSercice() : UDSClientBase
  • AccessWrite : A2LXCP_PAGE
  • Accuracy : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • ActionService() : CCPMasterBase
  • ActivationResult : RoutingActivationResponse
  • ActivationType : DoIPClient
  • Active : A2LCCP_SOURCE, A2LXCP_DAQ_LIST
  • ActivePage : CommMaster
  • AdaptiveCharList : AdaptiveState
  • add() : A2LFormulaDict, AdaptiveState
  • Add() : DAQCache, MemoryRangeList, AnnotationList
  • addAdaptiveCharacteristics() : CommMaster
  • addAnnotation() : MDFWriter
  • addAppText() : BLFFile
  • addCANFrame() : BLFFile
  • addChild() : A2LNODE
  • addColoredConsoleAppender() : LogManager
  • addDataEntry() : MDFWriter
  • addFrame() : FrameQueue< T >
  • addFromInstance() : A2LADDRESS
  • addIdentifier() : UDSClient
  • addMaxText() : A2LNODE
  • addMeasurement() : ODT, MDFWriter
  • addMeasurements() : MDFWriter
  • addModification() : ODXRoot
  • AddOffset : ICNBLOCK
  • addPresetDAQEvent() : A2LMEASUREMENT
  • addRawData() : MDFWriter
  • Address : A2LADDRESS, A2LCANAPE_ADDRESS_UPDATE.FlashSectionType, A2LCCP_DP_BLOB, IA2LMemory, A2LKWP_DP_BLOB, A2LKWP_KP_BLOB, MemorySegment, DataFileBinDlg, A2LXCP_ON_ETHERNET, CANFrame, CCPFrame, LINFrame, ODTEntry, XCPFrame, XCPMasterBase, SrcDataMemory, UDSFrame, DWARFInfo.SymbolValue, MAPFile.SymbolValue, UpdateData, UpdaterSymbols
  • AddressExt : A2LCCP_DP_BLOB
  • AddressExtension : A2LADDRESS, A2LXCP_SEGMENT
  • Addressing : DiagService
  • AddressOffset : A2LSTRUCTURE_COMPONENT
  • AddressRef : UpdateData
  • AddressSize : CompilationUnitHeader
  • AddrType : A2LTYPEDEF_MEASUREMENT
  • addSignal() : DBCFile.MsgType
  • addSourceInformation() : MDFWriter
  • Adr : ELFFile.ELFSection
  • AdrAlign : ELFFile.ELFSection
  • AdressType : A2LRECORD_LAYOUT.AxisPtsLayoutDesc, A2LRECORD_LAYOUT.FncValuesLayoutDesc
  • AdrFLASH : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM
  • AdrLen : RespWriteMemoryByAddress
  • AdrRAM : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM
  • alignDown() : Extensions
  • Alignment : A2LXCP_ENDPOINT
  • Alignments : A2LMOD_COMMON, A2LRECORD_LAYOUT
  • Alignments_ : A2LRECORD_LAYOUT
  • alignUp() : Extensions
  • AllocDAQ() : XCPMasterBase
  • AllocODT() : XCPMasterBase
  • AllocODTEntry() : XCPMasterBase
  • AlternateSettingNo : A2LXCP_ON_USB
  • AltSampleCounts : A2LXCP_EVENT_DAQ_PACKED_MODE
  • Annotation() : Annotation
  • AppName : Extensions
  • AppVersion : Extensions
  • ArrayDim : DWARFInfo.SymbolValue, UpdaterSymbols
  • ArrayIdx : UpdaterSymbols
  • ArrayOffset : ODTEntry
  • arrayToNum() : Extensions
  • AS : KWP_USDTP_TIMING
  • ASCIIValue() : ASCIIValue
  • AT : Attribute
  • AttribDefObjectType : DBCFile
  • AttribDefType() : DBCFile.AttribDefType
  • AttribDefValueType : DBCFile
  • AttributeDefinitions : DBCFile
  • Attributes : DBCFile, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalType, DBCFile.SourceType, AbbrevEntry
  • AutoSarSinglePointered : A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD
  • axis_monotony : CNcomment
  • AxisIdx : A2LRECORD_LAYOUT.ItemLayoutDesc
  • AxisPts : A2LRECORD_LAYOUT
  • AxisPtsLayoutDesc() : A2LRECORD_LAYOUT.AxisPtsLayoutDesc
  • AxisRescaleX : A2LRECORD_LAYOUT
  • AxisValue : ICharValue, CABLOCKV4


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BASE_TYPE_ENCODING : DiagCodedTypeBase
  • BaseAddress : A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING
  • BaseFrame() : BaseFrame
  • BaseValue() : BaseValue
  • BAUD_DEFs : A2LKWP_TP_BLOB
  • Baudrate : A2LKWP_CAN
  • BaudRate : A2LKWP_TP_BLOB.BAUD_DEF
  • Baudrate : CANConfiguration, LINConfiguration
  • BaudrateFD : CANConfiguration
  • Bind : ELFFile.ELFSymbol
  • BinFileOffset : MemorySegment
  • BitCount : CANFDMessage64
  • Bitmask : A2LCHARACTERISTIC
  • BitMask : A2LMEASUREMENT
  • Bitmask : A2LTYPEDEF_CHARACTERISTIC
  • BitMask : A2LTYPEDEF_MEASUREMENT
  • BitmaskCache : ICNBLOCK
  • BitOffset : ODTEntry, ICNBLOCK, AbbrevEntryMember, UpdaterSymbols
  • BitRateConfig() : CANConfiguration.BitRateConfig
  • BitSTIMSupported : A2LXCP_STIM
  • BLFFile() : BLFFile
  • BlobDict : A2LPROJECT
  • Block : WriteRawDataEventArgs
  • BLOCKBASE() : BLOCKBASE
  • BLOCKBASEV4() : BLOCKBASEV4
  • BlockForMicroSecs() : TimeBase
  • BlockModeID : A2LKWP_SOURCE.QP_BLOB
  • BlockSequenceCounter : RespTransferData
  • BlockSize : IMDFBlock
  • breakOffset : LibWrapper.ChannelConfig
  • Brp : CANConfiguration.BitRatePar
  • BS : KWP_USDTP_TIMING
  • BTLCycles : A2LKWP_CAN, A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • BtrCfgArb : CANFDMessage64
  • BtrCfgData : CANFDMessage64
  • BtrExtArb : CANFDManaged
  • btrExtData : CANFDManaged
  • buildArrayIndexes() : DWARFInfo.SymbolValue
  • buildAssembly() : A2LFormulaDict
  • buildBitmask() : Extensions
  • buildChecksum() : Checksum
  • BuildChecksum() : CCPMasterBase, XCPMasterBase
  • buildDAQMeasurements() : A2LMEASUREMENT
  • buildHtmlFromDescription() : ODXFile
  • buildHtmlTableLine() : Extensions
  • buildNewId() : ODXRoot
  • bus : SIcomment
  • BusId : CANConfiguration
  • BusID : CANFrame, CCPFrame
  • BusId : LINConfiguration
  • BusID : LINFrame, DBCFile.MsgType
  • Bw : WriteRawDataEventArgs
  • ByteOffsetBase : CABLOCKV4
  • ByteOrder : A2LAXIS_DESCR, A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF, A2LXCP_PROTOCOL_LAYER, XCPMaster
  • ByteSize : UpdaterSymbols


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CABlock : CNBLOCKV4
  • CalcMode : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • CalDll : A2LCCP_SEED_KEY
  • CAN_DATA_FRAMES : BLFFile
  • CAN_EXT_FLAG : CANProvider
  • CAN_EXT_ID_MASK : CANProvider
  • CAN_FD_XCP15_FLAG : CANProvider
  • CAN_ID_LIBRARY_VALID_MASK : CANProvider
  • CAN_ID_XCP15_VALID_MASK : CANProvider
  • CAN_STD_ID_MASK : CANProvider
  • Cancel : ProgressArgs
  • CANConfigException() : CANConfigException
  • CANConfiguration() : CANConfiguration
  • CANErrorExt() : CANErrorExt
  • CANEventArgs() : CANEventArgs
  • CANFillerByte : Protocol
  • CANFillerByteHandling : Protocol
  • CANFrame() : CANFrame
  • CANId : A2LKWP_SOURCE.QP_BLOB, DAQList
  • CANIdECU : A2LKWP_ADDRESS
  • CANIDMasterIncremental : A2LXCP_ON_CAN
  • CANIDSort() : CANProvider
  • CANIdTester : A2LKWP_ADDRESS
  • CANProvider() : CANProvider
  • CanWrite : CommMaster
  • Caption : Sdg
  • CATEGORY : CompuMethod, PDXIndex.ABLOCK
  • CCBlock : ICNBLOCK
  • CCPErrorReceived : CCPMaster
  • CCPEventReceived : CCPMaster
  • CCPFrame() : CCPFrame
  • CCPMaster() : CCPMaster
  • CCPMasterBase() : CCPMasterBase
  • CD : KWP_USDTP_TIMING
  • CDBlock : ICNBLOCK
  • CEBlock : ICNBLOCK
  • CGBlock : ICNBLOCK
  • CGBlocks : IDGBLOCK
  • ChangedType : A2LNODE
  • ChangedValues : IDataFile
  • ChangeEndianess : CommMaster
  • changeEndianess() : Extensions
  • ChangeEndianess : CompilationUnitHeader
  • changeEndianness() : RespBase, RespBuildChecksum, RespDownload, RespGetActiveCALPage, IResponse, EventResumeMode, EventResumeModeTS, EventStimTimeout, EventTimeSync, RespBase, RespBuildChecksum, RespConnect, RespDTOCtrResp, RespGetDAQClock, RespGetDAQListInfo, RespGetDAQListMode, RespGetDAQProcessorInfo, RespGetDAQResolutionInfo, RespGetID, RespGetSectorInfoModeAddressOrLen, RespGetSegmentInfoAddress, RespGetStatus, RespReadDAQ, RespTimeCorrelation
  • changeId() : ODXRoot
  • Channel : CANError, CANErrorExt, CANFDMessage, CANFDMessage64, CANMessage, CANConfiguration, FrameEventArgs< T >, LINConfiguration, DependencyType
  • channelBusActiveCapabilities : LibWrapper.ChannelConfig
  • channelBusCapabilities : LibWrapper.ChannelConfig
  • channelCapabilities : LibWrapper.ChannelConfig
  • ChannelGroup : DependencyType
  • channelIndex : LibWrapper.ChannelConfig
  • channelMask : LibWrapper.ChannelConfig
  • ChannelType : ICNBLOCK, CNBLOCKV4
  • Characteristic : ICharValue
  • CharDict : A2LPROJECT
  • CharType : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC, ICharValue
  • checkEPK() : IDataFile
  • checkIdentifier() : DBCFile
  • CheckSum : A2LXCP_CHECKSUM
  • ChecksumType : LINConfiguration
  • Childs : A2LNODE, AbbrevEntry, DWARFInfo.SymbolValue
  • ChkSumType : A2LKWP_CHECKSUM
  • ci : EType, NamesBase
  • clear() : CANFrameQueue
  • Clear() : DAQDict
  • clear() : FrameQueue< T >, LINFrameQueue
  • ClearDAQList() : XCPMasterBase
  • clearData() : DAQDict, DAQList, DAQListXCP
  • ClearDiagnosticInformation() : UDSClientBase
  • ClearMemory() : CCPMasterBase
  • clearServices() : UDSClient
  • ClientCount : IFrameProvider< T >
  • Clock : CANConfiguration.BitRateConfig
  • Clone() : MemorySegment, MemorySegmentList, DataFile, DataFileBin, DataFileHex, DataFileS19
  • close() : CCPonCAN, Communicator, IFrameProvider< T >, ISxIProvider, SxIProvider, XCPOnSxI, XCPonTCP, XCPonUDP, XCPOnUSB
  • CmdBase() : CmdBase
  • CmdId : IsoTp, UDSClientBase
  • CNBlocks : ICGBLOCK, ICNBLOCK, CNBLOCKV4
  • Coeffs : RationalCoeffs
  • Command : CCPErrorArgs, XCPErrorArgs
  • Comment : DBCFile, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalType, DBCFile.SourceType, IMDFComment
  • CommMaster() : CommMaster
  • CommMode : XCPCommModes
  • CommModeInfoResponse : XCPMaster
  • common_properties : CommentBase
  • CommunicationControl() : UDSClientBase
  • Communicator() : DoIPBase.Communicator
  • CompareTo() : BaseValue
  • ComparisonQuantity : A2LCHARACTERISTIC
  • CompDict : A2LPROJECT
  • CompilationUnits : DWARFInfo
  • COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER : A2LXCP_EVENT
  • COMPort : CANConfiguration
  • COMPortConfig : CANConfiguration
  • Compress : MDFWriter
  • CompressionMethod : A2LXCP_SEGMENT
  • CompTabDict : A2LPROJECT
  • COMPU_INTERNAL_TO_PHYS : CompuMethod
  • COMPU_SCALES : CompuInternalToPhys
  • computeAddress() : A2LCCP_TP_BLOB
  • ComputeKeyFromSeed() : NativeSKDLL
  • CompVTabDict : A2LPROJECT
  • CompVTabRangeDict : A2LPROJECT
  • configError : LibWrapper.ChannelConfig
  • configureLogOutput() : LogManager
  • configureMeasurements() : CCPMaster, CommMaster, XCPMaster
  • Connect() : CCPMasterBase, XCPMasterBase
  • ConnectBehaviour : CommMaster
  • Connected : CommMaster
  • connectedBusType : LibWrapper.ChannelConfig
  • connectionInfo : LibWrapper.ChannelConfig
  • ConnectionStateChanged : CommMaster
  • ConnectResponse : CCPMaster, XCPMaster
  • contains() : A2LCCP_DEFINED_PAGES, IA2LMemory
  • Content : A2LUNSUPPORTEDNODE
  • ControlDTCSetting() : UDSClientBase
  • Conversion : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • convertToByte< T >() : Extensions
  • convertToReference< T >() : CCPFrame, Extensions
  • COPY_PARA : A2LKWP_COPY
  • CopyCalPage() : XCPMasterBase
  • copyMemory() : Extensions
  • copyPage2Page() : CCPMaster, CommMaster, XCPMaster
  • CORE_LOAD : A2LXCP_CORE_LOAD
  • CORE_NR : A2LXCP_CORE_LOAD
  • CoreLoadMaxTotal : A2LXCP_DAQ
  • Count : ODTEntry, RespDTCCount
  • CountErrors : A2LParser, ODXRoot, MDFReader
  • CountWarnings : A2LParser, ODXRoot, MDFReader
  • CpuLoadMaxTotal : A2LXCP_DAQ
  • Crc : CANFDMessage64
  • CRC16() : Checksum
  • CRC16CCITT() : Checksum
  • CRC32() : Checksum
  • createBroadcastSocket() : DoIPBase
  • createChannelGroup() : MDFWriter
  • createDefault() : A2LMOD_COMMON
  • createDelegate< T >() : DLLWrapper
  • createInitialMemorySegments() : A2LMODULE
  • createRawData() : DBCFile.MsgType
  • createValue() : CharacteristicValue
  • CREATION_DATE : PDXIndex.FILE
  • CreatorIndex : ATBLOCKV4, EVBLOCKV4
  • CRLF_DELIMITER : Constants
  • Ctr : CCPFrame, XCPFrame
  • Cube4Value() : Cube4Value
  • Cube5Value() : Cube5Value
  • CuboidValue() : CuboidValue
  • CurrentDiagSession : UDSClientBase
  • currentlyAvailableTimestamps : LibWrapper.ChannelConfig
  • CurveValue() : CurveValue
  • CustomFlags : IIDBLOCK
  • Cycle : UDSClient.IdentifierRequest
  • CycleCount : CABLOCKV4


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DAQAlternatingSupported : A2LXCP_DAQ
  • DAQAndEvt() : DAQAndEvt
  • DAQAndEvtMap : A2LXCP_DAQ, XCPMaster
  • DAQClock : XCPMaster
  • DaqDll : A2LCCP_SEED_KEY
  • DAQLastTimestamp : TimeBase
  • DAQList : DAQAndEvt, ODTEntry
  • DAQListNo : ValuesReceivedEventArgs
  • DAQListXCP() : DAQListXCP
  • DAQMeasurement() : DAQMeasurement
  • DAQMemoryLimit : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • DAQNo : A2LXCP_DAQ_LIST_USB_ENDPOINT, DAQList
  • DAQPosition : ODTEntry
  • DAQProcInfo : XCPMaster
  • DAQResolutionInfo : XCPMaster
  • DAQs : CommMaster
  • DAQSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • Data : MemorySegment, CANFDManaged, RestorePointContainerManaged, SysVariableManaged, CANConfiguration.BitRateConfig, Frame, ValuesReceivedEventArgs, SxIEventArgs, RespData, FlashDataIntern, RawDataRecord
  • DATA_ : FlashDataIntern
  • DATA_ACCESS : A2LKWP_TP_BLOB
  • DataBytesPerLine : DataFile
  • DataChunks : MeasurementAccessData
  • DataContainerV4() : DataContainerV4
  • DataFile : MemorySegment, DataFile
  • DataFileBin() : DataFileBin
  • DataFileBinDlg() : DataFileBinDlg
  • DataFileHex() : DataFileHex
  • DataFileS19() : DataFileS19
  • DataGroup : DependencyType
  • DataLength : RestorePointContainer, SysVariable
  • DataOffset : ODTEntry
  • DataPage : J1939Frame
  • DataPoint() : DataPoint
  • DataPointF() : DataPointF
  • dataReceived() : XCPCommunicator
  • DataReceived : MDFWriter
  • DataStream() : DataStream
  • DataTransferBaudrate : A2LXCP_CAN_FD
  • DataType : A2LMEASUREMENT, A2LRECORD_LAYOUT.ItemLayoutDesc, A2LTYPEDEF_MEASUREMENT, SysVariable, DBCFile.AttribDefType, DBCFile.SignalType
  • Date : CCBLOCK
  • DBCFile() : DBCFile
  • DecimalCount : A2LCONVERSION_REF, ICharValue
  • DecimalCountAxis : ICharValue
  • decrement() : ICharValue
  • DefaultEntityAdr : DoIPClient
  • DefaultPageNumber : A2LXCP_SEGMENT
  • DefaultPort : DoIPBase
  • DefaultTesterAdr : DoIPClient
  • DefaultText : ICCBLOCK
  • DefaultTLSPort : DoIPBase
  • DefFunctionDict : A2LPROJECT
  • Delaytime : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • deleteFromModel() : A2LNODE
  • deleteNode() : A2LREFERENCE
  • delimiterOffset : LibWrapper.ChannelConfig
  • DependencyType : CDBLOCK
  • Deposit : A2LTYPEDEF_AXIS
  • DeregisterClient() : CommKernel
  • DESC : COMParamRef, LimitBase, NamedDescId
  • desc : EBase
  • Description : A2LADDRESS, IA2LDescription, COMParamRef, IDescription, LimitBase, NamedDescId, ICNBLOCK
  • DescriptionAddition : AdditiveDescriptionEventArgs
  • deserialize< T >() : Extensions
  • DesiredEventChannels : DAQMeasurement
  • DGBlock : ICGBLOCK
  • DGBlocks : IHDBLOCK
  • DiagMode : A2LKWP_TP_BLOB.BAUD_DEF
  • DiagnoseRequest() : DoIPClient
  • DiagnosticPowerMode() : DoIPClient
  • DiagnosticSessionControl() : UDSClientBase
  • DiagService() : CCPMasterBase
  • DIM : CEBLOCK
  • DimSize : CABLOCKV4
  • Dir : CANFDMessage64
  • Disconnect() : CCPMaster, CCPMasterBase, CommMaster, XCPMaster, XCPMasterBase
  • Discrete : A2LCHARACTERISTIC, A2LMEASUREMENT, A2LTYPEDEF_CHARACTERISTIC, A2LTYPEDEF_MEASUREMENT
  • Discriminator : A2LKWP_SOURCE.QP_BLOB
  • Display : A2LCANAPE_EXT
  • DisplayName : A2LADDRESS, IA2LDescription
  • Dispose() : A2LParser, DataFile, _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, CCPMaster, CCPonCAN, CommMaster, Communicator, FrameProvider< T, V >, FrameQueue< T >, ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, VectorLIN, SxIProvider, XCPCommunicator, XCPMaster, UDSClient, UDSClientBase, DLLWrapper, DataReader, MDFReader, MDFWriter, ELFFile
  • DistOp : A2LRECORD_LAYOUT
  • Dlc : CANErrorExt, CANFDMessage64
  • DLC : LINConfiguration, DBCFile.MsgType
  • dlcToLength() : CANProvider
  • Dll : A2LCCP_CHECKSUM
  • DLLWrapper() : DLLWrapper
  • DOCTYPE : IdRef
  • DoIPBase() : DoIPBase
  • DoIPClient() : DoIPClient, UDSClientBase
  • DoIPServer() : DoIPServer
  • dominantRecessiveDelay : LibWrapper.ChannelConfig
  • dominantTimeout : LibWrapper.ChannelConfig
  • doPlausibilityCheck() : DBCFile
  • DopRef : ParSystem, ParValue
  • Download() : CCPMasterBase, XCPMasterBase
  • download() : UDSClient
  • Download6() : CCPMasterBase
  • DownloadMax() : XCPMasterBase
  • DownloadNext() : XCPMasterBase
  • Dst : A2LCANAPE_ADDRESS_UPDATE.AdrMapType
  • DstAdr : DoIPClient, SrcDstFrame
  • DstOffset : FHBLOCKV4, HDBLOCKV4
  • DTC : DTCAndStatusRecord
  • DTCs : RespDTCRecords, RespDTCSeverityRecords
  • DTCS_ : DtcDop
  • DtoCtrProperties() : XCPMasterBase
  • Duration : Header
  • Dwarf : ELFFile
  • DynamicallyClearDataIdentifier() : UDSClientBase
  • DynamicallyDefineDataIdentifierByAdr() : UDSClientBase
  • DynamicallyDefineDataIdentifierById() : UDSClientBase


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • E : A2LKWP_TP_BLOB.KWP_SERAM
  • Ecc : CANErrorExt
  • EccFlagsType : CANErrorExt
  • ECU_CALIBRATION_OFFSET : A2LCANAPE_ADDRESS_UPDATE
  • ECUAddress : A2LKWP_TP_BLOB
  • EcuReset() : UDSClientBase
  • EID : VehicleIdResponse
  • Elapsed : Frame, TimeBase
  • ElapsedDAQSeconds : TimeBase
  • ElapsedTicks : TimeBase
  • ELM327CmdTimeout : CANConfiguration
  • ELM327Protocol : CANConfiguration
  • ELMNname : ELM327CAN
  • Encoding : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC
  • EncryptionMethod : A2LXCP_SEGMENT
  • Ended : Header
  • EndiannessType : ELFFile
  • EndLine : A2LNODE
  • EndPointNo : RespGetDAQListUSBEndpoint
  • enqueueFrame() : CANFrameQueue, J1939FrameQueue, CCPFrameQueue, LINFrameQueue, XCPFrameQueue, DoIPFrameQueue, UDSFrameQueue
  • Entities : DoIPClient
  • Entity : AnnoncementEventArgs
  • EntityAnnounced : DoIPClient
  • EntityStatus() : DoIPClient
  • EntrySize : DWARFInfo.SymbolValue
  • EntSize : ELFFile.ELFSection
  • Enum : DBCFile.ValueTable
  • enumArraySamples() : MDFReader
  • enumCANFrames() : BLFFile
  • enumChildNodes< T >() : A2LNODE
  • enumObjects() : BLFFile
  • Enums : DBCFile.AttribDefType, DBCFile.SignalType
  • enumSamples() : MDFReader
  • enumSymbols() : DWARFInfo.SymbolsTree
  • EnvAccessType : DBCFile
  • Environments : DBCFile
  • EnvironmentType() : DBCFile.EnvironmentType
  • EnvType : DBCFile
  • EPK : DataFileBin
  • EPK_ADDRESS : A2LCANAPE_ADDRESS_UPDATE
  • EPKAddress : DataFileBin
  • EPKCheck() : DataFile
  • epkCheck() : CommMaster
  • EPNo : A2LXCP_DAQ_LIST_USB_ENDPOINT, A2LXCP_ENDPOINT
  • EPPollInterval : A2LXCP_ENDPOINT
  • EPType : A2LXCP_DAQ_LIST_USB_ENDPOINT
  • ErrorCode : CCPErrorArgs, CCPEventArgs, RespError, XCPErrorArgs, RespBase
  • ErrorMask : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • ErrorsReceived : CommMaster
  • eval() : IEvaluator
  • Event : DoIPBase.Communicator
  • EventBase() : EventBase
  • EventFixed : A2LXCP_DAQ_LIST
  • Events : A2LXCP_DAQ_EVENT, A2LXCP_EVENT_LIST
  • EventsReceived : CommMaster
  • EventWindowTime : RespResponseOnEvent
  • EVersion : A2LKWP_TP_BLOB
  • Evt : DAQAndEvt, DAQListXCP
  • EvtNo : A2LXCP_EVENT_CAN_ID_LIST, DAQList
  • ExchangeID() : CCPMasterBase
  • ExchangeIDResponse : CCPMaster
  • ExchangeIDStr : CCPMaster
  • ExDataPage : J1939Frame
  • executeAliveRequests() : DoIPServer
  • executeService< T >() : UDSClientBase
  • expandSymbol() : DWARFInfo
  • ExtDataOffset : CANFDMessage64
  • ExternalFunction : A2LXCP_CHECKSUM
  • ExternalReferences : ODXRoot


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • Factor : RationalCoeffs, DBCFile.SignalType
  • FDBitRateConfig : CANConfiguration
  • FdFlags : CANFDMessage64
  • FILE_CACHE : Constants
  • FileID : IIDBLOCK
  • FileName : A2LParser
  • FilePath : DLLWrapper
  • FILES : PDXIndex.ABLOCK
  • FillByte : IsoTp, UDSClientBase
  • fillMemory() : Extensions
  • findCALPage() : A2LCCP_TP_BLOB
  • findId() : ODXRoot
  • findMemSeg() : IDataFile, MemorySegmentList, DataFile
  • findNode() : A2LNODE
  • findNode< T >() : A2LNODE
  • findPage() : A2LCCP_TP_BLOB
  • findRangeIndex() : MemoryRangeList
  • First : A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
  • FirstPID : DAQList
  • FixedCANIds : A2LXCP_EVENT_CAN_ID_LIST
  • FixNoAxisPts : A2LRECORD_LAYOUT
  • fixRationalParameters() : MDFReader
  • Flags : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM, CANErrorExt, DBCFile.SignalType, CNBLOCKV4, ELFFile.ELFSection
  • FlagsType : CANErrorExt, ELFFile
  • FlashSection : A2LCANAPE_ADDRESS_UPDATE.ExSymbolType
  • FLASHToRAMDiagMode : A2LKWP_COPY, A2LKWP_FLASH_COPY
  • FLASHToRAMMode : A2LKWP_COPY, A2LKWP_FLASH_COPY
  • FloatType : DBCFile.SignalType
  • FncValues : A2LRECORD_LAYOUT
  • ForbiddenDict : A2LVAR_FORBIDDEN_COMB
  • ForbiddenDict_ : A2LVAR_FORBIDDEN_COMB
  • FORM : Attribute
  • Format : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • FormatIdentifier : RespDTCCount
  • FormatType : ELFFile
  • Formula : ICCBLOCK
  • FormulaDict : A2LPROJECT
  • fpgaCoreCapabilities : LibWrapper.ChannelConfig
  • Frame : CANEventArgs, Frame, FrameEventArgs< T >, LINEventArgs, RespBase
  • FrameDict : CANFrameQueue, LINFrameQueue
  • FrameEnqueued : FrameQueue< T >
  • FrameFmt : XCPCommunicator
  • FrameLength : CANFDMessage64
  • FrameLengthInNs : CANErrorExt
  • FramesReceived : CommMaster
  • FramesSent : CommMaster
  • FreeDAQ() : XCPMasterBase
  • freezePage() : XCPMaster
  • fromHexStr() : Extensions
  • FromNICANId() : CANProvider
  • FuncDict : A2LPROJECT
  • FuncReqCANId : Protocol
  • FurtherAction : VehicleIdResponse


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GetActiveCALPage() : CCPMasterBase
  • getAddress() : A2LRECORD_LAYOUT_REF
  • getAddressOffset() : A2LMEASUREMENT
  • getAlignment() : A2LRECORD_LAYOUT
  • getAliveCycleTime() : CCPMasterBase, CommMaster, XCPMasterBase
  • getAnnotations() : MDFReader
  • getArrayElementCount() : DWARFInfo.SymbolValue
  • getArraySize() : A2LMEASUREMENT
  • getAttribute() : AbbrevEntry
  • getAvailableCOMPorts() : Extensions
  • GetAvailableHardware() : IFrameProvider< T >
  • GetAvailablePrivileges() : NativeSKDLL
  • getAxisDescription() : DataConservation
  • getBitOffset() : AbbrevEntry
  • getBroadcastIp() : DoIPBase
  • getBusload() : ICANProvider
  • getByteLenFromBitLen() : Extensions
  • getByteSize() : AbbrevEntry
  • GetCalPage() : XCPMasterBase
  • getCCPInterface() : A2LMODULE
  • GetCCPVersions() : CCPMasterBase
  • getChecksum() : CCPMaster, CommMaster, XCPMaster
  • GetCommModeInfo() : XCPMasterBase
  • getCommModes() : A2LXCP_NODE
  • getCompuMethod() : A2LNODE
  • getContext() : A2LNODE
  • getCountMessages() : DBCFile
  • getCountSignals() : DBCFile
  • getCountSources() : DBCFile
  • getCurrentValue() : ODTEntry
  • getCycleTime() : A2LCCP_NODE, A2LXCP_NODE
  • GetDAQClock() : XCPMasterBase
  • GetDAQClockMulitcast() : XCPMasterBase
  • GetDAQEventInfo() : XCPMasterBase
  • GetDAQID() : XCPMasterBase
  • GetDAQListInfo() : XCPMasterBase
  • GetDAQListMode() : XCPMasterBase
  • GetDAQListUSBEndpoint() : XCPMasterBase
  • getDAQPhysValue() : CommMaster
  • GetDAQProcessorInfo() : XCPMasterBase
  • getDAQRawValue() : CommMaster
  • GetDAQResolutionInfo() : XCPMasterBase
  • GetDAQSize() : CCPMasterBase
  • getDAQTime() : TimeBase
  • getData() : MeasurementAccessData, DAQCache, DAQStore, ODTEntry, MDFReader, ELFFile.SectionList, ELFFile.SectionValue
  • getDataASCIIStr() : Frame
  • getDataBytes() : MemorySegment
  • getDataF() : MDFReader
  • getDataFfromMemory() : MDFReader
  • getDataFromArray() : CANProvider
  • getDatafromMemory() : MDFReader
  • getDataSections() : ELFFile.SectionList
  • getDataStr() : Frame
  • getDecimalCount() : A2LCONVERSION_REF
  • getDefCharacteristicFunction() : A2LRECORD_LAYOUT_REF
  • getDescriptionAndAnnotation() : A2LADDRESS, A2LAXIS_PTS, A2LCHARACTERISTIC, A2LCOMPU_METHOD, A2LCOMPU_TAB_BASE, A2LFRAME, A2LINSTANCE, A2LMEASUREMENT, A2LMEMORY_SEGMENT, A2LMOD_PAR, A2LMODULE, A2LNODE, A2LPROJECT, A2LREFBASE, A2LREFERENCE, A2LTYPEDEF, A2LUNIT, A2LVAR_CRITERION, IA2LDescription
  • getDTC() : ODXRoot
  • getDTCs() : ODXRoot
  • getErrorCode() : ParNrcConst
  • getFiles() : PDXIndex
  • getFirstPID() : DAQDictXCP
  • getFncValue() : ICharValue
  • getFncValue< T >() : ICharValue
  • GetFncValuesEnumerator() : ICharValue, BaseValue
  • getFrameFromData() : XCPCommunicator, XCPonEth, XCPOnSxI, XCPOnUSB, XCPReceiveBuffer
  • getFrames() : FrameQueue< T >
  • getFunction() : CToCSharpMath
  • getID() : XCPMaster
  • GetID() : XCPMasterBase
  • getIDFieldSize() : A2LXCP_DAQ
  • getLength() : MDFReader
  • GetLogger() : LogManager
  • getMemoryRanges() : A2LMODULE
  • getMemorySegment() : A2LRECORD_LAYOUT_REF
  • getMemorySize() : A2LADDRESS, A2LBLOB, A2LINSTANCE, A2LMEASUREMENT, A2LRECORD_LAYOUT_REF
  • getMinIncrement() : A2LCOMPU_METHOD
  • getMultiplexSignal() : DBCFile.MsgType
  • getNearestDataFile() : DataFile
  • getNegResCode() : UDSClient
  • getNegResCodes() : ODXRoot
  • getNextValue() : BaseValue
  • getNode< T >() : A2LNODE
  • getNodeDepth() : A2LNODE
  • getNodeList< T >() : A2LNODE
  • getNumberOfElements() : A2LCHARACTERISTIC
  • getODTEntry() : DAQDict
  • getOperatingPoint() : CommMaster
  • getOverviewAsHtml() : ODXFile
  • getPaddingSize() : XCPMasterBase
  • GetPageInfo() : XCPMasterBase
  • getPages() : A2LCCP_TP_BLOB
  • GetPAGProcessorInfo() : XCPMasterBase
  • getParent< T >() : A2LNODE, AbbrevEntry
  • getPDXRoot() : ODXFile
  • GetPGMProcessorInfo() : XCPMasterBase
  • getPhysValue() : MeasurementAccessData
  • getPresetDAQEvent() : A2LMEASUREMENT
  • getPresetDAQEvents() : A2LMEASUREMENT
  • GetProcAddress() : DLLWrapper
  • getRawData() : MDFReader
  • getRawFrameLength() : CANFrame, CCPFrame, XCPFrame
  • getRawValue() : MeasurementAccessData, DBCFile.SignalType
  • getReadPosition() : ICNBLOCK
  • getRecordSize() : ICGBLOCK
  • getRefFunctions() : A2LCONVERSION_REF, A2LNODE, A2LRECORD_LAYOUT
  • getRefNodes() : A2LAXIS_PTS, A2LCOMPU_METHOD, A2LCOMPU_TAB_BASE, A2LINSTANCE, A2LMEASUREMENT, A2LMEMORY_LAYOUT, A2LMEMORY_SEGMENT, A2LNODE, A2LRECORD_LAYOUT, A2LTRANSFORMER, A2LTYPEDEF
  • getRWIndicator() : Frame
  • getSamplePointCount() : MDFReader
  • getSection() : ELFFile
  • GetSectorInfo() : XCPMasterBase
  • getSecurityAccessRequests() : ODXRoot
  • GetSeed() : CCPMasterBase, XCPMasterBase
  • GetSegmentInfo() : XCPMasterBase
  • GetSegmentInfoAddress() : XCPMasterBase
  • GetSegmentInfoMapping() : XCPMasterBase
  • GetSegmentMode() : XCPMasterBase
  • getSendMsgLen() : CANProvider
  • getService() : ODXRoot
  • getServices() : ODXRoot
  • getSettings() : A2LXCP_MEDIA
  • getShiftCount() : Extensions
  • getSignal() : DBCFile.MsgType
  • getSingleRawValue() : Extensions
  • getSingleRawValueBuffer() : Extensions
  • getSize() : A2LAXIS_PTS, A2LCHARACTERISTIC, A2LRECORD_LAYOUT_REF, AbbrevEntry
  • getSizeInBit() : Extensions
  • getSizeInByte() : Extensions
  • getSlaveIDs() : XCPMaster
  • getStatistics() : BLFFile
  • GetStatus() : CCPMasterBase, XCPMasterBase
  • getSupportedProtocols() : EcuVariant
  • getSymbols() : A2LPROJECT
  • getSymTabs() : ELFFile.SectionList
  • getTimestamp() : LObj
  • getTimeStr() : Frame
  • getTransmissionRate() : CommMaster
  • getTrimmedText() : Extensions
  • getTSSize() : RespGetDAQResolutionInfo
  • getTypeRef() : DWARFInfo
  • getTypeStr() : CCPFrame, XCPFrame, DWARFInfo
  • getUnreadFrames() : FrameQueue< T >
  • getUsageInPercent() : MemorySegment
  • getUsedBytes() : MemorySegment
  • getValue() : ODTEntry
  • getValue< T >() : CharacteristicValue
  • getValuesToSynchronize() : ELFFile, MAPFile, SymbolFile
  • getVariable() : AbbrevEntry
  • getVariant() : ODXRoot
  • getVariants() : ODXRoot
  • getXCPInterfaces() : A2LMODULE
  • getXCPSettings() : A2LMODULE
  • getXmlSerializer() : Extensions
  • GID : VehicleIdResponse
  • GroupDict : A2LPROJECT
  • GroupMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • GuardRails : A2LRECORD_LAYOUT_REF


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HardwareId : CANConfigException
  • HardwareType : CANConfiguration, LINConfiguration
  • HasChilds : AbbrevEntry
  • hasSent() : CANProvider, LINProvider
  • HasSubfunction() : ServiceProperties
  • HasTypeInfo : AbbrevEntry
  • Header : BLFFile, MDFReader, ELFFile
  • HeaderLen : A2LXCP_ON_USB
  • HostBufferSize : A2LXCP_ENDPOINT
  • HostName : A2LXCP_ON_ETHERNET
  • hwChannel : LibWrapper.ChannelConfig
  • hwIndex : LibWrapper.ChannelConfig
  • hwType : LibWrapper.ChannelConfig


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Id : CANErrorExt, CANFDMessage64
  • ID : CANFrame, CCPFrame, LINFrame, DBCFile.MsgType, DBCFile.SignalGroupType, UDSFrame, IId, MDFReader
  • Id : BLOCKBASE, BLOCKBASEV4
  • IDBLOCK() : IDBLOCK
  • IDBLOCKV4() : IDBLOCKV4
  • Identification : A2LRECORD_LAYOUT
  • Identifier : RespDynamicallyDefine, RespIdentfier, SrcDataIdentifier, IdentifierRecord
  • IdentifierMatch : Extensions
  • IdentifierRegEx : Extensions
  • IdentifierRequest() : UDSClient.IdentifierRequest
  • Identifiers : DiagService
  • IDString : DBCFile.MsgType
  • ik : A2LKWP_TP_BLOB.BAUD_DEF
  • import() : IDataFile, DataFile
  • InCircuit2 : A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD
  • IncludedFiles : A2LParser
  • increment() : ICharValue
  • incrementOrDecrement() : BaseValue, CuboidValue, CurveValue, MapValue, SingleValue, ValBlkValue
  • Index : DAQMeasurement, ODTEntry, DBCFile.EnvironmentType, MAPFile.SymbolValue
  • IndexMode : A2LRECORD_LAYOUT.FncValuesLayoutDesc
  • IndexOrder : A2LRECORD_LAYOUT.AxisPtsLayoutDesc
  • Info : ELFFile.ELFSection
  • Initialize() : RespBase, RespData, RespDTCCount, RespDTCRecords, RespDTCSeverityRecords, RespDynamicallyDefine, RespIdentfier, RespRequestUpDownload, RespReset, RespResponseOnEvent, RespRoutineControl, RespSecurityAccess, RespSession, RespSFBase, RespTimingParameter, RespTransferData, RespWriteMemoryByAddress
  • initialize() : BaseVariant, DataObjectProp, DiagService, EcuSharedData, EcuVariant, EndOfPDUField, Id, IId, Mux, ParamContainer, ParIdBase, Protocol, ProtStack, Session, Structure
  • InitProtocol : ELM327CAN
  • InputOutputControlByIdentifier() : UDSClientBase
  • InputQuantity : A2LTYPEDEF_AXIS
  • Instance : CANFrameQueue, J1939FrameQueue, CCPFrameQueue, LINFrameQueue, XCPFrameQueue, DoIPFrameQueue, UDSFrameQueue
  • InstanceDict : A2LPROJECT
  • Interface : CommMaster
  • InterfaceDescriptor : A2LXCP_ON_USB
  • Interfaces : DoIPClient
  • interfaceVersion : LibWrapper.ChannelConfig
  • internalConnect() : CCPMasterBase, CommMaster, XCPMasterBase
  • internalGetStatus() : CCPMasterBase, CommMaster, XCPMasterBase
  • InvalBitPosBase : CABLOCKV4
  • InvalSize : CGBLOCKV4
  • InvCCBlock : ICCBLOCK
  • IPV6 : A2LXCP_ON_ETHERNET
  • Is64Bit : CompilationUnitHeader
  • isAllowedRequest() : CCPMaster, CCPMasterBase, XCPMaster
  • isAvailable() : _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider
  • IsBitfield : UpdaterSymbols
  • IsCANIdValid() : CANProvider
  • IsDAQ : CCPFrame, XCPFrame
  • isDAQDynamic() : A2LXCP_DAQ
  • IsDAQRunning : CCPMaster, XCPMaster
  • IsDataSegment : MemorySegment
  • IsDeclaration : AbbrevEntry
  • IsDirty : IDataFile
  • IsError : CCPFrame, XCPFrame, BaseFrame, UDSFrame
  • IsExpanded : DWARFInfo.SymbolValue
  • IsExtendedID : CANFrame
  • IsExternal : AbbrevEntryVariable
  • IsExternalSymbol : AbbrevEntryVariable
  • IsFirstPID : ODT
  • IsFixed : A2LXCP_TIMESTAMP_SUPPORTED
  • IsFormatNotSet : A2LAXIS_DESCR, A2LCONVERSION_REF
  • IsInitialized : MemorySegment
  • IsInstanced : A2LNODE
  • IsLittleEndian : DBCFile.SignalType
  • IsMasterFrame : Frame
  • isMemoryIn() : MemorySegment
  • IsMultiplexed : DBCFile.SignalType
  • IsMultiplexSignal : DBCFile.SignalType
  • isOnBus : LibWrapper.ChannelConfig
  • IsoTp() : IsoTp
  • IsoTpFSM() : IsoTpFSM
  • IsPrototyped : AbbrevEntry
  • isReadOnly() : A2LRECORD_LAYOUT_REF
  • IsReadOnly : IA2LMemory
  • IsRegistered() : CommKernel
  • IsSigned : DBCFile.SignalType
  • isSlaveBlockMode() : XCPMaster
  • IsStoring : RespGetStatus
  • IsString : A2LCOMPU_METHOD
  • IsSymbol : AbbrevEntryVariable
  • isUpdateRequired() : AdaptiveState
  • IsValid : DBCFile.MsgType
  • isValidDesignator() : Extensions
  • IsWritingToFile : FrameQueue< T >


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • J1939Frame() : J1939Frame


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • K_LINE : A2LKWP_TP_BLOB
  • KeepDuplicateNodes : A2LParser
  • Key : VehicleIdResponse
  • KeyValuePairs : ICCBLOCK


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Language : AbbrevEntryCU
  • Last : A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
  • LastDiagNackCode : DoIPBase
  • LastElapsedTicks : AdaptiveState
  • LastErrorEnum : CommMaster
  • LastErrorResponse : CCPMasterBase, XCPMasterBase
  • LastErrorText : CommMaster
  • LastNackCode : DoIPBase
  • LastReceivedTime : CommMaster
  • LastResponse : CCPMasterBase, XCPMasterBase, UDSClient.IdentifierRequest
  • LastStateChange : CommMaster
  • LastUpdate : DBCFile.MsgType, DBCFile.SignalType, UDSClient.IdentifierRequest
  • LATEBOUND_DATAFILE : DataFile
  • Layout : A2LINSTANCE, A2LMEASUREMENT, A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_MEASUREMENT
  • LayoutEntries : A2LRECORD_LAYOUT
  • Len : CCPFrame, XCPFrame, DBCFile.SignalType, UDSFrame
  • Length : A2LCANAPE_ADDRESS_UPDATE.FlashSectionType, A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING, A2LKWP_DP_BLOB, CANError, CANErrorExt, DZBLOCKV4, CompilationUnitHeader
  • lengthToDLC() : CANProvider
  • LenOfTimeInt : ISRBLOCK
  • Limit : A2LCCP_CHECKSUM_PARAM
  • LINConfiguration() : LINConfiguration
  • LinesMax : A2LParserProgressEventArgs
  • LinesProcessed : A2LParserProgressEventArgs
  • LINEventArgs() : LINEventArgs
  • LINFrame() : LINFrame
  • Link : ELFFile.ELFSection
  • LinkCG : DependencyType
  • LinkCN : DependencyType
  • LinkControl() : UDSClientBase
  • LinkDG : DependencyType
  • linker_address : CNcomment
  • linker_name : CNcomment
  • LinkMap : A2LCANAPE_EXT
  • LINProvider() : LINProvider
  • load() : DataFile, DataFileBin, DataFileHex, DataFileS19
  • LocalEp : DoIPServer
  • LocalIp : DoIPClient
  • LocalRoutineNo : A2LKWP_CHECKSUM, A2LKWP_ROUTINE_PARA
  • Location : A2LKWP_KP_BLOB, AbbrevEntryVarBase
  • LogFileCSVHeader : FrameQueue< T >
  • LogFileName : FrameQueue< T >
  • LogicalAdr : DoIPServer, VehicleIdResponse
  • LogUnsupportedNodes : A2LParser
  • LowerLimit : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • LowerLimitEx : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MachineType : ELFFile
  • mAdaptiveCharDict : CommMaster
  • mAG : XCPMasterBase
  • Main() : Program
  • MajorVersion : A2LParser
  • mapAddress() : A2LMOD_PAR
  • MapAddress : A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING
  • mapAddress() : CCPMaster, CommMaster, XCPMaster
  • MapValue() : MapValue
  • Mask : DBCFile.SignalType
  • MasterID : LINConfiguration
  • MasterLimits : MDFReader
  • MatrixDim : A2LCHARACTERISTIC, A2LINSTANCE, A2LMEASUREMENT, A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_CHARACTERISTIC, A2LTYPEDEF_MEASUREMENT
  • Max : DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, DataLimits, sRange, ICCBLOCK, ICNBLOCK
  • max : RasterType
  • MAX_DLC : CANProvider
  • MAX_FD_DLC : CANProvider
  • MAX_FRAMES_IN_MEMORY : Constants
  • MAX_POINTS_IN_MEMORY : Constants
  • MAX_UNCOMPRESSED_ZIP : Constants
  • MaxAxisPoints : A2LTYPEDEF_AXIS
  • MaxBitRate : A2LXCP_ON_ETHERNET
  • MaxBlockSize : A2LXCP_CHECKSUM
  • MaxBS : XCPCommModes
  • MaxBusLoad : A2LXCP_MEDIA
  • MaxCTO : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • MaxDAQ : A2LXCP_DAQ
  • MaxDAQTotal : A2LXCP_DAQ
  • MaxDataSize : EntityStatusResponse
  • MaxDiff : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • MaxDLC : A2LXCP_CAN_FD
  • MaxDLCRequired : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • MaxDTO : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • MaxDTOStim : A2LXCP_PROTOCOL_LAYER
  • MaxEvtChn : A2LXCP_DAQ
  • MaxEx : ICNBLOCK
  • maximalBaudrate : LibWrapper.ChannelConfig
  • maximalSupplyVoltage : LibWrapper.ChannelConfig
  • MaxLength : AnnotationList
  • MaxMsgLen : IsoTp, UDSClientBase
  • MaxNoOfBytes : A2LKWP_SOURCE.QP_BLOB
  • MaxNoOfSignals : A2LKWP_SOURCE.QP_BLOB
  • MaxNoRescalePairs : A2LRECORD_LAYOUT.AxisRescaleLayoutDesc
  • MaxNumberOfBlockLength : RespRequestUpDownload
  • MaxODTDAQTotal : A2LXCP_DAQ
  • MaxODTEntriesDAQTotal : A2LXCP_DAQ
  • MaxODTEntriesSTIMTotal : A2LXCP_DAQ
  • MaxODTEntriesTotal : A2LXCP_DAQ
  • MaxODTEntrySize : A2LXCP_DAQ
  • MaxODTSTIMTotal : A2LXCP_DAQ
  • MaxODTTotal : A2LXCP_DAQ
  • MaxPktSize : A2LXCP_ENDPOINT
  • MaxRaw : ICNBLOCK
  • MaxSamplingRate : A2LKWP_SOURCE.QP_BLOB
  • MaxSockets : EntityStatusResponse
  • mConfig : CANProvider, LINProvider
  • mDataFiles : CommMaster
  • mDefaultCompuMethod : A2LCOMPU_METHOD
  • MDFWriter() : MDFWriter
  • MeasDict : A2LPROJECT
  • Measurement : DAQMeasurement, ODTEntry
  • MeasurementAccessData() : MeasurementAccessData, CommMaster
  • MeasuremntMode : A2LKWP_SOURCE.QP_BLOB
  • MemoryAddress : RespWriteMemoryByAddress
  • MemoryRange() : MemoryRange
  • MemoryRanges : AdaptiveState, MeasurementAccessData
  • MemorySegment() : MemorySegment
  • MemorySegmentList() : MemorySegmentList
  • MemorySize : RespWriteMemoryByAddress, SrcDataIdentifier
  • Message : ParserEventArgs
  • Messages : DBCFile.SourceType
  • mHandle : DLLWrapper
  • MIME_TYPE : PDXIndex.FILE
  • Min : DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, DataLimits, sRange, ICCBLOCK, ICNBLOCK
  • min : RasterType
  • MinDAQ : A2LXCP_DAQ
  • MinEx : ICNBLOCK
  • minimalSupplyVoltage : LibWrapper.ChannelConfig
  • MinorVersion : A2LParser
  • MinRaw : ICNBLOCK
  • MinST : XCPCommModes
  • MinSTSTIM : A2LXCP_STIM
  • mMaster : XCPCommunicator
  • Mode : A2LKWP_PAGE_SWITCH, A2LXCP_DAQ, CANConfiguration
  • ModelChanged : A2LPROJECT
  • ModelLink : A2LADDRESS
  • modifyAddFunc() : CharacteristicValue
  • modifyBits() : XCPMaster
  • ModifyBits() : XCPMasterBase
  • modifyDivFunc() : CharacteristicValue
  • modifyInvFunc() : CharacteristicValue
  • modifyMulFunc() : CharacteristicValue
  • modifySetFunc() : CharacteristicValue
  • modifySubFunc() : CharacteristicValue
  • modifyValue() : ICharValue
  • Monotony : A2LOVERWRITE, A2LTYPEDEF_AXIS
  • Move() : CCPMasterBase
  • mRxEvent : FrameProvider< T, V >
  • Msg : DBCFile.SignalType
  • MsgType() : DBCFile.MsgType
  • mStrTrimmer : CommMaster
  • MTABlockSizeAlign : A2LXCP_CHECKSUM
  • MultiplexValue : DBCFile.SignalType
  • mVersion : DoIPBase


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name : A2LCANAPE_ADDRESS_UPDATE.SymbolType, A2LCANAPE_EXT, A2LNAMEDNODE, A2LNODE, A2LCCP_NAMEDNODE, IA2LDescription, A2LKWP_NAMEDNODE, A2LXCP_NAMEDNODE, SysVariableManaged, DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalGroupType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, IdentifierRecord, IMDFBlock, BLOCKBASEV4
  • name : EBase
  • Name : AbbrevEntry, DWARFInfo.SymbolValue, ELFFile.ELFSection, ELFFile.SectionValue, ELFFile.SymbolValue, MAPFile.SymbolValue
  • NameChanged : DBCFile
  • NameLength : SysVariable
  • names : BaseNames
  • NativeSKDLL() : NativeSKDLL
  • NDim : CABLOCKV4
  • NEG_RESPONSE_VALUE : UDSClientBase
  • NegativeResponseCodes : UDSClient
  • NetworkInterfaceChanged : DoIPClient
  • Next : MemoryRange
  • NoAxisPts : A2LRECORD_LAYOUT
  • NoCompuMethod : A2LNODE
  • Node : WriterException
  • Nodes : ModelChangedEventArgs
  • NodeType : EntityStatusResponse
  • Nominal : CANConfiguration.BitRateConfig
  • NonISO : CANConfiguration.BitRateConfig
  • NoOfBits : ICNBLOCK
  • NoOfPages : A2LXCP_SEGMENT
  • NoOfSamplings : A2LKWP_SOURCE.QP_BLOB
  • NoRescaleX : A2LRECORD_LAYOUT
  • NoResponseTesterPresent : UDSClient
  • notifyThread() : CANProvider, LINProvider
  • NrOfRedSamples : ISRBLOCK
  • NS : DBCFile
  • Number : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC, DBCFile.SignalGroupType
  • NumberOfIdentifiedEvents : RespResponseOnEvent
  • NumberOfIF : A2LXCP_ON_USB
  • numToArray() : Extensions


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • O : A2LKWP_TP_BLOB.KWP_SERAM
  • ObjectCount : BLFFile
  • ObjectType : DBCFile.AttribDefType
  • ODT() : ODT
  • ODT_DAQ : A2LXCP_BUFFER_RESERVE
  • ODT_STIM : A2LXCP_BUFFER_RESERVE
  • ODTDAQBufferElementSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTDict : DAQListXCP
  • ODTEntries : A2LXCP_ODT, DAQDict, ODT
  • ODTEntry() : ODTEntry
  • ODTEntrySize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTNo : A2LXCP_ODT
  • ODTs : DAQList
  • ODTSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTSTIMBufferElementSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • Odx : Id, IId
  • ODX : ODXFile
  • Offset : A2LCANAPE_ADDRESS_UPDATE.SymbolType, A2LRECORD_LAYOUT, RationalCoeffs, DBCFile.SignalType, CompilationUnitHeader
  • Offsets : IA2LMemory
  • Ofs : ELFFile.ELFSection
  • onCANReceived() : DBCFile
  • onDAQFrameReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • onErrorReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • onEventReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • OnFormClosing() : DataFileBinDlg
  • OnlyOnActivePage : A2LKWP_CHECKSUM
  • onParserMessage() : A2LParser
  • onReceive() : FrameProvider< T, V >
  • OnReceived() : DoIPBase.ResponseEvent
  • onReceived() : IsoTp, IsoTpFSM
  • onReceivedFR() : IsoTpFSM
  • OnResponseReceived() : DoIPBase, DoIPClient, DoIPServer
  • onServiceReceived() : XCPMaster, XCPMasterBase
  • OnValuesReceived : CommMaster
  • OnWriteRawData : IDGBLOCK
  • open() : CDFFile, DataFile, DCMFile, MatlabFile, PARFile, BLFFile, _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider, DBCFile, ODXFile, MDFReader, ELFFile, MAPFile
  • OpenArrays : MDFReader
  • OpenChannelGroups : MDFReader
  • OpenChannels : MDFReader
  • OpenSockets : EntityStatusResponse
  • OptionalCmds : A2LXCP_PROTOCOL_LAYER
  • OptionalTLCmds : A2LXCP_MEDIA
  • OriginalPtrTable : A2LCANAPE_ADDRESS_UPDATE.ExSymbolType
  • OriginalStart : DBCFile.SignalType
  • OSType : ELFFile


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • p1Max : KWP_TIME_DEF
  • P2Client : IsoTp, UDSClientBase, Protocol
  • P2ExServerMax : RespSession
  • p2Max : KWP_TIME_DEF
  • p2Min : KWP_TIME_DEF
  • P2ServerMax : RespSession
  • P3Client : IsoTp, UDSClientBase, Protocol
  • p3Max : KWP_TIME_DEF
  • p3Min : KWP_TIME_DEF
  • p4Min : KWP_TIME_DEF
  • Packing : A2LXCP_ENDPOINT
  • PackMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • PageNo : A2LXCP_PAGE
  • PAGProcInfo : XCPMaster
  • Params : ICCBLOCK
  • Parent : A2LNODE, DBCFile.SourceType, IMDFBlock, AbbrevEntry, DWARFInfo.SymbolValue
  • parse() : A2LParser
  • parse2DoubleVal() : Extensions
  • parse2IntVal() : Extensions
  • parse2SingleVal() : Extensions
  • ParserEventArgs() : ParserEventArgs
  • ParserEvents : ODXRoot, MDFReader
  • ParserMessage : A2LParser, ODXRoot, MDFReader
  • ParType : PARFile
  • path : SIcomment
  • PDUFormat : J1939Frame
  • PDUSpecific : J1939Frame
  • Percent : ProgressArgs
  • PgmDll : A2LCCP_SEED_KEY
  • PGMProcInfo : XCPMaster
  • PgmVerify : A2LXCP_SEGMENT
  • PGN : J1939Frame
  • PhysicalProtocol : ODXRoot
  • PhysReqCANId : Protocol
  • PhysRespCANId : Protocol
  • PhysUnit : A2LOVERWRITE, A2LTYPEDEF_CONVERSION_REF
  • PID : ODT
  • Port : A2LXCP_ON_ETHERNET, ISxIProvider, SxIProvider, XCPMasterBase
  • POS_RESPONSE_MASK : UDSClientBase
  • Position : A2LRECORD_LAYOUT.ItemLayoutDesc, CANErrorExt
  • PositionInSrcDataRecord : SrcDataIdentifier
  • PowerDownTime : RespReset
  • PowerMode : DiagnosticPowerModeResponse
  • PreventDefaultRequests : XCPMaster
  • PrgType : MemorySegment
  • Priority : J1939Frame
  • Producer : AbbrevEntryCU
  • ProductID : A2LXCP_ON_USB
  • Program() : CCPMasterBase, XCPMasterBase
  • Program6() : CCPMasterBase
  • ProgramClear() : XCPMasterBase
  • ProgramFormat() : XCPMasterBase
  • ProgramId : IIDBLOCK
  • ProgramMax() : XCPMasterBase
  • ProgramNext() : XCPMasterBase
  • ProgramPrepare() : XCPMasterBase
  • ProgramReset() : XCPMasterBase
  • ProgramSpecificData : HDBLOCK
  • ProgramStart() : XCPMasterBase
  • programSync() : CCPMaster, CommMaster, XCPMaster
  • ProgramVerify() : XCPMasterBase
  • ProgressArgs() : ProgressArgs
  • ProgressChanged : A2LParser
  • Project : A2LParser
  • ProjectBaseAdress : A2LKWP_TP_BLOB
  • protocol : SIcomment
  • Protocols : BaseVariant


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • Quality : A2LXCP_CLOCK
  • QueueSize : XCPCommModes


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RaiseConnectionStateChanged() : CommMaster
  • RaiseOnValuesReceived() : CommMaster
  • RAMToFLASHMode : A2LKWP_FLASH
  • Raster : SourceAndRaster
  • raster : CNcomment
  • Rasters : A2LCCP_KP_BLOB
  • Rate : ICNBLOCK, CNBLOCK
  • RationalCoeffs() : RationalCoeffs
  • RawID : CANFrame
  • RawValue : DBCFile.MsgType
  • RawValueLen : DBCFile.MsgType
  • readCharacteristic() : CommMaster
  • ReadDAQ() : XCPMasterBase
  • readData() : IDataContainer
  • ReadDataByIdentifier() : UDSClientBase
  • ReadDataByPeriodicIdentifier() : UDSClientBase
  • readDataContainer() : DataContainerV4
  • ReadDTCInformation() : UDSClientBase
  • ReadDTCInformationCount() : UDSClientBase
  • ReadDTCInformationRecords() : UDSClientBase
  • Reader : ELFFile
  • readFromXML() : A2LParser
  • readMemory() : UDSClient
  • ReadMemoryByAddress() : UDSClientBase
  • ReadOnly : A2LRECORD_LAYOUT_REF
  • ReadScalingDataByIdentifier() : UDSClientBase
  • readSync() : CCPMaster, CommMaster, XCPMaster
  • readUTF8String() : ELFFile.SectionValue
  • ReadWrite : A2LINSTANCE, A2LMEASUREMENT
  • recalcCoeffs() : ICCBLOCK
  • receive() : DoIPBase
  • ReceivedEvent : XCPEventArgs
  • ReceivedServiceRequest : XCPServiceRequestArgs
  • Receivers : DBCFile.EnvironmentType, DBCFile.SignalType
  • receiveThread() : CANProvider, LINProvider
  • recessiveDominantDelay : LibWrapper.ChannelConfig
  • RecLayDict : A2LPROJECT
  • Record : UDSClient.IdentifierRequest
  • RecordCount : ICGBLOCK, CGBLOCKV4
  • RecordID : ICGBLOCK, CGBLOCK, CGBLOCKV4
  • RecordIDType : IDGBLOCK, DGBLOCKV4
  • RecordingTime : IHDBLOCK
  • RecordLayout : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • RecordSize : ICGBLOCK, CGBLOCKV4
  • reduce() : MemoryRangeList
  • RefAxisPtsRef : A2LAXIS_DESCR
  • RefComparisonQuantity : A2LCHARACTERISTIC
  • RefCompuMethod : A2LAXIS_DESCR, A2LCONVERSION_REF
  • RefCurveAxisRef : A2LAXIS_DESCR
  • ReferencedNodes : A2LFRAME, A2LFUNCTION, A2LGROUP, A2LREFBASE, A2LREFERENCE
  • RefFunctions : A2LCONVERSION_REF
  • RefId : AbbrevEntry
  • RefInstance : A2LADDRESS
  • ReflectDiagMessageOnAcknowledge : DoIPBase
  • RefMeasurement : A2LAXIS_DESCR, A2LAXIS_PTS
  • RefModCommon : A2LMODULE
  • RefModPar : A2LMODULE
  • RefRecordLayout : A2LRECORD_LAYOUT_REF
  • RefTypedef : A2LINSTANCE, A2LSTRUCTURE_COMPONENT
  • RefVariantCoding : A2LMODULE
  • RefVarMeasurement : A2LVAR_CRITERION
  • RefVarSelectionCharacteristic : A2LVAR_CRITERION
  • RegisterClient() : CommKernel
  • registerClient() : IFrameProvider< T >
  • RELATED_EVENT_CHANNEL_NUMBER : A2LXCP_EVENT
  • reLoad() : IDataFile
  • RemoteEp : DoIPClient
  • removeIdentifier() : UDSClient
  • Representation : SysVariable
  • RequestDownload() : UDSClientBase
  • RequestFileTransfer() : UDSClientBase
  • RequestIDsByBroadcast : A2LXCP_ON_CAN
  • RequestSTMin : IsoTpFSM
  • RequestTransferExit() : UDSClientBase
  • RequestUpload() : UDSClientBase
  • Reserved : A2LRECORD_LAYOUT
  • reset() : XCPReceiveBuffer
  • resetDAQTime() : TimeBase
  • resetLastError() : CCPMasterBase, CommMaster, XCPMasterBase
  • resetReceiverCache() : DBCFile
  • resetReferences() : A2LREFBASE
  • Resolution : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • respActionService() : Program.CCPSim
  • respAllocDAQ() : Program.XCPSim
  • respAllocODT() : Program.XCPSim
  • respAllocODTEntry() : Program.XCPSim
  • RespBase() : RespBase
  • respBuildChecksum() : Program.XCPSim
  • respBuildChksum() : Program.CCPSim
  • respClearDAQList() : Program.XCPSim
  • respClearMemory() : Program.CCPSim
  • respConnect() : Program.CCPSim, Program.XCPSim
  • respCopyCALPage() : Program.XCPSim
  • respDiagService() : Program.CCPSim
  • respDisconnect() : Program.CCPSim, Program.XCPSim
  • respDownload() : Program.CCPSim, Program.XCPSim
  • respDownload6() : Program.CCPSim
  • respDownloadMax() : Program.XCPSim
  • respExchangeID() : Program.CCPSim
  • respFreeDAQ() : Program.XCPSim
  • respGetActiveCALPage() : Program.CCPSim
  • respGetCalPage() : Program.XCPSim
  • respGetCCPVersion() : Program.CCPSim
  • respGetCommModeInfo() : Program.XCPSim
  • respGetDAQClock() : Program.XCPSim
  • respGetDAQEventInfo() : Program.XCPSim
  • respGetDAQListInfo() : Program.XCPSim
  • respGetDAQListMode() : Program.XCPSim
  • respGetDAQProcessorInfo() : Program.XCPSim
  • respGetDAQResolutionInfo() : Program.XCPSim
  • respGetDAQSize() : Program.CCPSim
  • respGetId() : Program.XCPSim
  • respGetPageInfo() : Program.XCPSim
  • respGetPAGProcessorInfo() : Program.XCPSim
  • respGetSeed() : Program.CCPSim, Program.XCPSim
  • respGetSegmentInfo() : Program.XCPSim
  • respGetStatus() : Program.CCPSim, Program.XCPSim
  • respModifyBits() : Program.XCPSim
  • respMove() : Program.CCPSim
  • ResponseOnEvent() : UDSClientBase
  • ResponseParamInfo : DiagService, IdentifierRecord
  • respPGMProcessorInfo() : Program.XCPSim
  • respProgram() : Program.CCPSim, Program.XCPSim
  • respProgram6() : Program.CCPSim
  • respProgramClear() : Program.XCPSim
  • respProgramFormat() : Program.XCPSim
  • respProgramMax() : Program.XCPSim
  • respProgramPrepare() : Program.XCPSim
  • respProgramReset() : Program.XCPSim
  • respProgramStart() : Program.XCPSim
  • respProgramVerify() : Program.XCPSim
  • respSectorInfo() : Program.XCPSim
  • respSelectCALPage() : Program.CCPSim
  • RespService() : RespService
  • respSetCalPage() : Program.XCPSim
  • respSetDAQListMode() : Program.XCPSim
  • respSetDAQPtr() : Program.CCPSim, Program.XCPSim
  • respSetMTA() : Program.CCPSim, Program.XCPSim
  • respSetRequest() : Program.XCPSim
  • respSetSegmentMode() : Program.XCPSim
  • respSetSStatus() : Program.CCPSim
  • respShortDownload() : Program.XCPSim
  • respShortUp() : Program.CCPSim
  • respShortUpload() : Program.XCPSim
  • respStartStop() : Program.CCPSim
  • respStartStopAll() : Program.CCPSim
  • respStartStopDAQList() : Program.XCPSim
  • respStartStopSynch() : Program.XCPSim
  • respSynch() : Program.XCPSim
  • respTest() : Program.CCPSim
  • respTransportLayerCmd() : Program.XCPSim
  • respUnlock() : Program.CCPSim, Program.XCPSim
  • respUpload() : Program.CCPSim, Program.XCPSim
  • respUserCmd() : Program.XCPSim
  • respWriteDAQ() : Program.CCPSim, Program.XCPSim
  • respWriteDAQMultiple() : Program.XCPSim
  • Restart() : DoIPBase.ResponseEvent
  • Result : A2LKWP_CHECKSUM, A2LKWP_FLASH, A2LKWP_ROUTINE_PARA, RespBase
  • ResultSk : NativeSKDLL
  • reverse() : Extensions
  • RipAddr : A2LRECORD_LAYOUT
  • RipAddrW : A2LRECORD_LAYOUT
  • ro : EType
  • RootEntries : CompilationUnitHeader
  • RootEntry : AbbrevEntry
  • RoutineControl() : UDSClientBase
  • RoutineIdentifier : RespRoutineControl
  • RoutineInfo : RespRoutineControl
  • RoutineStatusRecord : RespRoutineControl
  • RoutingActivation() : DoIPClient
  • RowFragment : ParTableEntry
  • RspId : IsoTp, UDSClientBase


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SA : IsoTp
  • SampleCount : A2LKWP_CAN, A2LXCP_EVENT_DAQ_PACKED_MODE
  • SamplePoint : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • SamplePoints : A2LKWP_CAN
  • save() : IDataFile, CDFFile, DCMFile, MatlabFile, PARFile, BLFFile, DBCFile, ODXFile, MDFReader, MDFWriter
  • SDG_CAPTION : Sdg
  • SDG_CAPTION_REF : Sdg
  • SDGS : Sdg
  • SecondarySamplePoint : A2LXCP_CAN_FD
  • Seconds : ValuesReceivedEventArgs
  • Section : ELFFile.SectionValue
  • Sections : ELFFile
  • SectionType : ELFFile
  • SecuredDataTransmission() : UDSClientBase
  • SECURITY_ACCESSs : A2LKWP_TP_BLOB
  • SecurityAccessRequestSeed() : UDSClientBase
  • SecurityAccessSendKey() : UDSClientBase
  • SecuritySeed : RespSecurityAccess
  • SeedAndKeyDLL : CommMaster
  • SeedAndKeyExternalFunction : A2LXCP_PROTOCOL_LAYER
  • SegmentList : IDataFile
  • SegmentNo : A2LXCP_SEGMENT
  • SelectCALPage() : CCPMasterBase
  • Selection : DataFormat
  • SELECTION_ : DataFormat
  • SEMANTIC : ParBaseDef
  • send() : _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider
  • sendAndWait< T >() : DoIPBase
  • sendCmd() : ELM327CAN
  • Sender : BaseFrame
  • sendError() : Program.XCPSim
  • sendEvent() : Program.CCPSim
  • sendMsg() : CANProvider, ICANProvider, ISxIProvider
  • sendPosResponse() : Program.UDSSim
  • sendRequest() : IsoTp
  • sendResponse() : Program.CCPSim, Program.XCPSim
  • sendServiceRequest() : Program.XCPSim
  • SERAM : A2LKWP_TP_BLOB
  • Service : UDSFrame
  • ServiceID : RespBase
  • ServicesReceived : CommMaster
  • ServiceStr : UDSFrame
  • setBitmask() : Extensions
  • SetCalPage() : XCPMasterBase
  • setConnectionState< T >() : CCPMaster, CCPMasterBase, CommMaster, XCPMaster, XCPMasterBase
  • setContent() : A2LUNSUPPORTEDNODE
  • setCurrentDAQTimeFromSeconds() : TimeBase
  • SetDAQID() : XCPMasterBase
  • SetDAQListMode() : XCPMasterBase
  • SetDAQListUSBEndpoint() : XCPMasterBase
  • SetDAQPtr() : CCPMasterBase, XCPMasterBase
  • setData() : MeasurementAccessData
  • setDataBytes() : MemorySegment
  • setEPK() : IDataFile, DataFile
  • setFncValue() : ICharValue
  • SetMTA() : CCPMasterBase, XCPMasterBase
  • setPage() : CCPMaster, CommMaster, XCPMaster
  • setPhysValue() : MeasurementAccessData
  • SetRequest() : XCPMasterBase
  • SetSegmentMode() : XCPMasterBase
  • setSegmentsData() : IDataFile, DataFile
  • SetStatus() : CCPMasterBase
  • setValue() : CharacteristicValue
  • SeverityDTCs : RespDTCSeverityRecords
  • ShiftOp : A2LRECORD_LAYOUT
  • SHORT_NAME : PDXIndex.ABLOCK, PDXIndex
  • ShortDownload() : XCPMasterBase
  • ShortUp() : CCPMasterBase
  • ShortUpload() : XCPMasterBase
  • SID : DiagService
  • SIExponents : A2LUNIT
  • SignalFlagsType : DBCFile
  • SignalFloatType : DBCFile
  • SignalGroups : DBCFile
  • SignalRefs : DBCFile.SignalGroupType
  • Signals : DBCFile.MsgType
  • SignalType() : DBCFile.SignalType, ICNBLOCK, CNBLOCKV4
  • SingleValue() : SingleValue
  • Size : A2LBLOB, A2LTYPEDEF_BLOB, A2LCCP_DP_BLOB, IA2LMemory, A2LKWP_KP_BLOB, MemorySegment, A2LXCP_TIMESTAMP_CHARACTERIZATION, ODTEntry, SrcDataMemory, DataPoint, DataPointF, MemoryRange, MemoryRangeList, DZBLOCKV4, DWARFInfo.SymbolValue, ELFFile.ELFSection, ELFFile.ELFSymbol, UpdateData, UpdaterSymbols
  • SizeLen : RespWriteMemoryByAddress
  • SJW : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • SJWLength : A2LKWP_CAN
  • SkippedValues : DataConservation
  • SocketType : BaseFrame
  • sortByAddress() : A2LNODE
  • sortByAddressAndName() : A2LNODE
  • sortByName() : A2LNODE
  • sortByTypeAndName() : A2LNODE
  • sortDataSegsToFront() : MemorySegmentList
  • SortMode : DBCFile
  • Source : SourceAndRaster, DBCFile.MsgType, ParserEventArgs
  • SourceAddress : J1939Frame
  • SourceAndRaster() : SourceAndRaster
  • SourceAndRasterMap : A2LCCP_TP_BLOB, CCPMaster
  • SourceFile : BLFFile, DBCFile, ODXFile, ODXRoot, MDFReader, SymbolFile
  • SourceFilename : IDataFile
  • Sources : DBCFile
  • specialCabFlags : LibWrapper.ChannelConfig
  • specialDeviceStatus : LibWrapper.ChannelConfig
  • SRBlocks : ICGBLOCK
  • Src : A2LCANAPE_ADDRESS_UPDATE.AdrMapType
  • SrcAddress : A2LRECORD_LAYOUT
  • SrcAdr : DoIPClient, SrcFrame
  • SrcDstFrame() : SrcDstFrame
  • SrcFrame() : SrcFrame
  • start() : FrameProvider< T, V >
  • Start : DBCFile.SignalType, MemoryRange
  • StartDiagWithoutBdSwitch : A2LKWP_TP_BLOB
  • Started : Header
  • StartLine : A2LNODE
  • StartListenToEntityAnnouncement() : DoIPClient
  • startMeasurements() : CCPMaster, CommMaster, XCPMaster
  • StartStop() : CCPMasterBase
  • StartStopAll() : CCPMasterBase
  • StartStopDAQList() : XCPMasterBase
  • StartStopRoutineNo : A2LKWP_CAN
  • StartStopSynch() : XCPMasterBase
  • StartValue : DBCFile.EnvironmentType
  • State : DAQListXCP
  • StaticAddressOffsets : A2LRECORD_LAYOUT
  • StaticRecordLayout : A2LRECORD_LAYOUT
  • StatusAvailabilityMask : RespDTCCount, RespDTCRecords, RespDTCSeverityRecords
  • StatusOfDTC : DTCAndStatusRecord
  • StatusResponse : CCPMaster, XCPMaster
  • StepSize : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • StimulationMode : A2LKWP_TP_BLOB
  • stop() : FrameProvider< T, V >
  • stopDAQTime() : TimeBase
  • StopListenToEntityAnnouncement() : DoIPClient
  • stopMeasurements() : CCPMaster, CommMaster, XCPMaster
  • StrAddressGranularity : XCPMaster
  • StrictParsing : A2LParser
  • STSMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • SubFunction : RespSFBase
  • Subfunction : UDSFrame, DiagService
  • SubfunctionStr : UDSFrame
  • SubNodes : TreeType
  • SubType : A2LCCP_NAMEDNODE, A2LKWP_NAMEDNODE
  • SxI : SxIProvider
  • SxIDataReceived : ISxIProvider, SxIProvider
  • SxIEventArgs() : SxIEventArgs
  • SxIProvider() : SxIProvider
  • Symbol : ELFFile.SymbolValue
  • SymbolBindType : ELFFile
  • SymbolLink : A2LADDRESS
  • SymbolOffset : A2LADDRESS
  • Symbols : DWARFInfo, ELFFile, MAPFile
  • SymbolType : ELFFile
  • SymbolTypeLink : A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_STRUCTURE
  • SyncBaseValue : EVBLOCKV4
  • SyncEdge : A2LKWP_CAN
  • SyncFactor : EVBLOCKV4
  • Synch() : XCPMasterBase
  • SynchronizationStatus : VehicleIdResponse
  • SyncType : ICNBLOCK
  • SystemConstants_ : A2LMOD_PAR


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TA : IsoTp
  • Tag : A2LNODE, DataFile, CANConfiguration, LINConfiguration, DBCFile.AttribDefDict, DBCFile.AttribDefType, DBCFile.EnvironmentDict, DBCFile.EnvironmentType, DBCFile.IDBCBase, DBCFile.MsgType, DBCFile.SignalGroupDict, DBCFile.SignalGroupType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, DBCFile.ValueTableDict, IMDFBlock, BLOCKBASEV4
  • TAG : AbbrevEntry
  • Tag : UpdaterSymbols
  • TcpRemoteEP : DoIPBase.Communicator
  • TcpSocketWithTimeout() : TcpSocketWithTimeout
  • TeamMemberRef : DocRevision
  • TemplateType : CABLOCKV4
  • Termination : DiagCodedTypeMinMax
  • TERMINATION_ : DiagCodedTypeMinMax
  • TesterAddress : A2LKWP_TP_BLOB
  • TesterPresent() : UDSClientBase
  • TEXT : DataFile, PDXIndex.FILE
  • Text : Annotation, EType, NamesBase
  • this[int handle] : MDFWriter
  • Time : CCBLOCK
  • TIME_DEFs : A2LKWP_TP_BLOB
  • time_source : HDcomment
  • TimeCorrelationProperties() : XCPMasterBase
  • TimeCycle : DAQList
  • TimeDefs : A2LKWP_TIME_DEF
  • TimeOffsetBrsNs : CANFDMessage64
  • TimeOffsetCrcDelNs : CANFDMessage64
  • Timeout : DoIPBase
  • TimeStamp : ParserEventArgs
  • Timestamp : Annotation, RawDataRecord
  • TimestampsRelateTo : A2LXCP_TIME_CORRELATION
  • TimingParameters : RespTimingParameter
  • Timings : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • TmpFileName : A2LParser
  • ToArray() : BaseFrame, SrcDstFrame, SrcFrame
  • toBinaryString() : Extensions
  • toByte() : Extensions
  • toByteArray< T >() : CCPFrame, XCPFrame
  • toCANIDPairString() : CANProvider
  • toCANIDString() : CANProvider
  • toClipboard() : CANFrame, J1939Frame, CCPFrame, Frame, LINFrame, XCPFrame, BaseFrame, UDSFrame
  • toCSV() : CANFrame, J1939Frame, CCPFrame, Frame, LINFrame, XCPFrame, BaseFrame, UDSFrame
  • ToCSV() : MDFReader
  • toDecimalString() : Extensions
  • toFileComment() : DBCFile.IDBCComment
  • toFileDefaultString() : DBCFile.IDBCAttribute
  • toFileString() : DBCFile.IDBCBase
  • toHexStr() : Extensions
  • toHexString() : Extensions
  • toLINIDString() : LINProvider
  • ToNICANId() : CANProvider
  • tool_id : FHcomment
  • tool_vendor : FHcomment
  • tool_version : FHcomment
  • toPhyical() : DBCFile.SignalType
  • toPhysical() : A2LCOMPU_METHOD, A2LCOMPU_TAB, A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE, A2LFormula, RationalCoeffs, TabCoeffs, IdentifierRecord, ICCBLOCK, CCBLOCK, CCBLOCKV4
  • toRaw() : A2LCOMPU_METHOD, A2LCOMPU_TAB, A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE, A2LFormula, RationalCoeffs, TabCoeffs, DBCFile.SignalType
  • toSingleValue() : ICharValue
  • ToString() : A2LCCP_TP_BLOB, A2LFormula, A2LKWP_TP_BLOB, MemorySegmentList, BaseValue, DataFile, A2LXCP_ON_ETHERNET, DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, DataPoint, DataPointF
  • toStringValue() : A2LCONVERSION_REF, A2LMEASUREMENT, A2LRECORD_LAYOUT_REF, DBCFile.SignalType
  • toToolTipString() : DBCFile.IDBCComment
  • toUserDescriptrion() : IA2LMemory
  • toValString() : DBCFile.IDBCSignal
  • transceiverName : LibWrapper.ChannelConfig
  • transceiverState : LibWrapper.ChannelConfig
  • transceiverType : LibWrapper.ChannelConfig
  • TransferData() : UDSClientBase
  • TransferType : A2LXCP_ENDPOINT
  • TransformerDict : A2LPROJECT
  • TransportLayerCmd() : XCPMasterBase
  • TransportLayerInstance : A2LXCP_MEDIA
  • tryAcquire() : DoIPBase
  • TryConnect() : TcpSocketWithTimeout
  • tryGetMemoryMappedStream() : Extensions
  • tryParse2DoubleVal() : Extensions
  • tryParse2IntVal() : Extensions
  • TX : CommentBase
  • TxCount : CANFDMessage64
  • TxTimeout : CANConfiguration
  • Type : A2LNODE, ModelChangedEventArgs, CANFrame, RespBuildChecksum, XCPFrame, XCPMasterBase, DBCFile.EnvironmentType, BaseFrame, IsoTp, CompuMethod, DataBlock, NativeSKDLL, ParserEventArgs, IIDBLOCK, MDFWriter
  • type : EType
  • Type : DWARFInfo.SymbolValue, ELFFile.ELFSection, ELFFile.ELFSymbol, UpdateData
  • TYPE_ : DataBlock
  • TypeDefDict : A2LPROJECT
  • TypeType : ELFFile


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • U : A2LKWP_TP_BLOB.KWP_SERAM
  • UDSClient() : UDSClient
  • UDSClientBase() : UDSClientBase
  • UDSFrame() : UDSFrame
  • UH : AbbrevEntryCU
  • unescapeStr() : Extensions
  • UnfinalizedFlags : IIDBLOCK
  • UniqueBusID : ICANProvider, FrameProvider< T, V >, ILINProvider
  • Unit : A2LCONVERSION_REF, ICharValue, DBCFile.EnvironmentType, DBCFile.SignalType, ICCBLOCK, ICNBLOCK
  • unit : EType, RasterType
  • unit_ref : EType, RasterType
  • UnitAxis : ICharValue
  • UnitConversion : A2LUNIT
  • UnitDict : A2LPROJECT
  • Unlock() : CCPMasterBase, XCPMasterBase
  • unlock() : UDSClient
  • unlockECU() : CCPMaster, XCPMaster
  • unregisterClient() : IFrameProvider< T >
  • UPD : PDXIndex.ABLOCK
  • updateAndWriteA2L() : SymbolFile
  • UpdateData() : UpdateData
  • updateFileLogSetting() : FrameQueue< T >
  • UpdType : PDXIndex
  • Upload() : CCPMasterBase, XCPMasterBase
  • upload() : UDSClient
  • UploadedData : RespTransferData
  • UpperLimit : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • UpperLimitEx : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • USDTPTimings : A2LKWP_TIME_DEF
  • UseCANFD : UDSClientBase
  • UseFillByte : IsoTp, UDSClientBase
  • user_name : FHcomment
  • UserCmd() : XCPMasterBase
  • UTCOffset : FHBLOCKV4, HDBLOCKV4


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValBlkValue() : ValBlkValue
  • ValidDataBytes : CANFDMessage64
  • ValidFlags : CANErrorExt
  • ValidFlagsType : CANErrorExt
  • Validity : ScaleConstr
  • VALIDITY_ : ScaleConstr
  • Value : ICharValue, ODTEntry, DBCFile.AttribDefType
  • value : RasterType
  • Value : Attribute, ELFFile.ELFSymbol
  • ValueFormat : ICharValue
  • Values : DataConservation
  • Values_ : A2LCOMPU_TAB
  • ValueTable() : DBCFile.ValueTable
  • ValueTables : DBCFile
  • VAR_NAMING : A2LVARIANT_CODING
  • VAR_SEPARATOR : A2LVARIANT_CODING
  • VarBase : DWARFInfo.SymbolValue
  • VectorCAN : CEBLOCK
  • VehicleIdRequest() : DoIPClient
  • VendorID : A2LXCP_ON_USB
  • Verbs_ : A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE
  • Version : A2LCANAPE_EXT, A2LParser, A2LXCP_MEDIA, A2LXCP_PROTOCOL_LAYER, ELM327CAN, CCPMaster, LINConfiguration, XCPMaster, DBCFile, BaseFrame, IIDBLOCK, CompilationUnitHeader
  • VersionType : ELFFile
  • VIN : VehicleIdResponse
  • VirtualConversion : A2LCANAPE_EXT
  • VirtualDict : A2LPROJECT
  • VKeyGenResultEx : NativeSKDLL
  • Voltage : ELM327CAN


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WFT_MAX : A2LKWP_CAN.NETWORK_LIMITS
  • write() : A2LParser
  • writeBlock() : IMDFBlock, BLOCKBASE, CCBLOCK, CDBLOCK, CEBLOCK, CGBLOCK, CNBLOCK, DGBLOCK, HDBLOCK, IDBLOCK, SRBLOCK, TRBLOCK, TXBLOCK, BLOCKBASEV4, CCBLOCKV4, CGBLOCKV4, CNBLOCKV4, DGBLOCKV4, DLBLOCKV4, DZBLOCKV4, FHBLOCKV4, HDBLOCKV4, HLBLOCKV4, IDBLOCKV4, RDSDBLOCKV4, SIBLOCKV4, SRBLOCKV4
  • WriteBytes() : XCPMasterBase
  • writeCharacteristic() : CommMaster
  • WriteDAQ() : CCPMasterBase, XCPMasterBase
  • WriteDAQMultiple() : XCPMasterBase
  • WriteDataByIdentifier() : UDSClientBase
  • WriteFileType : DataFileS19
  • writeMemory() : UDSClient
  • WriteMemoryByAddress() : UDSClientBase
  • writeSync() : CCPMaster, CommMaster, XCPMaster
  • writeToXML() : A2LParser
  • WS_DELIMITER : Constants


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X : DataPoint, DataPointF
  • XCPErrorReceived : XCPMaster
  • XCPEventReceived : XCPMaster
  • XCPFrame() : XCPFrame
  • XCPMaster() : XCPMaster
  • XCPMasterBase() : XCPMasterBase
  • XCPonEth() : XCPonEth
  • XCPonUDP() : XCPonUDP
  • XCPReceiveBuffer() : XCPReceiveBuffer
  • XCPServiceRequestReceived : XCPMaster
  • XDL_MAX : A2LKWP_CAN.NETWORK_LIMITS


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : DataPoint, DataPointF


ASAP2Library interface: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • ZLIB_HEADER : Constants


ASAP2Library interface: Class Members - Functions

- a -

  • A2LADDRESS() : A2LADDRESS
  • A2LCCP_NAMEDNODE() : A2LCCP_NAMEDNODE
  • A2LCONVERSION_REF() : A2LCONVERSION_REF
  • A2LFormulaDict() : A2LFormulaDict
  • A2LKWP_NAMEDNODE() : A2LKWP_NAMEDNODE
  • A2LNAMEDNODE() : A2LNAMEDNODE
  • A2LNODE() : A2LNODE
  • A2LParser() : A2LParser
  • A2LRECORD_LAYOUT_REF() : A2LRECORD_LAYOUT_REF
  • A2LUNSUPPORTEDNODE() : A2LUNSUPPORTEDNODE
  • A2LXCP_ON_CAN() : A2LXCP_ON_CAN
  • A2LXCP_ON_ETHERNET() : A2LXCP_ON_ETHERNET
  • A2LXCP_ON_TCP_IP() : A2LXCP_ON_TCP_IP
  • A2LXCP_ON_UDP_IP() : A2LXCP_ON_UDP_IP
  • AccessTimingSercice() : UDSClientBase
  • ActionService() : CCPMasterBase
  • add() : A2LFormulaDict, AdaptiveState
  • Add() : DAQCache, MemoryRangeList, AnnotationList
  • addAdaptiveCharacteristics() : CommMaster
  • addAnnotation() : MDFWriter
  • addAppText() : BLFFile
  • addCANFrame() : BLFFile
  • addChild() : A2LNODE
  • addColoredConsoleAppender() : LogManager
  • addDataEntry() : MDFWriter
  • addFrame() : FrameQueue< T >
  • addFromInstance() : A2LADDRESS
  • addIdentifier() : UDSClient
  • addMaxText() : A2LNODE
  • addMeasurement() : ODT, MDFWriter
  • addMeasurements() : MDFWriter
  • addModification() : ODXRoot
  • addPresetDAQEvent() : A2LMEASUREMENT
  • addRawData() : MDFWriter
  • addSignal() : DBCFile.MsgType
  • addSourceInformation() : MDFWriter
  • alignDown() : Extensions
  • alignUp() : Extensions
  • AllocDAQ() : XCPMasterBase
  • AllocODT() : XCPMasterBase
  • AllocODTEntry() : XCPMasterBase
  • Annotation() : Annotation
  • arrayToNum() : Extensions
  • ASCIIValue() : ASCIIValue
  • AttribDefType() : DBCFile.AttribDefType
  • AxisPtsLayoutDesc() : A2LRECORD_LAYOUT.AxisPtsLayoutDesc


ASAP2Library interface: Class Members - Functions

- b -

  • BaseFrame() : BaseFrame
  • BaseValue() : BaseValue
  • BitRateConfig() : CANConfiguration.BitRateConfig
  • BLFFile() : BLFFile
  • BLOCKBASE() : BLOCKBASE
  • BLOCKBASEV4() : BLOCKBASEV4
  • BlockForMicroSecs() : TimeBase
  • buildArrayIndexes() : DWARFInfo.SymbolValue
  • buildAssembly() : A2LFormulaDict
  • buildBitmask() : Extensions
  • buildChecksum() : Checksum
  • BuildChecksum() : CCPMasterBase, XCPMasterBase
  • buildDAQMeasurements() : A2LMEASUREMENT
  • buildHtmlFromDescription() : ODXFile
  • buildHtmlTableLine() : Extensions
  • buildNewId() : ODXRoot


ASAP2Library interface: Class Members - Functions

- c -

  • CANConfigException() : CANConfigException
  • CANConfiguration() : CANConfiguration
  • CANErrorExt() : CANErrorExt
  • CANEventArgs() : CANEventArgs
  • CANFrame() : CANFrame
  • CANIDSort() : CANProvider
  • CANProvider() : CANProvider
  • CCPFrame() : CCPFrame
  • CCPMaster() : CCPMaster
  • CCPMasterBase() : CCPMasterBase
  • changeEndianess() : Extensions
  • changeEndianness() : RespBase, RespBuildChecksum, RespDownload, RespGetActiveCALPage, IResponse, EventResumeMode, EventResumeModeTS, EventStimTimeout, EventTimeSync, RespBase, RespBuildChecksum, RespConnect, RespDTOCtrResp, RespGetDAQClock, RespGetDAQListInfo, RespGetDAQListMode, RespGetDAQProcessorInfo, RespGetDAQResolutionInfo, RespGetID, RespGetSectorInfoModeAddressOrLen, RespGetSegmentInfoAddress, RespGetStatus, RespReadDAQ, RespTimeCorrelation
  • changeId() : ODXRoot
  • checkEPK() : IDataFile
  • checkIdentifier() : DBCFile
  • clear() : CANFrameQueue
  • Clear() : DAQDict
  • clear() : FrameQueue< T >, LINFrameQueue
  • ClearDAQList() : XCPMasterBase
  • clearData() : DAQDict, DAQList, DAQListXCP
  • ClearDiagnosticInformation() : UDSClientBase
  • ClearMemory() : CCPMasterBase
  • clearServices() : UDSClient
  • Clone() : MemorySegment, MemorySegmentList, DataFile, DataFileBin, DataFileHex, DataFileS19
  • close() : CCPonCAN, Communicator, IFrameProvider< T >, ISxIProvider, SxIProvider, XCPOnSxI, XCPonTCP, XCPonUDP, XCPOnUSB
  • CmdBase() : CmdBase
  • CommMaster() : CommMaster
  • CommunicationControl() : UDSClientBase
  • Communicator() : DoIPBase.Communicator
  • CompareTo() : BaseValue
  • computeAddress() : A2LCCP_TP_BLOB
  • ComputeKeyFromSeed() : NativeSKDLL
  • configureLogOutput() : LogManager
  • configureMeasurements() : CCPMaster, CommMaster, XCPMaster
  • Connect() : CCPMasterBase, XCPMasterBase
  • contains() : A2LCCP_DEFINED_PAGES, IA2LMemory
  • ControlDTCSetting() : UDSClientBase
  • convertToByte< T >() : Extensions
  • convertToReference< T >() : CCPFrame, Extensions
  • CopyCalPage() : XCPMasterBase
  • copyMemory() : Extensions
  • copyPage2Page() : CCPMaster, CommMaster, XCPMaster
  • CRC16() : Checksum
  • CRC16CCITT() : Checksum
  • CRC32() : Checksum
  • createBroadcastSocket() : DoIPBase
  • createChannelGroup() : MDFWriter
  • createDefault() : A2LMOD_COMMON
  • createDelegate< T >() : DLLWrapper
  • createInitialMemorySegments() : A2LMODULE
  • createRawData() : DBCFile.MsgType
  • createValue() : CharacteristicValue
  • Cube4Value() : Cube4Value
  • Cube5Value() : Cube5Value
  • CuboidValue() : CuboidValue
  • CurveValue() : CurveValue


ASAP2Library interface: Class Members - Functions

- d -

  • DAQAndEvt() : DAQAndEvt
  • DAQListXCP() : DAQListXCP
  • DAQMeasurement() : DAQMeasurement
  • DataContainerV4() : DataContainerV4
  • DataFile() : DataFile
  • DataFileBin() : DataFileBin
  • DataFileBinDlg() : DataFileBinDlg
  • DataFileHex() : DataFileHex
  • DataFileS19() : DataFileS19
  • DataPoint() : DataPoint
  • DataPointF() : DataPointF
  • dataReceived() : XCPCommunicator
  • DataStream() : DataStream
  • DBCFile() : DBCFile
  • decrement() : ICharValue
  • deleteFromModel() : A2LNODE
  • deleteNode() : A2LREFERENCE
  • DeregisterClient() : CommKernel
  • deserialize< T >() : Extensions
  • DiagnoseRequest() : DoIPClient
  • DiagnosticPowerMode() : DoIPClient
  • DiagnosticSessionControl() : UDSClientBase
  • DiagService() : CCPMasterBase
  • Disconnect() : CCPMaster, CCPMasterBase, CommMaster, XCPMaster, XCPMasterBase
  • Dispose() : A2LParser, DataFile, _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, CCPMaster, CCPonCAN, CommMaster, Communicator, FrameProvider< T, V >, FrameQueue< T >, ETASLIN, IntrepidLIN, IXXATLIN, KvaserLIN, PeakLIN, VectorLIN, SxIProvider, XCPCommunicator, XCPMaster, UDSClient, UDSClientBase, DLLWrapper, DataReader, MDFReader, MDFWriter, ELFFile
  • dlcToLength() : CANProvider
  • DLLWrapper() : DLLWrapper
  • DoIPBase() : DoIPBase
  • DoIPClient() : DoIPClient
  • DoIPServer() : DoIPServer
  • doPlausibilityCheck() : DBCFile
  • Download() : CCPMasterBase, XCPMasterBase
  • download() : UDSClient
  • Download6() : CCPMasterBase
  • DownloadMax() : XCPMasterBase
  • DownloadNext() : XCPMasterBase
  • DtoCtrProperties() : XCPMasterBase
  • DynamicallyClearDataIdentifier() : UDSClientBase
  • DynamicallyDefineDataIdentifierByAdr() : UDSClientBase
  • DynamicallyDefineDataIdentifierById() : UDSClientBase


ASAP2Library interface: Class Members - Functions

- e -

  • EcuReset() : UDSClientBase
  • enqueueFrame() : CANFrameQueue, J1939FrameQueue, CCPFrameQueue, LINFrameQueue, XCPFrameQueue, DoIPFrameQueue, UDSFrameQueue
  • EntityStatus() : DoIPClient
  • enumArraySamples() : MDFReader
  • enumCANFrames() : BLFFile
  • enumChildNodes< T >() : A2LNODE
  • enumObjects() : BLFFile
  • enumSamples() : MDFReader
  • enumSymbols() : DWARFInfo.SymbolsTree
  • EnvironmentType() : DBCFile.EnvironmentType
  • EPKCheck() : DataFile
  • epkCheck() : CommMaster
  • eval() : IEvaluator
  • EventBase() : EventBase
  • ExchangeID() : CCPMasterBase
  • executeAliveRequests() : DoIPServer
  • executeService< T >() : UDSClientBase
  • expandSymbol() : DWARFInfo


ASAP2Library interface: Class Members - Functions

- f -

  • fillMemory() : Extensions
  • findCALPage() : A2LCCP_TP_BLOB
  • findId() : ODXRoot
  • findMemSeg() : IDataFile, MemorySegmentList, DataFile
  • findNode() : A2LNODE
  • findNode< T >() : A2LNODE
  • findPage() : A2LCCP_TP_BLOB
  • findRangeIndex() : MemoryRangeList
  • fixRationalParameters() : MDFReader
  • Frame() : Frame
  • FreeDAQ() : XCPMasterBase
  • freezePage() : XCPMaster
  • fromHexStr() : Extensions
  • FromNICANId() : CANProvider


ASAP2Library interface: Class Members - Functions

- g -

  • GetActiveCALPage() : CCPMasterBase
  • getAddress() : A2LRECORD_LAYOUT_REF
  • getAddressOffset() : A2LMEASUREMENT
  • getAlignment() : A2LRECORD_LAYOUT
  • getAliveCycleTime() : CCPMasterBase, CommMaster, XCPMasterBase
  • getAnnotations() : MDFReader
  • getArrayElementCount() : DWARFInfo.SymbolValue
  • getArraySize() : A2LMEASUREMENT
  • getAttribute() : AbbrevEntry
  • getAvailableCOMPorts() : Extensions
  • GetAvailableHardware() : IFrameProvider< T >
  • GetAvailablePrivileges() : NativeSKDLL
  • getAxisDescription() : DataConservation
  • getBitOffset() : AbbrevEntry
  • getBroadcastIp() : DoIPBase
  • getBusload() : ICANProvider
  • getByteLenFromBitLen() : Extensions
  • getByteSize() : AbbrevEntry
  • GetCalPage() : XCPMasterBase
  • getCCPInterface() : A2LMODULE
  • GetCCPVersions() : CCPMasterBase
  • getChecksum() : CCPMaster, CommMaster, XCPMaster
  • GetCommModeInfo() : XCPMasterBase
  • getCommModes() : A2LXCP_NODE
  • getCompuMethod() : A2LNODE
  • getContext() : A2LNODE
  • getCountMessages() : DBCFile
  • getCountSignals() : DBCFile
  • getCountSources() : DBCFile
  • getCurrentValue() : ODTEntry
  • getCycleTime() : A2LCCP_NODE, A2LXCP_NODE
  • GetDAQClock() : XCPMasterBase
  • GetDAQClockMulitcast() : XCPMasterBase
  • GetDAQEventInfo() : XCPMasterBase
  • GetDAQID() : XCPMasterBase
  • GetDAQListInfo() : XCPMasterBase
  • GetDAQListMode() : XCPMasterBase
  • GetDAQListUSBEndpoint() : XCPMasterBase
  • getDAQPhysValue() : CommMaster
  • GetDAQProcessorInfo() : XCPMasterBase
  • getDAQRawValue() : CommMaster
  • GetDAQResolutionInfo() : XCPMasterBase
  • GetDAQSize() : CCPMasterBase
  • getDAQTime() : TimeBase
  • getData() : MeasurementAccessData, DAQCache, DAQStore, ODTEntry, MDFReader, ELFFile.SectionList, ELFFile.SectionValue
  • getDataASCIIStr() : Frame
  • getDataBytes() : MemorySegment
  • getDataF() : MDFReader
  • getDataFfromMemory() : MDFReader
  • getDataFromArray() : CANProvider
  • getDatafromMemory() : MDFReader
  • getDataSections() : ELFFile.SectionList
  • getDataStr() : Frame
  • getDecimalCount() : A2LCONVERSION_REF
  • getDefCharacteristicFunction() : A2LRECORD_LAYOUT_REF
  • getDescriptionAndAnnotation() : A2LADDRESS, A2LAXIS_PTS, A2LCHARACTERISTIC, A2LCOMPU_METHOD, A2LCOMPU_TAB_BASE, A2LFRAME, A2LINSTANCE, A2LMEASUREMENT, A2LMEMORY_SEGMENT, A2LMOD_PAR, A2LMODULE, A2LNODE, A2LPROJECT, A2LREFBASE, A2LREFERENCE, A2LTYPEDEF, A2LUNIT, A2LVAR_CRITERION, IA2LDescription
  • getDTC() : ODXRoot
  • getDTCs() : ODXRoot
  • getErrorCode() : ParNrcConst
  • getFiles() : PDXIndex
  • getFirstPID() : DAQDictXCP
  • getFncValue() : ICharValue
  • getFncValue< T >() : ICharValue
  • GetFncValuesEnumerator() : ICharValue, BaseValue
  • getFrameFromData() : XCPCommunicator, XCPonEth, XCPOnSxI, XCPOnUSB, XCPReceiveBuffer
  • getFrames() : FrameQueue< T >
  • getFunction() : CToCSharpMath
  • getID() : XCPMaster
  • GetID() : XCPMasterBase
  • getIDFieldSize() : A2LXCP_DAQ
  • getLength() : MDFReader
  • GetLogger() : LogManager
  • getMemoryRanges() : A2LMODULE
  • getMemorySegment() : A2LRECORD_LAYOUT_REF
  • getMemorySize() : A2LADDRESS, A2LBLOB, A2LINSTANCE, A2LMEASUREMENT, A2LRECORD_LAYOUT_REF
  • getMinIncrement() : A2LCOMPU_METHOD
  • getMultiplexSignal() : DBCFile.MsgType
  • getNearestDataFile() : DataFile
  • getNegResCode() : UDSClient
  • getNegResCodes() : ODXRoot
  • getNextValue() : BaseValue
  • getNode< T >() : A2LNODE
  • getNodeDepth() : A2LNODE
  • getNodeList< T >() : A2LNODE
  • getNumberOfElements() : A2LCHARACTERISTIC
  • getODTEntry() : DAQDict
  • getOperatingPoint() : CommMaster
  • getOverviewAsHtml() : ODXFile
  • getPaddingSize() : XCPMasterBase
  • GetPageInfo() : XCPMasterBase
  • getPages() : A2LCCP_TP_BLOB
  • GetPAGProcessorInfo() : XCPMasterBase
  • getParent< T >() : A2LNODE, AbbrevEntry
  • getPDXRoot() : ODXFile
  • GetPGMProcessorInfo() : XCPMasterBase
  • getPhysValue() : MeasurementAccessData
  • getPresetDAQEvent() : A2LMEASUREMENT
  • getPresetDAQEvents() : A2LMEASUREMENT
  • GetProcAddress() : DLLWrapper
  • getRawData() : MDFReader
  • getRawFrameLength() : CANFrame, CCPFrame, XCPFrame
  • getRawValue() : MeasurementAccessData, DBCFile.SignalType
  • getReadPosition() : ICNBLOCK
  • getRecordSize() : ICGBLOCK
  • getRefFunctions() : A2LCONVERSION_REF, A2LNODE, A2LRECORD_LAYOUT
  • getRefNodes() : A2LAXIS_PTS, A2LCOMPU_METHOD, A2LCOMPU_TAB_BASE, A2LINSTANCE, A2LMEASUREMENT, A2LMEMORY_LAYOUT, A2LMEMORY_SEGMENT, A2LNODE, A2LRECORD_LAYOUT, A2LTRANSFORMER, A2LTYPEDEF
  • getRWIndicator() : Frame
  • getSamplePointCount() : MDFReader
  • getSection() : ELFFile
  • GetSectorInfo() : XCPMasterBase
  • getSecurityAccessRequests() : ODXRoot
  • GetSeed() : CCPMasterBase, XCPMasterBase
  • GetSegmentInfo() : XCPMasterBase
  • GetSegmentInfoAddress() : XCPMasterBase
  • GetSegmentInfoMapping() : XCPMasterBase
  • GetSegmentMode() : XCPMasterBase
  • getSendMsgLen() : CANProvider
  • getService() : ODXRoot
  • getServices() : ODXRoot
  • getSettings() : A2LXCP_MEDIA
  • getShiftCount() : Extensions
  • getSignal() : DBCFile.MsgType
  • getSingleRawValue() : Extensions
  • getSingleRawValueBuffer() : Extensions
  • getSize() : A2LAXIS_PTS, A2LCHARACTERISTIC, A2LRECORD_LAYOUT_REF, AbbrevEntry
  • getSizeInBit() : Extensions
  • getSizeInByte() : Extensions
  • getSlaveIDs() : XCPMaster
  • getStatistics() : BLFFile
  • GetStatus() : CCPMasterBase, XCPMasterBase
  • getSupportedProtocols() : EcuVariant
  • getSymbols() : A2LPROJECT
  • getSymTabs() : ELFFile.SectionList
  • getTimestamp() : LObj
  • getTimeStr() : Frame
  • getTransmissionRate() : CommMaster
  • getTrimmedText() : Extensions
  • getTSSize() : RespGetDAQResolutionInfo
  • getTypeRef() : DWARFInfo
  • getTypeStr() : CCPFrame, XCPFrame, DWARFInfo
  • getUnreadFrames() : FrameQueue< T >
  • getUsageInPercent() : MemorySegment
  • getUsedBytes() : MemorySegment
  • getValue() : ODTEntry
  • getValue< T >() : CharacteristicValue
  • getValuesToSynchronize() : ELFFile, MAPFile, SymbolFile
  • getVariable() : AbbrevEntry
  • getVariant() : ODXRoot
  • getVariants() : ODXRoot
  • getXCPInterfaces() : A2LMODULE
  • getXCPSettings() : A2LMODULE
  • getXmlSerializer() : Extensions


ASAP2Library interface: Class Members - Functions

- h -

  • hasSent() : CANProvider, LINProvider
  • HasSubfunction() : ServiceProperties


ASAP2Library interface: Class Members - Functions

- i -

  • IDBLOCK() : IDBLOCK
  • IDBLOCKV4() : IDBLOCKV4
  • IdentifierRequest() : UDSClient.IdentifierRequest
  • import() : IDataFile, DataFile
  • increment() : ICharValue
  • incrementOrDecrement() : BaseValue, CuboidValue, CurveValue, MapValue, SingleValue, ValBlkValue
  • Initialize() : RespBase, RespData, RespDTCCount, RespDTCRecords, RespDTCSeverityRecords, RespDynamicallyDefine, RespIdentfier, RespRequestUpDownload, RespReset, RespResponseOnEvent, RespRoutineControl, RespSecurityAccess, RespSession, RespSFBase, RespTimingParameter, RespTransferData, RespWriteMemoryByAddress
  • initialize() : BaseVariant, DataObjectProp, DiagService, EcuSharedData, EcuVariant, EndOfPDUField, Id, IId, Mux, ParamContainer, ParIdBase, Protocol, ProtStack, Session, Structure
  • InputOutputControlByIdentifier() : UDSClientBase
  • internalConnect() : CCPMasterBase, CommMaster, XCPMasterBase
  • internalGetStatus() : CCPMasterBase, CommMaster, XCPMasterBase
  • isAllowedRequest() : CCPMaster, CCPMasterBase, XCPMaster
  • isAvailable() : _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider
  • IsCANIdValid() : CANProvider
  • isDAQDynamic() : A2LXCP_DAQ
  • isMemoryIn() : MemorySegment
  • IsoTp() : IsoTp
  • IsoTpFSM() : IsoTpFSM
  • isReadOnly() : A2LRECORD_LAYOUT_REF
  • IsRegistered() : CommKernel
  • isSlaveBlockMode() : XCPMaster
  • isUpdateRequired() : AdaptiveState
  • isValidDesignator() : Extensions


ASAP2Library interface: Class Members - Functions

- j -

  • J1939Frame() : J1939Frame


ASAP2Library interface: Class Members - Functions

- l -

  • lengthToDLC() : CANProvider
  • LINConfiguration() : LINConfiguration
  • LINEventArgs() : LINEventArgs
  • LINFrame() : LINFrame
  • LinkControl() : UDSClientBase
  • LINProvider() : LINProvider
  • load() : DataFile, DataFileBin, DataFileHex, DataFileS19


ASAP2Library interface: Class Members - Functions

- m -

  • Main() : Program
  • mapAddress() : A2LMOD_PAR, CCPMaster, CommMaster, XCPMaster
  • MapValue() : MapValue
  • MDFWriter() : MDFWriter
  • MeasurementAccessData() : MeasurementAccessData
  • MemoryRange() : MemoryRange
  • MemorySegment() : MemorySegment
  • MemorySegmentList() : MemorySegmentList
  • modifyAddFunc() : CharacteristicValue
  • modifyBits() : XCPMaster
  • ModifyBits() : XCPMasterBase
  • modifyDivFunc() : CharacteristicValue
  • modifyInvFunc() : CharacteristicValue
  • modifyMulFunc() : CharacteristicValue
  • modifySetFunc() : CharacteristicValue
  • modifySubFunc() : CharacteristicValue
  • modifyValue() : ICharValue
  • Move() : CCPMasterBase
  • MsgType() : DBCFile.MsgType


ASAP2Library interface: Class Members - Functions

- n -

  • NativeSKDLL() : NativeSKDLL
  • notifyThread() : CANProvider, LINProvider
  • numToArray() : Extensions


ASAP2Library interface: Class Members - Functions

- o -

  • ODT() : ODT
  • ODTEntry() : ODTEntry
  • onCANReceived() : DBCFile
  • onDAQFrameReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • onErrorReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • onEventReceived() : CCPMaster, CCPMasterBase, XCPMaster, XCPMasterBase
  • OnFormClosing() : DataFileBinDlg
  • onParserMessage() : A2LParser
  • onReceive() : FrameProvider< T, V >
  • OnReceived() : DoIPBase.ResponseEvent
  • onReceived() : IsoTp, IsoTpFSM
  • onReceivedFR() : IsoTpFSM
  • OnResponseReceived() : DoIPBase, DoIPClient, DoIPServer
  • onServiceReceived() : XCPMaster, XCPMasterBase
  • open() : CDFFile, DataFile, DCMFile, MatlabFile, PARFile, BLFFile, _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider, DBCFile, ODXFile, MDFReader, ELFFile, MAPFile


ASAP2Library interface: Class Members - Functions

- p -

  • parse() : A2LParser
  • parse2DoubleVal() : Extensions
  • parse2IntVal() : Extensions
  • parse2SingleVal() : Extensions
  • ParserEventArgs() : ParserEventArgs
  • Program() : CCPMasterBase, XCPMasterBase
  • Program6() : CCPMasterBase
  • ProgramClear() : XCPMasterBase
  • ProgramFormat() : XCPMasterBase
  • ProgramMax() : XCPMasterBase
  • ProgramNext() : XCPMasterBase
  • ProgramPrepare() : XCPMasterBase
  • ProgramReset() : XCPMasterBase
  • ProgramStart() : XCPMasterBase
  • programSync() : CCPMaster, CommMaster, XCPMaster
  • ProgramVerify() : XCPMasterBase
  • ProgressArgs() : ProgressArgs


ASAP2Library interface: Class Members - Functions

- r -

  • RaiseConnectionStateChanged() : CommMaster
  • RaiseOnValuesReceived() : CommMaster
  • RationalCoeffs() : RationalCoeffs
  • readCharacteristic() : CommMaster
  • ReadDAQ() : XCPMasterBase
  • readData() : IDataContainer
  • ReadDataByIdentifier() : UDSClientBase
  • ReadDataByPeriodicIdentifier() : UDSClientBase
  • readDataContainer() : DataContainerV4
  • ReadDTCInformation() : UDSClientBase
  • ReadDTCInformationCount() : UDSClientBase
  • ReadDTCInformationRecords() : UDSClientBase
  • readFromXML() : A2LParser
  • readMemory() : UDSClient
  • ReadMemoryByAddress() : UDSClientBase
  • ReadScalingDataByIdentifier() : UDSClientBase
  • readSync() : CCPMaster, CommMaster, XCPMaster
  • readUTF8String() : ELFFile.SectionValue
  • recalcCoeffs() : ICCBLOCK
  • receive() : DoIPBase
  • receiveThread() : CANProvider, LINProvider
  • reduce() : MemoryRangeList
  • RegisterClient() : CommKernel
  • registerClient() : IFrameProvider< T >
  • reLoad() : IDataFile
  • removeIdentifier() : UDSClient
  • RequestDownload() : UDSClientBase
  • RequestFileTransfer() : UDSClientBase
  • RequestTransferExit() : UDSClientBase
  • RequestUpload() : UDSClientBase
  • reset() : XCPReceiveBuffer
  • resetDAQTime() : TimeBase
  • resetLastError() : CCPMasterBase, CommMaster, XCPMasterBase
  • resetReceiverCache() : DBCFile
  • resetReferences() : A2LREFBASE
  • respActionService() : Program.CCPSim
  • respAllocDAQ() : Program.XCPSim
  • respAllocODT() : Program.XCPSim
  • respAllocODTEntry() : Program.XCPSim
  • RespBase() : RespBase
  • respBuildChecksum() : Program.XCPSim
  • respBuildChksum() : Program.CCPSim
  • respClearDAQList() : Program.XCPSim
  • respClearMemory() : Program.CCPSim
  • respConnect() : Program.CCPSim, Program.XCPSim
  • respCopyCALPage() : Program.XCPSim
  • respDiagService() : Program.CCPSim
  • respDisconnect() : Program.CCPSim, Program.XCPSim
  • respDownload() : Program.CCPSim, Program.XCPSim
  • respDownload6() : Program.CCPSim
  • respDownloadMax() : Program.XCPSim
  • respExchangeID() : Program.CCPSim
  • respFreeDAQ() : Program.XCPSim
  • respGetActiveCALPage() : Program.CCPSim
  • respGetCalPage() : Program.XCPSim
  • respGetCCPVersion() : Program.CCPSim
  • respGetCommModeInfo() : Program.XCPSim
  • respGetDAQClock() : Program.XCPSim
  • respGetDAQEventInfo() : Program.XCPSim
  • respGetDAQListInfo() : Program.XCPSim
  • respGetDAQListMode() : Program.XCPSim
  • respGetDAQProcessorInfo() : Program.XCPSim
  • respGetDAQResolutionInfo() : Program.XCPSim
  • respGetDAQSize() : Program.CCPSim
  • respGetId() : Program.XCPSim
  • respGetPageInfo() : Program.XCPSim
  • respGetPAGProcessorInfo() : Program.XCPSim
  • respGetSeed() : Program.CCPSim, Program.XCPSim
  • respGetSegmentInfo() : Program.XCPSim
  • respGetStatus() : Program.CCPSim, Program.XCPSim
  • respModifyBits() : Program.XCPSim
  • respMove() : Program.CCPSim
  • ResponseOnEvent() : UDSClientBase
  • respPGMProcessorInfo() : Program.XCPSim
  • respProgram() : Program.CCPSim, Program.XCPSim
  • respProgram6() : Program.CCPSim
  • respProgramClear() : Program.XCPSim
  • respProgramFormat() : Program.XCPSim
  • respProgramMax() : Program.XCPSim
  • respProgramPrepare() : Program.XCPSim
  • respProgramReset() : Program.XCPSim
  • respProgramStart() : Program.XCPSim
  • respProgramVerify() : Program.XCPSim
  • respSectorInfo() : Program.XCPSim
  • respSelectCALPage() : Program.CCPSim
  • RespService() : RespService
  • respSetCalPage() : Program.XCPSim
  • respSetDAQListMode() : Program.XCPSim
  • respSetDAQPtr() : Program.CCPSim, Program.XCPSim
  • respSetMTA() : Program.CCPSim, Program.XCPSim
  • respSetRequest() : Program.XCPSim
  • respSetSegmentMode() : Program.XCPSim
  • respSetSStatus() : Program.CCPSim
  • respShortDownload() : Program.XCPSim
  • respShortUp() : Program.CCPSim
  • respShortUpload() : Program.XCPSim
  • respStartStop() : Program.CCPSim
  • respStartStopAll() : Program.CCPSim
  • respStartStopDAQList() : Program.XCPSim
  • respStartStopSynch() : Program.XCPSim
  • respSynch() : Program.XCPSim
  • respTest() : Program.CCPSim
  • respTransportLayerCmd() : Program.XCPSim
  • respUnlock() : Program.CCPSim, Program.XCPSim
  • respUpload() : Program.CCPSim, Program.XCPSim
  • respUserCmd() : Program.XCPSim
  • respWriteDAQ() : Program.CCPSim, Program.XCPSim
  • respWriteDAQMultiple() : Program.XCPSim
  • Restart() : DoIPBase.ResponseEvent
  • reverse() : Extensions
  • RoutineControl() : UDSClientBase
  • RoutingActivation() : DoIPClient


ASAP2Library interface: Class Members - Functions

- s -

  • save() : IDataFile, CDFFile, DCMFile, MatlabFile, PARFile, BLFFile, DBCFile, ODXFile, MDFReader, MDFWriter
  • SecuredDataTransmission() : UDSClientBase
  • SecurityAccessRequestSeed() : UDSClientBase
  • SecurityAccessSendKey() : UDSClientBase
  • SelectCALPage() : CCPMasterBase
  • send() : _8DevicesCAN, AdvantechCAN, CANProvider, EbElCAN, ELM327CAN, ESDCAN, ETASCAN, ICANProvider, IMEActiaCAN, IntrepidCAN, IXXATCAN, KvaserCAN, LawicelCAN, MHSCAN, NICAN, NIXNET, PeakCAN, SoftingCAN, VectorCAN, ETASLIN, ILINProvider, IntrepidLIN, IXXATLIN, KvaserLIN, LINProvider, PeakLIN, VectorLIN, ISxIProvider, SxIProvider
  • sendAndWait< T >() : DoIPBase
  • sendCmd() : ELM327CAN
  • sendError() : Program.XCPSim
  • sendEvent() : Program.CCPSim
  • sendMsg() : CANProvider, ICANProvider, ISxIProvider
  • sendPosResponse() : Program.UDSSim
  • sendRequest() : IsoTp
  • sendResponse() : Program.CCPSim, Program.XCPSim
  • sendServiceRequest() : Program.XCPSim
  • setBitmask() : Extensions
  • SetCalPage() : XCPMasterBase
  • setConnectionState< T >() : CCPMaster, CCPMasterBase, CommMaster, XCPMaster, XCPMasterBase
  • setContent() : A2LUNSUPPORTEDNODE
  • setCurrentDAQTimeFromSeconds() : TimeBase
  • SetDAQID() : XCPMasterBase
  • SetDAQListMode() : XCPMasterBase
  • SetDAQListUSBEndpoint() : XCPMasterBase
  • SetDAQPtr() : CCPMasterBase, XCPMasterBase
  • setData() : MeasurementAccessData
  • setDataBytes() : MemorySegment
  • setEPK() : IDataFile, DataFile
  • setFncValue() : ICharValue
  • SetMTA() : CCPMasterBase, XCPMasterBase
  • setPage() : CCPMaster, CommMaster, XCPMaster
  • setPhysValue() : MeasurementAccessData
  • SetRequest() : XCPMasterBase
  • SetSegmentMode() : XCPMasterBase
  • setSegmentsData() : IDataFile, DataFile
  • SetStatus() : CCPMasterBase
  • setValue() : CharacteristicValue
  • ShortDownload() : XCPMasterBase
  • ShortUp() : CCPMasterBase
  • ShortUpload() : XCPMasterBase
  • SignalType() : DBCFile.SignalType
  • SingleValue() : SingleValue
  • sortByAddress() : A2LNODE
  • sortByAddressAndName() : A2LNODE
  • sortByName() : A2LNODE
  • sortByTypeAndName() : A2LNODE
  • sortDataSegsToFront() : MemorySegmentList
  • SourceAndRaster() : SourceAndRaster
  • SrcDstFrame() : SrcDstFrame
  • SrcFrame() : SrcFrame
  • start() : FrameProvider< T, V >
  • StartListenToEntityAnnouncement() : DoIPClient
  • startMeasurements() : CCPMaster, CommMaster, XCPMaster
  • StartStop() : CCPMasterBase
  • StartStopAll() : CCPMasterBase
  • StartStopDAQList() : XCPMasterBase
  • StartStopSynch() : XCPMasterBase
  • stop() : FrameProvider< T, V >
  • stopDAQTime() : TimeBase
  • StopListenToEntityAnnouncement() : DoIPClient
  • stopMeasurements() : CCPMaster, CommMaster, XCPMaster
  • SxIEventArgs() : SxIEventArgs
  • SxIProvider() : SxIProvider
  • Synch() : XCPMasterBase


ASAP2Library interface: Class Members - Functions

- t -

  • TcpSocketWithTimeout() : TcpSocketWithTimeout
  • TesterPresent() : UDSClientBase
  • TimeCorrelationProperties() : XCPMasterBase
  • ToArray() : BaseFrame, SrcDstFrame, SrcFrame
  • toBinaryString() : Extensions
  • toByte() : Extensions
  • toByteArray< T >() : CCPFrame, XCPFrame
  • toCANIDPairString() : CANProvider
  • toCANIDString() : CANProvider
  • toClipboard() : CANFrame, J1939Frame, CCPFrame, Frame, LINFrame, XCPFrame, BaseFrame, UDSFrame
  • toCSV() : CANFrame, J1939Frame, CCPFrame, Frame, LINFrame, XCPFrame, BaseFrame, UDSFrame
  • ToCSV() : MDFReader
  • toDecimalString() : Extensions
  • toFileComment() : DBCFile.IDBCComment
  • toFileDefaultString() : DBCFile.IDBCAttribute
  • toFileString() : DBCFile.IDBCBase
  • toHexStr() : Extensions
  • toHexString() : Extensions
  • toLINIDString() : LINProvider
  • ToNICANId() : CANProvider
  • toPhyical() : DBCFile.SignalType
  • toPhysical() : A2LCOMPU_METHOD, A2LCOMPU_TAB, A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE, A2LFormula, RationalCoeffs, TabCoeffs, IdentifierRecord, ICCBLOCK, CCBLOCK, CCBLOCKV4
  • toRaw() : A2LCOMPU_METHOD, A2LCOMPU_TAB, A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE, A2LFormula, RationalCoeffs, TabCoeffs, DBCFile.SignalType
  • toSingleValue() : ICharValue
  • ToString() : A2LCCP_TP_BLOB, A2LFormula, A2LKWP_TP_BLOB, MemorySegmentList, BaseValue, DataFile, A2LXCP_ON_ETHERNET, DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, DataPoint, DataPointF
  • toStringValue() : A2LCONVERSION_REF, A2LMEASUREMENT, A2LRECORD_LAYOUT_REF, DBCFile.SignalType
  • toToolTipString() : DBCFile.IDBCComment
  • toUserDescriptrion() : IA2LMemory
  • toValString() : DBCFile.IDBCSignal
  • TransferData() : UDSClientBase
  • TransportLayerCmd() : XCPMasterBase
  • tryAcquire() : DoIPBase
  • TryConnect() : TcpSocketWithTimeout
  • tryGetMemoryMappedStream() : Extensions
  • tryParse2DoubleVal() : Extensions
  • tryParse2IntVal() : Extensions


ASAP2Library interface: Class Members - Functions

- u -

  • UDSClient() : UDSClient
  • UDSClientBase() : UDSClientBase
  • UDSFrame() : UDSFrame
  • unescapeStr() : Extensions
  • Unlock() : CCPMasterBase, XCPMasterBase
  • unlock() : UDSClient
  • unlockECU() : CCPMaster, XCPMaster
  • unregisterClient() : IFrameProvider< T >
  • updateAndWriteA2L() : SymbolFile
  • UpdateData() : UpdateData
  • updateFileLogSetting() : FrameQueue< T >
  • Upload() : CCPMasterBase, XCPMasterBase
  • upload() : UDSClient
  • UserCmd() : XCPMasterBase


ASAP2Library interface: Class Members - Functions

- v -

  • ValBlkValue() : ValBlkValue
  • ValueTable() : DBCFile.ValueTable
  • VehicleIdRequest() : DoIPClient


ASAP2Library interface: Class Members - Functions

- w -

  • write() : A2LParser
  • writeBlock() : IMDFBlock, BLOCKBASE, CCBLOCK, CDBLOCK, CEBLOCK, CGBLOCK, CNBLOCK, DGBLOCK, HDBLOCK, IDBLOCK, SRBLOCK, TRBLOCK, TXBLOCK, BLOCKBASEV4, CCBLOCKV4, CGBLOCKV4, CNBLOCKV4, DGBLOCKV4, DLBLOCKV4, DZBLOCKV4, FHBLOCKV4, HDBLOCKV4, HLBLOCKV4, IDBLOCKV4, RDSDBLOCKV4, SIBLOCKV4, SRBLOCKV4
  • WriteBytes() : XCPMasterBase
  • writeCharacteristic() : CommMaster
  • WriteDAQ() : CCPMasterBase, XCPMasterBase
  • WriteDAQMultiple() : XCPMasterBase
  • WriteDataByIdentifier() : UDSClientBase
  • writeMemory() : UDSClient
  • WriteMemoryByAddress() : UDSClientBase
  • writeSync() : CCPMaster, CommMaster, XCPMaster
  • writeToXML() : A2LParser


ASAP2Library interface: Class Members - Functions

- x -

  • XCPFrame() : XCPFrame
  • XCPMaster() : XCPMaster
  • XCPMasterBase() : XCPMasterBase
  • XCPonEth() : XCPonEth
  • XCPonUDP() : XCPonUDP
  • XCPReceiveBuffer() : XCPReceiveBuffer


ASAP2Library interface: Class Members - Variables

- a -

  • ActivationType : DoIPClient
  • AdaptiveCharList : AdaptiveState
  • Address : DWARFInfo.SymbolValue, UpdateData, UpdaterSymbols
  • AddressRef : UpdateData
  • AddressSize : CompilationUnitHeader
  • ArrayDim : DWARFInfo.SymbolValue, UpdaterSymbols
  • ArrayIdx : UpdaterSymbols
  • ArrayOffset : ODTEntry
  • AT : Attribute
  • Attributes : AbbrevEntry
  • axis_monotony : CNcomment


ASAP2Library interface: Class Members - Variables

- b -

  • Baudrate : CANConfiguration, LINConfiguration
  • BaudrateFD : CANConfiguration
  • BitCount : CANFDMessage64
  • BitOffset : UpdaterSymbols
  • Block : WriteRawDataEventArgs
  • breakOffset : LibWrapper.ChannelConfig
  • Brp : CANConfiguration.BitRatePar
  • BtrCfgArb : CANFDMessage64
  • BtrCfgData : CANFDMessage64
  • BtrExtArb : CANFDManaged
  • btrExtData : CANFDManaged
  • bus : SIcomment
  • BusId : CANConfiguration
  • BusID : CANFrame, CCPFrame
  • BusId : LINConfiguration
  • BusID : LINFrame
  • Bw : WriteRawDataEventArgs


ASAP2Library interface: Class Members - Variables

- c -

  • CAN_DATA_FRAMES : BLFFile
  • CAN_EXT_FLAG : CANProvider
  • CAN_EXT_ID_MASK : CANProvider
  • CAN_FD_XCP15_FLAG : CANProvider
  • CAN_ID_LIBRARY_VALID_MASK : CANProvider
  • CAN_ID_XCP15_VALID_MASK : CANProvider
  • CAN_STD_ID_MASK : CANProvider
  • Cancel : ProgressArgs
  • ChangeEndianess : CompilationUnitHeader
  • Channel : CANError, CANErrorExt, CANFDMessage, CANFDMessage64, CANMessage, CANConfiguration, FrameEventArgs< T >, LINConfiguration
  • channelBusActiveCapabilities : LibWrapper.ChannelConfig
  • channelBusCapabilities : LibWrapper.ChannelConfig
  • channelCapabilities : LibWrapper.ChannelConfig
  • channelIndex : LibWrapper.ChannelConfig
  • channelMask : LibWrapper.ChannelConfig
  • ChecksumType : LINConfiguration
  • ci : EType, NamesBase
  • Clock : CANConfiguration.BitRateConfig
  • Coeffs : RationalCoeffs
  • Command : CCPErrorArgs, XCPErrorArgs
  • common_properties : CommentBase
  • CompilationUnits : DWARFInfo
  • COMPort : CANConfiguration
  • COMPortConfig : CANConfiguration
  • configError : LibWrapper.ChannelConfig
  • connectedBusType : LibWrapper.ChannelConfig
  • connectionInfo : LibWrapper.ChannelConfig
  • Crc : CANFDMessage64
  • CRLF_DELIMITER : Constants
  • currentlyAvailableTimestamps : LibWrapper.ChannelConfig


ASAP2Library interface: Class Members - Variables

- d -

  • DAQList : DAQAndEvt, ODTEntry
  • DAQListNo : ValuesReceivedEventArgs
  • Data : CANFDManaged, RestorePointContainerManaged, SysVariableManaged, CANConfiguration.BitRateConfig, Frame, ValuesReceivedEventArgs, SxIEventArgs, RawDataRecord
  • DataLength : RestorePointContainer, SysVariable
  • DataOffset : ODTEntry
  • DataType : SysVariable
  • DefaultEntityAdr : DoIPClient
  • DefaultPort : DoIPBase
  • DefaultTesterAdr : DoIPClient
  • DefaultTLSPort : DoIPBase
  • DefFunctionDict : A2LPROJECT
  • delimiterOffset : LibWrapper.ChannelConfig
  • DESC : COMParamRef, LimitBase, NamedDescId
  • desc : EBase
  • DesiredEventChannels : DAQMeasurement
  • Dir : CANFDMessage64
  • Dlc : CANErrorExt, CANFDMessage64
  • DLC : LINConfiguration
  • DoIPClient : UDSClientBase
  • dominantRecessiveDelay : LibWrapper.ChannelConfig
  • dominantTimeout : LibWrapper.ChannelConfig
  • Dst : A2LCANAPE_ADDRESS_UPDATE.AdrMapType
  • DstAdr : SrcDstFrame


ASAP2Library interface: Class Members - Variables

- e -

  • Ecc : CANErrorExt
  • ELM327CmdTimeout : CANConfiguration
  • ELM327Protocol : CANConfiguration
  • EndPointNo : RespGetDAQListUSBEndpoint
  • Entities : DoIPClient
  • Entity : AnnoncementEventArgs
  • EntrySize : DWARFInfo.SymbolValue
  • ErrorCode : CCPErrorArgs, CCPEventArgs, XCPErrorArgs
  • Event : DoIPBase.Communicator
  • Evt : DAQAndEvt, DAQListXCP
  • EvtNo : DAQList
  • ExtDataOffset : CANFDMessage64


ASAP2Library interface: Class Members - Variables

- f -

  • FDBitRateConfig : CANConfiguration
  • FdFlags : CANFDMessage64
  • FILE_CACHE : Constants
  • Flags : CANErrorExt
  • FORM : Attribute
  • fpgaCoreCapabilities : LibWrapper.ChannelConfig
  • Frame : CANEventArgs, FrameEventArgs< T >, LINEventArgs
  • FrameFmt : XCPCommunicator
  • FrameLength : CANFDMessage64
  • FrameLengthInNs : CANErrorExt


ASAP2Library interface: Class Members - Variables

- h -

  • HardwareId : CANConfigException
  • HardwareType : CANConfiguration, LINConfiguration
  • HasChilds : AbbrevEntry
  • Header : MDFReader, ELFFile
  • hwChannel : LibWrapper.ChannelConfig
  • hwIndex : LibWrapper.ChannelConfig
  • hwType : LibWrapper.ChannelConfig


ASAP2Library interface: Class Members - Variables

- i -

  • Id : CANErrorExt, CANFDMessage64
  • ID : CANFrame, MDFReader
  • IdentifierMatch : Extensions
  • IdentifierRegEx : Extensions
  • Index : DAQMeasurement
  • Interfaces : DoIPClient
  • interfaceVersion : LibWrapper.ChannelConfig
  • Is64Bit : CompilationUnitHeader
  • isOnBus : LibWrapper.ChannelConfig


ASAP2Library interface: Class Members - Variables

- l -

  • LastElapsedTicks : AdaptiveState
  • Length : CANError, CANErrorExt, CompilationUnitHeader
  • LinesMax : A2LParserProgressEventArgs
  • LinesProcessed : A2LParserProgressEventArgs
  • linker_address : CNcomment
  • linker_name : CNcomment
  • LocalEp : DoIPServer
  • LocalIp : DoIPClient
  • LogicalAdr : DoIPServer


ASAP2Library interface: Class Members - Variables

- m -

  • mAdaptiveCharDict : CommMaster
  • mAG : XCPMasterBase
  • MasterID : LINConfiguration
  • Max : DataLimits, sRange
  • max : RasterType
  • MAX_DLC : CANProvider
  • MAX_FD_DLC : CANProvider
  • MAX_FRAMES_IN_MEMORY : Constants
  • MAX_POINTS_IN_MEMORY : Constants
  • MAX_UNCOMPRESSED_ZIP : Constants
  • maximalBaudrate : LibWrapper.ChannelConfig
  • maximalSupplyVoltage : LibWrapper.ChannelConfig
  • mConfig : CANProvider, LINProvider
  • mDataFiles : CommMaster
  • mDefaultCompuMethod : A2LCOMPU_METHOD
  • Measurement : DAQMeasurement, ODTEntry
  • MemoryRanges : AdaptiveState
  • mHandle : DLLWrapper
  • Min : DataLimits, sRange
  • min : RasterType
  • minimalSupplyVoltage : LibWrapper.ChannelConfig
  • mMaster : XCPCommunicator
  • Mode : CANConfiguration
  • mRxEvent : FrameProvider< T, V >
  • mStrTrimmer : CommMaster
  • mVersion : DoIPBase


ASAP2Library interface: Class Members - Variables

- n -

  • Name : SysVariableManaged
  • name : EBase
  • Name : ELFFile.ELFSection
  • NameLength : SysVariable
  • names : BaseNames
  • NEG_RESPONSE_VALUE : UDSClientBase
  • Next : MemoryRange
  • NoCompuMethod : A2LNODE
  • Nodes : ModelChangedEventArgs
  • Nominal : CANConfiguration.BitRateConfig
  • NonISO : CANConfiguration.BitRateConfig


ASAP2Library interface: Class Members - Variables

- o -

  • ODTEntries : DAQDict
  • ODTs : DAQList
  • ODX : ODXFile
  • Offset : CompilationUnitHeader
  • OpenArrays : MDFReader
  • OpenChannelGroups : MDFReader
  • OpenChannels : MDFReader


ASAP2Library interface: Class Members - Variables

- p -

  • Parent : DWARFInfo.SymbolValue
  • ParserMessage : ODXRoot, MDFReader
  • path : SIcomment
  • Percent : ProgressArgs
  • POS_RESPONSE_MASK : UDSClientBase
  • Position : CANErrorExt
  • protocol : SIcomment


ASAP2Library interface: Class Members - Variables

- r -

  • Raster : SourceAndRaster
  • raster : CNcomment
  • Reader : ELFFile
  • ReceivedEvent : XCPEventArgs
  • ReceivedServiceRequest : XCPServiceRequestArgs
  • recessiveDominantDelay : LibWrapper.ChannelConfig
  • Record : UDSClient.IdentifierRequest
  • RefId : AbbrevEntry
  • RemoteEp : DoIPClient
  • Representation : SysVariable
  • RequestSTMin : IsoTpFSM
  • ro : EType
  • RootEntries : CompilationUnitHeader


ASAP2Library interface: Class Members - Variables

- s -

  • SDG_CAPTION_REF : Sdg
  • Seconds : ValuesReceivedEventArgs
  • Sections : ELFFile
  • Sender : BaseFrame
  • Size : ODTEntry, DataPoint, DataPointF, DWARFInfo.SymbolValue, UpdateData, UpdaterSymbols
  • SkippedValues : DataConservation
  • Source : SourceAndRaster
  • SourceAndRasterMap : CCPMaster
  • SourceFile : MDFReader
  • specialCabFlags : LibWrapper.ChannelConfig
  • specialDeviceStatus : LibWrapper.ChannelConfig
  • Src : A2LCANAPE_ADDRESS_UPDATE.AdrMapType
  • SrcAdr : DoIPClient, SrcFrame
  • Start : MemoryRange
  • State : DAQListXCP
  • SubNodes : TreeType
  • SxI : SxIProvider
  • Symbols : DWARFInfo, ELFFile, MAPFile


ASAP2Library interface: Class Members - Variables

- t -

  • TAG : AbbrevEntry
  • Tag : UpdaterSymbols
  • TcpRemoteEP : DoIPBase.Communicator
  • Text : Annotation, EType, NamesBase
  • time_source : HDcomment
  • TimeCycle : DAQList
  • TimeOffsetBrsNs : CANFDMessage64
  • TimeOffsetCrcDelNs : CANFDMessage64
  • Timestamp : Annotation, RawDataRecord
  • tool_id : FHcomment
  • tool_vendor : FHcomment
  • tool_version : FHcomment
  • transceiverName : LibWrapper.ChannelConfig
  • transceiverState : LibWrapper.ChannelConfig
  • transceiverType : LibWrapper.ChannelConfig
  • TX : CommentBase
  • TxCount : CANFDMessage64
  • TxTimeout : CANConfiguration
  • Type : ModelChangedEventArgs, CANFrame
  • type : EType
  • Type : DWARFInfo.SymbolValue, ELFFile.ELFSection, UpdateData
  • TYPE_ : DataBlock


ASAP2Library interface: Class Members - Variables

- u -

  • UH : AbbrevEntryCU
  • unit : EType, RasterType
  • unit_ref : EType, RasterType
  • user_name : FHcomment


ASAP2Library interface: Class Members - Variables

- v -

  • ValidDataBytes : CANFDMessage64
  • ValidFlags : CANErrorExt
  • value : RasterType
  • VarBase : DWARFInfo.SymbolValue
  • Version : LINConfiguration, CompilationUnitHeader


ASAP2Library interface: Class Members - Variables

- w -

  • WS_DELIMITER : Constants


ASAP2Library interface: Class Members - Variables

- x -

  • X : DataPoint, DataPointF


ASAP2Library interface: Class Members - Variables

- y -

  • Y : DataPoint, DataPointF


ASAP2Library interface: Class Members - Variables

- z -

  • ZLIB_HEADER : Constants


ASAP2Library interface: Class Members - Enumerations

  • AttribDefObjectType : DBCFile
  • AttribDefValueType : DBCFile
  • EccFlagsType : CANErrorExt
  • EndiannessType : ELFFile
  • EnvAccessType : DBCFile
  • EnvType : DBCFile
  • FlagsType : CANErrorExt, ELFFile
  • FormatType : ELFFile
  • MachineType : ELFFile
  • OSType : ELFFile
  • ParType : PARFile
  • ResultSk : NativeSKDLL
  • SectionType : ELFFile
  • SignalFlagsType : DBCFile
  • SignalFloatType : DBCFile
  • SortMode : DBCFile
  • SymbolBindType : ELFFile
  • SymbolType : ELFFile
  • TypeType : ELFFile
  • UpdType : PDXIndex
  • ValidFlagsType : CANErrorExt
  • VersionType : ELFFile
  • VKeyGenResultEx : NativeSKDLL


ASAP2Library interface: Class Members - Properties

- a -

  • A : A2LKWP_TP_BLOB.KWP_SERAM
  • ABLOCKS : PDXIndex
  • AbsoluteDiff : DataLimits
  • Access : DBCFile.EnvironmentType
  • AccessECU : A2LXCP_PAGE
  • AccessMode : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • AccessRead : A2LXCP_PAGE
  • AccessWrite : A2LXCP_PAGE
  • Accuracy : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • ActivationResult : RoutingActivationResponse
  • Active : A2LCCP_SOURCE, A2LXCP_DAQ_LIST
  • ActivePage : CommMaster
  • AddOffset : ICNBLOCK
  • Address : A2LADDRESS, A2LCANAPE_ADDRESS_UPDATE.FlashSectionType, A2LCCP_DP_BLOB, IA2LMemory, A2LKWP_DP_BLOB, A2LKWP_KP_BLOB, MemorySegment, DataFileBinDlg, A2LXCP_ON_ETHERNET, CANFrame, CCPFrame, LINFrame, ODTEntry, XCPFrame, XCPMasterBase, SrcDataMemory, UDSFrame, MAPFile.SymbolValue
  • AddressExt : A2LCCP_DP_BLOB
  • AddressExtension : A2LADDRESS, A2LXCP_SEGMENT
  • Addressing : DiagService
  • AddressOffset : A2LSTRUCTURE_COMPONENT
  • AddrType : A2LTYPEDEF_MEASUREMENT
  • Adr : ELFFile.ELFSection
  • AdrAlign : ELFFile.ELFSection
  • AdressType : A2LRECORD_LAYOUT.AxisPtsLayoutDesc, A2LRECORD_LAYOUT.FncValuesLayoutDesc
  • AdrFLASH : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM
  • AdrLen : RespWriteMemoryByAddress
  • AdrRAM : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM
  • Alignment : A2LXCP_ENDPOINT
  • Alignments : A2LMOD_COMMON, A2LRECORD_LAYOUT
  • Alignments_ : A2LRECORD_LAYOUT
  • AlternateSettingNo : A2LXCP_ON_USB
  • AltSampleCounts : A2LXCP_EVENT_DAQ_PACKED_MODE
  • AppName : Extensions
  • AppVersion : Extensions
  • AS : KWP_USDTP_TIMING
  • AttributeDefinitions : DBCFile
  • Attributes : DBCFile, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalType, DBCFile.SourceType
  • AutoSarSinglePointered : A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD
  • AxisIdx : A2LRECORD_LAYOUT.ItemLayoutDesc
  • AxisPts : A2LRECORD_LAYOUT
  • AxisRescaleX : A2LRECORD_LAYOUT
  • AxisValue : ICharValue, CABLOCKV4


ASAP2Library interface: Class Members - Properties

- b -

  • BASE_TYPE_ENCODING : DiagCodedTypeBase
  • BaseAddress : A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING
  • BAUD_DEFs : A2LKWP_TP_BLOB
  • Baudrate : A2LKWP_CAN
  • BaudRate : A2LKWP_TP_BLOB.BAUD_DEF
  • Bind : ELFFile.ELFSymbol
  • BinFileOffset : MemorySegment
  • Bitmask : A2LCHARACTERISTIC
  • BitMask : A2LMEASUREMENT
  • Bitmask : A2LTYPEDEF_CHARACTERISTIC
  • BitMask : A2LTYPEDEF_MEASUREMENT
  • BitmaskCache : ICNBLOCK
  • BitOffset : ODTEntry, ICNBLOCK, AbbrevEntryMember
  • BitSTIMSupported : A2LXCP_STIM
  • BlobDict : A2LPROJECT
  • BlockModeID : A2LKWP_SOURCE.QP_BLOB
  • BlockSequenceCounter : RespTransferData
  • BlockSize : IMDFBlock
  • BS : KWP_USDTP_TIMING
  • BTLCycles : A2LKWP_CAN, A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • BusID : DBCFile.MsgType
  • ByteOffsetBase : CABLOCKV4
  • ByteOrder : A2LAXIS_DESCR, A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF, A2LXCP_PROTOCOL_LAYER, XCPMaster
  • ByteSize : UpdaterSymbols


ASAP2Library interface: Class Members - Properties

- c -

  • CABlock : CNBLOCKV4
  • CalcMode : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • CalDll : A2LCCP_SEED_KEY
  • CANFillerByte : Protocol
  • CANFillerByteHandling : Protocol
  • CANId : A2LKWP_SOURCE.QP_BLOB, DAQList
  • CANIdECU : A2LKWP_ADDRESS
  • CANIDMasterIncremental : A2LXCP_ON_CAN
  • CANIdTester : A2LKWP_ADDRESS
  • CanWrite : CommMaster
  • Caption : Sdg
  • CATEGORY : CompuMethod, PDXIndex.ABLOCK
  • CCBlock : ICNBLOCK
  • CD : KWP_USDTP_TIMING
  • CDBlock : ICNBLOCK
  • CEBlock : ICNBLOCK
  • CGBlock : ICNBLOCK
  • CGBlocks : IDGBLOCK
  • ChangedType : A2LNODE
  • ChangedValues : IDataFile
  • ChangeEndianess : CommMaster
  • Channel : DependencyType
  • ChannelGroup : DependencyType
  • ChannelType : ICNBLOCK, CNBLOCKV4
  • Characteristic : ICharValue
  • CharDict : A2LPROJECT
  • CharType : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC, ICharValue
  • CheckSum : A2LXCP_CHECKSUM
  • Childs : A2LNODE, AbbrevEntry, DWARFInfo.SymbolValue
  • ChkSumType : A2LKWP_CHECKSUM
  • ClientCount : IFrameProvider< T >
  • CmdId : IsoTp, UDSClientBase
  • CNBlocks : ICGBLOCK, ICNBLOCK, CNBLOCKV4
  • Comment : DBCFile, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalType, DBCFile.SourceType, IMDFComment
  • CommMode : XCPCommModes
  • CommModeInfoResponse : XCPMaster
  • ComparisonQuantity : A2LCHARACTERISTIC
  • CompDict : A2LPROJECT
  • COMPLEMENTARY_BYPASS_EVENT_CHANNEL_NUMBER : A2LXCP_EVENT
  • Compress : MDFWriter
  • CompressionMethod : A2LXCP_SEGMENT
  • CompTabDict : A2LPROJECT
  • COMPU_INTERNAL_TO_PHYS : CompuMethod
  • COMPU_SCALES : CompuInternalToPhys
  • CompVTabDict : A2LPROJECT
  • CompVTabRangeDict : A2LPROJECT
  • ConnectBehaviour : CommMaster
  • Connected : CommMaster
  • ConnectResponse : CCPMaster, XCPMaster
  • Content : A2LUNSUPPORTEDNODE
  • Conversion : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • COPY_PARA : A2LKWP_COPY
  • CORE_LOAD : A2LXCP_CORE_LOAD
  • CORE_NR : A2LXCP_CORE_LOAD
  • CoreLoadMaxTotal : A2LXCP_DAQ
  • Count : ODTEntry, RespDTCCount
  • CountErrors : A2LParser, ODXRoot, MDFReader
  • CountWarnings : A2LParser, ODXRoot, MDFReader
  • CpuLoadMaxTotal : A2LXCP_DAQ
  • CREATION_DATE : PDXIndex.FILE
  • CreatorIndex : ATBLOCKV4, EVBLOCKV4
  • Ctr : CCPFrame, XCPFrame
  • CurrentDiagSession : UDSClientBase
  • CustomFlags : IIDBLOCK
  • Cycle : UDSClient.IdentifierRequest
  • CycleCount : CABLOCKV4


ASAP2Library interface: Class Members - Properties

- d -

  • DAQAlternatingSupported : A2LXCP_DAQ
  • DAQAndEvtMap : A2LXCP_DAQ, XCPMaster
  • DAQClock : XCPMaster
  • DaqDll : A2LCCP_SEED_KEY
  • DAQLastTimestamp : TimeBase
  • DAQMemoryLimit : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • DAQNo : A2LXCP_DAQ_LIST_USB_ENDPOINT, DAQList
  • DAQPosition : ODTEntry
  • DAQProcInfo : XCPMaster
  • DAQResolutionInfo : XCPMaster
  • DAQs : CommMaster
  • DAQSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • Data : MemorySegment, RespData, FlashDataIntern
  • DATA_ : FlashDataIntern
  • DATA_ACCESS : A2LKWP_TP_BLOB
  • DataBytesPerLine : DataFile
  • DataChunks : MeasurementAccessData
  • DataFile : MemorySegment
  • DataGroup : DependencyType
  • DataPage : J1939Frame
  • DataReceived : MDFWriter
  • DataTransferBaudrate : A2LXCP_CAN_FD
  • DataType : A2LMEASUREMENT, A2LRECORD_LAYOUT.ItemLayoutDesc, A2LTYPEDEF_MEASUREMENT, DBCFile.AttribDefType, DBCFile.SignalType
  • Date : CCBLOCK
  • DecimalCount : A2LCONVERSION_REF, ICharValue
  • DecimalCountAxis : ICharValue
  • DefaultPageNumber : A2LXCP_SEGMENT
  • DefaultText : ICCBLOCK
  • Delaytime : A2LKWP_TP_BLOB.SECURITY_ACCESS
  • DependencyType : CDBLOCK
  • Deposit : A2LTYPEDEF_AXIS
  • Description : A2LADDRESS, IA2LDescription, COMParamRef, IDescription, LimitBase, NamedDescId, ICNBLOCK
  • DescriptionAddition : AdditiveDescriptionEventArgs
  • DGBlock : ICGBLOCK
  • DGBlocks : IHDBLOCK
  • DiagMode : A2LKWP_TP_BLOB.BAUD_DEF
  • DIM : CEBLOCK
  • DimSize : CABLOCKV4
  • Discrete : A2LCHARACTERISTIC, A2LMEASUREMENT, A2LTYPEDEF_CHARACTERISTIC, A2LTYPEDEF_MEASUREMENT
  • Discriminator : A2LKWP_SOURCE.QP_BLOB
  • Display : A2LCANAPE_EXT
  • DisplayName : A2LADDRESS, IA2LDescription
  • DistOp : A2LRECORD_LAYOUT
  • DLC : DBCFile.MsgType
  • Dll : A2LCCP_CHECKSUM
  • DOCTYPE : IdRef
  • DopRef : ParSystem, ParValue
  • DstAdr : DoIPClient
  • DstOffset : FHBLOCKV4, HDBLOCKV4
  • DTC : DTCAndStatusRecord
  • DTCs : RespDTCRecords, RespDTCSeverityRecords
  • DTCS_ : DtcDop
  • Duration : Header
  • Dwarf : ELFFile


ASAP2Library interface: Class Members - Properties

- e -

  • E : A2LKWP_TP_BLOB.KWP_SERAM
  • ECU_CALIBRATION_OFFSET : A2LCANAPE_ADDRESS_UPDATE
  • ECUAddress : A2LKWP_TP_BLOB
  • EID : VehicleIdResponse
  • Elapsed : Frame, TimeBase
  • ElapsedDAQSeconds : TimeBase
  • ElapsedTicks : TimeBase
  • ELMNname : ELM327CAN
  • Encoding : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC
  • EncryptionMethod : A2LXCP_SEGMENT
  • Ended : Header
  • EndLine : A2LNODE
  • EntSize : ELFFile.ELFSection
  • Enum : DBCFile.ValueTable
  • Enums : DBCFile.AttribDefType, DBCFile.SignalType
  • Environments : DBCFile
  • EPK : DataFileBin
  • EPK_ADDRESS : A2LCANAPE_ADDRESS_UPDATE
  • EPKAddress : DataFileBin
  • EPNo : A2LXCP_DAQ_LIST_USB_ENDPOINT, A2LXCP_ENDPOINT
  • EPPollInterval : A2LXCP_ENDPOINT
  • EPType : A2LXCP_DAQ_LIST_USB_ENDPOINT
  • ErrorCode : RespError, RespBase
  • ErrorMask : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • ErrorsReceived : CommMaster
  • EventFixed : A2LXCP_DAQ_LIST
  • Events : A2LXCP_DAQ_EVENT, A2LXCP_EVENT_LIST
  • EventsReceived : CommMaster
  • EventWindowTime : RespResponseOnEvent
  • EVersion : A2LKWP_TP_BLOB
  • EvtNo : A2LXCP_EVENT_CAN_ID_LIST
  • ExchangeIDResponse : CCPMaster
  • ExchangeIDStr : CCPMaster
  • ExDataPage : J1939Frame
  • ExternalFunction : A2LXCP_CHECKSUM
  • ExternalReferences : ODXRoot


ASAP2Library interface: Class Members - Properties

- f -

  • Factor : RationalCoeffs, DBCFile.SignalType
  • FileID : IIDBLOCK
  • FileName : A2LParser
  • FilePath : DLLWrapper
  • FILES : PDXIndex.ABLOCK
  • FillByte : IsoTp, UDSClientBase
  • First : A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
  • FirstPID : DAQList
  • FixedCANIds : A2LXCP_EVENT_CAN_ID_LIST
  • FixNoAxisPts : A2LRECORD_LAYOUT
  • Flags : A2LKWP_TP_BLOB.KWP_DATA_ACCESS, A2LKWP_TP_BLOB.KWP_SERAM, DBCFile.SignalType, CNBLOCKV4, ELFFile.ELFSection
  • FlashSection : A2LCANAPE_ADDRESS_UPDATE.ExSymbolType
  • FLASHToRAMDiagMode : A2LKWP_COPY, A2LKWP_FLASH_COPY
  • FLASHToRAMMode : A2LKWP_COPY, A2LKWP_FLASH_COPY
  • FloatType : DBCFile.SignalType
  • FncValues : A2LRECORD_LAYOUT
  • ForbiddenDict : A2LVAR_FORBIDDEN_COMB
  • ForbiddenDict_ : A2LVAR_FORBIDDEN_COMB
  • Format : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • FormatIdentifier : RespDTCCount
  • Formula : ICCBLOCK
  • FormulaDict : A2LPROJECT
  • Frame : RespBase
  • FrameDict : CANFrameQueue, LINFrameQueue
  • FramesReceived : CommMaster
  • FramesSent : CommMaster
  • FuncDict : A2LPROJECT
  • FuncReqCANId : Protocol
  • FurtherAction : VehicleIdResponse


ASAP2Library interface: Class Members - Properties

- g -

  • GID : VehicleIdResponse
  • GroupDict : A2LPROJECT
  • GroupMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • GuardRails : A2LRECORD_LAYOUT_REF


ASAP2Library interface: Class Members - Properties

- h -

  • HasTypeInfo : AbbrevEntry
  • Header : BLFFile
  • HeaderLen : A2LXCP_ON_USB
  • HostBufferSize : A2LXCP_ENDPOINT
  • HostName : A2LXCP_ON_ETHERNET


ASAP2Library interface: Class Members - Properties

- i -

  • ID : CCPFrame, LINFrame, DBCFile.MsgType, DBCFile.SignalGroupType, UDSFrame, IId
  • Id : BLOCKBASE, BLOCKBASEV4
  • Identification : A2LRECORD_LAYOUT
  • Identifier : RespDynamicallyDefine, RespIdentfier, SrcDataIdentifier, IdentifierRecord
  • Identifiers : DiagService
  • IDString : DBCFile.MsgType
  • ik : A2LKWP_TP_BLOB.BAUD_DEF
  • InCircuit2 : A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD
  • IncludedFiles : A2LParser
  • Index : ODTEntry, DBCFile.EnvironmentType, MAPFile.SymbolValue
  • IndexMode : A2LRECORD_LAYOUT.FncValuesLayoutDesc
  • IndexOrder : A2LRECORD_LAYOUT.AxisPtsLayoutDesc
  • Info : ELFFile.ELFSection
  • InitProtocol : ELM327CAN
  • InputQuantity : A2LTYPEDEF_AXIS
  • Instance : CANFrameQueue, J1939FrameQueue, CCPFrameQueue, LINFrameQueue, XCPFrameQueue, DoIPFrameQueue, UDSFrameQueue
  • InstanceDict : A2LPROJECT
  • Interface : CommMaster
  • InterfaceDescriptor : A2LXCP_ON_USB
  • InvalBitPosBase : CABLOCKV4
  • InvalSize : CGBLOCKV4
  • InvCCBlock : ICCBLOCK
  • IPV6 : A2LXCP_ON_ETHERNET
  • IsBitfield : UpdaterSymbols
  • IsDAQ : CCPFrame, XCPFrame
  • IsDAQRunning : CCPMaster, XCPMaster
  • IsDataSegment : MemorySegment
  • IsDeclaration : AbbrevEntry
  • IsDirty : IDataFile
  • IsError : CCPFrame, XCPFrame, BaseFrame, UDSFrame
  • IsExpanded : DWARFInfo.SymbolValue
  • IsExtendedID : CANFrame
  • IsExternal : AbbrevEntryVariable
  • IsExternalSymbol : AbbrevEntryVariable
  • IsFirstPID : ODT
  • IsFixed : A2LXCP_TIMESTAMP_SUPPORTED
  • IsFormatNotSet : A2LAXIS_DESCR, A2LCONVERSION_REF
  • IsInitialized : MemorySegment
  • IsInstanced : A2LNODE
  • IsLittleEndian : DBCFile.SignalType
  • IsMasterFrame : Frame
  • IsMultiplexed : DBCFile.SignalType
  • IsMultiplexSignal : DBCFile.SignalType
  • IsPrototyped : AbbrevEntry
  • IsReadOnly : IA2LMemory
  • IsSigned : DBCFile.SignalType
  • IsStoring : RespGetStatus
  • IsString : A2LCOMPU_METHOD
  • IsSymbol : AbbrevEntryVariable
  • IsValid : DBCFile.MsgType
  • IsWritingToFile : FrameQueue< T >


ASAP2Library interface: Class Members - Properties

- k -

  • K_LINE : A2LKWP_TP_BLOB
  • KeepDuplicateNodes : A2LParser
  • Key : VehicleIdResponse
  • KeyValuePairs : ICCBLOCK


ASAP2Library interface: Class Members - Properties

- l -

  • Language : AbbrevEntryCU
  • Last : A2LCANAPE_ADDRESS_UPDATE.FirstLastNode
  • LastDiagNackCode : DoIPBase
  • LastErrorEnum : CommMaster
  • LastErrorResponse : CCPMasterBase, XCPMasterBase
  • LastErrorText : CommMaster
  • LastNackCode : DoIPBase
  • LastReceivedTime : CommMaster
  • LastResponse : CCPMasterBase, XCPMasterBase, UDSClient.IdentifierRequest
  • LastStateChange : CommMaster
  • LastUpdate : DBCFile.MsgType, DBCFile.SignalType, UDSClient.IdentifierRequest
  • LATEBOUND_DATAFILE : DataFile
  • Layout : A2LINSTANCE, A2LMEASUREMENT, A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_MEASUREMENT
  • LayoutEntries : A2LRECORD_LAYOUT
  • Len : CCPFrame, XCPFrame, DBCFile.SignalType, UDSFrame
  • Length : A2LCANAPE_ADDRESS_UPDATE.FlashSectionType, A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING, A2LKWP_DP_BLOB, DZBLOCKV4
  • LenOfTimeInt : ISRBLOCK
  • Limit : A2LCCP_CHECKSUM_PARAM
  • Link : ELFFile.ELFSection
  • LinkCG : DependencyType
  • LinkCN : DependencyType
  • LinkDG : DependencyType
  • LinkMap : A2LCANAPE_EXT
  • LocalRoutineNo : A2LKWP_CHECKSUM, A2LKWP_ROUTINE_PARA
  • Location : A2LKWP_KP_BLOB, AbbrevEntryVarBase
  • LogFileCSVHeader : FrameQueue< T >
  • LogFileName : FrameQueue< T >
  • LogicalAdr : VehicleIdResponse
  • LogUnsupportedNodes : A2LParser
  • LowerLimit : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • LowerLimitEx : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF


ASAP2Library interface: Class Members - Properties

- m -

  • MajorVersion : A2LParser
  • MapAddress : A2LCCP_ADDRESS_MAPPING, A2LKWP_ADDRESS_MAPPING
  • Mask : DBCFile.SignalType
  • MasterLimits : MDFReader
  • MatrixDim : A2LCHARACTERISTIC, A2LINSTANCE, A2LMEASUREMENT, A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_CHARACTERISTIC, A2LTYPEDEF_MEASUREMENT
  • Max : DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, ICCBLOCK, ICNBLOCK
  • MaxAxisPoints : A2LTYPEDEF_AXIS
  • MaxBitRate : A2LXCP_ON_ETHERNET
  • MaxBlockSize : A2LXCP_CHECKSUM
  • MaxBS : XCPCommModes
  • MaxBusLoad : A2LXCP_MEDIA
  • MaxCTO : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • MaxDAQ : A2LXCP_DAQ
  • MaxDAQTotal : A2LXCP_DAQ
  • MaxDataSize : EntityStatusResponse
  • MaxDiff : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • MaxDLC : A2LXCP_CAN_FD
  • MaxDLCRequired : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • MaxDTO : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • MaxDTOStim : A2LXCP_PROTOCOL_LAYER
  • MaxEvtChn : A2LXCP_DAQ
  • MaxEx : ICNBLOCK
  • MaxLength : AnnotationList
  • MaxMsgLen : IsoTp, UDSClientBase
  • MaxNoOfBytes : A2LKWP_SOURCE.QP_BLOB
  • MaxNoOfSignals : A2LKWP_SOURCE.QP_BLOB
  • MaxNoRescalePairs : A2LRECORD_LAYOUT.AxisRescaleLayoutDesc
  • MaxNumberOfBlockLength : RespRequestUpDownload
  • MaxODTDAQTotal : A2LXCP_DAQ
  • MaxODTEntriesDAQTotal : A2LXCP_DAQ
  • MaxODTEntriesSTIMTotal : A2LXCP_DAQ
  • MaxODTEntriesTotal : A2LXCP_DAQ
  • MaxODTEntrySize : A2LXCP_DAQ
  • MaxODTSTIMTotal : A2LXCP_DAQ
  • MaxODTTotal : A2LXCP_DAQ
  • MaxPktSize : A2LXCP_ENDPOINT
  • MaxRaw : ICNBLOCK
  • MaxSamplingRate : A2LKWP_SOURCE.QP_BLOB
  • MaxSockets : EntityStatusResponse
  • MeasDict : A2LPROJECT
  • MeasurementAccessData : CommMaster
  • MeasuremntMode : A2LKWP_SOURCE.QP_BLOB
  • MemoryAddress : RespWriteMemoryByAddress
  • MemoryRanges : MeasurementAccessData
  • MemorySize : RespWriteMemoryByAddress, SrcDataIdentifier
  • Message : ParserEventArgs
  • Messages : DBCFile.SourceType
  • MIME_TYPE : PDXIndex.FILE
  • Min : DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.SignalType, ICCBLOCK, ICNBLOCK
  • MinDAQ : A2LXCP_DAQ
  • MinEx : ICNBLOCK
  • MinorVersion : A2LParser
  • MinRaw : ICNBLOCK
  • MinST : XCPCommModes
  • MinSTSTIM : A2LXCP_STIM
  • Mode : A2LKWP_PAGE_SWITCH, A2LXCP_DAQ
  • ModelLink : A2LADDRESS
  • Monotony : A2LOVERWRITE, A2LTYPEDEF_AXIS
  • Msg : DBCFile.SignalType
  • MTABlockSizeAlign : A2LXCP_CHECKSUM
  • MultiplexValue : DBCFile.SignalType


ASAP2Library interface: Class Members - Properties

- n -

  • Name : A2LCANAPE_ADDRESS_UPDATE.SymbolType, A2LCANAPE_EXT, A2LNAMEDNODE, A2LNODE, A2LCCP_NAMEDNODE, IA2LDescription, A2LKWP_NAMEDNODE, A2LXCP_NAMEDNODE, DBCFile.AttribDefType, DBCFile.EnvironmentType, DBCFile.MsgType, DBCFile.SignalGroupType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, IdentifierRecord, IMDFBlock, BLOCKBASEV4, AbbrevEntry, DWARFInfo.SymbolValue, ELFFile.SectionValue, ELFFile.SymbolValue, MAPFile.SymbolValue
  • NDim : CABLOCKV4
  • NegativeResponseCodes : UDSClient
  • NoAxisPts : A2LRECORD_LAYOUT
  • Node : WriterException
  • NodeType : EntityStatusResponse
  • NoOfBits : ICNBLOCK
  • NoOfPages : A2LXCP_SEGMENT
  • NoOfSamplings : A2LKWP_SOURCE.QP_BLOB
  • NoRescaleX : A2LRECORD_LAYOUT
  • NoResponseTesterPresent : UDSClient
  • NrOfRedSamples : ISRBLOCK
  • NS : DBCFile
  • Number : A2LCHARACTERISTIC, A2LTYPEDEF_CHARACTERISTIC, DBCFile.SignalGroupType
  • NumberOfIdentifiedEvents : RespResponseOnEvent
  • NumberOfIF : A2LXCP_ON_USB


ASAP2Library interface: Class Members - Properties

- o -

  • O : A2LKWP_TP_BLOB.KWP_SERAM
  • ObjectCount : BLFFile
  • ObjectType : DBCFile.AttribDefType
  • ODT_DAQ : A2LXCP_BUFFER_RESERVE
  • ODT_STIM : A2LXCP_BUFFER_RESERVE
  • ODTDAQBufferElementSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTDict : DAQListXCP
  • ODTEntries : A2LXCP_ODT, ODT
  • ODTEntrySize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTNo : A2LXCP_ODT
  • ODTSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • ODTSTIMBufferElementSize : A2LXCP_DAQ_MEMORY_CONSUMPTION
  • Odx : Id, IId
  • Offset : A2LCANAPE_ADDRESS_UPDATE.SymbolType, A2LRECORD_LAYOUT, RationalCoeffs, DBCFile.SignalType
  • Offsets : IA2LMemory
  • Ofs : ELFFile.ELFSection
  • OnlyOnActivePage : A2LKWP_CHECKSUM
  • OpenSockets : EntityStatusResponse
  • OptionalCmds : A2LXCP_PROTOCOL_LAYER
  • OptionalTLCmds : A2LXCP_MEDIA
  • OriginalPtrTable : A2LCANAPE_ADDRESS_UPDATE.ExSymbolType
  • OriginalStart : DBCFile.SignalType


ASAP2Library interface: Class Members - Properties

- p -

  • p1Max : KWP_TIME_DEF
  • P2Client : IsoTp, UDSClientBase, Protocol
  • P2ExServerMax : RespSession
  • p2Max : KWP_TIME_DEF
  • p2Min : KWP_TIME_DEF
  • P2ServerMax : RespSession
  • P3Client : IsoTp, UDSClientBase, Protocol
  • p3Max : KWP_TIME_DEF
  • p3Min : KWP_TIME_DEF
  • p4Min : KWP_TIME_DEF
  • Packing : A2LXCP_ENDPOINT
  • PackMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • PageNo : A2LXCP_PAGE
  • PAGProcInfo : XCPMaster
  • Params : ICCBLOCK
  • Parent : A2LNODE, DBCFile.SourceType, IMDFBlock, AbbrevEntry
  • ParserEvents : ODXRoot, MDFReader
  • PDUFormat : J1939Frame
  • PDUSpecific : J1939Frame
  • PgmDll : A2LCCP_SEED_KEY
  • PGMProcInfo : XCPMaster
  • PgmVerify : A2LXCP_SEGMENT
  • PGN : J1939Frame
  • PhysicalProtocol : ODXRoot
  • PhysReqCANId : Protocol
  • PhysRespCANId : Protocol
  • PhysUnit : A2LOVERWRITE, A2LTYPEDEF_CONVERSION_REF
  • PID : ODT
  • Port : A2LXCP_ON_ETHERNET, ISxIProvider, SxIProvider, XCPMasterBase
  • Position : A2LRECORD_LAYOUT.ItemLayoutDesc
  • PositionInSrcDataRecord : SrcDataIdentifier
  • PowerDownTime : RespReset
  • PowerMode : DiagnosticPowerModeResponse
  • PreventDefaultRequests : XCPMaster
  • PrgType : MemorySegment
  • Priority : J1939Frame
  • Producer : AbbrevEntryCU
  • ProductID : A2LXCP_ON_USB
  • ProgramId : IIDBLOCK
  • ProgramSpecificData : HDBLOCK
  • Project : A2LParser
  • ProjectBaseAdress : A2LKWP_TP_BLOB
  • Protocols : BaseVariant


ASAP2Library interface: Class Members - Properties

- q -

  • Quality : A2LXCP_CLOCK
  • QueueSize : XCPCommModes


ASAP2Library interface: Class Members - Properties

- r -

  • RAMToFLASHMode : A2LKWP_FLASH
  • Rasters : A2LCCP_KP_BLOB
  • Rate : ICNBLOCK, CNBLOCK
  • RawID : CANFrame
  • RawValue : DBCFile.MsgType
  • RawValueLen : DBCFile.MsgType
  • ReadOnly : A2LRECORD_LAYOUT_REF
  • ReadWrite : A2LINSTANCE, A2LMEASUREMENT
  • Receivers : DBCFile.EnvironmentType, DBCFile.SignalType
  • RecLayDict : A2LPROJECT
  • RecordCount : ICGBLOCK, CGBLOCKV4
  • RecordID : ICGBLOCK, CGBLOCK, CGBLOCKV4
  • RecordIDType : IDGBLOCK, DGBLOCKV4
  • RecordingTime : IHDBLOCK
  • RecordLayout : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • RecordSize : ICGBLOCK, CGBLOCKV4
  • RefAxisPtsRef : A2LAXIS_DESCR
  • RefComparisonQuantity : A2LCHARACTERISTIC
  • RefCompuMethod : A2LAXIS_DESCR, A2LCONVERSION_REF
  • RefCurveAxisRef : A2LAXIS_DESCR
  • ReferencedNodes : A2LFRAME, A2LFUNCTION, A2LGROUP, A2LREFBASE, A2LREFERENCE
  • RefFunctions : A2LCONVERSION_REF
  • RefInstance : A2LADDRESS
  • ReflectDiagMessageOnAcknowledge : DoIPBase
  • RefMeasurement : A2LAXIS_DESCR, A2LAXIS_PTS
  • RefModCommon : A2LMODULE
  • RefModPar : A2LMODULE
  • RefRecordLayout : A2LRECORD_LAYOUT_REF
  • RefTypedef : A2LINSTANCE, A2LSTRUCTURE_COMPONENT
  • RefVariantCoding : A2LMODULE
  • RefVarMeasurement : A2LVAR_CRITERION
  • RefVarSelectionCharacteristic : A2LVAR_CRITERION
  • RELATED_EVENT_CHANNEL_NUMBER : A2LXCP_EVENT
  • RequestIDsByBroadcast : A2LXCP_ON_CAN
  • Reserved : A2LRECORD_LAYOUT
  • Resolution : A2LMEASUREMENT, A2LTYPEDEF_MEASUREMENT
  • ResponseParamInfo : DiagService, IdentifierRecord
  • Result : A2LKWP_CHECKSUM, A2LKWP_FLASH, A2LKWP_ROUTINE_PARA, RespBase
  • RipAddr : A2LRECORD_LAYOUT
  • RipAddrW : A2LRECORD_LAYOUT
  • RootEntry : AbbrevEntry
  • RoutineIdentifier : RespRoutineControl
  • RoutineInfo : RespRoutineControl
  • RoutineStatusRecord : RespRoutineControl
  • RowFragment : ParTableEntry
  • RspId : IsoTp, UDSClientBase


ASAP2Library interface: Class Members - Properties

- s -

  • SA : IsoTp
  • SampleCount : A2LKWP_CAN, A2LXCP_EVENT_DAQ_PACKED_MODE
  • SamplePoint : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • SamplePoints : A2LKWP_CAN
  • SDG_CAPTION : Sdg
  • SDGS : Sdg
  • SecondarySamplePoint : A2LXCP_CAN_FD
  • Section : ELFFile.SectionValue
  • SECURITY_ACCESSs : A2LKWP_TP_BLOB
  • SecuritySeed : RespSecurityAccess
  • SeedAndKeyDLL : CommMaster
  • SeedAndKeyExternalFunction : A2LXCP_PROTOCOL_LAYER
  • SegmentList : IDataFile
  • SegmentNo : A2LXCP_SEGMENT
  • Selection : DataFormat
  • SELECTION_ : DataFormat
  • SEMANTIC : ParBaseDef
  • SERAM : A2LKWP_TP_BLOB
  • Service : UDSFrame
  • ServiceID : RespBase
  • ServicesReceived : CommMaster
  • ServiceStr : UDSFrame
  • SeverityDTCs : RespDTCSeverityRecords
  • ShiftOp : A2LRECORD_LAYOUT
  • SHORT_NAME : PDXIndex.ABLOCK, PDXIndex
  • SID : DiagService
  • SIExponents : A2LUNIT
  • SignalGroups : DBCFile
  • SignalRefs : DBCFile.SignalGroupType
  • Signals : DBCFile.MsgType
  • SignalType : ICNBLOCK, CNBLOCKV4
  • Size : A2LBLOB, A2LTYPEDEF_BLOB, A2LCCP_DP_BLOB, IA2LMemory, A2LKWP_KP_BLOB, MemorySegment, A2LXCP_TIMESTAMP_CHARACTERIZATION, SrcDataMemory, MemoryRange, MemoryRangeList, DZBLOCKV4, ELFFile.ELFSection, ELFFile.ELFSymbol
  • SizeLen : RespWriteMemoryByAddress
  • SJW : A2LXCP_CAN_FD, A2LXCP_ON_CAN
  • SJWLength : A2LKWP_CAN
  • SocketType : BaseFrame
  • Source : DBCFile.MsgType, ParserEventArgs
  • SourceAddress : J1939Frame
  • SourceAndRasterMap : A2LCCP_TP_BLOB
  • SourceFile : BLFFile, DBCFile, ODXFile, ODXRoot, SymbolFile
  • SourceFilename : IDataFile
  • Sources : DBCFile
  • SRBlocks : ICGBLOCK
  • SrcAddress : A2LRECORD_LAYOUT
  • Start : DBCFile.SignalType
  • StartDiagWithoutBdSwitch : A2LKWP_TP_BLOB
  • Started : Header
  • StartLine : A2LNODE
  • StartStopRoutineNo : A2LKWP_CAN
  • StartValue : DBCFile.EnvironmentType
  • StaticAddressOffsets : A2LRECORD_LAYOUT
  • StaticRecordLayout : A2LRECORD_LAYOUT
  • StatusAvailabilityMask : RespDTCCount, RespDTCRecords, RespDTCSeverityRecords
  • StatusOfDTC : DTCAndStatusRecord
  • StatusResponse : CCPMaster, XCPMaster
  • StepSize : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • StimulationMode : A2LKWP_TP_BLOB
  • StrAddressGranularity : XCPMaster
  • StrictParsing : A2LParser
  • STSMode : A2LXCP_EVENT_DAQ_PACKED_MODE
  • SubFunction : RespSFBase
  • Subfunction : UDSFrame, DiagService
  • SubfunctionStr : UDSFrame
  • SubType : A2LCCP_NAMEDNODE, A2LKWP_NAMEDNODE
  • Symbol : ELFFile.SymbolValue
  • SymbolLink : A2LADDRESS
  • SymbolOffset : A2LADDRESS
  • SymbolTypeLink : A2LSTRUCTURE_COMPONENT, A2LTYPEDEF_STRUCTURE
  • SyncBaseValue : EVBLOCKV4
  • SyncEdge : A2LKWP_CAN
  • SyncFactor : EVBLOCKV4
  • SynchronizationStatus : VehicleIdResponse
  • SyncType : ICNBLOCK
  • SystemConstants_ : A2LMOD_PAR


ASAP2Library interface: Class Members - Properties

- t -

  • TA : IsoTp
  • Tag : A2LNODE, DataFile, CANConfiguration, LINConfiguration, DBCFile.AttribDefDict, DBCFile.AttribDefType, DBCFile.EnvironmentDict, DBCFile.EnvironmentType, DBCFile.IDBCBase, DBCFile.MsgType, DBCFile.SignalGroupDict, DBCFile.SignalGroupType, DBCFile.SignalType, DBCFile.SourceType, DBCFile.ValueTable, DBCFile.ValueTableDict, IMDFBlock, BLOCKBASEV4
  • TeamMemberRef : DocRevision
  • TemplateType : CABLOCKV4
  • Termination : DiagCodedTypeMinMax
  • TERMINATION_ : DiagCodedTypeMinMax
  • TesterAddress : A2LKWP_TP_BLOB
  • TEXT : DataFile, PDXIndex.FILE
  • this[int handle] : MDFWriter
  • Time : CCBLOCK
  • TIME_DEFs : A2LKWP_TP_BLOB
  • TimeDefs : A2LKWP_TIME_DEF
  • Timeout : DoIPBase
  • TimeStamp : ParserEventArgs
  • TimestampsRelateTo : A2LXCP_TIME_CORRELATION
  • TimingParameters : RespTimingParameter
  • Timings : A2LXCP_PROTOCOL_LAYER, XCPMasterBase
  • TmpFileName : A2LParser
  • TransferType : A2LXCP_ENDPOINT
  • TransformerDict : A2LPROJECT
  • TransportLayerInstance : A2LXCP_MEDIA
  • Type : A2LNODE, RespBuildChecksum, XCPFrame, XCPMasterBase, DBCFile.EnvironmentType, BaseFrame, IsoTp, CompuMethod, DataBlock, NativeSKDLL, ParserEventArgs, IIDBLOCK, MDFWriter, ELFFile.ELFSymbol
  • TypeDefDict : A2LPROJECT


ASAP2Library interface: Class Members - Properties

- u -

  • U : A2LKWP_TP_BLOB.KWP_SERAM
  • UnfinalizedFlags : IIDBLOCK
  • UniqueBusID : ICANProvider, FrameProvider< T, V >, ILINProvider
  • Unit : A2LCONVERSION_REF, ICharValue, DBCFile.EnvironmentType, DBCFile.SignalType, ICCBLOCK, ICNBLOCK
  • UnitAxis : ICharValue
  • UnitConversion : A2LUNIT
  • UnitDict : A2LPROJECT
  • UPD : PDXIndex.ABLOCK
  • UploadedData : RespTransferData
  • UpperLimit : A2LCONVERSION_REF, A2LTYPEDEF_CONVERSION_REF
  • UpperLimitEx : A2LRECORD_LAYOUT_REF, A2LTYPEDEF_RECORDLAYOUT_REF
  • USDTPTimings : A2LKWP_TIME_DEF
  • UseCANFD : UDSClientBase
  • UseFillByte : IsoTp, UDSClientBase
  • UTCOffset : FHBLOCKV4, HDBLOCKV4


ASAP2Library interface: Class Members - Properties

- v -

  • Validity : ScaleConstr
  • VALIDITY_ : ScaleConstr
  • Value : ICharValue, ODTEntry, DBCFile.AttribDefType, Attribute, ELFFile.ELFSymbol
  • ValueFormat : ICharValue
  • Values : DataConservation
  • Values_ : A2LCOMPU_TAB
  • ValueTables : DBCFile
  • VAR_NAMING : A2LVARIANT_CODING
  • VAR_SEPARATOR : A2LVARIANT_CODING
  • VectorCAN : CEBLOCK
  • VendorID : A2LXCP_ON_USB
  • Verbs_ : A2LCOMPU_VTAB, A2LCOMPU_VTAB_RANGE
  • Version : A2LCANAPE_EXT, A2LParser, A2LXCP_MEDIA, A2LXCP_PROTOCOL_LAYER, ELM327CAN, CCPMaster, XCPMaster, DBCFile, BaseFrame, IIDBLOCK
  • VIN : VehicleIdResponse
  • VirtualConversion : A2LCANAPE_EXT
  • VirtualDict : A2LPROJECT
  • Voltage : ELM327CAN


ASAP2Library interface: Class Members - Properties

- w -

  • WFT_MAX : A2LKWP_CAN.NETWORK_LIMITS
  • WriteFileType : DataFileS19


ASAP2Library interface: Class Members - Properties

- x -

  • XDL_MAX : A2LKWP_CAN.NETWORK_LIMITS


ASAP2Library interface: Class Members - Events

  • CCPErrorReceived : CCPMaster
  • CCPEventReceived : CCPMaster
  • ConnectionStateChanged : CommMaster
  • EntityAnnounced : DoIPClient
  • FrameEnqueued : FrameQueue< T >
  • ModelChanged : A2LPROJECT
  • NameChanged : DBCFile
  • NetworkInterfaceChanged : DoIPClient
  • OnValuesReceived : CommMaster
  • OnWriteRawData : IDGBLOCK
  • ParserMessage : A2LParser
  • ProgressChanged : A2LParser
  • SxIDataReceived : ISxIProvider, SxIProvider
  • XCPErrorReceived : XCPMaster
  • XCPEventReceived : XCPMaster
  • XCPServiceRequestReceived : XCPMaster


ASAP2Library interface: Class Index

Class Index
A | B | C | D | E | F | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | _
A
A2LA2ML (jnsoft.ASAP2)
A2LADDRESS (jnsoft.ASAP2)
A2LANNOTATION (jnsoft.ASAP2)
A2LANNOTATION_TEXT (jnsoft.ASAP2)
A2LAR_COMPONENT (jnsoft.ASAP2)
A2LAXIS_DESCR (jnsoft.ASAP2)
A2LAXIS_PTS (jnsoft.ASAP2)
A2LBIT_OPERATION (jnsoft.ASAP2)
A2LBLOB (jnsoft.ASAP2)
A2LCALIBRATION_HANDLE (jnsoft.ASAP2)
A2LCALIBRATION_METHOD (jnsoft.ASAP2)
A2LCANAPE_ADDRESS_UPDATE (jnsoft.ASAP2)
A2LCANAPE_EXT (jnsoft.ASAP2)
A2LCCP_ADDRESS_MAPPING (jnsoft.ASAP2.CCP)
A2LCCP_CAN_PARAM (jnsoft.ASAP2.CCP)
A2LCCP_CHECKSUM (jnsoft.ASAP2.CCP)
A2LCCP_CHECKSUM_PARAM (jnsoft.ASAP2.CCP)
A2LCCP_DEFINED_PAGES (jnsoft.ASAP2.CCP)
A2LCCP_DP_BLOB (jnsoft.ASAP2.CCP)
A2LCCP_EVENT_GROUP (jnsoft.ASAP2.CCP)
A2LCCP_KP_BLOB (jnsoft.ASAP2.CCP)
A2LCCP_NAMEDNODE (jnsoft.ASAP2.CCP)
A2LCCP_NODE (jnsoft.ASAP2.CCP)
A2LCCP_QP_BLOB (jnsoft.ASAP2.CCP)
A2LCCP_RASTER (jnsoft.ASAP2.CCP)
A2LCCP_SEED_KEY (jnsoft.ASAP2.CCP)
A2LCCP_SOURCE (jnsoft.ASAP2.CCP)
A2LCCP_TP_BLOB (jnsoft.ASAP2.CCP)
A2LCHARACTERISTIC (jnsoft.ASAP2)
A2LCOMPU_METHOD (jnsoft.ASAP2)
A2LCOMPU_TAB (jnsoft.ASAP2)
A2LCOMPU_TAB_BASE (jnsoft.ASAP2)
A2LCOMPU_VTAB (jnsoft.ASAP2)
A2LCOMPU_VTAB_RANGE (jnsoft.ASAP2)
A2LCONVERSION_REF (jnsoft.ASAP2)
A2LDEF_CHARACTERISTIC (jnsoft.ASAP2)
A2LDEPENDENT_CHARACTERISTIC (jnsoft.ASAP2)
A2LFIX_AXIS_PAR_LIST (jnsoft.ASAP2)
A2LFORMULA (jnsoft.ASAP2)
A2LFormula (jnsoft.ASAP2.Formulas)
A2LFormulaDict (jnsoft.ASAP2.Formulas)
A2LFRAME (jnsoft.ASAP2)
A2LFUNCTION (jnsoft.ASAP2)
A2LFUNCTION_LIST (jnsoft.ASAP2)
A2LGROUP (jnsoft.ASAP2)
A2LHEADER (jnsoft.ASAP2)
A2LIF_DATA (jnsoft.ASAP2)
A2LIN_MEASUREMENT (jnsoft.ASAP2)
A2LINSTANCE (jnsoft.ASAP2)
A2LKWP_ADDRESS (jnsoft.ASAP2.KWP)
A2LKWP_ADDRESS_MAPPING (jnsoft.ASAP2.KWP)
A2LKWP_CAN (jnsoft.ASAP2.KWP)
A2LKWP_CHECKSUM (jnsoft.ASAP2.KWP)
A2LKWP_COPY (jnsoft.ASAP2.KWP)
A2LKWP_DIAG_BAUD (jnsoft.ASAP2.KWP)
A2LKWP_DP_BLOB (jnsoft.ASAP2.KWP)
A2LKWP_FLASH (jnsoft.ASAP2.KWP)
A2LKWP_FLASH_COPY (jnsoft.ASAP2.KWP)
A2LKWP_K_LINE (jnsoft.ASAP2.KWP)
A2LKWP_KP_BLOB (jnsoft.ASAP2.KWP)
A2LKWP_NAMEDNODE (jnsoft.ASAP2.KWP)
A2LKWP_NODE (jnsoft.ASAP2.KWP)
A2LKWP_PAGE_SWITCH (jnsoft.ASAP2.KWP)
A2LKWP_ROUTINE_PARA (jnsoft.ASAP2.KWP)
A2LKWP_SOURCE (jnsoft.ASAP2.KWP)
A2LKWP_TIME_DEF (jnsoft.ASAP2.KWP)
A2LKWP_TP_BLOB (jnsoft.ASAP2.KWP)
A2LLOC_MEASUREMENT (jnsoft.ASAP2)
A2LMEASUREMENT (jnsoft.ASAP2)
A2LMEMORY_LAYOUT (jnsoft.ASAP2)
A2LMEMORY_SEGMENT (jnsoft.ASAP2)
A2LMOD_COMMON (jnsoft.ASAP2)
A2LMOD_PAR (jnsoft.ASAP2)
A2LMODULE (jnsoft.ASAP2)
A2LNAMEDNODE (jnsoft.ASAP2)
A2LNODE (jnsoft.ASAP2)
A2LOUT_MEASUREMENT (jnsoft.ASAP2)
A2LOVERWRITE (jnsoft.ASAP2)
A2LParser (jnsoft.ASAP2)
A2LParserProgressEventArgs (jnsoft.ASAP2)
A2LPROJECT (jnsoft.ASAP2)
A2LRECORD_LAYOUT (jnsoft.ASAP2)
A2LRECORD_LAYOUT_REF (jnsoft.ASAP2)
A2LREF_CHARACTERISTIC (jnsoft.ASAP2)
A2LREF_GROUP (jnsoft.ASAP2)
A2LREF_MEASUREMENT (jnsoft.ASAP2)
A2LREFBASE (jnsoft.ASAP2)
A2LREFERENCE (jnsoft.ASAP2)
A2LSTRUCTURE_COMPONENT (jnsoft.ASAP2)
A2LSUB_FUNCTION (jnsoft.ASAP2)
A2LSUB_GROUP (jnsoft.ASAP2)
A2LTRANSFORMER (jnsoft.ASAP2)
A2LTRANSFORMER_IN_OBJECTS (jnsoft.ASAP2)
A2LTRANSFORMER_OUT_OBJECTS (jnsoft.ASAP2)
A2LTYPEDEF (jnsoft.ASAP2)
A2LTYPEDEF_AXIS (jnsoft.ASAP2)
A2LTYPEDEF_BLOB (jnsoft.ASAP2)
A2LTYPEDEF_CHARACTERISTIC (jnsoft.ASAP2)
A2LTYPEDEF_CONVERSION_REF (jnsoft.ASAP2)
A2LTYPEDEF_MEASUREMENT (jnsoft.ASAP2)
A2LTYPEDEF_RECORDLAYOUT_REF (jnsoft.ASAP2)
A2LTYPEDEF_STRUCTURE (jnsoft.ASAP2)
A2LUNIT (jnsoft.ASAP2)
A2LUNSUPPORTEDNODE (jnsoft.ASAP2)
A2LUSER_RIGHTS (jnsoft.ASAP2)
A2LVAR_ADDRESS (jnsoft.ASAP2)
A2LVAR_CHARACTERISTIC (jnsoft.ASAP2)
A2LVAR_CRITERION (jnsoft.ASAP2)
A2LVAR_FORBIDDEN_COMB (jnsoft.ASAP2)
A2LVARIANT_CODING (jnsoft.ASAP2)
A2LVIRTUAL (jnsoft.ASAP2)
A2LVIRTUAL_CHARACTERISTIC (jnsoft.ASAP2)
A2LXCP_ADDRESS_MAPPING (jnsoft.ASAP2.XCP)
A2LXCP_BUFFER_RESERVE (jnsoft.ASAP2.XCP)
A2LXCP_CAN_FD (jnsoft.ASAP2.XCP)
A2LXCP_CHECKSUM (jnsoft.ASAP2.XCP)
A2LXCP_CLOCK (jnsoft.ASAP2.XCP)
A2LXCP_CORE_LOAD (jnsoft.ASAP2.XCP)
A2LXCP_DAQ (jnsoft.ASAP2.XCP)
A2LXCP_DAQ_EVENT (jnsoft.ASAP2.XCP)
A2LXCP_DAQ_LIST (jnsoft.ASAP2.XCP)
A2LXCP_DAQ_LIST_CAN_ID (jnsoft.ASAP2.XCP)
A2LXCP_DAQ_LIST_USB_ENDPOINT (jnsoft.ASAP2.XCP)
A2LXCP_DAQ_MEMORY_CONSUMPTION (jnsoft.ASAP2.XCP)
A2LXCP_ECU_STATES_MEMORY_ACCESS (jnsoft.ASAP2.XCP)
A2LXCP_ECU_STATES_STATE (jnsoft.ASAP2.XCP)
A2LXCP_ENDPOINT (jnsoft.ASAP2.XCP)
A2LXCP_EVENT (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_CAN_ID_LIST (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_CPU_LOAD_CONSUMPTION_QUEUE (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_DAQ_PACKED_MODE (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_LIST (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_MIN_CYCLE_TIME (jnsoft.ASAP2.XCP)
A2LXCP_EVENT_ODT_ENTRY_SIZE_FACTOR_TABLE (jnsoft.ASAP2.XCP)
A2LXCP_FRAMING (jnsoft.ASAP2.XCP)
A2LXCP_IN_EP_ONLY_DAQ (jnsoft.ASAP2.XCP)
A2LXCP_IN_EP_ONLY_EVSERV (jnsoft.ASAP2.XCP)
A2LXCP_IN_EP_RESERR_DAQ_EVSERV (jnsoft.ASAP2.XCP)
A2LXCP_MEDIA (jnsoft.ASAP2.XCP)
A2LXCP_NAMEDNODE (jnsoft.ASAP2.XCP)
A2LXCP_NODE (jnsoft.ASAP2.XCP)
A2LXCP_ODT (jnsoft.ASAP2.XCP)
A2LXCP_ON_CAN (jnsoft.ASAP2.XCP)
A2LXCP_ON_ETHERNET (jnsoft.ASAP2.XCP)
A2LXCP_ON_SxI (jnsoft.ASAP2.XCP)
A2LXCP_ON_TCP_IP (jnsoft.ASAP2.XCP)
A2LXCP_ON_UDP_IP (jnsoft.ASAP2.XCP)
A2LXCP_ON_USB (jnsoft.ASAP2.XCP)
A2LXCP_OUT_EP_CMD_STIM (jnsoft.ASAP2.XCP)
A2LXCP_OUT_EP_ONLY_STIM (jnsoft.ASAP2.XCP)
A2LXCP_PAG (jnsoft.ASAP2.XCP)
A2LXCP_PAGE (jnsoft.ASAP2.XCP)
A2LXCP_PGM (jnsoft.ASAP2.XCP)
A2LXCP_PROTOCOL_LAYER (jnsoft.ASAP2.XCP)
A2LXCP_SECTOR (jnsoft.ASAP2.XCP)
A2LXCP_SEGMENT (jnsoft.ASAP2.XCP)
A2LXCP_STIM (jnsoft.ASAP2.XCP)
A2LXCP_TIME_CORRELATION (jnsoft.ASAP2.XCP)
A2LXCP_TIMESTAMP_CHARACTERIZATION (jnsoft.ASAP2.XCP)
A2LXCP_TIMESTAMP_SUPPORTED (jnsoft.ASAP2.XCP)
AbbrevEntry (jnsoft.Symbols.ELF.DWARF)
AbbrevEntryArray (jnsoft.Symbols.ELF.DWARF)
AbbrevEntryCU (jnsoft.Symbols.ELF.DWARF)
AbbrevEntryMember (jnsoft.Symbols.ELF.DWARF)
AbbrevEntryVarBase (jnsoft.Symbols.ELF.DWARF)
AbbrevEntryVariable (jnsoft.Symbols.ELF.DWARF)
PDXIndex.ABLOCK (jnsoft.Diagnose.ODX)
AdaptiveState (jnsoft.ASAP2.Helpers)
AdditiveDescriptionEventArgs (jnsoft.ASAP2)
Adler32Computer (jnsoft.Helpers)
AdminData (jnsoft.Diagnose.ODX)
A2LCANAPE_ADDRESS_UPDATE.AdrMapType (jnsoft.ASAP2)
AdvantechCAN (jnsoft.Comm.CAN.Advantech)
AnnoncementEventArgs (jnsoft.Diagnose.Comm.DoIp)
Annotation (jnsoft.MDF)
AnnotationList (jnsoft.MDF)
AppText (jnsoft.BLF)
AppTextManaged (jnsoft.BLF)
ASCIIValue (jnsoft.ASAP2.Values)
ATBLOCKV4 (jnsoft.MDF.V4)
DBCFile.AttribDefDict (jnsoft.DBC)
DBCFile.AttribDefType (jnsoft.DBC)
Attribute (jnsoft.Symbols.ELF.DWARF)
DBCFile.AttributeType (jnsoft.DBC)
DBCFile.AttributeTypeDict (jnsoft.DBC)
Audience (jnsoft.Diagnose.ODX)
A2LRECORD_LAYOUT.AxisPtsLayoutDesc (jnsoft.ASAP2)
A2LRECORD_LAYOUT.AxisRescaleLayoutDesc (jnsoft.ASAP2)
B
BaseDocInfoContainer (jnsoft.Diagnose.ODX)
BaseFrame (jnsoft.Diagnose.Comm.DoIp)
BaseNames (jnsoft.MDF.V4)
BaseValue (jnsoft.ASAP2.Values)
BaseVariant (jnsoft.Diagnose.ODX)
BaseVariantRef (jnsoft.Diagnose.ODX)
A2LKWP_TP_BLOB.BAUD_DEF (jnsoft.ASAP2.KWP)
CANConfiguration.BitRateConfig (jnsoft.Comm.CAN)
CANConfiguration.BitRatePar (jnsoft.Comm.CAN)
BLFFile (jnsoft.BLF)
BLOCKBASE (jnsoft.MDF.V3)
BLOCKBASEV4 (jnsoft.MDF.V4)
C
CABLOCKV4 (jnsoft.MDF.V4)
A2LCANAPE_ADDRESS_UPDATE.CALIBRATION_METHOD (jnsoft.ASAP2)
CANConfigException (jnsoft.Comm.CAN)
CANConfiguration (jnsoft.Comm.CAN)
CANDriverError (jnsoft.BLF)
CANError (jnsoft.BLF)
CANErrorExt (jnsoft.BLF)
CANEventArgs (jnsoft.Comm.CAN)
CANFDManaged (jnsoft.BLF)
CANFDMessage (jnsoft.BLF)
CANFDMessage64 (jnsoft.BLF)
CANFilterIDs (jnsoft.Comm.CAN)
CANFrame (jnsoft.Comm.CAN)
CANFrameQueue (jnsoft.Comm.CAN)
CANMessage (jnsoft.BLF)
CANMessage2 (jnsoft.BLF)
CANProvider (jnsoft.Comm.CAN)
CANStatistic (jnsoft.BLF)
Case (jnsoft.Diagnose.ODX)
CCBLOCK (jnsoft.MDF.V3)
CCBLOCKV4 (jnsoft.MDF.V4)
CCPErrorArgs (jnsoft.Comm.CCP)
CCPEventArgs (jnsoft.Comm.CCP)
CCPFrame (jnsoft.Comm.CCP)
CCPFrameQueue (jnsoft.Comm.CCP)
CCPMaster (jnsoft.Comm.CCP)
CCPMasterBase (jnsoft.Comm.CCP)
CCPonCAN (jnsoft.Comm.CCP)
Program.CCPSim (jnsoft.Comm.ECUSimulator)
CDBLOCK (jnsoft.MDF.V3)
CDFFile (jnsoft.ASAP2.Values)
CEBLOCK (jnsoft.MDF.V3)
CGBLOCK (jnsoft.MDF.V3)
CGBLOCKV4 (jnsoft.MDF.V4)
LibWrapper.ChannelConfig (jnsoft.Comm.Vector)
CharacteristicValue (jnsoft.ASAP2.Values)
ChartContainer (jnsoft.Diagnose.ODX)
CHBLOCKV4 (jnsoft.MDF.V4)
Checksum (jnsoft.ASAP2.Helpers)
CmdActionDiagService (jnsoft.Comm.CCP)
CmdBase (jnsoft.Comm.CCP)
CmdBase (jnsoft.Comm.XCP)
CmdMoveClearBC (jnsoft.Comm.CCP)
CmdUserTransCmd (jnsoft.Comm.XCP)
CNBLOCK (jnsoft.MDF.V3)
CNBLOCKV4 (jnsoft.MDF.V4)
CNcomment (jnsoft.MDF.V4)
CommentBase (jnsoft.MDF.V4)
CommKernel (jnsoft.Comm)
CommMaster (jnsoft.Comm)
Communicator (jnsoft.Comm)
DoIPBase.Communicator (jnsoft.Diagnose.Comm.DoIp)
CompanyData (jnsoft.Diagnose.ODX)
CompanySpecificInfo (jnsoft.Diagnose.ODX)
ComParam (jnsoft.Diagnose.ODX)
ComParamBase (jnsoft.Diagnose.ODX)
COMParamRef (jnsoft.Diagnose.ODX)
ComParamSpec (jnsoft.Diagnose.ODX)
ComParamSubset (jnsoft.Diagnose.ODX)
CompilationUnitHeader (jnsoft.Symbols.ELF.DWARF)
ComplexComParam (jnsoft.Diagnose.ODX)
CompuInternalToPhys (jnsoft.Diagnose.ODX)
CompuMethod (jnsoft.Diagnose.ODX)
CompuRationalCoeffs (jnsoft.Diagnose.ODX)
CompuScale (jnsoft.Diagnose.ODX)
Constants (jnsoft.Helpers)
CToCSharpMath (jnsoft.ASAP2.Helpers)
Cube4Value (jnsoft.ASAP2.Values)
Cube5Value (jnsoft.ASAP2.Values)
CuboidValue (jnsoft.ASAP2.Values)
CurveValue (jnsoft.ASAP2.Values)
D
DAQAndEvt (jnsoft.ASAP2.XCP)
DAQCache (jnsoft.Comm)
DAQDict (jnsoft.Comm)
DAQDictCCP (jnsoft.Comm.CCP)
DAQDictXCP (jnsoft.Comm.XCP)
DAQList (jnsoft.Comm)
DAQListCCP (jnsoft.Comm.CCP)
DAQListXCP (jnsoft.Comm.XCP)
DAQMeasurement (jnsoft.ASAP2)
DAQStore (jnsoft.Comm)
DAQToEvtMapDict (jnsoft.Comm)
DataBlock (jnsoft.Diagnose.ODX)
DataBlockExpander (jnsoft.MDF)
DataConservation (jnsoft.ASAP2.Values)
DataContainerV4 (jnsoft.MDF.V4)
DataFile (jnsoft.ASAP2.Values)
DataFile (jnsoft.Diagnose.ODX)
DataFileBin (jnsoft.ASAP2.Values)
DataFileBinDlg (jnsoft.ASAP2.Values)
DataFileHex (jnsoft.ASAP2.Values)
DataFileS19 (jnsoft.ASAP2.Values)
DataFormat (jnsoft.Diagnose.ODX)
DataLimits (jnsoft.Helpers)
DataObjectProp (jnsoft.Diagnose.ODX)
DataPoint (jnsoft.Helpers)
DataPointF (jnsoft.Helpers)
DataReader (jnsoft.MDF)
DataStream (jnsoft.MDF)
DBCFile (jnsoft.DBC)
DCMFile (jnsoft.ASAP2.Values)
DefaultCase (jnsoft.Diagnose.ODX)
DependencyType (jnsoft.MDF)
DescType (jnsoft.MDF.V4)
DetermineNumberOfItems (jnsoft.Diagnose.ODX)
DGBLOCK (jnsoft.MDF.V3)
DGBLOCKV4 (jnsoft.MDF.V4)
DiagCodedTypeBase (jnsoft.Diagnose.ODX)
DiagCodedTypeLL (jnsoft.Diagnose.ODX)
DiagCodedTypeMinMax (jnsoft.Diagnose.ODX)
DiagCodedTypePL (jnsoft.Diagnose.ODX)
DiagCodedTypeStd (jnsoft.Diagnose.ODX)
DiagDataDictionarySpec (jnsoft.Diagnose.ODX)
DiagDataDictSpec (jnsoft.Diagnose.ODX)
DiagLayerContainer (jnsoft.Diagnose.ODX)
DiagnosticMessage (jnsoft.Diagnose.Comm.DoIp)
DiagnosticPowerModeResponse (jnsoft.Diagnose.Comm.DoIp)
DiagService (jnsoft.Diagnose.ODX)
DictionaryProxy (jnsoft.ASAP2.Helpers)
DictionaryProxyComplex (jnsoft.ASAP2.Helpers)
A2LCANAPE_EXT.DisplayType (jnsoft.ASAP2)
DisplayType (jnsoft.MDF.V4)
DLBLOCKV4 (jnsoft.MDF.V4)
DLLWrapper (jnsoft.Helpers)
DocRevision (jnsoft.Diagnose.ODX)
DoIPBase (jnsoft.Diagnose.Comm.DoIp)
DoIPClient (jnsoft.Diagnose.Comm.DoIp)
DoIPFrameQueue (jnsoft.Diagnose.Comm.DoIp)
DoIPServer (jnsoft.Diagnose.Comm.DoIp)
LibWrapper.DriverConfig (jnsoft.Comm.Vector)
DTBLOCKV4 (jnsoft.MDF.V4)
Dtc (jnsoft.Diagnose.ODX)
DTCAndStatusRecord (jnsoft.Diagnose.Comm.UDS)
DtcDop (jnsoft.Diagnose.ODX)
DWARFInfo (jnsoft.Symbols.ELF.DWARF)
DynamicLengthField (jnsoft.Diagnose.ODX)
DZBLOCKV4 (jnsoft.MDF.V4)
E
EBase (jnsoft.MDF.V4)
EbElCAN (jnsoft.Comm.CAN.EbEl)
EcuMem (jnsoft.Diagnose.ODX)
EcuMemConnector (jnsoft.Diagnose.ODX)
EcuSharedData (jnsoft.Diagnose.ODX)
EcuSharedDataRef (jnsoft.Diagnose.ODX)
EcuVariant (jnsoft.Diagnose.ODX)
EcuVariantPatternContainer (jnsoft.Diagnose.ODX)
ELFFile (jnsoft.Symbols.ELF)
ELFFile.ELFHeader (jnsoft.Symbols.ELF)
ELFFile.ELFSection (jnsoft.Symbols.ELF)
ELFFile.ELFSymbol (jnsoft.Symbols.ELF)
ELM327CAN (jnsoft.Comm.CAN.ELM327)
EndOfPDUField (jnsoft.Diagnose.ODX)
EntityData (jnsoft.Diagnose.Comm.DoIp)
EntityStatusResponse (jnsoft.Diagnose.Comm.DoIp)
DBCFile.EnumDict (jnsoft.DBC)
EnvDataDesc (jnsoft.Diagnose.ODX)
EnvDataParamContainer (jnsoft.Diagnose.ODX)
DBCFile.EnvironmentDict (jnsoft.DBC)
DBCFile.EnvironmentType (jnsoft.DBC)
ESDCAN (jnsoft.Comm.CAN.ESD)
ETASCAN (jnsoft.Comm.CAN.ETAS)
ETASLIN (jnsoft.Comm.LIN.ETAS)
EType (jnsoft.MDF.V4)
EVBLOCKV4 (jnsoft.MDF.V4)
EventBase (jnsoft.Comm.XCP)
EventResumeMode (jnsoft.Comm.XCP)
EventResumeModeTS (jnsoft.Comm.XCP)
EventStimTimeout (jnsoft.Comm.XCP)
EventTimeSync (jnsoft.Comm.XCP)
A2LCANAPE_ADDRESS_UPDATE.ExSymbolType (jnsoft.ASAP2)
Extensions (jnsoft.ASAP2.Helpers)
Extensions (jnsoft.Helpers)
F
FHBLOCKV4 (jnsoft.MDF.V4)
FHcomment (jnsoft.MDF.V4)
PDXIndex.FILE (jnsoft.Diagnose.ODX)
Filter (jnsoft.Diagnose.ODX)
A2LCANAPE_ADDRESS_UPDATE.FirstLastNode (jnsoft.ASAP2)
Flash (jnsoft.Diagnose.ODX)
FlashDataExtern (jnsoft.Diagnose.ODX)
FlashDataIntern (jnsoft.Diagnose.ODX)
A2LCANAPE_ADDRESS_UPDATE.FlashSectionType (jnsoft.ASAP2)
A2LRECORD_LAYOUT.FncValuesLayoutDesc (jnsoft.ASAP2)
Frame (jnsoft.Comm)
FrameEventArgs (jnsoft.Comm)
FrameProvider (jnsoft.Comm)
FrameQueue (jnsoft.Comm)
FunctClass (jnsoft.Diagnose.ODX)
FunctionalGroup (jnsoft.Diagnose.ODX)
FunctionalGroupRef (jnsoft.Diagnose.ODX)
H
HDBLOCK (jnsoft.MDF.V3)
HDBLOCKV4 (jnsoft.MDF.V4)
HDcomment (jnsoft.MDF.V4)
Header (jnsoft.BLF)
Helpers (jnsoft.MDF)
HLBLOCKV4 (jnsoft.MDF.V4)
I
IA2LDescription (jnsoft.ASAP2)
IA2LMemory (jnsoft.ASAP2)
ICANProvider (jnsoft.Comm.CAN)
ICCBLOCK (jnsoft.MDF)
IcEcuProxy (jnsoft.Diagnose.ODX)
ICGBLOCK (jnsoft.MDF)
ICharValue (jnsoft.ASAP2)
IcModelYear (jnsoft.Diagnose.ODX)
ICNBLOCK (jnsoft.MDF)
IcOEM (jnsoft.Diagnose.ODX)
IcVehicleModel (jnsoft.Diagnose.ODX)
IcVehicleType (jnsoft.Diagnose.ODX)
Id (jnsoft.Diagnose.ODX)
IDataContainer (jnsoft.MDF)
IDataFile (jnsoft.ASAP2)
DBCFile.IDBCAttribute (jnsoft.DBC)
DBCFile.IDBCBase (jnsoft.DBC)
DBCFile.IDBCComment (jnsoft.DBC)
DBCFile.IDBCSignal (jnsoft.DBC)
IDBLOCK (jnsoft.MDF.V3)
IDBLOCKV4 (jnsoft.MDF.V4)
Ident (jnsoft.Diagnose.ODX)
IdentDesc (jnsoft.Diagnose.ODX)
IdentifierRecord (jnsoft.Diagnose.ODX)
UDSClient.IdentifierRequest (jnsoft.Diagnose.Comm.UDS)
IDescription (jnsoft.Diagnose.ODX)
IDGBLOCK (jnsoft.MDF)
IdRef (jnsoft.Diagnose.ODX)
IEvaluator (jnsoft.ASAP2.Formulas)
IFrameProvider (jnsoft.Comm)
IgnoreNSXmlTextReader (jnsoft.Helpers)
IHDBLOCK (jnsoft.MDF)
IId (jnsoft.Diagnose.ODX)
IIDBLOCK (jnsoft.MDF)
ILINProvider (jnsoft.Comm.LIN)
ILog (jnsoft.Logging)
IMDFBlock (jnsoft.MDF)
IMDFComment (jnsoft.MDF)
IMEActiaCAN (jnsoft.Comm.CAN.IMEActia)
InternalConstr (jnsoft.Diagnose.ODX)
IntrepidCAN (jnsoft.Comm.CAN.Intrepid)
IntrepidLIN (jnsoft.Comm.LIN.Intrepid)
IResponse (jnsoft.Comm)
IsoTp (jnsoft.Diagnose.Comm)
IsoTpFSM (jnsoft.Diagnose.Comm)
ISRBLOCK (jnsoft.MDF)
ISxIProvider (jnsoft.Comm.XCP.SxI)
A2LRECORD_LAYOUT.ItemLayoutDesc (jnsoft.ASAP2)
IXXATCAN (jnsoft.Comm.CAN.IXXAT)
IXXATLIN (jnsoft.Comm.LIN.IXXAT)
J
J1939Frame (jnsoft.Comm.CAN)
J1939FrameQueue (jnsoft.Comm.CAN)
K
DictionaryProxy.KeyAndValue (jnsoft.ASAP2.Helpers)
DictionaryProxyComplex.KeyAndValueComplex (jnsoft.ASAP2.Helpers)
KvaserCAN (jnsoft.Comm.CAN.Kvaser)
KvaserLIN (jnsoft.Comm.LIN.Kvaser)
A2LKWP_TP_BLOB.KWP_DATA_ACCESS (jnsoft.ASAP2.KWP)
A2LKWP_TP_BLOB.KWP_K_LINE (jnsoft.ASAP2.KWP)
A2LKWP_TP_BLOB.KWP_SERAM (jnsoft.ASAP2.KWP)
KWP_TIME_DEF (jnsoft.ASAP2.KWP)
KWP_USDTP_TIMING (jnsoft.ASAP2.KWP)
L
LawicelCAN (jnsoft.Comm.CAN.Lawicel)
LimitBase (jnsoft.Diagnose.ODX)
LINConfiguration (jnsoft.Comm.LIN)
LINEventArgs (jnsoft.Comm.LIN)
LINFilterIDs (jnsoft.Comm.LIN)
LINFrame (jnsoft.Comm.LIN)
LINFrameDict (jnsoft.Comm.LIN)
LINFrameQueue (jnsoft.Comm.LIN)
A2LCANAPE_EXT.LinkMapType (jnsoft.ASAP2)
LINMessageInfo (jnsoft.Comm.LIN.Kvaser)
LINProvider (jnsoft.Comm.LIN)
LObj (jnsoft.BLF)
LogContainer (jnsoft.BLF)
LogManager (jnsoft.Logging)
M
A2LCANAPE_ADDRESS_UPDATE.MAP_SYMBOL (jnsoft.ASAP2)
MAPFile (jnsoft.Symbols.MAP)
MapValue (jnsoft.ASAP2.Values)
MatchingParameterContainer (jnsoft.Diagnose.ODX)
MatlabFile (jnsoft.ASAP2.Values)
MDFReader (jnsoft.MDF)
MDFWriter (jnsoft.MDF)
MeasurementAccessData (jnsoft.ASAP2.Values)
Mem (jnsoft.Diagnose.ODX)
MemberLogicalLink (jnsoft.Diagnose.ODX)
A2LCANAPE_ADDRESS_UPDATE.MEMORY_SEGMENT (jnsoft.ASAP2)
MemoryRange (jnsoft.Helpers)
MemoryRangeList (jnsoft.Helpers)
MemorySegment (jnsoft.ASAP2)
MemorySegmentList (jnsoft.ASAP2)
MHSCAN (jnsoft.Comm.CAN.MHS)
ModelChangedEventArgs (jnsoft.ASAP2)
Modification (jnsoft.Diagnose.ODX)
DBCFile.MsgType (jnsoft.DBC)
MSRSW (jnsoft.ASAP2.Values.CDF)
Mux (jnsoft.Diagnose.ODX)
N
NamedDescId (jnsoft.Diagnose.ODX)
NamedId (jnsoft.Diagnose.ODX)
NamesBase (jnsoft.MDF.V4)
NamesType (jnsoft.MDF.V4)
NativeSKDLL (jnsoft.Helpers)
A2LKWP_CAN.NETWORK_LIMITS (jnsoft.ASAP2.KWP)
NICAN (jnsoft.Comm.CAN.NI)
NIXNET (jnsoft.Comm.CAN.NIXNET)
NonCompliantException (jnsoft.ASAP2)
NonCompliantException (jnsoft.Diagnose.ODX)
NotInheritedDiagComm (jnsoft.Diagnose.ODX)
O
ObjBase (jnsoft.BLF)
ODT (jnsoft.Comm.XCP)
A2LXCP_ODT.ODT_ENTRY (jnsoft.ASAP2.XCP)
ODTDict (jnsoft.Comm.XCP)
ODTEntry (jnsoft.Comm)
ODTList (jnsoft.Comm)
ODXFile (jnsoft.Diagnose.ODX)
ODXRoot (jnsoft.Diagnose.ODX)
OptionalCommandSet (jnsoft.ASAP2.XCP)
P
ParamContainer (jnsoft.Diagnose.ODX)
ParBaseDef (jnsoft.Diagnose.ODX)
ParCodedConst (jnsoft.Diagnose.ODX)
ParDynamic (jnsoft.Diagnose.ODX)
PARFile (jnsoft.ASAP2.Values)
ParIdBase (jnsoft.Diagnose.ODX)
ParLength (jnsoft.Diagnose.ODX)
ParMatchRequestParam (jnsoft.Diagnose.ODX)
ParNrcConst (jnsoft.Diagnose.ODX)
ParPhysConst (jnsoft.Diagnose.ODX)
ParReserved (jnsoft.Diagnose.ODX)
ParserEventArgs (jnsoft.Helpers)
ParSystem (jnsoft.Diagnose.ODX)
ParTableEntry (jnsoft.Diagnose.ODX)
ParTableKey (jnsoft.Diagnose.ODX)
ParTableStruct (jnsoft.Diagnose.ODX)
ParValue (jnsoft.Diagnose.ODX)
PDXIndex (jnsoft.Diagnose.ODX)
PeakCAN (jnsoft.Comm.CAN.Peak)
PeakLIN (jnsoft.Comm.LIN.Peak)
PhysicalDimension (jnsoft.Diagnose.ODX)
PhysicalType (jnsoft.Diagnose.ODX)
PhysMem (jnsoft.Diagnose.ODX)
PhysSegmentAddr (jnsoft.Diagnose.ODX)
PhysSegmentBase (jnsoft.Diagnose.ODX)
PhysSegmentSize (jnsoft.Diagnose.ODX)
PkysicalVehicleLink (jnsoft.Diagnose.ODX)
Program (jnsoft.ASAP2.Examples)
Program (jnsoft.ASAP2.Values.Examples)
Program (jnsoft.Comm.ECUSimulator)
Program (jnsoft.Comm.XCP.Examples)
Program (jnsoft.DBC.Examples)
Program (jnsoft.Diagnose.Comm.DoIp.Examples)
Program (jnsoft.Diagnose.ODX.Examples)
Program (jnsoft.LIN.Examples)
Program (jnsoft.MDF.Examples.Reader)
Program (jnsoft.MDF.Examples.Writer)
Program (jnsoft.Symbols.ELF.Examples)
ProgressArgs (jnsoft.Helpers)
Protocol (jnsoft.Diagnose.ODX)
ProtocolRef (jnsoft.Diagnose.ODX)
ProtStack (jnsoft.Diagnose.ODX)
Q
A2LKWP_SOURCE.QP_BLOB (jnsoft.ASAP2.KWP)
R
RasterType (jnsoft.MDF.V4)
RationalCoeffs (jnsoft.ASAP2.Helpers)
RawDataRecord (jnsoft.MDF)
RDSDBLOCKV4 (jnsoft.MDF.V4)
RelatedDoc (jnsoft.Diagnose.ODX)
RespActionDiagService (jnsoft.Comm.CCP)
RespBase (jnsoft.Comm.CCP)
RespBase (jnsoft.Comm.XCP)
RespBase (jnsoft.Diagnose.Comm.DoIp)
RespBase (jnsoft.Diagnose.Comm.UDS)
RespBuildChecksum (jnsoft.Comm.CCP)
RespBuildChecksum (jnsoft.Comm.XCP)
RespConnect (jnsoft.Comm.XCP)
RespControlDTCSetting (jnsoft.Diagnose.Comm.UDS)
RespData (jnsoft.Diagnose.Comm.UDS)
RespDownload (jnsoft.Comm.CCP)
RespDTCCount (jnsoft.Diagnose.Comm.UDS)
RespDTCRecords (jnsoft.Diagnose.Comm.UDS)
RespDTCSeverityRecords (jnsoft.Diagnose.Comm.UDS)
RespDTOCtrResp (jnsoft.Comm.XCP)
RespDynamicallyDefine (jnsoft.Diagnose.Comm.UDS)
RespError (jnsoft.Comm.XCP)
RespEvent (jnsoft.Comm.XCP)
RespExchangeID (jnsoft.Comm.CCP)
RespGetActiveCALPage (jnsoft.Comm.CCP)
RespGetCALPage (jnsoft.Comm.XCP)
RespGetCCPVersion (jnsoft.Comm.CCP)
RespGetCommModeInfo (jnsoft.Comm.XCP)
RespGetDAQClock (jnsoft.Comm.XCP)
RespGetDAQEventInfo (jnsoft.Comm.XCP)
RespGetDAQListInfo (jnsoft.Comm.XCP)
RespGetDAQListMode (jnsoft.Comm.XCP)
RespGetDAQListUSBEndpoint (jnsoft.Comm.XCP)
RespGetDAQProcessorInfo (jnsoft.Comm.XCP)
RespGetDAQResolutionInfo (jnsoft.Comm.XCP)
RespGetDAQSize (jnsoft.Comm.CCP)
RespGetID (jnsoft.Comm.XCP)
RespGetPageInfo (jnsoft.Comm.XCP)
RespGetPAGProcessorInfo (jnsoft.Comm.XCP)
RespGetPGMProcessorInfo (jnsoft.Comm.XCP)
RespGetSectorInfoModeAddressOrLen (jnsoft.Comm.XCP)
RespGetSectorInfoModeSectorNameLen (jnsoft.Comm.XCP)
RespGetSeed (jnsoft.Comm.CCP)
RespGetSeed (jnsoft.Comm.XCP)
RespGetSegmentInfo (jnsoft.Comm.XCP)
RespGetSegmentInfoAddress (jnsoft.Comm.XCP)
RespGetSegmentMode (jnsoft.Comm.XCP)
RespGetSStatus (jnsoft.Comm.CCP)
RespGetStatus (jnsoft.Comm.XCP)
RespIdentfier (jnsoft.Diagnose.Comm.UDS)
RespLinkControl (jnsoft.Diagnose.Comm.UDS)
DoIPBase.ResponseEvent (jnsoft.Diagnose.Comm.DoIp)
RespProgramStart (jnsoft.Comm.XCP)
RespReadDAQ (jnsoft.Comm.XCP)
RespRequestUpDownload (jnsoft.Diagnose.Comm.UDS)
RespReset (jnsoft.Diagnose.Comm.UDS)
RespResponseOnEvent (jnsoft.Diagnose.Comm.UDS)
RespRoutineControl (jnsoft.Diagnose.Comm.UDS)
RespSecurityAccess (jnsoft.Diagnose.Comm.UDS)
RespService (jnsoft.Comm.XCP)
RespSession (jnsoft.Diagnose.Comm.UDS)
RespSFBase (jnsoft.Diagnose.Comm.UDS)
RespStartStopDAQList (jnsoft.Comm.XCP)
RespTimeCorrelation (jnsoft.Comm.XCP)
RespTimingParameter (jnsoft.Diagnose.Comm.UDS)
RespTransferData (jnsoft.Diagnose.Comm.UDS)
RespUnlock (jnsoft.Comm.CCP)
RespUnlock (jnsoft.Comm.XCP)
RespWriteMemoryByAddress (jnsoft.Diagnose.Comm.UDS)
RestorePointContainer (jnsoft.BLF)
RestorePointContainerManaged (jnsoft.BLF)
RoutingActivationResponse (jnsoft.Diagnose.Comm.DoIp)
S
ScaleConstr (jnsoft.Diagnose.ODX)
Sdg (jnsoft.Diagnose.ODX)
ELFFile.SectionList (jnsoft.Symbols.ELF)
ELFFile.SectionValue (jnsoft.Symbols.ELF)
Security (jnsoft.Diagnose.ODX)
A2LKWP_TP_BLOB.SECURITY_ACCESS (jnsoft.ASAP2.KWP)
Segment (jnsoft.Diagnose.ODX)
LibWrapper.ServiceId (jnsoft.Comm.ETAS)
ServiceProperties (jnsoft.Diagnose.Comm.UDS)
ServiceType (jnsoft.Diagnose.Comm.UDS)
Session (jnsoft.Diagnose.ODX)
SessionDesc (jnsoft.Diagnose.ODX)
SIBLOCKV4 (jnsoft.MDF.V4)
SIcomment (jnsoft.MDF.V4)
DBCFile.SignalGroupDict (jnsoft.DBC)
DBCFile.SignalGroupType (jnsoft.DBC)
DBCFile.SignalType (jnsoft.DBC)
SingleValue (jnsoft.ASAP2.Values)
SnRef (jnsoft.Diagnose.ODX)
SoftingCAN (jnsoft.Comm.CAN.Softing)
SourceAndRaster (jnsoft.ASAP2.CCP)
DBCFile.SourceDict (jnsoft.DBC)
DBCFile.SourceType (jnsoft.DBC)
sRange (jnsoft.Helpers)
SRBLOCK (jnsoft.MDF.V3)
SRBLOCKV4 (jnsoft.MDF.V4)
SrcDataIdentifier (jnsoft.Diagnose.Comm.UDS)
SrcDataMemory (jnsoft.Diagnose.Comm.UDS)
SrcDstFrame (jnsoft.Diagnose.Comm.DoIp)
SrcFrame (jnsoft.Diagnose.Comm.DoIp)
StateTransitionContainer (jnsoft.Diagnose.ODX)
StaticField (jnsoft.Diagnose.ODX)
Structure (jnsoft.Diagnose.ODX)
SWAXISCONT (jnsoft.ASAP2.Values.CDF)
SWINSTANCE (jnsoft.ASAP2.Values.CDF)
SWINSTANCESPEC (jnsoft.ASAP2.Values.CDF)
SWINSTANCETREE (jnsoft.ASAP2.Values.CDF)
SwitchKey (jnsoft.Diagnose.ODX)
SWSYSTEM (jnsoft.ASAP2.Values.CDF)
SWVALUECONT (jnsoft.ASAP2.Values.CDF)
SxIEventArgs (jnsoft.Comm.XCP.SxI)
SxIProvider (jnsoft.Comm.XCP.SxI)
SymbolFile (jnsoft.Symbols)
DWARFInfo.SymbolsTree (jnsoft.Symbols.ELF.DWARF)
A2LCANAPE_ADDRESS_UPDATE.SymbolType (jnsoft.ASAP2)
DWARFInfo.SymbolValue (jnsoft.Symbols.ELF.DWARF)
ELFFile.SymbolValue (jnsoft.Symbols.ELF)
MAPFile.SymbolValue (jnsoft.Symbols.MAP)
SysVariable (jnsoft.BLF)
SysVariableManaged (jnsoft.BLF)
T
TabCoeffs (jnsoft.ASAP2.Helpers)
Table (jnsoft.Diagnose.ODX)
TableRow (jnsoft.Diagnose.ODX)
TCByteOrder (jnsoft.Helpers)
TCByteOrderWithNotSet (jnsoft.Helpers)
TCConversionRef (jnsoft.ASAP2.Helpers)
TCFormatRef (jnsoft.ASAP2.Helpers)
TCHexType (jnsoft.Helpers)
TCMeasurementRef (jnsoft.ASAP2.Helpers)
TcpSocketWithTimeout (jnsoft.Helpers)
TCTransformerRef (jnsoft.ASAP2.Helpers)
TCTypedefRef (jnsoft.ASAP2.Helpers)
TCUnitRef (jnsoft.ASAP2.Helpers)
TeamMember (jnsoft.Diagnose.ODX)
Header.Time (jnsoft.BLF)
TimeBase (jnsoft.Helpers)
TRBLOCK (jnsoft.MDF.V3)
TreeType (jnsoft.MDF.V4)
TRBLOCK.TriggerEvent (jnsoft.MDF.V3)
TXBLOCK (jnsoft.MDF.V3)
TypeUnitHeader (jnsoft.Symbols.ELF.DWARF)
TypeValueElement (jnsoft.Diagnose.ODX)
U
UDSClient (jnsoft.Diagnose.Comm.UDS)
UDSClientBase (jnsoft.Diagnose.Comm.UDS)
UDSFrame (jnsoft.Diagnose.Comm.UDS)
UDSFrameQueue (jnsoft.Diagnose.Comm.UDS)
Program.UDSSim (jnsoft.Comm.ECUSimulator)
Unit (jnsoft.Diagnose.ODX)
UnitSpec (jnsoft.Diagnose.ODX)
UnitSpecs (jnsoft.Diagnose.ODX)
UpdateData (jnsoft.Symbols)
UpdaterSymbols (jnsoft.Symbols)
V
ValBlkValue (jnsoft.ASAP2.Values)
ValuesReceivedEventArgs (jnsoft.Comm)
DBCFile.ValueTable (jnsoft.DBC)
DBCFile.ValueTableDict (jnsoft.DBC)
VectorCAN (jnsoft.Comm.CAN.Vector)
VectorLIN (jnsoft.Comm.LIN.Vector)
VehicleConnector (jnsoft.Diagnose.ODX)
VehicleConnectorPin (jnsoft.Diagnose.ODX)
VehicleIdResponse (jnsoft.Diagnose.Comm.DoIp)
VehicleInformation (jnsoft.Diagnose.ODX)
VehicleInfoSpec (jnsoft.Diagnose.ODX)
VendorType (jnsoft.MDF.V4)
VG (jnsoft.ASAP2.Values.CDF)
A2LCANAPE_EXT.VirtualConvType (jnsoft.ASAP2)
W
WriteRawDataEventArgs (jnsoft.MDF)
WriterException (jnsoft.ASAP2)
X
XCPCommModes (jnsoft.ASAP2.XCP)
XCPCommunicator (jnsoft.Comm.XCP)
XCPErrorArgs (jnsoft.Comm.XCP)
XCPEventArgs (jnsoft.Comm.XCP)
XCPFrame (jnsoft.Comm.XCP)
XCPFrameQueue (jnsoft.Comm.XCP)
XCPMaster (jnsoft.Comm.XCP)
XCPMasterBase (jnsoft.Comm.XCP)
XCPonEth (jnsoft.Comm.XCP)
XCPOnSxI (jnsoft.Comm.XCP)
XCPonTCP (jnsoft.Comm.XCP)
XCPonUDP (jnsoft.Comm.XCP)
XCPOnUSB (jnsoft.Comm.XCP)
XCPPrgParams (jnsoft.Comm)
XCPReceiveBuffer (jnsoft.Comm.XCP)
XCPServiceRequestArgs (jnsoft.Comm.XCP)
Program.XCPSim (jnsoft.Comm.ECUSimulator)
XDoc (jnsoft.Diagnose.ODX)
XmlBase (jnsoft.MDF.V4)
_
_8DevicesCAN (jnsoft.Comm.CAN._8Devices)


ASAP2Library interface: Member List

  • BLF
  • CANFDMessage
CANFDMessage Member List

This is the complete list of members for CANFDMessage, including all inherited members.

ArbBitCount (defined in CANFDMessage) | CANFDMessage |
CANFDMessage() (defined in CANFDMessage) | CANFDMessage |
Channel | CANFDMessage |
Data (defined in CANFDMessage) | CANFDMessage |
Dlc (defined in CANFDMessage) | CANFDMessage |
FdFlags (defined in CANFDMessage) | CANFDMessage |
Flags (defined in CANFDMessage) | CANFDMessage |
FrameLength (defined in CANFDMessage) | CANFDMessage |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id (defined in CANFDMessage) | CANFDMessage |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Type (defined in ObjBase) | ObjBase |
ValidDataBytes (defined in CANFDMessage) | CANFDMessage |


ASAP2Library interface: Member List

  • BLF
  • CANMessage
CANMessage Member List

This is the complete list of members for CANMessage, including all inherited members.

CANMessage() (defined in CANMessage) | CANMessage |
CANMessage(ObjectType type, ObjectFlagsType flags, ulong timeStamp, ushort channel, CANFrame frame) (defined in CANMessage) | CANMessage | protected
Channel | CANMessage |
Data (defined in CANMessage) | CANMessage |
Dlc (defined in CANMessage) | CANMessage |
Flags (defined in CANMessage) | CANMessage |
getTimestamp() | LObj |
getTimestampStr() (defined in LObj) | LObj |
Id (defined in CANMessage) | CANMessage |
LObj() (defined in LObj) | LObj |
LObj(ObjectType type, ObjectFlagsType flags, ulong timeStamp, int addSize=0) (defined in LObj) | LObj | protected
ObjBase() (defined in ObjBase) | ObjBase | protected
ObjBase(ObjectType type, int addSize=0) (defined in ObjBase) | ObjBase | protected
ObjectFlags (defined in LObj) | LObj |
Type (defined in ObjBase) | ObjBase |


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • MHS
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2AdjustDataExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Peak
  • obj
obj Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • ETAS
  • obj
obj Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • NIXNET
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • IXXAT
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • ASAP2If
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2DoIPExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: LIN Directory Reference

  • ASAP2If
  • LIN
LIN Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ELM327
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • MHS
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • NI
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: LINExample Directory Reference

  • Examples
  • LINExample
LINExample Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Softing
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • ASAP2If
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2WriterExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: IMEActia Directory Reference

  • CANHardware
  • IMEActia
IMEActia Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Vector
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • ESD
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Comm Directory Reference

  • Comm
Comm Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Peak
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Softing Directory Reference

  • CANHardware
  • Softing
Softing Directory Reference


ASAP2Library interface: ASAP2AdjustDataExample Directory Reference

  • Examples
  • ASAP2AdjustDataExample
ASAP2AdjustDataExample Directory Reference


ASAP2Library interface: ASAP2DoIPExample Directory Reference

  • Examples
  • ASAP2DoIPExample
ASAP2DoIPExample Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • NIXNET
  • obj
obj Directory Reference


ASAP2Library interface: Kvaser Directory Reference

  • CANHardware
  • Kvaser
Kvaser Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Vector
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Peak
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: ASAP2XCPExample Directory Reference

  • Examples
  • ASAP2XCPExample
ASAP2XCPExample Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • 8Devices
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2MergeDataExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • 8Devices
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: XCP Directory Reference

  • ECUSimulator
  • XCP
XCP Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Advantech
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • IMEActia
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: ODX Directory Reference

  • Diagnose
  • ODX
ODX Directory Reference


ASAP2Library interface: Release Directory Reference

  • ASAP2If
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Intrepid
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • IMEActia
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Diagnose Directory Reference

  • Diagnose
Diagnose Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • IXXAT
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • NI
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • IMEActia
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: IXXAT Directory Reference

  • CANHardware
  • IXXAT
IXXAT Directory Reference


ASAP2Library interface: CAN Directory Reference

  • ASAP2If
  • CAN
CAN Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Vector
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: ASAP2If Directory Reference

  • ASAP2If
ASAP2If Directory Reference

Directories

directory obj


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2MergeDataExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Advantech
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: ASAP2MDFReaderExample Directory Reference

  • Examples
  • ASAP2MDFReaderExample
ASAP2MDFReaderExample Directory Reference


ASAP2Library interface: ELM327 Directory Reference

  • CANHardware
  • ELM327
ELM327 Directory Reference


ASAP2Library interface: DoIP Directory Reference

  • Diagnose
  • Comm
  • DoIP
DoIP Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Intrepid
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2ODXExample
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2ELFExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • IXXAT
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: ASAP2ParserExample Directory Reference

  • Examples
  • ASAP2ParserExample
ASAP2ParserExample Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Advantech
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • NIXNET
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • IMEActia
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • MHS
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2MDFReaderExample
  • obj
obj Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • NI
  • obj
obj Directory Reference


ASAP2Library interface: UDS Directory Reference

  • ECUSimulator
  • UDS
UDS Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • MHS
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ESD
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2MDFWriterExample
  • obj
obj Directory Reference


ASAP2Library interface: Comm Directory Reference

  • Diagnose
  • Comm
Comm Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • ESD
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Intrepid Directory Reference

  • CANHardware
  • Intrepid
Intrepid Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2MDFReaderExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Advantech
  • obj
obj Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Softing
  • obj
obj Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • EbEl
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ETAS
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2ELFExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Softing
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: ASAP2WriterExample Directory Reference

  • Examples
  • ASAP2WriterExample
ASAP2WriterExample Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2DoIPExample
  • obj
obj Directory Reference


ASAP2Library interface: Advantech Directory Reference

  • CANHardware
  • Advantech
Advantech Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2MergeDataExample
  • obj
obj Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • NI
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • ECUSimulator
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2ODXExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2AdjustDataExample
  • obj
obj Directory Reference


ASAP2Library interface: NI Directory Reference

  • CANHardware
  • NI
NI Directory Reference


ASAP2Library interface: A2L Directory Reference

  • A2L
A2L Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Lawicel
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2XCPExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: CCP Directory Reference

  • Comm
  • CCP
CCP Directory Reference


ASAP2Library interface: ASAP2ELFExample Directory Reference

  • Examples
  • ASAP2ELFExample
ASAP2ELFExample Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Softing
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Lawicel
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • EbEl
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Release Directory Reference

  • ECUSimulator
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: MHS Directory Reference

  • CANHardware
  • MHS
MHS Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • DBCExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • ECUSimulator
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • MHS
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Peak
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • ELM327
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • 8Devices
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • ETAS
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Examples Directory Reference

  • Examples
Examples Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2ParserExample
  • obj
obj Directory Reference


ASAP2Library interface: Symbols Directory Reference

  • Symbols
Symbols Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • EbEl
  • obj
obj Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Intrepid
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: CANHardware Directory Reference

  • CANHardware
CANHardware Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Vector
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • ESD
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2MDFWriterExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Kvaser
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Kvaser
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Vector
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ETAS
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • IMEActia
  • obj
obj Directory Reference


ASAP2Library interface: ECUSimulator Directory Reference

  • ECUSimulator
ECUSimulator Directory Reference

Directories

directory obj


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Kvaser
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2AdjustDataExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • ECUSimulator
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • ASAP2If
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • 8Devices
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Peak
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • ASAP2If
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • IXXAT
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: ASAP2ODXExample Directory Reference

  • Examples
  • ASAP2ODXExample
ASAP2ODXExample Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2WriterExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • ETAS
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Intrepid
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: XCP Directory Reference

  • Comm
  • XCP
XCP Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • NIXNET
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • 8Devices
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: Peak Directory Reference

  • CANHardware
  • Peak
Peak Directory Reference


ASAP2Library interface: Vector Directory Reference

  • CANHardware
  • Vector
Vector Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2DoIPExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Lawicel
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: DBCExample Directory Reference

  • Examples
  • DBCExample
DBCExample Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Kvaser
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: obj Directory Reference

  • ECUSimulator
  • obj
obj Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Lawicel
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Vector
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: ASAP2UDSExample Directory Reference

  • Examples
  • ASAP2UDSExample
ASAP2UDSExample Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • ELM327
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: MDF Directory Reference

  • MDF
MDF Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2XCPExample
  • obj
obj Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • ETAS
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: ASAP2MDFWriterExample Directory Reference

  • Examples
  • ASAP2MDFWriterExample
ASAP2MDFWriterExample Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • IXXAT
  • obj
obj Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2ParserExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Lawicel
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Softing
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Lawicel Directory Reference

  • CANHardware
  • Lawicel
Lawicel Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ELM327
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2XCPExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Debug Directory Reference

  • ASAP2If
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • IXXAT
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • DBCExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: DBC Directory Reference

  • DBC
DBC Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • EbEl
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2ODXExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: ESD Directory Reference

  • CANHardware
  • ESD
ESD Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • ELM327
  • obj
obj Directory Reference


ASAP2Library interface: NIXNET Directory Reference

  • CANHardware
  • NIXNET
NIXNET Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • ESD
  • obj
obj Directory Reference


ASAP2Library interface: ETAS Directory Reference

  • CANHardware
  • ETAS
ETAS Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2ParserExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • Examples
  • ASAP2MDFWriterExample
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: 8Devices Directory Reference

  • CANHardware
  • 8Devices
8Devices Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • NIXNET
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • Kvaser
  • obj
  • Release
  • net40
net40 Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • EbEl
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2WriterExample
  • obj
obj Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Intrepid
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Lawicel
  • obj
obj Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Peak
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • NIXNET
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • ECUSimulator
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • NI
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: obj Directory Reference

  • Examples
  • DBCExample
  • obj
obj Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • IMEActia
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: ASAP2MergeDataExample Directory Reference

  • Examples
  • ASAP2MergeDataExample
ASAP2MergeDataExample Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • ELM327
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: CCP Directory Reference

  • ECUSimulator
  • CCP
CCP Directory Reference


ASAP2Library interface: SxI Directory Reference

  • Comm
  • XCP
  • SxI
SxI Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • MHS
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Kvaser
  • obj
obj Directory Reference


ASAP2Library interface: A2LValues Directory Reference

  • A2LValues
A2LValues Directory Reference


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • Softing
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: Release Directory Reference

  • CANHardware
  • Advantech
  • obj
  • Release
Release Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net6.0 Directory Reference

  • CANHardware
  • 8Devices
  • obj
  • Debug
  • net6.0
net6.0 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • ESD
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • EbEl
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: obj Directory Reference

  • CANHardware
  • Intrepid
  • obj
obj Directory Reference


ASAP2Library interface: obj Directory Reference

  • Examples
  • ASAP2ELFExample
  • obj
obj Directory Reference


ASAP2Library interface: Debug Directory Reference

  • CANHardware
  • Advantech
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: net40 Directory Reference

  • CANHardware
  • NI
  • obj
  • Debug
  • net40
net40 Directory Reference


ASAP2Library interface: EbEl Directory Reference

  • CANHardware
  • EbEl
EbEl Directory Reference


ASAP2Library interface: Debug Directory Reference

  • Examples
  • ASAP2MDFReaderExample
  • obj
  • Debug
Debug Directory Reference

Directories

Generated by doxygen 1.9.2


ASAP2Library interface: ASAP2Library interface

ASAP2Library interface

ASAP2Library key features:

  • .NET Framework assembly usable from any available .NET framework language (C#, VB.NET, F#, J#,...).
  • Exclusively written in managed code and therefore portable. Compilable for Windows (.NET Framework ≥ 4.0) or .NET (Windows/Linux/MacOS).
  • Modular architeture, modules can be combined as required.
  1. Reader module
    • Implements the complete ASAM MCD-2MC Version 1.7.1 (ASAP2) specification.
    • Creates an object oriented, hierarchical .NET object model, see the ASAP2Library API and the demo code.
    • Type safety - all A2L objects and their properties are mapped to it's corresponding .NET type.
    • The object model allows to change almost any A2L object property.
    • A2L syntax and model checking (e.g. missing object links).
    • Deserialize the .NET object model from an XML representation.
    • approximately 8 MBit/s parsing performance (maybe the fastest available ASAP2 parser)
  2. Writer module
    • Allows manual addition of any A2L objects to the A2L object model.
    • Rewrite the .NET object model (filtered and/or optimized) into an A2L file.
    • Serialize the .NET object model into an XML representation.
  3. Values module
    • Reading and Writing ECU calibration data files into/from the created A2L model (supported are Intel HEX, Motorola S, INCA DCM, CANape PAR, CDF and MATLAB (.m) file formats).
    • Convert byte streams from the calibration data file into physical values of corresponding A2L characteristics.
    • Convert physical data into byte streams in order to save modified data into a calibration data file.
  4. Comm module
    • Implements the ASAM MCD-1 XCP V1.3.0 specification, supporting communication over TCP/UDP on Ethernet, on Sxl, on USB and on CAN/CAN FD using supported CAN Hardware providers.
    • Implements the ASAM MCD-1 CCP V2.1.0 specification supporting communication over CAN (using supported CAN Hardware).
    • Supports accessing the CAN bus with various CAN/CAN FD Hardware:
      • 8devices
      • Advantech
      • Star corporation (Flexcard USB)
      • ESD (CAN-USB-Micro, CAN-USB/2, CAN-PCI, CAN-PCIe, ...), CAN FD support
      • ELM Electronics ELM327 (and compatible ones) (Any ELM327 based OBDII adapter using Bluetooth or Wi-Fi)
      • ETAS (ES500, E5800, ...), CAN FD support
      • I+ME Actia (XS Lite, Basix+ XS), 32 Bit only
      • Intrepid control systems (ValueCAN 4, ...), CAN FD support
      • IXXAT (CAN-IB, USB-to-CAN V2), CAN FD support
      • Kvaser (USB, PCI Board, ...), CAN FD support
      • MHS Elektronik Tiny-CAN I, Tiny-CAN II XL, Tiny-CAN IV XL, Tiny-CAN M1, ...)
      • Lawicel
      • National Instruments (NI-CAN) (USB 84XX, ...), 32 Bit only
      • National Instruments (XNET) (PCI-85XX, USB-85XX, PCIE-85XX, PXI-85XX, ...)
      • Peak (PCAN-USB, PCAN-PCI, PCAN-ISA, PCAN-PCCard, PCAN-Dongle, ...), CAN FD support
      • Softing
      • Vector (VN1600, VN8900, VN5610, ...), CAN FD support
    • Supports accessing the LIN bus with LIN supporting Hardware:
      • IXXAT (USB, PCIe, PCIe 104, PCI, PMC, ...)
      • Kvaser Leaf Professional LIN
      • Peak (PCAN-LIN)
  5. Diagnostic Services module
    • Implements the ISO 15765-2 (IsoTp; on CAN and CANFD) protocol.
    • Implements the ISO 13400-2 (Diagnostic communication over Internet Protocol, DoIP).
    • Implements the ISO 14229 (Unified Diagnostic Service, UDS) protocol.
    • Implements a module to read, modify and write ODX (Open Diagnostic data eXchange format, ASAM MCD-2D v2.0.1-v2.2.0) files
  6. DBC module
    • Implements a module to read, modify and write CANdb++ (DBC) files
    • Measure and compute physical signal values by connecting a supported CAN Hardware provider.
  7. MDF (Measurement data format) module
    • Implements a module to read MDF formats up to v4.1 and write MDF format v3.3 and MDF V4.1 (Measurement data format) files.
    • Both formats are accessible with the same interface for reading and writig measured data.
  8. ELF module
    • Implements a module to read ELF (Excecutable and Linkable Format) or MAP files (32 and 64 Bit) in order to synchronize A2L object addresses.
    • Supports DWARF2 formatted debug information contained in the ELF file
    • Allows to rewrite an A2L with updated addresses from an ELF or MAP file

  9. LIN module

    • Implements a module to read, modify and write LIN description (LDF) files
    • Measure signals from any jnsoft.Comm.LIN.LINProvider
    Author
    Copyright © JNachbaur technical software development, 2011-2022


ASAP2Library interface: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy